Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ インターフェイスおよびハードウェア コンポーネント コンフィギュレーション ガイド Cisco IOS XR ソフトウェア リリース 4.1
Cisco ASR 9000 シリーズ ルータでの双方向フォワーディング検出の設定
Cisco ASR 9000 シリーズ ルータ での双方向フォワーディング検出の設定
発行日;2012/05/08 | 英語版ドキュメント(2012/03/30 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

Cisco ASR 9000 シリーズ ルータ での双方向フォワーディング検出の設定

内容

BFD の設定の前提条件

BFD の設定に関する制約事項

BFD に関する情報

Cisco IOS XR ソフトウェアと Cisco IOS ソフトウェアにおける BFD の違い

BFD の動作モード

BFD パケット情報

BFD の送信元および宛先ポート

BFD パケット間隔および障害検出

BFD パケットのプライオリティの設定

IPv4 用 BFD

IPv6 用 BFD

バンドル VLAN での BFD

リンク バンドルのメンバ リンク上の BFD

メンバ リンクおよびバンドル ステータスでの BFD 状態変更動作の概要

BFD の設定方法

BFD 設定時の注意事項

ダイナミック ルーティング プロトコルの下またはスタティック ルートを使用した BFD の設定

BGP ネイバーでの BFD のイネーブル化

特定インターフェイスでの OSPF の BFD のイネーブル化

特定インターフェイスでの OSPFv3 の BFD のイネーブル化

スタティック ルートでの BFD のイネーブル化

バンドル メンバ リンクでの BFD の設定

前提条件

バンドルでの BFD 宛先アドレスの指定

バンドル メンバの BFD セッションのイネーブル化

アクティブ バンドルを維持するための最小しきい値の設定

バンドルの BFD パケット送信間隔と障害検出時間の設定

バンドルのタイマーを使用する BFD 状態変更通知で許容される遅延の設定

BFD ピアへの転送パスをテストするためのエコー モードのイネーブル化

デフォルト エコー パケット送信元アドレスの上書き

BFD のエコー パケット送信元アドレスのグローバルな指定

個々のインターフェイスまたはバンドルのエコー パケット送信元アドレスの指定

エコー遅延検出に基づく BFD セッション ティアダウンの設定

前提条件

制約事項

エコー パスと遅延の検証までの BFD セッション開始の遅延

前提条件

制約事項

エコー モードのディセーブル化

ルータでのエコー モードのディセーブル化

個々のインターフェイスまたはバンドルでのエコー モードのディセーブル化

BFD ダンプニングを使用する最小 BFD セッション フラッピング

IPv6 チェックサム サポートのイネーブル化とディセーブル化

ルータの BFD の IPv6 チェックサム計算のイネーブル化とディセーブル化

個々のインターフェイスまたはバンドルの BFD の IPv6 チェックサム計算のイネーブル化とディセーブル化

BFD カウンタのクリアおよび表示

BFD の設定例

BGP 上の BFD:例

OSPF 上の BFD:例

スタティック ルート上の BFD:例

バンドル VLAN での BFD:例

バンドル メンバ リンクでの BFD:例

エコー パケット送信元アドレス:例

エコー遅延検出:例

エコー起動検証:例

BFD エコー モードのディセーブル化:例

BFD ダンプニング:例

BFD IPv6 チェックサム:例

Cisco IOS および Cisco IOS XR ソフトウェアを実行しているルータの BFD ピア:例

関連情報

その他の関連資料

関連資料

標準

RFC

MIB

シスコのテクニカル サポート

Cisco ASR 9000 シリーズ ルータ での双方向フォワーディング検出の設定

このモジュールでは、Cisco ASR 9000 シリーズ アグリゲーション サービス ルータでの双方向フォワーディング検出(BFD)の設定について説明します。

双方向フォワーディング検出(BFD)では、隣接する転送エンジン間のパスにおける障害を低オーバーヘッド、短期間で検出できます。BFD では、あらゆるメディアおよびあらゆるプロトコル レイヤでの障害検出に単一のメカニズムを使用でき、広範な検出時間とオーバーヘッドに対応できます。障害の迅速な検出が可能なため、リンクやネイバーの障害発生時にもただちに障害に対応することができます。

Cisco IOS XR ソフトウェアでの双方向フォワーディング検出(BFD)設定機能の履歴

リリース
変更内容

リリース 3.7.2

BFD が Cisco ASR 9000 シリーズ ルータに追加されました。

リリース 3.9.0

BFD での次のアプリケーションのサポートが追加されました。

ホットスタンバイ ルータ プロトコル(HSRP)

仮想ルータ冗長プロトコル(VRRP)

dampening コマンドが、BFD セッション フラッピングおよびセッション開始遅延を最小化するために追加されました。

echo ipv4 source コマンドが、送信元 IP アドレスを指定して、デフォルトを上書きするために追加されました。

ipv6 checksum コマンドが、BFD コンフィギュレーション モードおよび BFD インターフェイス コンフィギュレーション モードの IPv6 チェックサム計算をイネーブルおよびディセーブルにするために追加されました。

リリース 4.0.0

次の BFD 機能のサポートが追加されました。

OSPFv3 用 BFD

IPv6 用 BFD

BFD のサポートは、次の SPA に追加されました。

1 ポート OC-192c/STM-64 POS/RPR XFP SPA

2 ポート OC-48c/STM-16 POS/RPR SPA

8 ポート OC-12c/STM-4 POS SPA

リリース 4.0.1

次の BFD 機能のサポートが追加されました。

リンク バンドルのメンバ リンク単位での BFD のサポートが追加されました。

echo latency detect コマンドが、非バンドル インターフェイスで BFD エコー パケットに対する遅延の検出をイネーブルにするために追加されました。

echo startup validate コマンドが、非バンドル インターフェイスで BFD セッションを開始する前にエコー パスを検証するために追加されました。

BFD の設定の前提条件

適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 このコマンド リファレンスには、各コマンドに必要なタスク ID が含まれます。 ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。

次に、BFD を実装するために必要な前提条件を示します。

マルチプロトコル ラベル スイッチング(MPLS)で BFD をイネーブルにする場合は、MPLS パッケージを含んだインストール済みの複合 PIE ファイル、または複合パッケージ イメージが必要です。ボーダー ゲートウェイ プロトコル(BGP)、Intermediate System-to-Intermediate System(IS-IS)、スタティック、Open Shortest Path First(OSPF)の場合は、インストール済みの Cisco IOS XR IP Unicast Routing Core Bundle イメージが必要です。

IS-IS または OSPF を使用している場合、ルータで内部ゲートウェイ プロトコル(IGP)がアクティブになっていること。

Cisco ASR 9000 シリーズ ルータでは、BFD をサポートする各ラインカードが次の作業を実行できる必要があります。

エコー パケットを 15 ms ごとに送信(通常の状態の最小値として)

制御パケットを 15 ms ごとに送信(ストレス状態の最小値として)

最大 9600 pps のユーザ データグラム プロトコル(UDP)を送受信。これにより、15 ms エコー間隔で 144 セッション(または 150 ms エコー間隔で 1440 セッション)を維持します。

ネイバーの BFD をイネーブルにするには、その隣接ルータが BFD をサポートしている必要があります。

3.9.0 よりも前の Cisco IOS XR リリースでは、BFD セッションを設定する前に、グローバル コンフィギュレーション モードで router-id コマンドを使用して、ローカル ルータ ID を設定することを推奨していました。ローカル ルータ ID を設定しなかった場合、デフォルトで BFD エコー モードでの IP パケットの送信元アドレスが、出力インターフェイスの IP アドレスとなります。Cisco IOS XR Release 3.9.0 以降は、送信元アドレスとして使用する IP アドレスを指定するために、 echo ipv4 source コマンドを使用できます。

バンドル メンバ リンクで BFD をサポートするために、次の要件を満たしていることを確認します。

バンドルの両端にあるルータ間は、レイヤ 2 スイッチなしでバックツーバックで接続されている。

BFD セッションを開始する場合、次のいずれかの設定または状態がバンドル メンバに存在する。

リンク集約制御プロトコル(LACP)分散状態に到達している、または

EtherChannel または POS チャネルが設定されている、または

ホット スタンバイおよび LACP 収集状態に到達している。

BFD の設定に関する制約事項

BFD には、次の制約事項が適用されます。

Cisco IOS XR ソフトウェアではデマンド モードはサポートされません。

BFD エコー モードは次のアプリケーションではサポートされません。

バンドル VLAN の IPv4 用 BFD。

IPv6 用 BFD(グローバルおよびリンクローカル アドレッシング)

uRPF を使用する BFD(IPv4 または IPv6)

BFD バンドル インターフェイスに複数のラックにまたがるメンバ リンクがある場合の、ラック リロードおよび活性挿抜(OIR)。

IPv6 用 BFD に関する制約事項は、次のとおりです。

IPv6 用 BFD は、バンドル VLAN インターフェイスではサポートされません。

IPv6 用 BFD は、エコーなしの非同期モードでのみサポートされます。

IPv6 スタティック ルート、OSPFv3、および BGP 用の BFD はクライアントでサポートされます。

バンドル VLAN 上の BFD では、スタティック、OSPF、および IS-IS アプリケーションのみがサポートされます。

イーサネット VLAN バンドル サブインターフェイス上の IPv4 を使用する BGP での BFD はサポートされません。

バンドル メンバ リンクの BFD では、各バンドル メンバ リンクの単一 BFD セッションのみが IPv4 アドレッシング タイプに対してだけ作成、モニタおよび維持されます。バンドルの IPv6 および VLAN リンクに関する制約事項は、次のとおりです。

IPv6 の状態はバンドル メンバで明示的にモニタされず、そのメンバ インターフェイスの IPv4 BFD セッションの状態を継承します。

バンドル メンバの VLAN サブインターフェイスも、そのメンバ インターフェイスの IPv4 BFD セッションからの BFD の状態を継承します。VLAN サブインターフェイスはバンドル メンバで明示的にモニタされません。

エコー遅延検出およびエコー検証は、バンドル インターフェイスではサポートされません。

BFD に関する情報

BFD を設定するには、次の概念について理解しておく必要があります。

「Cisco IOS XR ソフトウェアと Cisco IOS ソフトウェアにおける BFD の違い」

「BFD の動作モード」

「BFD パケット情報」

「IPv4 用 BFD」

「IPv6 用 BFD」

「バンドル VLAN での BFD」

「リンク バンドルのメンバ リンク上の BFD」

Cisco IOS XR ソフトウェアと Cisco IOS ソフトウェアにおける BFD の違い

すでに Cisco IOS ソフトウェアでの BFD の設定に精通している場合は、Cisco IOS XR ソフトウェア実装での BFD の設定に関する次の違いについて必ず考慮します。

Cisco IOS XR ソフトウェアでは、BFD は OSPF や BGP インスタンスなどのダイナミック ルーティング プロトコルの下で設定されたアプリケーションです。これは、BFD がインターフェイス上だけで設定されている Cisco IOS ソフトウェアでの BFD には該当しません。

Cisco IOS XR ソフトウェアでは、BFD ネイバーはルーティングを介して確立されます。Cisco IOS bfd neighbor インターフェイス コンフィギュレーション コマンドは、Cisco IOS XR ソフトウェアではサポートされません。

BFD ネイバーを確立するためにダイナミック ルーティング プロトコルを使用する代わりに、パスを定義するためにスタティック ルーティングの方式を使用して、Cisco IOS XR ソフトウェアでの BFD 応答に対する特定の BFD ピアまたはネイバーを確立できます。つまり、Cisco IOS XR ソフトウェアのダイナミック ルーティング プロトコル下で BFD を設定しない場合、BFD のスタティック ルートを設定する必要があります。詳細については、「スタティック ルートでの BFD のイネーブル化」を参照してください。

Cisco IOS ソフトウェアで BFD を実行しているルータは、 bfd neighbor コマンドを使用してピアとして Cisco IOS XR ソフトウェアで BFD を実行するルータを指定できます。Cisco IOS XR ルータは、Cisco IOS ルータに戻るダイナミック ルーティングまたはスタティック ルートをピア関係を確立するために使用する必要があります。「Cisco IOS および Cisco IOS XR ソフトウェアを実行しているルータの BFD ピア:例」を参照してください。

BFD の動作モード

Cisco IOS XR ソフトウェアは、エコー パケットを使用するか否かにかかわらず、非同期動作モードだけをサポートします。エコーなしの非同期モードでは、ローカルおよびリモート システム上のパケット スイッチング パスのさまざまな部分が関与します。ただし、エコーありの非同期モードは通常、若干広いテスト カバレッジを提供すると認識されています。これは、エコー パケットがリモート システムの通常のトラフィックと同じパケット スイッチング パスを通過する自分宛てのパケットであるためです。

BFD エコー モードは、次のインターフェイスではデフォルトでイネーブルです。

BFD バンドル インターフェイスのメンバ リンク上の IPv4 の場合。

最小間隔が 2 秒未満の他の物理インターフェイス上の IPv4 の場合。

BFD がエコー パケットなしの非同期で実行中の場合(図 2)、次のようになります。

各システムが相互に定期的に BFD 制御パケットを送信します。BFD ルータの「ピア B」に BFD ルータの「ピア A」が送信したパケットは、ピア A からの送信元アドレスおよびピア B の宛先アドレスを保持します。

制御パケット ストリームは互いに独立していて、要求/応答モデルで動作しません。

連続する多数のパケットが別のシステムによって受信されない場合、セッションがダウンしたと宣言されます。

図 2 エコー パケットなしの BFD 非同期モード

 

BFD がエコー パケットありの非同期で実行中の場合(図 3)、次のようになります。

BFD エコー パケットは、BFD ピアの転送パスだけを通じてループバックされ、プロトコル スタックで処理されません。このため、BFD ルータの「ピア A」が送信したパケットは、ピア A の送信元および宛先アドレスの両方を含めて送信できます。

BFD 制御パケットに加えて、BFD エコー パケットが送信されます。

図 3 エコー パケットありの BFD 非同期モード

 

非同期モードでの制御およびエコー パケット間隔の詳細については、「BFD パケット間隔および障害検出」を参照してください。

BFD の送信元および宛先ポート

BFD ペイロード制御パケットは、宛先ポート 3784 および送信元ポート 49152 を使用して、UDP パケットにカプセル化されます。イーサネットのような共有型メディアでも、BFD 制御パケットは常にユニキャスト パケットとして BFD ピアに送信されます。

エコー パケットも、宛先ポート 3785 および送信元ポート 3785 を使用して、UDP パケットにカプセル化されます。

バンドル メンバ機能を介して BFD は、各送信でエコー パケットの UDP 送信元ポートの各バイトを増分します。UDP 送信元ポートの範囲は 0xC0C0 から 0xFFFF です。次に例を示します。

1 番目のエコー パケット:0xC0C0

2 番目のエコー パケット:0xC1C1

3 番目のエコー パケット:0xC2C2

UDP 送信元ポートは、連続したエコー パケットが逸脱しているバンドル メンバにハッシュされるように増分されます。

BFD パケット間隔および障害検出

BFD は、設定可能な間隔と係数を使用して、制御およびエコー パケットが非同期モードで送信される期間およびそれに対応する障害検出を指定します。

物理インターフェイスで実行されている BFD セッション、およびバンドル メンバ リンクの BFD セッションに対するこれらの間隔と障害検出時間の実装方法には違いがあります。

物理インターフェイスでの BFD パケット間隔

BFD を物理インターフェイス上で実行している場合、エコー モードは設定された間隔が 2 秒未満の場合だけ使用されます。

エコー モードがイネーブルのとき、物理インターフェイス上で実行されている BFD セッションは、2 秒ごとの低速レートで BFD 制御パケットを送信します。エコー パケットがエコー障害検出時間内に受信されない場合、BFD エコー パケットは高速レートですでに送信されていてリンク障害が検出されるため、高速レートの制御パケット障害検出を重複させる必要はありません。

バンドル メンバ リンクの BFD パケット間隔

各バンドル メンバ インターフェイスの BFD 非同期モード制御パケットは、エコー モードが実行されている場合でも、ユーザが設定できる間隔と係数値で動作します。

ただし、バンドル メンバ インターフェイスでエコー モードがイネーブルのとき、BFD 非同期モードは高速レートで実行を続ける必要があります。これは、BFD エコー モードをイネーブルにする要件の 1 つとして、バンドル メンバ インターフェイスが BFD 非同期モードで使用できることがあるためです。

バンドル メンバ リンクの BFD の最大エコー パケット間隔は、30 秒または非同期制御パケット障害検出時間のいずれかの最小値です。

エコー モードがディセーブルの場合、セッションが設定されたレートで BFD 制御パケットを交換する物理インターフェイスでの BFD と動作は同じです。

非同期モードでの制御パケット障害検出

エコーなしの非同期モードでの制御パケット障害検出は、最小間隔(非バンドル インターフェイスでは bfd minimum-interval 、バンドル インターフェイスでは bfd address-family ipv4 minimum-interval )および係数(非バンドル インターフェイスでは bfd multiplier 、バンドル インターフェイスでは bfd address-family ipv4 multiplier )コマンドの値を使用して実行されます。

制御パケット障害検出では、ローカル係数値がネイバーに送信されます。障害検出タイマーは、( I x M )に基づいて開始されます。ここで、 I はネゴシエートされた間隔で、 M はリモート エンドによって提供された係数です。

有効な制御パケットがネイバーから受信されるたびに、障害検出タイマーはリセットされます。ネイバーからの有効な制御パケットが期間( I x M )内に受信されない場合、障害検出タイマーがトリガーされ、ネイバーがダウンしたと宣言されます。

非同期モードでのエコー パケット障害検出

標準のエコー障害検出方式は、非バンドル インターフェイスの bfd multiplier コマンドの値に基づいて、またバンドル インターフェイスの場合は bfd address-family ipv4 multiplier コマンドの値に基づいて、カウンタを通じて実行されます。

このカウンタは、エコー パケットがエコー パケット ストリームに送信された順序にかかわらず、システムがエコー パケットを送信するたびに増分され、 何らかの エコー パケットが受信されるたびにゼロにリセットされます。

これは理想的な状況では、BFD が一般に期間( I x M 、またはバンドル インターフェイスの場合は I x M x M )を超えたエコー障害を検出することを意味します。ここで、

I :最小間隔の値(非バンドル インターフェイスでは bfd minimum-interval 、またバンドル インターフェイスでは bfd address-family ipv4 minimum-interval)。

M :係数(非バンドル インターフェイスでは bfd multiplier 、またバンドル インターフェイスでは bfd address-family ipv4 multiplier )コマンドの値。

このため、エコー パケットを一切受信せずに、システムが係数カウントを超える 1 つのエコー パケットを追加で送信すると、エコー障害が検出され、ネイバーがダウンしたと宣言されます(「例 2」を参照)。

ただし、この標準エコー障害検出は、BFD セッションの経路で( I x M )を超えて増加可能な特定のエコー パケットの送受信間の遅延に対応しません。この場合、何らかのエコー パケットが係数の期間内で受信され続け、カウンタをゼロにリセットする限り、BFD はネイバーがダウンしたと宣言しません。Cisco IOS XR 4.0.1 以降では、非バンドル インターフェイスにおけるこの遅延を測定するために BFD を設定できます。詳細については、「例 3」および「エコー パケット遅延」を参照してください。

エコー障害検出の例

この項では、標準エコー パケット処理および非バンドル インターフェイスの遅延検出設定なしの障害検出のさまざまなシナリオの例を挙げます。次の例では、間隔が 50 ms で係数が 3 とします。


) エコー障害検出用に同じ間隔と係数カウンタ方式がバンドル インターフェイスでも使用されますが、値は bfd address-family ipv4 multiplier および bfd address-family ipv4 minimum-interval コマンドによって決定され、(I x M x M)の期間を使用してエコー パケットの受信がないことを検出します。


例 1

次のエコーが送信される前に各エコー パケットが戻る、理想的な例を次に示します。この場合、カウンタは 1 に増分されて、次のエコーが送信される前に 0 に戻り、エコー障害は発生しません。セッションのエコー パケットのラウンドトリップ遅延が最小間隔よりも小さい間は、このシナリオが発生します。

Time (T): Echo#1 TX (count = 1)
T + 1 ms: Echo#1 RX (count = 0)
T + 50 ms: Echo#2 TX (count = 1)
T + 51 ms: Echo#2 RX (count = 0)
T + 100 ms: Echo#3 TX (count = 1)
T + 101 ms: Echo#3 RX (count = 0)
T + 150 ms: Echo#4 TX (count = 1)
T + 151 ms: Echo#4 RX (count = 0)

例 2

エコー パケットが一切戻らない例を次に示します。4 番目のエコー パケットの送信後、カウンタが係数値 3 を超えてエコー障害が検出されます。この場合、エコー障害検出は、150 ms( I x M )期間で発生します。

Time (T): Echo#1 TX (count = 1)
T + 50 ms: Echo#2 TX (count = 2)
T + 100 ms: Echo#3 TX (count = 3)
T + 150 ms: Echo#4 TX (count = 4 -> echo failure

例 3

次に、標準のエコー障害検出を使用して BFD セッション経路で(I × M)を超えて特定のエコー パケットに対しラウンドトリップ遅延が増加可能だが、セッション全体のエコー パケットの戻り間の遅延が(I × M)期間を超えず、カウンタが係数を超えないため、ネイバーがダウンしたと宣言されない例を示します。


) Cisco IOS XR 4.0.1 以降では、echo latency detect コマンドを使用して、非バンドル インターフェイスのラウンドトリップ遅延を検出するように BFD を設定できます。


Time (T): Echo#1 TX (count = 1)
T + 1 ms: Echo#1 RX (count = 0)
T + 50 ms: Echo#2 TX (count = 1)
T + 51 ms: Echo#2 RX (count = 0)
T + 100 ms: Echo#3 TX (count = 1)
T + 150 ms: Echo#4 TX (count = 2)
T + 151 ms: Echo#3 RX (count = 0; ~50 ms roundtrip latency)
T + 200 ms: Echo#5 TX (count = 1)
T + 250 ms: Echo#6 TX (count = 2)
T + 251 ms: Echo#4 RX (count = 0; ~100 ms roundtrip latency)
T + 300 ms: Echo#7 TX (count = 1)
T + 350 ms: Echo#8 TX (count = 2)
T + 351 ms: Echo#5 RX (count = 0; ~150 ms roundtrip latency)
T + 451 ms: Echo#6 RX (count = 0; ~200 ms roundtrip latency; no failure detection)
T + 501 ms: Echo#7 RX (count = 0; ~200 ms roundtrip latency; no failure detection)
T + 551 ms: Echo#8 RX (count = 0; ~200 ms roundtrip latency; no failure detection)
 

BFD セッションのエコー パケットの受信間の遅延を見ると、(I x M)期間を超える遅延がないことが確認できます。

Echo#1 RX - Echo#2 RX: 50 ms
Echo#2 RX - Echo#3 RX: 100ms
Echo#3 RX - Echo#4 RX: 100ms
Echo#4 RX - Echo#5 RX: 100ms
Echo#5 RX - Echo#6 RX: 100ms
Echo#6 RX - Echo#7 RX: 50ms
Echo#7 RX - Echo#8 RX: 50ms

バンドル インターフェイスの BFD のパケット間隔および障害検出時間の概要

セッション間隔 I および係数 M のバンドル インターフェイスの BFD の場合、次のパケット間隔および障害検出時間が BFD 非同期モードに適用されます( 表 HC-8 )。

I の値:BFD 制御パケットの最小送信間隔。

I x M の値

BFD 制御パケット障害検出時間。これは、BFD セッションのダウンが宣言される前に BFD 制御パケットを受信せずに経過できる最大時間です。

BFD エコー パケットの最小送信間隔。

I x M )x M の値:BFD エコー パケット障害検出時間。これは、(「非同期モードでのエコー パケット障害検出」に説明する、標準係数カウンタ方式を使用して)BFD セッションのダウンが宣言される前に BFD エコー パケットを受信せずに経過できる最大時間です。

 

表 HC-8 バンドル インターフェイスの BFD パケット間隔と障害検出時間の例

設定された非同期制御パケット間隔(ms)
(bfd address-family ipv4 minimum-interval)
設定された係数
(bfd address-family ipv4 multiplier)
非同期制御パケット障害検出時間
(ms)
(間隔 x 係数)
エコー パケット間隔
(非同期制御パケット障害検出時間)
エコー パケット障害検出時間
(エコー間隔 x 係数)

50

3

150

150

450

75

4

300

300

1200

200

2

400

400

800

2000

3

6000

6000

18000

15000

3

45000

300001

90000

1.バンドル メンバ リンクの BFD の最大エコー パケット間隔は、30 秒または非同期制御パケット障害検出時間のいずれかの最小値です。

エコー パケット遅延

Cisco IOS XR 4.0.1 よりも前の Cisco IOS XR ソフトウェア リリースでは、BFD は特定のエコー パケットの TX/RX に対する特定の遅延ではなく、エコー パケットの受信がないことだけを検出します。場合によっては、BFD エコー パケットの受信が一般的に障害検出およびパケット送信の全体許容値内であるにもかかわらず、エコー パケットの特定のラウンドトリップのためにある期間の間に遅延がより長くなることがあります(「例 3」を参照)。

Cisco IOS XR 4.0.1 以降、ルータを設定して、非バンドル インターフェイスでエコー パケットの送受信間の実際の遅延を検出でき、また遅延がそのラウンドトリップ遅延に設定されたしきい値を超えるときにセッションをダウンできます。詳細については、「エコー遅延検出に基づく BFD セッション ティアダウンの設定」を参照してください。

また、BFD セッションを開始する前に、エコー パケット パスが指定された遅延許容値内にあることも検証できます。エコー起動検証では、BFD セッションの状態を変更できるようにする前に、設定された遅延内の正常送信を検証するために、ダウン中にエコー パケットがリンクで定期的に送信されます。詳細については、「エコー パスと遅延の検証までの BFD セッション開始の遅延」を参照してください。

BFD パケットのプライオリティの設定

オーバーサブスクリプションであるすべてのインターフェイスに対して、BFD パケットが他のデータ パケットによって過負荷にならないように、内部プライオリティをリモート BFD エコー パケットに割り当てる必要があります。また、中間スイッチの場合に、リモート BFD エコー パケットの応答がスイッチのその他すべてのパケットから保護されるように CoS 値を適切に設定する必要があります。

イーサネット ヘッダーに設定された CoS 値がエコー メッセージで維持されない可能性があるため、CoS 値を適切な出力 QoS サービス ポリシーに明示的に設定する必要があります。set cos コマンドを使用して、トラフィック クラスに付加された BFD パケットの CoS 値を設定できます。クラスベースの無条件パケット マーキングの設定の詳細については、『 Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Configuration Guide 』の「Configuring Modular QoS Packet Classification」を参照してください。

IPv4 用 BFD

Cisco IOS XR ソフトウェアは、IPv4 と IPv6 の両方について双方向フォワーディング検出(BFD)をサポートします。

IPv4 単一ホップ接続の BFD において、Cisco IOS XR ソフトウェアは、番号付けされた物理 Packet-over-SONET/SDH(POS)およびギガビット イーサネット リンクでの非同期モードとエコー モードの両方を次のようにサポートします。

エコー モードは、BFD 制御パケットを使用してセッションが確立された後にのみ開始されます。BFD バンドル メンバ インターフェイスでは、エコー モードは常にイネーブルです。物理インターフェイスでは、エコー パケットをサポートするために BFD 最小間隔も 2 秒未満である必要があります。

BFD エコー パケットは、送信元および宛先ポート 3785 を使用して、UDP/IPv4 で送信されます。IP パケットの送信元アドレスは、出力インターフェイスの IP アドレス(デフォルト)または echo ipv4 source コマンドで指定されたアドレスであり、宛先アドレスはローカル インターフェイス アドレスです。

BFD 非同期パケットは、送信元ポート 49152 および宛先ポート 3784 を使用して、UDP および IPv4 で送信されます。非同期モードの場合、IP パケットの送信元アドレスはローカル インターフェイス アドレス、宛先アドレスはリモート インターフェイス アドレスとなります。

Cisco IOS XR ソフトウェアに BFD を設定する場合は、次の注意事項を考慮してください。

BFD は固定長の Hello プロトコルで、接続の各終端で転送パスを通じてパケットを定期的に送信します。 Cisco IOS XR ソフトウェアは、BFD の適応型検出時間をサポートします。

BFD は、次のアプリケーションと併用することができます。

BGP

IS-IS

OSPF および OSPFv3

MPLS トラフィック エンジニアリング(MPLS-TE)

スタティック ルート(IPv4 および IPv6)

プロトコルに依存しないマルチキャスト(PIM)

ホットスタンバイ ルータ プロトコル(HSRP)

仮想ルータ冗長プロトコル(VRRP)


) 複数のアプリケーションが同じ BFD セッションを共有するとき、最も強力なタイマーのあるアプリケーションがローカルで優先されます。その結果は、次にピア ルータとネゴシエートされます。


BFD は、次のインターフェイス タイプでの接続でサポートされます。

ギガビット イーサネット(GigE)

10 ギガビット イーサネット(TenGigE)

Packet-over-SONET/SDH(POS)

シリアル

仮想 LAN(VLAN)

Cisco IOS XR ソフトウェアは、BFD バージョン 0 およびバージョン 1 をサポートします。BFD セッションは、ネイバーに応じていずれかのバージョンを使用して確立されます。BFD バージョン 1 はデフォルト バージョンであり、セッション作成において最初に試行されます。

BFD は、外部 BGP ピアに直接接続されている IPv4 でサポートされます。

IPv6 用 BFD

Cisco IOS XR ソフトウェアは、IPv4 と IPv6 の両方について双方向フォワーディング検出(BFD)をサポートします。IPv6 での双方向フォワーディング検出(BFD)では、IPv6 アドレスを使用するインターフェイスでの稼動中の接続の検証をサポートします。

稼動中の接続の検証は、IPv4 と IPv6 の両方のインターフェイスについて、次の同じサービスとプロセスによって実行されます。

ルート プロセッサ上の BFD サーバ

ラインカード上の BFD エージェント

ただし、BFD サーバと BFD エージェントの両方が個別のデータベースを使用します。

IPv4 アドレスを保存するための 1 つのセッション データベース。

IPv6 アドレスを保存するためのもう 1 つのセッション データベース。

同一ラインカード上で、IPv4 と IPv6 の両方の BFD セッションを同時に実行することができます。

IPv4 用 BFD でサポートされるものと同じ機能と設定が IPv6 用 BFD でもサポートされます。

バンドル VLAN での BFD

BFD は、スタティック ルーティング、IS-IS、OSPF を使用するバンドル VLAN でサポートされます。バンドル VLAN インターフェイスで BFD セッションを実行すると、VLAN バンドルがアップ状態である限り BFD セッションはアクティブな状態となります。

VLAN バンドルがアクティブである限り、次に示すイベントによって BFD セッションが失敗することはありません。

コンポーネント リンクの失敗。

1 つ以上のコンポーネント リンクをホストするラインカードの活性挿抜(OIR)。

バンドルへのコンポーネント リンクの追加(設定による)。

バンドルからのコンポーネント リンクの削除(設定による)。

コンポーネント リンクのシャットダウン。

RP スイッチオーバー。


) VLAN バンドル設定の詳細については、「Cisco ASR 9000 シリーズ ルータ でのリンク バンドルの設定」モジュールを参照してください。


バンドル VLAN 上の BFD を設定する場合には、次の事項に注意する必要があります。

RP スイッチオーバーの場合、設定されているネクストホップはルーティング情報ベース(RIB)に登録されます。

BFD 再起動の場合、スタティック ルートは RIB に残ります。BFD セッションは、BFD の再起動時に再確立されます。


) スタティック BFD セッションは、ネクストホップがルータに直接接続されているアドレス プレフィクスを持つピアでサポートされます。


リンク バンドルのメンバ リンク上の BFD

Cisco IOS XR Release 4.0.1 以降では、BFD 機能がリンクのレイヤ 3 接続をモニタする個々の物理バンドル メンバ リンクの BFD セッションをサポートします(図 1)。それよりも前のリリースでは、単一のバンドル メンバだけでサポートされていました。

図 1 バンドル上の元の BFD およびバンドル メンバ リンク アーキテクチャ上の拡張 BFD における BFD セッション

 

リンク バンドルで BFD を実行するとき、そのバンドルの一部である基礎となる各物理インターフェイスで独立した BFD セッションを実行できます。

BFD がリンク バンドル メンバで実行されているとき、接続の次のレイヤは BFD のインターフェイス状態モニタリングの一部として実質上テストされます。

レイヤ 1 の物理状態

レイヤ 2 のリンク アクセス コントロール プロトコル(LACP)状態

レイヤ 3 の BFD 状態

各バンドル メンバ リンクの BFD エージェントはリンクの状態変更をモニタリングします。バンドル メンバ リンクで実行されているセッションの BFD エージェントはバンドル マネージャと通信します。バンドル マネージャは、メンバ リンクの状態とバンドル全体のアベイラビリティを特定します。メンバ リンクの状態は、そのバンドル用に設定された最小アクティブ リンクまたは最小アクティブ帯域幅のしきい値に基づいて、バンドル全体の状態に影響を及ぼします。

メンバ リンクおよびバンドル ステータスでの BFD 状態変更動作の概要

この項では、バンドル メンバ リンクの状態がアクティブまたはダウンと見なされるとき、およびその状態のバンドル ステータス全体への影響について説明します。

すでにアクティブまたは非アクティブなバンドル メンバ インターフェイスに BFD を設定できます。インターフェイスで LACP を使用する BFD セッションが アップ になるには、LACP は 分散 状態に到達している必要があります。


) • リンクが LACP 分散状態にあり、BFD セッションがアップの場合、BFD メンバ リンクは「IIR Active」です。

LACP の状態遷移が受信されていない限り、BFD セッションがダウンしているときは、BFD メンバ リンクは「IIR Attached」です。


 

リンク バンドル BFD セッションのダウンを宣言する前に、ピアからの BFD 状態変更通知(SCN)の受信遅延を許可するように最大 3600 秒(1 時間)のタイマーを設定できます。設定可能なタイマーは、次の状況に適用されます。

BFD セッションの開始( bfd address-family ipv4 timers start コマンド):BFD メンバ リンク セッションの開始後、セッションのアップを宣言するために、BFD ピアからの予想される通知の受信までに許可する秒数。この期間を過ぎても SCN を受信しない場合、BFD セッションのダウンが宣言されます。

ネイバーによる BFD 設定の削除通知( bfd address-family ipv4 timers nbr-unconfig コマンド):BFD ピア間の設定の不一致を解決できるように、BFD の設定が BFD ネイバーによって削除されたことの通知の受信後に許可する秒数。指定されたタイマーに達する前に BFD 設定の問題が解決されない場合、BFD セッションのダウンが宣言されます。

BFD セッションは、次のいずれかが発生すると、DOWN 通知を送信します。

BFD 設定がローカル メンバ リンクで削除される。

BFD システムは、設定が削除されたことを隣接ルータのピアに通知します。BFD セッションは、他のバンドル メンバ インターフェイスまたはバンドル全体の状態に影響を与えずにバンドル マネージャから削除されます。

メンバ リンクがバンドルから削除される。

バンドルからのメンバ リンクの削除によって、バンドル メンバは強制的に削除されます。BFD セッションが削除され、隣接ルータの BFD は NBR_CONFIG_DOWN ではなく、セッションの DOWN を示します。

次の状況では、DOWN 通知は送信されませんが、DOWN が発生したように内部インフラストラクチャはイベントを処理します。

BFD 設定は隣接ルータから削除され、ネイバーの未設定タイマー(設定されている場合)が時間切れになります。

BFD システムは BFD 設定が隣接ルータから削除されたことをバンドル マネージャに通知し、 bfd timers nbr-unconfig がリンクで設定されている場合は、タイマーを開始します。タイマーが切れる前に BFD 設定がローカル ルータから削除された場合、タイマーが停止して、ローカル ルータからの BFD 設定削除で予期される動作になります。

タイマーが切れた場合、動作は BFD セッション DOWN 通知の場合と同じです。

セッションの開始タイマーは、BFD ピアからの通知を受信する前に時間切れになります。

バンドル メンバの BFD セッションがバンドル マネージャに BFD 状態変更通知を送信します。バンドル メンバ インターフェイスの BFD 状態変更通知がバンドル マネージャによっていったん受信されると、バンドル マネージャは対応するバンドル インターフェイスが使用可能であるかどうかを判断します。

バンドルのアクティブ メンバ リンクの最小数のしきい値は、メンバ リンクの状態に基づいてバンドルがアクティブなままか、ダウンであるかを判断するためにバンドル マネージャによって使用されます。BFD がすでにアクティブなバンドルで開始されたとき、バンドルの BFD 状態はすべての既存のアクティブ メンバの BFD 状態が認識された場合に宣言されます。

メンバの状態が変更されるたびに、アクティブ メンバの数がアクティブ リンクのしきい値の最小数よりも小さいかどうかをバンドル マネージャが判断します。小さい場合は、バンドルが DOWN 状態になるか、DOWN 状態を維持します。アクティブ リンク数が最小しきい値に達すると、バンドルは UP 状態に戻ります。

バンドルで設定可能な別のしきい値は、バンドルが DOWN 状態になるまで使用可能にする最小アクティブ帯域幅の量を決定するために、バンドル マネージャによって使用されます。これは bundle minimum-active bandwidth コマンドを使用して設定します。

BFD サーバは、バンドル インターフェイスの状態変更に関するバンドル マネージャからの情報に応答し、システム メッセージおよび MIB トラップも送信している間に、そのインターフェイスのアプリケーションに通知します。

バンドル マネージャは、バンドル インターフェイス(メンバ インターフェイスではない)の fast-protect イベントもサポートします。バンドル インターフェイスをアウト オブ サービスにするために十分なバンドル メンバ リンクが DOWN 状態に移行する場合、バンドル マネージャは PROT_IF_DOWN fast-protect イベントを生成します。この fast-protect イベントは、転送テーブルをアップデートするためにすぐに転送情報ベース(FIB)に通知します。BFD サーバもバンドル インターフェイスの PROT_BFD_SESSION_DOWN fast-protect イベントを生成できます。


) PROT_IF_DOWN メッセージは、PROT_BFD_SESSION_DOWN fast-protect メッセージの前に生成されます。したがって、PROT_IF_DOWN および PROT_BFD_SESSION_DOWN fast-protect イベントの両方を登録しているアプリケーションを使用するバンドル インターフェイスでは、PROT_IF_DOWN fast-protect イベントの受信に基づいて、必要なアクションのトリガーを計画する必要があります。


BFD の設定方法

ここでは、次の手順について説明します。

「BFD 設定時の注意事項」(必須)

「ダイナミック ルーティング プロトコルの下またはスタティック ルートを使用した BFD の設定」(必須)

「バンドル メンバ リンクでの BFD の設定」(任意)

「BFD ピアへの転送パスをテストするためのエコー モードのイネーブル化」(任意)

「デフォルト エコー パケット送信元アドレスの上書き」(任意)

「エコー遅延検出に基づく BFD セッション ティアダウンの設定」(任意)

「エコー パスと遅延の検証までの BFD セッション開始の遅延」(任意)

「BFD ダンプニングを使用する最小 BFD セッション フラッピング」(任意)

「エコー モードのディセーブル化」(任意)

「BFD カウンタのクリアおよび表示」(任意)

BFD 設定時の注意事項

BFD を設定する前に、次の注意事項を考慮してください。

BFD を使用する FRR/TE は、POS インターフェイスおよびイーサネット インターフェイスでサポートされます。

Cisco IOS XR ソフトウェアで BFD ネイバーを確立するには、BFD をダイナミック ルーティング プロトコルの下またはスタティック ルートを使用して設定する必要があります。

BFD セッションのパケット/秒(pps)単位の最大レートはラインカードに依存します。BFD をサポートする複数のラインカードがある場合、システムごとの BFD セッションの最大レートは、サポートされるラインカード レートにラインカードの数を掛けた値です。

ラインカードごとの BFD セッションの最大レートは 9600 pps です。

任意の 1 つのカードでサポートされる BFD セッションの最大数は 1250 です。

バンドルのメンバの最大数は 64 です。

バンドルの VLAN における BFD セッションの最大数は 128 です。

BFD を OSPF と併用するときは、次の注意事項を考慮してください。

BFD は、ネイバーの状態が フル の場合だけ、ネイバーから指定ルータ(DR)またはバックアップ DR(BDR)へのセッションを確立します。

BFD は DR-Other ネイバー間のセッションを確立しません(たとえば、これらの OSPF 状態が両方とも双方向のとき)。


注意 特定のインターフェイスで BFD をユニキャスト リバース パス転送(uRPF)と併用している場合は、echo disable コマンドを使用して、そのインターフェイスでのエコー モードをディセーブルにする必要があります。そうしないと、エコー パケットは拒否されます。詳細については、「エコー モードのディセーブル化」を参照してください。

IPv4 インターフェイスでの IPv4 uRPF チェックをイネーブルまたはディセーブルにするには、インターフェイス コンフィギュレーション モードで [no] ipv4 verify unicast source reachable-via コマンドを使用します。IPv6 インターフェイスでの loose 方式 IPv6 uRPF チェックをイネーブルまたはディセーブルにするには、インターフェイス コンフィギュレーション モードで [no] ipv6 verify unicast source reachable-via any コマンドを使用します。

ダイナミック ルーティング プロトコルの下またはスタティック ルートを使用した BFD の設定

BFD ネイバーを確立するには、ダイナミック ルーティング プロトコルの下の BFD を設定するか、またはスタティック ルートを使用して BFD を設定する、次のいずれかの手順を実行します。

「BGP ネイバーでの BFD のイネーブル化」

「特定インターフェイスでの OSPF の BFD のイネーブル化」

「特定インターフェイスでの OSPFv3 の BFD のイネーブル化」

「スタティック ルートでの BFD のイネーブル化」

BGP ネイバーでの BFD のイネーブル化

BFD は、ネイバー単位またはインターフェイス単位でイネーブルにすることができます。ここでは、隣接ルータの BGP に対して BFD をイネーブルにする方法について説明します。インターフェイス単位で BFD をイネーブルにするには、「特定インターフェイスでの OSPF の BFD のイネーブル化」に記載されている手順を使用します。


) BFD 隣接ルータの設定は、BGP でのみサポートされます。


手順の概要

1. configure

2. router bgp autonomous-system-number

3. bfd minimum-interval milliseconds

4. bfd multiplier multiplier

5. neighbor ip-address

6. remote-as autonomous-system-number

7. bfd fast-detect

8. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router bgp autonomous-system-number

 

RP/0/RSP0/CPU0:router(config)# router bgp 120

BGP コンフィギュレーション モードを開始します。このモードでは、BGP ルーティング プロセスの設定を行えます。

現在のルータの autonomous-system-number を取得するには、EXEC モードで show bgp コマンドを使用します。

ステップ 3

bfd minimum-interval milliseconds

 

RP/0/RSP0/CPU0:router(config-bgp)# bfd minimum-interval 6500

BFD の最小間隔を設定します。範囲は 15 ~ 30000 ミリ秒です。

ステップ 4

bfd multiplier multiplier

 

RP/0/RSP0/CPU0:router(config-bgp)# bfd multiplier 7

BFD 係数を設定します。

ステップ 5

neighbor ip-address

 

RP/0/RSP0/CPU0:router(config-bgp)# neighbor 172.168.40.24

BGP ルーティングのためにルータをネイバー コンフィギュレーション モードにして、ネイバー IP アドレスを BGP ピアとして設定します。

この例では、IP アドレス 172.168.40.24 を BGP ピアとして設定します。

ステップ 6

remote-as autonomous-system-number

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# remote-as 2002

ネイバーを作成し、そのネイバーをリモート自律システムに割り当てます。

この例では、設定されるリモート自律システムは 2002 です。

ステップ 7

bfd fast-detect

 

RP/0/RSP0/CPU0:router(config-bgp-nbr)# bfd fast-detect

ローカル ネットワーキング デバイスと、手順 5 で IP アドレスを BGP ピアとして設定したネイバー間での BFD をイネーブルにします。

手順 5 の例では、IP アドレス 172.168.40.24 が BGP ピアとして設定されています。この例では、ローカル ネットワーキング デバイスとネイバー 172.168.40.24 間での BFD がイネーブルになります。

ステップ 8

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bgp-nbr)# end

または

RP/0/RSP0/CPU0:router(config-bgp-nbr)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

特定インターフェイスでの OSPF の BFD のイネーブル化

次に、Open Shortest Path First(OSPF)での BFD を特定のインターフェイスで設定する手順について説明します。この方法の手順は、コマンド モードだけが異なる点を除き、IS-IS および MPLS-TE での BFD を設定する手順と共通です。


) インターフェイス単位での BFD の設定は、OSPF、OSPFv3、IS-IS、および MPLS-TE でのみサポートされます。OSPFv3 インターフェイスでの BFD の設定の詳細については、「特定インターフェイスでの OSPFv3 の BFD のイネーブル化」を参照してください。


手順の概要

1. configure

2. router ospf process-name

3. bfd minimum-interval milliseconds

4. bfd multiplier multiplier

5. area area-id

6. interface type interface-path-id

7. bfd fast-detect

8. end
または
commit

9. show run router ospf

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router ospf process-name

 

RP/0/RSP0/CPU0:router(config)# router ospf 0

OSPF コンフィギュレーション モードを開始します。このモードでは、OSPF ルーティング プロセスの設定を行えます。

現在のルータの process-name を取得するには、EXEC モードで show ospf コマンドを使用します。

(注) IS-IS または MPLS-TE での BFD を設定するには、対応するコンフィギュレーション モードを開始します。たとえば、MPLS-TE の場合は、MPLS-TE コンフィギュレーション モードを開始します。

ステップ 3

bfd minimum-interval milliseconds

 

RP/0/RSP0/CPU0:router(config-ospf)# bfd minimum-interval 6500

BFD の最小間隔を設定します。範囲は 15 ~ 30000 ミリ秒です。

この例では、BFD の最小間隔を 6500 ミリ秒に設定しています。

ステップ 4

bfd multiplier multiplier

 

RP/0/RSP0/CPU0:router(config-ospf)# bfd multiplier 7

BFD 係数を設定します。

この例では、BFD 係数を 7 に設定しています。

ステップ 5

area area-id

 

RP/0/RSP0/CPU0:router(config-ospf)# area 0

Open Shortest Path First(OSPF)領域を設定します。

area-id は、OSPF 領域の ID に置き換えます。

ステップ 6

interface type interface-path-id
 
RP/0/RSP0/CPU0:router(config-ospf-ar)# interface gigabitEthernet 0/3/0/1

インターフェイス コンフィギュレーション モードを開始して、インターフェイス名と rack/slot/module/port 表記を指定します。

この例では、モジュラ サービス カード スロット 3 にあるギガビット イーサネット インターフェイスを示しています。

ステップ 7

bfd fast-detect
 
RP/0/RSP0/CPU0:router(config-ospf-ar-if)# bfd fast-detect

隣接する転送エンジン間のパスで障害を検出するために、BFD をイネーブルにします。

ステップ 8

end

または

commit

 

RP/0/RSP0/CPU0:router (config-ospf-ar-if)# end

または

RP/0/RSP0/CPU0:router(config-ospf-ar-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 9

show run router ospf

 

RP/0/RSP0/CPU0:router (config-ospf-ar-if)# show run router ospf

適切なインターフェイスで BFD がイネーブルになっていることを確認します。

特定インターフェイスでの OSPFv3 の BFD のイネーブル化

次に、OSPFv3 での BFD を特定のインターフェイスで設定する手順について説明します。この方法の手順は、コマンド モードだけが異なる点を除き、IS-IS および MPLS-TE での BFD を設定する手順と共通です。


) インターフェイス単位での BFD の設定は、OSPF、OSPFv3、IS-IS、および MPLS-TE でのみサポートされます。OSPF インターフェイスでの BFD の設定の詳細については、「特定インターフェイスでの OSPF の BFD のイネーブル化」を参照してください。


手順の概要

1. configure

2. router ospfv3 process-name

3. bfd minimum-interval milliseconds

4. bfd multiplier multiplier

5. area area-id

6. interface type interface-path-id

7. bfd fast-detect

8. end
または
commit

9. show run router ospfv3

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router ospfv3 process-name

 

RP/0/RSP0/CPU0:router(config)# router ospfv3 0

OSPFv3 コンフィギュレーション モードを開始します。このモードでは、OSPFv3 ルーティング プロセスの設定を行えます。

現在のルータのプロセス名を取得するには、EXEC モードで show ospfv3 コマンドを使用します。

(注) IS-IS または MPLS-TE での BFD を設定するには、対応するコンフィギュレーション モードを開始します。たとえば、MPLS-TE の場合は、MPLS-TE コンフィギュレーション モードを開始します。

ステップ 3

bfd minimum-interval milliseconds

 

RP/0/RSP0/CPU0:router(config-ospfv3)# bfd minimum-interval 6500

BFD の最小間隔を設定します。範囲は 15 ~ 30000 ミリ秒です。

この例では、BFD の最小間隔を 6500 ミリ秒に設定しています。

ステップ 4

bfd multiplier multiplier

 

RP/0/RSP0/CPU0:router(config-ospfv3)# bfd multiplier 7

BFD 係数を設定します。

この例では、BFD 係数を 7 に設定しています。

ステップ 5

area area-id

 

RP/0/RSP0/CPU0:router(config-ospfv3)# area 0

OSPFv3 領域を設定します。

area-id は、OSPFv3 領域の ID に置き換えます。

ステップ 6

interface type interface-path-id
 
RP/0/RSP0/CPU0:router(config-ospfv3-ar)# interface gigabitEthernet 0/1/5/0

インターフェイス コンフィギュレーション モードを開始して、インターフェイス名と rack/slot/module/port 表記を指定します。

この例では、モジュラ サービス カード スロット 1 にあるギガビット イーサネット インターフェイスを示しています。

ステップ 7

bfd fast-detect
 
RP/0/RSP0/CPU0:router(config-ospfv3-ar-if)# bfd fast-detect

隣接する転送エンジン間のパスで障害を検出するために、BFD をイネーブルにします。

ステップ 8

end

または

commit

 

RP/0/RSP0/CPU0:router (config-ospfv3-ar-if)# end

または

RP/0/RSP0/CPU0:router(config-ospfv3-ar-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 9

show run router ospfv3

 

RP/0/RSP0/CPU0:router (config-ospfv3-ar-if)# show run router ospfv3

適切なインターフェイスで BFD がイネーブルになっていることを確認します。

スタティック ルートでの BFD のイネーブル化

次に、スタティック ルートでの BFD をイネーブルにする手順について説明します。


) バンドル VLAN セッションは、間隔 250 ミリ秒、係数 3 に制限されます。これよりも強力なパラメータは使用できません。


手順の概要

1. configure

2. router static

3. address-family ipv4 unicast address nexthop bfd fast-detect [ minimum interval interval ] [multiplier multiplier ]

4. vrf vrf-name

5. address-family ipv4 unicast address nexthop bfd fast-detect [ minimum interval interval ] [ multiplier multiplier ]

6. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router static

 

RP/0/RSP0/CPU0:router(config)# router static

スタティック ルート コンフィギュレーション モードを開始します。このモードでは、スタティック ルーティングの設定を行えます。

ステップ 3

address-family ipv4 unicast address nexthop bfd fast-detect [ minimum-interval interval ] [ multiplier multiplier ]

 
RP/0/RSP0/CPU0:router(config-static)# address-family ipv4 unicast 0.0.0.0/0 2.6.0.1 bfd fast-detect minimum-interval 1000 multiplier 5

指定の IPV4 ユニキャスト宛先アドレス プレフィクスおよびフォワーディング ネクストホップ アドレスで BFD 高速検出をイネーブルにします。

引数は、間隔をミリ秒単位で指定する数字に置き換えます。範囲は 10 ~ 10000 です。

引数は、検出係数を指定する数字に置き換えます。範囲は 1 ~ 10 です。

(注) バンドル VLAN セッションは、間隔 250 ミリ秒、係数 3 に制限されます。これよりも強力なパラメータは使用できません。

ステップ 4

vrf vrf-name

 
RP/0/RSP0/CPU0:router(config-static)# vrf vrf1

VPN ルーティングおよび転送(VRF)インスタンスを指定して、その VRF に対するスタティック ルート コンフィギュレーション モードを開始します。

ステップ 5

address-family ipv4 unicast address nexthop bfd fast-detect

 
RP/0/RSP0/CPU0:router(config-static-vrf)# address-family ipv4 unicast 0.0.0.0/0 2.6.0.2

指定の IPV4 ユニキャスト宛先アドレス プレフィクスおよびフォワーディング ネクストホップ アドレスで BFD 高速検出をイネーブルにします。

ステップ 6

end

または

commit

 

RP/0/RSP0/CPU0:router (config-static-vrf)# end

または

RP/0/RSP0/CPU0:router(config-static-vrf)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。
Uncommitted changes found.Commit them?

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、設定変更のコミットは行われず、ユーザに対して同じコマンド モードが継続されます。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

前提条件

バンドル メンバである物理インターフェイスは、間にスイッチを使用せずにピア ルータ間で直接接続している必要があります。

バンドルでの BFD 宛先アドレスの指定

バンドルで BFD 宛先アドレスを指定するには、次の手順を実行します。

手順の概要

1. configure

2. interface [ Bundle-Ether bundle-id

3. bfd address-family ipv4 destination ip-address

4. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router(config)# interface Bundle-Ether 1

指定したバンドル ID のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

bfd address-family ipv4 destination ip-address

 

RP/0/RSP0/CPU0:router(config-if)# bfd address-family ipv4 destination 10.20.20.1

接続されたリモート システムのバンドル インターフェイスに割り当てるプライマリ IPv4 アドレスを指定します。ここで、 ip-address は、ドット付き 10 進形式(A.B.C.D)の 32 ビット IP アドレスです。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

バンドル メンバの BFD セッションのイネーブル化

バンドル メンバ リンクの BFD セッションをイネーブルにするには、次の手順を実行します。

手順の概要

1. configure

2. interface Bundle-Ether bundle-id

3. bfd address-family ipv4 fast-detect

4. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router(config)# interface Bundle-Ether 1

指定したバンドル ID のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

bfd address-family ipv4 fast-detect

 

RP/0/RSP0/CPU0:router(config-if)# bfd address-family ipv4 fast-detect

バンドル メンバ リンクの IPv4 BFD セッションをイネーブルにします。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

アクティブ バンドルを維持するための最小しきい値の設定

バンドル マネージャは、メンバ リンクの状態に基づいて、バンドルが始動できるまたはアップのまま維持できる、またはダウンしているかどうかを判断するために 2 つの設定可能な最小しきい値を使用します。

アクティブ リンクの最小数

使用可能な最小アクティブ帯域幅

メンバの状態が変更されるたびに、アクティブ メンバの数または使用可能な帯域幅が最小値よりも小さいかどうかをバンドル マネージャが判断します。小さい場合は、バンドルが DOWN 状態になるか、DOWN 状態を維持します。アクティブ リンク数または使用可能な帯域幅が最小しきい値のいずれかに達すると、バンドルが UP 状態に戻ります。

最小バンドルしきい値を設定するには、次の手順を実行します。

手順の概要

1. configure

2. interface Bundle-Ether bundle-id

3. bundle minimum-active bandwidth kbps t

4. bundle minimum-active links links

5. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router(config)# interface Bundle-Ether 1

指定したバンドル ID のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

bundle minimum-active bandwidth kbps

 

 

RP/0/RSP0/CPU0:router(config-if)# bundle minimum-active bandwidth 580000

バンドルを始動またはアップのままにできる前に必要な最小帯域幅の量を設定します。範囲は 1 からプラットフォームおよびバンドル タイプによって異なる数値までです。

ステップ 4

bundle minimum-active links links

 

 

RP/0/RSP0/CPU0:router(config-if)# bundle minimum-active links 2

バンドルを始動またはアップのままにできる前に必要なアクティブ リンク数を設定します。範囲は 1 ~ 32 です。

(注) BFD がすでにアクティブなバンドルで開始されたとき、バンドルの BFD 状態はすべての既存のアクティブ メンバの BFD 状態が認識された場合に宣言されます。

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

バンドルの BFD パケット送信間隔と障害検出時間の設定

バンドル メンバ リンクの BFD セッションの BFD 非同期パケット間隔と障害検出時間は、 bfd address-family ipv4 minimum-interval および bfd address-family ipv4 multiplier インターフェイス コンフィギュレーション コマンドの組み合わせを使用して設定されます。

BFD 制御パケット間隔は、 bfd address-family ipv4 minimum-interval コマンドを使用して直接設定されます。BFD エコー パケット間隔およびすべての障害検出時間は、これらのコマンドの間隔および係数の値を組み合わせて決定されます。詳細については、「BFD パケット間隔および障害検出」を参照してください。

バンドル メンバ リンクの BFD 非同期モード制御およびエコー パケットの最小送信間隔と障害検出時間を設定するには、次の手順を実行します。

手順の概要

1. configure

2. interface Bundle-Ether bundle-id

3. bfd address-family ipv4 minimum-interval milliseconds

4. bfd address-family ipv4 multiplier multiplier

5. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router(config)# interface Bundle-Ether 1

指定したバンドル ID のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

bfd address-family ipv4 minimum-interval milliseconds

 

RP/0/RSP0/CPU0:router(config-if)#

バンドル メンバ リンクの IPv4 BFD セッションにおける非同期モード制御パケットの最小間隔を指定します。範囲は 15 ~ 30000 ミリ秒です。

(注) コマンドには最小で 15 ms を設定できますが、Cisco ASR 9000 シリーズ ルータでサポートされる最小値は 50 ms です。

ステップ 4

bfd address-family ipv4 multiplier multiplier

 

 

RP/0/RSP0/CPU0:router(config-if)#

バンドル メンバ リンクの IPv4 BFD セッションの BFD 制御、エコー パケット障害検出時間およびエコー パケットの送信間隔を決定するために、最小間隔とともに係数として使用する値を指定します。範囲は 2 ~ 50 です。デフォルトは 3 です。

(注) コマンドには最小で 2 を設定できますが、サポートされる最小値は 3 です。

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

バンドルのタイマーを使用する BFD 状態変更通知で許容される遅延の設定

リンク バンドル メンバの BFD セッションのダウンを宣言する前に、ピアからの BFD SCN の受信の遅延を許可するために次の 2 つの設定可能なタイマーが BFD システムによってサポートされています。

BFD セッションの開始

ネイバーによる BFD 設定の削除

これらのタイマーの動作および他の BFD 状態変更の動作の詳細については、「メンバ リンクおよびバンドル ステータスでの BFD 状態変更動作の概要」を参照してください。

ピアからの BFD SCN の受信の遅延を許可するタイマーを設定するには、次の手順を実行します。

手順の概要

1. configure

2. interface Bundle-Ether bundle-id

3. bfd address-family ipv4 timers start seconds

4. bfd address-family ipv4 timers nbr-unconfig seconds

5. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface Bundle-Ether bundle-id

 

RP/0/RSP0/CPU0:router(config)# interface Bundle-Ether 1

指定したバンドル ID のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

bfd address-family ipv4 timers start seconds

 

RP/0/RSP0/CPU0:router(config-if)#

セッションのアップが宣言できるように、BFD メンバ リンク セッション開始後に、BFD ピアからの予想される通知の受信を待機する秒数を指定します。この期間を過ぎても SCN を受信しない場合、BFD セッションのダウンが宣言されます。範囲は 60 ~ 3600 です。(Cisco IOS XR Release 4.0 および 4.0.1 では、使用可能な最小値は 30 ですが、これは推奨されません)。

ステップ 4

bfd address-family ipv4 timers nbr-unconfig seconds

 

RP/0/RSP0/CPU0:router(config-if)#

BFD ピア間の設定の不一致を解決できるように、BFD 設定が BFD ネイバーによって削除されたことの通知の受信後に待機する秒数を指定します。指定されたタイマーに達する前に BFD 設定の問題が解決されない場合、BFD セッションのダウンが宣言されます。範囲は 30 ~ 3600 です。

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

BFD ピアへの転送パスをテストするためのエコー モードのイネーブル化

BFD エコー モードは、次のインターフェイスではデフォルトでイネーブルです。

BFD バンドル インターフェイスのメンバ リンク上の IPv4 の場合。

最小間隔が 2 秒未満の他の物理インターフェイス上の IPv4 の場合。


bfd minimum-interval コマンドを使用して、物理インターフェイスの BFD 最小間隔に 2 秒よりも大きい値を設定した場合、エコー モードをサポートして、イネーブルにするためには間隔を 2 秒未満に変更する必要があります。これは、常にエコー モードをサポートするバンドル メンバ リンクには該当しません。


デフォルト エコー パケット送信元アドレスの上書き

エコー パケット送信元アドレスを指定しないと、BFD はエコー パケットのデフォルト送信元アドレスとして出力インターフェイスの IP アドレスを使用します。

Cisco IOS XR Release 3.9.0 よりも前では、 router-id コマンドを使用してローカル ルータ ID を設定し、エコー パケット送信元アドレスのデフォルト IP アドレスをルータ ID として指定されたアドレスに変更することが推奨されます。

Cisco IOS XR Release 3.9.0 以降では、BFD で echo ipv4 source コマンドを使用するか、インターフェイス BFD コンフィギュレーション モードを使用して、エコー パケット送信元アドレスとして使用する IP アドレスを指定できます。

ルータ全体の BFD、または特定のインターフェイス上でエコー パケットのデフォルト IP 送信元アドレスを上書きできます。

「BFD のエコー パケット送信元アドレスのグローバルな指定」

「個々のインターフェイスまたはバンドルのエコー パケット送信元アドレスの指定」

BFD のエコー パケット送信元アドレスのグローバルな指定

ルータで BFD のエコー パケット送信元 IP アドレスをグローバルに指定するには、次の手順を実行します。

手順の概要

1. configure

2. bfd

3. echo ipv4 source ip-address

4. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RSP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

echo ipv4 source ip-address

 

RP/0/RSP0/CPU0:router(config-bfd)# echo ipv4 source 10.10.10.1

BFD エコー パケットで送信元アドレスとして使用する IPv4 アドレスを指定します。ここで、 ip-address は、ドット付き 10 進形式(A.B.C.D)の 32 ビット IP アドレスです。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd)# end

または

RP/0/RSP0/CPU0:router(config-bfd)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

個々のインターフェイスまたはバンドルのエコー パケット送信元アドレスの指定

個々の BFD インターフェイスまたはバンドルのエコー パケット送信元 IP アドレスを指定するには、次の手順を実行します。

手順の概要

1. configure

2. bfd

3. interface type interface-path-id

4. echo ipv4 source ip-address

5. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RSP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config-bfd)# interface gigabitEthernet 0/1/5/0

特定のインターフェイスまたはバンドルの BFD インターフェイス コンフィギュレーション モードを開始します。BFD インターフェイス コンフィギュレーション モードでは、個々のインターフェイスまたはバンドルのエコー モードをディセーブルにすることができます。

ステップ 4

echo ipv4 source ip-address

 

RP/0/RSP0/CPU0:router(config-bfd)# echo ipv4 source 10.10.10.1

BFD エコー パケットで送信元アドレスとして使用する IPv4 アドレスを指定します。ここで、 ip-address は、ドット付き 10 進形式(A.B.C.D)の 32 ビット IP アドレスです。

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

エコー遅延検出に基づく BFD セッション ティアダウンの設定

Cisco IOS XR 4.0.1 以降、設定されたエコー遅延許容値を超えると、非バンドル インターフェイスの BFD セッションがダウンするように、BFD セッションを設定できます。

エコー遅延検出を使用して BFD セッションのティアダウンを設定するには、次の手順を実行します。

前提条件

エコー遅延検出をイネーブルにする前に、BFD の設定がエコー モードをサポートしていることを確認します。

制約事項

エコー遅延検出はバンドル インターフェイスではサポートされません。

手順の概要

1. configure

2. bfd

3. echo latency detect [ percentage percent-value [ count packet-count ]

4. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RSP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

echo latency detect [ percentage percent-value [ count packet-count ]

 

RP/0/RSP0/CPU0:router(config-bfd)# echo latency detect

BFD セッション経路上のエコー パケット遅延検出をイネーブルにします。ここで、

percentage percent-value :不正遅延として検出するエコー障害検出時間のパーセンテージを指定します。範囲は 100 ~ 250 です。デフォルトは 100 です。

count packet-count :BFD セッションをダウンする、不正遅延で受信する連続したパケット数を指定します。範囲は 1 ~ 10 です。デフォルトは 1 です。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd)# end

または

RP/0/RSP0/CPU0:router(config-bfd)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

エコー パスと遅延の検証までの BFD セッション開始の遅延

Cisco IOS XR Release 4.0.1 以降、非バンドル インターフェイスの BFD セッションを開始する前に、エコー パケット パスが動作していて設定された遅延しきい値内であることを検証できます。

BFD エコー起動検証を設定するには、次の手順を実行します。

前提条件

エコー起動検証をイネーブルにする前に、BFD の設定がエコー モードをサポートしていることを確認します。

制約事項

エコー起動検証はバンドル インターフェイスではサポートされません。

手順の概要

1. configure

2. bfd

3. echo startup validate [ force ]

4. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RSP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

echo startup validate [ force ]

 

RP/0/RSP0/CPU0:router(config-bfd)# echo startup validate

BFD セッション開始前のリンクでエコー パケットが定期的に送信されるエコー パケット パスの検証をイネーブルにします。検証では、BFD セッションの状態変更を許可する前に、設定された遅延内での正常送信を検証します。

force キーワードが設定されていない場合、ローカル システムは、次の条件を満たす場合にエコー起動検証を実行します。

ローカル ルータがエコーを実行できる(エコーがこのセッションに対してイネーブル)。

リモート ルータがエコーを実行できる(リモート システムから受信した制御パケットがゼロ以外の「Required Min Echo RX Interval」値を持つ)。

force キーワードが設定されている場合、ローカル システムは、次の条件を満たす場合にエコー起動検証を実行します。

ローカル ルータがエコーを実行できる(エコーがこのセッションに対してイネーブル)。

リモート ルータのエコー機能が考慮されていない(リモート システムから受信した制御パケットがゼロまたはゼロ以外の「Required Min Echo RX Interval」値を持つ)。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd)# end

または

RP/0/RSP0/CPU0:router(config-bfd)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

エコー モードのディセーブル化

BFD は、特定の環境でのエコー モードの非同期動作をサポートしません。BFD を次のアプリケーションまたは条件で使用する場合、エコー モードをディセーブルにする必要があります。

バンドル VLAN の IPv4 用 BFD。

IPv6 用 BFD(グローバルおよびリンクローカル アドレッシング)

uRPF を使用する BFD(IPv4 または IPv6)

BFD バンドル インターフェイスに複数のラックにまたがるメンバ リンクがある場合の、ラック リロードおよび活性挿抜(OIR)をサポートするため。


) 最小間隔が 2 秒を超えると、BFD エコー モードは、物理インターフェイスの BFD に対して自動的にディセーブルになります。最小間隔は BFD バンドル メンバ リンクのエコー モードには影響しません。


ルータ全体の BFD、または特定のインターフェイスに対するエコー モードをディセーブルにできます。

「ルータでのエコー モードのディセーブル化」

「個々のインターフェイスまたはバンドルでのエコー モードのディセーブル化」

ルータでのエコー モードのディセーブル化

ルータでエコー モードをグローバルにディセーブルにするには、次の手順を実行します。

手順の概要

1. configure

2. bfd

3. echo disable

4. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RSP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

echo ipv4 source ip-address

 

RP/0/RSP0/CPU0:router(config-bfd)# echo ipv4 source 10.10.10.1

BFD エコー パケットで送信元アドレスとして使用する IPv4 アドレスを指定します。ここで、 ip-address は、ドット付き 10 進形式(A.B.C.D)の 32 ビット IP アドレスです。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd)# end

または

RP/0/RSP0/CPU0:router(config-bfd)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

個々のインターフェイスまたはバンドルでのエコー モードのディセーブル化

次の手順は、インターフェイスまたはバンドルでエコー モードをディセーブルにする方法について説明します。

手順の概要

1. configure

2. bfd

3. interface type interface-path-id

4. echo disable

5. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RSP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config-bfd)# interface gigabitEthernet 0/1/5/0

特定のインターフェイスまたはバンドルの BFD インターフェイス コンフィギュレーション モードを開始します。BFD インターフェイス コンフィギュレーション モードでは、個々のインターフェイスまたはバンドルのエコー モードをディセーブルにすることができます。

ステップ 4

echo disable

 

RP/0/RSP0/CPU0:router(config-bfd-if)# echo disable

ルータでエコー モードをディセーブルにします。

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

BFD ダンプニングを使用する最小 BFD セッション フラッピング

BFD セッション フラッピングを制御するために BFD ダンプニングを設定するには、次の手順を実行します。

手順の概要

1. configure

2. bfd

3. dampening [ bundle-member ]{ initial-wait | maximum-wait | secondary-wait } milliseconds

4. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RSP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

dampening [ bundle-member ]{ initial-wait | maximum-wait | secondary-wait } milliseconds

 

RP/0/RSP0/CPU0:router(config-bfd)# dampening initial-wait 30000

フラッピングを制御するための BFD セッション開始の遅延をミリ秒単位で指定します。

 

の値よりも大きい必要があります。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd)# end

または

RP/0/RSP0/CPU0:router(config-bfd)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

IPv6 チェックサム サポートのイネーブル化とディセーブル化

デフォルトでは、UDP パケットの IPv6 チェックサム計算はルータの BFD に対してディセーブルです。

ルータ全体の BFD、または特定のインターフェイスに対する IPv6 チェックサム サポートをイネーブルにできます。

「ルータの BFD の IPv6 チェックサム計算のイネーブル化とディセーブル化」

「個々のインターフェイスまたはバンドルの BFD の IPv6 チェックサム計算のイネーブル化とディセーブル化」


) コマンドライン インターフェイス(CLI)は、BFD 設定と BFD インターフェイス コンフィギュレーションでは若干異なります。BFD 設定では、disable キーワードはオプションではありません。したがって、そのモードで BFD 設定をイネーブルにするには、コマンドの no 形式を使用する必要があります。


ルータの BFD の IPv6 チェックサム計算のイネーブル化とディセーブル化

ルータで IPv6 チェックサム計算をグローバルにイネーブルまたはディセーブルにするには、次の手順を実行します。

手順の概要

1. configure

2. bfd

3. [ no ] ipv6 checksum disable

4. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RSP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

echo ipv4 source ip-address

 

RP/0/RSP0/CPU0:router(config-bfd)# echo ipv4 source 10.10.10.1

BFD エコー パケットで送信元アドレスとして使用する IPv4 アドレスを指定します。ここで、 ip-address は、ドット付き 10 進形式(A.B.C.D)の 32 ビット IP アドレスです。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd)# end

または

RP/0/RSP0/CPU0:router(config-bfd)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

個々のインターフェイスまたはバンドルの BFD の IPv6 チェックサム計算のイネーブル化とディセーブル化

次の手順は、インターフェイスまたはバンドルの IPv6 チェックサム計算をイネーブルまたはディセーブルにする方法について説明します。

手順の概要

1. configure

2. bfd

3. interface type interface-path-id

4. ipv6 checksum [ disable ]

5. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

bfd

 

RP/0/RSP0/CPU0:router(config)# bfd

BFD コンフィギュレーション モードを開始します。

ステップ 3

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config-bfd)# interface gigabitEthernet 0/1/5/0

特定のインターフェイスまたはバンドルの BFD インターフェイス コンフィギュレーション モードを開始します。BFD インターフェイス コンフィギュレーション モードでは、個々のインターフェイスまたはバンドルのエコー モードをディセーブルにすることができます。

ステップ 4

ipv6 checksum [ disable ]

 

RP/0/RSP0/CPU0:router(config-bfd-if)# ipv6 checksum

インターフェイスでの IPv6 チェックサム サポートをイネーブルにします。ディセーブルにするには、 disable キーワードを使用します。

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router (config-bfd-if)# end

または

RP/0/RSP0/CPU0:router(config-bfd-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before
exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに設定変更が保存され、コンフィギュレーション セッションが終了し、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

BFD カウンタのクリアおよび表示

次に、BFD パケット カウンタの表示およびクリアの手順について説明します。特定ノードまたは特定インターフェイスでホストされている BFD セッションのパケット カウンタをクリアすることができます。

手順の概要

1. show bfd counters packet [ interface type interface-path-id ] location node-id

2. clear bfd counters packet [ interface type interface-path-id ] location node-id

3. show bfd counters packet [ interface type interface-path-id ] location node-id

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

show bfd counters [ipv4 | ipv6 | all] packet [interface type interface-path-id ] location node-id

 

RP/0/RSP0/CPU0:router# show bfd counters all packet location 0/3/cpu0

IPv4 パケット、IPv6 パケット、またはすべてのパケットの BFD カウンタを表示します。

ステップ 2

clear bfd counters [ipv4 | ipv6 | all] packet [ interface type interface-path-id ] location node-id

 

RP/0/RSP0/CPU0:router# clear bfd counters all packet interface POS 0/5/0/1 location 0/5/cpu0

IPv4 パケット、IPv6 パケット、またはすべてのパケットの BFD カウンタをクリアします。

ステップ 3

show bfd counters [ipv4 | ipv6 | all] packet [interface type interface-path-id ] location node-id

 

RP/0/RSP0/CPU0:router# show bfd counters all packet location 0/3/cpu0

IPv4 パケット、IPv6 パケット、またはすべてのパケットの BFD カウンタがクリアされていることを確認します。

BFD の設定例

この項では、次の BFD 設定の例を示します。

「BGP 上の BFD:例」

「OSPF 上の BFD:例」

「スタティック ルート上の BFD:例」

「バンドル VLAN での BFD:例」

「リンク バンドルのメンバ リンク上の BFD」

「エコー パケット送信元アドレス:例」

「エコー遅延検出:例」

「エコー起動検証:例」

「BFD エコー モードのディセーブル化:例」

「BFD ダンプニング:例」

「BFD IPv6 チェックサム:例」

「Cisco IOS および Cisco IOS XR ソフトウェアを実行しているルータの BFD ピア:例」

BGP 上の BFD:例

次に、自律システム 65000 とネイバー 192.168.70.24 間に BFD を設定する例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# router bgp 65000
RP/0/RSP0/CPU0:router(config-bgp)# bfd multiplier 2
RP/0/RSP0/CPU0:router(config-bgp)# bfd minimum-interval 20
RP/0/RSP0/CPU0:router(config-bgp)# neighbor 192.168.70.24
RP/0/RSP0/CPU0:router(config-bgp-nbr)# remote-as 2
RP/0/RSP0/CPU0:router(config-bgp-nbr)# bfd fast-detect

OSPF 上の BFD:例

次に、ギガビット イーサネット インターフェイスでの OSPF の BFD をイネーブルにする例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# router ospf 0
RP/0/RSP0/CPU0:router(config-ospf)# area 0
RP/0/RSP0/CPU0:router(config-ospf-ar)# interface gigabitEthernet 0/3/0/1
RP/0/RSP0/CPU0:router(config-ospf-ar-if)# bfd fast-detect
RP/0/RSP0/CPU0:router(config-ospf-ar-if)# commit
 
RP/0/RSP0/CPU0:Dec 2 07:06:48.508 : config[65685]: %MGBL-LIBTARCFG-6-COMMIT : Configuration committed by user 'xxx'. Use 'show configuration commit changes 1000001134' to view the changes.
 
RP/0/RSP0/CPU0:router(config-ospf-ar-if)# end
 
RP/0/RSP0/CPU0:Dec 2 07:06:48.848 : config[65685]: %MGBL-SYS-5-CONFIG_I : Configured from console by lab
 
RP/0/RSP0/CPU0:router# show run router ospf
 
router ospf 0
area 0
interface GigabitEthernet0/3/0/1
bfd fast-detect
 

次に、ギガビット イーサネット インターフェイスでの OSPFv3 の BFD をイネーブルにする例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# router ospfv3 0
RP/0/RSP0/CPU0:router(config-ospfv3)# bfd minimum-interval 6500
RP/0/RSP0/CPU0:router(config-ospfv3)# bfd multiplier 7
RP/0/RSP0/CPU0:router(config-ospfv3-ar)# area 0
RP/0/RSP0/CPU0:router(config-ospfv3-ar)# interface gigabitethernet 0/1/5/0
RP/0/RSP0/CPU0:router(config-ospfv3-ar-if)# bfd fast-detect
RP/0/RSP0/CPU0:router(config-ospfv3-ar-if)# commit
RP/0/RSP0/CPU0:router(config-ospfv3-ar-if)# end
RP/0/RSP0/CPU0:router# show run router ospfv3

スタティック ルート上の BFD:例

次に、IPv4 スタティック ルートでの BFD をイネーブルにする例を示します。この例では、BFD セッションは、ネクストホップ 10.3.3.3 が到達可能になると、このネクストホップで確立されます。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# router static
RP/0/RSP0/CPU0:router(config-static)# address-family ipv4 unicast 10.2.2.0/24 10.3.3.3 RP/0/RSP0/CPU0:router(config-static)# bfd fast-detect
RP/0/RSP0/CPU0:router(config-static)# end
 

次に、IPv6 スタティック ルートでの BFD をイネーブルにする例を示します。この例では、BFD セッションは、ネクスト ホップ 2001:0DB8:D987:398:AE3:B39:333:783 が到達可能になると、このネクスト ホップで確立されます。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# router static
RP/0/RSP0/CPU0:router(config-static)# address-family ipv6 unicast 2001:0DB8:C18:2:1::F/64 2001:0DB8:D987:398:AE3:B39:333:783
RP/0/RSP0/CPU0:router(config-static)# bfd fast-detect
RP/0/RSP0/CPU0:router(config-static)# minimum-interval 150 multiplier 4
RP/0/RSP0/CPU0:router(config-static)# end
RP/0/RSP0/CPU0:router# show run router static address-family ipv6 unicast

バンドル VLAN での BFD:例

次に、Cisco IOS XR 4.0.1 よりも前の Cisco IOS XR ソフトウェア リリースで、バンドル VLAN での BFD を設定する例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# interface Bundle-ether 1
RP/0/RSP0/CPU0:router(config-if)# bundle maximum-active links 1
RP/0/RSP0/CPU0:router(config-if)# exit
!
RP/0/RSP0/CPU0:router(config)# interface TenGigE 0/1/0/1
RP/0/RSP0/CPU0:router(config-if)# bundle id 1 mode active
RP/0/RSP0/CPU0:router(config-if)# exit
!
RP/0/RSP0/CPU0:router(config)# interface TenGigE 0/2/0/1
RP/0/RSP0/CPU0:router(config-if)# bundle id 1 mode active
RP/0/RSP0/CPU0:router(config-if)# exit
!
RP/0/RSP0/CPU0:router(config)# router static
RP/0/RSP0/CPU0:router(config-static)# address-family ipv4 unicast
RP/0/RSP0/CPU0:router(config-static-afi)# 10.2.1.0/24 172.16.1.2 bfd fast-detect minimum-interval 250
RP/0/RSP0/CPU0:router(config-static-afi)# 10.2.2.0/24 172.16.2.2 bfd fast-detect minimum-interval 250
RP/0/RSP0/CPU0:router(config-static-afi)# 10.2.3.0/24 172.16.3.2 bfd fast-detect minimum-interval 250
RP/0/RSP0/CPU0:router(config-static-afi)# exit
RP/0/RSP0/CPU0:router(config-static)# exit
!
RP/0/RSP0/CPU0:router(config)# interface Bundle-Ether1.2
RP/0/RSP0/CPU0:router(config-if)# ipv4 address 172.16.2.1 255.255.255.0
RP/0/RSP0/CPU0:router(config-if)# dot1q vlan 2
RP/0/RSP0/CPU0:router(config-if)# exit
!
RP/0/RSP0/CPU0:router(config)# interface Bundle-Ether1.1
RP/0/RSP0/CPU0:router(config-if)# ipv4 address 172.16.1.1 255.255.255.0
RP/0/RSP0/CPU0:router(config-if)# dot1q vlan 1
 

バンドル メンバ リンクでの BFD:例

次に、イーサネット バンドル インターフェイスのメンバ リンクで BFD を設定する例を示します。

bfd
interface Bundle-Ether4
echo disable
!
interface GigabitEthernet0/0/0/2.3
echo disable
!
!
interface GigabitEthernet0/0/0/3 bundle id 1 mode active
interface GigabitEthernet0/0/0/4 bundle id 2 mode active
interface GigabitEthernet0/1/0/2 bundle id 3 mode active
interface GigabitEthernet0/1/0/3 bundle id 4 mode active
interface Bundle-Ether1
ipv4 address 192.168.1.1/30
bundle minimum-active links 1
!
interface Bundle-Ether1.1
ipv4 address 192.168.100.1/30
dot1q vlan 1001
!
interface Bundle-Ether2
bfd address-family ipv4 destination 192.168.2.2
bfd address-family ipv4 fast-detect
bfd address-family ipv4 min 83
bfd address-family ipv4 mul 3
ipv4 address 192.168.2.1/30
bundle minimum-active links 1
!
interface Bundle-Ether3
bfd address-family ipv4 destination 192.168.3.2
bfd address-family ipv4 fast-detect
bfd address-family ipv4 min 83
bfd address-family ipv4 mul 3
ipv4 address 192.168.3.1/30
bundle minimum-active links 1
!
interface Bundle-Ether4
bfd address-family ipv4 destination 192.168.4.2
bfd address-family ipv4 fast-detect
bfd address-family ipv4 min 83
bfd address-family ipv4 mul 3
ipv4 address 192.168.4.1/30
bundle minimum-active links 1
!
interface GigabitEthernet 0/0/0/2
ipv4 address 192.168.10.1/30
!
interface GigabitEthernet 0/0/0/2.1
ipv4 address 192.168.11.1/30
ipv6 address beef:cafe::1/64
dot1q vlan 2001
!
interface GigabitEthernet 0/0/0/2.2
ipv4 address 192.168.12.1/30
dot1q vlan 2002
!
interface GigabitEthernet 0/0/0/2.3
ipv4 address 192.168.13.1/30
dot1q vlan 2003
!
router static
address-family ipv4 unicast
10.10.11.2/32 192.168.11.2 bfd fast-detect minimum-interval 250 multiplier 3
10.10.12.2/32 192.168.12.2 bfd fast-detect minimum-interval 250 multiplier 3
10.10.13.2/32 192.168.13.2 bfd fast-detect minimum-interval 250 multiplier 3
10.10.100.2/32 192.168.100.2 bfd fast-detect minimum-interval 250 multiplier 3
!
address-family ipv6 unicast
babe:cace::2/128 beef:cafe::2 bfd fast-detect minimum-interval 250 multiplier 3
!

エコー パケット送信元アドレス:例

次に、ルータのすべての BFD セッションの BFD エコー パケットの送信元アドレスとして、IP アドレス 10.10.10.1 を指定する例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# bfd

RP/0/RSP0/CPU0:router(config-bfd)# echo ipv4 source 10.10.10.1

 

次に、個々のギガビット イーサネット インターフェイスの BFD エコー パケットの送信元アドレスとして、IP アドレス 10.10.10.1 を指定する例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# interface gigabitethernet 0/1/0/0

RP/0/RSP0/CPU0:router(config-bfd-if)# echo ipv4 source 10.10.10.1

 

次に、個々の Packet-over-SONET(POS)インターフェイスの BFD エコー パケットの送信元アドレスとして、IP アドレス 10.10.10.1 を指定する例を示します。

RP/0/RSP0/CPU0:router # configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# interface pos 0/1/0/0

RP/0/RSP0/CPU0:router(config-bfd-if)# echo ipv4 source 10.10.10.1

エコー遅延検出:例

次の例では、BFD 最小間隔は 50 ms、また BFD セッションの係数は 3 とします。

次に、パケット カウントが 1 の場合にエコー障害期間(I x M)のデフォルト値 100 % を使用してエコー遅延検出をイネーブルにする例を示します。この例では、ラウンドトリップ遅延が 150 ms を超える 1 つのエコー パケットを検出すると、セッションはダウンします。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# bfd

RP/0/RSP0/CPU0:router(config-bfd)# echo latency detect

 

次に、パケット カウントが 1 の場合にエコー障害期間 200 %(2 倍)に基づいてエコー遅延検出をイネーブルにする例を示します。この例では、ラウンドトリップ遅延が 300 ms を超える 1 つのパケットを検出すると、セッションはダウンします。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# echo latency detect percentage 200
 

次に、パケット カウントが 3 の場合にエコー障害期間 100 % に基づいてエコー遅延検出をイネーブルにする例を示します。この例では、ラウンドトリップ遅延が 150 ms を超える 3 つの連続するエコー パケットを検出すると、セッションはダウンします。

RP/0/RSP0/CPU0:router # configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# echo latency detect percentage 100 count 3

エコー起動検証:例

次に、最後に受信した制御パケットにゼロ以外の「Required Min Echo RX Interval」値が含まれている場合に、非バンドル インターフェイスの BFD セッションのエコー起動検証をイネーブルにする例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# bfd

RP/0/RSP0/CPU0:router(config-bfd)# echo startup validate

 

次に、最後の制御パケットの「Required Min Echo RX Interval」値に関係なく、非バンドル インターフェイスの BFD セッションのエコー起動検証をイネーブルにする例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# echo startup validate force

BFD エコー モードのディセーブル化:例

次に、ルータでエコー モードをディセーブルにする例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# echo disable
 

次に、インターフェイスでエコー モードをディセーブルにする例を示します。

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# interface gigabitethernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-bfd-if)# echo disable

BFD ダンプニング:例

次に、BFD バンドル メンバの BFD セッション開始の初期および最大遅延を設定する例を示します。

RP/0/RSP0/CPU0:router # configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# dampening bundle-member initial-wait 8000
RP/0/RSP0/CPU0:router(config-bfd)# dampening bundle-member maximum-wait 15000
 

次に、非バンドル インターフェイスの BFD のデフォルト initial-wait を変更する例を示します。

RP/0/RSP0/CPU0:router # configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# dampening initial-wait 30000
RP/0/RSP0/CPU0:router(config-bfd)# dampening maximum-wait 35000

BFD IPv6 チェックサム:例

次に、ルータのすべての BFD セッションの UDP パケットの IPv6 チェックサム計算をイネーブルにする例を示します。

RP/0/RSP0/CPU0:router # configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# no ipv6 checksum disable
 

次に、ルータのすべての BFD セッションの UDP パケットの IPv6 チェックサム計算をディセーブルにする例を示します。

RP/0/RSP0/CPU0:router # configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# ipv6 checksum disable
 

次に、個々のインターフェイスで BFD セッションのエコー モードをイネーブルにする例を示します。

RP/0/RSP0/CPU0:router # configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# interface gigabitethernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-bfd-if)# ipv6 checksum
 

次に、個々のインターフェイスで BFD セッションのエコー モードをディセーブルにする例を示します。

RP/0/RSP0/CPU0:router # configure
RP/0/RSP0/CPU0:router(config)# bfd
RP/0/RSP0/CPU0:router(config-bfd)# interface gigabitethernet 0/1/0/0
RP/0/RSP0/CPU0:router(config-bfd-if)# ipv6 checksum disable

Cisco IOS および Cisco IOS XR ソフトウェアを実行しているルータの BFD ピア:例

次に、Cisco IOS ソフトウェアを実行しているルータ 1 のルータ インターフェイスで BFD を設定し、 bfd neighbor コマンドを使用してインターフェイスの IP アドレス 192.0.2.1 をルータ 2 の BFD ピアとして指定する例を示します。ルータ 2 は、Cisco IOS XR ソフトウェアを実行していて、 router static コマンドおよび address-family ipv4 unicast コマンドを使用して、IP アドレス 192.0.2.2 でルータ 1 のインターフェイスに戻るパスを指定します。

ルータ 1(Cisco IOS ソフトウェア)

Router# configure
Router(config)# interface GigabitEthernet8/1/0
Router(config-if)# description to-TestBed1 G0/0/0/0
Router(config-if)# ip address 192.0.2.2 255.255.255.0
Router(config-if)# bfd interval 100 min_rx 100 multiplier 3
Router(config-if)# bfd neighbor 192.0.2.1

ルータ 2(Cisco IOS XR ソフトウェア)

RP/0/RSP0/CPU0:router# configure
RP/0/RSP0/CPU0:router(config)# router static
RP/0/RSP0/CPU0:router(config-static)# address-family ipv4 unicast
RP/0/RSP0/CPU0:router(config-static-afi)# 10.10.10.10/32 192.0.2.2 bfd fast-detect
RP/0/RSP0/CPU0:router(config-static-afi)# exit
RP/0/RSP0/CPU0:router(config-static)# exit
RP/0/RSP0/CPU0:router(config)# interface GigabitEthernet0/0/0/0
RP/0/RSP0/CPU0:router(config-if)# ipv4 address 192.0.2.1 255.255.255.0

関連情報

BFD は、複数のプラットフォームでサポートされます。これらのコマンドの詳細については、プラットフォームに対応する『 Cisco IOS XR Routing Command Reference 』および『 Cisco IOS XR MPLS Command Reference 』の関連の章を次で参照してください。

http://www.cisco.com/en/US/products/ps5845/prod_command_reference_list.html

『BGP Commands on Cisco IOS XR Software』

『IS-IS Commands on Cisco IOS XR Software』

『OSPF Commands on Cisco IOS XR Software』

『Static Routing Commands on Cisco IOS XR Software』

『MPLS Traffic Engineering Commands on Cisco IOS XR Software』

その他の関連資料

次の各項では、Cisco IOS XR ソフトウェアでの BFD の実装に関する参考資料について説明します。

関連資料

関連項目
参照先

BFD コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト、使用上のガイドライン、例

Cisco IOS XR Interface and Hardware Command Reference

QoS パケット分類の設定

『Cisco ASR 9000 Series Aggregation Services Router Modular Quality of Service Configuration Guide』

標準

標準
タイトル

この機能によってサポートされる新しい標準または変更された標準はありません。またこの機能による既存標準のサポートに変更はありません。

--

RFC

RFC
タイトル

draft-ietf-bfd-base-06

Bidirectional Forwarding Detection 』2007 年 3 月

draft-ietf-bfd-v4v6-1hop-06

BFD for IPv4 and IPv6 (Single Hop) 』2007 年 3 月

MIB

MIB
MIB のリンク

--

Cisco IOS XR ソフトウェアを使用して MIB を検索およびダウンロードするには、 http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml の URL にある Cisco MIB Locator を使用し、[Cisco Access Products] メニューからプラットフォームを選択します。

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトには、数千ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/en/US/support/index.html