Cisco ASR 9000 シリーズ アグリゲーション サービス ルータ L2VPN およびイーサネット サービス コンフィギュレーション ガイド
ポイントツーポイント レイヤ 2 サービスの実装
ポイントツーポイント レイヤ 2 サービスの実装
発行日;2012/05/04 | 英語版ドキュメント(2011/09/02 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

ポイントツーポイント レイヤ 2 サービスの実装

内容

ポイントツーポイント レイヤ 2 サービス実装の前提条件

ポイントツーポイント レイヤ 2 サービスの実装に関する情報

レイヤ 2 バーチャル プライベート ネットワークの概要

レイヤ 2 ローカル スイッチングの概要

L2VPN での ATMoMPLS の概要

L2VPN での仮想回線接続検証

Ethernet over MPLS

イーサネット ポート モード

VLAN モード

Inter-AS モード

QinQ モード

QinAny モード

Quality of Service

ハイアベイラビリティ

優先トンネル パス

マルチセグメント疑似回線

疑似回線冗長性

疑似回線のロード バランシング

イーサネット ワイヤ サービス

IGMP スヌーピング

IP インターワーキング

Any Transport over MPLS

High-Level Data Link Control over MPLS

PPP over MPLS

Frame Relay over MPLS

ポイントツーポイント レイヤ 2 サービスを実装する方法

L2VPN のインターフェイスまたは接続の設定

ローカル スイッチングの設定

スタティック ポイントツーポイント相互接続の設定

ダイナミック ポイントツーポイント相互接続の設定

Inter-AS の設定

L2VPN Quality of Service の設定

制約事項

ポート モードでの L2VPN Quality of Service ポリシーの設定

VLAN モードでの L2VPN Quality of Service ポリシーの設定

優先トンネル パスの設定

マルチセグメント疑似回線の設定

マルチセグメント疑似回線設定のプロビジョニング

グローバル マルチセグメント疑似回線のディスクリプションのプロビジョニング

相互接続のディスクリプションのプロビジョニング

スイッチング ポイント TLV セキュリティのプロビジョニング

マルチセグメント疑似回線のイネーブル化

フローベースのロード バランシングのイネーブル化

疑似回線クラスのフローベースのロード バランシングのイネーブル化

疑似回線の冗長性の設定

バックアップ疑似回線の設定

ポイントツーポイント疑似回線の冗長性の設定

バックアップ疑似回線への強制的な手動切り替え

マルチキャスト接続の設定

AToM IP インターワーキングの設定

ポイントツーポイント レイヤ 2 サービスの設定例

L2VPN インターフェイスの設定:例

ローカル スイッチングの設定:例

ポイントツーポイント相互接続の設定:例

Inter-AS:例

L2VPN Quality of Service:例

優先パス:例

疑似回線:例

T-PE1 ノードのダイナミック疑似回線の設定:例

S-PE1 ノードのダイナミック疑似回線の設定:例

T-PE2 ノードのダイナミック疑似回線の設定:例

T-PE1 ノードのダイナミック疑似回線と優先パスの設定:例

S-PE1 ノードのダイナミック疑似回線と優先パスの設定:例

T-PE2 ノードのダイナミック疑似回線と優先パスの設定:例

T-PE1 ノードのスタティック疑似回線の設定:例

S-PE1 ノードのスタティック疑似回線の設定:例

T-PE2 ノードのスタティック疑似回線の設定:例

疑似回線ステータスの表示:例

show l2vpn xconnect

show l2vpn xconnect detail

Any Transport over MPLS(AToM)の設定:例

AToM IP インターワーキングの設定:例

その他の参考資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

ポイントツーポイント レイヤ 2 サービスの実装

このモジュールでは、Cisco ASR 9000 シリーズ アグリゲーション サービス ルータのポイントツーポイント レイヤ 2(L2)接続の概念および設定情報を提供します。

次のポイントツーポイント サービスがサポートされます。

ローカル スイッチング:単一の Cisco ASR 9000 シリーズ ルータへのポイントツーポイント内部回線(別名ローカル接続)。

疑似回線:Cisco ASR 9000 シリーズ ルータからの仮想ポイントツーポイント回線。疑似回線は、MPLS 上で実装されます。


) Cisco ASR 9000 シリーズ ルータの MPLS レイヤ 2 VPN の詳細について、およびこのモジュールに記載されているコマンドの説明については、「関連資料」を参照してください。設定作業の実行中に表示される可能性があるその他のコマンドのマニュアルを検索するには、Cisco IOS XR ソフトウェア マスター コマンド インデックスでオンライン検索を行ってください。


Cisco ASR 9000 シリーズ ルータへの MPLS レイヤ 2 VPN の実装に関する機能履歴

 

リリース
変更箇所

リリース 3.7.2

この機能は、Cisco ASR 9000 シリーズ ルータで導入されました。

リリース 3.9.0

スケール拡張機能が導入されました。スケール拡張機能の詳細については、表 4 を参照してください。

リリース 4.0.0

Any Transport over MPLS(AToM)機能のサポートが追加されました。

リリース 4.0.1

次の機能のサポートが追加されました。

疑似回線のロード バランシング

Any Transport over MPLS(AToM)機能

HDLC over MPLS(HDLCoMPLS)

PPP over MPLS(PPPoMPLS)

リリース 4.1.0

Flexible ルータ ID 機能のサポートが追加されました。

ポイントツーポイント レイヤ 2 サービス実装の前提条件

適切なタスク ID を含むタスク グループに関連付けられているユーザ グループに属している必要があります。 このコマンド リファレンスには、各コマンドに必要なタスク ID が含まれます。

ユーザ グループの割り当てが原因でコマンドを使用できないと考えられる場合、AAA 管理者に連絡してください。

ポイントツーポイント レイヤ 2 サービスの実装に関する情報

ポイントツーポイント レイヤ 2 サービスを実装するには、次の概念を理解する必要があります。

「レイヤ 2 バーチャル プライベート ネットワークの概要」

「L2VPN での ATMoMPLS の概要」

「L2VPN での仮想回線接続検証」

「Ethernet over MPLS」

「Quality of Service」

「ハイアベイラビリティ」

「優先トンネル パス」

「マルチセグメント疑似回線」

「疑似回線冗長性」

「Any Transport over MPLS」

レイヤ 2 バーチャル プライベート ネットワークの概要

レイヤ 2 バーチャル プライベート ネットワーク(L2VPN)は、IP または MPLS 対応の L2 スイッチド IP ネットワークで LAN の動作をエミュレートすることで、イーサネット デバイス同士が共通の LAN セグメントに接続した場合と同様に通信できるようにします。ポイントツーポイント L2 接続は、L2VPN を作成する場合に重要です。

インターネット サービス プロバイダー(ISP)が、フレーム リレーまたは非同期転送モード(ATM)インフラストラクチャを IP インフラストラクチャに置き換える場合、IP または MPLS 対応の L2 スイッチド IP インフラストラクチャを使用する標準的な方法を提供する必要があります。これらの方法は、カスタマーに実用的な L2 インターフェイスを提供し、具体的には、カスタマー サイトのペア間の仮想回線を提供します。

L2VPN システムを構築するには、ISP とカスタマーの間での調整が必要です。ISP は L2 接続を提供し、カスタマーは ISP から取得したデータ リンク リソースを使用してネットワークを構築します。L2VPN サービスでは、ISP は、カスタマーのネットワーク トポロジ、ポリシー、ルーティング情報、ポイントツーポイント リンクに関する情報や、他の ISP からのネットワーク ポイントツーポイント リンク関する情報を必要としません。

ISP には、次の機能を備えたプロバイダー エッジ(PE)ルータが必要です。

レイヤ 3(L3)パケット内への L2 プロトコル データ ユニット(PDU)のカプセル化。

any-to-any L2 転送のインターコネクト。

パケット スイッチ ネットワーク上での L2 Quality-of-Service(QoS)のエミュレーション。

L2 サービスの設定の簡素化。

各種のトンネリング メカニズム(MPLS、IPSec、GRE など)のサポート。

L2VPN プロセス データベースには、回線および接続に関するすべての情報が含まれます。

レイヤ 2 ローカル スイッチングの概要

ローカル スイッチングにより、同じルータ上の同じタイプの 2 つのインターフェイス間で L2 データを切り替えることができます(たとえば、イーサネットからイーサネット)。インターフェイスは、同じラインカード上にあっても、2 つの異なるラインカード上にあってもかまいません。これらのタイプのスイッチング中、レイヤ 2 アドレスが、レイヤ 3 アドレスの代わりに使用されます。ローカル スイッチング接続は、一方の接続回線(AC)から他方の接続回線に L2 トラフィックを切り替えます。ローカル スイッチング接続で設定される 2 つのポートは、そのローカル接続に関連する AC です。ローカル スイッチング接続の動作は、2 つのブリッジ ポートしかないブリッジ ドメインの動作と類似しており、トラフィックはローカル接続の一方のポートに入り、他方のポートから出ます。ただし、ローカル接続に関するブリッジングがないため、MAC 学習やフラッディングはありません。また、インターフェイスの状態が DOWN の場合、ローカル接続の AC は UP 状態ではありません (この動作は、ブリッジ ドメインの動作に準拠したときにも異なります)。

ローカル スイッチング AC は、L2 トランク(メイン)インターフェイス、バンドル インターフェイス、EFP など、多種多様な L2 インターフェイスを使用します。

また、同一ポートのローカル スイッチング機能を使用すると、同じインターフェイス上の 2 つの回線の間でレイヤ 2 データをスイッチングできます。

L2VPN での ATMoMPLS の概要

ATMoMPLS は、MPLS コア上でのレイヤ 2 ポイントツーポイント接続の一種です。

ATMoMPLS 機能を実装する場合、Cisco ASR 9000 シリーズ ルータは、カスタマー エッジ(CE)デバイスが Cisco ASR 9000 シリーズ ルータに接続されているプロバイダー ネットワークのエッジでプロバイダー エッジ(PE)ルータの役割を担います。

L2VPN での仮想回線接続検証

仮想回線接続性検証(VCCV)は、L2VPN の運用、管理、およびメンテナンス(OAM)機能であり、ネットワーク オペレータが、指定した疑似回線上で IP ベースのプロバイダー エッジ間(PE-to-PE)キープアライブ プロトコルを実行できるようにし、疑似回線データ パス転送で障害が発生しないようにします。ディスポジション PE は、指定した疑似回線に関連付けられる制御チャネルで VCCV パケットを受信します。疑似回線が各方向の PE 間で確立されると、VCCV に使用される制御チャネル タイプと接続検証タイプがネゴシエートされます。

次の 2 種類のパケットが、ディスポジション出力に到達できます。

タイプ 1:通常の Ethernet-over-MPLS(EoMPLS)データ パケットを指定します。

タイプ 2:VCCV パケットを指定します。

Cisco ASR 9000 シリーズ ルータ は、シグナリング中にイネーブルにされた場合にインバンド制御ワードを使用する、ラベル スイッチド パス(LSP)VCCV タイプ 1 をサポートしています。IPv4 では、VCCV エコー応答は、応答モードである IPv4 として送信されます。応答は IP、MPLS、またはその両方の組み合わせとして転送されます。

出力側の MPLS 転送では、VCCV pings カウンタがカウントされます。ただし、入力側では、これらはルート プロセッサから発信され、MPLS 転送カウンタとしてカウントされません。

Ethernet over MPLS

Ethernet-over-MPLS(EoMPLS)は、MPLS 対応 L3 コアを通じてイーサネット トラフィックのトンネリング メカニズムを提供し、(ラベル スタックを使用して)イーサネット プロトコル データ ユニット(PDU)を MPLS パケット内部にカプセル化して、それらを MPLS ネットワーク経由で転送します。

EoMPLS 機能は、次のサブセクションで説明します。

「イーサネット ポート モード」

「VLAN モード」

「Inter-AS モード」

「QinQ モード」

「QinAny モード」

イーサネット ポート モード

イーサネット ポート モードでは、イーサネット ポートが、疑似回線の両端がイーサネット ポートに接続されます。このモードでは、ポートは疑似回線でトンネリングされるか、同じ PE ノードに接続されている一方の接続回線(AC)から他方の AC にパケットまたはフレームをスイッチするローカル スイッチング(別名、 接続回線間相互接続 )を使用してトンネリングされます。

図 1 に、イーサネット ポート モードの例を示します。

図 1 イーサネット ポート モードのパケット フロー

 

VLAN モード

VLAN モードでは、カスタマー側とプロバイダー側のリンクで、各 VLAN は、仮想接続(VC)タイプ 4 または VC タイプ 5 を使用して個別 L2VPN 接続として設定できます。VC タイプ 5 がデフォルト モードです。

図 2に示されているように、イーサネット PE は、入力ポートから疑似回線にトラフィックを内部的に切り替えるために、イーサネット ポートに内部 VLAN タグを関連付けます。ただし、疑似回線にトラフィックを移動する前に、内部 VLAN タグを削除します。

図 2 VLAN モードのパケット フロー

 

出力 VLAN PE では、PE は、疑似回線から到着するフレームに VLAN タグを関連付け、トラフィックを内部的に切り替えた後、イーサネット トランク ポートにトラフィックを送信します。


) ポートがトランク モードであるため、VLAN PE は VLAN タグを削除せず、追加されたタグを持つポート経由でフレームを転送します。


Inter-AS モード

Inter-AS は、複数のプロバイダーまたはマルチドメイン ネットワークを通じて VPN を拡張できるピアツーピア タイプ モデルです。これにより、サービス プロバイダーは相互にピアアップでき、地理的に離れた位置でエンドツーエンドの VPN 接続が実現します。

EoMPLS サポートでは、単一 AS トポロジを想定でき、このトポロジでは、ポイントツーポイント EoMPLS 相互接続の 2 つの終端にある PE ルータを接続する疑似回線が、同一自律システムに存在します。または、複数の AS トポロジを想定でき、このトポロジでは、PE ルータが iBGP および eBGP ピアリングを使用して 2 つの異なる AS に存在できます。

図 3 は、各 AS で iBGP/LDP が使用される、基本的なデュアル AS のトポロジの Inter-AS に MPLS を表しています。

図 3 EoMPLS over Inter-AS:基本的なデュアル AS トポロジ

 

QinQ モード

QinQ は、複数の 802.1Q タグ(IEEE 802.1QinQ VLAN タグ スタッキング)を指定するための 802.1Q の拡張です。レイヤ 3 VPN サービス終了および L2VPN サービス転送は、QinQ サブインターフェイスではイネーブルです。

Cisco ASR 9000 シリーズ ルータは、プロバイダー エッジ ルータでのサブインターフェイスの設定に基づき、レイヤ 2 トンネリングまたはレイヤ 3 転送を実装します。この機能は、SPA および固定 PLIM で最大 2 つの QinQ タグのみサポートします。

L2VPN 接続回線のレイヤ 2 QinQ VLAN:QinQ L2VPN 接続回線は、仮想回線タイプ 4 とタイプ 5 の両方の疑似回線を使用して、ポイントツーポイント EoMPLS ベース相互接続用のレイヤ 2 転送サブインターフェイスで設定されます。また、802.1q VLAN およびポート モードでの QinQ の完全なインターワーキングのサポートなど、ポイントツーポイント ローカル スイッチングベース相互接続用のレイヤ 2 転送サブインターフェイスで設定されます。

レイヤ 3 QinQ VLAN:レイヤ 3 の終端ポイントとして使用されます。VLAN はいずれも入力プロバイダー エッジで削除され、フレームが転送されるときリモート プロバイダー エッジで追加され戻されます。

QinQ 上のレイヤ 3 サービスは次のとおりです。

IPv4 ユニキャストおよびマルチキャスト

IPv6 ユニキャストおよびマルチキャスト

MPLS

Intermediate System-to-Intermediate System(IS-IS)で使用されるコネクションレス型ネットワーク サービス(CLNS)

QinQ モードでは、各 CE VLAN は SP VLAN 内に伝送されます。QinQ モードでは VC タイプ 5 を使用する必要がありますが、VC タイプ 4 もサポートされます。各イーサネット PE では、内部(CE VLAN)と外部(SP VLAN)の両方を設定する必要があります。

図 4 は、VC タイプ 4 を使用する Q-in-Q を表しています。

図 4 EoMPLS over QinQ モード

 

QinAny モード

QinAny モードでは、サービス プロバイダー VLAN タグは、プロバイダー エッジ VLAN の入力ノードと出力ノードの両方で設定されます。カスタマー エッジ VLAN タグが不明なため、カスタマー エッジ VLAN タグが疑似回線上のパケットで送信されることを除き、QinAny モードはタイプ 5 VC を使用する Q-in-Q モードに似ています。

Quality of Service

L2VPN テクノロジーを使用して、ポートおよび VLAN の動作モードの両方に Quality of Service(QoS)レベルを割り当てることができます。

L2VPN テクノロジーでは、PE ルータの QoS 機能が、エッジ方向のインターフェイス(別名、 接続回線 )で L2 ペイロードベースである必要があります。図 5 は、一般的な L2VPN ネットワークでの L2 および L3 QoS サービス ポリシーを表しています。

図 5 L2VPN QoS 機能の適用

 

図 6 は、QoS サービス ポリシーを設定できるプロバイダー エッジ デバイス内の 4 つのパケット処理パスを表しています。L2VPN ネットワークでは、パケットはエッジ方向のインターフェイスで L2 パケットとして送受信され、コア方向のインターフェイスで MPLS(EoMPLS)パケットとして転送されます。

図 6 L2VPN QoS リファレンス モデル

 

ハイアベイラビリティ

L2VPN は、ルート プロセッサとラインカードの両方でコントロール プレーンを使用し、ラインカードでフォワーディング プレーン要素を使用します。

L2VPN の可用性は次の要件を満たします。

ルート プロセッサまたはラインカードでのコントロール プレーンの障害は、回線の転送パスには影響しません。

ルータ プロセッサのコントロール プレーンは、ラインカードの制御およびフォワーディング プレーンに影響を与えずに、フェールオーバーをサポートします。

L2VPN は既存のラベル配布プロトコル(LDP)のグレースフル リスタート メカニズムと統合されます。

優先トンネル パス

優先トンネル パスの機能により、特定のトラフィック エンジニアリング トンネルに疑似回線をマッピングできます。接続回線は、リモート PE ルータの IP アドレス(IGP または LDP を使用して到達可能)ではなく、特定の MPLS トラフィック エンジニアリング トンネル インターフェイスに相互接続されます。優先トンネル パスを使用する場合、L2 トラフィックを転送するトラフィック エンジニアリング トンネルが 2 台の PE ルータ間で動作することが常に想定されます(つまり、始端はインポジション PE ルータで、終端はディスポジション PE ルータです)。


) • 現在、優先トンネル パス設定は MPLS カプセル化だけに適用されます。


 

マルチセグメント疑似回線

疑似回線は Public Switched Network(PSN)上でレイヤ 2 プロトコル データ ユニット(PDU)を転送します。マルチセグメント疑似回線は、静的または動的に設定された、複数の隣接する疑似回線セグメントのセットです。これらのセグメントは単一の疑似回線として機能し、以下を実行できます。

管理ドメインまたはプロビジョニング ドメインを隔離することで、エンドツーエンド サービスを管理する。

相互自律システム(Inter-AS)の境界を越えて、プロバイダー エッジ(PE)ノードの IP アドレスをプライベートにする。自律システム境界ルータ(ASBR)の IP アドレスを使用し、それらのルータを疑似回線の集約ルータとして扱う。ASBR は、2 つのドメインの疑似回線を結合します。

マルチセグメント疑似回線は、Inter-AS 境界または 2 つのマルチプロトコル ラベル スイッチング(MPLS)ネットワークにまたがることができます。

疑似回線は、2 台の PE ノード間のトンネルです。2 種類の PE ノードがあります。

スイッチング PE(S-PE)ノード

マルチセグメント疑似回線の先行する疑似回線セグメントと後続の疑似回線セグメントの PSN トンネルを終端させます。

マルチセグメント疑似回線の先行する疑似回線セグメントと後続の疑似回線セグメントのコントロール プレーンとデータ プレーンを切り替えます。

終端 PE(T-PE)ノード

マルチセグメント疑似回線の最初と最後の両方のセグメントに配置されます。

このノードで、カスタマー方向の接続回線(AC)が疑似回線フォワーダにバインドされます。

疑似回線冗長性

疑似回線の冗長性を使用すると、ネットワーク内の障害を検出して、サービスの提供を続行可能な別のエンドポイントにレイヤ 2 サービスを再ルーティングするようにネットワークを設定できます。この機能により、リモート PE ルータで発生した障害、または PE ルータと CE ルータ間のリンクで発生した障害から回復できます。

L2VPN は、ルーティング プロトコルを通じて疑似回線冗長化機能を提供します。エンドツーエンド PE ルータ間の接続が障害になった場合、指示された LDP セッションとユーザ データの代替パスに引き継ぐことができます。ただし、ネットワークの一部は、この再ルーティング メカニズムでサービスの中断から保護されません。

疑似回線の冗長性を使用すると、バックアップ疑似回線を設定できます。ネットワークに冗長疑似回線と冗長ネットワーク エレメントを設定することもできます。

プライマリ疑似回線の障害前に、バックアップ疑似回線にトラフィックをスイッチングする機能が使用され、ルータのメンテナンスなどの計画された疑似回線の停止が処理されます。


) 疑似回線の冗長性は、ポイントツーポイント Virtual Private Wire Service(VPWS)疑似回線に対してのみ提供されます。


疑似回線のロード バランシング

冗長性を維持しつつ、ネットワークを最大限利用するには、通常、複数のリンクでのトラフィックのロード バランシングが必要です。精度の高い、より均等な分散を実現するには、プロビジョニングされたパイプの一部であるトラフィック フローのロード バランシングが理想的です。ロード バランシングは、IP アドレス、Mac アドレス、またはそれらの組み合わせに従い、フローベースにすることができます。またロード バランシングは、送信元または宛先の IP アドレス、あるいは送信元または宛先の MAC アドレスに従い、フローベースにすることができます。IP ヘッダーの処理に進むことができない場合、または IPv6 がフローベースの場合、トラフィックはデフォルトのフローベース MAC アドレスにフォールバックします。

この機能は、L2VPN 下の疑似回線に適用されます。これには、VPWS と VPLS の両方が含まれます。


) 疑似回線クラスに対し仮想回線(VC)ラベル ベースのロード バランシングをイネーブルにすると、L2VPN 下のグローバル フロー ベースのロード バランシングが上書きされます。


イーサネット ワイヤ サービス

イーサネット ワイヤ サービスは、ポイントツーポイントのイーサネット セグメントをエミュレートするサービスです。これは、プロバイダー エッジがレイヤ 2 で動作し、通常レイヤ 2 ネットワークで実行される以外、イーサネット専用回線(EPL)、レイヤ 1 ポイントツーポイント サービスに似ています。EWS は特定の UNI で受信されたすべてのフレームをカプセル化し、フレームに含まれる内容を参照せずに、これらのフレームを単一出力 UNI に転送します。このサービスの動作は EWS を VLAN タグ付きフレームで使用できることを示します。VLAN タグは、一部の例外を除いて EWS(ブリッジ プロトコル データ ユニット(BPDU))に対して透過的です。これらの例外には、IEEE 802.1x、IEEE 802.2ad、および IEEE 802.3x が含まれます。これは、これらのフレームがローカルで意味を持ち、カスタマーとサービス プロバイダーの両方がそれらのフレームをローカルで終了できるよう支援されるためです。

カスタマー側には 3 つのタイプがあります。

タグなし

単一タグ付き

二重タグ付き

802.1q

802.1ad

E-Line サービス

E-Line サービスは 2 つの UNI 間のポイントツーポイント EVC を提供します。2 種類の E-Line サービスがあります。

イーサネット専用回線(EPL)

サービス多重化は許可されていません

トランスペアレント

VLAN ID マップでカスタマーと SP 間は調整されません

イーサネット仮想専用回線(EVPL)

サービス多重化が許可されています

サービス フレームの完全な透過性は必要ありません

イーサネット LAN(E-LAN)サービス

E-LAN サービスはマルチポイント接続を提供します(2 つ以上の UNI を接続できます)。すべてのサイトでイーサネットが相互接続されます(クラウド内にマルチポイントツーマルチポイント EVC があります)。

E-LAN サービスのタイプ

透過型 LAN サービス(TLS)

バンドルされたサービス

Ethernet Virtual Connection Service(EVCS)

Per-VLAN サービス多重化サービス

Cisco イーサネット リレー サービスの概念は MEF イーサネット仮想専用回線(EVPL)の概念に対応します。Cisco イーサネット ワイヤ サービスの概念は MEF イーサネット専用回線の概念に対応します。Cisco マルチポイント サービスの概念は MEF 透過型 LAN サービスの概念に対応します。Cisco マルチポイント リレー サービスの概念は MEF Ethernet Virtual Connection Service の概念に対応します。UNI は、CE とプロバイダー エッジ(PE)間の境界です。

イーサネット サービスは、サービス プロバイダーが UNI 間で提供するサービスです。

イーサネット ライン サービス(E-Line)ポイントツーポイント

イーサネット LAN サービス(E-LAN)マルチポイント

イーサネット ツリー サービス(E-Tree)ポイントツーマルチポイント

これは、キャリア イーサネットです。これにより、高速化(GigE および 10GigE)などの利点のあるクラウド内のフレーム リレー/ATM を置き換えることができます。VPLS(バーチャル プライベート LAN サービス)は、MPLS ネットワークでマルチポイント イーサネット サービスを提供できるエンドツーエンド アーキテクチャです。このサービスの複数のインスタンスが同じ物理インフラストラクチャを共有するため、「バーチャル」です。サービスの各インスタンスが互いに独立して分離されるため、「プライベート」です。サブスクライバ間でレイヤ 2 のマルチポイント接続をエミュレートするため、「LAN サービス」です。

IGMP スヌーピング

IGMP スヌーピングは、レイヤ 2 でマルチキャスト トラフィックを抑制する方法を提供します。IGMP スヌーピング アプリケーションは、ブリッジ ドメインのホストによって送信された IGMP メンバーシップ レポートをスヌーピングすることで、レイヤ 2 マルチキャスト転送テーブルを設定して、少なくとも 1 つの関係メンバーを持つポートだけにトラフィックを送信できます。これにより、マルチキャスト トラフィックの量が大幅に削減されます。

IGMP は、レイヤ 3 で設定され、IPv4 マルチキャスト ネットワークのホストが、どのマルチキャスト トラフィックを対象とするか示すための手段を提供し、また、ルータがネットワーク(レイヤ 3)内のマルチキャスト トラフィックのフローを制御および制限するための手段を提供します。

IGMP スヌーピングは、レイヤ 2 の IP マルチキャスト トラフィックを制限するための、IGMP メンバーシップ レポート メッセージの情報を使用して、転送テーブルに対応する情報を構築します。転送テーブルのエントリは <ルート, OIF リスト> という形式です。

ルートは <*, G> ルートまたは <S, G> ルートです。

OIF リストは、指定されたルートと、ブリッジ ドメイン内のすべてのマルチキャスト ルータ(mrouter)ポートに関する IGMP メンバーシップ レポートを送信したすべてのブリッジ ポートで構成されます。

IGMP スヌーピング機能により、マルチキャスト ネットワークで次の利点が得られます。

基本的な IGMP スヌーピングは、VPLS ブリッジ ドメイン全体をフラッディングするマルチキャスト トラフィックを削減することで、帯域幅の使用量を減らします。

オプションの設定オプションを使用すると、IGMP スヌーピングは、1 つのブリッジ ポートでホストから受信された IGMP レポートをフィルタリングし、他のブリッジ ポートでホストへの漏出を防止することで、ブリッジ ドメイン間のセキュリティを確保できます。

オプションの設定オプションを使用すると、IGMP スヌーピングは、IGMP メンバーシップ レポート(IGMPv2)を抑制することで、またはアップストリーム IP マルチキャスト ルータへの IGMP プロキシ レポーター(IGMPv3)として動作することで、アップストリーム IP マルチキャスト ルータへのトラフィックの影響を低減できます。

IGMP スヌーピングの設定方法については、『 Cisco ASR 9000 Series Aggregation Services Router Multicast Configuration Guide 』の「 Implementing Layer 2 Multicast with IGMP Snooping 」モジュールを参照してください。

適用できる IGMP スヌーピング コマンドは『 Cisco ASR 9000 Series Aggregation Services Router Multicast Command Reference 』で説明します。

IP インターワーキング

カスタマー環境では、ソリューションによりネットワーク終端で異種転送を使用する AToM をサポートする必要があります。このソリューションには、1 つのカスタマー エッジ(CE)デバイスの転送を別の転送に変換する機能(たとえば、フレーム リレーからイーサネットなど)が必要です。Cisco ASR 9000 シリーズ SPA インターフェイス プロセッサ 700 および Cisco ASR 9000 シリーズ イーサネット ラインカードにより、Cisco ASR 9000 シリーズ ルータで複数のレガシー サービスをサポートできます。

IP インターワーキングは、IP/MPLS バックボーン上でレイヤ 2 トラフィックを転送するためのソリューションです。IP インターワーキングは、AToM トンネルを使用するイーサネット、フレーム リレーなど、多くのタイプのレイヤ 2 フレームに対応します。IP インターワーキングは、プロバイダー エッジ(PE)ルータでパケットをカプセル化し、それらをバックボーンを介してクラウドの反対側の PE ルータに転送し、カプセル化を削除し、それらを宛先に転送します。トランスポート層では、一方の側でイーサネットを使用し、もう一方の側でフレーム リレーを使用できます。IP インターワーキングは、AToM トンネルの異種エンドポイント間で実行されます。


) MPLS とローカル接続のシナリオでは、イーサネットとフレーム リレー ベースのネットワーク間でルーテッド インターワーキングのみサポートされます。


図 7 は、イーサネット接続 VC とフレーム リレー接続 VC 間の相互運用性を表しています。

図 7 IP インターワーキング over MPLS コア

 

接続回線は(AC)は、CE デバイスを PE デバイスに接続する物理的または論理的なポートまたは回線です。疑似回線(PW)は、2 つの AC を接続する双方向仮想接続(VC)です。MPLS ネットワークでは、PW は LSP トンネル内で伝送されます。PE1 および PE2 のコア方向のラインカードとして、Cisco ASR 9000 シリーズ SPA インターフェイス プロセッサ 700 または Cisco ASR 9000 シリーズ イーサネット ラインカードが使用可能です。

IP インターワーキング モードでは、入力 PE で受信されたパケットからレイヤ 2(L2)ヘッダーが削除され、IP ペイロードだけが出力 PE に送信されます。出力 PE では、パケットが出力ポートから送信される前に、L2 ヘッダーが付加されます。

図 7 では、CE1 および CE2 を、フレーム リレー(FR)インターフェイスまたはギガビット イーサネット(GigE)インターフェイスにすることができます。CE1 が FR で、CE2 が GigE または dot1q、あるいは QinQ であるとします。イーサネット CE(CE2)から着信するパケットの場合、CE 方向の PE(PE2)の入力 LC は、L2 フレーミングを削除し、そのパケットを、疑似回線上で IPoMPLS カプセル化を使用して出力 PE(PE1)に転送します。出力 PE のコア方向のラインカードは、MPLS ラベルを削除しますが、制御ワードを保持し、それを FR CE(CE1)方向の出力ライン カードに伝送します。FR PE では、ラベル ディスポジション後、レイヤ 3(L3)パケットは FR 上でカプセル化されます。

同様に、FR CE から着信した IP パケットは疑似回線上で IPoMPLS カプセル化に変換されます。コアから着信するパケットは IP ペイロードのみを伝送するため、イーサネット PE 側では、ラベル ディスポジション後、PE は、パケットを CE に伝送する前に、そのパケットに L2 イーサネット パケット ヘッダーを追加して戻します。

これらのモードは、AToM で IP インターワーキングをサポートします。

イーサネットとフレーム リレー

イーサネット CE デバイスから着信するパケットには、MAC(ポート モード、タグなし、シングル タグ、ダブル タグ)、IPv4 ヘッダー、およびデータが含まれます。イーサネット ラインカードは L2 フレーミングを削除し、その後、出力ラインカードに L3 パケットを転送します。出力ラインカードは、出力ポートからパケットを送信する前に、FR L2 ヘッダーを追加します。

イーサネットとイーサネット

CE デバイスは両方ともイーサネットです。各イーサネット インターフェイスは、ポート モード、タグなし、シングル タグ、またはダブル タグにすることができます。ただし、これは IP インターワーキングの一般的なシナリオではありません。

Any Transport over MPLS

Any Transport over MPLS(AToM)は、マルチプロトコル ラベル スイッチング(MPLS)バックボーン上でレイヤ 2 パケットを転送します。これにより、サービス プロバイダーは、単一の統合されたパケット ベース ネットワーク インフラストラクチャを使用することで、既存のレイヤ 2 ネットワークとカスタマー サイトを接続できます。この機能を使用すると、サービス プロバイダーは、別々のネットワークを使用する代わりに、MPLS バックボーン上でレイヤ 2 接続を提供できます。

AToM は、入力 PE ルータでレイヤ 2 フレームをカプセル化し、2 つの PE ルータ間を接続する疑似回線の反対側に位置する対応した PE ルータにそれらを送信します。出力 PE はカプセル化を削除し、レイヤ 2 フレームを送信します。

PE ルータ間でレイヤ 2 フレームを正常に転送するには、PE ルータを設定する必要があります。ルータ間で、疑似回線と呼ばれる接続を設定します。各 PE ルータで次の情報を指定します。

イーサネット、フレーム リレーなどの疑似回線で転送されるレイヤ 2 データのタイプ。

PE ルータが通信できる、ピア PE ルータのループバック インターフェイスの IP アドレス

疑似回線を識別するピア PE の IP アドレスと VC ID の一意の組み合せ

High-Level Data Link Control over MPLS

接続回線(AC)は、HDLC カプセル化が設定されたメイン インターフェイスです。AC との間のパケットは、MPLS コア ネットワーク上の他のプロバイダー エッジ(PE)との間の、VC タイプ 0x6 の疑似回線(PW)を使用して転送されます。

HDLC over MPLS では、HDLC パケット全体が転送されます。入力 PE ルータは、HDLC フラグおよび FCS ビットだけを削除します。

PPP over MPLS

接続回線(AC)は、PPP カプセル化が設定されたメイン インターフェイスです。AC との間のパケットは、MPLS コア ネットワーク上の他のプロバイダー エッジ(PE)との間の、VC タイプ 0x7 の AToM PW を使用して転送されます。

PPP over MPLS の場合、入力 PE ルータはフラグ、アドレス、制御フィールド、および FCS ビットを削除します。

Frame Relay over MPLS

Frame Relay over MPLS(FRoMPLS)は、2 つのフレーム リレー アイランド間の専用回線タイプの接続を提供します。フレーム リレー トラフィックは MPLS ネットワーク上で転送されます。


) データリンク接続識別子(DLCI)の DCLI-DLCI モードがサポートされます。追加の制御情報を伝えるために、制御ワード(DLCI-DLCI モードに必要)が使用されます。


プロバイダー エッジ(PE)ルータは、加入者サイトからフレーム リレー プロトコル パケットを受信すると、フレーム リレー ヘッダーおよびフレーム チェック シーケンス(FCS)を削除し、関連する仮想回線(VC)ラベルを付けます。削除された逆方向明示的輻輳通知(BECN)、順方向明示的輻輳通知(FECN)、廃棄適性(DE)、およびコマンド/応答(C/R)ビットが制御ワードを使用して個別に送信されます(DLCI-DLCI モードの場合)。

ポイントツーポイント レイヤ 2 サービスを実装する方法

ここでは、L2VPN を実装するために必要なタスクについて説明します。

「L2VPN のインターフェイスまたは接続の設定」

「ローカル スイッチングの設定」

「スタティック ポイントツーポイント相互接続の設定」

「ダイナミック ポイントツーポイント相互接続の設定」

「Inter-AS の設定」

「L2VPN Quality of Service の設定」

「優先トンネル パスの設定」

「マルチセグメント疑似回線の設定」

「フローベースのロード バランシングのイネーブル化」

「疑似回線クラスのフローベースのロード バランシングのイネーブル化」

「疑似回線の冗長性の設定」

「マルチキャスト接続の設定」

「AToM IP インターワーキングの設定」

L2VPN のインターフェイスまたは接続の設定

L2VPN のインターフェイスまたは接続を設定するには、次の作業を実行します。

手順の概要

1. configure

2. interface type interface-path-id

3. l2transport

4. exit

5. interface type interface-path-id

6. end
または
commit

7. show interface type interface-id

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config)# interface GigabitEthernet 0/0/0/0

インターフェイス コンフィギュレーション モードを開始し、インターフェイスを設定します。

ステップ 3

l2transport

 

RP/0/RSP0/CPU0:router(config-if)# l2transport

選択したインターフェイスで L2 転送をイネーブルにします。

ステップ 4

exit

 

RP/0/RSP0/CPU0:router(config-if-l2)# exit

現在のコンフィギュレーション モードを終了します。

ステップ 5

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config)# interface GigabitEthernet0/0/0/0

インターフェイス コンフィギュレーション モードを開始し、インターフェイスを設定します。

ステップ 6

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 7

show interface type interface-id

 

RP/0/RSP0/CPU0:router# show interface gigabitethernet 0/0/0/0

(任意)コミットしたインターフェイスの設定を表示します。

ローカル スイッチングの設定

手順の概要

1. configure

2. l2vpn

3. xconnect group group-name

4. p2p xconnect-name

5. interface type interface-path-id

6. interface type interface-path-id

7. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

xconnect group group-name

 

RP/0/RSP0/CPU0:router(config-l2vpn)# xconnect group grp_1

相互接続グループの名前を入力します。

ステップ 4

p2p xconnect-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc)# p2p vlan1

ポイントツーポイント相互接続の名前を入力します。

ステップ 5

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# interface TenGigE 0/7/0/6.5

インターフェイス タイプ ID を指定します。次の選択項目があります。

GigabitEthernet:ギガビット イーサネット/IEEE 802.3 インターフェイス。

TenGigE:TDR イーサネット/IEEE 802.3 インターフェイス。

ステップ 6

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# interface GigabitEthernet0/4/0/30

インターフェイス タイプ ID を指定します。次の選択項目があります。

GigabitEthernet:ギガビット イーサネット/IEEE 802.3 インターフェイス。

TenGigE:TDR イーサネット/IEEE 802.3 インターフェイス。

ステップ 7

end

または

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# end

または

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

スタティック ポイントツーポイント相互接続の設定

スタティック ポイントツーポイント相互接続を設定するには、次の作業を実行します。

スタティック ポイントツーポイント相互接続を設定する場合、相互接続に関する次の情報を考慮します。

相互接続はペアにより一意に識別されます。相互接続名は、グループ内で一意である必要があります。

セグメント(接続回線または疑似回線)は一意で、1 つの相互接続だけに属することができます。

スタティック VC のローカル ラベルはグローバルに一意で、1 つの疑似回線だけで使用できます。

1 台のルータにつき 16,000 以下の相互接続を設定できます。


) スタティック疑似回線接続はシグナリングに LDP を使用しません。


手順の概要

1. configure

2. l2vpn

3. xconnect group group-name

4. p2p xconnect-name

5. interface type interface-path-id

6. neighbor A.B.C.D pw-id pseudowire-id

7. mpls static label local { value } remote { value }

8. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

xconnect group group-name

 

RP/0/RSP0/CPU0:router(config-l2vpn)# xconnect group grp_1

相互接続グループの名前を入力します。

ステップ 4

p2p xconnect-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc)# p2p vlan1

ポイントツーポイント相互接続の名前を入力します。

ステップ 5

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# interface gigabitethernet 0/1/0/9

インターフェイス タイプとインスタンスを指定します。

ステップ 6

neighbor A.B.C.D pw-id pseudowire-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# neighbor 10.2.2.2 pw-id 2000

相互接続の疑似回線セグメントを設定します。

相互接続ピアの IP アドレスを指定するには、A.B.C.D 引数を使用します。

(注) A.B.C.D は再帰的または非再帰的プレフィクスです。

オプションで、制御ワードをディセーブルにすることや、イーサネットまたは VLAN への転送タイプを設定することができます。

ステップ 7

mpls static label local { value } remote { value }

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# mpls static label local 699 remote 890

ローカルおよびリモート ラベル ID 値を設定します。

ステップ 8

end

または

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# end

または

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ダイナミック ポイントツーポイント相互接続の設定

ダイナミック ポイントツーポイント相互接続を設定するには、次の作業を実行します。


) ダイナミック相互接続では、LDP が稼働中である必要があります。


手順の概要

1. configure

2. l2vpn

3. xconnect group group-name

4. p2p xconnect-name

5. interface type interface-path-id

6. neighbor A.B.C.D pw-id pseudowire-id

7. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

xconnect group group-name

 

RP/0/RSP0/CPU0:router(config-l2vpn)# xconnect group grp_1

相互接続グループの名前を入力します。

ステップ 4

p2p xconnect-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc)# p2p vlan1

ポイントツーポイント相互接続の名前を入力します。

ステップ 5

interface type interface-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# interface GigabitEthernet0/0/0/0.1

インターフェイス タイプ ID を指定します。次の選択項目があります。

GigabitEthernet:GigabitEthernet/IEEE 802.3 インターフェイス。

TenGigE:TenGigabitEthernet/IEEE 802.3 インターフェイス。

ステップ 6

neighbor A.B.C.D pw-id pseudowire-id

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# neighbor 10.2.2.2 pw-id 2000

相互接続の疑似回線セグメントを設定します。

オプションで、制御ワードをディセーブルにすることや、イーサネットまたは VLAN への転送タイプを設定することができます。

ステップ 7

end

または

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# end

または

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

Inter-AS の設定

Inter-AS の設定手順は、L2VPN 相互接続の設定作業と同じです(「スタティック ポイントツーポイント相互接続の設定」および「ダイナミック ポイントツーポイント相互接続の設定」を参照)。ただし、相互接続設定で使用されるリモート PE の IP アドレスが iBGP ピアリングを通じて到達可能であることを除きます。


) この設定を完了するには、IBGP、EBGP、および ASBR の用語および設定に関する知識が必要です。


L2VPN Quality of Service の設定

ここでは、ポート モードおよび VLAN モードで L2VPN Quality of Service(QoS)を設定する方法について説明します。

制約事項

l2transport コマンドは任意の IP アドレス、L3、または CDP の設定では使用できません。

ポート モードでの L2VPN Quality of Service ポリシーの設定

この手順では、ポート モードでの L2VPN QoS ポリシーの設定方法について説明します。


) ポート モードでは、インターフェイス名の形式に、サブインターフェイス番号が含まれません(たとえば、GigabitEthernet0/1/0/1)。


手順の概要

1. configure

2. interface type interface-path-id

3. l2transport

4. service-policy [ input | output ] [policy-map-name]

5. end
または
commit

6. show qos interface type interface-path-id service-policy [ input | output ] [ policy-map-name ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

コンフィギュレーション モードを開始します。

ステップ 2

interface type interface-path-id

 

RP/0/RSP0/CPU0:router(config)# interface GigabitEthernet0/0/0/0

インターフェイス接続回線を指定します。

ステップ 3

l2transport

 

RP/0/RSP0/CPU0:router(config-if)# l2transport

L2 スイッチングのインターフェイスまたは接続を設定します。

ステップ 4

service-policy [ input | output ] [ policy-map-name ]

 

RP/0/RSP0/CPU0:router(config-if)# service-policy input servpol1

入力インターフェイスまたは出力インターフェイスに、そのインターフェイスのサービス ポリシーとして使用する QoS ポリシーを付加します。

ステップ 5

end

または

commit

 

RP/0/RSP0/CPU0:router(config-if)# end

または

RP/0/RSP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 6

show qos interface type interface-id service-policy [input | output] [policy-map-name]

 

RP/0/RSP0/CPU0:router# show qos interface gigabitethernet 0/0/0/0 input serpol1

(任意)定義した QoS サービス ポリシーを表示します。

VLAN モードでの L2VPN Quality of Service ポリシーの設定

この手順では、VLAN モードでの L2VPN QoS ポリシーの設定方法について説明します。


) VLAN モードでは、インターフェイス名にサブインターフェイスを含める必要があります。次に例を示します。
GigabitEthernet 0/1/0/1.1
l2transport コマンドは、同じ CLI 行のインターフェイス タイプに従う必要があります。次に例を示します。
interface GigabitEthernet 0/0/0/0.1 l2transport


手順の概要

1. configure

2. interface type interface-path-id.subinterface l2transport

3. service-policy [ input | output ] [policy-map-name]

4. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RP0/CPU0:router# configure

コンフィギュレーション モードを開始します。

ステップ 2

interface type interface-path-id.subinterface l2transport

 

RP/0/RP0/CPU0:router(config)# interface GigabitEthernet0/0/0/0.1 l2transport

L2 スイッチングのインターフェイスまたは接続を設定します。

(注) VLAN モードでは、interface と同じ行に l2transport キーワードを入力する必要があります。

ステップ 3

service-policy [ input | output ] [policy-map-name]

 

RP/0/RP0/CPU0:router(config-if)# service-policy input servpol1

入力インターフェイスまたは出力インターフェイスに、そのインターフェイスのサービス ポリシーとして使用する QoS ポリシーを付加します。

ステップ 4

end

または

commit

 

RP/0/RP0/CPU0:router(config-if)# end

または

RP/0/RP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

優先トンネル パスの設定

この手順では、優先トンネル パスを設定する方法について説明します。


) 優先パスの設定に使用されるトンネルは、MPLS トラフィック エンジニアリング(MPLS-TE)トンネルです。


手順の概要

1. configure

2. l2vpn

3. pw-class { name }

4. encapsulation mpls

5. preferred-path { interface } { tunnel-te value } [ fallback disable ]

6. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

pw-class { name }

 

RP/0/RSP0/CPU0:router(config-l2vpn)# pw-class path1

疑似回線クラス名を設定します。

ステップ 4

encapsulation mpls

 

RP/0/RSP0/CPU0:router(config-l2vpn-pwc)# encapsulation mpls

MPLS に疑似回線カプセル化を設定します。

ステップ 5

preferred-path { interface } { tunnel-te value } [ fallback disable ]

 

RP/0/RSP0/CPU0:router(config-l2vpn-pwc-encap-
mpls)# preferred-path interface tunnel-te 11 fallback disable

優先パス トンネルを設定します。フォールバックのディセーブル化の設定が使用されており、優先パスとして設定されている TE トンネルがダウン状態になると、対応する疑似回線もダウン状態になることがあります。

(注) フォールバックがサポートされていることを確認します。

ステップ 6

end

または

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-pwc-encap-
mpls)# end

または

RP/0/RSP0/CPU0:router(config-l2vpn-pwc-encap-
mpls-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

マルチセグメント疑似回線設定のプロビジョニング

ポイントツーポイント(p2p)相互接続としてマルチセグメント疑似回線を設定します。P2P 相互接続の詳細については、「スタティック ポイントツーポイント相互接続の設定」を参照してください。

手順の概要

1. configure

2. l2vpn

3. xconnect group group-name

4. p2p xconnect-name

5. neighbor A.B.C.D pw-id value

6. pw-class class-name

7. exit

8. neighbor A.B.C.D pw-id value

9. pw-class class-name

10. commit

手順の詳細

 

コマンド
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

レイヤ 2 VPN コンフィギュレーション モードを開始します。

ステップ 3

xconnect group group-name

 

RP/0/RSP0/CPU0:router(config-l2vpn)# xconnect group MS-PW1

自由形式の 32 文字ストリングを使用して、相互接続グループ名を設定します。

ステップ 4

p2p xconnect-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc)# p2p ms-pw1

P2P コンフィギュレーション サブモードを開始します。

ステップ 5

neighbor A.B.C.D pw-id value

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# neighbor 10.165.200.25 pw-id 100

相互接続の疑似回線を設定します。

IP アドレスは、該当する PE ノードの IP アドレスです。

pw-id は PE ノードの pw-id と一致する必要があります。

ステップ 6

pw-class class-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# pw-class dynamic_mpls

疑似回線クラス サブモードになり、疑似回線クラス テンプレートを定義できます。

ステップ 7

exit

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# exit

疑似回線クラス サブモードを終了し、ルータを親コンフィギュレーション モードに戻します。

ステップ 8

neighbor A.B.C.D pw-id value

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# neighbor 10.165.202.158 pw-id 300

相互接続の疑似回線を設定します。

IP アドレスは、該当する PE ノードの IP アドレスです。

pw-id は PE ノードの pw-id と一致する必要があります。

ステップ 9

pw-class class-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# pw-class dynamic_mpls

疑似回線クラス サブモードになり、疑似回線クラス テンプレートを定義できます。

ステップ 10

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# commit

実行コンフィギュレーション ファイルに設定変更を保存し、コンフィギュレーション セッションを続行します。

グローバル マルチセグメント疑似回線のディスクリプションのプロビジョニング

S-PE ノードには、疑似回線切り替えポイントの Type-Length-Value(TLV)でディスクリプションが必要です。TLV は疑似回線が通過するすべてのスイッチング ポイントを記録し、トラブルシューティングのために便利な履歴を作成します。

各マルチセグメント疑似回線に独自のディスクリプションを設定できます。手順については、「相互接続のディスクリプションのプロビジョニング」を参照してください。独自のディスクリプションがない場合、このグローバルなディスクリプションが使用されます。

手順の概要

1. configure

2. l2vpn

3. description value

4. commit

手順の詳細

 

コマンド
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

レイヤ 2 VPN コンフィギュレーション モードを開始します。

ステップ 3

description value

 

RP/0/RSP0/CPU0:router(config-l2vpn)# description S-PE1

疑似回線切り替えポイント TLV を設定します。この TLV は、疑似回線が通過するすべてのスイッチング ポイントを記録します。

各マルチセグメント疑似回線に独自のディスクリプションを設定できます。独自のディスクリプションがない場合、このグローバルなディスクリプションが使用されます。

ステップ 4

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn)# commit

実行コンフィギュレーション ファイルに設定変更を保存し、コンフィギュレーション セッションを続行します。

相互接続のディスクリプションのプロビジョニング

S-PE ノードには、疑似回線切り替えポイントの TLV でディスクリプションが必要です。TLV は疑似回線が通過するすべてのスイッチング ポイントを記録し、トラブルシューティングのために便利な履歴を作成します。

手順の概要

1. configure

2. l2vpn

3. xconnect group group-name

4. p2p xconnect-name

5. description value

6. commit

手順の詳細

 

コマンド
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

レイヤ 2 VPN コンフィギュレーション モードを開始します。

ステップ 3

xconnect group group-name

 

RP/0/RSP0/CPU0:router(config-l2vpn)# xconnect group MS-PW1

自由形式の 32 文字ストリングを使用して、相互接続グループ名を設定します。

ステップ 4

p2p xconnect-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc)# p2p ms-pw1

P2P コンフィギュレーション サブモードを開始します。

ステップ 5

description value

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# description MS-PW from T-PE1 to T-PE2

疑似回線切り替えポイント TLV を設定します。この TLV は、疑似回線が通過するすべてのスイッチング ポイントを記録します。

各マルチセグメント疑似回線に独自のディスクリプションを設定できます。独自のディスクリプションがない場合、グローバルなディスクリプションが使用されます。詳細については、「マルチセグメント疑似回線設定のプロビジョニング」を参照してください。

ステップ 6

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# commit

実行コンフィギュレーション ファイルに設定変更を保存し、コンフィギュレーション セッションを続行します。

スイッチング ポイント TLV セキュリティのプロビジョニング

セキュリティ上の理由から、TLV を非表示にでき、それにより、疑似回線が通過するすべてのスイッチングポイントを誰かが表示することを防ぐことができます。

仮想回線接続性検証(VCCV)は、switching-tlv パラメータが「hide」に設定されたマルチセグメント疑似回線では機能しない場合があります。VCCV の詳細については、「L2VPN での仮想回線接続検証」を参照してください。

手順の概要

1. configure

2. l2vpn

3. pw-class class-name

4. encapsulation mpls

5. protocol ldp

6. switching-tlv hide

7. commit

手順の詳細

 

コマンド
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router (config)# l2vpn

レイヤ 2 VPN コンフィギュレーション モードを開始します。

ステップ 3

pw-class class-name

 

RP/0/RSP0/CPU0:router (config-l2vpn)# pw-class dynamic_mpls

疑似回線クラス サブモードになり、疑似回線クラス テンプレートを定義できます。

ステップ 4

encapsulation mpls

 

RP/0/RSP0/CPU0:router (config-l2vpn-pwc)# encapsulation mpls

MPLS に疑似回線カプセル化を設定します。

ステップ 5

protocol ldp

 

RP/0/RSP0/CPU0:router (config-l2vpn-pwc-encap-mpls)# protocol ldp

LDP に疑似回線シグナリング プロトコルを設定します。

ステップ 6

switching-tlv hide

 

RP/0/RSP0/CPU0:router (config-l2vpn-pwc-encap-mpls)# switching-tlv hide

疑似回線 TLV を非表示に設定します。

ステップ 7

commit

 

RP/0/RSP0/CPU0:router (config-l2vpn-pwc-encap-mpls)# commit

実行コンフィギュレーション ファイルに設定変更を保存し、コンフィギュレーション セッションを続行します。

マルチセグメント疑似回線のイネーブル化

pw-status コマンドをイネーブルにした後、pw-status コマンドを使用します。pw-status コマンドはデフォルトではディセーブルです。pw-status コマンドを変更すると、L2VPN で設定されたすべての疑似回線が再プロビジョニングされます。

手順の概要

1. configure

2. l2vpn

3. pw-status

4. commit

手順の詳細

 

コマンド
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router (config)# l2vpn

レイヤ 2 VPN コンフィギュレーション モードを開始します。

ステップ 3

pw-status

 

RP/0/RSP0/CPU0:router (config-l2vpn)# pw-status

このレイヤ 2 VPN で設定されるすべての疑似回線をイネーブルにします。

ステップ 4

commit

 

RP/0/RSP0/CPU0:router (config-l2vpn)# commit

実行コンフィギュレーション ファイルに設定変更を保存し、コンフィギュレーション セッションを続行します。

フローベースのロード バランシングのイネーブル化

フローベースのロード バランシングをイネーブルにするには、次の作業を実行します。

手順の概要

1. configure

2. l2vpn

3. load-balancing flow { src-dst-mac | src-dst-ip }

4. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

load-balancing flow { src-dst-mac | src-dst-ip }

 

RP/0/RSP0/CPU0:router(config-l2vpn)# load-balancing flow src-dst-ip

L2VPN 下のすべての疑似回線およびバンドル EFP に対しフロー ベースのロード バランシングをイネーブルにします。ただし、疑似回線クラスを通じて疑似回線に対して、および EFP-hash を通じてバンドルに対して明示的に指定されている場合は除きます。

ステップ 4

end

または

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn)# end

または

RP/0/RSP0/CPU0:router(config-l2vpn)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

疑似回線クラスのフローベースのロード バランシングのイネーブル化

疑似回線クラスに対しフローベースのロード バランシングをイネーブルにするには、次の作業を実行します。

手順の概要

1. configure

2. l2vpn

3. pw-class { name }

4. encapsulation mpls

5. load-balancing pw-label

6. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

pw-class { name }

 

RP/0/RSP0/CPU0:router(config-l2vpn)# pw-class path1

疑似回線クラス名を設定します。

ステップ 4

encapsulation mpls

 

RP/0/RSP0/CPU0:router(config-l2vpn-pwc)# encapsulation mpls

MPLS に疑似回線カプセル化を設定します。

ステップ 5

load-balancing pw-lab el

 

RP/0/RSP0/CPU0:router(config-l2vpn-pwc-encap-
mpls)# load-balancing pw-label

仮想回線ベースのロード バランシングを使用するために、定義されたクラスを使用してすべての疑似回線をイネーブルにします。

ステップ 6

end

または

commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-pwc-encap-
mpls)# end

または

RP/0/RSP0/CPU0:router(config-l2vpn-pwc-encap-
mpls)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

疑似回線の冗長性の設定

疑似回線の冗長性により、プライマリ疑似回線で障害が発生した場合のバックアップ疑似回線を設定できます。プライマリ疑似回線で障害が発生した場合、PE ルータをバックアップ疑似回線に切り替えることができます。復旧後にプライマリ疑似回線の運用が再開するように選択できます。

次のトピックでは、疑似回線の冗長性を設定する方法について説明します。

「バックアップ疑似回線の設定」

「ポイントツーポイント疑似回線の冗長性の設定」

「バックアップ疑似回線への強制的な手動切り替え」

バックアップ疑似回線の設定

ポイントツーポイント ネイバーのバックアップ疑似回線を設定するには、次の作業を実行します。


) プライマリ疑似回線を再プロビジョニングすると、2 秒でトラフィック再開されます。ただし、バックアップ疑似回線を再プロビジョニングすると、45 ~ 60 秒の遅延後にトラフィックが再開されます。これは、正常な動作です。


手順の概要

1. configure

2. l2vpn

3. xconnect group group-name

4. p2p { xconnect-name }

5. neighbor { A.B.C.D } { pw-id value }

6. backup { neighbor A.B.C.D } { pw-id value }

7. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

RP/0/RSP0/CPU0:router(config-l2vpn)#

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

xconnect group group-name

 

RP/O/RSP0/CPU0:router(config-l2vpn)# xconnect group A

RP/0/RSP0/CPU0:router(config-l2vpn-xc)#

相互接続グループの名前を入力します。

ステップ 4

p2p { xconnect-name }

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc)# p2p xc1

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)#

ポイントツーポイント相互接続の名前を入力します。

ステップ 5

neighbor { A.B.C.D } { pw-id value }

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# neighbor 10.1.1.2 pw-id 2

相互接続の疑似回線セグメントを設定します。

ステップ 6

backup {neighbor A.B.C.D } { pw-id value }

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# backup neighbor 10.2.2.2 pw-id 5

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw-backup)#

相互接続のバックアップ疑似回線を設定します。

neighbor キーワードを使用して、相互接続するピアを指定します。IP アドレス引数( A.B.C.D )は、ピアの IPv4 アドレスです。

pw-id キーワードを使用して、疑似回線 ID を設定します。範囲は 1 ~ 4294967295 です。

ステップ 7

end
または
commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw-backup)# end
or
RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw-backup)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ポイントツーポイント疑似回線の冗長性の設定

バックアップ遅延のためにポイントツーポイント疑似回線の冗長性を設定するには、次の作業を実行します。

手順の概要

1. configure

2. l2vpn

3. pw-class { class-name }

4. backup disable { delay value | never }

5. exit

6. xconnect group group-name

7. p2p { xconnect-name }

8. neighbor { A.B.C.D } { pw-id value }

9. pw-class { class-name }

10. backup { neighbor A.B.C.D } { pw-id value }

11. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

RP/0/RSP0/CPU0:router(config-l2vpn)#

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

pw-class {class- name }

 

RP/O/RSP0/CPU0:router(config-l2vpn)# pw-class path1

RP/0/RSP0/CPU0:router(config-l2vpn-pwc)#

疑似回線クラス名を設定します。

ステップ 4

backup disable { delay value | never }

 

RP/0/RSP0/CPU0:router(config-l2vpn-pwc)# backup disable delay 20

このコマンドは、プライマリ疑似回線がアクティブになってから、バックアップ疑似回線を引き継ぐまでの待ち時間を指定します。

delay キーワードを使用して、プライマリ疑似回線がアップ状態になってから、セカンダリ疑似回線が非アクティブになるまでの経過秒数を指定します。範囲は 0 ~ 180 秒です。

プライマリ疑似回線が再び使用できるようになった場合に、セカンダリ疑似回線で障害が発生しない限り、セカンダリ疑似回線からプライマリ疑似回線にフォール バックしないように指定するには、 never キーワードを使用します。

ステップ 5

exit

 

RP/0/RSP0/CPU0:router(config-l2vpn-pwc)# exit

RP/O/RSP0/CPU0:router(config-l2vpn)#

現在のコンフィギュレーション モードを終了します。

ステップ 6

xconnect group group-name

 

RP/0/RSP0/CPU0:router(config-l2vpn)# xconnect group A

RP/0/RSP0/CPU0:router(config-l2vpn-xc)#

相互接続グループの名前を入力します。

ステップ 7

p2p { xconnect-name }

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc)# p2p xc1

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)#

ポイントツーポイント相互接続の名前を入力します。

ステップ 8

neighbor { A.B.C.D } { pw-id value }

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# neighbor 10.1.1.2 pw-id 2

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)#

相互接続の疑似回線セグメントを設定します。

ステップ 9

pw-class {class- name }

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# pw-class path1

疑似回線クラス名を設定します。

ステップ 10

backup { neighbor A.B.C.D } { pw-id value }

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw)# backup neighbor 10.2.2.2 pw-id 5

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw-backup)#

相互接続のバックアップ疑似回線を設定します。

neighbor キーワードを使用して、相互接続するピアを指定します。A.B.C.D 引数はピアの IPv4 アドレスです。

pw-id キーワードを使用して、疑似回線 ID を設定します。範囲は 1 ~ 4294967295 です。

ステップ 11

end
または
commit

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw-backup)# end
or
RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p-pw-backup)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

バックアップ疑似回線への強制的な手動切り替え

ルータをバックアップまたはプライマリ疑似回線に強制的に切り替えるには、EXEC モードで l2vpn switchover コマンドを使用します。

手動切り替えは、コマンドが入力されたとき、コマンドで指定されたピアが実際に使用可能であり、相互接続が完全なアクティブ状態に移行する場合に限り実行されます。

マルチキャスト接続の設定

Cisco ASR 9000 Series Aggregation Services Router Multicast Configuration Guide 』の「 Implementing Multicast Routing on Cisco ASR 9000 Series Aggregation Services Routers 」モジュールおよび『 Cisco ASR 9000 Series Aggregation Services Router Multicast Command Reference 』の「 Multicast Routing and Forwarding Commands on Cisco ASR 9000 Series Aggregation Services Routers 」モジュールを参照してください。

手順の概要

1. configure

2. multicast-routing

3. address-family ipv4

4. nsf

5. interface all enable

6. accounting per-prefix

7. router pim

8. vrf default address-family ipv4

9. rp-address

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/RSP0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

multicast-routing [ address-family ipv4 ]

 

RP/0/RSP0/CPU0:router(config)# multicast-routing

マルチキャスト ルーティング コンフィギュレーション モードを開始します。

次のマルチキャスト プロセスが起動します:MRIB、MFWD、PIM、および IGMP。

IPv4 では、IGMP バージョン 3 はデフォルトでイネーブルです。

IPv4 の場合、 address-family ipv4 キーワードを使用します。

ステップ 3

interface all enable

 

RP/0/RSP0/CPU0:router(config-mcast-ipv4)# interface all enable

新規および既存のすべてのインターフェイスでマルチキャスト ルーティングおよび転送をイネーブルにします。

ステップ 4

exit

 

RP/0/RSP0/CPU0:router(config-mcast-ipv4)# exit

マルチキャスト ルーティング コンフィギュレーション モードを終了し、ルータを親コンフィギュレーション モードに戻します。

ステップ 5

router igmp

 
RP/0/RSP0/CPU0:router(config)# router igmp

(任意)ルータ IGMP コンフィギュレーション モードを開始します。

ステップ 6

version { 1 | 2 | 3 }

 

RP/0/RSP0/CPU0:router(config-igmp)# version 3

(任意)ルータ インターフェイスで使用する IGMP バージョンを選択します。

IGMP のデフォルトはバージョン 3 です。

ホスト レシーバは、PIM-SSM 動作の IGMPv3 をサポートする必要があります。

このコマンドがルータ IGMP コンフィギュレーション モードで設定されている場合、パラメータはすべての新規および既存インターフェイスによって継承されます。これらのパラメータは、インターフェイス コンフィギュレーション モードでインターフェイスごとに上書きできます。

ステップ 7

end
or

commit

 

RP/0/RSP0/CPU0:router(config-igmp)# end

または

RP/0/RSP0/CPU0:router(config-igmp)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ステップ 8

show pim [ ipv4 ] group-map [ ip-address-name ] [ info-source ]

 

RP/0//CPU0:router# show pim ipv4 group-map

(任意)グループと PIM モードのマッピングを表示します。

ステップ 9

show pim [ vrf vrf-name ] [ ipv4 ] topology [ source-ip-address [ group-ip-address ] | entry-flag flag | interface-flag | summary ] [ route-count ]

 

RP/0/RSP0/CPU0:router# show pim topology

(任意)特定のグループまたはすべてのグループの PIM トポロジ テーブル情報を表示します。

AToM IP インターワーキングの設定

AToM IP インターワーキングを設定するには、次の作業を実行します。

手順の概要

1. configure

2. l2vpn

3. xconnect group group-name

4. p2p xconnect-name

5. interworking ipv4

6. end
または
commit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure

 

RP/0/0/CPU0:router# configure

グローバル コンフィギュレーション モードを開始します。

ステップ 2

l2vpn

 

RP/0/RSP0/CPU0:router(config)# l2vpn

L2VPN コンフィギュレーション モードを開始します。

ステップ 3

xconnect group group-name

 

RP/0/RSP0/CPU0:router(config-l2vpn)# xconnect group grp_1

相互接続グループの名前を入力します。

ステップ 4

p2p xconnect-name

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc)# p2p vlan1

ポイントツーポイント相互接続の名前を入力します。

ステップ 5

interworking ipv4

 

RP/0/RSP0/CPU0:router(config-l2vpn-xc-p2p)# interworking ipv4

P2P で IPv4 インターワーキングを設定します。

ステップ 6

end

または

commit

 

RP/0/RP0/CPU0:router(config-if)# end

または

RP/0/RP0/CPU0:router(config-if)# commit

設定変更を保存します。

end コマンドを実行すると、変更をコミットするように要求されます。

Uncommitted changes found, commit them before exiting(yes/no/cancel)?
[cancel]:
 

yes と入力すると、実行コンフィギュレーション ファイルに変更が保存され、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。

no と入力すると、コンフィギュレーション セッションが終了して、ルータが EXEC モードに戻ります。変更はコミットされません。

cancel と入力すると、現在のコンフィギュレーション セッションが継続します。コンフィギュレーション セッションは終了せず、設定変更もコミットされません。

実行コンフィギュレーション ファイルに変更を保存し、コンフィギュレーション セッションを継続するには、 commit コマンドを使用します。

ポイントツーポイント レイヤ 2 サービスの設定例

ここで示す設定例は、次のとおりです。

「L2VPN インターフェイスの設定:例」

「ローカル スイッチングの設定:例」

「ポイントツーポイント相互接続の設定:例」

「Inter-AS:例」

「L2VPN Quality of Service:例」

「優先パス:例」

「疑似回線:例」

「疑似回線ステータスの表示:例」

「AToM IP インターワーキングの設定:例」

L2VPN インターフェイスの設定:例

次に、L2VPN インターフェイスを設定する例を示します。

configure
interface GigabitEthernet0/0/0/0.1 l2transport
カプセル化 dot1q 1
rewrite ingress pop 1 symmetric
end

ローカル スイッチングの設定:例

次に、レイヤ 2 ローカル スイッチングを設定する例を示します。

configure
l2vpn
xconnect group examples
p2p example1
interface TenGigE0/7/0/6.5
interface GigabitEthernet0/4/0/30
commit
end
 
show l2vpn xconnect group examples
Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,
SB = Standby, SR = Standby Ready
 
XConnect Segment 1 Segment 2
Group Name ST Description ST Description ST
------------------------ ------------------------- -------------------------
examples example1 UP Te0/7/0/6.5 UP Gi0/4/0/30 UP
--------------------------------------------------------------------------------
 
 
 

ポイントツーポイント相互接続の設定:例

ここでは、スタティックおよびダイナミック p2p 相互接続の設定例を示します。

スタティック設定

次に、スタティック ポイントツーポイント相互接続の設定例を示します。

configure
l2vpn
xconnect group vlan_grp_1
p2p vlan1
interface GigabitEthernet0/0/0/0.1
neighbor 10.2.1.1 pw-id 1
commit

ダイナミック設定

次に、ダイナミック ポイントツーポイント相互接続の設定例を示します。

configure
l2vpn
xconnect group vlan_grp_1
p2p vlan1
interface GigabitEthernet0/0/0/0.1
neighbor 10.2.1.1 pw-id 1
commit

Inter-AS:例

次に、AC1 から AC2 への AC 間相互接続の設定例を示します。

router-id Loopback0
 
interface Loopback0
ipv4 address 10.0.0.5 255.255.255.255
!
interface GigabitEthernet0/1/0/0.1 l2transport
encapsulation dot1q 1
!
!
interface GigabitEthernet0/0/0/3
ipv4 address 10.45.0.5 255.255.255.0
keepalive disable
!
interface GigabitEthernet0/0/0/4
ipv4 address 10.5.0.5 255.255.255.0
keepalive disable
!
router ospf 100
log adjacency changes detail
area 0
interface Loopback0
!
interface GigabitEthernet0/0/0/3
!
interface GigabitEthernet0/0/0/4
!
!
!
router bgp 100
address-family ipv4 unicast
allocate-label all
!
neighbor 10.2.0.5
remote-as 100
update-source Loopback0
address-family ipv4 unicast
!
address-family ipv4 labeled-unicast
!
!
!
l2vpn
xconnect group cisco
p2p cisco1
interface GigabitEthernet0/1/0/0.1
neighbor 10.0.1.5 pw-id 101
!
p2p cisco2
interface GigabitEthernet0/1/0/0.2
neighbor 10.0.1.5 pw-id 102
!
p2p cisco3
interface GigabitEthernet0/1/0/0.3
neighbor 10.0.1.5 pw-id 103
!
p2p cisco4
interface GigabitEthernet0/1/0/0.4
neighbor 10.0.1.5 pw-id 104
!
p2p cisco5
interface GigabitEthernet0/1/0/0.5
neighbor 10.0.1.5 pw-id 105
!
p2p cisco6
interface GigabitEthernet0/1/0/0.6
neighbor 10.0.1.5 pw-id 106
!
p2p cisco7
interface GigabitEthernet0/1/0/0.7
neighbor 10.0.1.5 pw-id 107
!
p2p cisco8
interface GigabitEthernet0/1/0/0.8
neighbor 10.0.1.5 pw-id 108
!
p2p cisco9
interface GigabitEthernet0/1/0/0.9
neighbor 10.0.1.5 pw-id 109
!
p2p cisco10
interface GigabitEthernet0/1/0/0.10
neighbor 10.0.1.5 pw-id 110
!
!
!
mpls ldp
router-id Loopback0
log
neighbor
!
interface GigabitEthernet0/0/0/3
!
interface GigabitEthernet0/0/0/4
!
!
end

L2VPN Quality of Service:例

次に、ポート モードの L2 インターフェイスにサービス ポリシーをアタッチする例を示します。

configure
interface GigabitEthernet 0/0/0/0
l2transport
service-policy input pmap_1
commit

優先パス:例

次に、優先トンネル パスを設定する例を示します。

configure
l2vpn
pw-class path1
encapsulation mpls
preferred-path interface tunnel value fallback disable

疑似回線:例

例には、次のデバイスおよび接続が含まれます。

T-PE1 ノードには次の項目があります。

AC インターフェイスとの相互接続(CE1 方向)

S-PE1 ノードへの疑似回線

IP アドレス:209.165.200.225

T-PE2 ノード

AC インターフェイスとの相互接続(CE2 方向)

S-PE1 ノードへの疑似回線

IP アドレス:209.165.200.254

S-PE1 ノード

T-PE1 ノードへの疑似回線セグメントによるマルチセグメント疑似回線相互接続

T-PE2 ノードへの疑似回線セグメント

IP アドレス:209.165.202.158

T-PE1 ノードのダイナミック疑似回線の設定:例

RP/0/RSP0/CPU0:T-PE1# configure

RP/0/RSP0/CPU0:T-PE1(config)# l2vpn

RP/0/RSP0/CPU0:T-PE1 (config-l2vpn)# pw-class dynamic_mpls

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc)# encapsulation mpls

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc-encap-mpls)# protocol ldp

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc-encap-mpls)# control-word disable

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc-encap-mpls)# exit

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc)# exit

RP/0/RSP0/CPU0:T-PE1(config-l2vpn)# xconnect group XCON1

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc)# p2p xc1

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p)# description T-PE1 MS-PW to 10.165.202.158 via 10.165.200.254

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p)# interface gigabitethernet 0/1/0/0.1

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p)# neighbor 10.165.200.254 pw-id 100

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p-pw)# pw-class dynamic_mpls

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p-pw)# commit

S-PE1 ノードのダイナミック疑似回線の設定:例

RP/0/RSP0/CPU0:S-PE1# configure

RP/0/RSP0/CPU0:S-PE1(config)# l2vpn

RP/0/RSP0/CPU0:S-PE1(config-l2vpn)# pw-class dynamic_mpls

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc)# encapsulation mpls

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# protocol ldp

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# control-word disable

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# exit

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc)# exit

RP/0/RSP0/CPU0:S-PE1(config-l2vpn)# xconnect group MS-PW1

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc)# p2p ms-pw1

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p)# description S-PE1 MS-PW between 10.165.200.225 and 10.165.202.158

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p)# neighbor 10.165.200.225 pw-id 100

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# pw-class dynamic_mpls

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# exit

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p)# neighbor 10.165.202.158 pw-id 300

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# pw-class dynamic_mpls

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# commit

T-PE2 ノードのダイナミック疑似回線の設定:例

RP/0/RSP0/CPU0:T-PE2# configure

RP/0/RSP0/CPU0:T-PE2(config)# l2vpn

RP/0/RSP0/CPU0:T-PE2 (config-l2vpn)# pw-class dynamic_mpls

RP/0/RSP0/CPU0:T-PE2 (config-l2vpn-pwc)# encapsulation mpls

RP/0/RSP0/CPU0:T-PE2 (config-l2vpn-pwc-encap-mpls)# protocol ldp

RP/0/RSP0/CPU0:T-PE2 (config-l2vpn-pwc-encap-mpls)# control-word disable

RP/0/RSP0/CPU0:T-PE2 (config-l2vpn-pwc-encap-mpls)# exit

RP/0/RSP0/CPU0:T-PE2 (config-l2vpn-pwc)# exit

RP/0/RSP0/CPU0:T-PE2(config-l2vpn)# xconnect group XCON1

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc)# p2p xc1

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p)# description T-PE2 MS-PW to 10.165.200.225 via 10.165.200.254

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p)# interface gigabitethernet 0/2/0/0.4

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p)# neighbor 10.165.200.254 pw-id 300

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p-pw)# pw-class dynamic_mpls

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p-pw)# commit

T-PE1 ノードのダイナミック疑似回線と優先パスの設定:例

RP/0/RSP0/CPU0:T-PE1# configure

RP/0/RSP0/CPU0:T-PE1(config)# l2vpn

RP/0/RSP0/CPU0:T-PE1(config-l2vpn)# pw-class dynamic_mpls

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc)# encapsulation mpls

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc-encap-mpls)# protocol ldp

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc-encap-mpls)# control-word disable

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc-encap-mpls)# preferred-path interface tunnel-te 1000

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc-encap-mpls)# exit

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-pwc)# exit

RP/0/RSP0/CPU0:T-PE1(config-l2vpn)# xconnect group XCON1

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc)# p2p xc1

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p)# description T-PE1 MS-PW to 10.165.202.158 via 10.165.200.254

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p)# interface gigabitethernet 0/1/0/0.1

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p)# neighbor 10.165.200.254 pw-id 100

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p-pw)# pw-class dynamic_mpls

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p-pw)# commit

S-PE1 ノードのダイナミック疑似回線と優先パスの設定:例

RP/0/RSP0/CPU0:S-PE1# configure

RP/0/RSP0/CPU0:S-PE1(config)# l2vpn

RP/0/RSP0/CPU0:S-PE1(config-l2vpn)# pw-class dynamic_mpls1

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc)# encapsulation mpls

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# protocol ldp

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# control-word disable

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# preferred-path interface tunnel-te 1000

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# exit

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc)# exit

RP/0/RSP0/CPU0:S-PE1(config-l2vpn)# pw-class dynamic_mpls2

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc)# encapsulation mpls

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# protocol ldp

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# control-word disable

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# preferred-path interface tunnel-te 2000

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# exit

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc)# exit

RP/0/RSP0/CPU0:S-PE1(config-l2vpn)# xconnect group MS-PW1

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc)# p2p ms-pw1

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p)# description S-PE1 MS-PW between 10.165.200.225 and 10.165.202.158

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p)# neighbor 10.165.200.225 pw-id 100

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# pw-class dynamic_mpls1

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# exit

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p)# neighbor 10.165.202.158 pw-id 300

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# pw-class dynamic_mpls2

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# commit

T-PE2 ノードのダイナミック疑似回線と優先パスの設定:例

RP/0/RSP0/CPU0:T-PE2# configure

RP/0/RSP0/CPU0:T-PE2(config)# l2vpn

RP/0/RSP0/CPU0:T-PE2(config-l2vpn)# pw -class dynamic_mpls

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-pwc)# encapsulation mpls

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-pwc-encap-mpls)# protocol ldp

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-pwc-encap-mpls)# control-word disable

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-pwc-encap-mpls)# preferred-path interface tunnel-te 2000

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-pwc-encap-mpls)# exit

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-pwc)# exit

RP/0/RSP0/CPU0:T-PE2(config-l2vpn)# xconnect group XCON1

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc)# p2p xc1

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p)# description T-PE2 MS-PW to 10.165.200.225 via 10.165.200.254

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p)# interface gigabitethernet 0/2/0/0.4

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p)# neighbor 10.165.200.254 pw-id 300

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p-pw)# pw-class dynamic_mpls

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p-pw)# commit

T-PE1 ノードのスタティック疑似回線の設定:例

RP/0/RSP0/CPU0:T-PE1# configure

RP/0/RSP0/CPU0:T-PE1(config)# l2vpn

RP/0/RSP0/CPU0:T-PE1(config-l2vpn)# xconnect group XCON1

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc)# p2p xc1

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p)# interface gigabitethernet 0/1/0/0.1

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p)# neighbor 10.165.200.254 pw-id 100

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p-pw)# mpls static label local 50 remote 400

RP/0/RSP0/CPU0:T-PE1(config-l2vpn-xc-p2p-pw)# commit

S-PE1 ノードのスタティック疑似回線の設定:例

RP/0/RSP0/CPU0:S-PE1# configure

RP/0/RSP0/CPU0:S-PE1(config)# l2vpn

RP/0/RSP0/CPU0:S-PE1(config-l2vpn)# xconnect group MS-PW1

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc)# p2p ms-pw1

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p)# neighbor 10.165.200.225 pw-id 100

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# mpls static label local 400 remote 50

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# exit

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p)# neighbor 10.165.202.158 pw-id 300

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# mpls static label local 40 remote 500

RP/0/RSP0/CPU0:S-PE1(config-l2vpn-xc-p2p-pw)# commit

T-PE2 ノードのスタティック疑似回線の設定:例

RP/0/RSP0/CPU0:T-PE2# configure

RP/0/RSP0/CPU0:T-PE2(config)# l2vpn

RP/0/RSP0/CPU0:T-PE2(config-l2vpn)# xconnect group XCON1

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc)# p2p xc1

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p)# interface gigabitethernet 0/2/0/0.4

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p)# neighbor 10.165.200.254 pw-id 300

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p-pw)# mpls static label local 500 remote 40

RP/0/RSP0/CPU0:T-PE2(config-l2vpn-xc-p2p-pw)# commit

疑似回線ステータスの表示:例

show l2vpn xconnect

RP/0/RSP0/CPU0:router# show l2vpn xconnect

Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,

LU = Local Up, RU = Remote Up, CO = Connected

XConnect Segment 1 Segment 2

Group Name ST Description ST Description ST

------------------------ ------------------------- -------------------------

MS-PW1 ms-pw1 UP 10.165.200.225 100 UP 10.165.202.158 300 UP

--------------------------------------------------------------------------------

show l2vpn xconnect detail

RP/0/RSP0/CPU0:router# show l2vpn xconnect detail

Group MS-PW1, XC ms-pw1, state is up; Interworking none

PW: neighbor 10.165.200.225, PW ID 100, state is up ( established )

PW class not set

Encapsulation MPLS, protocol LDP

PW type Ethernet VLAN, control word enabled, interworking none

PW backup disable delay 0 sec

Sequencing not set

PW Status TLV in use

MPLS Local Remote

------------ ------------------------------ -----------------------------

Label 16004 16006

Group ID 0x2000400 0x2000700

Interface GigabitEthernet0/1/0/2.2 GigabitEthernet0/1/0/0.3

MTU 1500 1500

Control word enabled enabled

PW type Ethernet VLAN Ethernet VLAN

VCCV CV type 0x2 0x2

(LSP ping verification) (LSP ping verification)

VCCV CC type 0x5 0x7

(control word) (control word)

(router alert label)

(TTL expiry) (TTL expiry)

------------ ------------------------------ -----------------------------

Incoming PW Switching TLVs (Label Mapping message):

None

Incoming Status (PW Status TLV and accompanying PW Switching TLV):

Status code: 0x0 (no fault) in Notification message

Outgoing PW Switching TLVs (Label Mapping message):

Local IP Address: 10.165.200.254 , Remote IP address: 10.165.202.158 , PW ID: 300

Description: S-PE1 MS-PW between 10.165.200.225 and 10.165.202.158

Outgoing Status (PW Status TLV and accompanying PW Switching TLV):

Status code: 0x0 (no fault) in Notification message

Local IP Address: 10.165.200.254

Create time: 04/04/2008 23:18:24 (00:01:24 ago)

Last time status changed: 04/04/2008 23:19:30 (00:00:18 ago)

Statistics:

packet totals: receive 0

byte totals: receive 0

PW: neighbor 10.165.202.158 , PW ID 300, state is up ( established )

PW class not set

Encapsulation MPLS, protocol LDP

PW type Ethernet VLAN, control word enabled, interworking none

PW backup disable delay 0 sec

Sequencing not set

PW Status TLV in use

MPLS Local Remote

------------ ------------------------------ -----------------------------

Label 16004 16006

Group ID 0x2000800 0x2000200

Interface GigabitEthernet0/1/0/0.3 GigabitEthernet0/1/0/2.2

MTU 1500 1500

Control word enabled enabled

PW type Ethernet VLAN Ethernet VLAN

VCCV CV type 0x2 0x2

(LSP ping verification) (LSP ping verification)

VCCV CC type 0x5 0x7

(control word) (control word)

(router alert label)

(TTL expiry) (TTL expiry)

------------ ------------------------------ -----------------------------

Incoming PW Switching TLVs (Label Mapping message):

None

Incoming Status (PW Status TLV and accompanying PW Switching TLV):

Status code: 0x0 (no fault) in Notification message

Outgoing PW Switching TLVs (Label Mapping message):

Local IP Address: 10.165.200.254 , Remote IP address: 10.165.200.225, PW ID: 100

Description: S-PE1 MS-PW between 10.165.200.225 and 10.165.202.158

Outgoing Status (PW Status TLV and accompanying PW Switching TLV):

Status code: 0x0 (no fault) in Notification message

Local IP Address: 10.165.200.254

Create time: 04/04/2008 23:18:24 (00:01:24 ago)

Last time status changed: 04/04/2008 23:19:30 (00:00:18 ago)

Statistics:

packet totals: receive 0

byte totals: receive 0

RP/0/RSP0/CPU0:router#

""Show l2vpn xconnect summary": added PW-PW count.

"Show l2vpn forwarding location <> (no change: does not display MS-PWs)

"Show l2vpn forwarding summary location <> (no change: does not display MS-PWs)

Any Transport over MPLS(AToM)の設定:例

次に、Any Transport over MPLS(AToM)を設定する例を示します。

config
l2vpn
xconnect group test
p2p test
interface POS 0/1/0/0.1
neighbor 10.1.1.1 pw-id 100
 

AToM IP インターワーキングの設定:例

次に、IP インターワーキングを設定する例を示します。

config
l2vpn
xconnect group test
p2p test
interworking ipv4
 

その他の参考資料

MPLS レイヤ 2 VPN の実装に関する追加情報については、以下を参照してください。

関連資料

 

関連項目
ドキュメント名

Cisco IOS XR L2VPN コマンド

Cisco ASR 9000 Series Aggregation Services Router L2VPN and Ethernet Services Command Reference

レイヤ 2 VPN

Cisco ASR 9000 Series Aggregation Services Router L2VPN and Ethernet Services Configuration Guide

MPLS VPN over IP トンネル

Cisco ASR 9000 Series Aggregation Services Router L2VPN and Ethernet Services Configuration Guide

スタートアップ マニュアル

『Cisco ASR 9000 Series Aggregation Services Router Getting Started Guide

標準

 

標準1
タイトル

この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

--

1.サポートされている規格がすべて記載されているわけではありません。

MIB

 

MIB
MIB リンク

--

Cisco IOS XR ソフトウェアを使用している MIB を特定してダウンロードするには、次の URL にある Cisco MIB Locator を使用し、[Cisco Access Products] メニューからプラットフォームを選択します。 http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

 

RFC
タイトル

RFC 4447

『Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP)』2006 年 4 月

RFC 4448

Encapsulation Methods for Transport of Ethernet over MPLS Networks 』2006 年 4 月

シスコのテクニカル サポート

 

説明
リンク

シスコのテクニカル サポート Web サイトには、数千ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/en/US/support/index.html