Cisco 12000 シリーズ ルータ SIP/SPA ソフトウェア コンフィギュレーション ガイド (Cisco IOS) 12.0(32)SY
ファスト イーサネットおよびギガビッ ト イーサネット SPA の設定
ファスト イーサネットおよびギガビット イーサネット SPA の設定
発行日;2012/02/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

ファスト イーサネットおよびギガビット イーサネット SPA の設定

設定作業

必要な設定作業

ファスト イーサネット SPA の必須の設定作業

ギガビット イーサネット SPA の必須の設定作業

インターフェイス アドレスの指定

インターフェイスの MAC アドレスの変更

MAC アドレスの確認

MAC アドレス アカウンティング統計情報の収集

HSRP の設定

インターフェイスの MTU サイズの変更

インターフェイスMTUの設定時の注意事項

インターフェイス MTU の設定作業

MTU サイズの確認

カプセル化タイプの設定

インターフェイスの自動ネゴシエーションの設定

自動ネゴシエーションのディセーブル化

自動ネゴシエーションのイネーブル化

VLAN でのサブインターフェイスの設定

VLAN のサブインターフェイス設定の確認

リンクのフロー制御サポートの設定

フロー制御ステータスの確認

設定の保存

でのインターフェイスのシャットダウンおよび再起動

インターフェイスの設定の確認

ポート単位のインターフェイス ステータスの確認

設定例

基本的なインターフェイス設定例

MAC アドレスの設定例

MTU の設定例

VLAN の設定例

ファスト イーサネットおよびギガビット イーサネット SPA の設定

この章では、Cisco 12000 シリーズ ルータに搭載された Cisco 1 ポート 10 ギガビット イーサネット SPA、5 ポート ギガビット イーサネット SPA、8 ポート ファスト イーサネット SPA、および Cisco 10 ポート ギガビット イーサネット SPA の設定方法について説明します。具体的な内容は次のとおりです。

「設定作業」

「インターフェイスの設定の確認」

「設定例」

システム イメージおよびコンフィギュレーション ファイルの管理については、『 Cisco IOS Configuration Fundamentals Configuration Guide 』 Release 12.0 および『 Cisco IOS Configuration Fundamentals Command Reference 』 Release 12.0 を参照してください。

この章で使用しているコマンドの詳細については、まず新規コマンドまたは変更されたコマンドが記載されている「SIP および SPA コマンド リファレンス」を参照してください。また、関連する Cisco IOS Release 12.0 ソフトウェア コマンド リファレンスおよびマスター インデックスも参照してください。これらのマニュアルの入手方法については、「関連資料」を参照してください。

設定作業

ここでは、Cisco 1 ポート 10 ギガビット イーサネット SPA、5 ポート ギガビット イーサネット SPA、8 ポート ファスト イーサネット、および Cisco 10 ポート ギガビット イーサネット SPA の設定方法、および設定の確認方法について説明します。

内容は、次のとおりです。

「必要な設定作業」

「インターフェイス アドレスの指定」

「インターフェイスの MAC アドレスの変更」

「インターフェイスの MTU サイズの変更」

「カプセル化タイプの設定」

「インターフェイスの自動ネゴシエーションの設定」

「VLAN でのサブインターフェイスの設定」

「リンクのフロー制御サポートの設定」

「設定の保存」

「SPA でのインターフェイスのシャットダウンおよび再起動」

必要な設定作業

ここでは、ギガビット イーサネット Shared Port Adapter(SPA)を設定するために必要な手順を示します。必須の設定コマンドの中には、ネットワークに最適なデフォルト値を提供するものがあります。そのデフォルト値がネットワークに適している場合は、そのコマンドを設定する必要はありません。このようなコマンドの説明カラムには、「(必要に応じて)」と示されています。

ファスト イーサネット SPA の必須の設定作業

8 ポート ファスト イーサネット SPA を設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface fastethernet slot / subslot / port [ . subinterface-number ]

設定するファスト イーサネット インターフェイスを指定します。

slot / subslot / port ― インターフェイスの位置を指定します。「インターフェイス アドレスの指定」を参照してください。

. subinterface-number ― (任意)セカンダリ インターフェイス(サブインターフェイス)の番号を指定します。

ステップ 3

Router(config-if)# ip address ip-address mask [ secondary ]

インターフェイスのプライマリまたはセカンダリ IP アドレスを設定します。

ip-address ― インターフェイスの IP アドレスを指定します。

mask ― 関連付けられた IP サブネットのマスクを指定します。

secondary ― (任意)設定されたアドレスがセカンダリ IP アドレスになるように指定します。このキーワードを省略すると、設定されたアドレスはプライマリ IP アドレスとなります。

ステップ 4

Router(config-if)# duplex { full | half }

(必要に応じて)インターフェイスのデュプレックス動作を設定します。

デフォルトは full です。

ステップ 5

Router(config-if)# speed { 10 | 100 }

(必要に応じて)インターフェイスの速度(Mbps)を設定します。

ステップ 6

Router(config-if)# mtu bytes

(必要に応じて)インターフェイスの最大パケット サイズを指定します。

bytes ― パケットの最大バイト数を指定します。デフォルト値は 1500 バイトです。

ステップ 7

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ギガビット イーサネット SPA の必須の設定作業

Cisco 1 ポート 10 ギガビット イーサネット SPA、5 ポート ギガビット イーサネット SPA、および Cisco 10 ポート ギガビット イーサネット SPA を設定する手順は、次のとおりです。

 

コマンド
説明

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface gigabitethernet slot / subslot / port [ . subinterface-number ]

または

Router(config)# interface tengigabitethernet slot / subslot / port [ . subinterface-number ]

設定するギガビット イーサネットまたは 10 ギガビット イーサネット インターフェイスを指定します。

slot / subslot / port ― インターフェイスの位置を指定します。「インターフェイス アドレスの指定」を参照してください。

. subinterface-number ― (任意)セカンダリ インターフェイス(サブインターフェイス)の番号を指定します。

ステップ 3

Router(config-if)# ip address ip-address mask [ secondary ]

IPv4 の場合:

IPv4 を使用するインターフェイスのプライマリまたはセカンダリ IP アドレスを設定します。

ip-address ― インターフェイスの IP アドレスを指定します。

mask ― 関連付けられた IP サブネットのマスクを指定します。

secondary ― (任意)設定されたアドレスがセカンダリ IP アドレスになるように指定します。このキーワードを省略すると、設定されたアドレスはプライマリ IP アドレスとなります。

ステップ 4

Router(config)# ip accounting mac-address { input | output }

(任意)MAC アドレス アカウンティングをイネーブルにします。MAC アドレス アカウンティングは、LAN インターフェイスの送信元および宛先 MAC アドレスに基づいて、IP トラフィックのアカウンティング情報を提供します。

input ― インターフェイスに着信するトラフィックに対して MAC アドレス アカウンティングを指定します。

output ― インターフェイスから送信されるトラフィックに対して MAC アドレス アカウンティングを指定します。

ステップ 5

Router(config-if)# mtu bytes

(必要に応じて)インターフェイスの最大パケット サイズを指定します。

bytes ― パケットの最大バイト数を指定します。

デフォルト値は 1500 バイトです。

ステップ 6

Router(config-if)# standby [ group-number ] ip [ ip-address [ secondary ]]

(Hot Standby Router Protocol [HSRP] 設定の場合のみ必須)HSRP グループの番号および仮想 IP アドレスを使用して、HSRP グループを作成(またはイネーブルに)します。

(任意) group-number ― HSRP をイネーブルにするインターフェイスのグループ番号。指定できる範囲は 0 ~ 255 で、デフォルトは 0 です。HSRP グループが 1 つしかない場合は、グループ番号を入力する必要はありません。

(HSRP を設定する場合は、1 つのインターフェイスで必須、それ以外は任意) ip-address ― ホット スタンバイ ルータ インターフェイスの仮想 IP アドレス。少なくとも 1 つのインターフェイスに対して仮想 IP アドレスを入力する必要があります。入力した仮想 IP アドレスを他のインターフェイスで学習することができます。

(任意) secondary ― IP アドレスはセカンダリ ホット スタンバイ ルータ インターフェイスです。ルータがセカンダリ ルータとスタンバイ ルータのいずれにも指定されておらず、プライオリティも設定されていない場合は、プライマリ IP アドレスが比較され、IP アドレスが最も大きいルータがアクティブ ルータ、IP アドレスが 2 番めに大きいルータがスタンバイ ルータになります。

このコマンドは HSRP をイネーブルにしますが、それ以上の設定は行いません。HSRP の設定方法については、『 Cisco IOS Release 12.2 IP Configuration Guide 』の「 Configuring Hot Standby Routing Protocol 」の項を参照してください。

ステップ 7

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

インターフェイス アドレスの指定

SPA を使用するときのインターフェイス アドレスのフォーマットは、 slot / subslot / port です。

slot ― SPA を搭載した SIP が装着された Cisco 12000 シリーズ ルータのスロット番号を指定します。

subslot ― 選択する SPA が搭載された MSC 上のセカンダリ スロットを指定します。

port ― SPA 上の選択するインターフェイス番号を指定します。

Cisco 1 ポート 10 ギガビット イーサネット SPA では、0 しか指定できません。

5 ポート ギガビット イーサネット SPA では、0 ~ 4 の範囲で指定できます。

8 ポート ファスト イーサネット SPA では、0 ~ 7 の範囲で指定できます。

Cisco 10 ポート ギガビット イーサネット SPA では、0 ~ 9 の範囲で指定できます。

図5-1 に、Cisco 12000 シリーズ ルータ上の Cisco 10 ポート ギガビット イーサネット SPA のスロット、サブスロット、およびインターフェイス ポートの位置を示します。

図5-1 Cisco 10 ポート ギガビット イーサネット SPA と 1 ポート 10 ギガビット イーサネット SPA のスロット、サブスロット、およびポートの位置

 

 

表5-1 ギガビット イーサネット SPA のスロットとポートの位置

コール アウト番号
説明

1

スロット 3

2

サブスロット 0、ポート 3/0/0

3

サブスロット 1、ポート 3/1/0 ~ 3/1/9

Cisco 12000 ルータへのカードの取り付けの詳細については、『 Cisco 12000 SIP and SPA Hardware Installation Guide 』を参照してください。

インターフェイスの MAC アドレスの変更

ファスト イーサネットおよびギガビット イーサネット SPA は、ポートごとにデフォルト MAC アドレスを使用します。このアドレスは、Cisco 12000 シリーズ ルータのバックプレーン上にある Electrically Erasable Programmable Read-Only Memory(EEPROM; 電気的消去再書き込み可能 ROM)に格納された基本アドレスから取得されます。

インターフェイスのデフォルト MAC アドレスをユーザ定義アドレスに変更するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

Router(config-if)# mac-address ieee-address

インターフェイスのデフォルト MAC アドレスをユーザ定義アドレスに変更します。

ieee-address ― 48 ビットの IEEE(米国電気電子学会)MAC アドレスを、3 つの 4 桁 16 進数のドット形式で指定します( xxxx.yyyy.zzzz )。

インターフェイスのデフォルト MAC アドレスに戻すには、このコマンドの no 形式を使用します。

MAC アドレスの確認

インターフェイスの MAC アドレスを確認するには、 show interfaces gigabitethernet イネーブル EXEC コマンドを使用して、[address is] フィールドの値を調べます。

次に、Cisco 12000 シリーズ ルータのスロット 3 に搭載された SPA のインターフェイス 0 について、MAC アドレスが 0008.7db3.8dfe である場合の例を示します。

Router# show interfaces gigabitethernet 3/0/0
GigabitEthernet3/0/0 is up, line protocol is up
Hardware is GigMac 1 Port 10 GigabitEthernet, address is 0008.7db3.8dfe (bia )
Internet address is 10.0.0.2/24
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec, rely 255/255, load 1/255
Encapsulation ARPA, loopback not set
.
.
.

MAC アドレス アカウンティング統計情報の収集

ip accounting mac-address [ input | output ] コマンドを入力すると、インターフェイス上で MAC アドレス アカウンティングをイネーブルにできます。

MAC アドレス アカウンティングをイネーブルにしたら、 show interface mac コマンドを入力して、MAC アドレス統計情報を収集できます。

HSRP の設定

Hot Standby Router Protocol(HSRP)は、ファスト イーサネットおよびギガビット イーサネット SPA で使用できます。HSRP を使用すると、個々のルータのアベイラビリティに依存することなくホストから IP トラフィックがルーティングされるため、ネットワークのアベイラビリティが高まります。HSRPはルータ グループ内で、アクティブ ルータおよびスタンバイ ルータを選択する場合に使用されます(アクティブ ルータは、パケットをルーティングするために選択されるルータです。スタンバイ ルータは、アクティブ ルータが故障した場合、または設定条件が満たされた場合に、ルーティング処理を引き継ぐルータです)。

インターフェイス上で HSRP をイネーブルにするには、 standby [ group-number ] ip [ ip-address [ secondary ]] コマンドを使用します。 standby コマンドは、さまざまな HSRP 要素を設定する場合にも使用します。このマニュアルでは、複雑な HSRP 設定は扱いません。HSRP の設定方法については、『 Cisco IOS Release 12.2 IP Configuration Guide 』の「 Configuring Hot Standby Routing Protocol」の項を参照してください。

次の HSRP 設定では、ポート GigabitEthernet 2/1/0 のスタンバイ グループ 2 にプライオリティ 110 が設定されています。また、このポートにスイッチオーバーが発生した場合に、プリエンプティブな遅延が発生するように設定されています。

Router(config)# interface GigabitEthernet 2/1/0
Router(config-if)# standby 2 ip 120.12.1.200
Router(config-if)# standby 2 priority 110
Router(config-if)# standby 2 preempt

インターフェイスの MTU サイズの変更

Cisco IOS ソフトウェアは、プロトコル スタックのレベルに応じて、3 つの異なるタイプの設定可能な MTU オプションをサポートします。

インターフェイス MTU ― ネットワークから着信したトラフィックが、SPA によって調べられます。インターフェイス タイプごとに、サポートされるインターフェイス MTU サイズおよびデフォルト値は異なります。インターフェイス MTU は、廃棄される前にインターフェイスで受信可能な最大パケット サイズ(バイト数)を定義します。フレームがインターフェイス MTU サイズよりも小さく、インターフェイス タイプの最小フレーム サイズ(イーサネットの場合は 64 バイトなど)以上である場合、フレームの処理は継続されます。

IP MTU ― サブインターフェイスに設定できます。パケットを分割するかどうかを判別するために、Cisco IOS ソフトウェアで使用されます。IP パケットが IP MTU サイズを超過すると、パケットは分割されます。

タグまたは Multiprotocol Label Switching(MPLS;マルチプロトコル ラベル スイッチング)MTU ― サブインターフェイスに設定できます。最大 6 つの異なるラベル(タグ ヘッダー)をパケットに付加できます。ラベルの最大数は、Cisco IOS ソフトウェア リリースによって異なります。

カプセル化方式およびMPLS MTUラベル数に応じて、パケットに余分なオーバーヘッドが追加されます。たとえば、Subnetwork Access Protocol(SNAP)カプセル化の場合は 8 バイト ヘッダーが追加されますが、dot1q カプセル化の場合は 2 バイト ヘッダーが追加されます。また、MPLS ラベルごとに、4 バイト ヘッダーが追加されます(ラベル数 n × 4 バイト)。

Cisco 12000 シリーズ ルータ上のファスト イーサネットおよびギガビット イーサネット SPA では、デフォルトの MTU サイズは 1500 バイトです。設定可能な最大 MTU は 9216 バイトです。SPA は追加オーバーヘッドを格納できるように、設定された MTU サイズに 38 バイトを自動的に追加します。

インターフェイスMTUの設定時の注意事項

Cisco 12000 シリーズ ルータ上のファスト イーサネットまたはギガビット イーサネット SPA でインターフェイス MTU サイズを設定する場合は、次の注意事項を考慮してください。

デフォルトのインターフェイス MTU サイズは、1500 バイト パケットに、次に示す追加オーバーヘッドを格納するための追加の 38 バイトを加えた値です。

レイヤ 2 ヘッダー ― 14 バイト

SNAP ヘッダー ― 8 バイト

dot1q ヘッダー ― 4 バイト

2 個の MPLS ラベル ― 8 バイト

CRC ― 4 バイト


) ご使用のCisco IOSソフトウェア リリースに応じて、サポートされるMPLSラベルの最大数は異なります。3 つ以上の MPLS ラベルをサポートする必要がある場合は、SPA のインターフェイスのデフォルトのインターフェイス MTU サイズを増加させる必要があります。


MPLS を使用している場合は、 mpls mtu コマンドをインターフェイス MTU 以下の値に設定してください。

MPLS ラベルを使用している場合は、MPLS ラベルを格納できるように、デフォルトのインターフェイス MTU サイズを増加させる必要があります。MPLS ラベル数が 1 増えるごとに、パケットに 4 バイトのオーバーヘッドが追加されます。

インターフェイス MTU の設定作業

インターフェイスの MTU サイズを変更するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

Router(config-if)# mtu bytes

インターフェイスの最大パケット サイズを設定します。

bytes ― パケットの最大バイト数を指定します。

デフォルト値は 1500 バイトです。

デフォルトの MTU サイズに戻すには、このコマンドの no 形式を使用します。

MTU サイズの確認

インターフェイスの MTU サイズを確認するには、 show interfaces fastethernet show interfaces gigabitethernet 、または show interfaces tengigabitethernet イネーブル EXEC コマンドを使用して、[MTU] フィールドの値を調べます。

次に、Cisco 12000 シリーズ ルータのスロット 3 に MSC が搭載され、その上部サブスロット(0)にギガビット イーサネット SPA が搭載されている場合、この SPA のインターフェイス ポート 0(1 番めのポート)の MTU サイズが 1500 バイトである例を示します。

Router# show interfaces gigabitethernet 3/0/0
GigabitEthernet3/0/0 is up, line protocol is up
Hardware is GigMac 1 Port 10 GigabitEthernet, address is 0008.7db3.8dfe (bia )
Internet address is 10.0.0.2/24
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec, rely 255/255, load 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 10000Mbps, link type is autonegotiation, media type is T
output flow-control is on, input flow-control is on
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
Available Bandwidth 10000000 kilobits/sec
30 second input rate 0 bits/sec, 0 packets/sec
30 second output rate 0 bits/sec, 0 packets/sec
11 packets input, 1154 bytes, 0 no buffer
Received 1 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
67 packets output, 20951 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

カプセル化タイプの設定

Cisco 1 ポート 10 ギガビット イーサネット SPA、5 ポート ギガビット イーサネット SPA、8 ポート ファスト イーサネット SPA、および Cisco 10 ポート ギガビット イーサネット SPA のインターフェイスは、デフォルトで Advanced Research Projects Agency(ARPA)カプセル化をサポートします。これらのインターフェイスでは、フレームを送信するために Service Access Point(SAP;サービス アクセス ポイント)または SNAP カプセル化を設定することはできません。ただし、SAP および SNAP カプセル化を使用するフレームは正常に受信されます。

SPA インターフェイスでサポートされるその他のカプセル化方式は、VLAN(仮想 LAN)の場合、IEEE 802.1Q カプセル化のみです。

インターフェイスの自動ネゴシエーションの設定

イーサネット インターフェイスは、 自動ネゴシエーション と呼ばれる接続設定アルゴリズムを使用します。ローカルおよびリモート デバイスは自動ネゴシエーションを使用して、リンクを介した通信設定の互換性を保つことができます。各デバイスは自動ネゴシエーションを使用して送信機能をアドバタイズし、リンクで使用する設定について合意します。

Cisco 12000 シリーズ ルータのファスト イーサネットおよびギガビット イーサネット インターフェイスでは、自動ネゴシエーションがイネーブル化されていると、フロー制御の自動ネゴシエーションが行われます。10 ギガビット イーサネット インターフェイスでは、自動ネゴシエーションは実行できません。

自動ネゴシエーションに関して、次の注意事項に従う必要があります。

リンクの一端で自動ネゴシエーションがディセーブルである場合は、リンクの反対側でもディセーブルにする必要があります。リンクの一端で自動ネゴシエーションがディセーブルであるにもかかわらず、反対側でイネーブルである場合、リンクは両端で適切に起動しません。

フロー制御はデフォルトでイネーブルです。

自動ネゴシエーションがリンク両端でディセーブルな場合、フロー制御は有効です。

自動ネゴシエーションのディセーブル化

自動ネゴシエーションは、自動的にイネーブルになります。自動ネゴシエーション中に、フロー制御がアドバタイズされます。自動ネゴシエーションがディセーブル化されたリンクにファスト イーサネットまたはギガビット イーサネット インターフェイスが接続されている場合は、リンクの反対側で自動ネゴシエーションを再びイネーブルにするか、ファスト イーサネットまたはギガビット イーサネット SPA で自動ネゴシエーションをディセーブルにする必要があります。リンクの一端でのみ自動ネゴシエーションがディセーブルになっている場合は、リンクの両端が適切に起動しません。

ファスト イーサネットまたはギガビット イーサネット インターフェイスで自動ネゴシエーションをディセーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

Router(config-if)# no negotiation auto

ギガビット イーサネット SPA インターフェイスで自動ネゴシエーションをディセーブルにします。フロー制御はアドバタイズされません。

自動ネゴシエーションのイネーブル化

自動ネゴシエーションは、自動的にイネーブルになります。自動ネゴシエーション中に、フロー制御のアドバタイズと設定が実行されます。ファスト イーサネットまたはギガビット イーサネット インターフェイスで自動ネゴシエーションを再イネーブル化するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

Router(config-if)# negotiation auto

ギガビット イーサネット SPA インターフェイスで自動ネゴシエーションをイネーブルにします。フロー制御がアドバタイズされます。

VLAN でのサブインターフェイスの設定

VLAN で Cisco 1 ポート 10 ギガビット イーサネット SPA、5 ポート ギガビット イーサネット SPA、8 ポート ファスト イーサネット SPA、および Cisco 10 ポート ギガビット イーサネット SPA のサブインターフェイスを設定するには、IEEE 802.1Q カプセル化を使用します。


) Cisco 10 ポート ギガビット イーサネット SPA では、Inter-Switch Link(ISL; スイッチ間リンク)カプセル化はサポートされていません。


VLAN の SPA サブインターフェイスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

ステップ 1

Router(config)# interface fastethernet slot / subslot / port . subinterface-number

または

Router(config)# interface gigabitethernet slot / subslot / port . subinterface-number

または

Router(config)# interface tengigabitethernet slot / subslot / port . subinterface-number

設定するファスト イーサネット、ギガビット イーサネット、または 10 ギガビット イーサネット インターフェイスを指定します。

slot / subslot / port ― インターフェイスの位置を指定します。「インターフェイス アドレスの指定」を参照してください。

. subinterface-number ― セカンダリ インターフェイス(サブインターフェイス)番号を指定します。

ステップ 2

Router(config-subif)# encapsulation dot1q vlan-id

カプセル化フォーマットを IEEE 802.1Q(「dot1q」)として定義します。 vlan-id は VLAN の番号(1 ~ 4095)です。

ステップ 3

Router(config-if)# ip address ip-address mask [ secondary ]

インターフェイスのプライマリまたはセカンダリ IP アドレスを設定します。

ip-address ― インターフェイスの IP アドレスを指定します。

mask ― 関連付けられた IP サブネットのマスクを指定します。

secondary ― (任意)設定されたアドレスがセカンダリ IP アドレスになるように指定します。このキーワードを省略すると、設定されたアドレスはプライマリ IP アドレスとなります。

VLAN のサブインターフェイス設定の確認

VLAN のサブインターフェイスの設定およびステータスを確認するには、 show vlans イネーブル EXEC コマンドを使用します。

次に、VLAN 番号 200 の SPA 上にあるポート 0 のサブインターフェイス番号 1 のステータスについて例を示します。

Router# show vlans
VLAN ID:200 (IEEE 802.1Q Encapsulation)
 
Protocols Configured: Received: Transmitted:
IP 0 14
 
VLAN trunk interfaces for VLAN ID 200:
 
GigabitEthernet4/1/0.1 (200)
 
IP:12.200.21.21
 
Total 0 packets, 0 bytes input
Total 2 packets, 120 bytes output

リンクのフロー制御サポートの設定

フロー制御は、自動ネゴシエーションの結果に基づいてオンまたはオフになります。このプロセスの詳細については、「インターフェイスの自動ネゴシエーションの設定」を参照してください。

フロー制御ステータスの確認

SPA 上のファスト イーサネットまたはギガビット イーサネット インターフェイスのフロー制御ステータスを確認するには、 show interfaces fastethernet show interfaces gigabitethernet 、または show interfaces tengigabitethernet イネーブル EXEC コマンドを使用し、[output flow-control is] および [input flow-control is] 出力行を表示して、入出力フロー制御がオンになっているか、またはオフになっているかを確認します。このコマンド出力の [pause input] および [pause output] カウンタは、インターフェイスで送受信されるポーズ フレーム数を表示する場合に使用できます。

次に、Cisco 12000 シリーズ ルータのスロット 3 に MSC が搭載され、そのサブスロット 0 に SPA が搭載されている場合に、SPA のインターフェイス ポート 3(4 番めのポート)の MAC デバイスで送受信されたポーズ フレーム数がゼロである例を示します。

Router# show interfaces gigabitethernet 3/0/3
GigabitEthernet3/0/3 is up, line protocol is up
Hardware is GigabitEthernet, address is 0008.7db3.8e01 (bia 0008.7db3.8e01)
Internet address is 13.0.0.2/24
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, rely 255/255, load 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1000Mbps, link type is autonegotiation, media type is T
output flow-control is on, input flow-control is on
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:09, output 00:00:09, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
Available Bandwidth 1000000 kilobits/sec
30 second input rate 0 bits/sec, 0 packets/sec
30 second output rate 0 bits/sec, 0 packets/sec
5 packets input, 520 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
26 packets output, 8286 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

設定の保存

実行コンフィギュレーションを NVRAM(不揮発性 RAM)に保存するには、イネーブル EXEC コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

Router# copy running-config startup-config

新しい設定を NVRAM に書き込みます。

コンフィギュレーション ファイルの管理方法については、『 Cisco IOS Configuration Fundamentals Configuration Guide 』 Release 12.0 および『 Cisco IOS Configuration Fundamentals Command Reference 』 Release 12.0 を参照してください。

SPA でのインターフェイスのシャットダウンおよび再起動

SPA の任意のインターフェイス ポートを個別にシャットダウンしたり、再起動したりすることができます。インターフェイスをシャットダウンすると、トラフィックが停止し、インターフェイスは「管理上のダウン」ステートになります。

SPA の Online Insertion and Removal(OIR; ホットスワップ)の準備を行っている場合は、SPA を非アクティブにする前に、各インターフェイスを個別にシャットダウンする必要はありません。 hw-module subslot shutdown コマンドを使用すると、インターフェイスのトラフィックは自動的に停止し、SPA とともにインターフェイスが非アクティブになって、OIR を実行できるようになります。

同様に、SPA または MSC の OIR 後に、SPA のインターフェイスを個別に再起動する必要はありません。

SPA のインターフェイスをシャットダウンするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

Router(config-if)# shutdown

インターフェイスをディセーブルにします。

SPA のインターフェイスを再起動するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
説明

Router(config-if)# no shutdown

ディセーブル化されたインターフェイスを再起動します。

インターフェイスの設定の確認

show running-configuration コマンドを使用してルータ設定を表示するだけでなく、 show interfaces gigabitethernet コマンドを使用して Cisco 1 ポート 10 ギガビット イーサネット SPA、5 ポート ギガビット イーサネット SPA、および Cisco 10 ポート ギガビット イーサネット SPA の詳細をポートごとに表示することもできます。8 ポート ファスト イーサネット SPA の場合、 show interfaces fastethernet を実行すると、ポートごとの詳細情報を収集できます。

ポート単位のインターフェイス ステータスの確認

ファスト イーサネットまたはギガビット イーサネット SPA についてインターフェイスの詳細情報をポートごとに確認するには、 show interfaces fastethernet show interfaces gigabitethernet 、または show interfaces tengigabitethernet コマンドを使用します。コマンド出力の説明については、「SIP および SPA コマンド リファレンス」を参照してください。

次に、Cisco 12000 シリーズ ルータのスロット 3 に MSC が搭載され、その上部サブスロット(0)にギガビット イーサネット SPA が搭載されている場合について、SPA のインターフェイス ポート 0 の出力例を示します。

Router# show interfaces gigabitethernet 3/0/0
GigabitEthernet3/0/0 is up, line protocol is up
Hardware is GigMac 1 Port 10 GigabitEthernet, address is 0008.7db3.8dfe (bia )
Internet address is 10.0.0.2/24
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec, rely 255/255, load 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 10000Mbps, link type is autonegotiation, media type is T
output flow-control is on, input flow-control is on
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
Available Bandwidth 10000000 kilobits/sec
30 second input rate 0 bits/sec, 0 packets/sec
30 second output rate 0 bits/sec, 0 packets/sec
11 packets input, 1154 bytes, 0 no buffer
Received 1 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
67 packets output, 20951 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
 

次に、Cisco 12000 シリーズ ルータのスロット 7 に MSC が搭載され、その上部サブスロット(0)にファスト イーサネット SPA が搭載されている場合について、SPA のインターフェイス ポート 0 の出力例を示します。

Router# show interfaces fastethernet 7/0/0
FastEthernet7/0/0 is administratively down, line protocol is down
Hardware is FastEthernet, address is 0000.001c.a400 (bia 0000.001c.a400)
MTU 1500 bytes, BW 100000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 100Mbps, link type is autonegotiation, media type is 100BaseTx
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
Available Bandwidth 100000 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
0 packets output, 0 bytes, 0 underruns
Transmitted 0 broadcasts
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

 

設定例

ここでは、次の設定例を示します。

「基本的なインターフェイス設定例」

「MAC アドレスの設定例」

「MTU の設定例」

「VLAN の設定例」

基本的なインターフェイス設定例

次に、グローバル コンフィギュレーション モードを開始し、設定するインターフェイスを指定し、インターフェイスに IP アドレスを設定して、設定を保存する例を示します。ここでは、Cisco 12000 シリーズ ルータのスロット 3 に MSC が搭載され、そのサブスロット 0 に SPA が搭載されている場合に、SPA のインターフェイス ポート 0 を設定する例を示します。

!Enter global configuration mode

!

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

!

! Specify the interface address

!

Router(config)# interface gigabitethernet 3/0/1

!

! Configure an IP address

!

Router(config-if)# ip address 192.168.50.1 255.255.255.0

!

! Start the interface

!

Router(config-if)# no shut

!

! Save the configuration to NVRAM

!

Router(config-if)# exit

Router# copy running-config startup-config

 

次に、ポートの設定が同じで IPv6 アドレスが使用されている場合の例を示します。

!Enter global configuration mode

!

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

!

!Enable IPv6 Routing

!

Router(config)#

!

! Specify the interface address

!

Router(config)# interface gigabitethernet 3/0/1

!

! Configure an IP address

!

Router(config-if)# ipv6 address 2001:10::1/64
Router(config-if)# ipv6 address FEC0:11:1001:11::1/64

!

! Start the interface

!

Router(config-if)# no shut

!

! Save the configuration to NVRAM

!

Router(config-if)# exit

Router# copy running-config startup-config

 

MAC アドレスの設定例

次に、インターフェイスのデフォルト MAC アドレスを 1111.2222.3333 に変更する例を示します。

!Enter global configuration mode

!

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

!

! Specify the interface address

!

Router(config)# interface gigabitethernet 3/0/1

!

! Modify the MAC address

!

Router(config-if)# mac-address 1111.2222.3333

MTU の設定例

次に、インターフェイス MTU を 9216 バイトに設定する例を示します。


) SPA では、設定されたインターフェイス MTU サイズに 36 バイトが自動的に追加されます。


!Enter global configuration mode

!

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

!

! Specify the interface address

!

Router(config)# interface gigabitethernet 3/0/1

!

! Configure the interface MTU

!

Router(config-if)# mtu 9216

 

VLAN の設定例

次に、SPA のインターフェイス ポート 2(3 番めのポート)にサブインターフェイス番号 268 を作成し、IEEE 802.1Q カプセル化を使用して、ID 番号 269 の VLAN でサブインターフェイスを設定する例を示します。


) SPA では、ISL カプセル化はサポートされません。


!Enter global configuration mode

!

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

!

! Specify the interface address

!

Router(config)# interface gigabitethernet 3/0/1.268

!

! Configure dot1q encapsulation and specify the VLAN ID

!

Router(config-subif)# encapsulation dot1q 268