Cisco 10000 シリーズ ルータ Line Card コンフィギュレーション ガイド
設定例
設定例
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

設定例

例 1:非チャネライズド サブレート T3 ポート、ポイント ツー マルチポイント フレームリレー、および OSPF

例 2:OSPF、BGP、チャネライズド フルレート T1

例 3:QPPB

例 4:MPLS VPN

設定例

この章では、Cisco 10000 シリーズ ルータの Cisco IOS Command Line Interface(CLI; コマンドライン インターフェイス)の設定例を示します。各例で使用されているコマンドは、IOS CLI で入力します。

この章では、次の例を示します。

「例 1:非チャネライズド サブレート T3 ポート、ポイント ツー マルチポイント フレームリレー、および OSPF」

「例 2:OSPF、BGP、チャネライズド フルレート T1」

「例 3:QPPB」

「例 4:MPLS VPN」

例 1:非チャネライズド サブレート T3 ポート、ポイント ツー マルチポイント フレームリレー、および OSPF

この例では、以下を実行するために必要なコマンド シーケンスを示します。

「非チャネライズド T3 コントローラの設定」

「サブレート T3 の設定」

「フレームリレー カプセル化の設定」

「ポイント ツー マルチポイント フレームリレーの設定」

「OSPF ルーティング プロセスの作成」

CLI コマンド シーケンスで前提となるのは、特権 EXEC プロンプトで開始するということです。CLI テキストに挿入された説明用見出しは、ハードウェアまたは機能がイネーブルであることを示します。

Router# config terminal
Enter configuration commands, one per line.End with CNTL/Z.
Router(config)# ip routing
Router(config)# !
 

非チャネライズド T3 コントローラの設定

非チャネライズド T3 コントローラを設定し、クロック ソースを指定します。

Router(config)# controller T3 1/0/0
Router(config)# no channelized
Router(config-controller)# clock source line
Router(config-controller)# end
 

サブレート T3 の設定

T3 ポートにサブレート 25,000 kbps を設定します。

Router(config)# interface Serial1/0/0/1:0
Router(config-if)# no ip address
Router(config-if)# no ip directed broadcast
Router(config-if)# dsu bandwidth 25000
Router(config-if)# dsu mode <dsu type>
 

フレームリレー カプセル化の設定

インターフェイス Serial 1/0/0/1:0 にフレームリレー カプセル化を設定します。

Router(config-if)# encapsulation frame-relay
Router(config-if)# frame-relay lmi-n391dte 6
Router(config-if)# keepalive 10
Router(config-if)# frame-relay lmi-n392dte 3
Router(config-if)# frame-relay lmi-n393dte 4
Router(config-if)# no shutdown
Router(config-if)# ip address 20.0.0.1 255.255.255.0
 

ポイント ツー マルチポイント フレームリレーの設定

ルータ 1 との通信に DLCI 101、ルータ 2 との通信に DLCI 102 を使用するように Cisco 10000 シリーズ ルータを設定します。

Router(config-if)# ip ospf network point-to-multipoint
Router(config-if)# frame-relay map ip 20.0.0.2 101 broadcast
Router(config-if)# frame-relay map ip 20.0.0.3 102 broadcast
Router(config-if)# no shutdown
 

OSPF ルーティング プロセスの作成

OSPF ルーティング プロセス 100 をイネーブルにします。OSPF が稼働するインターフェイス、およびそのインターフェイスのエリア ID を定義します。

Router(config-if)# router ospf 100
Router(config-router)# network 20.0.0.0 0.255.255.255 area 0
Router(config-router)# end
 

例 2:OSPF、BGP、チャネライズド フルレート T1

この例では、以下を実行するために必要なコマンド シーケンスを示します。

「ギガビット イーサネット アップリンク ポートの作成」

「T3 コントローラの作成」

「フルレート チャネライズド T1 インターフェイスの作成」

「フレームリレー カプセル化の設定」

「OSPF ルーティング プロセスのイネーブル化」

「OSPF ルート再配布のイネーブル化」

「AS 間でルートを再配布するための BGP 設定」

次に示す CLI コマンド シーケンスで前提となるのは、特権 EXEC プロンプトで開始するということです。CLI テキストに挿入された説明用見出しは、ハードウェアまたは機能がイネーブルであることを示します。

Router# config terminal
Enter configuration commands, one per line.End with CNTL/Z.
 

ギガビット イーサネット アップリンク ポートの作成

動作可能なギガビット イーサネット カードをプロビジョニングします。

Router(config)# interface GigabitEthernet8/0/0
Router(config-if)# ip address 125.1.1.2 255.255.255.0
Router(config-if)# keepalive
Router(config-if)# no shutdown
Router(config-if)# end
Router# config terminal
Enter configuration commands, one per line.End with CNTL/Z.
Router(config)# ip routing
 

T3 コントローラの作成

CT3 ライン カードで機能する T3 コントローラをイネーブルにします。

Router(config)# controller T3 1/0/0
Router(config-controller)# clock source line
 

フルレート チャネライズド T1 インターフェイスの作成

チャネライズド フルレート T1 を設定します。

Router(config-controller)# t1 1 channel-group 0 timeslots 1-24
Router(config-controller)# t1 1 clock source Line
Router(config-controller)# interface Serial1/0/0/1:0
Router(config-if)# no ip address
 

フレームリレー カプセル化の設定

フレームリレー カプセル化をイネーブルにし、フレームリレー サブインターフェイスを作成し、デフォルト LMI タイプを指定します。

Router(config-if)# encapsulation frame-relay
Router(config-if)# frame-relay lmi-n391dte 6
Router(config-if)# keepalive 10
Router(config-if)# frame-relay lmi-n392dte 3
Router(config-if)# frame-relay lmi-n393dte 4
Router(config-if)# no shutdown
Router(config-if)# interface Serial1/0/0/1:0.100 point-to-point
Router(config-subif)# ip address 128.1.1.2 255.255.255.0
Router(config-subif)# frame-relay interface-dlci 100
Router(config-fr-dlci)# no shutdown
Router(config-if)# end
Router# config terminal
Enter configuration commands, one per line.End with CNTL/Z.
 

OSPF ルーティング プロセスのイネーブル化

OSPF ルーティング プロセス 200 を作成し、ルーティング プロセスに対応付ける IPアドレス範囲を指定し、IP アドレス範囲に対応付けるエリア ID を割り当てます。

Router(config)# router ospf 200
Router(config-router)# network 125.1.1.0 0.0.0.255 area 0
 

OSPF ルート再配布のイネーブル化

BGP を介したルート再配布をイネーブルにします。

Router(config-router)# redistribute bgp 200 subnets
 

AS 間でルートを再配布するための BGP 設定

BGP をイネーブルにし(先頭行)、AS 300 のネイバを定義します(2 番めの行)。 network コマンドは、BGP テーブルに OSPF ルートを挿入する場合の挿入元ネットワークを定義します。

Router(config-router)# router bgp 200
Router(config-router)# neighbor 128.1.1.1 remote-as 300
Router(config-router)# network 125.0.0.0
Router(config-router)# end
Router# config terminal
Enter configuration commands, one per line.End with CNTL/Z.
Router(config)# router bgp 200
Router(config-router)# network 130.1.0.0
Router(config-router)# end
Router# config terminal
Enter configuration commands, one per line.End with CNTL/Z.
Router(config)# router bgp 200
Router(config-router)# network 130.2.0.0
Router(config-router)# end
Router# config terminal
Enter configuration commands, one per line.End with CNTL/Z.
Router(config)# router bgp 200
Router(config-router)# network 130.3.0.0
Router(config-router)# end
Router# config terminal
Enter configuration commands, one per line.End with CNTL/Z.
Router(config)# router bgp 200
Router(config-router)# network 130.4.0.0
Router(config-router)# end
Router# config terminal
Enter configuration commands, one per line.End with CNTL/Z.
Router(config)# router bgp 200
Router(config-router)# network 130.5.0.0
Router(config-router)# end
Router#
 

例 3:QPPB

QoS Policy Propagation using Border Gateway Protocol(QPPB; BGP による QoS ポリシー伝達)を使用すると、BGP コミュニティ リスト、BGP AS パス、およびアクセス リストに基づいて、IP precedence 別にパケットを分類することができます。パケットを分類したら、Committed Access Rate(CAR; 専用アクセス レート)や Weighted Random Early Detection(WRED; 重み付けランダム早期検出)など、その他の Quality of Service(QoS)機能を使用して、ビジネス モデルに適合するポリシーを指定し、実行することができます。

次に、以下の処理を実行する例を示します。

1. BGP コミュニティ リスト、アクセス リスト、および BGP AS パスと一致するルート マップを作成します。

2. ネイバから取得されたルートに IP precedence を適用します。

この例では、Cisco 10000 シリーズ ルータは AS 10 および AS 60 からルートを取得します。QoS ポリシーは、定義されたルート マップと一致するすべてのパケットに適用されます。Cisco 10000 シリーズ ルータから AS 10 または AS 60 に宛てたすべてのパケットは、該当する QoS ポリシーに送信されます(図18-1)。

図18-1 Cisco 10000 シリーズ ルータのルートおよび QoS ポリシー適用

 

Cisco 10000 シリーズ ルータの設定

Router(config)# router bgp 30
Router(config)# table-map precedence-map
Router(config-router)# neighbor 20.20.20.1 remote-as 10
Router(config-router)# neighbor 20.20.20.1 send-community
Router(config-router)# neigh 20.20.20.1 route-map precedence-map out
!
Router(config)# ip bgp-community new-format
 

コミュニティ 1 を照合し、IP precedence を priority に設定し、QoS グループを 1 に設定します。

Router(config)# route-map precedence-map permit 10
Router(config-route-ma)# match community 1
Router(config-route-ma)# set ip precedence priority
Router(config-route-ma)# set ip qos-group 1
 

コミュニティ 2 を照合し、IP precedence を immediate に設定します。

Router(config)# route-map precedence-map permit 20
Router(config-route-ma)# match community 2
Router(config-route-ma)# set ip precedence immediate
 

コミュニティ 3 を照合し、IP precedence を flash に設定します。

Router(config)# route-map precedence-map permit 30
Router(config-route-ma)# match community 3
Router(config-route-ma)# set ip precedence flash
 

コミュニティ 4 を照合し、IP precedence を flash-override に設定します。

Router(config)# route-map precedence-map permit 40
Router(config-route-ma)# match community 4
Router(config-route-ma)# set ip precedence flash-override
 

コミュニティ 5 を照合し、IP precedence を critical に設定します。

Router(config)# route-map precedence-map permit 50
Router(config-route-ma)# match community 5
Router(config-route-ma)# set ip precedence critical
 

コミュニティ 6 を照合し、IP precedence を internet に設定します。

Router(config)# route-map precedence-map permit 60
Router(config-route-ma)# match community 6
Router(config-route-ma)# set ip precedence internet
 

コミュニティ 7 を照合し、IP precedence を network に設定します。

Router(config)# route-map precedence-map permit 70
Router(config-route-ma)# match community 7
Router(config-route-ma)# set ip precedence network
 

IP アドレス アクセス リスト 69 または AS パス 1 を照合し、IP precedence を critical に設定し、QoS グループを 9 に設定します。

Router(config)# route-map precedence-map permit 75
Router(config-route-ma)# match ip address 69
Router(config-route-ma)# match as-path 1
Router(config-route-ma)# set ip precedence critical
Router(config-route-ma)# set ip qos-group 9
 

その他の場合は、IP precedence を routine に設定します。

Router(config)# route-map precedence-map permit 80
Router(config-route-ma)# set ip precedence routine
 

コミュニティ リストを定義します。

Router(config)# ip community-list 1 permit 60:1
Router(config)# ip community-list 2 permit 60:2
Router(config)# ip community-list 3 permit 60:3
Router(config)# ip community-list 4 permit 60:4
Router(config)# ip community-list 5 permit 60:5
Router(config)# ip community-list 6 permit 60:6
Router(config)# ip community-list 7 permit 60:7
 

AS パスを定義します。

Router(config)# ip as-path access-list 1 permit ^10_60
 

アクセス リストを定義します。

Router(config)# access-list 69 permit 69.0.0.0
 

ルータ B の実行コンフィギュレーション

RouterB(config)# router bgp 10
RouterB(config-router)# neighbor 30.30.30.1 remote-as 30
RouterB(config-router)# neighbor 30.30.30.1 send-community
RouterB(config-router)# neigh 30.30.30.1 route-map send_community out
!
RouterB(config)# ip bgp-community new-format
 

プレフィクス 10 を照合し、コミュニティを 60:1 に設定します。

RouterB(config)# route-map send_community permit 10
RouterB(config-route-ma)# match ip address 10
RouterB(config-route-ma)# set community 60:1
 

プレフィクス 20 を照合し、コミュニティを 60:2 に設定します。

RouterB(config)# route-map send_community permit 20
RouterB(config-route-ma)# match ip address 20
RouterB(config-route-ma)# set community 60:2
 

プレフィクス 30 を照合し、コミュニティを 60:3 に設定します。

RouterB(config)# route-map send_community permit 30
RouterB(config-route-ma)# match ip address 30
RouterB(config-route-ma)# set community 60:3
 

プレフィクス 40 を照合し、コミュニティを 60:4 に設定します。

RouterB(config)# route-map send_community permit 40
RouterB(config-route-ma)# match ip address 40
RouterB(config-route-ma)# set community 60:4
 

プレフィクス 50 を照合し、コミュニティを 60:5 に設定します。

RouterB(config)# route-map send_community permit 50
RouterB(config-route-ma)# match ip address 50
RouterB(config-route-ma)# set community 60:5
 

プレフィクス 60 を照合し、コミュニティを 60:6 に設定します。

RouterB(config)# route-map send_community permit 60
RouterB(config-route-ma)# match ip address 60
RouterB(config-route-ma)# set community 60:6
 

プレフィクス 70 を照合し、コミュニティを 60:7 に設定します。

RouterB(config)# route-map send_community permit 70
RouterB(config-route-ma)# match ip address 70
RouterB(config-route-ma)# set community 60:7
 

その他すべての場合で、コミュニティを 60:8 に設定します。

RouterB(config)# route-map send_community permit 80
RouterB(config-route-ma)# set community 60:8
 

アクセス リストを定義します。

RouterB(config)# access-list 10 permit 61.0.0.0
RouterB(config)# access-list 20 permit 62.0.0.0
RouterB(config)# access-list 30 permit 63.0.0.0
RouterB(config)# access-list 40 permit 64.0.0.0
RouterB(config)# access-list 50 permit 65.0.0.0
RouterB(config)# access-list 60 permit 66.0.0.0
RouterB(config)# access-list 70 permit 67.0.0.0
 

次に、IP precedence および QoS グループ ID に基づいてパケットを分類するように、複数のインターフェイスを設定する例を示します。

interface serial5/0/0/1:0
ip address 200.28.38.2 255.255.255.0
bgp-policy source ip-prec-map
no ip mroute-cache
no cdp enable
frame-relay interface-dlci 20 IETF
 
interface serial6/0/0/1:0
ip address 200.28.28.2 255.255.255.0
bgp-policy source qos-group
no ip mroute-cache
no cdp enable
frame-relay interface-dlci 20 IETF
 

例 4:MPLS VPN

MPLS を使用すると、IP ベース Virtual Private Network(VPN; バーチャル プライベート ネットワーク)を作成できます。MPLS VPN には、コスト削減やセキュリティ強化を含む、従来の VPN の機能がすべて備わっています。また、MPLS VPN はレイヤ 3 に作成されるため、レイヤ 2 VPN よりもスケーラビリティが高まり、設定や管理が簡単になります。

MPLS VPN を設定するには、ここに記載されたタスクを実行します。

ここでは、次の処理の例を示します。

VPN の定義

BGP ルーティング セッションの設定

PE 間ルーティング セッションの設定

BGP PE/CE 間ルーティング セッションの設定

RIP PE/CE 間ルーティング セッションの設定

スタティック ルートの PE/CE 間ルーティング セッションの設定

VPN の定義

VRF コンフィギュレーション モードを開始し、VRF 名を割り当てて VPN ルーティング インスタンスを定義し、ルーティングおよび転送テーブルを作成します。

Router(config)# ip vrf go_fast_internet_company
Router(config-vrf)# rd 200.28.28.40:42
 

指定された VRFに、インポートまたはエクスポート ルート ターゲット コミュニティ リストを作成します。

Router(config-vrf)# route-target import 200.28.28.40:43
 

指定された ルート マップに、VRF、およびインターフェイスまたはサブインターフェイスを対応付けます。

Router(config-vrf)# import map go_fast
Router(config-if)# ip vrf forwarding go_fast_internet_company
 

BGP ルーティング セッションの設定

プロバイダー ネットワーク内に BGP ルーティング セッションを設定するには、PE ルータのルータ コンフィギュレーション モードで次のコマンドを使用します。

BGP ルーティング プロセスに AS 番号を設定します。

Router(config)# router bgp 42
 

ネイバのIP アドレスまたは BGPピア グループを指定し、ローカル AS に対してこれらを識別します。

Router(config-router)# neighbor 200.28.28.40
 

IPv4 アドレス ファミリのアドバタイズメントをアクティブにします。

Router(config-router)# neighbor 200.28.28.40 activate
 

PE 間ルーティング セッションの設定

プロバイダー ネットワーク内に PE 間ルーティング セッションを設定するには、PE ルータで、ルータ コンフィギュレーション モードで次のコマンドを使用します。

VPNv4 Network-Layer Reachability Information(NLRI; ネットワーク レイヤ到着可能性情報)を交換するための IBGP パラメータを定義します。

Router(config-router)# address-family vpnv4 unicast
 

VPNv4 NLRI を交換するための IBGP セッションを定義します。

Router(config-router-af)# neighbor 200.28.28.45 remote-as 48
Router(config-router-af)# exit
 

IPv4アドレス ファミリーのアドバタイズメントをアクティブにします。

Router(config-router)# neighbor 200.28.28.45 activate
 

BGP PE/CE 間ルーティング セッションの設定

BGP PE/CE 間ルーティング セッションを設定するには、PE ルータのルータ コンフィギュレーション モードで次のコマンドを使用します。

PE/CE 間ルーティング セッションの EBGP パラメータを定義します。

Router(config-router)# address-family ipv4 unicast vrf go_fast_internet_company
 

PE/CE ルータ間の EBGP セッションを定義して、IPv4 アドレス ファミリーのアドバタイズメントをアクティブにします。

Router(config-router-af)# neighbor 200.28.28.46 remote-as 49
Router(config-router-af)# neighbor 200.28.28.46 activate
 

RIP PE/CE 間ルーティング セッションの設定

RIP PE/CE 間ルーティング セッションを設定するには、PE ルータのルータ コンフィギュレーション モードで次のコマンドを使用します。

RIP をイネーブルにし、PE/CE ルーティング セッションの RIP パラメータを定義し、PE/CE リンクで RIP をイネーブルにします。

Router(config)# router rip
Router(config-router)# address-family ipv4 unicast vrf go_fast_internet_company
Router(config-router-af)# network 200.28.28.47
 

スタティック ルートの PE/CE 間ルーティング セッションの設定

スタティック ルートの PE/CE 間ルーティング セッションを設定するには、PE ルータのルータ コンフィギュレーション モードで次のコマンドを使用します。

各 PE /CE 間セッションおよび各 BGP PE/CE ルーティング セッションのスタティック ルート パラメータを定義します。

Router(config)# ip route vrf go_fast_internet_company 200.28.28.46 255.255.255.0 200.28.28.50

 

Router(config-router)# address-family ipv4 unicast vrf go_fast_internet_company

 

VRF スタティック ルートおよび直接接続されたネットワークを VRF BGP テーブルに再配布します。

Router(config-router-af)# redistribute static
Router(config-router-af)# redistribute static connected