Cisco 10000 シリーズ ルータ ソフトウェア コンフィギュレーション ガイド
PPPoEoE および PPPoE over IEEE 802.1Q VLAN の設定
PPPoEoE および PPPoE over IEEE 802.1Q VLAN の設定
発行日;2012/02/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

PPPoEoE および PPPoE over IEEE 802.1Q VLAN の設定

PPPoEoE

PPPoEoE 機能の履歴

PPPoEoE の制約事項

PPPoEoE の設定作業

バーチャル テンプレート インターフェイスの設定

イーサネット インターフェイスの作成および PPPoE のイネーブル化

VPDN グループを使用した PPPoE の設定

BBA グループを使用した PPPoE の設定

PPPoEoE の設定例

PPPoE のスタティックな MAC アドレス

PPPoE のスタティック MAC アドレス機能の履歴

PPPoE over IEEE 802.1Q VLAN

PPPoE over IEEE 802.1Q VLAN 機能の履歴

PPPoE over IEEE 802.1Q VLAN の制約事項

PPPoE over IEEE 802.1Q VLAN の設定作業

バーチャル テンプレート インターフェイスの設定

イーサネット 802.1Q カプセル化サブインターフェイスの作成および PPPoE のイネーブル化

VPDN グループを使用した PPPoE の設定

BBA グループを使用した PPPoE の設定

PPPoE over IEEE 802.1Q VLAN の設定例

PPPoEoE および PPPoE over IEEE 802.1Q VLAN の確認

PPPoE セッションの削除

TCP MSS の調整

TCP MSS 調整の機能履歴

TCP MSS 調整について

TCP MSS 調整の制約事項

TCP MSS 調整の設定作業

TCP MSS 調整の設定例

VLAN レンジ

VLAN レンジ機能の履歴

VLAN レンジの制約事項

VLAN 範囲の設定作業

VLAN サブインターフェイス範囲の設定

VLAN 範囲の設定例

サブインターフェイス範囲の設定の確認

PPPoEoE および PPPoE over IEEE 802.1Q VLAN の設定

Cisco 10000 シリーズ ルータでは、イーサネット リンクを介した Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)セッションのトンネリングおよび終端が可能です。PPPoE over Ethernet(PPPoEoE)インターフェイス機能を使用すると、Cisco 10000 シリーズ ルータで、イーサネット リンクを介してイーサネット PPP セッションをトンネリングし、終端できます。PPPoE over IEEE 802.1Q VLAN 機能を使用すると、ルータは VLAN リンク間でイーサネット PPP セッションをトンネリングし、終端できます。IEEE 802.1Q カプセル化は、VLAN 対応ルータを他の VLAN 対応ネットワーク装置と相互接続するために使用されます。802.1Q リンク上のパケットは、標準のイーサネット フレームおよびそのフレームに関連する VLAN 情報で構成されます。

この章では、次の機能について説明します。

「PPPoEoE」

「PPPoE のスタティックな MAC アドレス」

「PPPoE over IEEE 802.1Q VLAN」

「TCP MSS の調整」

「VLAN レンジ」

詳細については、『 Cisco IOS Wide-Area Networking Configuration Guide and the VLAN Range 』Release 12.2(13)T機能ガイドの「Configuring Broadband Access:PPP and Routed Bridge Encapsulation」の章を参照してください。

PPPoEoE

PPPoEoE 機能には、単純なブリッジング アクセス装置を介して、ホスト ネットワークをリモート アクセス コンセントレータに接続する機能があります。Cisco 10000 シリーズ ルータは PPPoEoE セッションをサポートして、共有イーサネット インターフェイス上の複数のホストが、PPPoE サーバへの PPP セッションをオープンすることを可能にします。

PPPoEoE 機能については、次の項目で説明します。

「PPPoEoE 機能の履歴」

「PPPoEoE の制約事項」

「PPPoEoE の設定作業」

「PPPoEoE の設定例」

PPPoEoE 機能の履歴

 

Cisco IOS リリース
説明
必要な PRE

12.2(4)BZ1

この機能が Cisco 10000 シリーズ ルータに導入されました。

PRE1

12.3(7)XI1

この機能が Cisco IOS Release 12.3(7)XI1 に統合されました。

PRE2

12.2(28)SB

この機能が Cisco IOS Release 12.2(28)SB に統合されました。

PRE2

PPPoEoE の制約事項

PPPoEoE 機能には次の制約事項があります。

Cisco 10000 シリーズ ルータは、現在、ギガビット イーサネット ラインカードおよびファスト イーサネット 8 ポート ハーフハイト ラインカード上で、PPPoEoE 機能をサポートしています。Performance Routing Engine(PRE)のファスト イーサネット ポートは、PPPoEoE 機能をサポートしません。


) Cisco 10000 シリーズ ルータは、ファスト イーサネット インターフェイスを管理トラフィックに対してのみサポートします。


バーチャル テンプレート インターフェイスの設定

イーサネット インターフェイスに PPPoE を設定する前に、バーチャル テンプレートを設定します。バーチャル テンプレート インターフェイスは、着信 PPP セッション要求へ必要に応じて動的に適用される論理エンティティです。バーチャル テンプレート インターフェイスを設定するには、「バーチャル テンプレート インターフェイスの設定」を参照してください。

イーサネット インターフェイスの作成および PPPoE のイネーブル化

イーサネット インターフェイスを作成して、その上で PPPoE をイネーブルにするには、グローバル コンフィギュレーション モードを開始して、次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface GigabitEthernet number

イーサネット インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# pppoe enable

PPPoE をイネーブルにして、このインターフェイスを介して PPPoE セッションが作成されるようにします。

VPDN グループを使用した PPPoE の設定

PPPoE に使用する Virtual Private Dialup Network(VPDN; バーチャル プライベート ダイヤルアップ ネットワーク)グループを設定して、適切なバーチャル テンプレート インターフェイスにリンクするには、グローバル コンフィギュレーション モードを開始して、次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# vpdn enable

ルータで VPDN コンフィギュレーションをイネーブルにします。

ステップ 2

Router(config)# vpdn-group name

VPDN グループを、カスタマーまたは VPDN プロファイルに関連付けます。

ステップ 3

Router(config-vpdn)# accept-dialin

ダイヤルイン受け入れの VPDN グループを作成します。

ステップ 4

Router(config-vpdn-acc-in)# protocol pppoe

この VPDN グループを、PPPoE セッションを確立するために使用するよう指定します。

ステップ 5

Router(config-vpdn-acc-in)# virtual-template template-number

VAI をコピーするために使用されるバーチャル テンプレート インターフェイスを指定します。

ステップ 6

Router(config-vpdn)# pppoe limit per-mac per-mac-limit

(任意)グループを使用する PPPoE ポートごとに、MAC アドレス単位の最大セッション数を指定します。

ステップ 7

Router(config-vpdn)# pppoe limit max-sessions number

(任意)このルータで終端される、すべてのインターフェイスからの PPPoE セッションの最大数を指定します。


) PPPoE の BBA グループと PPPoE の VPDN グループを同時に設定することはできません。BBA グループを設定してから VPDN グループを設定した場合は、VPDN ダイヤルイン受け入れ設定モードの protocol コマンドに、PPPoE のオプションは含まれません(たとえば、protocol pppoe コマンドを指定できません)。protocol コマンドの pppoe オプションを再度イネーブルにするには、no bba-group pppoe コマンドを使用します。


BBA グループを使用した PPPoE の設定


) Cisco IOS リリース12.2(15)BXは、RADIUS を使用した BBA グループの設定をサポートしません。BBA グループは手動で設定する必要があります。


PPPoE に BBA グループを設定して、適切なバーチャル テンプレート インターフェイスにリンクするには、グローバル コンフィギュレーション モードを開始して、次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# bba-group pppoe { name | global }

PPPoE セッションを確立するため、BBA グループを設定します。

name は、BBA グループを識別します。複数の BBA グループを設定できます。

global は、BBA グループ名が指定されていない場合に、ATM 接続で使用されるデフォルトの BBA グループです。

ステップ 2

Router(config-bba)# virtual-template template-number

VAI をコピーするために使用されるバーチャル テンプレート インターフェイスを指定します。

ステップ 3

Router(config-bba)# pppoe limit per-mac per-mac-limit

(任意)グループを使用する PPPoE ポートごとに、MAC アドレス単位の最大セッション数を指定します。

ステップ 4

Router(config-bba)# pppoe limit max-sessions number

(任意)このルータで終端される、すべてのインターフェイスからの PPPoE セッションの最大数を指定します。

ステップ 5

Router(config-bba)# pppoe limit per-vc per-vc-limit

(任意)グループを使用する VC ごとに、PPPoE の最大セッション数を指定します。

ステップ 6

Router(config-bba)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

Router(config)# interface type number

BBA グループを付加するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

Router(config-if)# encapsulation dot1q vlan-id

VLAN に指定されたサブインターフェイス上のトラフィックの IEEE 802.1Q カプセル化をイネーブルにします。VLAN ID を指定します。

ステップ 9

Router(config-if)# protocol pppoe group group-name

BBA グループを VLAN に付加します。


) PPPoE の BBA グループと PPPoE の VPDN グループを同時に設定することはできません。BBA グループを設定してから VPDN グループを設定した場合は、VPDN ダイヤルイン受け入れ設定モードの protocol コマンドに、PPPoE のオプションは含まれません(たとえば、protocol pppoe コマンドを指定できません)。protocol コマンドの pppoe オプションを再度イネーブルにするには、no bba-group pppoe コマンドを使用します。


PPPoEoE の設定例

例6-1 に、PPPoEoE の設定を示します。この例では、バーチャル テンプレート virtual-template 1 が VPDN グループにリンクされます。また、この設定では VPDN グループ上で許可されるセッション数も指定します。

例6-1 VPDN グループを使用した PPPoEoE の設定

!Creates a VPDN session group and links it to a virtual template.
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
pppoe limit per-mac 10
pppoe limit max-sessions 32000
 
interface Loopback0
ip address 172.16.0.1 255.255.255.255
 
!Enables PPPoE and allows PPPoE sessions to be created through this subinterface.
interface GigabitEthernet1/0/0
no ip address
negotiation auto
pppoe enable
 
!Configures the virtual template interface.
interface Virtual-Template1
ip unnumbered loop 0
mtu 1492
peer default ip address pool pool1
ppp authentication chap
 
!Specifies the IP local pool to use for address assignment.
ip local pool pool1 192.168.0.1 192.168.0.100
 

例6-2 では、BBA グループ vpn-1 を作成して、virtual-template 1 にリンクします。BBA グループ vpn-1 は VLAN 20 に関連付けられます。

例6-2 BBA グループを使用した PPPoEoE の設定

bba-group pppoe vpn-1
virtual-template 1
sessions per-vc limit 5
sessions per-mac limit 10
!
!
interface GigabitEthernet1/0/0.1
encapsulation dot1q 20
protocol pppoe group vpn-1

PPPoE のスタティックな MAC アドレス

PPPoE のスタティックな MAC アドレス機能を使用すると、ATM Permanent Virtual Circuit(PVC; 相手先固定接続)で MAC アドレスを PPPoE over ATM(PPPoEoA)の発信元 MAC アドレスとして使用することができます。この機能は、BBA グループまたは VPDN グループに対して設定できます。この機能は、BBA グループまたは VPDN グループが適用される ATM PVC のすべての PPPoEoA セッションに適用されます。


) PPPoE のスタティック MAC アドレス機能は VPDN グループに設定できますが、BBA グループに設定することを推奨します。


PPPoE のスタティック MAC アドレス機能は、BBA グループと VPDN グループに相互に排他的に設定されます。MAC アドレスを BBA グループの送信元 MAC アドレスとして設定すると、VPDN グループはこの MACアドレスを VPDN グループの送信元 MAC アドレスとして使用することはできません。BBA グループ MAC アドレスを VPDN グループに適用するには、VPDN グループにも PPPoE のスタティック MAC アドレス機能を手動で設定する必要があります。

例6-3 では、MAC アドレスを使って PPP セッションを抑制する方法を示します。この例では、1 つの MAC アドレスにつき、最大 5 つのセッションが許可されます。この MAC アドレスで 6 つ以上のセッションを実行しようとすると、その MAC アドレスを使用するセッションは 30 秒間抑制されます。

例6-3 MAC アドレスを使用する PPP セッションの抑制

bba-group pppoe PPPoE
virtual-template 1
sessions per-vc limit 32000
sessions per-mac limit 32000
sessions per-mac throttle 5 1 30
 

抑制された MAC アドレスのリストを表示するには、特権 EXEC モードで show pppoe throttled mac コマンドを実行します。

Router# show pppoe throttled mac
MAC(s) throttled
MAC Ingress Port
00c1.00aa.006c ATM1/0/0.101
007c.009e.0070 ATM1/0/0.101
0097.009d.007a ATM1/0/0.101
008c.0077.0082 ATM1/0/0.101
00b5.00a8.009f ATM1/0/0.101
00a4.0088.00b5 ATM1/0/0.101

PPPoE のスタティック MAC アドレス機能の履歴

 

Cisco IOS リリース
説明
必要な PRE

12.2(4)BZ1

この機能が Cisco 10000 シリーズ ルータに導入されました。

PRE1

12.3(7)XI1

この機能が Cisco IOS Release 12.3(7)XI1 に統合されました。

PRE2

12.2(28)SB

この機能が Cisco IOS Release 12.2(28)SB に統合されました。

PRE2

PPPoE over IEEE 802.1Q VLAN

PPPoE over IEEE 802.1Q VLAN インターフェイス機能によって、Cisco 10000 シリーズ ルータは PPPoE over IEEE 802.1Q カプセル化 VLAN インターフェイスをサポートすることが可能になります。IEEE 802.1Q カプセル化は、VLAN 対応ルータを他の VLAN 対応ネットワーク装置と相互接続するために使用されます。802.1Q リンク上のパケットは、標準のイーサネット フレームおよびそのフレームに関連する VLAN 情報で構成されます。


) PPPoE は、デフォルトでは VLAN 上でディセーブルに設定されています。


PPPoE over IEEE 802.1Q VLAN 機能については、次の項目で説明します。

「PPPoE over IEEE 802.1Q VLAN 機能の履歴」

「PPPoE over IEEE 802.1Q VLAN の制約事項」

「PPPoE over IEEE 802.1Q VLAN の設定作業」

「PPPoE over IEEE 802.1Q VLAN の設定例」

「PPPoEoE および PPPoE over IEEE 802.1Q VLAN の確認」

「PPPoE セッションの削除」

PPPoE over IEEE 802.1Q VLAN 機能の履歴

 

Cisco IOS リリース
説明
必要な PRE

12.2(4)BZ1

この機能が Cisco 10000 シリーズ ルータに導入されました。

PRE1

12.3(7)XI1

この機能が Cisco IOS Release 12.3(7)XI1 に統合されました。

PRE2

12.2(28)SB

この機能が Cisco IOS Release 12.2(28)SB に統合されました。

PRE2

PPPoE over IEEE 802.1Q VLAN の制約事項

PPPoE over IEEE 802.1Q VLAN 機能には、次の制約事項があります。

Cisco 10000 シリーズ ルータは、現在、ギガビット イーサネット ラインカードおよびファスト イーサネット 8 ポート ハーフハイト ラインカード上で、PPPoE over IEEE 802.1Q VLAN 機能をサポートしています。PRE のファスト イーサネット ポートは、この機能をサポートしません。

Cisco 10000 シリーズ ルータは、PPPoE ダイヤルインの場合に限ってこの機能をサポートします。PPPoE ダイヤルアウト(クライアント)はサポートされません。

PPPoE over IEEE 802.1Q VLAN の設定作業

PPPoE over IEEE 802.1Q VLAN 機能を設定するには、次の設定作業を行います。

「バーチャル テンプレート インターフェイスの設定」

「イーサネット 802.1Q カプセル化サブインターフェイスの作成および PPPoE のイネーブル化」

「VPDN グループを使用した PPPoE の設定」

「BBA グループを使用した PPPoE の設定」

次に、これらの設定作業を行う手順について説明します。詳細については、『Cisco IOS Wide-Area Networking Configuration Guide』の「Configuring Broadband Access: PPP and Routed Bridge Encapsulation」の章を参照してください。

バーチャル テンプレート インターフェイスの設定

IEEE 802.1Q VLAN インターフェイスに PPPoE を設定する前に、バーチャル テンプレート インターフェイスを設定します。バーチャル テンプレート インターフェイスは、シリアル インターフェイスに必要に応じて動的に適用される論理エンティティです。バーチャル テンプレート インターフェイスを設定するには、「バーチャル テンプレート インターフェイスの設定」を参照してください。

イーサネット 802.1Q カプセル化サブインターフェイスの作成および PPPoE のイネーブル化

イーサネット 802.1Q カプセル化サブインターフェイスを作成して、その上で PPPoE をイネーブルにするには、グローバル コンフィギュレーション モードを開始して、次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface GigabitEthernet slot/module / port . subinterface-number

ギガビット イーサネット サブインターフェイスを作成して、サブインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-subif)# encapsulation dot1q vlan-id

VLAN の指定されたサブインターフェイスで、IEEE 802.1Q カプセル化をイネーブルにします。

ステップ 3

Router(config-subif)# pppoe enable

PPPoE をイネーブルにして、指定されたサブインターフェイスを介して PPPoE セッションが作成されるようにします。

ステップ 4

Router(config-subif)# pppoe max-sessions number

このルータで終端される、すべてのインターフェイスからの PPPoE セッションの最大数を指定します。

VPDN グループを使用した PPPoE の設定

PPPoE に使用する VPDN グループを設定して、適切なバーチャル テンプレート インターフェイスにリンクするには、グローバル コンフィギュレーション モードを開始して、次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# vpdn enable

ルータで VPDN コンフィギュレーションをイネーブルにします。

ステップ 2

Router(config)# vpdn-group name

VPDN グループを、カスタマーまたは VPDN プロファイルに関連付けます。

ステップ 3

Router(config-vpdn)# accept-dialin

ダイヤルイン受け入れの VPDN グループを作成します。

ステップ 4

Router(config-vpdn-acc-in)# protocol pppoe

この VPDN グループを、PPPoE セッションを確立するために使用するよう指定します。

ステップ 5

Router(config-vpdn-acc-in)# virtual-template template-number

VAI をコピーするために使用されるバーチャル テンプレート インターフェイスを指定します。

ステップ 6

Router(config-vpdn)# pppoe limit per-vlan number

(任意)各 VLAN での PPPoE セッションの最大数を指定します。

ステップ 7

Router(config-vpdn)# pppoe limit per-mac per-mac-limit

(任意)グループを使用する PPPoE ポートごとに、MAC アドレス単位の最大セッション数を指定します。

ステップ 8

Router(config-vpdn)# pppoe limit max-sessions number

(任意)このルータで終端される、すべてのインターフェイスからの PPPoE セッションの最大数を指定します。


) PPPoE の BBA グループと PPPoE の VPDN グループを同時に設定することはできません。BBA グループを設定してから VPDN グループを設定した場合は、VPDN ダイヤルイン受け入れ設定モードの protocol コマンドに、PPPoE のオプションは含まれません(たとえば、protocol pppoe コマンドを指定できません)。protocol コマンドの pppoe オプションを再度イネーブルにするには、no bba-group pppoe コマンドを使用します。


BBA グループを使用した PPPoE の設定


) Cisco IOS リリース12.2(15)BXは、RADIUS を使用した BBA グループの設定をサポートしません。BBA グループは手動で設定する必要があります。


PPPoE に BBA グループを設定して、適切なバーチャル テンプレート インターフェイスにリンクするには、グローバル コンフィギュレーション モードを開始して、次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# bba-group pppoe { name | global }

PPPoE セッションを確立するため、BBA グループを設定します。

name は、BBA グループを識別します。複数の BBA グループを設定できます。

global は、BBA グループ名が指定されていない場合に、ATM 接続で使用されるデフォルトの BBA グループです。

ステップ 2

Router(config-bba)# virtual-template template-number

VAI をコピーするために使用されるバーチャル テンプレート インターフェイスを指定します。

ステップ 3

Router(config-bba)# pppoe limit per-mac per-mac-limit

(任意)グループを使用する PPPoE ポートごとに、MAC アドレス単位の最大セッション数を指定します。

ステップ 4

Router(config-bba)# pppoe limit per-vlan number

(任意)各 VLAN での PPPoE セッションの最大数を指定します。

ステップ 5

Router(config-bba)# pppoe limit max-sessions number

(任意)このルータで終端される、すべてのインターフェイスからの PPPoE セッションの最大数を指定します。

ステップ 6

Router(config-bba)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

Router(config)# interface type number

BBA グループを付加するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

Router(config-if)# encapsulation dot1q vlan-id

VLAN に指定されたサブインターフェイス上のトラフィックの IEEE 802.1Q カプセル化をイネーブルにします。VLAN ID を指定します。

ステップ 9

Router(config-if)# protocol pppoe group group-name

BBA グループを VLAN に付加します。


) PPPoE の BBA グループと PPPoE の VPDN グループを同時に設定することはできません。BBA グループを設定してから VPDN グループを設定した場合は、VPDN ダイヤルイン受け入れ設定モードの protocol コマンドに、PPPoE のオプションは含まれません(たとえば、protocol pppoe コマンドを指定できません)。protocol コマンドの pppoe オプションを再度イネーブルにするには、no bba-group pppoe コマンドを使用します。


PPPoE over IEEE 802.1Q VLAN の設定例

例6-4 に、PPPoE over IEEE 802.1Q カプセル化 VLAN の設定例を示します。この例では、バーチャル テンプレート virtual-template 1 が VPDN グループにリンクされます。また、この設定では、VPDN グループ上で許可されるセッションの最大数および各 VLAN で許可されるセッション数も指定します。

例6-4 VPDN グループを使用した PPPoE over IEEE 802.1Q VLAN の設定

!Enables a virtual private dial-up network configuration on the router.
vpdn enable
!
!Creates a VPDN session group and links it to a virtual template.
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
pppoe limit per-mac 10
pppoe limit per-vlan 100
pppoe limit max-sessions 32000
 
interface Loopback0
ip address 172.16.0.1 255.255.255.255
 
interface GigabitEthernet1/0/0
no ip address
negotiation auto
 
!Enables PPPoE and allows PPPoE sessions to be created through this subinterface.
interface GigabitEthernet1/0/0.10
encapsulation dot1Q 20
pppoe enable
pppoe max-sessions 10
 
!Configures the virtual template interface.
interface Virtual-Template1
ip unnumbered loop 0
mtu 1492
peer default ip address pool pool1
ppp authentication chap
 
!Specifies the IP local pool to use for address assignment.
ip local pool pool1 192.168.0.1 192.168.0.100
 

例6-5 では、2 つの BBA グループ(VPN_1 および VPN_2)を作成します。BBA グループ VPN_1 は virtual-template 1 に、BBA グループ VPN_2 は virtual-template 2 に関連付けられています。グループ VPN_1 は VLAN 20 に、グループ VPN_2 は VLAN 30 に関連付けられています。

例6-5 BBA グループを使用した PPPoE over IEEE 802.1Q VLAN の設定

bba-group pppoe VPN_1
virtual-template 1
sessions per-vc limit 5
sessions per-mac limit 10
sessions per-vlan limit 5
!
!
bba-group pppoe VPN_2
virtual-template 2
sessions per-vc limit 5
sessions per-mac limit 10
sessions per-vlan limit 5
!
!
interface GigabitEthernet1/0/0.1
encapsulation dot1q 20
protocol pppoe group VPN_1
!
interface GigabitEthernet 2/0/0.2
encapsulation dot1q 30
protocol pppoe group VPN_2

PPPoEoE および PPPoE over IEEE 802.1Q VLAN の確認

PPPoEoE および PPPoE over IEEE 802.1Q VLAN を確認するには、特権 EXEC モードで次のコマンドを入力します。

 

コマンド
目的

Router# show vpdn

VPDN のアクティブな Level 2 Forwarding(L2F)プロトコル トンネルおよび Message Identifier(MID; メッセージ識別子)に関する情報を表示します。

Router# show vpdn session

VPDN のアクティブな Layer 2 Tunnel Protocol(L2TP; レイヤ 2 トンネル プロトコル)または L2F セッションに関する情報を表示します。

Router# show vpdn session packet

PPPoE セッションの統計情報を表示します。

Router# show vpdn session all

各セッション ID に関する PPPoE セッションの情報を表示します。

Router# show vpdn tunnel

トンネルの PPPoE セッション数を表示します。

Router# show pppoe session all

各セッション ID に関する PPPoE セッションの情報を表示します。

Router# show pppoe session packets

PPPoE セッションの統計情報を表示します。

PPPoE セッションの削除

PPPoE セッションを削除するには、特権 EXEC モードで次のコマンドを入力します。

 

コマンド
目的

Router# clear pppoe all

すべての PPPoE セッションを削除します。

Router# clear pppoe interface

物理インターフェイスまたはサブインターフェイス上のすべての PPPoE セッションを削除します。

Router# clear pppoe rmac

クライアント ホストの MAC アドレスからの PPPoE セッションを削除します。

TCP MSS の調整

TCP MSS の調整機能により、パケットの Maximum Segment Size(MSS; 最大セグメント サイズ)の設定が可能になります。

ホスト(通常 は PC)がサーバとの TCP セッションを開始する場合、TCP SYN パケット内の MSS オプション フィールドを使用して、IP セグメント サイズをネゴシエートします。MSS フィールドの値は、ホスト上の最大伝送ユニット(Maximum Transmission Unit; MTU)設定により決定します。PC のデフォルト MSS 値は、1500 バイトです。

PPPoE 標準は、1492 バイトの MTU しかサポートしません。ホストと PPPoE 間の MTU サイズの格差により、ホストとサーバ間のルータが 1500 バイトのパケットをドロップし、PPPoE ネットワーク上の TCP セッションを終端させる可能性があります。パス MTU(パスの適切な MTU を検出する)がホスト上でイネーブルである場合でも、システム管理者が、パス MTU を実行するためにホストからリレーされる必要がある Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)エラー メッセージをディセーブルにすることがあるため、セッションがドロップされる可能性があります。

ほとんどの場合、MSS 引数の最適値は 1452 バイトです。この値に 20 バイトの IP ヘッダー、20 バイトの TCP ヘッダー、および 8 バイトの PPPoE ヘッダーを加えると、イーサネット リンクの MTU サイズである 1500 バイトのパケットとなります。

TCP MSS 調整の機能履歴

 

Cisco IOS リリース
説明
必要な PRE

12.2(31)SB3

この機能が Cisco 10000 シリーズ ルータに導入されました。

PRE2 または PRE3

TCP MSS 調整について

この機能は、PTA および LNS セッションの両方に実行できます。

MSS 値は、グローバルに設定されるため、ルータを中継するすべてのパケットが書き換えの対象となります。

per interface コマンドは、RP にパントされるパケットにしか適用できないため、使用しないようにしてください。

TCP MSS 調整の制約事項

TCP MSS 調整機能は、 MaxSegSize オプションがパケットに含まれる最初のオプションである場合にのみ稼働します。非標準的な TCP パケットが受信された場合に、MaxSegSize オプションがパケットに含まれる最初のオプションでなければ、TCP MSS 調整機能の設定は機能しません。

TCP MSS 調整の設定作業

Cisco 10000 シリーズ ルータを経由する一時パケット(具体的には、SYN ビット内の TCP セグメント)の MSS、および IP パケットの MTU サイズを設定する場合は、次の作業を実行します。

サマリー ステップ

1. enable

2. configure terminal

3. ip pxf adjust-mss max-segment-size

4. end

詳細なステップ

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip pxf adjust-mss max-segment-size

 

Router(config-if)# ip tcp adjust-mss 1452

Cisco 10000 シリーズ ルータを経由する TCP SYN パケットの MSS 値を調整します。 max-segment-size 引数は、MSS(バイト)です。有効範囲は 500 ~ 1460 です。

ステップ 4

end

 

Router(config-if)# end

グローバル コンフィギュレーション モードを終了します。

TCP MSS 調整の設定例

図6-1 TCP MSS 調整のトポロジ例

 

次に、調整値を設定して、確認する例を示します。ルータ B のインターフェイス調整値を設定します。

Router_B(config)# ip pxf adjust-mss 500
 

ルータ A からルータ C を Telnet で接続し、ルータ B に MSS 調整を設定します。

Router_A# telnet 192.168.1.1
Trying 192.168.1.1... Open
 

ルータ C からのデバッグ出力を確認します。

Router_C# debug ip tcp transactions
 
Sep 5 18:42:46.247: TCP0: state was LISTEN -> SYNRCVD [23 -> 10.0.1.1(38437)]
Sep 5 18:42:46.247: TCP: tcb 32290C0 connection to 10.0.1.1:38437, peer MSS 500, MSS is 500
Sep 5 18:42:46.247: TCP: sending SYN, seq 580539401, ack 6015751
Sep 5 18:42:46.247: TCP0: Connection to 10.0.1.1:38437, advertising MSS 500
Sep 5 18:42:46.251: TCP0: state was SYNRCVD -> ESTAB [23 -> 10.0.1.1(38437)]
 

MSS は(設定どおり)、ルータ B 上で 500 に調整されます。

次に、MSS 値が 1452 に設定された PPPoE クライアント設定例を示します。

vpdn enable
no vpdn logging
!
vpdn-group 1
request-dialin
protocol pppoe
!
interface Ethernet0
ip address 192.168.100.1.255.255.255.0
ip pxf adjust-mss 1452
ip nat inside
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
pppoe client dial-pool-number 1
!
dsl equipment-type CPE
dsl operating-mode GSHDSL symmetric annex B
dsl linerate AUTO
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username sohodyn password 7 141B1309000528
!
ip nat inside source list 101 Dialer1 overload
ip route 0.0.0.0.0.0.0.0 Dialer1
access-list permit ip 192.168.100.0.0.0.0.255 any

VLAN レンジ

VLAN レンジ機能を使用すると、VLAN サブインターフェイスの設定が容易になります。また、VLAN サブインターフェイスを個別に設定するのではなく、VLAN サブインターフェイスのグループを一度に設定できます。VLAN サブインターフェイスのグループに対して入力されたコマンドは、グループ内の各サブインターフェイス、およびすべての既存 VLAN に適用されます。

VLAN レンジ機能を使用すると、重複するサブインターフェイス範囲、およびサブインターフェイス範囲内の個別のサブインターフェイスを設定することもできます。

VLAN レンジ機能については、次の項目で説明します。

「VLAN レンジ機能の履歴」

「VLAN レンジの制約事項」

「VLAN 範囲の設定作業」

「VLAN 範囲の設定例」

「サブインターフェイス範囲の設定の確認」

VLAN レンジ機能の履歴

 

Cisco IOS リリース
説明
必要な PRE

12.2(15)BX

この機能が Cisco 10000 シリーズ ルータに導入されました。

PRE2

12.3(7)XI1

この機能が Cisco IOS Release 12.3(7)XI1 に統合されました。

PRE2

12.2(28)SB

この機能が Cisco IOS Release 12.2(28)SB に統合されました。

PRE2

VLAN レンジの制約事項

VLAN レンジ機能には次の制約事項があります。

インターフェイス範囲設定モード( interface range コマンドの発行後に開始するモード)で入力したコマンドは、入力した時点で実行されます。インターフェイス範囲モードを終了したあとに、コマンドがバッチ処理されるわけではありません。コマンドの実行中にインターフェイス範囲設定モードを終了すると、コマンドによっては、範囲内の一部のインターフェイスに対して実行されない場合もあります。コマンド プロンプトが再表示されるのを待ってから、インターフェイス範囲設定モードを終了してください。

サブインターフェイス範囲に対する設定変更はすべて、NVRAM(不揮発性RAM)に保存されます。ただし、範囲自体は NVRAM に保存されません。範囲を作成し保存するには、define interface-range グローバル コンフィギュレーション コマンドを入力します。

Cisco IOS ソフトウェアは、 no interface range コマンドをサポートしません。サブインターフェイス範囲を削除するには、サブインターフェイスを個別に削除する必要があります。

VLAN 範囲の設定作業

VLAN 範囲機能を設定するには、次の必須の設定作業を行います。

「VLAN サブインターフェイス範囲の設定」

VLAN サブインターフェイス範囲の設定

VLAN サブインターフェイス範囲を設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface range {{ ethernet | fastethernet | gigabitethernet | atm } slot / interface . subinterface - { ethernet | fastethernet | gigabitethernet | atm } slot / interface . subinterface }

設定するサブインターフェイスの範囲を選択します。作成されていないサブインターフェイスを指定すると、interface range コマンドによって、このサブインターフェイスが作成されます。インターフェイス範囲設定モードを開始します。


) ダッシュの前後には、スペースが必須です。たとえば、コマンド interface range fastethernet 1 - 5 は有効ですが、コマンド interface range fastethernet 1-5 は無効です。


ステップ 2

Router(config-int-range)# encapsulation dot1q vlan-id [ native ]

 

トラフィックの IEEE 802.1Q カプセル化をイネーブルにして、範囲内の各サブインターフェイスに一意の VLAN ID を適用します。

vlan-id 引数は、VLAN ID です。1~4095 の値を入力する必要があります。


) VLAN ID 0 は ID としては有効ですが、VLAN の指定としては有効でありません。VLAN ID 0 は主に、本来はタグなしであるパケット上で、Class of Service(CoS; サービス クラス)情報を伝送するために使用されます。


(任意)native 引数は、ポートの VLAN ID 値を vlan-id 値に設定します。


) VLAN ID は範囲内の最初のサブインターフェイスに適用されます。後続の各インターフェイスには、指定された vlan-id にサブインターフェイス番号を加え、最初のサブインターフェイス番号を引いた値が割り当てられます。


VLAN ID + subinterface number - first subinterface number
 

VLAN 範囲の設定例

例6-6 では、5/1.1 ~ 5/1.4 の範囲のファスト イーサネット サブインターフェイスを設定して、次の VLAN ID を適用します。

ファスト イーサネット 5/1.1 = VLAN ID 301(vlan-id)

ファスト イーサネット 5/1.2 = VLAN ID 302(vlan-id = 301 + 2 - 1 = 302)

ファスト イーサネット 5/1.3 = VLAN ID 303(vlan-id = 301 + 3 - 1 = 303)

ファスト イーサネット 5/1.4 = VLAN ID 304(vlan-id = 301 + 4 - 1 = 304)

例6-6 VLAN サブインターフェイス範囲の設定

Router(config)# interface range fastethernet5/1.1 - fastethernet5/1.4
Router(config-if-range)# encapsulation dot1q 301
Router(config-if-range)# no shutdown

サブインターフェイス範囲の設定の確認

VLAN カプセル化用のサブインターフェイス範囲の設定を確認するには、特権 EXEC モードで次のコマンドを入力します。

 

コマンド
目的

Router# show running-config

ルータに設定されているインターフェイスやサブインターフェイスの情報、各インターフェイスに設定されているカプセル化タイプなど、現在の設定を表示します。

Router# show interface

各インターフェイスに設定されているカプセル化タイプなど、ルータに設定されているすべてのインターフェイスやサブインターフェイスの情報を表示します。

Router# show interface interface-type slot / interface.subinterface

設定されているカプセル化タイプなど、指定されたインターフェイスまたはサブインターフェイスの情報を表示します。