Cisco 10000 シリーズ ルータ ソフトウェア コンフィギュレーション ガイド
L2VPN インターワーキングの設定
L2VPN インターワーキングの設定
発行日;2012/02/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

L2VPN インターワーキングの設定

Ethernet to VLAN ― ブリッジド インターワーキング

L2VPN インターワーキングの設定

設定の確認

Ethernet to VLAN の設定例 ― ブリッジド

Ethernet to VLAN over LS ― ブリッジド:例

Ethernet to VLAN over AtoM ― ブリッジド:例

Ethernet/VLAN to ATM AAL5 インターワーキング

Ethernet/VLAN to ATM AAL5 インターワーキングの前提条件

Ethernet/VLAN to ATM AAL5 インターワーキングの制約条件

ATM AAL5 to Ethernet ローカル スイッチング ― ブリッジド インターワーキング

ATM AAL5 to VLAN 802.1Q ローカル スイッチング ― ブリッジド インターワーキング

ATM AAL5 to Ethernet Port AToM ― ブリッジド インターワーキング

ATM AAL5 to Ethernet VLAN 802.1Q AToM ― ブリッジド インターワーキング

設定作業および設定例

ローカル スイッチング

AToM

Ethernet/VLAN to Frame Relay インターワーキング

Ethernet/VLAN to Frame Relay インターワーキングの前提条件

Ethernet/VLAN to Frame Relay インターワーキングの制約事項

FR DLCI to Ethernet ローカル スイッチング ― ブリッジド インターワーキング

FR DLCI to VLAN 802.1Q ローカル スイッチング ― ブリッジド インターワーキング

FR DLCI to Ethernet Port AToM ― ブリッジド インターワーキング

ATM AAL5 to Ethernet VLAN 802.1Q AToM ― ブリッジド インターワーキング

設定作業および設定例

ローカル スイッチング

AToM

L2VPN インターワーキングの確認

L2VPN インターワーキングの設定

インターワーキングは、2 つの異種 Alternating Current(AC; 交流電流)の相互接続に必要なトランスフォーム機能です。インターワーキング機能にはいくつかの種類があります。使用される機能は、使用される AC のタイプ、伝送されるデータのタイプ、必要な機能のレベルによって決まります。Cisco IOS ソフトウェアがサポートしている 2 つの主要なインターワーキング機能は、次のとおりです。

ブリッジド インターワーキング ― レイヤ 3 コンテンツに関係なく、レイヤ 2(L2)パケットだけを考慮する場合に使用します。Internet Service Provider(ISP; インターネット サービス プロバイダー)によるルーティングは加わりません。特に、ブリッジド インターワーキングでは MPLS 擬似回線上のイーサネット(ポート)の使用がサポートされます。そのため、このタイプのインターワーキング機能は、イーサネット インターワーキングとも呼ばれています。

ルーテッド インターワーキング ― レイヤ 3 パケットの伝送に使用されます。プロトコル タイプごとに異なるルーテッド インターワーキング機能があります。一般的なルーテッド インターワーキング機能では、Internet Protocol(IP; インターネット プロトコル)がサポートされています。したがって、このタイプのインターワーキング機能は、IP インターワーキングとも呼ばれ、新しい擬似回線タイプである IP over MPLS が使用されます。


) Cisco 10000 シリーズのルータはイーサネット インターワーキングだけをサポートしています。


イーサネット間または PPP 間などの同種間の接続回路には、すでに Layer 2 transport over MPLS and IP があります。L2VPN インターワーキングは、異種間の接続回路による接続を可能にすることで、この機能を拡張しています。インターワーキング機能は、異なるレイヤ 2 カプセル化間の変換を円滑にします。インターワーキング モードはいくつかありますが、Cisco 10000 シリーズ ルータは、ブリッジド インターワーキング(イーサネット インターワーキング)だけをサポートしています。

モードを指定するには、pseudowire-class コンフィギュレーション モードで、 interworking { ethernet | ip } コマンドを実行します。 interworking コマンドを使用すると、接続回路はローカルで終端します。 ethernet キーワードを指定すると、接続回路からイーサネット フレームが抽出され、擬似回線を通じて送信されます。これはイーサネットのエンドツーエンド伝送を想定したものです。接続回路のイーサネット以外のフレームは廃棄されます。VLAN の場合は、VLAN タグが削除され、タグのないイーサネット フレームが残ります。

この章では、次の L2VPN 同種間機能およびインターワーキング機能について説明します。

「Ethernet to VLAN ― ブリッジド インターワーキング」

「Ethernet/VLAN to ATM AAL5 インターワーキング」

「Ethernet/VLAN to Frame Relay インターワーキング」

「L2VPN インターワーキングの確認」

Ethernet to VLAN ― ブリッジド インターワーキング

イーサネット インターワーキング(ブリッジド インターワーキング)では、イーサネット フレームは擬似回線を通じてブリッジングされます。CE ルータは、何も使用せずにイーサネットをブリッジングしたり、Bridge Virtual Interface(BVI)または RBE などのブリッジド カプセル化モデルを使用してルーティングしたりできます。PE ルータは、イーサネットの同種間モードで動作します。

Ethernet to VLAN(ブリッジド)機能については、次の項目で説明します。

「L2VPN インターワーキングの設定」

「設定の確認」

「Ethernet to VLAN の設定例 ― ブリッジド」

L2VPN インターワーキングの設定

L2VPN インターワーキングをイネーブルにするには、擬似配線を構成するコマンド リストに interworking コマンドを追加する必要があります。

サマリー ステップ

1. enable

2. configure terminal

3. pseudowire-class name

4. encapsulation mpls

5. interworking ethernet

詳細なステップ

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。パスワードを求めるプロンプトが表示された場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

pseudowire-class name

 

Router(config)# pseudowire-class class1

指定する名前で擬似配線クラスを設定します。擬似配線クラス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation mpls

 

Router(config-pw)# encapsulation mpls

トンネリング カプセル化を指定します。

ステップ 5

interworking ethernet

 

Router(config-pw)# interworking ethernet

擬似配線のタイプと擬似配線を通るトラフィック タイプを指定します。

設定の確認

show mpls l2transport vc detail コマンドを使用して、AToM 設定を確認できます。次の例では、インターワーキング タイプが太字で表示されています。

 

PE1
PE2

Router# show mpls l2transport vc detail

 

Local interface: Fa1/1/0 up, line protocol up, Ethernet up

Destination address: 10.9.9.9, VC ID: 123, VC status: up

Preferred path: not configured

Default path: active

Tunnel label: 17, next hop 10.1.1.3

Output interface: Fa4/0/0, imposed label stack {17 20}

Create time: 01:43:50, last status change time: 01:43:33

Signaling protocol: LDP, peer 10.9.9.9:0 up

MPLS VC labels: local 16, remote 20

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 15, send 4184

byte totals: receive 1830, send 309248

packet drops: receive 0, send 0

Router# show mpls l2transport vc detail

 

Local interface: Fa2/0.3 up, line protocol up, Eth VLAN 10 up

MPLS VC type is Ethernet, interworking type is Ethernet

Destination address: 10.8.8.8, VC ID: 123, VC status: up

Preferred path: not configured

Default path: active

Tunnel label: 16, next hop 10.1.1.3

Output interface: Fa6/0, imposed label stack {16 16}

Create time: 00:00:26, last status change time: 00:00:06

Signaling protocol: LDP, peer 10.8.8.8:0 up

MPLS VC labels: local 20, remote 16

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 5, send 0

byte totals: receive 340, send 0

packet drops: receive 0, send 0

Ethernet to VLAN の設定例 ― ブリッジド

ここでは、ローカル スイッチング(LS)と AtoM 両方の Ethernet to VLAN の例を示します。

Ethernet to VLAN over LS ― ブリッジド:例

Ethernet to VLAN over AtoM ― ブリッジド:例

Ethernet to VLAN over LS ― ブリッジド:例

 

PE
config t
interface atm 2/0/0
pvc 0/200 l2transport
encapsulation aal5snap
interface gigabitethernet 5/1/0
no ip address
connect ETH-VLAN gigabitethernet 5/0/0 gigabitethernet 5/1/0.3 interworking ethernet
 

Ethernet to VLAN over AtoM ― ブリッジド:例

 

PE1
PE2

ip cef

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

pseudowire-class atom

encapsulation mpls

!

interface Loopback0

ip address 10.9.9.9 255.255.255.255

!

interface FastEthernet0/0

no ip address

!

interface FastEthernet1/0

xconnect 10.9.9.9 123 pw-class atom

 

ip cef

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

pseudowire-class atom-eth-iw

encapsulation mpls

interworking ethernet

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

!

interface FastEthernet1/0.1

encapsulation dot1q 100

xconnect 10.9.9.9 123 pw-class atom-eth-iw

 

Ethernet/VLAN to ATM AAL5 インターワーキング

Ethernet/VLAN to ATM AAL5 インターワーキング機能については、次の項目で説明します。

「Ethernet/VLAN to ATM AAL5 インターワーキングの前提条件」

「Ethernet/VLAN to ATM AAL5 インターワーキングの制約条件」

「ATM AAL5 to Ethernet ローカル スイッチング ― ブリッジド インターワーキング」

「ATM AAL5 to VLAN 802.1Q ローカル スイッチング ― ブリッジド インターワーキング」

「ATM AAL5 to Ethernet Port AToM ― ブリッジド インターワーキング」

「ATM AAL5 to Ethernet VLAN 802.1Q AToM ― ブリッジド インターワーキング」

「設定作業および設定例」

Ethernet/VLAN to ATM AAL5 インターワーキングの前提条件

ネットワークに Ethernet/VLAN to ATM AAL5 インターワーキングを設定する前に、Cisco Express Forwarding をイネーブルにする必要があります。

Ethernet/VLAN to ATM AAL5 インターワーキングの制約条件

Cisco IOS Release 12.2(33)SB では、Ethernet/VLAN to ATM AAL5 ローカル スイッチングに次の制限があります。

サポートされているのは次の変換だけです。その他の変換は廃棄されます。

LAN FCSのないイーサネット(AAAA030080C200070000)

スパニング ツリー(AAAA030080C2000E)

ブリッジド インターワーキング用にサポートされている ATM カプセル化タイプ:aal5snap

ATM の既存の QoS 機能は、ATM CLP ビットの設定を含めてサポートされます。

ATM AAL5 virtual circuit(VC; 仮想回線)モードだけがサポートされます。ATM VP およびポート モードはサポートされません。

非 AAL5 トラフィックはパントされます(OAM セルなど)。エンドツーエンドの F5 ループ バック セルは PE ルータにループバックされます。

イーサネット CE からのイーサネット フレームに 802.1Q ヘッダー(VLAN ヘッダー)が含まれている場合、このタイプのエンドポイント接続(イーサネット ポート モード)では、VLAN ヘッダーがフレームに残ったまま、ATM CE に転送されます(図18-1 を参照)。

図18-1 ATM AAL5 to Ethernet のローカル スイッチング ブリッジド インターワーキングのプロトコル スタック ― VLAN ヘッダーあり

 

Cisco IOS Release 12.2(33)SB では、Ethernet/VLAN to ATM AAL5 AToMに次の制限があります。

サポートされているのは次の変換だけです。その他の変換は廃棄されます。

LAN FCSのないイーサネット(AAAA030080C200070000)

スパニング ツリー(AAAA030080C2000E)

ブリッジド インターワーキング用にサポートされている ATM カプセル化タイプ:aal5snap

ATM の既存の QoS 機能は、ATM CLP ビットの設定を含めてサポートされます。

ATM AAL5 VC モードだけがサポートされます。ATM VP およびポート モードはサポートされません。

SVC はサポートされていません。

擬似回線を通じて送信される前に、個々のAAL5 ATM セルがフレームに組み立てられます。

非 AAL 5 トラフィック(OAM セルなど)はパントされ、RP レベルで処理されます。ATM PE ルータに OAM セル エミュレーションとともに VC を設定すると( oam-ac emulation-enable CLI コマンドを使用)、設定された間隔でエンドツーエンドの F5 ループバック セルを CE ルータに送信できます。

擬似回線が停止した場合、PE ルータから CE ルータに、F5 エンドツーエンド セグメント AIS/RDI(アラーム表示信号/リモート障害表示)が送信されます。

イーサネット CE からのイーサネット フレームに 802.1Q ヘッダー(VLAN ヘッダー)が含まれている場合、このタイプのエンドポイント接続(イーサネット ポート モード)では、擬似回線上のフレームに VLAN ヘッダーが残ります(図18-2 を参照)。

図18-2 ATM to Ethernet AtoM ブリッジド インターワーキングのプロトコル スタック ― VLAN ヘッダーあり

 

ATM AAL5 to Ethernet ローカル スイッチング ― ブリッジド インターワーキング

このインターワーキング タイプは、同じ PE ルータに接続されているイーサネット接続 VC と ATM 接続 VC の相互運用性を提供します。このインターワーキング タイプでは、ブリッジド インターワーキングに対応するブリッジド カプセル化が使用されます。

イーサネットから ATM の方向では、PE ルータは出力インターフェイスを変更せずにレイヤ 2 パケットを転送し、ブリッジド カプセル化を使用して、AAL5 上のレイヤ 2 パケットをカプセル化します。

ATM からイーサネット方向では、ATM ヘッダーとブリッジド カプセル化が廃棄され、レイヤ 2 パケットはイーサネットでカプセル化されて送出されます。

図18-3 に ATM to Ethernet のローカル スイッチング(ブリッジド インターワーキング)のプロトコル スタックを示します。ATM 側のカプセル化タイプは aal5snap です。

図18-3 ATM AAL5 to Ethernet ローカル スイッチング ブリッジド インターワーキングのプロトコル スタック

 

ATM AAL5 to VLAN 802.1Q ローカル スイッチング ― ブリッジド インターワーキング

このインターワーキング タイプは、同じ PE ルータに接続されている ATM 接続 VC とイーサネット VLAN 接続 VC の相互運用性を提供します。ATM to Ethernet の場合と同様、ブリッジド(イーサネット)インターワーキング メカニズムに対応するブリッジド カプセル化が使用されます。

イーサネット VLAN 接続の場合、VLAN ID はサービス デリミタなので、ATM CE との間のフレームには VLAN ヘッダーは含まれません。

VLAN から ATM の方向では、PE ルータはレイヤ 2 パケットから VLAN ヘッダーを廃棄します。PE ルータは、ブリッジド カプセル化を使用して AAL5 上の L2 パケットをカプセル化してから、ATM 出力インターフェイスにフレームを送信します。

ATM から VLAN の方向では、ATM ヘッダーとブリッジド カプセル化が廃棄され、宛先/送信元 MAC アドレスの後ろに VLAN ヘッダーが挿入されて、L2 パケットが送出されます。

ATM to VLAN のローカル スイッチングのプロトコル スタックは図18-3 を参照してください。ATM 側のカプセル化タイプは aal5snap です。

ATM AAL5 to Ethernet Port AToM ― ブリッジド インターワーキング

このインターワーキング タイプは、異なる PE ルータに接続されている ATM 接続 VC とイーサネット接続 VC の相互運用性を提供します。ブリッジド(イーサネット)インターワーキング メカニズムに対応するブリッジド カプセル化が使用されます。

インターワーキング機能は、Multiprotocol Encapsulation over ATM Adaptation Layer 5 に基づいて、ATM 接続 VC に接続されている PE で実行されます(図18-4)。

図18-4 ATM to Ethernet AToM ブリッジド インターワーキングのネットワーク トポロジ

 

このアーキテクチャの利点は、イーサネット PE(イーサネット セグメントに接続されている)がイーサネットの同種間サービスと同様に動作することです。

インターワーキング機能を持つ PE では、ATM セグメントから MPLS クラウドへの方向で、ブリッジド カプセル化(ATM/SNAP ヘッダー)が廃棄され、イーサネット フレームは、VC タイプ 5(イーサネット)を使用し擬似回線を通じて送信するために必要なラベルでカプセル化されます(図18-5)。

反対方向では、MPLS クラウドからのラベルの廃棄後、ブリッジド カプセル化を使用して AAL5 上のイーサネット フレームがカプセル化されます。

図18-5 に ATM to Ethernet AtoM ブリッジド インターワーキングのプロトコル スタックを示します。ATM 側のカプセル化タイプは aal5snap です。

図18-5 ATM to Ethernet AtoM ブリッジド インターワーキングのプロトコル スタック ― VLAN ヘッダーなし

 

ATM AAL5 to Ethernet VLAN 802.1Q AToM ― ブリッジド インターワーキング

このインターワーキング タイプは、異なる PE ルータに接続されている ATM 接続 VC とイーサネット VLAN 接続 VC の相互運用性を提供します。ブリッジド(イーサネット)インターワーキング メカニズムに対応するブリッジド カプセル化が使用されます。

インターワーキング機能は、ATM to Ethernet Port の場合と同様に実行され、ATM 接続 VC に接続されている PE に実装されます。この実装は、Multiprotocol Encapsulation over ATM Adaptation Layer 5 に基づいています(図18-4を参照)。

イーサネット側に接続されている PE の大きな相違点は、着信パケットに VLAN ヘッダーがあることです。この PE は、VLAN CE からの着信フレームの VLAN ヘッダーを廃棄し、MPLS クラウドからのイーサネット フレームには VLAN ヘッダーを挿入します。擬似回線(VC タイプ 5 を使用)上を送信されるフレームは VLAN ヘッダーのないイーサネット フレームです。

図18-6 に、ATM Adaptation Layer 5 でのカプセル化を示します。

図18-6 ATM to VLAN AToM ブリッジド インターワーキングのプロトコル スタック

 

設定作業および設定例

ここでは、2 つの L2VPN テクノロジー ソリューションの設定作業と設定例を示します。:

ローカル スイッチング

AToM

ローカル スイッチング

図18-7 に、LS の構成を示します。

図18-7 CLI コマンドのローカル スイッチング モデル

 

Cisco 10000 ルータ上の LS インターワーキングでサポートされるのはブリッジド インターワーキング(イーサネット インターワーキング)機能だけです。

ここでは、次の LS 設定の手順と例を示します。

「ATM AAL5 to Ethernet Port」

「ATM AAL5 to Ethernet VLAN 802.1Q」

ATM AAL5 to Ethernet Port

PE ルータへの ATM AAL5 to Ethernet Port 機能の設定は、次の手順で行います。

1. config t

2. interface atm slot/subslot/port

3. pvc vpi/vci l2transport

4. encapsulation aal5snap

5. interface [ fastethernet | gigabitethernet ] slot/subslot/port

6. no ip address

7. connect connection-name [ fastethernet | gigabitethernet ] slot/subslot/port atm slot/subslot/port vpi/vci interworking ethernet


connect コマンド内のインターフェイスの順序は重要ではありません。


PE ルータに対する ATM AAL5 to Ethernet Port 機能の設定例を示します。

config t
interface atm 2/0/0
pvc 0/200 l2transport
encapsulation aal5snap
interface gigabitethernet 5/1/0
no ip address
connect atm-enet gigabitethernet 5/1/0 atm 2/0/0 0/200 interworking ethernet

ATM AAL5 to Ethernet VLAN 802.1Q

PE ルータへの ATM AAL5 to Ethernet VLAN 802.1Q 機能の設定は、次の手順で行います。

1. config t

2. interface atm slot/subslot/port

3. pvc vpi/vci l2transport

4. encapsulation aal5snap

5. interface [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface

6. encapsulation dot1q VLAN-ID

7. connect connection-name [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface atm slot/subslot/port vpi/vci interworking ethernet


connect コマンド内のインターフェイスの順序は重要ではありません。


PE ルータに対する ATM AAL5 to Ethernet VLAN 802.1Q 機能の設定例を示します。

config t
interface atm 2/0/0
pvc 0/200 l2transport
encapsulation aal5snap
interface gigabitethernet 5/1/0.3
encapsulation dot1q 2
connect atm-vlan gigabitethernet 5/1/0.3 atm 2/0/0 0/200 interworking ethernet

AToM

図18-8 に、AToM の構成を示します。

図18-8 CLI コマンドの AToM モデル

 

Cisco 10000 ルータ上の AToM インターワーキングでサポートされるのはブリッジド インターワーキング(イーサネット インターワーキング)機能だけです。

ここでは、次の AToM 設定の手順と例を示します。

「ATM AAL5 to Ethernet Port」

「ATM AAL5 to Ethernet VLAN 802.1Q の設定」

ATM AAL5 to Ethernet Port

PE1 ルータへの ATM AAL5 to Ethernet Port 機能の設定は、次の手順で行います。

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet

8. interface atm slot/subslot/port

9. pvc vpi/vci l2transport

10. encapsulation aal5snap

11. xconnect remote-ip-address vc-id pw-class name

PE2 ルータへの ATM AAL5 to Ethernet Port 機能の設定は、次の手順で行います。

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interface [ fastethernet | gigabitethernet ] slot/subslot/port

8. xconnect remote-ip-address vc-id pw-class name


) PE2 の設定は、同種間として処理され、また接続回線がすでにイーサネット ポートであるため、interworking ethernet コマンドはありません。


PE1 ルータに対する ATM AAL5 to Ethernet Port 機能の設定例を示します。

config t
mpls label protocol ldp
interface Loopback100
ip address 10.0.0.100 255.255.255.255
pseudowire-class atm-eth
encapsulation mpls
interworking ethernet
interface atm 2/0/0
pvc 0/200 l2transport
encapsulation aal5snap
xconnect 10.0.0.200 140 pw-class atm-eth
 

PE2 ルータに対する ATM AAL5 to Ethernet Port 機能の設定例を示します。

config t
mpls label protocol ldp
interface Loopback200
ip address 10.0.0.200 255.255.255.255
pseudowire-class atm-eth
encapsulation mpls
interface gigabitethernet 5/1/0
xconnect 10.0.0.100 140 pw-class atm-eth

ATM AAL5 to Ethernet VLAN 802.1Q の設定

PE1 ルータへの ATM AAL5 to Ethernet VLAN 802.1Q 機能の設定は、次の手順で行います。

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet

8. interface atm slot/subslot/port

9. pvc vpi/vci l2transport

10. encapsulation aal5snap

11. xconnect remote-ip-address vc-id pw-class name

PE2 ルータへの ATM AAL5 to Ethernet VLAN 802.1Q 機能の設定は、次の手順で行います。

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet

8. interface [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface

9. encapsulation dot1q VLAN-ID

10. xconnect remote-ip-address vci pw-class name


) ATM AAl5 to VLAN の場合は、PE2 の設定に interworking ethernet コマンドが含まれます。


PE1 ルータに対する ATM AAL5 to Ethernet VLAN 802.1Q 機能の設定例を示します。

config t
mpls label protocol ldp
interface Loopback100
ip address 10.0.0.100 255.255.255.255
pseudowire-class atm-vlan
encapsulation mpls
interworking ethernet
interface atm 2/0/0
pvc 0/200 l2transport
encapsulation aal5snap
xconnect 10.0.0.200 140 pw-class atm-vlan
 

PE2 ルータに対する ATM AAL5 to Ethernet VLAN 802.1Q 機能の設定例を示します。

config t
mpls label protocol ldp
interface Loopback200
ip address 10.0.0.200 255.255.255.255
pseudowire-class atm-vlan
encapsulation mpls
interworking ethernet
interface gigabitethernet 5/1/0.3
encapsulation dot1q 1525
xconnect 10.0.0.100 140 pw-class atm-vlan

) L2VPN インターワーキングのステータスを確認し、統計情報を調べる場合は、「L2VPN インターワーキングの確認」を参照してください。


Ethernet/VLAN to Frame Relay インターワーキング

Ethernet/VLAN to Frame Relay(FR)インターワーキング機能については、次の項目で説明します。

「Ethernet/VLAN to Frame Relay インターワーキングの前提条件」

「Ethernet/VLAN to Frame Relay インターワーキングの制約事項」

「FR DLCI to Ethernet ローカル スイッチング ― ブリッジド インターワーキング」

「FR DLCI to VLAN 802.1Q ローカル スイッチング ― ブリッジド インターワーキング」

「FR DLCI to Ethernet Port AToM ― ブリッジド インターワーキング」

「ATM AAL5 to Ethernet VLAN 802.1Q AToM ― ブリッジド インターワーキング」

「設定作業および設定例」

Ethernet/VLAN to Frame Relay インターワーキングの前提条件

ネットワークに Ethernet/VLAN to Frame Relay インターワーキングを設定する前に、Cisco Express Forwarding をイネーブルにする必要があります。

Ethernet/VLAN to Frame Relay インターワーキングの制約事項

Cisco IOS Release 12.2(33)SB では、Ethernet/VLAN to Frame Relay LS に次の制限があります。

サポートされているのは次の変換だけです。その他の変換は廃棄されます。

LAN FCSのないイーサネット(0300800080C20007 または 6558)

スパニング ツリー(0300800080C2000E または 4242)

PVC ステータス信号は、同種間の場合と同様に機能します。PE ルータは、一方の CE ルータのアベイラビリティに基づいて、もう一方の CE ルータに PVC ステータスを報告します。

サポートされるのは、FR DLCI モードだけです。FR ポート モードはサポートされていません。

イーサネット フレームに 802.1Q ヘッダー(VLAN ヘッダー)が含まれている場合、このタイプのエンドポイント接続(イーサネット ポート モード)では、VLAN ヘッダーがフレームに残されたまま、FR CE に転送されます(図18-9 を参照)。

図18-9 FR to Ethernet のローカル スイッチング ブリッジド インターワーキング ― VLAN ヘッダーあり

 

Cisco IOS Release 12.2(33)SB では、Ethernet/VLAN to Frame Relay AToM に次の制限があります。

サポートされているのは次の変換だけです。その他の変換は廃棄されます。

LAN FCSのないイーサネット(0300800080C20007)

スパニング ツリー(0300800080C2000E)

PE ルータは、CE からの着信のカプセル化タイプとして Cisco と IETF FR の両方の変換を自動的にサポートしますが、CE ルータへの送信時に変換するのは IETF だけです。Cisco CE ルータでは、これは特に問題になりません。Cisco CE ルータは Cisco カプセル化を送信するように設定されていても、受信時に IETF カプセル化を処理できるからです。

PVC ステータス信号は、同種間の場合と同様に機能します。PE ルータは、擬似回線のアベイラビリティに基づいて、CE ルータに PVC ステータスを報告します。

接続回線の最大伝送ユニット(maximum transmission unit; MTU)が、MPLS による接続の場合と一致する必要があります。

サポートされるのは、FR DLCI モードだけです。FR ポート モードはサポートされていません。

イーサネット フレームに 802.1Q ヘッダー(VLAN ヘッダー)が含まれている場合、このタイプのエンドポイント接続(イーサネット ポート モード)では、擬似回線上のフレームに VLAN ヘッダーが残ります(図18-10 を参照)。

ルーテッド インターワーキングの場合、着信トラフィックでは Cisco と IETF の FR カプセル化がサポートされます。ただし、CE への送信トラフィックでサポートされるのは IETF だけです。

図18-10 FR to Ethernet AToM ブリッジド インターワーキングのプロトコル スタック ― VLAN ヘッダーあり

 

FR DLCI to Ethernet ローカル スイッチング ― ブリッジド インターワーキング

このインターワーキング タイプは、同じ PE ルータに接続されている フレームリレー 接続 VC とイーサネット 接続 VC の相互運用性を提供します。このインターワーキング タイプでは、ブリッジド(イーサネット)インターワーキング メカニズムに対応するブリッジド カプセル化が使用されます。

イーサネットから FR の方向では、PE ルータは出力インターフェイスを変更せずにレイヤ 2 パケットを転送し、ブリッジド カプセル化を使用して、FR 上のレイヤ 2 パケットをカプセル化します。

FR からイーサネットの方向では、FR ヘッダーとブリッジド カプセル化が廃棄され、イーサネット カプセル化を使用してレイヤ 2 パケットが送出されます。

図18-11 に FR to Ethernet のローカル スイッチング(ブリッジド インターワーキング)のプロトコル スタックを示します。

図18-11 FR to Ethernet ローカル スイッチング ブリッジド インターワーキングのプロトコル スタック

 

PE ルータは、CE からの着信時のカプセル化タイプとして Cisco と IETF FR の両方の変換を自動的にサポートしますが、CE ルータへの送信時に変換するのは IETF だけです。Cisco CE ルータでは、これは特に問題になりません。Cisco CE ルータは Cisco カプセル化を送信するように設定されていても、受信時に IETF カプセル化を処理できるからです。

FR DLCI to VLAN 802.1Q ローカル スイッチング ― ブリッジド インターワーキング

このインターワーキング タイプは、同じ PE ルータに接続されている フレームリレー 接続 VC とイーサネット VLAN 接続 VC の相互運用性を提供します。このインターワーキング タイプでは、ブリッジド(イーサネット)インターワーキング メカニズムに対応するブリッジド カプセル化が使用されます。

イーサネット VLAN 接続の場合、VLAN ID はサービス デリミタなので、FR CE との間で送受信されるフレームには VLAN ヘッダーは含まれません。

VLAN から FR の方向では、PE ルータはレイヤ 2 パケットから VLAN ヘッダーを廃棄します。PE ルータは、ブリッジド カプセル化を使用して FR 上の L2 パケットをカプセル化してから、FR 出力インターフェイスにフレームを送信します。

FR から VLAN の方向では、FR ヘッダーとブリッジド カプセル化が廃棄され、宛先/送信元 MAC アドレスの後ろに VLAN ヘッダーが挿入されて、L2 パケットが送出されます。

FR to Ethernet ローカル スイッチング(ブリッジド インターワーキング)のプロトコルスタックは、図18-11 を参照してください。

FR DLCI to Ethernet Port AToM ― ブリッジド インターワーキング

このインターワーキング タイプは、異なる PE ルータに接続されている FR 接続 VC とイーサネット接続 VC の相互運用性を提供します。ブリッジド(イーサネット)インターワーキング メカニズムに対応するブリッジド カプセル化が使用されます。

FR to Ethernet Port の場合、フレームリレーによるマルチプロトコル相互接続に基づいて、FR 接続 VC に接続されている PEでインターワーキング機能が実行されます(図18-12)。インターワーキングの実装は、ATM-to-Ethernet の場合と同様です。

図18-12 FR to Ethernet AToM ブリッジド インターワーキングのネットワーク トポロジ

 

このアーキテクチャの利点は、イーサネット PE(イーサネット セグメントに接続されているPE)がイーサネットの同種間サービスと同様に動作することです。擬似回線のラベルがイーサネット ポートに割り当てられ、リモートのラベル配布プロトコル(Label Distribution Protocol; LDP)によって、そのピア PE にラベルが配布されます。イーサネット フレームは、Ethernet over MPLS(EoMPLS)を使用して、MPLS ネットワーク上を伝送されます。

インターワーキング機能を持つ PE では、FR セグメントから MPLS クラウドへの方向で、ブリッジド カプセル化(FR/SNAP ヘッダー)が廃棄され、イーサネット フレームは、VC タイプ 5(イーサネット)による擬似回線を通じた送信に必要なラベルでカプセル化されます(図18-13)。

反対方向では、MPLS クラウドからのラベルの廃棄後、ブリッジド カプセル化を使用して FR上のイーサネット フレームがカプセル化されます。

図18-13 に FR to Ethernet ブリッジド インターワーキングのプロトコル スタックを示します。

図18-13 FR to Ethernet AToM ブリッジド インターワーキングのプロトコル スタック ― VLAN ヘッダーあり

 

ATM AAL5 to Ethernet VLAN 802.1Q AToM ― ブリッジド インターワーキング

このインターワーキング タイプは、異なる PE ルータに接続されている FR 接続 VC とイーサネット VLAN 接続 VC の相互運用性を提供します。ブリッジド(イーサネット)インターワーキング メカニズムに対応するブリッジド カプセル化が使用されます。

インターワーキング機能は、フレームリレーによるマルチプロトコル相互接続に基づいて、FR to Ethernet Port の場合と同様に実行され、FR 接続 VC に接続されている PEに実装されます(図18-13 を参照)。

ATM to VLAN の場合と同様、イーサネット側の相違点は、着信パケットに VLAN ヘッダーがあることです。VLAN 側の PE は、VLAN CE からの着信フレームの VLAN ヘッダーを廃棄し、MPLS クラウドからのイーサネット フレームには VLAN ヘッダーを挿入します。擬似回線(VC タイプ 5 を使用)上を送信されるフレームは VLAN ヘッダーのないイーサネット フレームです。

図18-14 に FR to VLAN AToM ブリッジド インターワーキングのプロトコル スタックを示します。

図18-14 RF to VLAN AToM ブリッジド インターワーキングのプロトコル スタック

 

設定作業および設定例

ここでは、次に示す 2 つの L2VPN テクノロジー ソリューションの設定作業と設定例を示します。

ローカル スイッチング

AToM

ローカル スイッチング

図18-7 に、LS の構成を示します。Cisco 10000 ルータ上の LS インターワーキングでサポートされるのはブリッジド インターワーキング(イーサネット インターワーキング)機能だけです。

ここでは、次の LS 設定の手順と例を示します。

「FR DLCI to Ethernet Port」

「FR DLCI to Ethernet VLAN 802.1Q」

FR DLCI to Ethernet Port

ルータへの FR DLCI to Ethernet port 機能の設定は、次の手順で行います。

1. config t

2. frame-relay switching

3. interface serial slot/subslot/port[:channel | .channel]

4. encapsulation frame-relay

5. frame-relay intf-type dce

6. frame-relay interface-dlci DLCI switched

7. interface [ fastethernet | gigabitethernet ] slot/subslot/port

8. no ip address

9. connect connection-name [ fastethernet | gigabitethernet ] slot/subslot/port serial slot/subslot/port[:channel | .channel] interworking ethernet


connect コマンド内のインターフェイスの順序は重要ではありません。


ルータに対する FR DLCI to Ethernet Port 機能の設定例を示します。

config t
frame-relay switching
interface serial 2/0/0:1
encapsulation frame-relay
frame-relay intf-type dce
frame-relay interface-dlci 100 switched
interface gigabitethernet 5/1/0
no ip address
connect atm-enet gigabitethernet 5/1/0 serial 2/0/0:1 100 interworking ethernet

FR DLCI to Ethernet VLAN 802.1Q

ルータへの FR DLCI to Ethernet VLAN 802.1Q 機能の設定は、次の手順で行います。

1. config t

2. frame-relay switching

3. interface serial slot/subslot/port[:channel | .channel]

4. encapsulation frame-relay

5. frame-relay intf-type dce

6. frame-relay interface-dlci DLCI switched

7. interface [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface

8. encapsulation dot1q VLAN-ID

9. connect connection-name [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface serial slot/subslot/port[:channel | .channel] interworking ethernet


connect コマンド内のインターフェイスの順序は重要ではありません。


ルータに対する FR DLCI to Ethernet VLAN 802.1Q 機能の設定例を示します。

config t
frame-relay switching
interface serial 2/0/0:1
encapsulation frame-relay
frame-relay intf-type dce
frame-relay interface-dlci 100 switched
interface gigabitethernet 5/1/0.3
encapsulation dot1q 2
connect fr-vlan gigabitethernet 5/1/0.3 serial 2/0/0:1 100 interworking ethernet

AToM

図18-8 に、AToM の構成を示します。Cisco 10000 ルータ上の AToM インターワーキングでサポートされるのはブリッジド インターワーキング(イーサネット インターワーキング)機能だけです。

ここでは、次の AToM 設定の手順と例を示します。

「FR DLCI to Ethernet Port」

「FR DLCI to Ethernet VLAN 802.1Q」

FR DLCI to Ethernet Port

PE1 ルータへの FR DLCI to Ethernet port 機能の設定は、次の手順で行います。

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet

8. frame-relay switching

9. interface serial slot/subslot/port[:channel | .channel]

10. encapsulation frame-relay

11. frame-relay interface-dlci DLCI switched

12. connect mpls serial slot/subslot/port[:channel | .channel] DLCI l2transport

13. xconnect remote-ip-address vc-id pw-class name

PE2 ルータへの FR DLCI to Ethernet port 機能の設定は、次の手順で行います。

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interface [ fastethernet | gigabitethernet ] slot/subslot/port

8. xconnect remote-ip-address vc-id pw-class name


) PE2 の設定は、同種間として処理され、また接続回線がすでにイーサネット ポートであるため、interworking ethernet コマンドはありません。


PE1 ルータに対する FR DLCI to Ethernet port 機能の設定例を示します。

config t
mpls label protocol ldp
interface Loopback100
ip address 10.0.0.100 255.255.255.255
pseudowire-class fr-eth
encapsulation mpls
interworking ethernet
frame-relay switching
interface serial 2/0/0:1
encapsulation frame-relay
frame-relay intf-type dce
connect mpls serial 2/0/0:1 567 l2transport
xconnect 10.0.0.200 150 pw-class fr-eth
 

PE2 ルータに対する FR DLCI to Ethernet port 機能の設定例を示します。

config t
mpls label protocol ldp
interface Loopback200
ip address 10.0.0.200 255.255.255.255
pseudowire-class fr-eth
encapsulation mpls
interface gigabitethernet 5/1/0
xconnect 10.0.0.100 150 pw-class fr-eth

FR DLCI to Ethernet VLAN 802.1Q

PE1 ルータへの FR DLCI to Ethernet VLAN 802.1Q 機能の設定は、次の手順で行います。

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet

8. frame-relay switching

9. interface serial slot/subslot/port[:channel | .channel]

10. encapsulation frame-relay

11. frame-relay intf-type dce

12. frame-relay interface-dlci DLCI switched

13. connect mpls serial slot/subslot/port[:channel | .channel] DLCI l2transport

14. xconnect remote-ip-address vc-id pw-class name

PE2 ルータへの FR DLCI to Ethernet VLAN 802.1Q 機能の設定は、次の手順で行います。

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet

8. interface [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface

9. encapsulation dot1q VLAN-ID

10. xconnect remote-ip-address vc-id pw-class name


) FR DLCI to VLAN の場合は、PE2 の設定に interworking ethernet コマンドが含まれます。


PE1 ルータに対する FR DLCI to Ethernet VLAN 802.1Q 機能の設定例を示します。

config t
mpls label protocol ldp
interface Loopback100
ip address 10.0.0.100 255.255.255.255
pseudowire-class fr-vlan
encapsulation mpls
interworking ethernet
frame-relay switching
interface serial 2/0/0:1
encapsulation frame-relay
frame-relay intf-type dce
connect mpls serial 2/0/0:1 567 l2transport
xconnect 10.0.0.200 150 pw-class fr-vlan
 

PE2 ルータに対する FR DLCI to Ethernet VLAN 802.1Q 機能の設定例を示します。

config t
mpls label protocol ldp
interface Loopback200
ip address 10.0.0.200 255.255.255.255
pseudowire-class fr-vlan
encapsulation mpls
interworking ethernet
interface gigabitethernet 5/1/0.3
encapsulation dot1q 1525
xconnect 10.0.0.100 150 pw-class fr-vlan

) L2VPN インターワーキングのステータスを確認し、統計情報を調べる場合は、「L2VPN インターワーキングの確認」を参照してください。


L2VPN インターワーキングの確認

L2VPN ステータス(ローカル スイッチング)の確認には、次のコマンドを使用します。

show connection [ all | name | id | elements | port ]

show pxf cpu atom [ circuits | interface | vcci ]

L2VPN 統計(ローカル スイッチング)の表示には、次のコマンドを使用します。

show pxf cpu statistics atom

L2VPN ステータス(AtoM)の確認には、次のコマンドを使用します。

show connection [ all | name | id | elements | port ]

show xconnect [ all | interface | peer ]

show mpls l2transport [ binding | checkpoint | hw-capability | summary | vc ]

show mpls infrastructure lfd pseudowire vcid

show pxf cpu atom [ circuits | interface | vcci ]

L2VPN 統計(AtoM)の確認には、次のコマンドを使用します。

show pxf cpu statistics atom

show pxf cpu subblocks