Cisco 10000 シリーズ ルータ ソフトウェア コンフィギュレーション ガイド
L2 VPN の設定
L2 VPN の設定
発行日;2012/02/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

L2 VPN の設定

L2VPN 機能の履歴

サポートされている L2VPN トランスポート タイプ

L2VPN:AToM の要件

サポート対象のラインカード

L2VPN の制約事項

規格および RFC

MIB

NSF/SSO ― L2VPN

AToM 情報のチェックポインティング

チェックポインティングのトラブルシューティングに関するヒント

NSF/SSO ― L2VPN の要件

MPLS HA 環境内のネイバー ルータ

SSO

ルーティング プロトコルの NSF

NSF/SSO ― L2VPN の制約事項

NSF/SSO ― L2VPN の設定

NSF/SSO ― L2VPN の設定例

L2VPN ローカル スイッチング ― HDLC/PPP

L2VPN ローカル スイッチング ― HDLC/PPPの要件

L2VPN ローカル スイッチング ― HDLC/PPPの制約事項

PPP Like-to-Like ローカル スイッチング

HDLC Like-to-Like ローカル スイッチング

設定作業および設定例

L2VPN の設定作業

擬似配線 ― AToM 回線の設定

ATM AAL5 SDU support over MPLS の設定

ATM AAL5 SDU support over MPLS の確認

ATM 相互間 PVC ローカル スイッチングの設定

ATM AAL5 SDU support over MPLS の OAM セル エミュレーションの設定

PVC 上の ATM AAL5 SDU support over MPLS に対する OAM セル エミュレーションの設定

VC クラス設定モードによる ATM AAL5 SDU support over MPLS への OAM セル エミュレーションの設定

EoMPLS の設定

EoMPLS の制約事項

VLAN モードでの EoMPLS の設定

ポート モードでの EoMPLS の設定

AToM 用 IEEE 802.1Q Tunneling ― QinQ

AToM 用 IEEE 802.1Q Tunneling(QinQ)の要件

AToM 用 IEEE 802.1Q Tunneling(QinQ)の制約事項

イーサネット VLAN QinQ AToM

設定例

QinQ AToM の確認

リモート イーサネット ポート シャットダウン

リモート イーサネット ポート シャットダウンの設定に関する制約事項

リモート イーサネット ポート シャットダウンの設定

VLAN ID の書き換えによる EoMPLS の設定

FRoMPLS の設定

DLCI 間接続による FRoMPLS の設定

ポート間接続による FRoMPLS の設定

フレームリレー パケットを送信するための他の PE 装置のイネーブル化

フレームリレー相互間ローカル スイッチングの設定

ローカル スイッチングのフレームリレーの設定

フレームリレーの同一ポート スイッチングの設定

フレームリレーのレイヤ 2 ローカル スイッチングの確認

QoS 機能の設定

HDLCoMPLS と PPPoMPLS の設定

HDLCoMPLS の制約事項

PPPoMPLS の制約事項

HDLCoMPLS または PPPoMPLS の設定

コア ネットワークを通るパケット サイズの見積もり

パケット サイズの見積もり ― 例

P ルータと PE ルータの MTU サイズの変更

AToM での EXP ビットの設定

QoS 機能の設定

L2VPN のモニタリングおよびメンテナンス

設定例 ― FRoMPLS

AToM ― トンネル選択

設定例 ― AToM:トンネル選択

L2 VPN の設定

Service Provider(SP; サービス プロバイダー)は収益性を高めるため、運用コストを抑える新しいサービスを導入しています。管理するネットワーク数を削減するためには、ネットワークの収束、ネットワークのマルチフェーズ遷移を使用します。これはコアおよびエッジ/集約側の両方に影響を与えます。テクノロジーは、Multiprotocol Lavel Switching(MPLS; マルチプロトコル ラベル スイッチング)に基づくコア ネットワークが主流となっています。ただし、IP コアは大規模な SP の多くが選択するサービスです。IP コアおよび MPLS コアは、いずれもマルチサービス トラフィックを伝送します。ネットワークのエッジは、レイヤ 2 サービスとレイヤ 3 サービス間を収束するための単一のネットワーク要素を提供する複数のネットワーク要素により構築されています。

次の Layer 2 Virtual Private Network(L2VPN; L2 バーチャル プライベート ネットワーク)ソリューションを使用することで、既存または新生のレイヤ 2 トランスポート テクノロジーが統合型のMPLS ネットワークまたは IP コア ネットワークを介してインターワーキングできるようになります。

Virtual Private Wire Services(VPWS) ― 従来のインターフェイスに相互接続された個々のポイントツーポイント接続からなるポイントツーポイント サービス

Virtual Private LAN Service(VPLS) ― ポイントツーマルチポイント接続のセットからなるサービス

L2VPN 機能は、VPWS タイプで、キャリアに利益をもたらすように設計されています。L2VPN 機能により、ネットワーク リソースを透過的に使用したり、管理の必要があるネットワーク数を減らすことが可能になります。

Cisco Nonstop Fowarding(NSF)with Stateful Switchover(SSO)は、ネットワーク サービスのアベイラビリティを向上させるのに効果があります。Cisco NSF with SSO により、ネットワーク プロセッサにハードウェアまたはソフトウェア障害がある場合でも、パケットを転送し続けることができます。冗長システムでは、プライマリ プロセッサに重大な障害がある場合に、セカンダリ プロセッサがコントロール プレーンのサービスを回復します。SSO は、プライマリ プロセッサとセカンダリ プロセッサ間でネットワーク ステート情報を同期させます。

Any Transport over MPLS(AToM)は、NSF、SSO、およびグレースフル リスタートを使用して、Route Processor(RP; ルート プロセッサ)が MPLS フォワーディング ステートを維持したまま、コントロール プレーンの中断から回復するのを可能にします。Cisco IOS Release 12.2(33)SB で、L2VPN 機能が NSF/SSO をサポートします。「NSF/SSO ― L2VPN」を参照してください。

Cisco 10000 シリーズ ルータでは、次の L2VPN テクノロジー ソリューションもサポートしています。

Local Switching(LS; ローカル スイッチング) ― 順序付けられた二重<AC, AC>これは、Cisco 10000 シリーズ ルータ シャーシ内の 2 つの Attachment Circuits(AC)のポイントツーポイント相互接続です。さらに、2 つの AC には、次のタイプがあります。

同じタイプ ― like-to-like LS 接続を作成

異なるタイプ ― any-to-any LS 接続を作成

AToM ― 順序付けられた三重<AC, PW, AC>これは、擬似配線(MPLS)を介する、異なる Cisco 10000 シリーズ ルータ シャーシの 2 つの AC によるポイントツーポイント相互接続です。また、like-to-like AToM 接続が存在する場合、2 つの AC は 同じタイプとすることもできます。または、any-to-any AToM 接続が存在する場合、2 つの AC は 異なるタイプとすることができます。

AToM 回線セッションは、ラベル配布プロトコル(Label Distribution Protocol; LDP)を使用して、2 つの PE ルータ間の一意の Virtual Circuit(VC; バーチャル サーキット)によって特定されます。レイヤ 2 フレームがインポジション PE ルータで受信されると、VC ラベル、IGP ラベル、あるいはその他のラベルを付けた MPLS パケットにカプセル化されます。MPLS パケットがディスポジション PE ルータに到達すると、レイヤ 2 のカプセル化に再変換されます。

AToM は、レイヤ 2 フレームを入力(またはインポジション)Provider Edge(PE; プロバイダー エッジ)ルータでカプセル化し、接続の反対側にある、対応する PE ルータに送信します。対応するルータは出力(またはディスポジション)PE ルータで、カプセル化を削除し、レイヤ 2 フレームを送信します。

PE ルータ間でレイヤ 2 フレームを正しく伝送するには、PE ルータの設定が必要です。ルータ間に、擬似配線と呼ばれる接続を設定します。AToM 回線は、擬似配線接続の 1 つのタイプです。

MPLS ネットワークでレイヤ 2 パケットを送信することの利点

MPLS ネットワークでレイヤ 2 パケットを送信する際の利点の一部として、次のようなものがあります。

AToM 製品セットは、さまざまなタイプのレイヤ 2 パケット(イーサネット、フレームリレーなど)に対応しており、複数のシスコのルータ プラットフォームで利用できます。このため、サービス プロバイダーは、バックボーン上ですべてのタイプのトラフィックを送信し、すべてのタイプのお客様に対応できます。

AToM は、MPLS 上でレイヤ 2 パケットを送信するために開発された規格に準拠しています(AToM が準拠する規格については、規格および RFCを参照してください)。これは、業界標準の方法論でネットワークを構築しようと考えるサービス プロバイダーにとって最適です。これ以外のレイヤ 2 ソリューションは独自に開発されたもので、サービス プロバイダーのネットワーク拡張が制限されたり、特定ベンダーの装置しか使用できないことがあります。

AToM へのアップグレードは、お客様に対して透過的に行われます。サービス プロバイダーのネットワークはカスタマー ネットワークとは独立しているため、サービス プロバイダーは、お客様へのサービスを中断することなく AToM へのアップグレードを行うことができます。お客様からは、従来のレイヤ 2 バックボーンを使用しているように見えます。

インポジション ルータでコントロール ワード(別名、「 シム 」ヘッダー)を追加することができます。追加された場合、このコントロール ワードがディスポジション ルータで削除されます。

Cisco 10000 シリーズ ルータは、最大 8000 の AC をサポートします。AToM 回線では 1 つの AC を使用し、LS 回線では 2 つの AC を使用します。すなわち、Cisco 10000 シリーズ ルータは、8000 の AToM 接続、4000 の LS 接続、または合計で最大 8000 の AC となる AToM 接続と LS 接続両方の任意の組み合わせをサポートします。また、トンネル選択により、AToM トラフィックが使用するパスを指定することもできます。「AToM ― トンネル選択」を参照してください。

この章の内容は次のとおりです。

「L2VPN 機能の履歴」

「サポートされている L2VPN トランスポート タイプ」

「L2VPN:AToM の要件」

「L2VPN の制約事項」

「規格および RFC」

「MIB」

「NSF/SSO ― L2VPN」

「L2VPN ローカル スイッチング ― HDLC/PPP」

「L2VPN の設定作業」

「L2VPN のモニタリングおよびメンテナンス」

「設定例 ― FRoMPLS」

「AToM ― トンネル選択」

L2VPN 機能の履歴

 

Cisco IOS リリース
説明
必要な PRE

12.2(28)SB

この機能が Cisco 10000 シリーズ ルータに導入されました。

PRE2

12.2(31)SB2

PRE3 へのサポートが追加されました。

PRE3

12.2(31)SB2

Ethernet to VLAN over AToM(ブリッジド)機能が追加されました。

PRE2/PRE3

12.2(33)SB

Cisco 10000 シリーズ ルータで次の L2VPN 機能が追加されました。

AToM 用 IEEE 802.1Q Tunneling(QinQ)

NSF/SSO ― AToM

AToM:リモート イーサネット ポート シャットダウン

AToM:トンネル選択

L2VPN ローカル スイッチング ― HDLC/PPP

イーサネット/VLAN から ATM AAL5 へのインターワーキング

イーサネット VLAN からフレーム リレーへのインターワーキング

PRE2/PRE3/PRE4

サポートされている L2VPN トランスポート タイプ

Cisco IOS Release 12.2(28)SB では、Cisco 10000 シリーズ ルータが次の AToM トランスポート タイプをサポートしています。

ATM AAL5 SDU support over MPLS

Ethernet over MPLS(EoMPLS)

VLAN モード

ポート モード

FRoMPLS

DLCI 間接続

ポート間接続

HDLCoMPLS

PPPoMPLS


) 機能的には、HDLCoMPLS とフレーム リレーのポート間接続は同じです。


L2VPN:AToM の要件

L2VPN の設定を開始する前に、ネットワークを次のように設定しておいてください。

PE ルータが IP を使用して相互に通信できるように、コアの IP ルーティングを設定します。

ラベル配布プロトコルをラベル配布プロトコルとして設定します。

PE ルータ間に Label-Switched Path(LSP; ラベル スイッチド パス)を設定します。インポジションとディスポジション PE ルータ間のすべてのパスでダイナミック MPLS ラベリングをイネーブルにするには、mpls ip コマンドを使用します。

レイヤ 2 トラフィックの開始地点と終了地点にループバック インターフェイスを設定します。PE ルータが別のルータのループバック インターフェイスにアクセスできるようにしてください。ループバック インターフェイスが不要な場合もあります。たとえば、AToM が TE トンネルに直接マッピングされる場合は、トンネル選択にループバック インターフェイスは必要ありません。


) L2VPN:LS の場合、次の設定を行う必要はありません

― ラベル配布プロトコルとして設定するラベル配布プロトコル

― mpls ip コマンドを使用する PE ルータ間の LSP


サポート対象のラインカード

表17-1 に、Cisco 10000 シリーズ ルータでサポートされているライン カードを示します。

 

表17-1 L2VPN をサポートする Cisco 10000 シリーズ ラインカード

トランスポート タイプ
サポート対象のラインカード

ATM AAL5 SDU support over MPLS

4 ポート OC-3/STM-1 ATM
8 ポート E3/DS3 ATM
1 ポート OC-12 ATM

EoMPLS:
VLAN モード
ポート モード

8 ポート ファスト イーサネット ハーフハイト
1 ポート ギガビット イーサネット ハーフハイト
1 ポート ギガビット イーサネット

SIP-600
SPA-1X10GE-L-V2(10GE)
SPA-2X1GE-V2(2 ポート GE)
SPA-5X1GE-V2(5 ポート GE)

FRoMPLS:
DLCI 間接続
ポート間接続

HDLCoMPLS

PPPoMPLS

24 ポート チャネライズド E1/T1
1 ポート チャネライズド OC-12/STM-4
4 ポート チャネライズド OC-3/STM-1
4 ポート チャネライズド T3
6 ポート チャネライズド T3

8 ポート 非チャネライズド E3/T3

6 ポート OC-3/STM1 Packet over SONET(PoS)
1 ポート OC-12 PoS
1 ポート OC-48/STM-16 PoS

L2VPN の制約事項

L2VPN 機能には次の制約事項があります。

アドレス形式:すべての PE ルータの LDP ルータ ID を、/32 のマスクを持つループバック アドレスとして設定します。この設定をしない場合、設定の一部が正しく機能しないことがあります。

最大伝送ユニット(Maximum Transmission Unit; MTU)は、回線の両側で同じである必要があります。途中でパケットがフラグメンテーションしないように、回線の両端の MTU サイズをコア内の MTU サイズより小さくする必要があります。

次の L2VPN 機能はサポートされていません。

すべての ATM セル スイッチング

ATM AAL5 PDU モード

フラグメンテーションおよび再構成:内容は 2004 年 2 月の draft-ietf-pwe3-fragmentation-05.txt の『PWE3 Fragmentation and Reassembly』に定義されています。

制御ワードでのシーケンス番号のサポート

トンネル スイッチング

擬似配線の終端

規格および RFC

L2VPN は、 表17-2 の業界標準と RFC に準拠しています。

 

表17-2 L2VPN でサポートされている規格と RFC

規格または RFC
タイトル

draft-martini-l2circuit-trans-mpls-08.txt

Transport of Layer 2 Frames over MPLS

draft-martini-l2circuit-encap-mpls-04.txt

Encapsulation Methods for Transport of Layer 2 Frames over MPLS

RFC 3032

MPLS Label Stack Encoding

RFC 3036

LDP Specification

MIB

表17-3 に、L2VPN でサポートされている MIB を示します。

 

表17-3 L2VPN でサポートされている MIB

トランスポート タイプ
MIB

ATM AAL5 SDU support over MPLS

MPLS LDP MIB(MPLS-LDP-MIB.my)

ATM MIB(ATM-MIB.my)

CISCO AAL5 MIB(CISCO-AAL5-MIB.my)

Cisco Enterprise ATM Extension MIB
(CISCO-ATM-EXT-MIB.my)

Supplemental ATM Management Objects(CISCO-IETF-ATM2-PVCTRAP-MIB.my)

Interfaces MIB(IF-MIB.my)

EoMPLS:
VLAN モード
ポート モード

CISCO-ETHERLIKE-CAPABILITIES.my

Ethernet MIB(ETHERLIKE-MIB.my)

Interfaces MIB(IF-MIB.my)

MPLS LDP MIB(MPLS-LDP-MIB.my)

FRoMPLS:
DLCI 間接続
ポート間接続

Cisco Frame Relay MIB(CISCO-FRAME-RELAY-MIB.my)

Interfaces MIB(IF-MIB.my)

MPLS LDP MIB(MPLS-LDP-MIB.my)

HDLCoMPLS

PPPoMPLS

MPLS LDP MIB(MPLS-LDP-MIB.my)

Interfaces MIB(IF-MIB.my)

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を探して、ダウンロードするには、次の URL にある Cisco MIB Locator を使用してください。

http://tools.cisco.com/go/mibs

NSF/SSO ― L2VPN

L2VPN NSF により、AToM を使用してカスタマーにレイヤ 2 VPN サービスを提供するサービス プロバイダー ネットワークのアベイラビリティが改善されます。ハイ アベイラビリティ(HA)を実現することにより、提供されるサービスの中断を最小限に抑えながら、障害の検出および管理が可能になります。L2VPN NSF は、SSO メカニズムと NSF メカニズムにより達成されます。スタンバイ RP は、コントロール プレーンの冗長性を提供します。AToM L2VPN に NSF を提供するため、AC および AToM 擬似配線(PW)のコントロール プレーン ステートおよびデータ プレーンのプロビジョニング情報は、スタンバイ RP にチェックポイントされます。

AToM 情報のチェックポインティング

チェックポインティング機能により、アクティブ RP からバックアップ RP にステート情報がコピーされて、バックアップ RP で常に最新の情報を維持できるようになります。アクティブ RP に障害発生すると、バックアップ RP が引き継ぎます。

L2VPN NSF 機能の場合、チェックポインティング機能によりアクティブ RP の情報がコピーされ、バックアップ RP にバインドされます。アクティブ RP では、情報が変更されるとアップデートをバックアップ RP に送信します。

チェックポインティング データを表示するには、アクティブ RP およびバックアップ RP 上で show acircuit checkpoint コマンドを発行します。アクティブ RP およびバックアップ RP では、同じ情報のコピーが維持されます。

チェックポインティングのトラブルシューティングに関するヒント

チェックポインティング エラーのトラブルシュートに役立てるには、次のコマンドを入力します。

debug acircuit checkpoint コマンド ― AC のチェックポインティング デバッグ メッセージをイネーブルにする

debug mpls l2transport checkpoint コマンド ― AToM のチェックポインティング デバッグ メッセージをイネーブルにする

show acircuit checkpoint コマンド ― AC のチェックポイント情報を表示する

show mpls l2transport checkpoint コマンド ― チェックポインティングが許可されているかどうか、バルク同期された AToM VC 数(アクティブ RP 上)、およびチェックポイント データを維持する AToM VC数(スタンバイ RP 上)を表示する

show mpls l2transport vc detail コマンド ― チェックポイントされた VC の詳細情報を表示する

NSF/SSO ― L2VPN 機能については、次の項目で説明します。

「NSF/SSO ― L2VPN の要件」

「NSF/SSO ― L2VPN の制約事項」

「NSF/SSO ― L2VPN の設定」

「NSF/SSO ― L2VPN の設定例」

NSF/SSO ― L2VPN の要件

ここでは、この機能に関する次の要件について示します。

MPLS HA 環境内のネイバー ルータ

SSO

ルーティング プロトコルの NSF

MPLS HA 環境内のネイバー ルータ

Cisco 10000 ルータは、ネイバー デバイスとして使用する必要があります。

SSO

この機能については、次の URL にある『 NSF/SSO:Any Transport over MPLS and Graceful Restart 』マニュアルの「Stateful Switchover」を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2s/feature/guide/fsatomha.html#wp1098167

ルーティング プロトコルの NSF

この機能については、次の URL にある『 NSF/SSO:Any Transport over MPLS and Graceful Restart 』マニュアルの「Nonstop Forwarding for Routing Protocols」を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2s/feature/guide/fsatomha.html#wp1098561

NSF/SSO ― L2VPN の制約事項

この機能については、次の URL にある『 NSF/SSO:Any Transport over MPLS and Graceful Restart 』マニュアルの「Restrictions for AToM NSF」を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2s/feature/guide/fsatomha.html#wp1068923

NSF/SSO ― L2VPN の設定

この機能については、次の URL にある『 NSF/SSO:Any Transport over MPLS and Graceful Restart 』マニュアルの「How to Configure AToM NSF」を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2s/feature/guide/fsatomha.html#wp1112888

NSF/SSO ― L2VPN の設定例

例17-1 では、2 つの PE ルータ上で AToM NSF を設定します。

例17-1 AToM NSF によるイーサネットと VLAN のインターワーキング

 

PE1
PE2
ip cef
!
redundancy
mode sso
!
mpls ldp graceful-restart
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp advertise-tags
!
pseudowire-class atom-eth
encapsulation mpls
interworking ethernet
!
interface Loopback0
ip address 10.8.8.8 255.255.255.255
!
interface FastEthernet1/1/0
xconnect 10.9.9.9 123 encap mpls pw-class atom_eth
 
interface POS6/1/0
ip address 10.1.1.1 255.255.255.0
mpls ip
mpls label protocol ldp
clock source internal
crc 32
!
interface Loopback0
ip address 10.8.8.8 255.255.255.255
no shutdown
!
router ospf 10
nsf ietf
network 10.8.8.8 0.0.0.0 area 0
network 19.1.1.1 0.0.0.0 area 0
ip cef
!
redundancy
mode sso
!
 
mpls ldp graceful-restart
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp advertise-tags
!
pseudowire-class atom-eth
encapsulation mpls
interworking eth
!
interface Loopback0
ip address 10.9.9.9 255.255.255.255
!
interface FastEthernet3/0/0
ip route-cache cef
!
interface FastEthernet3/0/0.3
encapsulation dot1Q 10
xconnect 10.8.8.8 123 encap mpls pw-class atom_eth
 
interface POS1/0/0
ip address 10.1.1.2 255.255.255.0
mpls ip
mpls label protocol ldp
clock source internal
crc 32
!
interface Loopback0
ip address 10.9.9.9 255.255.255.255
!
router ospf 10
nsf ietf
network 10.9.9.9 0.0.0.0 area 0
network 10.1.1.2 0.0.0.0 area 0

) ルーティング プロトコルでは、NSF がイネーブルである必要があります。オプションは、cisco または ietf のいずれかを使用できます。ietf オプションが標準オプションであるのに対して、cisco 専用オプションであるため、例17-1 では ietf オプションを使用しています。


L2VPN ローカル スイッチング ― HDLC/PPP

L2VPN ローカル スイッチング ― HDLC/PPP 機能により、サービス プロバイダーはバックツーバック回線として機能する HDLC ローカル スイッチド回線上での異なるカプセル化をサポートすることができます。プロビジョニングされた HDLC ローカル スイッチド回線も、PWRED を使用することにより戻すことができます。

L2VPN ローカル スイッチング ― HDLC/PPPの要件

Cisco IOS Release 12.2(33)SB の、L2VPN ローカル スイッチング ― HDLC/PPP では、PE ルータ上でインターフェイスが、常に HDLC カプセル化されている必要があります。CE ルータはフレーム リレーおよび PPP など、任意の HDLC ベースのカプセル化を選択できます。

L2VPN ローカル スイッチング ― HDLC/PPPの制約事項

Cisco IOS Release 12.2(33)SB の L2VPN ローカル スイッチング ― HDLC/PPP 機能には、次の制約事項があります。

PE HDLC インターフェイス上では、IP アドレスは connect コマンドと競合するため、設定することができません。

HDLC/PPP インターフェイス上では、インターワーキングはサポートされません。

低速のインターフェイスをオーバーランする高速のインターフェイスのためにいずれかのパケットがドロップされないようにするため、同じ速度のインターフェイスだけを接続する必要があります。

時間遅延に影響されやすい一部の HDLC/PPP アプリケーションでは、PE がいくらかのネットワーク遅延を取り込む可能性があります。これにより、HDLC/PPP リンクがプロトコル タイムアウトが原因でアップできなくなります(ISDN Q921 リンク)。

PPP Like-to-Like ローカル スイッチング

2 つの CE 間での圧縮された音声の伝送など、一部のアプリケーションでは、同じ PE ルータに接続された 2 つの CE ルータ間でエンドツーエンドの PPP セッションをセットアップする必要があります。このような場合、HDLC パススルー メカニズムが提起され、インターワーキング シナリオは like-to-like サービス用に PPP トランスポートへと簡素化されます。PE ルータ上の PPP ローカル スイッチング機能では、異なる CE ルータ上で検出された 2 つのエンドユーザ間に単純な HDLC 接続を提供します(図17-1 を参照)。

図17-1 PPP ローカル スイッチング

 

インターフェイスは、PE ルータ上では HDLC カプセル化されます。CE ルータは、PPP ベースのカプセル化を使用する場合があります。

PE ルータにより操作されたフレームは、PPP ヘッダーを保持します(RFC-1661 で規定)。

HDLC Like-to-Like ローカル スイッチング

HDLC セッションは、PPP の場合と同様、同じ PE ルータに接続された 2 つの CE ルータ間で転送できます。マイクロコードには、HDLC トラフィックの HDLC パススルー メカニズムが実装されます。提供されるサービスは 2 つの CE ルータ間のバックツーバック シリアル接続と同等となるため、最大伝送ユニット設定が一致する同じ速度のインターフェイス間での接続となる必要があります。特定のインターフェイスが他のインターフェイスをオーバーランできないため、PE ルータ上には QoS 要件がありません。

インターフェイスは、PE ルータ上では HDLC カプセル化されます。CE ルータは、フレーム リレーなど、任意の HDLC ベースのカプセル化を使用します。

設定作業および設定例

PE ルータで L2VPN ローカル スイッチング ― HDLC/PPP 機能を設定する手順は、次のとおりです。

1. config t

2. interface serial slot/subslot/port:channel-id

3. encapsulation hdlc

4. interface serial slot/subslot/port:channel-id

5. encapsulation hdlc

6. connect connection-name interface interface

次に、PE ルータ上で L2VPN ローカル スイッチング ― HDLC/PPP 機能を設定する例を示します。

config t
interface serial 3/0/20:0
encapsulation hdlc
interface serial 4/0/11:9
encapsulation hdlc
connect hdlcls serial3/0/20:0 serial4/0/11:9

) シリアル インターフェイスのデフォルトのカプセル化は HDLC であるため、encapsulation コマンドはオプションです。ただし CE ルータを設定する場合は、設定が異なるため、encapsulation コマンドを指定する必要があります。


CE ルータ上で PPP を設定する手順は、次のとおりです。

1. config t

2. interface serial slot/subslot/port:channel-id

3. encapsulation ppp

CE ルータ上で HDLC を設定する手順は、次のとおりです。

1. config t

2. interface serial slot/subslot/port:channel-id

3. encapsulation hdlc

L2VPN の設定作業

L2VPN を設定するには、次の L2VPN 機能を設定する必要があります。

「擬似配線 ― AToM 回線の設定」

「ATM AAL5 SDU support over MPLS の設定」

「ATM 相互間 PVC ローカル スイッチングの設定」

「ATM AAL5 SDU support over MPLS の OAM セル エミュレーションの設定」

「EoMPLS の設定」

「AToM 用 IEEE 802.1Q Tunneling ― QinQ」

「リモート イーサネット ポート シャットダウン」

「FRoMPLS の設定」

「フレームリレー相互間ローカル スイッチングの設定」

「HDLCoMPLS と PPPoMPLS の設定」

「コア ネットワークを通るパケット サイズの見積もり」

「AToM での EXP ビットの設定」

「QoS 機能の設定」

擬似配線 ― AToM 回線の設定

PE ルータ間でレイヤ 2 フレームを正しく伝送するには、ルータ間に擬似配線と呼ばれる接続を設定する必要があります。各 PE ルータに次の情報を指定します。

イーサネット、フレームリレー、または ATM など、擬似配線で送信されるレイヤ 2 データのタイプ

PE ルータ 間の通信を可能にするピア PE ルータのループバック インターフェイスの IP アドレス

擬似配線を特定するピア PE IP アドレスと VC ID の一意の組み合わせ

2 つの PE ルータ間で擬似配線接続または AToM 回線を設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# pseudowire-class name

(任意)指定する名前で擬似配線クラスを設定し、トンネリング カプセル化を指定します。xconnect コマンドの一部としてトンネリング方法を指定する場合は、擬似配線クラスを指定する必要がありません。

擬似配線クラス コンフィギュレーション グループは、次の内容を含むトンネリング メカニズムの特性を指定します。

カプセル化タイプ

制御プロトコル

ペイロード固有のオプション

ステップ 2

Router(config)# interface interface-type interface-number

PE ルータ上のインターフェイスまたはサブインターフェイスを定義します。

ステップ 3

Router(config-if)# encapsulation encapsulation-type

dot1q など、インターフェイスのカプセル化タイプを指定します。

ステップ 4

Router(config-if)# xconnect peer-router-id vcid encapsulation mpls

ピア PE ルータの LDP ルータ ID を指定して、ピア PE ルータへの接続を行います。

2 つの PE ルータで共有されている一意の ID を特定します。vcid は、32 ビットの ID です。


) ピア ルータ ID と VC ID の組み合わせは、ルータ上で一意の組み合わせである必要があります。複数の回線で、同じピアルータ ID と VC ID の組み合わせを使用することはできません。


擬似配線でデータをカプセル化するためのトンネリング方式を指定します。AToM では、データのカプセル化のトンネリング方式は mpls になります。

例17-2 に、ATM AAL5 SDU over MPLS トランスポートの設定例を示します。0/100 上の Permanent Virtual Circuit(PVC; 相手先固定接続)が、AAL5 トランスポート用に設定されています。

例17-2 ATM AAL5 SDU support over MPLS

interface ATM4/0
pvc 0/100 l2transport
encapsulation aal5
xconnect 13.13.13.13 100 encapsulation mpls

ATM AAL5 SDU support over MPLS の設定

ATM AAL5 SDU support over MPLS は、MPLS パケット内の ATM AAL5 SDU をカプセル化し、MPLS ネットワークを通して転送します。各 ATM AAL5 SDU は、単一パケットとして送信されます。

ATM AAL5 SDU support over MPLS を設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface type slot/port

インターフェイスのタイプ、スロット、およびポート番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# pvc [ name ] vpi/vci l2transport

ATM PVC に名前を作成するか、割り当てます。

l2transport キーワードは、PVC が終端 PVC ではなく、スイッチド PVC であることを指定します。L2transport VC 設定モードを開始します。

ステップ 3

Router(config-if-atm-l2trans-pvc)# encapsulation aal5

PVC の ATM AAL5 カプセル化を指定します。

PE ルータと CE ルータに同じカプセル化タイプを指定してください。

ステップ 4

Router(config-if-atm-l2trans-pvc)# xconnect peer-router-id vcid encapsulation mpls

接続回路を擬似配線 VC にバインドします。

例17-3 では、ATM PVC 上の ATM AAL5 SDU support over MPLS をイネーブルする方法を示します。

例17-3 ATM PVC 上の ATM AAL5 SDU support over MPLS

interface atm1/0
pvc 1/200 l2transport
encapsulation aal5
xconnect 13.13.13.13 100 encapsulation mpls

ATM AAL5 SDU support over MPLS の確認

PVC に ATM AAL5 SDU support over MPLS が設定されていることを確認するには、show mpls l2transport vc コマンドを入力します。例17-4 に、このコマンドの出力例を示します。

例17-4 show mpls l2transport vc コマンドの出力

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
--------- ------------- ------------ ----- ------
ATM1/0 ATM AAL5 1/100 4.4.4.4 100 UP

ATM 相互間 PVC ローカル スイッチングの設定

Cisco 10000 シリーズ ルータでは、次の ATM ラインカードがサポートされています。

4 ポート OC-3/STM-1

8 ポート ES3/D3

1 ポート OC-12

ATM 相互間 PVC ローカル スイッチングを設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface atm slot/port

ATM インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# pvc vpi/vci l2transport

Virtual Path Identifier(VPI; 仮想パス識別子)と Virtual Channel Identifier(VCI; 仮想チャネル識別子)を割り当てます。

l2transport キーワードは、PVC が終端 PVC ではなく、スイッチド PVC であることを指定します。

ステップ 3

Router(cfg-if-atm-l2trans-pvc)# encapsulation layer-type

PVC のカプセル化タイプを指定します。サポートされているレイヤ タイプは AAL5 だけです。

同じルータ上の別の ATM PVC に対して、ステップ 1 ~ 3 を繰り返します。

ステップ 4

Router(config)# connect connection-name interface pvc interface pvc

指定した 2 つの PVC 間のローカル接続を作成します。

例17-5 に、ATM AAL5 SDU モードのレイヤ 2 ローカル スイッチングをイネーブルにする方法を示します。

例17-5 ATM AAL5 SDU モードのレイヤ 2 ローカル スイッチングのイネーブル化

interface atm 1/0/0
pvc 0/100 l2transport
encapsulation aal5
 
interface atm 2/0/0
pvc 0/50 l2transport
encapsulation aal5
connect conn1 atm 1/0/0 0/100 atm 2/0/0 0/50

ATM AAL5 SDU support over MPLS の OAM セル エミュレーションの設定

PE ルータが LSP で OAM セル(Operation, Administration, and Maintenance cell)の送信をサポートしていない場合、OAM セル エミュレーションを使用して、OAM セルをローカルで終端したり、ループバックしたりできます。両方の PE ルータに OAM セル エミュレーションを設定します。OAM セル エミュレーションは、2 つの単方向 LSP を形成して VC をエミュレートします。両方の PE ルータで oam-ac emulation-enable コマンドと oam-pvc manage コマンドを使用して、OAM セル エミュレーションをイネーブルにします。

ルータ上の OAM セル エミュレーションをイネーブルにしたら、終端 VC と同じ方法で ATM VC を設定および管理できます。OAM セル エミュレーションが設定された VC は、設定された間隔でローカル CE ルータにループバック セルを送信できます。

次のいずれかにエンドポイントを設定できます。

エンドツーエンド ループバック(OAM セルをローカル CE ルータに送信します)

セグメント ループバック(PE ルータと CE ルータ間のパス上の装置に OAM セルを送信します)

OAM セルには、次の内容が含まれます。

Alarm Indication Signal(AIS; アラーム表示信号)

Remote Defect Indication(RDI; リモート障害表示)

これらのセルは、VC の障害を特定および報告します。物理リンクまたはインターフェイスの障害が発生すると、中継ノードは、障害の影響を受けたすべてのダウンストリーム装置に OAM AIS セルを挿入します。AIS セルを受信すると、ルータは ATM VC をマークダウンしてから、RDI セルを送信して、リモート エンドに障害を通知します。


) AAL5 SDU support over MPLS の場合、oam-ac emulation-enable コマンドを入力したあとに、oam-pvc manage コマンドを設定できます。


次の方法で、ATM AAL5 SDU support over MPLS に OAM セル エミュレーションを設定できます。

「PVC 上の ATM AAL5 SDU support over MPLS に対する OAM セル エミュレーションの設定」

「VC クラス設定モードによる ATM AAL5 SDU support over MPLS への OAM セル エミュレーションの設定」

PVC 上の ATM AAL5 SDU support over MPLS に対する OAM セル エミュレーションの設定

PVC 上の ATM AAL5 SDU support over MPLS に OAM セル エミュレーションを設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface type slot/port

インターフェイスのタイプ、スロット、およびポート番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# pvc [ name ] vpi/vci l2transport

ATM PVC に名前を作成するか、割り当てます。

l2transport キーワードは、PVC が終端 PVC ではなく、スイッチド PVC であることを指定します。L2 トランスポート VC 設定モードを開始します。

ステップ 3

Router(config-if-atm-l2trans-pvc)# encapsulation aal5

PVC の ATM AAL5 カプセル化を指定します。

PE ルータと CE ルータに同じカプセル化タイプを指定してください。

ステップ 4

Router(config-if-atm-l2trans-pvc)# xconnect peer-router-id vcid encapsulation mpls

接続回路を擬似配線 VC にバインドします。

ステップ 5

Router(config-if-atm-l2trans-pvc)# oam-ac emulation-enable [ ais-rate ]

AAL5oMPLS の OAM セル エミュレーションをイネーブルにします。ais-rate 変数を使用すると、AIS セルの送信レートを指定できます。

有効範囲は 0 ~ 60 秒です。デフォルトは 1 秒です(毎秒 1 つの AIS セルが送信されます)。

ステップ 6

Router(config-if-atm-l2trans-pvc)# oam-pvc manage [ frequency ]

PVC をイネーブルにして、VC の接続を確認するエンドツーエンド OAM セル ループバック セルを生成します。

オプションの frequency 変数は、ループバック セルが伝送される間隔です。有効範囲は 0 ~ 600 秒です。デフォルト値は 10 秒です。

例17-6 に、ATM PVC 上の OAM セル エミュレーションをイネーブルにする方法を示します。

例17-6 ATM PVC 上の OAM セル エミュレーション

interface ATM 1/0/0
pvc 1/200 l2transport
encapsulation aal5
xconnect 13.13.13.13 100 encapsulation mpls
oam-ac emulation-enable
oam-pvc manage
 

例17-7 に、AIS セルの送信レートを毎 30 秒に設定する方法を示します。

例17-7 ATM PVC に対する OAM セル エミュレーションの AIS 送信レートの設定

interface ATM 1/0/0
pvc 1/200 l2transport
encapsulation aal5
xconnect 13.13.13.13 100 encapsulation mpls
oam-ac emulation-enable 30
oam-pvc manage
 

ATM PVC 上の OAM セル エミュレーションの確認

例17-8 の show atm pvc コマンドは、ATM PVC 上で OAM セル エミュレーションがイネーブルにされていることを示します。

例17-8 show atm pvc コマンドの出力

Router# show atm pvc 5/500
 
ATM4/1/0.200: VCD: 6, VPI: 5, VCI: 500
UBR, PeakRate: 1
AAL5-LLC/SNAP, etype:0x0, Flags: 0x34000C20, VCmode: 0x0
OAM Cell Emulation: enabled, F5 End2end AIS Xmit frequency: 1 second(s)
OAM frequency: 0 second(s), OAM retry frequency: 1 second(s)
OAM up retry count: 3, OAM down retry count: 5
OAM Loopback status: OAM Disabled
OAM VC state: Not ManagedVerified
ILMI VC state: Not Managed
InPkts: 564, OutPkts: 560, InBytes: 19792, OutBytes: 19680
InPRoc: 0, OutPRoc: 0
InFast: 4, OutFast: 0, InAS: 560, OutAS: 560
InPktDrops: 0, OutPktDrops: 0
CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0
Out CLP=1 Pkts: 0
OAM cells received: 26
F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 26
OAM cells sent: 77
F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutAIS: 77, F5 OutRDI: 0
OAM cell drops: 0
Status: UP

VC クラス設定モードによる ATM AAL5 SDU support over MPLS への OAM セル エミュレーションの設定

次の手順では、VC クラスで OAM セル エミュレーションを設定する方法について説明します。設定のあと、インターフェイス、サブインターフェイス、または VC に VC クラスを適用できます。VC クラス設定モードで OAM セル エミュレーションを設定してから、VC クラスをインターフェイスに適用する場合、インターフェイス上のすべての VC に VC クラスの設定が適用されます(ただし、サブインターフェイスまたは VC レベルなど、低いレベルで異なる OAM セル エミュレーション値を指定している場合を除く)。

たとえば、OAM セル エミュレーションを指定する VC クラスを作成し、AIS セルのレートを毎 30 秒に設定できます。VC クラスをインターフェイスに適用できます。そして、1 つの PVC の OAM セル エミュレーションをイネーブルにし、AIS セル レートを毎 15 秒に設定します。15 秒に設定された 1 つの PVC を除いて、インターフェイス上のすべての PVC が 30 秒のセル レートを使用します。

VC クラスで OAM セル エミュレーションをイネーブルにしてから、それをインターフェイスに適用するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# vc-class atm name

VC クラスを作成し、VC クラス設定モードを開始します。

ステップ 2

Router(config-vc-class)# encapsulation layer-type

ATM Adaptation Layer(AAL; ATM アダプテーション層)とカプセル化タイプを設定します。

ステップ 3

Router(config-vc-class)# oam-ac emulation-enable [ ais-rate ]

AAL5oMPLS の OAM セル エミュレーションをイネーブルにします。

ais-rate 変数を使用すると、AIS セルの送信レートを指定できます。

有効範囲は 0 ~ 60 秒です。デフォルトは 1 秒です(毎秒 1 つの AIS セルが送信されます)。

ステップ 4

Router(config-vc-class)# oam-pvc manage [ frequency ]

PVC をイネーブルにして、VC の接続を確認するエンドツーエンド OAM セル ループバック セルを生成します。

オプションの frequency 変数は、ループバック セルが伝送される間隔です。有効範囲は 0 ~ 600 秒です。デフォルト値は 10 秒です。

ステップ 5

Router(config-vc-class)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

Router(config)# interface type slot/port

インターフェイスのタイプ、スロット、およびポート番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

Router(config-if)# class-int vc-class-name

ATM メイン インターフェイスまたはサブインターフェイスに VC クラスを適用します。


) PVC に VC クラスを適用することもできます。


ステップ 8

Router(config-if)# pvc [ name ] vpi/vci l2transport

ATM PVC に名前を作成するか、割り当てます。

l2transport キーワードは、PVC が終端 PVC ではなく、スイッチド PVC であることを指定します。L2 トランスポート VC 設定モードを開始します。

ステップ 9

Router(config-if-atm-l2trans-pvc)# xconnect peer-router-id vcid encapsulation mpls

接続回路を擬似配線 VC にバインドします。

例17-9 では、VC クラス設定モードで、ATM AAL5 SDU support over MPLS に OAM セル エミュレーションを設定します。設定のあと、インターフェイスに VC クラスが適用されます。

例17-9 VC クラス設定モードによる ATM AAL5 SDU support over MPLSの OAM セル エミュレーション ― インターフェイスに VC クラスを適用する場合

vc-class atm oamclass
encapsulation aal5
oam-ac emulation-enable 30
oam-pvc manage
interface atm1/0
class-int oamclass
pvc 1/200 l2transport
xconnect 13.13.13.13 100 encapsulation mpls
 

例17-10 では、VC クラス設定モードで、ATM AAL5 over MPLS に OAM セル エミュレーションを設定します。設定のあと、PVC に VC クラスが適用されます。

例17-10 VC クラス設定モードによる ATM AAL5 SDU support over MPLS の OAM セル エミュレーション ― PVC に VC クラスを適用する場合

vc-class atm oamclass
encapsulation aal5
oam-ac emulation-enable 30
oam-pvc manage
interface atm1/0
pvc 1/200 l2transport
class-vc oamclass
xconnect 13.13.13.13 100 encapsulation mpls
 

例17-11 では、VC クラス設定モードで、ATM AAL5 over MPLS に OAM セル エミュレーションを設定します。設定のあと、インターフェイスに VC クラスが適用されます。1 つの PVC に 10 秒の AIS レートの OAM セル エミュレーションが設定されます。この PVC は、30 秒ではなく、10 秒の AIS レートを使用します。

例17-11 VC クラス設定モードによる ATM AAL5 SDU support over MPLSの OAM セル エミュレーション ― インターフェイスに VC クラスを適用する場合

vc-class atm oamclass
encapsulation aal5
oam-ac emulation-enable 30
oam-pvc manage
interface atm1/0
class-int oamclass
pvc 1/200 l2transport
oam-ac emulation-enable 10
xconnect 13.13.13.13 100 encapsulation mpls

EoMPLS の設定

EoMPLS は、MPLS パケット内の Protocol Data Unit(PDU; プロトコル データ ユニット)をカプセル化し、MPLS ネットワークを通して転送することで機能します。各 PDU は単一パケットとして送信されます。EoMPLS の設定方法はいくつかあります。

VLAN モード ― 送信元の 802.1Q VLAN から宛先の 802.1Q VLAN まで、コア MPLS ネットワーク上でイーサネット トラフィックを送信します。

ポート モード ― インターフェイスに入ってくるフレームを MPLS パケットにパッキングし、出力インターフェイスまで MPLS バックボーン上で送信できます。すべてのイーサネット フレームがプリアンブルまたは Frame Check Sequence(FCS; フレーム チェック シーケンス)を添付せずに単一パケットとして送信されます。

VLAN ID の書き換え ― この機能を使用すると、異なる VLAN ID を持つ VLAN インターフェイスをトンネルの両端で使用できます。

次の方法で、EoMPLS を設定できます。

「VLAN モードでの EoMPLS の設定」

「ポート モードでの EoMPLS の設定」

「VLAN ID の書き換えによる EoMPLS の設定」

EoMPLS の制約事項

EoMPLS トランスポートに適用される制約事項は、次のとおりです。

パケット形式:EoMPLS は、IEEE 802.1Q 標準に準拠した VLAN パケットをサポートしています。802.1Q 仕様では、VLAN メンバシップ情報をイーサネット フレームに挿入するための標準方式が規定されています。PE および CE ルータ間では、Inter-Switch Link(ISL; スイッチ間リンク)プロトコルがサポートされていません。

最初の EoMPLS が VLAN モード回線に設定されると、コントローラ(ポート全体)が自動的に混合モードになります。そのコントローラに関連付けられた VLAN モード回線の最後の EoMPLS が削除された場合にだけ、混合モードが解除されます。

AToM 制御ワードがサポートされています。ただし、ピア PE ルータで制御ワードがサポートされていない場合、制御ワードがディセーブルになります。このネゴシエーションは、LDP ラベル バインディングによって行われます。

ハードウェアレベルの Cyclic Redundancy Check(CRC; 巡回冗長検査)エラー、フレーム同期エラー、およびラント パケット付きのイーサネット パケットは、入力時に廃棄されます。

VLAN モードでの EoMPLS の設定

VLAN は、ユーザの物理的な位置に関係なく、機能、プロジェクト チーム、またはアプリケーションによって論理的に分割されたスイッチド ネットワークです。EoMPLS を使用すると、ユーザは異なる場所にある 2 つの VLAN ネットワークを接続できます。PE ルータを MPLS バックボーンの各端に設定し、ポイントツーポイント VC を追加します。MPLS バックボーンの入力ポイントと出力ポイントにある 2 つの PE ルータだけが、レイヤ 2 VLAN トラフィック送信専用の VC を認識しています。他のすべてのルータには、この VC に対するテーブル エントリがありません。

VLAN モードに設定された EoMPLS では、VPN 回線が擬似配線と連動します。ポートは混合モードなので、フレームは VLAN ID でフィルタリングされます。


) VLAN モードでの EoMPLS の設定を、サブインターフェイスで行う必要があります。ただし、Q-in-Q サブインターフェイスには EoMPLS(VLAN モード)を設定できません。


VLAN モードで EoMPLS を設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface gigabitethernet slot/interface.subinterface

ギガビット イーサネット サブインターフェイスを指定して、サブインターフェイス コンフィギュレーション モードを開始します。

隣接する CE ルータのサブインターフェイスが、この PE ルータと同じ VLAN に存在していることを確認してください。

ステップ 2

Router(config-subif)# encapsulation dot1q vlan-id

サブインターフェイスで 802.1Q VLAN パケットを受けられるようにします。

EoMPLS が動作する CE ルータと PE ルータ間のサブインターフェイスは、同じサブネット内に存在しなければなりません。これ以外のサブインターフェイスとバックボーン ルータについては、その必要はありません。

ステップ 3

Router(config-subif)# xconnect peer-router-id vcid encapsulation mpls

接続回路を擬似配線 VC にバインドします。このコマンドの構文は、他のすべてのレイヤ 2 トランスポートで同じです。

ポート モードでの EoMPLS の設定

ポート モードを使用すると、インターフェイスに入ってくるフレームを MPLS パケットにパッキングし、出力インターフェイスまで MPLS バックボーン上で送信できます。プリアンブルまたは FCS が添付されていないすべてのイーサネット フレームが単一パケットとして送信されます。ポート モードを設定するには、メイン インターフェイス モードで xconnect コマンドを使用して、宛先アドレスおよび VC ID を指定します。xconnect コマンドの構文およびセマンティックは、他のすべてのトランスポート タイプと同じです。各インターフェイスは、一意の擬似配線 VC ラベルに対応付けられています。

ポート モードで EoMPLS を設定する場合、次の注意事項に従ってください。

イーサネットに擬似配線 VC タイプを設定します。

ポート モードとイーサネット VLAN モードを両方一緒に使用することはできません。また、ポート間のトランスポート用のメイン インターフェイスをイネーブルにした場合、サブインターフェイスでコマンドを入力することはできません。

ポート モードで EoMPLS を設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface gigabitethernet slot/interface

ギガビット イーサネット インターフェイスを指定して、インターフェイス コンフィギュレーション モードを開始します。

隣接する CE ルータのインターフェイスが、この PE ルータと同じ VLAN に存在していることを確認してください。

ステップ 2

Router(config-if)# xconnect peer-router-id vcid encapsulation mpls

接続回路を擬似配線 VC にバインドします。

このコマンドの構文は、他のすべてのレイヤ 2 トランスポートで同じです。

例17-12 では、VC 123 をイーサネット ポート モードに設定します。

例17-12 ポート モードの EoMPLS

pseudowire-class ethernet-port
encapsulation mpls
interface gigabitethernet1/0
xconnect 10.0.0.1 123 pw-class ethernet-port

) インターフェイス タイプに応じて、interface fastethernet コマンドを使用することもできます。


VLAN モードおよびポート モードの EoMPLS の確認

VC が VLAN モードまたはポート モードに設定されていることを確認するには、show mpls l2transport vc コマンドを使用します。

例17-13 は、EoMPLS が設定されている 2 つの VC を表示します。

VC 2 には、イーサネット VLAN モードが設定されています。

VC 8 には、イーサネット ポート モードが設定されています。

例17-13 show mpls l2transport vc コマンドの出力

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Gi4/0.1 Eth VLAN 2 11.1.1.1 2 UP
Gi8/0/1 Ethernet 11.1.1.1 8 UP
 

show mpls l2transport vc detail コマンドを入力する場合も出力は同様になります(例17-14 を参照)。

例17-14 show mpls l2transport vc detail コマンドの出力

Router# show mpls l2transport vc detail
 
Local interface: Gi4/0.1 up, line protocol up, Eth VLAN 2 up
Destination address: 11.1.1.1, VC ID: 2, VC status: up
 
...
Local interface: Gi8/0/1 up, line protocol up, Ethernet up
Destination address: 11.1.1.1, VC ID: 8, VC status: up

AToM 用 IEEE 802.1Q Tunneling ― QinQ

AToM 用の IEEE 802.1Q トンネリング機能については、次の項目で説明します。

「AToM 用 IEEE 802.1Q Tunneling(QinQ)の要件」

「AToM 用 IEEE 802.1Q Tunneling(QinQ)の制約事項」

「イーサネット VLAN QinQ AToM」

「設定例」

「QinQ AToM の確認」

AToM 用 IEEE 802.1Q Tunneling(QinQ)の要件

Cisco IOS ソフトウェア リリース 12.2(33)SB では、次の Cisco 10000 シリーズ エンジンおよびラインカードが QinQ(802.1Q-in-802.1Q の省略)のトンネリングおよびタグの書き換え機能をサポートしています。

PRE-2、PRE-3、および PRE 4 エンジン

8 ポート ファスト イーサネット ラインカード(ESR-HH-8FE-TX)

2 ポート ハーフハイト ギガビット イーサネット ラインカード(ESR-HH-1GE)

1 ポート フルハイト ギガビット イーサネット ラインカード(ESR-1GE)

SPA ラインカード

AToM 用 IEEE 802.1Q Tunneling(QinQ)の制約事項

Cisco IOS Release 12.2(33)SB の QinQ トンネリングおよびタグ書き換え機能には、次の制約事項があります。

Ethernet QinQ over AToM 機能では、最大 447 の外部 VLAN ID と最大 4095 の内部 VLAN ID がサポートされます。

このリリースでは、Unambiguous VLAN のタグ イーサネット QinQ インターフェイスだけがサポートされます。すなわち、両方の VLAN タグのイーサネット VLAN QinQ 書き換え機能は、QinQ カプセル化および定義済みの明示的な VLAN ID のペアを含むイーサネット サブインターフェイス上でのみサポートされます。

イーサネット VLAN QinQ AToM

メトロ イーサネット配置では、CE ルータおよび PE ルータがイーサネット スイッチド アクセス ネットワークを介して接続され、PE ルータに着信するパケットには最大 2 つの IEEE 802.1Q VLAN タグ(カスタマーを識別する特定の内部 VLAN タグとカスタマーのサービス プロバイダーを表す別の外部 VLAN タグ)を含めることができます。特定のイーサネット パケットに複数の VLAN タグを付けし、VLAN ID のスタックを作成する技術は、QinQ(802.1Q-in-802.1Q の省略)と呼ばれます。図17-2 に、異なるエッジ デバイスが異なる VLAN スタック レベルで L2 スイッチングを行える例を示します。

図17-2 イーサネット VLAN QinQ

 

外部 VLAN タグがサービス区切りの VLAN タグである場合、QinQ パケットは 1 つの VLAN タグを持つパケットと同様に処理されます(12.2(31) SB リリースではサポート済みで、以前はイーサネット VLAN Q-in-Q という名前であったが、変更された)。ただし、カスタマーが外部 VLAN タグと内部 VLAN タグの組み合わせを使用して、カスタマーのサービスを区切る必要がある場合、パケットの内部 VLAN ID と外部 VLAN ID の組み合わせに基づいて、エッジ デバイスが一意の擬似配線を選択できるようにする必要があります(図17-3 を参照)。カスタマーが、トラフィック出力側の内部 VLAN ID と外部 VLAN ID の両方を書き換える可能性もあります。

図17-3 イーサネット VLAN QinQ ヘッダー

 

AToM 用 IEEE 802.1Q Tunneling(QinQ)についての詳細な説明は、次のとおりです。

「内部 VLAN タグおよび外部 VLAN タグに基づく QinQ トンネリング」

「QinQ フレームの内部 VLAN タグと外部 VLAN タグの書き換え」

内部 VLAN タグおよび外部 VLAN タグに基づく QinQ トンネリング

着信 QinQ イーサネット トラフィックを処理する場合、Cisco 10000 シリーズ エッジ ルータでは、カスタマーが内部 VLAN ID と外部 VLAN ID の組み合わせに基づいて、一意の擬似配線エンドポイントを選択し、トラフィックをスイッチングすることができます。たとえば、図17-4 に内部(カスタマー エッジ)VLAN ID および外部(サービス プロバイダー)の VLAN ID の組み合わせに応じて一意の擬似配線が選択される例を示します。このように、異なるカスタマーのトラフィックを分離しておくことができます。

図17-4 QinQ 接続

 

QinQ フレームの内部 VLAN タグと外部 VLAN タグの書き換え

着信 AToM イーサネット QinQ トラフィックを管理する場合、Cisco 10000 エッジ ルータでは、次のことを実行します。

1. MPLS ラベルを取り除きます。

2. パケットを出力 QinQ インターフェイスに送信する前に、カスタマーが内部 VLAN ID と外部 VLAN ID の両方を書き換えできるようにします。この機能は、AToM の like-to-like イーサネット QinQ トラフィックに対してのみ提供されます。

この機能のサポートが、Cisco IOS Release 12.2(33) に追加されました。QinQ AToM 機能は、AToM 上での like-to-like インターワーキング ケースです。この機能は、マイクロコードに変更する必要があります。これにより、AToM 擬似配線で送信されるイーサネット QinQ トラフィックの VLAN タグの 2 つのレイヤを上書きできるようになります。

入力側 ― パケットは 2 つの VLAN タグを持つ L2 ヘッダーを保持しながら、VC タイプ 4 の擬似配線で送信されます。

出力側 ― MPLS ラベルが取り除かれ、設定ごとに最大 2 つのレベルの VLAN タグが書き換えられます。

このリリースでは、Unambiguous VLAN のタグ イーサネット QinQ インターフェイスだけがサポートされます。すなわち、両方の VLAN タグのイーサネット VLAN Q-in-Q 書き換え機能は、QinQ カプセル化および定義済みの明示的な VLAN ID のペアを含むイーサネット サブインターフェイス上でのみサポートされます。

設定例

例17-15 に、GigE サブインターフェイス上に設定された unambiguous QinQ を示します。

例17-15 Unambiguous QinQ

interface GigabitEthernet1/0/0.100
encapsulation dot1q 100 second-dot1q 200
xconnect 23.0.0.16 410 encapsulation mpls
 

例17-16 に、GigE サブインターフェイス上に設定された ambiguous QinQ を示します。

例17-16 Ambiguous QinQ

interface GigabitEthernet1/0/0.200
encapsulation dot1q 200 second-dot1q 1000-2000,3000,3500-4000
xconnect 23.0.0.16 420 encapsulation mpls
interface GigabitEthernet1/0/0.201
encapsulation dot1q 201 second-dot1q any
xconnect 23.0.0.16 430 encapsulation mpls

) このリリースでは、Ambiguous 内部 VLAN ID はサポートされません。


QinQ AToM の確認

例17-17 に、EoMPLS QinQ モードの VC 設定を確認するのに使用される show mpls l2transport vc コマンドのコマンド出力を示します。

例17-17 show mpls l2transport vc コマンドの出力

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Gi1/0/0.1 Eth VLAN:100/200 100.1.1.2 1 UP

リモート イーサネット ポート シャットダウン

この Cisco IOS 機能により、EoMPLS 擬似配線のローカル エンドのサービス プロバイダー エッジ(PE)ルータがリモート リンク障害を検出し、ローカル カスタマー エッジ(CE)ルータのイーサネット ポートをシャットダウンできるようになります。ローカル CE ルータのイーサネット ポートがシャットダウンされるため、ルータは障害のあるリモート リンクにトラフィックを送信し続けることによりデータを損失することはありません。これは、リンクがスタティック IP ルートとして設定されている場合に有益です。

図17-5 は、CE1 ルータと PE1 ルータ間にダウンしたレイヤ 2 トンネル リンク がある EoMPLS Wide Area Network(WAN; ワイド エリア ネットワーク)の状態を表しています。レイヤ 2 トンネルの遠端の CE2 ルータは引き続き、L2 トンネルを介して CE1 にトラフィックを転送しています。

図17-5 EoMPLS WAN のリモート リンクの停止

 

Cisco IOS Release 12.2(33)SB より前のリリースでは、PE2 ルータは障害のあるリモート リンクを検出できませんでした。ルーティング プロトコルまたはスパニング ツリー プロトコルによりダウンしたリモート リンクが検出されるまでは、CE2 から CE1 に転送されるトラフィックは消失します。リンクにスタティック ルーティングが設定されていると、L3 ルーティング プロトコルがリモート リンクの停止を検出しにくい場合があります。

AToM のリモート イーサネット ポート シャットダウン機能の場合、PE2 ルータがリモート リンク障害を検出し、ローカル CE2 イーサネット ポートをシャットダウンさせます。リモート L2 トンネル リンクが元に戻ると、ローカル インターフェイスも自動的に元に戻ります。このため、データ損失の可能性は低減します。

図17-5 を参照にする場合、リモート イーサネット シャットダウンのシーケンスは次のようになります。

1. CE1 および PE1 間のリモート リンクに障害がある。

2. リモート イーサネット ポート シャットダウンがイネーブルな PE2 がリモート リンク障害を検出し、CE2 に接続されたラインカード インターフェイス上の伝送レーザーをディセーブルにする。

3. CE2 が インターフェイスをダウンさせる原因となる RX_LOS エラー アラームを受信する。

4. PE2 は、CE2 を含む自身のインターフェイスをアップ ステートで維持する。

5. リモート リンクおよび EoMPLS 接続が元に戻ると、PE2 ルータは伝送レーザーをイネーブルにする。

6. CE2 ルータはダウンしているインターフェイスをアップにする。

リモート イーサネット ポート シャットダウンの設定に関する制約事項

リモート イーサネット ポート シャットダウン機能に適用される制約事項は、次のとおりです。

Cisco IOS Release 12.2(33)SB の場合、この機能は、ポート モードの EoMPLS に対して Cisco 10000 シリーズ イーサネット ラインカード間でのみ実装されます。

リモート PE ルータが以前のバージョンのイメージを実行している場合、または EoMPLS リモート イーサネット ポート シャットダウン機能をサポートしていない別のプラットフォーム上にある場合、およびローカル PE がこの機能をサポートするイメージを実行している場合、この機能は対称的ではなくなります。

リモート イーサネット ポート シャットダウンの設定

デフォルトでは、Cisco 10000 シリーズ ルータ上にサポートされているイメージがロードされている場合、AToM のリモート イーサネット ポート シャットダウン機能は自動的にイネーブルになります。ただし、リモート イーサネット ポート シャットダウン機能をイネーブルにするには、remote link failure notification コマンドを入力します(例17-18 を参照)。

この機能をディセーブルにするには、no remote link failure notification コマンドを入力します(例17-19 を参照)。

例17-18 Xconnect 設定におけるリモート イーサネット ポート シャットダウンのイネーブル化

pseudowire-class eompls
encapsulation mpls
!
interface GigabitEthernet1/0/0
xconnect 1.1.1.1 1 pw-class eompls
remote link failure notification
!
 

例17-19 Xconnect 設定におけるリモート イーサネット ポート シャットダウンのディセーブル化

pseudowire-class eompls
encapsulation mpls
!
interface GigabitEthernet1/0/0
xconnect 1.1.1.1 1 pw-class eompls
no remote link failure notification
!
 

インターフェイスにより、すべてのリモート L2 トンネルの動作ステータスを確認するには、show interface コマンドおよびshow ip interface brief コマンドを入力します(例17-20を参照)。

例17-20 インターフェイスによるすべてのリモート L2 トンネルの動作ステータス

router# show interface GigabitEthernet1/0/0
GigabitEthernet1/0/0 is L2 Tunnel remote down, line protocol is up
Hardware is Half-height Gigabit Ethernet MAC Controller, address is 0009.b68f.9b18 (bia 0009.b68f.9b18)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
......
......
 
router# sh ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0/0 24.3.8.1 YES NVRAM up up
GigabitEthernet1/0/0 unassigned YES NVRAM L2 Tunnel remote down up
GigabitEthernet2/0/0 30.1.1.1 YES manual up up
 

ポートのトランシーバ ステートを確認するには、show controller コマンドおよび show controller interface コマンドを入力します(例17-21 を参照)。

例17-21 ポートのトランシーバ ステート

router# show controller GigabitEthernet1/0/0
Interface GigabitEthernet1/0/0(idb 0x4FB5CA7C)
Hardware is Half-height Gigabit Ethernet MAC Controller, network connection mode is auto
network link is L2 Tunnel remote down
loopback type is none
......

VLAN ID の書き換えによる EoMPLS の設定

VLAN ID の書き換え機能を使用すると、異なる VLAN ID を持つ VLAN インターフェイスをトンネルの両端で使用できます。Cisco 10000 シリーズ ルータは、ディスポジション PE ルータ上で自動的に VLAN ID の書き換えを実行します。設定を行う必要はありません。

FRoMPLS の設定

FRoMPLS は、MPLS パケット内でフレームリレー PDU をカプセル化し、MPLS ネットワークを通して転送します。フレームリレーでは、DLCI 間接続またはポート間接続を設定できます。

DLCI 間接続を使用する場合、PE ルータはヘッダーを削除し、ラベルを追加し、ヘッダーから PDU に制御ワード要素をコピーして、パケットを処理します。

ポート間接続を使用する場合、HDLC モードを使用して、フレームリレー カプセル化パケットを送信します。HDLC モードでは、HDLC パケット全体が送信されます。HDLC フラグおよび FCS ビットのみが削除されます。FECN、BECN、および DE ビットを含むパケットのコンテンツは使用されることも、変更されることもありません。


) フレームリレー トラフィック シェーピングは、AToM スイッチド VC ではサポートされていません。


次の方法で、FRoMPLS を設定できます。

「DLCI 間接続による FRoMPLS の設定」

「ポート間接続による FRoMPLS の設定」

「フレームリレー パケットを送信するための他の PE 装置のイネーブル化」

DLCI 間接続による FRoMPLS の設定

DLCI 間接続で FRoMPLS を設定するには、グローバル コンフィギュレーション モードを開始して、次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# frame-relay switching

フレームリレー装置で PVC スイッチングをイネーブルにします。

ステップ 2

Router(config)# interface serial slot/port

シリアル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# encapsulation frame-relay [cisco | ietf]

インターフェイスに対してフレームリレー カプセル化を指定します。

さまざまなカプセル化タイプを指定できます。あるインターフェイスをシスコのカプセル化方式に設定し、もう一方のインターフェイスを IETF のカプセル化方式に設定することもできます。

ステップ 4

Router(config-if)# frame-relay intf-type dce

インターフェイスが DCE スイッチであることを指定します。Network-to-Network Interface(NNI; ネットワーク間インターフェイス)および Data Terminal Equipment(DTE; データ端末装置)接続をサポートするようにインターフェイスを指定することもできます。

ステップ 5

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 6

Router(config)# connect connection-name interface dlci l2transport

フレームリレー PVC 間の接続を定義し、connect サブモードを開始します。l2transport キーワードを使用して、PVC がローカルでスイッチングされる PVC ではなく、バックボーン ネットワーク上でトンネリングされることを指定します。

connection-name 引数は、ユーザ側で指定する文字列です。

interface 引数は、PVC 接続を定義するインターフェイスです。

dlci 引数は、接続する PVC の DLCI 番号です。

ステップ 7

Router(config-fr-pw-switching)# xconnect peer-router-id vcid encapsulation mpls

レイヤ 2 パケットを送信する VC を作成します。

接続タイプが DLCI 間の場合、FRoMPLS では connect サブモードで xconnect コマンドを使用します。

例17-22 では、DLCI 間接続による FRoMPLS をイネーブルにする方法を示します。

例17-22 DLCI 間接続による FRoMPLS

frame-relay switching
interface Serial3/1
encapsulation frame-relay ietf
frame-relay intf-type dce
exit
connect fr1 Serial 5/0 1000 l2transport
xconnect 10.0.0.1 123 encapsulation mpls

ポート間接続による FRoMPLS の設定

PE ルータ間にポート間接続を設定する場合、HDLC モードを使用して、フレームリレー カプセル化パケットを送信します。このタスクを実行してフレームリレーのポート間接続を設定します。

ポート間接続で FRoMPLS を設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface serial slot/port

シリアル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# encapsulation hdlc

フレームリレー PDU を HDLC パケットにカプセル化することを指定します。

ステップ 3

Router(config-if)# xconnect peer-router-id vcid encapsulation mpls

レイヤ 2 パケットを送信する VC を作成します。

例17-23 では、ポート間接続による FRoMPLS をイネーブルにする方法を示します。

例17-23 ポート間接続による FRoMPLS

interface serial5/0

encapsulation hdlc

xconnect 10.0.0.1 123 encapsulation mpls

フレームリレー パケットを送信するための他の PE 装置のイネーブル化

インターフェイスは DTE 装置または Data Circuit-Terminating Equipment(DCE; データ回線終端装置)スイッチとして設定することも、NNI でスイッチに接続されるスイッチとして設定することもできます。インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

frame-relay intf-type [dce | dte | nni]

次の表で、キーワードについて説明します。

 

キーワード
説明

dce

ルータまたはアクセス サーバがルータに接続されたスイッチとして動作できるようにします。

dte

ルータまたはアクセス サーバが DTE 装置として動作できるようにします。DTE がデフォルトです。

nni

ルータまたはアクセス サーバがスイッチに接続されたスイッチとして動作できるようにします。

LMI および FRoMPLS

Local Management Interface(LMI; ローカル管理インターフェイス)は、PVC のステータス情報を伝えるプロトコルです。PVC が追加、削除、または変更されると、LMI がエンドポイントにステータスの変化を通知します。LMI はさらに、リンクがアップの状態かどうかを確認するポーリングのメカニズムも提供します。

LMI プロセス

PVC のステータスを判別するために、LMI は報告する側の装置からフレームリレー エンドユーザ装置への PVC が使用できるかどうかを調べます。PVC が使用できる場合、LMI はステータスが [Active] であることを報告します。これは、報告側の装置とフレームリレー エンドユーザ装置間ですべてのインターフェイス、回線プロトコル、およびコア セグメントが動作可能だということを意味します。これらのコンポーネントのいずれかが使用できない場合は、[Inactive] というステータスが報告されます。


) LMI ステータスを報告できるインターフェイス タイプは、DCE および NNI だけです。


図17-6 のトポロジ例に LMI の機能を示します。

図17-6 LMI のトポロジ例

 

図17-6 では、次の点に注目してください。

CE1 および PE1、PE2 および CE2 は、フレームリレー LMI ピアです。

CE1 および CE2 は、フレームリレー スイッチにすることも、エンドユーザ装置にすることもできます。

各フレームリレー PVC は複数のセグメントからなります。

DLCI 値は各セグメントに対してローカルであり、セグメントからセグメントにトラフィックがスイッチングされたときに変更されます。図17-6 には、2 つのフレームリレー PVC セグメントがあります。PE1 と CE1 間に 1 つ、PE2 と CE2 間に 1 つです。

LMI プロトコル動作は、DLCI 間接続かポート間接続かにより異なります。

DLCI 間接続

DLCI 間接続が設定されている場合、LMI は PE 装置と CE 装置間のフレームリレー ポート上でローカルに動作します。

CE1 の PVC が使用できる場合は、CE1 から PE1 にアクティブのステータスが送信されます。CE1 がスイッチの場合、LMI は CE1 から CE1 に接続されたユーザ装置への PVC が使用できるかどうかを調べます。

PE1 が CE1 にアクティブ ステータスを送信するのは、次の条件が満たされている場合です。

PE1 の PVC が使用可能である。

PE1 がリモート PE ルータから MPLS ラベルを受信した。

PE1 とリモート PE 間に MPLS トンネル ラベルがある。

DTE/DCE の設定では、LMI の動作は次のようになります。

ネットワーク(DTE)にアクセスするフレームリレー装置は、PVC ステータスを報告しません。ネットワーク装置(DCE)または NNI だけがステータスを報告できます。したがって、DTE 側に問題があっても、DCE はその問題を認識しません。

ポート間接続

ポート間接続が設定されている場合、PE ルータは LMI ステータス チェック プロシージャに加わりません。LMI は CE ルータ間でのみ動作します。CE ルータが DCE-DTE または NNI-NNI として設定されている必要があります。

設定手順を含め、LMI の詳細については、『 Configuring Frame Relay 』の「Configuring the LMI」を参照してください。

フレームリレー相互間ローカル スイッチングの設定

フレームリレー スイッチングとは、Data Link Connection Identifier(DLCI)に基づいてパケットをスイッチングする方法です。これは、MAC アドレスに相当するフレームリレーと考えることができます。スイッチングを実行するには、ルータまたはアクセス サーバをフレームリレー ネットワークとして設定します。フレームリレー ネットワークは、フレームリレー DTE(ルータまたはアクセス サーバ)およびフレームリレー Data Communications Equipment(DCE; データ通信装置)スイッチの 2 つの部分で構成されます。

ローカル スイッチングを使用すると、たとえば ATM 相互間またはフレームリレー相互間など、タイプが同じ 2 つのインターフェイス間でレイヤ 2 データをスイッチングできます。

フレームリレー相互間ローカル スイッチングに関する参考資料については、『 Distributed Frame Relay Switching 』フィーチャ ガイドを参照してください。

同一ポート上の仮想回線間をスイッチングできます(フレームリレーの同一ポート スイッチングの設定を参照)。

Cisco 10000 シリーズ ルータでは、次のチャネライズド ラインカードがサポートされています。

1 ポート チャネライズド OC-12/STM-4

4 ポート チャネライズド OC-3/STM-1

6 ポート チャネライズド T3

24 ポート チャネライズド E1/T1

Cisco 10000 シリーズ ルータでは、次の Packet over SONET(PoS)ラインカードがサポートされています。

1 ポート OC-12 POS

1 ポート OC-48/STM-16 POS

6 ポート OC-3/STM-1 POS

次のトピックで、フレームリレー相互間ローカル スイッチング機能について説明します。

「ローカル スイッチングのフレームリレーの設定」

「フレームリレーの同一ポート スイッチングの設定」

「フレームリレーのレイヤ 2 ローカル スイッチングの確認」

「QoS 機能の設定」

ローカル スイッチングのフレームリレーの設定

ローカル スイッチングのフレームリレーを設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# frame-relay switching

フレームリレー DCE 装置または NNI の PVC スイッチングをイネーブルにします。

ステップ 2

Router(config)# interface type number

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# encapsulation frame-relay [ cisco | ietf ]

フレームリレー カプセル化をイネーブルにします。

cisco ― シスコ独自のカプセル化(デフォルト)

ietf ― IETF 規格(RFC 1490)。フレームリレー ネットワークで別のベンダーの機器に接続する場合に、このキーワードを使用します。

ステップ 4

Router(config-if)# frame-relay interface-dlci dlci switched

(任意)スイッチド PVC を作成し、フレームリレー DLCI 設定モードを開始します。

各 スイッチド PVC に対して、ステップ 1 ~ 4 を繰り返します。

このステップでフレームリレー PVC を作成しない場合、ステップ 6 の connect コマンドで自動的に作成されます。

ステップ 5

Router(config-fr-dlci)# exit

フレームリレー DLCI コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

Router(config)# connect connection-name interface dlci interface dlci

フレームリレー PVC 間の接続を定義します。

例17-24 では、ローカル スイッチングのフレームリレー相互間の設定を行います。

例17-24 ローカル スイッチングのフレームリレー相互間の設定

frame-relay switching
interface serial 1/0/0.1/1:0
encapsulation frame-relay
frame-relay interface-dlci 100 switched
exit
connect connection1 serial1/0/0.1/1:0 100 serial2/0/0.1/2:0 101

フレームリレーの同一ポート スイッチングの設定

単一インターフェイスにローカル フレームリレーの同一ポート スイッチングを設定するには、グローバル コンフィギュレーション モードを開始して次の手順を行います。

 

コマンド
目的

ステップ 1

Router(config)# frame-relay switching

フレームリレー DCE 装置または NNI 上の PVC スイッチングをイネーブルにします。

ステップ 2

Router(config)# interface type number

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# encapsulation frame-relay [ cisco | ietf ]

フレームリレー カプセル化をイネーブルにします。

cisco ― シスコ独自のカプセル化(デフォルト)

ietf ― IETF 規格(RFC 1490)。フレームリレー ネットワークで別のベンダーの機器に接続する場合に、このキーワードを使用します。

ステップ 4

Router(config-if)# frame-relay intf-type { dce | dte | nni }

(任意)接続の特定タイプのサポートをイネーブルにします。

dce ― DCE

dte ― DTE

nni ― NNI

ステップ 5

Router(config-if)# frame-relay interface-dlci dlci switched

(任意)スイッチド PVC を作成し、フレームリレー DLCI 設定モードを開始します。

各 スイッチド PVC に対して、ステップ 1 ~ 5 を繰り返します。

このステップでフレームリレー PVC を作成しない場合、ステップ 8 の connect コマンドで自動的に作成されます。

ステップ 6

Router(config-fr-dlci)# exit

フレームリレー DLCI 設定モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

ステップ 7

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

Router(config)# connect connection-name interface dlci interface dlci

2 つのデータ リンク間の接続を定義します。

例17-25 では、フレームリレーの同一ポート スイッチングを設定します。

例17-25 フレームリレーの同一ポート スイッチングの設定

frame-relay switching
interface serial 1/0/0.1/1:0
encapsulation frame-relay
frame-relay intf-type nni
frame-relay interface-dlci 100 switched
exit
exit
connect connection1 serial1/0 100 serial1/0 200

フレームリレーのレイヤ 2 ローカル スイッチングの確認

レイヤ 2 ローカル スイッチング機能の設定を確認するには、特権 EXEC モードで show connection frame-relay-to-frame-relay コマンドと show frame-relay pvc コマンドを使用します。

例17-26 に、 show connection frame-relay-to-frame-relay コマンドの出力を示します。この出力は、フレームリレー インターフェイスとフレームリレー ローカル スイッチング インターフェイス間のローカル接続を表示します。

例17-26 show connection frame-relay-to-frame-relay コマンド出力

Router# show connection frame-relay-to-frame-relay
ID Name Segment 1 Segment 2 State
==================================================================
1 fr2fr Se3/0/0.1/1:0 100 Se3/0/0.1/2:0 200 UP
 

例17-27 に、 show frame-relay pvc コマンドの出力を示します。この出力は、スイッチド フレームリレー PVC を表示します。

例17-27 show frame-relay pvc コマンド出力

Router# show frame-relay pvc 16
PVC Statistics for interface POS5/0 (Frame Relay NNI)
DLCI = 16, DLCI USAGE = SWITCHED, PVC STATUS = UP, INTERFACE = POS5/0
LOCAL PVC STATUS = UP, NNI PVC STATUS = ACTIVE
input pkts 0 output pkts 0 in bytes 0
out bytes 0 dropped pkts 100 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
switched pkts 0
Detailed packet drop counters:
no out intf 0 out intf down 100 no out PVC 0
in PVC down 0 out PVC down 0 pkt too big 0
pvc create time 00:25:32, last time pvc status changed 00:06:31

QoS 機能の設定

Cisco 10000 シリーズ ルータに QoS 機能を設定する方法の詳細については、『 Cisco 10000 Series Router Quality of Service Configuration Guide 』を参照してください。

表17-4 および 表17-5 は、フレームリレー DLCI インターフェイスに関連する Modular QoS CLI(MQC; モジュラ QoS CLI)コマンドのサポート レベルをまとめたものです。

表に表示されている値は、次のとおりです。

無効 ― このポリシー マップ アクションを実行できません。

有効 ― このポリシー マップ アクションを実行できます。

N/A(適用外) ― このポリシー マップ アクションを適用できますが、パケットには影響しません。

 

表17-4 フレームリレー DLCI 入力ポリシー マップ アクション

ポリシー マップ アクション
フレームリレー DLCI インターフェイス

帯域幅

なし

queue-limit

なし

priority

なし

shape

なし

random-detect

なし

set ip prec/dscp

N/A

set qos-group

あり

set discard class

あり

set atm-clp

N/A

set fr-de

なし

set cos

なし

police

あり

set mpls-exp topmost

N/A

set mpls-exp imposition

N/A

 

表17-5 フレームリレー出力(ディスポジション ルータ)ポリシー マップ アクション

ポリシー マップ アクション
フレームリレー DLCI インターフェイス

帯域幅

あり

queue-limit

あり

priority

あり

shape

あり

random-detect

有効(廃棄クラスのみ)

set ip prec/dscp

N/A

set qos-group

N/A

set discard class

あり

set atm-clp

なし

set fr-de

サポートされていません

set cos

なし

police

あり

set mpls-exp topmost

N/A

HDLCoMPLS と PPPoMPLS の設定

HDLCoMPLS では、HDLC パケット全体が送信されます。入力 PE ルータでは、HDLC フラグと FCS ビットだけが削除されます。パケットのコンテンツは、使用されることも、変更されることもありません。

PPPoMPLS の場合、入力 PE ルータでは、フラグ、アドレス、制御フィールド、および FCS が削除されます。

HDLCoMPLS については、次の項目で説明します。

「HDLCoMPLS の制約事項」

「PPPoMPLS の制約事項」

「HDLCoMPLS または PPPoMPLS の設定」

HDLCoMPLS の制約事項

HDLCoMPLS 機能に適用される制約事項は、次のとおりです。

非同期インターフェイス:非同期インターフェイスはサポートされていません。

インターフェイス設定:HDLCoMPLS を、ルータ インターフェイスにのみ設定する必要があります。HDLCoMPLS をサブインターフェイスには設定できません。

PPPoMPLS の制約事項

PPPoMPLS 機能に適用される制約事項は、次のとおりです。

非同期インターフェイス:サポートされていません。バックボーンの両端の CE ルータと PE ルータ間の接続では、リンク レイヤの特性が同様である必要があります。CE ルータと PE ルータ間の接続は、両方で同期化される必要があります。

Multilink PPP(MLP; マルチリンク PPP)はサポートされていません。

インターフェイス設定:PPP を、ルータ インターフェイスにのみ設定する必要があります。PPP を、サブインターフェイスには設定できません。

HDLCoMPLS または PPPoMPLS の設定

HDLCoMPLS または PPPoMPLS を設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface serial slot/port

シリアル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。
HDLCoMPLS および PPPoMPLS を、ルータ インターフェイスにのみ設定する必要があります。HDLCoMPLS をサブインターフェイスには設定できません。

ステップ 2

Router(config-if)# encapsulation encapsulation-type

HDLC または PPP カプセル化を指定し、connect サブモードを開始します。

encapsulation-type には、HDLC または PPP を指定できます。

ステップ 3

Router(config-fr-pw-switching)# xconnect peer-router-id vcid encapsulation mpls

レイヤ 2 パケットを送信する VC を作成します。

コア ネットワークを通るパケット サイズの見積もり

次の計算式は、コア ネットワークを通るパケット サイズを判別するのに役立ちます。P ルータおよび PE ルータのコアに面したインターフェイス上の最大伝送ユニットがこのサイズ パケットに対応するように設定します。

次の方程式では、MTU の値が全項目の合計バイト数以上である必要があります。

Core MTU >= (Edge MTU + Transport header + AToM header + (MPLS label stack size* MPLS label size))

 

次のセクションでは、方程式で使用される変数について説明します。

エッジ MTU

エッジ MTU は、お客様に面したインターフェイスの MTU です。

トランスポート ヘッダー

トランスポート ヘッダーは、トランスポート タイプに応じて異なります。 表17-6 に、ヘッダーの具体的なサイズを示します。

 

表17-6 パケットのヘッダー サイズ

トランスポート タイプ
ヘッダー サイズ(バイト)

ATM AAL5 SDU support over MPLS

12

VLAN モードの EoMPLS

18

ポート モードの EoMPLS

14

DLCI 間接続による FRoMPLS

4

HDLCoMPLS

4

PPPoMPLS

4

AToM ヘッダー

AToM ヘッダーは、4 バイト(制御ワード)です。Cisco 10000 シリーズ ルータは、デフォルトによって、サポートされているすべてのトランスポート タイプに対して制御ワードを追加します。

MPLS ラベル スタック

MPLS ラベル スタック サイズは、コア MPLS ネットワークの設定に応じて異なります。

AToM は、1 つの MPLS ラベルを使用して AToM VC(VC ラベル)を特定します。そのため、直接接続されている AToM PE ルータ(間に P ルータが設置されていない PE ルータ)の場合、最小 MPLS ラベル スタックは 1 になります。

LDP が MPLS ネットワークで使用されている場合、ラベル スタック サイズは 2 になります(LDP ラベルと VC ラベル)。

LDP ではなく、TE トンネルが MPLS ネットワークの PE ルータ間で使用されている場合、ラベル スタック サイズは 2 になります(TE ラベルと VC ラベル)。

TE トンネルと LDP が MPLS ネットワークで使用されている場合(たとえば、P ルータ間、または P ルータと PE ルータ間の、LDP を使用した TE トンネル)、ラベル スタックは 3 になります(TE ラベル、LDP ラベル、VC ラベル)。

MPLS ネットワークで MPLS Fast Reroute(FRR)を使用する場合、スタックにラベルを追加します。この場合の最大 MPLS ラベル スタックは 4 になります(FRR ラベル、TE ラベル、LDP ラベル、VC ラベル)。

AToM が MPLS-VPN Carrier Supporting Carrier 環境のカスタマー キャリアで使用されている場合、スタックにラベルを追加します。プロバイダー キャリア ネットワークの最大 MPLS ラベル スタックは 5 になります(FRR ラベル、TE ラベル、LDP ラベル、VPN ラベル、VC ラベル)。

AToM トンネルが IPv4 BGP(RFC 3107)を使用して MPLS ラベルを交換する別のサービス プロバイダーをまたぐ場合、スタックにラベルを追加します。最大 MPLS ラベル スタックは 5 になります(FRR ラベル、TE ラベル、BGP ラベル、LDP ラベル、VC ラベル)。

その他の環境でも、MPLS ラベル スタック サイズが増加する可能性があります。そのため、AToM のトンネル エンドポイント間の完全なデータ パスを分析し、使用しているネットワークの最大 MPLS ラベル スタック サイズを判別します。その後、ラベル スタック サイズに MPLS ラベルのサイズをかけます。

パケット サイズの見積もり ― 例

例17-28 に、パケット サイズを見積もる例を示します。この例は、次の条件を前提とします。

エッジ MTU が 1500 バイトである。

トランスポート タイプはイーサネット VLAN で、トランスポート ヘッダーに対して 18 バイトを指定する。

制御ワードが常に使用されるため、AToM ヘッダーは 4 バイトである。

LDP が使用されているため、MPLS ラベル スタック サイズは 2 である。MPLS ラベル サイズは 4 バイトである。

例17-28 パケットの MTU の見積もり

Core MTU >= (Edge MTU + Transport header + AToM header + (MPLS label stack size* MPLS label size))
1500 + 18 + 0 + (2 * 4 ) = 1526
 

コア内の P ルータと PE ルータが 1526 バイトのパケットを受け入れるように設定する必要があります。P ルータと PE ルータの MTU サイズの設定については、次のセクションを参照してください。

P ルータと PE ルータの MTU サイズの変更

P ルータと PE ルータの MTU サイズを判別したら、ルータ上で mtu コマンドを入力して、MTU サイズを設定できます。次の例は、1526 バイトの MTU サイズを指定します。

Router(config-if)# mtu 1526

AToM での EXP ビットの設定

MPLS AToM では、ラベルの 3 つの Experimental(EXP)ビットを使用して、パケットのキューを判別します。デフォルトでは、EXP ビットは 0(ゼロ)に設定されています。表17-7 は、デフォルト値を無効にする場合に使用できるコマンドをまとめています。

 

表17-7 EXP ビットの変更が可能なコマンド

トランスポート タイプ
サポート対象のコマンド

ATM AAL5 SDU support over MPLS

EoMPLS:
ポート モード

FRoMPLS:
DLCI 間接続
ポート間接続

HDLCoMPLS

PPPoMPLS

set mpls experimental

match any

EoMPLS:
VLAN モード

set mpls experimental

match cos

VC ラベルと LSP トンネル ラベルの両方に EXP ビットを設定します。最後から 2 つめのルータで LSP トンネル ラベルが削除される可能性があるため、VC ラベルに EXP ビットを設定します。

EXP ビットを設定するには、グローバル コンフィギュレーション モードを開始して次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# class-map class-name

ユーザ定義のトラフィック クラス名を指定して、クラス マップ設定モードを開始します。

ステップ 2

VLAN モードの EoMPLS を除く、すべてのトランスポート タイプの場合

Router(config-cmap)# match any

 

 

VLAN モードの EoMPLS のみの場合

Router(config-cmap)# match cos cos-value

すべてのパケットが一致していることを指定します。




cos-value は、0 ~ 7 です。最大 4 つの CoS 値を 1 つの match cos ステートメントに指定できます。

ステップ 3

Router(config-cmap)# policy-map policy-name

設定するトラフィック ポリシー名を指定して、ポリシー マップ設定モードを開始します。

ステップ 4

Router(config-pmap)# class class-name

class-map コマンドで設定した、トラフィックをトラフィック ポリシーに分類するための、定義済みトラフィック クラス名を指定します。ポリシー マップ設定モードを開始します。

ステップ 5

Router(config-pmap-c)# set mpls experimental value

指定されたポリシー マップとパケットが一致する場合に、MPLS ビットに設定する値を指定します。

ステップ 6

Router(config-pmap-c)# exit

ポリシー マップ設定モードを終了します。

ステップ 7

Router(config-pmap)# exit

ポリシー マップ モードを終了します。

ステップ 8

Router(config)# interface slot/port

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

Router(config-if)# service-policy input policy-name

インターフェイスにトラフィック ポリシーを結合します。

インターフェイスに割り当てられたトラフィック ポリシーの表示

インターフェイスに結合されたトラフィック ポリシーを表示するには、show policy-map interface コマンドを使用します。

例17-29 は、デフォルトのクラスを使用する match any コマンドとともに set mpls experimental コマンドを使用します。これは、特定の AToM VC にトンネリングされるすべてのパケットが同じ MPLS EXP ビット値を伝送することを意味します。

例17-29 match any コマンドによる EXP ビットの設定

class-map match-any default-class
match any
policy-map atm-default-policy
class default-class
set mpls experimental 3
!
!
interface atm4/0
service-policy input atm-default-policy
 

例17-30 は、match cos コマンドとともに set mpls experimental コマンドを使用します。これにより、特定の AToM VC にトンネリングされるパケットが、異なる MPLS EXP ビット値を伝送できるようになります。match cos コマンドは、イーサネット VLAN サブインターフェイスにのみ設定できます。

例17-30 match cos コマンドによる EXP ビットの設定

class-map match-any match_cos_low
match cos 0 1 2 3
class-map match-any match_cos_high
match cos 4 5 6 7
policy-map ether-clp-policy
class match_cos_low
set mpls experimental 1
class match_cos_high
set mpls experimental 5
!
!
interface Gi0/0.1
service-policy input ether-clp-policy

QoS 機能の設定

Cisco 10000 シリーズ ルータに QoS 機能を設定する方法の詳細については、『 Cisco 10000 Series Router Quality of Service Configuration Guide 』を参照してください。

表17-8 および 表17-9 では、各種インターフェイス上でサポートされるポリシー マップ アクションについて説明します。表に表示されている値は、次のとおりです。

無効 ― このポリシー マップ アクションまたは一致基準を実行できません。

有効 ― このポリシー マップ アクションまたは一致基準を実行できます。

N/A(適用外) ― このポリシー マップ アクションまたは一致基準を適用できますが、パケットには影響しません。

 

表17-8 入力(インポジション ルータ)ポリシー マップ アクション

ポリシー マップ アクション
Interface
ATM
イーサネット
フレームリレー
HDLC と PPP

帯域幅

なし

なし

なし

なし

queue-limit

なし

なし

なし

なし

priority

なし

なし

なし

なし

shape

なし

なし

なし

なし

random-detect

なし

なし

なし

なし

set ip prec/dscp

N/A

N/A

N/A

N/A

set qos-group

あり

あり

あり

あり

set discard class

あり

あり

あり

あり

set atm-clp

N/A

N/A

N/A

N/A

set fr-de

N/A

N/A

N/A

N/A

set cos

N/A

N/A

N/A

N/A

police

あり

あり

あり

あり

set mpls-exp topmost

N/A

N/A

N/A

N/A

set mpls-exp imposition

あり

あり

あり

あり

 

表17-9 出力(ディスポジション ルータ)ポリシー マップ アクション

ポリシー マップ アクション
Interface
ATM
イーサネット
フレームリレー
HDLC と PPP

帯域幅

あり

あり

あり

あり

queue-limit

あり

あり

あり

あり

priority

あり

あり

あり

あり

shape

あり

あり

あり

あり

random-detect

有効(廃棄クラスのみ)

有効(廃棄クラスのみ)

有効(廃棄クラスのみ)

有効(廃棄クラスのみ)

set ip prec/dscp

なし

なし

なし

なし

set qos-group

N/A

N/A

N/A

N/A

set discard class

なし

なし

なし

なし

set atm-clp

あり

なし

なし

なし

set fr-de

なし

なし

なし

なし

set cos

なし

あり

なし

なし

police

あり

あり

あり

あり

set mpls-exp topmost

なし

なし

なし

なし

set mpls-exp imposition

N/A

N/A

N/A

N/A

表17-10 および 表17-11 で、各種インターフェイス上でのクラス マップ一致基準のサポートについて説明します。 表17-10 では、入力トラフィックの、 表17-11 では出力トラフィックの一致基準のサポートについて説明します。

 

表17-10 入力(インポジション ルータ)クラス マップ一致基準

一致基準
Interface
ATM
イーサネット
フレームリレー
HDLC と PPP

DSCP

なし

なし

なし

なし

IP precedence

なし

なし

なし

なし

MPLS EXP

なし

なし

なし

なし

IEEE 802.1P ビット

なし

あり

なし

なし

アクセス リスト

なし

なし

なし

なし

QoS グループ

N/A

N/A

N/A

N/A

廃棄クラス

N/A

N/A

N/A

N/A

入力インターフェイス

あり

あり

あり

あり

プロトコル

なし

なし

なし

なし

RTP

なし

なし

なし

なし

atm-clp

なし

なし

なし

なし

MAC アドレス

なし

なし

なし

なし

フレームリレー DLCI

なし

なし

なし

なし

VLAN ID

なし

なし

なし

なし

パケットの長さ

なし

なし

なし

なし

DE ビット(フレームリレー)

なし

なし

なし

なし

 

表17-11 出力(ディスポジション ルータ)クラス マップ一致基準

一致基準
Interface
ATM
イーサネット
フレームリレー
HDLC と PPP

DSCP

なし

なし

なし

なし

IP precedence

なし

なし

なし

なし

MPLS EXP

N/A

N/A

N/A

N/A

IEEE 802.1P ビット

N/A

N/A

N/A

N/A

アクセス リスト

なし

なし

なし

なし

QoS グループ

あり

あり

あり

あり

廃棄クラス

あり

あり

あり

あり

入力インターフェイス

あり

あり

あり

あり

プロトコル

なし

なし

なし

なし

RTP

なし

なし

なし

なし

atm-clp

N/A

N/A

N/A

N/A

MAC アドレス

なし

なし

なし

なし

フレームリレー DLCI

なし

なし

なし

なし

VLAN ID

なし

なし

なし

なし

パケットの長さ

なし

なし

なし

なし

DE ビット(フレームリレー)

N/A

N/A

N/A

N/A

L2VPN のモニタリングおよびメンテナンス

L2VPN 機能の設定を監視およびメンテナンスするには、特権 EXEC モードで次のコマンドを使用します。次のコマンド(show mpls l2transport コマンドを除く)は、シスコシステムズのテクニカル サポート スタッフが使用するための出力を作成することを念頭に置いておいてください。

 

コマンド
表示

show mpls l2transport

ルータでレイヤ 2 パケットをルーティングするためにイネーブル化された AToM VC に関する情報(プラットフォームに依存しない AToM ステータスと特定のインターフェイスの AToM 機能の内容を含む)

show pxf cpu atom

インターフェイスまたは VCCI(カラム 1 転送情報)の PXF 固有の転送 AToM および LS 情報

show mpls l2transport vc

ルータでレイヤ 2 パケットをルーティングするためにイネーブル化された AToM VC に関する情報

show pxf cpu mpls label

ラベルの PXF 固有の転送情報を表示します。出力は、AToM ディスポジション ラベル(具体的には、ラベルに関連するトランスポート タイプのほか、制御ワードやシーケンスなど、ラベルに関連する出力機能セット)を示すために拡張されました。

show pxf cpu subblocks

インターフェイスのステータスと PXF 関連パラメータで、AToM ステータスのカラム 0 を表示するために拡張されました。

show ssm

アクティブ セグメントに関するプラットフォーム固有の情報

debug pxf atom ac

接続回路イベントに関連する AToM 情報

debug pxf atom mpls

MPLS Forwarding Information(MFI)により発生したイベントに関連する AToM 情報


注意 デバッグ出力は CPU プロセスで高優先順位に割り当てられているので、システムを使用不能な状態にする可能性があります。そのため、特定の問題をトラブルシューティングする場合、またはシスコシステムズのテクニカル サポート担当者とのトラブルシューティング セッション時以外は debug コマンドを使用しないようにしてください。また、ネットワーク トラフィックが低く、ユーザが少ないときに debug コマンドを使用するのが最適です。このようにデバッグを行えば、debug コマンドの増加したオーバーヘッド処理によってシステム利用に影響が及ぶ可能性が軽減されます。

設定例 ― FRoMPLS

例17-31 に、2 つの PE(PE1 と PE2)ルータと 2 つの CE(CE1 と CE2)ルータ上の FRoMPLS の設定を示します。図17-7 に、トポロジ例を示します。

図17-7 FRoMPLS トポロジ例

 

AToM VC をアップの状態にするためには、MPLS/LDP とルーティング プロトコルがコア ネットワーク(PE1---P----PE2)で稼働している必要があります。PE1 と PE2 は、OSPF ルーティング プロトコルと MPLS/LDP がイネーブルにされていることを示します。

例17-31 FRoMPLS 設定

フレームリレーの CE1 設定

================================
interface Serial8/0/0.1/1:0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay lmi-type q933a
frame-relay intf-type dce
interface Serial8/0/0.1/1:0.1 point-to-point
ip address 192.1.1.1 255.255.255.0
frame-relay interface-dlci 17
!
interface Serial8/0/0.1/1:0.2 point-to-point
ip address 192.1.2.1 255.255.255.0
frame-relay interface-dlci 18
 

LDP と AToM VC の PE1 設定

==================================
!Enabling LDP
mpls ldp graceful-restart timers neighbor-liveness 300
mpls ldp graceful-restart timers max-recovery 600
mpls ldp graceful-restart
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!Define Loopback address for LDP protocol
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!Enable MPLS/LDP on the core interface
interface POS4/0/0
ip address 50.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
crc 32
clock source internal
!
!Enabling OSPF protocol
router ospf 100
log-adjacency-changes
network 1.0.0.0 0.255.255.255 area 100
network 50.0.0.0 0.255.255.255 area 100
!Define pseudowire-class
pseudowire-class pw_atom1
encapsulation mpls
!FR configuration with two subinterfaces
interface Serial8/0/0.1/1:0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay lmi-type q933a
!
interface Serial8/0/0.1/1:0.1 point-to-point
!
interface Serial8/0/0.1/1:0.2 point-to-point
!
!Two AToM VC configuration with vc ids 1 & 2, 2.2.2.2 is LB addr of PE2
connect atom1 Serial8/0/0.1/1:0 17 l2transport
xconnect 2.2.2.2 1 pw-class pw_atom1
!
!
connect atom2 Serial8/0/0.1/1:0 18 l2transport
xconnect 2.2.2.2 2 pw-class pw_atom1
 

PE2 設定

================================
!Enabling LDP
mpls ldp graceful-restart timers neighbor-liveness 300
mpls ldp graceful-restart timers max-recovery 600
mpls ldp graceful-restart
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!Define Loopback address for LDP protocol
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!Enable MPLS/LDP on the core interface
interface POS4/0/0
ip address 60.0.0.2 255.0.0.0
mpls label protocol ldp
mpls ip
crc 32
clock source internal
!
!Enabling OSPF protocol
router ospf 100
log-adjacency-changes
network 2.0.0.0 0.255.255.255 area 100
network 60.0.0.0 0.255.255.255 area 100
!Define pseudowire-class
pseudowire-class pw_atom1
encapsulation mpls
!FR configuration with two subinterfaces
interface Serial8/0/0.1/1:0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay lmi-type q933a
interface Serial8/0/0.1/1:0.1 point-to-point
interface Serial8/0/0.1/1:0.2 point-to-point
!Two AToM VC configuration with vc ids 1 & 2
connect atom1 Serial8/0/0.1/1:0 17 l2transport
xconnect 1.1.1.1 1 pw-class pw_atom1
!
!
connect atom2 Serial8/0/0.1/1:0 18 l2transport
xconnect 1.1.1.1 2 pw-class pw_atom1
 

CE2 設定

================================
interface Serial8/0/0.1/1:0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay lmi-type q933a
frame-relay intf-type dce
!
interface Serial8/0/0.1/1:0.1 point-to-point
ip address 192.1.1.2 255.255.255.0
frame-relay interface-dlci 17
!
interface Serial8/0/0.1/1:0.2 point-to-point
ip address 192.1.2.2 255.255.255.0
frame-relay interface-dlci 18
 

PE1 設定の確認

PE1 ルータは、2 つの AToM VC がアップの状態であることを示します。

================================
router# show mpls l2tran vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Se8/0/0.1/1:0 FR DLCI 17 2.2.2.2 1 UP
Se8/0/0.1/1:0 FR DLCI 18 2.2.2.2 2 UP
 
router# show mpls l2tran vc 1 det
Local interface: Se8/0/0.1/1:0 up, line protocol up, FR DLCI 17 up
Destination address: 2.2.2.2, VC ID: 1, VC status: up
Output interface: PO4/0/0, imposed label stack {93 19}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:00:49, last status change time: 00:00:06
Signaling protocol: LDP, peer 2.2.2.2:0 up
MPLS VC labels: local 19, remote 93
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0
 
router# sh mpls l2tran vc 2 det
Local interface: Se8/0/0.1/1:0 up, line protocol up, FR DLCI 18 up
Destination address: 2.2.2.2, VC ID: 2, VC status: up
Output interface: PO4/0/0, imposed label stack {98 19}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:00:53, last status change time: 00:00:10
Signaling protocol: LDP, peer 2.2.2.2:0 up
MPLS VC labels: local 22, remote 98
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0
 

AToM ― トンネル選択

トンネル選択により、AToM トラフィックが使用するパスを指定できます。MPLS トラフィック エンジニアリング トンネルまたは宛先 IP アドレスのいずれかを指定できます。指定されたパスが到達不能の場合は、VC がデフォルト パス(MPLS ラベル配布プロトコルがシグナリングに使用するパス)を使用するように指定できます。


) デフォルトでは、preferred-path サブコマンドにフォールバック擬似配線が含まれます。優先擬似配線がダウンすると、MPLS/LDP モジュールは一時的に回線を別の擬似配線に切り替えます。優先擬似配線が再びアップすると、回線は優先擬似配線に戻されます。preferred-path サブコマンドには disable-fallback オプションもあり、優先擬似配線がダウンした場合にランダムな擬似配線が選択されないようにできます。優先パスの擬似配線が再びアップするまで、回線はダウンしたままです。ただし 12.2(33) SB リリースでは、デフォルトで preferred-path サブコマンドに disable-fallback オプションが指定されています。このリリースでは、オプションが明示的に記述されていない場合でも、フォールバック擬似配線はありません。


次の情報については、『 AToM:Tunnel Selection 』マニュアルを参照してください。

AToM:トンネル選択の要件

AToM:トンネル選択の制約事項

AToM:トンネル選択の設定

AToM:トンネル選択を確認するための debug mpls l2transport vc コマンド

設定の確認 ― 例

AToM:トンネル選択のトラブルシューティング ― 例

設定例 ― AToM:トンネル選択

次に、PE1 に 2 つの優先パスを設定する例を示します。一方の優先パスは、MPLS トラフィック エンジニアリング トンネルを指定します。もう一方の優先パスは、PE2 のループバック アドレスの IP アドレスを指定します。PE2 の IP アドレスに到達するため、TE トンネルを使用する PE1 上に設定済みのスタティック ルートがあります。

ルータ PE1

mpls label protocol ldp
mpls traffic-eng tunnels
mpls ldp router-id Loopback0
pseudowire-class pw1
encapsulation mpls
preferred-path interface Tunnel1 disable-fallback
!
pseudowire-class pw2
encapsulation mpls
preferred-path peer 10.18.18.18
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface Tunnel1
ip unnumbered Loopback0
no ip directed-broadcast
tunnel destination 10.16.16.16
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth 1500
tunnel mpls traffic-eng path-option 1 explicit name path-tu1
!
interface Tunnel2
ip unnumbered Loopback0
no ip directed-broadcast
tunnel destination 10.16.16.16
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth 1500
tunnel mpls traffic-eng path-option 1 dynamic
!
interface gigabitethernet0/0/0
no ip address
no ip directed-broadcast
no negotiation auto
!
interface gigabitethernet0/0/0.1
encapsulation dot1Q 222
no ip directed-broadcast
xconnect 10.16.16.16 101 pw-class pw1
!
interface ATM1/0/0
no ip address
no ip directed-broadcast
no atm enable-ilmi-trap
no atm ilmi-keepalive
pvc 0/50 l2transport
encapsulation aal5
xconnect 10.16.16.16 150 pw-class pw2
!
interface gigabitEthernet2/0/1
ip address 10.0.0.1 255.255.255.0
no ip directed-broadcast
tag-switching ip
mpls traffic-eng tunnels
ip rsvp bandwidth 15000 15000
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.0.0.255 area 0
network 10.2.2.2 0.0.0.0 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
ip route 10.18.18.18 255.255.255.255 Tunnel2
!
ip explicit-path name path-tu1 enable
next-address 10.0.0.1
index 3 next-address 10.0.0.1
 

ルータ PE2

mpls label protocol ldp
mpls traffic-eng tunnels
mpls ldp router-id Loopback0
interface Loopback0
ip address 10.16.16.16 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface Loopback2
ip address 10.18.18.18 255.255.255.255
no ip directed-broadcast
!
interface gigabitEthernet3/1
ip address 10.0.0.2 255.255.255.0
no ip directed-broadcast
mpls traffic-eng tunnels
mpls ip
no cdp enable
ip rsvp bandwidth 15000 15000
!
interface gigabitEthernet3/3
no ip address
no ip directed-broadcast
no cdp enable
!
interface gigabitEthernet3/3.1
encapsulation dot1Q 222
no ip directed-broadcast
no cdp enable
mpls l2transport route 10.2.2.2 101
!
interface ATM5/0
no ip address
no ip directed-broadcast
no atm enable-ilmi-trap
no atm ilmi-keepalive
pvc 0/50 l2transport
encapsulation aal5
xconnect 10.2.2.2 150 encapsulation mpls
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.0.0.255 area 0
network 10.16.16.16 0.0.0.0 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0