Cisco MWR 2941-DC モバイル ワイヤレス エッジ ルータ ソフトウェア コンフィギュレーション ガイド、 Release 12.4(20)MR
設定例
設定例
発行日;2012/02/06 | 英語版ドキュメント(2010/12/08 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

設定例

設定例

疑似回線(PW)の設定

非対称 Pseudowire Emulation Edge-to-Edge(PWE3)の設定

PWE3 冗長性の設定

TDM over MPLS の設定

ATM over MPLS の設定

Ethernet over MPLS(EoMPLS)の設定

GSM の設定

GSM だけの設定

衛星を使用する GSM だけの設定

GSM 輻輳管理

Generic Routing Encapsulation(GRE)トンネリングの設定

CESoPSN と GRE トンネル バックホール

ATM over MPLS AAL5 SDU モードと GRE バックホール

ルーティング設定例

Open Shortest Path First(OSPF)と BFD

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)と BFD

Intermediate System-to-Intermediate System(IS-IS)と BFD

Precision Timing Protocol(PTP)設定例

PTP の冗長性

レイヤ 3 バーチャル プライベート ネットワーク(VPN)設定例

Quality of Service(QoS)設定例

スイッチポート プライオリティ

分類およびマーキング

プライオリティ キューイング

Cisco Networking Services(CNS)ゼロ タッチ配置設定

設定例

Cisco MWR 2941-DC は、Global System for Mobile Communications(GSM)設定に基づき、各種トポロジ設計をサポートします。これには次の共通トポロジが含まれます。

バックホール インターフェイスは、最適化された GSM トラフィックを転送するために使用されます。従来のバックホール インターフェイスは、1 つの マルチリンク接続を形成するために論理的に結合された 1 つ以上の T1/E1 コントローラから構成されています(T1/E1 回線のクロッキング用にバックホール インターフェイスを使用する High Speed Down link Packet Access(HSDPA)を除く)。

ショートホール インターフェイスは、Base Transceiver Station(BTS; 無線基地局)/ノード B から Cisco MWR 2941-DC ルータへ、さらに Cisco MWR 2941-DC ルータから Base Station Controller/Radio Network Controller(BSC/RNC)へ GSM トラフィックを転送するために使用されます。Radio Access Network-Optimization(RAN-O; 無線アクセス ネットワーク最適化)デバイス上の従来のショートホール接続は、Cisco T1/E1 インターフェイス カードを介して接続されています。

3x2 や 4x3 などのトポロジの命名規則は、展開のタイプを説明するために使用されます。最初の数字は GSM ショートホール インターフェイス接続の番号を示し、2 番目の数字はマルチリンク バックホール インターフェイス接続の番号を示しています。

設定例

ここでは、Cisco MWR 2941-DC に関する次の実際の設定例について示します。

「疑似回線(PW)の設定」

「GSM の設定」

「Generic Routing Encapsulation(GRE)トンネリングの設定」

「ルーティング設定例」

「Precision Timing Protocol(PTP)設定例」

「レイヤ 3 バーチャル プライベート ネットワーク(VPN)設定例」

「Quality of Service(QoS)設定例」

「Cisco Networking Services(CNS)ゼロ タッチ配置設定」


) この例に記載されているネットワーク アドレスは汎用アドレスです。そのため、ネットワークで使用する実際のアドレスに置き換える必要があります。


疑似回線(PW)の設定

ここでは、Pseudowire(PW; 疑似回線)接続の設定例を示します。

非対称 Pseudowire Emulation Edge-to-Edge(PWE3)の設定

PWE3 冗長性の設定

TDM over MPLS の設定

ATM over MPLS の設定

Ethernet over MPLS(EoMPLS)の設定

非対称 Pseudowire Emulation Edge-to-Edge(PWE3)の設定

次に、非対称 Pseudowire Emulation Edge-to-Edge(PWE3)の設定例を示します(図 A-1)。

図 A-1 非対称 PWE3 の設定

 

MWR_1

version 12.4
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
 
!
hostname MWR1
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
!
!
ip cef
!
!
controller E1 0/0
clock source internal
cem-group 1 unframed
!
controller E1 0/1
clock source internal
cem-group 20 unframed
!
controller E1 0/2
clock source internal
cem-group 12 unframed
!
controller E1 0/3
clock source internal
cem-group 30 unframed
!
controller E1 0/4
clock source internal
cem-group 8 unframed
!
controller E1 0/5
clock source internal
cem-group 25 unframed
!
controller E1 1/0
mode atm
clock source internal
!
controller E1 1/1
mode atm
clock source internal
!
controller E1 1/2
mode atm
clock source internal
!
controller E1 1/3
!
!
pseudowire-class mpls
encapsulation mpls
preferred-path peer 50.0.0.2
!
!
interface Loopback50
ip address 50.0.0.1 255.255.255.255
!
interface CEM0/0
no ip address
cem 1
xconnect 50.0.0.2 1 encapsulation mpls
!
!
interface GigabitEthernet0/0
ip address 20.0.0.1 255.0.0.0
load-interval 30
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface CEM0/1
no ip address
cem 20
xconnect 50.0.0.2 2 encapsulation mpls
!
interface GigabitEthernet0/1
ip address 60.0.0.1 255.0.0.0
duplex auto
speed auto
mpls ip
!
interface CEM0/2
no ip address
cem 12
xconnect 50.0.0.2 3 encapsulation mpls
!
!
interface CEM0/3
no ip address
cem 30
xconnect 50.0.0.2 4 encapsulation mpls
!
interface CEM0/4
no ip address
cem 8
xconnect 50.0.0.2 5 encapsulation mpls
!
!
interface CEM0/5
no ip address
cem 25
xconnect 50.0.0.2 6 encapsulation mpls
!
!
interface ATM1/0
no ip address
load-interval 30
scrambling-payload
mcpt-timers 1000 5000 10000
no ilmi-keepalive
pvc 0/5 l2transport
encapsulation aal0
cell-packing 10 mcpt-timer 3
xconnect 50.0.0.2 10 pw-class mpls1
!
pvc 0/6 l2transport
xconnect 50.0.0.2 20 pw-class mpls
!
pvc 0/7 l2transport
encapsulation aal0
cell-packing 28 mcpt-timer 3
xconnect 50.0.0.2 30 encapsulation mpls pw-class mpls one-to-one
!
pvc 0/8 l2transport
xconnect 50.0.0.2 40 pw-class mpls
!
pvc 0/9 l2transport
encapsulation aal0
xconnect 50.0.0.2 50 pw-class mpls one-to-one
!
!
interface ATM1/0.1 point-to-point
pvc 0/15 l2transport
xconnect 50.0.0.2 13 pw-class mpls
!
!
interface ATM1/0.2 multipoint
cell-packing 2 mcpt-timer 1
xconnect 50.0.0.2 12 encapsulation mpls
pvc 0/10 l2transport
encapsulation aal0
!
pvc 0/11 l2transport
encapsulation aal0
!
pvc 0/12 l2transport
encapsulation aal0
!
pvc 0/13 l2transport
encapsulation aal0
!
!
interface ATM1/0.3 point-to-point
pvc 0/16 l2transport
encapsulation aal0
xconnect 50.0.0.2 14 encapsulation mpls
!
!
interface ATM1/0.4 point-to-point
pvc 0/17 l2transport
encapsulation aal0
xconnect 50.0.0.2 15 pw-class mpls one-to-one
!
!
interface ATM1/0.6 multipoint
pvc 0/26 l2transport
xconnect 50.0.0.2 16 pw-class mpls
!
pvc 0/27 l2transport
encapsulation aal0
cell-packing 8 mcpt-timer 3
xconnect 50.0.0.2 17 pw-class mpls
!
pvc 0/28 l2transport
encapsulation aal0
cell-packing 16 mcpt-timer 2
xconnect 50.0.0.2 18 pw-class mpls
!
!
interface ATM1/0.7 multipoint
!
interface ATM1/1
no ip address
scrambling-payload
mcpt-timers 1000 5000 10000
no ilmi-keepalive
cell-packing 20 mcpt-timer 2
xconnect 50.0.0.2 11 encapsulation mpls
pvc 0/21 l2transport
encapsulation aal0
!
pvc 0/22 l2transport
encapsulation aal0
!
pvc 0/23 l2transport
encapsulation aal0
!
!
interface ATM1/1.1 point-to-point
!
interface ATM1/1.2 multipoint
!
interface ATM1/2
no ip address
scrambling-payload
ima-group 0
no ilmi-keepalive
!
ip route 50.0.0.2 255.255.255.255 20.0.0.2
!
ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback50 force
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
network-clock-select 1 E1 1/3
!
end
 

MWR_2

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname MWR2
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
!
enable password mypassword
!
no aaa new-model
!
ip cef
!
!
controller E1 0/0
cem-group 1 unframed
!
controller E1 0/1
cem-group 20 unframed
!
controller E1 0/2
cem-group 12 unframed
!
controller E1 0/3
cem-group 30 unframed
!
controller E1 0/4
cem-group 8 unframed
!
controller E1 0/5
cem-group 25 unframed
!
controller E1 1/0
mode atm
clock source internal
!
controller E1 1/1
mode atm
clock source internal
!
controller E1 1/2
mode atm
clock source internal
!
controller E1 1/3
clock source internal
!
pseudowire-class mpls
encapsulation mpls
preferred-path peer 50.0.0.1
!
pseudowire-class mpls1
encapsulation mpls
ip local interface Loopback50
!
!
interface Loopback50
ip address 50.0.0.2 255.255.255.255
!
interface CEM0/0
no ip address
cem 1
xconnect 50.0.0.1 1 encapsulation mpls
!
!
interface Vlan20
ip address 20.0.0.2 255.0.0.0
mpls ip
!
interface Vlan60
ip address 60.0.0.2 255.0.0.0
mpls ip
!
interface GigabitEthernet0/0
switchport access vlan 20
duplex auto
speed auto
!
interface GigabitEthernet0/1
switchport access vlan 60
duplex auto
speed auto
!
!
interface CEM0/1
no ip address
cem 20
xconnect 50.0.0.1 2 encapsulation mpls
!
!
interface CEM0/2
no ip address
cem 12
xconnect 50.0.0.1 3 encapsulation mpls
!
!
interface CEM0/3
no ip address
cem 30
xconnect 50.0.0.1 4 encapsulation mpls
!
!
interface CEM0/4
no ip address
cem 8
xconnect 50.0.0.1 5 encapsulation mpls
!
!
interface CEM0/5
no ip address
cem 25
xconnect 50.0.0.1 6 encapsulation mpls
!
!
interface ATM1/0
ip address 1.1.1.2 255.0.0.0
load-interval 30
scrambling-payload
mcpt-timers 1000 5000 10000
no ilmi-keepalive
pvc 0/5 l2transport
encapsulation aal0
cell-packing 25 mcpt-timer 3
xconnect 50.0.0.1 10 pw-class mpls1
!
pvc 0/6 l2transport
xconnect 50.0.0.1 20 pw-class mpls1
!
pvc 0/7 l2transport
encapsulation aal0
cell-packing 12 mcpt-timer 2
xconnect 50.0.0.1 30 encapsulation mpls pw-class mpls one-to-one
!
pvc 0/8 l2transport
xconnect 50.0.0.1 40 pw-class mpls
!
pvc 0/9 l2transport
encapsulation aal0
xconnect 50.0.0.1 50 pw-class mpls one-to-one
!
pvc 0/99
protocol ip 1.1.1.1 broadcast
encapsulation aal5snap
!
!
interface ATM1/0.1 point-to-point
pvc 0/15 l2transport
xconnect 50.0.0.1 13 pw-class mpls
!
!
interface ATM1/0.2 multipoint
cell-packing 10 mcpt-timer 2
xconnect 50.0.0.1 12 encapsulation mpls
pvc 0/10 l2transport
encapsulation aal0
!
pvc 0/11 l2transport
encapsulation aal0
!
pvc 0/12 l2transport
encapsulation aal0
!
pvc 0/13 l2transport
encapsulation aal0
!
!
interface ATM1/0.3 point-to-point
pvc 0/16 l2transport
encapsulation aal0
xconnect 50.0.0.1 14 encapsulation mpls
!
!
interface ATM1/0.4 point-to-point
pvc 0/17 l2transport
encapsulation aal0
xconnect 50.0.0.1 15 pw-class mpls one-to-one
!
!
interface ATM1/0.6 multipoint
pvc 0/26 l2transport
xconnect 50.0.0.1 16 pw-class mpls
!
pvc 0/27 l2transport
encapsulation aal0
cell-packing 18 mcpt-timer 3
xconnect 50.0.0.1 17 pw-class mpls
!
pvc 0/28 l2transport
encapsulation aal0
cell-packing 24 mcpt-timer 2
xconnect 50.0.0.1 18 pw-class mpls
!
!
interface ATM1/0.7 multipoint
!
interface ATM1/1
no ip address
scrambling-payload
mcpt-timers 1000 5000 10000
no ilmi-keepalive
cell-packing 20 mcpt-timer 2
xconnect 50.0.0.1 11 encapsulation mpls
pvc 0/21 l2transport
encapsulation aal0
!
pvc 0/22 l2transport
encapsulation aal0
!
pvc 0/23 l2transport
encapsulation aal0
!
!
interface ATM1/2
no ip address
scrambling-payload
ima-group 0
no ilmi-keepalive
!
ip route 50.0.0.1 255.255.255.255 60.0.0.1
!
!
ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback50 force
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
network-clock-select 1 BITS
!
end

PWE3 冗長性の設定

次に、PWE3 冗長性の設定例を示します(図 A-2)。

図 A-2 PWE3 冗長性の設定

 

MWR_1

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mwr-pe1
!
boot-start-marker
boot-end-marker
!
card type e1 0 1
card type e1 0 2
card type e1 1 0
card type e1 1 1
logging buffered 10000000
enable password lab
!
no aaa new-model
!
network-clock-select 1 E1 1/2
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
!
no ip domain lookup
vlan ifdescr detail
multilink bundle-name authenticated
mpls label protocol ldp
vpdn enable
!
archive
log config
hidekeys
!
!
controller E1 0/0
clock source internal
cem-group 0 unframed
!
controller E1 0/1
!
controller E1 0/2
!
controller E1 0/3
clock source internal
!
controller E1 1/0
mode aim 1
clock source internal
!
controller E1 1/1
!
controller E1 1/2
!
controller E1 1/3
clock source internal
!
interface cem0/0
cem 0
xconnect 2.2.2.2 1 encapsulation mpls
backup peer 2.2.2.2 2
backup delay 20 20
!
interface ATM1/0
no ip address
scrambling-payload
no ilmi-keepalive
xconnect 2.2.2.2 3 encapsulation mpls
backup peer 2.2.2.2 4
backup delay 20 20
pvc 0/1 l2transport
encapsulation aal0
!
interface Loopback0
no ip address
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
load-interval 30
!
interface Loopback101
no ip address
!
!
interface GigabitEthernet0/1
ip address 9.9.9.6 255.255.255.0
load-interval 30
speed 100
full-duplex
mpls ip
!
!
ip forward-protocol nd
ip route 2.2.2.2 255.255.255.255 9.9.9.8
!
ip http server
no ip http secure-server
!
!
snmp-server community public RO
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
exception data-corruption buffer truncate
!
end

MWR_2

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mwr-pe2
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
card type e1 0 2
card type e1 1 0
card type e1 1 1
logging buffered 10000000
enable password lab
!
no aaa new-model
!
network-clock-select 1 E1 0/0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip arp proxy disable
ip cef
!
!
no ip domain lookup
vlan ifdescr detail
multilink bundle-name authenticated
mpls label protocol ldp
mpls ldp session protection
mpls oam
echo revision 4
vpdn enable
!
!
!
archive
log config
hidekeys
!
!
controller E1 0/0
cem-group 0 unframed
!
controller E1 0/1
clock source internal
cem-group 0 unframed
!
controller E1 0/2
!
controller E1 0/3
clock source internal
!
controller E1 0/4
clock source internal
!
controller E1 0/5
!
controller E1 1/0
mode aim 1
clock source internal
!
controller E1 1/1
clock source internal
!
controller E1 1/2
clock source internal
!
controller E1 1/3
mode aim 1
clock source internal
!
! Primary
interface cem0/0
cem 0
xconnect 1.1.1.1 1 encapsulation mpls
!
! Backup
interface cem0/1
cem 0
xconnect 1.1.1.1 2 encapsulation mpls
!
! Primary
interface ATM1/0
no ip address
scrambling-payload
no ilmi-keepalive
xconnect 1.1.1.1 3 encapsulation mpls
pvc 0/1 l2transport
encapsulation aal0
!
! Backup
interface ATM1/3
no ip address
scrambling-payload
no ilmi-keepalive
xconnect 1.1.1.1 4 encapsulation mpls
pvc 0/1 l2transport
encapsulation aal0
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
!
interface GigabitEthernet0/1
ip address 9.9.9.8 255.255.255.0
load-interval 30
speed 100
full-duplex
mpls ip
no cdp enable
!
ip forward-protocol nd
ip route 1.1.1.1 255.255.255.255 9.9.9.6
!
no ip http server
no ip http secure-server
!
!
snmp-server community private RW
snmp-server community public RO
snmp-server ifindex persist
snmp-server trap link ietf
no snmp-server sparse-tables
snmp-server queue-length 100
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps ipran
no cdp run
route-map test permit 10
match mpls-label
!
!
!
mpls ldp router-id Loopback1 force
!
control-plane
!
no call rsvp-sync
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
exception data-corruption buffer truncate
!
end

TDM over MPLS の設定

図 A-3 は、TDM over MPLS の設定を示しています。この設定は、E1 および T1 で Structure-Agnostic TDM over Packet(SAToP)と Circuit Emulation Service over Packet-Switched Network(CESoPSN)の両方を使用します。

図 A-3 TDM over MPLS の設定

 

MWR_A

!
version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname mwr_A
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
enable password xxx
!
no aaa new-model
clock timezone est -5
!
ip cef
!
controller E1 0/0
cem-group 0 timeslots 1-31
description E1 CESoPSN example
!
controller E1 0/1
clock source internal
cem-group 1 unframed
description E1 SATOP example
!
controller E1 0/4
clock source internal
cem-group 4 unframed
description E1 SATOP example
!
controller E1 0/5
clock source internal
cem-group 5 timeslots 1-24
description E1 CESoPSN example
!
controller E1 1/0
clock source internal
!
controller E1 1/1
!
interface Loopback0
ip address 30.30.30.1 255.255.255.255
!
interface GigabitEthernet0/1
ip address 50.50.50.1 255.255.255.0
mpls ip
!
interface CEM0/0
no ip address
cem 0
xconnect 30.30.30.2 300 encapsulation mpls
!
interface CEM0/1
no ip address
cem 1
xconnect 30.30.30.2 301 encapsulation mpls
!
!
interface CEM0/4
no ip address
cem 4
xconnect 30.30.30.2 304 encapsulation mpls
!
!
interface CEM0/5
no ip address
cem 5
xconnect 30.30.30.2 305 encapsulation mpls
!
!
no ip classless
ip route 30.30.30.2 255.255.255.255 50.50.50.2
!
no ip http server
no ip http secure-server
!
line con 0
password xxx
login
line aux 0
password xxx
login
no exec
line vty 0 4
password xxx
login
!
network-clock-select 1 BITS
end
 

MWR_B

!
version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname mwr_B
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
enable password xxx
!
no aaa new-model
clock timezone est -5
!
ip cef
!
controller E1 0/0
clock source internal
cem-group 0 timeslots 1-31
description E1 CESoPSN example
!
controller E1 0/1
clock source internal
cem-group 1 unframed
description E1 SATOP example
!
controller E1 0/4
clock source internal
cem-group 4 unframed
description T1 SATOP example
!
controller E1 0/5
clock source internal
cem-group 5 timeslots 1-24
description T1 CESoPSN example
!
controller E1 1/0
 
!
controller E1 1/1
!
interface Loopback0
ip address 30.30.30.2 255.255.255.255
!
!
interface GigabitEthernet0/1
ip address 50.50.50.2 255.255.255.0
mpls ip
!
interface CEM0/0
no ip address
cem 0
xconnect 30.30.30.1 300 encapsulation mpls
!
interface CEM0/1
no ip address
cem 1
xconnect 30.30.30.1 301 encapsulation mpls
!
interface CEM0/4
no ip address
cem 4
xconnect 30.30.30.1 304 encapsulation mpls
!
!
interface CEM0/5
no ip address
cem 5
xconnect 30.30.30.1 305 encapsulation mpls
!
!
no ip classless
ip route 30.30.30.1 255.255.255.255 50.50.50.1
!
no ip http server
no ip http secure-server
!
line con 0
password xxx
login
line aux 0
password xxx
login
no exec
line vty 0 4
password xxx
login
!
network-clock-select 1 E1 1/0
end

ATM over MPLS の設定

ここでは、次の内容を設定する方法を示しています(図 A-4)。

0/1 Permanent Virtual Circuit(PVC; 相手先固定接続)0/100 に Asynchronous Transfer Mode(ATM; 非同期転送モード)Adaptation Layer 5(AAL5; ATM アダプテーション レイヤ 5)SDU モード PW

0/1 PVC 0/101 に N:1 Virtual Channel Connection(VCC; 仮想チャネル接続)セル モード PW

0/1.1 に複数 PVC の N:1 VCC セル モード PW

0/1 PVC 0/102 に 1:1 VCC セル モード PW

ポート モード PW のセル パッキング

VCC セル リレー モード PW

0/1.1 N:1 VCCセル リレー PW の PVC マッピング

図 A-4 ATM over MPLS の設定

 

MWR_A

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname mwr_A
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
logging buffered 4096
enable password lab
!
!
ip cef
!
!
no ip domain lookup
!
!
controller E1 0/0
mode atm
clock source internal
!
controller E1 0/1
mode atm
clock source internal
!
controller E1 0/2
mode atm
clock source internal
!
controller E1 0/3
mode atm
clock source internal
!
controller E1 0/4
!
controller E1 0/5
!
controller E1 1/0
!
controller E1 1/1
!
pseudowire-class mpls-exp-5
encapsulation mpls
mpls experimental 5
!
!
interface Loopback0
ip address 88.88.88.88 255.255.255.255
!
interface ATM0/0
no ip address
scrambling-payload
mcpt-timers 1000 2000 3000
no ilmi-keepalive
cell-packing 28 mcpt-timer 3
xconnect 99.99.99.99 100 encapsulation mpls
pvc 1/35 l2transport
encapsulation aal0
!
pvc 1/36 l2transport
encapsulation aal0
!
pvc 1/37 l2transport
encapsulation aal0
!
interface GigabitEthernet0/0
!
interface ATM0/1
no ip address
load-interval 30
scrambling-payload
mcpt-timers 1000 2000 3000
no ilmi-keepalive
pvc 0/10
!
pvc 0/100 l2transport
encapsulation aal5
xconnect 99.99.99.99 1100 encapsulation mpls
!
pvc 0/101 l2transport
encapsulation aal0
cell-packing 28 mcpt-timer 3
xconnect 99.99.99.99 1101 encapsulation mpls
!
pvc 0/102 l2transport
encapsulation aal0
cell-packing 28 mcpt-timer 3
xconnect 99.99.99.99 1102 encapsulation mpls
!
pvc 0/103 l2transport
encapsulation aal0
cell-packing 28 mcpt-timer 3
xconnect 99.99.99.99 1103 pw-class mpls-exp-5
!
!
interface ATM0/1.1 multipoint
cell-packing 28 mcpt-timer 3
xconnect 99.99.99.99 1200 encapsulation mpls
pvc 1/35 l2transport
encapsulation aal0
pw-pvc 2/135
!
pvc 1/36 l2transport
encapsulation aal0
pw-pvc 2/136
!
pvc 1/37 l2transport
encapsulation aal0
pw-pvc 2/137
!
!
interface GigabitEthernet0/1
description interface to 7600 fas 3/5
ip address 2.2.2.2 255.255.255.0
duplex auto
speed auto
mpls ip
no keepalive
!
interface ATM0/2
no ip address
scrambling-payload
no ilmi-keepalive
!
interface ATM0/3
no ip address
scrambling-payload
no ilmi-keepalive
!
ip route 99.99.99.99 255.255.255.255 2.2.2.3
!
!
ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback0
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
password lab
login
!
network-clock-select 1 E1 1/0
!
end

MWR_B

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname mwr_B
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
logging buffered 4096
enable password lab
!
!
ip cef
!
!
no ip domain lookup
!
!
controller E1 0/0
mode atm
!
controller E1 0/1
mode atm
!
controller E1 0/2
mode atm
!
controller E1 0/3
mode atm
!
controller E1 0/4
!
controller E1 0/5
!
pseudowire-class mpls-exp-5
encapsulation mpls
mpls experimental 5
!
!
interface Loopback0
ip address 99.99.99.99 255.255.255.255
!
interface ATM0/0
no ip address
scrambling-payload
mcpt-timers 1000 2000 3000
no ilmi-keepalive
cell-packing 28 mcpt-timer 3
xconnect 88.88.88.88 100 encapsulation mpls
pvc 1/35 l2transport
encapsulation aal0
!
pvc 1/36 l2transport
encapsulation aal0
!
pvc 1/37 l2transport
encapsulation aal0
!
!
interface GigabitEthernet0/0
!
interface ATM0/1
no ip address
scrambling-payload
mcpt-timers 1000 2000 3000
no ilmi-keepalive
pvc 0/2
!
pvc 0/100 l2transport
encapsulation aal5
xconnect 88.88.88.88 1100 encapsulation mpls
!
pvc 0/101 l2transport
encapsulation aal0
cell-packing 28 mcpt-timer 3
xconnect 88.88.88.88 1101 encapsulation mpls
!
pvc 0/102 l2transport
encapsulation aal0
cell-packing 28 mcpt-timer 3
xconnect 88.88.88.88 1102 encapsulation mpls
!
pvc 0/103 l2transport
encapsulation aal0
cell-packing 28 mcpt-timer 3
xconnect 88.88.88.88 1103 pw-class mpls-exp-5
!
interface ATM0/1.1 multipoint
cell-packing 28 mcpt-timer 3
xconnect 88.88.88.88 1200 encapsulation mpls
pvc 2/135 l2transport
encapsulation aal0
!
pvc 2/136 l2transport
encapsulation aal0
!
pvc 2/137 l2transport
encapsulation aal0
!
!
interface GigabitEthernet0/1
ip address 2.2.2.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface ATM0/2
no ip address
scrambling-payload
ima-group 0
no ilmi-keepalive
!
interface ATM0/3
no ip address
scrambling-payload
ima-group 0
no ilmi-keepalive
!
ip route 88.88.88.88 255.255.255.255 2.2.2.2
!
!
ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback0
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
network-clock-select 1 E1 0/0
!
end
 

Ethernet over MPLS(EoMPLS)の設定

次に、イーサネット疑似回線(別名 Ethernet over MPLS(EoMPLS))の設定例を示します。

 

MWR_A

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mwr_A
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
logging buffered 4096
enable password mypassword
!
no aaa new-model
!
network-clock-select 1 E1 0/0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
no ip domain lookup
ip domain name cisco.com
multilink bundle-name authenticated
mpls label protocol ldp
vpdn enable
!
!
controller E1 0/0
mode aim 1
!
controller E1 0/1
mode aim 1
!
controller E1 0/2
mode aim 1
!
controller E1 0/3
mode aim 1
!
controller E1 0/4
!
controller E1 0/5
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet0/4
switchport trunk allowed vlan 1,2,20,1002-1005
switchport mode trunk
!
interface GigabitEthernet0/5
switchport trunk allowed vlan 1,2,40,1002-1005
switchport mode trunk
!
interface Vlan20
ip address 20.20.20.1 255.255.255.0
no ptp enable
mpls ip
!
interface Vlan40
no ip address
no ptp enable
xconnect 2.2.2.2 10 encapsulation mpls
!
ip route 2.2.2.2 255.255.255.255 20.20.20.2
!
no ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback0
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
end
 
 

MWR_B

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mwr_B
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
card type e1 0 1
logging buffered 4096
enable password mypassword
!
no aaa new-model
!
network-clock-select 1 E1 0/0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip cef
!
no ip domain lookup
ip domain name cisco.com
multilink bundle-name authenticated
mpls label protocol ldp
vpdn enable
!
!
controller E1 0/0
mode aim 1
!
controller E1 0/1
mode aim 1
!
controller E1 0/2
mode aim 1
!
controller E1 0/3
mode aim 1
!
controller E1 0/4
!
controller E1 0/5
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/4
switchport trunk allowed vlan 1,2,20,1002-1005
switchport mode trunk
!
interface GigabitEthernet0/5
switchport trunk allowed vlan 1,2,40,1002-1005
switchport mode trunk
!
interface Vlan20
ip address 20.20.20.2 255.255.255.0
no ptp enable
mpls ip
!
interface Vlan40
no ip address
no ptp enable
xconnect 4.4.4.4 10 encapsulation mpls
!
ip route 4.4.4.4 255.255.255.255 20.20.20.1
!
no ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback0
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
password lab
login
!
end
 

GSM だけの設定

標準の GSM トポロジには、個別の T1/E1 接続を経由する BTS から Cisco MWR 2941-DC への 1 つまたは複数のショートホール インターフェイス接続が含まれます。Cisco MWR 2941-DC ルータは、Multilink Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)(MLPPP; マルチリンク PPP)バックホール接続(2 つ以上の T1/E1 接続)を使用してバックツーバックで接続されます。BSC 側の Cisco MWR 2941-DC と BSC との間の接続は、BTS と Cisco MWR 2941-DC との間の接続と同じです。この例では、GSM トラフィックだけがトポロジを経由します(図 A-5)。

図 A-5 GSM だけの設定

 

MWR_A

!
card type E1 0 0
!
!
controller E1 0/0
framing NO-CRC4
clock source internal
channel-group 0 timeslots 1-31
!
controller E1 0/1
channel-group 0 timeslots 1-31
!
controller E1 0/2
framing NO-CRC4
clock source internal
channel-group 0 timeslots 1-31
!
!
class-map match-any llq-class
match ip dscp ef
!
!
policy-map llq-policy
class llq-class
priority percent 99
class class-default
bandwidth remaining percent 1
queue-limit 45
!
interface Multilink1
ip address 10.10.10.1 255.255.255.252
load-interval 30
ppp pfc local request
ppp pfc remote apply
ppp acfc local request
ppp acfc remote apply
ppp multilink
ppp multilink interleave
ppp multilink group 1
ppp multilink fragment delay 0 1
ppp multilink multiclass
max-reserved-bandwidth 100
service-policy output llq-policy
hold-queue 50 out
ip rtp header-compression ietf-format
!
!
interface Serial0/0:0
no ip address
encapsulation gsm-abis
gsm-abis local 10.10.10.1 4444
gsm-abis remote 10.10.10.2 4444
gsm-abis set dscp ef
no keepalive
!
interface Serial0/1:0
no ip address
encapsulation ppp
keepalive 1
ppp multilink
ppp multilink group 1
max-reserved-bandwidth 100
!
interface Serial0/2:0
no ip address
encapsulation gsm-abis
gsm-abis local 10.10.10.1 4446
gsm-abis remote 10.10.10.2 4446
gsm-abis set dscp ef
no keepalive
!
logging history size 500
logging history debugging
logging trap warnings
snmp-server community public RO
snmp-server queue-length 100
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps ipran
snmp-server enable traps syslog
snmp-server trap link ietf
snmp-server ifIndex persist
snmp-server host 64.50.100.254 version 2c V2C
!
network-clock-select 1 E1 0/1
!

MWR_B

!
card type E1 0 0
!
!
controller E1 0/0
framing NO-CRC4
channel-group 0 timeslots 1-31
!
controller E1 0/1
clock source internal
channel-group 0 timeslots 1-31
!
controller E1 0/2
framing NO-CRC4
channel-group 0 timeslots 1-31
!
!
class-map match-any llq-class
match ip dscp ef
!
!
policy-map llq-policy
class llq-class
priority percent 99
class class-default
bandwidth remaining percent 1
queue-limit 45
!
interface Multilink1
ip address 10.10.10.2 255.255.255.252
load-interval 30
ppp pfc local request
ppp pfc remote apply
ppp acfc local request
ppp acfc remote apply
ppp multilink
ppp multilink interleave
ppp multilink group 1
ppp multilink fragment delay 0 1
ppp multilink multiclass
max-reserved-bandwidth 100
service-policy output llq-policy
hold-queue 50 out
ip rtp header-compression ietf-format
!
!
interface Serial0/0:0
no ip address
encapsulation gsm-abis
gsm-abis local 10.10.10.2 4444
gsm-abis remote 10.10.10.1 4444
gsm-abis set dscp ef
no keepalive
!
interface Serial0/1:0
no ip address
encapsulation ppp
keepalive 1
ppp multilink
ppp multilink group 1
max-reserved-bandwidth 100
!
interface Serial0/2:0
no ip address
encapsulation gsm-abis
gsm-abis local 10.10.10.2 4446
gsm-abis remote 10.10.10.1 4446
gsm-abis set dscp ef
no keepalive
!
logging history size 500
logging history debugging
logging trap warnings
snmp-server community public RO
snmp-server queue-length 100
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps ipran
snmp-server enable traps syslog
snmp-server trap link ietf
snmp-server ifIndex persist
snmp-server host 64.50.100.254 version 2c V2C
!
network-clock-select 1 E1 0/0
network-clock-select 2 E1 0/2
!

衛星を使用する GSM だけの設定

衛星を使用する GSM だけの設定により、ポイントツーポイントでネットワークを最適化できます(図 A-6)。

図 A-6 衛星を使用する GSM だけの設定

 

MWR_A

!
card type E1 0 0
!
!
controller E1 0/0
framing NO-CRC4
clock source internal
channel-group 0 timeslots 1-20
!
controller E1 0/1
channel-group 0 timeslots 1-20
!
!
class-map match-any llq-class
match ip dscp ef
!
!
policy-map llq-policy
class llq-class
priority percent 99
class class-default
bandwidth remaining percent 1
queue-limit 45
!
interface Multilink1
ip address 10.10.10.1 255.255.255.252
load-interval 30
no keepalive
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp acfc local request
ppp acfc remote apply
ppp multilink
ppp multilink interleave
ppp multilink group 1
ppp multilink fragment delay 0 1
ppp multilink multiclass
max-reserved-bandwidth 100
service-policy output llq-policy
hold-queue 50 out
ip rtp header-compression ietf-format
!
!
interface Serial0/0:0
no ip address
encapsulation gsm-abis
gsm-abis local 10.10.10.1 4444
gsm-abis remote 10.10.10.2 4444
gsm-abis jitter 10
gsm-abis retransmit 5
gsm-abis set dscp ef
no keepalive
!
interface Serial0/1:0
no ip address
encapsulation ppp
keepalive 1
ppp multilink
ppp multilink group 1
max-reserved-bandwidth 100
!
logging history size 500
logging history debugging
logging trap warnings
snmp-server community public RO
snmp-server queue-length 100
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps ipran
snmp-server enable traps syslog
snmp-server trap link ietf
snmp-server ifIndex persist
snmp-server host 64.50.100.254 version 2c V2C
!
network-clock-select 1 E1 0/1
 

MWR_B

!
card type E1 0 0
!
!
controller E1 0/0
framing NO-CRC4
channel-group 0 timeslots 1-20
!
controller E1 0/1
clock source internal
channel-group 0 timeslots 1-20
!
!
class-map match-any llq-class
match ip dscp ef
!
!
policy-map llq-policy
class llq-class
priority percent 99
class class-default
bandwidth remaining percent 1
queue-limit 45
!
interface Multilink1
ip address 10.10.10.2 255.255.255.252
load-interval 30
no keepalive
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp acfc local request
ppp acfc remote apply
ppp multilink
ppp multilink interleave
ppp multilink group 1
ppp multilink fragment delay 0 1
ppp multilink multiclass
max-reserved-bandwidth 100
service-policy output llq-policy
hold-queue 50 out
ip rtp header-compression ietf-format
!
!
interface Serial0/0:0
no ip address
encapsulation gsm-abis
gsm-abis local 10.10.10.2 4444
gsm-abis remote 10.10.10.1 4444
gsm-abis jitter 10
gsm-abis retransmit 5
gsm-abis set dscp ef
no keepalive
!
interface Serial0/1:0
no ip address
encapsulation ppp
keepalive 1
ppp multilink
ppp multilink group 1
max-reserved-bandwidth 100
!
logging history size 500
logging history debugging
logging trap warnings
snmp-server community public RO
snmp-server queue-length 100
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps ipran
snmp-server enable traps syslog
snmp-server trap link ietf
snmp-server ifIndex persist
snmp-server host 64.50.100.254 version 2c V2C
!
network-clock-select 1 E1 0/0
 

GSM 輻輳管理

次に、BTS 側および BSC 側の GSM 輻輳管理を設定する例を示します。


) ここでは、特定の機能を紹介する目的で設定の一部を示しています。


BTS 側

interface Serial0/0:0
no ip address
encapsulation gsm-abis
gsm-abis local 10.10.10.1 4444
gsm-abis remote 10.10.10.2 4444
gsm-abis congestion enable
gsm-abis congestion critical 1-2
gsm-abis congestion critical 31
gsm-abis set dscp ef
no keepalive
 

BSC 側

interface Serial0/0:0
no ip address
encapsulation gsm-abis
gsm-abis local 10.10.10.2 4444
gsm-abis remote 10.10.10.1 4444
gsm-abis congestion enable
gsm-abis congestion critical 1-2
gsm-abis congestion critical 31
gsm-abis set dscp ef
no keepalive
 

Generic Routing Encapsulation(GRE)トンネリングの設定

次の設定では、Generic Routing Encapsulation(GRE)トンネルを使用する疑似回線接続を作成します。

CESoPSN と GRE トンネル バックホール

ATM over MPLS AAL5 SDU モードと GRE バックホール

GRE の設定方法の詳細については、「GRE トンネリングの設定」を参照してください。


) ここでは、特定の機能を紹介する目的で設定の一部を示しています。


CESoPSN と GRE トンネル バックホール

!
controller E1 0/15
framing NO-CRC4
clock source line
cem-group 0 timeslots 1-31
description TDM Shorthaul for CESoPSN PW
!
interface Loopback0
description Loopback for MPLS and PWE3
ip address 10.10.10.1 255.255.255.255
!
interface CEM0/15
description CESoPSN
no ip address
cem 0
xconnect 10.10.10.2 111 encapsulation mpls
!
!
interface Tunnel3
ip address 9.9.9.9 255.255.255.0
tunnel mode gre ip
mpls ip
tunnel source Vlan3
tunnel destination 3.3.3.3
!
ip route 10.10.10.2 255.255.255.255 9.9.9.1
!
mpls ldp router-id Loopback0 force
!
 

ATM over MPLS AAL5 SDU モードと GRE バックホール

!
interface ATM0/0
no ip address
scrambling-payload
no atm ilmi-keepalive
pvc 0/10 l2transport
encapsulation aal5
xconnect 10.10.10.1 300 encapsulation mpls
!
interface Tunnel3
ip address 9.9.9.9 255.255.255.0
tunnel mode gre ip
mpls ip
tunnel source Vlan3
tunnel destination 3.3.3.3
!
interface Loopback0
description Loopback for MPLS and PWE3
ip address 10.10.10.1 255.255.255.255
!
ip route 10.10.10.2 255.255.255.255 9.9.9.1
!
mpls ldp router-id Loopback0 force
 

ルーティング設定例

ここでは、Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)を使用する各ルーティング プロトコルの設定例を示します。

Open Shortest Path First(OSPF)と BFD

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)と BFD

Intermediate System-to-Intermediate System(IS-IS)と BFD

Cisco MWR 2941-DC のルーティング設定方法の詳細については、「ルーティング プロトコルの設定」および「BFD の設定」を参照してください。

Open Shortest Path First(OSPF)と BFD

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BFD2941
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
logging buffered 1000000
no logging console
!
no aaa new-model
ip source-route
!
!
ip cef
no ip domain lookup
ip host tftp 64.102.116.25
ptp mode ordinary
ptp priority1 128
ptp priority2 128
ptp domain 0
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
controller T1 0/0
mode atm
clock source line
!
controller T1 0/1
clock source line
cem-group 0 timeslots 1-31
!
controller T1 0/2
clock source internal
!
controller T1 0/3
clock source internal
!
controller T1 0/4
clock source internal
!
controller T1 0/5
clock source internal
!
controller T1 0/6
clock source internal
!
controller T1 0/7
clock source internal
!
controller T1 0/8
clock source internal
!
controller T1 0/9
clock source internal
!
controller T1 0/10
clock source internal
!
controller T1 0/11
clock source internal
!
controller T1 0/12
clock source internal
!
controller T1 0/13
clock source internal
!
controller T1 0/14
clock source internal
!
controller T1 0/15
clock source internal
!
controller BITS
applique E1
!
!
interface Loopback0
ip address 88.88.88.150 255.255.255.255
!
interface GigabitEthernet0/0
switchport trunk allowed vlan 1-9,11-4094
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport access vlan 10
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface ATM0/0
no ip address
scrambling-payload
atm pvp 1 l2transport
xconnect 10.10.10.2 10001 encapsulation mpls
no atm ilmi-keepalive
pvc 0/20 l2transport
vc-hold-queue 80
encapsulation aal0
xconnect 10.10.10.2 10020 encapsulation mpls
!
pvc 0/30 l2transport
encapsulation aal5
xconnect 10.10.10.2 10030 encapsulation mpls
!
pvc 0/40
vc-hold-queue 50
encapsulation aal5snap
!
!
interface CEM0/1
no ip address
cem 0
xconnect 10.10.10.2 222 encapsulation mpls
!
!
interface Vlan1
no ip address
shutdown
no ptp enable
!
interface Vlan10
ip address 192.168.52.88 255.255.255.0
no ptp enable
!
interface Vlan100
description Primary EVC
ip address 172.22.41.2 255.255.255.0
ip ospf cost 4
ip ospf hello-interval 1
ip ospf dead-interval 3
no ptp enable
mpls ip
bfd interval 50 min_rx 50 multiplier 3
!
interface Vlan200
description Secondary EVC
ip address 172.22.42.2 255.255.255.0
ip ospf cost 5
ip ospf hello-interval 1
ip ospf dead-interval 3
no ptp enable
mpls ip
!
router ospf 100
router-id 88.88.88.150
log-adjacency-changes
timers throttle spf 50 50 1000
timers throttle lsa all 0 25 10000
timers lsa arrival 0
timers pacing flood 20
timers pacing retransmission 30
redistribute static subnets
network 88.88.88.150 0.0.0.0 area 0
network 172.22.41.0 0.0.0.255 area 0
network 172.22.42.0 0.0.0.255 area 0
bfd all-interfaces
!
ip default-gateway 192.168.52.1
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.52.1
ip route 64.102.116.25 255.255.255.255 192.168.52.1
!
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
exec-timeout 0 0
no modem enable
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
password xxxxx
login
!
exception data-corruption buffer truncate
network-clock-select hold-timeout infinite
network-clock-select mode nonrevert
network-clock-select 1 E1 0/0
end

 

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)と BFD

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BFD2941
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
logging buffered 1000000
no logging console
!
no aaa new-model
ip source-route
!
!
ip cef
no ip domain lookup
ip host tftp 64.102.116.25
ptp mode ordinary
ptp priority1 128
ptp priority2 128
ptp domain 0
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
controller T1 0/0
mode atm
clock source line
!
controller T1 0/1
clock source line
cem-group 0 timeslots 1-31
!
controller T1 0/2
clock source internal
!
controller T1 0/3
clock source internal
!
controller T1 0/4
clock source internal
!
controller T1 0/5
clock source internal
!
controller T1 0/6
clock source internal
!
controller T1 0/7
clock source internal
!
controller T1 0/8
clock source internal
!
controller T1 0/9
clock source internal
!
controller T1 0/10
clock source internal
!
controller T1 0/11
clock source internal
!
controller T1 0/12
clock source internal
!
controller T1 0/13
clock source internal
!
controller T1 0/14
clock source internal
!
controller T1 0/15
clock source internal
!
controller BITS
applique E1
!
interface Loopback0
ip address 20.20.20.20 255.255.255.255
!
interface GigabitEthernet0/2
switchport access vlan 10
load-interval 30
duplex full
speed 100
!
interface GigabitEthernet0/3
switchport access vlan 200
load-interval 30
duplex full
speed 100
!
interface GigabitEthernet0/4
switchport access vlan 4
load-interval 30
duplex full
speed 100
!
interface GigabitEthernet0/5
switchport access vlan 100
load-interval 30
duplex full
speed 100
!
interface ATM0/0
no ip address
scrambling-payload
atm bandwidth dynamic
pvc 0/100 l2transport
!
!
interface ATM0/0.1 multipoint
pvc 1/5 l2transport
encapsulation aal0
xconnect 10.10.10.10 10010 encapsulation mpls
!
pvc 1/6 l2transport
encapsulation aal5
xconnect 10.10.10.10 10020 encapsulation mpls
!
!
interface ATM0/0.2 multipoint
xconnect 10.10.10.10 10030 encapsulation mpls
pvc 2/5 l2transport
encapsulation aal0
!
pvc 2/6 l2transport
encapsulation aal0
!
!
interface ATM0/1
no ip address
scrambling-payload
no atm ilmi-keepalive
pvc 0/100 l2transport
!
!
interface Vlan4 (connected to 7600)
ip address 11.1.1.2 255.255.255.0
no ptp enable
bfd interval 50 min_rx 50 multiplier 3
!
interface Vlan10
ip address 192.168.40.61 255.255.255.128
no ptp enable
mpls ip
!
interface Vlan100
ip address 12.1.1.2 255.255.255.0
no ptp enable
mpls bgp forwarding
mpls ip
bfd interval 50 min_rx 50 multiplier 3
!
interface Vlan200
ip address 12.1.2.2 255.255.255.0
no ptp enable
mpls bgp forwarding
mpls ip
bfd interval 50 min_rx 50 multiplier 3
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 11.1.1.0
network 12.1.1.0
network 12.1.2.0
redistribute connected
neighbor 11.1.1.1 remote-as 100
neighbor 11.1.1.1 fall-over bfd
neighbor 11.1.1.1 send-label
neighbor 12.1.1.1 remote-as 300
neighbor 12.1.1.1 fall-over bfd
neighbor 12.1.1.1 send-label
neighbor 12.1.2.1 remote-as 300
neighbor 12.1.2.1 fall-over bfd
neighbor 12.1.2.1 send-label
no auto-summary
!
connect atmcellsw ATM0/0 0/100 ATM0/1 0/100
!
!
mpls ldp router-id Loopback0 force
!
 

Intermediate System-to-Intermediate System(IS-IS)と BFD

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BFD2941
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
logging buffered 1000000
no logging console
!
no aaa new-model
ip source-route
!
!
ip cef
no ip domain lookup
ip host tftp 64.102.116.25
ptp mode ordinary
ptp priority1 128
ptp priority2 128
ptp domain 0
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
controller T1 0/0
mode atm
clock source line
!
controller T1 0/1
clock source line
cem-group 0 timeslots 1-31
!
controller T1 0/2
clock source internal
!
controller T1 0/3
clock source internal
!
controller T1 0/4
clock source internal
!
controller T1 0/5
clock source internal
!
controller T1 0/6
clock source internal
!
controller T1 0/7
clock source internal
!
controller T1 0/8
clock source internal
!
controller T1 0/9
clock source internal
!
controller T1 0/10
clock source internal
!
controller T1 0/11
clock source internal
!
controller T1 0/12
clock source internal
!
controller T1 0/13
clock source internal
!
controller T1 0/14
clock source internal
!
controller T1 0/15
clock source internal
!
controller BITS
applique E1
!
interface Loopback0
ip address 20.20.20.20 255.255.255.255
!
interface GigabitEthernet0/2
switchport access vlan 10
load-interval 30
duplex full
speed 100
!
interface GigabitEthernet0/3
switchport access vlan 200
load-interval 30
duplex full
speed 100
!
interface GigabitEthernet0/4
switchport access vlan 4
load-interval 30
duplex full
speed 100
!
interface GigabitEthernet0/5
switchport access vlan 100
load-interval 30
duplex full
speed 100
!
interface ATM0/0
no ip address
scrambling-payload
atm bandwidth dynamic
pvc 0/100 l2transport
!
!
interface ATM0/0.1 multipoint
pvc 1/5 l2transport
encapsulation aal0
xconnect 10.10.10.10 10010 encapsulation mpls
!
pvc 1/6 l2transport
encapsulation aal5
xconnect 10.10.10.10 10020 encapsulation mpls
!
!
interface ATM0/0.2 multipoint
xconnect 10.10.10.10 10030 encapsulation mpls
pvc 2/5 l2transport
encapsulation aal0
!
pvc 2/6 l2transport
encapsulation aal0
!
!
interface ATM0/1
no ip address
scrambling-payload
no atm ilmi-keepalive
pvc 0/100 l2transport
!
!
interface Vlan4
ip address 11.1.1.2 255.255.255.0
ip router isis test_ip_isis
no ptp enable
isis bfd
!
interface Vlan10
ip address 192.168.40.61 255.255.255.128
no ptp enable
mpls ip
!
interface Vlan100
ip address 12.1.1.2 255.255.255.0
ip router isis test_ip_isis
no ptp enable
mpls ip
bfd interval 50 min_rx 50 multiplier 3
isis bfd
!
interface Vlan200
ip address 12.1.2.2 255.255.255.0
ip router isis test_ip_isis
no ptp enable
mpls ip
bfd interval 50 min_rx 50 multiplier 3
isis bfd
!
router isis test_ip_isis
net 47.0004.004d.0055.0000.0c00.0002.00
net 47.0004.004d.0056.0000.0c00.0002.00
is-type level-2-only
redistribute connected
bfd all-interfaces
!
 

Precision Timing Protocol(PTP)設定例

ここでは、Precision Timing Protocol(PTP)の設定例を示します。PTP の設定方法の詳細については、「クロッキングとタイミングの設定」を参照してください。

PTP の冗長性

次の設定では、PTP で PTP の冗長性を使用しています。


) ここでは、特定の機能を紹介する目的で設定の一部を示しています。


MWR_A

!
interface Loopback0
ip address 6.6.6.3 255.255.255.255
end
!
interface GigabitEthernet0/0
switchport access vlan 10
!
interface GigabitEthernet0/1
switchport access vlan 5
!
interface Vlan5
ip address 5.5.5.2 255.255.255.0
ip router isis
ip pim sparse-mode
no ptp enable
!
interface Vlan10
ip address 10.10.10.2 255.255.255.0
ip router isis
ip pim sparse-mode
no ptp enable
!
router isis
net 49.0001.1720.1600.3003.00
passive-interface Loopback0
!
ip pim rp-address 6.6.6.1 override
!
 

MWR_B

!
interface Loopback0
ip address 6.6.6.2 255.255.255.255
ip pim sparse-mode
end
!
interface GigabitEthernet0/0
switchport access vlan 10
!
interface GigabitEthernet0/4
switchport access vlan 4
load-interval 30
!
!
interface Vlan4
ip address 7.7.7.2 255.255.255.0
ip router isis
ip pim sparse-mode
no ptp enable
!
!
interface Vlan10
ip address 10.10.10.1 255.255.255.0
ip router isis
ip pim sparse-mode
no ptp enable
!
router isis
net 49.0001.1720.1600.9009.00
passive-interface Loopback0
!
ip pim rp-address 6.6.6.1 override
 
 

レイヤ 3 バーチャル プライベート ネットワーク(VPN)設定例

次に、レイヤ 3 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)の設定例を示します。レイヤ 3 VPN の設定方法の詳細については、「レイヤ 3 バーチャル プライベート ネットワーク(VPN)の設定」を参照してください。


) ここでは、特定の機能を紹介する目的で設定の一部を示しています。


!
-----------Customer definitions for 2 customers---------------------------------------
vrf definition customer_a
rd 192.168.1.1:100
route-target export 192.168.1.1:100
route-target import 192.168.1.1:100
!
address-family ipv4
exit-address-family
!
vrf definition customer_b
rd 192.168.2.1:200
route-target export 192.168.2.1:200
route-target import 192.168.2.1:200
!
address-family ipv4
exit-address-family
!
-------------------Loopback addresses for 2 customers-----------------------------------
interface Loopback100
vrf forwarding customer_a
ip address 192.169.1.3 255.255.255.255
!
interface Loopback101
vrf forwarding customer_b
ip address 192.168.100.1 255.255.255.255
!
------------------------Core-facing OSPF instance----------------------------
router ospf 1
log-adjacency-changes
network 100.0.0.0 0.255.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
network 192.169.0.0 0.0.255.255 area 0
!
----------------------VRF OSPF instances for 2 customers -------------------------------
router ospf 100 vrf customer_a
router-id 192.168.1.3
log-adjacency-changes
redistribute bgp 101 metric-type 1 subnets
network 192.168.0.0 0.0.255.255 area 0
network 192.169.0.0 0.0.255.255 area 0
!
router ospf 100 vrf customer_b
router-id 192.168.100.1
log-adjacency-changes
redistribute bgp 101 metric-type 1 subnets
network 192.168.0.0 0.0.255.255 area 0
network 192.169.0.0 0.0.255.255 area 0
!
----------------------MP-BGP with 2 VRF customers ---------------------------------
router bgp 101
bgp router-id 100.1.1.1
bgp log-neighbor-changes
neighbor 100.1.1.2 remote-as 101
neighbor 100.1.1.2 update-source Loopback1
!
address-family ipv4
redistribute connected
neighbor 100.1.1.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 100.1.1.2 activate
neighbor 100.1.1.2 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf customer_b
redistribute connected
neighbor 100.1.1.2 remote-as 101
neighbor 100.1.1.2 update-source Loopback1
neighbor 100.1.1.2 activate
no synchronization
exit-address-family
!
address-family ipv4 vrf customer_a
redistribute connected
neighbor 100.1.1.2 remote-as 101
neighbor 100.1.1.2 update-source Loopback1
neighbor 100.1.1.2 activate
no synchronization
exit-address-family
!
----------------MP-BGP loopback interface ---------------------------------
interface Loopback1
ip address 100.1.1.1 255.255.255.255
!
------------------Core-facing Vlan interface -------------------------------
interface GigabitEthernet0/1
switchport access vlan 20
switchport trunk allowed vlan 1,2,20-23,1002-1005
switchport mode trunk
load-interval 30
!
interface Vlan20
ip address 192.169.10.1 255.255.255.0
load-interval 30
no ptp enable
mpls ip
!
------------------CE-facing Vlan interfaces for 2 customers------------------------------
interface GigabitEthernet0/4
switchport access vlan 100
load-interval 30
duplex full
!
interface Vlan100
vrf forwarding customer_a
ip address 192.169.3.2 255.255.255.0
!
interface GigabitEthernet0/5
switchport access vlan 99
load-interval 30
duplex full
!
interface Vlan99
vrf forwarding customer_b
ip address 192.169.3.2 255.255.255.0
!

Quality of Service(QoS)設定例

次の設定例では、Cisco MWR 2941-DC に QoS 設定を適用する方法を示します。


) ここでは、特定の機能を紹介する目的で設定の一部を示しています。


ここでは、Cisco MWR 2941-DC の QoS の設定例を示します。

スイッチポート プライオリティ

分類およびマーキング

プライオリティ キューイング

QoS 設定方法の詳細については、「Quality of Service(QoS)の設定」を参照してください。

スイッチポート プライオリティ

次の設定例では、9ESW High-speed WAN Interface Card(HWIC; 高速 WAN インターフェイス カード)インターフェイスの着信トラフィックに P ビット値をマーク付けする方法を示しています。

...............
interface GigabitEthernet0/2
no ip address
switchport stacking-partner interface FastEthernet1/8
...............
interface FastEthernet1/7
switchport mode trunk
switchport priority override 7 ! set all ingress traffic to priority 7
! regardless of current priority values.
interface FastEthernet1/7
switchport mode access
switchport access vlan 100
switchport priority default 5 ! set all ingress traffic to priority 5
 
interface FastEthernet1/8
no IP address
switchport stacking-partner interface GigabitEthernet0/2
 

分類およびマーキング

次に、入力イーサネット トラフィックの Differentiated Service Code Point(DSCP; DiffServ コード ポイント)値をマーク付けして QoS グループに割り当てた後、P ビットをマーク付けする例を示します。出トラフィックは、Weighted Round-Robin(WRR)でキューイングし、各グループに帯域幅の割合を割り当てます。

! Note 1: these class-maps are applied on ingress
class-map match-any common-channels
match dscp af31 af32 af33
class-map match-any HSDPA
match dscp default
class-map match-any R99
match dscp af21 af22 af23
class-map match-any synchronization
match dscp ef cs6
class-map match-any signaling
match dscp af41 af42 af43
!
! Note 2: these classp-maps are applied on egress
Class-map match-any group1
Match qos-group 1
Class-map match-any group2
Match qos-group 2
Class-map match-any group3
Match qos-group 3
Class-map match-any group4
Match qos-group 4
Class-map match-any group5
Match qos-group 5
Class-map match-any group6
Match qos-group 6
 
! Note 3:The input policy performs the DSCP match and all marking
policy-map input-policy
class synchronization
set qos-group 6
set cos 6
class signaling
set qos-group 5
set cos 5
class common-channels
set qos-group 4
set cos 4
class R99
set qos-group 3
set cos 3
class HSDPA
set qos-group 1
class default
set qos-group 1
!
! Note 4: the hierarchical output policy handles WRR and shaping
policy-map QOS-child
class group6
priority percent 5
class group5
bandwidth percent 20
class group4
bandwidth percent 20
class group3
bandwidth percent 20
class group1
bandwidth percent 20
policy-map output-policy
class class-default
shape average 38000000
service-policy QOS-child
!
Interface GigabitEthernet 0/0
service-policy input input-policy
Interface GigabitEthernet 0/1
service-policy output output-policy
 

MPLS ビット マーキング

次に、疑似回線クラス Universal Mobile Telecommunications System(UMTS)_3 を通過するトラフィックに MPLS Experimental(Exp)ビットをマーク付けする例を示します。Exp ビット値は、MLPPP 出力インターフェイス、MLPPP キュー、またはレイヤ 2 イーサネット キューの QoS グループにマッピングできます。

!
pseudowire-class UMTS_3
encapsulation mpls
mpls experimental 3
!
interface ATM0/IMA0
pvc 2/1 l2transport
encapsulation aal0
xconnect 10.10.10.1 121 pw-class UMTS_3
!
!
 

プライオリティ キューイング

次に、DSCP 値が ef のトラフィックを、MLPPP マルチリンク インターフェイスのプライオリティ キューに配置する例を示します。

class-map match-any gsm-abis
match dscp ef
!
!
policy-map gsm-abis ? note that without multiclass up to 4 queues supported
class gsm-abis
priority percent 99
class class-default
bandwidth remaining percent 1
!
 
interface Multilink1
ip address 50.50.50.49 255.255.255.0
ip tcp header-compression ietf-format
load-interval 30
keepalive 1
ppp pfc local request
ppp pfc remote apply
ppp acfc local request
ppp acfc remote apply
ppp multilink
ppp multilink interleave
ppp multilink group 1
ppp multilink fragment delay 0 1
ppp multilink multiclass
ppp timeout multilink lost-fragment 1
max-reserved-bandwidth 100
service-policy output gsm-abis
hold-queue 50 out
ip rtp header-compression ietf-format
 
 

Cisco Networking Services(CNS)ゼロ タッチ配置設定

次に、IP アドレス 30.30.1.20 の Cisco Networking Services(CNS)-Customer Edge(CE; カスタマー エッジ)サーバに保存されたコンフィギュレーションを使用して Cisco MWR 2941-DC を起動するように設定する例を示します。CNS の設定の詳細については、「Cisco Networking Services(CNS)の設定」を参照してください。


) ここでは、特定の機能を紹介する目的で設定の一部を示しています。


 
hostname 2941
!
cns trusted-server all-agents 30.30.1.20
cns event 30.30.1.20 11011 keepalive 60 3
cns config initial 30.30.1.20 80
cns config partial 30.30.1.20 80
cns id hostname
cns id hostname event
cns id hostname image
cns exec 80
logging buffered 20000
!
end