Cisco 819 シリーズ サービス統合型ルータ ソフトウェア コンフィギュレーション ガイド
バックアップ データ回線およびリモート管理の設定
バックアップ データ回線およびリモート管理の設定
発行日;2013/05/19 | 英語版ドキュメント(2013/02/08 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

バックアップ データ回線およびリモート管理の設定

バックアップ インターフェイスの設定

セルラー ダイヤルオンデマンド ルーティング バックアップの設定

ダイヤラ ウォッチを使用した DDR バックアップの設定

浮動スタティック ルートを使用した DDR バックアップの設定

NAT および IPsec 設定でのバックアップとしてのセル ワイヤレス モデム

コンソール ポートを使用したダイヤル バックアップおよびリモート管理の設定

バックアップ データ回線およびリモート管理の設定

この章では、次の項で、バックアップ データ ラインおよびリモート管理の設定について説明します。

「バックアップ インターフェイスの設定」

「セルラー ダイヤルオンデマンド ルーティング バックアップの設定」

「コンソール ポートを使用したダイヤル バックアップおよびリモート管理の設定」

Cisco 819 サービス統合型ルータ(ISR)は、WAN のダウンタイムの削減を可能にするバックアップ データ ラインとのバックアップ データ接続をサポートします。

Cisco 819 ISR は、任意の Cisco 819 シリーズ ISR の補助ポートを介してリモート管理機能もサポートします。


) Cisco 819 シリーズ ISR では、コンソール ポートおよび補助ポートは、同じ物理 RJ-45 ポートにあります。そのため、これら 2 つのポートを同時にアクティブにできません。コマンドライン インターフェイス(CLI)を使用して、目的の機能をイネーブルにする必要があります。


バックアップ インターフェイスの設定

プライマリ インターフェイスがダウンしていることをルータが検出した場合、バックアップ インターフェイスはイネーブルになっています。指定された期間中にプライマリ接続が復旧した場合、バックアップ インターフェイスがディセーブルになります。

バックアップ インターフェイスがスタンバイ モードから起動した場合も、ルータはそのバックアップ インターフェイスに関する指定されたトラフィックを受信しない限り、バックアップ インターフェイスをイネーブルにしません。

表 6-1 に、各 Cisco 819 ISR で使用できるバックアップ インターフェイス、およびポート指定を示します。これらのインターフェイスの基本設定を 「WAN インターフェイスの設定」 に示します。

表 6-1 モデル番号およびデータ ライン バックアップ機能

ルータ モデル番号
3G

819

Yes

 

ルータでバックアップ インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

手順の概要

1. interface type number

2. backup interface interface-type interface-number

3. exit

手順の詳細

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface xxx 0
Router(config-if)#
 

バックアップ用に設定するインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ここで指定できるのは、シリアル インターフェイス、ISDN インターフェイス、または非同期インターフェイスです。

ステップ 2

backup interface interface-type interface-number

例:

Router(config-if)# backup interface serial 0
Router(config-if)#
 

インターフェイスをセカンダリ(バックアップ)インターフェイスに指定します。

ここで指定できるインターフェイスは、シリアル インターフェイスまたは非同期インターフェイスです。たとえば、シリアル 0 インターフェイスのバックアップとしてシリアル 1 インターフェイスを設定できます。

この例では、ATM 0 インターフェイスのバックアップ インターフェイスとしてシリアル インターフェイスを設定しています。

ステップ 3

exit

例:

Router(config-if)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了します。

セルラー ダイヤルオンデマンド ルーティング バックアップの設定

必要な場合にプライマリ接続を監視し、セルラー インターフェイスでバックアップ接続を開始する場合、ルータは次のいずれかの方法を使用できます。

バックアップ インターフェイス:スタンバイの状態のまま待機し、プライマリ インターフェイス回線プロトコルがダウンと認識されると、アップ状態になります。「バックアップ インターフェイスの設定」を参照してください。

ダイヤラ ウォッチ:ダイヤラ ウォッチは、ダイヤル バックアップをルーティング機能と統合するバックアップ機能です。「ダイヤラ ウォッチを使用した DDR バックアップの設定」を参照してください。

浮動スタティック ルート:バックアップ インターフェイスを介する経路に、プライマリ接続のアドミニストレーティブ ディスタンスよりも大きいアドミニストレーティブ ディスタンスがあり、プライマリ インターフェイスがダウンするまで、ルーティング テーブルには存在しません。プライマリ インターフェイスがダウンすると、フローティング スタティック ルートが使用されます。「浮動スタティック ルートを使用した DDR バックアップの設定」を参照してください。


) セルラー インターフェイスおよびその他の非同期シリアル インターフェイスのバックアップ インターフェイスは設定できません。


ダイヤラ ウォッチを使用した DDR バックアップの設定

ダイヤラ ウォッチを開始するには、インターフェイスを設定してダイヤルオンデマンド ルーティング(DDR)およびバックアップを実行する必要があります。ダイヤラ マップなどの、DDR 機能の従来の DDR コンフィギュレーション コマンドを使用します。バックアップ インターフェイスでダイヤラ ウォッチをイネーブルにし、ダイヤラ リストを作成するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

手順の概要

1. configure terminal

2. interface type number

3. dialer watch group group-number

4. dialer watch-list group-number ip ip-address address-mask

5. dialer-list <dialer-group> protocol <protocol name> {permit | deny | list <access list number> | access-group}

6. ip access-list <access list number> permit <ip source address>

7. interface cellular 0

8. dialer string <string>

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type number

 

Router (config)# interface 0

インターフェイスを指定します。

ステップ 3

dialer watch-group

group-number

 

Router(config-if)# dialer watch-group 2

バックアップ インターフェイスでダイヤラ ウォッチをイネーブルにします。

ステップ 4

dialer watch-list group-number ip ip-address address-mask

 

Router(config-if)# dialer watch-list 2 ip 10.4.0.254 255.255.0.0

監視されるすべての IP アドレスのリストを定義します。

ステップ 5

dialer-list <dialer-group> protocol <protocol-name> {permit | deny | list <access-list-number> | access-group}

 

Router(config)# dialer-list 2 protocol ip permit

関係するトラフィックのダイヤラ リストを作成し、プロトコル全体に対してアクセスを許可します。

ステップ 6

ip access-list <access list number> permit <ip source address>

 

Router(config)# access list 2 permit 10.4.0.0

関係するトラフィックを定義します。

IP ネットワークへのトラフィック送信を回避するには、access list permit all コマンドは使用しないでください。これによって、コールが強制的に終了される場合があります。

ステップ 7

interface cellular 0
 

Router (config)# interface cellular 0

セルラー インターフェイスを指定します。

ステップ 8

dialer string <string>

または

dialer group <dialer group number>
 

Router (config-if)# dialer string cdma *** cdma ***

 

または

Router (config-if)# dialer group 2 *** gsm ***

CDMA だけ。ダイヤラ スクリプトを指定します(chat script コマンドを使用して定義されます)。

GSM だけ。ダイヤラ リストをダイヤラ インターフェイスにマッピングします。

浮動スタティック ルートを使用した DDR バックアップの設定

フローティング スタティック デフォルト ルートをセカンダリ インターフェイスで設定するには、グローバル コンフィギュレーション モードから、次のコマンドを使用します。


) ルータで ip classless がイネーブルにされていることを確認してください。


手順の概要

1. configure terminal

2. ip route network-number network-mask {ip address | interface} [administrative distance] [name name]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

端末からグローバル コンフィギュレーション モードを開始します。

ステップ 2

ip route network-number network-mask

{ip-address | interface} [administrative distance] [name name]

 

Router (config)# ip route 0.0.0.0 Dialer 2 track 234

指定されたインターフェイスを介して、設定されているアドミニストレーティブ ディスタンスを使用して、浮動スタティック ルートを確立します。

プライマリ インターフェイスがダウンしたときだけバックアップ インターフェイスを使用するよう、バックアップ インターフェイスを通したルートのアドミニストレーティブ ディスタンスをより高く設定する必要があります。

NAT および IPsec 設定でのバックアップとしてのセル ワイヤレス モデム

次に、GSM ネットワークまたは CDMA ネットワークで NAT および IPsec を設定したバックアップとして 3G ワイヤレス モデムを設定する方法の例を示します。


) 送受信速度は設定できません。実際のスループットは、セルラー ネットワーク サービスによって異なります。


Current configuration : 3433 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
crypto isakmp key gsm address 128.107.241.234
!
!
crypto ipsec transform-set gsm ah-sha-hmac esp-3des
!
crypto map gsm1 10 ipsec-isakmp
set peer 128.107.241.234
set transform-set gsm
match address 103
!
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.4.0.254
!
ip dhcp pool gsmpool
network 10.4.0.0 255.255.0.0
dns-server 66.209.10.201 66.102.163.231
default-router 10.4.0.254
!
!
ip cef
!
no ipv6 cef
multilink bundle-name authenticated
chat-script gsm "" "atdt*98*1#" TIMEOUT 30 "CONNECT"
!
!
archive
log config
hidekeys
!
!
interface 0
no ip address
ip virtual-reassembly
load-interval 30
no ilmi-keepalive
!
interface 0.1 point-to-point
backup interface Cellular0
ip nat outside
ip virtual-reassembly
pvc 0/35
pppoe-client dial-pool-number 2
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 0
dialer string gsm
dialer-group 1
async mode interactive
no ppp lcp fast-start
ppp chap hostname chunahayev@wwan.ccs
ppp chap password 0 B7uhestacr
ppp ipcp dns request
crypto map gsm1
!
interface Vlan1
description used as default gateway address for DHCP clients
ip address 10.4.0.254 255.255.0.0
ip nat inside
ip virtual-reassembly
!
interface Dialer2
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer pool 2
dialer-group 2
ppp authentication chap callin
ppp chap password 0 cisco
ppp ipcp dns request
crypto map gsm1
!
ip local policy route-map track-primary-if
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer2 track 234
ip route 0.0.0.0 0.0.0.0 Cellular0 254
no ip http server
no ip http secure-server
!
!
ip nat inside source route-map nat2cell interface Cellular0 overload
!
ip sla 1
icmp-echo 209.131.36.158 source-interface Dialer2
timeout 1000
frequency 2
ip sla schedule 1 life forever start-time now
access-list 1 permit any
access-list 2 permit 10.4.0.0 0.0.255.255
access-list 3 permit any
access-list 101 permit ip 10.4.0.0 0.0.255.255 any
access-list 102 permit icmp any host 209.131.36.158
access-list 103 permit ip host 166.136.225.89 128.107.0.0 0.0.255.255
access-list 103 permit ip host 75.40.113.246 128.107.0.0 0.0.255.255
dialer-list 1 protocol ip list 1
dialer-list 2 protocol ip permit
!
!
!
route-map track-primary-if permit 10
match ip address 102
set interface Dialer2
!
route-map nat2cell permit 10
match ip address 101
match interface Cellular0
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line 3
exec-timeout 0 0
script dialer gsm
login
modem InOut
no exec
line vty 0 4
login
!
scheduler max-task-time 5000
 
!
webvpn cef
end
 

コンソール ポートを使用したダイヤル バックアップおよびリモート管理の設定

Cisco 819 ISR などの加入者宅内機器とインターネット サービス プロバイダー(ISP)が接続されている場合、IP アドレスは動的にルータに割り当てられます。また、中央管理機能を使用して、ルータのピアによって割り当てられることもあります。プライマリ回線に障害が発生した場合にフェールオーバー ルートを提供するため、ダイヤル バックアップ機能を追加できます。Cisco 819 ISR はダイヤル バックアップおよびリモート管理に補助ポートを使用できます。

図 6-1 は、リモート管理アクセスおよびプライマリ WAN 回線にバックアップを提供する場合に使用するネットワーク コンフィギュレーションを示しています。

図 6-1 補助ポートによるダイヤル バックアップおよびリモート管理

 

 

1

Cisco 819 ルータ

A

メイン WAN リンク。インターネット サービス プロバイダーへのプライマリ接続です。

2

モデム

B

ダイヤル バックアップ。プライマリ回線がダウンした場合に Cisco 819 ルータのフェールオーバー リンクとして機能します。

3

PC

C

リモート管理。Cisco IOS コンフィギュレーションへの変更または更新を可能にするダイヤルイン アクセスとして機能します。

これらのルータでダイヤル バックアップおよびリモート管理を設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

手順の概要

1. ip name-server server-address

2. ip dhcp pool name

3. exit

4. chat-script script-name expect-send

5. interface type number

6. exit

7. interface type number

8. dialer watch-group group-number

9. exit

10. ip nat inside source { list access-list-number }{ interface type number | pool name } [ overload ]

11. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

12. access-list access-list-number { deny | permit } source [ source-wildcard ]

13. dialerwatch-list group-number { ip ip-address address-mask | delay route-check initial seconds }

14. line [aux | console | tty | vty] line-number [ ending-line-number ]

15. modem enable

16. exit

17. line [aux | console | tty | vty] line-number [ ending-line-number ]

18. flowcontrol {none | software [lock] [in | out] | hardware [in | out]}

手順の詳細

コマンド
目的

ステップ 1

ip name-server server-address

例:

Router(config)#ip name-server 192.168.28.12
Router(config)#
 

ISP DNS IP アドレスを入力します。

ヒント 可能な場合は、複数のサーバ アドレスを追加できます。

ステップ 2

ip dhcp pool name

例:

Router(config)#ip dhcp pool 1
Router(config-dhcp)#
 

ルータ上に DHCP アドレス プールを作成します。続いて、DHCP プール コンフィギュレーション モードを開始します。 name 引数は、ストリングまたは整数にすることができます。

DHCP アドレス プールを設定します。DHCP プール コンフィギュレーション モードで使用できるサンプル コマンドについては、「例」を参照してください。

ステップ 3

exit

例:

Router(config-dhcp)#exit
Router(config)#
 

config-dhcp モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

ステップ 4

chat-script script-name expect-send

例:

Router(config)# chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102 T” TIMEOUT 45 CONNECT \c
Router(config)#
 

ダイヤルオンデマンド ルーティング(DDR)で使用するチャット スクリプトを設定し、モデムのダイヤリングおよびリモート システムへのログインを行うコマンドを使用します。定義されたスクリプトを使用して PSTN に接続されたモデムで通話します。

ステップ 5

interface type number

例:

Router(config)# interface Async 1
Router(config-if)#
 

非同期インターフェイスのコンフィギュレーション モードを作成および開始します。

非同期インターフェイスを設定します。非同期インターフェイス コンフィギュレーション モードで使用できるサンプル コマンドについては、「例」を参照してください。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

グローバル コンフィギュレーション モードを開始します。

ステップ 7

interface type number

例:

Router(config)# interface Dialer 3
Router(config-if)#
 

ダイヤラ インターフェイスのコンフィギュレーション モードを作成および開始します。

ステップ 8

dialer watch-group group-number

例:

Router(config-if)# dialer watch-group 1
Router(config-if)#
 

ウォッチ リストのグループ番号を指定します。

ステップ 9

exit

例:

Router(config-if)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了します。

ステップ 10

ip nat inside source {list access-list-number} {interface type number | pool name} [overload]

例:

Router(config)# ip nat inside source list 101 interface Dialer 3 overload
 

内部インターフェイス上のダイナミック アドレス変換をイネーブルにします。

ステップ 11

ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

例:

Router(config)# ip route 0.0.0.0 0.0.0.0 22.0.0.2
Router(config)#
 

ダイヤラ インターフェイスにポイントする IP ルートをデフォルト ゲートウェイとして設定します。

ステップ 12

access-list access-list-number {deny | permit} source [source-wildcard]

例:

Router(config)# access-list 1 permit 192.168.0.0 0.0.255.255 any
 

変換が必要なアドレスを示す拡張アクセス リストを定義します。

ステップ 13

dialerwatch-list group-number {ip ip-address address-mask | delay route-check initial seconds}

例:

Router(config)# dialer watch-list 1 ip 22.0.0.2 255.255.255.255
Router(config)#
 

ピアへのルートが存在するかどうかにより、プライマリ リンクのステータスを評価します。アドレス 22.0.0.2 は、ISP のピア IP アドレスです。

ステップ 14

line [aux | console | tty | vty] line-number [ending-line-number]

例:

Router(config)# line console 0
Router(config-line)#
 

ライン インターフェイスのコンフィギュレーション モードを開始します。

ステップ 15

modem enable

例:

Router(config-line)# modem enable
Router(config-line)#
 

ポートをコンソールから AUX ポート機能に変更します。

ステップ 16

exit

例:

Router(config-line)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了します。

ステップ 17

line [aux | console | tty | vty] line-number [ending-line-number]

例:

Router(config)# line aux 0
Router(config)#
 

補助インターフェイスのコンフィギュレーション モードを開始します。

ステップ 18

flowcontrol { none | software [ lock ] [ in | out ] | hardware [ in | out ]}

例:

Router(config)# flowcontrol hardware
Router(config)#
 

ハードウェア信号フロー制御をイネーブルにします。

次の設定例では、インターフェイスの IP アドレスを、PPP および IPCP アドレス ネゴシエーションおよびコンソール ポートを介したダイヤル バックアップによって指定します。

!
ip name-server 192.168.28.12
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool 1
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
! Need to use your own correct ISP phone number.
modemcap entry MY-USER_MODEM:MSC=&F1S0=1
chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102\T”
TIMEOUT 45 CONNECT \c
!
!
!
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
hold-queue 100 out
!
! Dial backup and remote management physical interface.
interface Async1
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 3
async default routing
async dynamic routing
async mode dedicated
ppp authentication pap callin
!
interface ATM0
mtu 1492
no ip address
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
! Primary WAN link.
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! Dialer backup logical interface.
interface Dialer3
ip address negotiated
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 3
dialer idle-timeout 60
dialer string 5555102 modem-script Dialout
dialer watch-group 1
!
! Remote management PC IP address.
peer default ip address 192.168.2.2
no cdp enable
!
! Need to use your own ISP account and password.
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! IP NAT over Dialer interface using route-map.
ip nat inside source route-map main interface Dialer1 overload
ip nat inside source route-map secondary interface Dialer3 overload
ip classless
!
! When primary link is up again, distance 50 will override 80 if dial backup
! has not timed out. Use multiple routes because peer IP addresses are alternated
! among them when the CPE is connected.
ip route 0.0.0.0 0.0.0.0 64.161.31.254 50
ip route 0.0.0.0 0.0.0.0 66.125.91.254 50
ip route 0.0.0.0 0.0.0.0 64.174.91.254 50
ip route 0.0.0.0 0.0.0.0 63.203.35.136 80
ip route 0.0.0.0 0.0.0.0 63.203.35.137 80
ip route 0.0.0.0 0.0.0.0 63.203.35.138 80
ip route 0.0.0.0 0.0.0.0 63.203.35.139 80
ip route 0.0.0.0 0.0.0.0 63.203.35.140 80
ip route 0.0.0.0 0.0.0.0 63.203.35.141 80
ip route 0.0.0.0 0.0.0.0 Dialer1 150
no ip http server
ip pim bidir-enable
!
! PC IP address behind CPE.
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 103 permit ip 192.168.0.0 0.0.255.255 any
!
! Watch multiple IP addresses because peers are alternated
! among them when the CPE is connected.
dialer watch-list 1 ip 64.161.31.254 255.255.255.255
dialer watch-list 1 ip 64.174.91.254 255.255.255.255
dialer watch-list 1 ip 64.125.91.254 255.255.255.255
!
! Dial backup will kick in if primary link is not available
! 5 minutes after CPE starts up.
dialer watch-list 1 delay route-check initial 300
dialer-list 1 protocol ip permit
!
! Direct traffic to an interface only if the dialer is assigned an IP address.
route-map main permit 10
match ip address 101
match interface Dialer1
!
route-map secondary permit 10
match ip address 103
match interface Dialer3
!
! Change console to aux function.
line con 0
exec-timedout 0 0
modem enable
stopbits 1
line aux 0
exec-timeout 0 0
! To enable and communicate with the external modem properly.
script dialer Dialout
modem InOut
modem autoconfigure discovery
transport input all
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
exec-timeout 0 0
password cisco
login
!
scheduler max-task-time 5000
end