Cisco 819 シリーズ サービス統合型ルータ ソフトウェア コンフィギュレーション ガイド
ルータの基本設定
ルータの基本設定
発行日;2013/05/19 | 英語版ドキュメント(2013/02/08 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

ルータの基本設定

インターフェイス ポート

デフォルト コンフィギュレーション

設定に必要な情報

コマンドライン アクセスの設定

グローバル パラメータの設定

WAN インターフェイスの設定

ギガビット イーサネット WAN インターフェイスの設定

セル ワイヤレス WAN インターフェイスの設定

3G ワイヤレス インターフェイスの設定に関する要件

セル ワイヤレス インターフェイスの設定に関する制約事項

データ アカウントのプロビジョニング

セルラー インターフェイスの設定

DDR の設定

セル ワイヤレス インターフェイスの設定例

デュアル SIM の設定

GPS の設定

GPS NMEA の設定

Microsoft Streets を実行する PC への Cisco 819 ISR の接続

プッシュ ボタンを使用したイメージおよび Config の復元のためのルータの設定

ボタンが押されていないときの出力:例

ボタンが押されたときの出力:例

WLAN AP のプッシュ ボタン

ファスト イーサネット LAN インターフェイスの設定

ループバック インターフェイスの設定

設定の確認

スタティック ルートの設定

設定の確認

ダイナミック ルートの設定

ルーティング情報プロトコルの設定

設定の確認

拡張インテリア ゲートウェイ ルーティング プロトコルの設定

設定の確認

ルータの基本設定

この章では、Cisco ルータで基本的なパラメータ(グローバル パラメータの設定、ルーティング プロトコル、インターフェイス、およびコマンドライン アクセスなど)を設定する手順について説明します。また、起動時のデフォルト設定についても説明します。

「インターフェイス ポート」

「デフォルト コンフィギュレーション」

「設定に必要な情報」

「コマンドライン アクセスの設定」

「グローバル パラメータの設定」

「WAN インターフェイスの設定」

「ループバック インターフェイスの設定」

「スタティック ルートの設定」

「ダイナミック ルートの設定」


) ルータの各モデルは、このマニュアルに記載されている機能の一部をサポートしていない場合があります。特定のルータでサポートされていない機能は、可能な限り明示されています。


この章では、該当するものがある場合には設定例と確認手順が記載されています。

グローバル コンフィギュレーション モードにアクセスする方法の詳細については、 「グローバル コンフィギュレーション モードの開始」 を参照してください。

インターフェイス ポート

表 5-1 は、各ルータでサポートされているインターフェイスと装置に表記されているポート ラベルを示しています。

 

表 5-1 Cisco ルータでサポートされているインターフェイスと対応するポート ラベル

ルータ
インターフェイス
ポート ラベル

Cisco 819 ルータ

4 ポート ファスト イーサネット LAN

LAN、FE0-FE3

ギガビット イーサネット WAN

GE WAN 0

シリアル

シリアル

3G ポート プロビジョニング用ミニ USB

3G RSVD

コンソール/Aux ポート

CON/AUX


) ラベルの付いた関連アンテナには、メインおよび DIV/GPS の 2 種類のラベルがあります。


デフォルト コンフィギュレーション

Cisco ルータを初めて起動すると、一部の基本的な設定はすでに行われています。LAN および WAN インターフェイスはすべて作成されており、コンソール ポートと VTY ポートの設定やネットワーク アドレス変換(NAT)用の内部インターフェイスの割り当てもすでに行われています。初期設定を表示するには、 show running-config コマンドを使用します(次の Cisco 819 ISR ルータの例を参照してください)。

Router# show running
Building configuration...
 
Current configuration : 977 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
no aaa new-model
ip source-route
ip cef
 
no ipv6 cef
license udi pid CISCO819G-G-K9 sn FHK1429768Q
controller Cellular 0
interface Cellular0
no ip address
encapsulation ppp
interface Ethernet-wan0
no ip address
shutdown
duplex auto
speed auto
interface FastEthernet0
interface FastEthernet1
interface FastEthernet2
interface FastEthernet3
interface Serial0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Vlan1
no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
 
logging esm config
 
control-plane
line con 0
no modem enable
line aux 0
line 3
no exec
line 7
stopbits 1
speed 115200
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end
 

設定に必要な情報

ネットワークを設定する前に、使用するネットワーク構成に基づいて、次の情報の一部またはすべてを収集しておく必要があります。

インターネット接続を設定する場合、次の情報を収集してください。

ユーザのログイン名として割り当てられた PPP クライアント名

PPP 認証のタイプ:チャレンジ ハンドシェイク認証プロトコル(CHAP)またはパスワード認証プロトコル(PAP)

インターネット サービス プロバイダー(ISP)アカウントにアクセスするための PPP パスワード

DNS サーバの IP アドレスおよびデフォルト ゲートウェイ

企業ネットワークへの接続を設定する場合は、ユーザとネットワーク管理者の間で、ルータの WAN インターフェイスに関する次の情報について打ち合わせておく必要があります。

PPP 認証のタイプ:CHAP または PAP

ルータにアクセスするための PPP クライアント名

ルータにアクセスするための PPP パスワード

IP ルーティングを設定する場合、次の準備が必要です。

IP ネットワークのアドレス指定方式を作成します。

シリアル インターフェイスを設定している場合:

動作のモード(sync、async、bisync)

モードによるクロック レート

モードによる IP アドレス

3G を設定している場合:

Cisco 819 ISR で通信事業者からのサービスを使用可能でなければなりません。また、ルータが物理的に置かれているネットワーク カバレッジも必要です。サポートされている通信事業者の一覧については、「Cisco 3G Wireless Connectivity Solutions」のデータ シートを参照してください。

ワイヤレス サービス プロバイダーのサービス プランに登録し、SIM カードを取得する必要があります。

SIM カードを取り付けてから 3G Cisco 819 ISR を設定する必要があります。SIM カードの取り付け方法については、「Cisco 800 Series RoutersConfiguring Cisco EHWIC and 880G for 3.7G (HSPA+)/3.5G (HSPA)」を参照してください。

Cisco 819 ISR の 3G を設定する前に必要なアンテナを取り付ける必要があります。アンテナの取り付け方法の説明については、次の URL を参照してください。

3G-ANTM1919D:「Cisco Multiband Swivel-Mount Dipole Antenna (3G-ANTM1919D)」を参照。

3G-ANTM1916-CM:「 Cisco Multiband Omnidirectional Ceiling Mount Antenna (3G-ANTM1916-CM) 」を参照。

3G-AE015-R(アンテナの拡張):「Cisco Single-Port Antenna Stand for Multiband TNC Male-Terminated Portable Antenna (Cisco 3G-AE015-R)」を参照。

3G-AE010-R(アンテナの拡張):「Cisco Single-Port Antenna Stand for Multiband TNC Male-Terminated Portable Antenna (Cisco 3G-AE015-R) 」を参照。このマニュアルは、3G-AE015-R と 3G-AE010-R に該当します。製品の違いはケーブルの長さのみです。

3G-ANTM-OUT-OM:「Cisco 3G Omnidirectional Outdoor Antenna (3G-ANTM-OUT-OM)」を参照。

3G-ANTM-OUT-LP:「Cisco Multiband Omnidirectional Panel-Mount Antenna (3G-ANTM-OUT-LP)」を参照。

3G-ACC-OUT-LA:「 Cisco 3G Lightning Arrestor (3G-ACC-OUT-LA) 」を参照。

4G-ANTM-OM-CM:「Cisco 4G Indoor Ceiling-Mount Omnidirectional Antenna (4G-ANTM-OM-CM)」を参照。

表 2-1 に説明したように、信号の受信状況について LED を確認する必要があります。

Cisco IOS ソフトウェアに精通している必要があります。Cisco 3G のサポートについては、リリース 12.4(15)T またはそれ以降の Cisco IOS マニュアルを参照してください。

3G データ プロファイルを設定するには、サービス プロバイダーからユーザ名、パスワード、およびアクセス ポイント名(APN)を取得する必要があります。

該当する情報の収集が済んだら、ルータの設定を行うことができます。「コマンドライン アクセスの設定」から設定を始めてください。

ソフトウェア ライセンスを取得または変更する場合:

Software Activation on Cisco Integrated Services Routers and Cisco Integrated Service Routers G2 』を参照してください。

コマンドライン アクセスの設定

ルータへのアクセスを制御するパラメータを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. line [aux | console | tty | vty] line-number

2. password password

3. login

4. exec-timeout minutes [ seconds ]

5. line [aux | console | tty | vty] line-number

6. password password

7. login

8. end

手順の詳細

コマンド
目的

ステップ 1

line [ aux | console | tty | vty ] line-number

例:

Router(config)# line console 0
Router(config-line)#
 

ライン コンフィギュレーション モードを開始します。続いて、回線のタイプを指定します。

この例では、アクセス用にコンソール端末を指定します。

ステップ 2

password password

例:

Router(config)# password 5dr4Hepw3
Router(config-line)#
 

コンソール端末回線に固有のパスワードを指定します。

ステップ 3

login

例:

Router(config-line)# login
Router(config-line)#
 

端末セッション ログイン時のパスワード チェックをイネーブルにします。

ステップ 4

exec-timeout minutes [seconds]

例:

Router(config-line)# exec-timeout 5 30
Router(config-line)#
 

ユーザ入力が検出されるまで EXEC コマンド インタープリタが待機する間隔を設定します。デフォルトは 10 分です。任意で、間隔値に秒数を追加します。

この例では、5 分 30 秒のタイムアウトを表示します。「0 0」のタイムアウトを入力すると、タイムアウトが発生しません。

ステップ 5

line [ aux | console | tty | vty ] line-number

例:

Router(config-line)# line vty 0 4
Router(config-line)#
 

リモート コンソール アクセス用の仮想端末を指定します。

ステップ 6

password password

例:

Router(config-line)# password aldf2ad1
Router(config-line)#
 

仮想端末回線に固有のパスワードを指定します。

ステップ 7

login

例:

Router(config-line)# login
Router(config-line)#
 

仮想端末セッション ログイン時のパスワード チェックをイネーブルにします。

ステップ 8

end

例:

Router(config-line)# end
Router#
 

回線コンフィギュレーション モードを終了します。続いて、特権 EXEC モードに戻ります。

次の設定は、コマンドライン アクセス コマンドを示します。

「default」と記されているコマンドは入力不要です。これらのコマンドは、 show running-config コマンドを使用すると生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
 

グローバル パラメータの設定

ルータに選択したグローバル パラメータを設定するには、次の作業を行います。

手順の概要

1. configure terminal

2. hostname name

3. enable secret password

4. no ip domain-lookup

手順の詳細

コマンド
目的

ステップ 1

configure terminal

例:

Router> enable

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。

リモート端末を使用してルータに接続している場合は、次のコマンドを使用します。

telnet router name or address

Login: login id

Password: *********

Router> enable

ステップ 2

hostname name

例:

Router(config)# hostname Router

Router(config)#

ルータ名を指定します。

ステップ 3

enable secret password

例:

Router(config)# enable secret cr1ny5ho

Router(config)#

ルータへの不正なアクセスを防止するには、暗号化パスワードを指定します。

ステップ 4

no ip domain-lookup

例:

Router(config)# no ip domain-lookup Router(config)#

ルータが未知の単語(入力ミス)を IP アドレスに変換しないようにします。

WAN インターフェイスの設定

必要に応じて、次のいずれかの手順を行い、ルータの WAN インターフェイスを設定します。

「ギガビット イーサネット WAN インターフェイスの設定」

「セル ワイヤレス WAN インターフェイスの設定」

「デュアル SIM の設定」

「GPS の設定」

「プッシュ ボタンを使用したイメージおよび Config の復元のためのルータの設定」

ギガビット イーサネット WAN インターフェイスの設定

Cisco 819 ISR でイーサネット インターフェイスを設定するには、グローバル コンフィギュレーション モードから次の手順を実行します。

手順の概要

1. interface type number

2. ip address ip-address mask

3. no shutdown

4. exit

手順の詳細

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface gigabitethernet 0
Router(config-if)#
 

ルータのギガビット イーサネット WAN インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 192.168.12.2 255.255.255.0
Router(config-if)#
 

指定したギガビット イーサネット インターフェイスの IP アドレスとサブネット マスクを設定します。

ステップ 3

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

イーサネット インターフェイスをイネーブルにして、インターフェイスの状態を管理上のダウンからアップに変更します。

ステップ 4

exit

例:

Router(config-if)# exit
Router(config)#
 

ギガビット イーサネット インターフェイスのコンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードに戻ります。

セル ワイヤレス WAN インターフェイスの設定

Cisco 819 ISR は、Global System for Mobile Communications(GSM)および符号分割多重接続(CDMA)ネットワークを介して使用する、第 3 世代(3G)ワイヤレス インターフェイスを提供します。インターフェイスは 34 mm の埋め込みミニ エクスプレス カードです。

その主な用途は、重要なデータ アプリケーションのバックアップ データ リンクとしての WAN 接続です。ただし、3G ワイヤレス インターフェイスは、ルータのプライマリ WAN 接続としても機能できます。

3G セル ワイヤレス インターフェイスを設定するには、次の注意事項および手順に従ってください。

「3G ワイヤレス インターフェイスの設定に関する要件」

「セル ワイヤレス インターフェイスの設定に関する制約事項」

「データ アカウントのプロビジョニング」

「セルラー インターフェイスの設定」

「DDR の設定」

「セル ワイヤレス インターフェイスの設定例」

「デュアル SIM の設定」

「GPS の設定」

3G ワイヤレス インターフェイスの設定に関する要件

次に、3G ワイヤレス インターフェイスの設定に関する要件を示します。

通信事業者のワイヤレス サービスが必要です。また、ルータが物理的に配置されるネットワーク カバレッジも必要です。サポートされている通信事業者の一覧については、次の URL のデータ シートを参照してください。

www.cisco.com/go/m2m

ワイヤレス サービス プロバイダーとのサービス プランに契約し、そのサービス プロバイダーから SIM カード(GSM モデムだけ)を取得する必要があります。

表 2-1 の説明に従い、信号強度について LED をチェックする必要があります。

Cisco IOS ソフトウェアに精通している必要があります。Cisco 3G ワイヤレス サポートについては、Cisco IOS Release 12.4(15)XZ またはそれ以降の Cisco IOS マニュアルを参照してください。

GSM データ プロファイルを設定するには、サービス プロバイダーから次の情報を取得する必要があります。

ユーザ名

パスワード

アクセス ポイント名(APN)

手動でアクティブにするために CDMA(CDMA のみ)データ プロファイルを設定するには、サービス プロバイダーから次の情報を取得する必要があります。

Master Subsidy Lock(MSL)番号

Mobile Directory Number(MDN)

Mobile Station Identifier(MSID)

Electronic Serial Number (ESN)

ルータの前面パネルにある LED で信号強度などの表示を確認します。 表 2-1 では、Cisco 819 ISR の 3G LED について説明します。

 

セル ワイヤレス インターフェイスの設定に関する制約事項

Cisco 3G ワイヤレス インターフェイスの設定には、次の制約事項があります。

データ接続は、3G ワイヤレス インターフェイスだけから行うことができます。リモート ダイヤルインはサポートされていません。

ワイヤレス通信共通の性質により、スループットは、ネットワークでのアクティブ ユーザの数や輻輳の量により異なります。

セル ネットワークの遅延は、優先ネットワークの場合よりも大きくなります。遅延レートは、テクノロジーおよび通信事業者に左右されます。ネットワーク輻輳が発生している場合、遅延が大きくなることがあります。

VoIP は現在サポートされていません。

通信事業者のサービス条件に含まれるいずれの制約事項も Cisco 3G ワイヤレス インターフェイスに適用されます。

取り外されたモデムとは別のタイプのモデムを取り付けた場合は、設定を変更して、システムをリロードしなければなりません。

データ アカウントのプロビジョニング


) モデムをプロビジョニングするには、サービス プロバイダーとのアクティブ ワイヤレス アカウントが必要です。SIM カードを GSM 3G ワイヤレス カードに挿入する必要があります。


データ アカウントをプロビジョニングするには、次の手順を実行します。

「信号の強さとサービスの可用性」

「GSM モデル データ プロファイルの設定」

「CDMA モデム アクティベーションおよびプロビジョニング」

信号の強さとサービスの可用性

モデムの信号の強さとサービスの可用性を確認するには、特権 EXEC モードで次のコマンドを使用します。

手順の概要

1. show cellular 0 network

2. show cellular 0 hardware

3. show cellular 0 connection

4. show cellular 0 gps

5. show cellular 0 radio

6. show cellular 0 profile

7. show cellular 0 security

8. show cellular 0 sms

9. show cellular 0 all

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

show cellular 0 network
 

Router# show cellular 0 network

通信事業者ネットワーク、セル サイト、および使用可能なサービスに関する情報を表示します。

ステップ 2

show cellular 0 hardware
 
Router# show cellular 0 hardware

セルラー モデム ハードウェア情報を表示します。

ステップ 3

show cellular 0 connection
 
Router# show cellular 0 connection

現在アクティブな接続状態およびデータの統計情報を表示します。

ステップ 4

show cellular 0 gps
 
Router# show cellular 0 gps

セルラー gps 情報を表示します。

ステップ 5

show cellular 0 radio
 

Router# show cellular 0 radio

無線信号の強さを示します。

(注) 安定した信頼性の高い接続には、RSSI が -90 dBm を超える必要があります。

ステップ 6

show cellular 0 profile
 

Router# show cellular 0 profile

作成されたモデム データ プロファイルに関する情報を示します。

ステップ 7

show cellular 0 security
 

Router# show cellular 0 security

SIM およびモデムのロック ステータスに関するセキュリティ情報を示します。

ステップ 8

show cellular 0 sms
 
Router# show cellular 0 sms

セルラー sms 情報を表示します。

ステップ 9

show cellular 0 all
 

Router# show cellular 0 all

モデムに関する統合的な情報、たとえば、作成されたプロファイル、無線信号強度、ネットワーク セキュリティなどの情報を表示します。

GSM モデル データ プロファイルの設定

新たなモデム データ プロファイルを設定または作成するには、特権 EXEC モードで次のコマンドを入力します。

手順の概要

1. cellular 0 gsm profile create <profile number> <apn> <authentication> <username> <password> ipv4

手順の詳細

コマンドまたはアクション
目的

ステップ 1

cellular 0 gsm profile create <profile number> <apn> <authentication> <username> <password> ipv4
 

Router# gsm profile create 2 <apn-name> chap username password ipv4

新しいモデム データ プロファイルを作成します。コマンド パラメータの詳細については、 表 5-2 を参照してください。

 

表 5-2 は、モデム データ プロファイルのパラメータのリストです。

 

表 5-2 モデム データ プロファイル パラメータ

profile number

作成するプロファイルの番号。最大 16 個のプロファイルを作成できます。

apn

アクセス ポイント名。この情報はサービス プロバイダーから取得する必要があります。

authentication

CHAP、PAP などの認証タイプ。

Username

サービス プロバイダーから提供されるユーザ名。

Password

サービス プロバイダーから提供されるパスワード。

CDMA モデム アクティベーションおよびプロビジョニング

アクティベーション手順は、通信事業者により異なります。通信事業者に問い合わせて、次のいずれかの手順を実行してください。

手動アクティベーション

地上波サービス プロビジョニングを使用したアクティベーション

次の表は、さまざまなワイヤレス通信事業者によりサポートされているアクティベーションおよびプロビジョニング プロセスのリストを示します。

 

表 5-3

アクティベーションおよびプロビジョニング プロセス
通信事業者

MDN、MSID、MSL を使用した手動によるアクティベーション

Sprint

OTASP1 アクティベーション

Verizon Wireless

データ プロファイル リフレッシュ用 IOTA2

Sprint

1.OTASP = Over the Air Service Provisioning(電波によるサービス提供)

2.IOTA = Internet Over the Air(インターネット地上波)

手動によるアクティベーション


) この手順を開始する前に、有効な Mobile Directory Numner(MDN)、Mobile Subsidy Lock(MSL)、および Mobile Station Identifier(MSID)情報を通信事業者から取得しておく必要があります。


モデム プロファイルを手動で設定するには、EXEC モードから、次のコマンドを使用します。

cellular unit cdma activate manual mdn msid msl

アクティブ化される前に、モデム データ プロファイルのプロビジョニングが、無線インターネット(IOTA)プロセスを介して行われます。IOTA プロセスは、 cellular unit cdma activate manual mdn msid msl コマンドを使用すると自動的に開始されます。

次に、このコマンドの出力例を示します。

router# cellular 0 cdma activate manual 1234567890 1234567890 12345
NAM 0 will be configured and will become Active
Modem will be activated with following Parameters
MDN :1234567890; MSID :1234567890; SID :1234; NID 12:
Checking Current Activation Status
Modem activation status: Not Activated
Begin Activation
Account activation - Step 1 of 5
Account activation - Step 2 of 5
Account activation - Step 3 of 5
Account activation - Step 4 of 5
Account activation - Step 5 of 5
Secure Commit Result: Succeed
Done Configuring - Resetting the modem
The activation of the account is Complete
Waiting for modem to be ready to start IOTA
Beginning IOTA
router#
*Feb 6 23:29:08.459: IOTA Status Message Received. Event: IOTA Start, Result: SUCCESS
*Feb 6 23:29:08.459: Please wait till IOTA END message is received
*Feb 6 23:29:08.459: It can take up to 5 minutes
*Feb 6 23:29:27.951: OTA State = SPL unlock, Result = Success
*Feb 6 23:29:32.319: OTA State = Parameters committed to NVRAM, Result = Success
*Feb 6 23:29:40.999: Over the air provisioning complete; Result:Success
*Feb 6 23:29:41.679: IOTA Status Message Received. Event: IOTA End, Result: SUCCESS

 

IOTA Start および IOTA End には、結果の出力として「SUCCESS」と示されていなければなりません。エラー メッセージが表示された場合、cellular cdma activate iota コマンドを使用して個別に IOTA を実行できます。

通信事業者により、データ プロファイルの定期的なリフレッシュが要求されることがあります。データ プロファイルをリフレッシュするには、次のコマンドを使用します。

cellular cdma activate iota

Over-the-Air Service Provisioning を使用したアクティベーション

電波によるサービス提供(OTASP)のプロビジョニングおよびアクティベーションを行うには、EXEC モードから次のコマンドを使用します。

router # cellular 0 cdma activate otasp phone_number


) このコマンドで使用する電話番号は、通信事業者から取得する必要があります。標準の OTASP 発番号は *22899 です。


次に、このコマンドの出力例を示します。

router# cellular 0 cdma activate otasp *22899
Beginning OTASP activation
OTASP number is *22899
819H#
OTA State = SPL unlock, Result = Success
router#
OTA State = PRL downloaded, Result = Success
OTA State = Profile downloaded, Result = Success
OTA State = MDN downloaded, Result = Success
OTA State = Parameters committed to NVRAM, Result = Success
Over the air provisioning complete; Result:Success

セルラー インターフェイスの設定

セル インターフェイスを設定するには、特権 EXEC モードから、次のコマンドを入力します。

手順の概要

1. configure terminal

2. interface cellular 0

3. encapsulation ppp

4. ppp chap hostname hostname

5. ppp chap password 0 password

6. asynchronous mode interactiv e

7. ip address negotiated


) この手順で使用する PPP チャレンジ ハンドシェイク認証プロトコル(CHAP)認証パラメータは、通信事業者により提供され、GSM プロファイル下だけで設定されているユーザ名およびパスワードと同じでなければなりません。CDMA では、ユーザ名またはパスワードは必要ありません。


手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal
 

Router# configure terminal

端末からグローバル コンフィギュレーション モードを開始します。

ステップ 2

interface cellular 0
 

Router (config)# interface cellular 0

セルラー インターフェイスを指定します。

ステップ 3

encapsulation ppp
 

Router (config-if)# encapsulation ppp

専用非同期モード用またはダイヤルオンデマンド ルーティング(DDR)用のインターフェイスの PPP カプセル化を指定します。

ステップ 4

ppp chap hostname hostname
 

Router (config-if)# ppp chap hostname cisco@wwan.ccs

インターフェイス固有のチャレンジ ハンドシェイク認証プロトコル(CHAP)ホスト名を定義します。これは、通信事業者から提供されたユーザ名に一致する必要があります。GSM だけに適用されます。

ステップ 5

ppp chap password 0 password
 

Router (config-if)# ppp chap password 0 cisco

インターフェイス固有の CHAP パスワードを指定します。これは、通信事業者から提供されたパスワードに一致する必要があります。

ステップ 6

asynchronous mode interactive
 

Router (config-if)# asynchronous mode interactive

ラインを専用非同期ネットワーク モードから対話モードに戻して、特権 EXEC モードで、slip および ppp コマンドをイネーブルにします。

ステップ 7

ip address negotiated
 

Router (config-if)# ip address negotiated

特定のインターフェイスの IP アドレスが PPP および IPCP アドレス ネゴシエーションを介して取得されることを指定します。


セル インターフェイスでスタティック IP アドレスが必要な場合、アドレスは、ip address negotiated として設定できます。インターネット プロトコル制御プロトコル(IPCP)を介して、ネットワークにより、正しいスタティック IP アドレスがデバイスに割り当てられるようになります。トンネル インターフェイスが ip address unnumbered <cellular interface> コマンドで設定されている場合、実際のスタティック IP アドレスは ip address negotiated でなく、セルラー インターフェイス下で設定されなければなりません。セルラー インターフェイスの例については、「基本セルラー インターフェイスの設定」を参照してください。


DDR の設定

セルラー インターフェイスのダイヤル オン デマンド ルーティング(DDR)を設定するには、次の手順を実行します。

手順の概要

1. configure terminal

2. interface cellular 0

3. dialer in-band

4. dialer idle-timeout seconds

5. dialer string string

6. dialer group number

7. exit

8. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

9. ip access-list < access list number> permit < ip source address >

10. line 3

11. script dialer <regexp>

12. exit

13. chat-script <script name> "" "ATDT*99*<profile number>#" TIMEOUT <timeout value> CONNECT
または
chat-script <script name> "" "ATDT*777*<profile number>#" TIMEOUT <timeout value> CONNECT

14. interface cellular 0

15. dialer string < string>

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface cellular 0

 

Router (config)# interface cellular 0

セルラー インターフェイスを指定します。

ステップ 3

dialer in-band

 

Router (config-if)# dialer in-band

DDR をイネーブルにし、インバンド ダイヤリングに指定されたシリアル インターフェイスを設定します。

ステップ 4

dialer idle-timeout seconds

 

Router (config-if)# dialer idle-timeout 30

回線切断後のアイドル時間を秒単位で指定します。

ステップ 5

dialer string string

 

Router (config-if)# dialer string gsm

ダイヤルする番号または文字列を指定します。チャット スクリプトの名前をここで使用します。

ステップ 6

dialer-group number

 

Router (config-if)# dialer-group 1

特定のインターフェイスが属するダイヤラ アクセス グループの番号を指定します。

ステップ 7

exit

 

Router (config-if)# exit

グローバル コンフィギュレーション モードを開始します。

ステップ 8

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

 

Router (config)# dialer-list 1 protocol ip list 1

関係するトラフィックのダイヤラ リストを作成し、プロトコル全体に対してアクセスを許可します。

ステップ 9

ip access-list <access list number> permit <ip source address>

 

Router (config)# ip access list 1 permit any

関係するトラフィックを定義します。

ステップ 10

line 3

 

Router (config-line)# line 3

ライン コンフィギュレーション モードを指定します。これは常に 3 です。

ステップ 11

script dialer <regexp>

 

Router (config-line)# script-dialer gsm

デフォルト モデムのチャット スクリプトを指定します。

ステップ 12

exit

 

Router (config-line)# exit

ライン コンフィギュレーション モードを終了します。

ステップ 13

GSM の場合

chat-script <script name> ”” “ATDT*99*<profile number>#” TIMEOUT <timeout value> CONNECT

 

CDMA の場合

chat-script <script name> "" "ATDT*777*<profile number>#" TIMEOUT <timeout value> CONNECT

 

Router (config)# chat-script gsm "" "ATDT*98*2#" TIMEOUT 60 "CONNECT“

GSM 用にこのラインを設定します。

CDMA 用にこのラインを設定します。

ダイヤラが開始されるときの Attention Dial Tone(ATDT)コマンドを定義します。

ステップ 14

interface cellular 0

 

Router (config)# interface cellular 0

セルラー インターフェイスを指定します。

ステップ 15

dialer string string

 

Router (config)# dialer string gsm

ダイヤラ スクリプトを指定します(chat script コマンドを使用して定義されます)。

セル ワイヤレス インターフェイスの設定例

ここでは、次の設定例について説明します。

「基本セルラー インターフェイスの設定」

「セルラー インターフェイスを介するトンネルの設定」

「8705 モデムの設定」

基本セルラー インターフェイスの設定

次に、プライマリ WAN 接続として使用される gsm セル インターフェイスを設定する例を示します。これは、デフォルト ルートとして設定されます。

chat-script gsm "" "ATDT*98*2#" TIMEOUT 60 "CONNECT“
 
!
interface Cellular0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string gsm
dialer-group 1
async mode interactive
ppp chap hostname cisco@wwan.ccs
ppp chap password 0 cisco
ppp ipcp dns request
!
 
ip route 0.0.0.0 0.0.0.0 Cellular0
!
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 3
exec-timeout 0 0
script dialer gsm
login
modem InOut
 

次に、プライマリ WAN 接続として使用される cdma セルラー インターフェイスを設定する例を示します。これは、デフォルト ルートとして設定されます。

chat-script cdma "" "ATDT#777" TIMEOUT 60 "CONNECT“
 
!
interface Cellular0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string cdma
dialer-group 1
async mode interactive
ppp chap password 0 cisco
!
 
ip route 0.0.0.0 0.0.0.0 Cellular0
!
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 3
exec-timeout 0 0
script dialer cdma
login
modem InOut

セルラー インターフェイスを介するトンネルの設定

次に、トンネル インターフェイスが ip address unnumbered < cellular interface > コマンドで設定される場合のスタティック IP アドレスを設定する例を示します。

interface Tunnel2
ip unnumbered Cellular0
tunnel source Cellular0
tunnel destination 128.107.248.254
 
interface Cellular0
bandwidth receive 1400000
ip address 23.23.0.1 255.255.0.0
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 0
dialer string dial<carrier>
dialer-group 1
async mode interactive
no ppp lcp fast-start
ppp chap hostname <hostname> *** gsm only ***
ppp chap password 0 <password>
ppp ipcp dns request
 
! traffic of interest through the tunnel/cellular interface
ip route 10.10.0.0 255.255.0.0 Tunnel2

8705 モデムの設定

次に、HSPA+ のモデムを設定する例を示します。

chat-script hspa "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
 
interface Cellular0
ip address negotiated
encapsulation slip
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive
 
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer pool 1
dialer string hspa
dialer-group 1
 
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
access-list 1 permit any
dialer-list 1 protocol ip permit
line 3
script dialer hspa+
modem InOut
no exec
transport input all

デュアル SIM の設定

デュアル SIM 機能は、Cisco 819 ISR で 2 つのセルラー ネットワーク間の自動スイッチおよびフェールオーバーを実装します。この機能は、プライマリ スロットである SIM スロット 0 とセカンダリ(フェールオーバー)スロットであるスロット 1 を使用して、デフォルトでイネーブルになっています。

次のコマンドを使用して、デュアル SIM 機能を設定できます。

コマンド
構文
説明

gsm failovertimer

gsm failovertimer <1-7>

フェールオーバー タイマーを分単位で設定します。

gsm sim authenticate

gsm sim authenticate <0,7> <pin> slot <0-1>

SIM CHV1 コードを確認します。

gsm sim max-retry

gsm sim max-retry <0-65535>

フェールオーバー リトライの最大回数を指定します。デフォルト値は、10 です。

gsm sim primary slot

gsm sim primary slot <0-1>

プライマリ スロットの割り当てを変更します。

gsm sim profile

gsm sim profile <1-16> slot <0-1>

SIM プロファイルを設定します。

次の点に注意してください。

自動スイッチおよびフェールオーバーを機能させるには、 gsm sim profile コマンドを使用してスロット 0 および 1 の SIM プロファイルを設定します。

動作スイッチおよびフェールオーバーを機能させるには、特定のプロファイル番号なしのチャット スクリプトを設定します。

SIM プロファイルが設定されていない場合、プロファイル #1 がデフォルトで使用されます。

GSM フェールオーバー タイマーが設定されていない場合、デフォルトのフェールオーバーのタイムアウトは 2 分です。

GSM SIM プライマリ スロットが設定されていない場合、デフォルトのプライマリ SIM はスロット 0 です。

次に、SIM スイッチオーバーのタイムアウト時間を 3 分に設定する例を示します。

router# conf t
router(config-controller)# gsm failovertimer 3

 

次に、暗号化されていないピンを使用して認証する例を示します。

router(config-controller)# gsm sim authenticate 0 1234 slot 0

次に、SIM スイッチオーバーのリトライ最大回数を 20 に設定する例を示します。

router(config-controller)# gsm sim max-retry 20

次に、プライマリ スロットとして SIM スロット 1 を設定する例を示します。

router(config-controller)# gsm sim primary slot 1

 

次に、プロファイル 10 を使用するように、スロット 0 の SIM カードを設定する例を示します。

router(config-controller)# gsm sim profile 10 slot 0

 

手動で SIM を切り替えるには、次のコマンドを実行します。

コマンド
構文
説明

cellular GSM SIM

cellular GSM SIM {lock | unlock}

SIM をロックまたはロック解除します。

gsm sim

cellular <unit> gsm sim [lock | unlock] <pin>

gsm SIM をロックまたはロック解除します。

gsm sim unblock

cellular <unit> gsm sim unblock <puk> <newpin>

gsm SIM のブロックを解除します。

gsm sim change-pin

cellular <unit> gsm sim change-pin <oldpin> <newpin>

SIM の PIN を変更します。

gsm sim activate slot

cellular <unit> gsm sim activate slot <slot_no>

GSM SIM をアクティブにします。

次のコマンドは、強制的にモデムを SIM1 に接続します。

Router# cellular 0 gsm sim activate slot 1

GPS の設定

次のコマンドを使用して、GPS 機能を設定できます。

コマンド
構文
説明

gsm gps mode

gsm gps mode standalone

GPS スタンドアロン モードをイネーブルにします。

gsm gps nmea

gsm gps nmea [ip | serial]

NMEA モードをイネーブルにします。

ip:IP インターフェイスを介する NMEA。

serial :シリアル インターフェイスを介する NMEA。

show cellular gps

show cellular unit gps

GPS データの要約を表示します。

show cellular unit gps detail

GPS データの詳細なリストを表示します。

次に、Cisco 819 ISR の概要と詳細な GPS データを表示する例を示します。出力には次の情報が含まれています。

GPS の状態とモード情報

GPS のトラッキング状態

NMEA のストリーム状態

GPS の位置およびタイムスタンプ情報

GPS 衛星情報

router# show cellular 0 gps
GPS Info
-------------
GPS State: GPS enabled
GPS Mode Configured: standalone
Latitude: 37 Deg 24 Min 59 Sec North
Longitude: 121 Deg 55 Min 8 Sec West
Timestamp (GMT): Thu Jul 29 11:08:39 2010
Fix type: 3D, Height: -6 m
Heading: 408, Velocity Horiz: 3, Velocity Vert: 0
Satellite Info
----------------
Satellite #13, elevation 75, azimuth 46, SNR 21
...
 
router# show cellular 0 gps detail
GPS Info
-------------
GPS State: GPS enabled
GPS Mode Configured: standalone
Latitude: 37 Deg 24 Min 59 Sec North
Longitude: 121 Deg 55 Min 7 Sec West
Timestamp (GMT): Thu Jul 29 22:17:57 2010
Fix type: 3D, Height: 12 m
Heading: 0, Velocity Horiz: 0, Velocity Vert: 0
HEPE: 2680 cm
Uncertainty Info:
Angle: 0 deg, A: 24 m, Position: 12 m, Vertical: 12 m
Satellite Info
----------------
Satellite #7, elevation 16, azimuth 123, SNR 14 *
...

GPS NMEA の設定

外部 NMEA 2.0 準拠 GPS プロッター アプリケーションへの GPS NMEA ストリーミングは、Cisco 819 ISR でサポートされています。

NMEA データ ストリーミングをイネーブルにするには、次のコマンドを実行します。

手順の概要

1. conf t

2. controller cellular 0

3. gsm gps mode standalone

4. gsm gps nmea [ip | serial]

5. end

6. show running

7. show line

8. telnet ip address port

手順の詳細

コマンド
説明

ステップ 1

conf t

例:

Router# conf t

コンフィギュレーション モードに入ります。

ステップ 2

controller cellular 0

例:

router(config)# controller cellular 0

コントローラ セルラー コンフィギュレーション モードを開始します。

ステップ 3

gsm gps mode standalone

例:

Router(config-controller)# gsm gps mode standalone

独立型 GPS をイネーブルにします。

ステップ 4

gsm gps nmea [ ip | serial]

例:

Router(config-controller)# gsm gps nmea ip

IP インターフェイスを介する NMEA をイネーブルにします。

ip :IP インターフェイスを介する NMEA。

serial :シリアル インターフェイスを介する NMEA。

ステップ 5

end

例:

Router(config-controller)# end

コントローラ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 6

show running

例:

Router# show running

<snip>

controller Cellular 0

gsm gps mode standalone

gsm gps nmea ip

設定の出力を表示します。

ステップ 7

show line

例:

Router# show line

Tty Typc Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

*0 CTY - - - - - 1 56 0/207449798 -

1 AUX 0/0 - - - - - 0 0 0/0 -

3 TTY - inout - - - 0 0 0/0 Ce0

6 TTY - inout - - - 1 1233437 0/0 NMEA5

7 TTY 9600/9600 - - - 0 0 0/0 Se0

10 VTY - - - - - 0 0 0/0 -

11 VTY - - - - - 0 0 0/0 -

12 VTY - - - - - 0 0 0/0 -

13 VTY - - - - - 0 0 0/0 -

14 VTY - - - - - 0 0 0/0 -

 

非同期ポート番号を表示します。

NMEA が設定されている場合、IOS は NMEA 非同期ポートを作成します。ポート番号はプラットフォームに依存します。この例では、非同期ポート番号はライン 6 です。


) ライン 2、4、5、8、9 は非同期モードではないか、ハードウェアが対応していません。


ステップ 8

telnet ip address port

例:

Router# telnet 1.1.1.1 2006

Trying 1.1.1.1, 2006 ... Open

$GPGSV,4,1,16,27,,,,09,,,,15,,,,26,,,*77

$GPGSV,4,2,16,17,,,,32,,,,28,,,,19,,,*7D

$GPGSV,4,3,16,11,,,,08,,,,03,,,,01,,,*73

$GPGSV,4,4,16,07,,,,06,,,,22,,,,16,,,*78

$GPGGA,230924.6,,,,,0,,,,,,,,*70

$GPVTG,,T,,M,,N,,K,N*2C

$GPRMC,,V,,,,,,,,,,N*53

$GPGSA,A,1,,,,,,,,,,,,,,,*1E

$GPGSV,4,1,16,27,,,,09,,,,15,,,,26,,,*77

$GPGSV,4,2,16,17,,,,32,,,,28,,,,19,,,*7D

$GPGSV,4,3,16,11,,,,08,,,,03,,,,01,,,*73

$GPGSV,4,4,16,07,,,,06,,,,22,,,,16,,,*78

$GPGGA,230925.6,,,,,0,,,,,,,,*71

$GPVTG,,T,,M,,N,,K,N*2C

$GPRMC,,V,,,,,,,,,,N*53

$GPGSA,A,1,,,,,,,,,,,,,,,*1E

NMEA ストリーミングがイネーブルの場合、モデムは、GPS の変更が取得されるかにかかわらず、NMEA ポート上の NMEA データのストリームを開始します。NMEA ポートにリバース Telnet を実行して、NMEA データをチェックできます。

Cisco 819 ISR の 3G 機能の設定については、次のマニュアルを参照してください。

「Configuring EHWIC-3G-EVDO-x Cards and C881G-x-K9 ISRs」

「Configuring Cisco EHWIC-3G-HSPA-U and C881G-U-K9」

Microsoft Streets を実行する PC への Cisco 819 ISR の接続

GPS アプリケーションをホストするリモート サーバに NMEA データをフィードできます。サーバは、イーサネット ケーブルを使用して、または LAN あるいは WAN ネットワーク経由でルータに直接接続できます。アプリケーションでシリアル ポートをサポートしている場合、シリアル ポート エミュレーション プログラムを実行して、LAN または WAN 接続で仮想シリアル ポートを作成する必要があります。


) Microsoft Streets は、Microsoft の Web サイトからダウンロード可能なライセンス ソフトウェアです。


Microsoft Streets を実行する PC に Cisco 819 ISR を接続するには、次の手順を実行します。


ステップ 1 イーサネット ケーブルで PC とルータをつなげます。

ステップ 2 PC とルータで ping を実行できることを確認します。

ステップ 3 PC のシリアル ポート リダイレクタを起動します。

ステップ 4 ルータの NMEA ポートに接続する仮想シリアル ポートを作成します。

ステップ 5 PC で Microsoft Streets を起動します。

ステップ 6 [GPS Menu] を選択します。

ステップ 7 [Start Tracking] をクリックします。

ステップ 8 ルータで show cellular gps コマンドの出力から位置の変更が得られれば、グラフに示された現在位置と、マップ上のその地点を中心とする円で赤茶色のドット カーソルが表示されます。


) 位置の変更が得られない場合、Microsoft アプリケーションはタイム アウトし、切断されます。



) GPS 固定位置を取得するには、サポートされている GPS アンテナを DIV/GPS ポートに接続する必要があります。スタンドアロン モードを使用して GPS 固定位置を取得するには、最大 12 分かかることがあります。これは、位置と使用されるアンテナの種類に依存します。


プッシュ ボタンを使用したイメージおよび Config の復元のためのルータの設定

プッシュ ボタン機能は Cisco 819 ISR で使用できます。ルータの前面パネルのリセット ボタンは、この機能をイネーブルにします。

この機能を使用するには、次の手順を実行します。


ステップ 1 電源プラグを外します。

ステップ 2 ルータの前面パネルのリセット ボタンを押します。

ステップ 3 リセット ボタンを押しながら、システムの電源を投入します。

システム LED が 4 回点滅し、ルータがボタンの押下を受け入れていることを示します。


 

このボタンの使用は、ROMMON の初期化中にのみ有効です。ウォーム リブート中にこのボタンを押しても、パフォーマンスには影響しません。 表 5-4 に、ROMMON の初期化中にボタンが押された場合の高レベルの機能を示します。

 

表 5-4 ROMMON の初期化中のプッシュ ボタンの機能

ROMMON の動作
IOS の動作

デフォルトのボー レートを使用してブートします。

自動ブートを実行します。

コンパクト フラッシュで *.default イメージを使用可能な場合はロードします。

(注) *.default イメージを使用できない場合は、ROMMON はフラッシュ上の最初の Cisco IOS イメージを使用して起動されます。

デフォルト イメージの名前の例:c800-universalk9-mz.SPA.default、c-800-universalk9_npe-mz.151T.default、image.default

(注) *.cfg オプションを含むコンフィギュレーション ファイルを 1 つだけ使用できます。複数のファイルが存在する場合は、不確かな動作上の反応が現れます。

*.cfg という設定が NVRAM ストレージまたはフラッシュ ストレージで使用できる場合、IOS は元の設定のバックアップを実行し、この設定を使用して起動されます。

(注) *.cfg オプションを含むコンフィギュレーション ファイルを 1 つだけ使用できます。複数のファイルが存在する場合は、不確かな動作上の反応が現れます。

ルータの現在のブートアップ モードを表示するには、show platform コマンドを使用します。次の項では、ボタンが押されていないときと、ボタンが押されたときの出力例を示します。

ボタンが押されていないときの出力:例

router# show platform boot-record
 
Platform Config Boot Record :
============================
Configuration Register at boot time : 0x0
Reset Button Status at Boot Time : Not Pressed
Startup-config Backup Status at Boot: No Status
Startup-config(backup file)location : No Backup
Golden config file at location : No Recovery Detected
Config Recovery Status : No Status

ボタンが押されたときの出力:例

router# show platform boot-record
Platform Config Boot Record :
============================
Configuration Register at boot time : 0x0
Reset Button Status at Boot Time : Pressed
Startup-config Backup Status at Boot: Ok
Startup-config(backup file)location : flash:/startup.backup.19000716-225840-UTC
Golden config file at location : flash:/golden.cfg
Config Recovery Status : Ok

WLAN AP のプッシュ ボタン

前面パネルのボタンが押されると、WLAN AP はイメージと設定の両方の復元を実行します。

イメージの復元を実行する場合、WLAN はブートローダに移行し、ユーザがブートローダ プロンプトからイメージをダウンロードできるようになります。

設定の復元を実行する場合、WLAN AP は、フラッシュ ドライブで flash:/cpconfig-ap802.cfg ファイルを使用できる場合、その内容で flash:/config.txt の内容を上書きします。それ以外の場合は、flash:/config.txt が削除されます。

ファスト イーサネット LAN インターフェイスの設定

ルータのファスト イーサネット LAN インターフェイスは、デフォルト VLAN の一部として自動的に設定され、個別のアドレスによる設定は行われません。アクセスは VLAN を通じて提供されます。必要に応じて、このインターフェイスを別の VLAN に割り当てることが可能です。VLAN の作成方法の詳細については、 「イーサネット スイッチの設定」 を参照してください。

ループバック インターフェイスの設定

ループバック インターフェイスは、スタティック IP アドレスのプレースホルダーとして機能し、デフォルトのルーティング情報を提供します。

ループバック インターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. interface type number

2. ip address ip-address mask

3. exit

手順の詳細

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface Loopback 0
Router(config-if)#
 

ループバック インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 10.108.1.1 255.255.255.0
Router(config-if)#
 

ループバック インターフェイスの IP アドレスとサブネット マスクを設定します。

ステップ 3

exit

例:

Router(config-if)# exit
Router(config)#
 

ループバック インターフェイスのコンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードに戻ります。

このコンフィギュレーション例のループバック インターフェイスは、仮想テンプレート インターフェイス上の NAT をサポートするために使用されています。この設定例は、スタティック IP アドレスとなる IP アドレス 200.200.100.1/24 を持つファスト イーサネット インターフェイスに設定されるループバック インターフェイスを示します。ループバック インターフェイスは、ネゴシエートされた IP アドレスを持つ virtual-template1 にポイントバックします。

!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
 

設定の確認

ループバック インターフェイスが正しく設定されたかどうかを確認するには、show interface loopback コマンドを入力します。次の例のような確認用の出力が表示されます。

Router# show interface loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 

ping を実行することによって、ループバック インターフェイスを確認する方法もあります。

Router# ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 
 

スタティック ルートの設定

スタティック ルートは、ネットワークを介した固定ルーティング パスを提供します。これらは、ルータ上で手動で設定されます。ネットワーク トポロジが変更された場合には、スタティック ルートを新しいルートに更新する必要があります。スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベート ルートです。

スタティック ルートを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

2. end

手順の詳細

コマンド
目的

ステップ 1

ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

例:

Router(config)# ip route 192.168.1.0 255.255.0.0 10.10.10.2
Router(config)#
 

IP パケットのスタティック ルートを指定します。

このコマンドと設定可能な追加パラメータについては、『Cisco IOS IP Routing: Protocol-Independent Command Reference』を参照してください。

ステップ 2

end

例:

Router(config)# end
Router#
 

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

スタティック ルーティングの一般的な説明については、 「フローティング スタティック ルート」 を参照してください。

次の設定例で、スタティック ルートは、ファスト イーサネット インターフェイスで宛先 IP アドレス 192.168.1.0 およびサブネット マスク 255.255.255.0 を持つすべての IP パケットを、IP アドレス 10.10.10.2 を持つ別のデバイスに送信します。具体的には、パケットが設定済みの PVC に送信されます。

「(default)」と記されているコマンドの入力は不要です。このコマンドは、 show running-config コマンドを使用すると、生成されたコンフィギュレーション ファイルに自動的に表示されます。

!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
 

設定の確認

スタティック ルーティングが正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「S」で表されるスタティック ルートを探します。

次のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
 

ダイナミック ルートの設定

ダイナミック ルーティングでは、ネットワーク トラフィックまたはトポロジに基づいて、ネットワーク プロトコルがパスを自動調整します。ダイナミック ルーティングの変更は、ネットワーク上の他のルータにも反映されます。

Cisco ルータは、ルーティング情報プロトコル(RIP)または Enhanced Interior Gateway Routing Protocol(EIGRP)などの IP ルーティング プロトコルを使用して、動的にルートを学習します。いずれかのルーティング プロトコルをルータに設定できます。

「ルーティング情報プロトコルの設定」

「拡張インテリア ゲートウェイ ルーティング プロトコルの設定」

ルーティング情報プロトコルの設定

ルータに RIP ルーティング プロトコルを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. router rip

2. version {1 | 2}

3. network ip-address

4. no auto-summary

5. end

手順の詳細

コマンド
作業

ステップ 1

router rip

例:

Router> configure terminal
Router(config)# router rip
Router(config-router)#

ルータ コンフィギュレーション モードを開始します。続いて、ルータの RIP をイネーブルにします。

ステップ 2

version { 1 | 2 }

例:

Router(config-router)# version 2
Router(config-router)#

RIP version 1 または 2 の使用を指定します。

ステップ 3

network ip-address

例:

Router(config-router)# network 192.168.1.1
Router(config-router)# network 10.10.7.1
Router(config-router)#

直接接続しているネットワークの各アドレスを使用して、RIP を適用するネットワーク リストを指定します。

ステップ 4

no auto-summary

例:

Router(config-router)# no auto-summary
Router(config-router)#

ネットワークレベル ルートへのサブネット ルートの自動サマライズをディセーブルにします。これにより、サブプレフィックス ルーティング情報がクラスフル ネットワーク境界を越えて送信されます。

ステップ 5

end

例:

Router(config-router)# end
Router#

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

RIP に関する一般情報については、 「RIP」 を参照してください。

次の設定例は、IP ネットワーク 10.0.0.0 および 192.168.1.0 でイネーブルにされる RIP version 2 を示します。

設定を表示するには、特権 EXEC モードで show running-config コマンドを使用します。

!
Router# show running-config
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
 

設定の確認

RIP が正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「R」で表される RIP ルートを探します。次の例のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0
 

拡張インテリア ゲートウェイ ルーティング プロトコルの設定

ルータに拡張インテリア ゲートウェイ ルーティング プロトコル(EIGRP)を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. router eigrp as-number

2. network ip-address

3. end

手順の詳細

コマンド
目的

ステップ 1

router eigrp as-number

例:

Router(config)# router eigrp 109
Router(config)#
 

ルータ コンフィギュレーション モードを開始します。続いて、ルータの EIGRP をイネーブルにします。自律システム(AS)番号は、他の EIGRP ルータへのルートを識別します。また、EIGRP 情報のタグ付けに使用されます。

ステップ 2

network ip-address

例:

Router(config)# network 192.145.1.0
Router(config)# network 10.10.12.115
Router(config)#
 

EIGRP を適用するネットワークのリストを指定します(直接接続されているネットワークの IP アドレスを使用)。

ステップ 3

end

例:

Router(config-router)# end
Router#
 

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

EIGRP の概念について一般的な説明は、 「EIGRP」 を参照してください。

次の設定例は、IP ネットワーク 192.145.1.0 および 10.10.12.115 でイネーブルにされる EIGRP ルーティング プロトコルを示します。EIGRP の自律システム番号として、109 が割り当てられています。

設定を表示するには、特権 EXEC モードで開始し、 show running-config コマンドを使用します。

!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!
 

設定の確認

IP EIGRP が正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「D」で表される EIGRP ルートを探します。次のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0