Cisco 860、Cisco 880 および Cisco 890 シリーズ サービス統合型ルータ ソフトウェア コンフィギュレーション ガイド
ルータの基本設定
ルータの基本設定
発行日;2012/06/19 | 英語版ドキュメント(2011/12/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

ルータの基本設定

インターフェイス ポート

デフォルト コンフィギュレーション

設定に必要な情報

コマンドライン アクセスの設定

グローバル パラメータの設定

WAN インターフェイスの設定

ファスト イーサネット WAN インターフェイスの設定

メディア タイプの設定

ギガビット イーサネット WAN インターフェイスの設定

V.92 モデム インターフェイスの設定

VDSL2 WAN インターフェイスの設定

Cisco 860VAE および 880VA マルチモード ISR の ADSL または VDSL の設定

Cisco 860VAE、886VA、および 887VA マルチモード ISR の概要

Over POTS VDSL2/ADSL マルチモード Annex A SKU での ADSL2/2+ Annex M モード

シームレス レート適応の設定

UBR+ の設定

ADSL モードの設定

ADSL auto モードの設定

ADSL モードの CPE およびピアの設定

ADSL の設定例

ADSL 設定の確認

ADSL の CPE からピアへの接続の確認

VDSL モードの設定

VDSL auto モードの設定

VDSL モードの CPE およびピアの設定

VDSL の設定例

VDSL 設定の確認

VDSL の CPE からピアへの接続の確認

Over POTS VDSL2/ADSL マルチモード Annex A SKU の ADSL2/2+ Annex M モードのイネーブル化

Over POTS VDSL2/ADSL マルチ モード Annex A SKU で ADSL2/2+ Annex M モードをイネーブルにするには、次の手順を実行します。

シームレス レート適応のイネーブル化

シームレス レート適応の例

UBR+ の設定

UBR+ の例

トラブルシューティング

CLI を使用したトレーニング ログの設定

トレーニング ログの取得

トレーニング ログの取得の停止

トレーニング ログのステータスおよびファイルの場所の表示

ATM モードでの G.SHDSL WAN インターフェイスの設定

設定の確認

EFM モードでの G.SHDSL WAN インターフェイスの設定

セル ワイヤレス WAN インターフェイスの設定

3G ワイヤレス インターフェイスの設定に関する要件

セル ワイヤレス インターフェイスの設定に関する制約事項

データ アカウントのプロビジョニング

セル インターフェイスの設定

DDR の設定

データ専用転送モード(DDTM)の設定

セル ワイヤレス インターフェイスの設定例

Cisco 860VAE ISR での WAN モードの設定

WAN モードのイネーブル化

WAN モード設定の表示

ファスト イーサネット LAN インターフェイスの設定

無線 LAN インターフェイスの設定

ループバック インターフェイスの設定

設定の確認

スタティック ルートの設定

設定の確認

ダイナミック ルートの設定

ルーティング情報プロトコルの設定

設定の確認

拡張インテリア ゲートウェイ ルーティング プロトコルの設定

設定の確認

ルータの基本設定

この章では、Cisco ルータで基本的なパラメータ(グローバル パラメータの設定、ルーティング プロトコル、インターフェイス、およびコマンドライン アクセスなど)を設定する手順について説明します。また、起動時のデフォルト設定についても説明します。

「インターフェイス ポート」

「デフォルト コンフィギュレーション」

「設定に必要な情報」

「コマンドライン アクセスの設定」

「グローバル パラメータの設定」

「WAN インターフェイスの設定」

「ファスト イーサネット LAN インターフェイスの設定」

「無線 LAN インターフェイスの設定」

「ループバック インターフェイスの設定」

「スタティック ルートの設定」

「ダイナミック ルートの設定」


) ルータの各モデルは、このマニュアルに記載されている機能の一部をサポートしていない場合があります。特定のルータでサポートされていない機能は、可能な限り明示されています。


この章では、該当するものがある場合には設定例と確認手順が記載されています。

グローバル コンフィギュレーション モードにアクセスする方法の詳細については、「グローバル コンフィギュレーション モードの開始」を参照してください。

インターフェイス ポート

表 3-1 は、各ルータでサポートされているインターフェイスと装置に表記されているポート ラベルを示しています。

 

表 3-1 Cisco ルータでサポートされているインターフェイスと対応するポート ラベル

ルータ
インターフェイス
ポート ラベル
LAN ポート

Cisco 860、Cisco 880、および Cisco 890 シリーズ

ファスト イーサネット LAN

LAN、FE0-FE3

ワイヤレス LAN

(表示なし)

Cisco 866VAE、867VAE

イーサネット LAN

LAN、FE0-FE3

Cisco 866VAE-K9、867VAE-K9

イーサネット LAN

LAN、GE0、FE0-FE3

WAN ポート

Cisco 861、861W、881、881W、881G、881GW、881-V

ファスト イーサネット WAN

WAN、FE4

Cisco 867、867W

ADSL2oPOTS WAN

ADSLoPOTS

Cisco 886、886W、886G、886GW

ADSL2oISDN WAN

ADSLoPOTS

Cisco 887、887W

ADSL2oPOTS WAN

ADSLoPOTS

Cisco 887V、Cisco 887VW、887VG、887VGW

VDSL2oPOTS WAN

VDSLoPOTS

Cisco 867VA、887VA、887VA-M、887VA-V、887VA-V-W

VDSL/ADSLoPOTS WAN

VDSL/ADSLoPOTS

Cisco 888、888W

G.SHDSL WAN

G.SHDSL

Cisco 891、892

ファスト イーサネット WAN

FE8

ギガビット イーサネット WAN

WAN GE 0

Cisco 866VAE、867VAE

ギガビット イーサネット WAN

WAN GE0

Cisco 866VAE-K9、867VAE-K9

ギガビット イーサネット WAN

WAN GE1

Cisco 866VAE、866VAE-K9

VDSL/ADSLoISDN WAN

VDSL/ADSL OVER ISDN

Cisco 867VAE、867VAE-K9

VDSL/ADSLoPOTS WAN

VDSL/ADSL OVER POTS

デフォルト コンフィギュレーション

Cisco ルータを初めて起動すると、一部の基本的な設定はすでに行われています。LAN および WAN インターフェイスはすべて作成されており、コンソール ポートと VTY ポートの設定やネットワーク アドレス変換(NAT)用の内部インターフェイスの割り当てもすでに行われています。初期設定を表示するには、 show running-config コマンドを使用します(次の Cisco 881W の例を参照してください)。

Router# show running-config
 
 
User Access Verification
 
Password:
Router> en
Password:
Router# show running-config
Building configuration...
 
Current configuration : 986 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$g4y5$NxDeM.0hON6YA51bcfGvN1
enable password ciscocisco
!
no aaa new-model
!
!
!
!
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authe
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
ip address 10.1.1.1 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface wlan-ap0
description Service Module interface to manage the embedded AP
ip unnumbered Vlan1
no cdp enable
arp timeout 0
!
ip route 0.0.0.0 0.0.0.0 10.1.1.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password cisco
login
transport input telnet ssh
!
scheduler max-task-time 5000
 
!
webvpn cef
end
 
Router#

設定に必要な情報

ネットワークを設定する前に、使用するネットワーク構成に基づいて、次の情報を収集します。

インターネット接続を設定する場合、次の情報を収集してください。

ユーザのログイン名として割り当てられた PPP クライアント名

PPP 認証のタイプ:Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェイク認証プロトコル)または Password Authentication Protocol(PAP)

ISP アカウントにアクセスするための PPP パスワード

DNS サーバの IP アドレスおよびデフォルト ゲートウェイ

企業ネットワークへの接続を設定する場合は、ユーザとネットワーク管理者の間で、ルータの WAN インターフェイスに関する次の情報について打ち合わせておく必要があります。

PPP 認証のタイプ:CHAP または PAP

ルータにアクセスするための PPP クライアント名

ルータにアクセスするための PPP パスワード

IP ルーティングを設定する場合、次の準備が必要です。

IP ネットワークのアドレス指定方式を作成します。

IP アドレスなどの IP ルーティング パラメータ情報と ATM 相手先固定接続(PVC)を特定します。通常、これらの PVC パラメータは、仮想パス識別子(VPI)、仮想回線識別子(VCI)、およびトラフィック シェーピング パラメータです。

サービス プロバイダーから付与された PVC 番号、VPI、および VCI を特定します。

PVC ごとに、サポートされている AAL5 カプセル化のタイプを判別します。次のいずれかの状態になります。

AAL5SNAP:これは、RFC 1483 ルーティングまたは RFC 1483 ブリッジングのいずれかです。RFC 1483 ルーティングの場合、サービス プロバイダーはスタティック IP アドレスを提供する必要があります。ブリッジング RFC 1483 の場合、DHCP を用いて IP アドレスを入手するか、サービス プロバイダーからスタティック IP アドレスを入手することもできます。

AAL5MUX PPP:このタイプでのカプセル化では、PPP 関連設定項目を判別する必要があります。

ADSL または G.SHDSL 回線を使用して接続する場合、次の準備が必要です。

電話会社と回線契約を結びます。

ADSL 回線の場合:ADSL シグナリング タイプが DMT(ANSI T1.413 ともいう)または DMT Issue 2 であることを確認します。

G.SHDSL 回線の場合:G.SHDSL 回線が ITU G.991.2 規格に準拠し、Annex A(北米)または Annex B(欧州)をサポートしていることを確認します。

適切な情報を収集したら、「コマンドライン アクセスの設定」のタスクからルータの完全な設定を行います。

作業内容に応じて、次のマニュアルを参照します。

音声機器を接続する場合は、『 Cisco IOS Voice Port Configuration Guide 』を参照してください。

ソフトウェア ライセンスを取得または変更する場合は、『 Software Activation on Cisco Integrated Services Routers and Cisco Integrated Service Routers G2 』を参照してください。

コマンドライン アクセスの設定

ルータへのアクセスを制御するパラメータを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. line [ aux | console | tty | vty ] line-number

2. password password

3. login

4. exec-timeout minutes [ seconds ]

5. line [ aux | console | tty | vty ] line-number

6. password password

7. login

8. end

手順の詳細

 

コマンド
目的

ステップ 1

line [ aux | console | tty | vty ] line-number

例:

Router(config)# line console 0
Router(config-line)#

回線コンフィギュレーション モードを開始します。続いて、回線のタイプを指定します。

この例では、アクセス用にコンソール端末を指定します。

ステップ 2

password password

例:

Router(config)# password 5dr4Hepw3
Router(config-line)#

コンソール端末回線に固有のパスワードを指定します。

ステップ 3

login

例:

Router(config-line)# login

端末セッション ログイン時のパスワード チェックをイネーブルにします。

ステップ 4

exec-timeout minutes [ seconds ]

例:

Router(config-line)# exec-timeout 5 30

ユーザ入力が検出されるまで EXEC コマンド インタープリタが待機する間隔を設定します。デフォルトは 10 分です。任意で、間隔値に秒数を追加します。

この例では、5 分 30 秒のタイムアウトを表示します。「0 0」のタイムアウトを入力すると、タイムアウトが発生しません。

ステップ 5

line [ aux | console | tty | vty ] line-number

例:

Router(config-line)# line vty 0 4

リモート コンソール アクセス用の仮想端末を指定します。

ステップ 6

password password

例:

Router(config-line)# password aldf2ad1

仮想端末回線に固有のパスワードを指定します。

ステップ 7

login

例:

Router(config-line)# login

仮想端末セッション ログイン時のパスワード チェックをイネーブルにします。

ステップ 8

end

例:

Router(config-line)# end
Router#

回線コンフィギュレーション モードを終了します。続いて、特権 EXEC モードに戻ります。

次の設定は、コマンドライン アクセス コマンドを示します。

「default」と記されているコマンドは入力不要です。これらのコマンドは、 show running-config コマンドを使用すると、生成されたコンフィギュレーション ファイルに自動的に表示されます。

!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
 

グローバル パラメータの設定

ルータに選択したグローバル パラメータを設定するには、次の作業を行います。

手順の概要

1. configure terminal

2. hostname name

3. enable secret password

4. no ip domain-lookup

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

例:

Router# configure terminal

グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。

リモート端末を使用してルータに接続している場合は、次のコマンドを使用します。

telnet router name or address

Login: login id

Password: *********

Router> enable

ステップ 2

hostname name

例:

Router(config)# hostname Router

ルータ名を指定します。

ステップ 3

enable secret password

例:

Router(config)# enable secret cr1ny5ho

ルータへの不正なアクセスを防止するには、暗号化パスワードを指定します。

ステップ 4

no ip domain-lookup

例:

Router(config)# no ip domain-lookup

ルータが未知の単語(入力ミス)を IP アドレスに変換しないようにします。

WAN インターフェイスの設定

必要に応じて、次のいずれかの手順を行い、ルータの WAN インターフェイスを設定します。

「ファスト イーサネット WAN インターフェイスの設定」

「メディア タイプの設定」

「ギガビット イーサネット WAN インターフェイスの設定」

「V.92 モデム インターフェイスの設定」

「VDSL2 WAN インターフェイスの設定」

「Cisco 860VAE および 880VA マルチモード ISR の ADSL または VDSL の設定」

「シームレス レート適応の設定」

「UBR+ の設定」

「ADSL モードの設定」

「VDSL モードの設定」

「CLI を使用したトレーニング ログの設定」

「ATM モードでの G.SHDSL WAN インターフェイスの設定」

「EFM モードでの G.SHDSL WAN インターフェイスの設定」

「セル ワイヤレス WAN インターフェイスの設定」

「Cisco 860VAE ISR での WAN モードの設定」

ファスト イーサネット WAN インターフェイスの設定

Cisco 861 または 881 ISR でファスト イーサネット インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

手順の概要

1. interface type number

2. ip address ip-address mask

3. no shutdown

4. exit

手順の詳細

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface fastethernet 4

ルータのファスト イーサネット WAN インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 192.168.12.2 255.255.255.0

指定されたファスト イーサネット インターフェイスの IP アドレスおよびサブネット マスクを設定します。

ステップ 3

no shutdown

例:

Router(config-if)# no shutdown

イーサネット インターフェイスをイネーブルにして、インターフェイスの状態を管理上のダウンからアップに変更します。

ステップ 4

exit

例:

Router(config-if)# exit
Router(config)#

ファスト イーサネット インターフェイスのコンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。


) Cisco IOS Release 15.1 (3) T では、インターフェイスモードに batch コマンドが導入されました。パケットがより効率的なキャッシュ使用率でバッチで処理されるため、インターフェイスのバッチがイネーブルの場合、CPU 使用率の低下を確認できます。


メディア タイプの設定

Cisco 892F ISR でギガビット イーサネット インターフェイスを設定する前に、まず SFP または RJ-45 としてメディア タイプを選択する必要があります。

メディア タイプを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. interface type number

2. media-type { sfp | rj45 }

3. exit

手順の詳細

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface gigabitethernet 0

ルータのギガビット イーサネット WAN インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

media-type { sfp | rj45 }

例:

Router(config-if)# media-type sfp
または
Router(config-if)# media-type rj45

SFP の物理接続を指定します。

または

RJ-45 の物理接続を指定します。

ステップ 3

exit

例:

Router(config-if)# exit
Router(config)#

ギガビット イーサネット インターフェイスのコンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードに戻ります。

ギガビット イーサネット WAN インターフェイスの設定

Cisco 891、892、または 860VAE ISR のギガビット イーサネット(GE)WAN インターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を行います。

手順の概要

1. interface type number

2. ip address ip-address mask

3. no shutdown

4. exit

手順の詳細

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface gigabitethernet 1
Router(config-if)#

ルータのギガビット イーサネット WAN インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 192.168.12.2 255.255.255.0

指定したギガビット イーサネット インターフェイスの IP アドレスとサブネット マスクを設定します。

ステップ 3

no shutdown

例:

Router(config-if)# no shutdown

イーサネット インターフェイスをイネーブルにして、インターフェイスの状態を管理上のダウンからアップに変更します。

ステップ 4

exit

例:

Router(config-if)# exit
Router(config)#

ギガビット イーサネット インターフェイスのコンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードに戻ります。

V.92 モデム インターフェイスの設定

Cisco 891 ISR には、V.92 モデムバックアップ インターフェイスがあります。このインターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. interface type number

2. ip address ip-address mask

3. encapsulation ppp

4. dialer in-band

5. dialer string dial-string

6. dialer-group group-number

7. async mode dedicated

8. exit

手順の詳細

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface async 1

ルータの V.92 WAN インターフェイス(シリアル インターフェイス)のコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 192.168.12.2 255.255.255.0

指定された V.92 インターフェイスの IP アドレスとサブネット マスクを設定します。

ステップ 3

encapsulation ppp

例:

Router(config-if)# encapsulation ppp

シリアル インターフェイスのポイントツーポイント プロトコル(PPP)に対するカプセル化方式を設定します。

ステップ 4

dialer in-band

例:

Router(config-if)# dialer in-band

ダイヤルオンデマンド ルーティング(DDR)をサポートするように指定します。

ステップ 5

dialer string dial-string

例:

Router(config-if)# dialer string 102

インターフェイスからコールを発信するときに使用する文字列(電話番号)を指定します。

ステップ 6

dialer-group group-number

例:

Router(config-if)# dialer-group 1

インターフェイスを、指定したダイヤル アクセス グループに属するように設定します。

ステップ 7

async mode dedicated

例:

Router(config-if)# async mode dedicated

シリアル ライン インターネット プロトコル(SLIP)または PPP カプセル化を使用して、専用非同期モードに回線を配置します。

ステップ 8

exit

例:

Router(config-if)# exit
Router(config)#

V.92 インターフェイスのコンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

VDSL2 WAN インターフェイスの設定

Cisco 887V ISR プラットフォームでは、VDSL2 WAN インターフェイスが使用されます。VDSL2 WAN インターフェイスは、レイヤ 2 転送メカニズムとしてイーサネットを使用することに注意してください。

Cisco 887V ISR で VDSL2 を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. controller vdsl 0

2. interface type number

3. ip address ip-address mask

4. shutdown

5. no shutdown

6. exit

手順の詳細

 

コマンド
目的

ステップ 1

controller vdsl 0

例:

Router(config)# controller vdsl 0

コントローラのコンフィギュレーション モードを開始し、コントローラ番号を入力します。

(注) CPE 側から VDSL2 パラメータを設定する必要はありません。DSLAM 側で特定の VDSL2 設定を実施する必要があります。

ステップ 2

interface type number

例:

Router(config)# interface ethernet 0

ルータ上の VDSL WAN インターフェイスを通してイーサネット レイヤ 2 転送のコンフィギュレーション モードを開始します。

ステップ 3

ip address ip-address mask

例:

Router(config-if)# ip address 192.168.12.2 255.255.255.0

インターフェイスに IP アドレスとサブネット マスクを設定します。

ステップ 4

shutdown

例:

Router(config-if)# no shutdown

インターフェイスをディセーブルにします。状態が管理アップから管理ダウンに変化します。

ステップ 5

no shutdown

例:

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。状態が管理ダウンから管理アップに変化します。

ステップ 6

exit

例:

Router(config-if)# exit

コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

Cisco 860VAE、886VA、および 887VA マルチモード ISR の概要

シスコの加入者宅内機器(CPE)である Cisco 866VAE、867VAE、866VAE-K9、867VAE-K9、886VA および 887VA サービス統合型ルータ(ISR)は、非対称デジタル加入者線(ADSL)1/2/2+、およびマルチモードと呼ばれる超高速デジタル加入者線 2(VDSL2)転送モードをサポートします。


) 866VAE および 886VA は、ISDN 経由の xDSL をサポートします。867VAE および 887VA は、従来のアナログ電話回線(POTS)経由の xDSL をサポートします。


デフォルトの CPE 動作モードは auto です。auto モードとは、CPE がデジタル加入者線アクセス マルチプレクサ(DSLAM)に設定されているモード、ADSL1/2/2+ または VDSL2 にトレーニングされるという意味です。

次の例では、DSLAM が ADSL2+ モードまたは VDSL2 で設定されていて、CPE が auto モードで設定されているものとします。

図 3-1 に、ATM WAN またはイーサネット WAN ネットワーク トポロジを示します。

図 3-1 トポロジの例

 

1

ファスト イーサネット LAN インターフェイス
または

ギガビット イーサネット LAN インターフェイス

2

ATM WAN インターフェイス:ADSL 1/2/2+ モード
または

イーサネット WAN インターフェイス:VDSL2 モード


) レイヤ 1 の DSLAM は auto モード用に設定できます。レイヤ 2 の DSLAM は、ATM モードまたは Packet Transfer Mode(PTM)用に設定する必要があります。



) Cisco 886VA および 887VA では、最大 4 つの Permanent Virtual Circuit(PVC; 相手先固定接続)が可能です。



) Cisco 866VAE、Cisco 867VAE、Cisco 866VAE-K9、および Cisco 867VAE-K9 ISR には、最大 2 つの PVC を設定できます。


Over POTS VDSL2/ADSL マルチモード Annex A SKU での ADSL2/2+ Annex M モード

Annex M は、ダウンストリーム周波数範囲から 32 の追加トーンを「借りる」ことで、アップストリーム帯域幅を 2 倍にする G.992.3 規格の拡張です。この機能は、サービス プロバイダーが、最大 2 Mbps のデータレートで ADSL2 および ADSL2+ サービスの対称データレートを提供できるようにします。

Cisco IOS Release 15.2(1)T では、Cisco 887VA プラットフォームで Annex A データ構造を、Cisco 887VA-M プラットフォームで Annex M データ構造をイネーブルにするサポートが追加されます。この機能を使用することで、Annex A と Annex M の両方の構造を同じプラットフォームで実行できます。ただし、デバイスに対して最適化されていない Annex のパフォーマンス トレードオフが存在します。この機能の実装によって、Annex A のプラットフォームでサポートされるモードは Annex M のプラットフォーム(887VA-M および EHWIC-1DSL-VA-M)でサポートされるモードと同じです。デジタル加入者線アクセス マルチプレクサ(DSLAM)が Annex M をサポートしている場合、Annex M モードは、Annex A モードよりも優先されます。


) Cisco 867VAE と 867VAE-K9 では、Cisco IOS Release 15.1(4)M2 または 15.2(2)T 以降がこの機能を使用する必要があります。


Annex A プラットフォームでの Annex M データ構造の設定については、「Over POTS VDSL2/ADSL マルチモード Annex A SKU の ADSL2/2+ Annex M モードのイネーブル化」を参照してください。

シームレス レート適応の設定

ADSL 接続は、クロストーク、ノイズ マージンの変化、温度変化、または干渉などの複数の理由によってドロップされる場合があります。ADSL2 は、データ レートをリアルタイムに適応することで、こうした問題に対処しています。シームレスレート適応(SRA)により、ADSL2 システムはサービスの中断またはビット エラーなしで、動作中に接続のデータ レートを変更できます。


) これらの機能は、866VAE、867VAE、866VAE-K9、および 867VAE-K9 では使用できません。


SRA の設定については、「シームレス レート適応のイネーブル化」を参照してください。

UBR+ の設定

UBR は、通常、ファイル転送や電子メールなどのデータ通信アプリケーションに対して使用されます。UBR はベスト エフォート サービスであり、階層の最下位レイヤのサービス クラスです。許可されている実際の帯域幅は保証されません。したがって、UBR 仮想回線(VC)は、セルが送信元から宛先に移動する場合に発生する、多数のセル ドロップまたは大きなセル転送遅延による影響を受けます。UBR は、セル遅延変動許容値(CDVT)の限度を持たない単なるベスト エフォート サービスです。

UBR+ はシスコが開発した特別な ATM サービス クラスです。UBR は、ピーク セル レート(PCR)だけを定義します。ただし、UBR+ は最低保証セル レート(MCR)および(スイッチでの)セル遅延変動許容値(CDVT)を定義します。


) Cisco IOS バージョン 15.2(1)T 以降では、UBR+ は Cisco マルチモード 886VA および 887VA ルータと互換性があります。



) これらの機能は、866VAE、867VAE、866VAE-K9、および 867VAE-K9 では使用できません。


UBR+ の設定の詳細については、「UBR+ の設定」を参照してください。

ADSL モードの設定

設定作業

ADSL モードを設定するには、次の作業を行います。

「ADSL auto モードの設定」

「ADSL モードの CPE およびピアの設定」

「ADSL 設定の確認」

「ADSL の CPE からピアへの接続の確認」

ADSL auto モードの設定

DSL コントローラを auto モードに設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。


) ルータを設定する前に、ADSL 1/2/2+ モードで DSLAM を設定します。


手順の概要

1. enable

2. configure terminal

3. controller vdsl slot

4. operating mode {auto | adsl1 | adsl2 | adsl2+ | vdsl2 | {ansi |etsi}}


) ANSI オプションは、POTS をサポートするモデルにのみ使用できます。ETSI オプションは、ISDN をサポートするモデルにのみ使用できます。


5. end

手順の詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトにパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

controller vdsl slot

例:

Router(config)# controller vdsl 0

VDSL コントローラのコンフィギュレーション モードを開始します。

ステップ 4

operating mode {auto | adsl1 | adsl2 | adsl2+ | vdsl2 | ansi}

例:

Router(config-controller)# operating mode auto

動作モードを設定します。デフォルトは auto で、これが推奨されるモードです。

(注) auto で設定した場合、show running コマンドでは動作モードが表示されません。

ステップ 5

end

例:

Router(config-controller)# end
Router#

コンフィギュレーション モードを終了し、EXEC モードを開始します。

(注) Cisco 866VAE、Cisco 867VAE、Cisco 866VAE-K9、および Cisco 867VAE-K9 で adsl または vdsl にモードを変更した場合はリロードが必要です。

ADSL モードの CPE およびピアの設定

ADSL を設定するときは、ATM メイン インターフェイスまたは ATM サブインターフェイスを PVC および IP アドレスを使用して設定する必要があり、必要な場合、インターフェイスで no shutdown コマンドを実行します。

手順の概要

1. interface type number

2. no shutdown

3. interface atm0.1 point-to-point

4. ip address ip-address mask

5. pvc [name] vpi/vci

6. protocol protocol {protocol-address [virtual-template] | inarp} [[no] broadcast | disable-check-subnet | [no] enable-check-subnet]

7. end

手順の詳細

ATM CPE 側の設定

グローバル コンフィギュレーション モードで ATM CPE 側を設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface atm0
Router(config-if)#

ATM WAN インターフェイス(ATM0)で、コンフィギュレーション モードを開始します。

ステップ 2

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#

ATM インターフェイスに対する設定変更をイネーブルにします。

ステップ 3

interface atm0.1 point-to-point

例:

Router(config-if)# interface ATM0.1 point-to-point
Router(config-subif)#

ATM0.1 ポイントツーポイント インターフェイスをイネーブルにします。

ステップ 4

ip address ip-address mask

例:

Router(config-subif)# ip address 30.0.0.1 255.255.255.0

IP アドレスとサブネット マスクを入力します。

ステップ 5

pvc [name] vpi/vci

例:

Router(config-subif)# pvc 13/32
Router(config-if-atm-vc)#

ATM PVC に名前を割り当てるかまたは名前を作成し、ATM 仮想回線コンフィギュレーション モードを開始します。

ステップ 6

protocol protocol {protocol-address [virtual-template] | inarp} [[no] broadcast | disable-check-subnet | [no] enable-check-subnet]

例:

Router(config-if-atm-vc)# protocol ip 30.0.0.2 broadcast

ATM PVC のスタティック マップを設定します。

ステップ 7

end

例:

Router(config-if-atm-vc)# end
Router#

コンフィギュレーション モードを終了し、EXEC モードを開始します。

ATM ピア側の設定

グローバル コンフィギュレーション モードで ATM ピア側を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface atm0

ATM WAN インターフェイス(ATM0)で、コンフィギュレーション モードを開始します。

ステップ 2

no shutdown

例:

Router(config-if)# no shutdown

ATM インターフェイスに対する設定変更をイネーブルにします。

ステップ 3

interface atm0.1 point-to-point

例:

Router(config-if)# interface ATM0.1 point-to-point

ATM0.1 ポイントツーポイント インターフェイスをイネーブルにします。

ステップ 4

ip address ip-address mask

例:

Router(config-subif)# ip address 30.0.0.2 255.255.255.0

IP アドレスとサブネット マスクを入力します。

ステップ 5

pvc [name] vpi/vci

例:

Router(config-subif)# pvc 13/32

ATM PVC に名前を割り当てるかまたは名前を作成し、ATM 仮想回線コンフィギュレーション モードを開始します。

ステップ 6

protocol protocol {protocol-address [virtual-template] | inarp} [[no] broadcast | disable-check-subnet | [no] enable-check-subnet]

例:

Router(config-if-atm-vc)# protocol ip 30.0.0.1 broadcast

ATM PVC のスタティック マップを設定します。

ステップ 7

end

例:

Router(config-if-atm-vc)# end
Router#

コンフィギュレーション モードを終了し、EXEC モードを開始します。

ADSL の設定例

次に、auto モードに設定する一般的な ADSL2+ 設定例を示します。太字で表示された箇所が重要です。

Router# show running
Building configuration...
 
 
Current configuration : 1250 bytes
!
! Last configuration change at 02:07:09 UTC Tue Mar 16 2010
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
ip source-route
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO887-V2-K9 sn FHK1313227E
license boot module c880-data level advipservices
!
!
vtp domain cisco
vtp mode transparent
!
!
controller VDSL 0
!
vlan 2-4
!
!
!
!
!
interface Ethernet0
no ip address
shutdown
no fair-queue
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
ip address 30.0.0.1 255.255.255.0
pvc 15/32
protocol ip 30.0.0.2 broadcast
!
!
 
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
exception data-corruption buffer truncate
end

ADSL 設定の確認

特権 EXEC モードで show controller vdsl 0 コマンドを使用して、正しく構成が設定されていることを確認します。太字で表示された箇所が重要です。

Router# show controller vdsl 0
Controller VDSL 0 is UP
 
 
Daemon Status: Up
 
 
XTU-R (DS) XTU-C (US)
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0x6110
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' 'BDCM'
Modem Vendor Specific: 0x4602 0x6110
Modem Vendor Country: 0xB500 0xB500
Serial Number Near: FHK1313227E 887-V2-K 15.1(20100
Serial Number Far:
Modem Version Near: 15.1(20100426:193435) [changahn
Modem Version Far: 0x6110
 
Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.992.5 (ADSL2+) Annex A
TC Mode: ATM
Selftest Result: 0x00
DELT configuration: disabled
DELT state: not running
Trellis: ON ON
Line Attenuation: 1.0 dB 1.4 dB
Signal Attenuation: 1.0 dB 0.0 dB
Noise Margin: 6.8 dB 13.6 dB
Attainable Rate: 25036 kbits/s 1253 kbits/s
Actual Power: 13.7 dBm 12.3 dBm
Total FECS: 0 0
Total ES: 0 0
Total SES: 0 0
Total LOSS: 0 0
Total UAS: 0 0
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0
Bit swap: 163 7
 
Full inits: 32
Failed full inits: 0
Short inits: 0
Failed short inits: 0
 
 
Firmware Source File Name (version)
-------- ------ -------------------
VDSL embedded VDSL_LINUX_DEV_01212008 (1)
 
 
Modem FW Version: 100426_1053-4.02L.03.A2pv6C030f.d22j
Modem PHY Version: A2pv6C030f.d22j
 
 
 
DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 24184 0 1047
Previous Speed: 0 24176 0 1047
Total Cells: 0 317070460 0 13723742
User Cells: 0 0 0 0
Reed-Solomon EC: 0 0 0 0
CRC Errors: 0 0 0 0
Header Errors: 0 0 0 0
Interleave (ms): 0.00 0.08 0.00 13.56
Actual INP: 0.00 0.00 0.00 1.80
 
 
Training Log : Stopped
Training Log Filename : flash:vdsllog.bin

ADSL の CPE からピアへの接続の確認

ピアに ping を発行し、CPE からピアへの構成が正しく設定されていることを確認します。

Router# ping 30.0.0.2 rep 20
 
Type escape sequence to abort.
Sending 20, 100-byte ICMP Echos to 30.0.0.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (20/20), round-trip min/avg/max = 20/22/28 ms
Router#

VDSL モードの設定

設定作業

VDSL モードを設定するには、次の作業を行います。

「VDSL auto モードの設定」

「VDSL モードの CPE およびピアの設定」

「VDSL 設定の確認」

「VDSL の CPE からピアへの接続の確認」

VDSL auto モードの設定

グローバル コンフィギュレーション モードで DSL コントローラを auto モードに設定するには、次の手順を実行します。


) ルータを設定する前に VDSL2 モードで DSLAM を設定します。


手順の概要

1. controller vdsl slot

2. operating mode {auto | adsl1 | adsl2 | adsl2+ | vdsl2 | {ansi |etsi}}


) ANSI オプションは、POTS をサポートするモデルにのみ使用できます。ETSI オプションは、ISDN をサポートするモデルにのみ使用できます。


3. end

手順の詳細

 

コマンド
目的

ステップ 1

controller vdsl slot

例:

Router(config)# controller vdsl 0

VDSL コントローラのコンフィギュレーション モードを開始します。

ステップ 2

operating mode {auto | adsl1 | adsl2 | adsl2+ | vdsl2 | ansi}

例:

Router(config-controller)# operating mode auto

動作モードを設定します。デフォルトは auto で、これが推奨されるモードです。

(注) auto で設定した場合、show running コマンドでは動作モードが表示されません。

ステップ 3

end

例:

Router(config-controller)# end
Router#

コンフィギュレーション モードを終了し、EXEC モードを開始します。

(注) Cisco 866VAE、Cisco 867VAE、Cisco 866VAE-K9、および Cisco 867VAE-K9 でモードを変更した場合は、リロードが必要です。

VDSL モードの CPE およびピアの設定

VDSL を設定する場合は ethernet 0 インターフェイスを設定し、必要に応じて no shutdown コマンドを実行します。グローバル コンフィギュレーション モードで開始します。

VDSL CPE 側の設定

VDSL CPE 側を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. interface type number

2. ip address ip-address mask

3. no shutdown

4. end

手順の詳細

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface ethernet0

イーサネット インターフェイス 0 のコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 90.0.0.1 255.255.255.0

IP アドレスとサブネット マスクを入力します。

ステップ 3

no shutdown

Router(config-if)# no shutdown

IP アドレスとサブネット マスクに対して設定変更をイネーブルにします。

ステップ 4

end

Router(config-if)# end
Router#

コンフィギュレーション モードを終了し、EXEC モードを開始します。

VDSL ピア側の設定

VDSL ピア側を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface ethernet0

イーサネット インターフェイス 0 のコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 90.0.0.2 255.255.255.0

IP アドレスとサブネット マスクを設定します。

ステップ 3

no shutdown

Router(config-if)# no shutdown

IP アドレスとサブネット マスクに対して設定変更をイネーブルにします。

ステップ 4

end

Router(config-if)# end
Router#

コンフィギュレーション モードを終了し、EXEC モードを開始します。

VDSL の設定例

次に、VDSL の設定の一般的な出力例を示します。太字で表示された箇所が重要です。

Router# show running
Building configuration...
 
 
Current configuration : 1250 bytes
!
! Last configuration change at 02:07:09 UTC Tue Mar 16 2010
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
ip source-route
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO887-V2-K9 sn FHK1313227E
license boot module c880-data level advipservices
!
!
vtp domain cisco
vtp mode transparent
!
!
controller VDSL 0
!
vlan 2-4
!
!
!
!
!
interface Ethernet0
ip address 30.0.0.1 255.255.255.0
no fair-queue
!
interface BRI
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface ATM0
no ip address
shutdown
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
exception data-corruption buffer truncate
end

VDSL 設定の確認

特権 EXEC モードから show controller vdsl 0 コマンドを使用して、設定が正しく行われていることを確認します。太字で表示された箇所が重要です。

Router# show controller vdsl 0
Controller VDSL 0 is UP
 
 
Daemon Status: Up
 
 
XTU-R (DS) XTU-C (US)
 
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0x0000
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' 'BDCM'
Modem Vendor Specific: 0x4602 0x0000
Modem Vendor Country: 0xB500 0xB500
Serial Number Near: FHK1313227E 887-V2-K 15.1(20100
Serial Number Far:
Modem Version Near: 15.1(20100426:193435) [changahn
Modem Version Far: 0x0000
 
 
Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.993.2 (VDSL2) Profile 12a
TC Mode: PTM
Selftest Result: 0x00
DELT configuration: disabled
DELT state: not running
Trellis: ON OFF
Line Attenuation: 1.0 dB 0.0 dB
Signal Attenuation: 1.0 dB 0.0 dB
Noise Margin: 12.0 dB 9.5 dB
Attainable Rate: 87908 kbits/s 50891 kbits/s
Actual Power: 13.5 dBm 8.9 dBm
Per Band Status: D1 D2 D3 U0 U1 U2 U3
Line Attenuation(dB): 0.9 2.3 N/A 7.2 2.9 7.0 N/A
Signal Attenuation(dB): 0.9 2.3 N/A N/A 2.3 6.6 N/A
Noise Margin(dB): 14.5 9.3 N/A N/A N/A N/A N/A
Total FECS: 0 0
Total ES: 0 0
Total SES: 0 0
Total LOSS: 0 0
Total UAS: 0 0
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0
Bit swap: 1 0
 
 
Full inits: 33
Failed full inits: 0
Short inits: 0
Failed short inits: 0
 
 
Firmware Source File Name (version)
-------- ------ -------------------
VDSL embedded VDSL_LINUX_DEV_01212008 (1)
 
 
Modem FW Version: 100426_1053-4.02L.03.A2pv6C030f.d22j
Modem PHY Version: A2pv6C030f.d22j
 
 
 
DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 84999 0 48968
Previous Speed: 0 24184 0 1047
Reed-Solomon EC: 0 0 0 0
CRC Errors: 0 0 0 0
Header Errors: 0 0 0 0
Interleave (ms): 0.00 6.00 0.00 0.00
Actual INP: 0.00 0.00 0.00 0.00
 
 
Training Log : Stopped
Training Log Filename : flash:vdsllog.bin
 
 
Router#
 

VDSL の CPE からピアへの接続の確認

ピアに ping を発行し、CPE からピアへの構成が正しく設定されていることを確認します。

Router# ping 30.0.0.2 rep 20
 
Type escape sequence to abort.
Sending 20, 100-byte ICMP Echos to 30.0.0.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (20/20), round-trip min/avg/max = 20/22/28 ms
Router#

Over POTS VDSL2/ADSL マルチモード Annex A SKU の ADSL2/2+ Annex M モードのイネーブル化

Over POTS VDSL2/ADSL マルチ モード Annex A SKU で ADSL2/2+ Annex M モードをイネーブルにするには、次の手順を実行します。


) この機能には、Cisco IOS Release 15.2(1)T 以降が必要になります。



) Cisco 867VAE と 867VAE-K9 では、Cisco IOS Release 15.1(4)M2 または 15.2(2)T 以降がこの機能を使用する必要があります。


手順の概要

1. enable

2. configure terminal

3. controller vdsl 0

4. operating mode {adsl1 | adsl2 [ annex a | annex m ] | adsl2+ [ annex a | annex m ] | ansi | auto| vdsl2 }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトにパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

controller vdsl 0

VDSL コントローラのコンフィギュレーション モードを開始します。

ステップ 4

operating mode {adsl1 | adsl2 [ annex a | annex m ] | adsl2+ [ annex a | annex m ] | ansi | auto| vdsl2}

 

Router(config-controller)# operating mode adsl2+ annex m

 

asdl1:ITU G.992.1 Annex A のフルレート モードでの動作を設定します。

adsl2:ADSL2 動作モード(ITU G.992.3 Annex A、Annex L、Annex M)での動作を設定します。Annex 動作モードが選択されていない場合は、Annex A、Annex L、Annex M がイネーブルになります。最終的なモードは、DSL アクセス マルチプレクサ(DSLAM)でのネゴシエーションによって決まります。

adsl2+:ADSL2+ モード(ITU G.992.5 Annex A および AnnexM)での動作を設定します。Annex A 動作モードが選択されていない場合は、Annex と Annex M の両方がイネーブルになります。最終的なモードは、DSLAM とのネゴシエーションによって決まります。

ansi:ANSI フルレート モード(ANSI T1.413)でルータが動作するように設定します。

auto:デフォルト設定。DSLAM が、「使用上のガイドライン」に記載されている順序で自動的に DSL 動作モードを選択するようにルータを設定します。サポートされているすべてのモードがイネーブルになります。

vdsl2:ITU G.993.2 モードでの動作を設定します。

annex a, m:(任意)annex オプションが指定されていない場合、Annex A と Annex M の両方がイネーブルになります。最終的なモードは、デジタル加入者線アクセス マルチプレクサ(DSLAM)とのネゴシエーションによって決まります。

シームレス レート適応のイネーブル化

SRA をイネーブルにするには、次の手順を実行します。


) SRA モードはデフォルトでディセーブルです。



) SRA には Cisco IOS Release 15.2(1)T 以降が必要です。



) これらの機能は、現在のところ Cisco 866VAE、867VAE、866VAE-K9、または 867VAE-K9 では使用できません。


手順の概要

SRA は次の手順でイネーブルおよびディセーブルにできます。

1. enable

2. configure terminal

3. controller vdsl x/y/z

4. sra

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router# enable

特権 EXEC モードをイネーブルにします。

プロンプトにパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

controller vdsl x/y/z

 

Router(config)# controller vdsl 0/0/0

コントローラ コンフィギュレーション モードを開始します。グローバル コンフィギュレーション モードで、controller vdsl コマンドを使用します。このコマンドには、no 形式はありません。

x:ネットワーク モジュールを定義します。

y:スロット番号を定義します。

z:ポート番号を定義します。

ステップ 4

sra

 

router(config-controller)# sra

SRA モードをイネーブルにします。

SRA を無効にするには、コマンドの no 形式を使用します。

シームレス レート適応の例

次の例では、VDSL 回線の SRA をイネーブルします。

!
!
!
rotuer>enable
router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z
router(config)# controller vdsl 0
router(config-controller)# sra
router(config-controller)# end
router#
!
!
!

 

UBR+ の設定

UBR+ を設定するには、次の手順を実行します。


) Cisco IOS Release 15.2(1)T 以降のリリースでは、Cisco 886VA、887VA および 887VA-M ルータ上で UBR+ を実行する必要があります。



) これらの機能は、現在のところ Cisco 866VAE、867VAE、866VAE-K9、または 867VAE-K9 では使用できません。


手順の概要

1. enable

2. configure terminal

3. ubr+ output-pcr output-mcr [input-pcr] [input-mcr]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトにパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ubr+ output-pcr output-mcr [input-pcr] [input-mcr]

 

Router(config-if-vc)# ubr+ 10000 3000 9000 1000

未指定ビット レート(UBR)の Quality of Service(QoS)を設定し、ATM 相手先固定接続(PVC)、PVC 範囲、相手先選択接続(SVC)、仮想回線(VC)クラス、または VC バンドル メンバの出力ピーク セル レートと出力最小保証セル レートを指定します。

UBR+ パラメータを削除するには、このコマンドの no 形式を使用します。

output-pcr:kbps 単位の出力ピーク セル レート(PCR)。

 

output-mcr:Kbps 単位の出力最小保証セル レート。

 

input-pcr:(SVC の場合だけはオプション)kbps 単位の入力 PCR。この値が省略された場合は、input-pcr は、output-pcr と等しくなります。

 

input-mcr:(SVC の場合だけはオプション)kbps 単位の入力最小保証セル レート。この値が省略された場合は、input-mcr は、output-mcr と等しくなります。

UBR+ の例

次に、DSL ライン上に UBR+ PVC を設定する例を示します。

interface atm 0/0
pvc 4/100
ubr+ 2304 2304

次の例では、ATM PVC の output-pcr 引数に 100,000 kbps を、output-mcr 引数に 3,000 kbps を指定しています。

pvc 1/32
ubr+ 100000 3000

次の例では、ATM SVC の output-pcr、output-mcr、input-pcr、および input-mcr 引数に、それぞれ、10,000 kbps、3,000 kbps、9,000 kbps、および、1,000 kbps を指定しています。

svc lion nsap 47.0091.81.000000.0040.0B0A.2501.ABC1.3333.3333.05
ubr+ 10000 3000 9000 1000

 

トラブルシューティング

Cisco 886VA および 887VA のトラフィックを確認する新しいコマンドはありません。便利なコマンドとして、次の show コマンドが挙げられます。

show interface Ethernet0

show interface ATM0

show interface summary

show controller vdsl 0

show controller atm0

show controller vdsl 0 datapath

show atm pvc

また、「 Cisco 860, Cisco 880, and Cisco 890 Series Integrated Services Routers Software Configuration Guide, Troubleshooting 」も役に立ちます。

CLI を使用したトレーニング ログの設定

Cisco 866VAE、Cisco 867VAE、Cisco 866VAE-K9、および Cisco 867VAE-K9 ISR で debug vdsl 0 training log を使用してトレーニング ログの取得をを開始すると、トレーニング ログファイルが開きます。生成されたメッセージがローカルにバッファされ、間隔あたり 5k バイトのトレーニング ログファイルに書き込まれます。トレーニング ログの取得機能をサポートする以前のソフトウェア バージョンと同様に、メッセージはすべて一度に書き込まれるわけではありません。


) Cisco 866VAE、Cisco 867VAE、Cisco 866VAE-K9、および Cisco 867VAE-K9 ISR の最大ログ容量は 8MB(約 1 時間)です。このため、全体のログ収集が 8MB を超えると、ログの取得が自動的に終了します。



) Cisco 866VAE、Cisco 867VAE、Cisco 866VAE-K9、および Cisco 867VAE-K9 ISR は、継続的なトレーニング ログの自動停止機能をサポートしていません。


トレーニング ログの取得

デフォルトでは、トレーニング ログは flash:vdsllog.bin に保存されます。

トレーニング ログの取得を開始するには、debug vdsl 0 training log コマンドを使用します。

Router# debug vdsl 0 training log
Router#
 

次の確認が表示されます。

Training log generation started for VDSL 0
 

トレーニング ログの取得の停止

トレーニング ログの取得を停止するには、no debug vdsl 0 training log コマンドを使用します。

Router# no debug vdsl 0 training log
Router#
 

次の確認が表示されます。

Training Log file for VDSL written to flash:vdsllog.bin
 

トレーニング ログのステータスおよびファイルの場所の表示

トレーニング ログのステータスおよびファイルの場所を表示するには、show controller vdsl 0 コマンドを使用します。

Router# show controller vdsl 0
Router#
 

次の確認が表示されます。

Controller VDSL 0 is UP
 
Daemon Status: NA
 
XTU-R (DS) XTU-C (US)
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0x938C
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' 'BDCM'
Modem Vendor Specific: 0x4602 0x938C
Modem Vendor Country: 0xB500 0xB500
Serial Number Near: GMH1049001M 867VAE-K 15.1(20110
Serial Number Far:
Modem Version Near: 15.1(20110422:230431) [suguraja
Modem Version Far: 0x938C
 
Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.992.5 (ADSL2+) Annex A
TC Mode: ATM
Selftest Result: 0x00
DELT configuration: disabled
DELT state: not running
Trellis: ON ON
Line Attenuation: 0.0 dB 0.0 dB
Signal Attenuation: 0.0 dB 0.0 dB
Noise Margin: 16.0 dB 14.6 dB
Attainable Rate: 28516 kbits/s 1222 kbits/s
Actual Power: 7.0 dBm 12.4 dBm
Total FECS: 3 0
Total ES: 0 0
Total SES: 0 0
Total LOSS: 0 0
Total UAS: 147 147
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0
Bit swap: 0 0
 
Full inits: 1
Failed full inits: 0
Short inits: 0
Failed short inits: 0
 
Firmware Source File Name (version)
-------- ------ -------------------
VDSL embedded (0)
 
Modem FW Version: 23a
Modem PHY Version: A2pv6C032b.d23a
 
 
DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 24543 0 1020
Previous Speed: 0 0 0 0
Total Cells: 0 87837567 0 3652502
User Cells: 0 0 0 0
Reed-Solomon EC: 0 3 0 0
CRC Errors: 0 0 0 0
Header Errors: 0 0 0 0
Interleave (ms): 0.00 15.00 0.00 3.76
Actual INP: 0.00 57.00 0.00 0.50
 
Training Log : Stopped
Training Log Filename : flash:vdsllog.bin

ATM モードでの G.SHDSL WAN インターフェイスの設定

Cisco 888 ISR で G.SHDSL を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. controller dsl slot/port

2. mode atm

3. line-term cpe

4. line-mode 4 wire standard

5. line-rate { auto | rate }

6. interface atm interface-number

7. ip-address ip-address

8. load-interval seconds

9. no atm ilmi-keepalive [ seconds ]

10. pvc [ name ] vpi/vci

11. protocol protocol protocol-address broadcast

12. encapsulation encapsulation-type

手順の詳細

 

コマンド
目的

ステップ 1

controller dsl slot/port

例:

Router(config)# controller dsl 0

コントローラのコンフィギュレーション モードを開始し、コントローラ番号を入力します。

ステップ 2

mode atm

例:

Router(config-ctrl)# mode atm

ATM カプセル化をイネーブルにし、論理 ATM インターフェイス 0 を作成します。

ステップ 3

line-term cpe

例:

Router(config-ctrl)# line-term cpe

CPE をイネーブルにします。

ステップ 4

line-mode 4 wire standard

例:

Router(config-ctrl)# line-mode 4 wire standard

4 線式動作をイネーブルにします。

ステップ 5

line-rate { auto | rate }

例:

Router(config-ctrl)# line-rate 4608

SHDSL ポートの DSL ライン レートを指定します。範囲は 192 ~ 2312 kbps です。デフォルトは、auto(SHDSL ポートおよび DSLAM 間でネゴシエートされます)です。

(注) 逆側の DSL アップリンクで設定されている DSL ライン レートが異なる場合、実際の DSL ライン レートは、常に、低い方のレートになります。

(注) 最大ピーク セル レートは、回線レートよりも 8 Kbps 低くなります。

ステップ 6

interface atm interface-number

例:

Router(config-ctrl)# interface atm0

インターフェイス ATM 0 の ATM コンフィギュレーション モードを開始します。

ステップ 7

ip-address ip-address

例:

Router(config-ctrl)# ip-address IP-address

DSL ATM インターフェイスに IP アドレスを割り当てます。

ステップ 8

load-interval seconds

例:

Router(config-ctrl)# load-interval 3

負荷の間隔値を割り当てます。

ステップ 9

no atm ilmi-keepalive [ seconds ]

例:

Router(config-ctrl)# no atm ilmi-keepalive0

統合ローカル管理インターフェイス(ILMI)キープアライブをディセーブルにします。

秒数を指定せずに ILMI キープアライブをイネーブルにした場合、デフォルトで、間隔は 3 秒になります。

ステップ 10

pvc [ name ] vpi/vci

例:

Router(config-ctrl)# pvc 0/35

atm-virtual-circuit(interface-atm-vc)コンフィギュレーション モードを開始し、名前(任意)および VPI/VCI 番号を割り当て、新しい ATM PVC を設定します。

デフォルトのトラフィック シェーピングは UBR、デフォルトのカプセル化は AAL5+LLC/SNAP です。

ステップ 11

protocol protocol protocol-address broadcast

例:

Router(config-ctrl)# protocol ip 10.10.10.2 broadcast

IP 接続をイネーブルにし、VC のポイントツーポイント IP アドレスを作成します。

ステップ 12

encapsulation [ encapsulation-type]

例:

Router(config-ctrl)# encapsulation aal5snap

ATM アダプテーション層(AAL)とカプセル化タイプを設定します。

aal2 キーワードを AAL2 に使用します。

aal5ciscoppp キーワードを Cisco PPP over AAL5 に使用します。

aal5mux キーワードを AAL5+MUX に使用します。

aal5nlpid キーワードを AAL5+NLPID に使用します。

aal5snap キーワードを AAL5+LLC/SNAP(デフォルト)に使用します。

次の設定例は、4 線式標準 G.SHDSL 設定を示しています。

!
controller DSL 0
mode atm
line-term cpe
line-mode 4-wire standard
dsl-mode shdsl symmetric annex B
line-rate 4608
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
!
interface ATM0
ip address 10.10.10.1 255.255.255.0
no atm ilmi-keepalive
pvc 0/35
protocol ip 10.10.10.2 broadcast
encapsulation aal5snap
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
shutdown
!
interface Vlan1
ip address 2.15.15.26 255.255.255.0
!
ip forward-protocol nd
ip route 223.255.254.254 255.255.255.255 Vlan1
no ip http server
no ip http secure-server
!
 

設定の確認

ルータが正しく設定されているかどうかを確認するには、show running コマンドを入力して、コントローラ DSL およびインターフェイス ATM0 パラメータを調べます。

Router# show running
Building configuration...
 
Current configuration : 1298 bytes
!
.......
 
!
controller DSL 0
mode atm
line-term cpe
line-mode 4-wire standard
dsl-mode shdsl symmetric annex B
line-rate 4608
!
!
interface ATM0
ip address 10.10.10.1 255.255.255.0
no atm ilmi-keepalive
pvc 0/31
protocol ip 10.10.10.5 broadcast
encapsulation aal5snap
!

 

 

EFM モードでの G.SHDSL WAN インターフェイスの設定

Cisco 888E ISR で G.SHDSL を設定するには、次の URL で『 Configuring Cisco G.SHDSL EFM HWICs in Cisco Routers 』を参照してください。

http://www.cisco.com/en/US/docs/routers/access/interfaces/software/feature/guide/GSHDSL_EFM_HWICS.html

セル ワイヤレス WAN インターフェイスの設定

Cisco 880 シリーズ ISR は、Global System for Mobile Communications(GSM)および符号分割多重接続(CDMA)ネットワークを介して使用する、第 3 世代(3G)ワイヤレス インターフェイスを提供します。このインターフェイスは、34-mm PCMCIA スロットです。

その主な用途は、重要なデータ アプリケーションのバックアップ データ リンクとしての WAN 接続です。ただし、3G ワイヤレス インターフェイスは、ルータのプライマリ WAN 接続としても機能できます。

3G セル ワイヤレス インターフェイスを設定するには、次の注意事項および手順に従ってください。

「3G ワイヤレス インターフェイスの設定に関する要件」

「セル ワイヤレス インターフェイスの設定に関する制約事項」

「データ アカウントのプロビジョニング」

「セル インターフェイスの設定」

「DDR の設定」

「データ専用転送モード(DDTM)の設定」

「セル ワイヤレス インターフェイスの設定例」

3G ワイヤレス インターフェイスの設定に関する要件

次に、3G ワイヤレス インターフェイスの設定に関する要件を示します。

通信事業者のワイヤレス サービスが必要です。また、ルータが物理的に配置されるネットワーク カバレッジも必要です。サポートされている通信事業者の一覧については、次の URL のデータ シートを参照してください。

http://www.cisco.com/en/US/prod/routers/networking_solutions_products_genericcontent0900aecd80601f7e.html

ワイヤレス サービス プロバイダーとのサービス プランに契約し、そのサービス プロバイダーから SIM カード(GSM モデムだけ)を取得する必要があります。

表 3-2 の説明に従い、信号強度について LED をチェックする必要があります。

Cisco IOS リリース 12.4(15)XZ 以降の Cisco IOS ソフトウェアを理解する必要があります。Cisco 3G ワイヤレス サポートについては、Cisco IOS のマニュアルを参照してください。

GSM データ プロファイルを設定するには、サービス プロバイダーから次の情報を取得する必要があります。

ユーザ名

パスワード

アクセス ポイント ネーム(APN)

手動でアクティブにするために CDMA データ プロファイルを設定するには、サービス プロバイダーから次の情報を取得する必要があります。

Master Subsidy Lock(MSL)番号

Mobile Directory Number(MDN)

Mobile Station Identifier(MSID)

Electronic Serial Number (ESN)

 

表 3-2 前面パネル LED の信号強度表示

LED
LED カラー
信号強度

P3G RSSI1

オレンジ

使用できるサービスがなく、RSSI が検出されません

グリーンの点灯

高 RSSI(-69 dBm 以上)

グリーンが素早く(16 Hz)点滅

中 RSSI(-89 ~ -70 dBm)

グリーンがゆっくり(1 Hz)点滅

低~中 RSSI(-99 ~ -90 dBm)、信頼できる接続の最小レベル

Off

低 RSSI(-100 dBm 未満)

1.3G RSSI = 3G 受信信号強度表示

セル ワイヤレス インターフェイスの設定に関する制約事項

Cisco 3G ワイヤレス インターフェイスの設定には、次の制約事項があります。

データ接続は、3G ワイヤレス インターフェイスだけから行うことができます。リモート ダイヤルインはサポートされていません。

ワイヤレス通信共通の性質により、スループットは、ネットワークでのアクティブ ユーザの数や輻輳の量により異なります。

セル ネットワークの遅延は、優先ネットワークの場合よりも大きくなります。遅延レートは、テクノロジーおよび通信事業者に左右されます。ネットワーク輻輳が発生している場合、遅延が大きくなることがあります。

VoIP は現在サポートされていません。

通信事業者のサービス条件に含まれるいずれの制約事項も Cisco 3G ワイヤレス インターフェイスに適用されます。

Cisco 880G ISR は、3G モデムの活性挿抜(OIR)をサポートしません。モデムをモデム タイプが同じ別のモデムと交換するには、モデムを交換する前に、Cisco CLI を使用して、セル インターフェイスで shutdown コマンドを入力します。

3G モデルが取り外されても、show interface cellular 0、show run および show version コマンドの出力には、セル インターフェイスに関する情報が表示されます。show interface コマンドを使用すると次のメッセージが表示され、他のすべての show コマンドを使用すると空の出力が表示されます。

3G Modem not inserted
 

3G モデムが取り外されている状態でセル インターフェイスを設定できます。ただし、3G モデムが取り付けられるまで有効になりません。次のメッセージは、モデムが取り付けられていない状態でセル インターフェイスを設定しようとした場合に表示されます。

Router(config)# interface cellular 0
Warning: 3G Modem is not inserted
Configuration will not be effective until modem is inserted
 

取り外されたモデムとは別のタイプのモデムを取り付けた場合は、設定を変更して、システムをリロードしなければなりません。

データ アカウントのプロビジョニング


) モデムをプロビジョニングするには、サービス プロバイダーとのアクティブ ワイヤレス アカウントが必要です。SIM カードを GSM 3G ワイヤレス カードに挿入する必要があります。


データ アカウントをプロビジョニングするには、次の手順を実行します。

「信号の強さとサービスの可用性」

「GSM モデル データ プロファイルの設定」

「CDMA モデム アクティベーションおよびプロビジョニング」

信号の強さとサービスの可用性

モデムの信号の強さとサービスの可用性を確認するには、特権 EXEC モードで次のコマンドを使用します。

手順の概要

1. show cellular 0 network

2. show cellular 0 hardware

3. show cellular 0 connection

4. show cellular 0 radio

5. show cellular 0 profile

6. show cellular 0 security

7. show cellular 0 all

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

show cellular 0 network

 

Router# show cellular 0 network

通信事業者ネットワーク、セル サイト、および使用可能なサービスに関する情報を表示します。

ステップ 2

show cellular 0 hardware

 
Router# show cellular 0 hardware

セルラー モデム ハードウェア情報を表示します。

ステップ 3

show cellular 0 connection

 
Router# show cellular 0 connection

現在アクティブな接続状態およびデータの統計情報を表示します。

ステップ 4

show cellular 0 radio

 

Router# show cellular 0 radio

無線信号の強さを示します。

(注) 安定した信頼性の高い接続には、RSSI が -90 dBm を超える必要があります。

ステップ 5

show cellular 0 profile

 

Router# show cellular 0 profile

作成されたモデム データ プロファイルに関する情報を示します。

ステップ 6

show cellular 0 security

 

Router# show cellular 0 security

SIM およびモデムのロック ステータスに関するセキュリティ情報を示します。

ステップ 7

show cellular 0 all

 

Router# show cellular 0 all

モデムに関する統合情報を示します。たとえば、作成されたプロファイル、ラジオ信号強度、ネットワーク セキュリティなどです。

GSM モデル データ プロファイルの設定

新しいモデム データ プロファイルを作成するには、特権 EXEC モードで cellular 0 gsm profile create <profile number> <apn> <authentication> <username> <password> コマンドを入力します。コマンド パラメータの詳細については、 表 3-3 を参照してください。

Router# cellular 0 gsm profile create 3 apn.com chap GSM GSMPassword
 

表 3-3 は、モデム データ プロファイルのパラメータのリストです。

 

表 3-3 モデム データ プロファイルのパラメータ

profile number

作成するプロファイルの番号。最大 16 個のプロファイルを作成できます。

apn

アクセス ポイント名。この情報はサービス プロバイダーから取得する必要があります。

authentication

CHAP、PAP などの認証タイプ。

username

サービス プロバイダーから提供されるユーザ名。

password

サービス プロバイダーから提供されるパスワード。

CDMA モデム アクティベーションおよびプロビジョニング

アクティベーション手順は、通信事業者により異なります。通信事業者に問い合わせて、次のいずれかの手順を実行してください。

手動によるアクティベーション

電波によるサービス提供(OTASP)を使用したアクティベーション

表 3-4 は、さまざまなワイヤレス通信事業者によりサポートされているアクティベーションおよびプロビジョニング プロセスのリストです。

表 3-4 CDMA モデム アクティベーションおよびプロビジョニング

アクティベーションおよびプロビジョニング プロセス
通信事業者

MDN、MSID、MSL を使用した手動によるアクティベーション

Sprint

OTASP2 アクティベーション

Verizon Wireless

データ プロファイル リフレッシュ用 IOTA3

Sprint

2.OTASP = Over the Air Service Provisioning(電波によるサービス提供)

3.IOTA = Internet Over the Air(インターネット地上波)

手動によるアクティベーション


) この手順を開始する前に、有効な Mobile Directory Numner(MDN)、Mobile Subsidy Lock(MSL)、および Mobile Station Identifier(MSID)情報を通信事業者から取得しておく必要があります。


モデム プロファイルを手動で設定するには、EXEC モードから、次のコマンドを使用します。

cellular 0 cdma activate manual mdn msid sid nid msl

アクティブ化される前に、モデル データ プロファイルのプロビジョニングが、Internet Over the Air(IOTA; インターネット地上波)プロセスを介して行われます。IOTA プロセスは、cellular cdma activate manual コマンドを使用すると自動的に開始されます。

次に、このコマンドの出力例を示します。

router# cellular 0 cdma activate manual 1234567890 1234567890 1234 12 12345
NAM 0 will be configured and will become Active
Modem will be activated with following Parameters
MDN :1234567890; MSID :1234567890; SID :1234; NID 12:
Checking Current Activation Status
Modem activation status: Not Activated
Begin Activation
Account activation - Step 1 of 5
Account activation - Step 2 of 5
Account activation - Step 3 of 5
Account activation - Step 4 of 5
Account activation - Step 5 of 5
Secure Commit Result: Succeed
Done Configuring - Resetting the modem
The activation of the account is Complete
Waiting for modem to be ready to start IOTA
Beginning IOTA
router#
*Feb 6 23:29:08.459: IOTA Status Message Received. Event: IOTA Start, Result: SUCCESS
*Feb 6 23:29:08.459: Please wait till IOTA END message is received
*Feb 6 23:29:08.459: It can take up to 5 minutes
*Feb 6 23:29:27.951: OTA State = SPL unlock, Result = Success
*Feb 6 23:29:32.319: OTA State = Parameters committed to NVRAM, Result = Success
*Feb 6 23:29:40.999: Over the air provisioning complete; Result:Success
*Feb 6 23:29:41.679: IOTA Status Message Received. Event: IOTA End, Result: SUCCESS

 

IOTA Start および IOTA End には、結果の出力として「SUCCESS」と示されていなければなりません。エラー メッセージが表示された場合、cellular cdma activate iota コマンドを使用して個別に IOTA を実行できます。

通信事業者により、データ プロファイルの定期的なリフレッシュが要求されることがあります。データ プロファイルをリフレッシュするには、次のコマンドを使用します。

cellular cdma activate iota

Over-the-Air Service Provisioning を使用したアクティベーション

電波によるサービス提供(OTASP)のプロビジョニングおよびアクティベーションを行うには、EXEC モードから次のコマンドを使用します。

router # cellular 0 cdma activate otasp phone_number


) このコマンドで使用する電話番号は、通信事業者から取得する必要があります。標準の OTASP 発番号は *22899 です。


次に、このコマンドの出力例を示します。

router# cellular 0 cdma activate otasp *22899
Beginning OTASP activation
OTASP number is *22899
steelers_c881G#
OTA State = SPL unlock, Result = Success
router#
OTA State = PRL downloaded, Result = Success
OTA State = Profile downloaded, Result = Success
OTA State = MDN downloaded, Result = Success
OTA State = Parameters committed to NVRAM, Result = Success
Over the air provisioning complete; Result:Success

セル インターフェイスの設定

セル インターフェイスを設定するには、特権 EXEC モードから、次のコマンドを入力します。

手順の概要

1. configure terminal

2. interface cellular 0

3. encapsulation ppp

4. ppp chap hostname host

5. ppp chap password 0 password

6. asynchronous mode interactive

7. ip address negotiated


) この手順で使用する PPP Challenge Handshake Authentication Protocol(CHAP)認証パラメータは、通信事業者により提供され、GSM プロファイル下だけで設定されているユーザ名およびパスワードと同じでなければなりません。CDMA では、ユーザ名またはパスワードは必要ありません。


手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

端末からグローバル コンフィギュレーション モードを開始します。

ステップ 2

interface cellular 0

 

Router (config)# interface cellular 0

セルラー インターフェイスを指定します。

ステップ 3

encapsulation ppp

 

Router (config-if)# encapsulation ppp

専用非同期モード用または Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)用のインターフェイスの PPP カプセル化を指定します。

ステップ 4

ppp chap hostname host

 

Router (config-if)# ppp chap hostname host@wwan.ccs

インターフェイス固有の Challenge Handshake Authentication Protocol(CHAP)ホスト名を定義します。これは、通信事業者から提供されたユーザ名に一致する必要があります。GSM だけに適用されます。

ステップ 5

ppp chap password 0 password

 

Router (config-if)# ppp chap password 0 cisco

インターフェイス固有の CHAP パスワードを指定します。これは、通信事業者から提供されたパスワードに一致する必要があります。

ステップ 6

asynchronous mode interactive

 

Router (config-if)# asynchronous mode interactive

ラインを専用非同期ネットワーク モードから対話モードに戻して、特権 EXEC モードで、slip および ppp コマンドをイネーブルにします。

ステップ 7

ip address negotiated

 

Router (config-if)# ip address negotiated

特定のインターフェイスの IP アドレスが PPP および IPCP アドレス ネゴシエーションを介して取得されることを指定します。


セル インターフェイスでスタティック IP アドレスが必要な場合、アドレスは、ip address negotiated として設定できます。Internet Protocol Control Protocol(IPCP; インターネット プロトコル コントロール プロトコル)を介して、ネットワークにより、正しいスタティック IP アドレスがデバイスに割り当てられるようになります。トンネル インターフェイスが ip address unnumbered cellular interface コマンドで設定されている場合、実際のスタティック IP アドレスは ip address negotiated でなく、セル インターフェイス下で設定されなければなりません。セルラー インターフェイスの例については、「基本セルラー インターフェイスの設定」を参照してください。


DDR の設定

セルラー インターフェイスのダイヤル オン デマンド ルーティング(DDR)を設定するには、次の手順を実行します。

手順の概要

1. configure terminal

2. interface cellular 0

3. dialer in-band

4. dialer idle-timeout seconds

5. dialer string string

6. dialer group number

7. exit

8. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

9. ip access-list access list number permit ip source address

10. line 3

11. script dialer regexp

12. exit

13. chat-script script name "" "ATDT*99*profile number#" TIMEOUT timeout value CONNECT
または
chat-script script name "" "ATDT*777* profile number #" TIMEOUT timeout value CONNECT

14. interface cellular 0

15. dialer string string

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface cellular 0

 

Router (config)# interface cellular 0

セルラー インターフェイスを指定します。

ステップ 3

dialer in-band

 

Router (config-if)# dialer in-band

DDR をイネーブルにし、インバンド ダイヤリングに指定されたシリアル インターフェイスを設定します。

ステップ 4

dialer idle-timeout seconds

 

Router (config-if)# dialer idle-timeout 30

回線切断後のアイドル時間を秒単位で指定します。

ステップ 5

dialer string string

 

Router (config-if)# dialer string gsm

ダイヤルする番号または文字列を指定します。チャット スクリプトの名前をここで使用します。

ステップ 6

dialer-group number

 

Router (config-if)# dialer-group 1

特定のインターフェイスが属するダイヤラ アクセス グループの番号を指定します。

ステップ 7

exit

 

Router (config-if)# exit

グローバル コンフィギュレーション モードを開始します。

ステップ 8

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

 

Router (config)# dialer-list 1 protocol ip list 1

関係するトラフィックのダイヤラ リストを作成し、プロトコル全体に対してアクセスを許可します。

ステップ 9

ip access-list access list number permit ip source address

 

Router (config)# ip access list 1 permit any

関係するトラフィックを定義します。

ステップ 10

line 3

 

Router (config-line)# line 3

ライン コンフィギュレーション モードを指定します。これは常に 3 です。

ステップ 11

script dialer regexp

 

Router (config-line)# script-dialer gsm

デフォルト モデムのチャット スクリプトを指定します。

ステップ 12

exit

 

Router (config-line)# exit

ライン コンフィギュレーション モードを終了します。

ステップ 13

GSM の場合:

chat-script script name "" "ATDT*99* profile number#" TIMEOUT timeout value CONNECT

CDMA の場合:

chat-script script name "" "ATDT*777* profile number #" TIMEOUT timeout value CONNECT

 

Router (config)# chat-script gsm "" "ATDT*98*2#" TIMEOUT 60 "CONNECT“

GSM の回線を設定します。


 

CDMA の回線を設定します。

ダイヤラが開始されるときの Attention Dial Tone(ATDT)コマンドを定義します。

ステップ 14

interface cellular 0

 

Router (config)# interface cellular 0

セルラー インターフェイスを指定します。

ステップ 15

dialer string string

 

Router (config)# dialer string gsm

ダイヤラ スクリプトを指定します(chat script コマンドを使用して定義されます)。

データ専用転送モード(DDTM)の設定

データ専用転送モード(DDTM)がディセーブルの場合、CDMA モデムでは、データ送信は、着信音声コールによって中断されます。DDTM モードをイネーブルにして、モデムが着信音声コールを無視するように設定できます。

CDMA モデムの DDTM をイネーブルにするには、コンフィギュレーション モードで cdma ddtm コマンドを使用します。

このコマンドは、デフォルトでイネーブルになっています。no cdma ddtm コマンドを使用して、この機能をディセーブルにできます。


) DDTM がイネーブルの場合、音声コールだけが MC5728v モデムに対してブロックされます。AC597E、MC5725 および MC5727 では、着信 SMS メッセージがブロックされます。


セル ワイヤレス インターフェイスの設定例

ここでは、次の設定例について説明します。

「基本セルラー インターフェイスの設定」

「セルラー インターフェイスを介するトンネルの設定」

基本セルラー インターフェイスの設定

次に、プライマリ WAN 接続として使用される gsm セル インターフェイスを設定する例を示します。これは、デフォルト ルートとして設定されます。

chat-script gsm "" "ATDT*98*2#" TIMEOUT 60 "CONNECT“
 
!
interface Cellular0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string gsm
dialer-group 1
async mode interactive
ppp chap hostname cisco@wwan.ccs
ppp chap password 0 cisco
ppp ipcp dns request
!
 
ip route 0.0.0.0 0.0.0.0 Cellular0
!
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 3
exec-timeout 0 0
script dialer gsm
login
modem InOut
 

次に、プライマリとして使用される cdma セル インターフェイスを設定する例を示します。これは、デフォルト ルートとして設定されます。

chat-script cdma "" "ATDT#777" TIMEOUT 60 "CONNECT“
 
!
interface Cellular0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string cdma
dialer-group 1
async mode interactive
ppp chap password 0 cisco
!
 
ip route 0.0.0.0 0.0.0.0 Cellular0
!
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 3
exec-timeout 0 0
script dialer cdma
login
modem InOut
 

セルラー インターフェイスを介するトンネルの設定

次に、トンネル インターフェイスが ip address unnumbered < cellular interface > コマンドで設定される場合のスタティック IP アドレスを設定する例を示します。

interface Tunnel2
ip unnumbered Cellular0
tunnel source Cellular0
tunnel destination 128.107.248.254
 
interface Cellular0
bandwidth receive 1400000
ip address 23.23.0.1 255.255.0.0
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 0
dialer string dial<carrier>
dialer-group 1
async mode interactive
no ppp lcp fast-start
ppp chap hostname <hostname> *** gsm only ***
ppp chap password 0 <password>
ppp ipcp dns request
! traffic of interest through the tunnel/cellular interface
ip route 10.10.0.0 255.255.0.0 Tunnel2
 

Cisco 860VAE ISR での WAN モードの設定

Cisco 866VAE、Cisco 867VAE、Cisco 866VAE-K9、および Cisco 867VAE-K9 ルータは、WAN リンクとして GE インターフェイスまたは DSL インターフェイスを使用するように設定できます。DSL は、Cisco 866VAE、Cisco 867VAE、Cisco 866VAE-K9、および Cisco 867VAE-K9 ルータ起動時のデフォルト WAN インターフェイスです。

ルータの起動後は、wan mode コマンドを使用して目的の WAN インターフェイスを選択できます。WAN モードがイーサネットとして設定されている場合、ATM0 と Ethernet0 インターフェイスの両方がシャットダウン状態になります。DSL インターフェイスのいずれかで no shutdown コマンドを入力しても、「 WAN interface is Ethernet 」というメッセージが表示されて拒否されます。同様に、WAN モードが DSL の場合、GE WAN インターフェイスはシャットダウン状態となり、 no shutdown コマンドを入力しても「 WAN interface is DSL 」というメッセージが表示されて拒否されます。


) ルータは、GE および DSL インターフェイスを同時にイネーブルにすることをサポートしていません。


DSL から Ethernet インターフェイス、またはその逆に切り替えるには、 wan mode dsl | ethernet コマンドを使用します。

ここでは、次の内容について説明します。

「WAN モードのイネーブル化」

「WAN モード設定の表示」

WAN モードのイネーブル化

WAN モードを選択してイネーブルにするには、次の手順を実行します。

手順の概要

1. enable

2. show running-configuration

3. wan mode {dsl | ethernet}

4. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトにパスワードを入力します。

ステップ 2

show running-configuration

 

Router# show running-configuration

起動時にデフォルト エントリを表示します。

ステップ 3

wan mode {dsl | ethernet}

例:

Router(config)# wan mode dsl

目的の WAN モードを選択します。

ステップ 4

exit

例:

Router(config)# exit

Router#

コンフィギュレーション モードを終了し、ルータを特権 EXEC モードに戻します。

WAN モード設定の表示

初期設定を表示するには、 show running-config コマンドを使用します(次の Cisco 866VAE ルータの例を参照してください)。


) Cisco ルータは、初期設定の完了後の起動シーケンス中に WAN モードを表示します。


Router#show running-config
Building configuration...
 
Current configuration : 1195 bytes
!
! Last configuration change at 13:27:25 UTC Wed Feb 24 2010
version 15.2
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
enable password lab
!
no aaa new-model
wan mode ethernet
no ipv6 cef
!
!
!
!
!
ip cef
!
crypto pki token default removal timeout 0
!
!
!
!
!
!
controller VDSL 0
shutdown
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
ip address 202.0.0.1 255.255.255.0
pvc 0/202
!
!
interface Ethernet0
no ip address
shutdown
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface GigabitEthernet0
ip address 1.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 60000 1000
!
end
 
Router#

ファスト イーサネット LAN インターフェイスの設定

ルータのファスト イーサネット LAN インターフェイスは、デフォルト VLAN の一部として自動的に設定され、個別のアドレスによる設定は行われません。アクセスは VLAN を通じて提供されます。他の VLAN にインターフェイスを割り当てることもできます。VLAN 作成の詳細については、「イーサネット スイッチの設定」を参照してください。

無線 LAN インターフェイスの設定

Cisco 860、Cisco 880、および Cisco 890 シリーズ無線ルータには、ワイヤレス LAN 接続用に 802.11n モジュールが内蔵されています。このルータは、ローカル インフラストラクチャのアクセス ポイントとして機能できます。ワイヤレス接続の設定の詳細については、「ワイヤレス デバイスの基本設定」を参照してください。

ループバック インターフェイスの設定

ループバック インターフェイスは、スタティック IP アドレスのプレースホルダーとして機能し、デフォルトのルーティング情報を提供します。

ループバック インターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. interface type number

2. ip address ip-address mask

3. exit

手順の詳細

 

コマンド
目的

ステップ 1

interface loopback number

例:

Router(config)# interface Loopback 0
Router(config-if)#

ループバック インターフェイスのコンフィギュレーション モードを開始します。

number:ループ バック インターフェイスの番号。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 10.108.1.1 255.255.255.0

ループバック インターフェイスの IP アドレスとサブネット マスクを設定します。

ステップ 3

exit

例:

Router(config-if)# exit
Router(config)#

ループバック インターフェイスのコンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードに戻ります。

このコンフィギュレーション例のループバック インターフェイスは、仮想テンプレート インターフェイス上の NAT をサポートするために使用されています。この設定例は、スタティック IP アドレスとなる IP アドレス 200.200.100.1/24 を持つファスト イーサネット インターフェイスに設定されるループバック インターフェイスを示します。ループバック インターフェイスは、ネゴシエートされた IP アドレスを持つ virtual-template1 にポイントバックします。

!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
 

設定の確認

ループバック インターフェイスが正しく設定されたかどうかを確認するには、show interface loopback コマンドを入力します。次の例のような確認用の出力が表示されます。

Router# show interface loopback 0
Loopback 0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 

ping を実行することによって、ループバック インターフェイスを確認する方法もあります。

Router# ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 
 

スタティック ルートの設定

スタティック ルートは、ネットワークを介した固定ルーティング パスを提供します。これらは、ルータ上で手動で設定されます。ネットワーク トポロジが変更された場合には、スタティック ルートを新しいルートに更新する必要があります。スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベート ルートです。

スタティック ルートを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

2. end

手順の詳細

 

コマンド
目的

ステップ 1

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 192.168.1.0 255.255.0.0 10.10.10.2

IP パケットのスタティック ルートを指定します。

このコマンドの詳細および設定可能なその他のパラメータについては、『 Cisco IOS IP Routing Protocols Command Reference 』を参照してください。

ステップ 2

end

例:

Router(config)# end
Router#

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

スタティック ルーティングの一般的な説明については、 「概要」 を参照してください。

次の設定例で、スタティック ルートは、ファスト イーサネット インターフェイスで宛先 IP アドレス 192.168.1.0 およびサブネット マスク 255.255.255.0 を持つすべての IP パケットを、IP アドレス 10.10.10.2 を持つ別のデバイスに送信します。具体的には、パケットが設定済みの PVC に送信されます。

「(default)」と記されているコマンドの入力は不要です。このコマンドは、 show running-config コマンドを使用すると、生成されたコンフィギュレーション ファイルに自動的に表示されます。

!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
 

設定の確認

スタティック ルーティングが正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「S」で表されるスタティック ルートを探します。

次のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0

ダイナミック ルートの設定

ダイナミック ルーティングでは、ネットワーク トラフィックまたはトポロジに基づいて、ネットワーク プロトコルがパスを自動調整します。ダイナミック ルーティングの変更は、ネットワーク上の他のルータにも反映されます。

Cisco ルータは、Routing Information Protocol(RIP; ルーティング情報プロトコル)または Enhanced Interior Gateway Routing Protocol(EIGRP)などの IP ルーティング プロトコルを使用して、動的にルートを学習します。いずれかのルーティング プロトコルをルータに設定できます。

「ルーティング情報プロトコルの設定」

「拡張インテリア ゲートウェイ ルーティング プロトコルの設定」

ルーティング情報プロトコルの設定

ルータに RIP ルーティング プロトコルを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. router rip

2. version { 1 | 2 }

3. network ip-address

4. no auto-summary

5. end

手順の詳細

 

コマンド
タスク

ステップ 1

router rip

例:

Router(config)# router rip
Router(config-router)#

ルータ コンフィギュレーション モードを開始します。続いて、ルータの RIP をイネーブルにします。

ステップ 2

version { 1 | 2 }

例:

Router(config-router)# version 2

RIP version 1 または 2 の使用を指定します。

ステップ 3

network ip-address

例:

Router(config-router)# network 192.168.1.1
Router(config-router)# network 10.10.7.1

直接接続しているネットワークの各アドレスを使用して、RIP を適用するネットワーク リストを指定します。

ステップ 4

no auto-summary

例:

Router(config-router)# no auto-summary

ネットワークレベル ルートへのサブネット ルートの自動サマライズをディセーブルにします。これにより、サブプレフィクス ルーティング情報がクラスフル ネットワーク境界を越えて送信されます。

ステップ 5

end

例:

Router(config-router)# end
Router#

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

RIP に関する一般情報については、 「RIP」 を参照してください。

次の設定例は、IP ネットワーク 10.0.0.0 および 192.168.1.0 でイネーブルにされる RIP version 2 を示します。

設定を表示するには、特権 EXEC モードで show running-config コマンドを使用します。

!
Router# show running-config
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
 

設定の確認

RIP が正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「R」で表される RIP ルートを探します。次の例のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0
 

拡張インテリア ゲートウェイ ルーティング プロトコルの設定

ルータに拡張インテリア ゲートウェイ ルーティング プロトコル(EIGRP)を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. router eigrp as-number

2. network ip-address

3. end

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-number

例:

Router(config)# router eigrp 109

ルータ コンフィギュレーション モードを開始します。続いて、ルータの EIGRP をイネーブルにします。Autonomous System(AS; 自律システム)番号は、他の EIGRP ルータへのルートを識別します。また、EIGRP 情報のタグ付けに使用されます。

ステップ 2

network ip-address

例:

Router(config)# network 192.145.1.0
Router(config)# network 10.10.12.115

EIGRP を適用するネットワークのリストを指定します(直接接続されているネットワークの IP アドレスを使用)。

ステップ 3

end

例:

Router(config-router)# end
Router#

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

EIGRP の概要については、 「EIGRP」 を参照してください。

次の設定例は、IP ネットワーク 192.145.1.0 および 10.10.12.115 でイネーブルにされる EIGRP ルーティング プロトコルを示します。EIGRP の AS 番号として、109 が割り当てられています。

設定を表示するには、特権 EXEC モードで開始し、 show running-config コマンドを使用します。

!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!
 

設定の確認

IP EIGRP が正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「D」で表される EIGRP ルートを探します。次のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0