Cisco 860、Cisco 880 および Cisco 890 シリーズ サービス統合型ルータ ソフトウェア コンフィギュレーション ガイド
DHCP および VLAN による LAN の設定
DHCP および VLAN による LAN の設定
発行日;2012/06/19 | 英語版ドキュメント(2011/11/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

DHCP および VLAN による LAN の設定

DHCP の設定

設定例

DHCP 設定の確認

VLAN の設定

VLAN へのスイッチ ポートの割り当て

VLAN コンフィギュレーションの確認

DHCP および VLAN による LAN の設定

Cisco 860 および Cisco 880 シリーズ サービス統合型ルータ(ISR)は、両方の物理 LAN および VLAN のクライアントをサポートします。各ルータは Dynamic Host Configuration Protocol(DHCP)を使用して、このようなネットワーク上にある各ノードに対して、IP 設定の自動割り当てをイネーブルにできます。

図 13-1 に、ルータおよび 2 つの VLAN を介して接続された 2 つの物理 LAN の一般的な構成例を示します。

図 13-1 Cisco ルータで DHCP が設定された物理および仮想 LAN

 

 

1

ファスト イーサネット LAN(複数のネットワーク デバイス)

2

インターネットに接続されたルータおよび DHCP サーバ(Cisco 860 および 880 シリーズ アクセス ルータ)

3

VLAN 1

4

VLAN 2

DHCP

DHCP は、RFC 2131 に説明されているように、アドレス割り当てにクライアント/サーバ モデルを採用しています。管理者は、Cisco 800 シリーズ ルータを DHCP サーバとして動作するように設定できます。この場合、IP アドレスの割り当てと他の TCP/IP 関連の設定情報をワーク ステーションに提供します。DHCP を使用すると、IP アドレスを各クライアントに手動で割り当てるという作業を省くことができます。

DHCP サーバの設定では、サーバのプロパティ、ポリシーおよび DHCP オプションを設定する必要があります。


) サーバのプロパティを変更する場合には、Network Registrar データベースからのコンフィギュレーション データでサーバを毎回リロードする必要があります。


VLAN

Cisco 860 および 880 シリーズ アクセス ルータは VLAN を設定できる 4 つのファスト イーサネット ポートをサポートします。

VLAN によって、ユーザの物理的な配置または LAN 接続に関係なく、ネットワークをユーザの論理グループに分割して、まとめることができます。

設定作業

次の作業を実行して、このネットワーク シナリオを設定します。

DHCP の設定

VLAN の設定


) この章の各手順では、ルータの基本機能、NAT による PPPoE または PPPoA をすでに設定していることを前提とします。これらの設定作業を実行していない場合は、使用しているルータに応じて「ルータの基本設定」「PPP over Ethernet と NAT の設定」、および「PPP over ATM と NAT の設定」を参照してください。


DHCP の設定

DHCP 用にルータを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. ip domain name name

2. ip name-server server-address1 [server-address2...server-address6]

3. ip dhcp excluded-address low-address [high-address]

4. ip dhcp pool name

5. network network-number [ mask | prefix-length ]

6. import all

7. default-router address [ address2 ... address8 ]

8. dns-server address [ address2 ... address8 ]

9. domain-name domain

10. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

ip domain name name

例:

Router(config)# ip domain name smallbiz.com
Router(config)#

未修飾のホスト名(ドット付き 10 進表記ドメイン名のない名前)を完成させるためにルータが使用する、デフォルトのドメインを特定します。

ステップ 2

ip name-server server-address1 [server-address2...server-address6]

例:

Router(config)# ip name-server 192.168.11.12
Router(config)#

名前およびアドレス解決に使用する 1 つ以上の Domain Name System(DNS; ドメイン ネーム システム)サーバのアドレスを指定します。

ステップ 3

ip dhcp excluded-address low-address [high-address]

例:

Router(config)# ip dhcp excluded-address 192.168.9.0

DHCP サーバが DHCP クライアントに割り当ててはいけない IP アドレスを指定します。

この例では、ルータのアドレスを除外します。

ステップ 4

ip dhcp pool name

例:

Router(config)# ip dhcp pool dpool1
Router(config-dhcp)#

ルータ上に DHCP アドレス プールを作成します。続いて、DHCP プール コンフィギュレーション モードを開始します。

name 引数は、ストリングまたは整数にすることができます。

ステップ 5

network network-number [ mask | prefix-length ]

例:

Router(config-dhcp)# network 10.10.0.0 255.255.255.0
Router(config-dhcp)#

DHCP アドレス プールのサブネット番号(IP)アドレスを定義します(任意でマスクを入力します)。

ステップ 6

import all

例:

Router(config-dhcp)# import all
Router(config-dhcp)#

ルータ データベースの DHCP 部分に DHCP オプション パラメータをインポートします。

ステップ 7

default-router address [ address2 ... address8 ]

例:

Router(config-dhcp)# default-router 10.10.10.10
Router(config-dhcp)#

DHCP クライアントのデフォルト ルータを最大 8 つまで指定します。

ステップ 8

dns-server address [ address2 ... address8 ]

例:

Router(config-dhcp)# dns-server 192.168.35.2
Router(config-dhcp)#

DHCP クライアントが使用できる DNS サーバを最大 8 つまで指定します。

ステップ 9

domain-name domain

例:

Router(config-dhcp)# domain-name cisco.com
Router(config-dhcp)#

DHCP クライアントのドメイン名を指定します。

ステップ 10

exit

例:

Router(config-dhcp)# exit
Router(config)#

DHCP コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

設定例

次の設定例は、この章で説明してきた DHCP 設定のコンフィギュレーション ファイルの一部を示します。

ip dhcp excluded-address 192.168.9.0
!
ip dhcp pool dpool1
import all
network 10.10.0.0 255.255.255.0
default-router 10.10.10.10
dns-server 192.168.35.2
domain-name cisco.com
!
ip domain name smallbiz.com
ip name-server 192.168.11.12
 

DHCP 設定の確認

DHCP 設定を表示するには、次のコマンドを使用します。

show ip dhcp import :DHCP サーバ データベースにインポートされたオプションのパラメータを表示します。

show ip dhcp pool :DHCP アドレス プールに関する情報を表示します。

show ip dhcp server statistics :アドレス プールおよびバインディングの数などの DHCP サーバ統計情報を表示します。

 
Router# show ip dhcp import
Address Pool Name: dpool1
 
Router# show ip dhcp pool
Pool dpool1 :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 0
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
10.10.0.1 10.10.0.1 - 10.10.0.254 0
 
Router# show ip dhcp server statistics
Memory usage 15419
Address pools 1
Database agents 0
Automatic bindings 0
Manual bindings 0
Expired bindings 0
Malformed messages 0
Secure arp entries 0
 
Message Received
BOOTREQUEST 0
DHCPDISCOVER 0
DHCPREQUEST 0
DHCPDECLINE 0
DHCPRELEASE 0
DHCPINFORM 0
 
Message Sent
BOOTREPLY 0
DHCPOFFER 0
DHCPACK 0
DHCPNAK 0
Router#
 

VLAN の設定

ルータに VLAN を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. vlan vlan_id

2. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

vlan vlan_id

 
Router(config)# vlan 2

VLAN を追加します(識別番号の範囲は 1 ~ 4094)。

ステップ 2

exit

例:

Router(config )# exit

VLAN データベースを更新し、管理ドメイン全体にデータベースを伝搬して、特権 EXEC モードに戻ります。

VLAN へのスイッチ ポートの割り当て

VLAN にスイッチ ポートを割り当てるには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. interface switch port id

2. switchport access vlan vlan-id

3. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

interface switch port id

例:

Router(config)# interface FastEthernet 2
Router(config-if)#

VLAN に割り当てるスイッチ ポートを指定します。

ステップ 2

switchport access vlan vlan-id

例:

Router(config-if)# switchport access vlan 2
Router(config-if)#

VLAN にポートを割り当てます。

ステップ 3

end

例:

Router(config-if)# end
Router#

インターフェイス モードを終了し、特権 EXEC モードに戻ります。

VLAN コンフィギュレーションの確認

VLAN コンフィギュレーションを表示するには、次のコマンドを使用します。

show :VLAN データベース モードから入力します。設定されたすべての VLAN の設定情報の概要を表示します。

show vlan-switch:特権 EXEC モードから入力します。設定されたすべての VLAN の詳細情報を表示します。

 
Router# vlan database
Router(vlan)# show
 
VLAN ISL Id: 1
Name: default
Media Type: Ethernet
VLAN 802.10 Id: 100001
State: Operational
MTU: 1500
Translational Bridged VLAN: 1002
Translational Bridged VLAN: 1003
 
VLAN ISL Id: 2
Name: VLAN0002
Media Type: Ethernet
VLAN 802.10 Id: 100002
State: Operational
MTU: 1500
 
VLAN ISL Id: 3
Name: red-vlan
Media Type: Ethernet
VLAN 802.10 Id: 100003
State: Operational
MTU: 1500
 
VLAN ISL Id: 1002
Name: fddi-default
Media Type: FDDI
VLAN 802.10 Id: 101002
State: Operational
MTU: 1500
Bridge Type: SRB
Translational Bridged VLAN: 1
Translational Bridged VLAN: 1003
 
VLAN ISL Id: 1003
Name: token-ring-default
Media Type: Token Ring
VLAN 802.10 Id: 101003
State: Operational
MTU: 1500
Bridge Type: SRB
Ring Number: 0
Bridge Number: 1
Parent VLAN: 1005
Maximum ARE Hop Count: 7
Maximum STE Hop Count: 7
Backup CRF Mode: Disabled
Translational Bridged VLAN: 1
Translational Bridged VLAN: 1002
 
VLAN ISL Id: 1004
Name: fddinet-default
Media Type: FDDI Net
VLAN 802.10 Id: 101004
State: Operational
MTU: 1500
Bridge Type: SRB
Bridge Number: 1
STP Type: IBM
 
VLAN ISL Id: 1005
Name: trnet-default
Media Type: Token Ring Net
VLAN 802.10 Id: 101005
State: Operational
MTU: 1500
Bridge Type: SRB
Bridge Number: 1
STP Type: IBM
 
Router# show vlan-switch
 
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0, Fa1, Fa3
2 VLAN0002 active Fa2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
 
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003
2 enet 100002 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 ibm - 0 0
1005 trnet 101005 1500 - - 1 ibm - 0 0