Cisco 860、Cisco 880 および Cisco 890 シリーズ サービス統合型ルータ ソフトウェア コンフィギュレーション ガイド
バックアップ データ回線およびリモート管理の設定
バックアップ データ回線およびリモート管理の設定
発行日;2012/06/19 | 英語版ドキュメント(2011/11/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

バックアップ データ回線およびリモート管理の設定

バックアップ インターフェイスの設定

セルラー ダイヤルオンデマンド ルーティング バックアップの設定

ダイヤラ ウォッチを使用した DDR バックアップの設定

フローティング スタティック ルートを使用した DDR バックアップの設定

NAT および IPsec 設定でのバックアップとしてのセル ワイヤレス モデム

コンソール ポートまたは AUX ポートを使用したダイヤル バックアップおよびリモート管理の設定

ISDN S/T ポート経由でのデータ回線バックアップおよびリモート管理の設定

ISDN 設定の構成

アグリゲータおよび ISDN ピア ルータの設定

ギガビット イーサネット フェールオーバー メディアの設定

バックアップ データ回線およびリモート管理の設定

この章では、次の項で、バックアップ データ ラインおよびリモート管理の設定について説明します。

「バックアップ インターフェイスの設定」

「セルラー ダイヤルオンデマンド ルーティング バックアップの設定」

「コンソール ポートまたは AUX ポートを使用したダイヤル バックアップおよびリモート管理の設定」

「ISDN S/T ポート経由でのデータ回線バックアップおよびリモート管理の設定」

「ギガビット イーサネット フェールオーバー メディアの設定」

Cisco 880 シリーズ サービス統合型ルータ(ISR)は、WAN のダウンタイムを削減するバックアップ データ ラインとのバックアップ データ接続をサポートします。


) ビデオ バックアップは、ルータ モデル C881SRST および C888SRST で使用できます。ビデオ バックアップの設定については、「音声機能の設定」を参照してください。


Cisco 880 ISR は、次のようにリモート管理機能をサポートします。

任意の Cisco 880 シリーズ ISR の AUX ポートを使用

Cisco 880 シリーズ ISR の ISDN S/T ポートを使用


) Cisco 880 シリーズ ISR では、コンソール ポートおよび補助ポートは、同じ物理 RJ-45 ポートにあります。したがって、2 ポートを同時にアクティブにすることはできません。必要な機能をイネーブルにするには、CLI を使用する必要があります。


Cisco 892F ISR には、銅線接続をサポートするギガ ビット イーサネット(GE)ポートまたはファイバ接続をサポートをサポートする Small Form-factor Pluggable(SFP)ポートがあり、ネットワークがダウンした場合のフェールオーバー冗長性に設定できます。

バックアップ インターフェイスの設定

プライマリ インターフェイスがダウンしていることをルータが検出した場合、バックアップ インターフェイスはイネーブルになっています。指定された期間中にプライマリ接続が復旧した場合、バックアップ インターフェイスがディセーブルになります。

バックアップ インターフェイスがスタンバイ モードから起動した場合も、ルータはそのバックアップ インターフェイスに関する指定されたトラフィックを受信しない限り、バックアップ インターフェイスをイネーブルにしません。

表 5-1 では、ポートの指定とともに Cisco 880 および Cisco 890 シリーズ ISR のバックアップ インターフェイスを示します。これらのインターフェイスの基本設定は、「ルータの基本設定」「WAN インターフェイスの設定」に示します。

 

表 5-1 モデル番号およびデータ ライン バックアップ機能

ルータ モデル番号
ISDN
3G
V.92

881G、886G、887G、887VG、888G

--

Yes

--

886、886VA、887、887V、888、888E

Yes

--

--

891

--

--

Yes

892、892F

Yes

--

--

ルータでバックアップ インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

手順の概要

1. interface type number

2. backup interface interface-type interface-number

3. exit

手順の詳細

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface atm 0

バックアップ用に設定するインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

このインターフェイスは、シリアル、ISDN、または非同期の可能性があります。

この例では、ATM WAN 接続のバックアップ インターフェイスを設定しています。

ステップ 2

backup interface interface-type interface-number

例:

Router(config-if)# backup interface bri 0

インターフェイスをセカンダリ、つまりバックアップ インターフェイスとして割り当てます。

ここで指定できるインターフェイスは、シリアル インターフェイスまたは非同期インターフェイスです。たとえば、シリアル 0 インターフェイスのバックアップとしてシリアル 1 インターフェイスを設定できます。

この例では、ATM 0 インターフェイスのバックアップ インターフェイスとして BRI インターフェイスを設定しています。

ステップ 3

exit

例:

Router(config-if)# exit
Router(config)#

インターフェイス コンフィギュレーション モードを終了します。

セルラー ダイヤルオンデマンド ルーティング バックアップの設定

必要な場合にプライマリ接続をモニタし、セルラー インターフェイスでバックアップ接続を開始する場合、ルータは次のいずれかの方法を使用できます。

バックアップ インターフェイス:スタンバイの状態のまま待機し、プライマリ インターフェイス回線プロトコルがダウンと認識されると、アップ状態になります。「バックアップ インターフェイスの設定」を参照してください。

ダイヤラ ウォッチ:ダイヤル バックアップとルーティング機能を統合するバックアップ機能です。「ダイヤラ ウォッチを使用した DDR バックアップの設定」を参照してください。

フローティング スタティック ルート:バックアップ インターフェイスを介する経路に、プライマリ接続のアドミニストレーティブ ディスタンスよりも大きいアドミニストレーティブ ディスタンスがあり、プライマリ インターフェイスがダウンするまで、ルーティング テーブルには存在しません。プライマリ インターフェイスがダウンすると、フローティング スタティック ルートが使用されます。「フローティング スタティック ルートを使用した DDR バックアップの設定」を参照してください。


) セルラー インターフェイスおよびその他の非同期シリアル インターフェイスのバックアップ インターフェイスは設定できません。


ダイヤラ ウォッチを使用した DDR バックアップの設定

ダイヤラ ウォッチを開始するには、インターフェイスを設定して Dial-on-demand Routing(DDR; ダイヤルオンデマンド ルーティング)およびバックアップを実行する必要があります。ダイヤラ マップなどの、DDR 機能の従来の DDR コンフィギュレーション コマンドを使用します。バックアップ インターフェイスでダイヤラ ウォッチをイネーブルにし、ダイヤラ リストを作成するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

手順の概要

1. configure terminal

2. interface type number

3. dialer watch group group-number

4. dialer watch-list group-number ip ip-address address-mask

5. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

6. ip access-list access-list-number permit ip source address

7. interface cellular 0

8. dialer string string

または

dialer group dialer group number

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type number

 

Router (config)# interface ATM0

インターフェイスを指定します。

ステップ 3

dialer watch-group group-number

 

Router(config-if)# dialer watch-group 2

バックアップ インターフェイスでダイヤラ ウォッチをイネーブルにします。

ステップ 4

dialer watch-list group-number ip ip-address address-mask

 

Router(config-if)# dialer watch-list 2 ip 10.4.0.254 255.255.0.0

監視されるすべての IP アドレスのリストを定義します。

ステップ 5

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

 

Router(config)# dialer-list 2 protocol ip permit

関係するトラフィックのダイヤラ リストを作成し、プロトコル全体に対してアクセスを許可します。

ステップ 6

ip access-list access-list-number permit ip source address

 

Router(config)# access list 2 permit 10.4.0.0

関係するトラフィックを定義します。

IP ネットワークへのトラフィック送信を回避するには、access list permit all コマンドは使用しないでください。これによって、コールが強制的に終了される場合があります。

ステップ 7

interface cellular 0
 

Router (config)# interface cellular 0

セルラー インターフェイスを指定します。

ステップ 8

dialer string string

または

dialer group dialer group number

 

Router (config-if)# dialer string cdma *** cdma ***

 

または

Router (config-if)# dialer group 2 *** gsm ***

CDMA だけ。ダイヤラ スクリプトを指定します(chat script コマンドを使用して定義されます)。

GSM だけ。ダイヤラ リストをダイヤラ インターフェイスにマッピングします。

フローティング スタティック ルートを使用した DDR バックアップの設定

フローティング スタティック デフォルト ルートをセカンダリ インターフェイスで設定するには、グローバル コンフィギュレーション モードから、次のコマンドを使用します。


) ルータで ip classless がイネーブルにされていることを確認してください。


手順の概要

1. configure terminal

2. ip route network-number network-mask { ip address | interface } [ administrative distance ] [name name]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

端末からグローバル コンフィギュレーション モードを開始します。

ステップ 2

ip route network-number network-mask { ip address | interface } [ administrative distance ] [name name]

 

Router (config)# ip route 0.0.0.0 Dialer 2 track 234

指定されたインターフェイスを介して、設定されているアドミニストレーティブ ディスタンスを使用して、フローティング スタティック ルートを確立します。

プライマリ インターフェイスがダウンしたときだけバックアップ インターフェイスを使用するするよう、バックアップ インターフェイスを通したルートのアドミニストレーティブ ディスタンスをより高く設定する必要があります。

NAT および IPsec 設定でのバックアップとしてのセル ワイヤレス モデム

次に、GSM ネットワークまたは CDMA ネットワークで NAT および IPsec を設定したバックアップとして 3G ワイヤレス モデムを設定する方法の例を示します。


) 送受信速度は設定できません。実際のスループットは、セルラー ネットワーク サービスによって異なります。


Current configuration : 3433 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
crypto isakmp key gsm address 128.107.241.234 *** or cdma ***
!
!
crypto ipsec transform-set gsm ah-sha-hmac esp-3des *** or cdma ***
!
crypto map gsm1 10 ipsec-isakmp *** or cdma1 ***
set peer 128.107.241.234
set transform-set gsm *** or cdma ***
match address 103
!
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.4.0.254
!
ip dhcp pool gsmpool *** or cdmapool ***
network 10.4.0.0 255.255.0.0
dns-server 66.209.10.201 66.102.163.231
default-router 10.4.0.254
!
!
ip cef
!
no ipv6 cef
multilink bundle-name authenticated
chat-script gsm "" "atdt*98*1#" TIMEOUT 30 "CONNECT" *** or cdma ***
!
!
archive
log config
hidekeys
!
!
controller DSL 0
mode atm
line-term cpe
line-mode 4-wire standard
line-rate 4608
!
!
!
!
interface ATM0
no ip address
ip virtual-reassembly
load-interval 30
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
backup interface Cellular0
ip nat outside
ip virtual-reassembly
pvc 0/35
pppoe-client dial-pool-number 2
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 0
dialer string gsm *** or cdma ***
dialer-group 1
async mode interactive
no ppp lcp fast-start
ppp chap hostname chunahayev@wwan.ccs
ppp chap password 0 B7uhestacr
ppp ipcp dns request
crypto map gsm1 *** or cdma1 ***
!
interface Vlan1
description used as default gateway address for DHCP clients
ip address 10.4.0.254 255.255.0.0
ip nat inside
ip virtual-reassembly
!
interface Dialer2
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer pool 2
dialer-group 2
ppp authentication chap callin
ppp chap hostname cisco@dsl.com
ppp chap password 0 cisco
ppp ipcp dns request
crypto map gsm1 *** or cdma1 ***
!
ip local policy route-map track-primary-if
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer2 track 234
ip route 0.0.0.0 0.0.0.0 Cellular0 254
no ip http server
no ip http secure-server
!
!
ip nat inside source route-map nat2cell interface Cellular0 overload
ip nat inside source route-map nat2dsl interface Dialer2 overload
!
ip sla 1
icmp-echo 209.131.36.158 source-interface Dialer2
timeout 1000
frequency 2
ip sla schedule 1 life forever start-time now
access-list 1 permit any
access-list 2 permit 10.4.0.0 0.0.255.255
access-list 3 permit any
access-list 101 permit ip 10.4.0.0 0.0.255.255 any
access-list 102 permit icmp any host 209.131.36.158
access-list 103 permit ip host 166.136.225.89 128.107.0.0 0.0.255.255
access-list 103 permit ip host 75.40.113.246 128.107.0.0 0.0.255.255
dialer-list 1 protocol ip list 1
dialer-list 2 protocol ip permit
!
!
!
route-map track-primary-if permit 10
match ip address 102
set interface Dialer2
!
route-map nat2dsl permit 10
match ip address 101
match interface Dialer2
!
route-map nat2cell permit 10
match ip address 101
match interface Cellular0
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line 3
exec-timeout 0 0
script dialer gsm *** or cdma ***
login
modem InOut
no exec
line vty 0 4
login
!
scheduler max-task-time 5000
 
!
webvpn cef
end

コンソール ポートまたは AUX ポートを使用したダイヤル バックアップおよびリモート管理の設定

Cisco 880 シリーズ ISR などの加入者宅内機器とインターネット サービス プロバイダー(ISP)が接続されている場合、IP アドレスは動的にルータに割り当てられます。また、中央管理機能を使用して、ルータのピアによって割り当てられることもあります。プライマリ回線に障害が発生した場合にフェールオーバー ルートを提供するため、ダイヤル バックアップ機能を追加できます。Cisco 880 シリーズ ISR では、AUX ポートを使用してダイヤル バックアップおよびリモート管理を行うことができます。

図 5-1 は、リモート管理アクセスおよびプライマリ WAN 回線にバックアップを提供する場合に使用するネットワーク コンフィギュレーションを示しています。

図 5-1 補助ポートによるダイヤル バックアップおよびリモート管理

 

 

1

Cisco 880 シリーズ ルータ

A

メイン WAN リンク。インターネット サービス プロバイダーへのプライマリ接続です。

2

モデム

B

ダイヤル バックアップ(プライマリ回線がダウンした場合に Cisco 880 ルータのフェールオーバー リンクとして機能)

3

PC

C

リモート管理。Cisco IOS コンフィギュレーションへの変更または更新を可能にするダイヤルイン アクセスとして機能します。

これらのルータでダイヤル バックアップおよびリモート管理を設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

手順の概要

1. ip name-server server-address

2. ip dhcp pool name

3. exit

4. chat-script script-name expect-send

5. interface type number

6. exit

7. interface type number

8. dialer watch-group group-number

9. exit

10. ip nat inside source {list access-list-number } {interface type number | pool name } [overload]

11. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

12. access-list access-list-number { deny | permit} source [ source-wildcard ]

13. dialer watch-list group-number { ip ip-address address-mask | delay route-check initial seconds }

14. line [ aux | console | tty | vty ] line-number [ ending-line-number ]

15. modem enable

16. exit

17. line [ aux | console | tty | vty ] line-number [ ending-line-number ]

18. flowcontrol { none | software [ lock ] [ in | out ] | hardware [ in | out ]}

手順の詳細

 

コマンド
目的

ステップ 1

ip name-server server-address

例:

Router(config)# ip name-server 192.168.28.12

ISP DNS IP アドレスを入力します。

ヒント 可能な場合は、複数のサーバ アドレスを追加できます。

ステップ 2

ip dhcp pool name

例:

Router(config)# ip dhcp pool 1

ルータ上に DHCP アドレス プールを作成します。続いて、DHCP プール コンフィギュレーション モードを開始します。 name 引数は、ストリングまたは整数にすることができます。

DHCP アドレス プールを設定します。DHCP プール コンフィギュレーション モードで使用できるサンプル コマンドについては、「例」を参照してください。

ステップ 3

exit

例:

Router(config-dhcp)#exit

config-dhcp モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

ステップ 4

chat-script script-name expect-send

例:

Router(config)# chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102 T” TIMEOUT 45 CONNECT \c

ダイヤルオンデマンド ルーティング(DDR)で使用するチャット スクリプトを設定し、モデムのダイヤリングおよびリモート システムへのログインを行うコマンドを使用します。定義されたスクリプトを使用して PSTN に接続されたモデムで通話します。

ステップ 5

interface type number

例:

Router(config)# interface Async 1

非同期インターフェイスのコンフィギュレーション モードを作成および開始します。

非同期インターフェイスを設定します。非同期インターフェイス コンフィギュレーション モードで使用できるサンプル コマンドについては、「例」を参照してください。

ステップ 6

exit

例:

Router(config-if)# exit

グローバル コンフィギュレーション モードを開始します。

ステップ 7

interface type number

例:

Router(config)# interface Dialer 3

ダイヤラ インターフェイスのコンフィギュレーション モードを作成および開始します。

ステップ 8

dialer watch-group group-number

例:

Router(config-if)# dialer watch-group 1

ウォッチ リストのグループ番号を指定します。

ステップ 9

exit

例:

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 10

ip nat inside source {list access-list-number } {interface type number | pool name } [overload]

例:

Router(config)# ip nat inside source list 101 interface Dialer 3 overload

内部インターフェイス上のダイナミック アドレス変換をイネーブルにします。

ステップ 11

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 0.0.0.0 0.0.0.0 22.0.0.2

ダイヤラ インターフェイスにポイントする IP ルートをデフォルト ゲートウェイとして設定します。

ステップ 12

access-list access-list-number { deny | permit} source [ source-wildcard ]

例:

Router(config)# access-list 1 permit 192.168.0.0 0.0.255.255 any

変換が必要なアドレスを示す拡張アクセス リストを定義します。

ステップ 13

dialerwatch-list group-number { ip ip-address address-mask | delay route-check initial seconds }

例:

Router(config)# dialer watch-list 1 ip 22.0.0.2 255.255.255.255

ピアへのルートが存在するかどうかにより、プライマリ リンクのステータスを評価します。アドレス 22.0.0.2 は、ISP のピア IP アドレスです。

ステップ 14

line [ aux | console | tty | vty ] line-number [ ending-line-number ]

例:

Router(config)# line console 0

ライン インターフェイスのコンフィギュレーション モードを開始します。

ステップ 15

modem enable

例:

Router(config-line)# modem enable

ポートをコンソールから AUX ポート機能に変更します。

ステップ 16

exit

例:

Router(config-line)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 17

line [ aux | console | tty | vty ] line-number [ ending-line-number ]

例:

Router(config)# line aux 0

補助インターフェイスのコンフィギュレーション モードを開始します。

ステップ 18

flowcontrol { none | software [ lock ] [ in | out ] | hardware [ in | out ]}

例:

Router(config)# flowcontrol hardware

ハードウェア信号フロー制御をイネーブルにします。

次の設定例では、ATM インターフェイスの IP アドレスを、PPP および Internet Protocol Control Protocol(IPCP; インターネット プロトコル コントロール プロトコル)アドレス ネゴシエーションおよびコンソール ポートを介したダイヤル バックアップによって指定します。

!
ip name-server 192.168.28.12
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool 1
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
! Need to use your own correct ISP phone number.
modemcap entry MY-USER_MODEM:MSC=&F1S0=1
chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102\T”
TIMEOUT 45 CONNECT \c
!
!
!
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
hold-queue 100 out
!
! Dial backup and remote management physical interface.
interface Async1
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 3
async default routing
async dynamic routing
async mode dedicated
ppp authentication pap callin
!
interface ATM0
mtu 1492
no ip address
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
! Primary WAN link.
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! Dialer backup logical interface.
interface Dialer3
ip address negotiated
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 3
dialer idle-timeout 60
dialer string 5555102 modem-script Dialout
dialer watch-group 1
!
! Remote management PC IP address.
peer default ip address 192.168.2.2
no cdp enable
!
! Need to use your own ISP account and password.
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! IP NAT over Dialer interface using route-map.
ip nat inside source route-map main interface Dialer1 overload
ip nat inside source route-map secondary interface Dialer3 overload
ip classless
!
! When primary link is up again, distance 50 will override 80 if dial backup
! has not timed out. Use multiple routes because peer IP addresses are alternated
! among them when the CPE is connected.
ip route 0.0.0.0 0.0.0.0 64.161.31.254 50
ip route 0.0.0.0 0.0.0.0 66.125.91.254 50
ip route 0.0.0.0 0.0.0.0 64.174.91.254 50
ip route 0.0.0.0 0.0.0.0 63.203.35.136 80
ip route 0.0.0.0 0.0.0.0 63.203.35.137 80
ip route 0.0.0.0 0.0.0.0 63.203.35.138 80
ip route 0.0.0.0 0.0.0.0 63.203.35.139 80
ip route 0.0.0.0 0.0.0.0 63.203.35.140 80
ip route 0.0.0.0 0.0.0.0 63.203.35.141 80
ip route 0.0.0.0 0.0.0.0 Dialer1 150
no ip http server
ip pim bidir-enable
!
! PC IP address behind CPE.
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 103 permit ip 192.168.0.0 0.0.255.255 any
!
! Watch multiple IP addresses because peers are alternated
! among them when the CPE is connected.
dialer watch-list 1 ip 64.161.31.254 255.255.255.255
dialer watch-list 1 ip 64.174.91.254 255.255.255.255
dialer watch-list 1 ip 64.125.91.254 255.255.255.255
!
! Dial backup will kick in if primary link is not available
! 5 minutes after CPE starts up.
dialer watch-list 1 delay route-check initial 300
dialer-list 1 protocol ip permit
!
! Direct traffic to an interface only if the dialer is assigned an IP address.
route-map main permit 10
match ip address 101
match interface Dialer1
!
route-map secondary permit 10
match ip address 103
match interface Dialer3
!
! Change console to aux function.
line con 0
exec-timedout 0 0
modem enable
stopbits 1
line aux 0
exec-timeout 0 0
! To enable and communicate with the external modem properly.
script dialer Dialout
modem InOut
modem autoconfigure discovery
transport input all
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
exec-timeout 0 0
password cisco
login
!
scheduler max-task-time 5000
end
 

ISDN S/T ポート経由でのデータ回線バックアップおよびリモート管理の設定

Cisco 880 シリーズ ルータは、リモート管理に ISDN S/T ポートを使用できます。図 5-2 および 図 5-3 は、プライマリ WAN 回線のリモート管理アクセスおよびバックアップを実現する 2 種類の典型的なネットワーク コンフィギュレーションを示します。図 5-2 の場合、ダイヤル バックアップ リンクは加入者宅内機器(CPE)のスプリッタ、デジタル加入者線アクセス マルチプレクサ(DSLAM)、およびセントラル オフィス(CO)のスプリッタを経由して ISDN 交換機に接続されます。図 5-3 では、ダイヤル バックアップ リンクは、ルータから ISDN 交換機に直接接続されます。

図 5-2 CPE スプリッタ、DSLAM、および CO スプリッタを経由するデータ回線バックアップ

 

 

1

Cisco 880 シリーズ ルータ

A

プライマリ DSL インターフェイス、FE インターフェイス(Cisco 881 ルータ)

2

DSLAM

B

ISDN インターフェイス(ISDN S/T ポート)経由のダイヤル バックアップおよびリモート管理。プライマリ回線がダウンした場合にフェールオーバー リンクとして機能します。

3

ATM アグリゲータ

4

ISDN スイッチ

5

ISDN

C

プライマリ DSL リンクがダウンした場合に、ISDN インターフェイスから管理者にリモート管理機能を提供します。Cisco IOS コンフィギュレーションへの変更または更新を可能にするダイヤルイン アクセスとして機能します。

6

ISDN ピア ルータ

7

Web サーバ

8

管理者

--

--

図 5-3 ルータから ISDN スイッチへの直接接続データ回線バックアップ

 

 

1

PC

A

プライマリ DSL インターフェイス

2

Cisco 880 シリーズ ISR

B

ISDN インターフェイス(ISDN S/T ポート)経由のダイヤル バックアップおよびリモート管理。プライマリ回線がダウンした場合にフェールオーバー リンクとして機能します。

3

DSLAM

4

アグリゲータ

5

ISDN スイッチ

C

プライマリ DSL リンクがダウンした場合に、ISDN インターフェイスから管理者にリモート管理機能を提供します。Cisco IOS コンフィギュレーションへの変更または更新を可能にするダイヤルイン アクセスとして機能します。

6

Web サーバ

7

管理者

ルータの ISDN S/T ポート経由でダイヤル バックアップおよびリモート管理を設定するには、次の手順を実行します。

ISDN 設定の構成

アグリゲータおよび ISDN ピア ルータの設定

ISDN 設定の構成


) バックアップ インターフェイスおよびフローティング スタティック ルート方式を使用してバックアップ ISDN 回線を起動するには、対象トラフィックが存在していなければなりません。ダイヤラ ウォッチを使用してバックアップ ISDN 回線を起動する場合は、対象トラフィックが存在しなくても構いません。


バックアップ インターフェイスとして使用するルータ ISDN インターフェイスを設定するには、グローバル コンフィギュレーション モードから始めて次の手順を実行します。

手順の概要

1. isdn switch-type switch-type

2. interface type number

3. encapsulation encapsulation-type

4. dialer pool-member number

5. isdn switch-type switch-type

6. exit

7. interface dialer dialer-rotary-group-number

8. ip address negotiated

9. encapsulation encapsulation-type

10. dialer pool number

11. dialer string dial-string# [ : isdn-subaddress ]

12. dialer-group group-number

13. exit

14. dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

手順の詳細

 

コマンド
目的

ステップ 1

isdn switch-type switch-type

例:

Router(config)# isdn switch-type basic-net3

ISDN スイッチ タイプを指定します。

この例では、豪州、欧州、および英国で使用するスイッチ タイプを指定しています。サポートされている他のスイッチ タイプの詳細については、『 Cisco IOS Dial Technologies Command Reference 』を参照してください。

ステップ 2

interface type number

例:

Router(config)# interface bri 0

ISDN BRI のコンフィギュレーション モードを開始します。

ステップ 3

encapsulation encapsulation-type

例:

Router(config-if)# encapsulation ppp

BRI0 インターフェイスのカプセル化タイプを設定します。

ステップ 4

dialer pool-member number

例:

Router(config-if)# dialer pool-member 1

ダイヤラ プールのメンバーシップを指定します。

ステップ 5

isdn switch-type switch-type

例:

Router(config-if)# isdn switch-type basic-net3

ISDN スイッチ タイプを指定します。

ステップ 6

exit

例:

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

ステップ 7

interface dialer dialer-rotary-group-number

例:

Router(config)# interface dialer 0

ダイヤラ インターフェイス(番号 0 ~ 255)を作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

ip address negotiated

例:

Router(config-if)# ip address negotiated

インターフェイスの IP アドレスを PPP/IPCP(IP Control Protocol)アドレス ネゴシエーションで取得することを指定します。ピアから IP アドレスを取得します。

ステップ 9

encapsulation encapsulation-type

例:

Router(config-if)# encapsulation ppp

インターフェイスのカプセル化タイプを PPP に設定します。

ステップ 10

dialer pool number

例:

Router(config-if)# dialer pool 1

使用するダイヤラ プールを指定します。

この例では、BRI0 の dialer pool-member 値は 1 なので、dialer pool 1 という設定により dialer 0 インターフェイスが BRI0 インターフェイスに対応付けられます。

ステップ 11

dialer string dial-string# [ : isdn-subaddress ]

例:

Router(config-if)# dialer string 384040

ダイヤルする電話番号を指定します。

ステップ 12

dialer-group group-number

例:

Router(config-if)# dialer group 1

ダイヤラ グループ(1 ~ 10)にダイヤラ インターフェイスを割り当てます。

ステップ 13

exit

例:

Router(config-if)# exit

ダイヤラ 0 のインターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

ステップ 14

dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

例:

Router(config)# dialer-list 1 protocol ip permit

指定したインターフェイス ダイヤラ グループ経由で転送する対象パケット用のダイヤラ リストを作成します。

この例では、dialer-list 1 が dialer-group 1 に対応します。

このコマンドの詳しい説明およびその他の設定可能なパラメータについては、『 Cisco IOS Dial Technologies Command Reference 』を参照してください。

アグリゲータおよび ISDN ピア ルータの設定

ISDN ピア ルータは、ISDN インターフェイスを装備し、公衆 ISDN ネットワーク経由で Cisco ルータの ISDN インターフェイスに到達可能なルータです。ISDN ピア ルータは、ATM ネットワークがダウンした場合、Cisco ルータにインターネット アクセスできるようになります。

通常、アグリゲータはシスコ ルータの ATM PVC が終端するコンセントレータ ルータです。次の設定例では、アグリゲータは、PPPoE サーバとして設定されます。

 
! This portion of the example configures the aggregator.
vpdn enable
no vpdn logging
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
!
interface Ethernet3
description “4700ref-1”
ip address 40.1.1.1 255.255.255.0
media-type 10BaseT
!
interface Ethernet4
ip address 30.1.1.1 255.255.255.0
media-type 10BaseT
!
interface Virtual-Template1
ip address 22.0.0.2 255.255.255.0
ip mtu 1492
peer default ip address pool adsl
!
interface ATM0
no ip address
pvc 1/40
encapsulation aal5snap
protocol pppoe
!
no atm limi-keepalive
!
ip local pool adsl 22.0.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 22.0.0.1 50
ip route 0.0.0.0 0.0.0.0 30.1.1.2.80
 
! This portion of the example configures the ISDN peer.
isdn switch-type basic-net3
!
interface Ethernet0
ip address 30.1.1.2 255.0.0.0
!
interface BRI0
description “to 836-dialbackup”
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer0
ip address 192.168.2.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 384020
dialer-group 1
peer default ip address pool isdn
!
ip local pool isdn 192.168.2.1
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 40.0.0.0 255.0.0.0 30.1.1.1
!
dialer-list 1 protocol ip permit!

ギガビット イーサネット フェールオーバー メディアの設定

Cisco 892F ルータには、銅線接続をサポートするギガ ビット イーサネット(GE)ポートまたはファイバ接続をサポートする Small Form-factor Pluggable(SFP)ポートがあります。ネットワークがダウンした場合に、フェールオーバー冗長性を保つようメディアを設定できます。

プライマリおよびセカンダリ フェールオーバー メディアを GE-SFP ポートに割り当てるには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. hostname name

2. enable secret password

3. interface gigabitethernet slot/port

4. media-type { sfp | rj45 } auto-failove r

5. exit

手順の詳細

 

コマンド
目的

ステップ 1

hostname name

 

Router(config)# hostname Router

ルータ名を指定します。

ステップ 2

enable secret password

 

Router(config)# enable secret cr1ny5ho

ルータへの不正なアクセスを防止するには、暗号化パスワードを指定します。

ステップ 3

interface gigabitethernet slot/port

 

Router(config)# interface gigabitethernet 0/1

インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

media-type {sfp | rj45} auto-failover

 

Router(config-if)# media-type sfp auto-failover

または

Router(config-if)# media-type rj45 auto-failover

SFP のあるポートを SFP から RJ-45 への自動フェールオーバーのプライマリ メディアとして設定します。

または

RJ-45 のあるポートを RJ-45 から SFP への自動フェールオーバーのプライマリ メディアとして設定します。

ステップ 5

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

Auto-Detect

Auto-Detect 機能は、media-type が設定されていない場合にイネーブルにされます。この機能により、どのメディアが接続されているか自動的に検出され、リンクが稼動します。両方のメディアが接続されている場合、最初に稼動したメディアのリンクが稼動します。


) Auto-Detect 機能は、1000 Base SFP だけで動作します。この機能は、100 Base SFP を検出しません。


Auto-Detect 機能を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

手順の概要

1. interface gigabitethernet slot/port

2. no media-type

3. exit

手順の詳細

 

コマンド
目的

ステップ 1

interface gigabitethernet slot/port

 

Router(config)# interface gigabitethernet 0/1

インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

no media-type

 

Router(config-if)# no media-type

GigabitEthernet0/1: Changing media to UNKNOWN.

You may need to update the speed and duplex settings for this interface.

Auto-Detect をイネーブルにします。1000Base SFP が接続されている場合、速度とデュプレックスは自動的に 1000 および全二重に設定されます。速度とデュプレックス オプションは使用できません。RJ45 接続は、速度 1000 および全二重の場合だけ動作します。SFP が接続されていない場合、RJ45 メディアにはすべての速度およびデュプレックスが使用できます。

(注) Auto-Detect 機能は、1000Base SFP だけで動作します。この機能は 100Base SFP を検出しません。

ステップ 3

exit

 

Router(config-if)# exit

Router(config)#

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。