Cisco 880 シリーズ サービス統合型ルータ ソフトウェア コンフィギュレーション ガイド
ルータの基本設定
ルータの基本設定
発行日;2013/05/19 | 英語版ドキュメント(2013/04/23 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

ルータの基本設定

インターフェイス ポート

デフォルト コンフィギュレーション

設定に必要な情報

コマンドライン アクセスの設定

グローバル パラメータの設定

WAN インターフェイスの設定

ファスト イーサネット WAN インターフェイスの設定

VDSL2 WAN インターフェイスの設定

Cisco Multi Mode 886VA および 887VA ISR での ADSL または VDSL の設定

ADSL モードの設定

ADSL auto モードの設定

ADSL モードの CPE およびピアの設定

ADSL の設定例

ADSL 設定の確認

ADSL の CPE からピアへの接続の確認

ファスト イーサネット LAN インターフェイスの設定

無線 LAN インターフェイスの設定

ループバック インターフェイスの設定

設定の確認

スタティック ルートの設定

設定の確認

ダイナミック ルートの設定

Routing Information Protocol の設定

設定の確認

拡張インテリア ゲートウェイ ルーティング プロトコルの設定

設定の確認

ルータの基本設定

この章では、Cisco ルータで基本的なパラメータ(グローバル パラメータの設定、ルーティング プロトコル、インターフェイス、およびコマンドライン アクセスなど)を設定する手順について説明します。また、起動時のデフォルト設定についても説明します。

「インターフェイス ポート」

「デフォルト コンフィギュレーション」

「設定に必要な情報」

「コマンドライン アクセスの設定」

「グローバル パラメータの設定」

「WAN インターフェイスの設定」

「ファスト イーサネット LAN インターフェイスの設定」

「無線 LAN インターフェイスの設定」

「ループバック インターフェイスの設定」

「スタティック ルートの設定」

「ダイナミック ルートの設定」


) ルータの各モデルは、このマニュアルに記載されている機能の一部をサポートしていない場合があります。特定のルータでサポートされていない機能は、可能な限り明示されています。


この章では、該当するものがある場合には設定例と確認手順が記載されています。

 

インターフェイス ポート

表 3-1 は、各ルータでサポートされているインターフェイスと装置に表記されているポート ラベルを示しています。

 

表 3-1 Cisco ルータでサポートされているインターフェイスと対応するポート ラベル

ルータ
インターフェイス
ポート ラベル

Cisco 880

ファスト イーサネット LAN

LAN、FE0-FE3

ワイヤレス LAN

(表示なし)

Cisco 881、881W、881G、881GW

ファスト イーサネット WAN

WAN、FE4

Cisco 886、886W、886G、886GW

ADSLoverISDN

ADSLoPOTS

Cisco 887、887W

ADSL2oPOTS WAN

ADSLoPOTS

Cisco 887V、887VW、887VG、887VGW

VDSL2oPOTS WAN

VDSLoPOTS

Cisco 888、888W

G.SHDSL WAN

G.SHDSL

デフォルト コンフィギュレーション

Cisco ルータを初めて起動すると、一部の基本的な設定はすでに行われています。LAN および WAN インターフェイスはすべて作成されており、コンソール ポートと VTY ポートの設定やネットワーク アドレス変換(NAT)用の内部インターフェイスの割り当てもすでに行われています。初期設定を表示するには、 show running-config コマンドを使用します(次の Cisco 881W の例を参照してください)。

Router# show running-config
 
 
User Access Verification
 
Password:
Router> en
Password:
Router# show running-config
Building configuration...
 
Current configuration : 986 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$g4y5$NxDeM.0hON6YA51bcfGvN1
enable password ciscocisco
!
no aaa new-model
!
!
!
!
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authe
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
ip address 10.1.1.1 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface wlan-ap0
description Service Module interface to manage the embedded AP
ip unnumbered Vlan1
no cdp enable
arp timeout 0
!
ip route 0.0.0.0 0.0.0.0 10.1.1.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password cisco
login
transport input telnet ssh
!
scheduler max-task-time 5000
 
!
webvpn cef
end
 
Router#

設定に必要な情報

ネットワークを設定する前に、使用するネットワーク構成に基づいて、次の情報の一部またはすべてを収集しておく必要があります。

インターネット接続を設定する場合、次の情報を収集してください。

ユーザのログイン名として割り当てられた PPP クライアント名

PPP 認証のタイプ:Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェイク認証プロトコル)または Password Authentication Protocol(PAP)

ISP アカウントにアクセスするための PPP パスワード

DNS サーバの IP アドレスおよびデフォルト ゲートウェイ

企業ネットワークへの接続を設定する場合は、ユーザとネットワーク管理者の間で、ルータの WAN インターフェイスに関する次の情報について打ち合わせておく必要があります。

PPP 認証のタイプ:CHAP または PAP

ルータにアクセスするための PPP クライアント名

ルータにアクセスするための PPP パスワード

IP ルーティングを設定する場合、次の準備が必要です。

IP ネットワークのアドレス指定方式を作成します。

IP アドレスなどの IP ルーティング パラメータ情報と ATM Permanent Virtual Circuit(PVC; 相手先固定接続)を特定します。通常、これらの PVC パラメータは、Virtual Path Identifier(VPI; 仮想パス識別子)、Virtual Circuit Identifier(VCI; 仮想回線識別子)、およびトラフィック シェーピング パラメータです。

サービス プロバイダーから付与された PVC 番号、VPI、および VCI を特定します。

PVC ごとに、サポートされている AAL5 カプセル化のタイプを判別します。次のいずれかを指定できます。

AAL5SNAP:これは、RFC 1483 ルーティングまたは RFC 1483 ブリッジングのいずれかです。RFC 1483 ルーティングの場合、サービス プロバイダーはスタティック IP アドレスを提供する必要があります。ブリッジング RFC 1483 の場合、DHCP を用いて IP アドレスを入手するか、サービス プロバイダーからスタティック IP アドレスを入手することもできます。

AAL5MUX PPP:このタイプでのカプセル化では、PPP 関連設定項目を判別する必要があります。

ADSL または G.SHDSL 回線を使用して接続する場合、次の準備が必要です。

電話会社と回線契約を結びます。

ADSL 回線の場合:ADSL シグナリング タイプが DMT(ANSI T1.413 ともいう)または DMT Issue 2 であることを確認します。

G.SHDSL 回線の場合:G.SHDSL 回線が ITU G.991.2 規格に準拠し、Annex A(北米)または Annex B(欧州)をサポートしていることを確認します。

該当する情報の収集が済んだら、ルータの設定を行うことができます。「コマンドライン アクセスの設定」から設定を始めてください。

ソフトウェア ライセンスを取得または変更するには、『 Software Activation on Cisco Integrated Services Routers and Cisco Integrated Service Routers G2 』を参照してください

コマンドライン アクセスの設定

ルータへのアクセスを制御するパラメータを設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. line [ aux | console | tty | vty ] line-number

2. password password

3. login

4. exec-timeout minutes [ seconds ]

5. line [ aux | console | tty | vty ] line-number

6. password password

7. login

8. end

手順の詳細

コマンド
目的

ステップ 1

line [ aux | console | tty | vty ] line-number

例:

Router(config)# line console 0
Router(config-line)#

回線コンフィギュレーション モードを開始します。続いて、回線のタイプを指定します。

この例では、アクセス用にコンソール端末を指定します。

ステップ 2

password password

例:

Router(config)# password 5dr4Hepw3
Router(config-line)#

コンソール端末回線に固有のパスワードを指定します。

ステップ 3

login

例:

Router(config-line)# login
Router(config-line)#

端末セッション ログイン時のパスワード チェックをイネーブルにします。

ステップ 4

exec-timeout minutes [ seconds ]

例:

Router(config-line)# exec-timeout 5 30
Router(config-line)#
 

ユーザ入力が検出されるまで EXEC コマンド インタープリタが待機する間隔を設定します。デフォルトは 10 分です。任意で、間隔値に秒数を追加します。

この例では、5 分 30 秒のタイムアウトを表示します。「0 0」のタイムアウトを入力すると、タイムアウトが発生しません。

ステップ 5

line [ aux | console | tty | vty ] line-number

例:

Router(config-line)# line vty 0 4
Router(config-line)#

リモート コンソール アクセス用の仮想端末を指定します。

ステップ 6

password password

例:

Router(config-line)# password aldf2ad1
Router(config-line)#

仮想端末回線に固有のパスワードを指定します。

ステップ 7

login

例:

Router(config-line)# login
Router(config-line)#

仮想端末セッション ログイン時のパスワード チェックをイネーブルにします。

ステップ 8

end

例:

Router(config-line)# end
Router#

回線コンフィギュレーション モードを終了します。続いて、特権 EXEC モードに戻ります。

次の設定は、コマンドライン アクセス コマンドを示します。

「default」と記されているコマンドは入力不要です。これらのコマンドは、 show running-config コマンドを使用すると、生成されたコンフィギュレーション ファイルに自動的に表示されます。

!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!

グローバル パラメータの設定

ルータに選択したグローバル パラメータを設定するには、次の作業を行います。

手順の概要

1. configure terminal

2. hostname name

3. enable secret password

4. no ip domain-lookup

手順の詳細

コマンド
目的

ステップ 1

configure terminal

例:

Router> enable

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。

リモート端末を使用してルータに接続している場合は、次のコマンドを使用します。

telnet router name or address

Login: login id

Password: *********

Router> enable

ステップ 2

hostname name

例:

Router(config)# hostname Router

Router(config)#

ルータ名を指定します。

ステップ 3

enable secret password

例:

Router(config)# enable secret cr1ny5ho

Router(config)#

ルータへの不正なアクセスを防止するには、暗号化パスワードを指定します。

ステップ 4

no ip domain-lookup

例:

Router(config)# no ip domain-lookup Router(config)#

ルータが未知の単語(入力ミス)を IP アドレスに変換しないようにします。

WAN インターフェイスの設定

必要に応じて、次のいずれかの手順を行い、ルータの WAN インターフェイスを設定します。

「ファスト イーサネット WAN インターフェイスの設定」

「VDSL2 WAN インターフェイスの設定」

「Cisco Multi Mode 886VA および 887VA ISR での ADSL または VDSL の設定」

「ADSL モードの設定」

ファスト イーサネット WAN インターフェイスの設定

Cisco 861 または 881 ISR でファスト イーサネット インターフェイスを設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. interface type number

2. ip address ip-address mask

3. no shutdown

4. exit

手順の詳細

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface fastethernet 4
Router(config-if)#

ルータのファスト イーサネット WAN インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 192.168.12.2 255.255.255.0
Router(config-if)#

指定されたファスト イーサネット インターフェイスの IP アドレスおよびサブネット マスクを設定します。

ステップ 3

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#

イーサネット インターフェイスをイネーブルにして、インターフェイスの状態を管理上のダウンからアップに変更します。

ステップ 4

exit

例:

Router(config-if)# exit
Router(config)#

ファスト イーサネット インターフェイスのコンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

VDSL2 WAN インターフェイスの設定

Cisco 887V ISR プラットフォームでは、VDSL2 WAN インターフェイスが使用されます。


) VDSL2 WAN インターフェイスは、レイヤ 2 転送メカニズムとしてイーサネットを使用します。


Cisco 887V ISR で VDSL2 を設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. controller vdsl 0

2. interface type number

3. ip address ip-address mask

4. shutdown

5. no shutdown

6. exit

手順の詳細

コマンド
目的

ステップ 1

controller vdsl 0

例:

Router# config t
Router(config)# controller vdsl 0

コントローラのコンフィギュレーション モードを開始し、コントローラ番号を入力します。

(注) CPE 側から VDSL2 パラメータを設定する必要はありません。DSLAM 側で特定の VDSL2 設定を実施する必要があります。

ステップ 2

interface type number

例:

Router(config)# interface ethernet 0
Router(config-if)#

ルータ上の VDSL WAN インターフェイスを通してイーサネット レイヤ 2 転送のコンフィギュレーション モードを開始します。

ステップ 3

ip address ip-address mask

例:

Router(config-if)# ip address 192.168.12.2 255.255.255.0
Router(config-if)#

インターフェイスに IP アドレスとサブネット マスクを設定します。

ステップ 4

shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#

インターフェイスをディセーブルにします。状態が管理アップから管理ダウンに変化します。

ステップ 5

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#

インターフェイスをイネーブルにします。状態が管理ダウンから管理アップに変化します。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#

コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

Cisco Multi Mode 886VA および 887VA ISR での ADSL または VDSL の設定

シスコの加入者宅内機器(CPE)886VA および 887VA Integrated Services Router(ISR)は、マルチ モードとも呼ばれる、非対称デジタル加入者線(ADSL)1/2/2+ と超高速デジタル加入者線 2(VDSL2)の伝送モードをサポートします。886VA は xDSL over ISDN をサポートし、887VA は xDSL over Plain Old Telephone System(POTS)をサポートします。

デフォルトの CPE 動作モードは auto です。auto モードとは、CPE が Digital Subscriber Line Access Multiplexer(DSLAM; デジタル加入者線アクセス マルチプレクサ)に設定されているモード、ADSL1/2/2+ または VDSL2 にトレーニングされるという意味です。

次の例では、DSLAM が ADSL2+ モードまたは VDSL2 で設定されていて、CPE が auto モードで設定されているものとします。

図 3-1 に、ATM WAN またはイーサネット WAN ネットワーク トポロジを示します。

図 3-1 トポロジの例

 

 


) レイヤ 1 の DSLAM は auto モード用に設定できます。レイヤ 2 の DSLAM は、ATM モードまたは Packet Transfer Mode(PTM)用に設定する必要があります。



) Cisco 886VA および 887VA では、最大 4 つの Permanent Virtual Circuit(PVC; 相手先固定接続)が可能です。


ADSL モードの設定

ADSL モードを設定するには、次の作業を行ってください。

「ADSL auto モードの設定」

「ADSL モードの CPE およびピアの設定」

「ADSL の設定例」

「ADSL 設定の確認」

「ADSL の CPE からピアへの接続の確認」

ADSL auto モードの設定

DSL コントローラを auto モードに設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。


) ルータを設定する前に、DSLAM を ADSL 1/2//2+ モードに設定します。


手順の概要

1. controller vdsl slot

2. operating mode {auto | adsl1 | adsl2 | adsl2+ | vdsl2 | ansl}

3. end

手順の詳細

コマンド
目的

ステップ 1

controller vdsl slot

例:

Router (config) #
Controller vdsl 0

VDSL コントローラのコンフィギュレーション モードを開始します。

ステップ 2

operating mode {auto|adsl1|adsl2|adsl2+|vdsl2|ansl}

例:

Router (config-controller) # operating mode
auto

動作モードを設定します。デフォルトは auto で、これが推奨されるモードです。

ステップ 3

end

例:

Router (config-conroller) # end
Router

コンフィギュレーション モードを終了し、EXEC モードを開始します。

auto で設定した場合は、show running コマンドで動作モードが表示されません。

ADSL モードの CPE およびピアの設定

ADSL を設定するとき、ATM メイン インターフェイスまたは ATM サブ インターフェイスは、PVC と IP アドレスで設定する必要があります。必要に応じて、インターフェイスで no shutdown コマンドを実行します。

ATM CPE 側の設定

ATM CPE 側を設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. interface type number

2. no shutdown

3. interface atm0.1 point-to-point

4. ip address ip-address mask

5. pvc [name] vpi/vci

6. protocol protocol {protocol-address [virtual-template] | inarp} [[no] broadcast |
disable-check-subnet | [no] enable-check-subnet]

7. end

手順の詳細

コマンド
目的

ステップ 1

interface type number

例:

Router (config) # interface atm0

ATM WAN インターフェイス(ATM0)で、コンフィギュレーション モードを開始します。

ステップ 2

no shutdown

例:

Router (config-if) # no shutdown
Router (config-if) #

ATM インターフェイスに対する設定変更をイネーブルにします。

ステップ 3

interface atm0.1 point-to-point

例:

Router (config-if) # interface ATM0.1
point-to-point
Router (config-subif) #

ATM0.1 ポイントツーポイント インターフェイスをイネーブルにします。

ステップ 4

ip address ip-address mask

例:

Router (config-subif)# ip address 30.0.0.1 255.255.255.0

IP アドレスとサブネット マスクを入力します。

ステップ 5

pvc [name] vpi/vci

例:

Router (config-subif) # pvc 13/32
Router (config-if-atm-vc) #

ATM PVC に名前を割り当てるかまたは名前を作成し、ATM 仮想回線コンフィギュレーション モードを開始します。

ステップ 6

protocol protocol {protocol-address [virtual-template] | inarp} [[no] broadcast | disable-check-subnet | [no] enable-check-subnet]

例:

Router (config-if-atm-vc) # protocol ip 30.0.0.2 broadcast

ATM PVC のスタティック マップを設定します。

ステップ 7

end

例:

Router (config-if-atm-vc) # end
Router #

コンフィギュレーション モードを終了し、EXEC モードを開始します。

ADSL の設定例

次に、auto モードに設定する一般的な ADSL2+ 設定例を示します。太字で表示された箇所が重要です。

Router# show running
Building configuration...
 
Current configuration : 1250 bytes
!
! Last configuration change at 02:07:09 UTC Tue Mar 16 2010
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
ip source-route
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO887-V2-K9 sn FHK1313227E
license boot module c880-data level adviperservices
!
!
vtp domain cisco
vtp mode transparet
!
!
controller VDSL 0
!
vlan 2-4
!
!
!
!
!
interface Ethernet 0
no ip address
shutdown
no fair-queue
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termintation multidrop
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
ip address 30.0.0.1 255.255.255.0
pvc 15/32
protocol ip 30.0.0.2 broadcast
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-palne
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
exception data-corruption buffer truncate
end

 

ADSL 設定の確認

特権 EXEC モードで show controller vdsl 0 コマンドを使用して、正しく構成が設定されていることを確認します。太字で表示された箇所が重要です。

Router# show controller vdsl 0
Controller VDSL 0 is UP
 
 
Daemon Status: Up
XTU-R (DS) XTU-C (US)
chip Vendor ID: ‘BDM’ ‘BDCM’
Chip Vendor Specific: 0x0000 0x6110
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: ‘csco’ ‘BDCM’
Modem Vendor Specific: 0x4602 0x6110
Modem Vendor Country: 0xB500 0xB500
Serial Number Near: FHK1313227E 887-V2-K 15.1(20100
Serial Number Far:
Modem Version Nead: 15.1(20100426:193435) [changahn
Modem Version Far: 0x6110

 

Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.992.5 (ADSL2+) Annex A
TC Mode: ATM
Selftest Result: 0x00
DELT configuration: disabled
DELT state: not running
Trellis: ON ON
Line Attenuation: 1.0 dB 1.4 dB
Signal Attenuation: 1.0 dB 0.0 dB
Noise Margin: 6.8 dB 13.6 dB
Atteinable Rate: 25036 kbits/s 1253 kbits/s
Actual Power: 13.7 dBm 12.3 dBM
Total FECS: 0 0
Total ES: 0 0
Total SES: 0 0
Total LOSS: 0 0
Total UAS: 0 0
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0
Bit swap: 163 7
 
Full inits: 32
Failed Full inits: 0
Short inits: 0
Failed short inits: 0
 
 
Firmware Source Filename (version)
-------- ------ ------------------
VDSL embedded VDSL_LINUX_DEV_01212008 (1)
 
 
Modem FW Version: 100426_1053-4.02L.03.A2pv6C030f.d22j
Modem PHY Version: A2pv6C030f.d22j
 

 

DS Channel1 DS Channel0 US Channel1 US channel0
Speed (kbps): 0 24184 0 1047
Previous Speed: 0 24176 0 1047
Total Cells: 0 317070460 0 13723742
User Cells: 0 0 0 0
Reed-solomon EC: 0 0 0 0
CRC Errors: 0 0 0 0
Header Errors: 0 0 0 0
Interleave (ms): 0.00 0.08 0.00 13.56
Actual INP: 0.00 0.00 0.00 1.80
 
 
Training Log: Stopped
Training Log Filename: flash:vdsllog.bin
 

ADSL の CPE からピアへの接続の確認

ピアに ping を発行し、CPE からピアへの構成が正しく設定されていることを確認します。

Router# ping 30.0.0.2 rep 20
 
Type escape sequence to abort.
Sending 20, 100-byte ICMP Echos to 30.0.0.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (20/20), round-trip min/avg/max = 20/22/28 ms
Router#

 

ファスト イーサネット LAN インターフェイスの設定

ルータのファスト イーサネット LAN インターフェイスは、デフォルト VLAN の一部として自動的に設定され、個別のアドレスによる設定は行われません。アクセスは VLAN を通じて提供されます。このインターフェイスを別の VLAN に割り当てることが可能です。

無線 LAN インターフェイスの設定

Cisco 880 シリーズ ワイヤレス ルータは、無線 LAN 接続用の統合 802.11n モジュールを備えています。このルータは、ローカル インフラストラクチャのアクセス ポイントとして機能できます。ワイヤレス接続の設定の詳細については、「ワイヤレス デバイスの基本設定」を参照してください。

ループバック インターフェイスの設定

ループバック インターフェイスは、スタティック IP アドレスのプレースホルダーとして機能し、デフォルトのルーティング情報を提供します。

ループバック インターフェイスを設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. interface type number

2. ip address ip-address mask

3. exit

手順の詳細

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface Loopback 0
Router(config-if)#

ループバック インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 10.108.1.1 255.255.255.0
Router(config-if)#

ループバック インターフェイスの IP アドレスとサブネット マスクを設定します。

ステップ 3

exit

例:

Router(config-if)# exit
Router(config)#

ループバック インターフェイスのコンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードに戻ります。

このコンフィギュレーション例のループバック インターフェイスは、仮想テンプレート インターフェイス上の NAT をサポートするために使用されています。この設定例は、スタティック IP アドレスとなる IP アドレス 200.200.100.1/24 を持つファスト イーサネット インターフェイスに設定されるループバック インターフェイスを示します。ループバック インターフェイスは、ネゴシエートされた IP アドレスを持つ virtual-template1 にポイントバックします。

!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
 

設定の確認

ループバック インターフェイスが正しく設定されたかどうかを確認するには、show interface loopback コマンドを入力します。次の例のような確認用の出力が表示されます。

Router# show interface loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 

ping を実行することによって、ループバック インターフェイスを確認する方法もあります。

Router# ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 
 

スタティック ルートの設定

スタティック ルートは、ネットワークを介した固定ルーティング パスを提供します。これらは、ルータ上で手動で設定されます。ネットワーク トポロジが変更された場合には、スタティック ルートを新しいルートに更新する必要があります。スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベート ルートです。

スタティック ルートを設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

2. end

手順の詳細

コマンド
目的

ステップ 1

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 192.168.1.0 255.255.0.0 10.10.10.2
Router(config)#

IP パケットのスタティック ルートを指定します。

このコマンドの詳細および設定可能なその他のパラメータについては、『 Cisco IOS IP Routing Protocols Command Reference 』を参照してください。

ステップ 2

end

例:

Router(config)# end
Router#

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

次の設定例で、スタティック ルートは、ファスト イーサネット インターフェイスで宛先 IP アドレス 192.168.1.0 およびサブネット マスク 255.255.255.0 を持つすべての IP パケットを、IP アドレス 10.10.10.2 を持つ別のデバイスに送信します。具体的には、パケットが設定済みの PVC に送信されます。

「(default)」と記されているコマンドの入力は不要です。このコマンドは、 show running-config コマンドを使用すると、生成されたコンフィギュレーション ファイルに自動的に表示されます。

!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
 

設定の確認

スタティック ルーティングが正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「S」で表されるスタティック ルートを探します。

次のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
 

ダイナミック ルートの設定

ダイナミック ルーティングでは、ネットワーク トラフィックまたはトポロジに基づいて、ネットワーク プロトコルがパスを自動調整します。ダイナミック ルーティングの変更は、ネットワーク上の他のルータにも反映されます。

Cisco ルータは、Routing Information Protocol(RIP; ルーティング情報プロトコル)または Enhanced Interior Gateway Routing Protocol(EIGRP)などの IP ルーティング プロトコルを使用して、動的にルートを学習します。いずれかのルーティング プロトコルをルータに設定できます。

「Routing Information Protocol の設定」

「拡張インテリア ゲートウェイ ルーティング プロトコルの設定」

Routing Information Protocol の設定

ルータに RIP ルーティング プロトコルを設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. router rip

2. version { 1 | 2 }

3. network ip-address

4. no auto-summary

5. end

手順の詳細

コマンド
作業

ステップ 1

router rip

例:

Router> configure terminal
Router(config)# router rip
Router(config-router)#

ルータ コンフィギュレーション モードを開始します。続いて、ルータの RIP をイネーブルにします。

ステップ 2

version { 1 | 2 }

例:

Router(config-router)# version 2
Router(config-router)#

RIP version 1 または 2 の使用を指定します。

ステップ 3

network ip-address

例:

Router(config-router)# network 192.168.1.1
Router(config-router)# network 10.10.7.1
Router(config-router)#

直接接続しているネットワークの各アドレスを使用して、RIP を適用するネットワーク リストを指定します。

ステップ 4

no auto-summary

例:

Router(config-router)# no auto-summary
Router(config-router)#

ネットワークレベル ルートへのサブネット ルートの自動サマライズをディセーブルにします。これにより、サブプレフィックス ルーティング情報がクラスフル ネットワーク境界を越えて送信されます。

ステップ 5

end

例:

Router(config-router)# end
Router#

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

次の設定例は、IP ネットワーク 10.0.0.0 および 192.168.1.0 でイネーブルにされる RIP version 2 を示します。

設定を表示するには、特権 EXEC モードで show running-config コマンドを使用します。

!
Router# show running-config
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
 

設定の確認

RIP が正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「R」で表される RIP ルートを探します。次の例のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0
 

拡張インテリア ゲートウェイ ルーティング プロトコルの設定

ルータに Enhanced Interior Gateway Routing Protocol(EIGRP; 拡張インテリア ゲートウェイ ルーティング プロトコル)を設定するには、グローバル コンフィギュレーション モードから始め、次の手順を実行します。

手順の概要

1. router eigrp as-number

2. network ip-address

3. end

手順の詳細

コマンド
目的

ステップ 1

router eigrp as-number

例:

Router(config)# router eigrp 109
Router(config)#

ルータ コンフィギュレーション モードを開始して、ルータ上で EIGRP をイネーブルにします。Autonomous System(AS; 自律システム)番号は、他の EIGRP ルータへのルートを識別します。また、EIGRP 情報のタグ付けに使用されます。

ステップ 2

network ip-address

例:

Router(config)# network 192.145.1.0
Router(config)# network 10.10.12.115
Router(config)#

EIGRP を適用するネットワークのリストを指定します(直接接続されているネットワークの IP アドレスを使用)。

ステップ 3

end

例:

Router(config-router)# end
Router#

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

次の設定例は、IP ネットワーク 192.145.1.0 および 10.10.12.115 でイネーブルにされる EIGRP ルーティング プロトコルを示します。EIGRP の自律システム番号として、109 が割り当てられています。

設定を表示するには、特権 EXEC モードで開始し、 show running-config コマンドを使用します。

!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!
 

設定の確認

IP EIGRP が正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「D」で表される EIGRP ルートを探します。次のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0