Cisco 850 / 870 シリーズ アクセス ルータ ソフトウェア コンフィギュレーション ガイド
ワイヤレス LAN 接続の設定
ワイヤレス LAN 接続の設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

ワイヤレス LAN 接続の設定

ルート無線局の設定

VLAN でのブリッジングの設定

無線局サブインターフェイスの設定

設定例

ワイヤレス LAN 接続の設定

Cisco 850 および Cisco 870 シリーズ ルータは、セキュアでコストが低く使いやすいワイヤレス LAN ソリューションをサポートしています。このワイヤレス LAN ソリューションは、ネットワークの専門家が必要とするエンタープライズ クラスの機能を使用してモビリティとフレキシビリティを実現しています。これらのシスコ ルータは、Cisco IOS ソフトウェアをベースとした管理システムを使用して、アクセス ポイントとして機能し、Wi-Fi 認定のIEEE 802.11a/b/g準拠ワイヤレスLANトランシーバになります。

これらのルータの設定およびモニタリングには、CLI(コマンドライン インターフェイス)、ブラウザベースの管理システム、または SNMP(簡易ネットワーク管理プロトコル)を使用できます。この章では、CLI を使用してルータを設定する手順について説明します。デバイスを無線コンフィギュレーション モードにするには、 interface dot11radio グローバル コンフィギュレーション CLI コマンドを使用します。

ワイヤレス LAN でこれらのシスコ ルータを設定する場合の詳細については、『 Cisco Access Router Wireless Configuration Guide 』を参照してください。

図9-1は、ワイヤレス ネットワークの構成を示しています。

図9-1 シスコ ルータへのワイヤレス接続

 

 

1

ワイヤレス LAN(複数のデバイスがネットワークに接続されている)

2

インターネットに接続されたCisco 850またはCisco 870シリーズ アクセス ルータ

3

VLAN 1

4

VLAN 2

次の設定例では、リモート ユーザがワイヤレス接続を使用してCisco 850またはCisco 870シリーズ アクセス ルータにアクセスします。リモート ユーザは、それぞれ固有の VLAN を使用します。

設定作業

このネットワーク構成を設定するには、次の作業を行います。

ルート無線局の設定

VLAN でのブリッジングの設定

無線局サブインターフェイスの設定

これらの作業を行った場合の設定例については、「設定例」を参照してください。


) この章で説明する手順は、基本的なルータ機能に加えて、NAT による PPPoE または PPPoA がすでに設定されていることを前提としています。これらの設定作業が済んでいない場合には、使用しているルータに応じて、「基本的なルータの設定」「NAT による PPPoE の設定」、および「NAT による PPP over ATM の設定」を参照してください。また、DHCP、VLAN、およびセキュア トンネルの設定が完了していても構いません。


ルート無線局の設定

ワイヤレス LAN で使用するルート無線局の作成および設定を行うには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface name number

例:

Router(config)# interface dot11radio 0
Router(config-if)#
 

無線インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

broadcast-key [ vlan vlan-id ] change seconds

例:

Router(config-if)# broadcast-key vlan 1 change 45
Router(config-if)#
 

クライアントに対して使用するブロードキャスト暗号鍵のローテーション間隔を秒単位で指定します。


) ブロードキャスト鍵のローテーションを有効にすると、スタティックWired Equivalent Privacy(WEP)を使用するクライアント デバイスは、アクセス ポイントを使用できなくなります。この場合、アクセス ポイントを使用できるのは、802.1X認証(Light Extensible Authentication Protocol [LEAP]、
Extensible Authentication Protocol ―
Transport Layer Security [EAP-TLS]、またはProtected Extensible Authentication Protocol [PEAP]など)を使用するクライアント デバイスだけです。



) このコマンドはブリッジではサポートされません。


詳しくは、『 Cisco IOS Commands for Access Points and Bridges 』を参照してください。

ステップ 3

encryption method algorithm key

例:

Router(config-if)# encryption vlan 1 mode ciphers tkip
Router(config-if)#
 

ワイヤレス インターフェイスへのアクセスに使用する暗号方式、暗号アルゴリズム、および暗号鍵を指定します。

この例では、VLAN とオプションのデータ暗号方式が使用されています。

ステップ 4

ssid name

例:

Router(config-if)# ssid cisco
Router(config-if-ssid)#
 

ワイヤレス ネットワークの公開名である Service Set ID(SSID; サービス セット ID)を作成します。


) WLAN 上のワイヤレス デバイスはすべて同じ SSID を使用して相互に通信します。


ステップ 5

vlan number

例:

Router(config-if-ssid)# vlan 1
Router(config-if-ssid)#
 

SSID を VLAN に対応付けます。

ステップ 6

authentication type

例:

Router(config-if-ssid)# authentication open
Router(config-if-ssid)# authentication network-eap eap_methods
Router(config-if-ssid)# authentication key-management wpa
 

ワイヤレス LAN にアクセスするユーザに対する認証方式を設定します。

この例に示すように、複数の方式を指定することができます。

ステップ 7

exit

例:

Router(config-if-ssid)# exit
Router(config-if)#
 

SSID コンフィギュレーション モードを終了し、無線インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 8

speed rate

例:

Router(config-if)# basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
Router(config-if)#
 

(任意)ワイヤレス接続上のトラフィックに必要な速度および許容される速度を Mbps 単位で指定します。

ステップ 9

rts [ retries | threshold ]

例:

Router(config-if)# rts threshold 2312
Router(config-if)#
 

(任意)ワイヤレス LAN が到達不能であると判断するための Request to Send(RTS; 送信要求)しきい値または要求の送信回数を指定します。

ステップ 10

power [ client | local ] [ cck [ number | maximum ] | ofdm [ number | maximum ]]

例:

Router(config-if)# power local cck 50
Router(config-if)# power local ofdm 30
Router(config-if)#
 

(任意)無線トランスミッタの出力レベルを指定します。

指定できる出力レベルについては、『 Cisco Access Router Wireless Configuration Guide 』を参照してください。

ステップ 11

channel [ number | least-congested ]

例:

Router(config-if)# channel 2462
Router(config-if)#
 

(任意)通信を行うチャネルを指定します。

指定できるチャネル番号については、『 Cisco Access Router Wireless Configuration Guide 』を参照してください。

ステップ 12

station-role [ repeater | root ]

例:

Router(config-if)# station-role root
Router(config-if)#
 

(任意)この無線インターフェイスの役割を指定します。

必ず 1 つ以上のルート インターフェイスを指定する必要があります。

ステップ 13

exit

例:

Router(config-if)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

VLAN でのブリッジングの設定

VLAN で Integrated Routing and Bridging(IRB)を設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンドまたは操作
目的

ステップ 1

bridge [ number | crb | irb | mac-address-table ]

例:

Router(config)# bridge irb
Router(config)#
 

ブリッジングのタイプを指定します。

この例では、IRB を指定しています。

ステップ 2

interface name number

例:

Router(config)# interface vlan 1
Router(config)#
 

インターフェイス コンフィギュレーション モードを開始します。

この例では、VLAN でブリッジングを設定するために VLAN インターフェイス コンフィギュレーション モードを開始しています。

ステップ 3

bridge-group number

例:

Router(config)# bridge-group 1
Router(config)#
 

インターフェイスにブリッジ グループを割り当てます。

ステップ 4

bridge-group parameter

例:

Router(config)# bridge-group spanning-disabled
Router(config)#
 

ブリッジング インターフェイスで、その他のブリッジ パラメータ設定します。

ステップ 5

interface name number

例:

Router(config)# interface bvi 1
Router(config)#
 

仮想ブリッジ インターフェイスのコンフィギュレーション モードを開始します。

ステップ 6

ip address address mask

例:

Router(config)# ip address 10.0.1.1 255.255.255.0
Router(config)#
 

仮想ブリッジ インターフェイスのアドレスを指定します。

ワイヤレス インターフェイスが必要な各 VLAN に対して、上記のステップ 2ステップ 6を繰り返します。

無線局サブインターフェイスの設定

各ルート無線局のサブインターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface dot11radio 0.1
Router(config-subif)#
 

ルート無線局インターフェイスのサブインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

description string

例:

Router(config-subif)# description Cisco open
Router(config-subif)#
 

管理者ユーザ用にサブインターフェイスの説明を記述します。

ステップ 3

encapsulation dot1q vlanID [ native | second-dot1q ]

例:

Router(config-subif)# encapsulation dot1q 1 native
Router(config-subif)#
 

指定されたサブインターフェイスで IEEE 802.1Q(dot1q)カプセル化を使用するように設定します。

ステップ 4

no cdp enable

例:

Router(config-subif)# no cdp enable
Router(config-subif)#
 

ワイヤレス インターフェイス上での Cisco Discovery Protocol(CDP)の使用をディセーブルにします。

ステップ 5

bridge-group number

例:

Router(config-subif)# bridge-group 1
Router(config-subif)#
 

サブインターフェイスにブリッジ グループを割り当てます。


) bridge-group コマンドがイネーブルの場合、次のコマンドが自動的にイネーブルになり、ディセーブルにすることはできません。次のコマンドをディセーブルにする場合、ワイヤレス装置の通信が中断する可能性があります。


bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

 

ステップ 6

exit

例:

Router(config-subif)# exit
Router(config)#
 

サブインターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

必要に応じて、他のサブインターフェイスを設定する場合は、これらの手順を繰り返します。

設定例

次の設定例は、前述の各項で説明したワイヤレス LAN のコンフィギュレーション ファイルの一部です。

!
bridge irb
!
interface Dot11Radio0
no ip address
!
broadcast-key vlan 1 change 45
!
!
encryption vlan 1 mode ciphers tkip
!
ssid cisco
vlan 1
authentication open
wpa-psk ascii 0 cisco123
authentication key-management wpa
!
ssid ciscowep
vlan 2
authentication open
!
ssid ciscowpa
vlan 3
authentication open
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
power local cck 50
power local ofdm 30
channel 2462
station-role root
!
interface Dot11Radio0.1
description Cisco Open
encapsulation dot1Q 1 native
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.2
encapsulation dot1Q 2
bridge-group 2
bridge-group 2 subscriber-loop-control
bridge-group 2 spanning-disabled
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
!
interface Dot11Radio0.3
encapsulation dot1Q 3
bridge-group 3
bridge-group 3 subscriber-loop-control
bridge-group 3 spanning-disabled
bridge-group 3 block-unknown-source
no bridge-group 3 source-learning
no bridge-group 3 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan2
no ip address
bridge-group 2
bridge-group 2 spanning-disabled
!
interface Vlan3
no ip address
bridge-group 3
bridge-group 3 spanning-disabled
!
interface BVI1
ip address 10.0.1.1 255.255.255.0
!
interface BVI2
ip address 10.0.2.1 255.255.255.0
!
interface BVI3
ip address 10.0.3.1 255.255.255.0
!