Cisco 850 / 870 シリーズ アクセス ルータ ソフトウェア コンフィギュレーション ガイド
DHCP および VLAN を使用した LAN の設定
DHCP および VLAN を使用した LAN の設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

DHCP および VLAN を使用した LAN の設定

DHCP の設定

設定例

DHCP 設定の確認

VLAN の設定

スイッチ ポートの VLAN への割り当て

VLAN 設定の確認

DHCP および VLAN を使用した LAN の設定

Cisco 870 シリーズ ルータは、物理 LAN および VLAN(仮想 LAN)の両方でクライアントをサポートしています。ルータは Dynamic Host Configuration Protocol(DHCP)を使用して、これらのネットワーク上のノードに IP の設定を自動的に割り当てることができます。

図5-1は、ルータによって接続された 2 つの物理 LAN と 2 つの VLAN で構成された一般的なネットワーク構成例を示しています。

図5-1 シスコ ルータ上で DHCP を設定した物理 LAN および仮想 LAN

 

 

1

ファスト イーサネット LAN(複数のデバイスを接続)

2

ルータおよび DHCP サーバ ― Cisco 870 シリーズ アクセス ルータ(インターネットと接続)

3

VLAN 1

4

VLAN 2

DHCP

DHCP(RFC 2131)は、アドレス割り当てを行うためのクライアント/サーバ モデルです。管理者は Cisco 800 シリーズ ルータを DHCP サーバとして設定し、ワークステーションに対して IP アドレス割り当て、およびその他の TCP/IP 設定情報を提供できます。DHCP を使用すると、クライアントごとに IP アドレスを手動で設定するユーザの作業が不要になります。

DHCP サーバを設定する場合は、サーバのプロパティ、ポリシー、および DHCP オプションを設定する必要があります。


) サーバのプロパティを変更する場合は、Network Registrar データベースのコンフィギュレーション データを使用してサーバをリロードする必要があります。


VLAN

Cisco 870 シリーズ アクセス ルータは、VLAN の設定が可能な ファスト イーサネット ポート 4つ をサポートしています。

VLAN を使用すると、ユーザの物理的な配置や LAN 接続に関係なく、ネットワークをセグメント化して、ユーザの論理グループを形成できます。

設定作業

このネットワーク構成を設定するには、次の作業を行います。

DHCP の設定

VLAN の設定


) この章で説明する手順は、基本的なルータ機能に加えて、NAT による PPPoE または PPPoA がすでに設定されていることを前提としています。これらの設定作業が済んでいない場合には、使用しているルータに応じて、「基本的なルータの設定」「NAT による PPPoE の設定」、および「NAT による PPP over ATM の設定」を参照してください。


DHCP の設定

ルータで DHCP を設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

ip domain name name

例:

Router(config)# ip domain name smallbiz.com
Router(config)#
 

完全修飾でないホスト名(ドット付き 10 進表記ドメイン名を使用しない名前)を完成させるためにルータが使用するデフォルト ドメイン名を指定します。

ステップ 2

ip name-server server-address1 [server-address2...server-address6]

例:

Router(config)# ip name-server 192.168.11.12
Router(config)#
 

1 つまたは複数の Domain Name System(DNS; ドメイン ネーム システム)サーバのアドレスを指定して、名前およびアドレスの解決に使用します。

ステップ 3

ip dhcp excluded-address low-address [high-address]

例:

Router(config)# ip dhcp excluded-address 192.168.9.0
 

DHCP サーバから DHCP クライアントへの割り当て対象から除外する IP アドレスを指定します。この例では、ルータのアドレスが除外されています。

ステップ 4

ip dhcp pool name

例:

Router(config)# ip dhcp pool dpool1
Router(config-dhcp)#
 

ルータ上に DHCP アドレス プールを作成し、DHCP プール コンフィギュレーション モードを開始します。 name 引数には、文字列または整数を使用できます。

ステップ 5

network network-number [ mask | prefix-length ]

例:

Router(config-dhcp)# network 10.10.0.0 255.255.255.0
Router(config-dhcp)#
 

DHCP アドレス プールのサブネット番号(IP)アドレスを定義します。オプションでマスクを設定することもできます。

ステップ 6

import all

例:

Router(config-dhcp)# import all
Router(config-dhcp)#
 

DHCP オプション パラメータをルータ データベースの DHCP 部分にインポートします。

ステップ 7

default-router address [ address2 ... address8 ]

例:

Router(config-dhcp)# default-router 10.10.10.10
Router(config-dhcp)#
 

DHCP クライアントのデフォルト ルータを最大 8 つ指定します。

ステップ 8

dns-server address [ address2 ... address8 ]

例:

Router(config-dhcp)# dns-server 192.168.35.2
Router(config-dhcp)#
 

DHCP クライアントが利用できる DNS サーバを最大 8 つ指定します。

ステップ 9

domain-name domain

例:

Router(config-dhcp)# domain-name cisco.com
Router(config-dhcp)#
 

DHCP クライアントのドメイン名を指定します。

ステップ 10

exit

例:

Router(config-dhcp)# exit
Router(config)#
 

DHCP コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

設定例

次の設定例は、この章で説明した DHCP 構成のコンフィギュレーション ファイルの一部です。

ip dhcp excluded-address 192.168.9.0
!
ip dhcp pool dpool1
import all
network 10.10.0.0 255.255.255.0
default-router 10.10.10.10
dns-server 192.168.35.2
domain-name cisco.com
!
ip domain name smallbiz.com
ip name-server 192.168.11.12
 

DHCP 設定の確認

DHCP の設定を確認するには、次のコマンドを使用します。

show ip dhcp import ― DHCP サーバのデータベースにインポートしたオプション パラメータを表示します。

show ip dhcp pool ― DHCP アドレス プールに関する情報を表示します。

show ip dhcp server statistics ― DHCP サーバの統計情報(アドレス プールやバインディングなど)を表示します。

 
Router# show ip dhcp import
Address Pool Name: dpool1
 
Router# show ip dhcp pool
Pool dpool1 :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 0
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
10.10.0.1 10.10.0.1 - 10.10.0.254 0
 
Router# show ip dhcp server statistics
Memory usage 15419
Address pools 1
Database agents 0
Automatic bindings 0
Manual bindings 0
Expired bindings 0
Malformed messages 0
Secure arp entries 0
 
Message Received
BOOTREQUEST 0
DHCPDISCOVER 0
DHCPREQUEST 0
DHCPDECLINE 0
DHCPRELEASE 0
DHCPINFORM 0
 
Message Sent
BOOTREPLY 0
DHCPOFFER 0
DHCPACK 0
DHCPNAK 0
Router#
 

VLAN の設定

ルータで VLAN を設定するには、特権 EXEC モードで次の作業を行います。

 

コマンド
目的

ステップ 1

vlan database

例:

Router# vlan database
Router(vlan)#
 

VLAN コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id [ media type] [ name vlan-name]

例:

Router(vlan)# vlan 2 media ethernet name VLAN0002
Router(vlan)# vlan 3 media ethernet name red-vlan
Router(vlan)#
 

VLAN を追加します(ID の範囲は 2 ~ 1001)。

このコマンドの詳細および設定可能なその他のパラメータについては、『 Cisco IOS Switching Services Command Reference 』を参照してください。

ステップ 3

exit

例:

Router(vlan)# exit
Router#
 

VLAN データベースを更新し、管理ドメイン全体にこれを伝播して、特権 EXEC モードに戻ります。

スイッチ ポートの VLAN への割り当て

スイッチ ポートを VLAN に割り当てるには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface switch port id

例:

Router(config)# interface FastEthernet 2
Router(config-if)#
 

VLAN に割り当てるスイッチ ポートを指定します。

ステップ 2

switchport access vlan vlan-id

例:

Router(config-if)# switchport access vlan 2
Router(config-if)#
 

VLAN にポートを割り当てます。

ステップ 3

end

例:

Router(config-if)# end
Router#
 

インターフェイス モードを終了して特権 EXEC モードに戻ります。

VLAN 設定の確認

VLAN の設定を確認するには、次のコマンドを使用します。

show ― VLAN データベース モードから入力します。すべての設定済み VLAN の設定情報のサマリーを表示します。

show vlan-switch ― 特権 EXEC モードから入力します。すべての設定済み VLAN の詳しい設定情報を表示します。

 
Router# vlan database
Router(vlan)# show
 
VLAN ISL Id: 1
Name: default
Media Type: Ethernet
VLAN 802.10 Id: 100001
State: Operational
MTU: 1500
Translational Bridged VLAN: 1002
Translational Bridged VLAN: 1003
 
VLAN ISL Id: 2
Name: VLAN0002
Media Type: Ethernet
VLAN 802.10 Id: 100002
State: Operational
MTU: 1500
 
VLAN ISL Id: 3
Name: red-vlan
Media Type: Ethernet
VLAN 802.10 Id: 100003
State: Operational
MTU: 1500
 
VLAN ISL Id: 1002
Name: fddi-default
Media Type: FDDI
VLAN 802.10 Id: 101002
State: Operational
MTU: 1500
Bridge Type: SRB
Translational Bridged VLAN: 1
Translational Bridged VLAN: 1003
 
VLAN ISL Id: 1003
Name: token-ring-default
Media Type: Token Ring
VLAN 802.10 Id: 101003
State: Operational
MTU: 1500
Bridge Type: SRB
Ring Number: 0
Bridge Number: 1
Parent VLAN: 1005
Maximum ARE Hop Count: 7
Maximum STE Hop Count: 7
Backup CRF Mode: Disabled
Translational Bridged VLAN: 1
Translational Bridged VLAN: 1002
 
VLAN ISL Id: 1004
Name: fddinet-default
Media Type: FDDI Net
VLAN 802.10 Id: 101004
State: Operational
MTU: 1500
Bridge Type: SRB
Bridge Number: 1
STP Type: IBM
 
VLAN ISL Id: 1005
Name: trnet-default
Media Type: Token Ring Net
VLAN 802.10 Id: 101005
State: Operational
MTU: 1500
Bridge Type: SRB
Bridge Number: 1
STP Type: IBM
 
Router# show vlan-switch
 
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0, Fa1, Fa3
2 VLAN0002 active Fa2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
 
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 1002 1003
2 enet 100002 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 1 1003
1003 tr 101003 1500 1005 0 - - srb 1 1002
1004 fdnet 101004 1500 - - 1 ibm - 0 0
1005 trnet 101005 1500 - - 1 ibm - 0 0