Cisco 850 / 870 シリーズ アクセス ルータ ソフトウェア コンフィギュレーション ガイド
NAT による PPP over ATM の設定
NAT による PPP over ATM の設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

NAT による PPP over ATM の設定

ダイヤラ インターフェイスの設定

ATM WAN インターフェイスの設定

DSL 信号プロトコルの設定

ADSL の設定

設定の確認

SHDSL の設定

設定の確認

NAT の設定

設定例

設定の確認

NAT による PPP over ATM の設定

Cisco 857、Cisco 876、Cisco 877、および Cisco 878 アクセス ルータは、Point-to-Point Protocol over Asynchronous Transfer Mode(ATM; 非同期転送モード)(PPPoA)クライアントおよび Network Address Translation(NAT; ネットワーク アドレス変換)をサポートしています。

ルータの内側にある LAN に複数の PC を接続することができます。これらの PC のトラフィックを PPPoA セッションに送信する前に、暗号化やフィルタリングなどを行うことが可能です。PPP over ATM を使用すると、ダイヤル ネットワークのようにアドレス処理が容易で信頼性の高いユーザ確認機能を持つネットワーク ソリューションを実現できます。図4-1 は、PPPoA クライアントおよびシスコ ルータ上に設定された NAT で構成された一般的なネットワーク構成例を示しています。このネットワーク構成では、1 つのスタティック IP アドレスを使用して ATM 接続を行っています。

図4-1 NAT による PPP over ATM

 

 

1

ネットワークに接続された複数のデバイスを持つ小規模企業 ― デスクトップ、ノート型 PC、スイッチ

2

ファスト イーサネット LAN インターフェイス(NAT の内部インターフェイス、192.168.1.1/24)

3

PPPoA クライアント ― Cisco 857、Cisco 876、Cisco 877、または Cisco 878 ルータ

4

NAT を実行するポイント

5

ATM WAN インターフェイス(NAT の外部インターフェイス)

6

PPPoA クライアントおよび ISP の PPPoA サーバ間の PPPoA セッション

この構成例で、ファスト イーサネット LAN 上の小規模企業またはリモート ユーザがインターネット サービス プロバイダー(ISP)に接続する場合、次のプロトコルを WAN 接続で使用できます。

ADSL over Plain Old Telephone Service(POTS; 加入電話サービス) ― Cisco 857 または Cisco 877 ルータを使用

ADSL over ISDN ― Cisco 876 ルータを使用

Single-pair High-Speed Digital Subscriber Line(G.SHDSL) ― Cisco 878 ルータを使用

ファスト イーサネット インターフェイスは LAN を介してデータ パケットを伝送し、ATM インターフェイス上の PPP 接続にオフロードします。ATM トラフィックはカプセル化されて、ADSL、ISDN、または G.SHDSL 回線を使用して送信されます。ISP との接続にはダイヤラ インターフェイスが使用されます。

PPPoA

ルータの PPPoA クライアント機能を使用すると、ATM インターフェイスで PPPoA クライアントをサポートできます。仮想アクセスをクローニングする場合は、ダイヤラ インターフェイスを使用する必要があります。1 つの ATM インターフェイスで複数の PPPoA クライアント セッションを設定できますが、各セッションは個別のダイヤラ インターフェイスおよび個別のダイヤラ プールを使用する必要があります。

PPPoA セッションは、Cisco 850 または Cisco 870 シリーズ ルータによってクライアント側で開始されます。

NAT

NAT(シスコ ルータのエッジにある点線)は、2 つのアドレッシング ドメインおよび内部の送信元アドレスを示します。パケットがネットワークを通過する方法は、送信元リストによって定義されます。

設定作業

このネットワーク構成を設定するには、次の作業を行います。

ダイヤラ インターフェイスの設定

ATM WAN インターフェイスの設定

DSL 信号プロトコルの設定

NAT の設定

これらの作業を行った場合の設定例については、「設定例」を参照してください。

ダイヤラ インターフェイスの設定

ダイヤラ インターフェイスでは、クライアント トラフィックの処理方法(デフォルトのルーティング情報、カプセル化プロトコル、およびダイヤラ プールなど)を指定します。ダイヤラ インターフェイスは、仮想アクセスをクローニングする場合にも使用します。1 つの ATM インターフェイスで複数の PPPoA クライアント セッションを設定できますが、各セッションは個別のダイヤラ インターフェイスおよび個別のダイヤラ プールを使用する必要があります。

ルータの ATM インターフェイスでダイヤラ インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface dialer dialer-rotary-group-number

例:

Router(config)# interface dialer 0
Router(config-if)#
 

ダイヤラ インターフェイス(0 ~ 255 の番号を指定)を作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip address negotiated

例:

Router(config-if)# ip address negotiated
Router(config-if)#
 

PPP/IPCP(IP Control Protocol)アドレス ネゴシエーションを使用してダイヤラ インターフェイスの IP アドレスを取得するように設定します。

ステップ 3

ip mtu bytes

例:

Router(config-if)# ip mtu 4470
Router(config-if)#
 

IP Maximum Transmission Unit(MTU;最大伝送ユニット)のサイズを設定します。デフォルトの最小値は 128 バイトです。ATM の場合の最大値は 4470 バイトです。

ステップ 4

encapsulation encapsulation-type

例:

Router(config-if)# encapsulation ppp
Router(config-if)#
 

送受信されるデータ パケットのカプセル化タイプを PPP に設定します。

ステップ 5

ppp authentication { protocol1 [ protocol2 ...]}

例:

Router(config-if)# ppp authentication chap
Router(config-if)#
 

PPP 認証方式を設定します。

この例では、Challenge Handshake Authentication Protocol(CHAP)を使用しています。

このコマンドの詳細および設定可能なその他のパラメータについては、『Cisco IOS Security Command Reference』を参照してください。

ステップ 6

dialer pool number

例:

Router(config-if)# dialer pool 1
Router(config-if)#
 

特定の宛先サブネットワークに接続する場合に使用するダイヤラ プールを指定します。

ステップ 7

dialer-group group-number

例:

Router(config-if)# dialer-group 1
Router(config-if)#
 

ダイヤラ インターフェイスをダイヤラ グループ(1 ~ 10)に割り当てます。


ヒント ダイヤラ グループを使用してルータへのアクセスを制御します。

ステップ 8

exit

例:

Router(config-if)# exit
Router(config)#
 

dialer 0 のインターフェイス コンフィギュレーション モードを終了します。

ステップ 9

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

例:

Router(config)# dialer-list 1 protocol ip permit
Router(config)#
 

ダイヤラ リストを作成して、ダイヤラ グループをダイヤラ リストに関連付けます。この場合、パケットは指定されたインターフェイス ダイヤラ グループを使用して転送されます。

このコマンドの詳細および設定可能なその他のパラメータについては、『Cisco IOS Dial Technologies Command Reference』を参照してください。

ステップ 10

ip route prefix mask { interface-type interface-number }

例:

Router(config)# ip route 10.10.25.2 0.255.255.255 dialer 0
Router(config)#
 

dialer 0 インターフェイスにデフォルト ゲートウェイの IP ルートを設定します。

このコマンドの詳細および設定可能なその他のパラメータについては、『Cisco IOS IP Command Reference, Volume 1 of 4: Routing Protocols』を参照してください。

ダイヤラ インターフェイスまたはダイヤラ プールを追加する場合は、これらの手順を繰り返します。

ATM WAN インターフェイスの設定

ATM インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface atm 0
Router(config-if)#
 

ATM インターフェイス(ルータの背面に
ADSLoPOTS または G.SHDSL と表示)のインターフェイス コンフィギュレーション モードを開始します。


) このインターフェイスは、基本的なルータの設定を行う際に設定されています。「WAN インターフェイスの設定」を参照してください。


ステップ 2

pvc vpi / vci

例:

Router(config-if)# pvc 8/35
Router(config-if-atm-vc)#
 

ルータが通信するエンド ノード(最大 10)ごとの ATM PVC を作成します。ATM Virtual Circuit(VC; 仮想回線)コンフィギュレーション モードを開始します。

PVC を定義すると、AAL5SNAP カプセル化がデフォルトで定義されます。これを変更する場合は、
encapsulation
コマンドを使用します(ステップ 3を参照)。VPI および VCI の引数を同時にゼロに設定することはできません。一方がゼロの場合、もう一方はゼロ以外の値に設定する必要があります。

このコマンドの詳細および設定可能なその他のパラメータについては、『Cisco IOS Wide-Area Networking Command Reference』を参照してください。

ステップ 3

encapsulation { aal5auto | aal5autoppp virtual-template number [ group group-name ] | aal5ciscoppp virtual-template number | aal5mux protocol | aal5nlpid | aal5snap }

例:

Router(config-if-atm-vc)# encapsulation aal5mux ppp dialer
Router(config-if-atm-vc)#
 

PVC のカプセル化タイプとダイヤラ インターフェイスを指定します。

このコマンドの詳細および設定可能なその他のパラメータについては、『Cisco IOS Wide-Area Networking Command Reference』を参照してください。

ステップ 4

dialer pool-member number

例:

Router(config-if-atm-vc)# dialer pool-member 1
Router(config-if-atm-vc)#
 

ATM インターフェイスをダイヤラ プロファイルのダイヤリング プールのメンバーに指定します。プール番号は 1 ~ 255 の範囲で指定します。

ステップ 5

no shutdown

例:

Router(config-if-atm-vc)# no shutdown
Router(config-if)#
 

ATM インターフェイスに対するインターフェイスおよび設定の変更をイネーブルにします。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

ATM インターフェイスのコンフィギュレーション モードを終了します。

DSL 信号プロトコルの設定

ISP と接続するには、ATM インターフェイスで Digital Subscriber Line(DSL; デジタル加入者線)信号方式を設定する必要があります。Cisco 857 および Cisco 877 ルータは POTS 上の ADSL 信号をサポートし、Cisco 876 は ISDN 上の ADSL 信号をサポートし、Cisco 878 は SHDSL 信号をサポートしています。設定するルータに基づいて次の各項を参照し、適切な DSL 信号プロトコルを設定してください。

ADSL の設定

SHDSL の設定

ADSL の設定

ADSL 信号のデフォルト設定は、 表4-1 のとおりです。

 

表4-1 デフォルトの ADSL 設定

属性
説明
デフォルト値

動作モード

ATM インターフェイスでの DSL の動作モードを指定します。

ADSL over POTS ― ANSI または ITU フル レート、または自動選択

ADSL over ISDN ― ITUフル レート、ETSI、または自動選択

自動

マージン ロス

マージン ロスの発生許容回数を指定します。

--

Training ログ

training ログをイネーブルまたはディセーブルに切り替えます。

ディセーブル

これらの設定を変更する場合には、グローバル コンフィギュレーション モードで次のいずれかのコマンドを使用します。

dsl operating-mode (ATM インターフェイス コンフィギュレーション モードで実行)

dsl lom integer

dsl enable-training-log

これらのコマンドの詳細については、『Cisco IOS Wide-Area Networking Command Reference』を参照してください。

設定の確認

設定を確認するには、特権 EXEC モードで show dsl interface atm コマンドを使用します。

SHDSL の設定

ルータで SHDSL 信号を使用するように DSL コントローラを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

controller dsl port

例:

Router(config)# controller dsl 0
Router(config-controller)#
 

DSL コントローラのコンフィギュレーション モードを開始します。

ステップ 2

line-term { co | cpe }

例:

Router(config-controller)# line-term co
Router(config-controller)#
 

DSL 回線をセントラル オフィス(CO)または Customer Premises Equipment(CPE; 顧客宅内機器)のいずれで終端するかを指定します。

ステップ 3

exit

例:

Router(config-controller)# exit
Router(config)#
 

コントローラのコンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 4

mode protocol

例:

Router(config)# mode atm
Router(config-controller)#
 

DSL コントローラのモードを指定して、コントローラ コンフィギュレーション モードを開始します。

ステップ 5

line-mode { 4-wire | 2-wire }

例:

Router(config-controller)# line-mode 4-wire
Router(config-controller)#
 

DSL 接続の動作モードを 2 線または 4 線に指定します。

ステップ 6

ignore-error-duration number

例:

Router(config-controller)# ignore-error-duration 15
Router(config-controller)#
 

エラーを無視する時間(15 ~ 30 秒)を指定します。

ステップ 7

exit

例:

Router(config-controller)# exit
Router(config)#
 

コントローラのコンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。


) シスコ ルータを欧州のネットワークで使用する場合には、dsl dsl-mode shdsl symmetric annex {A | B}コマンドを使用して annex B を選択します。ルータは、デフォルトで annex A を使用します(米国)。


設定の確認

設定を確認するには、特権 EXEC モードで show controllers dsl コマンドを使用します。

Router# show controllers dsl 0
DSL 0 controller UP
SLOT 0: Globespan xDSL controller chipset
DSL mode: SHDSL Annex A
Frame mode: Utopia
Configured Line rate: Auto
Line Re-activated 6 times after system bootup
LOSW Defect alarm: ACTIVE
CRC per second alarm: ACTIVE
Line termination: CPE
 
Current 15 min CRC: 0
Current 15 min LOSW Defect: 0
Current 15 min ES Defect: 0
Current 15 min SES Defect: 0
Current 15 min UAS Defect: 33287
 
Previous 15 min CRC Defect: 0
Previous 15 min LOSW Defect: 0
Previous 15 min ES Defect: 0
Previous 15 min SES Defect: 0
Previous 15 min UAS Defect: 0
 
Line-0 status
Chipset Version: 0
Firmware Version: A388
Modem Status: Data, Status 1
Last Fail Mode: No Failure status:0x0
Line rate: 2312 Kbps
Framer Sync Status: In Sync
Rcv Clock Status: In the Range
Loop Attenuation: 341.1450 dB
Transmit Power: 7.5 dB
Receiver Gain: 22.5420 dB
SNR Sampling: 36.8590 dB
Dying Gasp: Present
 

NAT の設定

NAT は、ダイヤラ インターフェイスによって割り当てられたグローバル アドレスを使用して標準アクセス リストと一致するアドレスからのパケットを変換します。ルータの内部インターフェイスに着信するパケット、またはルータから送出されるパケット(あるいは、その両方)は、アドレス変換用のアクセス リストと照合されます。NAT の設定では、スタティックまたはダイナミック アドレス変換を使用できます。

外部の ATM WAN インターフェイスをダイナミック NAT に設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

ip nat pool name start-ip end-ip { netmask netmask | prefix-length prefix-length }

例:

Router(config)# ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 255.255.255.0
Router(config)#
 

NAT に使用するグローバル IP アドレスのプールを作成します。

ステップ 2

ip nat inside source {list access-list-number } {interface type number | pool name } [overload]

例 1:

Router(config)# ip nat inside source list 1 interface dialer 0 overload
 

または

例 2:

Router(config)# ip nat inside source list acl1 pool pool1
 

内部のインターフェイスでダイナミック アドレス変換をイネーブルにします。

例 1 では、アクセス リスト 1 で許可されたアドレスが、ダイヤラ インターフェイス 0 で指定されたいずれかのアドレスに変換されます。

例 2 では、アクセス リスト acl1 で許可されたアドレスが、NAT プール pool1 で指定されたいずれかのアドレスに変換されます。

このコマンドの詳細および設定可能なその他のパラメータ、ならびにスタティック トランスレーションのイネーブル化については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services』を参照してください。

ステップ 3

interface type number

例:

Router(config)# interface vlan 1
Router(config-if)#
 

NAT の内部インターフェイスとなる VLAN(ファスト イーサネット LAN インターフェイス [FE0 ~ FE3] が存在)のコンフィギュレーション モードを開始します。

ステップ 4

ip nat {inside | outside}

例:

Router(config-if)# ip nat inside
Router(config-if)#
 

内部インターフェイスであるファスト イーサネット LAN インターフェイスに NAT を適用します。

このコマンドの詳細および設定可能なその他のパラメータ、ならびにスタティック トランスレーションのイネーブル化については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services』を参照してください。

ステップ 5

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

イーサネット インターフェイスに対する設定の変更をイネーブルにします。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

ファスト イーサネット インターフェイスのコンフィギュレーション モードを終了します。

ステップ 7

interface type number

例:

Router(config)# interface atm 0
Router(config-if)#
 

NAT の外部インターフェイスとなる ATM WAN インターフェイス(ATM0)のコンフィギュレーション モードを開始します。

ステップ 8

ip nat {inside | outside}

例:

Router(config-if)# ip nat outside
Router(config-if)#
 

指定された WAN インターフェイスを NAT の外部インターフェイスにします。

このコマンドの詳細および設定可能なその他のパラメータ、ならびにスタティック トランスレーションのイネーブル化については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services』を参照してください。

ステップ 9

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

イーサネット インターフェイスに対する設定の変更をイネーブルにします。

ステップ 10

exit

例:

Router(config-if)# exit
Router(config)#
 

ATM インターフェイスのコンフィギュレーション モードを終了します。

ステップ 11

access-list access-list-number { deny | permit} source [ source-wildcard ]

例:

Router(config)# access-list 1 permit 192.168.1.0 255.255.255.0
 

変換が必要なアドレスを許可する標準アクセス リストを定義します。


) その他のアドレスはすべて自動的に deny(拒否)に設定されます。



) NAT を仮想テンプレート インターフェイスで使用する場合には、ループバック インターフェイスを設定する必要があります。ループバック インターフェイスの設定については、「基本的なルータの設定」を参照してください。


NAT コマンドの詳細については、Cisco IOS Release 12.3のマニュアルを参照してください。NAT の概要については、 付録 B「概要」 を参照してください。

設定例

次の設定例は、この章で説明した PPPoA 構成例のクライアント用コンフィギュレーション ファイルの一部です。

VLAN インターフェイスの IP アドレスは 192.168.1.1 であり、サブネット マスクは 255.255.255.0 です。NAT は内部と外部に対して設定されています。


) 「(default)」と表記されているコマンドは、show running-configコマンドの実行時に自動的に生成されます。


!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly (default)
!
interface ATM0
no ip address
ip nat outside
ip virtual-reassembly
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface Dialer0
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
!
ip classless (default)
!
ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
 
ip route 10.10.25.2 0.255.255.255 dialer 0
!
 

設定の確認

NAT による PPPoA の設定を確認するには、特権 EXEC モードでshow ip nat statisticsコマンドを使用します。確認出力は、次の例のように表示されます。

Router# show ip nat statistics
Total active translations: 0 (0 static, 0 dynamic; 0 extended)
Outside interfaces:
ATM0
Inside interfaces:
Vlan1
Hits: 0 Misses: 0
CEF Translated packets: 0, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 1 interface Dialer0 refcount 0
Queued Packets: 0