Cisco 850 / 870 シリーズ アクセス ルータ ソフトウェア コンフィギュレーション ガイド
NAT による PPPoE の設定
NAT による PPPoE の設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

NAT による PPPoE の設定

VPDN グループ番号の設定

ファスト イーサネット WAN インターフェイスの設定

ダイヤラ インターフェイスの設定

NAT の設定

設定例

設定の確認

NAT による PPPoE の設定

Cisco 851 および Cisco 871 アクセス ルータは、Point-to-Point Protocol over Ethernet(PPPoE)クライアントおよび Network Address Translation(NAT; ネットワーク アドレス変換)をサポートしています。

ルータの内側にある LAN に複数の PC を接続することができます。これらの PC のトラフィックを PPPoE セッションに送信する前に、暗号化やフィルタリングなどを行うことが可能です。図3-1 は、PPPoE クライアントおよびシスコ ルータ上に設定された NAT で構成された一般的なネットワーク構成例を示しています。

図3-1 NAT による PPPoE

 

 

1

ネットワークに接続された複数のデバイス ― デスクトップ、ノート型 PC、スイッチ

2

ファスト イーサネット LAN インターフェイス(NAT の内部インターフェイス)

3

PPPoE クライアント ― Cisco 851 または Cisco 871 アクセス ルータ

4

NAT を実行するポイント

5

ファスト イーサネット WAN インターフェイス(NAT の外部インターフェイス)

6

インターネットに接続されたケーブル モデムまたはその他のサーバ(Cisco 6400 サーバなど)

7

PPPoE クライアントおよび PPPoE サーバ間の PPPoE セッション

PPPoE

ルータの PPPoE クライアント機能を使用すると、イーサネット インターフェイスで PPPoE クライアントをサポートできます。仮想アクセスをクローニングする場合は、ダイヤラ インターフェイスを使用する必要があります。1 つのイーサネット インターフェイスで複数の PPPoE クライアント セッションを設定できますが、各セッションは個別のダイヤラ インターフェイスおよび個別のダイヤラ プールを使用する必要があります。

PPPoE セッションは Cisco 850 または Cisco 870 シリーズ ルータによってクライアント側で開始されます。確立された PPPoE クライアント セッションは、次のいずれかの方法で終了できます。

clear vpdn tunnel pppoeコマンドを実行します。PPPoE クライアント セッションは終了し、PPPoE クライアントはただちにセッションを再度確立しようとします。この動作はセッションがタイムアウトする場合にも実行されます。

no pppoe-client dial-pool number コマンドを実行してセッションをクリアします。PPPoE クライアントはセッションを再度確立しようとはしません。

NAT

NAT(シスコ ルータのエッジにある点線)は、2 つのアドレッシング ドメインおよび内部の送信元アドレスを示します。パケットがネットワークを通過する方法は、送信元リストによって定義されます。

設定作業

このネットワーク構成を設定するには、次の作業を行います。

VPDN グループ番号の設定

ファスト イーサネット WAN インターフェイスの設定

ダイヤラ インターフェイスの設定

NAT の設定

これらの作業を行った場合の設定例については、「設定例」を参照してください。

VPDN グループ番号の設定

Virtual Private Dialup Network(VPDN; 仮想私設ダイヤルアップ網)を設定すると、複数のクライアントが 1 つの IP アドレスを使用してルータ経由で通信できます。

VPDN を設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。このモードを開始する場合の詳細については、「グローバル パラメータの設定」を参照してください。

 

コマンドまたは操作
目的

ステップ 1

vpdn enable

例:

Router(config)# vpdn enable
Router(config-vpdn)#
 

ルータ上で VPDN をイネーブルにします。

ステップ 2

vpdn group name

例:

Router(config-vpdn)# vpdn group 1
Router(config-vpdn-grp)#
 

VPDN グループを作成して、カスタマーまたは VPDN プロファイルに関連付けます。

ステップ 3

request-dialin

例:

Router(config-vpdn-grp)# request-dialin
Router(config-vpdn-grp)#
 

VPND の request-dialin サブグループ(ダイヤリング方向を示す)を作成して、トンネルを開始します。

ステップ 4

initiate to ip ip-address

例:

Router(config-vpdn-grp)# initiate to 192.168.1.1
Router(config-vpdn-grp)#
 

要求をトンネリングするアドレスを指定します。

このコマンドの詳細および設定可能なその他のパラメータについては、『 Cisco IOS Dial Technologies Command Reference』を参照してください。

ステップ 5

protocol { l2f | l2tp | pppoe | any }

例:

Router(config-vpdn-grp)# protocol pppoe
Router(config-vpdn-grp)#
 

VPDN のサブグループが確立するセッション タイプを指定します。

ステップ 6

exit

例:

Router(config-vpdn-grp)# exit
Router(config-vpdn)#
 

VPDN グループ コンフィギュレーションを終了します。

ステップ 7

exit

例:

Router(config-vpdn)# exit
Router(config)#
 

VPDN コンフィギュレーションを終了し、グローバル コンフィギュレーション モードに戻ります。

ファスト イーサネット WAN インターフェイスの設定

この構成例では、PPPoE クライアント(シスコ ルータ)は LAN 側と WAN 側の両方で 10/100 Mbps イーサネット インターフェイスを使用して通信します。

ファスト イーサネット WAN インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface fastethernet 4
Router(config-if)#
 

ファスト イーサネット WAN インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

pppoe-client dial-pool-number number

例:

Router(config-if)# pppoe-client dial-pool-number 1
Router(config-if)#
 

PPPoE クライアントを設定して、クローニングに使用するダイヤラ インターフェイスを指定します。

ステップ 3

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

ファスト イーサネット インターフェイスおよびこのインターフェイスに加えられた設定変更をイネーブルにします。

ステップ 4

exit

例:

Router(config-if)# exit
Router(config)#
 

ファスト イーサネット インターフェイスのコンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ダイヤラ インターフェイスの設定

ダイヤラ インターフェイスでは、クライアント トラフィックの処理方法(デフォルトのルーティング情報、カプセル化プロトコル、およびダイヤラ プールなど)を指定します。ダイヤラ インターフェイスは、仮想アクセスをクローニングする場合にも使用します。1 つのファスト イーサネット インターフェイスで複数の PPPoE クライアント セッションを設定できますが、各セッションは個別のダイヤラ インターフェイスおよび個別のダイヤラ プールを使用する必要があります。

ルータ上のいずれかのファスト イーサネット LAN インターフェイスでダイヤラ インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface dialer dialer-rotary-group-number

例:

Router(config)# interface dialer 0
Router(config-if)#
 

ダイヤラ インターフェイス(0 ~ 255 の番号を指定)を作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip address negotiated

例:

Router(config-if)# ip address negotiated
Router(config-if)#
 

PPP/IPCP(IP Control Protocol)アドレス ネゴシエーションを使用してインターフェイスの IP アドレスを取得するように設定します。

ステップ 3

ip mtu bytes

例:

Router(config-if)# ip mtu 1492
Router(config-if)#
 

IP Maximum Transmission Unit(MTU;最大伝送ユニット)のサイズを設定します。デフォルトの最小値は 128 バイトです。イーサネットの最大値は 1492 バイトです。

ステップ 4

encapsulation encapsulation-type

例:

Router(config-if)# encapsulation ppp
Router(config-if)#
 

送受信されるデータ パケットのカプセル化タイプを PPP に設定します。

ステップ 5

ppp authentication { protocol1 [ protocol2 ...]}

例:

Router(config-if)# ppp authentication chap
Router(config-if)#
 

PPP 認証方式を Challenge Handshake Authentication Protocol(CHAP)に設定します。

このコマンドの詳細および設定可能なその他のパラメータについては、『Cisco IOS Security Command Reference』を参照してください。

ステップ 6

dialer pool number

例:

Router(config-if)# dialer pool 1
Router(config-if)#
 

特定の宛先サブネットワークに接続する場合に使用するダイヤラ プールを指定します。

ステップ 7

dialer-group group-number

例:

Router(config-if)# dialer group 1
Router(config-if)#
 

ダイヤラ インターフェイスをダイヤラ グループ(1 ~ 10)に割り当てます。


ヒント ダイヤラ グループを使用してルータへのアクセスを制御します。

ステップ 8

exit

例:

Router(config-if)# exit
Router(config)#
 

dialer 0 のインターフェイス コンフィギュレーション モードを終了します。

ステップ 9

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

例:

Router(config)# dialer-list 1 protocol ip permit
Router(config)#
 

ダイヤラ リストを作成して、ダイヤラ グループをダイヤラ リストに関連付けます。この場合、パケットは指定されたインターフェイス ダイヤラ グループを使用して転送されます。

このコマンドの詳細および設定可能なその他のパラメータについては、『Cisco IOS Dial Technologies Command Reference』を参照してください。

ステップ 10

ip route prefix mask { interface-type interface-number }

例:

Router(config)# ip route 10.10.25.2 0.255.255.255 dialer 0
Router(config)#
 

dialer 0 インターフェイスにデフォルト ゲートウェイの IP ルートを設定します。

このコマンドの詳細および設定可能なその他のパラメータについては、『Cisco IOS IP Command Reference, Volume 2; Routing Protocols』を参照してください。

NAT の設定

NAT は、ダイヤラ インターフェイスによって割り当てられたグローバル アドレスを使用して標準アクセス リストと一致するアドレスからのパケットを変換します。ルータの内部インターフェイスに着信するパケット、またはルータから送出されるパケット(あるいは、その両方)は、アドレス変換用のアクセス リストと照合されます。NAT の設定では、スタティックまたはダイナミック アドレス変換を使用できます。

外部のファスト イーサネット WAN インターフェイスをダイナミック NAT に設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

ip nat pool name start-ip end-ip { netmask netmask | prefix-length prefix-length }

例:

Router(config)# ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 255.255.255.0
Router(config)#
 

NAT に使用するグローバル IP アドレスのプールを作成します。

ステップ 2

ip nat inside source {list access-list-number } {interface type number | pool name } [overload]

例 1:

Router(config)# ip nat inside source list 1 interface dialer 0 overload
 

または

例 2:

Router(config)# ip nat inside source list acl1 pool pool1
 

内部のインターフェイスでダイナミック アドレス変換をイネーブルにします。

例 1 では、アクセス リスト 1 で許可されたアドレスが、ダイヤラ インターフェイス 0 で指定されたいずれかのアドレスに変換されます。

例 2 では、アクセス リスト acl1 で許可されたアドレスが、NAT プール pool1 で指定されたいずれかのアドレスに変換されます。

このコマンドの詳細および設定可能なその他のパラメータ、ならびにスタティック トランスレーションのイネーブル化については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services』を参照してください。

ステップ 3

interface type number

例:

Router(config)# interface vlan 1
Router(config-if)#
 

NAT の内部インターフェイスとなる VLAN(ファスト イーサネット LAN インターフェイス [FE0 ~ FE3] が存在)のコンフィギュレーション モードを開始します。

ステップ 4

ip nat { inside | outside }

例:

Router(config-if)# ip nat inside
Router(config-if)#
 

指定された VLAN インターフェイスを NAT の内部インターフェイスにします。

このコマンドの詳細および設定可能なその他のパラメータ、ならびにスタティック トランスレーションのイネーブル化については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services』を参照してください。

ステップ 5

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

イーサネット インターフェイスに対する設定の変更をイネーブルにします。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

ファスト イーサネット インターフェイスのコンフィギュレーション モードを終了します。

ステップ 7

interface type number

例:

Router(config)# interface fastethernet 4
Router(config-if)#
 

NAT の外部インターフェイスとなるファスト イーサネット WAN インターフェイス(FE4)のコンフィギュレーション モードを開始します。

ステップ 8

ip nat { inside | outside }

例:

Router(config-if)# ip nat outside
Router(config-if)#
 

指定された WAN インターフェイスを NAT の外部インターフェイスにします。

このコマンドの詳細および設定可能なその他のパラメータ、ならびにスタティック トランスレーションのイネーブル化については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services』を参照してください。

ステップ 9

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

イーサネット インターフェイスに対する設定の変更をイネーブルにします。

ステップ 10

exit

例:

Router(config-if)# exit
Router(config)#
 

ファスト イーサネット インターフェイスのコンフィギュレーション モードを終了します。

ステップ 11

access-list access-list-number { deny | permit } source [ source-wildcard ]

例:

Router(config)# access-list 1 permit 192.168.1.0 255.255.255.0
 

変換が必要なアドレスを示す標準アクセス リストを定義します。


) その他のアドレスはすべて自動的に deny(拒否)に設定されます。



) NAT を仮想テンプレート インターフェイスで使用する場合には、ループバック インターフェイスを設定する必要があります。ループバック インターフェイスの設定については、「基本的なルータの設定」を参照してください。


NAT コマンドの詳細については、Cisco IOS Release 12.3のマニュアルを参照してください。NAT の概要については、 付録 B「概要」 を参照してください。

設定例

次の設定例は、この章で説明した PPPoE 構成例のコンフィギュレーション ファイルの一部です。

VLAN インターフェイスの IP アドレスは 192.168.1.1 であり、サブネット マスクは 255.255.255.0 です。NAT は内部と外部に対して設定されています。


) 「(default)」と表記されているコマンドは、show running-configコマンドの実行時に自動的に生成されます。


!
vpdn enable
vpdn-group 1
request-dialin
protocol pppoe
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast (default)
ip nat inside
!
interface FastEthernet 4
ip address 192.168.12.2 255.255.255.0
no ip directed-broadcast (default)
ip nat outside
!
interface dialer 1
ip address negotiated
ppp authentication chap
dialer pool 1
dialer-group 1
!
dialer-list 1 protocol ip permit
ip nat inside source list 1 interface dialer 0 overload
ip classless (default)
ip route 10.10.25.2 0.255.255.255 dialer 0
!
 

設定の確認

NAT による PPPoE の設定を確認するには、特権 EXEC モードでshow ip nat statisticsコマンドを使用します。確認出力は、次の例のように表示されます。

Router# show ip nat statistics
Total active translations: 0 (0 static, 0 dynamic; 0 extended)
Outside interfaces:
FastEthernet4
Inside interfaces:
Vlan1
Hits: 0 Misses: 0
CEF Translated packets: 0, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 1 interface Dialer0 refcount 0
Queued Packets: 0