Cisco 850 / 870 シリーズ アクセス ルータ ソフトウェア コンフィギュレーション ガイド
ダイヤル バックアップおよびリモート 管理の設定
ダイヤル バックアップおよびリモート管理の設定
発行日;2012/02/02 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

ダイヤル バックアップおよびリモート管理の設定

ダイヤル バックアップ機能のアクティブ化

バックアップ インターフェイス

バックアップ インターフェイスの設定

フローティング スタティック ルート

フローティング スタティック ルートの設定

ダイヤラ ウォッチ

ダイヤラ ウォッチの設定

ダイヤル バックアップ機能の制約事項

設定例

コンソール ポートまたは AUX ポートを使用したダイヤル バックアップおよびリモート管理の設定

設定作業

設定例

ISDN S/T ポートを使用したダイヤル バックアップおよびリモート管理の設定

設定作業

ISDN の設定

アグリゲータおよび ISDN ピア ルータの設定

ダイヤル バックアップおよびリモート管理の設定

Cisco 800 シリーズ アクセス ルータは、ダイヤルイン(リモート管理用)およびダイヤルアウト(ダイヤル バックアップ用)の機能をサポートしています。Cisco 800 シリーズ アクセス ルータは、バックアップ モデム回線接続を設定できるため、WAN のダウンタイムを防止することができます。デフォルトで、ダイヤル バックアップは非アクティブになっているため、アクティブにするには設定を行う必要があります。

ダイヤル バックアップ機能は、次の方法で設定できます。

Cisco 870シリーズ ルータの AUX ポートを使用

アドバンスト エンタープライズ イメージ(c870-adventerprisek9-mz)を使用した Cisco 876 の ISDN S/T ポートを使用

リモート管理機能は、次の方法で設定できます。

Cisco 850 または Cisco 870 シリーズ ルータの AUX ポートを使用

Cisco 876 および Cisco 878 ルータの ISDN S/T ポートを使用


) Cisco IOS ソフトウェアのコンフィギュレーションでは、コンソール ポートと AUX ポートは同じ RJ-45 ポート上にあるため、両方のポートを同時にアクティブにすることはできません。また、目的の機能を有効にするには、CLI(コマンドライン インターフェイス)を使用する必要があります。


この章では、次の内容について説明します。

ダイヤル バックアップ機能のアクティブ化

ダイヤル バックアップ機能の制約事項

コンソール ポートまたは AUX ポートを使用したダイヤル バックアップおよびリモート管理の設定

ISDN S/T ポートを使用したダイヤル バックアップおよびリモート管理の設定

ダイヤル バックアップ機能のアクティブ化

ダイヤル バックアップ機能は、次の 3 通りの方法でアクティブ化できます。

バックアップ インターフェイス

フローティング スタティック ルート

ダイヤラ ウォッチ

バックアップ インターフェイス

プライマリ回線がダウンしていることをルータが検出すると、バックアップ インターフェイスが起動します。指定された期間中にプライマリ回線が復旧した場合、バックアップ インターフェイスがダウンするように設定することができます。

この機能は、Dial-on-Demand Routing(DDR; ダイヤル オンデマンド ルーティング)を使用して実現されます。バックアップ インターフェイスを設定した場合、指定されたトラフィックがバックアップ コールのトリガーになります。


) バックアップ インターフェイスがスタンバイ モードから起動した場合も、ルータはバックアップ インターフェイスに関する指定されたトラフィックを受信しない限り、バックアップ コールをトリガしません。


バックアップ インターフェイスの設定

ルータでバックアップ インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface atm 0
Router(config-if)#
 

バックアップの設定を行うインターフェイスで、インターフェイス コンフィギュレーション モードを開始します。

ここで指定できるのは、シリアル インターフェイス、ISDN インターフェイス、または非同期インターフェイスです。

この例では、ATM WAN 接続のバックアップ インターフェイスを設定しています。

ステップ 2

backup interface interface-type interface-number

例:

Router(config-if)# backup interface bri 0
Router(config-if)#
 

インターフェイスをセカンダリ(バックアップ インターフェイス)に指定します。

ここで指定できるのは、シリアル インターフェイスまたは非同期インターフェイスです。たとえば、シリアル 0 インターフェイスのバックアップとしてシリアル 1 インターフェイスを設定できます。

この例では、ATM 0 インターフェイスのバックアップ インターフェイスとしてBasic Rate
Interface(BRI; 基本速度インターフェイス)を設定しています。

ステップ 3

exit

例:

Router(config-if)# exit
Router(config)#
 

グローバル コンフィギュレーション モードを開始します。

フローティング スタティック ルート

フローティング スタティック ルートは、トラフィックの代替ルートになります。フローティング スタティック ルートは、バックアップ インターフェイスの指定されたトラフィックによって DDR バックアップ コールがトリガされない限りアクティブ化されません。

フローティング スタティック ルートは、ライン プロトコルのステータスに依存しません。このことは、フレーム リレー回路では重要です。フレーム リレー回路では、Data Link Connection Identifier(DLCI)が非アクティブの場合に、ライン プロトコルがダウンしないことがあるためです。フローティング スタティック ルートは、カプセル化にも依存しません。


) スタティック ルートが設定されている場合に、フローティング スタティック ルートをアクティブにするには、プライマリ インターフェイス プロトコルをダウンさせる必要があります。


フローティング スタティック ルートの設定

フローティング スタティック ルートは、スタティック ルートおよびダイナミック ルートの 2 つで構成されます。ルータ上でスタティック ルートおよびダイナミック ルートを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 0.0.0.0 0.0.0.0 22.0.0.2
Router(config)#
 

プライマリ スタティック ルートを割り当てます。

ステップ 2

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ]

例:

Router(config)# ip route 0.0.0.0 0.0.0.0 192.168.2.2 150
Router(config)#
 

バックアップ インターフェイス ルートに、より小さなルーティング管理距離を割り当てます。192.168.2.2 は、バックアップ インターフェイスのピアIPアドレスです。

ステップ 3

router rip

例:

Router(config)# router ri p
Router(config)#
 

RIP ルーティングをイネーブルにします。

ステップ 4

network ip-address

例:

Router(config)# network 22.0.0.0
Router(config)#
 

プライマリ インターフェイス ネットワークを定義します。22.0.0.0 はプライマリ インターフェイスのネットワーク値です。

ステップ 5

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ]

例:

Router(config)# ip route 0.0.0.0 0.0.0.0 192.168.2.2 150
Router(config)#
 

バックアップ インターフェイス ルートに、より小さなルーティング管理距離を割り当てます。192.168.2.2 は、バックアップ インターフェイスのピアIPアドレスです。


) ダイナミック ルートが使用されている場合、フローティング スタティック ルートのアクティブ化に必要な時間はルーティング プロトコルのコンバージェンス時間に左右されます。


ダイヤラ ウォッチ

ダイヤラ ウォッチ方式は、Extended Interior Gateway Routing Protocol(EIGRP)リンクステート ダイナミック ルーティング プロトコルのみをサポートしています。

ダイヤラ ウォッチの設定

ルータ上でダイヤラ ウォッチを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface dialer 2
Router(config-if)#
 

ダイヤル バックアップ インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

dialerwatch-group group-number

例:

Router(config-if)# dialer watch-group 2
Router(config-if)#
 

ウォッチリストのグループ番号を指定します。

ステップ 3

exit

例:

Router(config-if)# exit
Router(config)#
 

グローバル コンフィギュレーション モードを開始します。

ステップ 4

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 0.0.0.0 0.0.0.0 22.0.0.2
Router(config)#
 

プライマリ ルートを割り当てます。22.0.0.2 は、プライマリ インターフェイスのピアIPアドレスです。

ステップ 5

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ distance ]

例:

Router(config)# ip route 0.0.0.0 0.0.0.0 192.168.2.2 150
Router(config)#
 

バックアップ インターフェイス ルートに、より小さなルーティング管理距離を割り当てます。192.168.2.2 は、バックアップ インターフェイスのピアIPアドレスです。

ステップ 6

dialerwatch-list group-number { ip ip-address address-mask | delay route-check initial seconds }

例:

Router(config)# dialer watch-list 2 ip 22.0.0.2 255.255.255.255
Router(config)#
 

ウォッチリストに IP アドレスを割り当てます。

プライマリ インターフェイスの接続が切断されて、ルータ上で IP アドレスが使用不能になると、バックアップ インターフェイスのダイヤルアウト機能がトリガされます。22.0.0.2 は、プライマリ インターフェイスのピア IP アドレスです。

ダイヤル バックアップ機能の制約事項

ダイヤル バックアップ機能には、次の制約事項があります。

コンソール ポートまたは AUX ポート バックアップ インターフェイス上でのブリッジングはサポートされていません。

Cisco 851 ルータの場合は、ダイヤルイン機能のみがサポートされます。

Cisco 871 ルータに接続されたモデムの ISP 接続側がダウンしている場合でも、イーサネット WAN インターフェイスは常に起動しているため、Cisco 871 ルータのダイヤル バックアップ機能のサポートは制約を受けます。使用するルータは PPPoE 環境でダイヤラ ウォッチ機能を実行していなければなりません。ダイヤラ ウォッチ コマンドおよびスタティック ルート コマンドでピアの IP アドレスを指定して、プライマリ回線がダウンした場合のダイヤル バックアップを有効にする必要があります。

表13-1 は、Cisco 800 シリーズ アクセス ルータのダイヤル バックアップのサポートおよび制約事項をまとめたものです。

 

表13-1 ダイヤル バックアップ機能のサポートおよび制約事項

WAN カプセル化タイプ
ダイヤル バックアップの可否
ダイヤル
バックアップ方式
制限事項
Cisco 851 または 871

PPPoE

ダイヤラ ウォッチ

低速インターフェイス(AUX ポートなど)によるブリッジングはサポートされません。 dialerwatch コマンドをおよび IP スタティック ルートを設定するには、ISP のピア IP アドレスが必要です。

標準 IP(ケーブル モデム シナリオの場合)

不可

ダイヤラ ウォッチ

ダイヤラ ウォッチを適切に稼働させるには、ピアの IP アドレスが必要です。DHCP によって取得されたリース期間が十分短い期間(1 ~ 2 分)に設定されていない場合、ダイヤル バックアップはサポートされません。

Cisco 876、877、または 878

PPP over ATM

PPP over Ethernet

バックアップ インターフェイス

フローティング スタティック ルート

ダイヤラ ウォッチ

フローティング スタティック ルートおよびダイヤラ ウォッチを使用する場合は、ルータ内でルーティング プロトコルを実行する必要があります。ダイヤラ ウォッチ方式では、プライマリ リンクがダウンした直後に、バックアップ インターフェイスが起動します。ダイヤラ タイムアウトに到達し、プライマリ インターフェイスが起動すると、バックアップ インターフェイスはただちにダウンします。ルータがプライマリ インターフェイスを調べるのは、ダイヤラ タイムアウトが経過した場合のみです。プライマリ インターフェイスが起動している場合も、ダイヤラ タイムアウトが経過しない限り、バックアップ インターフェイスは、アップ状態のままです。

ダイヤラ ウォッチ方式では、ピアの IP アドレスが既知の場合、ルータ内でルーティング プロトコルを実行する必要はありません。

RFC 1483(AAL5、SNAP、および MUX)

バックアップ インターフェイス

フローティング スタティック ルート

ダイヤラ ウォッチ

WAN インターフェイスを介してブリッジングを実行する場合、AUX ポートによるブリッジングはサポートされません。

設定例

次の 3 つの例は、3 種類のダイヤル バックアップ方式の設定例を示しています。

例13-1 バックアップ インターフェイスを使用したダイヤル バックアップの設定

!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
!
! Specifies the ISDN switch type
isdn switch-type basic-net3
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
hold-queue 100 out
!
! ISDN interface to be used as a backup interface
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface ATM0
backup interface BRI0
no ip address
no atm ilmi-keepalive
pvc 1/40
encapsulation aal5snap
pppoe-client dial-pool-number 2
!
dsl operating-mode auto
!
! Dial backup interface, associated with physical BRI0 interface.
! Dialer pool 1 associates it with BRI0’s dialer pool member 1.
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 30
dialer string 384040
dialer-group 1
!
! Primary interface associated with physical ATM0’s interface.
! Dialer pool 2 associates it with ATM0’s dial-pool-number2.
interface Dialer2
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 2
dialer-group 2
no cdp enable
!
ip classless
! Primary and backup interface are given route metric
ip route 0.0.0.0 0.0.0.0 22.0.0.2
ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
ip http server
!
! Specifies interesting traffic to trigger backup ISDN traffic.
dialer-list 1 protocol ip permit
 

例13-2 フローティング スタティック ルートを使用したダイヤル バックアップの設定

!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
!
! Specifies the ISDN switch type.
isdn switch-type basic-net3
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
hold-queue 100 out
!
! ISDN interface to be used as a backup interface.
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 1/40
encapsulation aal5snap
pppoe-client dial-pool-number 2
!
dsl operating-mode auto
!
! Dial backup interface, associated with physical BRI0 interface.
! Dialer pool 1 associates it with BRI0’s dialer pool member 1
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 30
dialer string 384040
dialer-group 1
!
! Primary interface associated with physical ATM0’s interface.
! Dialer pool 2 associates it with ATM0’s dial-pool-number2.
interface Dialer2
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 2
dialer-group 2
!
ip classless
no cdp enable
! Primary and backup interface are given route metric. (This example uses static routes,
! thus atm0 line protocol must be brought down for backup interface to function.)
ip route 0.0.0.0 0.0.0.0 22.0.0.2
ip route 0.0.0.0 0.0.0.0 192.168.2.2 150
ip http server
!
! Specifies interesting traffic to trigger backup ISDN traffic.
dialer-list 1 protocol ip permit
 

例13-3 ダイヤラ ウォッチを使用したダイヤル バックアップの設定

!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
!
! Specifies the ISDN switch type.
isdn switch-type basic-net3
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
hold-queue 100 out
!
! ISDN interface to be used as a backup interface.
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 1/40
encapsulation aal5snap
pppoe-client dial-pool-number 2
!
dsl operating-mode auto
!
! Dial backup interface, associated with physical BRI0 interface.
! Dialer pool 1 associates it with BRI0’s dialer pool member 1.
! Note “dialer watch-group 1” associates a watch list with corresponding
! “dialer watch-list” command.
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 30
dialer string 384040
dialer watch-group 1
dialer-group 1
!
! Primary interface associated with physical ATM0 interface.
! Dialer pool 2 associates it with ATM0’s dial-pool-number2.
interface Dialer2
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 2
dialer-group 2
no cdp enable
!
ip classless
!
! Primary and backup interface are given route metric.
ip route 0.0.0.0 0.0.0.0 22.0.0.2
ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
ip http server
!
! Watch for interesting traffic.
dialer watch-list 1 ip 22.0.0.2 255.255.255.255
 
! Specifies interesting traffic to trigger backup ISDN traffic.
dialer-list 1 protocol ip permit
!
 

コンソール ポートまたは AUX ポートを使用したダイヤル バックアップおよびリモート管理の設定

Cisco 850 または Cisco 870 シリーズ ルータなどのカスタマー側装置と ISP が接続されている場合、IP アドレスは動的にルータに割り当てられます。また、中央管理機能を使用して、ルータのピアによって割り当てられることもあります。ダイヤル バックアップ機能を追加すると、プライマリ回線に障害が発生した場合に、フェールオーバー ルートを使用できます。Cisco 850 および Cisco 870 ルータでは、AUX ポートを使用してダイヤル バックアップおよびリモート管理を行うことができます。


) 現在、ケーブル モデム環境はサポートされていません。


図13-1は、リモート管理アクセスおよびプライマリ WAN 回線のバックアップに使用するネットワーク構成を示しています。

図13-1 AUX ポートを使用したダイヤル バックアップおよびリモート管理

 

 

1

Cisco 850 または Cisco 870 シリーズ ルータ

A

メイン WAN リンク(ISP とのプライマリ接続)

2

モデム

B

ダイヤル バックアップ(プライマリ回線がダウンした場合に Cisco 870 ルータのフェールオーバー リンクとして機能)

3

PC

C

リモート管理(Cisco IOS の設定の変更または更新が可能なダイヤルイン アクセスとして機能)

設定作業

ルータでダイヤル バックアップおよびリモート管理を設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

ip name-server server-address

例:

Router(config)# ip name-server 192.168.28.12
Router(config)#
 

ISP DNS IP アドレスを入力します。


ヒント 複数のサーバ アドレスが存在する場合には、それらのアドレスも追加できます。

ステップ 2

ip dhcp pool name

例:

Router(config)# ip dhcp pool 1
Router(config-dhcp)#
 

ルータ上に DHCP アドレス プールを作成し、DHCP プール コンフィギュレーション モードを開始します。 name 引数には、文字列または整数を使用できます。

DHCP アドレス プールを設定します。DHCP プール コンフィギュレーション モードで使用可能なサンプル コマンドについては、「設定例」を参照してください。

ステップ 3

exit

例:

Router(config-dhcp)# exit
Router(config)#
 

グローバル コンフィギュレーション モードを開始します。

ステップ 4

chat-script script-name expect-send

例:

Router(config)# chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102 T” TIMEOUT 45 CONNECT \c
Router(config)#
 

DDR で使用するチャット スクリプトを使用して、モデムのダイヤリングおよびリモート システムへのログインの設定を行います。定義されたスクリプトは、モデム経由で発呼する場合に使用されます。

ステップ 5

interface type number

例:

Router(config)# interface Async 1
Router(config-if)#
 

非同期インターフェイスのコンフィギュレーション モードを開始します。

非同期インターフェイスを設定します。非同期インターフェイス コンフィギュレーション モードで使用可能なサンプル コマンドについては、「設定例」を参照してください。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

グローバル コンフィギュレーション モードを開始します。

ステップ 7

interface type number

例:

Router(config)# interface Dialer 3
Router(config-if)#
 

インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

dialer watch-group group-number

例:

Router(config-if)# dialer watch-group 1
Router(config-if)#
 

ウォッチリストのグループ番号を指定します。

ステップ 9

exit

例:

Router(config-if)# exit
Router(config)#
 

グローバル コンフィギュレーション モードを開始します。

ステップ 10

ip nat inside source {list access-list-number } {interface type number | pool name } [overload]

例:

Router(config)# ip nat inside source list 101 interface Dialer 3 overload
 

内部のインターフェイスでダイナミック アドレス変換をイネーブルにします。

ステップ 11

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 0.0.0.0 0.0.0.0 22.0.0.2
Router(config)#
 

デフォルト ゲートウェイとしてダイヤラ インターフェイスを示すように、IP ルートを設定します。

ステップ 12

access-list access-list-number { deny | permit} source [ source-wildcard ]

例:

Router(config)# access-list 1 permit 192.168.0.0 0.0.255.255 any
 

変換が必要なアドレスを指定する拡張アクセス リストを定義します。

ステップ 13

dialerwatch-list group-number { ip ip-address address-mask | delay route-check initial seconds }

例:

Router(config)# dialer watch-list 1 ip 22.0.0.2 255.255.255.255
Router(config)#
 

ピアへのルートが存在するかどうかに基づいて、プライマリ リンクのステータスを評価します。22.0.0.2 は ISP のピア IP アドレスです。

ステップ 14

line [ aux | console | tty | vty ] line-number [ ending-line-number ]

例:

Router(config)# line console 0
Router(config-line)#
 

ライン インターフェイスのコンフィギュレーション モードを開始します。

ステップ 15

modem enable

例:

Router(config-line)# modem enable
Router(config-line)#
 

ポートをコンソール ポートから AUX ポートに変更します。

ステップ 16

exit

例:

Router(config-line)# exit
Router(config)#
 

グローバル コンフィギュレーション モードを開始します。

ステップ 17

line [ aux | console | tty | vty ] line-number [ ending-line-number ]

例:

Router(config)# line aux 0
Router(config)#
 

AUX インターフェイス コンフィギュレーション モードを開始します。

ステップ 18

flowcontrol { none | software [ lock ] [ in | out ] | hardware [ in | out ]}

例:

Router(config)# flowcontrol hardware
Router(config)#
 

ハードウェア信号フロー制御をイネーブルにします。

設定例

次の設定例では、ATM インターフェイスの IP アドレスを、PPP/IPCP アドレス ネゴシエーションおよびコンソール ポートを介したダイヤル バックアップによって指定します。

!
ip name-server 192.168.28.12
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool 1
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
! Need to use your own correct ISP phone number.
modemcap entry MY-USER_MODEM:MSC=&F1S0=1
chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102\T”
TIMEOUT 45 CONNECT \c
!
!
!
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
hold-queue 100 out
!
! Dial backup and remote management physical interface.
interface Async1
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 3
async default routing
async dynamic routing
async mode dedicated
ppp authentication pap callin
!
interface ATM0
mtu 1492
no ip address
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
! Primary WAN link.
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! Dialer backup logical interface.
interface Dialer3
ip address negotiated
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 3
dialer idle-timeout 60
dialer string 5555102 modem-script Dialout
dialer watch-group 1
!
! Remote management PC IP address.
peer default ip address 192.168.2.2
no cdp enable
!
! Need to use your own ISP account and password.
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! IP NAT over Dialer interface using route-map.
ip nat inside source route-map main interface Dialer1 overload
ip nat inside source route-map secondary interface Dialer3 overload
ip classless
!
! When primary link is up again, distance 50 will override 80 if dial backup
! has not timed out. Use multiple routes because peer IP addresses are alternated
! among them when the CPE is connected.
ip route 0.0.0.0 0.0.0.0 64.161.31.254 50
ip route 0.0.0.0 0.0.0.0 66.125.91.254 50
ip route 0.0.0.0 0.0.0.0 64.174.91.254 50
ip route 0.0.0.0 0.0.0.0 63.203.35.136 80
ip route 0.0.0.0 0.0.0.0 63.203.35.137 80
ip route 0.0.0.0 0.0.0.0 63.203.35.138 80
ip route 0.0.0.0 0.0.0.0 63.203.35.139 80
ip route 0.0.0.0 0.0.0.0 63.203.35.140 80
ip route 0.0.0.0 0.0.0.0 63.203.35.141 80
ip route 0.0.0.0 0.0.0.0 Dialer1 150
no ip http server
ip pim bidir-enable
!
! PC IP address behind CPE.
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 103 permit ip 192.168.0.0 0.0.255.255 any
!
! Watch multiple IP addresses because peers are alternated
! among them when the CPE is connected.
dialer watch-list 1 ip 64.161.31.254 255.255.255.255
dialer watch-list 1 ip 64.174.91.254 255.255.255.255
dialer watch-list 1 ip 64.125.91.254 255.255.255.255
!
! Dial backup will kick in if primary link is not available
! 5 minutes after CPE starts up.
dialer watch-list 1 delay route-check initial 300
dialer-list 1 protocol ip permit
!
! Direct traffic to an interface only if the dialer is assigned an IP address.
route-map main permit 10
match ip address 101
match interface Dialer1
!
route-map secondary permit 10
match ip address 103
match interface Dialer3
!
! Change console to aux function.
line con 0
exec-timedout 0 0
modem enable
stopbits 1
line aux 0
exec-timeout 0 0
! To enable and communicate with the external modem properly.
script dialer Dialout
modem InOut
modem autoconfigure discovery
transport input all
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
exec-timeout 0 0
password cisco
login
!
scheduler max-task-time 5000
end
 

ISDN S/T ポートを使用したダイヤル バックアップおよびリモート管理の設定

Cisco 876 および Cisco 878 ルータは、ISDN S/T ポートを使用してリモート管理を行うことができます。また、アドバンスト エンタープライズ(c870-adventerprisek9-mz)イメージを使用すると、Cisco 876 ルータは ISDN S/T ポートを使用してダイヤル バックアップを行うこともできます。

図13-2および図13-3は、リモート管理アクセスおよびプライマリ WAN 回線のバックアップに使用する一般的なネットワーク構成を示しています。図13-2の場合、ダイヤル バックアップ リンクは Customer Premises Equipment(CPE; 顧客宅内機器)のスプリッタ、Digital Subscriber Line Access Multiplexer(DSLAM; デジタル加入者線アクセス マルチプレクサ)、およびセントラル オフィス(CO)のスプリッタを経由して ISDN 交換機に接続されます。図13-3では、ダイヤル バックアップ リンクは、シスコ ルータから ISDN 交換機に直接接続されます。

図13-2 CPE スプリッタ、DSLAM、および CO スプリッタを経由したダイヤル バックアップ

 

 

1

Cisco 876 または Cisco 878 ルータ

A

プライマリ DSL インターフェイス

2

DSLAM

B

ISDN インターフェイス(ISDN S/T ポート)を介したダイヤル バックアップおよびリモート管理(プライマリ回線がダウンした場合にフェールオーバー リンクとして機能)

3

ATM アグリゲータ

4

ISDN 交換機

5

ISDN

C

プライマリ DSL リンクがダウンした場合の、ISDN インターフェイスを介した管理者によるリモート管理(Cisco IOS 設定の変更または更新が可能なダイヤルイン アクセスとして機能)

6

ISDN ピア ルータ

7

Web サーバ

8

管理者

--

--

図13-3 ルータから ISDN 交換機に直接接続されたダイヤル バックアップ

 

 

1

PC

A

プライマリ DSL インターフェイス

2

Cisco 876 ルータ

B

ISDN インターフェイス(ISDN S/T ポート)を介したダイヤル バックアップおよびリモート管理(プライマリ回線がダウンした場合にフェールオーバー リンクとして機能)

3

DSLAM

4

アグリゲータ

5

ISDN 交換機

C

プライマリ DSL リンクがダウンした場合の、ISDN インターフェイスを介した管理者によるリモート管理(Cisco IOS 設定の変更または更新が可能なダイヤルイン アクセスとして機能)

6

Web サーバ

7

管理者

設定作業

ルータの ISDN S/T ポートを使用したダイヤル バックアップおよびリモート管理を設定するには、次の作業を行います。

ISDN の設定

アグリゲータおよび ISDN ピア ルータの設定

ISDN の設定


) バックアップ インターフェイスおよびフローティング スタティック ルート方式を使用してバックアップ ISDN 回線を起動するには、対象トラフィックが存在していなければなりません。ダイヤラ ウォッチを使用してバックアップ ISDN 回線を起動する場合は、対象トラフィックが存在しなくても構いません。


ルータの ISDN インターフェイスをバックアップ インターフェイスとして設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

isdn switch-type switch-type

例:

Router(config)# isdn switch-type basic-net3
Router(config)#
 

ISDN スイッチ タイプを指定します。

この例では、オーストラリア、欧州、および英国で使用されているスイッチ タイプを指定します。サポートされている他のスイッチ タイプの詳細については、『 Cisco IOS Dial Technologies Command Reference』を参照してください。

ステップ 2

interface type number

例:

Router(config)# interface bri 0
Router(config-if)#
 

ISDN BRI のコンフィギュレーション モードを開始します。

ステップ 3

encapsulation encapsulation-type

例:

Router(config-if)# encapsulation ppp
Router(config-if)#
 

BRI0 インターフェイスの暗号化タイプを設定します。

ステップ 4

dialer pool-member number

例:

Router(config-if)# dialer pool-member 1
Router(config-if)#
 

ダイヤラ プール メンバーシップを指定します。

ステップ 5

isdn switch-type switch-type

例:

Router(config-if)# isdn switch-type basic-net3
Router(config-if)#
 

ISDN スイッチ タイプを指定します。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

グローバル コンフィギュレーション モードを開始します。

ステップ 7

interface dialer dialer-rotary-group-number

例:

Router(config)# interface dialer 0
Router(config-if)#
 

ダイヤラ インターフェイス(0 ~ 255 の番号を指定)を作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

ip address negotiated

例:

Router(config-if)# ip address negotiated
Router(config-if)#
 

PPP/IPCP(IP Control Protocol)アドレス ネゴシエーションを使用してインターフェイスの IP アドレスを取得するように設定します。IP アドレスはピアから取得されます。

ステップ 9

encapsulation encapsulation-type

例:

Router(config-if)# encapsulation ppp
Router(config-if)#
 

インターフェイスのカプセル化タイプを PPP に設定します。

ステップ 10

dialer pool number

例:

Router(config-if)# dialer pool 1
Router(config-if)#
 

使用するダイヤラ プールを指定します。

この例の場合、BRI0 のダイヤラ プールメンバー(dialer pool-member)の値が1であるため、dialer pool 1 の設定によって、ダイヤラ 0 インターフェイスと BRI0 インターフェイスが関連付けられます。

ステップ 11

dialer string dial-string [ : isdn-subaddress ]

例:

Router(config-if)# dialer string 384040
Router(config-if)#
 

ダイヤルする電話番号を指定します。

ステップ 12

dialer-group group-number

例:

Router(config-if)# dialer group 1
Router(config-if)#
 

ダイヤラ インターフェイスをダイヤラ グループ(1 ~ 10)に割り当てます。

ステップ 13

exit

例:

Router(config-if)# exit
Router(config)#
 

ダイヤラ 0 のインターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

ステップ 14

dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

例:

Router(config)# dialer-list 1 protocol ip permit
Router(config)#
 

特定のインターフェイス ダイヤラ グループを介して転送される対象パケットについて、ダイヤラ リストを作成します。

この例の場合、ダイヤラリスト 1 はダイヤラグループ1に対応します。

このコマンドの詳細および設定可能なその他のパラメータについては、『 Cisco IOS Dial Technologies Command Reference』を参照してください。

アグリゲータおよび ISDN ピア ルータの設定

通常、アグリゲータはシスコ ルータの ATM PVC が終端するコンセントレータ ルータです。次の設定例では、アグリゲータは、この章に記載されている Cisco 876 ルータの設定例に対応する PPPoE サーバとして設定されます。

ISDN ピア ルータは、ISDN インターフェイスを備えた任意のルータで、パブリック ISDN ネットワークを介して通信し、シスコ ルータの ISDN インターフェイスに到達することができます。ISDN ピア ルータを使用すると、ATM ネットワークのダウンタイム時に、シスコ ルータからインターネットにアクセスすることができます。

! This portion of the example configures the aggregator.
vpdn enable
no vpdn logging
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
!
interface Ethernet3
description “4700ref-1”
ip address 40.1.1.1 255.255.255.0
media-type 10BaseT
!
interface Ethernet4
ip address 30.1.1.1 255.255.255.0
media-type 10BaseT
!
interface Virtual-Template1
ip address 22.0.0.2 255.255.255.0
ip mtu 1492
peer default ip address pool adsl
!
interface ATM0
no ip address
pvc 1/40
encapsulation aal5snap
protocol pppoe
!
no atm limi-keepalive
!
ip local pool adsl 22.0.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 22.0.0.1 50
ip route 0.0.0.0 0.0.0.0 30.1.1.2.80
 
! This portion of the example configures the ISDN peer.
isdn switch-type basic-net3
!
interface Ethernet0
ip address 30.1.1.2 255.0.0.0
!
interface BRI0
description “to 836-dialbackup”
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer0
ip address 192.168.2.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 384020
dialer-group 1
peer default ip address pool isdn
!
ip local pool isdn 192.168.2.1
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 40.0.0.0 255.0.0.0 30.1.1.1
!
dialer-list 1 protocol ip permit
!