Cisco 850 / 870 シリーズ アクセス ルータ ソフトウェア コンフィギュレーション ガイド
基本的なルータの設定
基本的なルータの設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

基本的なルータの設定

インターフェイスのポート ラベル

デフォルト設定の表示

設定に必要な情報

基本的なパラメータの設定

グローバル パラメータの設定

ファスト イーサネット LAN インターフェイスの設定

WAN インターフェイスの設定

ファスト イーサネット WAN インターフェイスの設定

ATM WAN インターフェイスの設定

ワイヤレス インターフェイスの設定

ループバック インターフェイスの設定

設定例

設定の確認

ルータへのコマンドライン アクセスの設定

設定例

スタティック ルートの設定

設定例

設定の確認

ダイナミック ルートの設定

RIP の設定

設定例

設定の確認

EIGRP の設定

設定例

設定の確認

基本的なルータの設定

この章では、シスコ ルータで基本的なパラメータ(グローバル パラメータの設定、ルーティング プロトコル、インターフェイス、およびコマンドライン アクセスなど)を設定する手順について説明します。また、起動時のデフォルト設定についても説明します。


) ルータの各モデルは、このマニュアルに記載されている機能の一部をサポートしていない場合があります。特定のルータでサポートされていない機能は、可能な限り明示されています。


この章の内容は次のとおりです。

インターフェイスのポート ラベル

デフォルト設定の表示

設定に必要な情報

基本的なパラメータの設定

スタティック ルートの設定

ダイナミック ルートの設定

EIGRP の設定

どのセクションにも、該当するものがある場合には設定例と確認手順が記載されています。

グローバル コンフィギュレーション モードを利用する詳しい手順については、付録 A 「Cisco IOS Basic Skills」の「グローバル コンフィギュレーション モードの開始」の項を参照してください。以下の表に記載されているコマンドの詳細については、Cisco IOS Release 12.3のマニュアルを参照してください。

インターフェイスのポート ラベル

表1-1 は、各ルータでサポートされているインターフェイスと装置に表記されているポート ラベルを示しています。

 

表1-1 シスコ ルータでサポートされているインターフェイスと対応するポート ラベル

Router
インターフェイス
ポート ラベル

Cisco 851

ファスト イーサネット LAN

LAN(上)、FE0 ~ FE3(下)

ファスト イーサネット WAN

WAN(上)、FE4(下)

ワイヤレス LAN

(表示なし)

Cisco 871

ファスト イーサネット LAN

FE0 ~ FE3

ファスト イーサネット WAN

FE4

ワイヤレス LAN

LEFT、RIGHT/PRIMARY

USB

1-0

Cisco 857

ファスト イーサネット LAN

LAN(上)、FE0 ~ FE3(下)

ATM WAN

ADSLoPOTS

ワイヤレス LAN

(表示なし)

Cisco 876

ファスト イーサネット LAN

LAN(上)、FE0 ~ FE3(下)

ATM WAN

ADSLoISDN

ワイヤレス LAN

LEFT、RIGHT/PRIMARY

BRI

ISDN S/T

Cisco 877

ファスト イーサネット LAN

LAN(上)、FE0 ~ FE3(下)

ATM WAN

ADSLoPOTS

ワイヤレス LAN

LEFT、RIGHT/PRIMARY

Cisco 878

ファスト イーサネット LAN

FE0 ~ FE3

ATM WAN

G.SHDSL

ワイヤレス LAN

LEFT、RIGHT/PRIMARY

BRI

ISDN S/T

デフォルト設定の表示

シスコ ルータを初めて起動すると、一部の基本的な設定はすでに行われています。LAN および WAN インターフェイスはすべて作成されており、コンソール ポートと VTY ポートの設定や Network Address Translation(NAT; ネットワーク アドレス変換)用の内部インターフェイスの割り当てもすでに行われています。初期設定を表示するには、 show running-config コマンドを使用します(例1-1を参照)。

例1-1 Cisco 851 の起動時のデフォルト設定

Router# show running-config
Building configuration...
 
Current configuration : 1090 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip subnet-zero
!
 
ip cef
ip ips po max-events 100
no ftp-server write-enable
!
interface FastEthernet0
no ip address
shutdown
!
interface FastEthernet1
no ip address
shutdown
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
54.0
rts threshold 2312
station-role root
!
interface Vlan1
no ip address
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
login
transport preferred all
transport input all
transport output all
!
end
 

設定に必要な情報

ネットワークを設定する前に、使用するネットワーク構成に基づいて、次の情報の一部またはすべてを収集しておく必要があります。

インターネット接続を設定している場合、次の情報を集めてください。

ユーザのログイン名として割り当てられた PPP(ポイントツーポイント プロトコル)クライアント名

PPP 認証のタイプ:Challenge Handshake Authentication Protocol(CHAP)または Password Authentication Protocol(PAP)

ISP(インターネット サービス プロバイダー)アカウントにアクセスするための PPP パスワード

Domain Name System(DNS; ドメイン ネーム システム)サーバの IP アドレスおよびデフォルト ゲートウェイ

企業ネットワークへの接続を設定する場合は、ユーザとネットワーク管理者の間で、ルータの WAN インターフェイスに関する次の情報について打ち合わせておく必要があります。

PPP 認証のタイプ:CHAP または PAP

ルータにアクセスするためのPPPクライアント名

ルータにアクセスするためのPPPパスワード

IP ルーティングを設定する場合、次の準備が必要です。

IP ネットワークのアドレス体系を作成します。

IP アドレスなどの IP ルーティング パラメータ情報と ATM Permanent Virtual Circuit(PVC;相手先固定接続)を特定します。通常、これらのPVCパラメータは、Virtual Path Identifier(VPI;仮想パス識別子)、VCI(仮想回線識別子)、およびトラフィック シェーピング パラメータです。

サービス プロバイダーから付与された PVC 番号、VPI、および VCI を特定します。

PVC ごとに、サポートされているAAL5カプセル化のタイプを判別します。次のようなものがあります。

AAL5SNAP ― これは、RFC 1483ルーティングまたはRFC 1483ブリッジングのいずれかです。RFC 1483ルーティングの場合、サービス プロバイダーはスタティックIPアドレスを提供する必要があります。ブリッジング RFC 1483 の場合、DHCP を用いて IP アドレスを入手するか、サービス プロバイダーからスタティックな IP アドレスを入手することもできます。

AAL5MUX PPP ― このタイプでは、PPP 関連設定項目を判別する必要があります。

ADSL またはG.SHDSL回線を使用して接続する場合、次の準備が必要です。

電話会社と回線契約を結びます。

ADSL 回線の場合 ― ADSL シグナリング タイプが DMT(ANSI T1.413ともいう)またはDMT Issue 2であることを確認します。

G.SHDSL回線の場合 ― G.SHDSL回線がITU G.991.2に準拠し、Annex A(北米)またはAnnex B(欧州)をサポートしていることを確認します。

関連する情報の収集が済んだら、ルータの設定を行うことができます。「基本的なパラメータの設定」の項から設定を始めてください。

基本的なパラメータの設定

ルータを設定する場合、次のうちの 1 つまたは複数の作業を行います。

グローバル パラメータの設定

ファスト イーサネット LAN インターフェイスの設定

WAN インターフェイスの設定

ループバック インターフェイスの設定

ルータへのコマンドライン アクセスの設定

ぞれぞれの設定には設定例が記載されています。これらは、各設定作業が完了したあとのネットワーク設定の例を示しています。

グローバル パラメータの設定

ルータのグローバル パラメータを設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

configure terminal

例:

Router> enable
Router# configure terminal
Router(config)#
 

グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。

リモート端末を使用してルータに接続している場合は、次の手順を使用します。

telnet router name or address
Login: login id
Password: *********
Router> enable
 

ステップ 2

hostname name

例:

Router(config)# hostname Router
Router(config)#
 

ルータ名を指定します。

ステップ 3

enable secret password

例:

Router(config)# enable secret cr1ny5ho
Router(config)#
 

ルータへの不正アクセスを防ぐための暗号化パスワードを指定します。

ステップ 4

no ip domain-lookup

例:

Router(config)# no ip domain-lookup Router(config)#
 

ルータが知らない語句(入力ミス)を IP アドレスに変換しないようにします。

グローバル パラメータ コマンドの詳細については、Cisco IOS Release 12.3のマニュアルを参照してください。

ファスト イーサネット LAN インターフェイスの設定

ルータのファスト イーサネット LAN インターフェイスは、デフォルト VLAN の一部として自動的に設定され、個別のアドレスによる設定は行われません。アクセスは VLAN を通じて提供されます。必要に応じて、このインターフェイスを別の VLAN に割り当てることが可能です。VLAN 作成の詳細については、「DHCP および VLAN を使用した LAN の設定」を参照してください。

WAN インターフェイスの設定

Cisco 851 および Cisco 871 ルータは、WAN 接続用にそれぞれ 1 つのファスト イーサネット インターフェイスを持っています。Cisco 857、Cisco 877、および Cisco 878 ルータは、WAN 接続用にそれぞれ 1 つの ATM インターフェイスを持っています。

WAN インターフェイスを設定するには、使用しているルータ モデルに基づいて、次のいずれかの作業を行います。

ファスト イーサネット WAN インターフェイスの設定

ATM WAN インターフェイスの設定

ファスト イーサネット WAN インターフェイスの設定

この手順が適用されるのは、Cisco 851 および Cisco 871 のルータ モデルだけです。ファスト イーサネット インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface fastethernet 4
Router(config-int)#
 

ルータのファスト イーサネット WAN インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-int)# ip address 192.168.12.2 255.255.255.0
Router(config-int)#
 

指定されたファスト イーサネット インターフェイスの IP アドレスおよびサブネット マスクを設定します。

ステップ 3

no shutdown

例:

Router(config-int)# no shutdown
Router(config-int)#
 

イーサネット インターフェイスをイネーブルにして、インターフェイスの状態を管理上のダウンからアップに変更します。

ステップ 4

exit

例:

Router(config-int)# exit
Router(config)#
 

ファスト イーサネット インターフェイスのコンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ATM WAN インターフェイスの設定

この手順が適用されるのは、Cisco 857、Cisco 876、Cisco 877、および Cisco 878 のモデルだけです。

ATM インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

Cisco 878 モデルの場合のみ

controller dsl 0
mode atm
exit

例:

Router(config)# controller dsl 0
Router(config-controller)# mode atm
Router(config-controller)# exit
Router(config)#
 

G.SHDSL シグナリングを使用するルータの場合、これらのコマンドを実行します。ADSL シグナリングを使用するルータは、このステップを省略します。

ステップ 2

interface type number

例:

Router(config)# interface atm0
Router(config-int)#
 

ATM インターフェイスのコンフィギュレーション モードを開始します。

ステップ 3

ip address ip-address mask

例:

Router(config-int)# ip address 200.200.100.1 255.255.255.0
Router(config-int)#
 

ATM インターフェイスの IP アドレスおよびサブネット マスクを設定します。

ステップ 4

no shutdown

例:

Router(config-int)# no shutdown
Router(config-int)#
 

ATM 0 インターフェイスをイネーブルにします。

ステップ 5

exit

例:

Router(config-int)# exit
Router(config)#
 

ATM インターフェイスのコンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ワイヤレス インターフェイスの設定

ワイヤレス インターフェイスを使用すると、ワイヤレス LAN 接続を経由してルータに接続できます。ワイヤレス接続の設定の詳細については、「ワイヤレス LAN 接続の設定」および『 Cisco Access Router Wireless Configuration Guide 』を参照してください。

ループバック インターフェイスの設定

ループバック インターフェイスは、スタティック IP アドレスのプレースホルダとして機能し、デフォルトのルーティング情報を提供します。

ループバック コマンドの詳細については、Cisco IOS Release 12.3のマニュアルを参照してください。

ループバック インターフェイスを設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface Loopback 0
Router(config-int)#
 

ループバック インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-int)# ip address 10.108.1.1 255.255.255.0
Router(config-int)#
 

ループバック インターフェイスの IP アドレスおよびサブネット マスクを設定します。

ステップ 3

exit

例:

Router(config-int)# exit
Router(config)#
 

ループバック インターフェイスのコンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

設定例

設定例のループバック インターフェイスは、仮想テンプレート インターフェイス上で NAT をサポートするのに用いられます。この設定例は、スタティック IP アドレスとなる IP アドレス 200.200.100.1/24 を持つファスト イーサネット インターフェイスに設定されるループバック インターフェイスを示します。このループバック インターフェイスは、ネゴシエートされた IP アドレスを持つ virtual-template1 を指します。

!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
 

設定の確認

ループバック インターフェイスが正しく設定されているかどうかを確認するには、show interface loopbackコマンドを入力します。確認出力は、次の例のように表示されます。

Router# show interface loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 

インターフェイスに対して ping を実行してループバック インターフェイスを確認することもできます。

Router# ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 
 

ルータへのコマンドライン アクセスの設定

ルータへのアクセスを制御するパラメータを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

line [ aux | console | tty | vty ] line-number

例:

Router(config)# line console 0
Router(config)#
 

ライン コンフィギュレーション モードを開始し、ライン タイプを指定します。

この例では、アクセス用のコンソール端末を指定しています。

ステップ 2

password password

例:

Router(config)# password 5dr4Hepw3
Router(config)#
 

コンソール端末ラインのパスワードを指定します。

ステップ 3

login

例:

Router(config)# login
Router(config)#
 

端末セッション ログインでパスワード チェックをイネーブルにします。

ステップ 4

exec-timeout minutes [ seconds ]

例:

Router(config)# exec-timeout 5 30
Router(config)#
 

EXEC コマンド インタープリタがユーザ入力を待機する時間を設定します。デフォルトは 10 分です。秒単位の時間を任意に設定することもできます。

この例では、タイムアウト時間が 5 分 30 秒であることを示しています。タイムアウト時間を 0 0 に設定すると、タイムアウトは無効になります。

ステップ 5

line [ aux | console | tty | vty ] line-number

例:

Router(config)# line vty 0 4
Router(config)#
 

リモート コンソール アクセスの仮想端末(vty)を指定します。

ステップ 6

password password

例:

Router(config)# password aldf2ad1
Router(config)#
 

仮想端末ラインのパスワードを指定します。

ステップ 7

login

例:

Router(config)# login
Router(config)#
 

仮想端末セッション ログインでパスワード チェックをイネーブルにします。

ステップ 8

end

例:

Router(config)# end
Router#
 

ライン コンフィギュレーション モードを終了して特権 EXEC モードに戻ります。

コマンドライン コマンドの詳細については、Cisco IOS Release 12.3のマニュアルを参照してください。

設定例

次の設定は、コマンドライン アクセス コマンドを示すものです。

[default] のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
 

スタティック ルートの設定

スタティック ルートを使用すると、ネットワーク内で固定ルーティング パスを利用できます。スタティック ルートは、ルータ上で手動で設定します。ネットワーク トポロジーが変化した場合には、新しいルートを使用してスタティック ルートを更新する必要があります。スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベートなルートです。Cisco 850 および Cisco 870 シリーズ ルータでのスタティック ルートの設定は任意です。

スタティック ルートを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 192.168.1.0 255.255.0.0 10.10.10.2
Router(config)#
 

IP パケットのスタティック ルートを指定します。

このコマンドの詳細および設定可能なその他のパラメータについては、『 Cisco IOS IP Command
Reference, Volume 2 of 4: Routing Protocols
』を参照してください。

ステップ 2

end

例:

Router(config)# end
Router#
 

ルータ コンフィギュレーション モードを終了して特権 EXEC モードに戻ります。

スタティック ルーティング コマンドの詳細については、Cisco IOS Release 12.3 のマニュアルを参照してください。スタティック ルーティングの概要については、 付録 B「概要」 を参照してください。

設定例

次の設定例で、スタティック ルートは、ファスト イーサネット インターフェイスで宛先 IP アドレス 192.168.1.0 およびサブネット マスク 255.255.255.0 を持つすべてのIPパケットを、IP アドレス 10.10.10.2 を持つ別のデバイスに送信します。これらのパケットは設定された PCV へ送信されています。

「(default)」のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
 

設定の確認

スタティック ルーティングが正しく設定されているかどうかを確認するには、show ip routeコマンドを入力し、[S] で表されるスタティック ルートを調べます。

確認出力は、次の例のように表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
 

ダイナミック ルートの設定

ダイナミック ルーティングでは、ネットワーク プロトコルは、ネットワーク トラフィックまたはネットワーク トポロジーに基づき自動的に経路を調整します。ダイナミック ルートの変更は、ネットワーク上の他のルータと共有されます。

シスコ ルータは、Routing Information Protocol(RIP)または Enhanced Interior Gateway Routing Protocol(EIGRP)などの IP ルーティング プロトコルを使用して、動的にルートを学習します。ルータでは RIP または EIGRP のどちらかのルーティング プロトコルを設定できます。

RIP の設定

ルータ上で RIP ルーティング プロトコルを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
作業

ステップ 1

router rip

例:

Router> configure terminal
Router(config)# router rip
Router(config-router)#
 

ルータ コンフィギュレーション モードを開始し、ルータ上で RIP をイネーブルにします。

ステップ 2

version { 1 | 2 }

例:

Router(config-router)# version 2
Router(config-router)#
 

RIP バージョン 1 または 2 を使用することを指定します。

ステップ 3

network ip-address

例:

Router(config-router)# network 192.168.1.1
Router(config-router)# network 10.10.7.1
Router(config-router)#
 

RIP を適用するネットワークを指定します(直接接続されているネットワークのネットワーク アドレスを使用)。

ステップ 4

no auto-summary

例:

Router(config-router)# no auto-summary
Router(config-router)#
 

ネットワーク レベル ルートへのサブネット ルートの自動サマライズをディセーブルにします。その結果、サブプレフィクス ルーティング情報がクラスフル ネットワーク境界を超えて伝送されます。

ステップ 5

end

例:

Router(config-router)# end
Router#
 

ルータ コンフィギュレーション モードを終了して特権 EXEC モードに戻ります。

ダイナミック ルーティング コマンドの詳細については、Cisco IOS Release 12.3のマニュアルを参照してください。RIP に関する一般的な説明については、 付録 B「概要」 を参照してください。

設定例

次に、IP ネットワーク 10.10.10.0 および 192.168.1.0で RIP バージョン 2 をイネーブルにする設定例を示します。

この設定を表示するには、特権 EXEC モードで show running-config コマンドを使用します。

!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
 

設定の確認

RIP が正しく設定されているかどうかを確認するには、show ip route コマンドを入力し、[R] で表される RIP ルートを調べます。確認出力は、次の例のように表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0
 

EIGRP の設定

EIGRP を設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

router eigrp as-number

例:

Router(config)# router eigrp 109
Router(config)#
 

ルータ コンフィギュレーション モードを開始して、ルータ上で EIGRP をイネーブルにします。Autonomous System(AS; 自律システム)番号は、他の EIGRP ルータへのルートを表し、EIGRP 情報のタグ付けに使用されます。

ステップ 2

network ip-address

例:

Router(config)# network 192.145.1.0
Router(config)# network 10.10.12.115
Router(config)#
 

EIGRP を適用するネットワークを指定します(直接接続されているネットワークのネットワーク アドレスを使用)。

ステップ 3

end

例:

Router(config-router)# end
Router#
 

ルータ コンフィギュレーション モードを終了して特権 EXEC モードに戻ります。

IP EIGRP コマンドの詳細については、Cisco IOS Release 12.3のマニュアルを参照してください。EIGRP の概要については、 付録 B「概要」 を参照してください。

設定例

次に、IP ネットワーク 192.145.1.0 および 10.10.12.115 で EIGRP ルーティング プロトコルをイネーブルにする設定例を示します。EIGRP AS 番号は、109 に設定されています。

この設定を表示するには、特権 EXEC モードで show running-config コマンドを使用します。

!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!

設定の確認

IP EIGRP が正しく設定されているかどうかを確認するには、show ip route コマンドを入力し、[D] で表される EIGRP ルートを調べます。確認出力は、次の例のように表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0