Cisco 860 および Cisco 880 シリーズ サービス 統合型ルータ ソフトウェア コンフィギュレーショ ン ガイド
基本的なルータの設定
基本的なルータの設定
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

基本的なルータの設定

インターフェイス ポート

デフォルト設定

設定に必要な情報

コマンドライン アクセスの設定

グローバル パラメータの設定

WAN インターフェイスの設定

ファスト イーサネット WAN インターフェイスの設定

G.SHDSL WAN インターフェイスの設定

設定の確認

セル ワイヤレス WAN インターフェイスの設定

3G ワイヤレス インターフェイスの設定に関する要件

セル ワイヤレス インターフェイスの設定に関する制約事項

データ アカウント プロビジョニング

セル インターフェイスの設定

DDR の設定

セル ワイヤレス インターフェイスの設定例

ファスト イーサネット LAN インターフェイスの設定

ワイヤレス LAN インターフェイスの設定

ループバック インターフェイスの設定

設定の確認

スタティック ルートの設定

設定の確認

ダイナミック ルートの設定

Routing Information Protocol の設定

設定の確認

Enhanced Interior Gateway Routing Protocol の設定

設定の確認

基本的なルータの設定

この章では、シスコ ルータで基本的なパラメータ(グローバル パラメータの設定、ルーティング プロトコル、インターフェイス、およびコマンドライン アクセスなど)を設定する手順について説明します。また、起動時のデフォルト設定についても説明します。

「インターフェイス ポート」

「デフォルト設定」

「設定に必要な情報」

「コマンドライン アクセスの設定」

「グローバル パラメータの設定」

「WAN インターフェイスの設定」

「ファスト イーサネット LAN インターフェイスの設定」

「ワイヤレス LAN インターフェイスの設定」

「ループバック インターフェイスの設定」

「スタティック ルートの設定」

「ダイナミック ルートの設定」


) ルータの各モデルは、このマニュアルに記載されている機能の一部をサポートしていない場合があります。特定のルータでサポートされていない機能は、可能な限り明示されています。


この章では、該当するものがある場合には設定例と確認手順が記載されています。

グローバル コンフィギュレーション モードの利用の詳細については、付録 A「Cisco IOS Basic Skills」の「グローバル コンフィギュレーション モードの開始」の項を参照してください。

インターフェイス ポート

表 3-1 は、各ルータでサポートされているインターフェイスと装置に表記されているポート ラベルを示しています。

 

表 3-1 シスコ ルータでサポートされているインターフェイスと対応するポート ラベル

ルータ
インターフェイス
ポート ラベル

Cisco 860 シリーズ、Cisco 880 シリーズ

ファスト イーサネット LAN

LAN、FE0-FE3

ワイヤレス LAN

(表示なし)

Cisco 861、861W、881、881W

ファスト イーサネット WAN

WAN、FE4

Cisco 888、888W

G.SHDSL WAN

G.SHDSL

デフォルト設定

シスコ ルータを初めて起動すると、一部の基本的な設定はすでに行われています。LAN および WAN インターフェイスはすべて作成されており、コンソール ポートと VTY ポートの設定や Network Address Translation(NAT; ネットワーク アドレス変換)用の内部インターフェイスの割り当てもすでに行われています。初期設定を表示するには、 show running-config コマンドを使用します(次の Cisco 881W の例を参照してください)。

Router# show running-config
 
 
User Access Verification
 
Password:
Router> en
Password:
Router# show running-config
Building configuration...
 
Current configuration : 986 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$g4y5$NxDeM.0hON6YA51bcfGvN1
enable password ciscocisco
!
no aaa new-model
!
!
!
!
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authe
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
ip address 10.1.1.1 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface wlan-ap0
description Service Module interface to manage the embedded AP
ip unnumbered Vlan1
no cdp enable
arp timeout 0
!
ip route 0.0.0.0 0.0.0.0 10.1.1.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password cisco
login
transport input telnet ssh
!
scheduler max-task-time 5000
 
!
webvpn cef
end
 
Router#

設定に必要な情報

ネットワークを設定する前に、使用するネットワーク構成に基づいて、次の情報の一部またはすべてを収集しておく必要があります。

インターネット接続を設定する場合、次の情報を収集してください。

ユーザのログイン名として割り当てられた PPP クライアント名

PPP 認証のタイプ:Challenge Handshake Authentication Protocol(CHAP)または Password Authentication Protocol(PAP)

Internet Service Provider(ISP; インターネット サービス プロバイダー)アカウントにアクセスするための PPP パスワード

DNS サーバの IP アドレスおよびデフォルト ゲートウェイ

企業ネットワークへの接続を設定する場合は、ユーザとネットワーク管理者の間で、ルータの WAN インターフェイスに関する次の情報について打ち合わせておく必要があります。

PPP 認証のタイプ:CHAP または PAP

ルータにアクセスするための PPP クライアント名

ルータにアクセスするための PPP パスワード

IP ルーティングを設定する場合、次の準備が必要です。

IP ネットワークのアドレス指定方式を作成します。

IP アドレスなどの IP ルーティング パラメータ情報と ATM Permanent Virtual Circuit(PVC; 相手先固定接続)を特定します。通常、これらの PVC パラメータは、Virtual Path Identifier(VPI; 仮想パス識別子)、Virtual Circuit Identifier(VCI; 仮想回線識別子)、およびトラフィック シェーピング パラメータです。

サービス プロバイダーから付与された PVC 番号、VPI、および VCI を特定します。

PVC ごとに、サポートされている AAL5 カプセル化のタイプを判別します。次のようなものがあります。

AAL5SNAP:これは、RFC 1483 ルーティングまたは RFC 1483 ブリッジングのいずれかです。RFC 1483 ルーティングの場合、サービス プロバイダーはスタティック IP アドレスを提供する必要があります。ブリッジング RFC 1483 の場合、DHCP を用いて IP アドレスを入手するか、サービス プロバイダーからスタティック IP アドレスを入手することもできます。

AAL5MUX PPP:このタイプでのカプセル化では、PPP 関連設定項目を判別する必要があります。

ADSL または G.SHDSL 回線を使用して接続する場合、次の準備が必要です。

電話会社と回線契約を結びます。

ADSL 回線の場合:ADSL シグナリング タイプが DMT(ANSI T1.413 ともいう)または DMT Issue 2 であることを確認します。

G.SHDSL 回線の場合:G.SHDSL 回線が ITU G.991.2 規格に準拠し、Annex A(北米)または Annex B(欧州)をサポートしていることを確認します。

該当する情報の収集が済んだら、ルータの設定を行うことができます。「コマンドライン アクセスの設定」から設定を始めてください。

音声機器に接続する場合:

Cisco IOS Voice Port Configuration Guide 』を参照してください。

ソフトウェア ライセンスを取得または変更する場合:

Software Activation On Cisco Integrated Services Routers 』を参照してください。

コマンドライン アクセスの設定

ルータへのアクセスを制御するパラメータを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

line [ aux | console | tty | vty ] line-number

例:

Router(config)# line console 0
Router(config-line)#
 

ライン コンフィギュレーション モードを開始し、ライン タイプを指定します。

この例では、アクセス用のコンソール端末を指定しています。

ステップ 2

password password

例:

Router(config)# password 5dr4Hepw3
Router(config-line)#
 

コンソール端末ラインの一意なパスワードを指定します。

ステップ 3

login

例:

Router(config-line)# login
Router(config-line)#
 

端末セッション ログインでパスワード チェックをイネーブルにします。

ステップ 4

exec-timeout minutes [ seconds ]

例:

Router(config-line)# exec-timeout 5 30
Router(config-line)#
 

EXEC コマンド インタープリタがユーザ入力を待機する時間を設定します。デフォルトは 10 分です。秒単位の時間を任意に設定することもできます。

この例では、タイムアウト時間が 5 分 30 秒であることを示しています。タイムアウト時間を 0 0 に設定すると、タイムアウトは無効になります。

ステップ 5

line [ aux | console | tty | vty ] line-number

例:

Router(config-line)# line vty 0 4
Router(config-line)#
 

リモート コンソール アクセスの仮想端末を指定します。

ステップ 6

password password

例:

Router(config-line)# password aldf2ad1
Router(config-line)#
 

仮想端末ラインの一意なパスワードを指定します。

ステップ 7

login

例:

Router(config-line)# login
Router(config-line)#
 

仮想端末セッション ログインでパスワード チェックをイネーブルにします。

ステップ 8

end

例:

Router(config-line)# end
Router#
 

ライン コンフィギュレーション モードを終了して特権 EXEC モードに戻ります。

次の設定は、コマンドライン アクセス コマンドを示すものです。

「default」のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
 

グローバル パラメータの設定

ルータに選択したグローバル パラメータを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

configure terminal

例:

Router> enable

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。

リモート端末を使用してルータに接続している場合は、次のコマンドを使用します。

telnet router name or address

Login: login id

Password: *********

Router> enable

ステップ 2

hostname name

例:

Router(config)# hostname Router

Router(config)#

ルータ名を指定します。

ステップ 3

enable secret password

例:

Router(config)# enable secret cr1ny5ho

Router(config)#

ルータへの不正アクセスを防ぐための暗号化パスワードを指定します。

ステップ 4

no ip domain-lookup

例:

Router(config)# no ip domain-lookup Router(config)#

ルータが知らない語句(入力ミス)を IP アドレスに変換しないようにします。

WAN インターフェイスの設定

Cisco 860 および Cisco 880 シリーズ ISR は、WAN 接続用にそれぞれ 1 つのインターフェイスを持っています。

必要に応じて、次のいずれかの手順を行い、ルータの WAN インターフェイスを設定します。

「ファスト イーサネット WAN インターフェイスの設定」

「G.SHDSL WAN インターフェイスの設定」

「セル ワイヤレス WAN インターフェイスの設定」

ファスト イーサネット WAN インターフェイスの設定

Cisco 861 または 881 ISR でファスト イーサネット インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface fastethernet 4
Router(config-if)#
 

ルータのファスト イーサネット WAN インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 192.168.12.2 255.255.255.0
Router(config-if)#
 

指定されたファスト イーサネット インターフェイスの IP アドレスおよびサブネット マスクを設定します。

ステップ 3

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

イーサネット インターフェイスをイネーブルにして、インターフェイスの状態を管理上のダウンからアップに変更します。

ステップ 4

exit

例:

Router(config-if)# exit
Router(config)#
 

ファスト イーサネット インターフェイスのコンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

G.SHDSL WAN インターフェイスの設定

Cisco 888 ISR で G.SHDSL を設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# controller dsl 0

 

コントローラのコンフィギュレーション モードを開始し、コントローラ番号を入力します。

ステップ 2

Router(config-ctrl)# mode atm

 

ATM カプセル化をイネーブルにし、論理 ATM インターフェイス 0 を作成します。

ステップ 3

Router(config-ctrl)# line-term cpe

 

CPE をイネーブルにします。

ステップ 4

Router(config-ctrl)# line-mode 4 wire standard

4 線式動作をイネーブルにします。

ステップ 5

Router(config-ctrl)# line-rate 4608

SHDSL ポートの DSL ライン レートを指定します。範囲は、192 ~ 2312 kb/s です。デフォルトは、auto(SHDSL ポートおよび DSLAM 間でネゴシエートされます)です。


) 逆側の DSL アップリンクで設定されている DSL ライン レートが異なる場合、実際の DSL ライン レートは、常に、低い方のレートになります。



) 最大ピーク セル レートは、ライン レートより 8 kb/s 低くなります。


ステップ 6

Router(config-ctrl)# interface atm0

インターフェイス ATM 0 の ATM コンフィギュレーションモードを開始します。

ステップ 7

Router(config-ctrl)#ip-address IP-address

DSL ATM インターフェイスに IP アドレスを割り当てます。

ステップ 8

Router(config-ctrl)#load-interval 3

ステップ 9

Router(config-ctrl)# no atm ilmi-keepalive0

(任意)Integrated Local Management Interface(ILMI; 統合ローカル管理インターフェイス)キープアライブをディセーブルにします。

秒数を指定せずに ILMI キープアライブをイネーブルにした場合、デフォルトで、間隔は 3 秒になります。

ステップ 10

Router(config-ctrl)# pvc 0/35

atm-virtual-circuit(interface-atm-vc)コンフィギュレーション モードを開始し、名前(任意)および VPI/VCI 番号を割り当て、新しい ATM PVC を設定します。

デフォルトのトラフィック シェーピングは UBR です。デフォルトのカプセル化は AAL5+LLC/SNAP です。

ステップ 11

Router(config-ctrl)# protocol ip 10.10.10.2 broadcast

(任意)IP 接続をイネーブルし、VC のポイントツーポイント IP アドレスを作成します。

ステップ 12

Router(config-ctrl)# encapsulation aal5snap

(任意)ATM Adaptation Layer(AAL; ATM アダプテーション レイヤ)およびカプセル化タイプを設定します。

aal2 キーワードを AAL2 に使用します。

aal5ciscoppp キーワードを Cisco PPP over AAL5 に使用します。

aal5mux キーワードを AAL5+MUX に使用します。

aal5nlpid キーワードを AAL5+NLPID に使用します。

aal5snap キーワードを AAL5+LLC/SNAP(デフォルト)に使用します。

次の設定例は、4 線式標準 G.SHDSL 設定を示しています。

!
controller DSL 0
mode atm
line-term cpe
line-mode 4-wire standard
dsl-mode shdsl symmetric annex B
line-rate 4608
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
!
interface ATM0
ip address 10.10.10.1 255.255.255.0
no atm ilmi-keepalive
pvc 0/35
protocol ip 10.10.10.2 broadcast
encapsulation aal5snap
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
shutdown
!
interface Vlan1
ip address 2.15.15.26 255.255.255.0
!
ip forward-protocol nd
ip route 223.255.254.254 255.255.255.255 Vlan1
no ip http server
no ip http secure-server
!
 

設定の確認

ルータが正しく設定されているかどうかを確認するには、show run コマンドを入力して、コントローラ DSL およびインターフェイス ATM0 パラメータを調べます。

Router#sh run
Building configuration...
 
Current configuration : 1298 bytes
!
.......
 
!
controller DSL 0
mode atm
line-term cpe
line-mode 4-wire standard
dsl-mode shdsl symmetric annex B
line-rate 4608
!
!
interface ATM0
ip address 10.10.10.1 255.255.255.0
no atm ilmi-keepalive
pvc 0/31
protocol ip 10.10.10.5 broadcast
encapsulation aal5snap
!

 

 

セル ワイヤレス WAN インターフェイスの設定

Cisco 881G および 888G ISR は、Global System for Mobile Communications(GSM)および Code Division Multiple Access(CDMA; 符号分割多重接続)ネットワークを介して使用する、Third Generation(3G)ワイヤレス インターフェイスを提供します。このインターフェイスは、34-mm PCMCIA スロットです。

その主な用途は、重要なデータ アプリケーションのバックアップ データ リンクとしての WAN 接続です。ただし、3G ワイヤレス インターフェイスは、ルータのプライマリ WAN 接続としても機能できます。

3G セル ワイヤレス インターフェイスを設定するには、次の注意事項および手順に従ってください。

「3G ワイヤレス インターフェイスの設定に関する要件」

「セル ワイヤレス インターフェイスの設定に関する制約事項」

「データ アカウント プロビジョニング」

「セル インターフェイスの設定」

「DDR の設定」

「セル ワイヤレス インターフェイスの設定例」

3G ワイヤレス インターフェイスの設定に関する要件

次に、3G ワイヤレス インターフェイスの設定に関する要件を示します。

通信事業者のワイヤレス サービスが必要です。また、ルータが物理的に配置されるネットワーク カバレッジも必要です。サポートされている通信事業者の詳細リストについては、次の URL のデータ シートを参照してください。

http://www.cisco.com/en/US/prod/routers/networking_solutions_products_genericcontent0900aecd80601f7e.html

ワイヤレス サービス プロバイダーとのサービス プランに契約し、そのサービス プロバイダーから SIM カード(GSM モデムだけ)を取得する必要があります。

表 3-2 の信号強度を参照して、LED をチェックしなければなりません。

Cisco IOS ソフトウェアの Cisco 3G ワイヤレス サポートの Cisco IOS リリース 12.4(15)XZ 以降を十分に理解している必要があります(Cisco IOS 資料を参照してください)。

GSM データ プロファイルを設定するには、サービス プロバイダーから次の情報を取得する必要があります。

ユーザ名

パスワード

Access Point Name(APN; アクセス ポイント ネーム)

手動でアクティブにするために CDMA データ プロファイルを設定するには、サービス プロバイダーから次の情報を取得する必要があります。

Master Subsidy Lock(MSL)番号

Mobile Directory Number(MDN)

Mobile Station Identifier(MSID)

Electronic Serial Number(ESN)

 

表 3-2 前面パネル LED の信号強度表示

LED
LED カラー
信号強度

3G RSSI1

オレンジ

使用できるサービスがなく、RSSI が検出されません

グリーンが点灯

高速 RSSI(-69 dBm 以上)

グリーンが素早く(16 Hz)点滅

中速 RSSI(-89 ~ -70 dBm)

グリーンがゆっくり(1 Hz)点滅

低~中速 RSSI(-99 ~ -90 dBm)、信頼できる接続の最小レベル

消灯

低速 RSSI(-100 dBm 未満)

1.3G 受信信号強度表示

セル ワイヤレス インターフェイスの設定に関する制約事項

Cisco 3G ワイヤレス インターフェイスの設定には、次の制約事項があります。

データ接続は、3G ワイヤレス インターフェイスだけから行うことができます。リモート ダイヤルインはサポートされていません。

ワイヤレス通信共通の性質により、スループットは、ネットワークでのアクティブ ユーザの数や輻輳の量により異なります。

セル ネットワークの遅延は、優先ネットワークの場合よりも大きくなります。遅延レートは、テクノロジーおよび通信事業者により異なります。ネットワーク輻輳が発生している場合、遅延が大きくなることがあります。

VoIP は現在サポートされていません。

通信事業者のサービス条件に含まれるいずれの制約事項も Cisco 3G ワイヤレス インターフェイスに適用されます。

Cisco 880G ISR は、3G モデムの Online Insertion and Removal(OIR; 活性挿抜)をサポートしません。モデムをモデム タイプが同じ別のモデルと交換するには、モデムを交換する前に、Cisco CLI を使用して、セル インターフェイスで shutdown コマンドを入力します。

3G モデルが取り外されても、show interface cellular 0、show run および show version 出力に、セル インターフェイスに関する情報が表示されます。show interface コマンドは、次のメッセージを表示します。その他のすべてのコマンドは空の出力を表示します。

3G Modem not inserted
 

3G モデムが取り外されている状態でセル インターフェイスを設定できます。ただし、3G モデムが取り付けられるまで、設定は有効になりません。モデムが取り付けられていない状態でセル インターフェイスを設定しようとすると、次のメッセージが表示されます。

Router(config)#interface cellular 0
Warning: 3G Modem is not inserted
Configuration will not be effective until modem is inserted
 

取り外したモデムとタイプが異なるモデムを取り付ける場合、設定を変更し、システムをリロードしなければなりません。

データ アカウント プロビジョニング


) モデムをプロビジョニングするには、サービス プロバイダーとのアクティブ ワイヤレス アカウントが必要です。SIM カードを GSM 3G ワイヤレス カードに挿入する必要があります。


データ アカウントをプロビジョニングするには、次の手順を行います。

「信号強度およびサービス アベイラビリティの確認」

「GSM モデル データ プロファイルの設定」

「CDMA モデム アクティベーションおよびプロビジョニング」

信号強度およびサービス アベイラビリティの確認

モデムの信号強度およびサービス アベイラビリティを確認するには、特権 EXEC モードで、次のコマンドを使用します。

手順概要

1. show cellular 0 network

2. show cellular 0 hardware

3. show cellular 0 connection

4. show cellular 0 radio

5. show cellular 0 profile

6. show cellular 0 security

7. show cellular 0 all

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

Router# show cellular 0 network
 

Router# show cellular 0 network

通信事業者ネットワーク、セル サイト、および使用可能なサービスに関する情報を表示します。

ステップ 2

Router# show cellular 0 hardware
 
Router# show cellular 0 hardware

セル モデム ハードウェア情報を表示します。

ステップ 3

Router# show cellular 0 connection
 
Router# show cellular 0 connection

現在アクティブな接続状態およびデータの統計情報を表示します。

ステップ 4

Router# show cellular 0 radio
 

Router# show cellular 0 radio

ラジオ信号強度を示します。


) 接続が安定し信頼できる状態であるには RSSI が -90 dBm 以上でなければなりません。


ステップ 5

Router# show cellular 0 profiles
 

Router# show cellular 0 profile

作成されたモデム データ プロファイルに関する情報を示します。

ステップ 6

Router# show cellular 0 security
 

Router# show cellular 0 security

SIM およびモデム ロック ステータスなど、モデルのセキュリティ情報を示します。

ステップ 7

Router# show cellular 0 all
 

Router# show cellular 0 all

モデムに関する統合情報を示します。たとえば、作成されたプロファイル、ラジオ信号強度、ネットワーク セキュリティなどです。

GSM モデル データ プロファイルの設定

新しいモデム データ プロファイルを設定または作成するには、特権 EXEC モードで、次のコマンドを入力します。

手順概要

1. cellular gsm profile create <profile number> <apn> <authentication> <username> <password>

詳細手順

 

コマンドまたはアクション
目的
Router# cellular 0 gsm profile create <profile number> <apn> <authentication> <username> <password>
 

Router# cellular 0 gsm profile create 3 apn.com chap GSM GSMPassword

新しいモデム データ プロファイルを作成します。コマンド パラメータの詳細については、 表 3-3 を参照してください。

次の表は、モデム データ プロファイル パラメータのリストを示します。

 

表 3-3 モデム データ プロファイル パラメータ

profile number

作成するプロファイルの番号。最大 16 のプロファイルを作成できます。

apn

アクセス ポイント ネーム。この情報をサービス プロバイダーから取得する必要があります。

authentication

認証のタイプ。たとえば、CHAP、PAP です。

Username

サービス プロバイダーにより提供されるユーザ名。

Password

サービス プロバイダーにより提供されるパスワード。

CDMA モデム アクティベーションおよびプロビジョニング

アクティベーション手順は、通信事業者により異なります。通信事業者に問い合せて、次のいずれかの手順を実行してください。

手動によるアクティベーション

地上波サービス プロビジョニングを使用したアクティベーション

次の表は、さまざまなワイヤレス通信事業者によりサポートされているアクティベーションおよびプロビジョニング プロセスのリストを示します。

アクティベーションおよびプロビジョニング プロセス
通信事業者

MDN、MSID、MSL を使用した手動によるアクティベーション

Sprint

OTASP2 アクティベーション

Verizon Wireless

データ プロファイル リフレッシュ用 IOTA3

Sprint

2.地上波サービス プロビジョニング

3.インターネット地上波

手動によるアクティベーション


) この手順を開始する前に、有効な Mobile Directory Numner(MDN)、Mobile Subsidy Lock(MSL)、および Mobile Station Identifier(MSID)情報を通信事業者から取得しておく必要があります。


モデム プロファイルを手動で設定するには、EXEC モードから、次のコマンドを使用します。

cellular 0 cdma activate manual mdn msid sid nid msl

アクティブ化される前に、モデル データ プロファイルのプロビジョニングが、Internet Over the Air(IOTA; インターネット地上波)プロセスを介して行われます。IOTA プロセスは、cellular cdma activate manual コマンドを使用すると自動的に開始されます。

次に、このコマンドの出力例を示します。

router# cellular 0 cdma activate manual 1234567890 1234567890 1234 12 12345
NAM 0 will be configured and will become Active
Modem will be activated with following Parameters
MDN :1234567890; MSID :1234567890; SID :1234; NID 12:
Checking Current Activation Status
Modem activation status: Not Activated
Begin Activation
Account activation - Step 1 of 5
Account activation - Step 2 of 5
Account activation - Step 3 of 5
Account activation - Step 4 of 5
Account activation - Step 5 of 5
Secure Commit Result: Succeed
Done Configuring - Resetting the modem
The activation of the account is Complete
Waiting for modem to be ready to start IOTA
Beginning IOTA
router#
*Feb 6 23:29:08.459: IOTA Status Message Received. Event: IOTA Start, Result: SUCCESS
*Feb 6 23:29:08.459: Please wait till IOTA END message is received
*Feb 6 23:29:08.459: It can take up to 5 minutes
*Feb 6 23:29:27.951: OTA State = SPL unlock, Result = Success
*Feb 6 23:29:32.319: OTA State = Parameters commited to NVRAM, Result = Success
*Feb 6 23:29:40.999: Over the air provisioning complete; Result:Success
*Feb 6 23:29:41.679: IOTA Status Message Received. Event: IOTA End, Result: SUCCESS

 

IOTA Start および IOTA End には、結果の出力として「SUCCESS」と示されていなければなりません。エラー メッセージが表示された場合、cellular cdma activate iota コマンドを使用して個別に IOTA を実行できます。

通信事業者により、データ プロファイルの定期的なリフレッシュが要求されることがあります。データ プロファイルをリフレッシュするには、次のコマンドを使用します。

cellular cdma activate iota

Over-the-Air Service Provisioning を使用したアクティベーション

Over-the-Air Service Provisioning(OTASP)のプロビジョニングおよびアクティベーションを行うには、EXEC モードから、次のコマンドを使用します。

cellular 0 cdma activate otasp phone_number


) このコマンドで使用する電話番号は、通信事業者から取得する必要があります。標準の OTASP 発番号は *22899 です。


次に、このコマンドの出力例を示します。

router# cellular 0 cdma activate otasp *22899
Beginning OTASP activation
OTASP number is *22899
steelers_c881G#
OTA State = SPL unlock, Result = Success
router#
OTA State = PRL downloaded, Result = Success
OTA State = Profile downloaded, Result = Success
OTA State = MDN downloaded, Result = Success
OTA State = Parameters commited to NVRAM, Result = Success
Over the air provisioning complete; Result:Success

セル インターフェイスの設定

セル インターフェイスを設定するには、特権 EXEC モードから、次のコマンドを入力します。

手順概要

1. configure terminal

2. interface cellular 0

3. encapsulation ppp

4. ppp chap hostname <host>

5. ppp chap password 0 <password>

6. asynchronous mode interactive

7. ip address negotiated


) この手順で使用する PPP Challenge Handshake Authentication Protocol(CHAP)認証パラメータは、通信事業者により提供され、GSM プロファイル下だけで設定されているユーザ名およびパスワードと同じでなければなりません。CDMA では、ユーザ名またはパスワードは必要ありません。


詳細手順

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal
 

Router# configure terminal

端末からグローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface cellular 0
 

Router (config)# interface cellular 0

セル インターフェイスを指定します。

ステップ 3

Router(config-if)# encapsulation ppp
 

Router (config-if)# encapsulation ppp

専用非同期モードまたは Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)に設定されているインターフェイスの PPP カプセル化を指定します。

ステップ 4

Router(config-if)# ppp chap hostname <hostname>
 

Router (config-if)# ppp chap hostname cisco@wwan.ccs

インターフェイス固有の Challenge Handshake Authentication Protocol(CHAP)ホスト名を定義します。これは、通信事業者により提供されるユーザ名と一致しなければなりません。GSM だけに適用されます。

ステップ 5

Router(config-if)# ppp chap password 0 <password>
 

Router (config-if)# ppp chap password 0 cisco

インターフェイス固有の CHAP パスワードを定義します。これは、通信事業者により提供されるパスワードと一致しなければなりません。

ステップ 6

Router(config-if)# asynchronous mode interactive
 

Router (config-if)# asynchronous mode interactive

ラインを専用非同期ネットワーク モードから対話モードに戻して、特権 EXEC モードで、slip および ppp コマンドをイネーブルにします。

ステップ 7

Router(config-if)# ip address negotiated
 

Router (config-if)# ip address negotiated

特定のインターフェイスの IP アドレスが PPP および IPCP アドレス ネゴシエーションを介して取得されることを指定します。


セル インターフェイスでスタティック IP アドレスが必要な場合、アドレスは、ip address negotiated として設定できます。Internet Protocol Control Protocol(IPCP; インターネット プロトコル コントロール プロトコル)を介して、ネットワークにより、正しいスタティック IP アドレスがデバイスに割り当てられるようになります。トンネル インターフェイスが ip address unnumbered <cellular interface> で設定されている場合、実際のスタティック IP アドレスは、ip address negotiated でなく、セル インターフェイス下で設定されなければなりません。セル インターフェイスの設定例については、「セル インターフェイスの基本設定」を参照してください。


DDR の設定

セル インターフェイスのダイヤルオンデマンド ルーティング(DDR)を設定するには、次の手順を実行します。

手順概要

1. configure terminal

2. interface cellular 0

3. dialer in-band

4. dialer idle-timeout <seconds>

5. dialer string <string>

6. dialer group <number>

7. exit

8. dialer-list <dialer-group> protocol <protocol-name> {permit | deny | list <access-list-number> | access-group}>

9. ip access-list <access list number> permit <ip source address>

10. line 3

11. script dialer <regexp>

12. exit

13. chat-script <script name> "" "ATDT*99*<profile number>#" TIMEOUT <timeout value> CONNECT

14. interface cellular 0

15. dialer string <string>

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface cellular 0

 

Router (config)# interface cellular 0

セル インターフェイスを指定します。

ステップ 3

Router(config-if)# dialer in-band

 

Router (config-if)# dialer in-band

DDR をイネーブルにし、インバンド ダイヤリングに指定されたシリアル インターフェイスを設定します。

ステップ 4

Router(config-if)# dialer idle-timeout <seconds>

 

Router (config-if)# dialer idle-timeout 30

回線が切断されるまでのアイドル時間を秒単位で指定します。

ステップ 5

Router(config-if)# dialer string <string>

 

Router (config-if)# dialer string gsm

ダイヤルする番号またはストリングを指定します。チャット スクリプトの名前をここで使用します。

ステップ 6

Router(config-if)# dialer-group <number>

 

Router (config-if)# dialer-group 1

特定のインターフェイスが属するダイヤラ アクセス グループの番号を指定します。

ステップ 7

Router(config-if)# exit

 

Router (config-if)# exit

グローバル コンフィギュレーション モードを開始します。

ステップ 8

Router(config)# dialer-list <dialer-group> protocol <protocol-name> {permit | deny | list <access-list-number> | access-group}>

 

Router (config)# dialer-list 1 protocol ip list 1

対象トラフィックのダイヤラ リストを作成して、すべてのプロトコルへのアクセスを許可します。

ステップ 9

Router(config)# ip access-list <access list number> permit <ip source address>

 

Router (config)# ip access list 1 permit any

対象トラフィックを定義します。

ステップ 10

Router(config)# line 3

 

Router (config-line)# line 3

ライン コンフィギュレーション モードを指定します。これは常に 3 です。

ステップ 11

Router(config-line)script dialer <regexp>

 

Router (config-line)# script-dialer gsm

デフォルト モデム チャット スクリプトを指定します。

ステップ 12

Router(config-line)exit

 

Router (config-line)# exit

ライン コンフィギュレーション モードを終了します。

ステップ 13

For GSM:

Router(config)# chat-script <script name> ”” “ATDT*99*<profile number>#” TIMEOUT <timeout value> CONNECT

 

For CDMA:

Router(config)# chat-script <script name> "" "ATDT*777*<profile number>#" TIMEOUT <timeout value> CONNECT

 

Router (config)# chat-script gsm "" "ATDT*98*2#" TIMEOUT 60 "CONNECT“

ラインが GSM 用です。

ラインが CDMA 用です。

ダイヤラが開始されるときの Attention Dial Tone(ATDT)コマンドを定義します。

ステップ 14

Router(config)# interface cellular 0

 

Router (config)# interface cellular 0

セル インターフェイスを指定します。

ステップ 15

Router(config-if)# dialer string <string>

 

Router (config)# dialer string gsm

ダイヤラ スクリプト(chat script コマンドを使用して定義されます)を指定します。

セル ワイヤレス インターフェイスの設定例

ここでは、次の設定例を示します。

「セル インターフェイスの基本設定」

「セル インターフェイス設定を介したトンネル」

セル インターフェイスの基本設定

次に、プライマリ WAN 接続として使用される gsm セル インターフェイスを設定する例を示します。これは、デフォルト ルートとして設定されます。

chat-script gsm "" "ATDT*98*2#" TIMEOUT 60 "CONNECT“
 
!
interface Cellular0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string gsm
dialer-group 1
async mode interactive
ppp chap hostname cisco@wwan.ccs
ppp chap password 0 cisco
ppp ipcp dns request
!
 
ip route 0.0.0.0 0.0.0.0 Cellular0
!
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 3
exec-timeout 0 0
script dialer gsm
login
modem InOut
 

次に、プライマリとして使用される cdma セル インターフェイスを設定する例を示します。これは、デフォルト ルートとして設定されます。

chat-script cdma "" "ATDT#777" TIMEOUT 60 "CONNECT“
 
!
interface Cellular0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string cdma
dialer-group 1
async mode interactive
ppp chap password 0 cisco
!
 
ip route 0.0.0.0 0.0.0.0 Cellular0
!
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 3
exec-timeout 0 0
script dialer cdma
login
modem InOut
 

セル インターフェイス設定を介したトンネル

次に、トンネル インターフェイスが ip address unnumbered < cellular interface > コマンドで設定される場合のスタティック IP アドレスを設定する例を示します。

interface Tunnel2
ip unnumbered Cellular0
tunnel source Cellular0
tunnel destination 128.107.248.254
 
interface Cellular0
bandwidth receive 1400000
ip address 23.23.0.1 255.255.0.0
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 0
dialer string dial<carrier>
dialer-group 1
async mode interactive
no ppp lcp fast-start
ppp chap hostname <hostname> *** gsm only ***
ppp chap password 0 <password>
ppp ipcp dns request
 
! traffic of interest through the tunnel/cellular interface
ip route 10.10.0.0 255.255.0.0 Tunnel2
 

ファスト イーサネット LAN インターフェイスの設定

ルータのファスト イーサネット LAN インターフェイスは、デフォルト VLAN の一部として自動的に設定され、個別のアドレスによる設定は行われません。アクセスは VLAN を通じて提供されます。必要に応じて、このインターフェイスを別の VLAN に割り当てることが可能です。VLAN 作成の詳細については、「イーサネット スイッチの設定」を参照してください。

ワイヤレス LAN インターフェイスの設定

Cisco 861W ISR および Cisco 880W シリーズ ISR は、ワイヤレス LAN 接続の統合 802.11n モジュールを備えています。このルータは、ローカル インフラストラクチャのアクセス ポイントとして機能できます。ワイヤレス接続の設定の詳細については、「ワイヤレス デバイスの基本設定」を参照してください。

ループバック インターフェイスの設定

ループバック インターフェイスは、スタティック IP アドレスのプレースホルダとして機能し、デフォルトのルーティング情報を提供します。

ループバック インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の手順を実行します。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface Loopback 0
Router(config-if)#
 

ループバック インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-if)# ip address 10.108.1.1 255.255.255.0
Router(config-if)#
 

ループバック インターフェイスの IP アドレスおよびサブネット マスクを設定します。

ステップ 3

exit

例:

Router(config-if)# exit
Router(config)#
 

ループバック インターフェイスのコンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

設定例のループバック インターフェイスは、仮想テンプレート インターフェイス上で Network Address Translation(NAT; ネットワーク アドレス変換)をサポートするために使用されます。この設定例は、スタティック IP アドレスとなる IP アドレス 200.200.100.1/24 を持つファスト イーサネット インターフェイスに設定されるループバック インターフェイスを示します。このループバック インターフェイスは、ネゴシエートされた IP アドレスを持つ virtual-template1 を指します。

!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
 

設定の確認

ループバック インターフェイスが正しく設定されているかどうかを確認するには、show interface loopback コマンドを入力します。確認出力は、次の例のように表示されます。

Router# show interface loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 

インターフェイスに対して ping を実行してループバック インターフェイスを確認することもできます。

Router# ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 
 

スタティック ルートの設定

スタティック ルートを使用すると、ネットワーク内で固定ルーティング パスを利用できます。スタティック ルートは、ルータ上で手動で設定します。ネットワーク トポロジーが変化した場合には、新しいルートを使用してスタティック ルートを更新する必要があります。スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベートなルートです。

スタティック ルートを設定するには、グローバル コンフィギュレーション モードから、次の手順を実行します。

 

コマンド
目的

ステップ 1

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 192.168.1.0 255.255.0.0 10.10.10.2
Router(config)#
 

IP パケットのスタティック ルートを指定します。

このコマンドの詳細および設定可能なその他のパラメータについては、『 Cisco IOS IP Routing Protocols Command Reference 』を参照してください。

ステップ 2

end

例:

Router(config)# end
Router#
 

ルータ コンフィギュレーション モードを終了して特権 EXEC モードに戻ります。

スタティック ルーティングの一般的な説明については、 付録 B「フローティング スタティック ルート」 を参照してください。

次の設定例で、スタティック ルートは、ファスト イーサネット インターフェイスで宛先 IP アドレス 192.168.1.0 およびサブネット マスク 255.255.255.0 を持つすべての IP パケットを、IP アドレス 10.10.10.2 を持つ別のデバイスに送信します。これらのパケットは設定された PVC へ送信されています。

「default」のマークが付いているコマンドは入力する必要がありません。このコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
 

設定の確認

スタティック ルーティングが正しく設定されているかどうかを確認するには、show ip route コマンドを入力し、「S」で表されるスタティック ルートを調べます。

確認出力は、次のように表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
 

ダイナミック ルートの設定

ダイナミック ルーティングでは、ネットワーク プロトコルは、ネットワーク トラフィックまたはネットワーク トポロジーに基づき自動的にパスを調整します。ダイナミック ルートの変更は、ネットワーク上の他のルータと共有されます。

シスコ ルータは、Routing Information Protocol(RIP)または Enhanced Interior Gateway Routing Protocol(EIGRP)などの IP ルーティング プロトコルを使用して、動的にルートを学習します。ルータでは RIP または EIGRP のいずれかのルーティング プロトコルを設定できます。

「Routing Information Protocol の設定」

「Enhanced Interior Gateway Routing Protocol の設定」

Routing Information Protocol の設定

ルータ上で RIP ルーティング プロトコルを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
作業

ステップ 1

router rip

例:

Router> configure terminal
Router(config)# router rip
Router(config-router)#
 

ルータ コンフィギュレーション モードを開始し、ルータ上で RIP をイネーブルにします。

ステップ 2

version { 1 | 2 }

例:

Router(config-router)# version 2
Router(config-router)#
 

RIP バージョン 1 または 2 を使用することを指定します。

ステップ 3

network ip-address

例:

Router(config-router)# network 192.168.1.1
Router(config-router)# network 10.10.7.1
Router(config-router)#
 

RIP を適用するネットワークのリストを指定します(直接接続されている各ネットワークのネットワーク アドレスを使用)。

ステップ 4

no auto-summary

例:

Router(config-router)# no auto-summary
Router(config-router)#
 

ネットワーク レベル ルートへのサブネット ルートの自動サマライズをディセーブルにします。その結果、サブプレフィクス ルーティング情報がクラスフル ネットワーク境界を超えて伝送されます。

ステップ 5

end

例:

Router(config-router)# end
Router#
 

ルータ コンフィギュレーション モードを終了して特権 EXEC モードに戻ります。

RIP に関する一般的な説明については、 付録 B「RIP」 を参照してください。

次に、IP ネットワーク 10.0.0.0 および 192.168.1.0 で RIP バージョン 2 をイネーブルにする設定例を示します。

この設定を参照するには、特権 EXEC モードから、 show running-config コマンドを使用します。

!
Router# show running-config
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
 

設定の確認

RIP が正しく設定されているかどうかを確認するには、show ip route コマンドを入力し、「R」で表される RIP ルートを調べます。確認出力は、次の例のように表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0
 

Enhanced Interior Gateway Routing Protocol の設定

Enhanced Interior Gateway Routing Protocol GRP(EGRP)を設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

router eigrp as-number

例:

Router(config)# router eigrp 109
Router(config)#
 

ルータ コンフィギュレーション モードを開始して、ルータ上で EIGRP をイネーブルにします。自律システム番号は、他の EIGRP ルータへのルートを表し、EIGRP 情報のタグ付けに使用されます。

ステップ 2

network ip-address

例:

Router(config)# network 192.145.1.0
Router(config)# network 10.10.12.115
Router(config)#
 

EIGRP を適用するネットワークのリストを指定します(直接接続されているネットワークの IP アドレスを使用)。

ステップ 3

end

例:

Router(config-router)# end
Router#
 

ルータ コンフィギュレーション モードを終了して特権 EXEC モードに戻ります。

EIGRP の概要については、 付録 B「EIGRP」 を参照してください。

次に、IP ネットワーク 192.145.1.0 および 10.10.12.115 で EIGRP ルーティング プロトコルをイネーブルにする設定例を示します。EIGRP 自律システム番号は、109 に設定されています。

この設定を参照するには、特権 EXEC モードから、 show running-config コマンドを使用します。

!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!
 

設定の確認

IP EIGRP が正しく設定されているかどうかを確認するには、show ip route コマンドを入力し、「D」で表される EIGRP ルートを調べます。確認出力は、次の例のように表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0