Cisco 860 および Cisco 880 シリーズ サービス 統合型ルータ ソフトウェア コンフィギュレーショ ン ガイド
バックアップ データ ラインおよびリモート管 理の設定
バックアップ データ ラインおよびリモート管理の設定
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

バックアップ データ ラインおよびリモート管理の設定

バックアップ インターフェイスの設定

セル ダイヤルオンデマンド ルーティング バックアップの設定

ダイヤラ ウォッチを使用した DDR バックアップの設定

フローティング スタティック ルートを使用した DDR バックアップの設定

NAT および IPsec 設定でのバックアップとしてのセル ワイヤレス モデム

コンソール ポートまたは AUX ポートを使用したダイヤル バックアップおよびリモート管理の設定

ISDN S/T ポートを使用したデータ ライン バックアップおよびリモート管理の設定

ISDN の設定

アグリゲータおよび ISDN ピア ルータの設定

バックアップ データ ラインおよびリモート管理の設定

この章では、次の項で、バックアップ データ ラインおよびリモート管理の設定について説明します。

「バックアップ インターフェイスの設定」

「セル ダイヤルオンデマンド ルーティング バックアップの設定」

「コンソール ポートまたは AUX ポートを使用したダイヤル バックアップおよびリモート管理の設定」

「ISDN S/T ポートを使用したデータ ライン バックアップおよびリモート管理の設定」

Cisco 880 シリーズ Integrated Services Router(ISR; サービス統合型ルータ)は、WAN のダウンタイムを削減するバックアップ データ ラインとのバックアップ データ接続をサポートします。


) ビデオ バックアップは、ルータ モデル C881SRST および C888SRST で使用できます。ビデオ バックアップの設定については、「音声機能の設定」を参照してください。


Cisco 880 ISR は、次のようにリモート管理機能をサポートします。

任意の Cisco 880 シリーズ ISR の AUX ポートを使用

Cisco 880 シリーズ ISR の ISDN S/T ポートを使用


) Cisco 880 シリーズ ISR では、コンソール ポートおよび AUX ポートは、同じ物理 RJ-45 ポートにあります。そのため、これら 2 つのポートを同時にアクティブにできません。Command-Line Interface(CLI; コマンドライン インターフェイス)を使用して、目的の機能をイネーブルにする必要があります。


バックアップ インターフェイスの設定

プライマリ インターフェイスがダウンしていることをルータが検出した場合、バックアップ インターフェイスはイネーブルになっています。指定された期間中にプライマリ接続が復旧した場合、バックアップ インターフェイスがディセーブルになります。

バックアップ インターフェイスがスタンバイ モードから起動した場合も、ルータはそのバックアップ インターフェイスに関する指定されたトラフィックを受信しない限り、バックアップ インターフェイスをイネーブルにしません。

表 4-1 に、各 Cisco 880 ISR で使用できるバックアップ インターフェイス、およびポート指定を示します。これらのインターフェイスの基本設定は、「基本的なルータの設定」「WAN インターフェイスの設定」に示します。

 

モデル番号およびデータ ライン バックアップ機能

ルータ モデル番号
ISDN
3G

881G

--

あり

888G

--

あり

888

あり

--

ルータでバックアップ インターフェイスを設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface atm 0
Router(config-if)#
 

バックアップの設定を行うインターフェイスで、インターフェイス コンフィギュレーション モードを開始します。

ここで指定できるのは、シリアル インターフェイス、ISDN インターフェイス、または非同期インターフェイスです。

この例では、ATM WAN 接続のバックアップ インターフェイスを設定しています。

ステップ 2

backup interface interface-type interface-number

例:

Router(config-if)# backup interface bri 0
Router(config-if)#
 

インターフェイスをセカンダリ、つまりバックアップ インターフェイスとして割り当てます。

ここで指定できるインターフェイスは、シリアル インターフェイスまたは非同期インターフェイスです。たとえば、シリアル 0 インターフェイスのバックアップとしてシリアル 1 インターフェイスを設定できます。

この例では、ATM 0 インターフェイスのバックアップ インターフェイスとして BRI インターフェイスを設定しています。

ステップ 3

exit

例:

Router(config-if)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了します。

セル ダイヤルオンデマンド ルーティング バックアップの設定

プライマリ接続を監視し、必要に応じてセル インターフェイスを介してバックアップ接続を開始するには、ルータは、次のいずれかの方法を使用できます。

バックアップ インターフェイス:プライマリ インターフェイス ライン プロトコルが停止していることが検出されてから、起動されるまで、スタンバイ モードを維持するバックアップ インターフェイス。「バックアップ インターフェイスの設定」を参照してください。

ダイヤラ ウォッチ:ダイヤラ ウォッチは、ダイヤル バックアップとルーティング機能を統合するバックアップ機能です。「ダイヤラ ウォッチを使用した DDR バックアップの設定」を参照してください。

フローティング スタティック ルート:バックアップ インターフェイスを介したルートの管理距離は、プライマリ接続ルートよりも長いため、プライマリ インターフェイスがダウンするまで、ルーティング テーブルに格納されません。プライマリ インターフェイスがダウンすると、フローティング スタティック ルートが使用されます。「フローティング スタティック ルートを使用した DDR バックアップの設定」を参照してください。


) セル インターフェイスのバックアップ インターフェイスおよびその他の任意の非同期シリアル インターフェイスは設定できません。


ダイヤラ ウォッチを使用した DDR バックアップの設定

ダイヤラ ウォッチを開始するには、Dial-On-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)およびバックアップを実行するインターフェイスを設定する必要があります。ダイヤラ マップなど、DDR 機能の従来の DDR コンフィギュレーション コマンドを使用します。バックアップ インターフェイスでダイヤラ ウォッチをイネーブルにして、ダイヤラ リストを作成するには、インターフェイス コンフィギュレーション モードで、次のコマンドを使用します。

手順概要

1. configure terminal

2. interface type number

3. dialer watch group group-number

4. dialer watch-list group-number ip ip-address address-mask

5. dialer-list <dialer-group> protocol <protocol name> {permit | deny | list <access list number> | access-group}

6. ip access-list <access list number> permit <ip source address>

7. interface cellular 0

8. dialer string <string>

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface type number

 

Router (config)# interface ATM0

インターフェイスを指定します。

ステップ 3

Router(config-if)# dialer watch-group

group-number

 

Router(config-if)# dialer watch-group 2

バックアップ インターフェイスでダイヤラ ウォッチをイネーブルにします。

ステップ 4

Router(config)# dialer watch-list group-number ip ip-address address-mask

 

Router(config-if)# dialer watch-list 2 ip 10.4.0.254 255.255.0.0

ウォッチ対象のすべての IP アドレスのリストを定義します。

ステップ 5

Router(config)# dialer-list <dialer-group> protocol <protocol-name> {permit | deny | list <access-list-number> | access-group}>

 

Router(config)# dialer-list 2 protocol ip permit

対象トラフィックのダイヤラ リストを作成して、すべてのプロトコルへのアクセスを許可します。

ステップ 6

Router(config)# ip access-list <access list number> permit <ip source address>

 

Router(config)# access list 2 permit 10.4.0.0

対象トラフィックを定義します。

access list permit all コマンドを使用して、トラフィックの IP ネットワークへの送信を回避しないでください。このようにすると、コールが終了することがあります。

ステップ 7

Router(config)# interface cellular 0
 

Router (config)# interface cellular 0

セル インターフェイスを指定します。

ステップ 8

Router(config-if)# dialer string <string>

または

Router(config-if)# dialer group <dialer group number>
 

Router (config-if)# dialer string cdma *** cdma ***

 

または

Router (config-if)# dialer group 2 *** gsm ***

CDMA だけ。ダイヤラ スクリプト(chat script コマンドを使用して定義されます)を指定します。

GSM だけ。ダイヤラ リストをダイヤラ インターフェイスにマッピングします。

フローティング スタティック ルートを使用した DDR バックアップの設定

フローティング スタティック デフォルト ルートをセカンダリ インターフェイスで設定するには、グローバル コンフィギュレーション モードから、次のコマンドを使用します。


) ルータで IP クラスがイネーブルになっていることを確認してください。


手順概要

1. configure terminal

2. ip route network-number network-mask {ip address | interface} [administrative distance] [name name]

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

 

Router# configure terminal

端末からグローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# ip route network-number network-mask

{ip-address | interface} [administrative distance] [name name]

 

Router (config)# ip route 0.0.0.0 Dialer 2 track 234

指定されたインターフェイスを介して設定されている管理距離でフローティング スタティック ルートを確立します。

プライマリ インターフェイスがダウンした場合だけバックアップ インターフェイスが使用されるように、バックアップ インターフェイスのルートに設定する管理距離は長くしてください。

NAT および IPsec 設定でのバックアップとしてのセル ワイヤレス モデム

次に、GSM または CDMA のいずれかのネットワークの NAT および IPsec で 3G ワイヤレス モデムを設定する例を示します。


) 受信および送信速度は設定できません。実際のスループットは、セル ネットワーク サービスにより異なります。


Current configuration : 3433 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
crypto isakmp key gsm address 128.107.241.234 *** or cdma ***
!
!
crypto ipsec transform-set gsm ah-sha-hmac esp-3des *** or cdma ***
!
crypto map gsm1 10 ipsec-isakmp *** or cdma1 ***
set peer 128.107.241.234
set transform-set gsm *** or cdma ***
match address 103
!
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.4.0.254
!
ip dhcp pool gsmpool *** or cdmapool ***
network 10.4.0.0 255.255.0.0
dns-server 66.209.10.201 66.102.163.231
default-router 10.4.0.254
!
!
ip cef
!
no ipv6 cef
multilink bundle-name authenticated
chat-script gsm "" "atdt*98*1#" TIMEOUT 30 "CONNECT" *** or cdma ***
!
!
archive
log config
hidekeys
!
!
controller DSL 0
mode atm
line-term cpe
line-mode 4-wire standard
line-rate 4608
!
!
!
!
interface ATM0
no ip address
ip virtual-reassembly
load-interval 30
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
backup interface Cellular0
ip nat outside
ip virtual-reassembly
pvc 0/35
pppoe-client dial-pool-number 2
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 0
dialer string gsm *** or cdma ***
dialer-group 1
async mode interactive
no ppp lcp fast-start
ppp chap hostname chunahayev@wwan.ccs
ppp chap password 0 B7uhestacr
ppp ipcp dns request
crypto map gsm1 *** or cdma1 ***
!
interface Vlan1
description used as default gateway address for DHCP clients
ip address 10.4.0.254 255.255.0.0
ip nat inside
ip virtual-reassembly
!
interface Dialer2
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer pool 2
dialer-group 2
ppp authentication chap callin
ppp chap hostname cisco@dsl.com
ppp chap password 0 cisco
ppp ipcp dns request
crypto map gsm1 *** or cdma1 ***
!
ip local policy route-map track-primary-if
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer2 track 234
ip route 0.0.0.0 0.0.0.0 Cellular0 254
no ip http server
no ip http secure-server
!
!
ip nat inside source route-map nat2cell interface Cellular0 overload
ip nat inside source route-map nat2dsl interface Dialer2 overload
!
ip sla 1
icmp-echo 209.131.36.158 source-interface Dialer2
timeout 1000
frequency 2
ip sla schedule 1 life forever start-time now
access-list 1 permit any
access-list 2 permit 10.4.0.0 0.0.255.255
access-list 3 permit any
access-list 101 permit ip 10.4.0.0 0.0.255.255 any
access-list 102 permit icmp any host 209.131.36.158
access-list 103 permit ip host 166.136.225.89 128.107.0.0 0.0.255.255
access-list 103 permit ip host 75.40.113.246 128.107.0.0 0.0.255.255
dialer-list 1 protocol ip list 1
dialer-list 2 protocol ip permit
!
!
!
route-map track-primary-if permit 10
match ip address 102
set interface Dialer2
!
route-map nat2dsl permit 10
match ip address 101
match interface Dialer2
!
route-map nat2cell permit 10
match ip address 101
match interface Cellular0
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line 3
exec-timeout 0 0
script dialer gsm *** or cdma ***
login
modem InOut
no exec
line vty 0 4
login
!
scheduler max-task-time 5000
 
!
webvpn cef
end
 

コンソール ポートまたは AUX ポートを使用したダイヤル バックアップおよびリモート管理の設定

Cisco 880 シリーズ ISR などの加入者宅内機器と Internet Service Provider(ISP; インターネット サービス プロバイダー)が接続されている場合、IP アドレスは動的にルータに割り当てられます。また、中央管理機能を使用して、ルータのピアによって割り当てられることもあります。ダイヤル バックアップ機能を追加すると、プライマリ回線に障害が発生した場合に、フェールオーバー ルートを使用できます。Cisco 880 シリーズ ISR では、AUX ポートを使用してダイヤル バックアップおよびリモート管理を行うことができます。

図 4-1 は、リモート管理アクセスおよびプライマリ WAN 回線のバックアップに使用するネットワーク設定を示しています。

図 4-1 AUX ポートを使用したダイヤル バックアップおよびリモート管理

 

 

1

Cisco 880 シリーズ ルータ

A

メイン WAN リンク(インターネット サービス プロバイダーとのプライマリ接続)

2

モデム

B

ダイヤル バックアップ(プライマリ回線がダウンした場合に Cisco 880 ルータのフェールオーバー リンクとして機能)

3

PC

C

リモート管理(Cisco IOS の設定の変更または更新が可能なダイヤルイン アクセスとして機能)

これらのルータでダイヤル バックアップおよびリモート管理を設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

ip name-server server-address

例:

Router(config)#ip name-server 192.168.28.12
Router(config)#
 

ISP DNS IP アドレスを入力します。

ヒント 複数のサーバ アドレスが存在する場合には、それらのアドレスも追加できます。

ステップ 2

ip dhcp pool name

例:

Router(config)#ip dhcp pool 1
Router(config-dhcp)#
 

ルータ上に DHCP アドレス プールを作成し、DHCP プール コンフィギュレーション モードを開始します。 name 引数には、ストリングまたは整数を使用できます。

DHCP アドレス プールを設定します。DHCP プール コンフィギュレーション モードで使用可能なサンプル コマンドについては、「例」を参照してください。

ステップ 3

exit

例:

Router(config-dhcp)#exit
Router(config)#
 

config-dhcp モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

ステップ 4

chat-script script-name expect-send

例:

Router(config)# chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102 T” TIMEOUT 45 CONNECT \c
Router(config)#
 

ダイヤルオンデマンド ルーティング(DDR)で使用するチャット スクリプトを設定し、モデムのダイヤリングおよびリモート システムへのログインを行うコマンドを使用します。定義されたスクリプトは、PSTN に接続されているモデム経由でコールする場合に使用されます。

ステップ 5

interface type number

例:

Router(config)# interface Async 1
Router(config-if)#
 

非同期インターフェイスのコンフィギュレーション モードを作成および開始します。

非同期インターフェイスを設定します。非同期インターフェイス コンフィギュレーション モードで使用可能なサンプル コマンドについては、「例」を参照してください。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

グローバル コンフィギュレーション モードを開始します。

ステップ 7

interface type number

例:

Router(config)# interface Dialer 3
Router(config-if)#
 

ダイヤラ インターフェイスのコンフィギュレーション モードを作成および開始します。

ステップ 8

dialer watch-group group-number

例:

Router(config-if)# dialer watch-group 1
Router(config-if)#
 

ウォッチ リストのグループ番号を指定します。

ステップ 9

exit

例:

Router(config-if)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了します。

ステップ 10

ip nat inside source {list access-list-number } {interface type number | pool name } [overload]

例:

Router(config)# ip nat inside source list 101 interface Dialer 3 overload
 

内部のインターフェイスでダイナミック アドレス変換をイネーブルにします。

ステップ 11

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 0.0.0.0 0.0.0.0 22.0.0.2
Router(config)#
 

デフォルト ゲートウェイとしてダイヤラ インターフェイスを示すように、IP ルートを設定します。

ステップ 12

access-list access-list-number { deny | permit} source [ source-wildcard ]

例:

Router(config)# access-list 1 permit 192.168.0.0 0.0.255.255 any
 

変換が必要なアドレスを指定する拡張アクセス リストを定義します。

ステップ 13

dialerwatch-list group-number { ip ip-address address-mask | delay route-check initial seconds }

例:

Router(config)# dialer watch-list 1 ip 22.0.0.2 255.255.255.255
Router(config)#
 

ピアへのルートが存在するかどうかに基づいて、プライマリ リンクのステータスを評価します。アドレス 22.0.0.2 は ISP のピア IP アドレスです。

ステップ 14

line [ aux | console | tty | vty ] line-number [ ending-line-number ]

例:

Router(config)# line console 0
Router(config-line)#
 

ライン インターフェイスのコンフィギュレーション モードを開始します。

ステップ 15

modem enable

例:

Router(config-line)# modem enable
Router(config-line)#
 

ポートをコンソールから AUX ポート機能に変更します。

ステップ 16

exit

例:

Router(config-line)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了します。

ステップ 17

line [ aux | console | tty | vty ] line-number [ ending-line-number ]

例:

Router(config)# line aux 0
Router(config)#
 

AUX インターフェイス コンフィギュレーション モードを開始します。

ステップ 18

flowcontrol { none | software [ lock ] [ in | out ] | hardware [ in | out ]}

例:

Router(config)# flowcontrol hardware
Router(config)#
 

ハードウェア信号フロー制御をイネーブルにします。

次の設定例では、ATM インターフェイスの IP アドレスを、PPP および Internet Protocol Control Protocol(IPCP; インターネット プロトコル コントロール プロトコル)アドレス ネゴシエーションおよびコンソール ポートを介したダイヤル バックアップによって指定します。

!
ip name-server 192.168.28.12
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool 1
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
! Need to use your own correct ISP phone number.
modemcap entry MY-USER_MODEM:MSC=&F1S0=1
chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102\T”
TIMEOUT 45 CONNECT \c
!
!
!
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
hold-queue 100 out
!
! Dial backup and remote management physical interface.
interface Async1
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 3
async default routing
async dynamic routing
async mode dedicated
ppp authentication pap callin
!
interface ATM0
mtu 1492
no ip address
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
! Primary WAN link.
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! Dialer backup logical interface.
interface Dialer3
ip address negotiated
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 3
dialer idle-timeout 60
dialer string 5555102 modem-script Dialout
dialer watch-group 1
!
! Remote management PC IP address.
peer default ip address 192.168.2.2
no cdp enable
!
! Need to use your own ISP account and password.
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! IP NAT over Dialer interface using route-map.
ip nat inside source route-map main interface Dialer1 overload
ip nat inside source route-map secondary interface Dialer3 overload
ip classless
!
! When primary link is up again, distance 50 will override 80 if dial backup
! has not timed out. Use multiple routes because peer IP addresses are alternated
! among them when the CPE is connected.
ip route 0.0.0.0 0.0.0.0 64.161.31.254 50
ip route 0.0.0.0 0.0.0.0 66.125.91.254 50
ip route 0.0.0.0 0.0.0.0 64.174.91.254 50
ip route 0.0.0.0 0.0.0.0 63.203.35.136 80
ip route 0.0.0.0 0.0.0.0 63.203.35.137 80
ip route 0.0.0.0 0.0.0.0 63.203.35.138 80
ip route 0.0.0.0 0.0.0.0 63.203.35.139 80
ip route 0.0.0.0 0.0.0.0 63.203.35.140 80
ip route 0.0.0.0 0.0.0.0 63.203.35.141 80
ip route 0.0.0.0 0.0.0.0 Dialer1 150
no ip http server
ip pim bidir-enable
!
! PC IP address behind CPE.
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 103 permit ip 192.168.0.0 0.0.255.255 any
!
! Watch multiple IP addresses because peers are alternated
! among them when the CPE is connected.
dialer watch-list 1 ip 64.161.31.254 255.255.255.255
dialer watch-list 1 ip 64.174.91.254 255.255.255.255
dialer watch-list 1 ip 64.125.91.254 255.255.255.255
!
! Dial backup will kick in if primary link is not available
! 5 minutes after CPE starts up.
dialer watch-list 1 delay route-check initial 300
dialer-list 1 protocol ip permit
!
! Direct traffic to an interface only if the dialer is assigned an IP address.
route-map main permit 10
match ip address 101
match interface Dialer1
!
route-map secondary permit 10
match ip address 103
match interface Dialer3
!
! Change console to aux function.
line con 0
exec-timedout 0 0
modem enable
stopbits 1
line aux 0
exec-timeout 0 0
! To enable and communicate with the external modem properly.
script dialer Dialout
modem InOut
modem autoconfigure discovery
transport input all
stopbits 1
speed 115200
flowcontrol hardware
line vty 0 4
exec-timeout 0 0
password cisco
login
!
scheduler max-task-time 5000
end
 

ISDN S/T ポートを使用したデータ ライン バックアップおよびリモート管理の設定

Cisco 880 シリーズ ルータは、リモート管理に ISDN S/T ポートを使用できます。図 4-2 および図 4-3 は、リモート管理アクセスおよびプライマリ WAN 回線のバックアップに使用する 2 つの一般的なネットワーク構成を示しています。図 4-2 の場合、ダイヤル バックアップ リンクは Customer Premises Equipment(CPE; 加入者宅内機器)のスプリッタ、Digital Subscriber Line Access Multiplexer(DSLAM; デジタル加入者線アクセス マルチプレクサ)、および Central Office(CO; セントラル オフィス)のスプリッタを経由して ISDN 交換機に接続されます。図 4-3 では、ダイヤル バックアップ リンクは、ルータから ISDN 交換機に直接接続されます。

図 4-2 CPE スプリッタ、DSLAM、および CO スプリッタを経由したデータ ライン バックアップ

 

 

1

Cisco 880 シリーズ ルータ

A

プライマリ DSL インターフェイス、FE インターフェイス(Cisco 881 ルータ)

2

DSLAM

B

ISDN インターフェイス(ISDN S/T ポート)を介したダイヤル バックアップおよびリモート管理(プライマリ回線がダウンした場合にフェールオーバー リンクとして機能)

3

ATM アグリゲータ

4

ISDN 交換機

5

ISDN

C

プライマリ DSL リンクがダウンした場合の、ISDN インターフェイスを介した管理者によるリモート管理機能(Cisco IOS 設定の変更または更新が可能なダイヤルイン アクセスとして機能)

6

ISDN ピア ルータ

7

Web サーバ

8

管理者

--

--

図 4-3 ルータから ISDN 交換機に直接接続されたデータ ライン バックアップ

 

 

1

PC

A

プライマリ DSL インターフェイス

2

Cisco 880 シリーズ ISR

B

ISDN インターフェイス(ISDN S/T ポート)を介したダイヤル バックアップおよびリモート管理(プライマリ回線がダウンした場合にフェールオーバー リンクとして機能)

3

DSLAM

4

アグリゲータ

5

ISDN 交換機

C

プライマリ DSL リンクがダウンした場合の、ISDN インターフェイスを介した管理者によるリモート管理機能(Cisco IOS 設定の変更または更新が可能なダイヤルイン アクセスとして機能)

6

Web サーバ

7

管理者

ルータの ISDN S/T ポートを介したダイヤル バックアップおよびリモート管理を設定するには、次の作業を行います。

ISDN の設定

アグリゲータおよび ISDN ピア ルータの設定

ISDN の設定


) バックアップ インターフェイスおよびフローティング スタティック ルート方式を使用してバックアップ ISDN 回線を起動するには、対象トラフィックが存在していなければなりません。ダイヤラ ウォッチを使用してバックアップ ISDN 回線を起動する場合は、対象トラフィックが存在しなくても構いません。


ルータの ISDN インターフェイスをバックアップ インターフェイスとして設定するには、グローバル コンフィギュレーション モードから、次の作業を行います。

 

コマンド
目的

ステップ 1

isdn switch-type switch-type

例:

Router(config)# isdn switch-type basic-net3
Router(config)#
 

ISDN スイッチ タイプを指定します。

この例では、オーストラリア、欧州、および英国で使用されているスイッチ タイプを指定します。サポートされている他のスイッチ タイプの詳細については、『 Cisco IOS Dial Technologies Command Reference 』を参照してください。

ステップ 2

interface type number

例:

Router(config)# interface bri 0
Router(config-if)#
 

ISDN Basic Rate Interface(BRI; 基本速度インターフェイス)のコンフィギュレーション モードを開始します。

ステップ 3

encapsulation encapsulation-type

例:

Router(config-if)#encapsulation ppp
Router(config-if)#
 

BRI0 インターフェイスの暗号化タイプを設定します。

ステップ 4

dialer pool-member number

例:

Router(config-if)# dialer pool-member 1
Router(config-if)#
 

ダイヤラ プール メンバーシップを指定します。

ステップ 5

isdn switch-type switch-type

例:

Router(config-if)# isdn switch-type basic-net3
Router(config-if)#
 

ISDN スイッチ タイプを指定します。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

ステップ 7

interface dialer dialer-rotary-group-number

例:

Router(config)# interface dialer 0
Router(config-if)#
 

ダイヤラ インターフェイス(0 ~ 255 の番号を指定)を作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

ip address negotiated

例:

Router(config-if)# ip address negotiated
Router(config-if)#
 

PPP/IPCP(インターネット プロトコル コントロール プロトコル)アドレス ネゴシエーションを使用してインターフェイスの IP アドレスを取得するように設定します。IP アドレスはピアから取得されます。

ステップ 9

encapsulation encapsulation-type

例:

Router(config-if)# encapsulation ppp
Router(config-if)#
 

インターフェイスのカプセル化タイプを PPP に設定します。

ステップ 10

dialer pool number

例:

Router(config-if)# dialer pool 1
Router(config-if)#
 

使用するダイヤラ プールを指定します。

この例の場合、BRI0 のダイヤラ プールメンバーの値が 1 であるため、dialer pool 1 の設定によって、ダイヤラ 0 インターフェイスと BRI0 インターフェイスが関連付けられます。

ステップ 11

dialer string dial-string# [ : isdn-subaddress ]

例:

Router(config-if)# dialer string 384040
Router(config-if)#
 

ダイヤルする電話番号を指定します。

ステップ 12

dialer-group group-number

例:

Router(config-if)# dialer group 1
Router(config-if)#
 

ダイヤラ インターフェイスをダイヤラ グループ(1 ~ 10)に割り当てます。

ステップ 13

exit

例:

Router(config-if)# exit
Router(config)#
 

ダイヤラ 0 のインターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに切り替えます。

ステップ 14

dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

例:

Router(config)# dialer-list 1 protocol ip permit
Router(config)#
 

特定のインターフェイス ダイヤラ グループを介して転送される対象パケットについて、ダイヤラ リストを作成します。

この例の場合、ダイヤラ リスト 1 はダイヤラ グループ 1 に対応します。

このコマンドの詳細および設定可能なその他のパラメータについては、『 Cisco IOS Dial Technologies Command Reference 』を参照してください。

アグリゲータおよび ISDN ピア ルータの設定

通常、アグリゲータはシスコ ルータの ATM PVC が終端するコンセントレータ ルータです。次の設定例では、アグリゲータは、PPPoE サーバとして設定されます。

ISDN ピア ルータは、ISDN インターフェイスを備え、パブリック ISDN ネットワークを介して通信し、シスコ ルータの ISDN インターフェイスに到達することができる任意のルータです。ISDN ピア ルータを使用すると、ATM ネットワークのダウンタイム時に、シスコ ルータからインターネットにアクセスすることができます。

 
! This portion of the example configures the aggregator.
vpdn enable
no vpdn logging
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
!
interface Ethernet3
description “4700ref-1”
ip address 40.1.1.1 255.255.255.0
media-type 10BaseT
!
interface Ethernet4
ip address 30.1.1.1 255.255.255.0
media-type 10BaseT
!
interface Virtual-Template1
ip address 22.0.0.2 255.255.255.0
ip mtu 1492
peer default ip address pool adsl
!
interface ATM0
no ip address
pvc 1/40
encapsulation aal5snap
protocol pppoe
!
no atm limi-keepalive
!
ip local pool adsl 22.0.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 22.0.0.1 50
ip route 0.0.0.0 0.0.0.0 30.1.1.2.80
 
! This portion of the example configures the ISDN peer.
isdn switch-type basic-net3
!
interface Ethernet0
ip address 30.1.1.2 255.0.0.0
!
interface BRI0
description “to 836-dialbackup”
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer0
ip address 192.168.2.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 384020
dialer-group 1
peer default ip address pool isdn
!
ip local pool isdn 192.168.2.1
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 40.0.0.0 255.0.0.0 30.1.1.1
!
dialer-list 1 protocol ip permit
!