Cisco 800 シリーズ ソフトウェア コンフィギュレーション ガイド
高度なルータ設定
高度なルータ設定
発行日;2012/01/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

高度なルータ設定

PPP over Ethernetサポートの設定

PPPoEクライアント サポートの設定

設定例

PPPoEのTCP最大セグメント サイズの設定

設定例

LLQおよびLFIの設定

LLQの設定

LFIの設定

LLQをサポートするCBTSの設定

CBTSのLLQ設定

設定例

PVC伝送リングの長さの設定

設定例

DHCPサーバ インポートの設定

設定例

IPCPサブネット マスク配信の設定

設定例

SAエージェントの設定

SSHの設定

IP名前つきアクセス リストの設定

国際電話サポートの設定

設定例

国際トーン、ケーデンス、リング周波数、およびインピーダンスのサポート

地域アナログ音声トーンの設定

FXS音調(Ring Cadence)の設定

FXS音声ポート リング周波数の設定

終端インピーダンスの設定

国際発信者IDサポート

発信者IDのFXSポートの設定

発信者ID通知の設定

発信者ID表示ブロッキング機能の設定

CARの設定

設定例

NATによるVPN IPSecサポートの設定

NATデフォルト内部サーバ拡張機能

設定例

VoAAL2 ATM Forum Profile 9サポートの設定

ATM Forum Profile 9の設定

設定例

ATM OAM F5 CCサポートの設定

PVC上でのCCの設定

設定例

CCの起動および停止要求頻度の設定

設定例

VC上でのCCサポートのディセーブル化

設定例

CCのデバッギングの設定

エンドツーエンドF5 OAMループバック セル生成の設定

出力例

RADIUSサポートの設定

Cisco Easy VPN Clientの設定

設定例

PPPoEクライアント用DDRの設定

PPPoEクライアント用DDRの設定

WFQの設定

WFQの設定

設定例

DSLコマンドの設定

設定例

DSLトレーニング ログのイネーブル化

DSLトレーニング ログを検索した後で、トレーニング ログの追加検索をディセーブル化

セカンダリDSLファームウェアの選択

出力例

設定例

DNSベースのX.25ルーティングの設定

X.25ロードバランシングの設定

X.25 CUGの設定

FTPクライアントの設定

認証プロキシの設定

PAMの設定

CBAC監査証跡と警告の設定

高度なルータ設定

ここでは、Cisco 800シリーズおよびCisco SOHOシリーズ ルータの高度な設定手順について説明します。


) 必ずしも記載されているすべての機能がすべてのルータ モデルでサポートされているというわけではありません。機能制限は、できる限り表示してあります。


ネットワークの構成例を使用してネットワークを構築したい場合は、 第4章「ネットワーク シナリオ」 を参照してください。基本的なルータ設定については、 第7章「ルータ機能の設定」 を参照してください。

この章の内容は次のとおりです。

「PPP over Ethernetサポートの設定」

「PPPoEのTCP最大セグメント サイズの設定」

「LLQおよびLFIの設定」

「LFIの設定」

「LLQをサポートするCBTSの設定」

「PVC伝送リングの長さの設定」

「DHCPサーバ インポートの設定」

「IPCPサブネット マスク配信の設定」

「SAエージェントの設定」

「SSHの設定」

「IP名前つきアクセス リストの設定」

「国際電話サポートの設定」

「CARの設定」

「NATによるVPN IPSecサポートの設定」

「NATデフォルト内部サーバ拡張機能」

「VoAAL2 ATM Forum Profile 9サポートの設定」

「ATM OAM F5 CCサポートの設定」

「RADIUSサポートの設定」

「Cisco Easy VPN Clientの設定」

「PPPoEクライアント用DDRの設定」

「WFQの設定」

「DSLコマンドの設定」

「FTPクライアントの設定」

「認証プロキシの設定」

「PAMの設定」

「CBAC監査証跡と警告の設定」

どのセクションにも、該当するものがある場合には設定例と確認手順が載っています。

すべてのCisco 800シリーズおよびCisco SOHOシリーズ ルータ モデルでサポートされる機能もあります。ルータ モデル機能制限および要件も、この章の該当する各セクションに表示します。

PPP over Ethernetサポートの設定

次のセクションでは、PPP over Ethernet(PPPoE)のサポートを設定する方法を説明します。

PPPoEクライアント サポートの設定

PPPoEのTCP最大セグメント サイズの設定

PPPoEクライアント サポートの設定

PPPoEは、次のシスコ ルータでサポートされます。

Cisco 806および831

Cisco 826および836

Cisco 827、827H、827-4V、および837

Cisco SOHO 77、SOHO 77H、SOHO 78、SOHO 96、およびSOHO 97

Cisco 828

PPPoEクライアントは、Asynchronous Transfer Mode(ATM;非同期転送モード)Permanent Virtual Circuit(PVC;相手先固定接続)でサポートされます。1つのATM PVCでは、1つのPPPoEクライアントだけがサポートされます。

PPPoEクライアント サポート用ルータの設定を行うには、次の作業を行います。


ステップ 1 Virtual Private Dialup Network(VPDN;仮想プライベート ダイヤルアップ ネットワーク)グループ番号を設定します。

a. グローバル コンフィギュレーション モードで vpdn enable コマンドを入力します。

b. vpdn group tagコマンドを入力してVPDNグループを設定します。

c. VPDNグループで request-dialin コマンドを入力して、ダイヤリング方向を指定します。

d. protocol pppoe コマンドを入力して、VPDNグループ内のプロトコルの種類を指定します。

ステップ 2 PPPoEサポートでATMインターフェイスを設定します。

a. interface atm 0 コマンドを入力して、ATMインターフェイスを設定します。

b. pvc numberコマンドを入力してATM PVCを指定します。

c. PPPoEクライアントを設定し、 pppoe-client dial-pool-number number コマンドを入力してクローニングに使用するダイヤラ インターフェイスを指定します。

ステップ 3 int dialer numberコマンドを入力して、ダイヤラ インターフェイスを設定します。

a. ip address negotiated コマンドを入力して、IPアドレスをネゴシエートに設定します。

b. (任意) ppp authentication protocol コマンドを入力して、ネットワークの認証を設定します。

c. dialer pool numberコマンドを入力して、ダイヤラ プール番号を設定します。

d. dialer-group numberコマンドを入力して、ダイヤラ グループ番号を設定します。

e. dialer-list 1 protocol ip permit コマンド を入力してダイヤラ グループに対応するダイヤラ リストを設定します。


 


) 複数PPPoEクライアントは、異なったPVCで稼働することができます。この場合、各クライアントは別のダイヤラ インターフェイスおよび別のダイヤラ プールを使用し、ダイヤラ インターフェイスでPPP(ポイントツーポイント プロトコル)パラメータを適用する必要があります。


PPPoEセッションは、ネットワークによりクライアント側で起動されます。セッションにタイムアウトが発生したり、切断されたりした場合は、PPPoEクライアントはただちにセッションを再確立しようとします。

すでに確立されているPPPoEクライアント セッションでclear vpdn tunnel pppoeコマンドを入力した場合、PPPoEクライアント セッションは停止し、PPPoEクライアントはただちにセッションを再確立しようとします。

設定例

次に、PPPoEクライアントの設定例を示します。

vpdn enable
vpdn-group 1
request-dialin
protocol pppoe
 
int atm0
 
pvc 1/100
pppoe-client dial-pool-number 1
 
int dialer 1
ip address negotiated
ppp authentication chap
dialer pool 1
dialer-group 1
 

PPPoEのTCP最大セグメント サイズの設定

PPPoEのTCP最大セグメント サイズを設定する機能は、次のシスコ ルータでサポートされます。

Cisco 806および831

Cisco 826および836

Cisco 827、827H、827-4V、および837

Cisco SOHO 77、SOHO 77H、SOHO 78、SOHO 96、およびSOHO 97

Cisco 828

シスコ ルータがPPPoEトラフィックを終端する場合、イーサネット インターフェイスに接続されているコンピュータは、Webサイトへのアクセスに問題があるかもしれません。これを解決するには、TCP Maximum Segment Size(MSS;最大セグメント サイズ)を抑制することにより、コンピュータ上に設定されているMaximum Transmission Unit(MTU;最大伝送ユニット)を手動で削減する必要があります。ルータのEthernet 0インターフェイスで次のコマンドを入力します。

ip tcp adjust-mss mss
 

ここで、 mss は1452以下です。

ip tcp adjust-mss コマンドが機能するようNetwork Address Translation(NAT;ネットワーク アドレス変換)を設定する必要があります。

設定例

次に、PPPoEクライアントの設定例を示します。

vpdn enable
no vpdn logging
!
vpdn-group 1
request-dialin
protocol pppoe
!
interface Ethernet0
ip address 192.168.100.1 255.255.255.0
ip tcp adjust-mss 1452
ip nat inside
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username sohodyn password 7 141B1309000528
!
ip nat inside source list 101 interface Dialer1 overload
ip route 0.0.0.0.0.0.0.0 Dialer1
access-list 101 permit ip 192.168.100.0.0.0.0.255 any
 

LLQおよびLFIの設定

Low Latency Queuing(LLQ;低遅延キューイング)は、Voice over IP(VoIP)トラフィックの低遅延で厳密なプライオリティの送信キューを提供します。

LLQは、次のCiscoルータでサポートされます。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837

Cisco 828

Link Fragmentation and Interleaving(LFI;リンク フラグメンテーションおよびインターリーブ)は、大きなデータ パケットを分割し、音声パケットをデータ フラグメントの中にインターリーブすることにより音声トラフィックの遅延およびジッタを低減します。

LLQの設定

ルータにLLQを設定するには次の作業を行います。


ステップ 1 ルータが音声パケットとデータ パケットを区別できるよう、音声パケットとデータ パケットのIP precedence値が異なっていることを確認します。通常、データ パケットの優先順位は0で、音声パケットの優先順位は5です。VoIPパケットがルータ内で生成されている場合は、次のようにダイヤル ピア音声コンフィギュレーション モードで ip precedence number コマンドを入力することにより、これらのパケットのIP precedenceを5に設定することができます。

a. グローバル コンフィギュレーション dial-peer voice 1 voip コマンドを入力します。

b. ip precedence 5 コマンドを入力します。

ステップ 2 アクセス リストおよび音声パケット用クラス マップを作成します。

a. access-list 101 permit ip any any precedence 5 コマンドを入力して、アクセス リストを作成します。

b. class-map match-all voice コマンドを入力して音声パケットのクラス マップを作成します。

c. match access-group 101 コマンドを入力してクラス マップをアクセス リストにリンクします。

ステップ 3 音声トラフィック用LLQを作成します。

a. policy-map mypolicy コマンドを入力してポリシー マップを作成します。

b. class voice コマンドを入力してクラスを定義します。

c. プライオリティ帯域幅を音声トラフィックに割り当てます。音声トラフィックに割り当てられたプライオリティ帯域幅は、使用されるコーデックおよび許可する同時コールの数によって異なります。たとえば、G.711コーデック コールは200 kbpsを消費します。したがって、1つのG.711音声コールをサポートするには、 priority 200 コマンドを入力します。

ステップ 4 LLQをダイヤラ インターフェイスに添付します。

a. グローバル コンフィギュレーション interface dialer 1 コマンドを入力します

b. service-policy out mypolicy コマンドを入力してサービス ポリシーを作成します。


 

LFIの設定

ルータにLFIを設定するには次の作業を行います。


) LFIを設定する場合、データ フラグメント サイズは、音声パケット サイズよりも大きくする必要があります。そうでないと、音声パケットが分割され、音声品質は劣化します。



ステップ 1 ダイヤラ帯域幅を設定します。ダイヤラ インターフェイスのデフォルト帯域幅は56 kbpsですが、これはお使いのDigital Subscriber Line(DSL;デジタル加入者線)接続の上り帯域幅より小さいかもしれません。DSL接続の上り帯域幅を調べるには、ダイヤラ インターフェイス コンフィギュレーション モードで show dsl interface atm0 コマンドを入力します。同じDSL接続を共有するPVCが複数ある場合は、ダイヤラ インターフェイスに設定される帯域幅は、割り当てられたPVCの帯域幅と同じである必要があります。

ステップ 2 PPPマルチリンクをイネーブルにして、ダイヤラ インターフェイスのフラグメント遅延およびインターリーブを設定します。

a. グローバル コンフィギュレーション interface dialer 1 コマンドを入力します。

b. bandwidth 640 コマンドを入力してダイヤラ帯域幅を指定します。帯域幅は、kbps(キロビット/秒)で指定します。

c. ppp multilink コマンドを入力します。

d. ppp multilink interleave コマンドを入力してPPPマルチリンク インターリーブを指定します。

e. ppp multilink fragment-delay 10 コマンドを入力して、フラグメント遅延を定義します。

f. 次の公式でフラグメント サイズを計算します。

フラグメント サイズ=(kbps単位の帯域幅/8)* ミリ秒(ms)単位のフラグメント遅延

この場合、フラグメント サイズ=(640/8)* 10でフラグメント サイズは800となります。フラグメント サイズは、G.711、20msの最大音声パケット サイズである200より大きくなります。低フラグメント遅延は、フラグメント サイズに対応しますが、音声パケット サイズよりも小さい場合があるため、音声品質が低下することに注意してください。


 

LLQをサポートするCBTSの設定

Class-Based Traffic Shaping(CBTS;クラスベース トラフィック シェーピング)は、次のシスコ ルータでサポートされます。

Cisco 806

Cisco 831

CBTSを使用することにより、WANインターフェイス トラフィック伝送速度を制御して、接続されているブロードバンド モデムまたはリモート ターゲット インターフェイスの速度に一致させることができます。CBTSにより、トラフィックは設定されたポリシーに確実に適合するようになり、データ レートのミスマッチによるトポロジーのボトルネックが解消されます。

shape average kbpsおよびshape peak kbpsコマンドにより、インターフェイスのトラフィック シェーピングが定義できるようになります。


) CBTSは、Ethernet 1インターフェイスでサポートされます。


CBTSのLLQ設定

CBTSを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。この手順は、複数のトラフィック クラスを作成し、これをポリシー マップと対応づけ、次にポシリー マップをルータ インターフェイスと対応づける方法を示すものです。


ステップ 1 トラフィック分類を定義します。

a. class-map map-nameコマンドを入力して、トラフィック分類を定義します。たとえば、voiceという名前を用いて、これが音声トラフィックのクラス マップであることを指定できます。

b. クラス コンフィギュレーション モードで、 match ip precedence 5コマンドを入力し、すべてのIP音声トラフィックを優先順位5に対応づけます。Cisco Architecture for Voice, Video and Integrated Data(AVVID)資料では、VoIPトラフィックについて優先順位値5が指定されています。

c. exitを入力して、クラス コンフィギュレーション モードを終了します。

ステップ 2 LLQのポリシー マップおよび対応するクラスを定義します。

a. グローバル コンフィギュレーション モードでpolicy-map map-name コマンドを入力してポリシーを構築し、異なったネットワーク リソースを定義済みトラフィック クラスに割り当てます。LLQという名前を使用して、これがLLQのポリシー マップであることを指定できます。

b. 次に、ポリシー マップ モードで、ステップ 1のclass-mapコマンドで定義したクラス マップ名を使用してclass QOS-class-nameを入力することにより、音声トラフィックを処理するクラスを定義します。このコマンドによって、ルータはQOSクラス コンフィギュレーション モードになります。

c. priority numberを入力します。ここで、numberは帯域幅(kbps)です。設定例に示す300の値は、2つのG.711音声ポートに十分な帯域幅を提供します。プライオリティ値を設定する前に、音声コールに使用されるCODECの仕様を参照してください。

d. exitを入力して、ポリシー マップ コンフィギュレーション モードに戻ります。

e. class class-default を入力して、音声トラフィック以外のすべてのトラフィックはデフォルト クラスを使用するようにします。class-defaultという名前は既知のものなので、class-mapコマンドで事前に定義する必要はありません。

f. fair-queueコマンドを入力して、Weighted Fair Queing(WFQ;均等化キューイング)を非音声トラフィックに適用します。

g. exitを2回入力して、グローバル コンフィギュレーション モードに戻ります。

ステップ 3 トラフィック シェーピング ポリシー マップを定義します。

a. グローバル コンフィギュレーション モードでpolicy-map map-name を入力します。shapeという名前を用いて、このマップがリモート送信速度帯域幅と互換性のあるトラフィック シェーピング全体を定義していることを示します。

b. class class-default を入力して、デフォルト クラスをこのポリシー マップに対応づけます。

c. shape average kbpsコマンドを入力して、トラフィック シェーピングの後で使用する伝送速度をブロードバンド モデムまたはリモート インターフェイスの速度と一致するよう設定します。ここで、kbpsは、キロビット/秒の値です。


注意 入力した伝送速度は、ルータが接続するDSLまたはケーブル モデムのTX帯域幅以下である必要があります。モデムのTX帯域幅を超える値を指定すると、モデムは輻輳し、QOSを適用する利点が失われます。

d. service-policy nameを入力して、LLQポリシー マップをトラフィック シェーピング ポリシー マップと対応づけます。低遅延キューのマップ名がLLQである場合、nameはLLQです。

e. exitを2回入力して、グローバル コンフィギュレーション モードに戻ります。

ステップ 4 これらのポリシーをEthernet 1インターフェイスに適用します。

a. interface Ethernet 1コマンドを入力します。

b. service-policy output nameを入力して、サービス ポリシーをEthernet 1インターフェイスに適用します。ここで、nameはトラフィック シェーピング ポリシー マップで定義されたポリシーに一致します。トラフィック シェーピング ポリシー マップ名がshapeである場合、サービス ポリシー名もshapeとなります。

ステップ 5 exitを入力して、ルータ コンフィギュレーション モードを終了します。


 

設定例

次に、音声ライン品質を保証しながら、制限された帯域幅でCisco 806ルータをブロードバンド モデムに接続するよう設定する例を示します。2つのポリシー マップが設定されます。

ポリシー マップLLQ

ポリシー マップshape

ポリシー マップLLQにより、音声トラフィックは最大300 kbpsの帯域幅の厳密なプライオリティ キューを持つようになります。ポリシー マップ シェープは、全体のスループットを2.2 Mbpsに制限します。

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password encryption
!
hostname 806-uut
!
ip subnet-zero
!
class-map match-all voice
match ip precedence 5
!
!
policy-map LLQ
class voice
priority 300
class class-default
fair-queue
policy-map shape
class class-default
shape average 2250000
service-policy LLQ
!
interface Ethernet0
ip address 1.7.65.11 255.255.0.0
!
interface Ethernet1
ip address 192.168.1.101 255.255.255.0
service-policy output shape
!
ip classless
ip http server
ip pim bidir-enable
!
line con 0
stopbits 1
line vty 0 4
login
!
!
scheduler max-task-time 5000
end
!
 

PVC伝送リングの長さの設定

PVC伝送リングの長さは、次のシスコ ルータで設定することができます。

Cisco 826および836

Cisco 827、827H、827-4V、および837

Cisco SOHO 77、SOHO 77H、SOHO 78、SOHO 96、およびSOHO 97

Cisco 828

音声パケットとデータ パケットの両方が同じPVCを共有している場合、PVC伝送(TX)リング サイズを削減することが大切です。こうすることにより、ハードウェア キューで音声パケットの前に置くことのできるデータ パケットとフラグメントの最大数が削減され、遅延が軽減されます。

PVC TXリング サイズを削減するには、次の作業を行います。


ステップ 1 グローバル コンフィギュレーション int atm 0 コマンドを入力します。

ステップ 2 pvc 1/100 コマンドを入力してPVC番号を指定します。

ステップ 3 tx-ring-limit 3 コマンドを入力して、PVC TXリング サイズを3に減らします。


 

設定例

次に、LFI、 LLQおよびPVC TXリング設定の組み合わせ例を示します。

class-map match-all voice
match access-group 101
!
policy-map mypolicy
class voice
priority 200
class class-default
fair-queue
!
interface Ethernet0
ip address 70.0.0.1 255.255.255.0
no ip mroute-cache
!
interface ATM0
no ip address
bundle-enable
dsl operating-mode auto
!
interface ATM0.1 point-to-point
no ip mroute-cache
pvc 1/40
encapsulation aal5mux ppp dialer
dialer pool-member 1
tx-ring-limit 3
!
interface Dialer1
bandwidth 640
ip address 60.0.0.1 255.255.255.0
encapsulation ppp
dialer pool 1
service-policy output mypolicy
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
!
ip classless
no ip http server
!
access-list 101 permit ip any any precedence 5
!
voice-port 1
!
voice-port 2
!
voice-port 3
!
voice-port 4
dial-peer voice 110 pots
destination-pattern 1105555
port 1
!
dial-peer voice 210 voip
destination-pattern 2105555
session target ipv4:60.0.0.2
codec g711ulaw
ip precedence 5
 

DHCPサーバ インポートの設定

Cisco IOS DHCPサーバは改良され、PPPによりコンフィギュレーション情報が自動的に更新されるようになっています。PPPをイネーブルにして自動的にDomain Name System(DNS;ドメイン ネーム システム)、Microsoft Windows Nameserver(WINS;Windowsネーム サーバ)、またはNetBIOS Name Service(NBNS; NetBIOSネーム サービス)およびCisco IOS DHCPサーバ プール内のIPアドレス情報を自動的に設定することができます。

この機能は、次のシスコ ルータでサポートされます。

Cisco 806および831

Cisco 826および836

Cisco 827、827H、827-4V、および837

Cisco SOHO 77、SOHO 77H、SOHO 78、SOHO 91、SOHO 96、およびSOHO 97

Cisco 828

DHCPサーバ インポート用にシスコ ルータを設定するには、次の作業を行います。


ステップ 1 ATMインターフェイスおよびADSLオペレーティング モードを設定します。

ステップ 2 データ トラフィック用ATM PVCを作成し、Virtual Circuit(VC;仮想回線)コンフィギュレーション モードを開始し、Virtual Path Identifier(VPI;仮想パス識別子)/Virtual Channel Identifier(VCI;仮想チャネル識別子)、カプセル化タイプ、およびダイヤル プール メンバーを指定します。

ステップ 3 ダイヤラ インターフェイスを作成します。

a. ダイヤラ インターフェイスのコンフィギュレーション モードを開始します。

b. MTUサイズを1492に指定します。

c. ip address negotiated をダイヤラ インターフェイスに割り当てます。

d. ダイヤラ グループ番号を設定します。

e. PPPカプセル化および(必要な場合は)Challenge Handshake Authentication Protocol(CHAP)を設定します。

f. DNSおよびWINS要求のIPネゴシエーションを設定します。

ステップ 4 IP DHCPプール名を定義します。

a. DHCPプールのネットワークおよび(必要な場合には)ドメイン名を設定します。

b. import all コマンドを入力します。

ステップ 5 ダイヤラ インターフェイスのダイヤラ リストおよびスタティック ルートを設定します。


 

設定例

次に、Cisco 800シリーズおよびCisco SOHOシリーズ ルータでのDHCPサーバ インポートの設定例を示します。

router-820#show run
Building configuration...
Current configuration :1510 bytes
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router-820
logging rate-limit console 10 except errors
!
username 3620-4 password 0 lab
mmi polling-interval 60
mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip dhcp excluded-address 192.150.2.100
ip dhcp pool 2
import all
network 192.150.2.0 255.255.255.0
domain-name devtest.com
default-router 192.150.2.100
lease 0 0 3
!
no ip dhcp-client network-discovery
vpdn enable
no vpdn logging
vpdn-group 1
request-dialin
protocol pppoe
 
call rsvp-sync
!
interface Ethernet0
ip address 192.150.2.100 255.255.255.0
ip nat inside
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/16 ilmi
!
pvc 1/40
protocol pppoe
pppoe-client dial-pool-number 1
!
bundle-enable
dsl operating-mode auto
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
ppp ipcp dns request
ppp ipcp wins request
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
ip nat inside source list 101 interface Dialer0 overload
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
snmp-server manager
!
voice-port 1
voice-port 2
voice-port 3
voice-port 4
!
line con 0
transport input none
stopbits 1
line vty 0 4
scheduler max-task-time 5000
end
 

次に、Cisco 800シリーズおよびCisco SOHOシリーズ ルータでのDHCPプロキシ クライアントの設定例を示します。

3620-4#show run
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3620-4
logging rate-limit console 10 except errors
!
username 820-uut1 password 0 lab
username 820-uut4 password 0 lab
memory-size iomem 10
ip subnet-zero
!
no ip finger
!
ip address-pool dhcp-proxy-client
ip dhcp-server 192.150.1.101
vpdn enable
no vpdn logging
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
!
call rsvp-sync
cns event-service server
!
interface Ethernet0/0
ip address 192.150.1.100 255.255.255.0
half-duplex
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
interface ATM1/0
no ip address
no atm scrambling cell-payload
no atm ilmi-keepalive
pvc 1/40
encapsulation aal5snap
protocol pppoe
!
interface Virtual-Template1
ip address 2.2.2.1 255.255.255.0
ip mtu 1492
peer default ip address dhcp
ppp authentication chap
!
ip kerberos source-interface any
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit
dial-peer cor custom
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
end
 

次に、Cisco 800シリーズおよびCisco SOHOシリーズ ルータでのリモートDHCPサーバの設定例を示します。

2500ref-4#show run
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname 2500ref-4
!
no logging console
!
ip subnet-zero
no ip domain-lookup
ip host PAGENT-SECURITY-V3 45.41.44.82 13.15.0.0
ip dhcp excluded-address 2.2.2.1
!
ip dhcp pool 1
network 2.2.2.0 255.255.255.0
dns-server 53.26.25.23
netbios-name-server 66.22.66.22
domain-name ribu.com
lease 0 0 5
!
cns event-service server
!
interface Ethernet0
ip address 192.150.1.101 255.255.255.0
interface Ethernet1
ip address 192.168.254.165 255.255.255.0
interface Serial0
no ip address
shutdown
no fair-queue
interface Serial1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 1.1.1.1
ip route 0.0.0.0 0.0.0.0 Ethernet0
no ip http server
!
dialer-list 1 protocol ip permit
line con 0
exec-timeout 0 0
transport input none
line aux 0
transport input all
line vty 0 4
login
no scheduler max-task-time
end

IPCPサブネット マスク配信の設定

IP Control Protocol(IPCP)サブネット マスク配信機能は、次のシスコ ルータでサポートされます。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837

Cisco SOHO 77、SOHO 77H、SOHO 78、SOHO 91、SOHO 96、およびSOHO 97

Cisco 828

IPCP機能は、IPアドレス プールをCPE(顧客宅内機器)デバイスに割り当てます。これらのデバイスは、IPアドレスをCPEおよびDHCPプールに割り当てます。

IPCPは、次の機能を提供します。

Cisco IOS CPEデバイスがサブネットを要求し、使用します。

Authentication, Authorization, Accounting(AAA;認証、許可、アカウンティング)Remote Authentication Dial-In User Service(RADIUS)は、サブネットを提供し、フレームド ルートを適切なVirtual Route Forwarding(VRF;仮想ルート転送)テーブルに挿入します。

Provider Edge(PE;プロバイダー エッジ)またはエッジ ルータは、IPCPを通してサブネットを提供します。

CPEは、PPPセットアップ ネゴシエーション中にIPアドレスおよびサブネット マスクの両方を受信することができるため、DHCPは、クライアント側ではもうサポートされません。CPEがDHCPサーバを使用して、そのネットワークにアドレスを割り当てる場合、サブネットはNetwork Access Server(NAS)上のNode Route Processor(NRP;ノード ルート プロセッサ)を通して割り当て、リモートCPE DHCPサーバに配信することができます。

CPEにIPCPを設定するには次の作業を行います。


ステップ 1 ATMインターフェイスを設定し、ADSLオペレーティング モードを開始します。

ステップ 2 ATMサブインターフェイスを設定します。

a. データ トラフィック用ATM PVCを作成し、VCコンフィギュレーション モードを開始し、VPIおよびVCI値を指定します。

b. PVCのカプセル化を aal5mux ppp に設定し、データ トラフィックをサポートします。

ステップ 3 ダイヤラ インターフェイスを作成します。

a. ダイヤラ インターフェイスのコンフィギュレーション モードを開始します。

b. PVCのPPPカプセル化タイプを指定します。

c. ip unnumbered Ethernet 0 コマンドを入力して、イーサネット インターフェイスをダイヤラ インターフェイスに割り当てます。

d. ダイヤラ グループ番号を設定します。

e. CHAPを設定します。

f. ppp ipcp mask request コマンドを入力します。

g. ダイヤラ リストをこのダイヤラ インターフェイスに割り当てます。

ステップ 4 IP DHCPプール名を定義します。

a. import all コマンドを入力します。

b. origin ipcp コマンドを入力します。

ステップ 5 イーサネット インターフェイスを設定し、IPアドレス プールを割り当てます。ステップ4で定義したプール名を入力します。

ステップ 6 ダイヤラ インターフェイスのダイヤラ リストおよびスタティック ルートを設定します。


 

設定例

次に、Cisco 827-4VルータでのIPCP設定例を示します。

router-8274v-1# show run
Building configuration...
Current configuration :1247 bytes
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname router-8274v-1
!
no logging buffered
logging rate-limit console 10 except errors
!
username 6400-nrp2 password 0 lab
ip subnet-zero
ip dhcp smart-relay
!
ip dhcp pool IPPOOLTEST
import all
origin ipcp
lease 0 0 1
!
no ip dhcp-client network-discovery
!
interface Ethernet0
ip address pool IPPOOLTEST
no shutdown
hold-queue 32 in
!
interface ATM0
no ip address
atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0.1 point-to-point
pvc 1/40
no ilmi manage
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
interface Dialer0
ip unnumbered Ethernet0
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname router-8274v-1
ppp chap password 7 12150415
ppp ipcp accept-address
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
stopbits 1
line vty 0 4
login
!
scheduler max-task-time 5000
end
 

次に、Cisco 827-4Vルータのリモート サーバ上でのIPCP設定例を示します。

6400-nrp2#show run
Building configuration...
 
Current configuration :1654 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 6400-nrp2
!
aaa new-model
aaa authentication ppp default group radius
aaa authorization network default group radius
aaa nas port extended
enable password lab
!
username router-8274v-1 password 0 lab
username TB2-8274v-2 password 0 lab
!
redundancy
main-cpu
auto-sync standard
no secondary console enable
ip subnet-zero
no ip finger
!
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
hold-queue 500 in
!
interface ATM0/0/0.4 point-to-point
pvc 6/40
encapsulation aal5mux ppp Virtual-Template5
!
!interface ATM0/0/0.5 point-to-point
pvc 5/46
protocol ip 7.0.0.60 broadcast
encapsulation aal5mux ppp Virtual-Template6
!
interface Ethernet0/0/1
no ip address
shutdown
!
interface Ethernet0/0/0
description admin IP address 192.168.254.201 255.255.255.0
ip address 192.168.254.240 255.255.255.0
!
interface FastEthernet0/0/0
ip address 192.168.100.101 255.255.255.0
half-duplex
!
interface Virtual-Template5
ip unnumbered FastEthernet0/0/0
no keepalive
no peer default ip address
ppp authentication chap
!
interface Virtual-Template6
ip unnumbered FastEthernet0/0/0
no peer default ip address
ppp authentication chap
!
ip classless
no ip http server
!
ip radius source-interface FastEthernet0/0/0
!
radius-server host 192.168.100.100 auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server attribute nas-port format d
radius-server key foo
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password lab
!
end
 

次に、Cisco 827-4Vルータ(Cisco Access Registrar 1.5)のRADIUSサーバ上でのIPCP設定例を示します。

/opt/AICar1/usrbin-4 % ./aregcmd
Access Registrar Configuration Utility Version 1.5
Copyright (C) 1995-1998 by American Internet Corporation, and 1998-2000 by
Cisco Systems, Inc. All rights reserved.
Cluster:localhost
User:admin
Password:
Logging in to localhost
400 Login failed/opt/AICar1/usrbin-5 % ./aregcmd
Access Registrar Configuration Utility Version 1.5
Copyright (C) 1995-1998 by American Internet Corporation, and 1998-2000 by
Cisco Systems, Inc. All rights reserved.
Cluster:localhost
User:admin
Password:
Logging in to localhost
 
[ //localhost ]
LicenseKey = SBUC-7DQF-PM1E-5HPC (expires in 51 days)
Radius/
Administrators/
 
Server 'Radius' is Running, its health is 10 out of 10
--> cd radius
 
[ //localhost/Radius ]
Name = Radius
Description =
Version = 1.6R1
IncomingScript~ =
OutgoingScript~ =
DefaultAuthenticationService~ = local-users
DefaultAuthorizationService~ = local-users
DefaultAccountingService~ = local-file
DefaultSessionService~ =
DefaultSessionManager~ =
UserLists/
UserGroups/
Policies/
Clients/
Vendors/
Scripts/
Services/
SessionManagers/
ResourceManagers/
Profiles/
Rules/
Translations/
TranslationGroups/
RemoteServers/
Advanced/
Replication/
 
--> cd profile
 
[ //localhost/Radius/Profiles ]
ls
Entries 1 to 6 from 6 total entries
Current filter:<all>
 
default-PPP-users/
default-SLIP-users/
default-Telnet-users/
StaticIP/
router-8274v-1/
TB2-8274v-2/
 
--> ls
 
[ //localhost/Radius/Profiles ]
Entries 1 to 6 from 6 total entries
Current filter:<all>
 
default-PPP-users/
default-SLIP-users/
default-Telnet-users/
StaticIP/
router-8274v-1/
TB2-8274v-2/
 
--> cd router-8274v-1
 
[ //localhost/Radius/Profiles/router-8274v-1 ]
Name = router-8274v-1
Description =
Attributes/
 
--> ls
 
[ //localhost/Radius/Profiles/router-8274v-1 ]
Name = router-8274v-1
Description =
Attributes/
 
--> cd attribute
 
[ //localhost/Radius/Profiles/router-8274v-1/Attributes ]
cisco-avpair = "ip:wins-servers=100.100.100.100 200.200.200.200"
cisco-avpair = "ip:dns-servers=60.60.60.60 70.70.70.70"
Framed-Compression = none
Framed-IP-Address = 40.1.2.30
Framed-IP-Netmask = 255.255.255.0
Framed-MTU = 1500
Framed-Protoc
l = ppp
Framed-Routing = None
Service-Type = Framed

SAエージェントの設定

SAエージェント(サービス保証エージェント)は、次のシスコ ルータで設定することができます。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837

Cisco SOHO 77、SOHO 77H、SOHO 78、SOHO 96、およびSOHO 97

Cisco 828

SAエージェントは、応答時間、アベイラビリティ、ジッタ(パケット間遅延変動)、接続時間、スループット、パケット損失などの主要メトリックを測定することにより、ネットワーク パフォーマンスをモニタする、アプリケーションを意識した統合オペレーション エージェントです。この機能は、Cisco VPN Solution Centerの機能を報告するサービスレベル アグリーメントのサポートを提供することを意図したものですが、トラブルシューティング、問題が発生する前に行う分析、今後のネットワーク トポロジーの設計などに使用することもできます。Response Time Monitoring(RTM;応答時間モニタリング)機能がサポートされます。

このコマンドのコンフィギュレーションについては、Cisco IOS Release 12.0マニュアルを参照してください。

SSHの設定

Secure Shell(SSH;セキュア シェル)は、安全なリモート接続をルータに提供するプロトコルです。SSHは、SSHバージョン1およびSSHバージョン2という2つのバージョンで利用可能です。Cisco IOSソフトウェアで利用できるのは、SSHバージョン1だけです。

SSHは、次のシスコ ルータでサポートされます。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837

Cisco 828

Cisco SOHO 91、SOHO 96、およびSOHO 97

このコマンドのコンフィギュレーションについては、Cisco IOS Release 12.0マニュアルを参照してください。

IP名前つきアクセス リストの設定

IP名前つきアクセス リストは、次のシスコ ルータでサポートされています。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837

Cisco SOHO 77、SOHO 77H、SOHO 78、SOHO 96、およびSOHO 97

Cisco 828

IPアクセス リストは、番号ではなく英数字文字列(名前)で識別することができます。名前つきアクセス リストを使用する場合、ルータにさらに多くのIPアクセス リストを設定することができます。

このコマンドのコンフィギュレーションについては、Cisco IOS Release 12.0マニュアルを参照してください。

国際電話サポートの設定

Cisco 827-4Vルータは、次の国で国際電話サポート(H.323のみ)を提供しています。

イタリア

デンマーク

オーストラリア

国際電話サポート コマンドは、音声ポート設定および発信者ID設定を設定します。

H.323国際電話サポートは、イタリアとデンマークについては、次の装置で動作することがテストされ確認されています。

イタリアでは次の装置がサポートされます。

電話

Siemens Gigaset 3015 Class Model

Telecom Italia MASTER s.p. LUPO VIEW

Alcatel Dial Face Mod.SIRIO 2000 Basic A

発信電話番号識別装置

BRONDI INDOVINO

ファックス装置

Canon FAX-B155

デンマークでは次の装置がサポートされます。

電話

Tele Danmark dana classic

Tele Danmark Danafon Topas

発信電話番号識別装置

DORO Danmark DOROX5

発信者ID、国際ケーデンス、インピーダンス、リング周波数をサポートする音声ポートを設定するには、グローバル コンフィギュレーション モードから開始して次の作業を行います。

 

コマンド
作業

ステップ 1

voice-port number

音声ポート コンフィギュレーション モードを開始します。

ステップ 2

cptone country-code

コールプログレス トーン、音調(Ring Cadence)、回線インピーダンス、リング周波数の設定を指定します。

ステップ 3

caller-id enable

caller-id alerting alerting-method

発信者IDサポートをイネーブルにするか、2番目のコマンドを入力して発信者IDサポートをイネーブルにして通知方法を指定します。

ステップ 4

caller-id block

コールの遠端で発信者ID情報のブロッキングを要求します。

ステップ 5

end

ルータ コンフィギュレーション モードを終了します。

設定例

次に、デンマークのプログレス トーンおよび回線特性用に設定された2つの音声ポートの設定例を示します。発信者IDは両方のポートでイネーブルであり、電話コールがポート1から発呼された場合に、ポート1は、発信者ID情報がもう一方の端でブロックされることを要求します。2番目のポートは、回線反転通知方法を使用します。

!
voice-port 1
cptone dk
caller-id enable
caller-id block
timeouts call-disconnect 0
!
voice-port 2
cptone dk
caller-id alerting line-reversal
timeouts call-disconnect 0
 

国際トーン、ケーデンス、リング周波数、およびインピーダンスのサポート

すべての音声ポートのデフォルト音声ポート設定では、米国の国コード、600 ohmのインピーダンス、25 Hzのリング周波数が指定されます。Cisco IOSソフトウェアは、リング トーン、ケーデンス、周波数、回線インピーダンスのコマンドをサポートしています。

地域アナログ音声トーンの設定

地域アナログ音声インターフェイス関連トーンを指定するにはcptoneコマンドを使用します。選択されたトーンをディセーブルにするには、このコマンドの no 形式を使用します。

cptone { dk | it | au }

no cptone { dk | it | au }

次の表に、各コードの意味を示します。

 

コード
パラメータ

dk

デンマーク

POTS回線タイプ2(複合インピーダンス)、a-law符号化、OSI切断監視、25 Hzリンギング周波数、0ガードタイム

it

イタリア

POTS回線タイプ2(複合インピーダンス)、a-law符号化、OSI切断監視、25 Hzリンギング周波数、0ガードタイム

au

オーストラリア

POTS回線タイプ2(複合インピーダンス)、a-law符号化、OSI切断監視、20 Hzリンギング周波数、0ガードタイム

FXS音調(Ring Cadence)の設定

Foreign Exchange Station(FXS)音声ポートの音調(Ring Cadence)を指定するには、音声ポート コンフィギュレーション モードでring cadenceコマンドを使用します。このコマンドのデフォルト値を復元するには、このコマンドのno形式を使用します。

ring cadence cadence
no ring cadence
 

ring cadenceコマンドは、次の値をとります。

 

意味

define

ユーザ定義ケーデンス

pattern01

2秒オン、4秒オフ

pattern02

1秒オン、4秒オフ

pattern03

1.5秒オン、3.5秒オフ

pattern04

1秒オン、2秒オフ

pattern05

1秒オン、5秒オフ

pattern06

1秒オン、3秒オフ

pattern07

0.8秒オン、3.2秒オフ

pattern08

1.5秒オン、3秒オフ

pattern09

1.2秒オン、3.7秒オフ

pattern10

1.2秒オン、4.7秒オフ

pattern11

0.4秒オン、0.2秒オフ後、
0.4秒オン、2秒オフ

pattern12

0.4秒オン、0.2秒オフ後、
0.4秒オン、2.6秒オフ

FXS音声ポート リング周波数の設定

指定されたFXS音声ポートのリング周波数を指定するには、音声ポート コンフィギュレーション モードでring frequencyコマンドを使用します。このコマンドのデフォルト値を復元するには、このコマンドのno形式を使用します。

ring frequency frequency
no ring frequency
 

リング周波数を選択するには、次のようにコマンドを使用します。

 

25

25 Hzリング周波数を指定します。

50

50 Hzリング周波数を指定します。

終端インピーダンスの設定

音声ポート インターフェイスの終端インピーダンスを指定するには、音声ポート インターフェイス モードでimpedanceコマンドを使用します。デフォルト値を復元するには、このコマンドのno形式を使用します。

impedance {600c | 600r | 900c | 900r | complex1 | complex2 }
no impedance {600c | 600r | 900c | 900r | complex1 | complex2 }
 

次の表に、各コードの意味を示します。

 

コード
インピーダンス

600c

600-ohm complex

600r

600-ohm real

900c

900-ohm complex

900r

900-ohm real

complex1

complex 1

complex2

complex 2

impedance コマンドを使用するときには、次の制約に注意してください。

600rオプションは、現在のPOTS回線タイプ0の実施を選択します。

900rオプションは、現在のPOTS回線タイプ1の実施を選択します。

600c、900c、complex1、およびcomplex2オプションは、現在のPOTS回線タイプ2の実施を選択します。

国際発信者IDサポート

Caller ID(CLID)は、受信回線がコールを受信したときに、発呼線の番号を受信回線の端末装置に表示するアナログ サービスです。CLIDをCalling Line Identity Presentation(CLIP;発信者番号通知)と呼んでいる国もあります。シスコ ルータはCLIDデータをH.225セットアップ メッセージの一部として受信し、これをCLID装置またはCLIDメッセージを表示できる電話のいずれかの端末装置に送信します。

CLIDには、タイプIとタイプⅡの2つの種類があります。タイプIは、受信電話がオンフックのときにCLID情報を送信します。タイプIIは、受信電話がオフフックのときにCLID情報を送信します。このリリースでは、タイプI CLIDだけがサポートされています。

発信者IDのFXSポートの設定

発信者ID情報をFXS音声ポートに送信できるようにするには、 caller-id enable 音声ポート コンフィギュレーション コマンドを使用します。発信者ID情報の送信をディセーブルにするには、このコマンドの no 形式を使用します。このコマンドを使用すると、その音声ポートの他のすべての発信者ID設定もクリアされます。

caller-id enable
no caller-id enable
 

cptone コマンドで指定される国は、発信者IDがサポートされている国である必要があります。デフォルトでは発信者IDはディセーブルです。

発信者ID通知の設定

caller-id alerting 音声ポート コンフィギュレーション コマンドを使用することにより、発信者ID通知方法を指定し、発信者IDサポートをイネーブルにします。このコマンドのno形式は、発信者ID通知タイプを発信者ID通知リング タイプ1に設定します。

caller-id alerting { line-reversal | pre-ring | ring < 1 | 2 > }
no caller-id alerting { line-reversal | pre-ring | ring < 1 | 2 > }
 

次の表で、通知方法を説明します。

 

通知方法
説明

line-reversal

回線反転通知方法を使用します。

pre-ring

FXS音声ポートでのオンフック(タイプI)発信者IDの発信者ID情報については、250ミリ秒プレリング通知方法を設定します。

ring < 1 | 2 >

FXS音声ポートでのオンフック(タイプI)発信者IDの受信発信者ID情報については、リングサイクル方法を設定します。

電話サービス プロバイダーがこれを指定している場合は、この設定で受信ステーションでの最初の呼び出し音の後に発信者ID通知(表示)が提供されます。

電話サービス プロバイダーがこれを指定している場合は、この設定で2番目の呼び出し音の後に発信者ID通知(表示)が提供されます。

デフォルトの通知方法は、 ring 1 です。ルータがインストールされている国で異なった通知方法が使用されている場合、適切な通知方法を設定する必要があります。BellCore/Telcordia標準を使用している国では、 caller-id alerting ring コマンドを使用することができます。BellCore/Telcordia標準を使用していない国では、 caller-id alerting line-reversal caller-id alerting pre-ring 、および caller-id alerting リング コマンドを使用することができます。

特定の音声ポートについては、caller-id alertingコマンドが自動的に発信者IDサポートをイネーブルにします。

発信者ID表示ブロッキング機能の設定

FXSポートで発信されたコールについて、コールの遠端で発信者ID情報のブロッキングを要求するには、発信側外部FXS音声ポートで caller-id block 音声ポート コンフィギュレーション コマンドを使用します。発信者ID情報の表示を許可するには、このコマンドの no 形式を使用します。

caller-id block
no caller-id block
 

デフォルトでは、発信者ID情報のブロッキングは行われません。


) 呼び出し側情報は、ルーテッド オンネット コールに含まれますが、この情報は、課金やコール ブロッキングなど他の目的で必要になることがよくあります。終端FXSポートでの呼び出し側情報の表示をブロックする要求は、通常シスコ ルータによって受け入れられますが、他の装置による要求の受け入れに関しては保証されません。


CARの設定

この機能は、次のシスコ ルータで利用可能です。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837

Cisco 828

トラフィック送信元および宛先への帯域幅伝送速度を制限し、指定された帯域幅割り当てに違反するトラフィックを処理するポリシーを指定するには、Committed Access Rate(CAR;専用アクセス レート)を使用します。CARをイネーブルにするには、ATMインターフェイス コンフィギュレーション モードで rate-limit コマンドを入力します。

設定例

次に、CAR設定の例を示します。

interface ATM0.1 point-to-point
mtu 576
ip address 10.0.0.10 255.255.255.0
rate-limit output 368000 2000 2000 conform-action set-dscp-transmit 40 exceed-action set-dscp-transmit 48
pvc 0/33
protocol ip 10.0.0.9 broadcast
vbr-nrt 142 142 1
encapsulation aal5snap
!
 

NATによるVPN IPSecサポートの設定

この機能は、次のシスコ ルータで利用可能です。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837

Cisco SOHO 77、SOHO 78、SOHO 96、およびSOHO 97

Cisco 828

この機能には、TCPラッピングまたはUDPラッピングを使用しないクライアント ソフトウェアが含まれます。この機能を使用することにより、シスコ ルータ上でIPSecパケット ラッピングがディセーブルまたはサポートされていない複数のPCベースのIPSecクライアントを同時に使用することができます。このルータに接続されたPCがIPSecトンネルを作成した場合、ルータ上のNATは、このパケット上のプライベートIPアドレスをパブリックIPアドレスに変換します。このNAT機能はまた、複数のPoint-to-Point Tunneling Protocol(PPTP;ポイントツーポイント トンネリング プロトコル)セッションもサポートしており、PPTPクライアント ソフトウェアがインストールされたPCで起動することができます。

この機能を稼働させるには、グローバル コンフィギュレーション モードで次のコマンドを入力する必要があります。

ip nat inside source list number interface BVI number overload
 

NATデフォルト内部サーバ拡張機能

この機能は、次のシスコ ルータでサポートされます。

Cisco 806

Cisco 831、836、および837

Cisco SOHO 91、SOHO 96、およびSOHO 97

NATコマンドが拡張され、ユーザは内部ローカル アドレスがコンフィギュレーション内の他のNATステートメントの基準に一致しないパケットを受信するよう指定することができます。

構文は次のとおりです。

ip nat inside source static inside_local interface interface_name
 

設定例

図 8-1に示すように、アドレス20.0.0.14および20.0.0.16の2つの装置をサポートしているCisco 806ルータの設定例を示します。

図 8-1 2つの装置のNATを行うCisco 806ルータ

 

NATステートメントの中には、トラフィックをアドレス20.0.0.14に宛てているものがあります。このNATステートメントに一致しないすべてのパケットは20.0.0.16にルーティングされます。

Current configuration :942 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c806-1
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
crypto mib ipsec flowmib history tunnel size 200
crypto mib ipsec flowmib history failure size 200
!
interface Ethernet0
ip address 20.0.0.1 255.0.0.0
ip nat inside
hold-queue 100 out
!
interface Ethernet1
ip address 10.0.0.1 255.0.0.0
ip nat outside
!
ip nat inside source static tcp 20.0.0.14 80 interface Ethernet1 80
ip nat inside source static udp 20.0.0.14 161 interface Ethernet1 161
!
ip nat inside source static 20.0.0.16 interface Ethernet1
! 20.0.0.16 is defined as the catch-all address
!
ip nat inside source static udp 20.0.0.14 1000 interface Ethernet1 1000
! udp port 1000 traffic will be routed to 20.0.0.14
!
ip nat inside source static tcp 20.0.0.14 23 interface Ethernet1 23
! telnet traffic will be routed to 20.0.0.14
!
ip classless
no ip http server
!
!
line con 0
stopbits 1
line vty 0 4
password lab
login
!

VoAAL2 ATM Forum Profile 9サポートの設定

Cisco 827-4Vルータは、Voice over ATM Adaptation Layer 2(VoAAL2;Voice over ATMアダプテーション レイヤ2)ATM Forum Profile 9をサポートします。ATM Forum Profile 9は、44バイト ペイロードをサポートし、音声伝送効率を最適化し、Tdsoftゲートウェイとのインターオペラビリティを可能にします。

この機能により、シスコ ルータは、Class 5スイッチと通信するGR.303およびV5.2ゲートウェイと相互運用することができるようになります。音声PVCは、GR.303またはV5.2プロトコルのいずれかをサポートするVoAAL2ゲートウェイにルーティングされます。このゲートウェイは、AAL2符号化音声セルを時分割多重接続でClass 5スイッチに送信することのできるフォーマットに変換します。データPVCは、Digital Subscriber Line Access Multiplexer(DSLAM;デジタル加入者線アクセス マルチプレクサ)またはアグリゲータを経由してデータ ネットワークへルーティングすることができます。

ATM Forum Profile 9の設定

音声ポートにATM Forum Profile 9サポートを設定するには、グローバル コンフィギュレーション モードから開始して次の作業を行います。

 

コマンド
作業

ステップ 1

voice class permanent 1

音声クラスを設定します。

ステップ 2

signal timing oos timeout disabled

シグナリング パケットが紛失した場合に受信out-of-service(OOS;アウトオブサービス)パターンのPBXへのアサートをディセーブルにします。

ステップ 3

exit

音声クラス コンフィギュレーション モードを終了します。

ステップ 4

voice service voatm

音声サービス コンフィギュレーション モードを開始します。

ステップ 5

session protocol aal2

音声サービス セッション コンフィギュレーション モードを開始し、AAL2トランキングを指定します。

ステップ 6

mode bles

VOATMが、Broadband Loop Emulation Service(BLES;ブロードバンド ループ エミュレーション サービス)モードで使用されることを示します。

ステップ 7

exit

exitコマンドを入力して、セッション プロトコル モードを終了します。再びexitを入力して、音声サービス コンフィギュレーション モードを終了します。

ステップ 8

interface atm0

ATM 0インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

pvc vpi vci

PVCのVPIおよびVCIを指定します。

ステップ 10

vbr-rt pcr acr bcs

Variable Bit Rate(VBR;可変ビット レート)リアルタイムPeak Cell Rate(PCR;ピーク セル レート)および平均セル レートをkbps単位で指定し、バースト セル サイズをセル数で指定します。

ステップ 11

encapsulation aal2

ATM Adaptation Layer 2(AAL2;アダプテーション レイヤ2)タイプ カプセル化を指定します。

ステップ 12

no atm cell-clumping-disable

音声セルが進行中の場合に、データ パケットに十分な帯域幅が割り当てられるようにします。

ステップ 13

exit

ATM 0インターフェイス コンフィギュレーション モードを終了します。

ステップ 14

dial-peer voice tag voatm

ルータをダイヤルピア音声コンフィギュレーション モードにします。

ステップ 15

session protocol aal2-trunk

セッション プロトコルがAAL2トランク パーマネント(プライベート回線)トランク コールをサポートするよう設定します。

ステップ 16

session target atm0 pvc vpi/vci cid cid

このコマンドには、 vpi( 仮想パス識別子)、 vci (仮想チャネル識別子)、および cid( AAL2チャネル識別子)という3つのパラメータがあります。

ステップ 17

codec aal2 profile

音声ダイヤル ピアにG.711 a-lawだけが使用されることを指定するには、 codec aal2-profile atmf 9 g711alaw を入力します。音声ダイヤル ピアにG.711 mu-lawだけが使用されることを指定するには、 codec aal2-profile atmf 9 g711ulaw を入力します。

ステップ 18

destination-pattern destination string

ダイヤル ピアを音声ポートと対応づけます。
destination string
は、E.164フォーマットの電話番号であり、音声ポートに設定された宛先文字列に一致する必要があります。

ステップ 19

voice-class permanent 1

このダイヤル ピアを設定済み音声クラスに対応づけます。

ステップ 20

no vad

Voice Activity Detection(VAD;音声アクティビティ検出)を行わないよう指定します。

ステップ 21

exit

ダイヤル ピア音声コンフィギュレーション モードを終了します。

ステップ 22

voice port #

音声ポート コンフィギュレーション モードを開始します。

ステップ 23

connection trunk destination-pattern

ダイヤラ文字列を指定します。宛先パターンは、ダイヤル ピアに設定された destination-string に一致する必要があります。

ステップ 24

playout-delay mode fixed no-timestamps

固定レートでAAL2パケットをプレイアウトし、そのパケットに記載されたタイムスタンプを無視します。

ステップ 25

end

ルータ コンフィギュレーション モードを終了します。


) 1本の電話線では、PCR値およびAllowed Cell Rate(ACR;実行セル レート)値の両方に最低78 kbpsの設定が必要です。


設定例

次にProfile 9およびG.711 a-lawコーデックを用いた2つの音声ポートの設定例を示します。4つの電話線を収容するためVBR-RT、PCR、およびACR値は312です。ただし、現在は2つの電話線だけが設定されています。

voice service voatm
!
session protocol aal2
mode bles
!
!
voice class permanent 1
signal timing oos timeout disabled
!
interface atm 0
no atm cell-clumping-disable
pvc 1/100
vbr-rt 312 312 32
encapsulation aal2
!
voice-port 1
playout-delay mode fixed no-timestamps
cptone DK
timeouts wait-release 3
connection trunk 8881052
caller-id enable
!
voice-port 2
playout-delay mode fixed no-timestamps
cptone DK
timeouts wait-release 3
connection trunk 8881053
caller-id enable
!
!dial-peer voice 1000 voatm
destination-pattern 8881052
voice-class permanent 1
session protocol aal2-trunk
session target ATM0 pvc 1/100 16
codec aal2-profile ATMF 9 g711alaw
no vad
!
dial-peer voice 1001 voatm
destination-pattern 8881053
voice-class permanent 1
session protocol aal2-trunk
session target ATM0 pvc 1/100 17
codec aal2-profile ATMF 9 g711alaw
no vad
!

ATM OAM F5 CCサポートの設定

この機能は、次のシスコ ルータで利用可能です。

Cisco 826および836

Cisco 827、827H、および837

Cisco SOHO 77、SOHO 96、およびSOHO 97

ATM Operation, Administration, and Maintenance(OAM)F5 Continuity Check(CC;導通チェック)セルにより、ネットワーク管理者はATMレイヤの設定ミスを検出することができます。このような設定ミスをすると、セル ストリームを第三者へ誤って配信したり、複数の送信元からのセルを意図に反して統合してしまったりします。

CCセルは、ATMレイヤでの接続問題を検出するために最適化されたインサービス ツールです。CCセルは、ソース位置として指定されたルータとシンク位置として指定されたルータとの間で送信されます。ローカル ルータは、ソース、シンク、またはソースとシンクの両方として設定することができます。セグメントのもう一方の端のルータ上でCC設定を入力する必要はありません。CCが設定されているルータは、CC起動要求をセグメントのもう一方の端のルータに送信し、ソースまたはシンクとして稼働するよう指示するためです。

PVC上でのCCの設定

PVCでCCを設定するには、次のコマンドを入力します。

oam-pvc manage cc segment direction [ source | sink | both ]
 

セグメントでCCをディセーブルにするには、このコマンドの no 形式を使用します。

no oam-pvc manage cc segment direction [ source | sink | both ]
 

設定例

次に、セグメントでCCを起動し、ルータをソースとして機能させる設定例を示します。

interface ATM0
ip address 10.0.0.3 255.255.255.0
pvc 0/33
oam-pvc manage cc segment direction source
!
end
 

次に、セグメント上でCCを起動し、ルータをシンクとして機能させる設定例を示します。

interface ATM0
ip address 10.0.0.3 255.255.255.0
pvc 0/33
oam-pvc manage cc segment direction sink
!
end
 

次に、セグメント上でCCを起動し、ルータをCCセルのソースおよびシンクとして機能させる設定例を示します。

interface ATM0
ip address 10.0.0.3 255.255.255.0
pvc 0/33
oam-pvc manage cc segment direction both
!
end
 

次に、セグメントCCを停止させる設定例を示します。

interface ATM0
ip address 10.0.0.3 255.255.255.0
pvc 0/33
no oam-pvc manage cc
!
end
 

CCの起動および停止要求頻度の設定

次のコマンドは、CCの起動および停止要求をセグメントのもう一方の端のルータに送信する頻度を設定します。

oam retry cc activation-count number deactivation-count number retry-frequency seconds

 

この設定を削除するには、このコマンドのno形式を使用します。

no oam retry cc activation-count number deactivation-count number retry-frequency seconds

 

設定例

次に、CCの起動と停止ならびに再試行の回数の設定例を示します。

interface ATM0
ip address 10.0.0.3 255.255.255.0
pvc 0/33
oam-pvc manage cc segment direction source
retry activation-count 10 deactivation-count 10 retry-frequency 3
!
end
 

VC上でのCCサポートのディセーブル化

次のコマンドは、当該コマンドが入力されたVC上でCCサポートをディセーブルにします。CCサポートがディセーブルになっているPVCは、CC起動要求を拒否します。

oam-pvc manage cc deny
 

VC上でのCCサポートを再びイネーブルにするには、このコマンドの no 形式を使用します。

no oam-pvc manage cc deny
 

設定例

次に、セグメントCCを拒否する設定例を示します。

interface ATM0
ip address 10.0.0.3 255.255.255.0
pvc 0/33
oam-pvc manage cc deny
!
end
 

CCのデバッギングの設定

CCの結果を確認するには、次のコマンドを使用します。

debug atm oam cc interface atm number
 

CCのデバッギングをディセーブルにするには、このコマンドの no 形式を使用します。

no debug atm oam cc interface atm number
 

エンドツーエンドF5 OAMループバック セル生成の設定

エンドツーエンドF5 OAMループバック セルの生成を設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

interface atm 0

ATMインターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

pvc routerA vpi/vci

PVCをvpiおよびvciの値とともにrouter Aに割り当てます。

ステップ 3

oam-pvc manage 3

OAMセル伝送間に3秒の頻度でOAM管理をイネーブルにします。

ステップ 4

oam retry 5 5 10

アップ数、ダウン数、および再試行頻度を設定します。

次に、ATM PVC上でOAM管理をイネーブルにする例を示します。PVCには、router Aが割り当てられ、VPIとVCIには、それぞれ0と32が割り当てられます。OAMセル伝送間に3秒の頻度でOAM管理がイネーブルになります。

interface atm 2/0
pvc routerA 0/32
oam-pvc manage 3
oam retry 5 5 10
 

出力例

次に、デバッグ atm oam cc コマンドが oam-pvc manage cc コマンドの入力で始まり、 no oam-pvc manage cc コマンドの入力で終わるアクティビティを記録する例を示します。ATM 0インターフェイスが指定され、「両側」のセグメント方向が指定されます。出力には、起動要求の送信と確認、セグメントの両側のルータによって送信された一連のCCセル、停止要求と確認が表示されます。

router#debug atm oam cc interface atm0

Generic ATM:

ATM OAM CC cells debugging is on

router#

00:15:05: CC ACTIVATE MSG (ATM0) I:VCD#1 VC 1/40 OAM Cell Type:4 OAM

Type:8 OAM Func:1 Direction:3 CTag:5

00:15:05: CC ACTIVATE CONFIRM MSG (ATM0) O:VCD#1 VC 1/40 OAM Cell

Type:4 OAM Type:8 OAM Func:1 Direction:3 CTag:5

00:15:06: CC CELL (ATM0) O:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1

00:15:07: CC CELL (ATM0) I:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:08: CC CELL (ATM0) O:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:09: CC CELL (ATM0) I:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:10: CC CELL (ATM0) O:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:11: CC CELL (ATM0) I:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:12: CC CELL (ATM0) O:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:13: CC CELL (ATM0) I:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:14: CC CELL (ATM0) O:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:15: CC CELL (ATM0) I:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:16: CC CELL (ATM0) O:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:17: CC CELL (ATM0) I:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:18: CC CELL (ATM0) O:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:19: CC CELL (ATM0) I:VCD#1 VC 1/40 OAM Cell Type:4 OAM Type:1 OAM Func:4

00:15:19: CC DEACTIVATE MSG (ATM0) I:VCD#1 VC 1/40 OAM Cell Type:4 OAM

Type:8 OAM Func:1 Direction:3 CTag:6

00:15:19: CC DEACTIVATE CONFIRM MSG (ATM0) O:VCD#1 VC 1/40 OAM Cell

Type:4 OAM Type:8 OAM Func:1 Direction:3 CTag:6

 

次の表で、重要なフィールドについて説明します。

 

フィールド
説明

00:15:05

タイム スタンプ

CC ACTIVATE MSG(ATM0)

メッセージ タイプとインターフェイス

0

ソース

1

シンク

VC 1/40

VC識別子

Direction:3

セルが移動する方向を示します。1はローカル ルータがシンクとして稼働することを示します。2はローカル ルータがソースとして稼働することを示します。3は、両方のルータがソースおよびシンクとして稼働することを示します。

RADIUSサポートの設定

RADIUSは、次のシスコ ルータでサポートされます。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837

Cisco 828

RADIUSを使用することにより、ネットワークを不正アクセスから保護することができます。RADIUSサーバは、ルータがRADIUSクライアント機能を使用するようサービス プロバイダーまたは会社ネットワークに設定される必要があります。RADIUSの設定については、『 Cisco 806 Router Software Configuration Guide 』および『 Cisco IOS Security Configuration Guide 』を参照してください。

Cisco Easy VPN Clientの設定

Cisco Easy VPN Client機能は、次のシスコ ルータでサポートされます。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837

Cisco 828

Cisco Easy VPN Client機能は、次の2つの動作モードをサポートします。

クライアント ― NATおよびPort Address Translation(PAT;ポート アドレス変換)を適用し、VPNトンネルのクライアント側のPCおよび他のホストが宛先サーバのIPアドレス空間のどのようなIPアドレスも使用しないプライベート ネットワークを形成するよう指定します。

ネットワーク拡張 ― VPNトンネルのクライアント側のPCおよび他のホストに宛先エンタープライズ ネットワークのIPアドレス空間のIPアドレスが与えられ、1つの論理ネットワークが形成されるよう指定します。

どちらの動作モードもオプションでスプリット トンネリングをサポートします。スプリット トンネリングは、VPNトンネル経由の企業リソースへの安全なアクセスを可能にする一方で、ISPまたは他のサービスへの接続によるインターネットへのアクセスを可能にします(これにより、Webアクセスの経路から企業ネットワークが削除されます)。この設定は、IPSecサーバに実装された簡易アクセス リストによってイネーブルにされます。


) Cisco 800シリーズ ルータは、VPN 3000コンセントレータのIPSecクライアントとしてサポートされます。他のIPSecサーバのサポートは、今後のリリースで利用可能になります。現在のリリースのCisco IOSリリース ノートを参照して、Cisco Easy VPN Clientの使用に関して他の制限があるかどうかを確認してください。


リリース ノート『 Cisco EZVPN Client for the Cisco uBR905/uBR925 Cable Access Routers 』は、DHCPサーバ プールおよびEasy VPN の実行に必要なEasy VPN Clientプロファイルの設定についての注意事項が記載されています。このリリース ノートにはまた、IPSecサーバの設定例およびEasy VPNを管理する コマンドの説明が記載されています

設定例

ここでは、Cisco 827ルータのクライアント モード設定例を示します。

次に示す例では、Cisco 827ルータは、クライアント動作モードでCisco Easy VPN機能を使用するIPSecクライアントとして設定されています。この例では、Cisco Easy VPN Client設定の次のコンポーネントを示しています。

DHCPサーバ プール ― ip dhcp pool コマンドは、ルータのEthernet 1インターフェイスに接続されているPCに割り当てられるIPアドレスを保存しておくプールを作成します。このプールは、クラスCプライベート アドレス空間(192.168.100.0)のアドレスを割り当てます。また、PCのデフォルトのルートが、ルータのイーサネット インターフェイスに割り当てられるIPアドレス192.168.100.1 となるように各PCを設定します。

EzVPNクライアント コンフィギュレーション ― 最初の crypto ipsec client ezvpn hw-client コマンド(グローバル コンフィギュレーション モード)は、名前が hw-client のEzVPNクライアント コンフィギュレーションを作成します。この設定では、グループ名を hw-client-groupname と指定し、共有鍵値を hw-client-password と指定します。また、この設定では、ピア宛先のIPアドレスを 188.185.0.5 に設定します(このアドレスは、宛先ピア ルータ上のインターネットに接続されるインターフェイスに割り当てられるアドレスです)。EzVPN設定は、デフォルトの動作モード、すなわち client モードで設定されます。


) DNSもルータ上に設定されている場合は、peerオプションも、IP アドレスの代わりにホスト名をサポートします。


2番目の crypto ipsec client ezvpn hw-client コマンド(ATM 0インターフェイス コンフィギュレーション モード)は、EzVPNクライアント コンフィギュレーションをATM 0インターフェイスに割り当てて、そのインターフェイス上に送受信されるすべてのトラフィックをVPNトンネル経由で送信します。

次に、show running-configコマンドの出力例を示します。

Current configuration :1040 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c827-18
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip dhcp excluded-address 192.168.100.1
!
ip dhcp pool CLIENT
import all
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
crypto ipsec client ezvpn hw-client
group hw-client-groupname key hw-client-password
mode client
peer 188.185.0.5
!
interface Ethernet0
ip address 192.168.100.1 255.255.255.0
hold-queue 100 out
!
interface ATM0
ip address 192.168.101.18 255.255.255.0
no atm ilmi-keepalive
protocol ip 192.168.101.19 broadcast
encapsulation aal5snap
!
dsl operating-mode auto
crypto ipsec client ezvpn hw-client
!
ip classless
ip route 0.0.0.0 0.0.0.0 ATM0
ip route 50.0.0.0 255.0.0.0 40.0.0.19
ip http server
ip pim bidir-enable
!
line con 0
stopbits 1
line vty 0 4
login
!

PPPoEクライアント用DDRの設定

PPPoEクライアント用Dial-on-Demand Routing(DDR;ダイヤル オンデマンド ルーティング)は、次のシスコ ルータでサポートされます。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837

Cisco SOHO 77、SOHO 77H、SOHO 78、SOHO 91、SOHO 96、およびSOHO 97

Cisco 828

PPPoEクライアント用DDRは、ネットワークに接続した時間に基づきISP料金が課される(非フラットレート サービス)加入者に融通性を提供します。PPPoEクライアント用DDR機能を使用すれば、対象トラフィックとしてトラフィックのタイプを指定することができます。また、対象トラフィックがLANインターフェイスから到着したときにPPPoE接続が行われ、ダイヤラ アイドル タイマーが切れたときに接続が切断されるようルータを設定することができます。

DDRは、pppoe-client dial-pool-numberコマンドをdial-on demandキーワードとともに使用し、Ethernet 1コンフィギュレーション モードで設定されます。構文は次のとおりです。

pppoe-client dial-pool-number number [dial-on-demand]
 

PPPoEクライアント用DDRの設定

PPPoEクライアント用DDRを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。


ステップ 1 VPDNをイネーブルにします。

a. グローバル コンフィギュレーション モードでvpdn enableコマンドを入力します。

b. no vpdn loggingコマンドを入力してVPDNロギングをディセーブルにします。

ステップ 2 VPDNグループを設定します。

a. グローバル コンフィギュレーション モードでvpdn-group numberコマンドを入力し、VPDNグループ コンフィギュレーション モードを開始します。

b. request-dialinを入力して、ダイヤルイン ダイヤリング モードを指定します。

ステップ 3 Ethernet 1インターフェイスを設定します。

a. interface Ethernet 1を入力して、Ethernet 1インターフェイス コンフィギュレーション モードを開始します。

b. pppoe enableを入力して、このインターフェイスのPPPoEをイネーブルにします。

c. DDRを起動し、pppoe-client dial-pool-number number dial-on-demandを入力してダイヤル プールを作成します。number値は、VPDNグループ番号と一致している必要があります。

ステップ 4 ダイヤラ インターフェイスを設定します。

a. interface dialer 1を入力して、ダイヤラ インターフェイス コンフィギュレーション モードを開始します。

b. ip address negotiatedを入力して、IPアドレスがDHCPサーバとネゴシエートされることを示します。

c. ip mtu 1492を入力してMTUサイズを指定します。

d. encapsulation pppを入力してカプセル化タイプを設定します。

e. dialer pool number コマンドを入力して、ダイヤラ インターフェイスをEthernet 1インターフェイス用に作成されたダイヤラ プールと対応づけます。

f. dialer idle-timeout 180 eitherを入力して、アイドル タイマー間隔を設定します。eitherキーワードは、着信または送信トラフィックのいずれかがアイドル タイマーをリセットできることを示します。


) ゼロの値は、タイマーが時間切れにならず、接続が常に行われていることを示します。


g. dialer hold-queue 100を入力して、接続が確立される前に対象パケットを収容できるサイズにキューを設定します。

h. dialer-group 1を入力して、対象トラフィックを定義するダイヤラ リストを指定します。

i. exitを入力して、Dialer 1インターフェイス コンフィギュレーション モードを終了します。

ステップ 5 グローバル コンフィギュレーション モードで、dialer-list 1 protocol ip permitコマンドを入力して、IPトラフィックを対象トラフィックとして定義します。

ステップ 6 ip route 0.0.0.0 0.0.0.0 dialer 1 permanentコマンドを入力して、Dialer 1インターフェイスのスタティック ルートを作成します。

ステップ 7 exitを入力して、コンフィギュレーション モードを終了します。


 

WFQの設定

WFQは、次のシスコ ルータでサポートされます。

Cisco 806

Cisco 826および836

Cisco 827、827H、827-4V、831、および837ルータ

Cisco 828

WFQには制限があります。フロー量がかなり増加した場合には計測することができず、ATMインターフェイスなどの高速インターフェイスで生来のWFQは利用できません。Cisco IOS Plus画像で利用できるクラスベースのWFQは、これらの制限を受けません。

WFQの設定

WFQをシスコ ルータのATMインターフェイスに適用するには、次の作業を行います。


ステップ 1 WFQのポリシー マップを作成します。

a. グローバル コンフィギュレーション モードで、policy-map map-name コマンドを入力してWFQポリシーを作成します。これがWFQのポリシー マップであることを指定するには、wfqというマップ名を使用することができます。

b. class class-default を入力して、すべてのトラフィックでデフォルト クラスを使用します。

c. fair-queueコマンドを入力して、WFQをすべてのトラフィックに適用します。

d. exitを2回入力して、グローバル コンフィギュレーション モードに戻ります。

ステップ 2 ポリシー マップをルータ インターフェイスに適用します。

a. interface atm numberを入力します。ここで、numberはATMインターフェイス番号です。

b. pvc vpi/vciを入力して、ポリシー マップをどのPVCに適用するのかを指定します。

c. service-policy output map-nameを入力して、ポリシーをこのPVCに適用します。ポリシー マップをwfqと名づけた場合、service-policy output wfqというコマンドを入力します。

ステップ 3 exitを入力して、ルータ コンフィギュレーション モードを終了します。


 

設定例

次の設定では、ATM 0.1インターフェイス上でWFQをPVC 0/33に適用します。wfqという名前のポリシー マップが作成され、WFQはそのポリシー マップで参照されたデフォルト クラスに適用されます。そして、wfqがATM 0.1インターフェイス コンフィギュレーションで参照されます。

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password encryption
!
hostname 806-uut
!
ip subnet-zero
!
policy-map wfq
class class-default
fair-queue
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
interface atm0.1
no ip address
pvc 0/33
service-policy output wfq
!
ip classless
ip http server
ip pim bidir-enable
!
line con 0
stopbits 1
line vty 0 4
login
!
scheduler max-task-time 5000
end
!

DSLコマンドの設定

ここでは、サポートされているDSLコマンドについて説明します。

DSL CLI(コマンドライン インターフェイス)コマンドを設定するには、次の作業を行います。

 

コマンド
作業

ステップ 1

dsl noise-margin

雑音マージン オフセットを設定します。

ステップ 2

max-tone-bits

トーンあたりの最大ビット制限を設定します。

ステップ 3

gain-setting rx-offset

受信ゲイン オフセットを設定します。

ステップ 4

gain-setting tx-offset

送信ゲイン オフセットを設定します。

設定例

次にdslコマンドの設定例を示します。

interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
dsl noise-margin 0
dsl max-tone-bits 14
dsl gain-setting tx-offset 0
dsl gain-setting rx-offset 1
 

DSLトレーニング ログのイネーブル化

DSLトレーニング ログは、次のシスコ ルータで利用可能です。

Cisco 826および836

Cisco 827、827H、827-4V、および837ルータ

Cisco 828

デフォルトでは、DSLトレーニング ログはCiscoルータがDSLAMとのコンタクトを確立するたびに検索されます。トレーニング ログは、ルータがセントラル オフィスのDSLAMとトレーニング、または通信パラメータをネゴシエートするときに発生するイベントの記録です。ただし、このログを検索すると、トレーニング プロセスにかなりの時間が追加されるので、ルータのトレーニングが順調に行われた後でいつも必要というわけではありません。このログの検索をイネーブルにするには、dsl enable-training-logコマンドを使用します。DSLトレーニング ログの検索をディセーブルにするには、このコマンドのno形式を使用します。

dsl enable-training-log
no dsl enable-training-log
 

DSLトレーニング ログを検索した後で、トレーニング ログの追加検索をディセーブル化

トレーニング ログを検索し、これを検査し、次回DSLAMとのトレーニングが実行される場合にこのルータがトレーニング ログを検索するのをディセーブルするには、次の作業を実行します。


ステップ 1 ルータがトレーニング ログを検索するよう設定します。

a. グローバル コンフィギュレーション モードでinterface ATM numberコマンドを入力します。ここでnumberは、ATMインターフェイスの番号です。

b. dsl enable-training-logを入力して、トレーニング ログの検索をイネーブルにします。

c. exitを入力して、ルータ コンフィギュレーション モードを終了します。

ステップ 2 ルータの背面でDSLソケットからDSLケーブルを抜き、数秒待ち、再びケーブルをソケットに差し込みます。

ステップ 3 [DSL line up]メッセージが表示されたら、show dsl int atm number コマンドを発行します。ここで、numberは検索されたログを表示するATMインターフェイスの番号です。

ステップ 4 ルータがもうトレーニング ログを検索する必要がないと判断した場合は、次の作業を行ってルータがログの検索をしないよう再設定します。

a. グローバル コンフィギュレーション モードでinterface ATM numberコマンドを入力します。ここでnumberは、ATMインターフェイスの番号です。

b. no dsl enable-training-logを入力して、トレーニング ログの検索をディセーブルにします。

c. exitを入力して、ルータ コンフィギュレーション モードを終了します。


 

セカンダリDSLファームウェアの選択

このコマンドは、Cisco 827、827H、827-4V、および837ルータで利用可能です。

ATMインターフェイス モードでdsl firmware secondaryコマンドを入力することにより、セカンダリDSLファームウェアを選択することができます。

dsl firmware secondary
 

プライマリ ファームウェアの使用に戻る場合は、このコマンドのno形式を入力します。

no dsl firmware secondary

) 設定変更を有効にするには、ルータのトレーニングを再度実行しなくてはなりません。回線のトレーニングを再度実行するには、ルータの背面でDSLソケットからDSLケーブルを抜き、再びケーブルをソケットに差し込みます。


show dsl interface atm numberコマンドを使用して、DSL回線の再トレーニングの前および後で使用中のファームウェア バージョンを比較することができます。

出力例

次に、dsl secondary firmwareコマンドがこの設定に追加される前のshow dsl interface atmコマンド出力の例を示します。

827-sus2#sh dsl int atm0
ATU-R (DS) ATU-C (US)
Modem Status: Showtime (DMTDSL_SHOWTIME)
DSL Mode: ITU G.992.1 (G.DMT)
ITU STD NUM: 0x01 0x01
Vendor ID: 'ALCB' 'GSPN'
Vendor Specific:0x0000 0x0002
Vendor Country: 0x00 0x00
Capacity Used: 66% 74%
Noise Margin: 16.5 dB 17.0 dB
Output Power: 8.0 dBm 12.0 dBm
Attenuation: 0.0 dB 4.0 dB
Defect Status: None None
Last Fail Code: None
Selftest Result:0x49
Subfunction: 0x02
Interrupts: 652 (1 spurious)
Activations: 1
SW Version: 3.8129
FW Version: 0x1A04
 

dsl firmware secondaryコマンドをこの設定に追加し、トレーニングを再度実行した後で、show dsl interface ATM0出力はソフトウェア バージョンが3.7123に変更されたことを示します。

827-sus2#sh dsl int atm0
ATU-R (DS) ATU-C (US)
Modem Status: Showtime (DMTDSL_SHOWTIME)
DSL Mode: ITU G.992.1 (G.DMT)
ITU STD NUM: 0x01 0x01
Vendor ID: 'ALCB' 'GSPN'
Vendor Specific:0x0000 0x0002
Vendor Country: 0x00 0x00
Capacity Used: 71% 74%
Noise Margin: 18.0 dB 17.0 dB
Output Power: 7.5 dBm 12.0 dBm
Attenuation: 0.0 dB 4.0 dB
Defect Status: None None
Last Fail Code: None
Selftest Result:0x00
Subfunction: 0x02
Interrupts: 1206 (2 spurious)
Activations: 2
SW Version: 3.7123
FW Version: 0x1A04
 

設定例

次に、セカンダリDSLファームウェアを使用したCisco 827ルータの設定例を示します。

827-sus2#sh run
Building configuration...
 
Current configuration :738 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
hostname 827-sus2
!
ip subnet-zero
no ip domain-lookup
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
interface Ethernet0
ip address 192.168.5.23 255.255.255.0
no cdp enable
hold-queue 100 out
!
interface Virtual-Template1
ip address 2.2.3.4 255.255.255.0
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 1/40
encapsulation aal5mux ppp Virtual-Template1
!
dsl operating-mode itu-dmt
dsl firmware secondary ===========> New CLI
!
ip classless
ip http server
ip pim bidir-enable
!
line con 0
exec-timeout 0 0
stopbits 1
line vty 0 4
login
!
scheduler max-task-time 5000
end
 
827-sus2#

DNSベースのX.25ルーティングの設定

DNSベースのX.25ルーティングがサポートされるのは、Cisco 805ルータだけです。

x25 route disposition xotコマンド オプションは、xotキーワードの後にdns pattern引数が含まれるよう変更されています。ここで、patternはアドレス置換ユーティリティが機能するのと同じように動作するリライト要素です。

X.25ロードバランシングの設定

X.25ロードバランシングがサポートされるのは、Cisco 805ルータだけです。Cisco 805ルータは、1つのシリアル インターフェイスしか持たないため、負荷分散のロータリー方式だけをサポートします。

現在X.25がVCを複数のシリアル回線に割り当てる方法は、まず1つのシリアル回線がいっぱいになるまでVCを割り当て、その後で2番目の回線を利用するというものです。その結果、最初のシリアル回線は、VCがなくなるまでは、頻繁に最大データ トラフィックを伝送することになります。

「ハントグループ」と呼ばれるファシリティ(X.25負荷分散方法)を使用すると、スイッチは同じホストへ送信されるX.25回線のプールを1つのアドレスとして見なし、「空いている論理チャネル」ごとにVCを割り当てることができます。この機能により、X.25コールの負荷は、すべての設定された送信インターフェイス間で分散されるため、すべての管理回線を十分に活用し、バランスをとることができます。

X.25 CUGの設定

X.25 Closed User Group(CUG;非公開ユーザ グループ)がサポートされるのは、Cisco 805ルータだけです。

CUGは、ネットワークが2つのメンバー間および1つのメンバーと非メンバー間でのアクセスを制御しているDTE装置の集合です。X.25ネットワークは、最大10,000個のCUG(0~9999の番号が付けられます)をサポートし、それぞれが任意の数のメンバーDTE装置を持つことができます。個々のDTEは、加入により特定ネットワークCUGのメンバーとなります。加入データには、DTEがネットワークCUGを識別するのに用いるローカル番号(これはネットワーク管理およびDTE装置の要件によりネットワーク番号と同じであってもかまいませんし、同じでなくてもかまいません)およびDTEがCUG内で電話を掛けるのを禁止したり、反対にネットワークがCUG内からDTEに電話を掛けるのを禁止したりする制限が含まれています。

CUGは、様々なネットワーク加入者(DTE装置)を、着信または送信アクセス制限のあるプライベート サブネットワークに分離するネットワーク サービスです。したがって、DTEは、アクセスする必要のあるCUG集合について、そのネットワーク サービス(POP)からメンバーシップを入手する必要があります。DTEは、同時に1つまたは複数のCUGに加入することもできますし、加入しなくてもかまいません。アクセスにCUGメンバーシップが必要でないDTEは、ネットワークの公開部分と考えられます。各CUGでは通常加入ユーザが相互接続することはできますが、非加入DTE装置との接続はできないようになっています。

FTPクライアントの設定

FTPクライアントは、Cisco 801~804ルータを除くすべてのCisco 800シリーズおよびCisco SOHO 70シリーズ ルータで使用可能です。

FTPは、インターネット プロトコル スイートのアプリケーション プロトコルです。FTPは、様々なインターネットワーキング環境で異なったホスト間のファイル転送をサポートします。FTPを使用すると、たとえ各コンピュータが異なったオペレーティングシステムで動作し、異なったファイル保存フォーマットを使用していたとしても、ファイルをコンピュータ間で移動することができます。FTPクライアントとして機能することのできるシスコ ルータは、ファイルをFTPサーバからフラッシュ メモリにコピーすることができます。

Cisco Router Web Setup(CRWS)ソフトウェアがルータにインストールされている場合、FTPを使用してフラッシュ メモリのCisco IOSイメージを更新したり、必要なFTPユーザ名およびパスワードでルータを設定したりします。


注意 CRWSがコンフィギュレーション ファイルに保存したFTPユーザ名およびパスワードが変更されると、CRWSは自動更新を行うことができません。

FTPを使用して手動でシステム イメージをフラッシュ メモリにコピーする場合には、次のURLでFTPユーザ名およびパスワードのコンフィギュレーション ファイルへの追加方法を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/ffun_c/ffcprt2/fcf008.htm

認証プロキシの設定

認証プロキシは、Cisco 806および831ルータでサポートされます。

Cisco IOS Firewall認証プロキシ機能を使用すると、ネットワーク管理者は特定のセキュリティ ポリシーをユーザごとに適用することができます。以前、ユーザIDおよびこれに関係する許可アクセスは、ユーザのIPアドレスと対応づけられるか、あるいは1つのセキュリティ ポリシーが全体のユーザ グループまたはサブネットに適用されなくてはなりませんでした。今では、ユーザはユーザごとのポリシーに基づき識別され、許可されるようになり、複数のユーザに適用される一般ポリシーとは対照的に、アクセス特権を個々に作成することが可能になりました。

認証プロキシ機能を使用することにより、ユーザはネットワークにログインしたり、HTTPを経由してインターネットにアクセスしたりすることができます。特定のアクセス プロファイルは自動的に検索され、Cisco Secure ACSまたは他のRADIUSまたはTACACS+認証サーバから適用されます。ユーザ プロファイルは、認証されたユーザからのアクティブなトラフィックがあるときに限りアクティブになります。

認証プロキシは、NAT、Context-Based Access Control(CBAC;コンテキスト ベースのアクセス制御)、IPSec暗号化、およびVPNクライアント ソフトウェアなど他のCisco IOSセキュリティ機能と互換性があります。

認証プロキシ設定については、『Cisco IOS Security Configuration Guide』を参照してください。

PAMの設定

Port to Application Mapping(PAM;ポート アプリケーション マッピング)は、Cisco 806および831ルータでサポートされます。

PAMを使用すると、ネットワーク管理者は、特定のアプリケーションおよびサービスについてネットワーク アクセス制御をカスタマイズすることができます。

PAMはまた、ホストまたはサブネット特定ポート マッピングをサポートします。これにより、ユーザは標準Access Control List(ACL;アクセス制御リスト)を用いて、PAMを1つのホストまたはサブネットに適用することができます。ホストまたはサブネット特定ポート マッピングは標準ACLを使用して実行されます。

PAMの設定については、『Cisco IOS Security Configuration Guide』を参照してください。

CBAC監査証跡と警告の設定

CBAC監査証跡と警告は、Cisco 806および831ルータでサポートされます。

CBACは、ルータがアプリケーション レイヤ プロトコル セッション情報に基づきTCPおよびUDPパケットをフィルタにかけ、リアルタイムの警告と監査証跡を生成することを可能にするセキュリティ機能です。CBACがない場合、フィルタリングはネットワーク レイヤおよびトランスポート レイヤ情報に基づいて実行するしかありません。拡張監査証跡機能は、SYSLOGを使用して全ネットワーク トランザクションを追跡し、先進セッション ベース報告のためにタイム スタンプ、送信元ホスト、宛先ホスト、使用されたポート、および合計転送バイト数を記録します。リアルタイム警告は、疑わしいアクティビティを検出するとSYSLOGエラー メッセージを中央管理コンソールに送信します。CBAC検査規則を使用すると、アプリケーション プロトコルごとに警告および監査証跡情報を設定することができます。たとえば、HTTPトラフィックの監査証跡情報を生成したい場合は、CBAC規則でHTTP検査を変換するよう指定することができます。

CBAC監査証跡と警告の設定については、『Cisco IOS Security Configuration Guide』を参照してください。