Cisco 800 シリーズ ソフトウェア コンフィギュレーション ガイド
ルータ機能の設定
ルータ機能の設定
発行日;2012/01/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

ルータ機能の設定

ネットワークを設定する前に

基本的なパラメータの設定

グローバル パラメータの設定

イーサネット インターフェイスの設定

設定例

設定の確認

ダイヤラ インターフェイスの設定

設定例

設定の確認

ループバック インターフェイスの設定

設定作業

設定例

設定の確認

ATMインターフェイスの設定

AAL5SNAPカプセル化の設定例

設定の確認

AAL5MUX PPPカプセル化設定例

設定の確認

ルータへのコマンドライン アクセスの設定

設定例

ブリッジングの設定

設定例

設定の確認

スタティック ルーティングの設定

設定例

設定の確認

ダイナミック ルーティングの設定

RIPの設定

設定例

設定の確認

IP EIGRPの設定

設定例

設定の確認

アドレス指定パラメータの設定

NATの設定

設定例

設定の確認

Easy IP(フェーズ1)の設定

Easy IP(フェーズ2)の設定

DHCPの設定

DHCPクライアント サポートの設定

設定例

DHCPサーバの設定

設定例

設定の確認

DHCPリレーの設定

設定例

設定の確認

TACACS+の設定

拡張アクセス リストの設定

設定例

QoSパラメータの設定

単一PVC環境の設定

IP precedenceの設定

アクセス リストおよび音声クラスの設定

ポリシー マップの設定および音声キューイングの指定

ポリシー マップの設定および音声クラスのプライオリティ キューイングの指定

ポリシー マップのATM PVCとの対応づけおよびATMインターフェイスのMTUの低減

設定例

RFC 1483カプセル化を用いた単一PVC環境の設定

データ パケットと音声パケットの区別

アクセス リストおよび音声クラスの設定

ポリシー マップの設定および音声キューイングの指定

ポリシー マップのATM PVCとの対応づけおよびTCP MSS調整の使用

PVC ATM送信リング バッファのサイズの微調整

設定例

PPP over ATMおよびマルチリンク カプセル化を用いた単一PVC環境の設定

データ パケットと音声パケットの区別

ポリシー マップの設定および音声キューイングの指定

ポリシー マップのATM PVCへの対応づけ

LLQでのリンク フラグメンテーションおよびインターリーブの設定

複数PVC環境の設定

異なったサブネット上の音声およびデータ

ATMインターフェイスおよびサブインターフェイスの設定

設定例

VCバンドリングを用いた同じサブネット上の音声およびデータ

ATMインターフェイス、音声およびデータ用PVCバンドル、および音声パケット用IP precedenceの設定

音声ネットワークのIP precedenceおよびサービス クラスの指定

設定例

ダイヤル バックアップの設定

バックアップ インターフェイスの指定

バックアップ回線遅延の定義

トラフィック負荷スレッシュホールドの定義

コンソール ポートを用いたダイヤル バックアップ

設定例

設定例

IGMPプロキシおよびsparse(疎)モードの設定

設定例

設定の確認

IPSecおよびGREトンネリングの設定

インターネット プロトコル パラメータの設定

アクセス リストの設定

IPSecの設定

GREトンネル インターフェイスの設定

イーサネット インターフェイスの設定

スタティック ルートの設定

高速クリプトの設定およびモニタ

設定例

マルチリンクPPPフラグメンテーションおよびインターリーブの設定

設定例

設定の確認

IP precedenceの設定

設定例

音声の設定

あらかじめ必要な作業

H.323シグナリング用音声の設定

POTSダイヤル ピアの設定

H.323シグナリング用音声ダイヤル ピアの設定

H.323シグナリング用音声ポートの設定

番号拡張の設定

設定例

Cisco 827ルータ設定例

Cisco 827-4Vルータ設定

Cisco 827ルータ設定

データ ネットワーク用の企業またはエンドポイント ルータ設定

データおよび音声ネットワーク用の企業またはエンドポイント ルータ設定

ルータ機能の設定

この章では、Cisco 800シリーズおよびCisco SOHOシリーズ ルータの基本設定手順を機能ごとに説明します。この章の記述は、すでに設定されているネットワークに特定の機能を追加する場合に役立ちます。


) 必ずしも記載されているすべての機能がすべてのルータ モデルでサポートされているというわけではありません。機能制限は、できる限り表示してあります。


ネットワークの構成例を使用してネットワークを構築したい場合は、 第4章「ネットワーク シナリオ」 を参照してください。

この章の内容は次のとおりです。

「ネットワークを設定する前に」

「基本的なパラメータの設定」

「ブリッジングの設定」

「スタティック ルーティングの設定」

「ダイナミック ルーティングの設定」

「IP EIGRPの設定」

「アドレス指定パラメータの設定」

「DHCPの設定」

「TACACS+の設定」

「拡張アクセス リストの設定」

「QoSパラメータの設定」

「RFC 1483カプセル化を用いた単一PVC環境の設定」

「ダイヤル バックアップの設定」

「IGMPプロキシおよびsparse(疎)モードの設定」

「IPSecおよびGREトンネリングの設定」

「マルチリンクPPPフラグメンテーションおよびインターリーブの設定」

「音声の設定」

「Cisco 827ルータ設定例」

「データおよび音声ネットワーク用の企業またはエンドポイント ルータ設定」

どのセクションにも、該当するものがある場合には設定例と確認手順が記載されています。

ネットワークを設定する前に

ネットワークを設定する前に、次の作業を行う必要があります。

必要な場合は、電話会社とADSL、G.SHDSL、またはISDN回線契約を結びます。

サービス プロバイダーによって提供されるPVCの数を、そのVirtual Path Identifier(VPI;仮想パス識別子)およびVirtual Channel Identifier(VCI;仮想チャネル識別子)とともに判別します。

PVCごとに、サポートされているAAL5カプセル化のタイプを判別します。次のようなものがあります。

AAL5SNAP:これは、ルーティングされたRFC 1483またはブリッジングされたRFC 1483のいずれかです。ルーティングされたRFC 1483の場合、サービス プロバイダーはスタティックなIPアドレスを提供します。ブリッジングされたRFC 1483の場合、Dynamic Host Configuration Protocol(DHCP)を用いてIPアドレスを入手してもかまいませんし、サービス プロバイダーからスタティックなIPアドレスを提供してもらってもかまいません。

AAL5MUX PPP:このタイプでは、PPP(ポイントツーポイント プロトコル)関連設定項目を判別する必要があります。

インターネット接続を設定している場合、次の情報を集めてください。

ユーザのログイン名として割り当てられたPPPクライアント名

PPP認証のタイプ:Challenge Handshake Authentication Protocol(CHAP)またはPassword Authentication Protocol(PAP)

ISP(インターネット サービス プロバイダー)アカウントにアクセスするためのPPPパスワード

Domain Name System(DNS;ドメイン ネーム システム)サーバのIPアドレスおよびデフォルト ゲートウェイ

企業ネットワークへの接続を設定する場合は、ユーザとネットワーク管理者の間で、ルータのWANインターフェイスに関する次の情報について打ち合わせておく必要があります。

PPP認証のタイプ:CHAPまたはPAP

ルータにアクセスするためのPPPクライアント名

ルータにアクセスするためのPPPパスワード

IPルーティングを設定する場合は、IPネットワークのアドレス指定方式を決定します。

基本的なパラメータの設定

ルータを設定するには、次のセクションで説明する作業を行う必要があります。

グローバル パラメータの設定

イーサネット インターフェイスの設定

ダイヤラ インターフェイスの設定

ループバック インターフェイスの設定

ATMインターフェイスの設定

ルータへのコマンドライン アクセスの設定

作業の後には、ネットワークを設定する方法を図示したコンフィギュレーション ファイル例が記載されます。

ルータが起動した後で、次のプロンプトが表示されます。 no を入力してください。

Would you like to enter the initial configuration dialog [yes]: no
 

グローバル コンフィギュレーション モードにアクセスする手順については「グローバル コンフィギュレーション モードの開始」を参照してください。下記の表で使用されているコマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。

グローバル パラメータの設定

次の手順に従い、ルータのグローバル パラメータを設定します。

 

コマンド
作業

ステップ 1

configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

hostname name

ルータ名を指定します。

ステップ 3

enable secret password

ルータへの無許可アクセスを防ぐための暗号化パスワードを指定します。

ステップ 4

ip subnet-zero

ルータが、ゼロのサブネット範囲を有効なアドレス範囲として認識するように設定します。

ステップ 5

no ip domain-lookup

ルータがコンソール セッション時に入力された未知の語(タイプミス)をIPアドレスに変換できないようにします。

グローバル パラメータ コマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。

イーサネット インターフェイスの設定

イーサネット インターフェイスを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

interface ethernet 0

イーサネット インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

イーサネット インターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 3

no shutdown

イーサネット インターフェイスが、ステートを管理上のダウンからアップに変更するのをイネーブルにします。

ステップ 4

exit

イーサネット インターフェイスのコンフィギュレーション モードを終了します。

イーサネット コマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。イーサネットの概念についての概要は、 第1章「概要」 を参照してください。

設定例

次に、イーサネット インターフェイスの設定例を示します。[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast (default)
!
 

設定の確認

イーサネット インターフェイスが正しく設定されているかどうかを確認するには、show interface ethernet0 コマンドを入力します。確認出力は、次の例のように表示されます。

router#sh int eth0
Ethernet0 is up, line protocol is up
Hardware is PQUICC Ethernet, address is 0000.Oc13.a4db
(bia0010.9181.1281)
Internet address is 170.1.4.101/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255., txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
 

ダイヤラ インターフェイスの設定

ATM PVCにPPPカプセル化を使用している場合は、次のコマンドを使用します。

ダイヤラ インターフェイスを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

interface dialer number

ダイヤラ インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

encapsulation ppp

PVCのカプセル化タイプをPPPに指定します。

ステップ 3

ip address ip-address mask

ダイヤラ インターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 4

dialer pool number

使用しているダイヤラ プール番号を指定します。

ステップ 5

pvc vpi/vci

ルータが通信するエンド ノードごとに、ATM PVCを作成します。

ステップ 6

encapsulation aal5mux ppp dialer

AAL5MUX PPPにカプセル化タイプを指定します。

ステップ 7

dialer pool-member number

ダイヤラ プール番号を指定します。

ステップ 8

dialer-group number

ダイヤラ グループを指定します。ダイヤラ グループは、送信パケットのファスト スイッチングを行うのに必要です。

ステップ 9

exit

ATMインターフェイスのコンフィギュレーション モードを終了します。

設定例

次に、ダイヤラ インターフェイスの設定例を示します。[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
interface atm0
pvc 1/40
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
interface dialer 0
ip address 200.200.100.1 255.255.255.0
encapsulation ppp
dialer pool 1!
 

設定の確認

ダイヤラ インターフェイスが正しく設定されているかどうかを確認するには、 show interface virtual-access 1コマンドを入力します。ライン プロトコルとdialer 0の両方が稼働している必要があります。確認出力は、次の例のように表示されます。

router(config-if)#sh int virtual-access 1
Virtual-Access1 is up, line protocol is up
Hardware is Virtual Access interface
Interface is unnumbered. Using address of Dialer0 (2.2.2.1)
MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set

Virtual-access 1 is upは、インターフェイスが稼働しているという意味です。出力がVirtual-access 1 is downであった場合は、インターフェイスが「管理上ダウン」しているか、またはインターフェイスがシャットダウン コマンドで設定されています。インターフェイスを稼働させるには、no shutdownコマンドを入力します。

ループバック インターフェイスの設定

ここでは、ループバック インターフェイスの設定について説明します。ループバック インターフェイスは、スタティックIPアドレスのプレースホルダとして機能し、デフォルトのルーティング情報を提供します。

ループバック コマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。

設定作業

次の手順で、ループバック インターフェイスを設定します。

 

コマンド
作業

ステップ 1

interface Loopback 0

ループバック インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

ループバック インターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 3

ip nat outside

外部ネットワークに接続するインターフェイスを設定します。

ステップ 4

exit

ループバック インターフェイスのコンフィギュレーション モードを終了します。

設定例

設定例でのループバック インターフェイスは、仮想テンプレート インターフェイス上でNetwork Address Translation(NAT;ネットワーク アドレス変換)をサポートするのに用いられます。このコンフィギュレーション例は、スタティックIPアドレスとなるIPアドレス200.200.100.1/24を持つイーサネット インターフェイスに設定されるループバック インターフェイスを示します。このループバック インターフェイスは、ネゴシエートされたIPアドレスを持つvirtual-template1を指します。

!
interface Loopback0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside
!
 

設定の確認

ループバック インターフェイスが正しく設定されているかどうかを確認するには、show interface loopback 0コマンドを入力します。確認出力は、次の例のように表示されます。

Router #sh int loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 

ループバック インターフェイスを確認するもう1つの方法は、複数のpingパケットをここに送信することです。

Router#ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 

ATMインターフェイスの設定

Asynchronous Transfer Mode(ATM;非同期転送モード)インターフェイスを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。


) ATMインターフェイス設定のためのデフォルト サービス クラスは、Unspecified Bit Rate(UBR;無規定ビット レート)です。サービス クラスは、vbr-nrtまたは vbr-rtいずれかのコマンドを用いてVariable Bit Rate Non-Real Time(VBR-NRT;非リアルタイムの可変ビット レート)またはVariable Bit Rate Real Time(VBR-RT;リアルタイムの可変ビット レート)に変更することができます。Cisco IOS Release 12.0マニュアルを参照してください。サービス クラスの定義の詳細については、第1章「概要」を参照してください。


 

コマンド
作業

ステップ 1

interface ATM 0

ATMインターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

dsl equipment-type { co | cpe }

DSL装置タイプを設定します(該当する場合)。

ステップ 3

dsl linerate { number | auto }

G.SHDSLライン レートを指定します(該当する場合)。有効数字は、72~2312です。

ステップ 4

dsl operating-mode gshdsl symmetric annex annex

G.SHDSLオペレーティング モードを設定し(該当する場合)、G.991.2アネックスを選択します。

ステップ 5

ip address ip-address mask

ATMインターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 6

pvc vpi/vci

ルータが通信するエンド ノードごとのATM PVCを作成します。

ステップ 7

protocol ip ip-address broadcast

IPアドレスのプロトコル ブロードキャストを設定します。

ステップ 8

encapsulation protocol

PVCのカプセル化タイプを指定します。カプセル化は、AAL5SNAP、AAL5MUX IP、またはAAL5MUX PPPのいずれかに指定することができます。1

ステップ 9

tx-ring-limit number

PVC送信キューのサイズを設定します。デフォルト設定値は6です。

ステップ 10

no shutdown

ATMインターフェイスをイネーブルにします。

ステップ 11

exit

ATMインターフェイスのコンフィギュレーション モードを終了します。

1.この手順は任意です。AAL5MUX PPPカプセル化を指定する場合、手順を追加して、dialer-pool member numberコマンドでダイヤラ プールメンバー番号を指定する必要があります。

ATMコマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。ATMの概要については、 第1章「概要」 を参照してください。

AAL5SNAPカプセル化の設定例

次に、AAL5SNAPカプセル化のATMインターフェイスの設定例を示します。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
interface ATM0
ip address 200.200.100.1 255.255.255.0
no ip directed-broadcast (default)
no atm ilmi-keepalive (default)
pvc 8/35
encapsulation aal5snap
protocol ip 200.200.100.254 broadcast
!
 

設定の確認

AAL5SNAPカプセル化ATMインターフェイスが正しく設定されているかどうかを確認するには、show interface atm0コマンドを入力します。確認出力は、次の例のように表示されます。

router#sh int atm0
ATM0 is up, line protocol is up
Hardware is PQUICC_SAR (with Alcatel ADSL Module)
Internet address is 1.1.1.1/24
MTU 1500 bytes, sub MTU 1500, BW 640 Kbit, DLY 80 usec, reliability
113/255. txload 1/255, rxload 1/255
Encapsulation aal5snap, loopback not set
Keepalive not supported
DTR is pulsed for 5 seconds on reset
LCP Closed
 

AAL5MUX PPPカプセル化設定例

次に、AAL5MUX PPPカプセル化のATMインターフェイスの設定例を示します。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
interface ATM0
no ip directed-broadcast (default)
no atm ilmi-keepalive (default)
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!

設定の確認

AAL5MUX PPPカプセル化ATMインターフェイスが正しく設定されているかどうかを確認するには、virtual-access 1コマンドを入力します。確認出力は、次の例のように表示されます。

router#sh int virtual-access 1
Virtual-Access1 is up, line protocol is up
Hardware is Virtual Access interface
Interface is unnumbered. Using address of Dialer0 (2.2.2.1)
MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
 

Virtual-access 1 is upは、インターフェイスが稼働しているという意味です。出力がVirtual-access 1 is downであった場合は、インターフェイスが「管理上ダウン」しているか、またはインターフェイスがシャットダウン コマンドで設定されています。インターフェイスを稼働させるには、no shutdownコマンドを入力します。

ルータへのコマンドライン アクセスの設定

ルータへのアクセスを制御するパラメータを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

line console 0

ライン コンフィギュレーション モードを開始し、コンソール端末ラインを指定します。

ステップ 2

password password

ライン上で固有のパスワードを指定します。

ステップ 3

login

端末セッション ログインでパスワード チェックをイネーブルにします。

ステップ 4

exec-timeout 10 0

EXECコマンド インタープリタがユーザ入力を待機する時間を設定します。exec-timeout 10 0がデフォルトです。

ステップ 5

line vty 0 4

リモート コンソール アクセスの仮想端末を指定します。

ステップ 6

password password

ライン上で固有のパスワードを指定します。

ステップ 7

login

仮想端末セッション ログインでパスワード チェックをイネーブルにします。

ステップ 8

end

ライン コンフィギュレーション モードを終了してイネーブルEXECモードに戻ります。

コマンドライン コマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。

設定例

次の設定は、コマンドライン アクセス コマンドを示すものです。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!

ブリッジングの設定

ブリッジは通常、セグメント間を流れるトラフィックを固有のハードウェア アドレスを使用することによってフィルタするストア アンド フォワード型の装置です。ルータは、純粋なブリッジとして設定することができます。

ブリッジングを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

no ip routing

IPルーティングをディセーブルにします。

ステップ 2

bridge number protocol protocol

Spanning-Tree Protocol(STP;スパニングツリー プロトコル)のタイプを定義するブリッジ プロトコルを指定します。

ステップ 3

interface ethernet 0

イーサネット インターフェイスのコンフィギュレーション モードを開始します。

ステップ 4

bridge-group number

イーサネット インターフェイスが所属するブリッジ グループ番号を指定します。

ステップ 5

no shutdown

イーサネット インターフェイスをイネーブルにします。

ステップ 6

exit

イーサネット インターフェイスおよびルータのコンフィギュレーション モードを終了します。

ステップ 7

interface ATM 0

ATMインターフェイスのコンフィギュレーション モードを開始します。

ステップ 8

dsl equipment-type { co | cpe }

DSL装置タイプを設定します(該当する場合)。

ステップ 9

dsl linerate { number | auto }

G.SHDSLライン レートを指定します(該当する場合)。有効数字は、72~2312です。

ステップ 10

dsl operating-mode gshdsl symmetric annex annex

G.SHDSLオペレーティング モードを設定し(該当する場合)、G.991.2アネックスを選択します。

ステップ 11

pvc vpi/vci

ルータが通信するエンド ノードごとのATM PVCを作成します。

ステップ 12

encapsulation type

PVCのカプセル化タイプを指定します。

ステップ 13

bridge-group number

ATMインターフェイスが所属するブリッジ グループ番号を指定します。

ステップ 14

no shutdown

ATMインターフェイスをイネーブルにします。

ステップ 15

end

ATMインターフェイスのコンフィギュレーション モードを終了します。

ブリッジング コマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。ブリッジングの概要については、 第1章「概要」 を参照してください。

設定例

次の設定例では、AAL5SNAPカプセル化ブリッジングが使用されています。[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

次に、イーサネットおよびATMインターフェイスの設定例を示します。イーサネット インターフェイスは、ブリッジングのためにIPアドレス指定をオフにし、IP指定ブロードキャストをディセーブルにします。これにより、指定ブロードキャストが物理ブロードキャストに変換されるのを防ぎます。ATMインターフェイスが対応づけられているブリッジ グループ番号は1に設定されます。

ATMインターフェイスには8/35のPVCがあり、カプセル化はAAL5SNAPに設定されます。IPアドレスはブリッジングのためディセーブルになり、IP指定ブロードキャストはディセーブルになります。これにより、指定ブロードキャストが物理ブロードキャストに変換されるのを防ぎます。ブリッジ プロトコルはSTPを定義するため1に設定されます。

no ip routing
!
interface Ethernet0
no ip address
no ip directed-broadcast (default)
bridge-group 1
!
interface ATM0
no ip address
no ip directed-broadcast (default)
pvc 8/35
encapsulation aal5snap
!
bridge-group 1
!
ip classless (default)
!
bridge 1 protocol ieee
!
end
 

設定の確認

ブリッジングが正しく設定されているかどうかを確認するには、show spanning-treeコマンドを入力します。確認出力は、次の例のように表示されます。

router#sh spanning-tree
 
Bridge group 1 is executing the IEEE compatible Spanning Tree protocol
Bridge Identifier has priority 32768, address 1205.9356.0000
Configured hello time 2, max age 20, forward delay 15
We are the root of the spanning tree
Port Number size is 9
Topology change flag set, detected flag set
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers:hello 1, topology change 34, notification 0
bridge aging time 15
 
Port 2 (Ethernet0) of Bridge group 1 is forwarding
Port path cost 100, Port priority 128
Designated root has priority 32768, address 1205.9356.0000
Designated bridge has priority 32768, address 1205.9356.0000
Designated port is 2, path cost 0
Timers:message age 0, forward delay 0, hold 0
BPDU:sent 0, received 0
 
Port 3 (ATM0 RFC 1483) of Bridge group 1 is forwarding
Port path cost 1562, Port priority 128
Designated root has priority 32768, address 1205.9356.0000
Designated bridge has priority 32768, address 1205.9356.0000
Designated port is 3, path cost 0
Timers:message age 0, forward delay 0, hold 0
BPDU:sent 0, received 0
 

スタティック ルーティングの設定

スタティック ルートは、ユーザがルータ上で手動で設定するルーティング情報です。ネットワーク トポロジーが変化した場合には、新しいルートを使用してスタティック ルートを更新する必要があります。スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベートなルートです。800シリーズ ルータ上のスタティック ルーティングは、任意で設定することができます。

スタティック ルーティングを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

ip classless

ルータが認識していないネットワークを宛先とするパケット用の最適ルートを設定します。

ステップ 2

ip route network-number mask

IPパケットのスタティック ルートを指定します。

ステップ 3

end

ルータ コンフィギュレーション モードを終了します。

スタティック ルーティング コマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。スタティック ルーティングの概要については、 第1章「概要」 を参照してください。

設定例

次の設定例では、スタティック ルートは、ATMインターフェイス上で宛先1.0.0.0、サブネットマスク255.0.0.0のすべてのIPパケットをIPアドレス14.0.0.1の別の装置へ送信しています。特に、パケットは設定されたPCVへ送信されています。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
ip classless (default)
ip route 1.0.0.0 255.0.0.0 atm0 14.0.0.1
no ip http server (default)
!

設定の確認

スタティック ルーティングが正しく設定されているかどうかを確認するには、show ip routeコマンドを入力し、[S]で表されるスタティック ルートを調べます。

確認出力は、次の例のように表示されます。

router#sh ip route
Codes:C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
 
5* 2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Ethernet0/0
S* 0.0.0.0/0 is directly connected, Ethernet0/0
 

ダイナミック ルーティングの設定

ダイナミック ルーティングでは、ネットワーク プロトコルは、ネットワーク トラフィックまたはネットワーク トポロジーに基づき自動的に経路を調整します。ダイナミック ルーティングの変更は、ネットワーク上の他のルータと共有されます。

IPルーティング プロトコルは、Routing Information Protocol(RIP)またはEnhanced Interior Gateway Routing Protocol(EIGRP)を使用して、動的にルートを学ぶことができます。これらのルーティング プロトコルのうち、どちらか1つを設定できます。

RIPの設定

ルータ上でRIPルーティング プロトコルを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

router rip

ルータ コンフィギュレーション モードを開始し、ルータ上でRIPをイネーブルにします。

ステップ 2

version 2

RIP Version 2を使用することを指定します。

ステップ 3

network network-number

直接接続されたネットワークごとに、ネットワーク番号を指定します。

ステップ 4

no auto-summary

ネットワーク レベル ルートへのサブネット ルートの自動サマライズをディセーブルにします。その結果、サブプレフィクス ルーティング情報がクラスフル ネットワーク境界を超えて伝送されます。

ステップ 5

end

ルータ コンフィギュレーション モードを終了します。

ダイナミック ルーティング コマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。RIPの概要については、 第1章「概要」 を参照してください。

設定例

次に、IPネットワーク10.10.10.0でRIP Version 2をイネーブルにする設定例を示します。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
router rip
version 2
network 10.0.0.0
no auto-summary
!

設定の確認

RIPが正しく設定されているかどうかを確認するには、show ip routeコマンドを入力し、[R]で表されるRIPルートを調べます。確認出力は、次の例のように表示されます。

router#sh ip route
Codes:C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Ethernet0/0
R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0

IP EIGRPの設定

IP EIGRPを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

router eigrp autonomous-system

ルータ コンフィギュレーション モードを開始し、ルータ上でEIGRPをイネーブルにします。Autonomous System(AS;自律システム)番号は、他のEIGRPルータへのルートを表し、EIGRP情報のタグ付けに使用されます。

ステップ 2

network network-number

直接接続されたネットワークごとに、ネットワーク番号を指定します。

ステップ 3

end

ルータ コンフィギュレーション モードを終了します。

IP EIGRPコマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。EIGRPの概要については、 第1章「概要」 を参照してください。

設定例

次に、IPネットワーク10.10.10.0および172.17.0.0でEIGRPルーティング プロトコルをイネーブルにする設定例を示します。EIGRP AS番号は、100に設定しています。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
router eigrp 100
network 10.0.0.0
network 172.17.0.0
!
 

設定の確認

IP EIGRP が正しく設定されているかどうかを確認するには、show ip route コマンドを入力し、[D]で表されるEIGRPルートを調べます。確認出力は、次の例のように表示されます。

router#sh ip route
Codes:C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Ethernet0/0
D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0
 

アドレス指定パラメータの設定

ここでは、NATおよびEasy IPフェーズ1および2を用いてアドレス指定を設定する方法を説明します。

NATの設定

NATを設定してスタティックまたはダイナミック アドレス変換を行うことができます。

スタティックまたはダイナミックな内部ソース変換を設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

ip nat pool name start-ip end-ip { netmask netmask | prefix-length prefix-length }

NATに使用するグローバルIPアドレスのプールを作成します。

ステップ 2

access-list access-list-number permit source [ source-wildcard ]

変換が必要なアドレスを許可する標準アクセス リストを定義します。

ステップ 3

ip nat inside source list access-list-number pool name

アクセス リストで許可されたアドレスを、指定したプール内のいずれかのアドレスにダイナミックに変換できるようにします。

ステップ 4

ip nat inside source static local-ip global-ip number extendable

指定した内部ローカル アドレスを、グローバルで固有のIPアドレスにスタティックに変換できるようにします。このコマンドは任意です。

ステップ 5

interface ethernet 0

イーサネット インターフェイスのコンフィギュレーション モードを開始します。

ステップ 6

ip nat inside

イーサネット インターフェイスを内部インターフェイスとして設定します。

ステップ 7

exit

イーサネット インターフェイスのコンフィギュレーション モードを終了します。

ステップ 8

interface atm 0

ATMインターフェイスのコンフィギュレーション モードを開始します。

ステップ 9

dsl equipment-type { co | cpe }

適用可能な場合は、DSL装置タイプを設定します(該当する場合)。

ステップ 10

dsl linerate { number | auto }

G.SHDSLライン レートを指定します(該当する場合)。有効数字は、72~2312です。

ステップ 11

dsl operating-mode gshdsl symmetric annex annex

G.SHDSLオペレーティング モードを設定し(該当する場合)、G.991.2アネックスを選択します。

ステップ 12

ip nat outside

ATMインターフェイスを外部インターフェイスとして設定します。

ステップ 13

exit

ATMインターフェイスのコンフィギュレーション モードを終了します。


) NATを仮想テンプレート インターフェイスで使用する場合には、ループバック インターフェイスを設定する必要があります。


NATコマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。NATの概要については、 第1章「概要」 を参照してください。

設定例

次に、イーサネット インターフェイスおよびATMインターフェイスに設定されるNATの設定例を示します。

Ethernet 0インターフェイスのIPアドレスは192.168.1.1であり、サブネット マスクは255.255.255.0です。このインターフェイスは、NAT変換の対象になる内部ネットワークに接続しているので、NATはinsideとして設定します。

ATM 0インターフェイスのIPアドレスは200.200.100.1であり、サブネット マスクは255.255.255.0です。このインターフェイスは、インターネットなどの外部ネットワークに接続しているので、NATはoutsideとして設定しています。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast (default)
ip nat inside
!
interface ATM0
ip address 200.200.100.1 255.255.255.0
no ip directed-broadcast (default)
ip nat outside
no atm ilmi-keepalive (default)
pvc 8/35
encapsulation aal5snap
!
ip route 0.0.0.0.0.0.0.0 200.200.100.254
!
ip nat pool test 200.200.100.1 200.200.100.1 netmask 255.255.255.0
ip nat inside source list 101 pool test overload
ip classless (default)
!
 

設定の確認

NATが正しく設定されているかどうかを確認するには、show ip nat statisticsコマンドを入力します。確認出力は、次の例のように表示されます。

router#sh ip nat statistics
Total active translations:45 (10 static, 35 dynamic; 45 extended)
Outside interfaces:
ATM0
Inside interfaces:
Ethernet0
Hits:34897598 Misses:44367
Expired translations:119305
Dynamic mappings:
-- Inside Source
access-list 1 pool homenet refcount 14
pool homenet:netmask 255.255.255.0
start 200.200.100.1 end 200.200.100.1
type generic, total addresses 1, allocated 1 (100%), misses

Easy IP(フェーズ1)の設定

ここでは、Easy IP(フェーズ1)の設定方法を説明します。Easy IP(フェーズ1)には、NAT過負荷およびPPP/Internet Protocol Control Protocol(IPCP)が含まれます。NAT過負荷を設定すると、インターフェイスに1つの登録済みIPアドレスを使用することができ、そのアドレスを使用してネットワーク上のすべての装置からインターネットにアクセスすることができます。

PPP/IPCPを使用すると、Cisco 800シリーズ ルータはISPルートからのインターフェイス用に、グローバルで一意の(登録済みまたはパブリック)IPアドレスを自動的にネゴシエートします。

Easy IP(フェーズ1)を設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

access-list access-list-number permit source [ source-wildcard ]

ホストの未登録IPアドレスを許可する標準アクセス リストを定義します。

ステップ 2

ip nat inside source list access-list-number interface interface overload

ステップ1で定義されたアクセス リストによって識別されるアドレスの変換を設定します。

ステップ 3

interface ethernet 0

イーサネット インターフェイスのコンフィギュレーション モードを開始します。

ステップ 4

ip nat inside

イーサネット インターフェイスをNAT用内部インターフェイスとして設定します。

ステップ 5

no shutdown

イーサネット インターフェイスおよびこのインターフェイスに加えられた設定変更をイネーブルにします。

ステップ 6

exit

イーサネット インターフェイスのコンフィギュレーション モードを終了します。

ステップ 7

interface dialer

ダイヤラ インターフェイスのコンフィギュレーション モードを開始します。

ステップ 8

ip address negotiated

ネゴシエートされたIPアドレスをダイヤラ インターフェイスに割り当てます。

ステップ 9

ip nat outside

ダイヤラ インターフェイスをNAT用外部インターフェイスとして設定します。

ステップ 10

dialer pool number

使用しているダイヤラ プール番号を指定します。

ステップ 11

exit

ダイヤラ インターフェイスを終了します。

ステップ 12

interface ATM 0

ATMインターフェイスのコンフィギュレーション モードを開始します。

ステップ 13

dsl equipment-type { co | cpe }

DSL装置タイプを設定します(該当する場合)。

ステップ 14

dsl linerate { number | auto }

G.SHDSLライン レートを指定します(該当する場合)。有効数字は、72~2312です。

ステップ 15

dsl operating-mode gshdsl symmetric annex annex

G.SHDSLオペレーティング モードを設定し(該当する場合)、G.991.2アネックスを選択します。

ステップ 16

pvc vpi/vci

ルータが通信するエンド ノードごとのATM PVCを作成します。

ステップ 17

encapsulation aal5mux ppp dialer

PVCのカプセル化タイプをAAL5MUX PPPと指定し、ダイヤラ インターフェイスを指すようにします。

ステップ 18

dialer pool-member number

使用しているダイヤラ プールメンバーを指定します。

ステップ 19

no shutdown

ATMインターフェイスに対して行われたインターフェイスおよび設定の変更をイネーブルにします。

ステップ 20

exit

ATMインターフェイスのコンフィギュレーション モードを終了します。

Easy IPコマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。Easy IP(フェーズ1)の概要については、 第1章「概要」 を参照してください。

Easy IP(フェーズ2)の設定

ここでは、Cisco 800シリーズ ルータをDHCPサーバとして設定する方法を説明します。

Easy IP(フェーズ2)機能は、DHCPサーバとリレーを結合しています。DHCPを使用すると、IPネットワーク上のLAN装置(DHCPクライアント)がDHCPサーバにIPアドレスを要求できます。DHCPサーバは必要に応じて、中央のプールからIPアドレスを割り当てます。DHCPサーバは、ワークステーション、PC、またはシスコ ルータとして設定できます。ルータにDHCPリレー機能を設定すると、図 7-1に示すように、ルータは、LANインターフェイスからDHCPサーバにIPアドレス要求をリレーできます。

図 7-1 Easy IP(フェーズ2) ― DHCPサーバおよびリレー

 

 

図中の番号
説明
1

DHCPクライアント

2

Cisco 827ルータのあるリモート オフィス

3

DHCPリレー

4

Cisco 3600ルータのある本社オフィス

5

DHCPサーバ

DHCPの設定

ここでは、ルータをDHCPクライアント、サーバ、またはリレーとして設定する方法を説明します。

DHCPクライアント サポートの設定

DHCPクライアント サポート用ルータの設定を行うには、次の作業を行います。


ステップ 1 ip address dhcp client-id Ethernet 0コマンドを入力して、BVIインターフェイスを設定します。

client-id ethernet0 という値を指定すると、DHCP要求が送信された場合に、イーサネット インターフェイスのMAC(メディア アクセス制御)アドレスが、クライアントIDとして使用されます。そうでない場合は、BVIインターフェイスのMACアドレスがクライアントIDとして使用されます。

ステップ 2 NATを設定します。

a. ip nat outsideコマンドを入力してBVIインターフェイスを設定します。

b. ip nat insideコマンドを入力してイーサネット インターフェイスを設定します。

c. access-list 1 permit ip addressコマンドを入力してNAT下にアクセス リストを作成し、すべてのイーサネットIPアドレスとのマッチングを行います。

d. ip nat inside source list 1 interface BVI 1 overloadコマンドを入力して、NAT下のソース リストを設定します。

ステップ 3 DHCPサーバとして機能するシスコ ルータを設定します。この手順は任意です。

a. config-ifルータ プロンプトに対して、ip dhcp pool server name コマンドを入力します。

b. import allコマンドを入力して、シスコ ルータに名前解決のためのMicrosoft Windows Nameserver(WINS;Windowsネームサーバ)およびDomain Name System(DNS;ドメイン ネーム システム)サーバ アドレスを検索させます。


 

設定例

次に、DHCPクライアントの設定例を示します。

 
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c827
!
!
ip subnet-zero
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool SERVER
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
import all
!
bridge irb
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface ATM0
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
bundle-enable
hold-queue 208 in
!
interface ATM0.1 point-to-point
no ip directed-broadcast
pvc 1/100
encapsulation aal5snap
!
bridge-group 1
!
interface ATM0.2 point-to-point
ip address 5.0.0.2 255.0.0.0
no ip directed-broadcast
pvc 1/101
protocol ip 5.0.0.1 broadcast
protocol ip 5.0.0.5 broadcast
encapsulation aal5snap
!
!
interface BVI1
ip address dhcp client-id Ethernet0
no ip directed-broadcast
ip nat outside
!
ip nat inside source list 1 interface BVI1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 BVI1
no ip http server
!
access-list 1 permit 10.10.10.0 0.0.0.255
bridge 1 protocol ieee
bridge 1 route ip
!
voice-port 1
timing hookflash-in 0
!
voice-port 2
timing hookflash-in 0
!
voice-port 3
timing hookflash-in 0
!
voice-port 4
timing hookflash-in 0
!
!
line con 0
exec-timeout 0 0
transport input none
stopbits 1
line vty 0 4
password lab
login
!
scheduler max-task-time 5000
end
 

DHCPサーバの設定

ルータをDHCPサーバとして設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

ip dhcp pool name

DHCPコンフィギュレーション モードを開始して、DHCPクライアントに割り当てることのできるIPアドレスのプールを作成します。

ステップ 2

network ip-address subnet-mask

DHCPクライアントに割り当てることのできるIPアドレスの範囲を指定します。

ステップ 3

domain-name domain name

ドメイン名を設定します。

ステップ 4

dns-server ip-address

デフォルト ルータとしてルータを指定し、IPアドレスを指定します。

ステップ 5

netbios-name-server ip-address

NetBIOSネーム サーバを設定します。

ステップ 6

default-router ip-address

DNSサーバを設定します。

ステップ 7

lease days hours minutes

リース期間を指定します。

ステップ 8

exit

DHCPコンフィギュレーション モードを終了します。

この設定で使用されない機能の詳細については、『 Cisco IOS DHCP Server』 フィーチャ モジュールを参照してください。DHCPサーバの概要については、 第1章「概要」 を参照してください。

設定例

次の設定は、IPアドレス20.1.1.2のDHCPサーバ設定を示したものです。

!
ip dhcp pool CLIENT
network 20.20.20.0 255.255.255.0
domain-name cisco.com
default-router 20.20.20.20
netbios-name-server 1.1.1.1
dns-server 1.1.1.2
lease 0 1
!

設定の確認

DHCPサーバが正しく設定されているかどうかを確認するには、show dhcp serverコマンドを入力して、割り当てられたサーバIPを調べます。確認出力は、次の例のように表示されます。

router# sh dhcp server
show ip dhcp binding
show ip dhcp conflict
show ip dhcp server statics
 

DHCPリレーの設定

ここでは、DHCPクライアントからIPアドレス要求を含めUDPブロードキャストを転送するよう、ルータを設定する方法を示します。

DHCPリレーを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

interface Ethernet 0

イーサネット インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip helper-address address

IP設定要求を含むデフォルトUDPブロードキャストをDHCPサーバに転送します。

ステップ 3

no shutdown

イーサネット インターフェイスおよび設定変更をイネーブルにします。

ステップ 4

exit

イーサネット インターフェイスのコンフィギュレーション モードを終了します。

DHCPリレー コマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。DHCPリレーの概要については、 第1章「概要」 を参照してください。

設定例

次の設定には、DHCPリレーだけに関係するコマンドが含まれています。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
int Ethernet0
ip address 192.168.100.1 255.255.255.0
ip helper-address 200.200.200.1
!
 

設定の確認

DHCPリレーが正しく設定されているかどうかを確認するには、show dhcp serverコマンドを入力します。確認出力は、次の例のように表示されます。

router#sh dhcp server
DHCP server:2.2.2.2
Leases: 0
Offers: 0 Requests:0 Acks:0 Naks:0
Declines:0 Releases:0 Bad: 0
 

TACACS+の設定

Cisco 806、827、831、836、837、827H、827-4VルータおよびCisco SOHO 71、91、96、97ルータは、Telnetを経由してTerminal Access Controller Access Control System Plus(TACACS+)プロトコルをサポートしています。TACACS+は、リモート アクセス認証およびイベント ロギングなどの関連ネットワーク セキュリティ サービスを提供するシスコ独自の認証プロトコルです。ユーザ パスワードは、個々のルータではなく中央のデータベースで管理されます。TACACS+はまた、個々のルータで設定される別のモジュラAuthentication, Authorization,
Accounting(AAA;認証、許可、アカウンティング)機能をサポートします。

ルータがTACACS+をサポートするようにするには、次の作業を行います。

 

コマンド
作業

ステップ 1

aaa new-model

グローバル コンフィギュレーション コマンドを入力して、AAAをイネーブルにします。AAAは、TACACS+を使用するよう設定する必要があります。

ステップ 2

tacacs-server host

1つまたは複数のTACACS+デーモンのIPアドレスを指定します。

ステップ 3

tacacs-server key

Network Access Server(NAS)およびTACACS+デーモン間のすべての交換を暗号化するのに使用される暗号鍵を指定します。これと同じ鍵をTACACS+デーモンでも設定する必要があります。

ステップ 4

aaa authentication

TACACS+認証方式のリストを定義します。

ステップ 5

line

定義した認証方式リストを各種インターフェイスに適用します。

TACACS+接続についてアカウンティングをイネーブルにする場合は、その他の設定手順を行う必要がある場合があります。TACACS+の詳しい設定手順については、『Security Configuration Guide』を参照してください。

拡張アクセス リストの設定

ルータの設定に1つまたは複数の拡張アクセス リストを含めるには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

access-list 100 permit tcp any ip ip address-mask established

ネットワーク上の任意のホストが、任意のインターネット サーバにアクセスできるようにします。

ステップ 2

access-list 100 deny ip ip adddress-mask any

任意のインターネット ホストが、ネットワーク上のホストをスプーフィングすることを禁止します。

ステップ 3

access-list 100 permit tcp host ip address-mask

インターネットDNSサーバが、ネットワーク上の任意のホストにTCP返信を送信することを許可します。

ステップ 4

access-list 100 permit udp host ip address-mask

インターネットDNSサーバが、ネットワーク上の任意のホストにUDP返信を送信するのを許可します。

ステップ 5

access-list 100 permit tcp any host ip address

SMTPメール サーバが任意のインターネット サーバにアクセスするのを許可します。

ステップ 6

access-list 100 permit tcp any host ip address

Webサーバが任意のインターネット サーバにアクセスするのを許可します。

ステップ 7

access-list 100 permit tcp any host ip address

FTPサーバが任意のインターネット サーバにアクセスするのを許可します。

ステップ 8

access-list 100 deny tcp any ip address-mask

インターネット ホストが、ネットワーク上の任意のホストにTelnet接続を行うことを制限します。

ステップ 9

interface atm 0

ATMインターフェイスのコンフィギュレーション モードを開始します。

ステップ 10

dsl equipment-type co/cpe

DSL装置タイプを設定します(該当する場合) 。

ステップ 11

dsl linerate number/auto

G.SHDSLライン レートを指定します(該当する場合)。有効数字は、72~2312です。

ステップ 12

dsl operating-mode gshdsl symmetric annex annex

G.SHDSLオペレーティング モードを設定し(該当する場合)、G.991.2アネックスを選択します。

ステップ 13

ip access-group 100 in

アクセス リスト100をアクティブにします。

ステップ 14

no shutdown

インターフェイスに対して行われたインターフェイスおよび設定の変更をイネーブルにします。

ステップ 15

exit

ATMインターフェイスのコンフィギュレーション モードを終了します。

拡張アクセス リスト コマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。TCPポートおよびUDPポートの割り当てについては、 付録C「共通ポート割り当て」 を参照してください。

設定例

この設定は、IPアドレス192.168.1.0に対して適用されるアクセス リストを表示しています。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
access-list 101 permit tcp any host 192.168.1.0 0.0.0.255
!
 

QoSパラメータの設定

ここでは、Quality of Service(QoS;サービス品質)パラメータの設定方法を説明します。音声QoSの要件は次のとおりです。

音声トラフィックのプライオリティ キューイング

大きなデータ パケットの分割および音声パケットのインターリーブ

QoSは単一PVCまたは複数PVC環境で設定することができます。単一PVC環境では、トラフィックは、Class-Based Weighted Fair Queuing(CBWFQ;クラス ベース均等化キューイング)を用いて音声トラフィックの優先順位を付け、MTUサイズを小さくしてデータ パケットのレイヤ3分割を行うプライオリティ キューイングを提供するIOSに依存します。複数PVC環境では、トラフィックは音声のプライオリティ キューイングおよびフラグメンテーションとインターリーブを提供するATMインターフェイスに依存します。


) QoSパラメータがサポートされるのは、音声機能を持つルータに限ります。


QoSコマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。QoSの概要については、 第1章「概要」 を参照してください。

単一PVC環境の設定

単一PVC環境では、トラフィックは(CBWFQを用いて)プライオリティ キューイングを提供するIOSに依存します。この作業では、次のように単一PVC環境を設定します。

音声パケットについてはIP precedence 5を設定します。

アクセス リストおよび音声クラスを設定します。

ポリシー マップを設定し、音声クラスのプライオリティ キューイングを指定します。

ポリシー マップをATM PVCと対応づけ、ATMインターフェイスのMTUを減少させます。

IP precedenceの設定

IP precedenceは、音声パケットにIPデータ トラフィックよりも高いプライオリティを与えます。ルータは、 ip precedence コマンドを使用して、音声トラフィックとデータ トラフィックを区別します。したがって、データIPパケットが音声パケットと同じIP precedenceを持たないことを確認する必要があります。

リアルタイム音声トラフィックに他のIPネットワーク トラフィックよりも高い優先順位を与えるよう設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

dial-peer voice number voip

ダイヤル ピア コンフィギュレーション モードを開始して、VoIPダイヤル ピアを設定します。

ステップ 2

destination-pattern number

宛先パターンを設定します。

ステップ 3

session target { ipv4 : destination-address }

ダイヤル ピアの宛先IPを指定します。

ステップ 4

ip precedence number

当該ダイヤル ピアと対応づけられた音声トラフィックの優先レベルを選択します。

ステップ 5

exit

ダイヤル ピア インターフェイスのコンフィギュレーション モードを終了します。


) IP precedenceでは、1~5の番号でIPフローのクラスが識別され、6~7の番号がネットワークとバックボーン ルーティングおよび更新に使用されます。IP precedence 5を音声パケットに使用することを推奨します。


アクセス リストおよび音声クラスの設定

ポリシー マップを作成して、プライオリティ キューを音声クラスと対応づけるには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

access-list 101 permit ip any any precedence 5

音声パケットのマッチングを行うためのアクセス リストを設定します。

ステップ 2

class-map voice

音声クラスを設定します。

ステップ 3

match access-group 101

音声クラスをアクセス リストと対応づけます。

ポリシー マップの設定および音声キューイングの指定

ポリシー マップを設定して、音声キューイングを指定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

policy map name

ポリシー マップを設定します。2

ステップ 2

class voice

キューイングのクラスを指定します。

ステップ 3

priority number

キューイングのプライオリティを指定します。

2.ポリシー マップの全帯域幅は全PVC帯域幅の75%を超えないようにしてください。

ポリシー マップの設定および音声クラスのプライオリティ キューイングの指定

ポリシー マップをATM PVCに対応づけて、ATMインターフェイスのMTUを低減して大きなデータ パケットを分割するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

policy map name

ポリシー マップを設定します。3

ステップ 2

class voice

キューイングのクラスを指定します。

ステップ 3

priority bandwidth

キューイングのプライオリティを指定します。

ステップ 4

exit

ポリシー マップのコンフィギュレーション モードを終了します。

3.ポリシー マップの全帯域幅は全PVC帯域幅の75%を超えないようにしてください。

ポリシー マップのATM PVCとの対応づけおよびATMインターフェイスのMTUの低減

ポリシー マップをATM PVCに対応づけてATMを低減するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。MTUサイズには300を使用することを推奨します。様々なコーデックによって生成される音声パケットのサイズより大きくなるためです。


) ATMインターフェイス設定のためのデフォルト サービス クラスは、UBRです。ポリシー マップをATM PVCに添付するには、vbr-nrtまたはvbr-rtのサービス クラスを使用する必要があります。


 

コマンド
作業

ステップ 1

interface ATM 0

ATMインターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

ATMインターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 3

pvc vpi/vci

ルータが通信するエンド ノードごとのATM PVCを作成します。

ステップ 4

encapsulation protocol

PVCのカプセル化タイプを指定します。カプセル化は、AAL5SNAPまたはAAL5MUX PPPのいずれかに指定することができます。

ステップ 5

service policy out name

サービス ポリシー名を対応づけます。

ステップ 6

vbr-rt pcr scr bs

サービス クラスを指定します。

ステップ 7

exit

ATM PVCのコンフィギュレーション モードを終了します。

ステップ 8

mtu number

ATMインターフェイスのMTUを指定します。

ステップ 9

no shutdown

ATMインターフェイスをイネーブルにします。

ステップ 10

exit

ATMインターフェイスのコンフィギュレーション モードを終了します。

設定例

次に、AAL5SNAPカプセル化を用いた単一PVC環境での音声QoSの設定例を示します。

!
dial-peer voice 105 voip
destination-pattern 3..
session target ipv4:10.1.2.3
ip precedence 5
 
access-list 101 permit ip any any precedence critical
 
class-map voice
match access-group 101
 
policy-map mypolicy
class voice
priority 480
 
int atm0
mtu 300
pvc 8/35
encapsulation aal5snap
service-policy out mypolicy
vbr-rt 640 640 10
!
 

RFC 1483カプセル化を用いた単一PVC環境の設定

ここでは、RFC 1483を用いた単一PVC環境の設定について説明します。

RFC 1483カプセル化を用いた単一PVC環境では、トラフィックはLow Latency Queuing(LLQ;低遅延キューイング)を用いたプライオリティ キューイングを提供するCisco IOSに依存します。単一PVC環境を設定するには、次に作業が必要です。

データ パケットと音声パケットの区別

アクセス リストおよび音声クラスの設定

ポリシー マップの設定および音声キューイングの指定

ポリシー マップのATM PVCとの対応づけおよびTCP MSS調整の使用

PVC ATM送信リング バッファのサイズの微調整

データ パケットと音声パケットの区別

音声パケットにプライオリティを与えるには、ルータは着信する音声パケットとデータ パケットを区別する必要があります。パケットを区別する1つの方法は、送信元または宛先IPアドレスを調べることです。なぜなら、データおよびVoice over IP(VoIP)装置には異なったIPアドレスがあるかもしれないためです。

パケットを区別するもう1つの方法は、IP precedenceを使用することです。通常、データ パケットには優先順位0があり、音声パケットにはIP precedence 5があります。音声パケットのIP precedenceを知る方法については、ご使用のVoIP装置のマニュアルを参照してください。


) IP precedenceでは、1~5の番号でIPフローのクラスが識別され、6~7の番号がネットワークとバックボーン ルーティングおよび更新に使用されます。IP precedence 5を音声パケットに使用することを推奨します。


アクセス リストおよび音声クラスの設定

すべての音声パケットが優先順位5であり、すべてのデータ パケットが優先順位0であると仮定した場合に、すべての優先順位5のパケットと一致するアクセス リストを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

access-list 101 permit ip any any precedence

音声パケットのマッチングを行うためのアクセス リストを設定します。

ステップ 2

class-map voice

音声クラスを設定します。

ステップ 3

match access-group 101

音声クラスをアクセス リストと対応づけます。

ポリシー マップの設定および音声キューイングの指定

ポリシー マップを設定して、音声キューイングを指定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

policy map name

ポリシー マップを設定します。4

ステップ 2

class voice

キューイングのクラスを指定します。

ステップ 3

priority bandwidth

この厳密なプライオリティ キューの帯域幅を指定します。

4.ポリシー マップの全帯域幅は全PVC帯域幅の75%を超えないようにしてください。

ポリシー マップのATM PVCとの対応づけおよびTCP MSS調整の使用

ポリシー マップをATM PVCと対応づけ、TCP MSS adjustコマンドで遅延を制御するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。


) ATMインターフェイス設定のためのデフォルト サービス クラスは、UBRです。ポリシー マップをATM PVCに添付するには、vbr(nrt)またはvbr(rt)のサービス クラスを使用する必要があります。


 

コマンド
作業

ステップ 1

interface ATM 0

ATMインターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

dsl equipment-type {co | cpe}

DSL装置タイプを設定します。

ステップ 3

dsl linerate {number| auto}

ADSLライン レートを指定します。有効数字は、72~2312です。

ステップ 4

ip address ip-address mask

ATMインターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 5

pvc vpi/vci

ルータが通信するエンド ノードごとのATM PVCを作成します。

ステップ 6

encapsulation protocol

PVCのカプセル化タイプを指定します。カプセル化は、AAL5SNAPまたはAAL5MUX PPPのいずれかに指定することができます。

ステップ 7

service policy out name

サービス ポリシー名を対応づけます。

ステップ 8

vbr-rt pcr scr bs

サービス クラスを指定します。

ステップ 9

exit

ATM PVCのコンフィギュレーション モードを終了します。

ステップ 10

ip tcp adjust-mss mss

TCP Maximum Segment Size(MSS;最大セグメント サイズ)を指定します。

ステップ 11

no shutdown

ATMインターフェイスをイネーブルにします。

ステップ 12

exit

ATMインターフェイスのコンフィギュレーション モードを終了します。

PVC ATM送信リング バッファのサイズの微調整

各PVCには、パケットをトランシーバに送信する前に一時的に格納するハードウェア出力First-in first-out(FIFO;先入れ先出し)キューがあります。音声パケットの遅延を低減するため、このキューのサイズを小さくする必要があります。キューのサイズを小さくすると、送信キュー内で音声パケットの「前」になるデータ パケットの最大数が減ります。ただし、送信キュー サイズが小さすぎると、送信スループット パフォーマンスが低下します。

設定例

次に、AAL5SNAPカプセル化を用いた単一PVC環境での音声QoSの設定例を示します。

access-list 101 permit ip any any precedence critical
 
class-map voice
match access-group 101
 
policy-map mypolicy
class voice
priority 480
 
int atm0
dsl equipment-type CPE
dsl linerate AUTO
ip tcp-mss 1452
pvc 8/35
encapsulation aaal5snap
service-policy out mypolicy
vbr-rt 1000 1000 1
tx-ring-limit 5
!
 

PPP over ATMおよびマルチリンク カプセル化を用いた単一PVC環境の設定

ここでは、PPP over ATMおよびマルチリンク カプセル化を用いた単一PVC環境の設定について説明します。

「LLQでのリンク フラグメンテーションおよびインターリーブの設定」には、2つめの単一PVC環境のマルチリンクでのPPPフラグメンテーションおよびインターリーブの設定について記載されています。

PPP over ATMマルチリンク カプセル化を用いた単一PVC環境では、トラフィックはLLQを用いたプライオリティ キューイングを提供するCisco IOSに依存します。単一PVC環境の設定には以下の作業が含まれます。

データ パケットと音声パケットの区別

ポリシー マップの設定および音声キューイングの指定

ポリシー マップのATM PVCへの対応づけ

LLQでのリンク フラグメンテーションおよびインターリーブの設定

データ パケットと音声パケットの区別

音声パケットにプライオリティを与えるには、ルータは着信する音声パケットとデータ パケットを区別する必要があります。パケットを区別する1つの方法は、送信元または宛先IPアドレスを調べることです。なぜなら、データおよびVoIP装置には異なったIPアドレスがあるかもしれないためです。

パケットを区別するもう1つの方法は、IP precedenceを使用することです。通常、データ パケットには優先順位0があり、音声パケットにはIP precedence 5があります。音声パケットのIP precedenceを知る方法については、ご使用のVoIP装置のマニュアルを参照してください。


) IP precedenceでは、1~5の番号でIPフローのクラスが識別され、6~7の番号がネットワークとバックボーン ルーティングおよび更新に使用されます。IP precedence 5を音声パケットに使用することを推奨します。


ポリシー マップの設定および音声キューイングの指定

ポリシー マップを設定して、音声キューイングを指定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

policy map name

ポリシー マップを設定します。5

ステップ 2

class voice

キューイングのクラスを指定します。

ステップ 3

priority bandwidth

この厳密なプライオリティ キューの帯域幅を指定します。

5.ポリシー マップの全帯域幅は全PVC帯域幅の75%を超えないようにしてください。

ポリシー マップのATM PVCへの対応づけ

ポリシー マップをATM PVCへ対応づけるには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

interface ATM 0

ATMインターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

dsl equipment-type {co | cpe}

DSL装置タイプを設定します。

ステップ 3

dsl linerate {number| auto}

ADSLライン レートを指定します。有効数字は、72~2312です。

ステップ 4

ip address ip-address mask

ATMインターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 5

pvc vpi/vci

ルータが通信するエンド ノードごとのATM PVCを作成します。

ステップ 6

encapsulation protocol

PVCのカプセル化タイプを指定します。カプセル化は、AAL5SNAPまたはAAL5MUX PPPのいずれかに指定することができます。

ステップ 7

service policy out name

サービス ポリシー名を対応づけます。

ステップ 8

vbr-rt pcr scr bs

サービス クラスを指定します。

ステップ 9

exit

ATM PVCのコンフィギュレーション モードを終了します。

LLQでのリンク フラグメンテーションおよびインターリーブの設定

マルチリンクPPP over ATMを使用している場合は、Link Fragmentation and Interleaving(LFI;リンク フラグメンテーションおよびインターリーブ)が利用できます。

同じリンクで次の2種類のトラフィックを同時に送信することができます。

重くて遅延に敏感でないトラフィック送信元からの大きなパケット

遅延に敏感なトラフィック送信元からの小さなパケット

LFIの目的は、遅延に敏感なトラフィックの遅延を低減することです。LFIを使用すると次の2つのことが起こります。

遅延に敏感でない送信元から受信した大きなパケットは分割されます。

遅延に敏感な送信元から受信した小さなパケットは、大きなパケットのフラグメントにインターリーブされます。

マルチリンクPPPは、LFI実行方法の一例です。

ルータにLFIを設定するには次の作業を行います。グローバル コンフィギュレーション モードで開始します。

 

コマンド
作業

ステップ 1

bandwidth bandwidth-kpts

ダイヤラ帯域幅を設定します。ダイヤラ インターフェイスで設定された帯域幅は、その割り当てられたPVCの帯域幅と同じである必要があります。

ステップ 2

ppp multilink

PPPマルチリンクをイネーブルにします。

ステップ 3

ppp multilink interleave

PPPマルチリンク インターリーブを指定します。

ステップ 4

ppp multilink fragment-delay milliseconds

分割遅延を定義します。

ステップ 5

access-list access-list-number {permit | deny} address mask precedence number

アクセス リストを作成します。

ステップ 6

class-map match-all voice

クラス マップを作成します。

ステップ 7

match access-group number

クラス マップをアクセス リストにリンクします。

ステップ 8

policy-map name

ポリシー マップを作成します。

ステップ 9

class name

クラスを定義します。

ステップ 10

priority number

プライオリティ帯域幅をトラフィックに割り当てます。

ステップ 11

interface dialer number

ダイヤラ ロータリ グループを定義します。

ステップ 12

service-policy {input | output} policy-map

サービス ポリシーを作成します。

次の公式でフラグメント サイズを計算します。

フラグメント サイズ=(kbps単位の帯域幅/8)* ミリ秒(ms)単位のフラグメント遅延

この場合、フラグメント サイズ=(640/8)* 10 = 800です。フラグメント サイズは、G.711、20msの最大音声パケット サイズである200より大きくなります。低フラグメント遅延は、フラグメント サイズに対応しますが、音声パケット サイズよりも小さい場合があるため、音声品質が低下することに注意してください。


) LFIは、1 Mbpsを超えるリンクがある場合には使用しないでください。これほど高速なリンクでは、大きなパケットの送信に伴う遅延はとても小さいため、LFIの利点がそれほど生かされないためです。LFIを使用すると遅延が実際には大きくなる場合があります。パケットを分割するための余分な処理時間がボトルネックとなるためです。


複数PVC環境の設定

複数PVC環境では、トラフィックは音声のプライオリティ キューイングおよびフラグメンテーションとインターリーブを提供するATMインターフェイスに依存します。次に、使用できる設定について説明します。

異なったサブネット上の音声およびデータ

図 7-2に異なったサブネット上の音声およびデータ パケットを示します。すべての音声トラフィックは、vbr-rtサービス クラスのATM PVC上にあり、すべてのデータ トラフィックは、ubrサービス クラスのATM PVCで伝送されます。

図 7-2 異なったサブネット上の音声とデータ

 

ATMインターフェイスおよびサブインターフェイスの設定

ATMインターフェイスおよびサブインターフェイスを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

interface ATM 0.1 point-to-point

ATM0.1サブインターフェイスを指定します。

ステップ 2

ip address ip-address mask

ATM0.1サブインターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 3

pvc vpi/vci

ルータが通信するエンド ノードごとのATM PVCを作成します。

ステップ 4

encapsulation type

PVCのカプセル化タイプを指定します。

ステップ 5

protocol ip address broadcast

IPアドレスのプロトコル ブロードキャストを設定します。

ステップ 6

interface ATM 0.2 point-to-point

ATM0.2サブインターフェイスを指定します。

ステップ 7

ip address ip-address mask

ATM0.2サブインターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 8

pvc vpi/vci

ルータが通信するエンド ノードごとのATM PVCを作成します。

ステップ 9

encapsulation type

PVCのカプセル化タイプを指定します。

ステップ 10

protocol ip address broadcast

IPアドレスのプロトコル ブロードキャストを設定します。

ステップ 11

exit

ATMインターフェイスのコンフィギュレーション モードを終了します。

設定例

次に、30.0.0.1ネットワーク上にすべてのデータ トラフィックがあり、20.0.0.1ネットワークにすべての音声トラフィックがある音声QoSの設定例を示します。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
interface ATM0.1 point-to-point
ip address 20.0.0.1 255.0.0.0
no ip directed-broadcast (default)
pvc 1/100
protocol ip 20.0.0.2 broadcast
vbr-rt 424 424 5
encapsulation aal5snap
!
interface ATM0.2 point-to-point
ip address 30.0.0.1 255.0.0.0
no ip directed-broadcast (default)
pvc 1/101
protocol ip 30.0.0.2 broadcast
encapsulation aal5snap

VCバンドリングを用いた同じサブネット上の音声およびデータ

に、Virtual Circuit(VC;仮想回線)バンドリングを用いた同じサブネット上の音声パケットおよびデータ パケットを示します。VCバンドリングを利用すると同じバンドル上に複数のPVCを置くことができます。VCバンドリングを使用し、優先順位5を音声パケットに割り当て、データ パケットにはこれを割り当てないと、2つのトラフィックは確実に2つのPVCに分離されます。

図 7-3 VCバンドリングを用いた同じサブネット上の音声およびデータ

 

 

図中の番号
説明
1

Ethernet 0

2

バンドル

3

PVCバンドル1/40 BVR(RT)、音声

4

PVCバンドル8/35 UBR、データ

VCバンドリングで同じサブネット上に音声ネットワークおよびデータ ネットワークを設定する作業は次のとおりです。

ATMインターフェイスの設定

音声用PVCバンドルの設定

データ用PVCバンドルの設定

音声パケットのIP precedenceの設定

ATMインターフェイス、音声およびデータ用PVCバンドル、および音声パケット用IP precedenceの設定

ATMインターフェイス、 音声およびデータ用PVCバンドル、および 音声パケット用IP precedenceを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

interface ATM 0

ATMインターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

dsl equipment-type co/cpe

DSL装置タイプを設定します。

ステップ 3

dsl linerate number/auto

G.SHDSLライン レートを指定します。有効数字は、72~2312です。

ステップ 4

dsl operating-mode gshdsl symmetric annex annex

G.SHDSLオペレーティング モードを設定し、G.991.2アネックスを選択します。

ステップ 5

ip address ip-address mask

ATMインターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 6

bundle name

バンドル名を指定します。

ステップ 7

encapsulation type

音声バンドルPVCのカプセル化タイプを指定します。

ステップ 8

protocol ip ip-address broadcast

IPアドレスのプロトコル ブロードキャストを設定します。

ステップ 9

pvc-bundle name vpi/vci

音声バンドル用PVCを作成します。

ステップ 10

vbr-rt pcr scr bs

音声バンドルのサービス クラスを設定します。6

ステップ 11

ip precedence number

作成した音声バンドル特定のIP precedenceレベルを選択します。

ステップ 12

pvc-bundle name vpi/vci

データ バンドル用PVCを作成します。

ステップ 13

ubr pcr

データ7 バンドルのサービス クラスを設定します。

ステップ 14

precedence other

IP precedenceレベルotherを、作成したデータ バンドルに設定します。

ステップ 15

exit

ATMインターフェイスのコンフィギュレーション モードを終了します。

6.音声については、サービス クラスはvbr-rtまたはvbr-nrtに設定してください。

7.データについては、サービス クラスはvbr-nrtまたはubrに設定してください。

音声ネットワークのIP precedenceおよびサービス クラスの指定

リアルタイム音声トラフィックに他のIPネットワーク トラフィックよりも高い優先順位を与えるよう設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

dial-peer voice number voip

ダイヤル ピア コンフィギュレーション モードを開始してVoIPダイヤル ピアを設定します。

ステップ 2

destination-pattern number

宛先パターンを設定します。

ステップ 3

session target { ipv4 : destination-address }

ダイヤル ピアの宛先IPアドレスを指定します。

ステップ 4

precedence number

当該ダイヤル ピアと対応づけられた音声トラフィックの優先レベルを選択します。


) IP precedenceでは、1~5の番号でIPフローのクラスが識別され、6~7の番号がネットワークとバックボーン ルーティングおよび更新に使用されます。IP precedence 5を音声パケットに使用することを推奨します。


設定例

次に、VCバンドリングによる同じサブネット上の音声およびデータの設定例を示します。トラフィックを2つの異なったATM PVCに分離できるよう、IP precedence 5は音声パケットに対して設定されていますが、データ パケットには設定されていません。

!
interface atm0
ip address 20.0.0.1 255.0.0.0
bundle test
encapsulation aal5snap
protocol ip 20.0.0.2 broadcast
!
pvc-bundle voice 1/100
vbr-rt 424 424 5
precedence 5
!
pvc-bundle data 1/101
precedence other
!
 
dial-peer voice 100 voip
destination-pattern 26..
session target ipv4:20.0.0.8
ip precedence 5
!

ダイヤル バックアップの設定

プライマリ回線がダウンしたとき、プライマリ回線上のトラフィック負荷が定義されたスレッシュホールドを超えた場合、またはその両方が発生した場合にバックアップ インターフェイスを起動するかどうかを決定する必要があります。実行する作業は、どのような決定をするかによって異なります。ダイヤル バックアップを設定するには、次のセクションに記載された作業を行います。

バックアップ インターフェイスの指定 (必須)

バックアップ回線遅延の定義 (任意)

トラフィック負荷スレッシュホールドの定義 (任意)

次にDial-on-Demand Routing(DDR;ダイヤル オンデマンド ルーティング)のバックアップ インターフェイスを設定して、必要に応じて電話がかけられるようにします。

バックアップ インターフェイスの指定

プライマリWANインターフェイスまたはサブインターフェイスのバックアップ インターフェイスを指定するには、backup interface type numberコマンドを入力してバックアップ インターフェイスを選択します。


) ダイヤル バックアップ用BRI(基本インターフェイス)を使用する場合、インターフェイスがスタンバイ モードの間はどのBチャネルも使用することはできません。さらに、BRIがバックアップ インターフェイスとして使用され、BRIがレガシーDDR用に設定されている場合、使用できるBチャネルは1つだけです。いったんバックアップが1つのBチャネルで開始されると、2番目のBチャネルは使用できなくなります。バックアップ インターフェイスをダイヤラ プロファイル用に設定した場合、両方のBチャネルを使用することができます。


IOSで利用できるダイヤル バックアップ機構の詳細については、次のURLを参照してください。

http://www.cisco.com/warp/public/123/backup-main.html

バックアップ回線遅延の定義

プライマリ回線のステータスが変化した後でセカンダリ回線のステータスが変化するまでの経過時間を定義する値を設定することができます。2つの遅延を定義することができます。

プライマリ回線はダウンしたが、セカンダリ回線はまだ起動されていない期間に適用される遅延

プライマリ回線は活動化したが、セカンダリ回線がまだ停止していない期間に適用される遅延

これらの遅延を定義するには、次の構文を使用します。

Router (config-if) # backup delay {enable-delay | never} {disable-delay | never}

トラフィック負荷スレッシュホールドの定義

プライマリ回線のトラフィック負荷に基づきセカンダリ回線を起動するためのダイヤル バックアップを設定することができます。ソフトウェアは、トラフィック負荷をモニタし、5分の移動平均を計算します。この平均が、回線に対して設定された値を超えた場合、セカンダリ回線が起動され、回線の設定方法によっては、トラフィックの一部または全部がセカンダリ ダイヤルアップ回線に流れ込みます。

追加接続がプライマリWANインターフェイスに追加される、トラフィックの負荷レベルを設定することができます。負荷レベルの範囲は、1(負荷なし)~255(フル負荷)です。

WAN回線スレッシュホールドを定義するには、次の構文を使用します。

Router (config-if) # dialer load-threshold 8 outbound {enable-threshold | never} {disable-threshold | never}

コンソール ポートを用いたダイヤル バックアップ

次に、DDR用に設定されたコンソール ポートを用いたダイヤル バックアップ例を示します。

interface atm 0
ip address 172.30.3.4 255.255.255.0
backup interface async1
backup delay 10 10
!
interface async 1
ip address 172.30.3.5 255.255.255.0
dialer in-band
dialer string 5551212
dialer-group 1
async dynamic routing
dialer list 1 protocol ip permit
chat-script sillyman “““atdt 5551212” TIMEOUT 60 “CONNECT”
line aux 0
modem chat-script sillyman
modem inout
speed 9600

設定例

次に、コンソール ポートおよびダイヤラ ウォッチを用いたCisco 831およびCisco 837ルータでのダイヤル バックアップおよびリモート ルータ管理の設定例を示します。

!
username Router password !PASSWORD
!
modemcap entry MY_USR_MODEM:MSC=&F1S0=1
!
chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT 5555102\T" TIMEOUT 60 CONNECT \c
!
interface Async1
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 3
autodetect encapsulation ppp
async default routing
async dynamic routing
async mode dedicated
pap authentication pap callin
!
! Dialer3 is for dial backup and remote router management
!
interface Dialer3
ip address negotiated
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 3
dialer remote-name !REMOTE-NAME
dialer idle-timeout 300
dialer string 5555102 modem-script Dialout
dialer watch-group 1
dialer-group 1
autodetect encapsulation ppp
peer default ip address 192.168.2.2
no cdp enable
ppp pap sent-username ! USER SPECIFIC password ! USER SPECIFIC
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! IP NAT over Dialer interface using route-map
ip nat inside source route-map main interface Dialer1 overload
ip nat inside source route-map secondary interface Dialer3 overload
ip classless
ip route 0.0.0.0 0.0.0.0 !(dial backup peer address @ISP)
ip route 0.0.0.0 0.0.0.0 Dialer1 150
!
no ip http server
ip pim bidir-enable
!
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
dialer watch-list 1 ip !(ATM peer address @ISP) 255.255.255.255
dialer-list 1 protocol ip permit
!
! To direct traffic to an interface only if the Dialer gets assigned with an ip address
route-map main permit 10
match ip address 101
match interface Dialer1
!
route-map secondary permit 10
match ip address 101
match interface Dialer3
!
line con 0
exec-timeout 0 0
modem enable
stopbits 1
line aux 0
exec-timeout 0 0
script dialer Dialout
modem InOut
modem autoconfigure type MY_USR_MODEM
transport input all
stopbits 1
speed 38400
flowcontrol hardware
line vty 0 4
exec-timeout 0 0
login local
!
 

次に、Cisco SOHO 91およびCisco SOHO 97ルータ用のコンソール ポートを用いたリモート管理の設定例を示します。

!
username Router password !PASSWORD
!
modemcap entry MY_USR_MODEM:MSC=&F1S0=1
!
interface Async1
no ip address
encapsulation ppp
dialer in-band
autodetect encapsulation ppp
async default routing
async dynamic routing
async mode dedicated
pap authentication pap callin
peer default ip address pool clientpool
!
! dialer 1 used for PPPoE or PPPoATM
! PPPoE or PPPoATM dialer1 configurations are not shown in this sample
!
ip route 0.0.0.0 0.0.0.0 dialer 1 150
!
dialer list 1 protocol ip permit
!
ip local pool clientpool 192.168.0.2 192.168.0.10
!
line con 0
exec-timeout 0 0
modem enable
stopbits 1
line aux 0
exec-timeout 0 0
modem Dialin
modem autoconfigure type MY_USER_MODEM
transport input all
stopbits 1
speed 38400
flowcontrol hardware
to align with line aux 0
exec-timeout 0 0
login local
!
 

設定例

次に、ISDN S/Tポートおよびダイヤラ ウォッチを用いたCisco 836ルータでのダイヤル バックアップおよびリモート管理の設定例を示します。

Cisco836#
!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
!
!Specifies the ISDN switch type
isdn switch-type basic-net3
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
hold-queue 100 out
!
!ISDN interface to be used as a backup interface
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 1/40
encapsulation aal5snap
pppoe-client dial-pool-number 2
!
dsl operating-mode auto
!
! Dial backup interface, associated with physical BRI0 interface. Dialer pool 1 associates it with BRI0’s dialer pool member 1. Note “dialer watch-group 1” associates a watch list with corresponding “dialer watch-list” command
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 30
dialer string 384040
dialer watch-group 1
dialer-group 1
!
! Primary interface associated with physical ATM0 interface, dialer pool 2 associates it with ATM0’s dial-pool-number2
interface Dialer2
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 2
dialer-group 2
no cdp enable
!
ip classless
 
!Primary and backup interface given route metric
ip route 0.0.0.0 0.0.0.0 22.0.0.2
ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
ip http server
!
!Watch for interesting traffic
dialer watch-list 1 ip 22.0.0.2 255.255.255.255
 
!Specifies interesting traffic to trigger backup ISDN traffic
dialer-list 1 protocol ip permit
!

IGMPプロキシおよびsparse(疎)モードの設定

Internet Group Management Protocol(IGMP)プロキシ機能は、単一方向リンク ルーティング機能に追加され、直接下りルータに接続されていないホストが、上りネットワークからのマルチキャスト グループに参加できるようにします。

IGMPプロキシおよびsparse(疎)モードを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

ip multicast-routing

IPマルチキャスト転送をイネーブルにします。

ステップ 2

ip pim rp-address address

Protocol Independent Multicast(PIM;プロトコル独立マルチキャスト)rendezvous point(RP;ランデブー ポイント)アドレスを設定します。

ステップ 3

interface ethernet 0

Ethernet 0インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address subnet-mask

Ethernet 0インターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 5

ip pim { sparse |dense }-mode

PIM sparse(疎)モードまたはPIM dense(密)モードのEthernet 0インターフェイスを設定します。

ステップ 6

interface Ethernet 1

Ethernet 1コンフィギュレーション モードを開始します。

ステップ 7

ip address { ip-address subnet-mask negotiated}

ダイヤラ インターフェイスのIPアドレスおよびサブネット マスクを指定します。またはIPアドレスをネゴシエートすべきであることを指定します。

ステップ 8

ip pim { sparse | dense} - mode

PIM sparse(疎)モードまたはPIM dense(密)モードのダイヤラ インターフェイスを設定します。

ステップ 9

ip igmp mroute-proxy loopback 0

ip igmp proxy-serviceコマンドとともに使用されると、このコマンドはIGMPのマルチキャスト転送テーブルのすべての転送エントリをイネーブルにして、プロキシ サービス インターフェイスに通知します。

ステップ 10

end

ルータ コンフィギュレーション モードを終了します。

ステップ 11

interface loopback 0

ループバック インターフェイス コンフィギュレーション モードを開始します。

ステップ 12

ip address ip-address subnet-mask

loopback 0インターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 13

ip pim sparse-mode

PIM sparse(疎)モードまたはPIM dense(密)モードのループバック インターフェイスを設定します。

ステップ 14

ip igmp helper-address udl ethernet 0

Ethernet 0へのIGMPヘルパー アドレス単一方向リンクを入力します。

ステップ 15

ip igmp proxy-service

マルチキャスト ルート プロキシ サービスをイネーブルにします。IGMPクエリ間隔に基づき、ルータは定期的にip igmp mroute-proxyコマンドで設定されたインターフェイスと一致する転送エントリのマルチキャスト ルーティング テーブルをチェックします。一致するものがある場合、IGMPレポートが1つ作成され、インターフェイスで受信されます。このコマンドは、IGMPレポートを上りルータに転送するip igmp helper-address udlコマンドとともに使用されることが想定されています。

設定例

次に、関連するIGMPプロキシおよびsparse(疎)モード コマンドの例を示します。Ethernet 0、Ethernet 1、およびloopback 0インターフェイスは、PIM sparse(疎)モードに設定され、PIM RPアドレスは10.5.1.1と定義されています。

ip pim rp-address 10.5.1.1 5
access-list 5 permit 239.0.0.0 255.255.255.255
!
interface loopback 0
ip address 10.7.1.1 255.255.255.0
ip pim sparse-mode
ip igmp helper-address udl ethernet 0
ip igmp proxy-service
!
interface ethernet 0
ip address 10.2.1.2 255.255.255.0
ip pim sparse-mode
ip igmp unidirectional link
!
interface ethernet 1
ip address 10.5.1.1 255.255.255.0
ip pim sparse-mode
ip igmp mroute-proxy loopback 0
!
 

設定の確認

show ip igmp interface ethernet 0マルチキャスティング コマンドにより、設定を確認することができます。確認出力は、次の例のように表示されます。

router#show ip igmp interface ethernet 0
Ethernet0 is up, line protocol is up
Internet address is 10.2.1.2 255.255.255.0
IGMP is enabled on interface
Current IGMP host version is 2
Current IGMP router version is 2
IGMP query interval is 60 seconds
IGMP querier timeout is 120 seconds
IGMP max query response time is 10 seconds
Last member query response interval is 1000 ms
Inbound IGMP access group is not set
IGMP activity: 1 joins, 0 leaves
Multicast routing is enabled on interface
Multicast designated router (DR) is 10.2.1.2 (this system)
IGMP querying router is 10.2.1.2 (this system)
Multicast groups joined (number of users):
224.0.1.40 (1)

IPSecおよびGREトンネリングの設定

IP Security(IPSec)は、2つのルータなど2つのピア間にセキュア トンネルを提供します。どのパケットが敏感であると考えられ、セキュア トンネルを経由して送信する必要があるのかを定義することができます。また、このトンネルの特性を指定することにより、これらの敏感なパケットを保護するために使用するパラメータを定義することができます。IPSecピアは敏感なパケットを見つけたら、適切なセキュア トンネルを設定し、そのトンネルを使用してパケットをリモート ピアに送信します。

ここでは、次のことについて説明します。

インターネット プロトコル パラメータの設定

アクセス リストの設定

IPSecの設定

GREトンネル インターフェイスの設定

イーサネット インターフェイスの設定

スタティック ルートの設定

高速クリプトの設定およびモニタ

設定例

ここでは、IPSecおよびGeneric Routing Encapsulation(GRE;総称ルーティング カプセル化) トンネリングの両方の設定について説明します。GREトンネルを用いてIPSを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

一般的なIPSecの設定については、次のURLを参照してください。

www.cisco.com/warp/public/707/index.shtml#ipsec

インターネット プロトコル パラメータの設定

IPパラメータを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

ip subnet-zero

ルータが、ゼロのサブネット範囲を有効なアドレス範囲として認識するように設定します。

ステップ 2

no ip finger

着信IPフィンガ パケットをブロックします。

ステップ 3

no ip domain-lookup

コンソール セッション中にホスト名として入力された未知の単語(入力ミス)をルータが解析しないようにします。

ステップ 4

ip classless

クラスレス ルーティングの転送ルールに従います。

アクセス リストの設定

access-list コマンドを使用してアクセス リストを作成し、GREプロトコルを許可し、GREトンネルの開始および終了IPアドレスを指定します。次の構文を使用します。

access-list 101 permit gre host ip-address host ip-address

上記のコマンド行で、最初の host ip-address はトンネルの開始ポイントを表し、2番目の host ip-address はトンネルの終了ポイントを表します。

IPSecの設定

IPSecを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

crypto isakmp policy 10

Internet Key Exchange(IKE)ポリシーを定義し、そのポリシーにプライオリティを割り当てます。このコマンドによって、ルータはIKEポリシー コンフィギュレーション モードになります。

ステップ 2

hash md5

ポリシーにmd5ハッシュ アルゴリズムを指定します。

ステップ 3

authentication pre-share

認証方式として事前共有鍵を指定します。

ステップ 4

exit

IKEポリシー コンフィギュレーション モードを終了します。

ステップ 5

crypto isakmp key name address ip-address

各VPNクライアントに、事前共有鍵およびスタティックIPアドレスを設定します。

ステップ 6

crypto ipsec transform-set name esp-des esp-md5-hmac

IPSecネゴシエート時に発生するセキュリティ アソシエーションの組み合わせを定義します。

ステップ 7

crypto map name local-address ethernet 1

クリプトマップを作成し、そのクリプトマップがIPSecトラフィックに使用するインターフェイスを指定および命名します。

ステップ 8

crypto map name seq-num ipsec-isakmp

クリプトマップ コンフィギュレーション モードを開始し、IPSec ISAKMPモードでクリプトマップ エントリを作成します。

ステップ 9

set peer ip-address

リモートIPSecピアを特定します。

ステップ 10

set transform-set name

使用するトランスフォーム セットを指定します。

ステップ 11

match address access-list-id

クリプトマップ エントリの拡張アクセス リストを指定します。

ステップ 12

exit

クリプトマップ コンフィギュレーション モードを終了します。

GREトンネル インターフェイスの設定

GREトンネル インターフェイスを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

interface tunnel 0

Tunnel 0インターフェイスを設定します。

ステップ 2

ip address ip-address subnet-mask

Tunnel 0インターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 3

tunnel source ethernet 1

Ethernet 1インターフェイスをトンネル送信元として指定します。

ステップ 4

tunnel destination default-gateway-ip-address

デフォルト ゲートウェイをトンネル宛先として指定します。

ステップ 5

crypto map name

設定済みのクリプトマップをTunnel 0インターフェイスに対応づけます。

ステップ 6

exit

Tunnel 0インターフェイスの設定を終了します。

イーサネット インターフェイスの設定

Ethernet 0およびEthernet 1インターフェイスを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

interface ethernet 0

Ethernet 0インターフェイスを設定します。

ステップ 2

ip address ip-address subnet-mask

Ethernet 0インターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 3

exit

Ethernet 0インターフェイスの設定を終了します。

ステップ 4

interface ethernet 1

Ethernet 1インターフェイスを設定します。

ステップ 5

ip address ip-address subnet-mask

Ethernet 1インターフェイスのIPアドレスおよびサブネット マスクを設定します。

ステップ 6

crypto map name

Ethernet 1インターフェイスにクリプトマップを対応づけます。

ステップ 7

end

ルータ コンフィギュレーション モードを終了します。

スタティック ルートの設定

スタティック ルートを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

ip route default-gateway-ip-address mask ethernet 1

Ethernet 1インターフェイスのスタティック ルートを作成します。

ステップ 2

ip route default-gateway-ip-address mask tunnel 0

Tunnel 0インターフェイスのスタティック ルートを作成します。

ステップ 3

ip route default-gateway-ip-address mask gateway-of-last-resort

ラスト リゾートのゲートウェイへのスタティック ルートを作成します。

ステップ 4

end

ルータ コンフィギュレーション モードを終了します。

高速クリプトの設定およびモニタ

高速クリプトをイネーブルにするには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

crypto engine accelerator
 

高速クリプトをディセーブルにするには、次のコマンドを使用します。

no crypto engine accelerator
 

高速クリプトをモニタするには、次のコマンドを使用します。

show crypto engine accelerator statistic
 

IPSec設定の詳細については、『Cisco IOS Security Configuration Guide』を参照してください。

設定例

次のCisco 831ルータの設定例では、IPSecがGREトンネルで使用されています。この例はまた、Cisco SOHO 91ルータにも適用されます。[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 831-uut1
!
memory-size iomem 10
!
ip subnet-zero
!
ip audit notify log
ip audit po max-events 100
!
crypto isakmp policy 1
encr 3des
authentication pre-share
crypto isakmp key grel address 100.1.1.1
!
crypto ipsec security-association lifetime seconds 86400
!
crypto ipsec transform-set strong esp-3des esp-sha-hmac
!
crypto map mymap local-address Ethernet1
crypto may mymap 1 ipsec-isakmp
set peer 100.1.1.1
set transform-set strong
match address 151
!
!
!
!
interface Tunnel0
ip address 1.1.1.1 255.255.255.0
tunnel source Ethernet1
tunnel destination 100.1.1.1
crypto map mymap
!
interface Ethernet0
ip address 202.2.2.2 255.255.255.0
hold-queue 100 out
!
interface Ethernet1
ip address 100.1.1.1 255.255.255.0
crypto map mymap
!
ip classless
ip route 200.1.1.0 255.255.255.0 Tunnel0
ip http server
!
!
access-list 151 permit gre host 100.1.1.2 host 100.1.1.1
!
line con 0
no modem enable
stopbits 1
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
 

次に、Cisco 837ルータでのIPSec設定例を示します。

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 837-uutl
!
memory-size iomem 10
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
ip audit notify log
ip audit po max-events 100
ip ssh time-out 120
ip ssh authentication-retries 3
!
crypto isakmp policy 1
encr 3des
authentication pre-share
crypto isakmp key grel address 100.1.1.1
!
crypto ipsec transform-set strong esp-3des esp-sha-hmac
!
crypto map mymap local-address ATM0
crypto map mymap 1 ipsec-isakmp
set peer 100.1.1.1
set transform-set strong
match address 151
!
interface Tunnel0
ip address 1.1.1.1 255.255.255.0
ip mtu 1440
tunnel source ATM0
tunnel destination 100.1.1.1
crypto map mymap
!
interface Ethernet0
ip address 202.2.2.2 255.255.255.0
hold-queue 100 out
!
interface ATM0
ip address 100.1.1.2 255.255.255.0
no atm ilmi-keepalive
pvc 1/40
protocol ip 100.1.1.1 broadcast
encapsulation aa15snap
!
dsl operating-mode auto
crypto map mymap
!
ip classless
ip route 200.1.1.0 255.255.255.0 Tunnel0
ip http server
ip pim bidir-enable

マルチリンクPPPフラグメンテーションおよびインターリーブの設定

PPPカプセル化を使用したポイントツーポイント接続を行う場合、またはお使いのネットワークよりも低速のリンクがある場合には、マルチリンクPPPフラグメンテーションを設定する必要があります。

インターリーブのPPPサポートは、ダイヤラ インターフェイス上で設定することができます。

ダイヤラ インターフェイス上でマルチリンクPPPおよびインターリーブを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

interface dialer

ダイヤラ インターフェイスのコンフィギュレーション モードを開始します。

ステップ 2

ppp multilink

ダイヤラ インターフェイスのマルチリンクPPPをイネーブルにします。

ステップ 3

bandwidth n

ダイヤラ インターフェイスを使用しているPVCと対応づけられた帯域幅番号を指定します。ここで、nはダイヤラ インターフェイスを使用しているPVCのSustained Cell Rate(SCR;平均セル レート)の値です。この値を指定しないと、特定のサービス クラスを設定した場合にダイヤラ インターフェイスは100 kbpsの値を想定してしまうため、このコマンドは重要です。

ステップ 4

ppp multilink interleave

マルチリンクPPPバンドル上の大きなパケットのフラグメント間でRTPパケットのインターリーブをイネーブルにします。

ステップ 5

ppp multilink fragment-delay milliseconds

フラグメントの最大遅延時間を20ミリ秒に設定します。このコマンドは任意です。

ステップ 6

ip rtp reserve lowest-UDP-port range-of-ports [ maximum-bandwidth ]

特定の宛先UDPポートへのリアルタイム パケット フローに特殊キューを予約し、リアルタイム トラフィックに他のフローより高いプライオリティが与えられるようにします。

ステップ 7

exit

ダイヤラ インターフェイスのコンフィギュレーション モードを終了します。

PPPフラグメンテーションおよびインターリーブ コマンドの詳細については、『 Dial Solutions Configuration Guide』 Cisco IOS Release 12.0T を参照してください。 PPPフラグメンテーションおよびインターリーブの概要については、 第1章「概要」 を参照してください。

設定例

つぎの設定は、インターリーブを行うマルチリンクPPPおよび20ミリ秒の最大リアルタイム トラフィック遅延をイネーブルにするダイヤラ インターフェイスを定義したものです。カプセル化タイプは、aal5muxと定義されます。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
interface dialer 1
ppp multilink
encapsulated ppp
ppp multilink interleave
bandwidth 640
ppp multilink fragment-delay 20
ip rtp reserve 16384 100 64
!
interface ATM0
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1

設定の確認

PPPフラグメンテーションおよびインターリーブが正しく設定されているかどうかを確認するには、debug ppp multilink fragmentコマンドを入力し、1500バイトのpingパケットを1つ送信します。デバッグ メッセージには、送信されているフラグメントについての情報が表示されます。

IP precedenceの設定

IP precedenceは、音声パケットに他のIPデータ トラフィックよりも高いプライオリティを与えます。リアルタイム音声トラフィックに他のIPネットワーク トラフィックよりも高い優先順位を与えるよう設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

dial-peer voice number voip

ダイヤル ピア コンフィギュレーション モードを開始してVoIPダイヤル ピアを設定します。

ステップ 3

destination-pattern number

宛先パターンを設定します。

ステップ 4

ip precedence number

当該ダイヤル ピアと対応づけられた音声トラフィックの優先レベルを選択します。


) IP precedenceでは、1~5の番号でIPフローのクラスが識別され、6~7の番号がネットワークとバックボーン ルーティングおよび更新に使用されます。


IP precedenceコマンドの詳細については、CiscoIOS Release 12.0マニュアルを参照してください。IP precedenceの概要については、 第1章「概要」 を参照してください。

設定例

次に、設定されたIP precedenceでの音声の設定例を示します。IP宛先ターゲットは、8ダイヤル桁に設定され、IP precedenceはシスコ ルータ上で自動的に5に設定されます。ダイヤル ピア セッション ターゲットはRegistration, Admission, and Status protocol(RAS)です。これは、H.323音声プロトコル ゲートウェイとゲートキーパとの間で実行されるプロトコルです。

[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
access-list 101 permit
route-map data permit 10
set ip precedence routing
!

音声の設定

 

コマンド
作業

ステップ 1

configure dial-peer

ダイヤル ピアのコンフィギュレーション モードを開始します。

ステップ 2

dial-peer voice number voip

ダイヤル ピア音声番号を割り当てて、VoIPダイヤル ピアを設定します。

Cisco 827音声対応ルータは、H.323シグナリング プロトコルをデフォルトのシグナリング プロトコルとして使用する音声をサポートします。

あらかじめ必要な作業

お使いのルータで音声を処理する場合には、次の作業が必要です。

有効なIPネットワークを確立します。

会社のダイヤル プランを作成します。

会社のダイヤル プランに基づいて有効なテレフォニー ネットワークを確立します。

ダイヤル プランとテレフォニー ネットワークを既存のIPネットワーク トポロジーに組み込みます。

H.323シグナリング用音声の設定

ここでは、音声ポート上でH.323シグナリング用ルータを設定するのに必要な作業を説明します。

POTSダイヤル ピアの設定

Plain Old Telephone Service(POTS;加入電話サービス)ダイヤル ピアを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

dial-peer voice number POTS

ダイヤル ピアのコンフィギュレーション モードを開始します。

ステップ 2

destination-pattern string

VoIPダイヤル ピアと対応づけられる宛先電話番号を定義します。

ステップ 3

port number

ポート番号を指定します。

H.323シグナリング用音声ダイヤル ピアの設定

H.323シグナリング用音声ダイヤル ピアを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

dial-peer voice number VoIP

ダイヤル ピアのコンフィギュレーション モードを開始します。

ステップ 2

destination-pattern string

各VoIPダイヤル ピアと対応づけられる宛先電話番号を定義します。

ステップ 3

codec string

g.729のデフォルト コーデックを使用していない場合は、コーデックを指定します。

ステップ 4

session target { ipv4 : destination-address }

各ダイヤル ピアの宛先IPアドレスを指定します。

H.323シグナリング用音声ポートの設定

米国では音声ポート設定は自動で行われるはずですが、米国外で音声ポートを設定するには、グローバル コンフィギュレーション モードから始めて、次の作業を行います。

 

コマンド
作業

ステップ 1

configure dial-peer

ダイヤル ピアのコンフィギュレーション モードを開始します。

ステップ 2

voice-port port

設定したい音声ポートを識別し、音声ポート コンフィギュレーション モードを開始します。

ステップ 3

cptone country

そのインターフェイスに適した音声コール プログレス トーンを選択します。このコマンドのデフォルト国は、usです。

ステップ 4

ring frequency(25 \ 50)

この音声ポートに接続されている装置に適合し、使用国に該当するリング周波数(Hz)を選択します。

ステップ 5

description string

この音声ポート接続について記述するテキストを追加します。

ステップ 6

comfort-noise

VAD(音声アクティビティ検出)がアクティブになっている場合は、背景雑音が生成されるように指定します。

ステップ 7

impedance

POTSポートに差し込まれた装置の電気特性に関連するインピーダンスを指定します。インピーダンスはオームで測定されます。

ダイヤル ピア コマンドの詳細については、Cisco IOS Release 12.0 マニュアルを参照してください。ダイヤル ピアの概要については、 第1章「概要」 を参照してください。

番号拡張の設定

ここでは、内線番号を特定の宛先パターンに拡張する方法を説明します。次のグローバル コンフィギュレーション コマンドを用いて、内線番号を拡張します。

Router(config)# num-exp extension-number extension-string
 

電話番号が正しくマッピングされたかどうかを確認するには、 show num-exp コマンドを入力します。

ダイヤル ピアを設定し、宛先パターンをそこに割り当てた後で、 show dialplan number コマンドを入力して、電話番号がどのようにダイヤル ピアにマッピングされているのかを確かめます。

番号拡張コマンドの詳細については、Cisco IOS Release 12.0マニュアルを参照してください。

設定例

次に、音声トラフィックの設定例を示します。[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

!
class-map voice
match access-group 101
!
policy-map mypolicy
class voice
priority 128
class class-default
fair-queue 16
!
ip subnet-zero
!
gateway
!
interface Ethernet0
ip address 20.20.20.20 255.255.255.0
no ip directed-broadcast (default)
ip route-cache policy
ip policy route-map data
!
interface ATM0
ip address 10.10.10.20 255.255.255.0
no ip directed-broadcast (default)
no atm ilmi-keepalive (default)
pvc 1/40
service-policy output mypolicy
protocol ip 10.10.10.36 broadcast
vbr-nrt 640 600 4
! 640 is the maximum upstream rate of ADSL
encapsulation aal5snap
!
bundle-enable
h323-gateway voip interface
h323-gateway voip id gk-twister ipaddr 172.17.1.1 1719
h323-gateway voip h323-id gw-820
h323-gateway voip tech-prefix 1#
!
router eigrp 100
network 10.0.0.0
network 20.0.0.0
!
ip classless (default)
no ip http server
!
access-list 101 permit ip any any precedence critical
route-map data permit 10
set ip precedence routine
!
!
line con 0
exec-timeout 0 0
transport input none
stopbits 1
line vty 0 4
login
!
!
voice-port 1
local-alerting
timeouts call-disconnect 0
!
voice-port 2
local-alerting
timeouts call-disconnect 0
!
voice-port 3
local-alerting
timeouts call-disconnect 0
!
voice-port 4
local-alerting
timeouts call-disconnect 0
!
dial-peer voice 10 voip
destination-pattern........
ip precedence 5
session target ras
!
dial-peer voice 1 pots
destination-pattern 5258111
port 1
!
dial-peer voice 2 pots
destination-pattern 5258222
port 2
!
dial-peer voice 3 pots
destination-pattern 5258333
port 3
!
dial-peer voice 4 pots
destination-pattern 5258444
port 4
!
end
 

Cisco 827ルータ設定例

次の設定例を示します。

Cisco 827-4Vルータ設定

Cisco 827ルータ設定

データ ネットワーク用の企業またはエンドポイント ルータ設定

データおよび音声ネットワーク用の企業またはエンドポイント ルータ設定

これらの設定は、あくまでも例です。実際のルータ設定は、ネットワークにより異なったものとなるはずです。

Cisco 827-4Vルータ設定

次に示すのは、H.323シグナリング音声トラフィック用に設定されたCisco 827-4Vルータの設定です。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

ip subnet-zero
!
bridge crb
!
interface Ethernet0
no ip address
no ip directed-broadcast
bridge-group 1
!
interface ATM0
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
bundle-enable
!
interface ATM0.1 point-to-point
ip address 1.0.0.1 255.255.255.0
no ip directed-broadcast
pvc voice 1/40
protocol ip 1.0.0.2 broadcast
encapsulation aal5snap
!
!
interface ATM0.2 point-to-point
no ip address
no ip directed-broadcast
pvc data 1/41
encapsulation aal5snap
!
bridge-group 1
!
ip classless
!
bridge 1 protocol ieee
!
voice-port 1
local-alerting
timeouts call-disconnect 0
!
voice-port 2
local-alerting
timeouts call-disconnect 0
!
voice-port 3
local-alerting
timeouts call-disconnect 0
!
voice-port 4
local-alerting
timeouts call-disconnect 0
!
dial-peer voice 101 pots
destination-pattern 14085271111
port 1
!
dial-peer voice 1100 voip
destination-pattern 12123451111
codec g711ulaw
session target ipv4:1.0.0.2
!
dial-peer voice 102 pots
destination-pattern 14085272222
port 2
!
dial-peer voice 1200 voip
destination-pattern 12123452222
codec g711ulaw
session target ipv4:1.0.0.2
!
dial-peer voice 103 pots
destination-pattern 14085273333
port 3
!
dial-peer voice 1300 voip
destination-pattern 12123453333
codec g711ulaw
session target ipv4:1.0.0.2
!
dial-peer voice 104 pots
destination-pattern 14085274444
port 4
!
dial-peer voice 1400 voip
destination-pattern 12123454444
codec g711ulaw
session target ipv4:1.0.0.2
!

Cisco 827ルータ設定

次に示すのは、Cisco 827ルータの設定です。[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

Current configuration:
!
version 12.0
no service pad (default)
service timestamps debug uptime (default)
service timestamps log uptime (default)
no service password-encryption (default)
hostname Cisco827
enable secret 5 $1$RnI.$K4mh5q4MFetaqKzBbQ7gv0
ip subnet-zero
no ip domain-lookup
ip dhcp-server 20.1.1.2
ipx routing 0010.7b7e.5499
!In the preceding command, the router MAC address is automatically used ! as the router IPX address.
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast (default)
ipx network 100 novell-ether
!
interface ATM0
ip address 14.0.0.17 255.0.0.0
no ip directed-broadcast (default)
no atm ilmi-keepalive (default)
pvc 8/35
protocol ip 14.0.0.1 no broadcast
encapsulation aal5snap
!
router rip
version 2
network 10.0.0.0
network 30.0.0.0
no auto-summary
!
no ip http server (default)
ip classless (default)
!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
end

データ ネットワーク用の企業またはエンドポイント ルータ設定

ここでは、Cisco 3600ルータをユーザのデータ ネットワーク内の企業ルータまたはエンドポイント ルータとして設定する場合に利用できる設定を示します。[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

Current configuration:
!
version 12.0
no service pad (default)
service timestamps debug uptime (default)
service timestamps log uptime (default)
no service password-encryption (default)
!
hostname c3600
enable secret 5 $1$8TI8$WjLcYWgZ7EZhqH49Y2hJV!
ip subnet-zero
no domain-lookup
ipx routing 0010.7b7e.5498
!In the preceding command, the router MAC address is automatically used as the router IPX address.
!
interface Ethernet0
ip address 20.0.0.1 255.0.0.0
no ip directed-broadcast (default)
ipx network 200
!
router rip
version 2
network 20.0.0.0
network 30.0.0.0
no auto-summary
!
no ip http server (default)
ip classless (default)
!
protocol ip 2.0.0.1 broadcast
!
line con 0
exec-timeout 0 0
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!
end
 

データおよび音声ネットワーク用の企業またはエンドポイント ルータ設定

ここでは、Cisco 3600ルータをユーザの音声およびデータ ネットワーク内の企業ルータまたはエンドポイント ルータとして設定する場合に利用できる設定を示します。[default]のマークが付いているコマンドは入力する必要がありません。これらのコマンドは、 show running-config コマンドを使用した場合に生成されるコンフィギュレーション ファイルに自動的に表示されます。

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c3640
!
ip subnet-zero
!
cns event-service server
!
!
!
voice-port 1/0/0
no echo-cancel enable
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer voice 101 pots
destination-pattern 5552222
port 1/0/0
!
dial-peer voice 102 pots
destination-pattern 5554444
port 1/0/1
!
dial-peer voice 103 pots
destination-pattern 5556666
port 1/1/0
!
dial-peer voice 104 pots
destination-pattern 5558888
port 1/1/1
dial-peer voice 1100 voip
destination-pattern 5551111
codec g711alaw
ip precedence 5
no vad
session target ipv4:2.0.0.3
!
dial-peer voice 1101 voip
destination-pattern 5553333
codec g711alaw
ip precedence 5
no vad
session target ipv4:2.0.0.3
!
dial-peer voice 1102 voip
destination-pattern 5555555
codec g711alaw
ip precedence 5
session target ipv4:2.0.0.3
!
dial-peer voice 1103 voip
destination-pattern 5557777
codec g711alaw
ip precedence 5
session target ipv4:2.0.0.3
!
process-max-time 200
!
interface Ethernet0/1
no ip address
no ip directed-broadcast (default)
shutdown
!
router rip
version 2
network 3.0.0.0
!
ip classless (default)
ip route 0.0.0.0 0.0.0.0 Ethernet 0/0
ip route 1.0.0.0 255.0.0.0 3.0.0.0
ip route 2.0.0.0 255.0.0.0 3.0.0.1
 
ip route 5.0.0.0 255.0.0.0 3.0.0.1
ip route 40.0.0.0 255.255.255.0 172.28.9.1
ip route 172.28.5.0 255.255.255.0 172.28.9.1
ip route 172.28.9.0 255.255.255.0 172.28.9.1
no http server
!
line con 0
transport input none (default)
line aux 0
line vty 0 4
login
!
end