Cisco IOS XE ブロードバンド アクセス集約および DSL コンフィギュレーション ガイド
PPPoE リレー ディスカバリのイネーブル化 およびサービス選択機能
PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能
発行日;2012/02/01 | 英語版ドキュメント(2011/06/06 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能

機能情報の確認

目次

PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能の前提条件

PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能に関する情報

PPPoE の L2TP アクティブ ディスカバリ リレー

PPPoE リレー ディスカバリおよびサービス選択機能をイネーブルにする方法

PPPoE リレーのための LAC とトンネル スイッチの設定

次の作業

リレーされた PAD メッセージに応答するための LNS(マルチホップ ノード)の設定

PPPoE リレーの監視

トラブルシューティングのヒント

PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能の設定例

LAC 設定での PPPoE リレー:例

PPPoE リレー用の LNS の基本設定:例

PAD メッセージに応答するためのトンネル スイッチ(またはマルチホップ ノード)の設定:例

PAD メッセージをリレーするためのトンネル スイッチの設定:例

LAC の RADIUS 加入者プロファイル エントリ:例

LNS の RADIUS VPDN グループ ユーザ プロファイル エントリ:例

その他の関連資料

関連マニュアル

標準

MIB

RFC

シスコのテクニカル サポート

PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能の機能情報

PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能

PPPoE リレー機能を使用すると、L2TP Access Concentrator(LAC; L2TP アクセス コンセントレータ)から L2TP Network Server(LNS; L2TP ネットワーク サーバ)またはトンネル スイッチ(マルチホップ ノード)に PPP over Ethernet(PPPoE)のアクティブ ディスカバリとサービスの選択の機能を Layer 2 Tunneling Protocol(L2TP; レイヤ 2 トンネリング プロトコル)制御チャネルでリレーできます。この機能のリレー機能を使用することで、LNS またはトンネル スイッチはクライアントに提供するサービスをアドバタイズでき、それによって LNS と PPPoE クライアントの間でサービスのエンドツーエンド制御を提供できます。

機能情報の確認

最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能の機能情報」を参照してください。

プラットフォームのサポートおよび Cisco IOS XE ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能の前提条件

「ブロードバンド アクセス集約の準備」で説明されている概念について理解している必要があります。

「PPPoE セッションのブロードバンド アクセス集約に対するプロトコル サポートの提供」の手順を使用して、PPPoE セッションを確立する必要があります。

このマニュアルでは、Virtual Private Dial-up Network(VPDN; バーチャル プライベート ダイヤルアップ ネットワーク)トンネルおよびトンネル スイッチの設定方法を理解していることを前提としています。これらの機能の詳細については、「関連マニュアル」を参照してください。

PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能に関する情報

PPPoE リレーを設定するには、次の概念を理解しておく必要があります。

「PPPoE の L2TP アクティブ ディスカバリ リレー」

PPPoE の L2TP アクティブ ディスカバリ リレー

RFC 2516 で説明されている PPPoE プロトコルでは、LAC によるネットワーク内のデバイスのアクティブ ディスカバリとサービスの選択のための方法が定義されています。PPPoE クライアントはこれらの方法を使用してネットワーク内のアクセス コンセントレータを検出し、アクセス コンセントレータはこれらの方法を使用して、提供するサービスをアドバタイズします。

PPPoE リレー機能を使用することで、LAC だけでなく LNS も、アクティブ ディスカバリとサービスの選択の機能を提供できます。PPPoE リレー機能は、「 L2TP Active Discovery Relay for PPPoE 」というタイトルの Network Working Group Internet-Draft を実装します。Internet-Draft では、L2TP 制御チャネル(トンネル)経由で PPPoE Active Discovery(PAD)メッセージおよび Service Relay Request(SRRQ)メッセージをリレーする方法が記述されています。Network Working Group Internet-Draft にアクセスする方法については、「RFC」を参照してください。

PPPoE リレー機能の重要な利点は、LNS と PPPoE クライアントの間でのサービスのエンドツーエンド制御です。

PPPoE リレー ディスカバリおよびサービス選択機能をイネーブルにする方法

ここでは、次の手順について説明します。

「PPPoE リレーのための LAC とトンネル スイッチの設定」(必須)

「リレーされた PAD メッセージに応答するための LNS(マルチホップ ノード)の設定」(必須)

「その他の関連資料」(任意)

PPPoE リレーのための LAC とトンネル スイッチの設定

PPPoE リレー用に LAC およびトンネル スイッチを設定するには、この作業を実行します。この作業では、リレーされる PAD メッセージを L2TP トンネルに送信する加入者プロファイルを設定します。加入者プロファイルには、発信 L2TP トンネルの認証キーも含まれます。

手順の概要

1. enable

2. configure terminal

3. subscriber profile profile-name

4. service relay pppoe vpdn group vpdn-group-name

5. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

subscriber profile profile-name

 

Router(config)# subscriber profile profile-1

加入者プロファイル名を設定し、加入者プロファイル コンフィギュレーション モードを開始します。

profile-name bba-group pppoe グローバル コンフィギュレーション コマンドによって設定される PPPoE プロファイルから参照されます。これにより、 bba-group pppoe コマンドによって定義される PPPoE プロファイルを使用するすべての PPPoE セッションが、定義されている加入者プロファイルに従って処理されるようになります。

ステップ 4

service relay pppoe vpdn group vpdn-group-name

 

Router(config-sss-profile)# service relay pppoe vpdn group Group-A

リレーに VPDN L2TP トンネルを使用する PPPoE リレー サービスを提供します。指定されている VPDN グループ名は、発信 L2TP トンネルの情報を取得するために使用されます。

同等の RADIUS プロファイル エントリについては、「次の例は、AAA RADIUS サーバ プロファイルで Subscriber Service Switch 加入者サービス アトリビュートを入力する方法を示しています。」を参照してください。

ステップ 5

exit

 

Router(config-sss-profile)# exit

(任意)コンフィギュレーション セッションを終了し、特権 EXEC モードに戻ります。

次の作業

「リレーされた PAD メッセージに応答するための LNS(マルチホップ ノード)の設定」で説明されている作業を実行して、設定の LNS 側を設定します。

リレーされた PAD メッセージに応答するための LNS(マルチホップ ノード)の設定

リレーされた PAD メッセージに応答するルータで次の作業を実行して、PPPoE グループを設定し、L2TP のダイヤルイン コールを受け付ける VPDN グループにそれを接続します。リレーされた PAD メッセージは、VPDN L2TP トンネルおよびセッションから、PAD 応答を受け取るための PPPoE ブロードバンド グループに渡されます。

手順の概要

1. enable

2. configure terminal

3. vpdn-group vpdn-group-name

4. accept-dialin

5. protocol l2tp

6. virtual-template template-number

7. exit

8. terminate-from hostname host-name

9. relay pppoe bba-group pppoe-bba-group-name

10. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vpdn-group vpdn-group-name

 

Router(config)# vpdn-group Group-A

VPDN グループを作成し、VPDN グループ コンフィギュレーション モードを開始します。

ステップ 4

accept-dialin

 

Router(config-vpdn)# accept-dialin

LAC からトンネル化 PPP 接続を受け付ける LNS を設定し、accept-dialin VPDN サブグループを作成します。

ステップ 5

protocol l2tp

 

Router(config-vpdn-req-in)# protocol l2tp

L2TP トンネリング プロトコルを指定します。

ステップ 6

virtual-template template-number

 

Router(config-vpdn-req-in)# virtual-template 2

仮想アクセス インターフェイスのクローンを作成する際に使用される仮想テンプレートを指定します。

ステップ 7

exit

 

Router(config-vpdn-req-in)# exit

VPDN グループ コンフィギュレーション モードを終了します。

ステップ 8

terminate-from hostname host-name

 

Router(config-vpdn)# terminate-from hostname LAC-1

VPDN トンネルを受け付けるときに必要になる LAC ホスト名を指定します。

ステップ 9

relay pppoe bba-group pppoe-bba-group-name

 

Router(config-vpdn)# relay pppoe bba-group group-2

PAD メッセージに応答する PPPoE BBA グループを指定します。

PPPoE BBA グループ名は、 bba-group pppoe group-name グローバル コンフィギュレーション コマンドで定義します。

同等の RADIUS プロファイル エントリについては、「 LNS の RADIUS VPDN グループ ユーザ プロファイル エントリ 」を参照してください。

ステップ 10

exit

 

Router(config-vpdn)# exit

グローバル コンフィギュレーション モードに戻ります。

PPPoE リレーの監視

PPPoE リレーを監視するには、この作業を実行します。

手順の概要

1. enable

2. show pppoe session

3. show pppoe relay context all

4. clear pppoe relay context

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

show pppoe session

 

Router# show pppoe session

現在アクティブな PPPoE セッションに関する情報を表示します。


ステップ 1 enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

Router> enable

ステップ 2 show pppoe session

現在アクティブな PPPoE セッションに関する情報を表示します。

Router# show pppoe session

 
1 session in FORWARDED (FWDED) State
1 session total
 
Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st
26 19 0001.96da.a2c0 Et0/0.1 5 N/A RELFWD
000c.8670.1006 VLAN:3434

 

ステップ 3 show pppoe relay context all

PAD メッセージのリレー用に作成された PPPoE リレー コンテキストを表示します。

Router# show pppoe relay context all
 
Total PPPoE relay contexts 1
UID ID Subscriber-profile State
25 18 cisco.com RELAYED

 

 

ステップ 4 clear pppoe relay context

このコマンドは PAD メッセージのリレー用に作成された PPPoE リレー コンテキストをクリアします。

Router(config)# clear pppoe relay context


 

トラブルシューティングのヒント

PPPoE リレー機能をトラブルシューティングするときは、特権 EXEC モードで次のコマンドを使用します。

debug ppp forwarding

debug ppp negotiation

debug pppoe events

debug pppoe packets

debug vpdn l2x-events

debug vpdn l2x-packets

PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能の設定例

ここでは、次の設定例について説明します。

「LAC 設定での PPPoE リレー:例」

「PPPoE リレー用の LNS の基本設定:例」

「PAD メッセージに応答するためのトンネル スイッチ(またはマルチホップ ノード)の設定:例」

「PAD メッセージをリレーするためのトンネル スイッチの設定:例」

「LAC の RADIUS 加入者プロファイル エントリ:例」

「LNS の RADIUS VPDN グループ ユーザ プロファイル エントリ:例」

LAC 設定での PPPoE リレー:例

次に示すのは、PPPoE リレーをイネーブルにするコマンドが追加された標準的な LAC 設定の例です。

hostname User2
!
username User1 password 0 field
username User2 password 0 field
username user-group password 0 field
username User5 password 0 field
username User2-lac-domain password 0 field
username User1-client-domain@cisco.net password 0 field
username User3-lns-domain password 0 field
!
ip domain-name cisco.com
!
vpdn enable
vpdn source-ip 10.0.195.151
!
vpdn-group User2-vpdn-group-domain
request-dialin
protocol l2tp
domain cisco.net
initiate-to ip 10.0.195.133
local name User2-lac-domain
!
!
interface Loopback123
ip address 10.22.2.2 255.255.255.0
!
interface Ethernet0/0
ip address 10.0.195.151 255.255.255.0
no keepalive
half-duplex
pppoe enable group group-1
no cdp enable
!
interface Virtual-Template1
mtu 1492
ip unnumbered Loopback123
ppp authentication chap
ppp chap hostname User2-lac-domain
!
ip route 0.0.0.0 0.0.0.0 10.0.195.1
!
!
subscriber profile Profile1
service relay pppoe vpdn group User2-vpdn-group-domain
!
bba-group pppoe group-1
virtual-template 1
service profile Profile1
!

PPPoE リレー用の LNS の基本設定:例

次に、PPPoE リレー用のコマンドが追加された LNS の基本設定の例を示します。

hostname User5
!
!
username User5 password 0 field
username user-group password 0 field
username User1 password 0 field
username User2 password 0 field
username User3 password 0 field
username User3-dialout password 0 cisco
username User2-dialout password 0 cisco
username abc password 0 cisco
username dial-7206a password 0 field
username mysgbpgroup password 0 cisco
username User3-lns-domain password 0 field
username User2-lac-domain password 0 field
username User1-client-domain@cisco.net password 0 field
username User5-mh password 0 field
username User1@domain.net password 0 field
ip subnet-zero
!
!
ip domain-name cisco.com
!
vpdn enable
vpdn multihop
vpdn source-ip 10.0.195.133
!
vpdn-group 1
request-dialin
protocol l2tp
!
vpdn-group 2
! Default L2TP VPDN group
accept-dialin
protocol l2tp
!
vpdn-group User5-mh
request-dialin
protocol l2tp
domain cisco.net
initiate-to ip 10.0.195.143
local name User5-mh
!
vpdn-group User3-vpdn-group-domain
accept-dialin
protocol l2tp
virtual-template 2
terminate-from hostname User2-lac-domain
local name User3-lns-domain
relay pppoe group group-1
!
!
interface Loopback0
no ip address
!
!
interface Loopback123
ip address 10.23.3.2 255.255.255.0
!
!
interface FastEthernet0/0
ip address 10.0.195.133 255.255.255.0
duplex auto
speed auto
no cdp enable
!
!
interface Virtual-Template2
mtu 1492
ip unnumbered Loopback123
ip access-group virtual-access3#234 in
ppp mtu adaptive
ppp authentication chap
ppp chap hostname User3-lns-domain
!
!
ip default-gateway 10.0.195.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.195.1
!
!
bba-group pppoe group-1
virtual-template 2
!

PAD メッセージに応答するためのトンネル スイッチ(またはマルチホップ ノード)の設定:例

次に示すのは、PPPoE リレー メッセージへの応答をイネーブルにするコマンドが追加された標準的なトンネル スイッチ設定の例です。

hostname User3
!
!
username User1 password 0 room1
username User2 password 0 room1
username User3 password 0 room1
username User1@domain.net password 0 room1
username User3-lns-dnis password 0 cisco
username User3-lns-domain password 0 room1
username User2-lac-dnis password 0 cisco
username User2-lac-domain password 0 room1
username User5 password 0 room1
username User5-mh password 0 room1
username user-group password 0 room1
username User3-dialout password 0 cisco
username User2-dialout password 0 cisco
username abc password 0 cisco
username dial-7206a password 0 room1
username mysgbpgroup password 0 cisco
username User1-client-domain@cisco.net password 0 room1
username User4-lns-domain password 0 room1
!
ip domain-name cisco.com
!
vpdn enable
!
vpdn-group User3-mh
accept-dialin
protocol l2tp
virtual-template 1
terminate-from hostname User5-mh
relay pppoe bba-group group-1
!
interface Loopback0
ip address 10.4.4.2 255.255.255.0
!
interface Loopback1
ip address 10.3.2.2 255.255.255.0
!
interface Ethernet2/0
ip address 10.0.195.143 255.255.0.0
half-duplex
no cdp enable
!
interface Virtual-Template1
mtu 1492
ip unnumbered Loopback0
no keepalive
ppp mtu adaptive
ppp authentication chap
ppp chap hostname User3-lns-domain
!
ip default-gateway 10.0.195.1
ip route 0.0.0.0 0.0.0.0 10.0.195.1
!
!
bba-group pppoe group-1
virtual-template 1
!

PAD メッセージをリレーするためのトンネル スイッチの設定:例

次の部分的な例では、トンネル スイッチが PAD メッセージをリレーできるようにする設定を示します。

subscriber profile profile-1
! Configure profile for PPPoE Relay
service relay pppoe vpdn group Example1.net
.
.
.
vpdn-group Example2.net
! Configure L2TP tunnel for PPPoE Relay
accept-dialin
protocol l2tp
.
.
.
terminate-from host Host1
relay pppoe bba-group group-1
.
.
.
vpdn-group Example1.net
! Configure L2TP tunnel for PPPoE Relay
request-dialin
protocol l2tp
.
.
.
initiate-to ip 10.17.1.3
.
.
.
! PPPoE-group configured for relay
bba-group pppoe group-1
.
.
.
service profile profile-1

LAC の RADIUS 加入者プロファイル エントリ:例

次の例は、AAA RADIUS サーバ プロファイルで Subscriber Service Switch 加入者サービス アトリビュートを入力する方法を示しています。

profile-1 = profile-name
.
.
.

Cisco:Cisco-Avpair = "sss:sss-service=relay-pppoe"

次に示すのは、LAC の一般的な RADIUS 加入者プロファイル エントリの例です。

cisco.com Password = "password"
Cisco:Cisco-Avpair = "sss:sss-service=relay-pppoe",
Tunnel-Type = L2TP,
Tunnel-Server-Endpoint = .....,
Tunnel-Client-Auth-ID = "client-id",
Tunnel-Server-Auth-ID = "server-id",
Cisco:Cisco-Avpair = "vpdn:l2tp-tunnel-password=password",
Cisco:Cisco-Avpair = "vpdn:l2tp-nosession-timeout=never",
Tunnel-Assignment-Id = assignment-id

LNS の RADIUS VPDN グループ ユーザ プロファイル エントリ:例

次の例は、AAA RADIUS サーバ プロファイルで VPDN グループ アトリビュートを入力する方法を示しています。

profile-1 = profile-name
.
.
.

Cisco:Cisco-Avpair = "vpdn:relay-pppoe-bba-group= group-name "

次に示すのは、LNS の一般的な RADIUS 加入者プロファイル エントリの例です。

cisco.com Password = "password"
Tunnel-Type = L2TP,
Tunnel-Server-Endpoint = .....,
Tunnel-Client-Auth-ID = "client-id",
Tunnel-Server-Auth-ID = "server-id",
Cisco:Cisco-Avpair = "vpdn:l2tp-tunnel-password=password",
Cisco:Cisco-Avpair = "vpdn:l2tp-nosession-timeout=never",
Cisco:Cisco-Avpair = "vpdn:relay-pppoe-bba-group=group-name"
Tunnel-Assignment-Id = assignment-id

その他の関連資料

ここでは、PPPoE リレー機能に関する参考資料を紹介します。

関連マニュアル

内容
参照先

VPDN トンネル

Cisco IOS XE Dial Technologies Configuration Guide

VPDN トンネル コマンド

Cisco IOS XE Dial Technologies Configuration Guide

トンネル スイッチング

L2TP Tunnel Switching 』機能モジュール

PPPoE ブロードバンド グループ

『Cisco IOS XE Broadband Access Aggregation and DSL Configuration Guide』

PPPoE ブロードバンド コマンド

『Cisco IOS XE Broadband Access Aggregation and DSL Command Reference』

ブロードバンド アクセス集約の概念

『Cisco IOS XE Broadband Access Aggregation and DSL Configuration Guide』

ブロードバンド アクセス集約の準備作業

『Cisco IOS XE Broadband Access Aggregation and DSL Configuration Guide』

標準

標準
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS XE ソフトウェア リリース、およびフィーチャ セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2516

『Method for Transmitting PPP Over Ethernet (PPPoE)』

RFC 3817

『L2TP Active Discovery Relay for PPPoE』

Network Working Group Internet-Draft『 L2TP Active Discovery Relay for PPPoE 』:これは次の URL で参照できます。 http://www.ietf.org/internet-drafts/draft-dasilva-l2tp-relaysvc-06.txt

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能の機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームをサポートする Cisco IOS XE のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS XE ソフトウェア リリース群で特定の機能をサポートする Cisco IOS XE ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS XE ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能の機能情報

機能名
リリース
機能の設定情報

PPPoE リレー

Cisco IOS XE Release 2.1

PPPoE リレー機能を使用すると、L2TP Access Concentrator(LAC; L2TP アクセス コンセントレータ)から L2TP Network Server(LNS; L2TP ネットワーク サーバ)またはトンネル スイッチ(マルチホップ ノード)に PPP over Ethernet(PPPoE)のアクティブ ディスカバリとサービスの選択の機能を Layer 2 Tunneling Protocol(L2TP; レイヤ 2 トンネリング プロトコル)制御チャネルでリレーできます。

この機能に関する詳細については、次の各項を参照してください。

「PPPoE リレー ディスカバリのイネーブル化およびサービス選択機能に関する情報」

「PPPoE リレー ディスカバリおよびサービス選択機能をイネーブルにする方法」

この機能は、Cisco IOS XE Release 2.1 に統合されました。

PPPoE Service Selection

Cisco IOS XE Release 2.4

この機能は、Cisco IOS XE Release 2.4 に統合されました。