Cisco IOS XE ブロードバンド アクセス集約および DSL コンフィギュレーション ガイド
ブロードバンド アクセス集約の準備
ブロードバンド アクセス集約の準備
発行日;2012/02/01 | 英語版ドキュメント(2011/06/06 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

ブロードバンド アクセス集約の準備

機能情報の確認

目次

ブロードバンド アクセス集約の準備の制約事項

ブロードバンド アクセス集約の準備に関する情報

仮想アクセス インターフェイス

ブロードバンド スケーラビリティの設定拡張機能

仮想アクセス サブインターフェイス

仮想テンプレートのサブインターフェイスとの互換性

ブロードバンド スケーラビリティ機能の利点

ブロードバンド アクセス集約を準備する方法

仮想テンプレート インターフェイスの設定

ブロードバンド スケーラビリティの拡張機能の設定

仮想テンプレートの仮想アクセス サブインターフェイスとの互換性の確認

ブロードバンド アクセス集約の準備の設定例

仮想アクセス サブインターフェイスの設定:例

仮想アクセス サブインターフェイスの設定:例

仮想テンプレートのサブインターフェイスとの互換性のテスト:例

その他の関連資料

関連マニュアル

標準

MIB

RFC

シスコのテクニカル サポート

ブロードバンド アクセス集約の準備の機能情報

ブロードバンド アクセス集約の準備

ブロードバンド アクセス集約の達成に必要な作業を実行する前に、自分の判断で実行できる準備作業がいくつかあります。これらの準備作業を実行すると、集約作業をより効率的に行うことができます。

仮想テンプレート インターフェイスを使用すると、時間を節約できます。PPP パラメータはすべて、仮想テンプレート設定内で管理されるからです。仮想テンプレートで行った設定はすべて、各仮想アクセス インターフェイスに自動的に伝播されます。

ブロードバンド スケーラビリティの拡張機能では、仮想アクセス サブインターフェイスを作成して、終了した各 PPP セッションで使用されるメモリの量を減らすことができます。仮想アクセス サブインターフェイスがシステムで使用可能かどうかを確認し、これらの拡張機能を事前に設定しておくと、集約プロセスを高速化し、システムのパフォーマンスを向上させることができます。

機能情報の確認

最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「ブロードバンド アクセス集約の準備の機能情報」を参照してください。

プラットフォームのサポートおよび Cisco IOS XE ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

ブロードバンド アクセス集約の準備の制約事項

次の制約事項が適用されます。

高度なスケーリング要件により、仮想アクセス サブインターフェイスのみがサポートされます。仮想アクセス サブインターフェイスのディセーブル化はサポートされません。

仮想アクセス インターフェイスのクローンの事前作成はサポートされません。

ブロードバンド アクセス集約の準備に関する情報

ブロードバンド アクセス集約を準備するには、次の概念を理解しておく必要があります。

「仮想アクセス インターフェイス」

「ブロードバンド スケーラビリティの設定拡張機能」

仮想アクセス インターフェイス

仮想テンプレート インターフェイスは、ダイナミックに作成される仮想アクセス インターフェイスに設定を提供するために使用されます。仮想テンプレート インターフェイスはユーザによって作成され、NVRAM に保存されます。

仮想テンプレート インターフェイスを作成したら、シリアル インターフェイスと同様の方法で設定できます。

仮想テンプレート インターフェイスは、仮想プロファイル、Virtual Private Dial-up Network(VPDN; バーチャル プライベート ダイヤルアップ ネットワーク)、プロトコル変換など、さまざまなアプリケーションで作成および適用できます。

PPP パラメータはすべて、仮想テンプレート設定内で管理されます。仮想テンプレートに対する設定変更は、各仮想アクセス インターフェイスに自動的に伝播されます。1 つの仮想テンプレートから複数の仮想アクセス インターフェイスを作成することができます。

Cisco IOS XE ソフトウェアでは、最大で 4096 の仮想テンプレート設定がサポートされます。それよりも多くのカスタム設定が必要な場合は、Authentication, Authorization, and Accounting(AAA; 認証、認可、アカウンティング)サーバを使用できます。

インターフェイスを設定する前に仮想テンプレートのパラメータを明示的に定義しなかった場合、PPP インターフェイスは仮想テンプレートのデフォルト値を使用して起動します。一部のパラメータ(IP アドレスなど)は、PPP インターフェイスが起動する前に指定された場合にのみ有効になります。したがって、このようなパラメータを有効にするために、インターフェイスを設定する前に仮想テンプレートを明示的に作成して設定することを推奨します。インターフェイスを設定した後にパラメータを指定する場合は、サブインターフェイスで shutdown コマンドの後に no shutdown コマンドを実行してインターフェイスを再起動します。この再起動により、新しく設定されたパラメータ(IP アドレスなど)が有効になります。

ブロードバンド スケーラビリティの設定拡張機能

ブロードバンド スケーラビリティ機能の設定拡張機能では、仮想アクセス サブインターフェイスを作成して、終了した各 PPP セッションで使用されるメモリの量を減らすことができます。仮想アクセス サブインターフェイスを使用できるかどうかは、作成元の仮想テンプレートの設定によって異なります。この機能では、仮想テンプレートに仮想アクセス サブインターフェイスとの互換性があるかどうかを確認するコマンドも導入されます。

仮想アクセス サブインターフェイス

virtual-template コマンドでは、既存の機能と設定がサポートされます。virtual-template subinterface コマンドは、デフォルトでイネーブルになっています。このコマンドをディセーブルにできません。

仮想テンプレート マネージャは、仮想テンプレートで設定されているすべてのオプションがサブインターフェイスでサポートされるかどうかを確認します。仮想アクセス サブインターフェイスは、サブインターフェイスをサポートするすべての仮想テンプレートに対して作成されます。ユーザがサブインターフェイスでサポートされないコマンドを入力した場合、完全な仮想アクセス インターフェイスが作成され、その仮想テンプレートを使用するすべての PPP セッションにクローンが作成されます。

個々のアプリケーションがサブインターフェイスに対応しているかどうかに関係なく、さまざまなアプリケーションで同じ仮想テンプレートを使用できます。仮想テンプレート マネージャは、アプリケーションが仮想アクセス サブインターフェイスをサポートするかどうかを通知され、適切なリソースを作成します。

仮想テンプレートのサブインターフェイスとの互換性

The test virtual-template subinterface 特権 EXEC コマンドは、仮想テンプレートが仮想アクセス サブインターフェイスの作成をサポートできるかどうかを確認します。仮想テンプレートにサブインターフェイスの作成を妨げるコマンドが含まれている場合、test virtual-template subinterface コマンドはそれらのコマンドを特定して表示します。

debug vtemplate subinterface コマンドは、ユーザがサブインターフェイスで有効でないコンフィギュレーション コマンドを仮想テンプレートで入力した場合に生成されるデバッグ メッセージを表示します。これらのメッセージは、debug vtemplate subinterface コマンドと virtual-template subinterface コマンドがイネーブルになっていて、サブインターフェイスの作成をサポートできる仮想テンプレートが設定されている場合にのみ生成されます。仮想アクセス サブインターフェイスの作成が no virtual-template サブインターフェイス コマンドによってディセーブルにされている場合、 debug vtemplate subinterface コマンドは出力を生成しません。

ブロードバンド スケーラビリティ機能の利点

ブロードバンド スケーラビリティでは、仮想アクセス サブインターフェイスを作成して、終了した各 PPP セッションで使用されるメモリの量を減らすことができます。これらの仮想アクセス サブインターフェイスは、ユーザにとって透過的な機能向上と共に、クローンの作成プロセスを高速化します。

ブロードバンド アクセス集約を準備する方法

ここでは、次の手順について説明します。

「仮想テンプレート インターフェイスの設定」

「ブロードバンド スケーラビリティの拡張機能の設定」

仮想テンプレート インターフェイスの設定

ギガビット イーサネット インターフェイスに PPPoE を設定する前に、仮想テンプレートを設定します。仮想テンプレート インターフェイスは、必要に応じて着信 PPP セッション要求にダイナミックに適用される論理エンティティです。仮想テンプレート インターフェイスを作成して設定するには、グローバル コンフィギュレーション モードで次のコマンドを入力します。

手順の概要

1. enable

2. configure terminal

3. interface virtual-template number

4. ip unnumbered loopback number

5. mtu bytes

6. ppp authentication chap

7. ppp ipcp ip address required

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Interface virtual-template number

 

Router(config)# interface virtual-template 1

仮想テンプレート インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip unnumbered loopback number

 

Router(config-if)# ip unnumbered loopback 0

LAN 上の特定の IP アドレスを割り当てずに IP をイネーブルにします。

ステップ 5

mtu bytes

 

Router(config-if)# mtu 1492

(任意)インターフェイスの最大 MTU サイズを設定します。

(注) 設定できる MTU サイズは 1492 または 1500 のいずれかだけです。1492 より大きい MTU サイズを設定するには、tag ppp-max-payload コマンドを使用する必要があります。

ステップ 6

ppp authentication chap

 

Router(config-if)# ppp authentication chap

仮想テンプレート インターフェイスで PPP 認証をイネーブルにします。

ステップ 7

ppp ipcp ip address required

 

Router(config-if)# ppp ipcp ip address required

有効なアドレスのネゴシエーションなしに PPP セッションが設定されるのを防止します。

このコマンドは、レガシー ダイヤルアップ ネットワークやレガシー DSL ネットワークで必要になります。

次に、仮想テンプレート インターフェイスの設定例を示します。

interface virtual-template 1
ip unnumbered Loopback 0
no peer default ip address
ppp authentication chap vpn1
ppp authorization vpn1
ppp accounting vpn1

ブロードバンド スケーラビリティの拡張機能の設定

ブロードバンド スケーラビリティの拡張機能を設定するには、次の作業を実行します。

「仮想テンプレートの仮想アクセス サブインターフェイスとの互換性の確認」

仮想テンプレートの仮想アクセス サブインターフェイスとの互換性の確認

仮想テンプレートをテストし、仮想テンプレートが仮想アクセス サブインターフェイスの作成に対応しているかどうかを確認するには、次の作業を実行します。

手順の概要

1. enable

2. test virtual-template template subinterface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

test virtual-template template subinterface

 

Router# test virtual-template virtual-template1 subinterface

指定された仮想テンプレートをテストし、その仮想テンプレートが仮想アクセス サブインターフェイスの作成に対応しているかどうかを確認します。

test virtual-template subinterface コマンドによって生成された出力は、仮想テンプレートがサブインターフェイスの作成に対応しているかどうかを示します。

次の例の出力は、仮想テンプレートに互換性がないことを示しています。この出力には、仮想テンプレートで設定されていて、非互換性の原因になっているコマンドのリストも含まれています。

 
Router# test virtual-template virtual-template1 subinterface
 
Subinterfaces cannot be created using
Virtual-Template1
 
Interface commands:
traffic-shape rate 50000 8000 8000 1000

ブロードバンド アクセス集約の準備の設定例

ここでは、次の設定例について説明します。

「仮想アクセス サブインターフェイスの設定:例」

仮想アクセス サブインターフェイスの設定:例

ここでは、次の設定例について説明します。

「仮想アクセス サブインターフェイスの設定:例」

「仮想テンプレートのサブインターフェイスとの互換性のテスト:例」

仮想アクセス サブインターフェイスの設定:例

次に、仮想アクセス サブインターフェイスと互換性がある仮想テンプレートの例を示します。


virtual-access subinterface コマンドは、デフォルトでイネーブルになっており、実行コンフィギュレーションには表示されません。実行コンフィギュレーションに表示されるのは、no virtual-access subinterface コマンドだけです。


interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address pool pool-1
ppp authentication chap
ppp multilink

 

次に、仮想アクセス サブインターフェイスの作成が no virtual-access subinterface コマンドによってディセーブルにされている設定例を示します。このコマンドが設定されている場合、仮想アクセス インターフェイスはルータの SNMP コードに登録されません。PPP セッションの管理に SNMP を使用しないネットワーク環境では、これによってメモリと CPU 処理を節約できます。仮想アクセス インターフェイスを SNMP コードに登録するのに必要なメモリと CPU 処理を使用せずに済むからです。

 
Current configuration :6003 bytes
!
 
! Last configuration change at 10:59:02 EDT Thu Sep 19 2004
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
service udp-small-servers
service tcp-small-servers
!
hostname ioswan5-lns
!
enable password lab
!
username cisco password 0 cisco
clock timezone EST -5
clock summer-time EDT recurring
aaa new-model
!
!
aaa authentication ppp default local
 
aaa authorization network default local
aaa session-id common
ip subnet-zero
no ip gratuitous-arps
ip cef
!
!
no ip domain lookup
ip name-server 10.44.11.21
ip name-server 10.44.11.206
!
ip vrf vpn1
rd 10:1
route-target export 10:1
route-target import 10:1
!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol l2tp
virtual-template 1
terminate-from hostname ioswan5-lac
local name tunnel1
l2tp tunnel password 7 01100F175804
!

!

!
no virtual-template subinterface
no virtual-template snmp
virtual-template 1 pre-clone 10
!
!
!
buffers small permanent 20000
buffers middle permanent 7500
!
!
!
interface Loopback1
ip address 10.111.1.1 255.255.255.0

仮想テンプレートのサブインターフェイスとの互換性のテスト:例

次に、仮想テンプレートをテストし、仮想テンプレートが仮想アクセス サブインターフェイスをサポートできるかどうかを確認する例を示します。次のコマンドは、仮想テンプレート 1 の設定を表示します。

Router# show running interface virtual-template 1
 
Building configuration...
!
interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address pool pool-1
ppp authentication chap
traffic-shape rate 50000 8000 8000 1000
end
 

test virtual-template subinterface コマンドは、仮想テンプレート 1 をテストし、この仮想テンプレートがサブインターフェイスをサポートできるかどうかを確認します。出力は、仮想テンプレート 1 で設定されている traffic-shape rate コマンドが原因で、仮想テンプレートがサブインターフェイスをサポートできなくなっていることを示しています。

Router# test virtual-template 1 subinterface
 
Subinterfaces cannot be created using Virtual-Template1
Interface commands:
traffic-shape rate 50000 8000 8000 1000

その他の関連資料

ここでは、ブロードバンド アクセス集約の準備に関する参考資料を紹介します。

関連マニュアル

内容
参照先

PPPoE セッションのブロードバンド アクセス集約

『Providing Protocol Support for Broadband Access Aggregation of PPPoE Sessions』

ppp-max payload タグ値の範囲の指定

『PPP-Max-Payload and IWF PPPoE Tag Support』

このマニュアルで使用しているコマンドのその他の情報

『Cisco IOS Broadband Access Aggregation and DSL Command Reference』

『Cisco IOS Master Command List, All Releases』

標準

標準
タイトル

この機能によりサポートされた新規標準または改訂標準はありません。またこの機能による既存標準のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS XE リリース、およびフィーチャ セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

ブロードバンド アクセス集約の準備の機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator により、どの Cisco IOS XE のソフトウェア イメージが特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームをサポートするか調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS XE ソフトウェア リリース群で特定の機能をサポートする Cisco IOS XE ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS XE ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 ブロードバンド集約の準備の機能情報

機能名
ソフトウェア リリース
機能の設定情報

仮想サブインターフェイス(ブロードバンド スケーラビリティの設定拡張機能)

Cisco IOS XE Release 2.1

この機能は、Cisco ASR 1000 シリーズ ルータに追加されました。

この機能では、仮想アクセス サブインターフェイスを作成して、終了した各 PPP セッションで使用されるメモリの量を減らすことができます。仮想アクセス サブインターフェイスを使用できるかどうかは、作成元の仮想テンプレートの設定によって異なります。この機能では、仮想テンプレートに仮想アクセス サブインターフェイスとの互換性があるかどうかを確認するコマンドも導入されます。

この機能に関する詳細については、次の各項を参照してください。

「ブロードバンド スケーラビリティの拡張機能の設定」

「仮想アクセス サブインターフェイスの設定:例」