Cisco IOS XE ブロードバンド アクセス集約および DSL コンフィギュレーション ガイド
ブロードバンド ハイ アベイラビリティ ステー トフル スイッチオーバー
ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー
発行日;2012/02/01 | 英語版ドキュメント(2011/06/06 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー

機能情報の確認

目次

の前提条件

に関する制約事項

について

の機能設計

サポートされているブロードバンド集約プロトコル

SSO L2TP

SSO PPPoE

SSO RA-MLPS VPN

の利点

の設定方法

ブロードバンド HA ステートフル スイッチオーバーの加入者冗長性ポリシーの設定

ブロードバンド HA ステートフル スイッチオーバーの加入者冗長性ポリシーの確認とトラブルシューティング

の設定例

SSO を使用した RA-MPLS ネットワークに終端する PPPoX:例

その他の関連資料

関連マニュアル

標準

MIB

RFC

シスコのテクニカル サポート

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの機能情報

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー機能は、二重のルート プロセッサ システムに対して Point-to-Point Protocol over <各種メディア>(PPPoX)セッションのステートフル スイッチオーバーをサポートする機能を提供し、システムの制御およびルーティング プロトコルの実行をアクティブ プロセッサとスタンバイ プロセッサ間で転送するときにアプリケーションと機能で状態を維持できるようにするため、SSO--PPPoE 機能を使用します。

機能情報の確認

最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの機能情報」を参照してください。

プラットフォームのサポートおよび Cisco IOS XE ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの前提条件

Stateful Switchover(SSO; ステートフル スイッチオーバー)機能と Nonstop Forwarding(NSF; ノンストップ フォワーディング)機能がイネーブルになっている必要があります。SSO の詳細については、「 Stateful Switchover 」を参照してください。NSF の詳細については、「 Cisco Nonstop Forwarding 」を参照してください。

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーに関する制約事項

SSO は、High Availability(HA; ハイ アベイラビリティ)ネットワーク デバイスでのみサポートされます。

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーについて

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー機能を設定するには、次の概念を理解しておく必要があります。

「ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの機能設計」

「ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの利点」

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの機能設計

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー機能が実装される前は、コントロール プレーンとデータプレーンで予期せぬ障害が発生すると、PPPoX セッションでサービスの停止およびネットワークのダウンタイムが生じていました。SSO を含むシスコのハイ アベイラビリティ機能では、このような障害から迅速に回復することで、ネットワークを保護できます。ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー 機能では、トラフィックの転送を続けながら、スタンバイ プロセッサへのステートフル スイッチオーバーを提供することで、停止の原因を排除します。SSO は、サポートされる機能のプロトコルと状態情報をスタンバイ ルート プロセッサと同期し、スイッチオーバーが行われるときにセッションや接続が中断されないようにすることで、アクティブなルート プロセッサでハードウェアまたはソフトウェアの障害が発生するのを防ぎます。

SSO 機能は、ルート プロセッサの 1 つをアクティブ プロセッサとし、もう一方のルート プロセッサをスタンバイ プロセッサに設定し、それらのプロセッサ間で重要な状態情報を同期して、ルートプロセッサの冗長性を利用します。2 つのプロセッサ間で初期(バルク)同期が行われた後、SSO はそれらのプロセッサ間でルート プロセッサの状態情報をダイナミックに維持します。アクティブなルート プロセッサに障害が発生したとき、ネットワーク デバイスから削除されたとき、または手動でメンテナンスから排除されたときに、アクティブなプロセッサからスタンバイ プロセッサへのスイッチオーバーが発生します。その後、スタンバイ ルート プロセッサが制御を引き継ぎ、アクティブなルート プロセッサになるため、サポートされる機能のセッションおよび接続は保持されます。この時点では、新しいアクティブなルート プロセッサでルート収束が行われている間もパケット転送は続行されます。SSO とシスコ HA テクノロジーの不可欠な構成要素は、スタンバイ プロセッサ上でセッションの再作成を管理する Cluster Control Manager(CCM; クラスタ コントロール マネージャ)です。ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー 機能では、加入者冗長性ポリシーを設定して、同期処理を調整できます。詳細については、「ブロードバンド HA ステートフル スイッチオーバーの加入者冗長性ポリシーの設定」を参照してください。

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー 機能は、Cisco NSF および SSO HA 機能と連携して、PPPoX セッションを維持します。NSF は、ネットワーク トラフィックとアプリケーション状態情報の転送を継続するため、スイッチオーバーの後もユーザ セッション情報は維持されます。

ハイ アベイラビリティおよびステートフル スイッチオーバーの詳細については、『 Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide 』の「High Availability Overview」の章を参照してください。

サポートされているブロードバンド集約プロトコル

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーフィーチャ セットは、次のブロードバンド集約プロトコルをサポートしています。

「SSO L2TP」

「SSO PPPoE」

「SSO RA-MLPS VPN」

SSO L2TP

L2TP HA Session SSO/ISSU on a LAC/LNS機能は、Layer 2 Access Concentrator(LAC; レイヤ 2 アクセス コンセントレータ)および Layer 2 Network Server(LNS; レイヤ 2 ネットワーク サーバ)上の Layer 2 Tunneling Protocol(L2TP; レイヤ 2 トンネリング プロトコル)のための、汎用 Stateful Switchover/In Service Software Upgrade(SSO/ISSU; ステートフル スイッチオーバー/インサービス ソフトウェア アップグレード)メカニズムを提供します。この機能では、SSO スイッチオーバーや、ISSU アップグレードまたはダウングレード中に、完全に確立された PPP および L2TP セッションが保持されます。

SSO PPPoE

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー 機能は、PPPoE、PPPoEoVLAN、および PPPoEoQinQ を含む PPP over Ethernet(PPPoE)加入者アクセス セッションに対し、ステートフル スイッチオーバー機能を提供します。

SSO RA-MLPS VPN

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー機能は、プロセッサのスイッチオーバー中に Remote Access(RA; リモート アクセス)-MPLS VPN に終端する PPPoX セッションまたは MPLS VPN への PPPoX セッションに対し、ステートフル スイッチオーバー機能を提供します。

図 1 に、SSO 機能を使用した一般的なブロードバンド集約 HA 展開を示します。

図 1 ブロードバンド集約ハイ アベイラビリティ展開

 

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの利点

停止に関連する運用コストが削減されます。

高いサービス レベルが加入者に提供されます。

ネットワークのアベイラビリティが向上します。

特定のネットワーク サービスを提供するノードを通じて、継続的な接続、低パケット損失、および一貫したパス フローが促進されます。

サービスの中断が軽減され、ダウンタイムのコストが削減されて、運用効率が向上します。

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの設定方法

ここでは、次の作業について説明します。

「ブロードバンド HA ステートフル スイッチオーバーの加入者冗長性ポリシーの設定」

「ブロードバンド HA ステートフル スイッチオーバーの加入者冗長性ポリシーの確認とトラブルシューティング」

ブロードバンド HA ステートフル スイッチオーバーの加入者冗長性ポリシーの設定

ブロードバンド加入者セッションで HA SSO 機能の加入者冗長性ポリシーを設定するには、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. subscriber redundancy [ bulk limit cpu percentage delay seconds allow value ] [ dynamic limit cpu percentage delay seconds allow value] [delay time] [rate sessions time]

4. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

subscriber redundancy [bulk limit cpu percentage delay seconds allow value][dynamic limit cpu percentage delay seconds allow value][delay time][rate sessions time]

 

Router(config)# subscriber redundancy bulk limit cpu 75 delay 20 allow 30

(任意)加入者冗長性ポリシーを設定します。

bulk:バルク同期冗長性ポリシーを設定します。

limit cpu percentage:CPU のビジー状態のしきい値をパーセンテージで指定します。範囲は 0 ~ 100 で、デフォルトは 90 です。

delay seconds:CPU のビジー状態のしきい値を超えた後で、CCM コンポーネントでセッションを同期化する前に遅延を秒単位で指定します。

allow value:CPU のビジー状態のしきい値を超え、指定された遅延を満たすと、同期化するセッションの最小数を指定します。範囲は 1 ~ 2147483637 で、デフォルトは 25 です。

dynamic:ダイナミック同期冗長性ポリシーを設定します。

delay time:ダイナミック同期が発生する前にセッションで準備しておく必要のある最小時間を秒単位で指定します。値の範囲は 1 ~ 33550 です。

rate sessions time:バルク同期とダイナミック同期の期間ごとのセッション数を指定します。

sessions:範囲は 1 ~ 32000 で、デフォルトは 250 です。

time:範囲は 1 ~ 33550 で、デフォルトは 1 です。

ステップ 4

exit

 

Router(config)# exit

現在のコンフィギュレーション モードを終了します。

ブロードバンド HA ステートフル スイッチオーバーの加入者冗長性ポリシーの確認とトラブルシューティング

コンフィギュレーションを表示するには、 show running-config コマンドを使用します。出力例は、「ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの設定例」にあります。

ステップ 1 およびステップ 2 は、CCM 同期コンポーネントをトラブルシューティングするのに役立ちます。ステップ 3 およびステップ 4 は、PPPoX セッション統計情報を確認するのに役立ちます。ステップ 5 およびステップ 6 は、L2TP トンネルまたは VPDN グループの障害を確認するのに役立ちます。ステップ 7 は、一般にシスコの技術者が、内部的なデバッグ目的で使用します。

手順の概要

1. show ccm clients

2. show ccm sessions

3. show ppp subscriber statistics

4. show pppoe statistics

5. show vpdn redundancy

6. show vpdn history failure

7. debug pppoe redundancy

手順の詳細


ステップ 1 show ccm clients

このコマンドは、冗長なプロセッサ HA システムのスタンバイ プロセッサでセッション起動を同期する機能を管理する HA コンポーネント、CCM に関する情報を示します。CCM クライアントに関する情報を表示するには、show ccm clients コマンドを使用します

アクティブなルート プロセッサ

Router# show ccm clients
CCM bundles sent since peer up:
Sent Queued for flow control
Sync Session 16000 0
Update Session 0 0
Active Bulk Sync End 1 0
Session Down 0 0
ISSU client msgs 346 0
Dynamic Session Sync 0 0
Unknown msgs 0 0
Client events sent since peer up:
PPP 144000
PPPoE 96002
VPDN FSP 0
AAA 64000
PPP SIP 0
LTERM 16000
AC 0
L2TP CC 0
SSS FM 16000
VPDN LNS 0

スタンバイのルート プロセッサ

Router# show ccm clients
CCM bundles rcvd since last boot:
Sync Session 16000
Update Session 0
Active Bulk Sync End 1
Session Down 0
ISSU client msgs 173
Dynamic Session Sync 0
Unknown msgs 0
Client events extracted since last boot:
PPP 144000
PPPoE 96002
VPDN FSP 0
AAA 64000
PPP SIP 0
LTERM 16000
AC 0
L2TP CC 0
SSS FM 16000
VPDN LNS 0
 

ステップ 2 show ccm sessions

このコマンドは、CCM で管理されているセッションについての情報を表示します。

アクティブなルート プロセッサ

Router# show ccm sessions
Global CCM state: CCM HA Active - Dynamic Sync
Global ISSU state: Compatible, Clients Cap 0x9EFFE
 
Current Bulk Sent Bulk Rcvd
----------- ----------- -----------
Number of sessions in state Down: 0 0 0
Number of sessions in state Not Ready: 0 0 9279
Number of sessions in state Ready: 0 0 6721
Number of sessions in state Dyn Sync: 16000 16000 0
 
Timeout: Timer Type Delay Remaining Starts CPU Limit CPU Last
------------ -------- --------- ----------- --------- --------
Rate 00:00:01 - 64 - -
Dynamic CPU 00:00:10 - 0 90 0
Bulk Time Li 00:08:00 - 1 - -
RF Notif Ext 00:00:01 - 475 - -

スタンバイのルート プロセッサ

Router# show ccm sessions
Global CCM state: CCM HA Standby - Collecting
Global ISSU state: Compatible, Clients Cap 0x9EFFE

Current Bulk Sent Bulk Rcvd
----------- ----------- -----------
Number of sessions in state Down: 0 0 0
Number of sessions in state Not Ready: 0 0 8384
Number of sessions in state Ready: 16000 0 7616
Number of sessions in state Dyn Sync: 0 0 0
 
Timeout: Timer Type Delay Remaining Starts CPU Limit CPU Last
------------ -------- --------- ----------- --------- --------
Rate 00:00:01 - 0 - -
Dynamic CPU 00:00:10 - 0 90 0
Bulk Time Li 00:08:00 - 1 - -
RF Notif Ext 00:00:01 - 0 - -
 

ステップ 3 show ppp subscriber statistics

このコマンドは、PPP 加入者のイベントおよび統計情報を表示するのに便利です。show ppp subscriber statistics コマンドは、PPP 加入者イベントと統計情報の累積数を表示するためと、最後に clear ppp subscriber statistics コマンドを発行してからの増分を表示するために使用します。

次に、show ppp subscriber statistics コマンドの出力例を示します。

Router# show ppp subscriber statistics
 
PPP Subscriber Events TOTAL SINCE CLEARED
Encap 5 5
DeEncap 0 0
CstateUp 7 7
CstateDown 4 4
FastStart 0 0
LocalTerm 7 7
LocalTermVP 0 0
MoreKeys 7 7
Forwarding 0 0
Forwarded 0 0
SSSDisc 0 0
SSMDisc 0 0
PPPDisc 0 0
PPPBindResp 7 7
PPPReneg 3 3
RestartTimeout 5 5
 
PPP Subscriber Statistics TOTAL SINCE CLEARED
IDB CSTATE UP 4 4
IDB CSTATE DOWN 8 8
APS UP 0 0
APS UP IGNORE 0 0
APS DOWN 0 0
READY FOR SYNC 8 8
 

ステップ 4 show pppoe statistics

このコマンドは、PPPoE セッションの統計情報とイベントを取得するのに便利です。show pppoe statistics コマンドは、PPPoE イベントおよび統計情報の累積数を表示するためと、最後に clear pppoe statistics コマンドを発行してからの増分を表示するために使用します。

次に、show pppoe statistics コマンドの出力例を示します。

Router# show pppoe statistics
 
PPPoE Events TOTAL SINCE CLEARED
------------------------------ ------------- -------------
INVALID 0 0
PRE-SERVICE FOUND 0 0
PRE-SERVICE NONE 0 0
SSS CONNECT LOCAL 0 0
SSS FORWARDING 0 0
SSS FORWARDED 0 0
SSS MORE KEYS 0 0
SSS DISCONNECT 0 0
CONFIG UPDATE 0 0
STATIC BIND RESPONSE 0 0
PPP FORWARDING 0 0
PPP FORWARDED 0 0
PPP DISCONNECT 0 0
PPP RENEGOTIATION 0 0
SSM PROVISIONED 0 0
SSM UPDATED 0 0
SSM DISCONNECT 0 0
 
PPPoE Statistics TOTAL SINCE CLEARED
------------------------------ ------------- -------------
SSS Request 0 0
SSS Response Stale 0 0
SSS Disconnect 0 0
PPPoE Handles Allocated 0 0
PPPoE Handles Freed 0 0
Dynamic Bind Request 0 0
Static Bind Request 0 0
 
 

ステップ 5 show vpdn redundancy

このコマンドは、L2TP トンネルの障害を確認するために使用します。

Router# show vpdn redundancy
L2TP HA support: Silent Failover
 
L2TP HA Status:
Checkpoint Messaging on: FALSE
Standby RP is up: TRUE
Recv'd Message Count: 0
L2TP Tunnels: 2/2/2/0 (total/HA-enabled/HA-est/resync)
L2TP Sessions: 10/10/10 (total/HA-enabled/HA-est)
L2TP Resynced Tunnels: 0/0 (success/fail)
 

ステップ 6 show vpdn history failure

このコマンドは、VPDN グループの障害を確認するために使用します。

Router# show vpdn history failure
% VPDN user failure table is empty
 

ステップ 7 debug pppoe redundancy

debug pppoe redundancy コマンドは、HA システム上の PPPoE セッションの CCM イベントとメッセージを表示するために使用します。このコマンドは、一般にシスコの技術者だけが、CCM プロセスの内部的なデバッグのために使用します。

Router# debug pppoe redundancy
 
Nov 22 17:21:11.327: PPPoE HA[0xBE000008] 9: Session ready to sync data
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PADR, length = 58
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SESSION ID, length = 2
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SWITCH HDL, length = 4
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SEGMENT HDL, length = 4
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PHY SWIDB DESC, length = 20
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = VACCESS DESC, length = 28
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: Sync collection for ready events
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PADR, length = 58
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SESSION ID, length = 2
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SWITCH HDL, length = 4
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = SEGMENT HDL, length = 4
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = PHY SWIDB DESC, length = 20
Nov 22 17:21:11.351: PPPoE HA[0xBE000008] 9: code = VACCESS DESC, length = 28
 


 

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの設定例

ここでは、次の設定例について説明します。

「SSO を使用した RA-MPLS ネットワークに終端する PPPoX:例」

SSO を使用した RA-MPLS ネットワークに終端する PPPoX:例

次の例は、RA-MPLS ネットワークでブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー機能を設定する方法を示しています。

Router# show running-config
 
hostname Router
!
boot-start-marker
boot system bootflash:packages.conf !
enable password cisco
!
aaa new-model
!
!
aaa authentication ppp default local
!
!
!
aaa session-id common
ppp hold-queue 80000
ip subnet-zero
no ip gratuitous-arps
no ip domain lookup
ip vrf vrf1
rd 1:1
route-target export 1:1
route-target import 1:1
!
no ip dhcp use vrf connected
!
!
!
!
no subscriber policy recording rules
 

次の行は、加入者冗長性ポリシーの設定を示します。

subscriber redundancy dynamic limit cpu 90 delay 10
subscriber redundancy bulk limit cpu 90 delay 10
subscriber redundancy rate 4000 1
subscriber redundancy delay 10
no mpls traffic-eng
mpls ldp graceful-restart
mpls ldp router-id Loopback100
no virtual-template snmp
no issu config-sync policy bulk prc
no issu config-sync policy bulk bem
!
redundancy mode sso
username cisco password 0 cisco
!
bba-group pppoe grp1
virtual-template 1
!
bba-group pppoe grp2
virtual-template 2
!
bba-group pppoe grp3
virtual-template 3
!
bba-group pppoe grp4
virtual-template 4
!
bba-group pppoe grp5
virtual-template 5
!
bba-group pppoe grp7
virtual-template 7
!
bba-group pppoe grp8
virtual-template 8
!
bba-group pppoe grp6
virtual-template 6
!
!
interface Loopback0
ip vrf forwarding vrf1
ip address 10.1.1.1 255.255.255.255
!
interface Loopback100
ip address 192.168.0.1 255.255.255.255
!
interface FastEthernet0/0/0
ip address 192.168.2.26 255.255.255.0
speed 100
full-duplex
!
interface GigabitEthernet1/0/0
no ip address
load-interval 30
!
interface GigabitEthernet1/0/0.1
encapsulation dot1Q 2
pppoe enable group grp1
!
!
interface GigabitEthernet1/0/0.2
encapsulation dot1Q 2
pppoe enable group grp2
!
!
interface GigabitEthernet1/0/1
no ip address
!
interface GigabitEthernet1/0/1.1
encapsulation dot1Q 2
pppoe enable group grp3
!
!
interface GigabitEthernet1/0/1.2
encapsulation dot1Q 2
pppoe enable group grp4
!
!
interface GigabitEthernet1/0/2
no ip address
!
interface GigabitEthernet1/0/2.1
encapsulation dot1Q 2
pppoe enable group grp5
!
!
interface GigabitEthernet1/0/2.2
encapsulation dot1Q 2
pppoe enable group grp6
!
!
interface GigabitEthernet1/0/3
no ip address
!
interface GigabitEthernet1/0/3.1
encapsulation dot1Q 2
pppoe enable group grp7
!
!
interface GigabitEthernet1/0/3.2
encapsulation dot1Q 2
pppoe enable group grp8
!
interface GigabitEthernet7/0/3
no ip address
!
interface GigabitEthernet8/0/0
mac-address 0011.0022.0033
ip vrf forwarding vrf1
ip address 10.1.1.2 255.255.255.0
negotiation auto
!
interface GigabitEthernet8/1/0
ip address 10.1.1.1 255.255.255.0
negotiation auto
mpls ip
!
interface Virtual-Template1
ip vrf forwarding vrf1
ip unnumbered Loopback0
no logging event link-status
peer default ip address pool pool1
no snmp trap link-status
keepalive 30
ppp authentication pap
!
interface Virtual-Template2
ip vrf forwarding vrf1
ip unnumbered Loopback0
no logging event link-status
peer default ip address pool pool2
no snmp trap link-status
keepalive 30
ppp authentication pap
!
interface Virtual-Template3
ip vrf forwarding vrf1
ip unnumbered Loopback0
no logging event link-status
peer default ip address pool pool3
no snmp trap link-status
keepalive 30
ppp authentication pap
!
interface Virtual-Template4
ip vrf forwarding vrf1
ip unnumbered Loopback0
no logging event link-status
peer default ip address pool pool4
no snmp trap link-status
keepalive 30
ppp authentication pap
!
interface Virtual-Template5
ip vrf forwarding vrf1
ip unnumbered Loopback0
no logging event link-status
peer default ip address pool pool5
no snmp trap link-status
keepalive 30
ppp authentication pap
!
interface Virtual-Template6
ip vrf forwarding vrf1
ip unnumbered Loopback0
no logging event link-status
peer default ip address pool pool6
no snmp trap link-status
keepalive 30
ppp authentication pap
!
interface Virtual-Template7
ip vrf forwarding vrf1
ip unnumbered Loopback0
no logging event link-status
peer default ip address pool pool7
no snmp trap link-status
keepalive 30
ppp authentication pap
!
interface Virtual-Template8
ip vrf forwarding vrf1
ip unnumbered Loopback0
no logging event link-status
peer default ip address pool pool8
no snmp trap link-status
keepalive 30
ppp authentication pap
!
router ospf 1
log-adjacency-changes
nsf
network 10.1.1.0 0.0.0.255 area 0
network 224.0.0.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 224.0.0.3 remote-as 1
neighbor 224.0.0.3 update-source Loopback100
no auto-summary
!
address-family vpnv4
neighbor 224.0.0.3 activate
neighbor 224.0.0.3 send-community extended
exit-address-family
!
address-family ipv4 vrf vrf1
redistribute connected
redistribute static
no auto-summary
no synchronization
exit-address-family
!
ip local pool pool2 10.1.1.1 10.1.16.160
ip local pool pool3 10.13.1.1 10.13.16.160
ip local pool pool4 10.14.1.1 10.14.16.160
ip local pool pool5 10.15.1.1 10.15.16.160
ip local pool pool6 10.16.1.1 10.16.16.160
ip local pool pool7 10.17.1.1 10.17.16.160
ip local pool pool8 10.18.1.1 10.18.16.160
ip classless !
!
no ip http server
!
!
arp 10.20.1.1 0020.0001.0001 ARPA
arp vrf vrf1 10.20.1.1 0020.0001.0001 ARPA !
!
!
line con 0
line aux 0
line vty 0 4
password cisco
!
exception crashinfo file bootflash:crash.log !
end
 

その他の関連資料

ここでは、ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー機能に関する関連資料について説明します。

関連マニュアル

内容
参照先

ハイ アベイラビリティ

Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide 』の「High Availability Overview」の章

ISSU の実行

Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide 』の次の章

「Cisco IOS XE Software Package Compatibility for ISSU」

「In Service Software Upgrade (ISSU)」

ブロードバンド ISSU

『Broadband High Availability In Service Software Upgrade』

ステートフル スイッチオーバー

『Stateful Switchover』

シスコ ノンストップ フォワーディング

『Cisco Nonstop Forwarding』

レイヤ 2 トンネル プロトコル

『Layer 2 Tunnel Protocol Technology Brief』

このマニュアルで使用しているコマンドのその他の情報

『Cisco IOS Broadband Access Aggregation and DSL Command Reference』

『Cisco IOS Master Command List, All Releases』

標準

標準
タイトル

この機能によりサポートされた新規標準または改訂標準はありません。またこの機能による既存標準のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS XE リリース、およびフィーチャ セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバーの機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator により、どの Cisco IOS XE のソフトウェア イメージが特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームをサポートするか調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS XE ソフトウェア リリース群で特定の機能をサポートする Cisco IOS XE ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS XE ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 ブロードバンド ハイ アベイラビリティ ステートフル スイッチオーバー機能の機能情報

機能名
リリース
機能情報

SSO--PPPoE

Cisco IOS XE Release 2.1、

Cisco IOS XE Release 2.5

この機能は、Cisco IOS XE Release 2.1 で、Cisco ASR 1000 ルータに実装されました。

この機能は、二重のルート プロセッサ システムに対して PPPoX セッションのステートフル スイッチオーバーをサポートする機能を提供し、システムの制御およびルーティング プロトコルの実行をアクティブ プロセッサとスタンバイ プロセッサ間で転送するときにアプリケーションと機能で状態を維持できるようにするため、SSO--PPPoE 機能を使用します。

次のコマンドが導入または変更されました。 clear ppp subscriber statistics clear pppoe statistics debug pppoe redundancy、show ccm clients、show ccm sessions、show ppp subscriber statistics、 show pppoe statistic、subscriber redundancy