Cisco 4000 シリーズ ISR ソフトウェア コンフィギュレーション ガイド
ルータの基本設定
ルータの基本設定

ルータの基本設定

ここでは、ルータの基本設定について説明します。次の項で構成されています。

デフォルト設定

ルータを初めて起動すると、一部の基本設定がすでに完了していることがわかります。 初期設定を表示するには、次の例に示すように show running-config コマンドを使用します。

Router# show running-config
Building configuration...
Current configuration : 977 bytes
!
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
no aaa new-model
!
ipv6 multicast rpf use-bgp
!
!
multilink bundle-name authenticated
!
!
redundancy
mode none
!
 
interface GigabitEthernet0/0/0
no ip address
negotiation auto
!
interface GigabitEthernet0/0/1
no ip address
negotiation auto
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
!
interface GigabitEthernet0/0/3
no ip address
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
negotiation auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
 
!
control-plane
!
!
line con 0
stopbits 1
line vty 0 4
login
!
!
end
 

グローバル パラメータの設定

ルータのグローバル パラメータを設定するには、次の手順を実行します。

手順の概要

    1.    configure terminal

    2.    hostname name

    3.    enable secret password

    4.    no ip domain-lookup


手順の詳細
     コマンドまたはアクション目的
    ステップ 1configure terminal


    例:
    Router> enable
    Router# configure terminal
    Router(config)#
     

    グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。

    次のコマンドを使用して、ルータとリモート ターミナルを接続します。

    telnet router-name or address
    Login: login-id
    Password: *********
    Router> enable
     
    ステップ 2hostname name


    例:
    Router(config)# hostname Router
     

    ルータ名を指定します。

     
    ステップ 3enable secret password


    例:
    Router(config)# enable secret cr1ny5ho
     

    ルータへの不正なアクセスを防止するには、暗号化パスワードを指定します。

     
    ステップ 4no ip domain-lookup


    例:
    Router(config)# no ip domain-lookup
     

    ルータが未知の単語(入力ミス)を IP アドレスに変換しないようにします。

    グローバル パラメータ コマンドの詳細については、『Cisco IOS Release Configuration Guide』マニュアル セットを参照してください。

     

    ギガビット イーサネット インターフェイスの設定

    オンボードのギガビット イーサネットインターフェイスを手動で定義するには、グローバル コンフィギュレーション モードから開始して、次の手順を実行します。

    手順の概要

      1.    interface gigabitethernet slot/bay/port

      2.    ip address ip-address mask

      3.    ipv6 address ipv6-address/prefix

      4.    no shutdown

      5.    exit


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 interface gigabitethernet slot/bay/port


      例:
      Router(config)# interface gigabitethernet 0/0/1
       

      ルータ上で ギガビット イーサネット インターフェイスのコンフィギュレーション モードを開始します。

       
      ステップ 2 ip address ip-address mask


      例:
      Router(config-if)# ip address 192.168.12.2 255.255.255.0
       

      指定したギガビット イーサネット インターフェイスの IP アドレスとサブネット マスクを設定します。 IPv4 アドレスを設定する場合は、このステップを使用します。

       
      ステップ 3ipv6 address ipv6-address/prefix


      例:
      Router(config-if)# ipv6 address 2001.db8::ffff:1/128
       

      指定したギガビット イーサネット インターフェイスの IPv6 アドレスとプレフィクスを設定します。 IPv6 アドレスを設定する場合は、ステップ 2 の代わりにこのステップを使用します。

       
      ステップ 4no shutdown


      例:
      Router(config-if)# no shutdown
       

      ギガビット イーサネット インターフェイスをイネーブルにし、その状態を管理上のダウンから管理上のアップに変更します。

       
      ステップ 5 exit


      例:
      Router(config-if)# exit
       

      ギガビット イーサネット インターフェイスのコンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

       

      ループバック インターフェイスの設定

      はじめる前に

      ループバック インターフェイスは、スタティック IP アドレスのプレースホルダーとして機能し、デフォルトのルーティング情報を提供します。

      ループバック インターフェイスを設定するには、次の手順を実行します。

      手順の概要

        1.    interface type number

        2.    (オプション 1)ip address ip-address mask

        3.    (オプション 2) ipv6 address ipv6-address/prefix

        4.    exit


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 interface type number


        例:
        Router(config)# interface Loopback 0
        
         

        ループバック インターフェイスのコンフィギュレーション モードを開始します。

         
        ステップ 2(オプション 1)ip address ip-address mask

        例:
        Router(config-if)# ip address 10.108.1.1 255.255.255.0
         

        ループバック インターフェイスの IP アドレスとサブネット マスクを設定します。 IPv6 アドレスを設定する場合は、次に説明する ipv6 address ipv6-address/prefix コマンドを使用します。

         
        ステップ 3(オプション 2) ipv6 address ipv6-address/prefix

        例:
        Router(config-if)# 2001:db8::ffff:1/128
         

        ループバック インターフェイスの IPv6 アドレスとプレフィクスを設定します。

         
        ステップ 4 exit


        例:
        Router(config-if)# exit
         

        ループバック インターフェイスのコンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードに戻ります。

         

        このコンフィギュレーション例のループバック インターフェイスは、仮想テンプレート インターフェイス上の NAT をサポートするために使用されています。 この設定例は、スタティック IP アドレスとして機能する IP アドレス 192.0.2.0/24 のギガビット イーサネット インターフェイス上に設定されるループバック インターフェイスを示しています。 ループバック インターフェイスは、ネゴシエートされた IP アドレスを持つ virtual-template1 にポイントバックします。

        !
        interface loopback 0
        ip address 192.0.2.0 255.255.255.0 (static IP address)
        ip nat outside
        !
        interface Virtual-Template1
        ip unnumbered loopback0
        no ip directed-broadcast
        ip nat outside

        show interface loopback コマンドを入力します。 次の例のような出力が表示されます。

        Router# show interface loopback 0
        Loopback0 is up, line protocol is up 
          Hardware is Loopback
          Internet address is 200.200.100.1/24
          MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec, 
             reliability 255/255, txload 1/255, rxload 1/255
          Encapsulation LOOPBACK, loopback not set
          Last input never, output never, output hang never
          Last clearing of "show interface" counters never
          Queueing strategy: fifo
          Output queue 0/0, 0 drops; input queue 0/75, 0 drops
          5 minute input rate 0 bits/sec, 0 packets/sec
          5 minute output rate 0 bits/sec, 0 packets/sec
             0 packets input, 0 bytes, 0 no buffer
             Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
             0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
             0 packets output, 0 bytes, 0 underruns
             0 output errors, 0 collisions, 0 interface resets
             0 output buffer failures, 0 output buffers swapped out
        

        または、次の例に示すように、ping コマンドを使用してループバック インターフェイスを確認します。

        Router# ping 192.0.2.0
        Type escape sequence to abort.
        Sending 5, 100-byte ICMP Echos to 192.0.2.0, timeout is 2 seconds:
        !!!!!
        Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
        

        モジュール インターフェイスの設定

        サービス モジュールの設定の詳細については、『Cisco SM-1T3/​E3 Service Module Configuration Guide』の「Service Module Management」の項の「Service Modules」を参照してください。

        Cisco Discovery Protocol の有効化

        ルータでは、Cisco Discovery Protocol(CDP)がデフォルトでイネーブルに設定されています。


        (注)  


        Cisco アグリゲーション サービス ルータまたは Cisco CSR 1000v では、CDP はデフォルトでイネーブルに設定されていません。


        CDP の使用法の詳細については、『Cisco Discovery Protocol Configuration Guide, Cisco IOS XE Release 3S』を参照してください。

        コマンドライン アクセスの設定

        ルータへのアクセスを制御するパラメータを設定するには、次の手順を実行します。

        手順の概要

          1.    line [aux | console | tty | vty] line-number

          2.    password password

          3.    login

          4.    exec-timeout minutes [seconds]

          5.    exit

          6.    line [aux | console | tty | vty] line-number

          7.    password password

          8.    login

          9.    end


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 line [aux | console | tty | vty] line-number


          例:
          Router(config)# line console 0
           

          回線コンフィギュレーション モードを開始します。続いて、回線のタイプを指定します。

          ここに示す例では、アクセス用のコンソール端末を指定します。

           
          ステップ 2password password


          例:
          Router(config-line)# password 5dr4Hepw3
           

          コンソール端末回線に固有のパスワードを指定します。

           
          ステップ 3login


          例:
          Router(config-line)# login
           

          端末セッション ログイン時のパスワード チェックをイネーブルにします。

           
          ステップ 4exec-timeout minutes [seconds]


          例:
          Router(config-line)# exec-timeout 5 30
          Router(config-line)#
           

          ユーザ入力が検出されるまで EXEC コマンド インタープリタが待機する間隔を設定します。 デフォルトは 10 分です。 任意指定で、間隔値に秒数を追加します。

          ここに示す例は、5 分 30 秒のタイムアウトを示しています。 タイムアウト値「0 0」を入力すると、タイムアウトが発生しません。

           
          ステップ 5 exit


          例:
          Router(config-line)# exit
           

          回線コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードを再開します。

           
          ステップ 6 line [aux | console | tty | vty] line-number


          例:
          Router(config)# line vty 0 4
          Router(config-line)#
           

          リモート コンソール アクセス用の仮想端末を指定します。

           
          ステップ 7password password


          例:
          Router(config-line)# password aldf2ad1
           

          仮想端末回線に固有のパスワードを指定します。

           
          ステップ 8 login


          例:
          Router(config-line)# login
           

          仮想端末セッション ログイン時のパスワード チェックをイネーブルにします。

           
          ステップ 9end


          例:
          Router(config-line)# end
           

          回線コンフィギュレーション モードを終了します。続いて、特権 EXEC モードに戻ります。

           

          次の設定は、コマンドライン アクセス コマンドを示します。

          default と示されているコマンドは、入力する必要はありません。 これらのコマンドは、show running-config コマンドの使用時に、生成されたコンフィギュレーション ファイルに自動的に示されます。

          !
          line console 0
          exec-timeout 10 0
          password 4youreyesonly
          login
          transport input none (default)
          stopbits 1 (default)
          line vty 0 4
          password secret
          login
          !

          スタティック ルートの設定

          スタティック ルートは、ネットワークを介した固定ルーティング パスを提供します。 これらは、ルータ上で手動で設定されます。 ネットワーク トポロジが変更された場合には、スタティック ルートを新しいルートに更新する必要があります。 スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベート ルートです。

          スタティック ルートを設定するには、次の手順を実行します。

          手順の概要

            1.    (オプション 1) ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

            2.    (オプション 2) ipv6 route prefix/mask {ipv6-address | interface-type interface-number [ipv6-address]}

            3.    end


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1(オプション 1) ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

            例:
            Router(config)# ip route 192.168.1.0 255.255.0.0 10.10.10.2
            
             

            IP パケットのスタティック ルートを指定します。 (IPv6 アドレスを設定する場合は、次に説明する ipv6 address コマンドを使用してください。)

             
            ステップ 2(オプション 2) ipv6 route prefix/mask {ipv6-address | interface-type interface-number [ipv6-address]}

            例:
            Router(config)# ipv6 route 2001:db8:2::/64
             

            IP パケットのスタティック ルートを指定します。

             
            ステップ 3 end


            例:
            Router(config)# end
            
             

            グローバル コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

             

            次の設定例は、宛先 IP アドレスが 192.168.1.0、サブネット マスクが 255.255.255.0 のすべての IP パケットを、IP アドレス 10.10.10.2 の他の装置に対して、ギガビット インターフェイス上からスタティック ルートで送信します。 具体的には、パケットが設定済みの PVC に送信されます。

            default と示されているコマンドは、入力する必要はありません。 このコマンドは、running-config コマンドの使用時に、生成されたコンフィギュレーション ファイルに自動的に示されます。

            !
            ip classless (default)
            ip route 192.168.1.0 255.255.255.0
            

            スタティック ルートが正しく設定されていることを確認するには、show ip route コマンド(または show ipv6 route コマンド)を入力し、文字 S で示されるスタティック ルートを見つけます。

            IPv4 アドレスを使用する場合は、次のような確認用の出力が表示されます。

            Router# show ip route
            Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
                   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
                   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
                   E1 - OSPF external type 1, E2 - OSPF external type 2
                   i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
                   ia - IS-IS inter area, * - candidate default, U - per-user static route
                   o - ODR, P - periodic downloaded static route
            
            Gateway of last resort is not set
            
                 10.0.0.0/24 is subnetted, 1 subnets
            C       10.108.1.0 is directly connected, Loopback0
            S*   0.0.0.0/0 is directly connected, FastEthernet0
            

            IPv6 アドレスを使用する場合は、次のような確認用の出力が表示されます。

            Router# show ipv6 route
            IPv6 Routing Table - default - 5 entries
            Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
                   B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
                   I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
                   EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE -
            Destination
                   NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
                   OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
                   ls - LISP site, ld - LISP dyn-EID, a - Application
            
            C   2001:DB8:3::/64 [0/0]
                   via GigabitEthernet0/0/2, directly connected
            S   2001:DB8:2::/64 [1/0]
                   via 2001:DB8:3::1
            

            ダイナミック ルートの設定

            ダイナミック ルーティングでは、ネットワーク トラフィックまたはトポロジに基づいて、ネットワーク プロトコルがパスを自動調整します。 ダイナミック ルーティングの変更は、ネットワーク上の他のルータにも反映されます。

            ルータは、ルーティング情報プロトコル(RIP)または Enhanced Interior Gateway Routing Protocol(EIGRP)などの IP ルーティング プロトコルを使用して、ルートを動的に学習できます。

            Routing Information Protocol の設定

            ルータの RIP を設定するには、次の手順を実行します。

            手順の概要

              1.    router rip

              2.    version {1 | 2}

              3.    network ip-address

              4.    no auto-summary

              5.    end


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1 router rip


              例:
              Router(config)# router rip
              
               

              ルータ コンフィギュレーション モードを開始します。続いて、ルータの RIP をイネーブルにします。

               
              ステップ 2 version {1 | 2}


              例:
              Router(config-router)# version 2
               

              RIP version 1 または 2 の使用を指定します。

               
              ステップ 3 network ip-address


              例:
              Router(config-router)# network 192.168.1.1
              Router(config-router)# network 10.10.7.1
               

              直接接続しているネットワークの各アドレスを使用して、RIP を適用するネットワーク リストを指定します。

               
              ステップ 4 no auto-summary


              例:
              Router(config-router)# no auto-summary
              
               

              ネットワークレベル ルートへのサブネット ルートの自動サマライズをディセーブルにします。 これにより、サブプレフィックス ルーティング情報がクラスフル ネットワーク境界を越えて送信されます。

               
              ステップ 5 end


              例:
              Router(config-router)# end
              
               
              ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。  

              次の設定例は、IP ネットワーク 10.0.0.0 および 192.168.1.0 でイネーブルにされる RIP version 2 を示します。 設定を表示するには、特権 EXEC モードで show running-config コマンドを使用します。

              !
              Router# show running-config
              Building configuration...
              
              Current configuration : 1616 bytes
              !
              ! Last configuration change at 03:17:14 EST Thu Sep 6 2012
              !
              version 15.3
              service timestamps debug datetime msec
              service timestamps log datetime msec
              no platform punt-keepalive disable-kernel-core
              !
              hostname Router
              !
              boot-start-marker
              boot-end-marker
              !
              !
              vrf definition Mgmt-intf
               !
               address-family ipv4
               exit-address-family
               !
               address-family ipv6
               exit-address-family
              !
              enable password cisco
              !
              no aaa new-model
              !
              transport-map type console consolehandler
               banner wait ^C
              Waiting for IOS vty line
              ^C
               banner diagnostic ^C
              Welcome to diag mode
              ^C
              !
              clock timezone EST -4 0
              !
              !
              
              
              ip domain name cisco.com
              ip name-server vrf Mgmt-intf 203.0.113.1
              ip name-server vrf Mgmt-intf 203.0.113.129
              
              !
              ipv6 multicast rpf use-bgp
              !
              !
              multilink bundle-name authenticated
              !
              redundancy
               mode none
              !
              ip ftp source-interface GigabitEthernet0
              ip tftp source-interface GigabitEthernet0
              !
              !
              interface GigabitEthernet0/0/0
               no ip address
               negotiation auto
              !
              interface GigabitEthernet0/0/1
               no ip address
               negotiation auto
              !
              interface GigabitEthernet0/0/2
               no ip address
               negotiation auto
              !
              interface GigabitEthernet0/0/3
               no ip address
               negotiation auto
              !
              interface GigabitEthernet0
               vrf forwarding Mgmt-intf
               ip address 172.18.77.212 255.255.255.240
               negotiation auto
              !
              ip forward-protocol nd
              !
              no ip http server
              no ip http secure-server
              ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 172.18.77.209
              !
              control-plane
              !
              !
              line con 0
               stopbits 1
              line aux 0
               stopbits 1
              line vty 0 4
               password cisco
               login
              !
              transport type console 0 input consolehandler
              !
              ntp server vrf Mgmt-intf 10.81.254.131
              !
              end 
              

              RIP が正しく設定されていることを確認するには、show ip route コマンドを入力し、文字 R で示される RIP ルートを見つけます。 次の例のような出力が表示されます。

              Router# show ip route
              Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
                     D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
                     N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
                     E1 - OSPF external type 1, E2 - OSPF external type 2
                     i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
                     ia - IS-IS inter area, * - candidate default, U - per-user static route
                     o - ODR, P - periodic downloaded static route
              
              Gateway of last resort is not set
              
                   10.0.0.0/24 is subnetted, 1 subnets
              C       10.108.1.0 is directly connected, Loopback0
              R    3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0/0
              

              拡張インテリア ゲートウェイ ルーティング プロトコルの設定

              拡張インテリア ゲートウェイ ルーティング プロトコル(EIGRP)を設定するには、次の手順を実行します。

              手順の概要

                1.    router eigrp as-number

                2.    network ip-address

                3.    end


              手順の詳細
                 コマンドまたはアクション目的
                ステップ 1 router eigrp as-number


                例:
                Router(config)# router eigrp 109
                
                 

                ルータ コンフィギュレーション モードを開始して、ルータ上で EIGRP をイネーブルにします。 自律システム(AS)番号は、他の EIGRP ルータへのルートを識別します。また、EIGRP 情報のタグ付けに使用されます。

                 
                ステップ 2 network ip-address


                例:
                Router(config)# network 192.168.1.0
                Router(config)# network 10.10.12.115
                
                 

                EIGRP を適用するネットワークのリストを指定します(直接接続されているネットワークの IP アドレスを使用)。

                 
                ステップ 3 end


                例:
                Router(config-router)# end
                
                 
                ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。  

                次の設定例は、IP ネットワーク 192.168.1.0 および 10.10.12.115 でイネーブルにされる EIGRP ルーティング プロトコルを示します。 EIGRP の自律システム番号として、109 が割り当てられています。 この設定を表示するには、show running-config コマンドを使用します。

                Router# show running-config
                .
                .
                .
                !
                router eigrp 109
                	network 192.168.1.0
                		network 10.10.12.115
                !
                .
                .
                .
                

                IP EIGRP を正しく設定したことを確認するには、show ip route コマンドを入力し、文字 D のマークが付いている EIGRP ルートを見つけます。 次のような確認用の出力が表示されます。

                Router# show ip route
                Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
                       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
                       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
                       E1 - OSPF external type 1, E2 - OSPF external type 2
                       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
                       ia - IS-IS inter area, * - candidate default, U - per-user static route
                       o - ODR, P - periodic downloaded static route
                
                Gateway of last resort is not set
                
                     10.0.0.0/24 is subnetted, 1 subnets
                C       10.108.1.0 is directly connected, Loopback0
                D    	3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0