Cisco 4000 シリーズ ISR ソフトウェア コンフィギュレーション ガイド
管理インターフェイスの使用
管理インターフェイスの使用

目次

管理インターフェイスの使用

外部のユーザおよびアプリケーション向けに次の管理インターフェイスが提供されています。

ギガビット イーサネット管理インターフェイス

ギガビット イーサネット管理インターフェイスの概要

ルータには、GigabitEthernet0 という名前のイーサネット管理ポートがあります。

イーサネット管理ポートにより、ルータ上で管理タスクを実行できます。 このインターフェイスでは、ネットワーク トラフィック転送を実行してはなりなせん(または、しばしば実行できません) 。ただしこのインターフェースを使用して、Telnet および Secure Shell(SSH)を介してルータにアクセスし、ルータで管理タスクを実行することができます。 このインターフェイスは、ルータがルーティングを開始する前か、またはその他の転送インターフェイスが非アクティブ時にトラブルシューティングを行う場合に有用な機能を提供します。

イーサネット管理インターフェイスのいくつかの重要な点を以下に示します。

  • ルータには、GigabitEthernet0 という名前のイーサネット管理インターフェイスが 1 つあります。

  • インターフェイスでサポートされるルーテッド プロトコルは、IPv4 および IPv6 だけです。

  • 管理インターフェイスは、転送インターフェイスが機能していない場合や、システム プロセスがダウンしている場合でも、ルータにアクセスできる手段となります。

  • イーサネット管理インターフェイスは、独自の仮想ルーティングおよび転送(VRF)の一部です。 詳細については、ギガビット イーサネット管理インターフェイスの VRFを参照してください。

ギガビット イーサネットのデフォルト構成

デフォルトでは、Mgmt-intf という名前の特殊なグループを持つイーサネット管理インターフェイス用に転送 VRF が設定されます。 この設定は変更できません。 Mgmt-intf という名前の特殊グループを持つインターフェイスの転送 VRF を設定することで、イーサネット管理インターフェイスのトラフィックを、転送プレーンから分離できるようになります。 そうしないと、ほとんどの機能に対して、インターフェイスが他のギガビット イーサネット インターフェイスと同じように設定できてしまいます。

たとえば、デフォルト設定は次のとおりです。

Router(config)# interface GigabitEthernet0
Router(config-if)# vrf forwarding Mgmt-intf

ギガビット イーサネット ポートの番号

ギガビット イーサネット管理ポートは常に GigabitEthernet0 であり、このポートにはグローバル コンフィギュレーション モードでアクセスできます。次に例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface gigabitethernet0
Router(config-if)#

ギガビット イーサネット管理インターフェイスの VRF

ギガビット イーサネット管理インターフェイスは、自動的に自身の VRF の一部となります。 Mgmt-intf という名前の VRF がルータで自動的に設定され、管理イーサネット インターフェイス専用として使用されます。その他のインターフェイスはこの VRF に参加できず、管理 VRF に他のインターフェイスを配置することもできません。 管理イーサネット インターフェイス VRF は、MPLS VPN VRF やその他のネットワーク全体の VRF に参加しません。

ギガビット イーサネット管理インターフェイスをそれ自体の VRF 内に配置すると、管理イーサネット インターフェイスに次のような影響が生じます。

  • 複数の機能の設定が必要となる:他のルータと比較して、Cisco IOS CLI は特定の管理イーサネット機能の点で異なることがあるため、多数の VRF 機能を設定または使用する必要があります。

  • 中継トラフィックがルータを通過できなくなる:すべてのモジュール インターフェイスと管理イーサネット インターフェイスは異なる VRF に自動的に配置されるため、中継トラフィックは管理イーサネット インターフェイスから入ってモジュール インターフェイスを出たり、またはその逆に通過したりできません。

  • インターフェイスのセキュリティが向上する:Mgmt-intf VRF はそれ自体の VRF 内にあるため、独自のルーティング テーブルを持ちます。このため、管理イーサネット インターフェイスのルーティング テーブルにルートが追加されるのは、明示的にルートを入力した場合だけです。

管理イーサネット インターフェイス VRF では、IPv4 と IPv6 の両方のアドレス ファミリがサポートされます。


(注)  


Mgmt-intf VRF の一部として、ギガビット イーサネット管理インターフェイス(およびループバック インターフェイス)だけを設定できます。 この VRF では他のインターフェイスを設定できません。


共通のギガビット イーサネット管理タスク

イーサネット管理インターフェイスにアクセスして、ルータで次のタスクを実行できます。


(注)  


これは、イーサネット管理インターフェイスを使用して実行できるすべてのタスクをリストしているわけではありません。


VRF 設定の表示

ギガビット イーサネット管理インターフェイスの VRF 設定を表示するには、show running-config vrf コマンドを使用します。 次に、VRF のデフォルト設定の例を示します。

Router# show running-config vrf
 
Building configuration...
 
Current configuration : 351 bytes
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
(some output removed for brevity)

ギガビット イーサネット管理 VRF の詳細情報の表示

ギガビット イーサネット管理 VRF の詳細情報を表示するには、次の例に示すように show vrf detail Mgmt-intf コマンドを入力します。

Router# show vrf detail Mgmt-intf
 
VRF Mgmt-intf (VRF Id = 4085); default RD <not set>; default VPNID <not set>
Interfaces:
Gi0
Address family ipv4 (Table ID = 4085 (0xFF5)):
No Export VPN route-target communities
No Import VPN route-target communities
No import route-map
No export route-map
VRF label distribution protocol: not configured
VRF label allocation mode: per-prefix
Address family ipv6 (Table ID = 503316481 (0x1E000001)):
No Export VPN route-target communities
No Import VPN route-target communities
No import route-map
No export route-map
VRF label distribution protocol: not configured
VRF label allocation mode: per-prefix

管理イーサネット インターフェイス VRF でのデフォルト ルートの設定

ギガビット イーサネット管理インターフェイス VRF でデフォルト ルートを設定するには、次のコマンドを入力できます。

Router(config)# ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 next-hop-IP-address

IPv6 アドレスを使用して管理イーサネット インターフェイス VRF でデフォルト ルートを設定するには、次のコマンドを入力します。

Router(config)# ipv6 route vrf Mgmt-intf : : /next-hop-IPv6-address/

ギガビット イーサネット管理 IP アドレスの設定

ギガビット イーサネット管理ポートの IP アドレスは、他のインターフェイスの IP アドレスと同様の方法で設定できます。

イーサネット管理インターフェイスの IPv4 アドレスを設定するには、次のコマンドを入力します。

Router(config)# interface GigabitEthernet 0
Router(config-if)# ip address A.B.C.D A.B.C.D

イーサネット管理インターフェイスの IPv6 アドレスを設定するには、次のコマンドを入力します。

Router(config)# interface GigabitEthernet 0
Router(config-if)# ipv6 address X:X:X:X::X

ギガビット イーサネット管理インターフェイスを介した Telnet の使用

Telnet を使用して、ギガビット イーサネット管理インターフェイス VRF を介してルータに接続するには、telnet コマンドとルータの IP アドレスを使用します。

Telnet を使用してルータの IPv4 アドレスに接続するには、次のコマンドを入力します。

Router# telnet 172.17.1.1 /vrf Mgmt-intf

Telnet を使用してルータの IPv6 アドレスに接続するには、次のコマンドを入力します。

Router# telnet 2001:db8::abcd /vrf Mgmt-intf

ギガビット イーサネット管理インターフェイスを介した ping

VRF でイーサネット管理インターフェイスを使用して、他のインターフェイスに対する ping を実行できます。

IPv4 アドレスのインターフェイスに ping を実行するには、次のコマンドを入力します。

Router# ping vrf Mgmt-intf 172.17.1.1

IPv6 アドレスのインターフェイスに ping を実行するには、次のコマンドを入力します。

Router# ping vrf Mgmt-intf 2001:db8::abcd

TFTP または FTP を使用したファイルのコピー

Trivial File Transfer Protocol(TFTP)を使用してイーサネット管理インターフェイス経由でファイルをコピーするには、copy tftp コマンドの前に ip tftp source-interface GigabitEthernet 0 コマンドを入力する必要があります。これは、copy tftp コマンドで VRF 名を指定するオプションがないためです。

同様に、FTP を使用して管理イーサネット インターフェイス経由でファイルをコピーするには、copy ftp コマンドの入力前に ip ftp source-interface GigabitEthernet 0 コマンドを入力する必要があります。これもやはり、copy ftp コマンドに VRF 名を指定するオプションがないためです。

次に、TFTP を使用してファイルをコピーする例を示します。

Router(config)# ip tftp source-interface gigabitEthernet 0

次に、FTP を使用してファイルをコピーする例を示します。

Router(config)# ip ftp source-interface gigabitEthernet 0
 
Building configuration...
-	Omitted lines -
!
!
ip ftp source-interface GigabitEthernet0
ip tftp source-interface GigabitEthernet0
!

NTP サーバを使用したソフトウェア クロックの設定

ギガビット イーサネット管理インターフェイスを通じてネットワーク タイム プロトコル(NTP)タイム サーバと同期をとれるようにソフトウェア クロックを設定するには、ntp server vrf Mgmt-intf コマンドを入力し、アップデートを提供するデバイスの IP アドレスを指定します。

IPv4 アドレスを使用してイーサネット管理インターフェイスで NTP サーバを設定するには、次のコマンドを入力します。

Router(config)# ntp server vrf Mgmt-intf 172.17.1.1

IPv6 アドレスを使用してイーサネット管理インターフェイスで NTP サーバを設定するには、次のコマンドを入力します。

Router(config)# ntp server vrf Mgmt-intf 2001:db8::abcd

ロギング

ロギングの送信元 IP または IPv6 アドレスとしてギガビット イーサネット管理インターフェイスを指定するには、logging host ip-address vrf Mgmt-intf コマンドを入力します。

Router(config)# logging host 172.17.1.1 vrf Mgmt-intf

SNMP-Related サービス

ギガビット イーサネット管理インターフェイスをすべての SNMP トラップ メッセージのソースとして指定するには、snmp-server source-interface traps gigabitethernet 0 コマンドを入力します。

Router(config)# snmp-server source-interface traps gigabitethernet 0

ドメイン名の割り当て

VRF を介したギガビット イーサネット管理インターフェイス用の IP ドメイン名を割り当てます。

デフォルトのドメイン名をギガビット イーサネット管理 VRF インターフェイスとして定義するには、ip domain-name vrf Mgmt-intf domain コマンドを入力します。

Router(config)# ip domain-name vrf Mgmt-intf cisco.com

DNS の割り当て

イーサネット管理インターフェイス VRF をネーム サーバとして指定するには、ip name-server vrf Mgmt-intf IPv4-or-IPv6-address コマンドを入力します。

Router(config)# ip name-server vrf Mgmt-intf A.B.C.D

または

Router(config)# ip name-server vrf Mgmt-intf X:X:X:X::X

RADIUS または TACACS+ サーバ グループの設定

管理 VRF を AAA サーバ グループの一部としてグループ化するには、AAA サーバ グループの設定時に ip vrf forward Mgmt-intf コマンドを入力します。

TACACS+ サーバ グループを設定する場合も、同様にします。 管理 VRF を TACACS+ サーバ グループの一部としてグループ化するには、TACACS+ サーバ グループの設定時に ip vrf forwarding Mgmt-intf コマンドを入力します。

次に、RADIUS サーバ グループを設定する例を示します。

Router(config)# aaa group server radius hello
Router(config-sg-radius)# ip vrf forwarding Mgmt-intf

次に、TACACS+ サーバ グループを設定する例を示します。

Router(config)# aaa group server tacacs+ hello
Router(config-sg-tacacs+)# ip vrf forwarding Mgmt-intf

VTY 回線に ACL を関連付ける

VRF を使用している(または使用していない)VTY 回線にアクセス コントロール リスト(ACL)を確実に付加するには、vrf-also キーワードを使用します。

Router(config)# line vty 0 4
Router(config-line)# access-class 90 in vrf-also

または

Router(config-line)# IPv6 access-class my-vty-acl in vrf-also

ROMMON での IP アドレス設定とイーサネット管理ポート

ROMMON で IP アドレスを設定するには、IP_ADDRESS= および IP_SUBNET_MASK= コマンドを使用できます。 また、インターフェイス コンフィギュレーション モードで ip address コマンドを使用して IP アドレスを設定することもできます。

システムが起動して Cisco IOS プロセスがルータで実行されるようになる前は、ROMMON で設定された IP アドレスが、イーサネット管理インターフェイスの IP アドレスとして機能します。

Cisco IOS プロセスが開始してイーサネット管理インターフェイスを制御するようになった後では、Cisco IOS CLI の GigabitEthernet0 インターフェイスの設定時に指定した IP ドレスが、イーサネット管理インターフェイスの IP アドレスになります。

ROMMON で定義された IP アドレスが使用されるのは、Cisco IOS プロセスがアクティブになるまでです。 したがって、ギガビット イーサネット管理インターフェイスが正しく機能するためには、ROMMON と Cisco IOS XE コマンドで指定された IP アドレスが同一である必要があります。

SNMP のイネーブル化

SNMP のイネーブル化の詳細については、SNMP-Related サービスおよび「Configuring SNMP Support」を参照してください。

Web ユーザ インターフェイス管理

Web ユーザ インターフェイスを使用してルータにアクセスできます。 Web ユーザ インターフェイスでは、わかりやすいグラフィカル インターフェイスを使用してルータのパフォーマンスを監視できます。 Web ユーザ インターフェイスを使用して、ルータのほとんどの側面を監視し、次の機能を実行することができます。

  • グラフィカルな見やすい形式での情報の表示。

  • Cisco IOS XE 統合パッケージ内の Cisco IOS サブパッケージおよび非 Cisco IOS サブパッケージに関連するプロセスなど、ほとんどのソフトウェア プロセスの監視。

  • ルータに装着されているすべての RP、NIM、SM-X など、ほとんどのハードウェア コンポーネントの監視。

  • 拡張 Web ユーザ インターフェイスに加えて、レガシー Web ユーザ インターフェイスにもアクセスできる機能。

  • show コマンド出力の収集。

ここでは、次の内容について説明します。

レガシー Web ユーザ インターフェイスの概要

これまでのシスコ ルータには、レガシー Web ユーザ インターフェイスが装備されており、これを使用してルータを監視できます。 このレガシー Web ユーザ インターフェイスは、グラフィックを使用せず、直接的に情報を表示します。 ルータでは、このインターフェイスはより広範な Web ユーザ インターフェイスの一部に取り込まれており、左側メニューの [IOS Web UI] オプションをクリックしてこれにアクセスできます。

ルータでは、Cisco IOS サブパッケージを設定および監視する目的でのみ、レガシー Web ユーザ インターフェイスを使用できます。 一部の状況では(特に ip http コマンドを入力して HTTP または HTTPS サーバがイネーブルにされているものの、適切に設定された Web ユーザ インターフェイス トランスポート マップがルータにまだ適用されていない場合には)、グラフィックベース Web ユーザ インターフェイスにアクセスできない間、レガシー Web ユーザ インターフェイスを使用できます。

IOS Web ユーザ インターフェイスのホーム ページの例を次の図に示します。

図 1. レガシー Web ユーザ インターフェイスのホーム ページ



グラフィックベース Web ユーザ インターフェイスの概要

ルータ上のグラフィックベース Web ユーザ インターフェイスは、情報の種類に応じてグラフィックベース の表、グラフ、またはチャートの形式でルータ情報を表示します。 Web ユーザ インターフェイスを使用して、Cisco IOS サブパッケージおよび Cisco IOS 以外のサブパッケージの両方に保存されているすべてのモニタ関連情報にアクセスし、ルータの詳細情報を表示できます。 次の図は、グラフィックベース Web ユーザ インターフェイスのホーム ページの例です。

図 2. グラフィックベース Web ユーザ インターフェイスのホーム ページ



固定的 Web ユーザ インターフェイス トランスポート マップの概要

ルータでグラフィックベースの Web ユーザ インターフェイスをイネーブルにするには、固定的 Web ユーザ インターフェイス トランスポート マップを設定する必要があります。 適切に設定され、ルータに適用された固定的 Web ユーザ インターフェイス トランスポート マップは、Web ユーザ インターフェイスからの着信要求をルータが処理する方法を定義します。 固定的 Web ユーザ インターフェイス トランスポート マップでは、グラフィックベース Web ユーザ インターフェイスへのアクセスに HTTP、HTTPS、またはその両方のプロトコルのいずれを使用するかを定義できます。 1 つの固定的 Web ユーザ インターフェイス マップだけをルータに適用できます。

ルータでグラフィックベース Web ユーザ インターフェイスをイネーブルにする前に、レガシー Web ユーザ インターフェイス トランスポート マップを設定する必要があります。 レガシー Web ユーザ インターフェイスを設定するには、ip http コマンド セットを使用できます。

ip http コマンドの設定は、レガシー Web ユーザ インターフェイスとグラフィックベース Web ユーザ インターフェイスの両方について、HTTP または HTTPS で使用されるポートを定義します。

ルータでの固定的 Web ユーザ インターフェイス トランスポート マップの設定を含む、グラフィックベース Web ユーザ インターフェイス全体の設定については、Web ユーザ インターフェイス アクセスの設定を参照してください。

Web ユーザ インターフェイス アクセスのイネーブル化

Web ユーザ インターフェイス アクセスの設定
はじめる前に
  • ルータでグラフィックベースの Web ユーザ インターフェイスをイネーブルにする前に、レガシー Web ユーザ インターフェイスを設定する必要があります。 ルータの Web ユーザ インターフェイスへのアクセスは、デフォルトではディセーブルになっています。

  • ルータで Web ユーザ インターフェイスを設定する前に、ギガビット イーサネット管理 VRF インターフェイスでデフォルト ルートを指定する必要があります。 ギガビット イーサネット管理インターフェイスが設定されていない場合、または機能していない場合は、Web ユーザ インターフェイスはディセーブルになります。 ルータのギガビット イーサネット管理インターフェイスでのデフォルト ルート設定については、管理イーサネット インターフェイス VRF でのデフォルト ルートの設定を参照してください。


    ステップ 1   (任意)ルータのクロック設定が正確であることを確認するために、特権 EXEC モードで show clock コマンドを入力します。
    Router# show clock
    *19:40:20.598 UTC Fri Jan 21 2013
    
    

    ルータの時刻が適切に設定されていない場合は、clock set および clock timezone コマンドを使用してシステム クロックを設定します。

    (注)     

    ルータと Web ブラウザの両方のクロック設定が Web ユーザ インターフェイスにどのように影響するかについての詳細は、クロックと Web ユーザ インターフェイスを参照してください。

    ステップ 2   configure terminal コマンドを実行して、グローバル コンフィギュレーション モードを開始します。
    ステップ 3   次のコマンドを入力して、レガシー Web ユーザ インターフェイスをイネーブルにします。
    • ip http server:ポート 80(デフォルトの HTTP ポート)で HTTP をイネーブルにします。

    • ip http port port-number:デフォルト以外のユーザ指定のポートで HTTP をイネーブルにします。 デフォルトのポート番号は 80 です。

    • ip http secure-server:ポート 443(デフォルトの HTTPS ポート)で HTTPS をイネーブルにします。

    • ip http secure-port port-number:デフォルト以外のユーザ指定のポートで HTTPS をイネーブルにします。

    これで、レガシー Web ユーザ インターフェイスにアクセスできます。

    ステップ 4   transport-map type persistent webui transport-map - name コマンドを入力することで、固定的 Web ユーザ インターフェイスのトランスポート マップを作成して名前を付けます。
    ステップ 5   トランスポート マップ コンフィギュレーション モードで次のコマンドを入力して、HTTP、HTTPS、またはその両方をイネーブルにします。
    • server:HTTP をイネーブルにします。

    • secure-server:HTTPS をイネーブルにします。

    トランスポート マップ内にポート番号を設定できません。 ステップ 3 で定義したポート番号が、固定的 Web ユーザ インターフェイス トランスポート マップの設定でも使用されます。

    ステップ 6   (任意)特権 EXEC モードで show transport-map name transport-map-name コマンドを入力して、トランスポート マップが適切に設定されていることを確認します。
    ステップ 7   グローバル コンフィギュレーション モードで transport-map type persistent webui transport-map - name コマンドを入力して、トランスポート マップをイネーブルにします。

    Web ユーザ インターフェイスへのアクセス

      ステップ 1   Web ブラウザを開きます。 Web ユーザ インターフェイスでは次の Web ブラウザがサポートされています。
      • Microsoft Internet Explorer 6 以降

      • Mozilla Firefox 2.0 以降

      ステップ 2   Web ブラウザのアドレス フィールドにルータのアドレスを入力します。 ルータのアドレスの形式は、http://<routername または management-ethernet-ip-address>:[http-port]、あるいは https://<routername または management-ethernet-ip-address>:[https-port] です。 アドレスは、ご使用の Web ブラウザ ユーザ インターフェイス設定と、ルータが DNS に参加しているかどうかによって異なります。

      次に、有効なアドレス フィールド エントリの例を示します。

      HTTP Using Default Port Example
      http://172.16.5.1
      HTTPS Using Default Port Example
      https://172.16.5.1
      HTTP Using NonDefault Port Example
      http://172.16.5.1:94
      HTTPS Using NonDefault Port Example
      https://172.16.5.1:530/
      HTTP Using Default Port Participating in DNS Example
      http://router1
      HTTPS Using Default Port Participating in DNS Example
      https://router1
      HTTP Using NonDefault Port Participating in DNS Example
      http://router1:94
      HTTPS Using NonDefault Port Participating in DNS Example
      https://router1:530/
      
      
      ステップ 3   入力画面が表示されたら、ユーザ名とパスワードを入力します。
      (注)     

      Web ユーザ インターフェイスを表示するために必要なユーザ名とパスワードの組み合わせは、ルータにアクセスするために必要なユーザ名とパスワードの組み合わせと同じです。

      グラフィックベース Web ユーザ インターフェイスの概要の図のようなグラフィックベースの Web ユーザ インターフェイスが表示されます。

      コマンドと、各コマンド使用できるオプションの詳細については、『Cisco IOS Configuration Fundamentals Command Reference』を参照してください。


      Web ユーザ インターフェイス認証

      ルータの Web ユーザ インターフェイスにアクセスするときには、認証用にルータで設定されているものと同じユーザ名とパスワードを入力する必要があります。 Web ブラウザは、すべてのユーザに対してユーザ名とパスワードの入力を求め、ルータでこの情報を検証した後、Web ユーザ インターフェイスへのアクセスを許可します。

      特権レベル 15 のユーザだけが Web ユーザ インターフェイスにアクセスできます。 Web ユーザ インターフェイス トラフィックの認証は、他のすべてのトラフィックの認証設定によって制御されます。

      ルータで認証を設定するには、『Cisco IOS Security Configuration Guide』の「Configuring Authentication」を参照してください。

      ドメイン ネーム システムと Web ユーザ インターフェイス

      ドメイン ネーム システム(DNS)は、DNS サーバから DNS プロトコルを使用してホスト名を IP アドレスにマッピングできる分散データベースです。

      ルータが DNS に参加するよう設定されている場合、ユーザは Web ブラウザにアドレス http://<dns-hostname> を入力して Web ユーザ インターフェイスにアクセスできます。

      DNS の設定については、『IP Addressing: DNS Configuration Guide, Cisco IOS XE Release 3S』の「Configuring DNS」を参照してください。

      クロックと Web ユーザ インターフェイス

      いくつかのブラウザでは、Web ブラウザが認識する時刻と、ルータに示される時刻が 1 時間以上異なる場合に、Web ユーザ インターフェイスの表示要求を拒否できます。 ルータを設定する前に、show clock コマンドを使ってルータの時刻を確認することをお勧めします。 ルータのシステム時刻を設定するには、clock set コマンドと clock timezone コマンドを使用できます。

      同様に、Web ユーザ インターフェイスに適切にアクセスするには、Web ブラウザのクロック ソース(通常はパーソナル コンピュータ)の時刻も正確である必要があります。

      Your access is being denied for one of the following reasons:
      –	Your previous session has timed-out.
      
      –	You have been logged out from elsewhere.
      
      –	You have not yet logged in.
      
      –	The resource requires a higher privilege level login.
      

      前述の問題の 1 つ以上の原因を修正しても、Web ユーザ インターフェイスにアクセスできない場合は、ルータのクロック設定と PC のクロック設定を調べて、両方のクロックに表示される日時が正しいことを確認し、Web ユーザ インターフェイスへのアクセスを再試行してください。


      (注)  


      一方のクロックが夏時間に変更され、もう一方のクロックは未変更の場合に、クロック関連の問題が発生することがあります。


      自動更新の使用

      Web ユーザ インターフェイスの内容は、デフォルトでは自動的に更新されません。 自動更新の間隔を設定するには、次の手順を実行します。


        ステップ 1   グラフィカル Web ユーザ インターフェイスのホーム ページで [Refresh every] チェックボックスを選択します。

        チェックボックスにチェック マークが表示されます。 (次の図を参照してください。)

        図 3. グラフィックベース Web ユーザ インターフェイスの [Auto-refresh] チェックボックス



        ステップ 2   ドロップダウン メニューを使用して、自動更新の間隔を設定します。
        ステップ 3   ドロップダウン メニューを使用して、自動更新の間隔を設定します。
        ステップ 4   ドロップダウン メニューの右にある [Start] ボタンをクリックします。

        [Start] ボタンをクリックした直後に、このボタンが [Stop] ボタンに変わり、次の図に示すようにこの [Stop] ボタンの右側にカウントダウン タイマーが表示されます。

        図 4. [Stop] ボタンと自動更新カウンタ




        設定例

        デフォルトの HTTP ポートを使用した Web ユーザ インターフェイスのイネーブル化:例
        Router# configure terminal
        Enter configuration commands, one per line. End with CNTL/Z.
        Router(config)# ip http server
        Router(config)# transport-map type persistent webui http-webui
        Router(config-tmap)# server
        Router(config-tmap)# exit
        Router(config)# exit
        Router# show transport-map name http-webui
        Transport Map:
          Name: http-webui
          Type: Persistent Webui Transport
        Webui:
          Server:        enabled
          Secure Server: disabled
        Router# configure terminal
        Router(config)# transport type persistent webui input http-webui
        *Sep. 21 02:43:55.798: %UICFGEXP-6-SERVER_NOTIFIED_START: R0/0: psd: Server wui has been
        notified to start
        デフォルトの HTTPS ポートを使用した Web ユーザ インターフェイスのイネーブル化:例
        Router# configure terminal
        Enter configuration commands, one per line. End with CNTL/Z.
        Router(config)# ip http secure-server
        Router(config)# transport-map type persistent webui https-webui
        Router(config-tmap)# secure-server
        Router(config-tmap)# exit
        Router(config)# transport type persistent webui input https-webui
        *Sep. 21 02:38:43.597: %UICFGEXP-6-SERVER_NOTIFIED_START: R0/0: psd: Server wui has been 
        notified to start
        デフォルトの HTTP および HTTPS ポートを使用した Web ユーザ インターフェイスのイネーブル化:例
        Router# configure terminal
        Enter configuration commands, one per line. End with CNTL/Z.
        Router(config)# ip http server
        Router(config)# ip http secure-server
        Router(config)# transport-map type persistent webui http-https-webui
        Router(config-tmap)# server
        Router(config-tmap)# secure-server
        Router(config-tmap)# exit
        Router(config)# transport type persistent webui input http-https-webui
        *Sep 21 02:47:22.981: %UICFGEXP-6-SERVER_NOTIFIED_START: R0/0: psd: Server wui has been 
        notified to start