Cisco 3800 シリーズ ソフトウェア コンフィギュレー ション ガイド
グループ アプリケーション向け IP コミュニ ケーション ソリューションの設定例
グループ アプリケーション向け IP コミュニケーション ソリューションの設定例
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

グループ アプリケーション向け IP コミュニケーション ソリューションの設定例

概要

前提条件

要件

使用されるコンポーネント

関連製品

表記法

設定

ネットワーク図

設定

Cisco 3845 ルータ

確認

確認画面:例

Cisco CallManager の画面例

Cisco CME の画面例

Cisco Unity Express の画面例

トラブルシューティング

トラブルシューティング用の参照マニュアルとコマンド

関連情報

グループ アプリケーション向け IP コミュニケーション ソリューションの設定例

目次

「概要」

「前提条件」

「設定」

「確認」

「トラブルシューティング」

「関連情報」

概要

このマニュアルでは、次のような設定例を説明します。

ある小規模なブランチ オフィスでは、アナログ電話機と IP Phone の両方を使用しています。このマニュアルで取り上げるこの小規模ブランチ オフィスには、IP テレフォニー サービスが必要であり、Cisco アクセス ルータの他の Full-Service Branch(FSB)機能を使用する可能性もあります。たとえば、Cisco Content Engine(CE)、Voice over IP(VoIP)サービス、バックエンドの VoIP 呼制御デバイスとの統合などの機能です。また、この小規模ブランチ オフィスは、堅牢な統合ボイスメール ソリューションを必要としています。サービス統合型ルータは、WAN アップリンク モジュールや統合 LAN スイッチング モジュールのさまざまなオプションをサポートしています。

Land Mobile Radio(LMR)は、損失防止(構内の安全とセキュリティ)や無線システム範囲内のモバイル ワーカー用 Push-to-Talk(PTT)通信など、いくつかの理由から企業に利用されています。LMR の基地局を E&M ポートと接続して IP ネットワークに統合すると、VoIP 経由で基地局にアクセスできます。LMR 機能により、マルチキャストを使用した無線へのトランシーバの接続も可能になります。

マルチキャストとは、E.164 番号を使用して IP Phone と Public Switched Telephone Network(PSTN; 公衆交換電話網)電話機から LMR にダイヤルインできるようにしたダイヤルプランです。これまで、PSTN または Hoot & Holler ネットワークへの接続には、E&M ポートが使用されていました。E&M ポートを LMR に接続すると、マルチキャストと VoIP の接続が可能になります。このようなネットワーク構成では、XML サービスを使用している LAN 上のデスクトップ クライアントや IP Phone クライアントから、Cisco IOS のマルチキャスト機能を通じて直接無線システムに接続できます。LMR はゲートウェイ上の E&M ポートと統合できます。ゲートウェイのコマンドは、このようなルータから無線への接続をサポートしています。

このマニュアルでは、物理 T1 ループバックを使用して、マルチキャスト VoIP とユニキャスト VoIP をブリッジする手段を説明します。これは必ず必要な設定ではありません。これは、Skinny、H.323、SIP などの標準ベースの VoIP 呼制御スキームにマルチキャスト VoIP オーディオを統合できることを示すために取り上げています。標準ベースの VoIP プロトコル間のブリッジングには、IP 間ゲートウェイの使用を推奨します。物理ループバックを使用した VoIP 対マルチキャストのブリッジは、Cisco CallManager Express(Cisco CME)Phone または PSTN 電話機によるローカル マルチパーティ会議にも使用できます。

オンボード DSP は、WAN Interface Card(WIC; WAN インターフェイス カード)スロットに搭載された音声モジュールに使用されます。

Cisco CallManager は、Cisco CallManager(Release 3.3 (3) 以上)に定義されている H.323 トランクを通じて、Cisco CME とシームレスに接続します。

Cisco CME(Release 3.2)はローカルの電話ネットワークを管理します。Cisco CME と Cisco Unity Express を使用することで、ボイスメール システムと結合された PBX のようにゲートウェイを使用できます。

NM-CUE 上の Cisco Unity Express(Cisco Service Engine 1.1 を使用)は、ボイスメール サービスと自動応答サービスを提供します。

Cisco CME は、本社サイトの Cisco CallManager とシームレスに統合され、すべての補足サービスをサポートします。

Content Engine(CE)モジュールは、Web キャッシュ、ビデオオンデマンド、およびライブ分割のアプリケーションをサポートしています。

CE(ce2636-sw-5.1.3)上の Cisco Access Control Network Server(ACNS)は、ユニキャストおよびマルチキャストを通じたストリーミング ビデオの Web キャッシュと分割によって WAN の帯域幅を節約します。

前提条件

以下は、この項に含まれる前提条件です。

「要件」

「使用されるコンポーネント」

「関連製品」

「表記法」

要件

このマニュアルについての特定な要件はありません。

使用されるコンポーネント

このマニュアルの情報は、次のソフトウェアおよび Cisco 3845 ルータのハードウェアとソフトウェアに基づいています。

FastEthernet インターフェイス(NM-ESW-16)(x 16)

シリアル インターフェイス(x 1)

端末回線(x 3)

チャネライズド T1/PRI ポート(x 2)

音声 FXS インターフェイス(VIC-4FXS-DID)(x 4)

音声 E&M インターフェイス(VIC2-2E&M)(x 2)

Cisco Service Engine(NM-CUE)(x 1)

Cisco Content Engine(NM-CE-BP)(x 1)

スロット 0 の VIC2-4FS

スロット 1 の VIC2-2FXS

スロット 2 ~ 3 のインライン パワー カード搭載 HWICD-9ESW(倍幅)

Cisco CallManager Release 3.3(3)

Cisco IOS Release 12.3(11)T 以上

Enterprise Services フィーチャ セット

このマニュアルの情報は、特定のラボ環境で使用されるデバイスを反映しています。この設定例に使用されるデバイスはすべて、初期設定(デフォルト)の状態から作業が開始されています。ライブ ネットワークで操作している場合は、使用前に、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。このマニュアルで示す設定例は、ブランチ オフィスの単一ルータ上での機能の組み合わせを示しています。このマニュアルに加え、「関連情報」にリストされたマニュアルも参照してください。

関連製品

この設定は、Cisco 2800 および Cisco 3800 シリーズのすべてのルータにも使用できます。

設定

ここでは、このマニュアルで説明する機能を設定するための情報を示します。


) このマニュアルで使用されるコマンドに関する追加情報を検索するには、Cisco IOS Command Lookup Tool を使用してください。アクセスするには、Cisco.com のアカウントが必要です。アカウントをお持ちでない場合や、ユーザ名やパスワードを忘れた場合は、ログイン ダイアログボックスで [Cancel] をクリックし、表示される説明に従ってください。


設定のヒント

ルータ上のギガビット ポートは、インライン パワーを提供しません。

ルーティングは、イネーブルの状態でなければならず、設定済みであることが前提です。

サービス統合型ルータ上の外部フラッシュ カードには、ルータ イメージ、VLAN データベース、および Cisco CME と Cisco Unity Express 用の GUI(グラフィカル ユーザ インターフェイス)ファイルが保存されています。ルータの通常の動作中は、このカードを取り外さないでください。

LMR をルータに統合する際は、無線周波数(RF)または無線技術(通常、非 IP の製品固有の実装に関する技術)が必要になる場合があります。無線からルータに接続する物理ケーブルは、すぐに入手できない場合があります。

ネットワーク図

このマニュアルでは、次の図に示すネットワーク セットアップを使用します。

 

 

1

システム エンコーダ、オリジナル ソース

7

LMR(LMR のルータへの統合)

2

TDM

8

T1 ループバック(ユニキャストからマルチキャストへのブリッジ)、マルチキャスト オーディオと標準ベースの VoIP を統合するための解決策

3

NM-CE による ACNS でのマルチキャストおよびライブ分割

9

PSTN

4

Cisco CME/Cisco Unity Express

10

本社

5

ゲートウェイからの LAN 上のローカル マルチキャスト

11

Cisco CallManager

6

PC クライアント、マルチキャスト RTP クライアント、Media Player(ストリーミング)

設定

この例は、Cisco 3845 ルータの設定を示します。

Cisco 3845 ルータ

3845-gw#show running-config
Building configuration...
 
Current configuration : 17622 bytes
!
!---Last configuration change at 23:07:46 PDT Wed Jul 7 2004 by cisco
!
version 12.3
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service internal
!
hostname 3845-gw
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 informational
enable secret 5 $1$3do1$SDp9TOK4YaZ7XguJYD2MD1
!
!---Local Database of username and passwords for Web server and local
!---authentication
!
username cisco password 7 1511021F0725
!
clock timezone PST -8
clock summer-time PDT recurring
no network-clock-participate slot 1
no network-clock-participate slot 2
no network-clock-participate slot 3
no network-clock-participate slot 4
no network-clock-participate wic 0
no network-clock-participate wic 1
network-clock-participate wic 2
no network-clock-participate wic 3
no network-clock-participate aim 0
no network-clock-participate aim 1
 
aaa new-model
!
!
aaa group server tacacs+ admin
server 192.x or 10.x
server 192.x or 10.x
!
aaa group server radius vpn
server 192.x or 10.x auth-port 1645 acct-port 1646
!
!---AAA configuration used for local authentication
!
aaa authentication login admin group tacacs+ enable
aaa authentication login remote group vpn
aaa authentication login NOTACACS line
aaa authentication login LOCAL local
aaa authentication login WEB none
aaa authentication ppp LOCAL local
aaa authentication dot1x default group vpn
aaa authorization console
aaa authorization exec default local
aaa authorization network groupauthor local
aaa session-id common
ip subnet-zero
no ip source-route
!
 
ip cef
!
!
!---Configure a DHCP address pool for each IP phone:
ip dhcp excluded-address 192.168.10.1 192.168.10.99
!
ip dhcp pool NONAT
network 10.1.153.0 255.255.255.248
default-router 10.1.153.1
dns-server 10.1.162.183 10.1.156.120
option 150 ip 10.1.152.9
domain-name cisco.com
!
ip dhcp pool NAT
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 10.1.162.183 1010.1.156.120
option 150 ip 10.1.152.9
domain-name cisco.com
 
!
ip domain name cisco.com
ip name-server 10.1.162.183
ip name-server 10.1.156.120
ip multicast-routing
ip sap cache-timeout 30
ip ssh time-out 30
ip ssh version 1
ip ids po max-events 100
no ip rcmd domain-lookup
ip rcmd rcp-enable
ip rcmd rsh-enable
!
voice-card 0
 
no dspfarm
!
!
!
!---Configuration to enable “H.323 to H.323” and “H.323 to SIP” calls between Cisco
!---CallManager-Cisco CME-Cisco Unity Express. The “allow connections h323 to h323” &
!---“allow-connections h323 to sip” enable an easy configuration on gateway without the
!---need for loopback-dn for incoming calls from Cisco CallManager or for call flow from
!---Cisco CallManager to SIP for Voice Mail.
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12 advertise-only
h323
!
!
!
!---Configuration to support LMR(Land Mobile Radio) integration through E&M port on the
!---router (similar to Hoot and Holler configuration)
!
voice class permanent 1
signal timing oos restart 50000
signal timing oos timeout disabled
signal keepalive disabled
signal sequence oos no-action
!
!
!---Two T1 ports connected back-to-back to bridge VoIP to multicast audio bridging. This
!---is required to enable dialing into multicast. Connecting the TDM T1 port back-to-back
!---offers the possibility of using E.164 number as a conference ID, or for using the
!---multicast stream for application such as Hoot and Holler.
!---
!---Cisco CME offers 3-party conference calling and is the recommended method for a
!---small branch office, the following T1 loopback cable is not required for configuring
!---the conferencing features.
!---
!---Cisco IOS supports audio mixing of loudest three streams. The TDM back to
!---back connection enables the bridging of 23 channels of VoIP to one or
!---more multicast connections (one side with multicast configuration and the
!---other side with VoIP configuration)
 
!---This method provides a way to connect the standards-based VoIP call control to
!---the multicast audio streams that do not have any associated call control.
!
controller T1 0/2/0
framing esf
linecode b8zs
ds0-group 1 timeslots 1 type e&m-immediate-start
ds0-group 2 timeslots 2 type e&m-immediate-start
ds0-group 3 timeslots 3 type e&m-immediate-start
ds0-group 4 timeslots 4 type e&m-immediate-start
ds0-group 5 timeslots 5 type e&m-immediate-start
ds0-group 6 timeslots 6 type e&m-immediate-start
!
controller T1 0/2/1
framing esf
clock source internal
linecode b8zs
ds0-group 1 timeslots 1 type e&m-immediate-start
ds0-group 2 timeslots 2 type e&m-immediate-start
ds0-group 3 timeslots 3 type e&m-immediate-start
ds0-group 4 timeslots 4 type e&m-immediate-start
ds0-group 5 timeslots 5 type e&m-immediate-start
ds0-group 6 timeslots 6 type e&m-immediate-start
!
no crypto isakmp enable
!
!
!---Loopback0 used to bind H323 to the Loopback0 interface. RTP Packets
!---originate/terminate on the router using this IP address.
!
interface Loopback0
ip address 10.1.152.9 255.255.255.255
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.1.152.9
!
interface Loopback2
ip address 10.1.152.241 255.255.255.252
ip ospf network point-to-point
!
interface Loopback3
ip address 10.1.152.249 255.255.255.252
ip virtual-reassembly
ip ospf network point-to-point
!
!---Configuration to enable Hoot and Holler using multicast on router. The multicast
!---streaming of packets from the local router uses the VIF interface to derive the local
!---ip address and the port of the packets. This can be verified by the show command “show
!---voip rtp connection”
!
interface Vif1
ip address 10.1.153.41 255.255.255.252
ip pim sparse-dense-mode
 
!
!
!---WAN uplink
!
interface Serial0/0/0
ip address 10.1.152.30 255.255.255.252
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly
no fair-queue
!
!--- Content Engine connected as a Network Module.
!
interface Content-Engine1/0
ip unnumbered Loopback3
ip pim sparse-dense-mode
service-module ip address 10.1.152.250 255.255.255.252
service-module ip default-gateway 10.1.152.249
!
!
interface FastEthernet3/0
switchport access vlan 110
switchport trunk native vlan 100
switchport mode trunk
switchport voice vlan 110
no ip address
!
interface FastEthernet3/1
switchport access vlan 100
switchport trunk native vlan 100
switchport mode trunk
switchport voice vlan 110
no ip address
!
interface FastEthernet3/2
switchport access vlan 100
switchport trunk native vlan 100
switchport mode trunk
switchport voice vlan 110
no ip address
!
interface FastEthernet3/3
switchport access vlan 100
switchport trunk native vlan 100
switchport mode trunk
switchport voice vlan 110
no ip address
!
!
!---Cisco Unity Express used for local voice-mail storage
!
interface Service-Engine4/0
ip unnumbered Loopback2
service-module ip address 10.1.152.242 255.255.255.252
service-module ip default-gateway 10.1.152.241
!
!--- Data VLAN, used for the desktops at the branch
!
interface Vlan100
ip address 192.168.10.1 255.255.255.0
ip pim sparse-dense-mode
ip nat inside
ip virtual-reassembly
!
interface Vlan110
ip address 10.1.153.1 255.255.255.248
ip pim sparse-dense-mode
ip virtual-reassembly
!
!---OSPF used as the routing protocol for scenario
!
router ospf 1
router-id 10.1.152.9
log-adjacency-changes
network 10.1.152.9 0.0.0.0 area 0
network 10.1.152.10 0.0.0.0 area 0
 
network 10.1.152.28 0.0.0.3 area 0
network 10.1.152.140 0.0.0.3 area 0
network 10.1.152.240 0.0.0.3 area 0
network 10.1.152.248 0.0.0.3 area 0
network 10.1.153.0 0.0.0.3 area 0
!
!---Static routes defined for routing to Service-Engine and Content-Engine network Module
ip classless
ip route 10.1.152.242 255.255.255.255 Service-Engine4/0
ip route 10.1.152.250 255.255.255.255 Content-Engine1/0
!
ip http server
ip http authentication aaa login-authentication LOCAL
no ip http secure-server
ip http path flash:
!
!---PAT (Port address translation used for the Data VLAN.
ip nat inside source list 11 interface Serial0/0/0 overload
!
!
access-list 11 permit 192.168.11.0 0.0.0.255
access-list 11 permit 192.168.20.0 0.0.0.255
access-list 11 permit 192.168.10.0 0.0.0.255
!
!
!---Router serves as TFTP server for Signed Image for 7960 phone on Local LAN.
!
tftp-server flash:P00306000300.bin
tftp-server flash:P00306000300.loads
tftp-server flash:P00306000300.sb2
!
control-plane
!
!
!---VoIP side of the Back-to-Back T1 used for bridging VoIP to multicast streams defined
!---by the dial-peer with “ session protocol multicast”
!
voice-port 0/2/0:1
auto-cut-through
!
voice-port 0/2/0:2
auto-cut-through
!
voice-port 0/2/0:3
auto-cut-through
!
voice-port 0/2/0:4
auto-cut-through
!
voice-port 0/2/0:3
auto-cut-through
!
voice-port 0/2/0:4
auto-cut-through
!
voice-port 0/2/0:5
auto-cut-through
!
voice-port 0/2/0:6
auto-cut-through
!
!---E&M ports connected to the LMR (Land Mobile Radio). Each radio may have a different
!---radio frequency (such as VHF or UHF)
!
voice-port 0/1/0
auto-cut-through
voice-class permanent 1
operation 4-wire
signal lmr
lmr e-lead voice
timeouts call-disconnect 3
connection trunk 20480
!
 
voice-port 0/1/1
auto-cut-through
voice-class permanent 1
operation 4-wire
signal lmr
lmr m-lead audio-gate-in
lmr e-lead voice
timeouts call-disconnect 3
connection trunk 20481
!
!---Multicast side of the back-to-back T1 used for bridging VoIP to multicast connection
!---trunk points to the dial-peer that is used for streaming into multicast
!
voice-port 0/2/1:1
auto-cut-through
timeouts call-disconnect 3
connection trunk 20480
!
voice-port 0/2/1:2
auto-cut-through
timeouts call-disconnect 3
connection trunk 20481
!
!---Multicast side of the back-to-back T1 used for bridging VoIP to multicast connection
!---trunk points to the dial-peer that is used for streaming into multicast for local
!---conferencing. 2111 dialed from the network side is looped back to the other side of
!---the T1 that is connected to the multicast dial-peer to convert it into a multicast
!---stream. The 3-party mixing algorithm takes care of conferencing between the dialed
!---parties
!
voice-port 0/2/1:3
auto-cut-through
timeouts call-disconnect 3
connection trunk 21111
!
voice-port 0/2/1:4
auto-cut-through
timeouts call-disconnect 3
connection trunk 21111
!
voice-port 0/2/1:5
auto-cut-through
timeouts call-disconnect 3
connection trunk 21111
!
voice-port 0/2/1:6
auto-cut-through
timeouts call-disconnect 3
connection trunk 21111
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
!---FXS ports tied to multicast Hoot and Holler
!
voice-port 0/3/3
!
!---Dial peers pointing toward the NM-CUE for auto attendant and voice mail
!
dial-peer voice 27749 voip
description Towards CUE-Auto-Attendant
destination-pattern 27749
session protocol sipv2
session target ipv4:10.1.152.242
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 27748 voip
description Towards CUE-Voice-Mail
destination-pattern 27748
session protocol sipv2
session target ipv4:10.1.152.242
dtmf-relay sip-notify
codec g711ulaw
no vad
!
!---Dial peers for dialing out; pointing to Cisco CallManager Release 3.3(3)
!
dial-peer voice 101 voip
description CCM-IT-Cisco
destination-pattern .T
session target ipv4:10.1.148.178
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 9 voip
 
preference 1
destination-pattern 91..........
session target ipv4:10.1.148.178
!
dial-peer voice 2 voip
destination-pattern 2....
session target ipv4:10.1.148.178
!
!---Dial Peers for multicast streaming from TDM port
!
dial-peer voice 20480 voip
description VoIP to multicast bridging for LMR integration
destination-pattern 20480
voice-class permanent 1
session protocol multicast
session target ipv4:239.192.17.191:20480
codec g711ulaw
vad aggressive
!
dial-peer voice 20481 voip
description VoIP to multicast bridging for LMR integration
destination-pattern 20481
voice-class permanent 1
session protocol multicast
session target ipv4:239.192.17.192:20480
codec g711ulaw
vad aggressive
!
dial-peer voice 21111 voip
description VoIP to multicast bridging for Local Conferencing
destination-pattern 21111
voice-class permanent 1
session protocol multicast
session target ipv4:239.192.17.195:20480
dtmf-relay cisco-rtp
codec g711ulaw
vad aggressive
!---Dial Peers for the T1 physical loopback used for bridging multicast to VoIP
!---(VoIP Side)
!
dial-peer voice 1 pots
description VoIP to multicast bridging for LMR
destination-pattern 27737
port 0/2/0:1
!
dial-peer voice 3 pots
description VoIP to multicast bridging for LMR
destination-pattern 4089027737
port 0/2/0:1
!
dial-peer voice 4 pots
description VoIP to multicast bridging for LMR
destination-pattern 27738
port 0/2/0:2
!
dial-peer voice 5 pots
description VoIP to multicast bridging for LMR
destination-pattern 4089027738
port 0/2/0:2
!
dial-peer voice 6 pots
description VoIP to local multicast conference bridge
destination-pattern 2111
port 0/2/0:3
!
dial-peer voice 7 pots
description VoIP to local multicast conference bridge
destination-pattern 2111
port 0/2/0:4
!
dial-peer voice 8 pots
description VoIP to local multicast conference bridge
destination-pattern 2111
port 0/2/0:5
!
dial-peer voice 9 pots
description VoIP to local multicast conference bridge
destination-pattern 2111
port 0/2/0:6
!
!
!---Dial Cisco CME Configuration with services configuration
!
!
telephony-service
fxo hook-flash
load 7910 P00403020214
load 7960-7940 P00306000300
max-ephones 27
max-dn 40
ip source-address 10.1.152.9 port 2000
auto assign 1 to 27
timeouts interdigit 5
system message Next GEN Branch Documentation
url services http://phone-xml.berbee.com/menu.xml
create cnf-files version-stamp 7960 Jun 24 2004 14:00:45
dialplan-pattern 1 408902.... extension-length 5
 
voicemail 27749
mwi relay
mwi expires 99999
max-conferences 8
call-forward pattern .....
web admin customer name cisco password admin
dn-webedit
time-webedit
transfer-system full-consult
transfer-pattern .....
secondary-dialtone 9
!
!
ephone-dn 1 dual-line
number 27725
description Ross
name Ross
call-forward busy 27749
call-forward noan 27749 timeout 10
!
!
ephone-dn 2 dual-line
number 27726
description Rachel
name Rachel
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 3 dual-line
number 27727
description Chandler
name Chandler
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 4 dual-line
number 27728
description Monica
name Monica
call-forward busy 27749
call-forward noan 27749 timeout 10
!
!
ephone-dn 5 dual-line
number 27729
description Jen-Shue Shih
name Jen-Shue Shih
call-forward busy 27749
call-forward noan 27749 timeout 10
!
!
ephone-dn 6 dual-line
number 27730
description Mike
name Mike
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 7 dual-line
number 27731
 
description Phoebe
name Phoebe
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 8 dual-line
number 27732
description Cosmo
name Cosmo
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 9 dual-line
number 27733
description Jerry
name Jerry
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 10 dual-line
number 27734
description George
name George
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 11 dual-line
number 27735
description Frank
name Frank
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 12 dual-line
number 27736
description Estelle
name Estelle
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 13 dual-line
!
!
ephone-dn 14 dual-line
!
!
ephone-dn 15 dual-line
number 27739
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 16 dual-line
number 27740
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
 
ephone-dn 17 dual-line
number 27741
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 18 dual-line
number 27742
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 19 dual-line
number 27743
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 20 dual-line
number 27744
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 21 dual-line
number 27745
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 25
!
!
ephone-dn 27
number 27749
call-forward busy 27749
call-forward noan 27749 timeout 18
!
!
ephone-dn 39
number 8000.....
mwi off
!
!
ephone-dn 40
number 8001.....
mwi on
!
!
ephone 1
mac-address 0003.4713.5554
type CIPC
button 1:1
!
!
!
ephone 2
mac-address 0002.8A3E.6606
type CIPC
button 1:2
!
!
!
ephone 3
 
mac-address 0001.022C.88A1
type CIPC
button 1:3
!
!
!
ephone 4
mac-address 0009.6B10.494D
type CIPC
button 1:4
!
!
!
ephone 5
mac-address 0002.8A4B.000B
type CIPC
button 1:5
!
!
!
ephone 6
mac-address 0009.6B53.44C6
type CIPC
button 1:6
!
!
!
ephone 7
mac-address 0009.6B30.E399
type CIPC
button 1:7
!
!
!
ephone 8
mac-address 000B.BE37.1AB1
type 7960
button 1:8
!
!
!
ephone 9
mac-address 0006.D74B.15B3
type 7960
button 1:9
!
!
!
ephone 10
mac-address 000B.5F92.5784
type 7960
button 1:10
!
!
!
ephone 11
mac-address 000C.CE3A.87FA
type 7960
button 1:11
!
!
!
ephone 12
mac-address 000C.CE35.1B23
 
type 7960
button 1:12
!
!
!
ephone 13
mac-address 0002.8A9B.0CE5
type CIPC
button 1:13
!
!
!
ephone 14
mac-address 0003.47D8.C236
type CIPC
button 1:14
!
!
!
ephone 15
mac-address 000C.CE35.1935
type 7960
button 1:15
!
!
!
ephone 16
mac-address 0030.94C3.BE45
type 7960
button 1:16
!
!
!
ephone 17
!
!
!
ephone 18
!
!
!
ephone 19
!
!
!
ephone 20
!
!
!
ephone 21
!
!
!
line con 0
authorization exec LOCAL
stopbits 1
line aux 0
stopbits 1
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output all
 
line 130
no activation-character
no exec
transport preferred none
transport input all
transport output all
line 258
no activation-character
no exec
transport preferred none
transport input all
transport output all
line vty 0 4
exec-timeout 0 0
password 7 04490E020D205E4107
line vty 5 8
exec-timeout 0 0
password 7 03165E0F040E334340
!
scheduler allocate 20000 1000
ntp clock-period 1079741
ntp master
ntp update-calendar
ntp server 10.68.10.80
ntp server 10.68.10.150
end
 
 

確認

ここでは、設定が正しく機能していることを確認するために使用する情報を示します。

一部の show コマンドは Output Interpreter Tool でサポートされています(登録ユーザのみ)。このツールを使用すると、 show コマンド出力の分析結果を表示できます。コマンドの使用方法を次にまとめます。

show telephony-service :Cisco CallManager サーバで使用可能な IP テレフォニー サービスを表示します。

show ephone registered :IP 電話の登録の発生を確認し、各登録済み IP 電話に関連する情報を一覧表示します。

音声ゲートウェイ用の show コマンド

show voice port summary :すべての音声ポートの概要を表示します。

show voip rtp connections :VoIP RTP のアクティブな接続を表示します。

show voip dsp :DSP 情報を表示します。

show voice trace :すべての DSP チャネルについて、音声チャネル設定情報を表示します。

show voice call summary :すべての音声ポートのコール ステータスを表示します。

show running-config :現在の実行コンフィギュレーション ファイルの内容を表示します。

CE 用の show コマンド

show version :現在ロードされている CE ソフトウェア バージョンに関する情報を、ハードウェアおよびデバイス情報とともに表示します。

show running-config :現在の実行コンフィギュレーション ファイルの内容を表示します。

show processes cpu :詳細な CPU 使用率の統計情報(プロセス単位の CPU 使用率)を表示します。

show statistics wmt streamstat :Windows Media Technologies(WMT)ストリーミング接続の統計情報を表示します。

show statistics wmt all :すべての WMT の統計情報を表示します。

Cisco CME に関する Cisco Unity Express 用の show および service コマンド

show interface service-engine :サービス エンジン インターフェイスのステータスを表示します。

service-module service-engine 4/0 status :Cisco Unity Express のステータスを表示します。

service-module service-engine 4/0 session :Cisco Unity Express とのセッションを開きます。

Cisco Unity Express 用の show コマンド

show running-config :現在の実行コンフィギュレーション ファイルの内容を表示します。

show voicemail mailboxes :メールボックスの所有者およびステータスの概要を表示します。

show voicemail usage :ボイスメール システムの使用状況のスナップショットを表示します。

show voicemail limits :ボイスメール システムのシステム制限を表示します。

show ccn application :設定済みの各アプリケーションに関する詳細を表示します。

show ccn trigger :設定済みのすべてのトリガーのパラメータ値を表示します。

次の概要で、これらの各コマンドの代表的な出力例を示します。


) 必要に応じて、関連する出力表示を強調表示で示します。


次に、Cisco CME での show telephony-service コマンドの出力例を示します。

CCME-CUE-SJC# show telephony-service
 
CONFIG (Version=3.2)
=====================
 
Version 3.2
Cisco CallManager Express
For on-line documentation please see:
www.cisco.com/univercd/cc/td/doc/product/access/ip_ph/ip_ks/index.htm
 
ip source-address 10.1.152.9 port 2000
load 7910 P00403020214
load 7960-7940 P00303020214
max-ephones 27
max-dn 40
max-conferences 8
dspfarm units 0
dspfarm transcode sessions 0
max-redirect 5
dialplan-pattern 1 408902.... extension-length 5
voicemail 27749
mwi relay
mwi expires 99999
time-format 12
date-format mm-dd-yy
timezone 0 Greenwich Standard Time
secondary-dialtone 9
url services http://phone-xml.berbee.com/menu.xml
call-forward pattern .....
transfer-pattern .....
keepalive 30
timeout interdigit 5
timeout busy 10
timeout ringing 180
caller-id name-only: enable
system message CCME2 Cisco (MCEBU) Bldg 22
web admin system name cisco password 3800
web admin customer name cisco1 password 38001
edit DN through Web: enabled.
edit TIME through web: enabled.
Log (table parameters):
max-size: 150
retain-timer: 15
create cnf-files version-stamp 7960 Apr 12 2004 12:16:53
transfer-system full-consult
auto assign 1 to 27
fxo hook-flash
local directory service: enabled.
 

次に、 show ephone registered コマンドを使用した出力例を示します。

CCME-CUE-SJC# show ephone registered
 
 
ephone-1 Mac:0003.4713.5554 TCP socket:[6] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
IP:172.19.150.31 1649 CIPC keepalive 10410 max_line 8
button 1: dn 1 number 27725 CH1 IDLE CH2 IDLE
 
 
ephone-9 Mac:0006.D74B.15B3 TCP socket:[1] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
IP:192.168.20.4 50475 Telecaster 7960 keepalive 39556 max_line 6
button 1: dn 9 number 27733 CH1 IDLE CH2 IDLE
 
 
ephone-15 Mac:000C.CE35.1935 TCP socket:[3] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
IP:192.168.20.2 51961 Telecaster 7960 keepalive 39556 max_line 6
 
button 1: dn 15 number 27739 CH1 IDLE CH2 IDLE
 

次に、ブランチ オフィスのルータでの show voice port summary コマンドの出力例を示します。

 
3845-gw# show voice port summary
 
IN OUT
PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
========= == ============ ===== ==== ======== ======== ==
0/2/0:1 01 e&m-imd up dorm idle idle y
0/2/0:2 02 e&m-imd up dorm idle idle y
0/2/0:3 03 e&m-imd up dorm idle idle y
0/2/0:4 04 e&m-imd up dorm idle idle y
0/2/0:5 05 e&m-imd up dorm idle idle y
0/2/0:6 06 e&m-imd up dorm idle idle y
0/1/0 -- e&m-lmr up up trunked trunked y
0/1/1 -- e&m-lmr up up trunked trunked y
0/2/1:1 01 e&m-imd up up trunked trunked y
0/2/1:2 02 e&m-imd up up trunked trunked y
0/2/1:3 03 e&m-imd up up trunked trunked y
0/2/1:4 04 e&m-imd up up trunked trunked y
0/2/1:5 05 e&m-imd up up trunked trunked y
0/2/1:6 06 e&m-imd up up trunked trunked y
0/3/0 -- fxs-ls up dorm on-hook idle y
0/3/1 -- fxs-ls up dorm on-hook idle y
0/3/2 -- fxs-ls up dorm on-hook idle y
0/3/3 -- fxs-ls up dorm on-hook idle y
50/0/1 1 efxs up up on-hook idle y
50/0/1 2 efxs up up on-hook idle y
50/0/2 1 efxs up up on-hook idle y
50/0/2 2 efxs up up on-hook idle y
50/0/3 1 efxs up up on-hook idle y
.
50/0/40 1 efxs up dorm on-hook idle y
 

次に、ブランチ オフィスのルータでの show voice rtp connections コマンドの出力例を示します。

3845-gw# show voip rtp connections
 
VoIP RTP active connections :
No. CallId dstCallId LocalRTP RmtRTP LocalIP RemoteIP
1 2 1 32414 20480 10.1.153.42 239.192.17.191
2 4 3 28764 20480 10.1.153.42 239.192.17.192
3 6 5 16416 20480 10.1.153.42 239.192.17.191
4 8 7 27572 20480 10.1.153.42 239.192.17.192
5 1754 1753 16446 20480 10.1.153.42 239.192.17.195
6 1756 1755 31552 20480 10.1.153.42 239.192.17.195
7 1758 1757 16454 20480 10.1.153.42 239.192.17.195
8 1761 1760 16496 20480 10.1.153.42 239.192.17.195
Found 8 active RTP connections
 

次に、ブランチ オフィスのルータでの show voip dsp コマンドの出力例を示します。

3845-gw# show voip dsp
 
----------------------------FLEX VOICE CARD 0 ------------------------------
*DSP VOICE CHANNELS*
DSP DSP DSPWARE CURR BOOT PAK TX/RX
TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABRT PACK COUNT
===== === == ======== ======= ===== ======= === == ========= == ==== ============
C5510 013 01 g711ulaw 4.4.1 busy idle 0 0 0/1/0 00 0 1/419970
C5510 013 02 g711ulaw 4.4.1 busy idle 0 0 0/2/1:2 02 0 15/420330
C5510 013 03 g711ulaw 4.4.1 busy idle 0 0 0/2/1:1 01 0 16/420130
C5510 013 04 g711ulaw 4.4.1 busy idle 0 0 0/1/1 01 0 0/419879
C5510 013 05 None 4.4.1 busy idle 0 0 0/2/0:3 03 0 0/14
C5510 013 06 g711ulaw 4.4.1 busy idle 0 0 0/2/1:3 03 0 1873/1655
C5510 014 01 None 4.4.1 busy idle 0 0 0/2/0:4 04 0 0/14
C5510 014 02 g711ulaw 4.4.1 busy idle 0 0 0/2/1:6 06 0 1833/5379
C5510 014 03 None 4.4.1 busy idle 0 0 0/2/0:5 05 0 0/14
C5510 014 04 None 4.4.1 busy idle 0 0 0/2/0:6 06 0 0/14
C5510 014 05 g711ulaw 4.4.1 busy idle 0 0 0/2/1:5 05 0 1424/5334
C5510 014 06 g711ulaw 4.4.1 busy idle 0 0 0/2/1:4 04 0 1402/5057
*DSP SIGNALING CHANNELS*
DSP DSP DSPWARE CURR BOOT PAK TX/RX
TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABRT PACK COUNT
===== === == ======== ======= ===== ======= === == ========= == ==== ============
C5510 013 01 {flex} 4.4.1 alloc idle 0 0 0/1/0 02 0 34/0
C5510 013 02 {flex} 4.4.1 alloc idle 0 0 0/1/1 02 0 35/0
C5510 013 03 {flex} 4.4.1 alloc idle 0 0 0/3/1 06 0 14/0
C5510 013 04 {flex} 4.4.1 alloc idle 0 0 0/3/0 06 0 14/0
C5510 013 05 {flex} 4.4.1 alloc idle 0 0 0/3/3 02 0 14/0
C5510 013 06 {flex} 4.4.1 alloc idle 0 0 0/3/2 02 0 14/0
C5510 013 07 {flex} 4.4.1 alloc idle 0 0 0/2/0:1 01 0 4/18
C5510 013 08 {flex} 4.4.1 alloc idle 0 0 0/2/0:2 02 0 4/18
C5510 013 09 {flex} 4.4.1 alloc idle 0 0 0/2/1:1 01 0 27/23
C5510 013 10 {flex} 4.4.1 alloc idle 0 0 0/2/1:2 02 0 27/23
C5510 013 11 {flex} 4.4.1 alloc idle 0 0 0/2/0:3 03 0 454/335
C5510 013 12 {flex} 4.4.1 alloc idle 0 0 0/2/0:4 04 0 465/341
C5510 013 13 {flex} 4.4.1 alloc idle 0 0 0/2/0:5 05 0 433/315
C5510 013 14 {flex} 4.4.1 alloc idle 0 0 0/2/0:6 06 0 421/307
C5510 013 15 {flex} 4.4.1 alloc idle 0 0 0/2/1:3 03 0 3969/3831
C5510 013 16 {flex} 4.4.1 alloc idle 0 0 0/2/1:4 04 0 4050/3933
C5510 014 01 {flex} 4.4.1 alloc idle 0 0 0/2/1:5 05 0 3819/3657
C5510 014 02 {flex} 4.4.1 alloc idle 0 0 0/2/1:6 06 0 3724/3553
------------------------END OF FLEX VOICE CARD 0 ----------------------------
 

次に、ブランチ オフィスのルータでの show voice trace コマンドの出力例を示します。

3845-gw# show voice trace 0/2/1:1
 
0/2/1:1 1 State Transitions: timestamp (state, event) -> (state, event) ...
42.808 (S_SETUP_INDICATED, E_CC_PROCEEDING) ->
42.808 (S_PROCEEDING, E_CC_CONNECT) ->
 
State Transitions: timestamp (state, event) -> (state, event) ...
42.808 (S_TRUNK_PEND, E_HTSP_EVENT_TIMER) ->
42.808 (S_TRUNK_PROC, E_HTSP_SETUP_ACK) ->
42.808 (S_TRUNK_PROC, E_HTSP_PROCEEDING) ->
42.808 (S_TRUNK_PROC, E_HTSP_VOICE_CUT_THROUGH) ->
42.808 (S_TRUNK_W_CONNECT, E_HTSP_CONNECT) ->
 

次に、ブランチ オフィスのルータでの show voice call summary コマンドの出力例を示します。

3845-gw# show voice call summary
 
PORT CODEC VAD VTSP STATE VPM STATE
============== ======== === ==================== ======================
0/2/0:1.1 - - - EM_ONHOOK
0/2/0:2.2 - - - EM_ONHOOK
0/2/0:3.3 - - - EM_ONHOOK
0/2/0:4.4 - - - EM_ONHOOK
0/2/0:5.5 - - - EM_ONHOOK
0/2/0:6.6 - - - EM_ONHOOK
0/1/0 g711ulaw y S_CONNECT S_TRUNKED
0/1/1 g711ulaw y S_CONNECT S_TRUNKED
0/2/1:1.1 g711ulaw y S_CONNECT S_TRUNKED
0/2/1:2.2 g711ulaw y S_CONNECT S_TRUNKED
0/2/1:3.3 g711ulaw y S_CONNECT S_TRUNKED
0/2/1:4.4 g711ulaw y S_CONNECT S_TRUNKED
0/2/1:5.5 g711ulaw y S_CONNECT S_TRUNKED
0/2/1:6.6 g711ulaw y S_CONNECT S_TRUNKED
0/3/0 - - - FXSLS_ONHOOK
0/3/1 - - - FXSLS_ONHOOK
0/3/2 - - - FXSLS_ONHOOK
0/3/3 - - - FXSLS_ONHOOK
50/0/1 .1 - - - EFXS_ONHOOK
50/0/9 .1 - - - EFXS_ONHOOK
50/0/9 .2 - - - EFXS_ONHOOK
 

次に、CE での show version コマンドの出力例を示します。

sjc22-13a-rb-CE3# show version
 
Application and Content Networking System Software (ACNS)
Copyright (c) 1999-2003 by Cisco Systems, Inc.
Application and Content Networking System Software Release 5.1.3 (build b15 Feb
13 2004)
Version: ce2636-sw-5.1.3
 
Compiled 17:52:07 Feb 13 2004 by test
Compile Time Options: PP SS
 
System was restarted on Tue Jan 1 00:01:12 1980.
The system has been up for 16 hours, 8 seconds.
 

次に、CE での show running-config コマンドの出力例を示します。

sjc22-13a-rb-CE3# show running-config
 
hostname sjc22-13a-rb-CE3
!
http dns-cache serial-lookup
!
!
ip domain-name cisco.com
!
!
gui-server secure port 8002
!
!
interface FastEthernet external
shutdown
exit
interface FastEthernet internal
exit
!
!
primary-interface FastEthernet 0/1
!
wmt license-key 92W5SNNNSULWCXN78
wmt accept-license-agreement
wmt max-concurrent-sessions 9
wmt mms allow extension asf none nsc wma wmv mp3
wmt broadcast alias-name lanka source mms://24.6.215.172/AAA
 
wmt enable
!
!
multicast accept-license-agreement
!
!
ip name-server 10.68.162.183
ip name-server 10.72.156.120
!
!
wccp router-list 1 10.1.152.249
wccp web-cache router-list-num 1
wccp version 2
!
!
!
!
!
!
 
!
!
username admin password 1 bVmDmMMmZAPjY
username admin privilege 15
!
!
authentication login local enable primary
authentication configuration local enable primary
!
!
cdm ip 10.86.46.81
cms enable
!
!
!
End of ACNS configuration
 

次に、CE での show processes cpu コマンドの出力例を示します。

sjc22-13a-rb-CE3# show processes cpu
 
CPU usage:
Current Peak
cpu: 96 % 100 %
CPU average usage since last reboot:
cpu: 0.03% User, 7.28% System, 1.80% User(nice), 90.90% Idle
cpu0: 0.03% User, 7.28% System, 1.80% User(nice), 90.90% Idle
--------------------------------------------------------------------
PID STATE PRI User T SYS T COMMAND
----- ----- --- ------ ------ --------------------
1 S 0 744 4839 (init)
 
2 R 0 0 0 (keventd)
3 S 19 0 0 (ksoftirqd_CPU0)
4 S 0 0 0 (kswapd)
5 S 0 0 0 (bdflush)
6 S 0 0 0 (kupdated)
157 S 0 0 0 (streamd)
197 S 10 30143 3926 (nodemgr)
201 S 10 0 0 (syslogd)
202 R 10 396 150 (dataserver)
298 S 0 0 0 (kjournald)
902 S 10 108 23 (ruby_disk)
1494 S 10 2 1 (parser_server)
1544 S 10 3 1 (su)
 

次に、CE での show statistics xmt streamstat コマンドの出力例を示します。

sjc22-13a-rb-CE3# show statistics wmt streamstat
 
Detailed Stream Statistics
==========================
 
Incoming Streams:
=================
Bandwidth in Kbps, Duration in seconds
 
Type Transport Source Pkts_Recd Bytes_Recd Duration BW Server-IP
Filename Stream-Id
LIVE MMS(TCP) RMT_MMS 807995 1165556557 44531 216 24.6.215.172
AAA 5878
 
Outgoing Streams:
=================
Client-IP Type Transport Source State Pkts_sent Bytes_sent Duration BW Server-IP Filename Stream-Id
10.21.96.174 LIVE HTTP RMT_MMS Play 216441 312540804 11946 216 24.6.215.172 lanka 13830
10.21.81.206 LIVE MMS(UDP) RMT_MMS Play 59505 85925220 3283 216 24.6.215.172 lanka 15639
10.21.88.96 LIVE HTTP RMT_MMS Play 165227 238587788 9129 216 24.6.215.172 lanka 14402
10.21.113.252 LIVE MMS(UDP) RMT_MMS Play 596188 860895472 32961 216 24.6.215.172 lanka 8644
10.21.116.124 LIVE HTTP RMT_MMS Play 53848 77756512 3033 216 24.6.215.172 lanka 15682
10.21.115.95 LIVE MMS(UDP) RMT_MMS Play 481970 695964680 26584 216 24.6.215.172 lanka 10694
10.21.65.223 LIVE MMS(UDP) RMT_MMS Play 15883 22935052 878 216 24.6.215.172 lanka 16161
sjc22-13a-rb-CE3#
 

次に、CE での show statistics xmt all コマンドの出力例を示します。

sjc22-13a-rb-CE3# show statistics wmt all
 
Unicast Requests Statistics
===========================
Total unicast requests received: 79
-------------------------------------
 
Total % of Total
Unicast Requests
--------------------------------------------
 
Streaming Requests served: 75 94.94%
Mcast nsc file Request: 0 0.00%
Requests error: 0 0.00%
 
 
Total % of Total Streaming Requests
---------------------------------------------
 
By Type of Content
------------------
Live content: 75 100.00%
On-Demand Content: 0 0.00%
 
By Transport Protocol
---------------------
MMSU: 32 42.67%
MMST: 1 1.33%
HTTP: 42 56.00%
 
By Source of Content
--------------------
Local: 0 0.00%
Remote MMS: 75 100.00%
Remote HTTP: 0 0.00%
Multicast: 0 0.00%
 
 
CDN-Related WMT Requests
--------------------
CDN Content Hits: 0 0.00%
CDN Content Misses: 0 0.00%
CDN Content Live: 0 0.00%
CDN Content Errors: 0 0.00%
Unicast Bytes Statistics
========================
Total unicast incoming bytes: 1178064843
---------------------------------
Total % of Total Unicast
Incoming Bytes
--------------------------------------------
 
By Type of Content
------------------
Live content: 1178064843 100.00%
On-Demand Content: 0 0.00%
 
By Transport Protocol
---------------------
MMSU: 0 0.00%
MMST: 1178064843 100.00%
HTTP: 0 0.00%
 
Unicast Bytes Statistics
========================
Total unicast outgoing bytes: 4698135144
---------------------------------
Total % of Total Unicast
Outgoing Bytes
--------------------------------------------
 
By Type of Content
------------------
Live content: 4698135144 100.00%
On-Demand Content: 0 0.00%
 
By Transport Protocol
---------------------
MMSU: 3148201513 67.01%
 
MMST: 0 0.00%
HTTP: 1549933631 32.99%
 
Unicast Savings Statistics
==========================
Total bytes saved: 3520070301
--------------------------
Total % of Total Bytes
Saved
--------------------------------------------
By Pre-positioned content: 0 0.00%
By Live-splitting: 3520070301 100.00%
By Cache-hit: 0 0.00%
 
Total % of Total
Live Outgoing Bytes
--------------------------------------------
Live Splitting
--------------
Incoming bytes: 1178064843 25.08%
Outgoing bytes: 4698135144 100.00%
Bytes saved: 3520070301 74.92%
 
Total % of Bytes Cache
Total
--------------------------------------------
Caching
-------
Bytes cache-miss: 0 0.00%
Bytes cache-hit: 0 0.00%
Bytes cache-total: 0 0.00%
 
Bytes cache-bypassed: 0
 
Total % of Req Cache
Total
--------------------------------------------
 
Cacheable requests
------------------
Req cache-miss: 0 0.00%
Req cache-hit: 0 0.00%
Req cache-partial-hit: 0 0.00%
Req cache-total: 0 0.00%
 
Req cache-bypassed: 81
 
Objects not cached
------------------
Cache bypassed: 81
Exceed max-size: 0
 
 
 
Usage Summary
=============
Concurrent Unicast Client Sessions
----------------------------------
Current: 8
Max: 8
 
Concurrent Active Multicast Sessions
------------------------------------
Current: 0
Max: 0
 
Concurrent Remote Server Sessions
---------------------------------
Current: 1
Max: 1
 
Concurrent Unicast Bandwidth (Kbps)
-----------------------------------
Current: 1734.120
Max: 1734.120
 
Concurrent Multicast Out Bandwidth (Kbps)
-----------------------------------------
Current: 0.000
Max: 0.000
 
Concurrent Bandwidth to Remote Servers (Kbps)
---------------------------------------------
Current: 216.765
 
Max: 216.765
 
Error Statistics
================
Total request errors: 0
 
Errors generated by this box
Reach MAX connections: 0
Reach MAX incoming bandwidth: 0
Reach MAX outgoing bandwidth: 0
Reach MAX incoming bit rate: 0
Reach MAX outgoing bit rate: 0
MMSU under wccp: 0
MMSU not allowed: 0
MMST not allowed: 0
MMSU/T not allowed: 0
HTTP not allowed: 0
1st tcp pkt error, possible port scan: 0
Illegal url: 0
No socket: 0
Cannot connect: 0
Authentication fail: 0
Remote server error: 0
Client error: 0
Internal error: 0
Local vod file not found: 0
Local vod file header corrupted: 0
Local vod file data corrupted: 0
Unknown error: 0
 
Errors generated by remote servers
Reach MAX connections: 0
Reach MAX bandwidth: 0
Reach MAX bit rate: 0
Illegal url: 0
Invalid request: 0
No socket: 0
Cannot connect: 0
Conection refused: 0
Access deny: 0
Invalid stream type: 0
Remote server error: 0
Remote timeout: 0
Remote proxy error: 0
File not found: 0
File header corrupted: 0
File data corrupted: 0
Remote unknown error: 0
 
Authentication Retries from Clients: 0
 
WMT Rule Template Statistics
================
URL Rewrite: 0
Connection Reset: 0
URL Block: 0
No-Auth: 0
No-Cache: 0
Selective Cache: 0
Allow: 0
 
WMT URL Filter Statistics
================
URL Allowed: 0
 
URL Filtered: 0
 

次に、Cisco CME での Cisco Unity Express の show interface service-engine 4/0 コマンドの出力例を示します。

 
3845-gw# show interface service-engine 4/0
 
Service-Engine4/0 is up, line protocol is up
Hardware is I82559FE, address is 000e.8335.7c30 (bia 000e.8335.7c30)
Interface is unnumbered. Using address of Loopback2 (10.1.152.241)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:14, output 00:00:02, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
138507 packets input, 21920546 bytes, 0 no buffer
Received 2237 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
421216 packets output, 53661814 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

 

次に、Cisco CME での Cisco Unity Express の service-module service-engine 4/0 status コマンドの出力例を示します。

3845-gw# service-module service-Engine 4/0 status
 
Service Module is Cisco Service-Engine4/0
Service Module supports session via TTY line 258
Service Module is in Steady state
Getting status from the Service Module, please wait..
cisco service engine 1.1
 

次に、Cisco CME での Cisco Unity Express の service-module service-engine 4/0 status session コマンドの出力例を示します。

3845-gw# service-module service-engine 4/0 session
 
Trying 10.1.152.241, 2258 ... Open
 
 
User Access Verification
 
Username: cisco
Password:
se-10-32-152-242#
se-10-32-152-242#
 

次に、Cisco Unity Express での show running-config コマンドの出力例を示します。

se-10-32-152-242# show running-config
 
Generating configuration:
 
clock timezone America/Los_Angeles
 
hostname se-10-32-152-242
 
ip domain-name cisco.com
ip name-server 10.64.2.113 10.64.11.48
 
ntp server 10.1.152.241
 
groupname Administrators create
 
username Ross create
username Rachel create
username Chandler create
username Monica create
username Jeshih create
username Mike create
username Phoebe create
username Cosmo create
username Jerry create
username George create
username Frank create
username Estelle create
username Ross phonenumber "27725"
username Rachel phonenumber "27726"
username chandler phonenumber "27727"
username Monica phonenumber "27728"
username Jeshih phonenumber "27729"
username Mike phonenumber "27730"
username Phoebe phonenumber "27731"
username Cosmo phonenumber "27732"
username Jerry phonenumber "27733"
username George phonenumber "27734"
username Frank phonenumber "27735"
username Estelle phonenumber "27736"
 
groupname Administrators member cisco
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
 
backup server url "ftp://127.0.0.1/ftp" credentials hidden "EWlTygcMhYmjazXhE/VN
XHCkplVV4KjescbDaLa4fl4WLSPFvv1rWUnfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35jwAAAAA="
 
ccn application autoattendant
description "autoattendant"
enabled
maxsessions 8
script "aa.aef"
parameter "MaxRetry" "3"
parameter "operExtn" "0"
parameter "welcomePrompt" "AAWelcome.wav"
end application
 
ccn application ciscomwiapplication
description "ciscomwiapplication"
enabled
maxsessions 8
script "setmwi.aef"
parameter "strMWI_OFF_DN" "8000"
parameter "strMWI_ON_DN" "8001"
parameter "CallControlGroupID" "0"
end application
 
ccn application promptmgmt
description "promptmgmt"
enabled
maxsessions 1
script "promptmgmt.aef"
end application
 
ccn application voicemail
description "voicemail"
enabled
maxsessions 8
script "voicebrowser.aef"
parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
end application
 
ccn engine
end engine
 
ccn subsystem jtapi
ccm-manager address
end subsystem
 
ccn subsystem sip
gateway address "10.1.152.241"
end subsystem
 
ccn trigger sip phonenumber 27748
application "autoattendant"
enabled
locale "en_US"
maxsessions 8
end trigger
 
ccn trigger sip phonenumber 27749
application "voicemail"
enabled
locale "en_US"
maxsessions 8
end trigger
 
ccn trigger sip phonenumber 27751
application "promptmgmt"
enabled
locale "en_US"
maxsessions 1
end trigger
 
voicemail default expiration time 30
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail recording time 900
voicemail default messagesize 60
voicemail operator telephone 0
voicemail capacity time 6000
voicemail mailbox owner "Ross" size 3000
description "Ross mailbox"
end mailbox
 
voicemail mailbox owner "Rachel" size 3000
description "Rachel mailbox"
end mailbox
 
voicemail mailbox owner "Chandler" size 3000
description "Chandler mailbox"
end mailbox
 
voicemail mailbox owner "Monica" size 3000
description "Monica mailbox"
end mailbox
 
voicemail mailbox owner "Jeshih" size 3000
description "Jeshih mailbox"
end mailbox
 
voicemail mailbox owner "Mike" size 3000
description "Mike mailbox"
end mailbox
 
voicemail mailbox owner "Phoebe" size 3000
description "Phoebe mailbox"
end mailbox
 
voicemail mailbox owner "Cosmo" size 3000
description "Cosmo mailbox"
end mailbox
 
voicemail mailbox owner "Jerry" size 3000
description "Jerry mailbox"
end mailbox
 
voicemail mailbox owner "George" size 3000
description "George mailbox"
end mailbox
 
voicemail mailbox owner "Frank" size 3000
description "Frank mailbox"
end mailbox
 
voicemail mailbox owner "Estelle" size 3000
description "Estelle mailbox"
end mailbox
 
end
 

次に、Cisco Unity Express での show voicemail mailboxes コマンドの出力例を示します。

se-10-32-152-242# show voicemail mailboxes
 
OWNER MSGS NEW SAVED MSGTIME MBXSIZE USED
"Ross" 0 0 0 0 3000 0 %
"Rachel" 0 0 0 0 3000 0 %
"Chandler" 0 0 0 0 3000 0 %
"Monica" 3 3 0 142 3000 5 %
"Jeshih" 0 0 0 0 3000 0 %
"Mike" 0 0 0 0 3000 0 %
"Phoebe" 0 0 0 0 3000 0 %
"Cosmo" 0 0 0 0 3000 0 %
"Jerry" 0 0 0 0 3000 0 %
"George" 0 0 0 0 3000 0 %
"Frank" 0 0 0 0 3000 0 %
"Estelle" 0 0 0 0 3000 0 %

次に、Cisco Unity Express での show voicemail usage コマンドの出力例を示します。

se-10-32-152-242# show voicemail usage
 
personal mailboxes: 12
general delivery mailboxes: 0
orphaned mailboxes: 0
capacity of voicemail (minutes): 6000
allocated capacity (minutes): 600.0
message time used (seconds): 141
message count: 3
average message length (seconds): 47.0
greeting time used (seconds): 0
greeting count: 0
average greeting length (seconds): 0.0
total time used (seconds): 141
total time used (minutes): 2.3499999046325684
percentage used time (%): 1
 

次に、Cisco Unity Express での show voicemail limits コマンドの出力例を示します。

se-10-32-152-242# show voicemail limits
 
Default Mailbox Size (seconds): 3000
Default Caller Message Size (seconds): 60
Maximum Recording Size (seconds): 900
Default Message Age (days): 30
System Capacity (minutes): 6000
Default Prompt Language: en_US
Operator Telephone: 0
 

次に、Cisco Unity Express での show ccn application コマンドの出力例を示します。

se-10-32-152-242# show ccn application
 
Name: ciscomwiapplication
Description: ciscomwiapplication
Script: setmwi.aef
ID number: 0
Enabled: yes
Maximum number of sessions: 8
strMWI_OFF_DN: 8000
strMWI_ON_DN: 8001
CallControlGroupID: 0
 
Name: voicemail
Description: voicemail
Script: voicebrowser.aef
ID number: 1
Enabled: yes
Maximum number of sessions: 8
logoutUri: http://localhost/voicemail/vxmlscripts/m
bxLogout.jsp
uri: http://localhost/voicemail/vxmlscripts/l
ogin.vxml
 
Name: autoattendant
Description: autoattendant
Script: aa.aef
ID number: 2
Enabled: yes
Maximum number of sessions: 8
MaxRetry: 3
operExtn: 0
welcomePrompt: AAWelcome.wav
Name: promptmgmt
Description: promptmgmt
Script: promptmgmt.aef
ID number: 3
Enabled: yes
Maximum number of sessions: 1
 

次に、Cisco Unity Express での show ccn trigger コマンドの出力例を示します。

se-10-32-152-242# show ccn trigger
 
Name: 27749
Type: SIP
Application: voicemail
Locale: en_US
Idle Timeout: 10000
Enabled: yes
Maximum number of sessions: 8
 
Name: 27751
Type: SIP
Application: promptmgmt
Locale: en_US
Idle Timeout: 10000
Enabled: yes
Maximum number of sessions: 1
 
Name: 27748
Type: SIP
Application: autoattendant
Locale: en_US
Idle Timeout: 10000
Enabled: yes
Maximum number of sessions: 8
se-10-32-152-242#
 

確認画面:例

次の表示画面の例は、確認目的での Cisco CallManager、Cisco CallManager Express(Cisco CME)、および Cisco Unity Express のグラフィカル ユーザ インターフェイスを示しています。これらの画面例は参照用として掲載しており、次の項で説明します。

「Cisco CallManager の画面例」

「Cisco CME の画面例」

「Cisco Unity Express の画面例」

Cisco CallManager の画面例

次の画面例は、Cisco CallManager Release 3.3(3) の Cisco CME 用のトランク設定を示しています。

 

次の画面表示例は、メディア ターミネーション ポイント(MTP)ソフトウェア設定を示しています。

 

Cisco CME の画面例

次の画面表示例は、Cisco CallManager の内線を示しています。

 

次の画面表示例は、Cisco CME Phone に関する詳細情報を示しています。

 

Cisco Unity Express の画面例

次の画面表示例は、Cisco Unity Express ユーザ設定の音声メールボックスのリストを示しています。

 

次の画面表示例は、Cisco Unity Express の音声メールボックスに関する詳細情報を示しています。

 

次の画面表示例は、グループ プロファイル アドミニストレータの表示を示しています。

 

トラブルシューティング

ここでは、設定のトラブルシューティングに使用できる情報を示します。

次のテクニカル ノートを参照してください。

『IP Security Troubleshooting - Understanding and Using debug Commands』

トラブルシューティング用の参照マニュアルとコマンド

以下で勧める参考資料とコマンドは、Cisco CME ベースでの Cisco Unity Express の実装におけるトラブルシューティングに役立ちます。


debug コマンドを実行する前に、『Important Information on Debug Commands』を参照してください。


VoIP コールの基本事項に対するトラブルシューティングおよびデバッグについては、次のマニュアルを参照してください。

http://www.cisco.com/warp/public/788/voip/voip_debugcalls.html

次は、VoIP コールのトラブルシューティングに関するコマンドです。

show dialplan number :このコマンドは、特定の電話番号をダイヤルしたときに到達するダイヤル ピアを示すために使用します。

debug vtsp session :このコマンドは、シグナリング スタックからの信号表示やアプリケーションからの要求に基づいて、ルータがどのように DSP と相互作用しているかを追跡するのに役立つ情報を表示します。

debug vtsp dsp :このコマンドは、音声ポートによって受信された番号を表示します。

debug vtsp all :このコマンドにより、次のデバッグ音声テレフォニー サービス プロバイダー(VTSP)のコマンド(debug vtsp session、debug vtsp error、および debug vtsp dsp)がイネーブルになります。

debug vpm signal :このコマンドは、シグナリング イベントだけに関するデバッグ情報を収集します。このコマンドは、PBX へのシグナリングでの問題を解決する場合にも役立ちます。

debug voip ccapi :このコマンドは、呼制御 Application Programming Interface(API; アプリケーション プログラミング インターフェイス)を通じた実行パスを追跡します。呼制御 API は、コール セッション アプリケーションと、下位のネットワーク固有のソフトウェアとの間のインターフェイスとして機能します。このコマンドの出力結果を使用して、ルータがコールを処理する方法がわかります。

debug vpm port :このコマンドは、デバッグ出力を特定のポートに制限します。デバッグ出力は、単位のポートには大量すぎる場合があります。6 ポート シャーシでは問題が発生する可能性があります。このデバッグ コマンドは、他のデバッグ モードのいずれかまたはすべてと併用してください。

Cisco Unity Express のトラブルシューティングおよびデバッグについては、次のマニュアルを参照してください。

http://www.cisco.com/en/US/products/sw/voicesw/ps5520/products_administration_guide_chapter09186a00801f4eb6.html

Cisco CME のトラブルシューティングおよびデバッグについては、次のマニュアルを参照してください。

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_configuration_guide_chapter09186a00801f12fb.html

CE のトラブルシューティングおよびメンテナンスについては、次のマニュアルを参照してください。

http://www.cisco.com/en/US/products/sw/conntsw/ps491/products_maintenance_guide_book09186a0080080be8.html

Land Mobile Radio とゲートウェイの E&M ポートとの統合でのトラブルシューティング ヒントについては、次のマニュアルを参照してください。

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00801f092c.html#wp1242977

関連情報

LMR のゲートウェイとの統合に関するその他の詳細については、次を参照してください。

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00801f092c.html

Cisco CallManager Express のその他の詳細については、次を参照してください。

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/index.html

Cisco Unity Express のその他の詳細については、次を参照してください。

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/index.html

中小企業向けの Cisco CallManager など、Cisco IP Communications ソリューションに関するその他の詳細については、次を参照してください。

http://www.cisco.com/en/US/netsol/ns339/ns395/ns359/networking_solutions_packages_list.html

Cisco ACNS のその他の詳細については、次を参照してください。

http://www.cisco.com/warp/public/cc/so/neso/cxne/acnss_wp.htm

Copyright © 2004-2010. シスコシステムズ合同会社.