Cisco 3200 シリーズ ワイヤレス MIC ソフトウェア コンフィギュレーション ガイド
トンネル テンプレート
トンネル テンプレート
発行日;2012/02/06 | 英語版ドキュメント(2009/02/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

トンネル テンプレート

ホーム エージェントでのトンネル テンプレートの適用

モバイル ルータでのトンネル テンプレートの適用

設定例

IPSec ツーボックス ソリューションへのトンネル テンプレートの適用

関連資料

トンネル テンプレート

トンネル テンプレートを使用すると、モバイル ルータのローミング時にマルチキャスト セッションをモバイル ネットワークに伝送できます。マルチキャスト用トンネル テンプレート機能を使用すると、静的に作成されたトンネルのマルチキャスト セッションの設定を、ホーム エージェントとモバイル ルータで有効になっているダイナミック トンネルに適用できます。定義したトンネル テンプレートはホーム エージェントとモバイル ルータの間のトンネルに適用されます。

モバイル ルータからホーム エージェントへの反転トンネリングがイネーブルになっている必要があります。

次の制限が適用されます。

トンネルがテンプレートとして使用されている場合、そのトンネルは削除できません。

この機能は、モバイル ノードとして機能しているモバイル ルータでは使用できません。

ホーム エージェントでのトンネル テンプレートの適用

トンネル テンプレートをホーム エージェントで有効になっているトンネルに適用するには、 interface tunnel コマンドを使用します。次に例を示します。

WMIC>enable
WMIC>password ! If prompted
WMIC#configure terminal
WMIC(config)#ip multicast-routing ! Enables IP multicast routing.
WMIC(config)#interface tunnel interfacenumber ! Designates a tunnel interface and enters interface configuration mode. This is the tunnel template that will be applied to the mobile networks.
WMIC(config-in)#ip pim sparse-mode ! Enables Protocol Independent Multicast (PIM) on the tunnel interface in sparse mode.
WMIC(config)#exit
WMIC(config)#router mobile ! Enables Mobile IP on the router.
WMIC(config)#ip mobile mobile-networks ! Configures mobile networks for the mobile host and enters mobile networks configuration mode.
WMIC(config)#tunnel template interfacenumber ! Designates the tunnel template to apply during registration. The interfacenumber argument is set to the tunnel template.
WMIC(config)#end

show ip mobile tunnel コマンドを使用すると、アクティブなトンネルを表示できます。次の例は、アクティブなモバイル IP トンネルと、ホーム エージェントのトンネルのテンプレート設定を示しています。

Router# show ip mobile tunnel
 
Mobile Tunnels:
 
Total mobile ip tunnels 2
Tunnel1:
src 1.1.1.1, dest 20.20.0.1
encap IP/IP, mode reverse-allowed, tunnel-users 1
IP MTU 1460 bytes
Path MTU Discovery, mtu:0, ager:10 mins, expires:never
outbound interface Tunnel0
HA created, fast switching enabled, ICMP unreachable enabled
27 packets input, 2919 bytes, 0 drops
24 packets output, 2568 bytes
Running template configuration for this tunnel:
ip pim sparse-dense-mode
 
Tunnel0:
src 1.1.1.1, dest 30.30.10.2
encap IP/IP, mode reverse-allowed, tunnel-users 1
IP MTU 1480 bytes
Path MTU Discovery, mtu:0, ager:10 mins, expires:never
outbound interface Ethernet1/3
HA created, fast switching enabled, ICMP unreachable enabled
0 packets input, 0 bytes, 0 drops
24 packets output, 3048 bytes

モバイル ルータでのトンネル テンプレートの適用

トンネル テンプレートをモバイル ルータで有効にされているトンネルに適用するには、次の手順に従います。

WMIC>enable
WMIC>password ! If prompted
WMIC#configure terminal
WMIC(config)#ip multicast-routing ! Enables IP multicast routing.
WMIC(config)#interface tunnel interfacenumber ! Designates a tunnel interface and enters interface configuration mode. This is the tunnel template that will be applied to the mobile networks.
WMIC(config-in)#ip pim sparse-mode ! Enables Protocol Independent Multicast (PIM) on the tunnel interface in sparse mode.
WMIC(config)#exit
WMIC(config)#router mobile ! Enables Mobile IP on the router.
WMIC(config)#ip router mobile ! Enables the mobile router and enters mobile router configuration mode.
WMIC(config)#tunnel template interfacenumber ! Designates the tunnel template to apply during registration. The interfacenumber argument is set to the tunnel template.
WMIC(config)#end

show ip mobile tunnel コマンドを使用すると、アクティブなトンネルを表示できます。

設定例

次の設定例では、トンネル テンプレートが定義され、ホーム エージェントとモバイル ルータで有効になるよう設定されています。外部エージェントでは追加設定をしなくても Cisco Mobile Networks のマルチキャスト用トンネル テンプレート機能を使用できます。

ホーム エージェント

ip multicast-routing
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
! Tunnel template to be applied to mobile networks
interface tunnel100
ip address 13.0.0.1 255.0.0.0
ip pim sparse-mode
!
router mobile
ip mobile mobile-networks 11.1.0.1
description jet
network 11.1.2.0 255.255.255.0
network 11.1.1.0 255.255.255.0
! Select tunnel template to apply during registration
template tunnel100
!
ip mobile secure host 11.1.0.1 spi 101 key hex 12345678123456781234567812345678 algorithm md5 mode prefix-suffix
!
no ip mobile tunnel route-cache

モバイル ルータ

ip multicast-routing
!
interface Loopback0
ip address 11.1.0.1 255.255.255.255
ip pim sparse-mode
!
! Tunnel template to be applied to mobile networks
interface tunnel 100
no ip address
ip pim sparse-mode
!
interface Ethernet1/1
ip address 20.0.0.1 255.0.0.0
ip pim sparse-mode
ip mobile router-service roam
!
router mobile
ip pim rp-address 7.7.7.7
ip mobile secure home-agent 1.1.1.1 spi 102 key hex 23456781234567812345678123456781 algorithm md5 mode prefix-suffix
ip mobile router
address 11.2.0.1 255.255.0.0
home-agent 1.1.1.1
! Select tunnel template to apply during registration
template tunnel 100
register extend expire 5 retry 2 interval 15
register lifetime 10000
reverse-tunnel

IPSec ツーボックス ソリューションへのトンネル テンプレートの適用

IPSec を Cisco IOS Mobile Network ソフトウェアとあわせて設定する場合、特別な注意が必要です。トラフィックの出力インターフェイスが変わる場合があり、IPSec は通常出力インターフェイスで設定されるためです。従来は、ループバック インターフェイスでクリプト マップを設定し、暗号化が必要なすべてのトラフィックに対してポリシー ルーティングを使用して ネクストホップ ループバックを設定 することが推奨されていました。


) ループバック インターフェイスへのクリプト マップの適用は、サポートされている設定ではありません(CSCdx79795 を参照)。


Cisco IOS リリース 12.2(15)T で導入されたトンネル テンプレートではマルチキャストがサポートされていますが、他のパラメータを内部トンネル インターフェイスに適用する場合にも使用できます。トンネル テンプレートをクリプト マップに適用する場合、次の設定例のように crypto map local-address コマンドが必要です。ローカル アドレスはホーム アドレス インターフェイスに設定されている必要があります。これによりポリシー ルーティングは必要がなくなり、すべてのトラフィックをシスコ エクスプレス フォワーディング(CEF)交換にすることができます(ループバック インターフェイスではサポートされていません)。

暗号化を行うには、モバイル ルータからのすべてのトラフィックに反転トンネリングを行う必要があります。反転トンネルクリプト マップが適用される出力インターフェイスとなります。

設定例

hostname MN
!
crypto isakmp policy 10
encr aes
authentication pre-share
group 2
lifetime 900
crypto isakmp key skeleton
!
address 192.168.1.1
crypto ipsec transform-set aes esp-aes 256 esp-sha-hmac
!
! Local-address must point to the Home Address
!
crypto map MAR_VPN local-address Loopback 0
crypto map MAR_VPN 1 ipsec-isakmp
set peer 192.168.1.1
set transform-set aes
match address 110
!
interface Tunnel99
description Mobile Networks Tunnel Template
no ip address
crypto map MAR_VPN
!
interface LoopbackO
ip address 192.168.100.10 255.255.255.255
!
interface EthernetO/O
ip address 169.254.255.1 255.255.255.255
ip mobile router-service roam
!
interface Ethernet1/0
description Mobile Network
ip address 192.168.124.1 255.255.255.0
!
router mobile
!
ip mobile secure home-agent 192.168.1.2 spi 100 key hex 1234567890abcdef1234567890abcdef algorithm md5 mode prefix-suffix
ip mobile router
address 192.168.100.10 255.255.255.0
home-agent 192.168.1.2
mobile-network Ethernet1/0
!
! Tunnel Template where the crypto map is applied
!
template Tunnel99
!
! Reverse tunneling must be enabled or traffic will not exit via the tunnel
!
reverse-tunnel
!
access-list 110 permit ip any host 192.168.2.2
!
end
 

設定の検証

設定を検証するには、 show ip mobile router コマンドを使用して、モバイル ルータが使用しているトンネル インターフェイスを特定します。その後、 show crypto ipsec sa interface tunnel n コマンドを使用して、関連する SA がアクティブであることを確認します。次の出力例では、重要な部分を強調表示してあります。

MN#show ip mobile router
Mobile Router
Enabled 10/18/05 18:50:54
Last redundancy state transition NEVER
 
Configuration:
Home Address 192.168.100.10 Mask 255.255.255.0
Home Agent 192.168.1.2 Priority 100 (best) (current)
Registration lifetime 65534 sec
Retransmit Init 1000, Max 5000 msec, Limit 3
Extend Expire 120, Retry 3, Interval 10
Reverse tunnel required
Mobile Networks: Loopback2 (192.168.123.0/255.255.255.0)
Ethernet1/0 (192.168.124.0/255.255.255.0)
 
Monitor:
Status -Registered
Active foreign agent 192.168.6.1, Care-of 192.168.6.1 On interface EthernetO/O
TunnelO mode IP/IP
 
MN#show crypto ipsec sa interface tunnel 0
interface: Tunnel 0
Crypto map tag: MAR_VPN, local addr 192.168.100.10
protected vrf: (none)
local ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)
remote ident (addr/mask/prot/port): (192.168.2.2/255.255.255.255/0/0)
current-peer 192.168.1.1 port 500
PERMIT, flags={)
#pkts encaps: 5, #pkts encrypt: 5, #pkts digest: 5
#pkts decaps: 9, #pkts decrypt: 9, #pkts verify: 9
#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 0, #pkts compr. failed: 0
#pkts not decompressed: 0, #pkts decompress failed: 0
#send errors 0, #recv errors 0
local crypto endpt.: 192.168.100.10, remote crypto endpt.: 192.168.1.1
path mtu 1514, ip mtu 1514
current outbound spi: OxC8D41EOA(336934452~)
inbound esp sas:
spi: OxB7BClB29 (3082558249)
transfor.m: esp-256-aes esp-sha-hmac ,
in use settings ={Tunnel, }
conn id: 1, flow_id: SW:l, crypto map: MAR_VPN
sa timdng: remaining key lifetime (k/sec): (4602927/3584) IV size: 16 bytes
replay detection support: Y
Status: ACTIVE
inbound ah sas:
inbound pcp sas:
outbound esp sas:
spi: OxC8D41EOA(3369344522)
transfor.m: esp-256-aes esp-sha-hmac ,
in use settings ={Tunnel, }
conn id: 2, flow_id: SW:2, crypto map: MAR VPN
sa timdng: remaining key lifetime (k/sec): (4602928/3582) IV size: 16 bytes
replay detection support: Y
Status: ACTIVE
outbound ah sas:
outbound pcp sas:
protected vrf: (none) .
local ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)
remote ident (addr/mask/prot/port): (192.168.2.2,255.255.255.255/0/0) current-peer 192.168.1.1 port 500
PERMIT, flags={origin_is_acl,ipsec_sa_request_sent}
#pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
#pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 0, #pkts compr. failed: 0
#pkts not decompressed: 0, #pkts decompress failed: 0
#send errors 8, #recv errors 0
local crypto endpt,:192.168.100.10, remote crypto endpt.: 192.168.1.1
path mtu 1514, ip mtu 1514
current outbound spi: 0x0(0)
 
inbound esp sas:
inbound ah sas:
inbound pcp sas:
outbound esp sas:
outbound ah sas:
outbound pcp sas:
 

関連資料

Cisco Mobile Networks のマルチキャスト用トンネル テンプレート

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a0080455164.html

『Cisco Mobile Wireless Home Agent Feature Guide』の「Other Configuration Tasks」

http://www.cisco.com/en/US/docs/ios/12_3/12_3y/12_3_14yx/12_3_14yx7/ha_feature_guide_yx7/ha_other.html

次のマニュアルは、Cisco Connection Online(CCO)(www.cisco.com)の Documentation ページでご覧になれます。次の URL からアクセスしてください。 http://www.cisco.com/en/US/products/hw/routers/ps272/tsd_products_support_series_home.html

Cisco 3200 Series Mobile Access Router Card Release Notes 』:Cisco 3200 シリーズ ワイヤレス/モバイル ルータのマニュアルおよびテクニカル サポートの入手に関する情報。

Cisco IOS Command Reference for Cisco Access Points and Bridges 1 :Wireless Mobile Interface Card(WMIC) で提供される無線ポート用の Cisco IOS の新しい、および改訂されたコマンド。

Cisco 3200 Series Wireless MIC Software Configuration Guide 1 :IOS コマンドを使用して Wireless Mobile Interface Card(WMIC)を設定する手順の例。

Configuration Guide for the Cisco 3200 Series Mobile Access Router 1 :IOS コマンドを使用して組み立てられた Cisco 3200 シリーズ ルータを設定する手順の例。

Cisco 3200 Series Mobile Access Router Hardware Reference 1 :このマニュアル。Cisco 3200 シリーズ ルータで使用される Cisco MIC I/O カードに関する説明もあります。

Cisco 3200 Series Mobile Access Router Reference Sell Document 1 :Cisco 3200 シリーズ ルータの Reference Sell Program およびコンポーネントの概要説明

Release Notes for the Cisco 3250 Mobile Router for Cisco IOS Release Number XX.X 』には、Cisco 3200 シリーズ ルータに関する Cisco IOS の各リリースの拡張点と注意事項を一覧掲載していますが、これは次の URL から入手できます。

http://www.cisco.com/en/US/products/sw/iosswrel/products_ios_cisco_ios_software_releases.html または

http://www.cisco.com/en/US/products/sw/iosswrel/ps5012/ps4629/index.html

1. プラットフォーム専用の CD-ROM にも収録されています。

この機能により、RFC 2006 の Set 操作およびセキュリティ違反トラップがサポートされます。仕様については、RFC 2006「 The Definitions of Managed Objects for IP Mobility Support Using SMIv2 」を参照してください。

Cisco IOS ソフトウェアにより SNMP を設定する方法については、次のマニュアルを参照してください。

Cisco IOS Configuration Fundamentals Configuration Guide, Release 12.2』 の「 Configuring SNMP Support 」の章

Cisco IOS Configuration Fundamentals Command Reference, Release 12.2』 の「 SNMP Commands 」の章

Cisco IOS ソフトウェアにより SNMP MIB 機能を設定する方法については、ご使用のネットワーク管理システムに応じたマニュアルを参照してください。

Cisco IOS ソフトウェアを使用してモバイル IPを設定する方法については、次のマニュアルを参照してください。

Cisco IOS IP Configuration Guide, Release 12.2』 の「Configuring Mobile IP」の章

Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.2』 の「Mobile IP Commands」の章

Cisco TAC Web ページに掲載されている関連資料には、次のようなものがあります。

Antenna Cabling 』(http://www.cisco.com/warp/public/102/wlan/antcable.html)