Cisco 3200 シリーズ ワイヤレス MIC ソフトウェア コンフィギュレーション ガイド
STPの設定
STPの設定
発行日;2012/02/06 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

STPの設定

STP

STPの概要

ブリッジのインターオペラビリティ

BPDU

スパニングツリー ルートの選定

スパニングツリー タイマー

スパニングツリー トポロジーの作成

スパニングツリー インターフェイスのステート

ブロッキング ステート

リスニング ステート

ラーニング ステート

フォワーディング ステート

ディセーブル ステート

STP機能の設定

STPのデフォルト設定

STPの設定

STPの設定例

ルート ブリッジ(VLANが設定されていない場合)

非ルート ブリッジ(VLANが設定されていない場合)

ルート ブリッジ(VLANが設定されている場合)

非ルート ブリッジ(VLANが設定されている場合)

スパニングツリー ステータスの表示

STPの設定

この章では、WMICにSpanning-Tree Protocol(STP;スパニングツリー プロトコル)の設定方法について説明します。この章の内容は、次のとおりです。

「STP」

「STP機能の設定」

「スパニングツリー ステータスの表示」


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースの『Cisco IOS Command Reference for Access Points and Bridges』を参照してください。


STP

ここでは、スパニングツリー機能の動作について説明します。具体的な内容は次のとおりです。

「STPの概要」

「BPDU」

「スパニングツリー ルートの選定」

「スパニングツリー タイマー」

「スパニングツリー トポロジーの作成」

「スパニングツリー インターフェイスのステート」

STPの概要

STPは、ネットワーク上でループを防止しながらパスの冗長性を実現するレイヤ2リンク管理プロトコルです。レイヤ2イーサネット ネットワークを正しく機能させるには、2つのステーション間に存在するアクティブ パスが1つのみでなければなりません。スパニングツリーの動作はエンド ステーションに対してトランスペアレントです。エンド ステーションは接続先が1つのLANセグメントなのか、それとも複数のセグメントからなるLANなのかを認識できません。

フォールトトレラントなインターネットワークを作成する場合は、ネットワーク上のすべてのノード間にループフリー パスを形成する必要があります。レイヤ2ネットワーク上で最良のループフリー パスは、スパニングツリー アルゴリズムによって計算されます。無線ブリッジやスイッチなどのインフラストラクチャ デバイスは、定期的にBridge Protocol Data Unit(BPDU;ブリッジ プロトコル データ ユニット)と呼ばれるスパニングツリー フレームを送受信します。これらのデバイスはこれらのフレームを転送せずに、フレームを使用してループフリー パスを構築します。

エンド ステーション間に複数のアクティブ パスがあると、ネットワーク内でループが発生する原因になります。ネットワークにループが存在していると、エンド ステーションは重複するメッセージを受け取る可能性があります。また、インフラストラクチャ デバイスが複数のレイヤ2インターフェイス上のエンド ステーションMAC(メディア アクセス制御)アドレスを学習する可能性もあります。このような状況が発生すると、ネットワークが不安定になります。

STPは、ルート ブリッジおよびそのルートからレイヤ2ネットワーク上のすべてのインフラストラクチャ デバイスへのループフリー パスを含むツリーを定義します。


) STPに関する説明では、ルートと用語は2つの概念を示します。スパニングツリー内の中心点として機能するネットワーク上のブリッジは、ルート ブリッジといいます。デバイスへの最も効率的なパスを提供する各デバイスのポート は、ルート ポートといいます。これらの意味は、ルートおよび非ルート オプションを含む無線ネットワーク設定内の役割には依存しません。無線ネットワーク設定内の役割がルート ブリッジであるブリッジが、必ずしもスパニングツリー内のルート ブリッジになるとはかぎりません。この章では、スパニング ツリー内のルート ブリッジをスパニングツリー ルートと呼びます。


STPは冗長データ パスを強制的にスタンバイ(ブロック)ステートにします。スパニングツリーのネットワーク セグメントで障害が発生した場合に、冗長パスが存在していれば、スパニングツリー アルゴリズムがスパニングツリー トポロジーを再計算し、スタンバイ パスをアクティブにします。

2つのインターフェイスがループの一部になっている場合は、スパニングツリーのポート プライオリティおよびパス コストの設定によって、フォワーディング ステートになるインターフェイスとブロッキング ステートになるインターフェイスが決まります。ポート プライオリティ値は、ネットワーク トポロジー内でのインターフェイスの位置を表すとともに、インターフェイスがトラフィックを伝送するために適した位置にあるかどうかを表します。パス コスト値は、メディア速度を表します。

VLAN(仮想LAN)が存在しない場合、ブリッジはPer-VLAN Spanning Tree(PVST)と単一の802.1qスパニングツリーをサポートします。ブリッジは、複数のVLANを1つのインスタンスからなるスパニングツリーに対応付ける802.1s MSTまたは802.1d Common Spanning Treeを実行できません。

ブリッジは、ブリッジに設定されているアクティブVLANごとに、個別のスパニングツリー インスタンスを維持します。各インスタンスには、ブリッジ プライオリティおよびMACアドレスで構成されるブリッジIDが対応付けられます。VLANごとに、ブリッジIDが最小のブリッジがそのVLANのスパニングツリー ルートになります。

ブリッジのインターオペラビリティ

シスコ製ブリッジは、STPがイネーブルで、かつVLANが設定されていない場合に、相互運用できます。この設定が使用可能な唯一の設定である理由は、次のとおりです。

STPがディセーブルの場合、ブリッジはアクセス ポイントとして機能し、非ルート ブリッジのアソシエーションを禁止します。

ブリッジ内のSTPインスタンスの個数は、非VLAN構成の場合は1つ、VLAN構成の場合は複数です。

単一のSTPインスタンスと複数のSTPインスタンスには互換性がないため、VLANが設定されている場合に、トラフィックのブロックに矛盾が生じることがあります。ネイティブVLANがブロックされると、ブリッジにフラッピングが発生することがあります。

このため、STPインターオペラビリティを実現する最適な構成は、ブリッジSTP機能がイネーブルで、かつVLANが設定されていない場合になります。


) シスコ製ブリッジがワークグループ ブリッジとして設定されている場合、これらのブリッジはSTPがディセーブルの状態で動作し、アクセス ポイントとのアソシエーションを設定できます。ただし、この構成は、技術的にはブリッジ間の構成例ではありません。


BPDU

アクティブで安定したネットワークのスパニングツリー トポロジーは、次の要素によって決まります。

各無線ブリッジ上の各VLANに対応付けられた一意のブリッジID(無線ブリッジ プライオリティおよびMACアドレス)

スパニングツリー ルートへのスパニングツリー パス コスト

各レイヤ2インターフェイスに対応付けられたポートID(ポート プライオリティおよびMACアドレス)

ネットワーク内のブリッジに電源が投入されると、各ブリッジはSTPルートとして機能します。ブリッジはイーサネットおよび無線ポートを通してコンフィギュレーションBPDUを送信します。BPDUはスパニングツリー トポロジーの通信と計算を行います。各コンフィギュレーションBPDUには、次の情報が含まれます。

送信側ブリッジがスパニングツリー ルートとして識別する無線ブリッジの一意のブリッジID

ルートへのスパニングツリー パス コスト

送信側ブリッジのブリッジID

メッセージの有効期限

送信側インターフェイスのID

helloタイマー、転送遅延タイマー、およびmax-ageプロトコル タイマーの値

ブリッジは、 優位の 情報(より小さなブリッジID、より小さいなパス コストなど)を持つコンフィギュレーションBPDUを受信すると、そのポートの情報を保存します。ルート ポートでこのBPDUを受信したブリッジは、そのブリッジが指定ブリッジとなっているすべての接続LANに、このBPDUを更新メッセージと一緒に転送します。

ブリッジは、現在ポートに保存されている情報よりも 下位の 情報を持つコンフィギュレーションBPDUを受信すると、そのBPDUを廃棄します。ブリッジが下位BPDUの受信元LANの指定ブリッジである場合、そのブリッジはそのポート用に保存されている最新情報を含むBPDUをそのLANに送信します。これによって下位の情報は廃棄され、優位の情報がネットワークを伝播します。

BPDU交換によって、次の動作が発生します。

1台のブリッジがスパニングツリー ルートとして選定されます。

ブリッジごとにルート ポートが選択されます(スパニングツリー ルートを除く)。このポートは、ブリッジからスパニングツリー ルートへパケットを転送する場合の最適パス(最小コスト パス)を提供します。

パス コストに基づいて、ブリッジごとにスパニングツリー ルートまでの最短距離が計算されます。

LANセグメントごとに指定ブリッジが選択されます。指定ブリッジは、そのLANからスパニングツリー ルートにパケットを転送する場合の最小パス コストを選びます。指定ブリッジとLANの接続に使用されるポートは、指定ポートといいます。

スパニングツリー インスタンスに含まれるインターフェイスが選択されます。ルート ポートと指定ポートがフォワーディング ステートになります。

スパニングツリーに含まれないインターフェイスはすべてブロックされます。

スパニングツリー ルートの選定

STPに関与するレイヤ2ネットワーク内のすべてのブリッジは、BPDUデータ メッセージの交換により、ネットワーク内の他のブリッジの情報を収集します。このメッセージ交換により、次の動作が発生します。

スパニングツリー インスタンスごとに一意のスパニングツリー ルートが選定されます。

LANセグメントごとに指定ブリッジが1つ選定されます。

冗長リンクに接続されたレイヤ2インターフェイスをブロックすることによって、ネットワークのループが除去されます。

VLANごとに、最高のブリッジ プライオリティ(最小のプライオリティ値)を持つブリッジがスパニングツリー ルートとして選定されます。すべてのブリッジがデフォルト プライオリティ(32768)に設定されている場合は、VLAN内で最小のMACアドレスを持つブリッジがスパニングツリー ルートになります。ブリッジ プライオリティ値はブリッジIDの最上位ビットです。

ブリッジ プライオリティ値を変更すると、ブリッジがルート ブリッジとして選定される確率が変わります。高い値を設定すると確率が減り、低い値を設定すると確率が増します。

スパニングツリー ルートは、スパニングツリー トポロジーの論理上の中心です。ネットワーク内のどの場所からでも、スパニングツリー ルートに到達するために必要でないパスは、すべてスパニングツリー ブロッキング モードになります。

BPDUには、ブリッジおよびMACアドレス、ブリッジ プライオリティ、ポート プライオリティ、パス コストなど、送信側ブリッジおよびそのポートに関する情報が含まれます。STPはこの情報を使用して、ネットワークのスパニングツリー ルートおよびルート ポート、さらに各LANセグメント用のルート ポートおよび指定ポートを選定します。

スパニングツリー タイマー

表 8-1 に、スパニングツリー全体のパフォーマンスに関連するタイマーを示します。

 

表 8-1 スパニングツリー タイマー

タイマー
説明

helloタイマー

ブリッジから他のブリッジにhelloメッセージをブロードキャストする間隔を決定します。

転送遅延タイマー

インターフェイスが転送を開始するまでに、リスニング ステートおよびラーニング ステートがそれぞれ継続する時間を決定します。

最大エージング タイマー

インターフェイスが受信したプロトコル情報をブリッジが保存する時間を決定します。

スパニングツリー トポロジーの作成

図 8-1では、ブリッジ4がスパニングツリー ルートに選定されます。これは、すべてのブリッジのプライオリティがデフォルト(32768)に設定されていて、ブリッジ4のMACアドレスが最小であるためです。ただし、トラフィック パターン、転送インターフェイスの数、またはリンク タイプによっては、ブリッジ4が最適なスパニングツリー ルートにならない場合もあります。最適なブリッジのプライオリティを上げる(プライオリティ値を小さくする)ことによって、そのブリッジがスパニングツリー ルートになるように設定すると、スパニングツリーが強制的に再計算されて、最適なブリッジをスパニングツリー ルートとして持つ新しいスパニングツリー トポロジーが形成されます。

図 8-1 スパニングツリー トポロジー

 

スパニングツリー インターフェイスのステート

プロトコル情報が無線LANを通過するときに、伝送遅延が生じることがあります。その結果、さまざまな時点で、およびネットワークのさまざまな場所で、トポロジーが変化することがあります。インターフェイスがスパニングツリー トポロジーに含まれていない状態からフォワーディング ステートに直接移行すると、一時的にデータ ループが形成される可能性があります。インターフェイスは新しいトポロジー情報がLAN上で伝播されるまで待機してから、フレーム転送を開始する必要があります。インターフェイスはさらに、古いトポロジーで使用されていた転送フレームのフレーム存続時間を満了させる必要もあります。

スパニング ツリーを使用するブリッジの各インターフェイスは、次のステートのいずれかになります。

ブロッキング ― インターフェイスはフレーム転送に関与しません。

リスニング ― インターフェイスがフレーム転送に参加すべきであるとスパニングツリーが判断した場合に、ブロッキング ステート後、最初に開始する移行ステートです。

ラーニング ― インターフェイスはフレーム転送に関与する準備をしている状態です。

フォワーディング ― インターフェイスはフレームを転送します。

ディセーブル ― インターフェイスはスパニングツリーに参加していない状態です。ポートのシャットダウン、ポート上のリンク欠落、ポートで稼働するスパニングツリー インスタンスが存在しないことなどが原因です。

インターフェイスは次のように、ステートを移行します。

初期化からブロッキング

ブロッキングからリスニングまたはディセーブル

リスニングからラーニングまたはディセーブル

ラーニングからフォワーディングまたはディセーブル

フォワーディングからディセーブル

図 8-2図 8-2に、インターフェイスのステート移行経路を示します。

図 8-2 スパニングツリー インターフェイスのステート

 

ブリッジ上でSTPをイネーブルにすると、イーサネットおよび無線インターフェイスはブロッキング ステートを経て、リスニングおよびラーニングの移行ステートに進みます。スパニングツリーは、フォワーディング ステートまたはブロッキング ステートで各インターフェイスを安定させます。

スパニングツリー アルゴリズムによってレイヤ2インターフェイスがフォワーディング ステートに移行すると、次のプロセスが発生します。

1. インターフェイスはリスニング ステートになり、スパニングツリーはインターフェイスをブロッキング ステートに移行するためのプロトコル情報を待ち受けます。

2. スパニングツリーは、転送遅延タイマーの満了を待つ間に、インターフェイスをラーニング ステートに移行し、転送遅延タイマーをリセットします。

3. ラーニング ステートでは、ブリッジが転送データベースのエンド ステーションの位置情報を学習する間、インターフェイスはフレーム転送を引き続きブロックします。

4. 転送遅延タイマーが満了すると、スパニングツリーはインターフェイスをフォワーディング ステートに移行し、ここでラーニングとフレーム転送の両方がイネーブルになります。

ブロッキング ステート

ブロッキング ステートのインターフェイスはフレームの転送に関与しません。初期化後、ブリッジのイーサネット ポートおよび無線ポートにBPDUが送信されます。ブリッジは当初、他のブリッジとBPDUを交換するまで、スパニングツリー ルートとして機能します。このBPDU交換により、ネットワーク上のどのブリッジがスパニングツリー ルートになるかが確定します。ネットワークにブリッジが1台しかない場合、BPDU交換は行われず、転送遅延タイマーが満了して、インターフェイスがリスニング ステートになります。STPをイネーブルにすると、インターフェイスは必ずブロッキング ステートになります。

ブロッキング ステートのインターフェイスは、次のように動作します。

ポートで受信したフレームを廃棄します。

アドレスを学習しません。

BPDUを受信します。


) ポートがブロックされている場合は、ブロードキャストまたはマルチキャスト パケットがブリッジの一部が転送ポートに到達することができ、ブロック ポートでパケットが廃棄される直前に、ブリッジング ロジックによってブロック ポートがリスニング ステートに移行します。


リスニング ステート

リスニング ステートは、ブロッキング ステートを経て、インターフェイスが最初に移行するステートです。インターフェイスがリスニング ステートになるのは、STPによってそのインターフェイスのフレーム転送への関与が決定された場合です。

リスニング ステートのインターフェイスは、次のように動作します。

ポートで受信したフレームを廃棄します。

アドレスを学習しません。

BPDUを受信します。

ラーニング ステート

ラーニング ステートのインターフェイスは、フレーム転送に関与するための準備を行います。インターフェイスはリスニング ステートからラーニング ステートに移行します。

ラーニング ステートのインターフェイスは、次のように動作します。

ポートで受信したフレームを廃棄します。

アドレスを学習します。

BPDUを受信します。

フォワーディング ステート

フォワーディング ステートのインターフェイスは、フレームを転送します。インターフェイスはラーニング ステートからフォワーディング ステートに移行します。

フォワーディング ステートのインターフェイスは、次のように動作します。

ポートでフレームを受信して転送します。

アドレスを学習します。

BPDUを受信します。

ディセーブル ステート

ディセーブル ステートのインターフェイスは、フレーム転送やスパニングツリーに関与しません。ディセーブル ステートのインターフェイスは動作不能です。

ディセーブル インターフェイスは次のように動作します。

ポートで受信したフレームを廃棄します。

アドレスを学習しません。

BPDUを受信しません。

STP機能の設定

WMICにSTPを設定するには、主に次の3つの手順を実行します。

1. 必要に応じて、ブリッジ グループにインターフェイスおよびサブインターフェイスを割り当てます。

2. ブリッジ グループごとにSTPをイネーブルにします。

3. ブリッジ グループごとにSTPプライオリティを設定します。

ここでは、スパニングツリーの設定情報を示します。

「STPのデフォルト設定」

「STPの設定」

「STPの設定例」

STPのデフォルト設定

STPはデフォルトでディセーブルです。 表 8-2 に、STPをイネーブルにした場合のSTPのデフォルト設定を示します。

 

表 8-2 STPをイネーブルにした場合のデフォルトSTP値

設定
デフォルト値

ブリッジ プライオリティ

32768

ブリッジの最大有効期限

20

ブリッジのhelloタイム

2

ブリッジの転送遅延

15

イーサネット ポートのパス コスト

19

イーサネット ポートのプライオリティ

128

無線ポートのパス コスト

33

無線ポートのプライオリティ

128

ブリッジの無線インターフェイス、イーサネット インターフェイス、およびネイティブVLANは、デフォルトでブリッジ グループ1に割り当てられます。STPをイネーブルにして、ブリッジ グループ1にプライオリティを割り当てると、無線インターフェイス、イーサネット インターフェイス、およびプライマリVLANでSTPがイネーブルになり、ブリッジ グループ1に割り当てられたプライオリティがこれらのインターフェイスで採用されます。サブインターフェイスのブリッジ グループを作成し、これらのブリッジ グループごとに異なるSTP設定を割り当てることができます。

STPの設定

WMICにSTPを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface { dot11radio number | fastethernet number }

無線インターフェイス、イーサネット インターフェイス、またはサブインターフェイスで、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

bridge-group number

ブリッジ グループにインターフェイスを割り当てます。ブリッジ グループには1~255の値を指定できます。

ステップ 4

no bridge-group number spanning-disabled

ブリッジ グループに関してSTPを自動的にディセーブルにするコマンドを無効にします。ブリッジにn protocol ieeeコマンドを入力すると、インターフェイス上でSTPがイネーブルになります。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

bridge number protocol ieee

ブリッジ グループに関してSTPをイネーブルにします。 bridge- groupコマンドで作成したブリッジ グループごとに、STPをイネーブルにする必要があります。

ステップ 7

bridge number priority priority

(任意)ブリッジ グループにプライオリティを割り当てます。プライオリティが小さいブリッジほど、スパニングツリー ルートになる可能性が高くなります。

ステップ 8

end

イネーブルEXECモードに戻ります。

ステップ 9

show spanning-tree bridge

設定を確認します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

STPの設定例

次に、VLANが設定されている場合、および設定されていない場合に、ルート ブリッジおよび非ルート ブリッジでSTPをイネーブルにする例を示します。

「ルート ブリッジ(VLANが設定されていない場合)」

「非ルート ブリッジ(VLANが設定されていない場合)」

「ルート ブリッジ(VLANが設定されている場合)」

「非ルート ブリッジ(VLANが設定されている場合)」

ルート ブリッジ(VLANが設定されていない場合)

次に、VLANが設定されておらず、STPがイネーブルである場合の、ルート ブリッジの設定例を示します。

 
hostname master-bridge-south
ip subnet-zero
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid tsunami
authentication open
guest-mode
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role root
no cdp enable
infrastructure-client
bridge-group 1
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
!
interface BVI1
ip address 1.4.64.23 255.255.0.0
no ip route-cache
!
ip default-gateway 1.4.0.1
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 9000
!
line con 0
exec-timeout 0 0
line vty 0 4
login
line vty 5 15
login
!
end
 

非ルート ブリッジ(VLANが設定されていない場合)

次に、VLANが設定されておらず、STPがイネーブルである場合の、非ルート ブリッジの設定例を示します。

 
hostname client-bridge-north
ip subnet-zero
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid tsunami
authentication open
guest-mode
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role non-root
no cdp enable
bridge-group 1
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1 path-cost 40
!
interface BVI1
ip address 1.4.64.24 255.255.0.0
no ip route-cache
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 10000
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end

ルート ブリッジ(VLANが設定されている場合)

次に、VLANが設定されていて、STPがイネーブルである場合の、ルート ブリッジの設定例を示します。

hostname master-bridge-hq
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid vlan1
vlan 1
infrastructure-ssid
authentication open
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role root
no cdp enable
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
no cdp enable
bridge-group 1
!
interface Dot11Radio0.2
encapsulation dot1Q 2
no ip route-cache
no cdp enable
bridge-group 2
!
interface Dot11Radio0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
bridge-group 3 path-cost 500
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
!
interface FastEthernet0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
!
interface BVI1
ip address 1.4.64.23 255.255.0.0
no ip route-cache
!
ip default-gateway 1.4.0.1
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 9000
bridge 2 protocol ieee
bridge 2 priority 10000
bridge 3 protocol ieee
bridge 3 priority 3100
!
line con 0
exec-timeout 0 0
line vty 5 15
!
end

非ルート ブリッジ(VLANが設定されている場合)

次に、VLANが設定されていて、STPがイネーブルである場合の、非ルート ブリッジの設定例を示します。

 
hostname client-bridge-remote
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid vlan1
vlan 1
authentication open
infrastructure-ssid
!
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
station-role non-root
no cdp enable
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
no cdp enable
bridge-group 1
!
interface Dot11Radio0.2
encapsulation dot1Q 2
no ip route-cache
no cdp enable
bridge-group 2
!
interface Dot11Radio0.3
encapsulation dot1Q 3
no ip route-cache
no cdp enable
bridge-group 3
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
!
interface FastEthernet0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
bridge-group 3 path-cost 400
!
interface BVI1
ip address 1.4.64.24 255.255.0.0
no ip route-cache
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 10000
bridge 2 protocol ieee
bridge 2 priority 12000
bridge 3 protocol ieee
bridge 3 priority 2900
!
line con 0
line vty 5 15
!
end

スパニングツリー ステータスの表示

スパニングツリー ステータスを表示するには、 表 8-3 のイネーブルEXECコマンドを1つまたは複数使用します。

 

表 8-3 スパニングツリー ステータスの表示に使用するコマンド

コマンド
目的

show spanning-tree

ネットワークのスパニングツリー情報を表示します。

show spanning-tree blocked-ports

現在のデバイスのブロック ポートの一覧を表示します。

show spanning-tree bridge

現在のブリッジのステータスおよび設定を表示します。

show spanning-tree active

アクティブ インターフェイスに関するスパニングツリー情報のみを表示します。

show spanning-tree root

スパニングツリー ルート情報の詳細サマリーを表示します。

show spanning-tree interface interface-id

特定のインターフェイスのスパニングツリー情報を表示します。

show spanning-tree summary [ totals ]

ポート ステータスのサマリー、またはSTPステート セクションのすべての行を表示します。

show spanning-tree イネーブルEXECコマンドのその他のキーワードの詳細については、『Cisco IOS Command Reference for Cisco Access Points and Bridges』を参照してください。