Cisco 3200 シリーズ モバイル アクセス ルータ ソフ トウェア コンフィギュレーション ガイド
スタティックおよびダイナミック CCoA
スタティックおよびダイナミック CCoA
発行日;2012/01/31 | 英語版ドキュメント(2009/02/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

スタティックおよびダイナミック CCoA

CCoA のイネーブル化

デフォルト ゲートウェイ

CCoA の登録

外部エージェントの検出

CCoA トンネリング

外部エージェントとして設定されたモバイル アクセス ルータ

移動の検出およびレイヤ 2 シグナリング

モバイル アクセス ルータの SNMP メッセージ処理

linkUp トラップの処理

linkDown トラップの処理

設定例

SNMP トラップの設定例

CCoA の設定例

ワークグループ ブリッジの設定例

noauth モードの例

noauth および authNoPriv モードの例

関連コマンド

ip mobile router-service collocated コマンド

ip mobile router-service collocated registration retry コマンド

ip mobile router-service hold-down コマンド

ip dhcp client mobile renew

debug snmp packet コマンド

show ip mobile router コマンド

show ip mobile router agent コマンド

show ip mobile router interface コマンド

show ip mobile router binding コマンド

スタティックおよびダイナミック CCoA

Collocated Care-Of Address(CCoA)は、ホーム エージェントからモバイル デバイスへのトンネルを終端します。これは、外部エージェントがホーム エージェントに登録される Care-Of Address(CoA) とは対照的で、モバイル デバイスは外部エージェントに登録されます。これにより、モバイル デバイスは外部エージェントが配置されている外部ネットワークまたは外部エージェントが存在する外部ネットワークをローミングできますが、外部エージェントの機能は使用できません。

モバイル アクセス ルータでは、ローミング用に設定されたインターフェイスの IP アドレスは CCoA アドレスでもあります。このアドレスは、固定 IP アドレス(スタティック CCoA)でも、ポイントツーポイント プロトコル(PPP)/IP Control Protocol(IPCP)、または DHCP を使用してダイナミックに取得したアドレス(ダイナミック CCoA)でも構いません。

スタティック CCoA は、モバイル アクセス ルータのローミング インターフェイス IP アドレスが固定されている場合に使用されます。たとえば、Cellular Digital Packet Data(CDPD)無線ネットワークなどです。ダイナミック CCoA は、DHCP を使用して IP アドレスを取得するようにインターフェイスが設定されており、インターフェイスが no shut モードの場合に使用されます。

モバイル アクセス ルータが外部ネットワークをローミングする場合、最初に外部エージェントを検出しようとします。モバイル アクセス ルータが外部エージェントを検出すると、CoA の設定されたモバイル アクセス ルータは外部エージェントに登録を試み、(アドバタイズされた CoA を使用して)レジストレーション要求を外部エージェントに送信します。外部エージェントは要求をホーム エージェントにリレーします。ホーム エージェントは要求を処理して、外部エージェントに返信します。外部エージェントは返信をモバイル アクセス ルータにリレーします。登録に成功すると、ホーム エージェントと外部エージェント(CoA)間にルーティング パスが設定されます。

外部エージェントが検出されない場合、モバイル アクセス ルータは外部ネットワーク内のアドレスを取得し、CCoA として外部ネットワークによってホーム エージェントに割り当てられたアドレスを使用して、レジストレーション要求をモバイル アクセス ルータに直接送信します。ホーム エージェントは要求を処理して、モバイル アクセス ルータに返信します。登録に成功すると、ホーム エージェントとモバイル アクセス ルータの CCoA インターフェイス間にルーティング パスが設定されます。

モバイル アクセス ルータは、自身がホーム上にあることを検出すると、ホーム エージェントにデレジストレーション要求を送信します。

要求がトリガーされるのは、次の場合です。

外部エージェントアドバタイズが受信され、モバイル アクセス ルータの登録理由が存在する場合

アクティブ外部エージェントアドバタイズ(IRDP 有効期間)の期限が切れ、モバイル アクセス ルータが別の外部エージェントに登録することを選択した場合

再登録または有効期間の期限切れにより、登録タイマーの期限が切れた場合

ID 不一致によるサービス拒否を返信したホーム エージェントから回復する場合

有効期間不足によるサービス拒否が原因で返信された外部エージェントから回復する場合

設定後、モバイル アクセス ルータがローミング用に設定済みで、外部エージェントへの登録理由が存在する場合

モバイル アクセス ルータが外部エージェントまたはホーム エージェントに登録する理由は、次のとおりです。

移動が検出された。

外部エージェントの再起動が検出された。

モバイル アクセス ルータが独立している。

信頼できる外部エージェント上により適切なインターフェイスが検出された。

モバイル アクセス ルータがアクティブ外部エージェントのない外部ネットワークをローミングしている。

モバイル アクセス ルータがアクティブ外部エージェントを含むホーム ネットワークをローミングしている。

レジストレーション応答を受信すると、応答メッセージ アドレスがモバイル アクセス ルータインターフェイスの IP アドレスに等しい場合、モバイル アクセス ルータはこの応答を処理します。モバイル アクセス ルータは、応答に対応するレジストレーション要求を登録テーブル内で検索します。モバイル アクセス ルータは応答を認証し、ホーム エージェントとの間にルーティング パスを設定します。さらに、外部ネットワークを通るデフォルト ルートを作成します。

CCoA のイネーブル化

ip mobile router-service collocated コマンドはインターフェイスを CCoA 用に設定します。最初に ip mobile router-service roam コマンドを使用して、インターフェイスをローミング インターフェイスとして設定する必要があります。そうでない場合は、エラー メッセージが表示されます。

登録できない場合、モバイル アクセス ルータはデフォルト秒数だけ待機してから、再試行します。デフォルトの待機時間は 60 秒です。この値はインターフェイス コンフィギュレーション コマンドを使用して設定できます。

デフォルト ゲートウェイ

ローミング インターフェイス上でスタティック IP アドレスから DHCP アドレス取得に変更すると、CCoA でスタティック ゲートウェイ アドレスは不要になります。代わりに、IP アドレス取得時にデフォルト ルータ アドレスが DHCP から取得され、CCoA ゲートウェイ アドレスとして使用されます。ゲートウェイ アドレスは 0.0.0.0 にリセットされ、 gateway キーワードは CCoA コマンド ラインで使用できなくなります。

インターフェイスが IP アドレスを取得すると、DHCP デフォルト ルータ アドレスが CCoA ゲートウェイとして使用されます。逆に、DHCP アドレス設定が DHCP で取得する IP アドレスからスタティック IP アドレスに変更されると、CCoA ゲートウェイ アドレスは 0.0.0.0 にリセットされ、CCoA デフォルト ゲートウェイが未設定であるという警告が表示されます。

スタティック IP アドレスを使用してモバイル アクセス ルータを設定すると、 ip mobile router-service collocated コマンドを使用して、コンフィギュレーションにデフォルト ゲートウェイを指定する必要があります。このゲートウェイ アドレスは、スタティック CCoA 用に設定されたインターフェイスと同じネットワーク上になければなりません。モバイル アクセス ルータはこのアドレスをMobile IP Registration Request(RRQ)のネクスト ホップ宛先として使用します。正常にMobile IP Registration Reply(RRP)を受信すると、モバイル アクセス ルータはこのアドレスをモバイル アクセス ルータのデフォルト ルートおよびゲートウェイとして使用します。

CCoA の登録

CCoA を登録する場合、モバイル アクセス ルータは RRQ 内のモバイル ノードでカプセル化を解除するように設定し、CCoA を RRQ 送信元アドレスとして使用します。Generic Routing Encapsulation(GRE) トンネリングを実行するように設定されている場合、RRQ は GRE トンネリングを要求します。RRQ はホーム エージェントに直接送信されます。最初の登録でモバイル アクセス ルータが正しく登録しなかった場合は、所定の秒数だけ待機してから再試行します。デフォルトの待機時間は 60 秒です。この値を設定するには、ip mobile router-service collocated registration retry インターフェイス コマンドを使用します。

ルータを起動するか、またはローミング用に設定すると、ダイナミック CCoAが設定されたインターフェイスはエージェント アドバタイズの送信請求および待ち受けを実行して、リンク上の外部エージェントを検出します。外部エージェントが検出されると、モバイル アクセス ルータはアドバタイズされた CoA を登録します。外部エージェントが検出されない場合、モバイル アクセス ルータは自身の CCoA を登録します。

外部エージェントを検出した(および外部エージェントに登録した可能性のある)ローミング インターフェイスを、スタティックまたはダイナミック CCoA を即座に登録するように設定するには、 ip mobile router-serv collocated ccoa-only コマンドを使用します。

ip mobile router-serv collocated コマンドを使用してインターフェイスを設定した場合、外部エージェントの登録は維持されます。このコマンドを使用すると、インターフェイスが最初にアップになったときにローミング インターフェイスは外部エージェントを検出できます。外部エージェントが検出された場合、CCoA の登録をイネーブルにするには、 ip mobile router-serv collocated ccoa-only コマンドを呼び出す必要があります。外部エージェントが検出されない場合、CCoA の登録は自動的にイネーブルになります。

外部エージェント CoA および CCoA の両方に登録されたインターフェイスでは、必ず外部エージェント CoA 登録が使用されます。外部エージェントアドバタイズを受信すると、すでに CCoA が登録済みの場合でも、インターフェイスは外部エージェント CoA を登録します。それ以外の場合は、CCoA が指定または取得されたときに、それが登録されます。

ローミングを素早く行うために、インターフェイスはアドバタイズを受信したときに外部エージェント CoA の登録を行うか、またはアドレスを取得したときに CCoA を登録します。これは、どちらが先に起きるかによって異なります (従来、ルータはいくつかのアドバタイズを受信してから外部エージェント CoA を登録していました)。

DHCP インターフェイスが no shut になっているか、または up しているインターフェイスが最初に DHCP に設定されると、DHCP による IP アドレス取得(検出)が開始されます。アドレス検出は、間隔を徐々に長くしながら(最大 60 秒)、アドレスが取得されるまで繰り返し行われます。検出が行われている間、インターフェイスは IP 対応になるため、インターフェイスに IP アドレスが登録されていなくても、IRDP および MIP 登録をサポートして IP パケットを処理可能です。

外部エージェント CoA をサポートするために設定されたローミング インターフェイスは、送信請求をただちに送信し、アドバタイズが受信されると、インターフェイスは外部エージェントを通じて CoA を登録します。インターフェイスで CCoA も登録されており、アドバタイズが受信されない場合、DHCP は CCoA 登録を開始します。インターフェイスが ccoa-only (外部エージェントがあれば無視する)に設定されている場合、インターフェイスがアップになると送信請求は送信されません。IP アドレスが取得されると、インターフェイスは新しく取得した CCoA を登録しようとします。

インターフェイスが外部エージェントを通じて登録を行う場合でも、DHCP を使用して IP アドレスを取得できますが、これによって外部エージェント登録が影響を受けることはありません。外部エージェントが登録されたインターフェイスは、あとの CCoA 登録で使用するために、取得した IP アドレスを保持します。

DHCP ローミング インターフェイスで linkUp トラップが受信されると、現在の IP アドレスの延長が 1 回または複数回試行されます。IP アドレスの延長に失敗した場合、インターフェイスは新しい DHCP アドレスを取得しようとします。これは、延長/解放/検出機能によって実行されます。

CCoA が登録されたインターフェイスが linkDown トラップ イベントに対応して登録を終了すると、CCoA 登録の再試行タイマーが起動します。タイマーの有効期間が切れる前に linkUp イベントが発生しなければ、インターフェイスは現在の DHCP IP アドレスの延長を 1 回または複数回試行するか、または新しい IP アドレスを取得しようとします。これも、延長機能によって実行されます。

外部エージェントの検出

ccoa-only に設定されている場合を除き、スタティック IP アドレスまたは DHCP アドレスが設定されたローミング インターフェイスは、インターフェイスがアップになるとすぐに送信請求を開始します。DHCP アドレスが設定されている場合、IP アドレスを取得していなくても、送信請求の送信とアドバタイズの受信は可能です。IPCP を使用してインターフェイスが IP アドレスを取得する場合、インターフェイスは IP アドレスを取得してからでないと送信請求を送信できません。

CCoA をサポートするには、デフォルト ゲートウェイ アドレスが必要です。このアドレスは CCoA 登録のデフォルト ゲートウェイとして使用され、インターフェイスが登録されるとデフォルト ルートとして使用されます。イーサネット インターフェイスのスタティック CCoA の場合、ローミング インターフェイスの CCoA 設定を使用してデフォルト ゲートウェイ アドレスを提供する必要があります。DHCP インターフェイスの場合、DCCoA 登録は DHCP デフォルト ルータ アドレスを使用します。インターフェイスが登録されると、このアドレスはモバイル アクセス ルータのデフォルト ルートおよびデフォルト ゲートウェイとしても使用されます。

ローミング インターフェイスが PPP/IPCP を使用して IP アドレスを取得するように設定されている場合に、このインターフェイスが no shut モードになると、ピアとのアドレス ネゴシエーションが開始されます。IP アドレスを取得したインターフェイスは、外部エージェントに送信請求を実行するか、または取得された IP アドレスを CCoA として登録しようとします。

送信請求メッセージが終了し、外部エージェント アドバタイズが受信されなかった場合、このあとの送信請求メッセージはディセーブルになり、外部エージェントからのアドバタイズは無視されます。ホーム エージェントからのアドバタイズは、モバイル アクセス ルータがホームに戻ったかどうかを判別するために処理されます。CCoA をディセーブルにすると、送信請求および外部エージェントのアドバタイズ処理が再びイネーブルになります。

CCoA トンネリング

CCoA を使用して登録さている場合、モバイル アクセス ルータ CCoA はホーム エージェントからのトンネルのエンドポイントになります。モバイル アクセス ルータはホーム エージェントからトンネルを経由して CCoA に送信されるパケットのカプセル化を解除します。

ホーム エージェント/CCoA トンネルは、モバイル ネットワークに登録されたホーム エージェントに作成される、モバイル アクセス ルータ/モバイル アクセス ルータホーム アドレス トンネルと別個のトンネルです。2 つのトンネルが使用され、二重にカプセル化が行われるのを防ぐため、モバイル アクセス ルータはいずれか一方のトンネルだけを作成してトンネリングを最適化します。ホーム エージェント側では、ホーム エージェント/CCoA トンネルのみが確実に作成されます。ホーム エージェント/モバイル アクセス ルータ トンネルはモバイル アクセス ルータのモバイル ネットワークがルーティング テーブルに追加されるまで作成されず、トンネル最適化にはホーム エージェント/CCoA トンネルのみが使用されます。

モバイル アクセス ルータがリバース トンネリング用に設定されている場合は、登録中に作成された 1 つのホーム エージェント/CCoA トンネルを使用して、パケットがホーム エージェントにリバース トンネリングされます。

外部エージェントとして設定されたモバイル アクセス ルータ

モバイル アクセス ルータは外部エージェントとしても設定できます。CCoA を外部エージェント CoA として使用している場合に、モバイル アクセス ルータが外部エージェントとして設定されると、CCoA の変更時にモバイル アクセス ルータはエージェント アドバタイズを送信します。モバイル アクセス ルータに定期的アドバタイズが設定されていない場合でもアドバタイズが送信され、新しい CoA を使用して登録するように接続先ネットワーク上のモバイル ノードに通知されます。

移動の検出およびレイヤ 2 シグナリング

従来、モバイル アクセス ルータ CCoA のローミング プロセスを開始できるのは、ローミング インターフェイス上でインターフェイスのアップ/ダウン信号が発生した場合、または IP アドレスが変更された場合だけでした。しかし、一部のローミング構成では、移動を検出してタイムリーにハンドオフを行うために、別の内部または外部シグナリングが必要です。たとえば、イーサネット インターフェイスが 802.11 ブリッジを経由して WLAN に接続されている場合です。無線リンクがアップまたはダウンしてもシグナリングが発生しないため、モバイル アクセス ルータのイーサネット インターフェイスは変更を認識しません。モバイル アクセス ルータの外部エージェント CoA インターフェイスは、外部エージェントアドバタイズのホールドタイムが切れるまで待機する必要があります。CCoA のみの構成では、モバイル アクセス ルータはインターフェイスの状態変更通知を受信しません。

Wireless Mobile Interface Card(WMIC)はファスト イーサネット インターフェイスを経由してモバイル アクセス ルータに接続されます。WMIC上で発生する 802.11 レイヤ 2 での変化(結合および結合解除)は SNMP(簡易ネットワーク管理プロトコル)メッセージによって通知されます。具体的には、インターフェイス MIB の linkUp および linkDown トラップがモバイル アクセス ルータのイーサネットまたは VLAN インターフェイスに送信されます。

モバイル アクセス ルータの SNMP メッセージ処理

モバイル アクセス ルータのインターフェイスは、ローミング用に設定する必要があります(デフォルトでは外部エージェント CoA 登録)。また、必要に応じて CCoA 登録用に設定する必要があります。モバイル アクセス ルータは、SNMP トラップ メッセージを受信するようにも設定する必要があります。SNMP プロセスはトラップを受信して、レジストリを呼び出してモバイル アクセス ルータにトラップの内容を検査させます。モバイル アクセス ルータは、次の内容を調べます。

トラップがローミング インターフェイスで受信されたかどうか

トラップが linkUp または linkDown イベントかどうか(他のイベントは無視する)

トラップが Dot11Radio0 インターフェイスから受信したものかどうか

linkDown トラップの場合、locIfReason の内容を調べ、 down または administratively down トラップだけを処理

直前に受信したトラップが linkUp でも、有効な linkUp トラップまたは linkDown トラップを受信するたびに、DHCP とモバイル アクセス ルータは処理を行います。モバイル アクセス ルータはトラップの履歴を保管しません。

linkUp トラップの処理

linkUp トラップ イベントが発生すると、DHCP クライアントは現在の IP アドレスを延長するか、またはできるだけ速やかに新しい IP アドレスを取得する必要があります。DHCP インターフェイスに IP アドレスが設定されていない場合、アドレス取得(検出)が起動されます。

ip dhcp client mobile renew count < num > interval < msec > コマンドを使用すると、DHCP Renew が実行されたときの試行回数と試行間隔を設定できます。設定した値は、DHCP Renew の要求側から提供される値よりも優先されます。

IP アドレス検出がすでに開始されていて、次の試行を待っている場合、アドレス検出はただちに再開されます。

インターフェイスに DHCP で取得した IP アドレスがすでに設定されている場合、モバイル アクセス ルータはそれが前と同じサブネット上にあるかどうかを認識しないため、モバイル アクセス ルータは現在のアドレスを延長しようとします。このため、モバイル アクセス ルータが同じサブネットに再度関連付けらた場合、DHCP メッセージは少なくなります。別のサブネットにある DHCP サーバから DHCP NACK メッセージを受信した場合、または DHCP ACK を受信しない場合、インターフェイスは現在の IP アドレスを解放し、Discover を使用して新しい IP アドレスを取得します。

ローミング インターフェイスで linkUp トラップが受信されると、ローミング インターフェイスをアップにしたときと同じようにイベントが処理されます。たとえば、適切であれば送信請求が送信され、モバイル アクセス ルータはこのインターフェイスを(他のローミング インターフェイスと比較して)登録すべきかどうかを判断します。ダイナミック アドレス取得では、DCCoA 登録を行うことが可能です。

後続の linkUP トラップも同様に処理されます。ただし、インターフェイスがすでに登録済みで、登録の判断に影響する変更が行われていない場合、ルータは新しい登録を行いません。

linkDown トラップの処理

インターフェイスは DHCP で取得した IP アドレスを保持します。有効な linkDown トラップを受信すると、再結合ホールドダウン タイマーが起動されます。このタイマーは 0~5000 ミリ秒の範囲で設定できます。デフォルトは 1000 ミリ秒です。

モバイル アクセス ルータブリッジが新しいサブネット上で再結合を行う時間ができるまで、このホールドダウン期間はトラップへの応答(通常、次の適切なWMIC インターフェイスを使用して登録を試行)を遅らせます。タイマーの値は、特定の環境で再結合に必要と考えられる最悪のケースを反映する必要があります。このホールドダウン期間の間、モバイル アクセス ルータは登録された状態のままになり、外部エージェントのデータは保持されます。

ホールドダウン タイマーが期限切れになる前に linkUp トラップが到着すると、モバイル アクセス ルータは登録されたままになり、外部エージェントのデータは保持されます。外部エージェントを検出するために送信請求が送信され、DHCP IP アドレスの延長および検出プロセスが開始されます。

ホールドダウン タイマーが期限切れになるか、またはホールドダウン時間が 0 の場合、インターフェイスがダウンした場合と同じようにモバイル アクセス ルータの処理が行われます。このインターフェイスで受信された外部エージェントは外部エージェント リストから削除されます。また、インターフェイスで登録が行われている場合、モバイル アクセス ルータは現在の登録を削除して、次の適切なローミング インターフェイスを使用して登録しようとします。外部エージェントを検出するために送信請求が送信され、DHCP IP アドレスの延長が開始されます。

linkDown イベントが処理されたあとに linkUp トラップが到着しない場合、モバイル アクセス ルータは別のプライオリティの低いインターフェイスを使用して登録できます。linkUp トラップがない場合でも、外部エージェントアドバタイズは外部エージェント登録を再び開始し、DHCP アドレス取得は CCoA 登録を開始します。

設定例

ここでは、CCoA および DHCP の設定例を示します。

SNMP トラップの設定例

SNMP の linkUp トラップおよび linkDown トラップは、DCCoA 環境のローミング インターフェイス上でレイヤ 2 シグナリングとして使用されます。WMICの関連付けが行われた場合、または関連付けが解除された場合には必ず、SNMP トラップがルータに送信され、DCCoA ローミング インターフェイスは通知を受けます。

WMIC

arp 85.85.85.1 000b.4681.0d40 ARPA BVI1
snmp-server enable traps snmp linkdown linkup
no snmp-server enable traps tty
snmp-server enable traps disassociate
snmp-server enable traps deauthenticate
snmp-server host 85.85.85.1 version 2c l2sig

) 85.85.85.1 はルータのループバック IP アドレスです。000b.4681.0d40 はルータの F0/0 インターフェイスの MAC アドレスです(WMIC の F0 インターフェイスがルータの F0/0 インターフェイスに接続されていると仮定)。


モバイル アクセス ルータ

snmp-server manager
!

CCoA の設定例

次に、モバイル アクセス ルータの CCoA 設定例を示します。

スタティック CCoA

interface Serial1/0
ip address 11.0.0.1 255.255.255.0
ip mobile router-service roam
ip mobile router-service collocated

PPP/IPCP を使用したダイナミック CCoA

interface Serial2/0
ip address negotiated
encapsulation ppp
ip mobile router-service roam
ip mobile router-service collocated

モバイル アクセス ルータ

ip mobile secure home-agent 43.0.0.3 spi 100 key hex 11223344556677881122334455667788
ip mobile router
address 20.0.4.1 255.255.255.0
home-agent 43.0.0.3

ワークグループ ブリッジの設定例

次に、SNMPv2 の link トラップを使用するように設定されたワークグループ ブリッジの例を示します。

ワークグループ ブリッジ(WMIC)

arp 85.85.85.1 0000.abcd.1111 ARPA BVI1
snmp-server trap-source Dot11Radio0
snmp-server enable traps snmp linkdown linkup
no snmp-server enable traps tty
snmp-server enable traps disassociate
snmp-server enable traps deauthenticate
snmp-server host 85.85.85.1 version 2c l2sig

モバイル アクセス ルータ

interface Loopback0
ip address 85.85.85.1 255.255.0.0
!
snmp-server community public RO
snmp-server enable traps ttyy

次に、DCCoA に対する DHCP および SNMPv3 の設定例を示します。

モバイル アクセス ルータ

interface FastEthernet0
ip dhcp client mobile renew count 3 interval 20
ip address dhcp
ip mobile router-service roam
ip mobile router-service collocated
ip mobile router-service hold-down reassociate 2000
!
! Receive v1 or v2 traps
snmp-server community public RO
snmp-server enable traps tty
!
 
! Receive v3 traps
snmp-server engineID remote 85.85.85.3 1234
snmp-server user labusr labgrp remote 85.85.85.2 v3 auth md5 <SNMP user password on WGB>
snmp-server group labgrp v3 auth
snmp-server manager
snmp-server manager session-timeout 25

noauth モードの例

WMICが noauth および authNoPriv モードでサポートしているのは、SNMPv3 だけです。

次に、 noauth モードで SNMPv3 の link トラップに対して設定されたワークグループ ブリッジの例を示します。

ワークグループ ブリッジ

interface Loopback0
ip address 1.2.3.4 255.255.0.0
no ip route-cache
 
snmp-server group labgrp v3 noauth
snmp-server user labusr labgrp v3
snmp-server trap-source Loopback0
snmp-server enable traps snmp linkdown linkup
no snmp-server enable traps tty
snmp-server host 1.7.35.35 version 3 noauth labusr

モバイル アクセス ルータ

snmp-server engineID remote 1.2.3.4
snmp-server user labusr labgrp remote 1.2.3.4 v3
snmp-server group labgrp v3 noauth
snmp-server manager
snmp-server manager session-timeout <num>

noauth および authNoPriv モードの例

WMICが noauth および authNoPriv モードでサポートしているのは、SNMPv3 だけです。

次に、 authNoPriv モードで SNMPv3 の link トラップに対して設定されたワークグループ ブリッジの例を示します。

ワークグループ ブリッジ

interface Loopback0
ip address 1.2.3.4 255.255.0.0
no ip route-cache
 
snmp-server group labgrp v3 auth
snmp-server user labusr labgrp v3 auth md5 MD5passwd
snmp-server trap-source Loopback0
snmp-server enable traps snmp linkdown linkup
no snmp-server enable traps tty
snmp-server host 1.7.35.35 version 3 auth labusr

モバイル アクセス ルータ

snmp-server engineID remote 1.2.3.4
snmp-server user labusr labgrp remote 1.2.3.4 v3 auth md5 MD5passwd
snmp-server group labgrp v3 auth
snmp-server manager
snmp-server manager session-timeout <num>

 

) アドレス取得時に高速でローミングを行うには、DHCP サーバからクライアントへの ping が無効に設定されている必要があります。


関連コマンド

ここでは、次の関連コマンドについて説明します。

ip mobile router-service collocated コマンド

ip mobile router-service collocated registration retry コマンド

ip mobile router-service hold-down コマンド

ip dhcp client mobile renew

debug snmp packet コマンド

show ip mobile router コマンド

show ip mobile router agent コマンド

show ip mobile router interface コマンド

show ip mobile router binding コマンド

ip mobile router-service collocated コマンド

ip mobile router-service collocated コマンドは、インターフェイスでの CCoA 処理をイネーブルまたはディセーブルにします。CCoA にはインターフェイスのプライマリ IP アドレスが使用されます。事前にインターフェイスがローミング インターフェイスとして設定されていなければなりません(ip mobile router-service roam)。そうでない場合は、エラー メッセージが表示されます。

インターフェイスでの CCoA 処理をイネーブルまたはディセーブルにするには、 ip mobile router-service collocated インターフェイス コマンドを使用します。

ip mobile router-service collocated [gateway <ipaddress>] [ccoa-only]

それぞれ次のようになります。

gateway < ipaddress > は、イーサネット インターフェイスにスタティック IP アドレスが設定されている場合に指定する必要があります。IP アドレスは、イーサネットに CCoA を登録する場合に使用するデフォルト ゲートウェイを指定します。デフォルト ゲートウェイの IP アドレスは、スタティック CCoAが設定されたインターフェイスと同じリンク上になければなりません。

このアドレスには 0.0.0.0 または 255.255.255.255 以外の値を指定する必要があります。そうしないと、パラメータが拒否されます。モバイル アクセス ルータの登録中にこのゲートウェイ アドレスを変更すると、新しいアドレスを使用して新しい登録が実行されます。

ローミング インターフェイスがアップになると、インターフェイスは外部エージェントアドバタイズの送信請求を実行し、アドバタイズが受信されると外部エージェント CoA を登録します。アドバタイズが受信されない場合は、このインターフェイスで CCoA 登録がイネーブルになります。

ccoa-only を指定するとエージェント検出がオフになり、インターフェイスはすぐに CCoA 対応になります。外部エージェント CoA が登録されているインターフェイスでこのオプションを使用して CCoA をイネーブルにすると、モバイル アクセス ルータはすぐに CCoA の登録を開始します。

CCoA が登録されているインターフェイスに no ip mobile router-service collocated コマンドを使用して CCoA をディセーブルにすると、インターフェイスは CCoA の登録を解除して、外部エージェントの検出を開始します。

イーサネット インターフェイスがスタティック IP アドレスを使用して設定されている場合、ゲートウェイ アドレスを設定する必要があります。IP アドレス設定がダイナミックな IP アドレス取得に変更されると、ゲートウェイ アドレスは CCoA になります。ゲートウェイ アドレスは 0.0.0.0 にリセットされます。設定がスタティック アドレスに変更されると、指定したゲートウェイ アドレスを使用して CCoA がイネーブルに設定されるまで、CCoA 処理がディセーブルなるという警告が表示されます。

CCoA にはプライマリ インターフェイス アドレスが使用されますが、CCoA およびホーム アドレスが同じである場合は、ホーム エージェントで登録が拒否されます。この方法でアドレスを設定しようとすると、警告メッセージが表示されます。インターフェイスの IP アドレスまたは CCoA ゲートウェイ アドレスが設定される(または、ダイナミックに取得される)か、あるいはホーム アドレスが設定されると、アドレス確認が行われます。必要に応じて警告が表示されますが、設定は有効です。登録時に CCoA およびホーム アドレスが同じである場合、モバイル アクセス ルータは要求を送信せず、エラー メッセージが表示されます。

ip mobile router-service collocated registration retry コマンド

CCoA インターフェイスは、登録に失敗すると、インターバル タイマーを使用して登録を再試行します。

CCoA 登録を再試行するインターバルを設定するには、ip mobile router-service collocated registration retry インターフェイス コマンドを使用します。

ip mobile router-service collocated registration retry <1-65535>

1-65535 は、登録に失敗してから登録を再試行するまで、デバイスが待機する秒数です。デフォルト値は 60 秒です。

再試行インターバル値を表示するには、 show ip mobile router agent コマンドを使用します。インターバル タイマーが稼動している場合は、次の登録を試行するまでの残り時間も表示されます。

注:このコマンドを入力しても、CCoA サポートはイネーブルにもディセーブルにもなりません。タイマーのインターバルを設定するだけです。

ip mobile router-service hold-down コマンド

ip mobile router-service hold-down [ foreign-agent < sec > | reassociate < msec >] レイヤ 2 ホールドダウン コンフィギュレーション コマンドを使用すると、無線リンクに接続されたローミング インターフェイスの再結合遅延を設定できます。次に例を示します。

(config-if)#ip mobile router-service hold-down [foreign-agent | reassociate]

 

foreign-agent

新しい外部エージェントを認識するまでの待機時間(0~3600 秒、デフォルトは 0)

reassociate

レイヤ 2 リンク再結合の待機時間(0~5000 ミリ秒、デフォルトは 1000)

ip dhcp client mobile renew

ip dhcp client mobile renew インターフェイス コンフィギュレーション コマンドは、モバイル DHCP クライアントで使用します。特定のイベント(無線アクセス ポイント間での移動など)に反応して、クライアントは既存の IP アドレスを自動的に延長しようとします。延長の試行回数および試行間隔は、ネットワークの条件に応じて変更できます。

検出プロセスを開始する前の IP アドレス延長の試行回数を設定するには、 ip dhcp client mobile renew count コマンドを使用します。

ip dhcp client mobile renew count <count> interval <msec>
 

 

count

検出を開始する前の延長試行回数。指定できる範囲は 0~10 回です。デフォルトは 2 回です。

interval

延長試行間隔( ミリ秒 )。指定できる範囲は 1~1000 msecです。デフォルトは 50 msecです。

debug snmp packet コマンド

debug snmp packet コマンドは、ルータが送受信する SNMP パケットの情報を表示します。debug snmp packet コマンドは、特権 EXEC モードで使用します。

Router#debug snmp packet

次に、debug snmp packet コマンドの出力例を示します。この例では、SNMP トラップが正しく設定されていれば、ルータが受信するメッセージに次のメッセージが表示されます。

WMIC

Router# debug snmp packet
Mar 1 00:04:40.508: SNMP: Queuing packet to 85.85.85.1
*Mar 1 00:04:40.509: SNMP: V2 Trap, reqid 2, errstat 0, erridx 0
sysUpTime.0 = 28051
snmpTrapOID.0 = snmpTraps.3
ifEntry.1.5 = 5
ifEntry.2.5 = Virtual-Dot11Radio0
ifEntry.3.5 = 71
lifEntry.20.5 = administratively down
*Mar 1 00:04:40.515: SNMP: Queuing packet to 85.85.85.1
*Mar 1 00:04:40.515: SNMP: V2 Trap, reqid 2, errstat 0, erridx 0
sysUpTime.0 = 28051
snmpTrapOID.0 = snmpTraps.3
ifEntry.1.1 = 1
ifEntry.2.1 = Dot11Radio0
ifEntry.3.1 = 71
lifEntry.20.1 = administratively down
*Mar 1 00:04:40.759: SNMP: Packet sent via UDP to 85.85.85.1
*Mar 1 00:04:41.009: SNMP: Packet sent via UDP to 85.85.85.1

モバイル ルータ

Router# debug snmp packet
*Mar 4 19:30:12.265: SNMP: Packet received via UDP from 40.20.0.12 on FastEthernet0/0
*Mar 4 19:30:12.513: SNMP: Packet received via UDP from 40.20.0.12 on FastEthernet0/0

show ip mobile router コマンド

次に、インターフェイスが DCCoA として登録されている場合の show ip mobile router コマンドの出力例を示します。

UUT1#sh ip mobile router
 
Mobile Router
Enabled 03/01/02 02:44:14
Last redundancy state transition NEVER
 
Configuration:
Home Address 85.85.85.1 Mask 255.255.255.0
Home Agent 30.10.0.2 Priority 100 (best) (current)
Registration lifetime 60 sec
Retransmit Init 1000, Max 5000 msec, Limit 3
Extend Expire 120, Retry 3, Interval 10
 
Monitor:
Status -Registered-
Using collocated care-of address 40.20.0.11
On interface FastEthernet0/0
Tunnel0 mode IP/IP

次に、インターフェイスが CoA を使用して登録されている場合の show ip mobile router コマンドの出力例を示します。

UUT1#sh ip mobile router
 
Mobile Router
Enabled 03/01/02 02:44:14
Last redundancy state transition NEVER
 
Configuration:
Home Address 85.85.85.1 Mask 255.255.255.0
Home Agent 30.10.0.2 Priority 100 (best) (current)
Registration lifetime 60 sec
Retransmit Init 1000, Max 5000 msec, Limit 3
Extend Expire 120, Retry 3, Interval 10
 
Monitor:
Status -Registered-
Active foreign agent 40.20.0.2, Care-of 40.20.0.2
On interface FastEthernet0/0
Tunnel0 mode IP/IP

show ip mobile router agent コマンド

次に、 show ip mobile router agent コマンドの出力例を示します。

Router#show ip mobile router agent
Mobile Router Agents:
Foreign agent 45.0.0.2:
Care-of address 42.0.0.2
Interface Ethernet1, MAC 0030.9492.6627
Agent advertisement seq 56649, Flags rbhFmGvt, Lifetime 36000
IRDP advertisement lifetime 30, Remaining 29
Last received 02/13/02 17:55:48
First heard 02/13/02 11:21:46
 
Collocated Care-of address 11.0.0.1
Interface Serial0/1
Default gateway 11.0.0.2
Registration retry interval 60
Next CCoA reg attempt in 00:00:55 seconds

show ip mobile router interface コマンド

show ip mobile router interface コマンド出力には、レイヤ 2 リンクダウン抑制値および直前に処理されたリンク ステート トラップが表示されます。

mobrouter#show ip mobile router interface
Ethernet1:
Priority 110, Bandwidth 10000, Address 55.0.0.8
Periodic solicitation disabled, Interval 600 sec
Retransmit Init 1000, Max 5000 msec, Limit 3
Current 5000, Remaining 0 msec, Count 4
Foreign agent hold down 0 sec
Layer 2 reassociation hold down 5000 msec
Last layer 2 link-state trap: linkDown
Routing disallowed
Collocated CoA 55.0.0.8 - Solicit FAs

show ip mobile router binding コマンド

次に、ホーム エージェント上で show ip mobile router binding コマンドを使用した場合の出力例を示します。

Router#show ip mobile binding
Mobility Binding List:
Total 1
20.0.4.1:
Care-of Addr 12.0.0.1, Src Addr 12.0.0.1
Lifetime granted 00:02:00 (120), remaining 00:01:54
Flags sbDmgvt, Identification C05E97DB.167E8950
Tunnel0 src 46.0.0.3 dest 12.0.0.1 reverse-allowed
MR Tunnel0 src 46.0.0.3 dest 12.0.0.1 reverse-allowed
MR mobile-network 20.0.4.1
Routing Options - (D)Direct-to-MN

Flags sbDmgvt エントリで、「D」は CCoA を使用してモバイル ノードが登録されていることを示します (小文字の「d」は外部エージェントを使用してモバイル ノードが登録されていることを示します)。