Cisco 2600/3600/3700 シリーズ ルータ ソフトウェア コンフィギュレーション ガイド
設定例
設定例
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

設定例

Cisco 2600シリーズ ルータの設定例

Cisco 3631ルータの設定例

Cisco 3725ルータの設定例

1ポートADSL WANインターフェイス カードの設定例

ATMインターフェイスにおけるVoATM over AAL2の設定例

ATMインターフェイスにおけるVoATM over AAL5の設定例

NM-AIC-64コンタクト クロージャ ネットワークの設定例

AIC IPアドレスの設定例

AICへのIPルートの設定例

アンナンバードIPアドレスを使用する場合

アンナンバードIPアドレスを使用しない場合

CLIによるAICのアラーム設定

個別アラーム

アナログ アラーム モニタリング電流

ディスクリート(個別)として設定したアナログ アラーム モニタリング電流

ISDNおよびモデム コールをサポートするCisco 3640セントラル サイト設定

CPEモードの設定例

COモードの設定例

設定例

この付録では、Cisco 2600/3600/3700シリーズ ルータの設定例をいくつか紹介します。

Cisco 2600シリーズ ルータの設定例

Cisco 2600シリーズ ルータの設定例を示します。

The following configuration command script was created:
 
hostname 2600
enable secret 5 $1$zxxT$YZMzUP1/wQvyLn5cWeyPu.
enable password guessme
line vty 0 4
password guessagain
snmp-server community public
!
no appletalk routing
no decnet routing
ip routing
no clns routing
no ipx routing
no vines routing
no xns routing
no apollo routing
no bridge 1
!
line 1 64
speed 115200
flowcontrol hardware
login local
autoselect during-login
autoselect ppp
modem dialin
ip local pool setup_pool 172.20.30.40 172.20.30.88
!
username user password passwd
line 1 64
modem output
transport input all
!
interface Ethernet0/0
no shutdown
ip address 255.255.255.0 255.255.0.0
lat enabled
no mop enabled
!
interface Serial0/0
encapsulation hdlc
clock rate 2000000
ip address 1.0.0.1 255.0.0.0
lat enabled
appletalk cable-range 3-3 3.3
appletalk zone myzone
ipx network 8
no vines metric
mop enabled
!
interface Ethernet0/1
ip address 255.255.255.1 255.255.0.0
lat enabled
no vines metric
mop enabled
!
interface Serial0/1
physical-layer sync
encapsulation ppp
ip address 2.0.0.1 255.0.0.0
lat enabled
appletalk cable-range 6-6 6.6
appletalk zone myzone
ipx network 6
no vines metric
xns network 7
mop enabled
!
interface Serial0/2
physical-layer async
ip address 3.0.0.1 255.0.0.0
lat enabled
appletalk cable-range 8-8 8.8
appletalk zone myzone
ipx network 8
no vines metric
mop enabled
!
interface Serial1/0
physical-layer sync
encapsulation frame-relay
frame-relay lmi-type cisco
clock rate 115200
ip address 4.0.0.1 255.0.0.0
no lat enabled
no vines metric
no mop enabled
!
interface Serial1/1
physical-layer async
ip address 5.0.0.1 255.0.0.0
no lat enabled
no vines metric
no mop enabled
!
interface Serial1/2
physical-layer sync
encapsulation x25 dte
x25 address 1234
x25 map ip 1.0.0.1 4321
x25 map ipx 6.0.0.1 -2132065964
x25 ltc 1
x25 htc 64
x25 win 7
x25 wout 7
x25 threshold 2
x25 ips 128
x25 ops 128
clock rate 115200
ip address 6.0.0.1 255.0.0.0
no lat enabled
no vines metric
no mop enabled
!
interface Serial1/3
physical-layer sync
encapsulation smds
smds address c141.5556.1415
no keepalive
smds static-map ip 2.0.0.1 c141.5556.1414
smds static-map ipx 2.0.0.1 c141.5556.1414
clock rate 115200
ip address 172.22.50.10 255.255.0.0
no lat enabled
no vines metric
no mop enabled
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
router igrp 1
redistribute connected
network 172.21.0.0
!
end
 

Cisco 2691ルータの設定例を示します。

C2691#show running-config
Building configuration...
 
Current configuration : 1143 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname C2691
!
enable password lab
!
voice-card 1
!
ip subnet-zero
!
!
no ip domain-lookup
ip host rtplab-dev 172.18.207.10
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller T1 1/0
framing esf
linecode b8zs
ds0-group 1 timeslots 1-24 type e&m-wink-start
!
controller T1 1/1
framing sf
linecode ami
!
!
!
!
interface FastEthernet0/0
ip address 172.18.193.171 255.255.255.0
speed 100
full-duplex
!
interface FastEthernet0/1
ip address 50.0.0.4 255.0.0.0
speed 100
full-duplex
!
ip classless
ip route 172.18.207.0 255.255.255.0 172.18.193.1
ip http server
ip pim bidir-enable
!
!
!
call rsvp-sync
!
voice-port 1/0:1
output attenuation 3
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 919 pots
destination-pattern 919
port 1/0:1
prefix 919
!
dial-peer voice 408 voip
destination-pattern 408
session target ipv4:50.0.0.3
dtmf-relay h245-alphanumeric
codec g711alaw
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password lab
login
!
end
 

Cisco 2620XMルータの設定例を示します。

Building configuration...
 
Current configuration : 588 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2620xm
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
ip address 111.0.0.29 255.255.255.0
duplex auto
speed auto
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
no ip http server
ip pim bidir-enable
!
!
no cdp run
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

Cisco 3631ルータの設定例

次のモジュールを搭載した、Cisco 3631ルータの設定例を示します。

IMA-8T1

NM-4A/S

WIC-2A/S

WIC-1DSU-56K4

Building configuration...
00:45:06: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 3095 bytes
!
! Last configuration change at 12:12:59 PDT Tue Dec 4 2001
! NVRAM config last updated at 12:12:26 PDT Tue Dec 4 2001
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cisco3631
!
enable secret 5 $1$6UL.$w0aJJ5oZmIv1zRDl1RMvo/
!
username USER password 7 01030717481C091D25
memory-size iomem 10
clock timezone PDT -8
ip subnet-zero
no ip domain-lookup
!
x29 profile linemode 2:1 3:2 15:1
x25 routing
!
chat-script test "" "ATDT\T" TIMEOUT 120 CONNECT \c
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description FAST ETHERNET INTERFACE
ip address x.x.x.x x.x.x.x
duplex auto
speed auto
!
interface Serial0/0
description WIC-1DSU-56k4
ip address x.x.x.x x.x.x.x
encapsulation ppp
!
interface Serial0/1
description WIC-2A/S
physical-layer async
no ip address
encapsulation ppp
dialer in-band
dialer rotary-group 3
dialer-group 1
async mode dedicated
no fair-queue
!
interface Serial0/2
description WIC-2A/S
physical-layer async
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer in-band
dialer rotary-group 3
dialer-group 1
async default routing
async mode dedicated
no fair-queue
!
interface Serial1/0
description NM-4A/S
no ip address
encapsulation x25
x25 htc 8
!
interface Serial1/1
description NM-4A/S
no ip address
encapsulation x25 dce
x25 ips 256
x25 ops 256
clockrate 9600
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
interface ATM2/0
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
interface ATM2/1
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
interface ATM2/2
description ATM T1
ip address x.x.x.x x.x.x.x
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
pvc atm71 0/71
protocol clns 47.0004.004d.0056.0000.0c00.0003.00 broadcast
protocol ip 12.0.0.2 broadcast
encapsulation aal5snap
!
scrambling-payload
impedance 120-ohm
!
interface ATM2/3
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
interface ATM2/4
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
interface ATM2/5
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
interface ATM2/6
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
interface ATM2/7
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
interface ATM2/IMA0
description ATM-IMA GROUP
ip address x.x.x.x x.x.x.x
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
pvc atm71 0/71
protocol clns 47.0004.004d.0056.0000.0c00.0002.00 broadcast
protocol ip 12.0.0.1 broadcast
encapsulation aal5snap
!
interface Dialer3
ip address x.x.x.9 x.x.x.x
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer in-band
dialer idle-timeout 500
dialer map ip x.x.x.10 name USER modem-script test broadcast
9,5551122
dialer map ip x.x.x.10 name USER modem-script test broadcast
9,5551123
dialer hold-queue 15
dialer load-threshold 5 either
dialer-group 1
no fair-queue
no cdp enable
ppp authentication chap
ppp multilink
group-range 4 5
!
router ospf 1
redistribute connected subnets
network X.X.X.X 0.0.0.X area 3
!
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
!
!
!
!
!
!
!
!
snmp-server view cutdown internet included
snmp-server view cutdown at excluded
snmp-server community public view cutdown RO
snmp-server community private view cutdown RW
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
line con 0
line 3
modem InOut
transport input all
autohangup
stopbits 1
rxspeed 115200
txspeed 115200
flowcontrol hardware
line 5
modem InOut
transport input all
autohangup
stopbits 1
rxspeed 115200
txspeed 115200
flowcontrol hardware
line 6
line aux 0
password 7 08314D5D1A0E0A0516
login
modem InOut
transport input all
line vty 0 4
password 7 00141215174C04140B
login
!
end

Cisco 3725ルータの設定例

Cisco 3725ルータの設定例を示します。

version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname pipertdm
!
no logging buffered
logging rate-limit console 10 except errors
no logging console
!
!
!
ip subnet-zero
!
!
no ip finger
ip host rtplab-tftp2 172.18.207.16
ip host rtplab-dev 172.18.207.10
!
no ip dhcp-client network-discovery
no mgcp timer receive-rtcp
call rsvp-sync
!
!
!
!
!
fax interface-type modem
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
ip address 172.18.197.74 255.255.255.252
no keepalive
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1
ip address 2.2.2.2 255.0.0.0
no keepalive
duplex auto
speed auto
no cdp enable
!
interface BRI1/0
no ip address
shutdown
!
interface FastEthernet1/0
ip address 1.1.1.1 255.0.0.0
no keepalive
duplex auto
speed auto
no cdp enable
!
interface Serial1/0
no ip address
shutdown
no fair-queue
clockrate 125000
!
interface FastEthernet1/1
ip address 3.3.3.3 255.0.0.0
no keepalive
shutdown
duplex auto
speed auto
no cdp enable
!
interface Serial1/1
no ip address
shutdown
clockrate 125000
!
ip kerberos source-interface any
ip classless
ip route 172.18.0.0 255.255.0.0 FastEthernet0/0
ip http server
!
!
!
!
snmp-server packetsize 4096
snmp-server chassis-id
snmp-server manager
!
!
dial-peer cor custom
!
!
!
!
line con 0
exec-timeout 0 0
transport input none
line 1 32
line 35 96
line aux 0
line vty 0 4
!
end

1ポートADSL WANインターフェイス カードの設定例

次の設定例を紹介します。

「ATMインターフェイスにおけるVoATM over AAL2の設定例」

「ATMインターフェイスにおけるVoATM over AAL5の設定例」

ATMインターフェイスにおけるVoATM over AAL2の設定例

ADSLカードが搭載されたAsynchronous Transfer Mode(ATM;非同期転送モード)インターフェイス上のVoATM over AAL2の設定例を示します。

Router#
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname host1
!
memory-size iomem 10
voice-card 1
!
ip subnet-zero
ip host host2 225.255.255.224
!
no mgcp timer receive-rtcp
call rsvp-sync
!
!
controller T1 1/0
framing esf
linecode b8zs
ds0-group 0 timeslots 1 type e&m-wink-start
ds0-group 1 timeslots 2 type e&m-wink-start
.
.
.
ds0-group 23 timeslots 24 type e&m-wink-start
!
controller T1 1/1
framing esf
linecode b8zs
!
interface Ethernet0/0
ip address 1.6.46.119 255.255.255.224
half-duplex
no cdp enable
!
interface Serial0/0
no ip address
shutdown
!
interface ATM0/1
ip address 10.1.1.1 255.0.0.0
load-interval 30
atm vc-per-vp 256
no atm ilmi-keepalive
pvc 10/100
vbr-rt 672 672 512
encapsulation aal2
!
pvc 10/200
protocol ip 10.1.1.2 broadcast
encapsulation aal5snap
!
dsl operating-mode ansi-dmt
no fair-queue
!
interface Ethernet0/1
no ip address
shutdown
!
ip classless
ip route 223.255.254.254 255.255.255.224 Ethernet0/0
no ip http server
!
!
snmp-server engineID local 000000090200003080477F20
snmp-server manager
!
voice-port 1/0:0
local-alerting
timeouts wait-release 3
connection trunk 3001
!
voice-port 1/0:1
local-alerting
timeouts wait-release 3
connection trunk 3002
.
.
.
voice-port 1/0:23
local-alerting
timeouts wait-release 3
connection trunk 3024
shutdown
!
dial-peer cor custom
!
dial-peer voice 3001 voatm
destination-pattern 3001
called-number 4001
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 31
codec aal2-profile ITUT 1 g711ulaw
no vad
!
dial-peer voice 3002 voatm
destination-pattern 3002
called-number 4002
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 32
codec aal2-profile custom 100 g726r32
no vad
!
dial-peer voice 3003 voatm
destination-pattern 3003
called-number 4003
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 33
codec aal2-profile ITUT 7 g729abr8
no vad
.
.
.
dial-peer voice 3024 voatm
destination-pattern 3024
called-number 3024
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 54
codec aal2-profile ITUT 7 g729abr8
no vad
!
dial-peer voice 1 pots
destination-pattern 4001
port 1/0:0
!
dial-peer voice 2 pots
destination-pattern 4002
port 1/0:1
.
.
.
dial-peer voice 24 pots
destination-pattern 4024
port 1/0:23
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
no scheduler allocate
end
 

ATMインターフェイスにおけるVoATM over AAL5の設定例

ADSLカードが搭載されたATMインターフェイス上のVoATM over AAL5について、Cisco 2600シリーズ ルータの設定例を示します。

Router#
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname u2621
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
!
memory-size iomem 15
voice-card 1
!
ip subnet-zero
!
no ip finger
no ip domain-lookup
!
no mgcp timer receive-rtcp
call rsvp-sync
!
controller T1 1/0
framing esf
linecode b8zs
ds0-group 0 timeslots 1-24 type e&m-wink-start
!
controller T1 1/1
!
!
interface ATM0/0
ip address 12.0.0.1 255.255.255.224
load-interval 30
atm vc-per-vp 256
no atm ilmi-keepalive
dsl operating-mode auto
no fair-queue
!
!
interface FastEthernet0/0
ip address 1.7.73.1 255.255.255.224
duplex auto
speed auto
!
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.224
load-interval 30
duplex auto
speed auto
!
ip classless
ip route 223.255.254.0 255.255.255.224 FastEthernet0/0
no ip http server
!
!
snmp-server engineID local 0000000902000002163DB260
snmp-server packetsize 4096
snmp-server manager
!
voice-port 1/0:0
!
dial-peer cor custom
!
!
dial-peer voice 5 pots
destination-pattern 777...
port 1/0:0
prefix 777
!
!
dial-peer voice 100 voatm
destination-pattern 888....
session target atm0/0 pvc 0/72
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
end

NM-AIC-64コンタクト クロージャ ネットワークの設定例

ここで紹介する例は、次のとおりです。

「AIC IPアドレスの設定例」

「AICへのIPルートの設定例」

「アンナンバードIPアドレスを使用する場合」

「アンナンバードIPアドレスを使用しない場合」

「CLIによるAICのアラーム設定」

AIC IPアドレスの設定例

AIC IPアドレスについて、Cisco 3600ルータの設定例を示します。

version 12.2
no service single-slot-reload-enable
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3600-top
!
logging rate-limit console 10 except errors
!
memory-size iomem 15
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
ip host moe 172.31.10.2
ip host mickey 10.1.1.2
!
no ip dhcp-client network-discovery
frame-relay switching
x25 routing
!
!
call-history-mib max-size 50
!
interface Ethernet0/0
ip address 10.5.37.13 255.255.0.0
ip helper-address 223.255.254.254
no keepalive
half-duplex
!
interface Serial0/0
ip address 10.5.5.1 255.255.255.0
encapsulation frame-relay
no ip mroute-cache
clockrate 500000
frame-relay class voice-vc
frame-relay traffic-shaping
frame-relay map ip 10.5.5.2 990 broadcast
frame-relay interface-dlci 990
frame-relay intf-type dce
!
interface Ethernet0/1
no ip address
half-duplex
no cdp enable
!
interface Serial0/1
ip address 10.11.11.1 255.255.255.0
encapsulation frame-relay
no ip mroute-cache
clockrate 256000
frame-relay class voice-vc
frame-relay traffic-shaping
frame-relay interface-dlci 991
frame-relay intf-type dce
!
interface Serial1/0
ip address negotiated
!
router mobile
!
ip kerberos source-interface any
ip classless
ip route 223.255.254.254 255.255.255.255 10.5.0.1
ip route 223.255.254.254 255.255.255.255 Ethernet0/0
no ip http server
!
!
map-class frame-relay voice-vc
frame-relay cir 800000
frame-relay bc 512000
no frame-relay adaptive-shaping
frame-relay fair-queue
frame-relay voice bandwidth 500000
frame-relay fragment 100
frame-relay ip rtp priority 16384 16383 512
!
map-class frame-relay fr1
frame-relay cir 1000000
frame-relay bc 1000
no frame-relay adaptive-shaping
frame-relay fair-queue
frame-relay voice bandwidth 1000000
frame-relay fragment 100
!
map-class frame-relay voice-vc2
frame-relay cir 800000
frame-relay bc 512000
no frame-relay adaptive-shaping
frame-relay voice bandwidth 800000
!
map-class frame-relay voice-data
access-list 1 deny 192.200.1.20
access-list 2 deny 10.10.1.10
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
snmp-server packetsize 4096
snmp-server manager
!
alarm-interface 1
ip address 10.4.3.2
call rsvp-sync
!
mgcp modem passthrough voip mode ca
no mgcp timer receive-rtcp
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 1 pots
destination-pattern 3
direct-inward-dial
forward-digits all
!
dial-peer voice 100 voip
shutdown
destination-pattern 3
session target ipv4:10.2.81.1
playout-delay maximum 300
!
dial-peer voice 2 pots
shutdown
destination-pattern 3002
!
dial-peer voice 3 pots
shutdown
destination-pattern 3003
!
dial-peer voice 4 pots
shutdown
destination-pattern 3004
!
dial-peer voice 2000 voip
shutdown
destination-pattern 2...
session target ipv4:5.5.5.2
playout-delay maximum 300
!
dial-peer voice 110 voip
shutdown
destination-pattern 1...
session target ipv4:10.2.83.30
playout-delay maximum 300
!
dial-peer voice 922 pots
shutdown
destination-pattern 9..
!
dial-peer voice 22 pots
shutdown
destination-pattern 22
!
dial-peer voice 6001 pots
shutdown
destination-pattern 6001
!
dial-peer voice 333 voip
shutdown
destination-pattern 1
session target ipv4:10.2.79.55
playout-delay maximum 300
!
dial-peer voice 200 vofr
shutdown
destination-pattern 1
!
dial-peer voice 7001 pots
shutdown
destination-pattern 7001
!
dial-peer voice 5000 voip
shutdown
destination-pattern 5...
session target ipv4:10.11.11.2
playout-delay maximum 300
!
dial-peer voice 20 voip
shutdown
destination-pattern 1
session target ipv4:10.11.11.2
playout-delay maximum 300
!
dial-peer voice 2001 voip
preference 2
shutdown
destination-pattern 2...
session target ipv4:10.2.79.7
playout-delay maximum 300
!
dial-peer voice 1000 voip
destination-pattern 1...
session target ipv4:10.2.81.6
playout-delay maximum 300
no vad
!
dial-peer voice 1001 voatm
shutdown
destination-pattern 1...
!
dial-peer voice 1100 vofr
shutdown
destination-pattern 1...
session target Serial0/0 990
no vad
!
gateway
!
gateway
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
transport input none
line 33
no exec
transport preferred none
transport input telnet
transport output none
stopbits 1
line aux 0
line vty 0 4
login
!
end

AICへのIPルートの設定例

次に、アンナンバードIPアドレスおよびナンバードIPアドレスを使用する場合について、AICへのIPルートの設定例を示します。

アンナンバードIPアドレスを使用する場合

Cisco 3660ルータに、アンナンバードIPアドレスを使用してAICへのIPルートを設定した場合の例を示します。

version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname uut2-3660
!
logging rate-limit console 10 except errors
no logging console
!
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
!
call rsvp-sync
cns event-service server
!
interface FastEthernet0/0
ip address 10.2.130.2 255.255.0.0
duplex auto
speed auto
no cdp enable
!
interface Serial5/0
ip unnumbered FastEthernet0/0
!
ip kerberos source-interface any
ip classless
ip route 0.0.0.0 0.0.0.0 10.2.0.1
ip route 10.2.130.102 255.255.255.255 Serial5/0
ip http server
!
no cdp run
!
alarm-interface 5
ip address 10.2.130.102
!
dial-peer cor custom
!
!
!
line con 0
exec-timeout 0 0
transport input none
line 161
no exec
transport preferred none
transport input telnet
transport output none
stopbits 1
line aux 0
line vty 0 4
password lab
login
!
end
 

アンナンバードIPアドレスを使用しない場合

アンナンバードIPアドレスを使用しないでCisco 2621ルータを設定した場合の例を示します。

uut5-2621#s run
Building configuration...
 
Current configuration :1318 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname uut5-2621
!
logging rate-limit console 10 except errors
no logging console
!
ip subnet-zero
!
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
interface FastEthernet0/0
ip address 10.2.130.5 255.255.0.0
duplex auto
speed auto
no cdp enable
!
interface Serial1/0
ip address 172.128.12.1 255.255.255.252
!
router rip
network 10.0.0.0
!
ip kerberos source-interface any
ip classless
ip route 0.0.0.0 0.0.0.0 10.2.0.1
no ip http server
!
no cdp run
!
snmp-server packetsize 4096
snmp-server manager
!
!
alarm-interface 1
ip address 172.128.12.2
call rsvp-sync
!
dial-peer cor custom
!
line con 0
exec-timeout 0 0
transport input none
line 33
no exec
transport preferred none
transport input telnet
transport output none
stopbits 1
line aux 0
line vty 0 4
password lab
login
!
no scheduler allocate
!
end

 

CLIによるAICのアラーム設定

show alarm config # コマンドの出力例を紹介します。

個別アラーム

description:west door
normally closed
normal state description:door closed
alarm state description:door open
SNMP trap:enabled
 

アナログ アラーム モニタリング電流

description:thermostat
high-high state description:very hot
high state description:hot
normal state description:just right
low state description:cold
low-low state description:very cold
current-loop -5.2 5.4 15.0 25.0 35.1 45.6
SNMP trap:enabled
 

ディスクリート(個別)として設定したアナログ アラーム モニタリング電流

description:east door
configured as discrete
normal state description:door closed
alarm description:door open
current-loop 0.0 3.2 5.9
SNMP trap:enabled

 

ISDNおよびモデム コールをサポートするCisco 3640セントラル サイト設定

次の設定を使用すると、リモートLANおよびスタンドアロンのリモート ユーザはモデムを使用して、セントラル サイトにダイヤルインできます。

次のハードウェア構成でCisco 3640ルータを設定する例を示します。

スロット1に2ポートISDN PRIネットワーク モジュールを1つ搭載

スロット2およびスロット3にデジタル モデム ネットワーク モジュールを1つ搭載

スロット0に1ポート イーサネット ネットワーク モジュールを1つ搭載


) MICAデジタル モデム カードごとに、独自のグループ非同期設定があります。また、モデム カードごとに単一範囲の非同期回線が使用されています。その他のインターフェイス番号については、『Digital Modem Network Module Configuration Note』を参照してください。


!
version 11.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname NAS
!
aaa new-model
aaa authentication login default local
aaa authentication login console enable
aaa authentication login vty local
aaa authentication login dialin local
aaa authentication ppp default local
aaa authentication ppp dialin if-needed local
enable secret cisco
!
username admin password cisco
username remotelan1 password dialpass1
username remotelan2 password dialpass2
username PCuser1 password dialpass3
username PCuser2 password dialpass4
async-bootp dns-server 10.1.3.1 10.1.3.2
isdn switch-type primary-5ess
!
controller T1 1/0
framing esf
clock source line
linecode b8zs
pri-group timeslots 1-24
!
controller T1 1/1
framing esf
clock source line
linecode b8zs
pri-group timeslots 1-24
!
interface Loopback0
ip address 10.1.2.254 255.255.255.0
!
interface Ethernet0/0
ip address 10.1.1.10 255.255.255.0
ip summary address eigrp 10 10.1.2.0 255.255.255.0
!
interface Serial 1/0:23
no ip address
encapsulation ppp
no keepalive
isdn incoming-voice modem
dialer rotary-group 0
dialer-group 1
no fair-queue
no cdp enable
!
interface Serial 1/1:23
no ip address
encapsulation ppp
no keepalive
isdn incoming-voice modem
dialer rotary-group 0
dialer-group 1
no fair-queue
no cdp enable
!
interface Group-Async1
ip unnumbered Loopback0
encapsulation ppp
async mode interactive
peer default ip address pool dialin_pool
no cdp enable
ppp authentication chap pap dialin
group-range 65 88
!
interface Group-Async2
ip unnumbered Loopback0
encapsulation ppp
async mode interactive
peer default ip address pool dialin_pool
no cdp enable
ppp authentication chap pap dialin
group-range 97 120
!
interface Dialer0
ip unnumbered Loopback0
no ip mroute-cache
encapsulation ppp
peer default ip address pool dialin_pool
dialer in-band
dialer-group 1
no fair-queue
no cdp enable
ppp authentication chap pap dialin
ppp multilink
!
router eigrp 10
network 10.0.0.0
passive-interface Dialer0
no auto-summary
!
ip local pool dialin_pool 10.1.2.1 10.1.2.50
ip default-gateway 10.1.1.1
ip classless
!
dialer-list 1 protocol ip permit
!
line con 0
login authentication console
line 65 88
autoselect ppp
autoselect during-login
login authentication dialin
modem DialIn
line 97 120
autoselect ppp
autoselect during-login
login authentication dialin
modem DialIn
line aux 0
login authentication console
line vty 0 4
login authentication vty
transport input telnet rlogin
!
end
 

CPEモードの設定例

Customer Premises Equipment(CPE;顧客宅内装置)モードで動作するCisco 2600シリーズ ルータ上のVoATM over AAL2について、G.SHDSLの設定例を示します。CPEモードのこのルータは、Digital Subscriber Line Access Multiplexer(DSLAM;デジタル加入者線アクセス マルチプレクサ)にリンクさせることも、Central Office(CO;セントラル オフィス)モードで動作するように設定された別のルータにリンクさせることもできます。

Router#
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname host1
!
memory-size iomem 10
voice-card 1
!
ip subnet-zero
ip host host2 225.255.255.224
!
no mgcp timer receive-rtcp
call rsvp-sync
!
!
controller T1 1/0
framing esf
linecode b8zs
ds0-group 0 timeslots 1 type e&m-wink-start
ds0-group 1 timeslots 2 type e&m-wink-start
.
.
.
ds0-group 23 timeslots 24 type e&m-wink-start
!
controller T1 1/1
framing esf
linecode b8zs
!
interface Ethernet0/0
ip address 209.165.202.128 255.255.255.224
half-duplex
no cdp enable
!
interface Serial0/0
no ip address
shutdown
!
interface ATM0/1
ip address 209.165.201.1 255.255.255.224
dsl operating-mode gshdsl symmetric annex A
dsl equipment-type cpe
dsl linerate auto
load-interval 30
atm vc-per-vp 256
no atm ilmi-keepalive
pvc 10/100
vbr-rt 672 672 512
encapsulation aal2
!
pvc 10/200
protocol ip 209.165.202.159 broadcast
encapsulation aal5snap
!
no fair-queue
!
interface Ethernet0/1
no ip address
shutdown
!
ip classless
ip route 209.165.202.128 255.255.255.224 Ethernet0/0
no ip http server
!
!
snmp-server engineID local 000000090200003080477F20
snmp-server manager
!
voice-port 1/0:0
local-alerting
timeouts wait-release 3
connection trunk 3001
!
voice-port 1/0:1
local-alerting
timeouts wait-release 3
connection trunk 3002
.
.
.
voice-port 1/0:23
local-alerting
timeouts wait-release 3
connection trunk 3024
shutdown
!
dial-peer cor custom
!
dial-peer voice 3001 voatm
destination-pattern 3001
called-number 4001
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 31
codec aal2-profile ITUT 1 g711ulaw
no vad
!
dial-peer voice 3002 voatm
destination-pattern 3002
called-number 4002
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 32
codec aal2-profile custom 100 g726r32
no vad
!
dial-peer voice 3003 voatm
destination-pattern 3003
called-number 4003
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 33
codec aal2-profile ITUT 7 g729abr8
no vad
.
.
.
dial-peer voice 3024 voatm
destination-pattern 3024
called-number 3024
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 54
codec aal2-profile ITUT 7 g729abr8
no vad
!
dial-peer voice 1 pots
destination-pattern 4001
port 1/0:0
!
dial-peer voice 2 pots
destination-pattern 4002
port 1/0:1
.
.
.
dial-peer voice 24 pots
destination-pattern 4024
port 1/0:23
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
no scheduler allocate
end

COモードの設定例

COモードで動作するCisco 2600シリーズ ルータ上のVoATM over AAL2について、G.SHDSLの設定例を示します。COモードのこのルータは、CPEモードで動作するように設定された別のルータとリンクさせることができます。

Router#
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname host2
!
memory-size iomem 10
voice-card 1
!
ip subnet-zero
ip host host2 225.255.255.224
!
no mgcp timer receive-rtcp
call rsvp-sync
!
!
controller T1 1/0
framing esf
linecode b8zs
ds0-group 0 timeslots 1 type e&m-wink-start
ds0-group 1 timeslots 2 type e&m-wink-start
.
.
.
ds0-group 23 timeslots 24 type e&m-wink-start
!
controller T1 1/1
framing esf
linecode b8zs
!
interface Ethernet0/0
ip address 209.165.202.128 255.255.255.224
half-duplex
no cdp enable
!
interface Serial0/0
no ip address
shutdown
!
interface ATM0/1
ip address 209.165.201.1 255.255.255.224
dsl operating-mode gshdsl symmetric annex A
dsl equipment-type co
dsl linerate auto
load-interval 30
atm vc-per-vp 256
no atm ilmi-keepalive
pvc 10/100
vbr-rt 672 672 512
encapsulation aal2
!
pvc 10/200
protocol ip 209.165.202.159 broadcast
encapsulation aal5snap
!
no fair-queue
!
interface Ethernet0/1
no ip address
shutdown
!
ip classless
ip route 209.165.202.128 255.255.255.224 Ethernet0/0
no ip http server
!
!
snmp-server engineID local 000000090200003080477F20
snmp-server manager
!
voice-port 1/0:0
local-alerting
timeouts wait-release 3
connection trunk 3001
!
voice-port 1/0:1
local-alerting
timeouts wait-release 3
connection trunk 3002
.
.
.
voice-port 1/0:23
local-alerting
timeouts wait-release 3
connection trunk 3024
shutdown
!
dial-peer cor custom
!
dial-peer voice 3001 voatm
destination-pattern 3001
called-number 4001
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 31
codec aal2-profile ITUT 1 g711ulaw
no vad
!
dial-peer voice 3002 voatm
destination-pattern 3002
called-number 4002
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 32
codec aal2-profile custom 100 g726r32
no vad
!
dial-peer voice 3003 voatm
destination-pattern 3003
called-number 4003
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 33
codec aal2-profile ITUT 7 g729abr8
no vad
.
.
.
dial-peer voice 3024 voatm
destination-pattern 3024
called-number 3024
session protocol aal2-trunk
session target ATM0/1 pvc 10/100 54
codec aal2-profile ITUT 7 g729abr8
no vad
!
dial-peer voice 1 pots
destination-pattern 4001
port 1/0:0
!
dial-peer voice 2 pots
destination-pattern 4002
port 1/0:1
.
.
.
dial-peer voice 24 pots
destination-pattern 4024
port 1/0:23
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
no scheduler allocate
end