Cisco 2600/3600/3700 シリーズ ルータ ソフトウェア コンフィギュレーション ガイド
VoIPの設定
VoIPの設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

VoIPの設定

VoIPの要件

音声インターフェイスの設定

VoIPの設定例

RSVPを使用したFXS/FXS接続

ルータRLB-1の設定

ルータRLB-wの設定

ルータR12-eの設定

ルータRLB-2の設定

E&Mトランク回線を使用したPBXユーザ間のリンク

ルータSJの設定

ルータSLCの設定

FXO接続を使用したPSTNゲートウェイ アクセス

ルータSJの設定

ルータSLCの設定

FXO接続(PLARモード)を使用したPSTNゲートウェイ アクセス

ルータSJの設定

ルータSLCの設定

BRIポートでのDIDの設定

ルータ1の設定

ルータ2の設定

ルータ3の設定

次の作業

VoIPの設定

この章では、ルータのrecEive and transMit(E&M)、Foreign Exchange Office(FXO)、およびForeign Exchange Station(FXS)インターフェイスを使用して、音声ネットワーク モジュールを設定する方法について説明します。音声ネットワーク モジュールは、電話の音声信号を、IPネットワーク上で伝送できる形式に変換します。この章の内容は、次のとおりです。

「VoIPの要件」

「音声インターフェイスの設定」

「VoIPの設定例」

「次の作業」

音声接続には、音声ネットワーク モジュールおよび音声インターフェイス カードの両方が必要です。2チャネル音声ネットワーク モジュールには音声インターフェイス カードを1枚、4チャネル モジュールには音声インターフェイス カードを2枚搭載できます。IP LANまたはWANに接続するには、ルータに最低もう1枚のネットワーク モジュールまたはWANインターフェイス カードを搭載する必要があります。

Voice over IP(VoIP)により、ルータを使用して、(電話やファックスなどの)リアルタイムの音声トラフィックをIPネットワーク上で伝送できるようになります。VoIPには、次の利点があります。

長距離電話料金(市外通話料金)を節約する

WAN上にリモートPBXを配置できる

音声とデータを統合したトランキングができる

Plain Old Telephone Service(POTS;加入電話サービス)とインターネット電話間のゲートウェイを提供する

VoIPの要件

ルータにVoIPを設定する前に、あらかじめ次の作業を実行する必要があります。

IPネットワークの実行環境を設定します。IPネットワーク設定の詳細については、Cisco IOS
Release 11.3 『Network Protocols Configuration Guide, Part 1 』の「Configuring IP」を参照してください。

ルータに、音声ネットワーク モジュールを搭載します。音声ネットワーク モジュールの詳細については、『 Cisco Network Modules Hardware Installation Guide 』の「Connecting Voice Network Modules to a Network」を参照してください。

自社のダイヤル プランを検討します。すなわち、ダイヤル番号のパターンと、接続先の電話通信のエンドポイントを決定します。

自社のダイヤル プランに基づく電話ネットワークを設定します。

既存のIPネットワーク トポロジーに、ダイヤル プランと電話ネットワークを組み込みます。

音声インターフェイスの設定

新しいインターフェイスを使用する場合、または既存のインターフェイスの設定を変更する場合には、インターフェイスを設定する必要があります。設定済みのモジュールと交換した場合、ルータは既存の設定に基づいてインターフェイスを起動します。

インターフェイスを設定する前に、次の情報を用意してください。

新しいインターフェイスで使用するルーティング プロトコル

IPアドレス、サブネット マスク、ネットワーク番号、ゾーン、およびその他のルーティング プロトコル関連情報


ワンポイント・アドバイス ルータの設定を始める前に、システム管理者に問い合わせるか、ネットワーク プランを参照して、これらの情報を入手してください。


音声インターフェイスを設定するには、コンフィギュレーション モード(手動設定)を使用します。コンフィギュレーション モードでは、ルータ プロンプトにCisco IOSコマンドを入力します。

AutoInstallプロセスが実行されないように、前もってルータからすべてのWANケーブルを取り外しておいてください。ルータのNVRAM(不揮発性RAM)に有効なコンフィギュレーション ファイルが保存されていない場合(新しいインターフェイスを追加したときなど)、両エンドがWAN接続されていると、ルータの電源投入時にAutoInstallプロセスの実行が試行されます。リモートのTCP/IPホストにAutoInstallが接続されないことが判別されるまで、数分かかることがあります。

音声インターフェイス コンフィギュレーション モードを設定する手順は、次のとおりです。


ステップ 1 ルータにコンソールを接続します。コンソールの接続方法については、ルータのインストレーション コンフィギュレーション ガイドを参照してください。

ステップ 2 ルータの電源をオンにします。現在の設定が無効な場合には、約1分後に次のプロンプトが表示されます。

Would you like to enter the initial dialog? [yes/no]:
 

noと応答します。ルータの標準オペレーティング モードが開始されます。


) 現在の設定が有効な場合は、自動的にルータの標準オペレーティング モードになります。


ステップ 3 数秒後に、ユーザEXECプロンプト( Router> )が表示されます。enableと入力し、パスワードを入力してイネーブル モードを開始します。

Router> enable
Password: <password>
 

設定の変更は、常にイネーブル モードで行う必要があります。プロンプトが、イネーブルEXECプロンプト( Router# )に変わります。

Router#
 

ステップ 4 configure terminalコマンドを入力し、コンフィギュレーション モードを開始します。

Router# configure terminal
Router(config)#
 

グローバル コンフィギュレーション モードを開始すると、プロンプトが Router(config)# に変わります。

ステップ 5 ルータの設定を行っていない場合、または設定を変更する場合は、Cisco IOSコマンドを使用して、グローバル パラメータ、パスワード、ネットワーク管理情報、およびルーティング プロトコルを指定します。この例では、IPルーティングをイネーブルにします。

Router(config)# ip routing
 

グローバル コンフィギュレーション コマンドの詳細については、Cisco IOSソフトウェアのコンフィギュレーション ガイドおよびコマンド リファレンスを参照してください。

ステップ 6 IPトラフィックに使用するネットワーク モジュールまたはWANインターフェイス カードを設定します(設定していない場合)。設定方法については、ルータのインストレーション コンフィギュレーション ガイド、およびネットワーク モジュールまたはWANインターフェイス カードのコンフィギュレーション ノートを参照してください。

ステップ 7 別のインターフェイスを設定する場合は、 exit コマンドを入力して Router(config)# プロンプトに戻ります。

ステップ 8 ルータに音声トラフィックを設定する場合は、詳細な設定手順について、『 Voice over IP Configuration 』を参照してください。

ステップ 9 インターフェイスの設定が終了したら、 Ctrl-z キーを押してコンフィギュレーション モードを終了し、イネーブル プロンプトに戻ります。変更した内容を含む現在の実行コンフィギュレーションを表示するには、 show running-config コマンドを入力します。

Router# show running-config
 

NVRAMに現在保存されている設定を表示するには、イネーブル プロンプトにshow startup-configコマンドを入力します。

Router# show startup-config
 

ステップ 10 変更した設定をNVRAMに保存しなかった場合は、show running-configコマンドと show
startup-config
コマンドの出力結果が異なります。設定の変更をNVRAMに保存するには、イネーブル プロンプトに copy running-config startup-config コマンドを入力します。

Router# copy running-config startup-config
Building configuration. . .
[OK]
Router#
 

ルータは、次の電源投入時に新しい設定で起動します。


 

VoIPの設定例

VoIPの設定手順は、使用する音声ネットワークのトポロジーによって異なります。次に記載する設定例を参考にしてください。実際の設定では、使用するネットワーク トポロジーに合わせて設定の内容をカスタマイズする必要があります。

ここでは、次の設定例を紹介します。

「RSVPを使用したFXS/FXS接続」

「E&Mトランク回線を使用したPBXユーザ間のリンク」

「FXO接続を使用したPSTNゲートウェイ アクセス」

「FXO接続(PLARモード)を使用したPSTNゲートウェイ アクセス」

「BRIポートでのDIDの設定」

次に、これらの設定例を示します。

RSVPを使用したFXS/FXS接続

次に、単純なFXS-FXS接続のためのVoIPの設定例を示します。ここでは、2つのオフィスを持つ小規模な会社が、既存のIPネットワークにVoIPを統合する例について説明します。ルータRLB-1には1台の基本電話機が接続されています。そのため、ルータRLB-1は1つのPOTSピアおよび1つのVoIPピア用に設定されています。ルータRLB-wおよびルータR12-eは、2つのオフィス間のWAN接続を確立しています。ルータRLB-2には1台のPOTS電話機が接続されているので、同様に1つのPOTSピアおよび1つのVoIPピア用に限定して設定されています。

この例では、RSVPを要求するのは発信側(ルータRLB-1)だけです。図 4-1に、このFXS/FXS接続例のトポロジーを示します。

図 4-1 FXS/FXS接続の例

 

ルータRLB-1の設定

 
hostname rlb-1
! Create voip dial-peer 10
dial-peer voice 10 voip
! Define its associated telephone number and IP address
destination-pattern +4155264000
sess-target ipv4:40.0.0.1
! Request RSVP
req-qos guaranteedDelay
! Create pots dial-peer 1
dial-peer voice 1 pots
! Define its associated telephone number and voice port
destination-pattern +4085264000
port 1/0/0
! Configure serial interface 0/0
interface Serial0/0
ip address 10.0.0.1 255.0.0.0
no ip mroute-cache
! Configure RTP header compression
ip rtp header-compression
ip rtp compression-connections 25
! Enable RSVP on this interface
ip rsvp bandwidth 48 48
fair-queue 64 256 36
clockrate 64000
router igrp 888
network 10.0.0.0
network 20.0.0.0
network 40.0.0.0

ルータRLB-wの設定

 
hostname rlb-w
! Configure serial interface 1/0
interface Serial1/0
ip address 10.0.0.2 255.0.0.0
! Configure RTP header compression
ip rtp header-compression
ip rtp compression-connections 25
! Enable RSVP on this interface
ip rsvp bandwidth 96 96
fair-queue 64 256 3
! Configure serial interface 1/3
interface Serial1/3
ip address 20.0.0.1 255.0.0.0
! Configure RTP header compression
ip rtp header-compression
ip rtp compression-connections 25
! Enable RSVP on this interface
ip rsvp bandwidth 96 96
fair-queue 64 256 3
! Configure IGRP
router igrp 888
network 10.0.0.0
network 20.0.0.0
network 40.0.0.0

ルータR12-eの設定

 
hostname r12-e
! Configure serial interface 1/0
interface Serial1/0
ip address 40.0.0.2 25.0.0.0
! Configure RTP header compression
ip rtp header-compression
ip rtp compression-connections 25
! Enable RSVP on this interface
ip rsvp bandwidth 96 96
fair-queue 64 256 3
! Configure serial interface 1/3
interface Serial1/3
ip address 20.0.0.2 255.0.0.0
! Configure RTP header compression
ip rtp header-compression
ip rtp compression-connections 25
! Enable RSVP on this interface
ip rsvp bandwidth 96 96
fair-queue 64 256 3
clockrate 128000
! Configure IGRP
router igrp 888
network 10.0.0.0
network 20.0.0.0
network 40.0.0.0

ルータRLB-2の設定

 
hostname r1b-2
! Create pots dial-peer 2
dial-peer voice 2 pots
! Define its associated telephone number and voice-port
destination-pattern +4155264000
port 1/0/0
! Create voip dial-peer 20
dial-peer voice 20 voip
!Define its associated telephone number and IP address
destination-pattern +4085264000
sess-target ipv4:10.0.0.1
! Configure serial interface 0/0
interface Serial0/0
ip address 40.0.0.1 255.0.0.0
no ip mroute-cache
! Configure RTP header compression
ip rtp header-compression
ip rtp compression-connections 25
! Enable RSVP on this interface
ip rsvp bandwidth 96 96
fair-queue 64 256 3
clockrate 64000
! Configure IGRP
router igrp 888
network 10.0.0.0
network 20.0.0.0
network 40.0.0.0

E&Mトランク回線を使用したPBXユーザ間のリンク

次に、E&Mトランク回線を使用してPBXユーザを相互にリンクさせるためのVoIPの設定例を示します。

ここでは、ある企業が2つのオフィスを接続する例について説明します。1つのオフィスはカリフォルニア州サンノゼに、もう1つのオフィスはユタ州ソルトレイク シティにあります。各オフィスにはPBXを使用した構内電話網があり、E&Mインターフェイスによって音声ネットワークに接続しています。ソルトレイク シティおよびサンノゼの両オフィスとも、E&Mポート タイプII、4線オペレーションおよびImmediateStartシグナリングを採用しています。各E&Mインターフェイスは、2つの音声インターフェイス接続によりルータに接続します。サンノゼのユーザは、ソルトレイク シティのオフィスに接続する場合、[8-569]およびエクステンション番号をダイヤルします。ソルトレイク シティのユーザは、サンノゼのオフィスに接続する場合、[4-527]およびエクステンション番号をダイヤルします。

図 4-2に、この接続例のトポロジーを示します。

図 4-2 E&Mトランク回線を使用したPBXユーザ間リンクの例

 


) この例は、2つのリモート オフィス間にすでにIP接続が確立されていることを前提としています。


ルータSJの設定

 
hostname sanjose
!Configure pots dial-peer 1
dial-peer voice 1 pots
destination-pattern +527....
port 1/0/0
!Configure pots dial-peer 2
dial-peer voice 2 pots
destination-pattern +527....
port 1/0/1
!Configure voip dial-peer 3
dial-peer voice 3 voip
destination-pattern +569....
session target ipv4:172.16.65.182
!Configure the E&M interface
voice-port 1/0/0
signal immediate
operation 4-wire
type 2
voice-port 1/0/1
signal immediate
operation 4-wire
type 2
!Configure the serial interface
interface serial 0/0
description serial interface type dce (provides clock)
clock rate 2000000
ip address 172.16.1.123
no shutdown

ルータSLCの設定

 
hostname saltlake
!Configure pots dial-peer 1
dial-peer voice 1 pots
destination-pattern +569....
port 1/0/0
!Configure pots dial-peer 2
dial-peer voice 2 pots
destination-pattern +569....
port 1/0/1
!Configure voip dial-peer 3
dial-peer voice 3 voip
destination-pattern +527....
session target ipv4:172.16.1.123
!Configure the E&M interface
voice-port 1/0/0
signal immediate
operation 4-wire
type 2
voice-port 1/0/0
signal immediate
operation 4-wire
type 2
!Configure the serial interface
interface serial 0/0
description serial interface type dte
ip address 172.16.65.182
no shutdown

) PBXは、すべてのDTMF信号がルータに送られるように設定してください。「ストアアンドフォワード」トーンは設定しないことを推奨します。



) ゲインまたは電話通信ポートを変更する場合は、電話通信ポートがDTMF信号を受け付けることを確認してください。


FXO接続を使用したPSTNゲートウェイ アクセス

次に、FXO接続を使用してPSTNゲートウェイにアクセスし、ユーザ間をリンクさせるためのVoIPの設定例を示します。

この例では、カリフォルニア州サンノゼのルータSJに接続したユーザが、ルータSLCを経由してユタ州ソルトレイク シティのPSTNユーザに接続できます。ソルトレイク シティのルータSLCは、FXOインターフェイスによってPSTNに直接接続しています。

図 4-3に、この接続例のトポロジーを示します。

図 4-3 FXO接続を使用したPSTNゲートウェイ アクセスの例

 


) この例は、2つのリモート オフィス間にすでにIP接続が確立されていることを前提としています。


ルータSJの設定

 
! Configure pots dial-peer 1
dial-peer voice 1 pots
destination-pattern +14085274000
port 1/0/0
! Configure voip dial-peer 2
dial-peer voice 2 voip
destination-pattern +9...........
session target ipv4:172.16.65.182
! Configure the serial interface
interface serial 0/0
clock rate 2000000
ip address 172.16.1.123
no shutdown

ルータSLCの設定

 
! Configure pots dial-peer 1
dial-peer voice 1 pots
destination-pattern +9...........
port 1/0/0
! Configure voip dial-peer 2
dial-peer voice 2 voip
destination-pattern +14085274000
session target ipv4:172.16.1.123
! Configure serial interface
interface serial 0/0
ip address 172.16.65.182
no shutdown

FXO接続(PLARモード)を使用したPSTNゲートウェイ アクセス

次に、FXO接続(PLARモード)を使用してPSTNゲートウェイにアクセスし、ユーザ間をリンクさせるためのVoIPの設定例を示します。

この例では、ユタ州ソルトレイク シティのPSTNユーザは、ローカル番号をダイヤルするだけで、リモートの私設回線に接続できます。前述の例と同様に、ソルトレイク シティのルータSLCは、FXOインターフェイスによってPSTNに直接接続しています。

図 4-4に、この接続例のトポロジーを示します。

図 4-4 FXO接続(PLARモード)を使用したPSTNゲートウェイ アクセス

 


) この例は、2つのリモート オフィス間にすでにIP接続が確立されていることを前提としています。


ルータSJの設定

 
! Configure pots dial-peer 1
dial-peer voice 1 pots
destination-pattern +14085274000
port 1/0/0
! Configure voip dial-peer 2
dial-peer voice 2 voip
destination-pattern +9...........
session target ipv4:172.16.65.182
! Configure the serial interface
interface serial 0/0
clock rate 2000000
ip address 172.16.1.123
no shutdown

ルータSLCの設定

 
! Configure pots dial-peer 1
dial-peer voice 1 pots
destination-pattern +9...........
port 1/0/0
! Configure voip dial-peer 2
dial-peer voice 2 voip
destination-pattern +14085274000
session target ipv4:172.16.1.123
! Configure the voice port
voice port 1/0/0
connection plar 14085274000
! Configure the serial interface
interface serial 0/0
ip address 172.16.65.182
no shutdown

BRIポートでのDIDの設定

次に、BRIポートにDirect-Inward Dialing(DID;ダイヤルイン方式)を設定する例を示します。この設定では、ISDN Q.931セットアップ メッセージの着信番号情報を、ISDN回線上のルーティングに使用します。

この例では、コールが着信するのはBRIポート上のルータ1です。DID情報により、ルータは着信番号に基づいてコールをルーティングします。着信番号が2xxxであれば、コールはルータ2000にルーティングされます。着信番号が3xxxであれば、コールはルータ3000にルーティングされます。

図 4-5に、この接続例のトポロジーを示します。

図 4-5 BRIポートでのDIDの設定

 

ルータ1の設定

dial-peer voice 1 pots
port 1/0/0
destination-pattern 1...
direct-inward-dial
dial-peer voice 2 voip
session target ipv4:1.1.1.2
destination-pattern 2...
dial-peer voice 3 voip
session target ipv4:1.1.1.3
destination-pattern 3...

ルータ2の設定

dial-peer voice 1 pots
port 1/0/0
destination-pattern 2000

ルータ3の設定

dial-peer voice 1 pots
port 1/0/0
destination-pattern 3000
 
 
 

次の作業

この段階で、次のいずれかを実行できます。

より詳細なVoIP設定を実行します。手順およびコマンドの詳細については、『 Voice over IP Software Configuration Guide 』を参照してください。

より高度な設定の情報については、Cisco IOSソフトウェアのコンフィギュレーション ガイドおよびコマンド リファレンスを参照してください。これらの資料は、Cisco.comおよびルータに付属のDocumentation CD-ROMから入手できます。印刷資料を発注することもできます。