Cisco 1900 シリーズ サービス統合型ルータ ハードウェア インストレーション
ルータの設定
ルータの設定
発行日;2013/01/16 | 英語版ドキュメント(2011/12/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

ルータの設定

ルータの電源投入

Cisco ルータに電源を投入する前のチェック リスト

Cisco ルータの起動

前面パネルの LED インジケータの確認

ルータの初期設定の実行

Cisco Setup コマンド機能の使い方

Cisco Configuration Professional Express の使用

Cisco CLI を使用した手動設定

CLI の初期設定

ルータのホスト名の設定

イネーブルおよびイネーブル シークレット パスワードの設定

コンソールのアイドル特権 EXEC タイムアウトの設定

ギガビット イーサネット インターフェイスの設定

デフォルト ルートまたはラスト リゾート ゲートウェイの指定

IP ルーティングおよび IP プロトコルの設定

ラスト リゾート ゲートウェイ

リモート コンソール アクセスのための仮想端末回線の設定

補助回線の設定

ネットワーク接続の確認

ルータ設定の保存

設定およびシステム イメージのバックアップ コピーの保存

初期設定の確認

ルータの設定

この章の次のセクションでは、ルータに電源を投入し、初期設定を行う方法について説明します。

「ルータの電源投入」

「ルータの初期設定の実行」

「Cisco Setup コマンド機能の使い方」

「Cisco Configuration Professional Express の使用」

「Cisco CLI を使用した手動設定」

「初期設定の確認」

ルータの電源投入


警告 ブランクの前面プレートおよびカバー パネルには 3 つの重要な機能があります。シャーシ内の危険な電圧および電流による感電を防ぐこと、他の装置への EMI の影響を防ぐこと、およびシャーシ内の空気の流れを適切な状態に保つことです。システムは、必ずすべてのカード、前面プレート、前面カバー、および背面カバーを正しく取り付けた状態で運用してください。ステートメント 1029


「Cisco ルータに電源を投入する前のチェック リスト」

「Cisco ルータの起動」

「前面パネルの LED インジケータの確認」

Cisco ルータに電源を投入する前のチェック リスト

ルータに電源を投入する前に、次の項目を確認します。

確実にシャーシを設置し、アース接続したこと。

電力ケーブルおよびインターフェイス ケーブルを接続したこと。

外部 CompactFlash メモリ カードをスロットに正しく挿入したこと。取り付けの手順については、『Installing and Upgrading Internal Modules and FRUs in Cisco 1900 Series ISRs』を参照してください。

コンソール ポートに接続され、端末エミュレーション プログラム(HyperTerminal または同等のプログラム)を備えた PC があること。これが、9600 ボー、8 データ ビット、1 ストップ ビット、パリティなし、フロー コントロール「なし」と設定されていること。

ターミナル エミュレーション プログラムで、適切な PC の COM ポートを選択したこと。

アクセス コントロールのためにパスワードが選択されている。

イーサネットおよびシリアル インターフェイスの IP アドレスが確定している。

Cisco ルータの起動

Cisco ルータの電源を投入するには、次の手順を実行して、ルータが初期化とセルフテストを実行したことを確認します。手順が完了したら、ルータを選択する準備が整います。

ルータの起動時に問題が発生した場合は、Cisco.com でルータのトラブルシューティングに関するページを参照してください。

ROM モニタとブートストラップ プログラムについては、『 Using the ROM Monitor 』を参照してください。コンフィギュレーション レジスタの詳細については、『 Changing the Configuration Register Settings 』を参照してください。


) ブート シーケンスを表示するには、Cisco ルータの電源を投入する前に、ルータへのコンソールの接続を確認する必要があります。


はじめる前に

「Cisco ルータに電源を投入する前のチェック リスト」に従って PC に電源が投入し、接続する準備ができていることを確認します。

手順


ステップ 1 電源スイッチをオンの位置に動かします。

シャーシの前面にある SYS LED はグリーンの点滅になります。

ファンが動作し始めます。

スタートアップ メッセージがコンソール ウィンドウに表示されます。スタートアップ メッセージが停止すると、SYS LED はグリーンの点灯になります。

インストールによっては、シャーシの背面にある LED およびインストール済みモジュールの LED の一部が光る可能性があります。


注意 メッセージが停止し、SYS LED がグリーンの点灯になるまで、キーボードのキーは押さないでください。このときに任意のキーを押すと、メッセージが停止したときに入力された最初のコマンドと解釈されます。その結果、ルータの電源がオフになり、最初からやり直しになる可能性があります。メッセージが停止するまでは数分かかります。


 

関連情報

起動プロセスで問題が発生した場合は、『 Troubleshooting Cisco 3900 Series, 2900 Series, and 1900 Series ISRs 』を参照してください。

前面パネルの LED インジケータの確認

表 1-4 で説明されている前面パネルの LED インジケータで、電源投入中に役立つ電源、アクティビティ、およびステータス情報がわかります。

ルータの初期設定の実行

ルータで初期設定を実行するには、次のツールを使用します。

「Cisco Setup コマンド機能の使い方」

「Cisco Configuration Professional Express の使用」

「Cisco CLI を使用した手動設定」


) ルータで初期設定を実行するには、Cisco Configuration Professional Express を使用することを推奨します。このツールには Web ベースのグラフィカル ユーザ インターフェイス(GUI)があるためです。


Cisco Setup コマンド機能の使い方

シスコの setup コマンド機能を使用すると、設定ダイアログでルータの初期設定を指定できます。次のメッセージが表示される場合、ルータはブート済みで、setup コマンド機能を使用して初期設定できる準備が整っています。

--- System Configuration Dialog ---
 
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 
Would you like to enter the initial configuration dialog? [yes/no]:
 

システム設定ダイアログ メッセージが表示されない場合、デフォルトの設定ファイルは出荷前にルータにインストールされています。ルータの設定については、 「Cisco Configuration Professional Express の使用」 を参照してください。

setup コマンド機能を使用すると、ルータを迅速に設定するために必要な情報を入力するようにプロンプトが表示されます。また、LAN および WAN インターフェイスなどの初期設定を順番に実行できます。setup コマンド機能の概要については、『 Cisco IOS Configuration Fundamentals Configuration Guide, Release 12.4 』を参照してください。


) • 表示されるメッセージは、ルータ モデル、装着されているインターフェイス モジュール、およびソフトウェア イメージによって変わります。次の例とユーザ入力(太字の部分)は、あくまでも例です。

setup コマンド機能を間違って使用した場合は、setup コマンド機能を終了し、再度実行してください。 Ctrl+C を押し、特権 EXEC モード(Router#)に setup コマンドを入力します。


 

手順


ステップ 1 setup コマンド機能を入力します。Cisco IOS CLI から、特権 EXEC モードで setup コマンドを入力し、以下を入力します。

Router> enable
Password: <password>
Router# setup
 
--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]:
 

ステップ 2 setup コマンド機能を引き続き使用する場合は、 yes を入力します。

Continue with configuration dialog? [yes/no]:

At any point you may enter a question mark '?' for help.
 
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 

ステップ 3 十分な接続だけを設定する基本管理セットアップを使用して、作業を進めます。

Would you like to enter basic management setup? [yes/no]: yes
 

ステップ 4 ルータのホスト名を入力します。

Configuring global parameters:
Enter host name [Router]: myrouter
 

ステップ 5 イネーブル シークレット パスワードを入力します。このパスワードは暗号化される(安全性が高い)ので、設定を表示してもパスワードは表示されません。

The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret: cisco
 

ステップ 6 イネーブル シークレット パスワードとは異なるイネーブル パスワードを入力します。このパスワードは暗号化 されない (安全性が低い)ので、設定を表示するとパスワードも表示されます。

The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password: cisco123
 

ステップ 7 仮想端末パスワードを入力します。このパスワードによって、コンソール ポート以外のポートからの不正アクセスを防止できます。

The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password: cisco
 

ステップ 8 次のプロンプトに対して、使用するネットワークに適した応答を入力します。

Configure SNMP Network Management? [no]: yes
Community string [public]:
 

システムで使用可能なインターフェイスの概要が表示されます。


) インターフェイスの概要には、インターフェイスのナンバリングが含まれます。これはルータ モデルおよびインストールされているモジュールとインターフェイス カードによって変わります。


Current interface summary
 
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES NVRAM administratively down down
GigabitEthernet0/1 10.10.10.12 YES DHCP up up
GigabitEthernet0/2 unassigned YES NVRAM administratively down down
SSLVPN-VIF0 unassigned NO unset up
 
Any interface listed with OK? value "NO" does not have a valid configuration
 

ステップ 9 管理ネットワークにルータを接続するために、使用可能なインターフェイスの中から 1 つを選択します。

Enter interface name used to connect to the management network from the above interface summary: gigabitethernet0/1
 

ステップ 10 次のプロンプトに対して、使用するネットワークに適した応答を入力します。

Configuring interface GigabitEthernet0/1:
Configure IP on this interface? [yes]: yes
IP address for this interface [10.10.10.12]:
Subnet mask for this interface [255.0.0.0] : 255.255.255.0
Class A network is 10.0.0.0, 24 subnet bits; mask is /24
 

システムは、次のコンフィギュレーション コマンド スクリプトを作成します。

hostname myrouter
enable secret 5 $1$t/Dj$yAeGKviLLZNOBX0b9eifO0 enable password cisco123 line vty 0 4 password cisco snmp-server community public !
no ip routing
 
!
interface GigabitEthernet0/0
shutdown
no ip address
!
interface GigabitEthernet0/1
no shutdown
ip address 10.10.10.12 255.255.255.0
!
interface GigabitEthernet0/2
shutdown
no ip address
!
end
 

ステップ 11 次のプロンプトに応答します。 2 を選択して初期設定を保存します。

[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
 
Enter your selection [2]: 2
Building configuration...
Use the enabled mode 'configure' command to modify this configuration.
 
Press RETURN to get started! RETURN
 

システムは、ユーザ プロンプトを表示します。

myrouter>
 

ステップ 12 設定を保存するようにプロンプトが表示されます。設定を保存し、ユーザ EXEC プロンプト(Router>) に戻るには、 yes と入力します

Use this configuration? {yes/no} : yes
Building configuration...
Use the enabled mode 'configure' command to modify this configuration.
 
 
Press RETURN to get started!
 
%LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
%LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
%LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
%LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
%LINK-3-UPDOWN: Interface Serial0/2, changed state to down
%LINK-3-UPDOWN: Interface Serial1/0, changed state to up
%LINK-3-UPDOWN: Interface Serial1/1, changed state to down
%LINK-3-UPDOWN: Interface Serial1/2, changed state to down
 
<Additional messages omitted.>
 

ステップ 13 画面にメッセージの停止が表示されたら、Return を押すと Router> プロンプトが表示されます。


) 次のメッセージが表示される場合、ポートに接続されているネットワーク上にその他のルータが見つからなかったことを意味します。
%AT-6-ONLYROUTER: Ethernet0/0: AppleTalk port enabled; no neighbors found


ステップ 14 Router> プロンプトは、CLI を実行中で、ルータの初期設定を完了したことを示します。それでも、これは設定の完了では ありません 。この時点で 2 つの選択肢があります。

もう一度 setup コマンド機能を実行し、別の設定を作成します。

Router> enable
Password: password
Router# setup
 

CLI を使用して、既存の設定を変更するか、追加の機能を設定します。

Router> enable
Password: password
Router# configure terminal
Router(config)#
 


 

Cisco Configuration Professional Express の使用

Cisco Configuration Professional Express Web ベース アプリケーションを使用して、ルータの初期設定を指定します。詳細については、『 Cisco Configuration Professional Express User Guide 』を参照してください。

インターフェイスおよびポートのナンバリングについては、を参照してください。

Cisco CLI を使用した手動設定

ここでは、ルータの初期設定を行うために CLI にアクセスする方法を示します。


rommon 1> プロンプトが表示される場合、システムは ROM モニタ モードでブートされています。ROM モニタについては、「Using the ROM Monitor」を参照してください。


システム設定ダイアログ メッセージが表示されない場合、デフォルトの設定ファイルは出荷前にルータにインストールされています。ルータの設定については、 「Cisco Configuration Professional Express の使用」 を参照してください。

インターフェイスおよびポートのナンバリングについては、を参照してください。

ここでは、次の項目について説明します。

「CLI の初期設定」 (必須)

「ルータのホスト名の設定」(任意)

「イネーブルおよびイネーブル シークレット パスワードの設定」 (必須)

「コンソールのアイドル特権 EXEC タイムアウトの設定」(任意)

「ギガビット イーサネット インターフェイスの設定」 (必須)

「デフォルト ルートまたはラスト リゾート ゲートウェイの指定」 (必須)

「IP ルーティングおよび IP プロトコルの設定」 (必須)

「リモート コンソール アクセスのための仮想端末回線の設定」 (必須)

「補助回線の設定」(任意)

「ネットワーク接続の確認」 (必須)

「ルータ設定の保存」 (必須)

「設定およびシステム イメージのバックアップ コピーの保存」(任意)

CLI の初期設定

手順


ステップ 1 システム メッセージがルータに表示されたら、 no と入力します。

--- System Configuration Dialog ---
 
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 
Would you like to enter the initial configuration dialog? [yes/no]: no
 

ステップ 2 Return を押して自動インストールを終了し、手動設定を続行します。

Would you like to terminate autoinstall? [yes] Return
 

いくつかのメッセージが表示され、次のような行で終わります。

...
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled <date> <time> by <person>
 

ステップ 3 Return を押すと Router> プロンプトが表示されます。

...
flashfs[4]: Initialization complete.
Router>
 

ステップ 4 enable と入力して特権 EXEC モードを開始します。

Router> enable
Router#


 

ルータのホスト名の設定

ホスト名は CLI プロンプトとデフォルトの設定ファイル名に使用されます。ルータのホスト名を設定しないと、出荷時のデフォルトのホスト名である「Router」が使用されます。

ホスト名の大文字と小文字の区別が保持されることは期待しないでください。多くのインターネット ソフトウェア アプリケーションでは、大文字と小文字は同一に扱われます。通常実行するときに名前を大文字にすることは適切なこともありますが、表記法では、コンピュータ名はすべて小文字で表示されます。詳細については、RFC 1178『 Choosing a Name for Your Computer 』を参照してください。

名前は、Advanced Research Projects Agency Network(ARPANET)のホスト名に関する規則に従う必要があります。このルールではホスト名は文字で始まり、文字または数字で終わり、その間には文字、数字、またはハイフンしか使用できません。名前は 63 文字以下にする必要があります。詳細については、RFC 1035『 Domain Names--Implementation and Specification 』を参照してください。

手順の概要

1. enable

2. configure terminal

3. hostname name

4. ルータ プロンプトに新しいホスト名が表示されることを確認します。

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hostname name

 

Router(config)# hostname myrouter

ネットワーク サーバのホスト名を指定または修正します。

ステップ 4

ルータ プロンプトに新しいホスト名が表示されることを確認します。

 

myrouter(config)#

--

ステップ 5

end

 

myrouter# end

(任意)特権 EXEC モードに戻ります。

イネーブルおよびイネーブル シークレット パスワードの設定

セキュリティのレイヤを追加するには、特にネットワークを経由するパスワードまたは TFTP サーバに保存されるパスワードの場合、 enable password コマンドまたは enable secret コマンドを使用します。どちらのコマンドも同じ結果を達成します。つまり、特権 EXEC(イネーブル)モードにアクセスするために入力する必要がある、暗号化されたパスワードを設定できます。

より高度な暗号化アルゴリズムが使用されるので、 enable secret コマンドを使用することを推奨します。 enable password コマンドを使用するのは、 enable secret コマンドを認識しない古いイメージの Cisco IOS ソフトウェアをブートする場合、または古いブート ROM をブートする場合だけです。

詳細については、『 Cisco IOS Security Configuration Guide 』の「Configuring Passwords and Privileges」を参照してください。また、『 Cisco IOS Password Encryption Facts 』テクニカル ノートと『 Improving Security on Cisco Routers 』テクニカル ノートも参照してください。

制約事項 

enable secret コマンドを設定した場合、このコマンドは enable password コマンドよりも優先されます。同時に 2 つのコマンドを有効にはできません。

手順の概要

1. enable

2. configure terminal

3. enable password password

4. enable secret password

5. end

6. enable

7. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

enable password password

 

Router(config)# enable password pswd2

(任意)多様な特権レベルに対して、アクセスを制御するローカル パスワードを設定します。

この手順を実行するのは、 enable secret コマンドを認識しない古いイメージの Cisco IOS ソフトウェアをブートする場合、または古いブート ROM をブートする場合だけです。

ステップ 4

enable secret password

 

Router(config)# enable secret greentree

enable password コマンドよりも強化したセキュリティ レイヤを指定します。

ステップ 3 で入力したパスワードと同じパスワードを使用しないでください。

ステップ 5

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 6

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

新しいイネーブルまたはイネーブル シークレット パスワードが機能していることを確認します。

ステップ 7

end

 

Router(config)# end

(任意)特権 EXEC モードに戻ります。

コンソールのアイドル特権 EXEC タイムアウトの設定

ここでは、コンソール回線のアイドル特権 EXEC タイムアウトを設定する方法について説明します。デフォルトでは、特権 EXEC コマンド インタープリタは、ユーザ入力の検出を 10 分間待ってからタイムアウトします。

コンソール回線を設定するとき、通信パラメータの設定、自動ボー接続の指定、および使用している端末の端末操作パラメータの設定を行うこともできます。コンソール回線の設定の詳細については、『 Cisco IOS Configuration Fundamentals and Network Management Configuration Guide 』を参照してください。特に、「Configuring Operating Characteristics for Terminals」と「Troubleshooting and Fault Management」の章を参照してください。

手順の概要

1. enable

2. configure terminal

3. line console 0

4. exec-timeout minutes [ seconds ]

5. end

6. show running-config

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line console 0

 

Router(config)# line console 0

コンソール回線を設定し、回線コンフィギュレーション コマンドのコレクション モードを開始します。

ステップ 4

exec-timeout minutes [ seconds ]

 

Router(config-line)# exec-timeout 0 0

アイドル特権 EXEC タイムアウトを設定します。これは特権 EXEC コマンド インタープリタがユーザの入力が検出されるまで待つ間隔です。

次に、タイムアウトなしを指定する例を示します。exec-timeout 値を 0 に設定すると、ルータへのログイン後にタイムアウトでログアウトすることがなくなります。この場合、disable コマンドを使用して手動でログアウトせずにコンソールを離れると、セキュリティ上の問題が発生する可能性があります。

ステップ 5

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 6

show running-config

 

Router(config)# show running-config

実行コンフィギュレーション ファイルを表示します。

アイドル特権 EXEC タイムアウトを適切に設定したことを確認します。

次に、コンソールのアイドル特権 EXEC タイムアウトを 2 分 30 秒に設定する例を示します。

line console
exec-timeout 2 30
 

次に、コンソールのアイドル特権 EXEC タイムアウトを 10 秒に設定する例を示します。

line console
exec-timeout 0 10

ギガビット イーサネット インターフェイスの設定

ここでは、IP アドレスおよびインターフェイスの説明をルータのイーサネット インターフェイスに割り当てる方法について説明します。

ギガビット イーサネット インターフェイスの総合的な設定情報については、『 Cisco IOS Interface and Hardware Component Configuration Guide 』の「Configuring LAN Interfaces」の章を参照してください。

インターフェイスのナンバリングについては、ルータのソフトウェア コンフィギュレーション ガイドを参照してください。

手順の概要

1. enable

2. show ip interface brief

3. configure terminal

4. interface { fastethernet | gigabitethernet } 0/ port

5. description string

6. ip address ip-address mask

7. no shutdown

8. end

9. show ip interface brief

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

show ip interface brief

 

Router# show ip interface brief

IP に設定されているインターフェイスの簡単なステータスを表示します。

ルータ上にあるイーサネット インターフェイスの種類がわかります。

ステップ 3

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

interface { fastethernet | gigabitethernet } 0/ port

 

Router(config)# interface gigabitethernet 0/0

イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

(注) インターフェイスのナンバリングについては、ソフトウェア コンフィギュレーション ガイドを参照してください。

ステップ 5

description string

 

Router(config-if)# description GE int to 2nd floor south wing

(任意)インターフェイス設定に説明を追加します。

説明があると、そのインターフェイスに接続されているものを思い出しやすくなります。また、トラブルシューティングのために役立つこともあります。

ステップ 6

ip address ip-address mask

 

Router(config-if)# ip address 172.16.74.3 255.255.255.0

インターフェイスのプライマリ IP アドレスを設定します。

ステップ 7

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 8

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 9

show ip interface brief

 

Router# show ip interface brief

IP に設定されているインターフェイスの簡単なステータスを表示します。

イーサネット インターフェイスが起動し、正しく設定されていることを確認します。

ギガビットイーサネット インターフェイスの設定

!
interface GigabitEthernet0/0
description GE int to HR group
ip address 172.16.3.3 255.255.255.0
duplex auto
speed auto
no shutdown
!

show ip interface brief コマンドの出力例

Router# show ip interface brief
 
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 172.16.3.3 YES NVRAM up up
GigabitEthernet0/1 unassigned YES NVRAM administratively down down
Router#

デフォルト ルートまたはラスト リゾート ゲートウェイの指定

ここでは、IP ルーティングをイネーブルにしてデフォルト ルートを指定する方法について説明します。デフォルト ルートの指定の代替手段については、『 Configuring a Gateway of Last Resort Using IP Commands 』テクニカル ノートを参照してください。

パケットのよりよいルートがない場合、および宛先が接続されているネットワークではない場合、Cisco IOS ソフトウェアはラスト リゾート ゲートウェイ(ルータ)を使用します。ここでは、デフォルト ルート(ラスト リゾート ゲートウェイを計算するルート候補)としてネットワークを選択する方法について説明します。ルーティング プロトコルがデフォルト ルート情報を伝播する方法は、プロトコルによって異なります。

IP ルーティングおよび IP プロトコルの設定

IP ルーティングおよび IP ルーティング プロトコルの総合的な設定情報については、『 Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4T 』を参照してください。

「IP ルーティング」

「デフォルト ルート」

「デフォルト ネットワーク」

IP ルーティング

ルータがルーティングとブリッジ処理を同時に実行するように、Integrated Routing and Bridging(IRB)を設定できます。ルーティングがイネーブルかどうかに関係なく、ルータはネットワーク上の IP ホストとして動作します。IRB の詳細については、Cisco.com の http://www.cisco.com/en/US/tech/tk389/tk815/tk855/tsd_technology_support_sub-protocol_home.html を参照してください。

IP ルーティングは Cisco IOS ソフトウェアで自動的にイネーブルにされます。IP ルーティングを設定すると、設定済みのデフォルト ルートなど、パケットの転送に設定済みまたは既存のルートが使用されます。


) このタスク セクションは、IP ルーティングをディセーブルにするときは適用されません。IP ルーティングをディセーブルにするときにデフォルト ルートを指定するには、『Configuring a Gateway of Last Resort Using IP Commands』テクニカル ノートを参照してください。


デフォルト ルート

ルータは他のすべてのネットワークに対してルートを決定できないこともあります。ルーティング機能を実現するための一般的な方法は、スマート ルータとして複数のルータを使用し、残りのルータのデフォルト ルータをスマート ルータに設定します (スマート ルータには、インターネットワーク全体のルーティング テーブル情報があります)。これらのデフォルト ルートをダイナミックに渡すことや、個々のルータに設定することができます。

ほとんどのダイナミックな内部ルーティング プロトコルには、スマート ルータがダイナミックなデフォルト情報を生成し、それを他のルータに渡す処理を発生させるメカニズムが含まれます。

デフォルト ネットワーク

指定したデフォルト ネットワークに直接接続されているインターフェイスがルータにある場合、ルータで実行されるダイナミック ルーティング プロトコルによって、デフォルト ルートが生成されるか、デフォルト ルートが調達されます。RIP の場合、ルータは疑似ネットワーク 0.0.0.0 をアドバタイズします。IGRP の場合、ネットワーク自体がアドバタイズされ、外部ルートとしてフラグが付けられます。

ネットワークのデフォルトを生成するルータも、デフォルト ルータを必要とする場合があります。ルータが自身のデフォルト ルートを生成する方法の 1 つは、適切なデバイスを経由してネットワーク 0.0.0.0 に至るスタティック ルートを指定することです。

ラスト リゾート ゲートウェイ

デフォルト情報をダイナミック ルーティング プロトコルを介して渡している場合、その他の設定は不要です。ルーティング テーブルは定期的にスキャンされ、デフォルト ルートとして最適なデフォルト ネットワークが選択されます。RIP の場合、0.0.0.0 という唯一の選択肢しかありません。IGRP の場合、システム デフォルトの候補にすることができるネットワークが複数存在することもあります。Cisco IOS ソフトウェアではアドミニストレーティブ ディスタンスおよびメトリック情報の両方を使用して、デフォルト ルート(ラスト リゾート ゲートウェイ)を判断します。選択したデフォルト ルートは、 show ip route EXEC コマンドのラスト リゾート ゲートウェイの表示に表示されます。

ダイナミックなデフォルト情報がソフトウェアに渡されない場合、デフォルト ルートの候補を ip default-network グローバル コンフィギュレーション コマンドで指定します。この方法では、 ip default-network コマンドは引数として未接続ネットワークを使用します。このネットワークが任意のソース(ダイナミックまたはスタティック)のルーティング テーブルに表示される場合、デフォルト ルート候補としてフラグが付けられ、デフォルト ルートとして使用できる選択肢になります。

ルータのデフォルト ネットワークにインターフェイスがなく、そのネットワークに対するルートはある場合、そのネットワークはデフォルト パス候補と見なされます。ルート候補は検査され、アドミニストレーティブ ディスタンスおよびメトリックに基づいて最適な候補が選択されます。最適なデフォルト パスに対するゲートウェイは、ラスト リゾート ゲートウェイになります。

手順の概要

1. enable

2. configure terminal

3. ip routing

4. ip route dest-prefix mask next-hop-ip-address [ admin-distance ] [ permanent ]

5. ip default-network network-number
または
ip route dest-prefix mask next-hop-ip-address

6. end

7. show ip route

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip routing

 

Router(config)# ip routing

IP ルーティングをイネーブルにします。

ステップ 4

ip route dest-prefix mask next-hop-ip-address [ admin-distance ] [ permanent ]

 

Router(config)# ip route 192.168.24.0 255.255.255.0 172.28.99.2

スタティック ルートを確立します。

ステップ 5

ip default-network network-number

or

ip route dest-prefix mask next-hop-ip-address

 

Router(config)# ip default-network 192.168.24.0

 

Router(config)# ip route 0.0.0.0 0.0.0.0 172.28.99.1

ラスト リゾート ゲートウェイを計算するルート候補としてネットワークを選択します。

ラスト リゾート ゲートウェイを計算するために、ネットワーク 0.0.0.0 0.0.0.0 に対するスタティック ルートを作成します。

ステップ 6

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 7

show ip route

 

Router# show ip route

現在のルーティング テーブル情報を表示します。

ラスト リゾート ゲートウェイが設定されていることを確認します。

デフォルト ルートの指定:例

!
ip routing
!
ip route 192.168.24.0 255.255.255.0 172.28.99.2
!
ip default-network 192.168.24.0
!

show ip route コマンドの出力例

Router# show ip route
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
Gateway of last resort is 172.28.99.2 to network 192.168.24.0
 
172.24.0.0 255.255.255.0 is subnetted, 1 subnets
C 172.24.192.0 is directly connected, FastEthernet0
S 172.24.0.0 255.255.0.0 [1/0] via 172.28.99.0
S* 192.168.24.0 [1/0] via 172.28.99.2
172.16.0.0 255.255.255.0 is subnetted, 1 subnets
C 172.16.99.0 is directly connected, FastEthernet1
Router#

リモート コンソール アクセスのための仮想端末回線の設定

Virtual Terminal(VTY; 仮想端末)回線は、ルータに対してリモート アクセスするために使用されます。ここでは、電源があるユーザだけがルータをリモート アクセスできるように、パスワードを使用して仮想端末回線を設定する方法について説明します。

デフォルトで、ルータには 5 個の仮想端末回線があります。ただし、『Cisco IOS Terminal Services Configuration Guide, Release 12.4』に従って、追加の仮想端末回線を作成できます。「 Configuring Terminal Operating Characteristics for Dial-In Sessions」の項を参照してください。

回線パスワードおよびパスワードの暗号化については、『Cisco IOS Security Configuration Guide, Release 12.4』を参照してください。「 Security with Passwords, Privilege Levels, and Login Usernames for CLI Sessions on Networking Devices 」の項を参照してください。アクセス リストで VTY 回線のセキュリティを保護する場合、『 Access Control Lists: Overview and Guidelines 』を参照してください。また、『 Cisco IOS Password Encryption Facts 』テクニカル ノートを参照してください。

手順の概要

1. enable

2. configure terminal

3. line vty line-number [ ending-line-number ]

4. password password

5. login

6. end

7. show running-config

8. 別のネットワーク デバイスから、ルータに対する Telnet セッションの開始を試行します。

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line vty line-number [ ending-line-number ]

 

Router(config)# line vty 0 4

リモート コンソール アクセスために、仮想端末回線(VTY)の回線コンフィギュレーション コマンドのコレクション モードを開始します。

ルータ上のすべての VTY 回線を設定していることを確認します。

コマンドを使用します。

ステップ 4

password password

 

Router(config-line)# password guessagain

回線のパスワードを指定します。

ステップ 5

login

 

Router(config-line)# login

ログイン時のパスワード チェックをイネーブルにします。

ステップ 6

end

 

Router(config-line)# end

特権 EXEC モードに戻ります。

ステップ 7

show running-config

 

Router# show running-config

実行コンフィギュレーション ファイルを表示します。

リモート アクセスのために仮想端末回線を適切に設定したことを確認します。

ステップ 8

別のネットワーク デバイスから、ルータに対する Telnet セッションの開始を試行します。

 

Router# 172.16.74.3

Password:

ルータにリモート アクセスできること、および仮想端末回線のパスワードが正しく設定されていることを確認します。

次に、パスワードを使用して仮想端末回線を設定する例を示します。

!
line vty 0 4
password guessagain
login
!

次の作業

VTY 回線を設定したら、次の手順を実行します。

(任意)仮想端末回線のパスワードを暗号化するには、『 Cisco IOS Security Configuration Guide 』の「Configuring Passwords and Privileges」の章を参照してください。また、『 Cisco IOS Password Encryption Facts 』テクニカル ノートを参照してください。

(任意)アクセス リストを使用して VTY 回線のセキュリティを保護するには、『 Cisco IOS Security Configuration Guide 』の「Part 3: Traffic Filtering and Firewalls」を参照してください。

補助回線の設定

ここでは、補助回線について回線コンフィギュレーション モードを開始する方法について説明します。補助回線の設定方法は、補助ポートの具体的な実装によって異なります。補助回線の設定については、次のマニュアルを参照してください。

Configuring a Modem on the AUX Port for EXEC Dialin Connectivity 』(テクニカル ノート)

Configuring Dialout Using a Modem on the AUX Port 』(設定例)

Configuring AUX-to-AUX Port Async Backup with Dialer Watch 』(設定例)

Modem-Router Connection Guide 』(テクニカル ノート)

手順の概要

1. enable

2. configure terminal

3. line aux 0

4. 補助ポートの特定の実装に合わせて回線を設定するには、テクニカル ノートと設定例を参照してください。

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line aux 0

 

Router(config)# line aux 0

補助回線について回線コンフィギュレーション コマンドのコレクション モードを開始します。

ステップ 4

補助ポートの特定の実装に合わせて回線を設定するには、テクニカル ノートと設定例を参照してください。

--

ネットワーク接続の確認

ここでは、ルータのネットワーク接続を確認する方法について説明します。

前提条件

この章で前述したすべての設定タスクを完了します。

適切に設定したネットワーク ホストにルータを接続する必要があります。

手順の概要

1. enable

2. ping [ ip-address | hostname ]

3. telnet { ip-address | hostname }

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

ping [ ip-address | hostname ]

 

Router# ping 172.16.74.5

初期ネットワーク接続を診断します。

接続を確認するには、ネクスト ホップのルータ、または設定済みの各インターフェイスに接続しているホストに対して ping を実行します。

ステップ 3

telnet { ip-address | hostname }

 

Router# telnet 10.20.30.40

Telnet をサポートするホストにログインします。

VTY 回線パスワードをテストする場合、別のネットワーク デバイスからこの手順を実行し、ルータの IP アドレスを使用します。

次の表示は、IP アドレス 192.168.7.27 に対して ping を実行したときの出力例です。

Router# ping
 
Protocol [ip]:
Target IP address: 192.168.7.27
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.27, timeout is 2 seconds:
!!!!!
Success rate is 100 percent, round-trip min/avg/max = 1/2/4 ms
 

次の表示は、IP ホスト名 donald に対して ping を実行したときの出力例です。

Router# ping donald
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.27, timeout is 2 seconds:
!!!!!
Success rate is 100 percent, round-trip min/avg/max = 1/3/4 ms

ルータ設定の保存

ここでは、実行コンフィギュレーションを NVRAM のスタートアップ コンフィギュレーションに保存することで、次のシステム リロード時、または電源の再投入時に設定を失わない方法について説明します。NVRAM には、ルータ上に 256KB のストレージがあります。

手順の概要

1. enable

2. copy running-config startup-config

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

copy running-config startup-config

 

Router# copy running-config startup-config

実行中の設定をスタートアップ コンフィギュレーションに保存します。

設定およびシステム イメージのバックアップ コピーの保存

ファイルの破損時にファイルの回復を補助し、ダウンタイムを最小限に抑えるために、スタートアップ コンフィギュレーション ファイルおよび Cisco IOS ソフトウェア システム イメージ ファイルのバックアップ コピーをサーバに保存することを推奨します。

手順の概要

1. enable

2. copy nvram:startup-config { ftp: | rcp: | tftp: }

3. show {flash0|flash1}:

4. copy {flash0|flash1}: { ftp: | rcp: | tftp: }

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

copy nvram:startup-config { ftp: | rcp: | tftp: }

 

Router# copy nvram:startup-config ftp:

スタートアップ コンフィギュレーション ファイルをサーバにコピーします。

コンフィギュレーション ファイルのコピーはバックアップ コピーとして使用できます。

プロンプトが表示されたら、コピー先の URL を入力します。

ステップ 3

show {flash0|flash1}:

 

Router# show {flash0|flash1} :

フラッシュ メモリ ファイル システムのレイアウトとコンテンツを表示します。

システム イメージ ファイルの名前を確認します。

ステップ 4

copy {flash0|flash1}: { ftp: | rcp: | tftp: }

 

Router# copy {flash0|flash1}: ftp :

フラッシュ メモリのファイルをサーバにコピーします。

システム イメージ ファイルをサーバにコピーし、バックアップ コピーとして使用します。

プロンプトが表示されたら、ファイル名とコピー先の URL を入力します。

スタートアップ コンフィギュレーションの TFTP サーバへのコピー:例

次に、スタートアップ コンフィギュレーションを TFTP サーバにコピーする例を示します。

Router# copy nvram:startup-config tftp:
 
Remote host[]? 172.16.101.101
 
Name of configuration file to write [rtr2-confg]? <cr>
Write file rtr2-confg on host 172.16.101.101?[confirm] <cr>
![OK]

フラッシュ メモリから TFTP サーバへのコピー:例

次に、特権 EXEC で show {flash0|flash1}: コマンドを使用してシステム イメージ ファイルの名前を確認し、 copy {flash0|flash1}: tftp: 特権 EXEC コマンドを使用して、システム イメージ(c3900-2is-mz)を TFTP サーバにコピーする例を示します。このルータはデフォルトのユーザ名とパスワードを使用しています。

Router# show {flash0|flash1}:
 
System flash directory:
File Length Name/status
1 4137888 c3900-c2is-mz
[4137952 bytes used, 12639264 available, 16777216 total]
16384K bytes of processor board System flash (Read/Write)\
 
Router# copy {flash0|flash1}: tftp:
 
IP address of remote host [255.255.255.255]? 172.16.13.110
filename to write on tftp host? c3900-c2is-mz
writing c3900-c2is-mz !!!!...
successful ftp write.

) 完了した作業内容を失わないために、進行に合わせてときどき設定を保存してください。copy running-config startup-config コマンドを使用して設定を NVRAM に保存します。


初期設定の確認

ルータの初期設定を確認するには、Cisco IOS で次のコマンドを入力します。

show version :システムのハードウェア バージョン、インストールされているソフトウェア バージョン、コンフィギュレーション ファイルの名前とソース、ブート イメージ、および使用されている DRAM、NVRAM、およびフラッシュ メモリの合計サイズを表示します。

show diag :インストールされているコントローラ、インターフェイス プロセッサ、およびポート アダプタに関する診断情報を一覧表示します。

show interfaces :インターフェイスが正しく動作していること、インターフェイスおよび回線プロトコルが正しい状態(アップまたはダウン)にあることを表示します。

show ip interface brief :IP プロトコルに設定されているインターフェイスのステータス概要を表示します。

show configuration :正しいホスト名とパスワードを設定したことを確認します。

初期設定を完了および確認したら、特定の特性と機能を設定できるようになります。『 Cisco 1900 Series, 2900 Series, and 3900 Series Software Configuration Guide 』を参照してください。