Cisco 1900 シリーズ統合型サービス ルータ ハード ウェア インストレーション
基本的な接続の確立
基本的な接続の確立
発行日;2012/01/13 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

基本的な接続の確立

ルータの起動

起動チェックリスト

起動手順

前面パネル LED 表示の確認

ルータにおける初期設定の実行

Cisco Setup コマンド機能の使い方

設定の完了

Cisco Configuration Professional Express の使い方

Cisco CLI を使用した手動設定

ルータのホスト名の設定

イネーブル パスワードとイネーブル シークレット パスワードの設定

コンソールのアイドル イネーブル EXEC タイムアウトの設定

ギガビット イーサネット インターフェイスの設定

デフォルト ルートまたはラスト リゾート ゲートウェイの指定

IP ルーティングと IP プロトコルの計算

デフォルト ルート

デフォルト ネットワーク

ラスト リゾート ゲートウェイ

リモート コンソール アクセス用の仮想端末回線の設定

補助回線の設定

ネットワーク接続の確認

ルータ コンフィギュレーションの保存

コンフィギュレーションおよびシステム イメージのバックアップ コピーの保存

初期設定の確認

基本的な接続の確立

このマニュアルでは、ルータの起動方法および初期設定の実行方法について次の各セクションで説明します。

「ルータの起動」

「ルータにおける初期設定の実行」

「Cisco Setup コマンド機能の使い方」

「Cisco Configuration Professional Express の使い方」

「Cisco CLI を使用した手動設定」

「初期設定の確認」

ルータの起動


警告 ブランクの前面プレートおよびカバー パネルには、シャーシ内の危険な電圧および電流による感電を防ぐこと、他の装置への Electromagnetic Interference(EMI; 電磁波干渉)の影響を防ぐこと、およびシャーシ内の空気の流れを適切な状態に保つことという 3 つの重要な機能があります。必ずすべてのカード、前面プレート、前面カバー、および背面カバーをスロットに正しく取り付けた状態で、システムを運用してください。ステートメント 1029


ここでは、次の内容について説明します。

「起動チェックリスト」

「起動手順」

「前面パネル LED 表示の確認」

「ルータにおける初期設定の実行」

起動チェックリスト

ルータを起動する前に、次の項目を確認します。

シャーシが確実に設置されていて、アースされている。

電源コードおよびインターフェイス ケーブルが接続されている。

外付け CompactFlash メモリ カードがスロットに正しく装着されている。取り付け手順については、オンライン ドキュメントの 「Cisco 1900 シリーズ ルータにおける CompactFlash メモリ カードの取り付けおよび取り外し」 を参照してください。

端末エミュレーション プログラム(HyperTerminal または同等のもの)を搭載した PC がコンソール ポートに接続されており、9600 ボー、8 データ ビット、1 ストップ ビット、パリティなし、およびフロー制御「なし」として設定されている。

端末エミュレーション プログラムで適切な PC COM ポートが選択されている。

アクセス制御のためにパスワードが選択されている。

イーサネットおよびシリアル インターフェイスの IP アドレスが確定している。

起動手順

シスコのルータを起動するには、次の手順に従ってルータが初期化およびセルフテストを完了したことを確認します。手順を完了すると、ルータを設定する準備が整います。

ルータの起動時に問題が発生した場合は、Cisco.com でルータのトラブルシューティングに関するページを参照してください。

ROM モニタおよびブートストラップ プログラムについては、ルータのソフトウェア コンフィギュレーション ガイドの『 Using the ROM Monitor 』を参照してください。コンフィギュレーション レジスタについては、ルータのソフトウェア コンフィギュレーション ガイドの『 Changing the Configuration Register Settings 』を参照してください。


) 起動シーケンスを表示するには、シスコ ルータを起動する前に、ルータにコンソールを接続しておく必要があります。



ステップ 1 「起動チェックリスト」に記載されているように、PC が起動し、接続されていることを確認します。

ステップ 2 電源スイッチを ON の位置に移動にします。

シャーシ前面の SYS OK LED がグリーンの点滅を開始します。

ファンが動作を開始します。

コンソール ウィンドウに起動メッセージが表示されます。起動メッセージが終了すると、SYS LED がグリーンに点灯します。


注意 メッセージが停止し、SYS LED がグリーンに点灯するまでは、キーボードのキーを押さないでください。この間にいずれかのキーを押すと、メッセージが停止した時点で最初に入力されたコマンドと見なされ、ルータの電源がオフになったり、再起動したりすることがあります。メッセージが停止するまでに数分かかります。


) 設置環境によっては、シャーシ背面および搭載されているモジュールの LED の一部が点灯します。


起動プロセスで問題が発生した場合は、Cisco.com で提供されている『Troubleshooting Cisco 3900 Series, 2900 Series, and 1900 Series ISRs』を参照してください。

ステップ 3 次のいずれかのツールを使用して初期設定を行います。

「Cisco Configuration Professional Express」


) Cisco Configuration Professional Express には Web ベースのグラフィカルユーザ インターフェイスが用意されているので、このツールを使用して初期設定を行うことが推奨されます。「Cisco Configuration Professional Express」を参照してください。


「Cisco Setup コマンド機能」

「Cisco コマンドライン インターフェイス」

Cisco Setup コマンド機能

Cisco Setup コマンド機能では、設定ダイアログを使用してルータの初期設定を行うことができます。次のメッセージが表示された場合、ルータは起動が完了しており、setup コマンド機能を使用して、初期設定を行うことができます。

--- System Configuration Dialog ---
 
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 
Would you like to enter the initial configuration dialog? [yes/no]:
 

Cisco Setup コマンド機能に従うには、「ルータにおける初期設定の実行」を参照してください。


) システム設定ダイアログのメッセージが表示されない場合、デフォルトのコンフィギュレーション ファイルが出荷前にルータにインストール済みです。ルータを設定するには、「Cisco Configuration Professional Express の使い方」を参照してください。


Cisco Configuration Professional Express

Web ベースのアプリケーションである Cisco Configuration Professional Express を使用してルータの初期設定を行います。詳細な手順については、Cisco.com で提供されている『 Cisco Configuration Professional Express User Guide 』を参照してください。 http://www.cisco.com/en/US/docs/net_mgmt/cisco_configuration_professional_express/version1_1/online_help/CCPE11.pdf

インターフェイス番号およびポート番号については、「インターフェイス番号」を参照してください。

Cisco コマンドライン インターフェイス

Cisco Command Line Interface(CLI; コマンドライン インターフェイス)では、ルータの初期設定を手動で行うことができます。次のメッセージが表示された場合、ルータは起動が完了しており、CLI を使用して、初期設定を行うことができます。CLI を使用してルータを設定する方法については、「Cisco CLI を使用した手動設定」を参照してください。


rommon 1> プロンプトが表示された場合、システムは ROM モニタ モードで起動しています。ROM モニタについては、『Using the ROM Monitor』を参照してください。


前面パネル LED 表示の確認

表 6-1 に記載されている前面パネル LED インジケータは、起動時に役立つ電源、アクティビティ、およびステータス情報を提供します。

 

表 6-1 Cisco 1900 シリーズの LED インジケータ

LED のラベル
LED のカラーまたは状態
意味

SYS
PWR

グリーンに点灯

システムは正常に動作しています。

グリーンに点滅

システムは起動中または ROM モニタ モードです。

オレンジ

システム エラーです。

消灯

電源オフまたは電源障害です。

ACT

グリーン

WAN や LAN でパケットの送受信中、またはシステム アクティビティのモニタリング中に、点灯または点滅します。

POE

グリーン

Power over Ethernet(POE)を使用できます。

オレンジ

電源装置は、POE 電力を供給していません。

WLAN 2.4GHz(ワイヤレス モデル)

グリーン

オン:無線は接続済み、SSID1 は設定済み、信号は送信され、クライアントは関連付けられていますが、データを受信していないか、送信していません。

ゆっくり点滅:無線は接続済み、SSID は設定済みであり、ビーコンを送信しています。

速い点滅:データを受信または送信しています。

オフ:無線が切断され、SSID は設定されていません。

WLAN 5GHz(ワイヤレス モデル)

グリーン

オン:無線は接続済み、SSID は設定済み、信号は送信され、クライアントは関連付けられていますが、データを受信していないか、送信していません。

ゆっくり点滅:無線は接続済み、SSID は設定済みであり、ビーコンを送信しています。

速い点滅:データを受信または送信しています。

オフ:無線が切断され、SSID は設定されていません。

WLAN

グリーン

Autonomous モード

オン:ワイヤレス リンクは、アップ状態です。

点滅:イーサネット リンクはアップ状態です。データを受信または送信しています。

オフ:ワイヤレス リンクは、ダウン状態です。

Unified モード

オン:イーサネット リンクはアップ状態です。ワイヤレス アクセス ポイントは、Lightweight AP Protocol(LWAPP; Lightweight AP プロトコル)コントローラと通信しています。点滅:イーサネット リンクはアップ状態です。ワイヤレス アクセス ポイントは、LWAPP コントローラと通信していません。

オフ:イーサネット リンクは、ダウン状態です。

1.SSID = Service Set Identifier(サービス セット ID)

ルータにおける初期設定の実行

次のツールを使用して、ルータで初期設定を実行します。

「Cisco Setup コマンド機能の使い方」

「Cisco Configuration Professional Express の使い方」

「Cisco CLI を使用した手動設定」

Cisco Setup コマンド機能の使い方

setup コマンド機能では、ルータを迅速に設定するために必要な情報の入力が求められます。この機能では、LAN および WAN インターフェイスを含む初期設定を順に行います。setup コマンド機能の一般情報については、次のマニュアルを参照してください。

Cisco IOS Configuration Fundamentals Configuration Guide , Release 12.4』の「Part 2: Cisco IOS User Interfaces:Using AutoInstall and Setup」
http://www.cisco.com/en/US/docs/ios/fundamentals/configuration/guide/12_4/cf_12_4_book.html

ここでは、ルータのホスト名とパスワードを設定し、管理ネットワークと通信するためのインターフェイスを設定する方法について説明します。


) 表示されるメッセージは、使用するルータ モデル、搭載されているインターフェイス モジュール、およびソフトウェア イメージによって異なります。次の例およびユーザ入力(太字フォント)は、例題としてだけ表示されています。



) setup コマンド機能の使用中に間違えた場合は、setup コマンド機能をいったん終了してから、もう一度実行できます。Ctrl キーを押した状態で C キーを押し、イネーブル EXEC モード(Router#)で setup コマンドを入力します。



ステップ 1 次のいずれかの方法を使用して、setup コマンド機能を開始します。

Cisco IOS CLI から、イネーブル EXEC モードで setup コマンドを入力する。

Router> enable
Password: <password>
Router# setup
 
--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]:
 

Setup Configuration Utility が起動しました。

setup コマンド機能のプロンプトは、使用するルータ モデル、搭載されているインターフェイス モジュール、およびソフトウェア イメージによって異なります。次の手順およびユーザ入力(太字フォント)は、例題としてだけ表示されています。


) setup コマンド機能の使用中に間違えた場合は、setup コマンド機能をいったん終了してから、もう一度実行できます。Ctrl キーを押した状態で C キーを押し、イネーブル EXEC モード(Router#)で setup コマンドを入力します。setup コマンド機能の使い方については、次の URL で『Cisco IOS Configuration Fundamentals Command Reference, Release 12.2T』の「The Setup Command」の章を参照してください。http://www.cisco.com/en/US/docs/ios/12_2t/fun/command/reference/122tfr.html


ステップ 2 setup コマンド機能の使用を続ける場合は、 yes を入力します。

Continue with configuration dialog? [yes/no]:

At any point you may enter a question mark '?' for help.
 
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 

ステップ 3 管理の基本設定では、十分な接続だけが設定されます。

Would you like to enter basic management setup? [yes/no]: yes
 

ステップ 4 ルータのホスト名(例では myrouter)を入力します。

Configuring global parameters:
Enter host name [Router]: myrouter
 

ステップ 5 イネーブル シークレット パスワードを入力します。このパスワードは(安全性向上のために)暗号化されるので、設定を表示しても見ることはできません。

The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret: cisco
 

ステップ 6 イネーブル シークレット パスワードとは異なるイネーブル パスワードを入力します。このパスワードは暗号化 されない ので(安全性が低い)、設定を表示すると見ることができます。

The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password: cisco123
 

ステップ 7 仮想端末パスワードを入力します。このパスワードによって、コンソール ポート以外のポートからルータへの不正アクセスを防止します。

The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password: cisco
 

ステップ 8 使用するネットワークに基づいて、次のプロンプトに応答します。

Configure SNMP Network Management? [no]: yes
Community string [public]:
 

使用可能なインターフェイスの要約が表示されます。


) インターフェイスの要約には、ルータ モデル、および搭載されているモジュールとインターフェイス カードによって異なる、インターフェイス番号が含まれます。


Current interface summary
 
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES NVRAM administratively down down
GigabitEthernet0/1 10.10.10.12 YES DHCP up up
GigabitEthernet0/2 unassigned YES NVRAM administratively down down
SSLVPN-VIF0 unassigned NO unset up
 
Any interface listed with OK? value "NO" does not have a valid configuration
 

ステップ 9 管理ネットワークにルータを接続するために使用できるインターフェイスを 1 つ選択します。

Enter interface name used to connect to the
management network from the above interface summary: gigabitethernet0/1
 

ステップ 10 使用するネットワークに基づいて、次のプロンプトに応答します。

Configuring interface GigabitEthernet0/1:
Configure IP on this interface? [yes]: yes
IP address for this interface [10.10.10.12]:
Subnet mask for this interface [255.0.0.0] : 255.255.255.0
Class A network is 10.0.0.0, 24 subnet bits; mask is /24

 

次のコンフィギュレーション コマンド スクリプトが作成されます。

hostname myrouter
enable secret 5 $1$t/Dj$yAeGKviLLZNOBX0b9eifO0 enable password cisco123 line vty 0 4 password cisco snmp-server community public !
no ip routing
 
!
interface GigabitEthernet0/0
shutdown
no ip address
!
interface GigabitEthernet0/1
no shutdown
ip address 10.10.10.12 255.255.255.0
!
interface GigabitEthernet0/2
shutdown
no ip address
!
end
 

ステップ 11 次のプロンプトに応答します。初期設定を保存する場合は、[2] を選択します。

[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
 
Enter your selection [2]: 2
Building configuration...
Use the enabled mode 'configure' command to modify this configuration.
 
Press RETURN to get started! RETURN
 

ユーザ プロンプトが表示されます。

myrouter>

設定の完了

Cisco Setup の使用時に、この機能で求められる情報をすべて入力すると、最終設定が表示されます。ルータ設定を完了するには、次の手順に従います。


ステップ 1 設定の保存を促すプロンプトが表示されます。

no と応答すると、入力した設定情報は保存 されず 、ルータのイネーブル プロンプト(Router#)に戻ります。setup と入力して、システム設定ダイアログに戻ります。

yes と応答すると、設定が保存され、ユーザ EXEC プロンプト(Router>)に戻ります。

Use this configuration? {yes/no} : yes
Building configuration...
Use the enabled mode 'configure' command to modify this configuration.
 
 
Press RETURN to get started!
 
%LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
%LINK-3-UPDOWN: Interface Ethernet0/1, changed state to up
%LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
%LINK-3-UPDOWN: Interface Serial0/0/1, changed state to down
%LINK-3-UPDOWN: Interface Serial0/2, changed state to down
%LINK-3-UPDOWN: Interface Serial1/0, changed state to up
%LINK-3-UPDOWN: Interface Serial1/1, changed state to down
%LINK-3-UPDOWN: Interface Serial1/2, changed state to down
 
<Additional messages omitted.>
 

ステップ 2 画面にメッセージが表示されなくなったら、 Return キーを押して Router> プロンプトをアクティブにします。


) 次のメッセージが表示された場合、ポートに接続されているネットワーク上で他のルータが検出されないことを意味します。


%AT-6-ONLYROUTER: Ethernet0/0: AppleTalk port enabled; no neighbors found
 

ステップ 3 Router> プロンプトは、ユーザがコマンドライン インターフェイス(CLI)にいて、ルータの初期設定を完了したところであることを示します。しかしながら、これは完全な設定では ありません 。この時点では、次の 2 つの選択肢があります。

setup コマンド機能を再実行して、別の設定を作成する。

Router> enable
Password: password
Router# setup
 

既存の設定を変更する、または CLI を使用して追加機能を設定する。

Router> enable
Password: password
Router# configure terminal
Router(config)#

 


 

Cisco Configuration Professional Express の使い方

Web ベースのアプリケーションである Cisco Configuration Professional Express を使用してルータの初期設定を行います。詳細な手順については、Cisco.com で提供されている『 Cisco Configuration Professional Express User Guide 』を参照してください。 http://www.cisco.com/en/US/docs/net_mgmt/cisco_configuration_professional_express/version1_1/online_help/CCPE11.pdf

インターフェイス番号およびポート番号については、「インターフェイス番号」を参照してください。

Cisco CLI を使用した手動設定

ここでは、コマンドライン インターフェイス(CLI)にアクセスして、ルータで初期設定を行う方法について説明します。

システム設定ダイアログのメッセージが表示されない場合、デフォルトのコンフィギュレーション ファイルが出荷前にルータにインストール済みです。ルータを設定するには、 「Cisco Configuration Professional Express の使い方」 を参照してください。

インターフェイス番号およびポート番号については、「インターフェイス番号」を参照してください。


ステップ 1 ルータにシステム メッセージが表示されたら、次の応答を入力します。

--- System Configuration Dialog ---
 
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 
Would you like to enter the initial configuration dialog? [yes/no]: no
 

ステップ 2 Return キーを押して、自動インストールを終了し、手動設定を続けます。

Would you like to terminate autoinstall? [yes] Return
 

複数のメッセージが表示されたあと、次のような行が最後に表示されます。

...
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled <date> <time> by <person>
 

ステップ 3 Return キーを押して、 Router> プロンプトをアクティブにします。

...
flashfs[4]: Initialization complete.
Router>
 

ステップ 4 enable と入力して、イネーブル EXEC モードを開始します。

Router> enable
Router#
 

「ルータのホスト名の設定」(任意)

「イネーブル パスワードとイネーブル シークレット パスワードの設定」(必須)

「コンソールのアイドル イネーブル EXEC タイムアウトの設定」(任意)

「ギガビット イーサネット インターフェイスの設定」(必須)

「デフォルト ルートまたはラスト リゾート ゲートウェイの指定」(必須)

「IP ルーティングと IP プロトコルの計算」(必須)

「リモート コンソール アクセス用の仮想端末回線の設定」(必須)

「補助回線の設定」(任意)

「ネットワーク接続の確認」(必須)

「ルータ コンフィギュレーションの保存」(必須)

「コンフィギュレーションおよびシステム イメージのバックアップ コピーの保存」(任意)

ルータのホスト名の設定

ホスト名は、CLI プロンプトおよびデフォルトのコンフィギュレーション ファイル名に使用されます。ルータのホスト名を設定しないと、出荷時に割り当てられたデフォルトのホスト名「Router」が使用されます。

ホスト名では、大文字小文字の区別は維持されません。多くのインターネット ソフトウェア アプリケーションでは、大文字と小文字は同一として処理されます。通常どおり名前を大文字化するのが適切と思うかも知れませんが、規定では、コンピュータ名はすべて小文字で表示されるように定められています。詳細については、RFC 1178『 Choosing a Name for Your Computer 』を参照してください。

ホスト名は、Advanced Research Projects Agency Network(ARPANET; 高等研究計画局)のホスト名に関する規則にも従う必要があります。名前の先頭は文字、末尾は文字または数字にする必要があります。また、名前の先頭と末尾以外には、文字、数字、およびハイフンだけを設定する必要があります。名前は、63 文字以内にする必要があります。詳細については、RFC 1035『 Domain Names--Implementation and Specification 』を参照してください。

要約手順

1. enable

2. configure terminal

3. hostname 名前

4. ルータ プロンプトに新しいホスト名が表示されることを確認する。

5. end

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

プロンプトが表示された場合、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hostname name

 

Router(config)# hostname myrouter

ネットワーク サーバのホスト名を指定または変更します。

ステップ 4

--

ステップ 5

end

 

myrouter# end

(任意)イネーブル EXEC モードに戻ります。

イネーブル パスワードとイネーブル シークレット パスワードの設定

特にネットワークを通過する、または Trivial File Transfer Protocol(TFTP; 簡易ファイル転送プロトコル)サーバに保存されるパスワードにより強力なセキュリティを設定するには、 enable password コマンドまたは enable secret コマンドのいずれかを使用できます。どちらのコマンドも、同じ結果をもたらします。つまり、イネーブル EXEC(イネーブル)モードへのアクセスに入力が必要な、暗号化されたパスワードを設定できます。

enable secret コマンドは改良された暗号化アルゴリズムを使用するので、このコマンドを使用することが推奨されます。 enable password コマンドは、Cisco IOS ソフトウェアの古いイメージを使用する場合、または enable secret コマンドを認識しない古いブート ROM を起動する場合に使用します。

詳細については、『 Cisco IOS Security Configuration Guide 』の「Configuring Passwords and Privileges」を参照してください。『 Cisco IOS Password Encryption Facts 』テクニカル ノートおよび『 Improving Security on Cisco Routers 』テクニカル ノートも参照してください。

制約事項

enable secret コマンドを設定すると、このコマンドが enable password コマンドよりも優先されます。これら 2 つのコマンドは同時には機能できません。

要約手順

1. enable

2. configure terminal

3. enable password パスワード

4. enable secret パスワード

5. end

6. enable

7. end

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

プロンプトが表示された場合、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

enable password password

 

Router(config)# enable password pswd2

(任意)ローカル パスワードを設定して、さまざまなイネーブル レベルへのアクセスを制御します。

この手順は、Cisco IOS ソフトウェアの古いイメージを起動する場合、または enable secret コマンドを認識しない古いブート ROM を起動する場合だけ実行することが推奨されます。

ステップ 4

enable secret password

 

Router(config)# enable secret greentree

enable password コマンドよりも強力なセキュリティを指定します。

ステップ 3 で入力したパスワードと同じものは使用しないでください。

ステップ 5

end

 

Router(config)# end

イネーブル EXEC モードに戻ります。

ステップ 6

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

新しいイネーブル パスワードまたはイネーブル シークレット パスワードが機能することを確認します。

ステップ 7

end

 

Router(config)# end

(任意)イネーブル EXEC モードに戻ります。

コンソールのアイドル イネーブル EXEC タイムアウトの設定

ここでは、コンソール回線のアイドル イネーブル EXEC タイムアウトの設定方法について説明します。デフォルトでは、イネーブル EXEC コマンド インタープリタは、タイム アウトになるまでに 10 分間待機してユーザ入力を検出します。

コンソール回線を設定すると、使用する端末の通信パラメータの設定、自動ボー接続の指定、および端末動作パラメータの設定も行うことができます。コンソール回線の詳細については、『 Cisco IOS Configuration Fundamentals and Network Management Configuration Guide 』を参照してください。特に、「Configuring Operating Characteristics for Terminals」および「Troubleshooting and Fault Management」を参照してください。

要約手順

1. enable

2. configure terminal

3. line console 0

4. exec-timeout [ ]

5. end

6. show running-config

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

プロンプトが表示された場合、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line console 0

 

Router(config)# line console 0

コンソール回線を設定し、ライン コンフィギュレーション コマンド コレクション モードを開始します。

ステップ 4

exec-timeout minutes [ seconds ]

 

Router(config-line)# exec-timeout 0 0

アイドル イネーブル EXEC タイムアウトを設定します。これは、イネーブル EXEC コマンド インタープリタが、ユーザ入力を検出するまで待機する間隔です。

次の例は、タイムアウトをなしに設定する方法を示します。EXEC タイムアウト値を 0 に設定した場合、ルータが 1 度ログインすると、ログアウトしなくなります。disable コマンドを使用して手動でログ アウトせずにコンソールから離れようとした場合、セキュリティに影響を及ぼす可能性があります。

ステップ 5

end

 

Router(config)# end

イネーブル EXEC モードに戻ります。

ステップ 6

show running-config

 

Router(config)# show running-config

実行コンフィギュレーション ファイルを表示します。

アイドル イネーブル EXEC タイムアウトを適切に設定したことを確認します。

次の例では、コンソールのアイドル イネーブル EXEC タイムアウトを 2 分 30 秒に設定する方法を示します。

line console
exec-timeout 2 30
 

次の例では、コンソールのアイドル イネーブル EXEC タイムアウトを 10 秒に設定する方法を示します。

line console
exec-timeout 0 10

ギガビット イーサネット インターフェイスの設定

ここでは、ルータのイーサネット インターフェイスに IP アドレスおよびインターフェイスの記述を割り当てる方法について説明します。

ギガビット イーサネット インターフェイスに関する設定情報の詳細については、次の URL で『 Cisco IOS Interface and Hardware Component Configuration Guide 』の「Configuring LAN Interfaces」を参照してください。 http://www.cisco.com/en/US/docs/ios/12_2/interface/configuration/guide/icflanin.html

インターフェイス番号については、お使いのルータのソフトウェア コンフィギュレーション ガイドを参照してください。

要約手順

1. enable

2. show ip interface brief

3. configure terminal

4. interface { fastethernet | gigabitethernet } 0/ ポート

5. description 文字列

6. ip address IP アドレス マスク

7. no shutdown

8. end

9. show ip interface brief

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

プロンプトが表示された場合、パスワードを入力します。

ステップ 2

show ip interface brief

 

Router# show ip interface brief

IP に設定するインターフェイスの簡単なステータスを表示します。

ルータのイーサネット インターフェイスのタイプを調べます。

ステップ 3

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

interface { fastethernet | gigabitethernet } 0/ port

 

Router(config)# interface gigabitethernet 0/0

イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

(注) インターフェイス番号については、ソフトウェア コンフィギュレーション ガイドを参照してください。

ステップ 5

description string

 

Router(config-if)# description GE int to 2nd floor south wing

(任意)インターフェイス コンフィギュレーションに記述を追加します。

記述によって、このインターフェイスに何が接続されているのかがわかりやすくなります。この記述は、トラブルシューティングに役立ちます。

ステップ 6

ip address ip-address mask

 

Router(config-if)# ip address 172.16.74.3 255.255.255.0

ステップ 7

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 8

end

 

Router(config)# end

イネーブル EXEC モードに戻ります。

ステップ 9

show ip interface brief

 

Router# show ip interface brief

IP に設定するインターフェイスの簡単なステータスを表示します。

イーサネット インターフェイスがアップ状態であること、および正しく設定されていることを確認します。

ギガビット イーサネット インターフェイスの設定:例

!
interface GigabitEthernet0/0
description GE int to HR group
ip address 172.16.3.3 255.255.255.0
duplex auto
speed auto
no shutdown
!

show ip interface brief コマンドの出力例

Router# show ip interface brief
 
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 172.16.3.3 YES NVRAM up up
GigabitEthernet0/1 unassigned YES NVRAM administratively down down
Router#

デフォルト ルートまたはラスト リゾート ゲートウェイの指定

ここでは、IP ルーティングをイネーブルにして、デフォルト ルートを指定する方法について説明します。その他のデフォルト ルートの指定方法については、『 Configuring a Gateway of Last Resort Using IP Commands 』テクニカル ノートを参照してください。

Cisco IOS ソフトウェアは、パケットに適切なルートが他にない場合や宛先がネットワークに接続されていない場合に、ラスト リゾート ゲートウェイ(ルータ)を使用します。ここでは、デフォルト ルート(ラスト リゾート ゲートウェイ計算の候補ルート)としてネットワークを選択する方法について説明します。ルーティング プロトコルがデフォルト ルート情報を伝播する方法はプロトコルによってさまざまです。

IP ルーティングと IP プロトコルの計算

IP ルーティングおよび IP ルーティング プロトコルに関する設定情報の詳細については、次の URL の Cisco.com で提供される『 Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4T 』を参照してください http://www.cisco.com/en/US/docs/ios/iproute/configuration/guide/12_4t/irp_12_4t_book.html

IP ルーティング

Inegrated Routing and Bridging(IRB)を設定して、ルータがルーティングとブリッジングを同時に行うことができます。ルータは、ルーティングがイネーブルかどうかに関係なく、ネットワーク上で IP ホストとして機能します。IRB の詳細については、次の URL の Cisco.com を参照してください。 http://www.cisco.com/en/US/tech/tk389/tk815/tk855/tsd_technology_support_sub-protocol_home.html

Cisco IOS ソフトウェアでは、IP ルーティングは自動的にイネーブルになります。IP ルーティングが設定されている場合、システムは、設定されたデフォルト ルートを含む、設定されたまたは学習されたルートを使用してパケットを転送します。


) このタスク セクションは、IP ルーティングがディセーブルの場合には該当しません。IP ルーティングがディセーブルの場合にデフォルト ルートを指定するには、Cisco.com で提供されている『Configuring a Gateway of Last Resort Using IP Commands』テクニカル ノートを参照してください。


デフォルト ルート

ルータは、他のすべてのネットワークへのルートを判別できない場合があります。完全なルーティング機能を提供するには、通常、一部のルータをスマート ルータとして使用し、残りのルータのデフォルト ルートをスマート ルータ宛に指定します (スマート ルータには、インターネットワーク全体のルーティング テーブル情報が格納されます)。これらのデフォルト ルートはダイナミックに転送できるか、ルータごとに設定できます。

ほとんどのダイナミックな内部ルーティング プロトコルには、スマート ルータを使用してダイナミックなデフォルト情報を生成し、他のルータに転送するメカニズムがあります。

デフォルト ネットワーク

指定されたデフォルト ネットワークに直接接続されたインターフェイスがルータに存在する場合は、そのルータ上で動作するダイナミック ルーティング プロトコルによってデフォルト ルートが生成または提供されます。RIP の場合、疑似ネットワーク 0.0.0.0 がアドバタイズされます。IGRP の場合は、ネットワーク自体がアドバタイズされ、外部ルートとしてフラグが付けられます。

ネットワークのデフォルトを生成しているルータには、そのルータ自身のデフォルト ルートも指定する必要があります。ルータが自身のデフォルト ルートを生成できる方法の 1 つは、適切な装置を経由してネットワーク 0.0.0.0 に至るスタティック ルートを指定することです。

ラスト リゾート ゲートウェイ

デフォルト情報がダイナミック ルーティング プロトコルを使用して転送される場合、追加設定は不要です。システムによってルーティング テーブルが定期的にスキャンされ、最適なデフォルト ネットワークがデフォルト ルートとして選択されます。RIP の場合、ネットワーク 0.0.0.0 以外の選択肢はありません。IGRP の場合は、システム デフォルトの候補となり得るネットワークが複数存在することがあります。Cisco IOS ソフトウェアは、管理ディスタンスとメトリック情報の両方を使用してデフォルト ルート(ラスト リゾート ゲートウェイ)を決定します。選択されたデフォルト ルートは、 show ip route EXEC コマンドのラスト リゾート ゲートウェイに表示されます。

ダイナミック デフォルト情報がソフトウェアに渡されていない場合、 ip default-network グローバル コンフィギュレーション コマンドでデフォルト ルートの候補が指定されます。この場合、 ip default-network コマンドは、接続されていないネットワークを引数として使用します。任意のソース(ダイナミックまたはスタティック)のルーティング テーブルにこのネットワークが表示される場合、デフォルト ルートの候補としてフラグが付けられ、デフォルト ルートの選択肢となります。

デフォルト ネットワーク上にルータのインターフェイスが存在しないものの、ネットワークへのルートが存在する場合、このネットワークは、デフォルト パスの候補と見なされます。管理ディスタンスおよびメトリックに基づいてルート候補が検討され、最適なルートが選択されます。最適なデフォルト パスへのゲートウェイが、ラスト リゾート ゲートウェイになります。

要約手順

1. enable

2. configure terminal

3. ip routing

4. ip route 宛先プレフィクス マスク ネクスト ホップの IP アドレス [ 管理ディスタンス ] [ permanent ]

5. ip default-network ネットワーク番号
または
ip route 宛先プレフィクス マスク ネクスト ホップの IP アドレス

6. end

7. show ip route

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

プロンプトが表示された場合、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip routing

 

Router(config)# ip routing

IP ルーティングをイネーブルにします。

ステップ 4

ip route dest-prefix mask next-hop-ip-address [ admin-distance ] [ permanent ]

 

Router(config)# ip route 192.168.24.0 255.255.255.0 172.28.99.2

スタティック ルートを確立します。

ステップ 5

ip default-network network-number

または

ip route dest-prefix mask next-hop-ip-address

 

Router(config)# ip default-network 192.168.24.0

 

Router(config)# ip route 0.0.0.0 0.0.0.0 172.28.99.1

ラスト リゾート ゲートウェイ計算用の候補ルートとしてネットワークを 1 つ選択します。

ラスト リゾート ゲートウェイ計算用にネットワーク 0.0.0.0 0.0.0.0 へのスタティック ルートを作成します。

ステップ 6

end

 

Router(config)# end

イネーブル EXEC モードに戻ります。

ステップ 7

show ip route

 

Router# show ip route

現在のルーティング テーブル情報を表示します。

ラスト リゾート ゲートウェイが設定されていることを確認します。

デフォルト ルートの指定:例

!
ip routing
!
ip route 192.168.24.0 255.255.255.0 172.28.99.2
!
ip default-network 192.168.24.0
!

show ip route コマンドの出力例

Router# show ip route
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
Gateway of last resort is 172.28.99.2 to network 192.168.24.0
 
172.24.0.0 255.255.255.0 is subnetted, 1 subnets
C 172.24.192.0 is directly connected, FastEthernet0
S 172.24.0.0 255.255.0.0 [1/0] via 172.28.99.0
S* 192.168.24.0 [1/0] via 172.28.99.2
172.16.0.0 255.255.255.0 is subnetted, 1 subnets
C 172.16.99.0 is directly connected, FastEthernet1
Router#

リモート コンソール アクセス用の仮想端末回線の設定

Virtual Terminal(vty; 仮想端末)回線を使用することにより、ルータへのリモート アクセスが可能になります。ここでは、仮想端末回線を設定してパスワードを指定し、許可されたユーザだけがルータにリモート アクセスできるようにする方法について説明します。

ルータにはデフォルトで 5 つの仮想端末回線が設定されています。ただし、『Cisco IOS Terminal Services Configuration Guide, Release 12.4』に記載されているように追加の仮想端末回線を作成できます。 「Configuring Terminal Operating Characteristics for Dial-In Sessions 」を参照してください。

回線パスワードおよびパスワードの暗号化については、『Cisco IOS Security Configuration Guide, Release 12.4』に記載されています。「 Security with Passwords, Privilege Levels, and Login Usernames for CLI Sessions on Networking Devices 」を参照してください。アクセス リストを使用して vty 回線のセキュリティを強化する場合は、『 Access Control Lists: Overview and Guidelines 』を参照してください。『 Cisco IOS Password Encryption Facts 』テクニカル ノートも参照してください。

要約手順

1. enable

2. configure terminal

3. line vty 回線番号 [ 最終回線番号 ]

4. password パスワード

5. login

6. end

7. show running-config

8. 他のネットワーク装置デバイスから、ルータへの Telnet セッションを開きます。

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

プロンプトが表示された場合、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line vty line-number [ ending-line-number ]

 

Router(config)# line vty 0 4

リモート コンソール アクセス用の仮想端末回線(vty)のライン コンフィギュレーション コマンド コレクション モードを開始します。

ルータ上のすべての vty 回線を設定したことを確認します。

コマンドを使用します。

ステップ 4

password password

 

Router(config-line)# password guessagain

回線にパスワードを指定します。

ステップ 5

login

 

Router(config-line)# login

ログイン時のパスワード チェックをイネーブルにします。

ステップ 6

end

 

Router(config-line)# end

イネーブル EXEC モードに戻ります。

ステップ 7

show running-config

 

Router# show running-config

実行コンフィギュレーション ファイルを表示します。

リモート アクセス用の仮想端末回線が正しく設定されていることを確認します。

ステップ 8

ルータにリモート アクセスできること、および仮想端末回線のパスワードが正しく設定されていることを確認します。

次の例は、仮想端末回線を設定し、パスワードを指定する方法を示します。

!
line vty 0 4
password guessagain
login
!

次の作業

vty 回線を設定したら、次の手順に従います。

(任意)仮想端末回線のパスワードを暗号化するには、『 Cisco IOS Security Configuration Guide 』の「Configuring Passwords and Privileges」を参照してください。『 Cisco IOS Password Encryption Facts 』テクニカル ノートも参照してください。

(任意)アクセス リストを使用して vty 回線のセキュリティを強化するには、『 Cisco IOS Security Configuration Guide 』の「Part 3: Traffic Filtering and Firewalls」を参照してください。

補助回線の設定

ここでは、補助回線のライン コンフィギュレーション モードの開始方法について説明します。補助回線の設定方法は、補助(AUX)ポートの実装によって異なります。補助回線の設定については、次のドキュメントを参照してください。

Configuring a Modem on the AUX Port for EXEC Dialin Connectivity 』テクニカル ノート

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_tech_note09186a0080094bbc.shtml

Configuring Dialout Using a Modem on the AUX Port 』コンフィギュレーション例

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094579.shtml

Configuring AUX-to-AUX Port Async Backup with Dialer Watch 』コンフィギュレーション例

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080093d2b.shtml

Modem-Router Connection Guide 』テクニカル ノート

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_tech_note09186a008009428b.shtml

要約手順

1. enable

2. configure terminal

3. line aux 0

4. AUX ポートの実装に応じた回線の設定方法については、テクニカル ノートおよびコンフィギュレーション例を参照してください。

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

プロンプトが表示された場合、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line aux 0

 

Router(config)# line aux 0

AUX 回線のライン コンフィギュレーション コマンド コレクション モードを開始します。

ステップ 4

AUX ポートの実装に応じた回線の設定方法については、テクニカル ノートおよびコンフィギュレーション例を参照してください。

--

ネットワーク接続の確認

ここでは、ルータのネットワーク接続の確認方法について説明します。

前提条件

このマニュアルにこれまで記載されたすべての設定タスクを完了している。

適切に設定したネットワーク ホストにルータを接続している。

要約手順

1. enable

2. ping [ IP アドレス | ホスト名 ]

3. telnet { IP アドレス | ホスト名 }

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

プロンプトが表示された場合、パスワードを入力します。

ステップ 2

ping [ ip-address | hostname ]

 

Router# ping 172.16.74.5

ネットワークの初期接続を診断します。

接続を確認するために、設定されている各インターフェイスのネクスト ホップ ルータまたは接続先ホストに ping を送信します。

ステップ 3

telnet { ip-address | hostname }

 

Router# telnet 10.20.30.40

Telnet をサポートするホストにログインします。

vty 回線のパスワードをテストする場合は、別のネットワーク装置から、そのルータの IP アドレスを使用して、この手順を実行します。

IPアドレス 192.168.7.27 に ping を送信した場合の ping コマンドの出力例を次に示します。

Router# ping
 
Protocol [ip]:
Target IP address: 192.168.7.27
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.27, timeout is 2 seconds:
!!!!!
Success rate is 100 percent, round-trip min/avg/max = 1/2/4 ms
 

IPホスト名 donald に ping を送信した場合の ping コマンドの出力例を示します。

Router# ping donald
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.27, timeout is 2 seconds:
!!!!!
Success rate is 100 percent, round-trip min/avg/max = 1/3/4 ms

ルータ コンフィギュレーションの保存

ここでは、実行コンフィギュレーションを Nonvolatile Random-Access Memory(NVRAM; 不揮発性 RAM)内のスタートアップ コンフィギュレーションに保存することにより、次回のシステム リロード時または次回の電源の再投入時にコンフィギュレーションが失われないようにする方法について説明します。NVRAM は、256KB の記憶域をルータに提供します。

要約手順

1. enable

2. copy running-config startup-config

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

プロンプトが表示された場合、パスワードを入力します。

ステップ 2

copy running-config startup-config

 

Router# copy running-config startup-config

実行コンフィギュレーションをスタートアップ コンフィギュレーションに保存します。

コンフィギュレーションおよびシステム イメージのバックアップ コピーの保存

ファイル破損時のファイル リカバリを円滑にし、ダウンタイムを最小限に抑えるために、サーバ上のスタートアップ コンフィギュレーション ファイルおよび Cisco IOS ソフトウェアのシステム イメージ ファイルのバックアップ コピーを保存することが推奨されます。

要約手順

1. enable

2. copy nvram:startup-config { ftp: | rcp: | tftp: }

3. show {flash0|flash1}:

4. copy {flash0|flash1}: { ftp: | rcp: | tftp: }

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

イネーブル EXEC モードをイネーブルにします。

プロンプトが表示された場合、パスワードを入力します。

ステップ 2

copy nvram:startup-config { ftp: | rcp: | tftp: }

 

Router# copy nvram:startup-config ftp:

スタートアップ コンフィギュレーション ファイルをサーバにコピーします。

コンフィギュレーション ファイルのコピーはバックアップ コピーとして機能できます。

プロンプトが表示されたら、コピー先の URL を入力します。

ステップ 3

show {flash0|flash1}:

 

Router# show {flash0|flash1} :

フラッシュ メモリ ファイル システムのレイアウトおよび内容を表示します。

システム イメージ ファイルの名前を調べます。

ステップ 4

copy {flash0|flash1}: { ftp: | rcp: | tftp: }

 

Router# copy {flash0|flash1}: ftp :

フラッシュ メモリからサーバにファイルをコピーします。

バックアップ コピーとして機能するシステム イメージ ファイルを、サーバにコピーします。

プロンプトが表示されたら、ファイル名とコピー先の URL を入力します。

TFTP サーバへのスタートアップ コンフィギュレーションのコピー:例

次の例では、TFTP サーバにスタートアップ コンフィギュレーションをコピーします。

Router# copy nvram:startup-config tftp:
 
Remote host[]? 172.16.101.101
 
Name of configuration file to write [rtr2-confg]? <cr>
Write file rtr2-confg on host 172.16.101.101?[confirm] <cr>
![OK]

フラッシュ メモリから TFTP サーバへのコピー:例

次の例では、イネーブル EXEC で show {flash0|flash1}: コマンドを使用してシステム イメージ ファイルの名前を調べ、 copy {flash0|flash1}: tftp: イネーブル EXEC コマンドを使用してシステム イメージ(c3900-2is-mz)を TFTP サーバにコピーします。このルータでは、デフォルトのユーザ名とパスワードが使用されます。

Router# show {flash0|flash1}:
 
System flash directory:
File Length Name/status
1 4137888 c3900-c2is-mz
[4137952 bytes used, 12639264 available, 16777216 total]
16384K bytes of processor board System flash (Read/Write)\
 
Router# copy {flash0|flash1}: tftp:
 
IP address of remote host [255.255.255.255]? 172.16.13.110
filename to write on tftp host? c3900-c2is-mz
writing c3900-c2is-mz !!!!...
successful ftp write.

) 完了した作業が失われないように、作業中に何度かコンフィギュレーションを保存してください。NVRAM にコンフィギュレーションを保存するには、copy running-config startup-config コマンドを使用します。


初期設定の確認

Cisco IOS で次のコマンドを入力して、ルータの初期設定を確認します。

show version :システム ハードウェアのバージョン、インストールされているソフトウェアのバージョン、コンフィギュレーション ファイルの名前とソース、ブート イメージ、搭載されている DRAM、NVRAM、およびフラッシュ メモリの容量が表示されます。

show diag :搭載されているコントローラ、インターフェイス プロセッサ、およびポート アダプタに関する診断情報が表示されます。

show interfaces :インターフェイスが正常に動作し、インターフェイスと回線プロトコルが正しい状態(アップまたはダウン)になっていることが表示されます。

show ip interface brief: IP プロトコル用に設定されたインターフェイスのサマリー ステータスが表示されます。

show configuration: 正しいホスト名とパスワードが設定されていることを確認します。

初期設定を完了して確認すると、特定の機能を設定する準備が整います。Cisco 1900 シリーズ、2900 シリーズ、および 3900 シリーズのソフトウェア コンフィギュレーション ガイドを参照してください。


) インターフェイス番号およびポート番号について不明点がある場合は、「インターフェイス番号」を参照してください。