ルータ : Cisco 1900 シリーズ サービス統合型ルータ

Cisco ISR G2 Multi Gigabit Fabric

Cisco ISR G2 Multi Gigabit Fabric
発行日;2013/01/14 | 英語版ドキュメント(2011/07/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco ISR G2 Multi Gigabit Fabric

内容

MGF について

MGF を設定する前に

Cisco IOS Release 15.1(3)T よりも前のリリースでの MGF

Cisco IOS Release 15.1(3)T 以降のリリースでの MGF

Cisco IOS Release 15.1(3)T の実行コンフィギュレーションへの変更

制約事項 

Cisco IOS Release 15.1(3)T 以降のリリースの Cisco SRE での MGF インターフェイスの設定

Cisco IOS Release 15.1(3)T 以降のリリースの Cisco SRE での MGF インターフェイスの設定:例

Cisco SRE コンフィギュレーション

Cisco Enhanced EtherSwitch サービス モジュールの設定

Cisco Gigabit EtherSwitch EHWIC の設定

Cisco Enhanced EtherSwitch サービス モジュールでの MGF の設定

既存の MGF インターフェイスの再設定

MGF インターフェイスの再設定が必要ない場合

MGF インターフェイスを再設定する必要がある場合

参考資料

関連資料

シスコのテクニカル サポート

Cisco ISR G2 Multi Gigabit Fabric

初版発行日:2010 年 11 月 5 日
最終更新日:2011 年 7 月 25 日

 

Multi-Gigabit Fabric(MGF)機能により、ルータの CPU を介さずに、ルータの 1 つまたは複数のモジュールが相互に通信できます。MGF 機能は次のモジュールでサポートされています。

Cisco SRE Internal Service Module-Services Ready Engine(Cisco SRE ISM)

Cisco SRE Service Module-Services Ready Engine(Cisco SRE SM)

Cisco Enhanced EtherSwitch サービス モジュール(Cisco SM-ES および Cisco SM-ES-D)

このマニュアルでは、Cisco IOS Release 15.1(3)T 以降のソフトウェア リリースを実行している Cisco Integrated Services Routers Generation 2(Cisco ISR G2)の MGF 設定について説明します。以前のソフトウェア リリースを実行する Cisco ISR G2 での MGF 設定の詳細については、『 Cisco SRE Service Module Configuration and Installation Guide 』を参照してください。

MGF について

MGF は、このマニュアルの最初にリストされているモジュールを含むルータ内の多くのデバイスと CPU を接続する GigabitEthernet スイッチです。図 1 に示すように、MGF がないと、ルータ内のデバイス間のすべての通信に CPU が関与します。

図 1 MGF 以前の ISR-G2 ハードウェア アーキテクチャ

 

MGF を使用すると、CPU はオフロードされ、他の目的に使用できるようになります。モジュールは、ルータ CPU を介さずに互いに通信できます。図 2 は、MGF を介した Cisco ISR G2 のモジュール間の通信を示します。

図 2 MGF と ISR-G2 ハードウェア アーキテクチャ

 

図 3 は、MGF を介した、異なるモジュールのアプリケーション間のパケット フローを示します。

図 3 MGF を介したパケット フローの例

 

Cisco IOS Release 15.1(3)T よりも前のリリースでは、 slot /1 インターフェイスが作成され、インターフェイスに IP アドレスを割り当てることができます。その後、High-Speed Intrachassis Module Interconnect(HIMI)接続または VLAN 接続を使用して、MGF スイッチを介して別のモジュールに接続します。

Cisco IOS Release 15.1(3)T 以降のリリースでは、Cisco SRE SM モジュールの動作が異なります。デフォルトでは、 slot /1 インターフェイスは、switch-pm で管理されるようになりました。その結果、MGF インターフェイスはスイッチ ポートのように動作し、デフォルトで VLAN 1 を作成します。VLAN 1 は、ルータに挿入されるスイッチ モジュールがある場合に、デフォルトで作成されます。これに対する例外は、独立したエンティティとして動作する別のスイッチの Cisco IOS ソフトウェアがあるため、すべての Cisco EtherSwitch サービス モジュールが VLAN 1 をデフォルトで作成しない場合です。

HIMI 接続は、Cisco IOS Release 15.1(3)T 以降のリリースの MGF インターフェイスではサポートされません。ルータにレガシー スイッチ モジュールの Cisco EtherSwitch HWIC または Cisco EtherSwitch ネットワーク モジュールがすでに設定されている場合、 slot /1 インターフェイスは、Cisco IOS Release 15.1(3)T よりも前のリリースと同様に動作し、IP アドレスをインターフェイスに割り当てることができます。HIMI または VLAN 接続は、上記のようにモジュール間の接続に使用できます。

表 1 は、MGF を使用したモジュール間の互換性を示します。

 

表 1 MGF を使用したモジュール間の互換性

Cisco EtherSwitch Network Module および
Cisco EtherSwitch HWIC
Cisco Enhanced EtherSwitch サービス モジュール
Cisco EtherSwitch Network Module および
Cisco EtherSwitch HWIC

サポート。外部スタックが必要。2 つのスイッチ モジュールに制限。

サポート。必要な場合は、外部トランキングが必要。接続は必要なし。

Cisco Enhanced EtherSwitch サービス モジュール

サポート。必要な場合は、外部トランキングが必要。接続は必要なし。

サポート。必要な場合は外部トランキング可能。

Cisco SRE ISM および Cisco SRE SM

サポートされていません。SRE 機能は制限付き。モジュールとの互換性なし。

デフォルトは、Cisco IOS Release 15.1(3)T 以前の動作。

サポート。

表 2 は、このマニュアルに記載されているモジュールの SKU を示します。

 

表 2 モジュールの名前および SKU

モジュール
SKU

Cisco EtherSwitch HWIC

HWIC-4ESW、HWIC-4ESW-C、

HWIC-D-9ESW、HWIC-D-9ESW-C

Cisco Gigabit Etherswitch EHWIC

EHWIC-4ESG、EHWIC-4ESG-P、

EHWIC-D-8ESG、EHWIC-D-8ESG-P

Cisco EtherSwitch ネットワーク モジュール

NM-16ESW

Cisco Enhanced EtherSwitch

SM-ES2-16-P、SM-ES3-16-P、

SM-ES3G-16-P、SM-ES2-24、

SM-ES2-24-P、SM-ES3-24-P、

SM-ES3G-24-P、SM-D-ES2-48、

SM-D-ES3-48-P、SM-D-ES3G-48-P

Cisco EtherSwitch サービス モジュール

NME-16ES-1G、NME-16ES-1G-P、NME-X-23ES-1G、NME-X-23ES-1G-P、NME-XD-24ES-1S-P、NME-XD-48ES-2S-P

MGF を設定する前に

MGF 機能の設定は、Cisco IOS Release 15.1(3)T で変更されました。MGF を設定する前に、MGF を Cisco IOS Release 15.1(3)T よりも前のリリースで設定することと、次のセクションで説明する Cisco IOS Release 15.1(3)T 以降のリリースで設定することの違いを理解する必要があります。

「Cisco IOS Release 15.1(3)T よりも前のリリースでの MGF」

「Cisco IOS Release 15.1(3)T 以降のリリースでの MGF」

「Cisco IOS Release 15.1(3)T の実行コンフィギュレーションへの変更」

「制約事項 」

Cisco IOS Release 15.1(3)T よりも前のリリースでの MGF

Cisco IOS Release 15.1(3)T よりも前のリリースでは、MGF インターフェイスはレイヤ 3 ポートで、IP アドレスを設定できます。IP アドレスが MGF インターフェイスに設定されている場合は、High-Speed Intrachassis Module Interconnect(HIMI)接続と VLAN 接続を設定して、ルータ内のデバイス間の通信を可能にできます。

Cisco IOS Release 15.1(3)T 以降のリリースでの MGF

Cisco IOS Release 15.1(3)T 以降のリリースでは、MGF インターフェイスはレイヤ 2 ポートで、IP アドレスは設定できません。MGF インターフェイスは SRE SM では interface sm slot /1 と呼ばれ、SRE ISM では ism 0/1 と呼ばれます。MGF インターフェイスは Cisco Enhanced EtherSwitch サービス モジュールでは interface GigabitEthernet slot /1 と呼ばれます。これらのインターフェイスはレイヤ 2 インターフェイスで、トランク モードに設定して、複数の VLAN トラフィックが流れるようにできます。また、これらのインターフェイスをアクセス VLAN として設定して、1 つの VLAN だけを明示的に許可できます。

MGF 機能には 2 つの部分があります。

SRE SM および SRE ISM と動作するように設計されている service-module mgf コマンド。これらのコマンドの詳細については、次の URL の『 Cisco IOS Interface and Hardware Component Command Reference 』を参照してください。

http://www.cisco.com/en/US/docs/ios/interface/command/reference/ir_book.html

SRE SM、SRE ISM、および Cisco Enhanced EtherSwitch サービス モジュールでトランクまたはアクセス モードを設定するためのレイヤ 2 スイッチ インターフェイス。

MGF インターフェイスはレイヤ 2 スイッチ ポートで、VLAN の一部である必要があります。Cisco IOS Release 15.1(3)T よりも前のリリースでは、SRE SM および SRE ISM の場合のみ、MGF インターフェイスに IP アドレスを設定できます。Cisco IOS Release 15.1(3)T 以降では、デフォルト VLAN(VLAN 1)が自動的に作成されます。VLAN 1 に IP アドレスを設定します。これらのレイヤ 2 インターフェイスでは、一部のコマンドだけでスイッチ モードをトランクまたはアクセスに設定できます。その他のレイヤ 2 機能のサポートは、このマニュアルで明示的に指定されていない場合は使用できません。

Cisco IOS Release 15.1(3)T の実行コンフィギュレーションへの変更

Cisco ISR G2 で Cisco IOS Release 15.1(3)T よりも前のリリースを実行中で、既存の MGF インターフェイスが設定されている場合に、Cisco IOS Release 15.1(3)T 以降のリリースにアップグレードすると、 slot /1 インターフェイスに設定されている IP アドレスと、そのインターフェイスのその他の設定は実行コンフィギュレーションに表示されません。新しいデフォルト VLAN 1 の設定が実行コンフィギュレーションに表示されます。

Cisco ISR G2 で Cisco IOS Release 15.1(3)T 以降のリリースを実行中で、Cisco Enhanced EtherSwitch サービス モジュールが含まれている場合、新しい GigabitEthernet slot /1 のインターフェイスと、新しいデフォルト VLAN 1 の設定が実行コンフィギュレーションに表示されます。

制約事項 

MGF 機能は、次のモジュールでのみ使用可能です。

Cisco SRE ISM

Cisco SRE SM

Cisco Enhanced EtherSwitch サービス モジュール(Cisco SM-ES および Cisco SM-ES-D)

Cisco EtherSwitch HWIC および Cisco EtherSwitch サービス ネットワーク モジュールがシステムに存在しない場合、HIMI 接続または VLAN 接続は、Cisco Enhanced EtherSwitch サービス モジュールおよび SRE では使用できません。システム内のいずれの Cisco EtherSwitch サービス モジュールとの接続にも、HIMI または VLAN を使用できません。

VLAN の最大数は 64 です(ネイティブ VLAN を含めない)。

SM は VLAN 1 をネイティブ VLAN としてのみ使用できます。このネイティブ制限は Cisco Enhanced EtherSwitch サービス モジュールには適用されません。

PVDM は同じ VLAN にあっても他のモジュールと通信できません。Cisco Enhanced EtherSwitch サービス モジュールおよび Cisco Gigabit EtherSwitch EHWIC ポートは、外部ケーブルなしで通信できます。Cisco 1941 のみが WLAN をサポートします。

service-module mgf コマンドは、Linux アプリケーションが MGF 機能をサポートする場合にのみ表示されます。Linux アプリケーションのマニュアルを参照して、MGF がサポートされるかどうかを確認してください。

VLAN を作成して VLAN データベースに保存することは、Cisco EtherSwitch HWIC や Cisco EtherSwitch ネットワーク モジュールなどのレガシー スイッチ モジュールがあることと同じです。

ルータで Cisco IOS Release 15.2(1)T よりも前の Cisco IOS のリリースを実行している場合、
Cisco SRE SM、Cisco SRE ISM、または Cisco Enhanced EtherSwitch サービス モジュールの MGF 機能によって、活性挿抜(OIR)がサポートされません。これらの Cisco IOS の以前のリリースのいずれかを使用する場合は、OIR 後にルータをリロードする必要があります。

Cisco IOS Release 15.1(3)T 以降のリリースの Cisco SRE での MGF インターフェイスの設定

ルータに Cisco SRE SM、Cisco SRE ISM、または Cisco Enhanced EtherSwitch サービス モジュールだけが設定されたこの展開シナリオは、最も一般的です。

ネイティブ VLAN は、SRE MGF ポートがトランクとして設定されている場合に設定されます。デフォルトのネイティブ VLAN は VLAN 1 です。すべての VLAN 設定は、interface SM slot /1 で行われます。各 VLAN に複数の IP アドレスを割り当てる必要があります。

「Cisco IOS Release 15.1(3)T 以降のリリースの Cisco SRE での MGF インターフェイスの設定:例」

手順の概要

ホスト ルータの CLI より

1. enable

2. configure terminal

3. interface ism 0/0

または

interface sm 1/0

4. service-module mgf ip address module-side-ip-address subnet-mask

5. service-module mgf ip default-gateway gateway-ip-address

6. service-module mgf ip address module-side-ip-address subnet-mask vlan vlan-id

7. service-module mgf ip default-gateway gateway-ip-address vlan vlan-id

8. end

9. interface ism 0/1

または

interface sm 1/1

10. switchport mode trunk

11. end

12. interface ism 0/0

または

interface sm 2/0

13. service-module mgf ip address module-side-ip-address subnet-mask

14. service-module mgf ip default-gateway gateway-ip-address

15. service-module mgf ip address module-side-ip-address subnet-mask vlan vlan-id

16. service-module mgf ip default-gateway gateway-ip-address vlan vlan-id

17. end

18. interface ism 0/1

または

interface sm 2/1

19. switchport mode trunk

20. end

21. interface vlan 1

22. ip address ip-address mask

23. interface vlan 2

24. ip address ip-address mask

手順の詳細

コマンドまたはアクション
目的
 
ホスト ルータの CLI より

ステップ 1

enable

password

 

Router> enable

Password: password

Router#

ホスト ルータで特権 EXEC モードを開始します。パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

ホスト ルータでグローバル コンフィギュレーション モードを開始します。

ステップ 3

interface ism 0/0

 

または

interface sm 1 /0

 

Router(config)# interface ism 0/0

 

または

Router(config)# interface sm 1/0

Cisco ISM-SRE が装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

または

Cisco SM-SRE が装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

service-module mgf ip address module-side-ip-address subnet-mask

 

Router(config-if)# service-module mgf ip address 10.0.0.2

インターフェイスのモジュール側の IP アドレスを指定します。

この IP アドレスは、ネイティブ VLAN によって使用されます。

module-side-ip-address :モジュールの IP アドレスを示します。

subnet-mask :IP アドレスに付加するサブネット マスクであり、ホスト ルータと同じサブネットに属する必要があります。

ステップ 5

service-module mgf ip default-gateway gateway-ip-address

 

Router(config-if)# service-module mgf ip default-gateway 10.0.0.1

(任意)サービス モジュールのデフォルト ゲートウェイ(ルータ)を定義します。

gateway-ip-address :モジュールの IP アドレスを示します。

デフォルト ゲートウェイの IP アドレスが VLAN の IP アドレスと同じサブネット内にある必要はありません。

デフォルト ゲートウェイの IP アドレスはモジュールから到達可能でなければなりません。

ステップ 6

service-module mgf ip address module-side-ip-address subnet-mask vlan vlan-id

 

Router(config-if)# service-module mgf ip address 10.2.0.2 vlan 2

指定された VLAN のインターフェイスのモジュール側 IP アドレスを指定します。

module-side-ip-address :モジュールの IP アドレスを示します。

subnet-mask :IP アドレスに付加するサブネット マスクであり、ホスト ルータと同じサブネットに属する必要があります。

vlan vlan-id :割り当てる VLAN の数を示します。有効範囲は 2 ~ 4094 です。

ステップ 7

service-module mgf ip default-gateway gateway-ip-address vlan vlan-id

 

Router(config-if)# service-module mgf ip default-gateway 10.2.0.1 vlan 2

(任意)サービス モジュールのデフォルト ゲートウェイ(ルータ)を定義します。

gateway-ip-address :モジュールの IP アドレスを示します。

vlan vlan-id :割り当てる VLAN の数を示します。有効範囲は 2 ~ 4094 です。

ステップ 8

end

 

Router(config-if)# end

ホスト ルータのグローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface ism 0/1

 

または

interface sm 1/1

 

Router(config)# interface ism 0/1

 

または

Router(config)# interface sm 1/1

Cisco ISM-SRE が装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

または

Cisco SM-SRE が装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 10

switchport mode trunk

 

Router(config-if)# switchport mode trunk

トランキング VLAN レイヤ 2 のインターフェイス タイプを設定します。

ステップ 11

end

 

Router(config-if)# end

ホスト ルータのグローバル コンフィギュレーション モードに戻ります。

ステップ 12

interface ism 0/0

 

または

interface sm 2 /0

 

Router(config)# interface ism 0/0

 

または

Router(config)# interface sm 2/0

Cisco ISM-SRE が装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

または

Cisco SM-SRE が装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 13

service-module mgf ip address module-side-ip-address subnet-mask

 

Router(config-if)# service-module mgf ip address 10.0.0.3

インターフェイスのモジュール側の IP アドレスを指定します。

module-side-ip-address :モジュールの IP アドレスを示します。

subnet-mask :IP アドレスに追加するサブネット マスクで、ホスト ルータと同じサブネットにあることが必要

ステップ 14

service-module mgf ip default-gateway gateway-ip-address

 

Router(config-if)# service-module mgf ip default-gateway 10.0.0.1

(任意)サービス モジュールのデフォルト ゲートウェイ(ルータ)を定義します。

gateway-ip-address :モジュールの IP アドレスを示します。

デフォルト ゲートウェイの IP アドレスが VLAN の IP アドレスと同じサブネット内にある必要はありません。

デフォルト ゲートウェイの IP アドレスはモジュールから到達可能でなければなりません。

ステップ 15

service-module mgf ip address module-side-ip-address subnet-mask vlan vlan-id

 

Router(config-if)# service-module mgf ip address 10.2.0.3 vlan 2

インターフェイスのモジュール側の IP アドレスを指定します。

module-side-ip-address :モジュールの IP アドレスを示します。

subnet-mask :IP アドレスに付加するサブネット マスクであり、ホスト ルータと同じサブネットに属する必要があります。

vlan vlan-id :割り当てる VLAN の数を示します。有効範囲は 2 ~ 4094 です。

vlan が指定されていない場合、設定はネイティブ VLAN に適用されます。

ステップ 16

service-module mgf ip default-gateway gateway-ip-address vlan vlan-id

 

Router(config-if)# service-module mgf ip default-gateway 10.2.0.1 vlan 2

(任意)サービス モジュールのデフォルト ゲートウェイ(ルータ)を定義します。

gateway-ip-address :モジュールの IP アドレスを示します。

vlan vlan-id :割り当てる VLAN の数を示します。有効範囲は 2 ~ 4094 です。

ステップ 17

end

 

Router(config-if)# end

ホスト ルータのグローバル コンフィギュレーション モードに戻ります。

ステップ 18

interface ism 0/1

 

または

interface sm 2/1

 

Router(config)# interface ism 0/1

 

または

Router(config)# interface sm 2/1

Cisco ISM-SRE が装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

または

Cisco SM-SRE が装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 19

switchport mode trunk

 

Router(config-if)# switchport mode trunk

トランキング VLAN レイヤ 2 のインターフェイス タイプを設定します。

ステップ 20

end

 

Router(config-if)# end

ホスト ルータのグローバル コンフィギュレーション モードに戻ります。

ステップ 21

interface vlan 1

 

 

Router(config)# interface vlan 1

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 22

ip address ip-address mask

 

Router(config-if)# ip address 10.0.0.1 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 23

interface vlan 2

 

 

Router(config)# interface vlan 2

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 24

ip address ip-address mask

 

Router(config-if)# ip address 10.2.0.1 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

Cisco IOS Release 15.1(3)T 以降のリリースの Cisco SRE での MGF インターフェイスの設定:例

「Cisco SRE コンフィギュレーション」

「Cisco Enhanced EtherSwitch サービス モジュールの設定」

「Cisco Gigabit EtherSwitch EHWIC の設定」

Cisco SRE コンフィギュレーション

次に、Cisco EtherSwitch HWIC および Cisco EtherSwitch ネットワーク モジュールがネットワークに存在しない場合の、Cisco SRE 設定を示します。次の設定では、SM1 インターフェイスは VLAN 1 の MGF に接続され、SM2 インターフェイスは VLAN 2 の MGF に接続されます。SM は複数の VLAN のメンバーであるため、トランク モードが必要です。ネイティブ VLAN は、デフォルトで 1 に設定されます。

! SM 1
interface SM 1/0
service-module mgf ip address 10.0.0.2
service-module mgf ip default-gateway 10.0.0.1
service-module mgf ip address 10.2.0.2 vlan 2
service-module mgf ip default-gateway 10.2.0.1 vlan 2
 
interface SM 1/1
switchport mode trunk
 
! SM 2
! Defining a default gateway is optional.
interface SM 2/0
service-module mgf ip address 10.0.0.3
service-module mgf ip default-gateway 10.0.0.1
service-module mgf ip address 10.2.0.3 vlan 2
service-module mgf ip default-gateway 10.2.0.1 vlan 2
 
interface SM 2/1
switchport mode trunk
 
! Common configuration at the router level
interface vlan 1
ip address 10.0.0.1 255.255.255.0
 
interface vlan 2
ip address 10.2.0.1 255.255.255.0

Cisco Enhanced EtherSwitch サービス モジュールの設定

次に、Cisco EtherSwitch HWIC および Cisco EtherSwitch ネットワーク モジュールがネットワークに存在しない場合の、Cisco Enhanced EtherSwitch サービス モジュールの設定を示します。

interface GigabitEthernet1/1
switchport mode trunk
! Cisco Enhanced EtherSwitch Service Module port
! needs to be configured on Cisco Enhanced EtherSwitch Service Module
! side
 
! Common configuration at the router level
interface vlan 1
ip address 10.0.0.1 255.255.255.0
 
interface vlan 2
ip address 10.2.0.1 255.255.255.0
 

Cisco Gigabit EtherSwitch EHWIC の設定

次に、Cisco Gigabit EtherSwitch EHWIC の設定を示します。Cisco EtherSwitch HWIC および Cisco EtherSwitch ネットワーク モジュールは、Cisco Gigabit EtherSwitch EHWIC が存在するネットワークには使用できません。レガシー モジュールがルータに挿入されると、すべての新しい MGF コマンドが使用できなくなります。

! SM
interface SM 1/0
service-module mgf ip address 10.0.0.2
service-module mgf ip address 10.2.0.2 vlan 2
 
interface SM 1/1
switchport mode trunk
 
! Cisco Gigabit EtherSwitch EHWIC
interface GigabitEthernet 0/1/0
! Will communicate with application on VLAN 1 running on SRE in slot 1
 
interface GigabitEthernet 0/1/1
switchport access vlan 2
! Will communicate with application on VLAN 2 running on SRE in slot 1
 
interface GigabitEthernet 0/1/2
switchport mode trunk
! Will communicate with application on VLAN 1 & 2 running on SRE in slot 1
 
! Common configuration at the router level
interface vlan 1
ip address 10.0.0.1 255.255.255.0
 
interface vlan 2
ip address 10.2.0.1 255.255.255.0
 

Cisco Enhanced EtherSwitch サービス モジュールでの MGF の設定

Cisco IOS Release 15.1(3)T よりも前のリリースを実行する Cisco ISR G2 では、Cisco IOS ソフトウェアのコマンドラインから Cisco Enhanced EtherSwitch サービス モジュールで MGF を設定できません。MGF インターフェイスはユーザに非表示になっています。

Cisco IOS Release 15.1(3)T 以降のソフトウェアを実行する Cisco ISR G2 では、新しく作成された MGF インターフェイスを使用してトランクまたはアクセス モードを設定して、Cisco Enhanced EtherSwitch サービス モジュールから生成されたトラフィックを、他の Cisco Enhanced EtherSwitch サービス モジュールまたは VLAN インターフェイスに送ることができます。Cisco Enhanced EtherSwitch サービス モジュールを設定するには、製品マニュアルを参照してください。

Cisco IOS Release 15.1(3)T 以降のソフトウェア リリースを実行中の Cisco ISR G2 で、Cisco Enhanced EtherSwitch サービス モジュール側のポートを次のように設定できます。

interface GigabitEthernet1/1
switchport mode trunk
 
interface GigabitEthernet2/1
switchport mode trunk
 
interface vlan 1
ip address 10.0.0.1 255.255.255.0
 
interface vlan 2
ip address 10.2.0.1 255.255.255.0
 

既存の MGF インターフェイスの再設定

ルータで実行中の Cisco IOS ソフトウェア リリース、アップグレード対象リリース、およびルータ内のモジュールによっては、既存の MGF インターフェイスを再設定する必要がある場合があります。

MGF インターフェイスの再設定が必要ない場合

次のシナリオでは、MGF インターフェイスを再設定する必要はありません。

Cisco ISR G2 が次の状態の場合:

Cisco IOS Release 15.1(3)T よりも前のリリースを実行している。

Cisco EtherSwitch HWIC または Cisco EtherSwitch ネットワーク モジュールがある。

および

Cisco ISR G2 を Cisco IOS Release 15.1(3)T 以降のリリースにアップグレードする。

Cisco EtherSwitch HWIC または Cisco EtherSwitch ネットワーク モジュールを保持する。

MGF インターフェイスを再設定する必要はありません。

MGF インターフェイスを再設定する必要がある場合

次のシナリオでは、既存の MGF インターフェイスを再設定する必要があります。

シナリオ 1

Cisco ISR G2 が次の状態の場合:

Cisco IOS Release 15.1(3)T よりも前のリリースを実行している。

Cisco EtherSwitch HWIC または Cisco EtherSwitch ネットワーク モジュールがある。

および

Cisco ISR G2 を Cisco IOS Release 15.1(3)T 以降のリリースにアップグレードする。

Cisco EtherSwitch HWIC または Cisco EtherSwitch ネットワーク モジュールを削除する。

「Cisco IOS Release 15.1(3)T 以降のリリースの Cisco SRE での MGF インターフェイスの設定」で説明されているように、MGF インターフェイスを再設定する必要があります。

シナリオ 2

Cisco ISR G2 が次の状態の場合:

Cisco IOS Release 15.1(3)T よりも前のリリースを実行している。

Cisco EtherSwitch HWIC または Cisco EtherSwitch ネットワーク モジュールがない。

および

Cisco ISR G2 を Cisco IOS Release 15.1(3)T 以降のリリースにアップグレードする。

「Cisco IOS Release 15.1(3)T 以降のリリースの Cisco SRE での MGF インターフェイスの設定」で説明されているように、MGF インターフェイスを再設定する必要があります。

参考資料

ここでは、Cisco SM-SRE に関連する参考資料を示します。

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html