Cisco 1800 シリーズ ソフトウェア コンフィギュレーション
Cisco IOS コマンドライン インターフェイスを使用した基本的なソフトウェア コンフィギュレーション
Cisco IOS コマンドライン インターフェイスを使用した基本的なソフトウェア コンフィギュレーション
発行日;2012/12/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Cisco IOS コマンドライン インターフェイスを使用した基本的なソフトウェア コンフィギュレーション

内容

このマニュアルでサポートされるプラットフォーム

CiscoIOS CLI を使用した基本的なソフトウェア コンフィギュレーションのための前提条件

CiscoIOS CLI を使用した基本的なソフトウェア コンフィギュレーションの制限事項

CiscoIOS CLI を使用した基本的なソフトウェア コンフィギュレーションの実行方法

ルータのホスト名の設定

次の作業

イネーブルおよびイネーブル シークレット パスワードの設定

制約事項 

トラブルシューティングのヒント

次の作業

コンソールのアイドル特権 EXEC タイムアウトの設定

次の作業

ファスト イーサネット インターフェイスおよびギガビット イーサネット インターフェイスの設定

次の作業

デフォルト ルートまたはラスト リゾート ゲートウェイの指定

次の作業

リモート コンソール アクセスのための仮想端末回線の設定

次の作業

補助回線の設定

次の作業

ネットワーク接続の確認

前提条件

次の作業

ルータ設定の保存

次の作業

コンフィギュレーションおよびシステム イメージのバックアップ コピーの保存

次の作業

その他の参考資料

関連資料:基本的なソフトウェア コンフィギュレーション

関連資料:その他の設定

シスコのテクニカル サポート

Cisco IOS コマンドライン インターフェイスを使用した基本的なソフトウェア コンフィギュレーション

このマニュアルでは、Cisco IOS コマンドライン インターフェイス(CLI)を使用して、ルータの基本的なソフトウェア コンフィギュレーションを実行する方法を説明します。

このマニュアルでサポートされるプラットフォーム

このマニュアルは、次のプラットフォームに対して使用してください。

Cisco 1800 シリーズ ルータ

Cisco 2800 シリーズ ルータ

Cisco 3800 シリーズ ルータ

Cisco IOS CLI を使用した基本的なソフトウェア コンフィギュレーションのための前提条件

ルータに付属のクイック スタート ガイドの手順に従い、シャーシを設置し、ケーブルを接続し、ルータの電源をオンにしてください。


ワンポイント アドバイス AutoInstall プロセスが実行されないようにするため、ルータの電源をオンにする前に、ルータからすべての WAN ケーブルを外してください。WAN ケーブルが接続の両側のルータに取り付けられていて、ルータの NVRAM(不揮発性 RAM)に有効なコンフィギュレーション ファイルが保存されていない場合(新しいインターフェイスを追加する場合など)、ルータの電源をオンにすると、AutoInstall の実行が試行される可能性があります。AutoInstall がリモートの TCP/IP ホストに接続されていないとルータが判断するのに、数分間かかることもあります。


Cisco IOS CLI を使用した基本的なソフトウェア コンフィギュレーションの制限事項

ルータに Cisco Router and Security Device Manager(SDM)がインストールされている場合は、ソフトウェアの初期設定に Cisco IOS CLI ではなく Cisco SDM を使用することを推奨します。SDM にアクセスするには、ルータに付属のクイック スタート ガイドを参照してください。

Cisco IOS CLI を使用した基本的なソフトウェア コンフィギュレーションの実行方法

ここでは、次の手順について説明します。

「ルータのホスト名の設定」(任意)

「イネーブルおよびイネーブル シークレット パスワードの設定」 (必須)

「コンソールのアイドル特権 EXEC タイムアウトの設定」(任意)

「ファスト イーサネット インターフェイスおよびギガビット イーサネット インターフェイスの設定」 (必須)

「デフォルト ルートまたはラスト リゾート ゲートウェイの指定」 (必須)

「リモート コンソール アクセスのための仮想端末回線の設定」 (必須)

「補助回線の設定」(任意)

「ネットワーク接続の確認」 (必須)

「ルータ設定の保存」 (必須)

「コンフィギュレーションおよびシステム イメージのバックアップ コピーの保存」(任意)

ルータのホスト名の設定

ホスト名は CLI プロンプトとデフォルトの設定ファイル名に使用されます。ルータのホスト名を設定しないと、出荷時のデフォルトのホスト名である「Router」が使用されます。

ホスト名では、大文字と小文字が区別されるとは限りません。多くのインターネット ソフトウェア アプリケーションでは、大文字と小文字は同一に扱われます。通常実行するときに名前を大文字にすることは適切なこともありますが、表記法では、コンピュータ名はすべて小文字で表示されます。詳細については、RFC 1178 の「 Choosing a Name for Your Computer 」を参照してください。

名前は、Advanced Research Projects Agency Network(ARPANET)のホスト名に関する規則に従う必要があります。このルールではホスト名は文字で始まり、文字または数字で終わり、その間には文字、数字、またはハイフンしか使用できません。名前は 63 文字以下にする必要があります。詳細については、RFC 1035 の「 Domain Names--Implementation and Specification 」を参照してください。

手順の概要

1. enable

2. configure terminal

3. hostname name

4. ルータ プロンプトに新しいホスト名が表示されることを確認します。

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hostname name

 

Router(config)# hostname myrouter

ネットワーク サーバのホスト名を指定または修正します。

ステップ 4

ルータ プロンプトに新しいホスト名が表示されることを確認します。

 

myrouter(config)#

--

ステップ 5

end

 

myrouter# end

(任意)特権 EXEC モードに戻ります。

イネーブルおよびイネーブル シークレット パスワードの設定

セキュリティのレイヤを追加するには、特にネットワークを経由するパスワードまたは TFTP サーバに保存されるパスワードの場合、 enable password コマンドまたは enable secret コマンドを使用します。どちらのコマンドも同じ結果を達成します。つまり、特権 EXEC(イネーブル)モードにアクセスするために入力する必要がある、暗号化されたパスワードを設定できます。

より高度な暗号化アルゴリズムが使用されるので、 enable secret コマンドを使用することを推奨します。 enable password コマンドを使用するのは、 enable secret コマンドを認識しない古いイメージの Cisco IOS ソフトウェアをブートする場合、または古いブート ROM をブートする場合だけです。

詳細については、『 Cisco IOS Security Configuration Guide 』の「Configuring Passwords and Privileges」を参照してください。また、『 Improving Security on Cisco Routers 』テクニカル ノートを参照してください。

制約事項 

enable secret コマンドを設定した場合、このコマンドは enable password コマンドよりも優先されます。同時に 2 つのコマンドを有効にはできません。

手順の概要

1. enable

2. configure terminal

3. enable password password

4. enable secret password

5. end

6. enable

7. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

enable password password

 

Router(config)# enable password pswd2

(任意)多様な特権レベルに対して、アクセスを制御するローカル パスワードを設定します。

この手順を実行するのは、 enable secret コマンドを認識しない古いイメージの Cisco IOS ソフトウェアをブートする場合、または古いブート ROM をブートする場合だけです。

ステップ 4

enable secret password

 

Router(config)# enable secret greentree

enable password コマンドよりも強化したセキュリティ レイヤを指定します。

ステップ 3で入力したパスワードと同じパスワードを使用しないでください。

ステップ 5

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 6

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

新しいイネーブルまたはイネーブル シークレット パスワードが機能していることを確認します。

ステップ 7

end

 

Router(config)# end

(任意)特権 EXEC モードに戻ります。

トラブルシューティングのヒント

設定したパスワードを思い出せない場合、または特権 EXEC(イネーブル)モードにアクセスできない場合は、 http://www.cisco.com/warp/public/474 で、お使いのルータの『 Password Recovery Procedures 』を参照してください。

次の作業

コンソール インターフェイスの特権 EXEC タイムアウトを 10 分(デフォルト値)以外の値に設定するには、「コンソールのアイドル特権 EXEC タイムアウトの設定」に進みます。

特権 EXEC タイムアウトを変更しない場合は、「デフォルト ルートまたはラスト リゾート ゲートウェイの指定」に進みます。

コンソールのアイドル特権 EXEC タイムアウトの設定

ここでは、コンソール回線のアイドル特権 EXEC タイムアウトを設定する方法について説明します。デフォルトでは、特権 EXEC コマンド インタープリタは、ユーザ入力の検出を 10 分間待ってからタイムアウトします。

コンソール回線を設定するとき、通信パラメータの設定、自動ボー接続の指定、および使用している端末の端末操作パラメータの設定を行うこともできます。コンソール回線の設定の詳細については、『 Cisco IOS Configuration Fundamentals and Network Management Configuration Guide 』を参照してください。特に、「Configuring Operating Characteristics for Terminals」と「Troubleshooting and Fault Management」の章を参照してください。

手順の概要

1. enable

2. configure terminal

3. line console 0

4. exec-timeout minutes [ seconds ]

5. end

6. show running-config

7. exit


) exec-timeout コマンド、または exec-command 値に対する変更は、EXEC モードを終了してログインし直した場合にだけトリガーされます。


手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line console 0

 

Router(config)# line console 0

コンソール回線を設定し、回線コンフィギュレーション コマンドのコレクション モードを開始します。

ステップ 4

exec-timeout minutes [ seconds ]

 

Router(config-line)# exec-timeout 0 0

アイドル特権 EXEC タイムアウトを設定します。これは特権 EXEC コマンド インタープリタがユーザの入力が検出されるまで待つ間隔です。

次に、タイムアウトなしを指定する例を示します。

ステップ 5

end

 

Router(config-line)# end

特権 EXEC モードに戻ります。

ステップ 6

show running-config

 

Router# show running-config

実行コンフィギュレーション ファイルを表示します。

アイドル特権 EXEC タイムアウトを適切に設定したことを確認します。

ステップ 7

exit

 

Router# exit

特権 EXEC モードを終了します。

(注) exec-timeout コマンドの結果を反映するには、EXEC モードを終了し、ログインし直す必要があります。

次に、コンソールのアイドル特権 EXEC タイムアウトを 2 分 30 秒に設定する例を示します。

line console
exec-timeout 2 30
 

次に、コンソールのアイドル特権 EXEC タイムアウトを 10 秒に設定する例を示します。

line console
exec-timeout 0 10

ファスト イーサネット インターフェイスおよびギガビット イーサネット インターフェイスの設定

ここでは、IP アドレスおよびインターフェイスの説明をルータのイーサネット インターフェイスに割り当てる方法について説明します。

ファスト イーサネット インターフェイスおよびギガビット イーサネット インターフェイスの総合的な設定情報については、『 Cisco IOS Interface and Hardware Component Configuration Guide 』の「Configuring LAN Interfaces」の章を参照してください。

インターフェイス番号については、ルータに付属のクイック スタート ガイドを参照してください。


) Cisco 1841 および Cisco 2801 のルータには、ファスト イーサネット ポート FE0/0 および FE0/1 に関するハードウェア上の制限事項があります。半二重モードでトラフィックが許容量の 100% 以上(各方向に 5 Mbps 以上発生することと同等)になると、インターフェイスでは衝突の超過が発生し、1 秒ごとにリセットされます。この問題を回避するには、トラフィックを許容量の 100% 未満に抑える必要があります。


手順の概要

1. enable

2. show ip interface brief

3. configure terminal

4. interface { fastethernet | gigabitethernet } 0/ port

5. description string

6. ip address ip-address mask

7. no shutdown

8. end

9. show ip interface brief

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

show ip interface brief

 

Router# show ip interface brief

IP に設定されているインターフェイスの簡単なステータスを表示します。

ルータのイーサネット インターフェイスのタイプ(ファスト イーサネットまたはギガビット イーサネット)を調べます。

ステップ 3

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

interface { fastethernet | gigabitethernet } 0/ port

 

Router(config)# interface fastethernet 0/1

 

Router(config)# interface gigabitethernet 0/0

イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

(注) インターフェイス番号については、ルータに付属のクイック スタート ガイドを参照してください。

ステップ 5

description string

 

Router(config-if)# description FE int to 2nd floor south wing

(任意)インターフェイス設定に説明を追加します。

説明があると、そのインターフェイスに接続されているものを思い出しやすくなります。また、トラブルシューティングのために役立つこともあります。

ステップ 6

ip address ip-address mask

 

Router(config-if)# ip address 172.16.74.3 255.255.255.0

インターフェイスのプライマリ IP アドレスを設定します。

ステップ 7

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 8

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 9

show ip interface brief

 

Router# show ip interface brief

IP に設定されているインターフェイスの簡単なステータスを表示します。

イーサネット インターフェイスが起動し、正しく設定されていることを確認します。

ファスト イーサネット インターフェイスの設定:例

!
interface FastEthernet0/0
description FE int to HR group
ip address 172.16.3.3 255.255.255.0
duplex auto
speed auto
no shutdown
!

show ip interface brief コマンドの出力例

Router# show ip interface brief
 
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 172.16.3.3 YES NVRAM up up
FastEthernet0/1 unassigned YES NVRAM administratively down down
Router#

デフォルト ルートまたはラスト リゾート ゲートウェイの指定

ここでは、IP ルーティングをイネーブルにしてデフォルト ルートを指定する方法について説明します。デフォルト ルートの指定の代替手段については、『 Configuring a Gateway of Last Resort Using IP Commands 』テクニカル ノートを参照してください。

パケットのよりよいルートがない場合、および宛先が接続されているネットワークではない場合、Cisco IOS ソフトウェアはラスト リゾート ゲートウェイ(ルータ)を使用します。ここでは、デフォルト ルート(ラスト リゾート ゲートウェイを計算するルート候補)としてネットワークを選択する方法について説明します。ルーティング プロトコルがデフォルト ルート情報を伝播する方法は、プロトコルによって異なります。

IP ルーティングおよび IP ルーティング プロトコルの総合的な設定情報については、『 Cisco IOS IP Configuration Guide 』を参照してください。特に、「Configuring IP Addressing」の章および「Part 2: IP Routing Protocols」のすべての章を参照してください。

手順の概要

1. enable

2. configure terminal

3. ip routing

4. ip route dest-prefix mask next-hop-ip-address [ admin-distance ] [ permanent ]

5. ip default-network network-number
または
ip route dest-prefix mask next-hop-ip-address

6. end

7. show ip route

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip routing

 

Router(config)# ip routing

IP ルーティングをイネーブルにします。

ステップ 4

ip route dest-prefix mask next-hop-ip-address [ admin-distance ] [ permanent ]

 

Router(config)# ip route 192.168.24.0 255.255.255.0 172.28.99.2

スタティック ルートを確立します。

ステップ 5

ip default-network network-number

or

ip route dest-prefix mask next-hop-ip-address

 

Router(config)# ip default-network 192.168.24.0

 

Router(config)# ip route 0.0.0.0 0.0.0.0 172.28.99.1

ラスト リゾート ゲートウェイを計算するルート候補としてネットワークを選択します。

ラスト リゾート ゲートウェイを計算するために、ネットワーク 0.0.0.0 0.0.0.0 に対するスタティック ルートを作成します。

ステップ 6

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 7

show ip route

 

Router# show ip route

現在のルーティング テーブル情報を表示します。

ラスト リゾート ゲートウェイが設定されていることを確認します。

デフォルト ルートの指定:例

!
ip routing
!
ip route 192.168.24.0 255.255.255.0 172.28.99.2
!
ip default-network 192.168.24.0
!

show ip route コマンドの出力例

Router# show ip route
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
 
Gateway of last resort is 172.28.99.2 to network 192.168.24.0
 
172.24.0.0 255.255.255.0 is subnetted, 1 subnets
C 172.24.192.0 is directly connected, FastEthernet0
S 172.24.0.0 255.255.0.0 [1/0] via 172.28.99.0
S* 192.168.24.0 [1/0] via 172.28.99.2
172.16.0.0 255.255.255.0 is subnetted, 1 subnets
C 172.16.99.0 is directly connected, FastEthernet1
Router#

リモート コンソール アクセスのための仮想端末回線の設定

Virtual Terminal(VTY; 仮想端末)回線は、ルータに対してリモート アクセスするために使用されます。ここでは、電源があるユーザだけがルータをリモート アクセスできるように、パスワードを使用して仮想端末回線を設定する方法について説明します。

デフォルトで、ルータには 5 個の仮想端末回線があります。ただし、仮想端末回線は追加で作成できます。『 Cisco IOS Terminal Services Configuration Guide 』の「Configuring Protocol Translation and Virtual Asynchronous Devices」の章を参照してください。

回線パスワードおよびパスワード暗号化の詳細については、『 Cisco IOS Security Configuration Guide 』の「Configuring Passwords and Privileges」の章を参照してください。また、『 Cisco IOS Password Encryption Facts 』テクニカル ノートを参照してください。

アクセス リストを使用して VTY 回線をセキュリティ保護するには、『 Cisco IOS Security Configuration Guide 』の「Traffic Filtering and Virus Protection」の章を参照してください。

手順の概要

1. enable

2. configure terminal

3. line vty line-number [ ending-line-number ]

4. password password

5. login

6. end

7. show running-config

8. 別のネットワーク デバイスから、ルータに対する Telnet セッションの開始を試行します。

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line vty line-number [ ending-line-number ]

 

Router(config)# line vty 0 4

リモート コンソール アクセスために、仮想端末回線(VTY)の回線コンフィギュレーション コマンドのコレクション モードを開始します。

ルータ上のすべての VTY 回線を設定していることを確認します。

コマンドを使用します。

ステップ 4

password password

 

Router(config-line)# password guessagain

回線のパスワードを指定します。

ステップ 5

login

 

Router(config-line)# login

ログイン時のパスワード チェックをイネーブルにします。

ステップ 6

end

 

Router(config-line)# end

特権 EXEC モードに戻ります。

ステップ 7

show running-config

 

Router# show running-config

実行コンフィギュレーション ファイルを表示します。

リモート アクセスのために仮想端末回線を適切に設定したことを確認します。

ステップ 8

別のネットワーク デバイスから、ルータに対する Telnet セッションの開始を試行します。

 

Router# 172.16.74.3

Password:

ルータにリモート アクセスできること、および仮想端末回線のパスワードが正しく設定されていることを確認します。

次に、パスワードを使用して仮想端末回線を設定する例を示します。

!
line vty 0 4
password guessagain
login
!

次の作業

VTY 回線を設定したら、次の手順を実行します。

(任意)仮想端末回線のパスワードを暗号化するには、『 Cisco IOS Security Configuration Guide 』の「Configuring Passwords and Privileges」の章を参照してください。また、『 Cisco IOS Password Encryption Facts 』テクニカル ノートを参照してください。

(任意)アクセス リストを使用して VTY 回線をセキュリティ保護するには、『 Cisco IOS Security Configuration Guide 』の「Part 3: Traffic Filtering and Firewalls」を参照してください。

ルータ用の基本的なソフトウェア コンフィギュレーションを続けるには、「補助回線の設定」に進みます。

補助回線の設定

ここでは、補助回線について回線コンフィギュレーション モードを開始する方法について説明します。補助回線の設定方法は、補助(AUX)ポートの具体的な実装によって異なります。補助回線の設定については、次のマニュアルを参照してください。

Configuring a Modem on the AUX Port for EXEC Dialin Connectivity 』(テクニカル ノート)

http://www.cisco.com/warp/public/471/mod-aux-exec.html

Configuring Dialout Using a Modem on the AUX Port 』(設定例)

http://www.cisco.com/warp/public/471/mod-aux-dialout.html

Connecting a SLIP/PPP Device to a Router's AUX Port 』(テクニカル ノート)

http://www.cisco.com/warp/public/701/6.html

Configuring AUX-to-AUX Port Async Backup with Dialer Watch 』(設定例)

http://www.cisco.com/warp/public/471/aux-aux-watch.html

Modem-Router Connection Guide 』(テクニカル ノート)

http://www.cisco.com/warp/public/76/9.html

手順の概要

1. enable

2. configure terminal

3. line aux 0

4. AUX ポートの特定の実装に合わせて回線を設定するには、テクニカル ノートと設定例を参照してください。

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line aux 0

 

Router(config)# line aux 0

補助回線について回線コンフィギュレーション コマンドのコレクション モードを開始します。

ステップ 4

AUX ポートの特定の実装に合わせて回線を設定するには、テクニカル ノートと設定例を参照してください。

--

次の作業

「ネットワーク接続の確認」に進みます。

ネットワーク接続の確認

ここでは、ルータのネットワーク接続を確認する方法について説明します。

前提条件

このマニュアルで前述したすべての設定タスクを完了します。

適切に設定したネットワーク ホストにルータを接続する必要があります。

手順の概要

1. enable

2. ping [ ip-address | hostname ]

3. telnet { ip-address | hostname }

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

ping [ ip-address | hostname ]

 

Router# ping 172.16.74.5

基本的なネットワーク接続を診断します。

接続を確認するには、ネクスト ホップのルータ、または設定済みの各インターフェイスに接続しているホストに対して ping を実行します。

ステップ 3

telnet { ip-address | hostname }

 

Router# telnet 10.20.30.40

Telnet をサポートするホストにログインします。

VTY 回線パスワードをテストする場合、別のネットワーク デバイスからこの手順を実行し、ルータの IP アドレスを使用します。

次の表示は、IP アドレス 192.168.7.27 に対して ping を実行したときの出力例です。

Router# ping
 
Protocol [ip]:
Target IP address: 192.168.7.27
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.27, timeout is 2 seconds:
!!!!!
Success rate is 100 percent, round-trip min/avg/max = 1/2/4 ms
 

次の表示は、IP ホスト名 donald に対して ping を実行したときの出力例です。

Router# ping donald
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.27, timeout is 2 seconds:
!!!!!
Success rate is 100 percent, round-trip min/avg/max = 1/3/4 ms

次の作業

「ルータ設定の保存」に進みます。

ルータ設定の保存

ここでは、実行コンフィギュレーションを NVRAM のスタートアップ コンフィギュレーションに保存することで、次のシステム リロード時、または電源の再投入時に設定を失わない方法について説明します。

手順の概要

1. enable

2. copy running-config startup-config

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

copy running-config startup-config

 

Router# copy running-config startup-config

実行中の設定をスタートアップ コンフィギュレーションに保存します。

コンフィギュレーションおよびシステム イメージのバックアップ コピーの保存

ファイルの破損時にファイルの回復を補助し、ダウンタイムを最小限に抑えるために、スタートアップ コンフィギュレーション ファイルおよび Cisco IOS ソフトウェア システム イメージ ファイルのバックアップ コピーをサーバに保存することを推奨します。

詳細については、『 Cisco IOS Configuration Fundamentals and Network Management Configuration Guide 』の「Managing Configuration Files」および「Loading and Maintaining System Images」の章を参照してください。

手順の概要

1. enable

2. copy nvram:startup-config { ftp: | rcp: | tftp: }

3. show flash:

4. copy flash: { ftp: | rcp: | tftp: }

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

copy nvram:startup-config { ftp: | rcp: | tftp: }

 

Router# copy nvram:startup-config ftp:

スタートアップ コンフィギュレーション ファイルをサーバにコピーします。

コンフィギュレーション ファイルのコピーはバックアップ コピーとして使用できます。

プロンプトが表示されたら、コピー先の URL を入力します。

ステップ 3

show flash:

 

Router# show flash:

フラッシュ メモリ ファイル システムのレイアウトとコンテンツを表示します。

システム イメージ ファイルの名前を確認します。

ステップ 4

copy flash: { ftp: | rcp: | tftp: }

 

Router# copy flash: ftp:

フラッシュ メモリのファイルをサーバにコピーします。

システム イメージ ファイルをサーバにコピーし、バックアップ コピーとして使用します。

プロンプトが表示されたら、ファイル名とコピー先の URL を入力します。

スタートアップ コンフィギュレーションの TFTP サーバへのコピー:例

次に、スタートアップ コンフィギュレーションを TFTP サーバにコピーする例を示します。

Router# copy nvram:startup-config tftp:
 
Remote host[]? 172.16.101.101
 
Name of configuration file to write [rtr2-confg]? <cr>
Write file rtr2-confg on host 172.16.101.101?[confirm] <cr>
![OK]

フラッシュ メモリから TFTP サーバへのコピー:例

次に、特権 EXEC モードで show flash: コマンドを使用してシステム イメージ ファイル名を確認し、 copy flash: tftp: 特権 EXEC コマンドを使用してシステム イメージ(c3640-2is-mz)を TFTP サーバにコピーする方法を示します。このルータはデフォルトのユーザ名とパスワードを使用しています。

Router# show flash:
 
System flash directory:
File Length Name/status
1 4137888 c3640-c2is-mz
[4137952 bytes used, 12639264 available, 16777216 total]
16384K bytes of processor board System flash (Read/Write)\
 
Router# copy flash: tftp:
 
IP address of remote host [255.255.255.255]? 172.16.13.110
filename to write on tftp host? c3600-c2is-mz
writing c3640-c2is-mz !!!!...
successful ftp write.

次の作業

基本的なソフトウェア コンフィギュレーションが完了したら、ルータを保護するため、ルーティング プロトコルかアクセス リストの実装を検討するか、その他のセキュリティ強化策を検討します。「関連資料:その他の設定」に記載されているマニュアルを参照してください。

ルータの機能を設定するには、 「機能マニュアルの検索」 を参照してください。

その他の参考資料

ここでは、Cisco IOS CLI を使用した基本的なソフトウェア コンフィギュレーションに関連する資料について説明します。

関連資料:基本的なソフトウェア コンフィギュレーション

トピック
関連するマニュアルのタイトルまたはリンク

シャーシの設置、ケーブルの接続、電源投入の手順、およびインターフェイスの番号付け

ご使用のルータのクイック スタート ガイド

Cisco Security Device Manager(SDM)

http://www.cisco.com/go/sdm

ルータのホスト名を割り当てるためのガイドライン

RFC 1035、「 Domain Names--Implementation and Specification

RFC 1178、「 Choosing a Name for Your Computer

アクセス リスト、パスワード、および特権

『Cisco IOS Security Configuration Guide』

シスコ製品のパスワード回復手順

『Password Recovery Procedures』

コンソール回線の設定、コンフィギュレーション ファイルの管理、およびシステム イメージのロードおよび維持

『Cisco IOS Configuration Fundamentals and Network Management Configuration Guide』

インターフェイスの設定

『Cisco IOS Interface and Hardware Component Configuration Guide』

IP ルーティングおよび IP ルーティング プロトコル

『Cisco IOS IP Configuration Guide』

デフォルト ルートまたはラスト リゾート ゲートウェイの設定

Configuring a Gateway of Last Resort Using IP Commands 』テクニカル ノート

仮想端末回線の設定

『Cisco IOS Terminal Services Configuration Guide』

補助(AUX)ポートの設定

Configuring a Modem on the AUX Port for EXEC Dialin Connectivity』テクニカル ノート

Configuring Dialout Using a Modem on the AUX Port 』設定例

Connecting a SLIP/PPP Device to a Router's AUX Port 』(テクニカル ノート)

Configuring AUX-to-AUX Port Async Backup with Dialer Watch 』(設定例)

Modem-Router Connection Guide 』(テクニカル ノート)

関連資料:その他の設定

トピック
関連するマニュアルのタイトルまたはリンク

セキュリティ強化のため、ルータ上(特に境界ルータ上)でネットワーク管理者が変更を検討すべきシスコのコンフィギュレーション設定

Improving Security on Cisco Routers 』テクニカル ノート

(注) このマニュアルを表示するには、Cisco.com のアカウントが必要です。アカウントをお持ちでない場合や、ユーザ名やパスワードを忘れた場合は、ログイン ダイアログボックスで [Cancel] をクリックし、表示される説明に従ってください。

IP ルーティングおよび IP ルーティング プロトコル

『Cisco IOS IP Configuration Guide』

アクセス リスト

『Cisco IOS Security Configuration Guide』

シスコのテクニカル サポート

説明
リンク

TAC のホームページには、3 万ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml