Cisco 1812J ソフトウェア コンフィギュレーション ガイド(最新版)
ワイヤレス LAN 接続
ワイヤレス LAN 接続
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

ワイヤレス LAN 接続

ルート無線ステーションの設定

VLAN でのブリッジングの設定

無線ステーションのサブインターフェイスの設定

設定例

ワイヤレス LAN 接続

Cisco 1800 シリーズ サービス統合型固定構成ルータは、モビリティと柔軟性をネットワーク技術者が必要とするエンタープライズクラスの機能と組み合わせた、セキュアかつ安価で使いやすいワイヤレス LAN ソリューションをサポートします。Cisco IOS ソフトウェアをベースとした管理システムにより、Cisco ルータはアクセス ポイントとして機能し、Wi-Fi 認定を受けた、IEEE 802.11a/b/g 準拠のワイヤレス LAN トランシーバとなります。

これらのルータは、Command-Line Interface(CLI; コマンドライン インターフェイス)、ブラウザベースの管理システム、または Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)を使用して設定およびモニタできます。この章では、CLI を使用してルータを設定する方法について説明します。 interface dot11radio グローバル コンフィギュレーション CLI コマンドを使用して、デバイスを無線コンフィギュレーション モードにします。

ワイヤレス LAN アプリケーションでのこれらの Cisco ルータの設定に関する詳細については、『 Cisco Access Router Wireless Configuration Guide 』を参照してください。

図 9-1 に、ワイヤレス ネットワークの構成を示します。

図 9-1 ワイヤレス LAN の例

 

 

1

ワイヤレス LAN(ネットワークで接続された複数のデバイスを使用)

2

インターネットに接続された Cisco 1800 シリーズ サービス統合型ルータ

3

VLAN 1

4

VLAN 2

以下の設定例では、リモート ユーザがワイヤレス接続を使用して Cisco 1800 シリーズ サービス統合型ルータにアクセスします。各リモート ユーザは独自の VLAN を持ちます。

設定作業

次の作業を実行して、このネットワーク シナリオを設定します。

「ルート無線ステーションの設定」

「VLAN でのブリッジングの設定」

「無線ステーションのサブインターフェイスの設定」

これらの設定タスクの結果を示す例を、 「設定例」 の項に示します。


) この章の手順では、基本的なルータ機能と、NAT を使用した PPPoE または PPPoA がすでに設定されていることを前提とします。これらの設定作業を実行していない場合は、使用しているルータに応じて第 1 章「ルータの基本設定」第 3 章「PPP over Ethernet と NAT の設定」、および第 4 章「PPP over ATM と NAT の設定」を参照してください。DHCP、VLAN、およびセキュアなトンネルが設定されていることもあります。


ルート無線ステーションの設定

ワイヤレス LAN のルート無線ステーションを作成および設定するには、グローバル コンフィギュレーション モードを開始し、次の手順を実行します。

 

 
コマンド
目的

ステップ 1

interface name number

例:

Router(config)# interface dot11radio 0
Router(config-if)#
 

指定したワイヤレス インターフェイスに対してインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

broadcast-key [[ vlan vlan-id ] change secs ] [ membership-termination ] [ capability-change ]

例:

Router(config-if)# broadcast-key vlan 1 change 45
Router(config-if)#
 

クライアントに使用されるブロードキャスト暗号キーのローテーション間隔(秒単位)を指定します。

(注) ブロードキャスト キー ローテーションをイネーブルにする場合は、スタティックな Wired Equivalent Privacy(WEP; 有線と同等のプライバシー)を使用しているクライアント デバイスはアクセス ポイントを使用できません。802.1x 認証(Light Extensible Authentication Protocol(LEAP)、Extensible Authentication Protocol-Transport Layer Security(EAP-TLS)、Protected Extensible Authentication Protocol(PEAP)など)を使用するワイヤレス クライアント デバイスのみがアクセス ポイントを使用できます。

(注) このコマンドはブリッジでサポートされません。

詳細については、『 Cisco IOS Commands for Access Points and Bridges 』を参照してください。

ステップ 3

encryption method algorithm key

例:

Router(config-if)# encryption vlan 1 mode ciphers tkip
Router(config-if)#
 

ワイヤレス インターフェイスにアクセスするために使用される暗号化方式、アルゴリズム、およびキーを指定します。

例では、オプションのデータ暗号化方式で VLAN を使用します。

ステップ 4

ssid name

例:

Router(config-if)# ssid cisco
Router(config-if-ssid)#
 

ワイヤレス ネットワークの公開名である Service Set ID(SSID)を作成します。

(注) WLAN 上のすべてのワイヤレス デバイスは、相互に通信するために同じ SSID を使用する必要があります。

ステップ 5

vlan number

例:

Router(config-if-ssid)# vlan 1
Router(config-if-ssid)#
 

SSID を VLAN にバインドします。

ステップ 6

authentication type

例:

Router(config-if-ssid)# authentication open
Router(config-if-ssid)# authentication network-eap eap_methods
Router(config-if-ssid)# authentication key-management wpa
 

ワイヤレス LAN にアクセスするユーザに許可された認証方法を設定します。

例で示されたように、複数の方法を指定できます。

ステップ 7

exit

例:

Router(config-if-ssid)# exit
Router(config-if)#
 

SSID コンフィギュレーション モードを終了し、ワイヤレス インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 8

speed rate

例:

Router(config-if)# basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
Router(config-if)#
 

(任意)ワイヤレス接続を介したトラフィックに対して必要かつ許可されたレート(Mbps 単位)を指定します。

ステップ 9

rts [ retries | threshold ]

例:

Router(config-if)# rts threshold 2312
Router(config-if)#
 

(任意)ワイヤレス LAN が到達可能であることを調べる前に Request to Send(RTS; 送信要求)しきい値または要求の送信回数を指定します。

ステップ 10

power [ client | local ] [ cck [ number | maximum ] | ofdm [ number | maximum ]]

例:

Router(config-if)# power local cck 50
Router(config-if)# power local ofdm 30
Router(config-if)#
 

(任意)無線トランスミッタの電力レベルを指定します。

利用可能な電力レベルの値については、『 Cisco Access Router Wireless Configuration Guide 』を参照してください。

ステップ 11

channel [ number | least-congested ]

例:

Router(config-if)# channel 2462
Router(config-if)#
 

(任意)通信が行われるチャンネルを指定します。

利用可能なチャンネル数については、『 Cisco Access Router Wireless Configuration Guide 』を参照してください。

ステップ 12

station-role [ repeater | root ]

例:

Router(config-if)# station-role root
Router(config-if)#
 

(任意)このワイヤレス インターフェイスの役割を指定します。

少なくとも 1 つのルート インターフェイスを指定する必要があります。

ステップ 13

exit

例:

Router(config-if)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

VLAN でのブリッジングの設定

VLAN で統合されたルーティングおよびブリッジングを設定するには、グローバル コンフィギュレーション モードを開始し、次の手順を実行します。

 

 
コマンドまたはアクション
目的

ステップ 1

bridge [ number | crb | irb | mac-address-table ]

例:

Router(config)# bridge irb
Router(config)#
 

ブリッジングのタイプを指定します。

この例では、統合されたルーティングおよびブリッジングを指定します。

ステップ 2

interface name number

例:

Router(config)# interface vlan 1
Router(config)#
 

インターフェイス コンフィギュレーション モードを開始します。

VLAN でブリッジングを設定するため、この例では VLAN インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

bridge-group number

例:

Router(config)# bridge-group 1
Router(config)#
 

ブリッジ グループをインターフェイスに割り当てます。

ステップ 4

bridge-group parameter

例:

Router(config)# bridge-group spanning-disabled
Router(config)#
 

ブリッジング インターフェイスに他のブリッジ パラメータを設定します。

ステップ 5

interface name number

例:

Router(config)# interface bvi 1
Router(config)#
 

仮想ブリッジ インターフェイスに対してコンフィギュレーション モードを開始します。

ステップ 6

ip address address mask

例:

Router(config)# ip address 10.0.1.1 255.255.255.0
Router(config)#
 

仮想ブリッジ インターフェイスにアドレスを指定します。

ワイヤレス インターフェイスが必要な各 VLAN に対して上記のステップ 2ステップ 6 を繰り返します。

無線ステーションのサブインターフェイスの設定

各ルート ステーションのサブインターフェイスを設定するには、グローバル コンフィギュレーション モードを開始し、次の手順を実行します。

 

 
コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface dot11radio 0.1
Router(config-subif)#
 

ルート ステーションのインターフェイスに対してサブインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

description string

例:

Router(config-subif)# description Cisco open
Router(config-subif)#
 

管理ユーザのためにサブインターフェイスの説明を提供します。

ステップ 3

encapsulation dot1q vlanID [ native | second-dot1q ]

例:

Router(config-subif)# encapsulation dot1q 1 native
Router(config-subif)#
 

指定されたサブインターフェイスで IEEE 802.1q カプセル化をイネーブルにします。

ステップ 4

no cdp enable

例:

Router(config-subif)# no cdp enable
Router(config-subif)#
 

ワイヤレス インターフェイスで Cisco Discovery Protocol(CDP; シスコ検出プロトコル)をディセーブルにします。

ステップ 5

bridge-group number

例:

Router(config-subif)# bridge-group 1
Router(config-subif)#
 

ブリッジ グループをサブインターフェイスに割り当てます。

ステップ 6

exit

例:

Router(config-subif)# exit
Router(config)#
 

サブインターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

必要に応じてこれらの手順を繰り返し、さらに多くのサブインターフェイスを設定します。

設定例

次の設定例は、これまでの項で説明されたワイヤレス LAN シナリオのコンフィギュレーション ファイルの一部を示しています。

!
bridge irb
!
interface Dot11Radio0
no ip address
!
broadcast-key vlan 1 change 45
!
!
encryption vlan 1 mode ciphers tkip
!
ssid cisco
vlan 1
authentication open
authentication network-eap eap_methods
authentication key-management wpa
!
ssid ciscowep
vlan 2
authentication open
!
ssid ciscowpa
vlan 3
authentication open
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 2312
power local cck 50
power local ofdm 30
channel 2462
station-role root
!
interface Dot11Radio0.1
description Cisco Open
encapsulation dot1Q 1 native
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.2
encapsulation dot1Q 2
bridge-group 2
bridge-group 2 subscriber-loop-control
bridge-group 2 spanning-disabled
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
!
interface Dot11Radio0.3
encapsulation dot1Q 3
bridge-group 3
bridge-group 3 subscriber-loop-control
bridge-group 3 spanning-disabled
bridge-group 3 block-unknown-source
no bridge-group 3 source-learning
no bridge-group 3 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan2
no ip address
bridge-group 2
bridge-group 2 spanning-disabled
!
interface Vlan3
no ip address
bridge-group 3
bridge-group 3 spanning-disabled
!
interface BVI1
ip address 10.0.1.1 255.255.255.0
!
interface BVI2
ip address 10.0.2.1 255.255.255.0
!
interface BVI3
ip address 10.0.3.1 255.255.255.0
!