Cisco 1812J ソフトウェア コンフィギュレーション ガイド(最新版)
ルータの基本 設定
ルータの基本設定
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

ルータの基本設定

インターフェイス ポート ラベル

デフォルト設定の表示

設定に必要な情報

基本パラメータの設定

グローバル パラメータの設定

ファスト イーサネット LAN インターフェイスの設定

WAN インターフェイスの設定

ファスト イーサネット WAN インターフェイスの設定

ATM WAN インターフェイスの設定

ワイヤレス インターフェイスの設定

ループバック インターフェイスの設定

設定例

設定の確認

ルータへのコマンドライン アクセスの設定

設定例

スタティック ルートの設定

設定例

設定の確認

ダイナミック ルートの設定

RIP の設定

設定例

設定の確認

拡張 IGRP の設定

設定例

設定の確認

ルータの基本設定

この章では、Cisco ルータで基本的なパラメータ(グローバル パラメータの設定、ルーティング プロトコル、インターフェイス、およびコマンドライン アクセスなど)を設定する手順について説明します。また、起動時のデフォルト設定についても説明します。ルータの各モデルは、このマニュアルに記載されている機能の一部をサポートしていない場合があります。特定のルータでサポートされていない機能は、可能な限り明示されています。

この章で説明する内容は、次のとおりです。

「インターフェイス ポート ラベル」

「デフォルト設定の表示」

「設定に必要な情報」

「基本パラメータの設定」

「スタティック ルートの設定」

「ダイナミック ルートの設定」

「拡張 IGRP の設定」

該当する場合、各項には設定例と確認手順が記載されています。

グローバル コンフィギュレーション モードへのアクセス方法の詳細については、付録 A「Cisco IOS ソフトウェアの基礎知識」の「グローバル コンフィギュレーション モードの開始」を参照してください。次の表に示すコマンドの詳細については、Cisco IOS Release 12.3 のマニュアル セットを参照してください。

インターフェイス ポート ラベル

表 1 に、各ルータでサポートされているインターフェイスと装置に表記されているポート ラベルを示します。

 

表 1 Cisco ルータでサポートされているインターフェイスと対応するポート ラベル

ルータ
Interface
ポート ラベル

Cisco 1801

ファスト イーサネット LAN

SWITCH および FE8-FE5(上部)、FE x および FE4-FE1(下部)

ファスト イーサネット WAN

FE0

ATM WAN

ADSLoPOTS

ワイヤレス LAN

LEFT、RIGHT/PRIMARY

BRI

ISDN S/T

Cisco 1802

ファスト イーサネット LAN

SWITCH および FE8-FE5(上部)、FE x および FE4-FE1(下部)

ファスト イーサネット WAN

FE0

ATM WAN

ADSLoISDN

ワイヤレス LAN

LEFT、RIGHT/PRIMARY

BRI

ISDN S/T

Cisco 1803

ファスト イーサネット LAN

SWITCH および FE8-FE5(上部)、FE x および FE4-FE1(下部)

ファスト イーサネット WAN

FE0

ATM WAN

G.SHDSL

ワイヤレス LAN

LEFT、RIGHT/PRIMARY

BRI

ISDN S/T

Cisco 1811

ファスト イーサネット LAN

SWITCH および FE9-FE6(上部)、FE x および FE5-FE2(下部)

ファスト イーサネット WAN

FE0-FE1

ワイヤレス LAN

LEFT、RIGHT/PRIMARY

USB

1-0

V.92

MODEM

Cisco 1812J

ファスト イーサネット LAN

SWITCH および FE9-FE6(上部)、FE x および FE5-FE2(下部)

ファスト イーサネット WAN

FE0-FE1

ワイヤレス LAN

LEFT、RIGHT/PRIMARY

BRI

ISDN S/T

USB

1-0

デフォルト設定の表示

Cisco ルータを初めて起動すると、一部の基本的な設定はすでに行われています。LAN および WAN インターフェイスはすべて作成されており、コンソール ポートと VTY ポートの設定やネットワーク アドレス変換用の内部インターフェイスの割り当てもすでに行われています。初期設定を表示するには、例 1例 1 に示すように、 show running-config コマンドを使用します。


) 初期設定を表示できず、「No Password Set」エラー メッセージを受信した場合は、初期パスワードをリセットする必要があります。詳細は、第 14 章「トラブルシューティング」「パスワードを忘れた場合の回復方法」を参照してください。


例 1 Cisco 1812J の起動時のデフォルト設定

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
ip cef
!
ip ips po max-events 100
no ftp-server write-enable
!
interface BRI0
no ip address
shutdown
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface FastEthernet4
no ip address
shutdown
!
interface FastEthernet5
no ip address
shutdown
!
interface FastEthernet6
no ip address
shutdown
!
interface FastEthernet7
no ip address
shutdown
!
interface FastEthernet8
no ip address
shutdown
!
interface FastEthernet9
no ip address
shutdown
!
interface Vlan1
no ip address
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end
 

設定に必要な情報

ネットワークを設定する前に、使用するネットワーク構成に基づいて、次の情報の一部またはすべてを収集しておく必要があります。

インターネット接続を設定する場合、次の情報を収集してください。

ログイン名として割り当てられている Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)クライアント名

PPP 認証のタイプ:Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェイク認証プロトコル)または Password Authentication Protocol(PAP)

Internet Service Provider(ISP; インターネット サービス プロバイダー)アカウントにアクセスするための PPP パスワード

DNS サーバの IP アドレスおよびデフォルト ゲートウェイ

企業ネットワークへの接続を設定する場合は、ユーザとネットワーク管理者の間で、ルータの WAN インターフェイスに関する次の情報について打ち合わせておく必要があります。

PPP 認証のタイプ:CHAP または PAP

ルータにアクセスするための PPP クライアント名

ルータにアクセスするための PPP パスワード

IP ルーティングを設定する場合、次の準備が必要です。

IP ネットワークのアドレス指定方式を作成します。

IP アドレスなどの IP ルーティング パラメータ情報と ATM Permanent Virtual Circuit(PVC; 相手先固定接続)を特定します。通常、これらの PVC パラメータは、Virtual Path Identifier(VPI; 仮想パス識別子)、Virtual Circuit Identifier(VCI; 仮想回線識別子)、およびトラフィック シェーピング パラメータです。

サービス プロバイダーから付与された PVC 番号、VPI、および VCI を特定します。

PVC ごとに、サポートされている AAL5 カプセル化のタイプを判別します。次のいずれかになります。

AAL5SNAP:これは、RFC 1483 ルーティングまたは RFC 1483 ブリッジングのいずれかです。RFC 1483 ルーティングの場合、サービス プロバイダーはスタティック IP アドレスを提供する必要があります。ブリッジング RFC 1483 の場合、DHCP を用いて IP アドレスを入手するか、サービス プロバイダーからスタティック IP アドレスを入手することもできます。

AAL5MUX PPP:このタイプでのカプセル化では、PPP 関連設定項目を判別する必要があります。

ADSL または G.SHDSL 回線を使用して接続する場合、次の準備が必要です。

電話会社と回線契約を結びます。

ADSL 回線の場合:ADSL シグナリング タイプが DMT(ANSI T1.413 ともいう)または DMT Issue 2 であることを確認します。

G.SHDSL 回線の場合:G.SHDSL 回線が ITU G.991.2 規格に準拠し、Annex A(北米)または Annex B(欧州)をサポートしていることを確認します。

該当する情報の収集が済んだら、ルータの設定を行うことができます。「基本パラメータの設定」の作業から設定を始めてください。

基本パラメータの設定

ルータを設定するには、次のいずれか、または複数の作業を実行します。

「グローバル パラメータの設定」

「ファスト イーサネット LAN インターフェイスの設定」

「WAN インターフェイスの設定」

「ループバック インターフェイスの設定」

「ルータへのコマンドライン アクセスの設定」

作業完了後のネットワーク設定を示すため、作業ごとに設定例が示されています。

グローバル パラメータの設定

ルータに対して選択したグローバル パラメータを設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

例:

Router> enable

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します(コンソール ポート使用時)。

リモート端末を使用してルータに接続している場合は、次のコマンドを使用します。

telnet router name or address

Login: login id

Password: *********

Router> enable

ステップ 2

hostname name

例:

Router(config)# hostname Router

Router(config)#

ルータ名を指定します。

ステップ 3

enable secret password

例:

Router(config)# enable secret cr1ny5ho

Router(config)#

ルータへの不正なアクセスを防止するには、暗号化パスワードを指定します。

ステップ 4

no ip domain-lookup

例:

Router(config)# no ip domain-lookup Router(config)#

ルータが未知の単語(入力ミス)を IP アドレスに変換しないようにします。

グローバル パラメータ コマンドの詳細については、Cisco IOS Release 12.3 のマニュアル セットを参照してください。

ファスト イーサネット LAN インターフェイスの設定

ルータのファスト イーサネット LAN インターフェイスは、デフォルト VLAN の一部として自動的に設定されるので、個別のアドレスによる設定は行われません。アクセスは VLAN を通じて提供されます。必要に応じて、このインターフェイスを別の VLAN に割り当てることが可能です。VLAN 作成の詳細については、 第 5 章「DHCP および VLAN による LAN の設定」 を参照してください。

WAN インターフェイスの設定

Cisco 1811 ルータおよび Cisco 1812J ルータにはそれぞれ、WAN 接続用に 2 つのファスト イーサネット インターフェイスが搭載されています。Cisco 1801 ルータ、Cisco 1802 ルータ、および Cisco 1803 ルータにはそれぞれ、WAN 接続用に 1 つの ATM インターフェイスが搭載されています。

使用しているルータ モデルに基づいて、次のいずれかの手順で WAN インターフェイスを設定します。

「ファスト イーサネット WAN インターフェイスの設定」

「ATM WAN インターフェイスの設定」

ファスト イーサネット WAN インターフェイスの設定

この手順は、Cisco 1811 ルータ モデルおよび Cisco 1812J ルータ モデルにのみ適用します。ファスト イーサネット インターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface fastethernet 0
Router(config-int)#
 

ルータのファスト イーサネット WAN インターフェイスのコンフィギュレーション モードを開始します。

(注) Cisco 1800 シリーズ ルータのファスト イーサネット WAN ポートには、0 ~ 1 の番号が割り当てられています。

ステップ 2

ip address ip-address mask

例:

Router(config-int)# ip address 192.1.12.2 255.255.255.0
Router(config-int)#
 

指定されたファスト イーサネット インターフェイスの IP アドレスおよびサブネット マスクを設定します。

ステップ 3

no shutdown

例:

Router(config-int)# no shutdown
Router(config-int)#
 

イーサネット インターフェイスをイネーブルにして、インターフェイスの状態を管理上のダウンからアップに変更します。

ステップ 4

exit

例:

Router(config-int)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

必要に応じて、その他のファスト イーサネット WAN インターフェイスに対してこの手順を繰り返します。

ATM WAN インターフェイスの設定

この手順は、Cisco 1801、Cisco 1802、および Cisco 1803 モデルにのみ適用します。

ATM インターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

Cisco 1803 の場合のみ:

controller dsl 0
mode atm
exit

例:

Router(config)# controller dsl 0
Router(config-controller)# mode atm
Router(config-controller)# exit
Router(config)#
 

G.SHDSL シグナリングを使用するルータに対して、これらのコマンドを実行します。ADSL シグナリングを使用するルータの場合は、このステップを無視します。

ステップ 2

interface type number

例:

Router(config)# interface atm0
Router(config-int)#
 

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip address ip-address mask

例:

Router(config-int)# ip address 200.200.100.1 255.255.255.0
Router(config-int)#
 

ATM インターフェイスの IP アドレスとサブネット マスクを設定します。

ステップ 4

no shutdown

例:

Router(config-int)# no shutdown
Router(config-int)#
 

ATM 0 インターフェイスをイネーブルにします。

ステップ 5

exit

例:

Router(config-int)# exit
Router(config)#
 

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ワイヤレス インターフェイスの設定

ワイヤレス インターフェイスは、ワイヤレス LAN 接続を介してルータに接続できるようにします。ワイヤレス接続の設定の詳細については、 第 9 章「ワイヤレス LAN 接続」 および『 Cisco Access Router Wireless Configuration Guide 』を参照してください。

ループバック インターフェイスの設定

ループバック インターフェイスは、スタティック IP アドレスのプレースホルダーとして機能し、デフォルトのルーティング情報を提供します。

ループバック コマンドの詳細については、Cisco IOS Release 12.3のマニュアル セットを参照してください。

ループバック インターフェイスを設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface Loopback 0
Router(config-int)#
 

インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip address ip-address mask

例:

Router(config-int)# ip address 10.108.1.1 255.255.255.0
Router(config-int)#
 

ループバック インターフェイスの IP アドレスとサブネット マスクを設定します。

ステップ 3

exit

例:

Router(config-int)# exit
Router(config)#
 

ループバック インターフェイスのコンフィギュレーション モードを終了します。続いて、グローバル コンフィギュレーション モードに戻ります。

設定例

このコンフィギュレーション例のループバック インターフェイスは、仮想テンプレート インターフェイス上の NAT をサポートするために使用されています。この設定例は、スタティック IP アドレスとなる IP アドレス 200.200.100.1/24 を持つファスト イーサネット インターフェイスに設定されるループバック インターフェイスを示します。ループバック インターフェイスは、ネゴシエートされた IP アドレスを持つ virtual-template1 にポイントバックします。

!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
ip unnumbered loopback0
no ip directed-broadcast
ip nat outside

設定の確認

ループバック インターフェイスが正しく設定されたかどうかを確認するには、show interface loopback コマンドを入力します。次の例のような確認用の出力が表示されます。

Router# show interface loopback 0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 

ping を実行することによって、ループバック インターフェイスを確認する方法もあります。

Router# ping 200.200.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 

ルータへのコマンドライン アクセスの設定

ルータへのアクセスを制御するパラメータを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

line [ aux | console | tty | vty ] line-number

例:

Router(config)# line console 0
Router(config)#
 

回線コンフィギュレーション モードを開始します。続いて、回線のタイプを指定します。

この例では、アクセス用にコンソール端末を指定します。

ステップ 2

password password

例:

Router(config)# password 5dr4Hepw3
Router(config)#
 

コンソール端末回線に固有のパスワードを指定します。

ステップ 3

login

例:

Router(config)# login
Router(config)#
 

端末セッション ログイン時のパスワード チェックをイネーブルにします。

ステップ 4

exec-timeout minutes [ seconds ]

例:

Router(config)# exec-timeout 5 30
Router(config)#
 

ユーザ入力が検出されるまで EXEC コマンド インタープリタが待機する間隔を設定します。デフォルト値は 10 分です。任意で、間隔値に秒数を追加します。

この例では、5 分 30 秒のタイムアウトを表示します。「0 0」のタイムアウトを入力すると、タイムアウトが発生しません。

ステップ 5

line [ aux | console | tty | vty ] line-number

例:

Router(config)# line vty 0 4
Router(config)#
 

リモート コンソール アクセス用の仮想端末を指定します。

ステップ 6

password password

例:

Router(config)# password aldf2ad1
Router(config)#
 

仮想端末回線に固有のパスワードを指定します。

ステップ 7

login

例:

Router(config)# login
Router(config)#
 

仮想端末セッション ログイン時のパスワード チェックをイネーブルにします。

ステップ 8

end

例:

Router(config)# end
Router#
 

回線コンフィギュレーション モードを終了します。続いて、特権 EXEC モードに戻ります。

コマンド ライン コマンドの詳細については、Cisco IOS Release 12.3 のマニュアル セットを参照してください。

設定例

次の設定は、コマンドライン アクセス コマンドを示します。

「default」と記されているコマンドは入力不要です。これらのコマンドは、 show running-config コマンドを使用すると、生成されたコンフィギュレーション ファイルに自動的に表示されます。

!
line con 0
exec-timeout 10 0
password 4youreyesonly
login
transport input none (default)
stopbits 1 (default)
line vty 0 4
password secret
login
!

スタティック ルートの設定

スタティック ルートは、ネットワークを介した固定ルーティング パスを提供します。これらは、ルータ上で手動で設定されます。ネットワーク トポロジーが変更された場合には、スタティック ルートを新しいルートに更新する必要があります。スタティック ルートは、ルーティング プロトコルによって再配信される場合を除き、プライベート ルートです。Cisco 1800 シリーズ ルータへのスタティック ルートの設定は任意です。

スタティック ルートを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}

例:

Router(config)# ip route 192.168.1.0 255.255.0.0 10.10.10.2
Router(config)#
 

IP パケットのスタティック ルートを指定します。

このコマンドの詳しい説明およびその他の設定可能なパラメータについては、『 Cisco IOS IP Command Reference, Volume 2 of 4: Routing Protocols 』を参照してください。

ステップ 2

end

例:

Router(config)# end
Router#
 

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

スタティック ルーティング コマンドの詳細については、Cisco IOS Release 12.3 のマニュアル セットを参照してください。スタティック ルーティングの概要については、 付録 B「概要」 を参照してください。

設定例

次の設定例で、スタティック ルートは、ファスト イーサネット インターフェイスで宛先 IP アドレス 192.168.1.0 およびサブネット マスク 255.255.255.0 を持つすべての IP パケットを、IP アドレス 10.10.10.2 を持つ別のデバイスに送信します。具体的には、パケットが設定済みの PVC に送信されます。

「(default)」と記されているコマンドは入力不要です。これらのコマンドは、 show running-config コマンドを使用すると、生成されたコンフィギュレーション ファイルに自動的に表示されます。

!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
 

設定の確認

スタティック ルーティングが正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「S」で表されるスタティック ルートを探します。

次の例のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, FastEthernet0
 

ダイナミック ルートの設定

ダイナミック ルーティングでは、ネットワーク トラフィックまたはトポロジーに基づいて、ネットワーク プロトコルがパスを自動調整します。ダイナミック ルーティングの変更は、ネットワーク上の他のルータにも反映されます。

Cisco ルータは、Routing Information Protocol(RIP; ルーティング情報プロトコル)または Enhanced Interior Gateway Routing Protocol(EIGRP)などの IP ルーティング プロトコルを使用して、動的にルートを学習します。いずれかのルーティング プロトコルをルータに設定できます。

RIP の設定

ルータに RIP ルーティング プロトコルを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
作業

ステップ 1

router rip

例:

Router> configure terminal
Router(config)# router rip
Router(config-router)#
 

ルータ コンフィギュレーション モードを開始します。続いて、ルータの RIP をイネーブルにします。

ステップ 2

version {1 | 2}

例:

Router(config-router)# version 2
Router(config-router)#
 

RIP version 1 または 2 の使用を指定します。

ステップ 3

network ip-address

例:

Router(config-router)# network 192.168.1.1
Router(config-router)# network 10.10.7.1
Router(config-router)#
 

直接接続しているネットワークのアドレスを使用して、RIP を適用するネットワーク リストを指定します。

ステップ 4

no auto-summary

例:

Router(config-router)# no auto-summary
Router(config-router)#
 

ネットワークレベル ルートへのサブネット ルートの自動サマライズをディセーブルにします。これにより、サブプレフィクス ルーティング情報がクラスフル ネットワーク境界を越えて送信されます。

ステップ 5

end

例:

Router(config-router)# end
Router#
 

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

ダイナミック ルーティング コマンドの詳細については、Cisco IOS Release 12.3 のマニュアル セットを参照してください。RIP の概要については、 付録 B「概要」 を参照してください。

設定例

次の設定例は、IP ネットワーク 10.0.0.0 および 192.168.1.0 でイネーブルにされる RIP version 2 を示します。

この設定を表示するには、特権 EXEC モードから show running-config コマンドを実行します。

!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
 

設定の確認

RIP が正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「R」で表される RIP ルートを探します。次の例のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0
 

拡張 IGRP の設定

Enhanced IGRP(EIGRP; 拡張 IGRP)を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

router eigrp as-number

例:

Router(config)# router eigrp 109
Router(config)#
 

ルータ コンフィギュレーション モードを開始して、ルータ上で EIGRP をイネーブルにします。Autonomous System(AS; 自律システム)番号は、他の EIGRP ルータへのルートを識別します。また、EIGRP 情報のタグ付けに使用されます。

ステップ 2

network ip-address

例:

Router(config)# network 192.145.1.0
Router(config)# network 10.10.12.115
Router(config)#
 

EIGRP を適用するネットワークのリストを指定します(直接接続されているネットワークの IP アドレスを使用)。

ステップ 3

end

例:

Router(config-router)# end
Router#
 

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

IP EIGRP コマンドの詳細については、Cisco IOS Release 12.3 のマニュアル セットを参照してください。EIGRP の概要については、 付録 B「概要」 を参照してください。

設定例

次の設定例は、IP ネットワーク 192.145.1.0 および 10.10.12.115 でイネーブルにされる EIGRP ルーティング プロトコルを示します。EIGRP の自律システム番号として、109 が割り当てられています。

この設定を表示するには、特権 EXEC モードから show running-config コマンドを実行します。

!
router eigrp 109
network 192.145.1.0
network 10.10.12.115
!
 

設定の確認

IP EIGRP が正しく設定されたかどうかを確認するには、show ip route コマンドを入力し、「D」で表される EIGRP ルートを探します。次の例のような確認用の出力が表示されます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0