Cisco 1812J ソフトウェア コンフィギュレーション ガイド(最新版)
PPP over Ethernet と NAT の設定
PPP over Ethernet と NAT の設定
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

PPP over Ethernet と NAT の設定

バーチャル プライベート ダイヤルアップ ネットワーク グループ番号の設定

ファスト イーサネット WAN インターフェイスの設定

ダイヤラ インターフェイスの設定

ネットワーク アドレス変換の設定

設定例

設定の確認

PPP over Ethernet と NAT の設定

Cisco 1811 および Cisco 1812J サービス統合型固定構成ルータは、Point-to-Point Protocol over Ethernet(PPPoE)クライアントおよび Network Address Translation(NAT; ネットワーク アドレス変換)をサポートします。

ルータの背後の LAN には、複数の PC を接続できます。これらの PC からのトラフィックに対しては、PPPoE セッションに送信する前に暗号化やフィルタリングなどを行うことができます。図 3-1 に、Cisco ルータに PPPoE クライアントと NAT が設定された一般的な配置シナリオを示します。

図 3-1 PPP over Ethernet と NAT

 

 

1

複数のネットワーク接続デバイス:デスクトップ、ラップトップ PC、スイッチ

2

ファスト イーサネット LAN インターフェイス(NAT の内部インターフェイス)

3

PPPoE クライアント:Cisco 1811 または Cisco 1812J サービス統合型ルータ

4

NAT が実行されるポイント

5

ファスト イーサネット WAN インターフェイス(NAT の外部インターフェイス)

6

インターネットに接続しているケーブル モデムまたはその他のサーバ(Cisco 6400 サーバなど)

7

クライアントと PPPoE サーバ間の PPPoE セッション

PPPoE

ルータ上の PPPoE クライアント機能により、イーサネット インターフェイスでの PPPoE クライアント サポートが可能になります。仮想アクセスのクローニングには、ダイヤラ インターフェイスを使用する必要があります。イーサネット インターフェイスには、複数の PPPoE クライアント セッションを設定できますが、セッションごとに別個のダイヤラ インターフェイスと別個のダイヤラ プールを使用する必要があります。

PPPoE セッションは、Cisco 1800 シリーズ ルータによってクライアント側で開始されます。確立された PPPoE クライアント セッションは、次のいずれかの方法で終了できます。

clear vpdn tunnel pppoe コマンドを入力する。PPPoE クライアント セッションが終了し、PPPoE クライアントはただちにセッションの再確立を試みます。セッションがタイムアウトした場合にも、この動作が発生します。

no pppoe-client dial-pool number コマンドを入力して、セッションをクリアする。PPPoE クライアントは、セッションの再確立を試みません。

NAT

NAT(Cisco ルータの端に点線で表示)は、2 つのアドレス指定ドメインと内部送信元アドレスを示します。送信元リストには、パケットがネットワークをどのように通過するかが定義されます。

設定作業

次の作業を実行して、このネットワーク シナリオを設定します。

「バーチャル プライベート ダイヤルアップ ネットワーク グループ番号の設定」

「ファスト イーサネット WAN インターフェイスの設定」

「ダイヤラ インターフェイスの設定」

「ネットワーク アドレス変換の設定」

「設定例」 には、これらの設定作業の結果を示した例が示されています。

バーチャル プライベート ダイヤルアップ ネットワーク グループ番号の設定

Virtual Private Dialup Network(VPDN; バーチャル プライベート ダイヤルアップ ネットワーク)を設定すると、複数のクライアントが 1 つの IP アドレスを使用してルータを介して通信できるようになります。

VPDN を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。このモードの開始に関する詳細については、「グローバル パラメータの設定」を参照してください。

 

コマンドまたはアクション
目的

ステップ 1

vpdn enable

例:

Router(config)# vpdn enable
Router(config-vpdn)#
 

ルータで VPDN をイネーブルにします。

ステップ 2

vpdn group name

例:

Router(config-vpdn)# vpdn group 1
Router(config-vpdn-grp)#
 

VPDN グループを作成し、カスタマーまたは VPDN プロファイルに関連付けます。

ステップ 3

request-dialin

例:

Router(config-vpdn-grp)# request-dialin
Router(config-vpdn-grp)#
 

ダイヤリング方向を示す request-dialin VPDN サブグループを作成し、トンネルを開始します。

ステップ 4

initiate to ip ip-address

例:

Router(config-vpdn-grp)# initiate to 192.168.1.1
Router(config-vpdn-grp)#
 

要求のトンネリング先にするアドレスを指定します。

このコマンドの詳しい説明およびその他の設定可能なパラメータについては、『 Cisco IOS Dial Technologies Command Reference 』を参照してください。

ステップ 5

protocol { l2f | l2tp | pppoe | any }

例:

Router(config-vpdn-grp)# protocol pppoe
Router(config-vpdn-grp)#
 

VPDN サブグループが確立できるセッションのタイプを指定します。

ステップ 6

exit

例:

Router(config-vpdn-grp)# exit
Router(config-vpdn)#
 

VPDN グループの設定を終了します。

ステップ 7

exit

例:

Router(config-vpdn)# exit
Router(config)#
 

VPDN の設定を終了し、グローバル コンフィギュレーション モードに戻ります。

ファスト イーサネット WAN インターフェイスの設定

このシナリオでは、PPPoE クライアント(お使いの Cisco ルータ)は内部と外部の両方で 10/100-Mbps イーサネット インターフェイスを介して通信します。


) Cisco 1800 シリーズのサービス統合型固定構成ルータには、ファスト イーサネット ポート FE0 および FE1 に関するハードウェア制限があります。半二重モードでトラフィックが許容量の 100 % 以上(各方向に 5 Mbps 以上発生することと同等)になると、インターフェイスでは過度の衝突が発生し、1 秒ごとにリセットされます。この問題を回避するため、トラフィックの許容量を 100 % 未満に制限する必要があります。


ファスト イーサネット WAN インターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface fastethernet 0
Router(config-if)#
 

ファスト イーサネット WAN インターフェイスに対するインターフェイス コンフィギュレーション モードを開始します。

Cisco 1800 サービス統合型ルータには、2 つのファスト イーサネット WAN インターフェイスが搭載されています。次の手順を使用して、これらのインターフェイスのいずれか、または両方を設定できます。

ステップ 2

pppoe-client dial-pool-number number

例:

Router(config-if)# pppoe-client dial-pool-number 1
Router(config-if)#
 

PPPoE クライアントを設定し、クローニングに使用するダイヤラ インターフェイスを指定します。

ステップ 3

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

ファスト イーサネット インターフェイスとそれに対して行った設定変更をイネーブルにします。

ステップ 4

exit

例:

Router(config-if)# exit
Router(config)#
 

ファスト イーサネット インターフェイスのコンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ダイヤラ インターフェイスの設定

ダイヤラ インターフェイスは、デフォルトのルーティング情報、カプセル化プロトコル、および使用するダイヤラ プールなど、クライアントからのトラフィックを処理する方法を示します。ダイヤラ インターフェイスは、仮想アクセスのクローニングにも使用されます。ファスト イーサネット インターフェイスには、複数の PPPoE クライアント セッションを設定できますが、セッションごとに別個のダイヤラ インターフェイスと別個のダイヤラ プールを使用する必要があります。

ルータの一方のファスト イーサネット LAN インターフェイスに対してダイヤラ インターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

interface dialer dialer-rotary-group-number

例:

Router(config)# interface dialer 0
Router(config-if)#
 

ダイヤラ インターフェイス(番号 0 ~ 255)を作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip address negotiated

例:

Router(config-if)# ip address negotiated
Router(config-if)#
 

インターフェイスの IP アドレスを PPP/IPCP(IP Control Protocol)アドレス ネゴシエーションで取得することを指定します。

ステップ 3

ip mtu bytes

例:

Router(config-if)# ip mtu 1492
Router(config-if)#
 

IP Maximum Transmission Unit(MTU; 最大伝送ユニット)のサイズを設定します。デフォルトの最小値は 128 バイトです。イーサネットの最大値は 1492 バイトです。

ステップ 4

encapsulation encapsulation-type

例:

Router(config-if)# encapsulation ppp
Router(config-if)#
 

送受信中のデータ パケットに対するカプセル化タイプを PPP に設定します。

ステップ 5

ppp authentication { protocol1 [ protocol2 ...]}

例:

Router(config-if)# ppp authentication chap
Router(config-if)#
 

PPP 認証方式を Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェイク認証プロトコル)に設定します。

このコマンドの詳しい説明およびその他の設定可能なパラメータについては、『 Cisco IOS Security Command Reference 』を参照してください。

ステップ 6

dialer pool number

例:

Router(config-if)# dialer pool 1
Router(config-if)#
 

特定の宛先サブネットワークへの接続に使用するダイヤラ プールを指定します。

ステップ 7

dialer-group group-number

例:

Router(config-if)# dialer group 1
Router(config-if)#
 

ダイヤラ グループ(1 ~ 10)にダイヤラ インターフェイスを割り当てます。

ヒント ダイヤラ グループを使用して、ルータへのアクセスを制御します。

ステップ 8

exit

例:

Router(config-if)# exit
Router(config)#
 

ダイヤラ 0 インターフェイスの設定を終了します。

ステップ 9

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

例:

Router(config)# dialer-list 1 protocol ip permit
Router(config)#
 

ダイヤラ リストを作成し、ダイヤル グループを関連付けます。パケットは、指定されたインターフェイス ダイヤラ グループを通じて転送されます。

このコマンドの詳しい説明およびその他の設定可能なパラメータについては、『 Cisco IOS Dial Technologies Command Reference 』を参照してください。

ステップ 10

ip route prefix mask { interface-type interface-number }

例:

Router(config)# ip route 10.10.25.2 0.255.255.255 dialer 0
Router(config)#
 

ダイヤラ 0 インターフェイスのデフォルト ゲートウェイに IP ルートを設定します。

このコマンドの詳細および設定可能なその他のパラメータについては、『 Cisco IOS IP Command Reference, Volume 2; Routing Protocols 』を参照してください。

ネットワーク アドレス変換の設定

Network Address Translation(NAT; ネットワーク アドレス変換)は、ダイヤラ インターフェイスによって割り当てられたグローバル アドレスを使用して、標準のアクセス リストに一致するアドレスからのパケットを変換します。内部インターフェイスを介してルータに到達したパケット、ルータから発信されたパケット、またはその両方のパケットについて、可能なアドレス変換がアクセス リストで確認されます。NAT には、スタティック アドレス変換もダイナミック アドレス変換も設定できます。

外部のファスト イーサネット WAN インターフェイスにダイナミック NAT を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

ip nat pool name start-ip end-ip { netmask netmask | prefix-length prefix-length }

例:

Router(config)# ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255
Router(config)#
 

NAT 用のグローバル IP アドレスのプールを作成します。

ステップ 2

ip nat inside source {list access-list-number } {interface type number | pool name } [overload]

例 1:

Router(config)# ip nat inside source list 1 interface dialer 0 overload
 

または

例 2:

Router(config)# ip nat inside source list acl1 pool pool1
 

内部インターフェイス上のダイナミック アドレス変換をイネーブルにします。

最初の例は、アクセス リスト 1 で許可されたアドレスが、ダイヤラ インターフェイス 0 に指定されているいずれかのアドレスに変換されることを示しています。

次の例は、アクセス リスト acl1 で許可されたアドレスが、NAT プール pool1 に指定されたいずれかのアドレスに変換されることを示しています。

このコマンドの詳しい説明とその他の設定可能なパラメータ、およびスタティック変換をイネーブルにする方法については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services 』を参照してください。

ステップ 3

interface type number

例:

Router(config)# interface vlan 1
Router(config-if)#
 

NAT の内部インターフェイスにする VLAN(ファスト イーサネット LAN インターフェイスが存在する)に対して、コンフィギュレーション モードを開始します。

ステップ 4

ip nat {inside | outside}

例:

Router(config-if)# ip nat inside
Router(config-if)#
 

指定の VLAN インターフェイスを NAT の内部インターフェイスとして識別します。

このコマンドの詳しい説明とその他の設定可能なパラメータ、およびスタティック変換をイネーブルにする方法については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services 』を参照してください。

ステップ 5

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

イーサネット インターフェイスに対する設定変更をイネーブルにします。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

ファスト イーサネット インターフェイスに対するコンフィギュレーション モードを終了します。

ステップ 7

interface type number

例:

Router(config)# interface fastethernet 0
Router(config-if)#
 

NAT の外部インターフェイスとするファスト イーサネット WAN インターフェイス(FE0 または FE1)に対して、コンフィギュレーション モードを開始します。

ステップ 8

ip nat { inside | outside }

例:

Router(config-if)# ip nat outside
Router(config-if)#
 

指定の WAN インターフェイスを NAT の外部インターフェイスとして識別します。

このコマンドの詳しい説明とその他の設定可能なパラメータ、およびスタティック変換をイネーブルにする方法については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services 』を参照してください。

ステップ 9

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

イーサネット インターフェイスに対する設定変更をイネーブルにします。

ステップ 10

exit

例:

Router(config-if)# exit
Router(config)#
 

ファスト イーサネット インターフェイスに対するコンフィギュレーション モードを終了します。

ステップ 11

access-list access-list-number { deny | permit} source [ source-wildcard ]

例:

Router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

変換が必要なアドレスを示す標準アクセス リストを定義します。

(注) その他のアドレスはすべて、暗黙的に拒否されます。


) NAT を仮想テンプレート インターフェイスで使用する場合は、ループバック インターフェイスを設定する必要があります。ループバック インターフェイスの設定の詳細については、第 1 章「ルータの基本設定」を参照してください。


NAT コマンドの詳細については、Cisco IOS Release 12.3 のマニュアル セットを参照してください。NAT の概要については、 付録 B「概要」 を参照してください。

設定例

次の設定例は、この章で説明した PPPoE シナリオのコンフィギュレーション ファイルの一部を示しています。

VLAN インターフェイスの IP アドレスは 192.168.1.1、サブネット マスクは 255.255.255.0 です。NAT は内部と外部に設定されています。


) VLAN インターフェイスは LAN 上にあるので、ここではプライベート IP アドレスを使用しています。



) 「(default)」のマークが付いているコマンドは、show running-config コマンドを実行すると自動的に生成されます。


!
vpdn enable
vpdn-group 1
request-dialin
protocol pppoe
!
interface vlan 1
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast (default)
ip nat inside
!
interface FastEthernet 0
ip address 192.1.12.2 255.255.255.0
no ip directed-broadcast (default)
ip nat outside
!
interface dialer 1
ip address negotiated
ppp authentication chap
dialer pool 1
dialer-group 1
!
dialer-list 1 protocol ip permit
ip nat inside source list 1 interface dialer 1 overload
ip classless (default)
ip route 10.10.25.2 0.255.255.255 dialer 1
!

設定の確認

NAT の設定を確認するには、特権 EXEC モードで show ip nat statistics コマンドを使用します。次の例のような確認用の出力が表示されます。

Router# show ip nat statistics
Total active translations: 0 (0 static, 0 dynamic; 0 extended)
Outside interfaces:
FastEthernet4
Inside interfaces:
Vlan1
Hits: 0 Misses: 0
CEF Translated packets: 0, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 1 interface Dialer0 refcount 0
Queued Packets: 0