Cisco 1812J ソフトウェア コンフィギュレーション ガイド(最新版)
PPP over ATM と NAT の設定
PPP over ATM と NAT の設定
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

PPP over ATM と NAT の設定

ダイヤラ インターフェイスの設定

ATM WAN インターフェイスの設定

DSL シグナリング プロトコルの設定

ADSL の設定

設定の確認

SHDSL の設定

設定の確認

ネットワーク アドレス変換の設定

設定例

設定の確認

PPP over ATM と NAT の設定

Cisco 1801、Cisco 1802、および Cisco 1803 アクセス ルータは、Point-to-Point Protocol over Asynchronous Transfer Mode(PPPoA)クライアントと Network Address Translation(NAT; ネットワーク アドレス変換)をサポートします。

ルータの背後の LAN には、複数の PC を接続できます。PC からのトラフィックに対しては、PPPoA セッションに送信する前に暗号化やフィルタリングなどを行うことができます。PPP over ATM により、ダイヤル ネットワークのような簡素化されたアドレス処理と単純なユーザ検証がネットワーク ソリューションで実現します。図 4-1 に、Cisco ルータに PPPoA クライアントと NAT を設定する一般的な配置シナリオを示します。このシナリオでは、ATM 接続に単一のスタティック IP アドレスを使用しています。

図 4-1 PPP over ATM と NAT

 

 

1

複数のネットワーク接続デバイス(デスクトップ、ラップトップ PC、スイッチ)を使用するスモール ビジネス

2

ファスト イーサネット LAN インターフェイス(NAT の内部インターフェイス、192.168.1.1/24)

3

PPPoA クライアント(Cisco 1801、Cisco 1802、または Cisco 1803 ルータ)

4

NAT が実行されるポイント

5

ATM WAN インターフェイス(NAT の外部インターフェイス)

6

クライアントと ISP の PPPoA サーバ間の PPPoA セッション

このシナリオでは、ファスト イーサネット LAN 上のスモール ビジネスまたはリモート ユーザは、WAN 接続で次のプロトコルを使用して、Internet Service Provider(ISP; インターネット サービス プロバイダー)に接続できます。

Cisco 1801 ルータを使用する Plain Old Telephone Service(POTS; 一般電話サービス)経由の Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)

Cisco 1802 ルータを使用する ADSL over Integrated Services Digital Network(ISDN;サービス統合デジタル ネットワーク)

Cisco 1803 ルータを使用する Single-pair High-speed Digital Subscriber Line(G.SHDSL; シングルペア高ビットレート デジタル加入者線)

ファスト イーサネット インターフェイスは、LAN を通じてデータ パケットを伝送し、ATM インターフェイスの PPP 接続にオフロードします。ATM トラフィックはカプセル化され、ADSL、ISDN、または G.SHDSL 回線で送信されます。ISP との接続には、ダイヤラ インターフェイスが使用されます。

PPPoA

ルータ上の PPPoA クライアント機能により、ATM インターフェイスでの PPPoA クライアント サポートが可能になります。仮想アクセスのクローニングには、ダイヤラ インターフェイスを使用する必要があります。ATM インターフェイスには、複数の PPPoA クライアント セッションを設定できますが、セッションごとに別個のダイヤラ インターフェイスと別個のダイヤラ プールを使用する必要があります。

PPPoA セッションは、Cisco 1800 シリーズ ルータによってクライアント側で開始されます。

NAT

NAT(Cisco ルータの端に点線で表示)は、2 つのアドレス指定ドメインと内部送信元アドレスを示します。送信元リストには、パケットがネットワークをどのように通過するかが定義されます。

設定作業

次の作業を実行して、このネットワーク シナリオを設定します。

「ダイヤラ インターフェイスの設定」

「ATM WAN インターフェイスの設定」

「DSL シグナリング プロトコルの設定」

「ネットワーク アドレス変換の設定」

「設定例」 には、これらの設定作業の結果を示した例が示されています。

ダイヤラ インターフェイスの設定

ダイヤラ インターフェイスは、デフォルトのルーティング情報、カプセル化プロトコル、および使用するダイヤラ プールなど、クライアントからのトラフィックを処理する方法を示します。また、仮想アクセスのクローニングにも使用されます。ATM インターフェイスには、複数の PPPoA クライアント セッションを設定できますが、セッションごとに別個のダイヤラ インターフェイスと別個のダイヤラ プールを使用する必要があります。

ルータ上の ATM インターフェイスに対してダイヤラ インターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

interface dialer dialer-rotary-group-number

例:

Router(config)# interface dialer 0
Router(config-if)#
 

ダイヤラ インターフェイス(番号 0 ~ 255)を作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip address negotiated

例:

Router(config-if)# ip address negotiated
Router(config-if)#
 

ダイヤラ インターフェイスの IP アドレスを PPP/IPCP(IP Control Protocol)アドレス ネゴシエーションで取得することを指定します。

ステップ 3

ip mtu bytes

例:

Router(config-if)# ip mtu 4470
Router(config-if)#
 

IP Maximum Transmission Unit(MTU; 最大伝送ユニット)のサイズを設定します。デフォルトの最小値は 128 バイトです。ATM の最大値は、4470 バイトです。

ステップ 4

encapsulation encapsulation-type

例:

Router(config-if)# encapsulation ppp
Router(config-if)#
 

送受信中のデータ パケットに対するカプセル化タイプを PPP に設定します。

ステップ 5

ppp authentication { protocol1 [ protocol2 ...]}

例:

Router(config-if)# ppp authentication chap
Router(config-if)#
 

PPP 認証方式を設定します。

この例では、Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェイク認証プロトコル)が適用されます。

このコマンドの詳しい説明およびその他の設定可能なパラメータについては、『 Cisco IOS Security Command Reference 』を参照してください。

ステップ 6

dialer pool number

例:

Router(config-if)# dialer pool 1
Router(config-if)#
 

特定の宛先サブネットワークへの接続に使用するダイヤラ プールを指定します。

ステップ 7

dialer-group group-number

例:

Router(config-if)# dialer-group 1
Router(config-if)#
 

ダイヤラ グループ(1 ~ 10)にダイヤラ インターフェイスを割り当てます。

ヒント ダイヤラ グループを使用して、ルータへのアクセスを制御します。

ステップ 8

exit

例:

Router(config-if)# exit
Router(config)#
 

ダイヤラ 0 インターフェイスの設定を終了します。

ステップ 9

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

例:

Router(config)# dialer-list 1 protocol ip permit
Router(config)#
 

ダイヤラ リストを作成し、ダイヤル グループを関連付けます。パケットは、指定されたインターフェイス ダイヤラ グループを通じて転送されます。

このコマンドの詳しい説明およびその他の設定可能なパラメータについては、『 Cisco IOS Dial Technologies Command Reference 』を参照してください。

ステップ 10

ip route prefix mask { interface-type interface-number }

例:

Router(config)# ip route 10.10.25.0 255.255.255.0 dialer 0
Router(config)#
 

ダイヤラ 0 インターフェイスのデフォルト ゲートウェイに IP ルートを設定します。

このコマンドの詳しい説明および設定可能なその他のパラメータについては、『 Cisco IOS IP Command Reference, Volume 1 of 4: Routing Protocols 』を参照してください。

ダイヤラ インターフェイスまたはダイヤラ プールを追加する必要がある場合は、この手順を繰り返します。

ATM WAN インターフェイスの設定

ATM インターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

interface type number

例:

Router(config)# interface atm 0
Router(config-if)#
 

ATM インターフェイス(ルータの背面に ADSLoPOTS または G.SHDSL というラベルがあります)に対するインターフェイス コンフィギュレーション モードを開始します。

(注) このインターフェイスは、ルータの基本設定時に初期設定されています。「WAN インターフェイスの設定」を参照してください。

ステップ 2

pvc vpi / vci

例:

Router(config-if)# pvc 8/35
Router(config-if-atm-vc)#
 

ルータが通信する各エンド ノード(最大 10 台)用に ATM PVC を作成します。ATM 仮想回線コンフィギュレーション モードを開始します。

PVC が定義されると、AAL5SNAP カプセル化がデフォルトで定義されます。この設定を変更するには、 に示すように encapsulation コマンドを使用します。VPI および VCI 引数は同時に 0 に設定できません。一方が 0 の場合、もう一方は 0 にできません。

このコマンドの詳しい説明およびその他の設定可能なパラメータについては、『 Cisco IOS Wide-Area Networking Command Reference 』を参照してください。

ステップ 3

encapsulation { aal5auto | aal5autoppp virtual-template number [ group group-name ] | aal5ciscoppp virtual-template number | aal5mux protocol | aal5nlpid | aal5snap }

例:

Router(config-if-atm-vc)# encapsulation aal5mux ppp dialer
Router(config-if-atm-vc)#
 

PVC のカプセル化タイプを指定し、ダイヤラ インターフェイスに戻ります。

このコマンドの詳しい説明およびその他の設定可能なパラメータについては、『 Cisco IOS Wide-Area Networking Command Reference 』を参照してください。

ステップ 4

dialer pool-member number

例:

Router(config-if-atm-vc)# dialer pool-member 1
Router(config-if-atm-vc)#
 

ダイヤラ プロファイル ダイヤリング プールのメンバーとして、ATM インターフェイスを指定します。プール番号は 1 ~ 255 の範囲内にする必要があります。

ステップ 5

no shutdown

例:

Router(config-if-atm-vc)# no shutdown
Router(config-if)#
 

ATM インターフェイスに対するインターフェイスおよび設定の変更をイネーブルにします。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

ATM インターフェイスに対するコンフィギュレーション モードを終了します。

DSL シグナリング プロトコルの設定

DSL シグナリングは、ISP への接続用に ATM インターフェイスに設定する必要があります。Cisco 1801 は POTS を介した ADSL シグナリングを、Cisco 1802 は ISDN を介した ADSL シグナリングを、Cisco 1803 は SHDSL シグナリングをそれぞれサポートします。

適切な DSL シグナリング プロトコルを設定するには、設定しているルータに基づいて次のいずれかの項を参照してください。

「ADSL の設定」

「SHDSL の設定」

ADSL の設定

表 4-1 には、ADSL シグナリングのデフォルト設定を示します。

 

表 4-1 ADSL のデフォルト設定

アトリビュート
説明
デフォルト値

動作モード

ATM インターフェイスの Digital Subscriber Line(DSL; デジタル加入者線)の動作モードを指定します。

ADSL over POTS:ANSI または ITU フル レート、または自動選択。

ADSL over ISDN:ITU フル レート、ETSI、または自動選択。

Auto

マージン損失

マージン損失の発生可能回数を指定します。

トレーニング ログ

トレーニング ログの有効化と無効化を切り替えます。

ディセーブル

これらの設定を変更する場合は、グローバル コンフィギュレーション モードで次のいずれかのコマンドを使用します。

dsl operating-mode (ATM インターフェイス コンフィギュレーション モードから)

dsl lom integer

dsl enable-training-log

これらのコマンドの詳細については、『Cisco IOS Wide-Area Networking Command Reference』を参照してください。

設定の確認

設定に誤りがないことを確認するには、特権 EXEC モードで show dsl interface atm 0 コマンドを使用します。

SHDSL の設定

SHDSL シグナリングを使用するように、ルータの DSL コントローラを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

controller dsl port

例:

Router(config)# controller dsl 0
Router(config-controller)#
 

DSL コントローラに対するコンフィギュレーション モードを開始します。

ステップ 2

line-term { co | cpe }

例:

Router(config-controller)# line-term co
Router(config-controller)#
 

DSL 回線の終端が Central Office(CO; セントラル オフィス)であるか、Customer Premises Equipment(CPE; 顧客宅内機器)であるかを指定します。

ステップ 3

exit

例:

Router(config-controller)# exit
Router(config)#
 

コントローラ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 4

mode protocol

例:

Router(config)# mode atm
Router(config-controller)#
 

DSL コントローラのモードを指定し、コントローラ コンフィギュレーション モードを開始します。

ステップ 5

line-mode { 4-wire enhanced | 4-wire standard | 2-wire }

例:

Router(config-controller)# line-mode 4-wire standard
Router(config-controller)#
 

この DSL 接続の動作が 2 線モードであるか、4 線標準モードであるか、または 4 線拡張モードであるかどうかを指定します。


line mode 4-wire は、デフォルトで 4 線拡張モードに設定されます。


ステップ 6

ignore-error-duration number

例:

Router(config-controller)# ignore-error-duration 15
Router(config-controller)#
 

エラーを無視する時間(15 ~ 30 秒)を指定します。

ステップ 7

exit

例:

Router(config-controller)# exit
Router(config)#
 

コントローラ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。


) Cisco ルータを欧州ネットワークに組み込む場合は、次のいずれかのコマンドを使用してください。

CO モードの場合は、dsl dsl-mode shdsl symmetric annex {A | B | B-ANFP} コマンドを使用して annex B または B-ANFP を選択します。

CPE モードの場合は、dsl dsl-mode shdsl symmetric annex {A | A-B | A-B-ANFP | B | B-ANFP} を使用してオプション A を除く任意のオプションを選択します。

ルータでは、デフォルトで annex A が使用されます(米国)。


設定の確認

設定に誤りがないことを確認するには、特権 EXEC モードで show controllers dsl コマンドを使用します。

Router# show controllers dsl 0
DSL 0 controller UP
SLOT 0: Globespan xDSL controller chipset
Line Mode: Four Wire Standard Mode
DSL mode: SHDSL Annex A
Frame mode: Utopia
Configured Line rate: Auto
Line Re-activated 6 times after system bootup
LOSW Defect alarm: ACTIVE
CRC per second alarm: ACTIVE
Line termination: CPE
 
Current 15 min CRC: 0
Current 15 min LOSW Defect: 0
Current 15 min ES Defect: 0
Current 15 min SES Defect: 0
Current 15 min UAS Defect: 33287
 
Previous 15 min CRC Defect: 0
Previous 15 min LOSW Defect: 0
Previous 15 min ES Defect: 0
Previous 15 min SES Defect: 0
Previous 15 min UAS Defect: 0
 
Line-0 status
Chipset Version: 0
Firmware Version: A388
Modem Status: Data, Status 1
Last Fail Mode: No Failure status:0x0
Line rate: 2312 Kbps
Framer Sync Status: In Sync
Rcv Clock Status: In the Range
Loop Attenuation: 341.1450 dB
Transmit Power: 7.5 dB
Receiver Gain: 22.5420 dB
SNR Sampling: 36.8590 dB
Dying Gasp: Present
 

ネットワーク アドレス変換の設定

Network Address Translation(NAT; ネットワーク アドレス変換)は、ダイヤラ インターフェイスによって割り当てられたグローバル アドレスを使用して、標準のアクセス リストに一致するアドレスからのパケットを変換します。内部インターフェイスを介してルータに到達したパケット、ルータから発信されたパケット、またはその両方のパケットについて、可能なアドレス変換がアクセス リストで確認されます。NAT には、スタティック アドレス変換もダイナミック アドレス変換も設定できます。

外部 ATM WAN インターフェイスにダイナミック NAT を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

ip nat pool name start-ip end-ip { netmask netmask | prefix-length prefix-length }

例:

Router(config)# ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255
Router(config)#
 

NAT 用のグローバル IP アドレスのプールを作成します。

ステップ 2

ip nat inside source {list access-list-number } {interface type number | pool name } [overload]

例 1:

Router(config)# ip nat inside source list 1 interface dialer 0 overload
 

または

例 2:

Router(config)# ip nat inside source list acl1 pool pool1
 

内部インターフェイス上のダイナミック アドレス変換をイネーブルにします。

最初の例は、アクセス リスト 1 で許可されたアドレスが、ダイヤラ インターフェイス 0 に指定されているいずれかのアドレスに変換されることを示しています。

次の例は、アクセス リスト acl1 で許可されたアドレスが、NAT プール pool1 に指定されたいずれかのアドレスに変換されることを示しています。

このコマンドの詳しい説明とその他の設定可能なパラメータ、およびスタティック変換をイネーブルにする方法については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services 』を参照してください。

ステップ 3

interface type number

例:

Router(config)# interface vlan 1
Router(config-if)#
 

NAT の内部インターフェイスにする VLAN(ファスト イーサネット LAN インターフェイス(FE2 -FE9)が存在する)に対して、コンフィギュレーション モードを開始します。

ステップ 4

ip nat {inside | outside}

例:

Router(config-if)# ip nat inside
Router(config-if)#
 

ファスト イーサネット LAN インターフェイスを内部インターフェイスとして、NAT を適用します。

このコマンドの詳しい説明とその他の設定可能なパラメータ、およびスタティック変換をイネーブルにする方法については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services 』を参照してください。

ステップ 5

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

イーサネット インターフェイスに対する設定変更をイネーブルにします。

ステップ 6

exit

例:

Router(config-if)# exit
Router(config)#
 

ファスト イーサネット インターフェイスに対するコンフィギュレーション モードを終了します。

ステップ 7

interface type number

例:

Router(config)# interface fastethernet 0
Router(config-if)#
 

NAT の外部インターフェイスとする ATM WAN インターフェイス(FE0 または FE1)に対して、コンフィギュレーション モードを開始します。

ステップ 8

ip nat {inside | outside}

例:

Router(config-if)# ip nat outside
Router(config-if)#
 

指定の WAN インターフェイスを NAT の外部インターフェイスとして識別します。

このコマンドの詳しい説明とその他の設定可能なパラメータ、およびスタティック変換をイネーブルにする方法については、『 Cisco IOS IP Command Reference, Volume 1 of 4: Addressing and Services 』を参照してください。

ステップ 9

no shutdown

例:

Router(config-if)# no shutdown
Router(config-if)#
 

イーサネット インターフェイスに対する設定変更をイネーブルにします。

ステップ 10

exit

例:

Router(config-if)# exit
Router(config)#
 

ATM インターフェイスに対するコンフィギュレーション モードを終了します。

ステップ 11

access-list access-list-number { deny | permit} source [ source-wildcard ]

例:

Router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

変換が必要なアドレスを許可する標準アクセス リストを定義します。

(注) その他のアドレスはすべて、暗黙的に拒否されます。


) NAT を仮想テンプレート インターフェイスで使用する場合は、ループバック インターフェイスを設定する必要があります。ループバック インターフェイスの設定については、第 1 章「ルータの基本設定」を参照してください。


NAT コマンドの詳細については、Cisco IOS Release 12.3 のマニュアル セットを参照してください。NAT の概要については、 付録 B「概要」 を参照してください。

設定

次の設定例は、この章で説明した PPPoA シナリオにおけるクライアントのコンフィギュレーション ファイルの一部を示します。

VLAN インターフェイスの IP アドレスは 192.168.1.1、サブネット マスクは 255.255.255.0 です。NAT は内部と外部に設定されています。


) 「(default)」のマークが付いているコマンドは、show running-config コマンドを実行すると自動的に生成されます。


!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly (default)
!
interface ATM0
no ip address
ip nat outside
ip virtual-reassembly
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface Dialer0
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
!
ip classless (default)
!
ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 0.0.0.255
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
 
ip route 10.10.25.2 0.255.255.255 dialer 0
!

設定の確認

PPPoA クライアントと NAT の設定を確認するには、特権 EXEC モードで show ip nat statistics コマンドを使用します。次の例のような確認用の出力が表示されます。

Router# show ip nat statistics
Total active translations: 0 (0 static, 0 dynamic; 0 extended)
Outside interfaces:
ATM0
Inside interfaces:
Vlan1
Hits: 0 Misses: 0
CEF Translated packets: 0, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 1 interface Dialer0 refcount 0
Queued Packets: 0