Cisco ONS 15454 DWDM リファレンス マニュアル 製品およびソフトウェア リリース 9.2
疑似コマンド ライン インターフェイス リファ レンス
疑似コマンド ライン インターフェイス リファレンス
発行日;2012/05/09 | 英語版ドキュメント(2011/02/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 27MB) | フィードバック

目次

疑似コマンド ライン インターフェイス リファレンス

enable shelf/slot

configure terminal

show modules

show vlans

show interfaces

show policy-maps

show policy-map name

show policy-map type port

show controllers type port

show vlan profiles

show vlan profiles name

show ethernet service instance name

show users

reload

show history

show startup-config

show ip igmp snooping groups vlan vlanid

show lacp [detail]

ethernet oam remote-loopback

show ethernet oam discovery

show ethernet oam statistics

show ethernet oam status

show ethernet oam summary

clear ethernet cfm

clear ethernet cfm statistics

show ethernet cfm domain

show ethernet cfm maintenance-points local

show ethernet cfm maintenance-points

show ethernet cfm mpdb

show ethernet cfm statistics

show interfaces rep

show rep topology

interface channel-group

ethernet cfm ieee

ethernet cfm domain

ethernet cfm service

rep admin svlan

mac-address-table learning vlan vlanid

[no] mac-address-table learning interface type port

[no] vlan vlan-id

interface gigabitethernet port

interface tengigabitethernet port

policy-map name

[no] mvr

mvr vlan

mvr group ip address count

ethernet cfm cc_interval interval

service service_name

continuity-check

name vlan name

protected

ip igmp snooping

ip igmp snooping immediate-leave

ip igmp snooping report-suppression

channel-group channel-number mode chanlgrp-mode

channel-group channel-number hash chanlgrp-hash

channel-group channel-number expected speed chanlgrp-speed

description description

ethernet oam

ethernet oam mode

ethernet oam link-monitor frame

ethernet oam link-monitor frame-period

ethernet oam link-monitor frame-seconds

ethernet oam link-monitor high-threshold

ethernet oam remote-failure link-fault

ethernet cfm mip

ethernet cfm mep

ethernet cfm interface

rep segment

rep stcn

rep preempt delay

rep preempt

rep preempt segment

rep block port

shutdown

mtu bytes

speed auto|1000, 10000

flowcontrol on|off

switchport mode trunk

switchport mode dot1q-tunnel

service-policy input name

service-policy output name

service instance ethernet name

l2protocol-tunnel

[no] switchport port-security mac-address mac-address

ip igmp snooping mrouter

encapsulation default

encapsulation dot1q first cvlan last cvlan

encapsulation untagged

bridge-domain svlan

police cir percent % bc bytes be bytes

set cos number

wrr-queue cos-map queue-id cos1 … cosn

wrr-queue queue-id weight 1-16 bandwidth percent %

疑似コマンド ライン インターフェイス リファレンス

この章では、GE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードの Pseudo-IOS Command Line Interface(PCLI; 疑似コマンド ライン インターフェイス)について説明します。


) 特に指定のない限り、「ONS 15454」は、ANSI と ETSI 両方のシェルフ アセンブリを指します。


C.1 PCLI の概要

PCLI は、レイヤ 2(L2)モードの GE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードに IOS のようなコマンド ライン インターフェイスを提供します。また、PCLI では Cisco IOS Modular QoS CLI(MQC; モジュラ QoS CLI)を採用しています。

PCLI は、GE_XP、10GE_XP、GE_XPE、および 10GE_XPE のカード情報の操作、プロビジョニング、および取得を実行できるテキスト インターフェイスです。PCLI はノード コントローラの Timing, Communications, and Control(TCC)で実行され、カード レベルの情報にアクセスします。PCLI は CORBA クライアントとして機能し、CTC または TL1 と同じプロビジョニング メカニズムを提供します。CTC から [Tools] > [Open Pseudo IOS Connection] メニュー オプションを選択するか、[Network View] でノードを右クリックしで [Open Pseudo IOS Connection] を選択すると、PCLI にアクセスできます。PCLI テキスト インターフェイスにアクセスするには、Telnet または SSH を使用してシェル セッションを開き、GE_XP、10GE_XP、GE_XPE、または 10GE_XPE カードに接続して、IOS のようなコマンドを入力します。

Windows XP から PCLI にアクセスするには、Windows のコマンド プロンプトで次のコマンドを入力します。

telnet <node name> <port number>
 

Solaris 8 から PCLI にアクセスするには、次のコマンドを入力します。

ssh -p <Port Number> <Node Name>
telnet <Node Name> <Port Number>
 

PCLI シェルでは 454 マルチシェルフ アーキテクチャをサポートしています。マルチシェルフでは 16 のシェルフをサポートしており、各シェルフには 17 のスロットがあります。GE_XP、10GE_XP、GE_XPE、または 10GE_XPE カードは、Input/Output(IO; 入出力)スロットまたはシェルフに挿入できます。また、PCLI には指定されたシェルフまたはスロットに仮想的に接続するためのコマンドがあります。ただし、非 X ポンダ スロットまたは L2 モードではない X ポンダ スロットへの接続はサポートされていません。PCLI では、ノード コントローラ 1 つに対して最大 16 の同時ログイン セッションをサポートしています。PCLI セッションからログアウトするか、アイドル タイマーがタイム アウトすると、セッションをキャンセルできます。


) PCLI は、CTC または TL1 を使用して設定されたアイドル ユーザ タイムアウト期間のセキュリティ ポリシーに従います。



) セキュリティ ポリシーの表示の詳細については、『Cisco ONS 15454 DWDM Procedure Guide』の「DLP-G189 Change Security Policy for Multiple Nodes」のタスクを参照してください。


特定のポート番号を使用してノードで PCLI セッションを開いた場合、PCLI セッションが使用しているポート番号を変更することはできません。非セキュア状態でノードおよびポートに接続する場合は、非セキュア モードのみに設定されたポート番号を使用します。また、セキュア状態でノードおよびポートに接続する場合は、セキュア モード用に設定されたポート番号を使用します。

C.1.1 PCLI のセキュリティ

PCLI では、アクセス メカニズムごとに、設定可能なポート番号を持つ設定可能でセキュアなアクセス、または設定可能で非セキュアなアクセスをサポートしています。これらの設定を表示または変更するには、CTC を使用します。デフォルトのアクセス状態は「非セキュア」で、デフォルトのポート番号は「65000」です。

PCLI は、Telnet を使用した非セキュアな接続と、Secure Shell(SSH; セキュア シェル)を使用したセキュアな接続をサポートとしています。これには、既存のシステムの Authentication, authorization and accounting(AAA; 認証、認可、アカウンティング)メカニズムを使用します。Network Element(NE; ネットワーク要素)で設定されたユーザ/パスワードを使用してログインします。ユーザ アカウントの管理には CTC または TL1 を使用します。


) 非セキュア状態で PCLI 接続にログインし、CTC を使用してセキュア状態の接続に変更した場合(あるいはその逆の場合)、CTC の設定が完了すると PCLI の非セキュア状態(場合によってはセキュア状態)は閉じられます。


アクセス状態(非セキュアまたはセキュア)の設定の詳細については、『 Cisco ONS 15454 DWDM Procedure Guide 』を参照してください。

C.2 PCLI コマンド モード

PCLI では 8 種類の異なるコマンド モードをサポートしています。コマンドを指定すると、各コマンド モードにアクセスできます。プロンプトが変化し、現在の新しいコマンド モードが示されます。その結果、有効なコマンド セットが変化し、そのモードで使用できるサブコマンドが示されます。

次のセクションでは、各コマンド モードでサポートされている PCLI コマンドを示します。

C.2.1 共通のコマンド

次のコマンドは、すべてのコマンド モードで共通です。

?:システム プロンプトに疑問符(?)を入力すると、各コマンド モードで使用できるコマンドの一覧が表示されます。

!:システム プロンプトに感嘆符(!)を入力すると、コメントが追加されます。

exit:システム プロンプトに exit を入力すると、現在のモードを終了します。

C.2.2 ユーザ EXEC モード

プロンプト: (>)

正常にログインすると、システムはユーザ Executive(EXEC)コマンド モードを開始します。ユーザ EXEC モードの PCLI コマンドの大部分は、システム動作を変更しません。ユーザ EXEC モードを使用すると、特定のシェルフやスロットの 1 つのカードに対して指定された時刻に表示することを制限しながら、1 つのセッションの間に複数の GE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードに対して作業できます。このモードでは、ノードのすべてのカードに及ぶシステム全体のパラメータが表示されます。

ユーザ EXEC モードでは次のコマンドがサポートされています。

enable shelf/slot

show modules

show users

C.2.3 特権 EXEC モード

プロンプト:(#)

一般的に、特権 EXEC コマンドを使用すると、リモート デバイスへの接続、基本的なテストの実行、およびシステム情報の表示を行うことができます。特権 EXEC モードの CLI コマンドの大部分は、プロビジョニングやシステム動作を変更または修正しません。最も一般的な EXEC コマンドは show コマンドです。このコマンドは設定や動作データの表示に使用され、プロビジョニングを修正する機能はありません。

特権 EXEC モードを開始するには、 enable shelf/slot コマンドを使用します。

特権 EXEC モードには次のコマンドがあります。

configure terminal

reload

show startup-config

show users

show ip igmp snooping groups vlan vlanid

show interfaces

show ethernet service instance name

show vlan profiles

show vlans

show modules

show controllers type port

show history

show policy-maps

show policy-map name

show policy-map type port

show lacp [detail]

ethernet oam remote-loopback

show ethernet oam discovery

show ethernet oam statistics

show ethernet oam status

show ethernet oam summary

clear ethernet cfm

clear ethernet cfm statistics

show ethernet cfm domain

show ethernet cfm maintenance-points local

show ethernet cfm maintenance-points

show ethernet cfm mpdb

show ethernet cfm statistics

show interfaces rep

show rep topology

C.2.4 グローバル コンフィギュレーション モード

プロンプト:ノード名# (Config)

特権 EXEC モードからグローバル コンフィギュレーション モードに入ります。グローバル コンフィギュレーション コマンドは、一般的に、1 つのプロトコルやインターフェイスのみではなくシステム全体に適用されます。グローバル コンフィギュレーション モードから、このセクションに示す他のコンフィギュレーション サブ モードを開始できます。

グローバル コンフィギュレーション モードを開始するには、 configure terminal コマンドを使用します。


) ノード名は、CTC を使用して設定できます。[Node view] > [General] > [General] > [Node Name] の順に選択します。


グローバル コンフィギュレーション モードには次のコマンドがあります。

interface channel-group

ethernet cfm ieee

ethernet cfm domain

ethernet cfm service

mac-address-table learning vlan vlanid

[no] mac-address-table learning interface type port

[no] vlan vlan-id

interface gigabitethernet port

interface tengigabitethernet port

policy-map name

[no] mvr

mvr vlan

mvr group ip address count

rep admin svlan

C.2.5 VLAN コンフィギュレーション モード

プロンプト:(config-vlan)

グローバル コンフィギュレーション モードから VLAN コンフィギュレーション モードに入ります。個々の VLAN のパラメータを設定できます。

VLAN コンフィギュレーション モードを開始するには、 vlan <vlanid> コマンドを使用します。

VLAN コンフィギュレーション モードには次のコマンドがあります。

name vlan name

protected

ip igmp snooping

ip igmp snooping immediate-leave

ip igmp snooping report-suppression

C.2.6 インターフェイス コンフィギュレーション モード

プロンプト:(config-if)

グローバル コンフィギュレーション モードからインターフェイス コンフィギュレーション モードに入ります。このモードおよび他のインターフェイス サブ モードでは、さまざまな機能がサポートされています。特定のモジュール インターフェイス(ポートなど)のプロビジョニングを設定できます。

インターフェイス コンフィギュレーション モードを開始するには、 interface gigabitethernet port コマンドまたは interface tengigabitethernet port コマンドを使用します。

インターフェイス コンフィギュレーション モードには次のコマンドがあります。

channel-group channel-number mode chanlgrp-mode

channel-group channel-number hash chanlgrp-hash

channel-group channel-number expected speed chanlgrp-speed

description description

ethernet oam

ethernet oam mode

ethernet oam link-monitor frame

ethernet oam link-monitor frame-period

ethernet oam link-monitor frame-seconds

ethernet oam link-monitor high-threshold

ethernet oam remote-failure link-fault

ethernet cfm mip

ethernet cfm mep

ethernet cfm interface

rep segment

rep stcn

rep preempt delay

rep preempt

rep preempt segment

rep block port

shutdown

mtu bytes

speed auto|1000, 10000

flowcontrol on|off

switchport mode trunk

switchport mode dot1q-tunnel

service-policy input name

service-policy output name

service instance ethernet name

l2protocol-tunnel

[no] switchport port-security mac-address mac-address

ip igmp snooping mrouter

C.2.7 サービス インスタンス コンフィギュレーション モード

プロンプト:(config-if-srv)

サービス インターフェイス コンフィギュレーション モードはインターフェイス コンフィギュレーション モードのサブ モードです。このモードは、Ethernet Flow Point(EFP; イーサネット フロー ポイント)などのサービス インターフェイスの定義に使用されます。EFP は特定のインターフェイスに固有です。複数の EFP をつないで、Ethernet Virtual Circuit(EVC; イーサネット仮想回線)を作成できます。

任意の組み合わせで encapsulation コマンドを使用して、EFP を柔軟に実装することができます。ただし、 dot1q および untagged コマンドは、選択モードの変換に使用する必要があります。また、 default コマンドはトランスペアレント モードの変換に使用する必要があります。encapsulation コマンドには次の制約事項が適用されます。

選択モードおよびトランスペアレント モードはポート全体に適用され、相互に排他的です。

encapsulation default はトランスペアレント変換用です。1 つのポートにつき 1 つのトランスペアレント サービス インスタンスのみを使用できます。

encapsulation untagged は、 cvlan タグを使用しない選択変換用です。動作が DOUBLE_ADD( rewrite ingress tag push dot1q <multipurpose vlan> second-dot1q <svlan> )である場合は、1 つのポートにつき 1 つのサービス インスタンスのみを使用できます。

サービス インスタンス コンフィギュレーション モードを開始するには、 service instance ethernet name コマンドを使用します。

サービス インスタンス コンフィギュレーション モードには次のコマンドがあります。

encapsulation default

encapsulation dot1q first cvlan last cvlan

encapsulation untagged

service-policy input name

bridge-domain svlan


) encapsulation コマンドと rewrite とコマンドは連携して機能します。これらのコマンドは、次の順序に従った場合にのみ有効です。

1. encapsulation コマンドを入力します。

2. rewrite コマンドを入力します。


 


) サービス インスタンス コンフィギュレーション モードを終了すると、サービス インスタンスを編集することはできません。これらのパラメータのいずれかを変更するには、サービス インスタンスを削除してから再作成します。


 

C.2.8 ポリシー マップ コンフィギュレーション モード

プロンプト:(config-pmap)

ポリシー マップを作成したり、既存のポリシー マップを変更するには、 policy-map コマンドを使用して、グローバル コンフィギュレーション モードからポリシー マップ コンフィギュレーション モードを開始します。このモードは Quality of Service(QoS)機能の一部です。

特定のインターフェイスに QoS ポリシーを適用するには、インターフェイスを識別してから service-policy コマンドを使用して既存のポリシーを適用し、グローバル コンフィギュレーション モードからインターフェイス コンフィギュレーション モードを開始する必要があります。QoS ポリシー マップのプロビジョニングには複数のGE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードからアクセスできます。

ポリシー マップ コンフィギュレーション モードを開始するには、グローバル コンフィギュレーション モードから policy-map name コマンドを入力します。

ポリシー マップ コンフィギュレーション モードには次のコマンドがあります。

police cir percent % bc bytes be bytes

set cos number

wrr-queue cos-map queue-id cos1 ... cosn

wrr-queue queue-id weight 1-16 bandwidth percent %

C.2.9 VLAN プロファイル コンフィギュレーション モード

プロンプト:(config-profile)

VLAN プロファイル コンフィギュレーション モードは、VLAN プロファイルのパラメータのプロビジョニングに使用できます。VLAN プロファイルは後で複数の VLAN に適用できます。VLAN プロファイルのプロビジョニングには複数の GE カードからアクセスできます。

VLAN プロファイル コンフィギュレーション モードを開始するには、グローバル コンフィギュレーション モードから vlan profile name コマンドを使用します。

VLAN プロファイル コンフィギュレーション モードには次のコマンドがあります。

police cir percent % bc bytes be bytes

enable shelf/slot

特権 EXEC モードを開始するには、ユーザ EXEC モードで enable コマンドを使用します。

enable shelf/slot

 
構文の説明

shelf/slot

シェルフおよびスロットの番号です。

 
コマンド モード

ユーザ EXEC

 
使用上のガイドライン

このコマンドを使用して、特権コンフィギュレーション モードを開始します。特権 EXEC モードを開始すると、特権コマンドを使用できます。ユーザ EXEC モードのプロンプトは大なり記号(>)で、特権 EXEC モードのプロンプトはポンド記号(#)であることに注意してください。

MSTP-176> enable 2/12
MSTP-176#
 

configure terminal

グローバル コンフィギュレーション モードを開始するには、特権 EXEC モードで configure terminal コマンドを使用します。

configure terminal

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド モード

特権 EXEC

 
使用上のガイドライン

このコマンドを使用して、グローバル コンフィギュレーション モードを開始します。

configure terminal コマンドを入力した後は、システム プロントが <node-name># から <node-name>(config)# に変わり、カードがグローバル コンフィギュレーション モードであることを示します。グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻るには、 exit と入力します。

MSTP-176# configure terminal
MSTP-176(config)#
 

show modules

GE_XP、10GE_XP、GE_XPE、または 10GE_XPE カードのサマリー情報(シェルフ/スロット/ポート、機器のタイプ、サービス ステート)を表示するには、ユーザ EXEC モードおよび特権 EXEC モードで show modules コマンドを使用します。

show modules

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

デフォルトの動作や値はありません。

 
コマンド モード

ユーザ EXEC、特権 EXEC

次に、 show modules コマンドの出力例を示します。

MSTP-176# show modules
Shelf/Slot/Port EquipType ServiceState
1/NA/NA BIC_UNKNOWN IS-NR
1/1 /NA XP_GE_LINE_CARD IS-NR
1/1 /1 PPM_1_PORT OOS-AU,AINS&UEQ
1/1 /2 PPM_1_PORT OOS-AU,AINS&UEQ
1/1 /8 PPM_1_PORT OOS-AU,AINS&UEQ
1/1 /9 PPM_1_PORT OOS-AU,AINS&UEQ
1/1 /11 PPM_1_PORT IS-NR
1/1 /15 PPM_1_PORT IS-NR
1/1 /16 PPM_1_PORT OOS-AU,AINS&UEQ
MSTP-176#

 

show vlans

VLAN 情報を表示するには、特権 EXEC モードで show vlans コマンドを使用します。

show vlans

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

デフォルトの動作または値はありません。

 
コマンド モード

特権 EXEC

次に、 show vlans コマンドの出力例を示します。この例では、指定された VLAN の GE_XP、10GE_XP、GE_XPE、または 10GE_XPE カードでの 1+1 の保護、MAC アドレス ラーニング、IGMP スヌーピング、即時脱退、およびレポートの抑制の状態を示しています。

MSTP-176# show vlans
IGMP
VLAN Name Prot MAC Learn Enable Immed Suppress
2 F F F F T
50 F F F F F
100 F F T F T
101 F F F F T
MSTP-176#

 

show interfaces

GE_XP、10GE_XP、GE_XPE、または 10GE_XPE に設定されたインターフェイスのポート レベルのパラメータと統計情報を表示するには、特権 EXEC モードで show interfaces コマンドを使用します。

show interfaces

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

特権 EXEC

次に、 show interfaces コマンドの出力例を示します。この例の出力は、カードのインターフェイスのタイプと数によって異なります。そのため、出力の一部のみを示します。

MSTP-176# show interfaces
Port 22 (Trunk), Port name:
Admin State: ADMIN_IS, Service State: IS_NR
Reach: LR, Wavelength: WV_1310, AIS Action: NONE
Flow Control: DISABLED, Duplex Mode: FULL, Speed: SPEED_10G, MTU: 9700
NI Mode: NNI, MAC Learning: DISABLED, IGMP Static Router Port: DISABLED
Ingress CoS: 0, Ethertype Inner/Outer: 8100/8100, Egress QoS: DISABLED
Committed Info Rate: 100, Burst Size Committed/Excess: BCKT_4K/BCKT_4K
ifInOctets: 196928, rxTotalPkts: 2896, ifInUcastPkts: 0
ifInMulticastPkts: 2896, ifInBroadcastPkts: 0
ifInDiscards: 0, ifOutOctets: 448072424, txTotalPkts: 132911365
ifOutMulticastPkts: 132911359, ifOutBroadcastPkts: 0
ifOutDiscards: 0, ifOutErrors: 0
dot3StatsAlignmentErrors: 0, dot3StatsFCSErrors: 0
dot3StatsFrameTooLong: 0, dot3StatsControlInUnknownOpCodes: 0
dot3StatsInPauseFrames: 0, dot3StatsOutPauseFrames: 0
etherStatsUndersizePkts: 0, etherStatsFragments: 0
etherStatsPkts: 132914261, etherStatsPkts64Octets: 0
65-127 Octets: 132914247, 128-255 Octets: 0
256-511 Octets: 0, 512-1023 Octets: 0
1024-1518 Octets: 0, 1519-1522: 0
etherStatsBroadcastPkts: 0, etherStatsMulticastPkts: 132914255
etherStatsOversizePkts: 0, etherStatsJabbers: 0
etherStatsOctets: 448269352, etherStatsCRCAlignErrors: 0
etherStatsOctets: 448269352, etherStatsCRCAlignErrors: 0
ifHCInOctets: 196928, ifHCInUcastPkts: 0
ifHCInMulticastPkts: 2896, ifHCInBroadcastPkts: 0
ifHCOutOctets: 448072424, ifHCOutMulticastPkts: 132911359
ifHCOutBroadcastPkts: 0, etherStatsHighCapacityPkts: 132914261
etherStatsHighCapacityOctets: 448269352
etherStatsHighCapacityPkts64Octets: 0
etherStatsHighCapacityPkts65to127Octets: 132914247
etherStatsHighCapacityPkts128to255Octets: 0
etherStatsHighCapacityPkts256to511Octets: 0
etherStatsHighCapacityPkts512to1023Octets: 0
etherStatsHighCapacityPkts1024to1518Octets: 0
cisRxReports: 2854, cisRxLeaves: 2
cisTxReports: 0, cisTxLeaves: 2
cisTxGeneralQueries: 2251, cisTxGroupSpecificQueries: 6
cisRxGeneralQueries: 35, RxGroupSpecificQueries 5
cisRxValidPackets: 2896, cisRxInvalidPackets: 0
MSTP-176#

show policy-maps

ノードのすべてのポリシー マップを表示するには、 show policy-maps コマンドを使用します。

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

特権 EXEC

次に、GE_XP、10GE_XP、GE_XPE、または 10GE_XPE カードのすべてのポリシー マップの例を示します。

MSTP-176# show policy-map
Policy Name: port1
Policy Type: SERVICE INSTANCE
CoS: 2
 
Policy Name: cos3
Policy Type: INGRESS
Ingress CoS: 3 Committed Info Rate: 80 Committed Burst Size: 1
Excess Burst Size: 2 Excess Info Rate: 100
MSTP-176#

 

show policy-map name

名前のないクラスの情報を表示するには、特権 EXEC モードで show policy-map コマンドを使用します。

show policy-map name

 
構文の説明

name

(任意)全設定を表示するサービス ポリシー マップの名前です。名前は、最大 31 文字まで指定できます。

 
デフォルト

既存のポリシー マップの設定が表示されます。

 
コマンド モード

特権 EXEC

show policy-map コマンドは、 policy-map name コマンドを使用して作成されたサービス ポリシー マップ設定を表示します。

 

次に、GE_XP、10GE_XP、GE_XPE、または 10GE_XPE カードの「pmapegress」というポリシー マップの内容を示します。

MSTP-176# show policy-maps pmapegress
Policy Name: pmapegress
Policy Type: EGRESS
CoS: 0 Queue: 0 Bandwidth: 15 Weight: 1
CoS: 1 Queue: 1 Bandwidth: 100 Weight: 1
CoS: 2 Queue: 2 Bandwidth: 100 Weight: 1
CoS: 3 Queue: 3 Bandwidth: 100 Weight: 1
CoS: 4 Queue: 4 Bandwidth: 100 Weight: 1
CoS: 5 Queue: 5 Bandwidth: 100 Weight: 1
CoS: 6 Queue: 6 Bandwidth: 100 Weight: 1
CoS: 7 Queue: 7 Bandwidth: 100 Weight: 1
MSTP-176#

show policy-map type port

ポートに設定されたすべてのポリシー マップを表示するには、特権 EXEC モードで show policy-map type port を使用します。

show policy-map type port

 
構文の説明

type port

インターフェイス タイプとポート番号です。

 
コマンド デフォルト

このコマンドにデフォルトの動作または値はありません。

 
コマンド モード

特権 EXEC

 
使用上のガイドライン

show policy-map type port コマンドは、指定されたインターフェイスのクラスの設定を表示します。

この項では、一般的な show policy-map type port コマンドの出力例を示します。この出力例は、カードのインターフェイスのタイプと数、およびイネーブルになっているオプションによって異なります。そのため、出力の一部のみを示します。出力は異なる場合があります。

MSTP-176# show policy-map int g 1
Policy Name: ingress
Policy Type: INGRESS
Ingress CoS: 3 Committed Info Rate: 50 Committed Burst Size: 4K
Excess Burst Size: 4K
 
Policy Name: new
Policy Type: EGRESS
CoS: 0 Queue: 0 Bandwidth: 100 Weight: 1
CoS: 1 Queue: 1 Bandwidth: 90 Weight: 2
CoS: 2 Queue: 0 Bandwidth: 100 Weight: 1
CoS: 3 Queue: 3 Bandwidth: 100 Weight: 1
CoS: 4 Queue: 4 Bandwidth: 100 Weight: 1
CoS: 5 Queue: 5 Bandwidth: 100 Weight: 1
CoS: 6 Queue: 6 Bandwidth: 100 Weight: 1
CoS: 7 Queue: 7 Bandwidth: 100 Weight: 1
MSTP-176#

show controllers type port

設置された Small Form-factor Pluggable(SFP; 着脱可能小型フォーム ファクタ)に関する情報を表示するには、特権 EXEC モードで show controllers type port コマンドを使用します。

show controllers type port

 
構文の説明

type port

インターフェイス タイプとポート番号です。

 
デフォルト

デフォルト設定はありません。

 
コマンド モード

特権 EXEC

この項では、一般的な show controllers type port コマンドの出力例を示します。

MSTP-176# show controllers g 2
Port 22 SFP is Present
Equipment Type : 1GE/1FC/2FC-1310nm
HW Part Number : 10-2273-01
HW Revision : A
Serial Number : FNS1032J435
CLEI Code : WMOTB17AAA
Product ID : ONS-SE-G2F-LX
Version ID : V01
 

MSTP-176#

show vlan profiles

設定されたすべての VLAN または特定の VLAN(VLAN ID または名前を指定した場合)のパラメータを表示するには、特権 EXEC モードで show vlan profiles コマンドを使用します。


) VLAN プロファイルとは、VLAN 属性の名前付きのセットです。プロファイルはインターフェイスの VLAN ID に関連付けることができます。プロファイルは複数の VLAN/インターフェイスのペアに添付できます。


show vlan profiles

 
コマンド モード

特権 EXEC

次に、 show vlan profiles コマンドによる出力例を示します。

MSTP-176# show vlan profiles
Name CIR BC PIR BE LinkIntegrity
a_profile 100 4 100 4 F
d_profile 200 4 100 4 T
e_profile 300 4 100 4 F
v_profile 400 4 100 4 T
 
MSTP-176#

show vlan profiles name

設定されたすべての VLAN または特定の VLAN(VLAN ID または名前を指定した場合)のパラメータを表示するには、特権 EXEC モードで show vlan profiles name コマンドを使用します。

 
構文の説明

name

VLAN 名で特定された 1 つの VLAN に関する情報を表示します。


) VLAN プロファイルとは、VLAN 属性の名前付きのセットです。プロファイルはインターフェイスの VLAN ID に関連付けることができます。プロファイルは複数の VLAN/インターフェイスのペアに添付できます。


 
コマンド モード

特権 EXEC

次に、 show vlan profiles name コマンドの出力例を示します。

MSTP-176# show vlan profiles a_profile
Name CIR BC PIR BE LinkIntegrity
a_profile 100 4 100 4 F
 

 

show ethernet service instance name

イーサネット カスタマー サービス インスタンスに関する情報を表示するには、特権 EXEC モードで show ethernet service instance name コマンドを使用します。

show ethernet service instance name

 
構文の説明

name

指定したサービス インスタンスのサービス インスタンス情報を表示します。

 
コマンド モード

特権 EXEC

 
使用上のガイドライン

このコマンドは、システム モニタリングおよびトラブルシューティングに便利です。

次に、 show ethernet service instance コマンドの出力例を示します。

MSTP-176# show ethernet service instance
Identifier Interface CE-Vlans
222 FastEthernet0/1 untagged,1-4093
10 FastEthernet0/2
222 FastEthernet0/2 200
333 FastEthernet0/2 default
10 FastEthernet0/3 300
11 FastEthernet0/3
10 FastEthernet0/4 300
10 FastEthernet0/6 untagged,1-4093
10 FastEthernet0/7 untagged,1-4093
10 FastEthernet0/8 untagged,1-4093
10 FastEthernet0/9 untagged
20 FastEthernet0/9
222 FastEthernet0/11 300-350,900-999
333 FastEthernet0/11 100-200,1000,1999-4093
222 FastEthernet0/12 20
333 FastEthernet0/12 10
10 FastEthernet0/13 10
20 FastEthernet0/13 20
30 FastEthernet0/13 30
200 FastEthernet0/13 222
200 FastEthernet0/14 200,222
300 FastEthernet0/14 333
555 FastEthernet0/14 555

 

show users

ノードのアクティブ ユーザに関する情報を表示するには、ユーザ EXEC モードまたは特権 EXEC モードで show users コマンドを使用します。

show users

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド モード

ユーザ EXEC または特権 EXEC

 
使用上のガイドライン

このコマンドは、ユーザ名、セキュリティ レベル、ユーザが使用しているアプリケーション、およびノード上のすべてのユーザのログイン時刻を表示します。

次に、 show users コマンドの出力例を示します。

MSTP-176# show users
User1, SUPERUSER, PCLI, loginTime:05.13.2000 10:08:29
User2, SUPERUSER, EMS, loginTime:05.13.2000 10:05:27
User3, SUPERUSER, EMS, loginTime:05.13.2000 09:39:35
User4, SUPERUSER, EMS, loginTime:05.13.2000 07:35:18
MSTP-176#

reload

カードをリセットするには、特権 EXEC モードで reload コマンドを使用します。

reload

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド モード

特権 EXEC

 
使用上のガイドライン

このコマンドは、現在使用しているカードをリセットします。

次に、 reload コマンドの出力例を示します。

MSTP-176> reload
Warning! Resetting this card may impact traffic.
Please confirm (yes/no): n
Command cancelled.
 
MSTP-176>

show history

(すべてのモードで)現在のセッションの間に入力したコマンドを一覧表示するには、 show history コマンドを使用します。

show history

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド モード

すべてのモード

 
使用上のガイドライン

show history コマンドでは、入力したコマンドの記録が表示されます。履歴バッファでは 100 個のコマンドを記録します。

show history コマンドは、 表 C-1 に示す特定のキーのヘルプと一緒に使用できます。

 

表 C-1 履歴キー

カード
ポートの説明

Ctrl+P または↑キー1

直前に入力されたコマンドから始めて逆順に、履歴バッファに保管されているコマンドを呼び出します。このキーを連続して繰り返すと、順に古いコマンドを再呼び出しします。

Ctrl+N キーまたは↓キー1

Ctrl+P または↑キーを使用してコマンドを呼び出したあと、履歴バッファ内のより新しいコマンドに戻ります。このキーを連続して繰り返すと、順に新しいコマンドを再呼び出しします。

1.矢印キーは、ANSI 互換端末のみで機能します。

次に、 show history コマンドの出力例を示します。ここでは、このセッションの間にユーザが特権 EXEC モードで入力したコマンドを一覧表示します。

MSTP-176# show history
help
show users
show history
MSTP-176#
 

show startup-config

GE_XP、10GE_XP、GE_XPE、または 10GE_XPE カードの現在の構成を表示するには、特権 EXEC モードで show startup-config コマンドを使用します。start-up config と running-config は同じです。

show startup-config

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド モード

特権 EXEC

 
コマンド デフォルト

デフォルト設定はありません。

次に、startup-config という名前のコンフィギュレーション ファイルの出力例の一部を示します。

MSTP-176# show startup-config
 
interface tengigabitethernet 22
speed 10000
mtu 9700
flowcontrol off
switchport mode trunk
switchport dot1q ethertype 8100
switchport dot1q ethertype inner 8100
no ip igmp snooping mrouter
switchport port-security mac-address blocked
no l2protocol-tunnel
link integrity action none
service instance ethernet
no shutdown
 
vlan profile a
no link integrity
police cir percent 100 pir percent 100 bc 4 be 4
 
no mac-address-table learning interface gigabitethernet 11
no mac-address-table learning interface gigabitethernet 13
no mac-address-table learning interface tengigabitethernet 21
no mac-address-table learning interface tengigabitethernet 22
end
MSTP-176#

 

show ip igmp snooping groups vlan vlanid

指定された SVLAN/MVLAN で Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)を通じて学習されたマルチキャスト グループを表示するには、特権 EXEC モードで show ip igmp groups vlan vlanid を使用します。

show ip igmp groups vlan vlanid

 
構文の説明

vlanid

VLAN ID 範囲は 1 ~ 4093 です。

 
コマンド モード

特権 EXEC

 
コマンド デフォルト

デフォルト設定はありません。

次に、VLAN 10 のマルチキャスト グループの出力例の一部を示します。

MSTP-176# show ip igmp sn gr vlan 128
MCAST IP ADDR VLAN Ports
224.1.1.1 128 ETHER(99)/SH-1/SL-13/PRT-2
224.1.1.2 128 ETHER(99)/SH-1/SL-13/PRT-2
224.1.1.3 128 ETHER(99)/SH-1/SL-13/PRT-2
 
MSTP-176#

show lacp [detail]

GE_XP、10GE_XP、GE_XPE、または 10GE_XPE カードの LACP の詳細情報を表示するには、特権 EXEC モードで show lacp コマンドを使用します。

show lacp [detail]

 
構文の説明

detail

LACP の詳細情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

 
使用上のガイドライン

detail キーワードを省略すると、LACP の基本情報が表示されます。

次に、 show lacp コマンドの出力例を示します。

MSTP-176# show lacp
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode
P - Device is in Passive mode
Link state can be:
bndl: active in an aggregation
hot-sby: In hot standby mode (Not supported)
susp: LACP not up
down: link is not available
________________________________________________________________________________
Channel Group 1
________________________________________________________________________________
Actor Port Flags State LACP Port Admin Oper Port
Number Priority Key Key State
Phy21 SP down 32768 1 0 0x44
--------------------------------------------------------------------------------
Partner Oper Flags State LACP Port Admin Oper Port
Port # Priority Key Key State
Phy21 0 SP down 0 0 0 0x0
________________________________________________________________________________
MSTP-176#

ethernet oam remote-loopback

EFM インターフェイスでリモート ループバック機能をオンまたはオフにするには、特権 EXEC モードで ethernet oam remote-loopback コマンドを使用します。このコマンドには、 no 形式はありません。

ethernet oam remote-loopback {start|stop} {interface number }

 
構文の説明

start

リモート ループバック操作を開始します。

stop

リモート ループバック操作を停止します。

interface

イーサネット インターフェイスを指定します。

number

イーサネット インターフェイスの番号です。操作が start の場合、番号の範囲は 1 ~ 20 になり、操作が stop の場合、番号の範囲は 21 ~ 22 になります。

 
コマンド デフォルト

デフォルトでは、リモート ループバックの機能はオフになっています。

 
コマンド モード

特権 EXEC(#)

 
使用上のガイドライン

EFM インターフェイスでリモート ループバック機能がイネーブルになっている場合、このインターフェイスに渡されたトラフィックはリモート インターフェイスによって廃棄されます。

次に、特定のインターフェイスでリモート ループバック セッションを開始する例を示します。

MSTP-176# ethernet oam remote-loopback start interface 8

show ethernet oam discovery

すべての EFM インターフェイス、または特定の EFM インターフェイスの検出情報を表示するには、特権 EXEC モードで show ethernet oam discovery コマンドを使用します。

show ethernet oam discovery [interface number ]

 
構文の説明

interface

イーサネット インターフェイスを指定します。

number

イーサネット インターフェイスの番号です。番号の範囲は 1 ~ 22 です。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

 
使用上のガイドライン

このコマンドは、イーサネット OAM 検出に関連する次の情報を表示します。

このデバイスに直接接続されているリモート デバイス

ローカルおよびリモートの OAM の設定と機能

ローカルおよびリモートの OAM モード

リモート プラットフォームの ID

ローカル検出ステート マシンの状態

インターフェイスが指定されている場合、そのインターフェイスの OAM ピアに関連するデータのみが表示されます。指定されていない場合は、すべてのインターフェイスのすべての OAM ピアのデータが表示されます。

次に、特定の EFM インターフェイスの検出情報を表示する例を示します。

MSTP-176# show ethernet oam discovery
Interface-22:
Local client
------------
Administrative configurations:
Mode: active
Link monitor: (on)
Remote loopback: supported
Mtu size: 1500
Operational status:
Port status: active send
Loopback status: no loopback
PDU revision: 0
Remote client
-------------
Remote Ethernet OAM client has not been found!
MSTP-176#

show ethernet oam statistics

EFM パケットに関する詳細情報を表示するには、特権 EXEC モードで show ethernet oam statistics コマンドを使用します。

show ethernet oam statistics [interface number ]

 
構文の説明

interface

イーサネット インターフェイスを指定します。

number

イーサネット インターフェイスの番号です。番号の範囲は 1 ~ 22 です。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

 
使用上のガイドライン

このコマンドは、次の統計情報を表示します。

OAM Protocol Data Unit(PDU; プロトコル データ ユニット)の Rx/Tx のカウンタ

リンク モニタリング イベント(イベント ログなど、該当する場合)

リモート障害検出イベント

リモート ループバック イベント

次に、特定のインターフェイスの情報を表示する例を示します。

MSTP-176# show ethernet oam statistics interface 22
Interface-22:
Counters:
---------
Information OAMPDU Tx: 1
Information OAMPDU Rx: 0
Unique Event Notification OAMPDU Tx: 0
Unique Event Notification OAMPDU Rx: 0
Duplicate Event Notification OAMPDU TX: 0
Duplicate Event Notification OAMPDU RX: 0
Loopback Control OAMPDU Tx: 0
Loopback Control OAMPDU Rx: 0
Variable Request OAMPDU Tx: 0
Variable Request OAMPDU Rx: 0
Variable Response OAMPDU Tx: 0
Variable Response OAMPDU Rx: 0
Cisco OAMPDU Tx: 0
Cisco OAMPDU Rx: 0
Unsupported OAMPDU Tx: 0
Unsupported OAMPDU Rx: 0
Frames Lost due to OAM: 0
Local Faults:
-------------
1 Link Fault records
Total link faults: 1
Time stamp: 1271800854d
0 Dying Gasp records
0 Critical Event records
Remote Faults:
--------------
0 Link Fault records
0 Dying Gasp records
0 Critical Event records
Local event logs:
-----------------
0 Errored Symbol Period records
0 Errored Frame records
0 Errored Frame Period records
0 Errored Frame Second records
Remote event logs:
------------------
0 Errored Symbol Period records
0 Errored Frame records
0 Errored Frame Period records
0 Errored Frame Second records
MSTP-176#

show ethernet oam status

すべてのインターフェイス、または特定のインターフェイスの EFM 設定を表示するには、特権 EXEC モードで show ethernet oam status コマンドを使用します。

show ethernet oam status [interface number ]

 
構文の説明

interface

イーサネット インターフェイスを指定します。

number

イーサネット インターフェイスの番号です。番号の範囲は 1 ~ 22 です。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

 
使用上のガイドライン

すべてのインターフェイスまたは特定のインターフェイスのリンク モニタリングの実行時の設定、および OAM の一般的な操作を表示するには、このコマンドを使用します。

このコマンドを使用する前に、インターフェイスで OAM が操作可能になっている必要があります。

次に、特定のインターフェイスの EFM 設定を表示する例を示します。

MSTP-176# show ethernet oam status interface 22
Interface-22:
General
-------
Admin state: enabled
Mode: active
PDU rate: 1 packet per 1 second
Link timeout: 5 seconds
High threshold action: error block interface
Link fault action: error block interface
Link Monitoring
---------------
Status:
Frame Error
Window: 10 x 100 milliseconds
Low threshold: 10 error frame(s)
High threshold: 10 error frame(s)
Frame Period Error
Window: 1000 x 10000 frames
Low threshold: 9 error frame(s)
High threshold: 10 error frame(s)
Frame Seconds Error
Window: 100 x 100 milliseconds
Low threshold: 1 error second(s)
High threshold: none
MSTP-176#

show ethernet oam summary

デバイスでアクティブな EFM セッションを表示するには、特権 EXEC モードで show ethernet oam summary コマンドを使用します。

show ethernet oam summary

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

次に、デバイスでアクティブな EFM セッションを表示する例を示します。

MSTP-176# show ethernet oam summary
Symbols: * - Master Loopback State, # - Slave Loopback State
& - Error Block State
Capability codes: L - Link Monitor, R - Remote Loopback
U - Unidirection, V - Variable Retrieval
Local Remote
Interface MAC Address OUI Mode Capability
Interface-22
MSTP-176#

clear ethernet cfm

CFM の Maintenance Intermediate Point(MIP; メンテナンス中間ポイント)および Maintenance End Point(MEP; メンテナンス エンド ポイント)データベースを消去するには、特権 EXEC モードで clear ethernet cfm maintenance-points remote コマンドを使用します。

clear ethernet cfm maintenance-points remote

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

次に、MIP および MEP データベースを消去する例を示します。

MSTP-176# clear ethernet cfm maintenance-points remote

clear ethernet cfm statistics

CFM 統計情報を消去するには、特権 EXEC モードで clear ethernet cfm statistics コマンドを使用します。

clear ethernet cfm statistics

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

次に、CFM 統計情報を消去する例を示します。

MSTP-176# clear ethernet cfm statistics

show ethernet cfm domain

CFM メンテナンス ドメイン、およびそのドメインに設定されたサービスの要約情報または詳細情報を表示するには、特権 EXEC モードで show ethernet cfm domain を使用します。

show ethernet cfm domain [brief | domain_name ]

 
構文の説明

brief

CFM メンテナンス ドメインに関する要約情報を表示します。

domain_name

メンテナンス ドメインの名前です。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

次に、特定の CFM メンテナンス ドメインに関する詳細情報を表示する例を示します。

MSTP-176# show ethernet cfm domain test_domain
Domain Name: test_domain Level:2
 
Attached to MAProfile: maprofile1 VlanId:150 CCEnabled: True
MSTP-176#

show ethernet cfm maintenance-points local

デバイスに設定されたメンテナンス ポイントを表示するには、特権 EXEC モードで show ethernet cfm maintenance-points local コマンドを使用します。

show ethernet cfm maintenance-points local [mip [level level] [service vlan] | mep [domain domain_name] [service vlan]]

 
構文の説明

level

メンテナンス レベル。level の範囲は 0 ~ 7 です。

vlan

VLAN の範囲。VLAN の範囲は 1 ~ 4093 です。

domain_name

メンテナンス ドメインの名前です。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

次に、デバイスに設定されたすべてのメンテナンス ポイントを表示する例を示します。

MSTP-176# show ethernet cfm maintenance-points local
Local MEP Configuration
Local MIP Configuration
Port: 1 SvlanId :150 level:2
MSTP-176#

show ethernet cfm maintenance-points

リモート メンテナンス ポイント ドメインに関する情報を表示するには、特権 EXEC モードで show ethernet cfm maintenance-points remote を使用します。

show ethernet cfm maintenance-points remote [domain domain_name] [service vlan]]

 
構文の説明

domain_name

メンテナンス ドメインの名前です。

vlan

VLAN の範囲。VLAN の範囲は 1 ~ 4093 です。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

次に、リモート メンテナンス ポイント ドメインに関する情報を表示する例を示します。

MSTP-176# show ethernet cfm maintenance-points remote domain test_domain service 6
Maintenance Domain Name: test_domain level:6
Domain Name: ma6 VlanId:6
MPId:34 Remote MAC: 22:22:22:22:31:34
Incoming Port:21 ccLifeTime: 3500 ageOfLastCC: 266
MSTP-176#

show ethernet cfm mpdb

イーサネット CFM MIP データベースの出力を表示するには、特権 EXEC モードで show ethernet cfm mpdb コマンドを使用します。

show ethernet cfm mpdb [level level] [service vlan]

 
構文の説明

level

メンテナンス レベル。level の範囲は 0 ~ 7 です。

vlan

VLAN の範囲。VLAN の範囲は 1 ~ 4093 です。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

次に、CFM MIP データベースの出力を表示する例を示します。

MSTP-176# show ethernet cfm mpdb level 6 service 6
Level: 6 VlanId:6
MPId:34 Remote MAC: 22:22:22:22:31:34
Ingress Port:21 archiveTimer: 6003500
MSTP-176#

show ethernet cfm statistics

CFM 統計情報を表示するには、特権 EXEC モードで show ethernet cfm statistics コマンドを使用します。

show ethernet cfm statistics [domain domain_name] [service vlan]

 
構文の説明

domain_name

メンテナンス ドメインの名前です。

vlan

VLAN の範囲。VLAN の範囲は 1 ~ 4093 です。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

次に、CFM 統計情報を表示する例を示します。

MSTP-176# show ethernet cfm statistics domain test_domain service 6
Domain Name: test_domain VlanId:6 mpId:6
Ccm transmitted:70268 ccmRececived: 583 ccRecvSeqErr: 1 Lt Unexpected recv:0 lbr transmitted: 0 lbr rcvd in order: 0 Lbr Recvd Seq Error:0 lbr rcvd bad msdu: 0
MSTP-176#

show interfaces rep

特定のインターフェイス、またはすべてのインターフェイスの REP 設定およびステータスを表示するには、特権 EXEC モードで show interfaces rep コマンドを使用します。

show interfaces [ interface_name ] rep [detail]

 
構文の説明

interface_name

特定の物理インターフェイスまたはポート チャネル ID の REP 設定およびステータス。

detail

REP の設定およびステータス情報の詳細を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

次に、 show interfaces rep コマンドの出力例を示します。

MSTP-176# show interfaces rep detail
Phy1 REP enabled
Segment-id: 2 (Preferred)
PortID: 00000019076cb77a
Preferred flag: Yes
Operational Link Status: NO_NEIGHBOR
Current Key: 00000019076cb77a5bdd
Port Role: Fail No Ext Neighbor
Blocked VLAN: 1-4094
Rcvd VLAN: <empty>
Admin-svlan: 0
Admin-cvlan: 0
Preempt Delay Timer: disabled
LSL Ageout Timer: 5000 ms
VLAN load balancing: disabled
STCN Propagate to: none
LSL PDU rx: 0, tx: 102
HFL PDU rx: 0, tx: 0
BPA TLV rx: 0, tx: 0
BPA (STCN, LSL) TLV rx: 0, tx: 0
BPA (STCN, HFL) TLV rx: 0, tx: 0
EPA-ELECTION TLV rx: 0, tx: 0
EPA-COMMAND TLV rx: 0, tx: 0
EPA-INFO TLV rx: 0, tx: 0
MSTP-176#

show rep topology

1 つのセグメントまたはすべてのセグメント(セグメント内のプライマリ エッジ ポートおよびセカンダリ エッジ ポートを含む)の REP トポロジ情報を表示するには、特権 EXEC モードで show rep topology コマンドを使用します。

show rep topology [segment id ] [archive] [detail]

 
構文の説明

segment id

特定のセグメントの REP トポロジ情報を表示します。指定できる ID 範囲は 1 ~ 1024 です。

archive

セグメントの前回のトポロジを表示します。

detail

REP トポロジの詳細情報を表示します。

 
コマンド デフォルト

なし

 
コマンド モード

特権 EXEC(#)

 
使用上のガイドライン

archive キーワードは、リンク障害のトラブルシューティングに便利です。

次に、 show rep topology コマンドの出力例を示します。

MSTP-176# show rep topology
BridgeName PortName Edge Role
------------------- ---------- ---- ----
10.64.106.37-s1 Phy1 FailNoNbr
MSTP-176#

interface channel-group

GE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードでチャネル グループを作成するには、グローバル コンフィギュレーション モードで interface channel-group コマンドを使用します。

interface channel-group chanlgrp-num

 
構文の説明

chanlgrp-num

チャネル グループの ID。チャネル グループの範囲は次のとおりです。

GE_XP および GE_XPE カードでは 1 ~ 11。

10GE_XP および 10GE_XPE カードでは 1 ~ 2。

 
コマンド デフォルト

チャネル グループは作成されません。

 
コマンド モード

グローバル コンフィギュレーション(config)

次に、ID 7 を持つチャネル グループを作成する例を示します。

MSTP-176(config)# interface channel-group 7

ethernet cfm ieee

GE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードで CFM をイネーブルにするには、グローバル コンフィギュレーション モードで ethernet cfm ieee コマンドを使用します。カードで CFM をディセーブルにするには、このコマンドの no 形式を使用します。

ethernet cfm ieee

[no] ethernet cfm ieee

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション(config)

次に、GE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードで CFM をイネーブルにする例を示します。

MSTP-176# ethernet cfm ieee

ethernet cfm domain

メンテナンス ドメインを作成するには、グローバル コンフィギュレーション モードで ethernet cfm domain を使用します。

ethernet cfm domain domain_name level level

[no] ethernet cfm domain domain_name level level

 
構文の説明

domain_name

level

メンテナンス ドメインの名前

メンテナンス レベル。level の範囲は 0 ~ 7 です

 
コマンド デフォルト

メンテナンス ドメインは作成されません。

 
コマンド モード

グローバル コンフィギュレーション(config)

次に、レベル 4 のメンテナンス ドメインを作成する例を示します。

MSTP-176# ethernet cfm domain test_domain level 4

ethernet cfm service

メンテナンス ドメインにメンテナンス アソシエーションを適用するには、グローバル コンフィギュレーション モードで ethernet cfm service コマンドを使用します。

ethernet cfm service service_name vlan vlan

[no] ethernet cfm service service_name vlan vlan

 
構文の説明

service_name

メンテナンス アソシエーションによって識別されるサービスの名前。

vlan

VLAN の範囲。VLAN の範囲は 1 ~ 4093 です。

 
コマンド モード

グローバル コンフィギュレーション(config)

次に、メンテナンス ドメインにメンテナンス アソシエーションを適用する例を示します。

MSTP-176# ethernet cfm service service name vlan 100

rep admin svlan

Hardware Flood Layer(HFL)メッセージを送信するように REP 管理 VLAN を設定するには、グローバル コンフィギュレーション モードで rep admin svlan コマンドを使用します。VLAN 1 が管理 VLAN になるようにデフォルトの設定に戻すには、このコマンドの no 形式を使用します。

rep admin svlan svlanid

no rep admin svlan

 
構文の説明

svlanid

SVLAN 識別子。SVLAN の範囲は 1 ~ 4093 です。

 
コマンド デフォルト

デフォルトの管理 VLAN は VLAN 1 です。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
使用上のガイドライン

REP 管理 VLAN が設定されていない場合、デフォルトは VLAN 1 です。スイッチとセグメントで 1 つの管理 VLAN だけが可能です。

次に、REP 管理 VLAN を設定する例を示します。

MSTP-176(config)# rep admin svlan 4000

mac-address-table learning vlan vlanid

VLAN で MAC アドレス ラーニングをイネーブルにするには、 mac address-table learning グローバル コンフィギュレーション コマンドを使用します。VLAN で MAC アドレス ラーニングをディセーブルにして、MAC アドレスを学習できる VLAN を制御するには、このコマンドの no 形式を使用します。

mac-address-table learning vlan vlanid

no mac-address-table learning vlan <vlanid>

 
構文の説明

vlanid

VLAN ID 範囲は 1 ~ 4093 です。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンド デフォルト

デフォルトでは、MAC アドレス ラーニングはすべての VLAN でディセーブルです。

 
使用上のガイドライン

サービス プロバイダーのネットワーク上のカスタマーは、ネットワーク経由で多数の MAC アドレスをトンネリングし、使用可能な MAC アドレス テーブル スペースを満たすことができます。VLAN で MAC アドレス ラーニングを制御する場合、MAC アドレスを学習できる VLAN、さらにポートを制御することで、利用可能な MAC アドレス テーブル スペースを管理できます。

次に、VLAN 10 で MAC アドレス ラーニングをイネーブルにする例を示します。

MSTP-176# mac-address-table learning vlan 10
MSTP-176#
 

[no] mac-address-table learning interface type port

MAC アドレスの学習に基づいてインターフェイスを指定するには、 mac-address-table learning interface type port グローバル コンフィギュレーション コマンドを使用します。

 
構文の説明

type/port

インターフェイス タイプとポート番号です。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンド デフォルト

なし

 
使用上のガイドライン

なし

次に、インターフェイスで MAC アドレス ラーニングをイネーブルにする例を示します。

MSTP-176# mac-address-table learning interface gig 1
MSTP-176#
 

[no] vlan vlan-id

VLAN を追加して、config-VLAN サブモードを開始するには、vlan コマンドを使用します。VLAN を削除するには、このコマンドの no 形式を使用します。

vlan vlan-id

 
構文の説明

vlan-id

VLAN ID です。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンド デフォルト

なし

 
使用上のガイドライン

なし

次に、新規 VLAN を追加して、config-VLAN サブモードを開始する例を示します。

MSTP-176# (config)# vlan 2
MSTP-176# (config-vlan)#
 

interface gigabitethernet port

Gigabit Ethernet(GigE; ギガビット イーサネット)インターフェイス コンフィギュレーションを開始するには、適切なコンフィギュレーション モードで interface gigabitethernet コマンドを使用します。

interface gigabitethernet port

 
構文の説明

port

1 ~ 20 のポート番号を入力します。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンド デフォルト

 
使用上のガイドライン

次に、ポート 2 でギガビット イーサネット インターフェイスを開始する例を示します。

MSTP-176(config)# interface gigabitethernet 2
MSTP-176(config-if)#
 

 

interface tengigabitethernet port

Ten Gigabit Ethernet(10 GigE; 10 ギガビット イーサネット)インターフェイス コンフィギュレーションを開始するには、適切なコンフィギュレーション モードで interface tengigabitethernet コマンドを使用します。

interface tengigabitethernet port

 
構文の説明

port

21 ~ 22 のポート番号を入力します。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンド デフォルト

 
使用上のガイドライン

次に、ポート 21 で 10GigE インターフェイスを開始する例を示します。

MSTP-176(config)# interface tengigabitethernet 21
MSTP-176(config-if)#

policy-map name

Quality of Service(QoS)ポリシー マップを設定するには、 policy-map コマンドを使用します。ポリシー マップを削除するには、このコマンドの no 形式を使用します。

policy-map name

[no] policy-map name

 
構文の説明

name

ポリシー マップ名です。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンド デフォルト

なし

 
使用上のガイドライン

なし

次に、インターフェイス コマンドで入力トラフィックの QoS ポリシーを作成する例を示します。

MSTP-176(config)# policy map pmap
MSTP-176(config-pmap)# police cir percent 60 pir percent 80 bc 4 be 16
MSTP-176(config-pmap)# set cos 8
MSTP-176(config-pmap)# service-policy input servpol1
MSTP-176# end

[no] mvr

GE_XP、10GE_XP、GE_XPE、および 10GE_XPE で Multicast VLAN Registration(MVR; マルチキャスト VLAN レジストレーション)機能をイネーブルにするには、 mvr グローバル コンフィギュレーション コマンドを使用します。MVR とそのオプションをディセーブルにするには、このコマンドの [no] mvr 形式を使用します。

mvr group ip-address vlan vlan-id

[no] mvr group ip-address vlan vlan-id

 
コマンド モード

グローバル コンフィギュレーション

 
コマンド デフォルト

MVR はデフォルトでディセーブルです。

 
使用上のガイドライン

最大 256 の MVR マルチキャスト グループを GE_XP、10GE_XP、GE_XPE、および 10GE_XPE に設定できます。マルチグループ アドレスと VLAN を設定した後のみに MVR をイネーブルにすることができます。

次の例では、228.1.23.4 を IP マルチキャスト アドレスとして設定する方法を示します。

MSTP-176(config)# mvr group 228.1.23.4
 

次の例では、VLAN 2 をマルチキャスト VLAN として設定する方法を示します。

MSTP-176(config)# mvr vlan 2
 

次の例では、MVR をイネーブルにする方法を示します。

MSTP-176(config)# mvr
 

次の例では、MVR をディセーブルにする方法を示します。

MSTP-176(config)# no mvr
 

mvr vlan

VLAN(SVLAN)がマルチキャスト VLAN として機能するように指定するには、 mvr vlan コマンドを使用します。すべてのポートがこの VLAN に属する必要があります。

mvr vlan svlan

 
構文の説明

svlan

SVLAN ID です。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンド デフォルト

デフォルトで、SVLAN 上の MVR は無効になっています。

 
使用上のガイドライン

なし

次に、VLAN をマルチキャスト VLAN として機能するように設定する例を示します。

MSTP-176(config)# mvr vlan 22

 

mvr group ip address count

GE_XP、10GE_XP、GE_XPE、または 10GE_XPE カードで IP マルチキャスト アドレスを設定するには、 count パラメータを使用して、連続する MVR グループ アドレスを設定します。このアドレスに送信されたマルチキャスト データは、スイッチ上のすべての送信元ポートおよびそのマルチキャスト アドレスのデータを受信するために選ばれたすべてのレシーバー ポートに送信されます。マルチキャスト アドレスとテレビ チャネルは 1 対 1 の対応です。

mvr group ip address count

 
構文の説明

count

count の範囲は 1 ~ 256 です。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンド デフォルト

デフォルトで、SVLAN 上の MVR は無効になっています。

次に、2 つの連続 MVR アドレス グループを設定する例を示します。

MSTP-176(config)# mvr group 228.1.23.4 2
 

ethernet cfm cc_interval interval

Continuity Check timer(CC タイマー; 連続性チェック タイマー)の値を設定するには、CFM メンテナンス アソシエーション コンフィギュレーション モードで ethernet cfm cc_interval コマンドを使用します。

ethernet cfm cc_interval interval

[no] ethernet cfm cc_interval interval

 
構文の説明

interval

連続性チェック タイマーの間隔です。間隔の値は、1 秒、10 秒、および 1 分です。

 
コマンド デフォルト

デフォルト設定は 1 秒です。

 
コマンド モード

CFM メンテナンス アソシエーション コンフィギュレーション(config-ecfm-srv)

次に、CC タイマーの値を 10 秒に設定する例を示します。

MSTP-176(config-ecfm-srv)# ethernet cfm cc_interval 10s

service service_name

メンテナンス アソシエーションのサービス名を設定するには、CFM メンテナンス アソシエーション コンフィギュレーション モードで service service_name コマンドを使用します。

service service_name

 
構文の説明

service_name

メンテナンス アソシエーションのサービス名です。

 
コマンド モード

CFM メンテナンス アソシエーション コンフィギュレーション(config-ecfm-srv)

次に、CFM サービスを設定する例を示します。

MSTP-176(config-ecfm-srv)# service service name

continuity-check

メンテナンス アソシエーション プロファイルの CC タイマーをイネーブルにするには、CFM メンテナンス アソシエーション コンフィギュレーション モードで continuity-check コマンドを使用します。メンテナンス アソシエーション プロファイルの CC タイマーをディセーブルにするには、このコマンドの no 形式を使用します。

continuity-check

[no] continuity-check

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

デフォルトでは、連続性チェックはディセーブルです。

 
コマンド モード

CFM メンテナンス アソシエーション コンフィギュレーション(config-ecfm-srv)

次に、メンテナンス アソシエーション プロファイルの CC タイマーをイネーブルにする例を示します。

MSTP-176(config-ecfm-srv)# continuity-check

name vlan name

VLAN を設定するには、VLAN インターフェイス コンフィギュレーション モードで name vlan name コマンドを使用します。

name vlan name

 
構文の説明

name

VLAN の名前を指定します。

 
コマンド モード

VLAN インターフェイス コンフィギュレーション

 
コマンド デフォルト

デフォルトでは、VLAN に名前は割り当てられていません。

 
使用上のガイドライン

名前を二重引用符で囲むと、空白を含む名前を入力できます。

次に、VLAN の名前を設定する例を示します。

MSTP-176(config-vlan)# name MYVLAN

protected

指定された SVLAN で Fast Automatic Protection Switching(FAPS; 高速自動保護スイッチング)をイネーブルまたはディセーブルにするには、protected コマンドを使用します。

protected

[no] protected

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド モード

VLAN インターフェイス コンフィギュレーション

 
コマンド デフォルト

デフォルトでは、FAPS はすべての SVLAN でディセーブルです。

次に、カードの保護を設定する例を示します。

MSTP-176(config-vlan)# protected
 

ip igmp snooping

IGMP スヌーピングをイネーブルにするには、 ip igmp snooping コマンドを使用します。IGMP スヌーピングをディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp snooping

no ip igmp snooping

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

デフォルトでは、IGMP スヌーピングはすべての SVLAN でディセーブルです。

 
コマンド モード

VLAN インターフェイス コンフィギュレーション

 
使用上のガイドライン

IGMP スヌーピングをイネーブルにする前に、VLAN インターフェイスにマルチキャスト ルーティングを設定します。

次に、IGMP スヌーピングをイネーブルにする例を示します。

MSTP-176(config-vlan)# ip igmp snooping
MSTP-176(config-vlan)#
 

ip igmp snooping immediate-leave

既存のすべての VLAN インターフェイスで IGMPv2 スヌーピングの即時脱退処理をイネーブルにするには、 ip igmp snooping immediate-leave コマンドを使用します。即時脱退処理をディセーブルにするには、このコマンドの no 形式を使用します。

ip igmp snooping immediate-leave

no ip igmp snooping immediate-leave

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

デフォルトでは、IGMP スヌーピングの即時脱退はすべての SVLAN でディセーブルです。

 
コマンド モード

VLAN インターフェイス コンフィギュレーション

 
使用上のガイドライン

即時脱退機能をサポートするのは、IGMP バージョン 2 のみです。

次に、IGMP 即時脱退処理をイネーブルにする例を示します。

MSTP-176(config-vlan)# ip igmp snooping immediate-leave
MSTP-176(config-vlan)#
 

ip igmp snooping report-suppression

レポート抑制をイネーブルにするには、 ip igmp snooping report-suppression コマンドを使用します。レポート抑制をディセーブルにして、レポートをマルチキャスト デバイスに転送するには、このコマンドの no 形式を使用します。

ip igmp snooping report-suppression

no igmp snooping report-suppression

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

デフォルトでは、IGMP スヌーピングのレポート抑制はすべての SVLAN でディセーブルです。

 
コマンド モード

VLAN インターフェイス コンフィギュレーション

次の例では、レポート抑制をイネーブルにする方法を示します。

MSTP-176(config-vlan)# ip igmp snooping report-suppression
MSTP-176(config-vlan)#
 

次の例では、レポート抑制をディセーブルにする方法を示します。

MSTP-176(config-vlan)# )# no ip igmp snooping report-suppression
MSTP-176(config-vlan)#

channel-group channel-number mode chanlgrp-mode

GE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードでチャネル グループのモードを設定するには、インターフェイス コンフィギュレーション モードで channel-group channel-number mode chanlgrp-mode コマンドを使用します。チャネル グループ モードを active に設定するには、このコマンドの no 形式を使用します。

channel-group channel-number mode chanlgrp-mode

[no] channel-group channel-number mode chanlgrp-mode

 
構文の説明

channel-number

チャネル グループの番号を指定します。

chanlgrp-mode

チャネル グループのモードを指定します。チャネル グループ モードの値は、active、passive、および manual です。

 
コマンド デフォルト

チャネル グループ モードは active に設定されています。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

次に、チャネル グループ モードを passive に変更する例を示します。

MSTP-176(config-if)# channel-group 6 mode passive

channel-group channel-number hash chanlgrp-hash

GE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードでチャネル グループのハッシュ アルゴリズムを設定するには、インターフェイス コンフィギュレーション モードで channel-group channel-number hash chanlgrp-hash コマンドを使用します。

channel-group channel-number hash chanlgrp-hash

[no] channel-group channel-number hash chanlgrp-hash

 
構文の説明

channel-number

チャネル グループの番号を指定します。

chanlgrp-hash

チャネル グループのハッシュ アルゴリズムを指定します。チャネル グループのハッシュの値は、sa-incoming、da-incoming、sa-da-incoming、src-ip-tcp-udp、dst-ip-tcp-udp、および src-dst-ip-tcp-udp です。

 
コマンド デフォルト

ハッシュ アルゴリズムは sa-da-incoming に設定されています。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

次に、チャネル グループ モードのハッシュ アルゴリズムを src-ip-tcp-udp に変更する例を示します。

MSTP-176(config-if)# channel-group 2 hash src-ip-tcp-udp

channel-group channel-number expected speed chanlgrp-speed

GE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードでチャネル グループの予測速度を変更するには、インターフェイス コンフィギュレーション モードで channel-group channel-number expected speed chanlgrp-speed コマンドを使用します。

channel-group channel-number expected speed chanlgrp-speed

[no] channel-group channel-number expected speed chanlgrp-speed

 
構文の説明

channel-number

チャネル グループの番号を指定します。

chanlgrp-speed

チャネル グループの予測速度を指定します。チャネル グループの速度の値は 10、100、および 1000 です。

 
コマンド デフォルト

デフォルトの予測速度は 1000 です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

次に、チャネル グループの予測速度を 100 に変更する例を示します。

MSTP-176(config-if)# channel-group 2 expected speed 100

description description

ポート名を指定するには、インターフェイス コンフィギュレーション モードで description コマンドを使用します。

description

 
構文の説明

description

ポート名は、最大 32 文字まで指定できます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
使用上のガイドライン

インターフェイス上のポートを表示するには、特権 EXEC モードで show interfaces コマンドを使用します。

次に、ポート名を指定する例を示します。

MSTP-176(config-if)# description 5p
 

次に、設定されたポート名の出力例の一部を示します。

MSTP-176# show interface
 
Port 2 (Client), Port name: 5p
Admin State: ADMIN_OOS_DSBLD, Service State: OOS_MA_DSBLD
Reach: REACH_UNKNOWN, Wavelength: WV_UNKNOWN, AIS Action: NONE
Flow Control: DISABLED, Duplex Mode: FULL, Speed: SPEED_AUTO, MTU: 9700
NI Mode: UNI, MAC Learning: DISABLED, IGMP Static Router Port: DISABLED
Ingress CoS: 0, Ethertype Inner/Outer: 8100/8100, Egress QoS: DISABLED
Committed Info Rate: 100, Burst Size Committed/Excess: BCKT_4K/BCKT_4K
Failed to get PM counters for this port
 
MSTP-176#

ethernet oam

インターフェイスで EFM をイネーブルにするには、インターフェイス コンフィギュレーション モードで ethernet oam コマンドを使用します。インターフェイスで EFM をディセーブルにするには、このコマンドの no 形式を使用します。

ethernet oam

[no] ethernet oam

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

EFM はデフォルトではディセーブルになっています。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

インターフェイスに EFM が設定されていると、EFM クライアントのデフォルト モードは active になります。トラフィックが通過する 2 つのインターフェイスで EFM がイネーブルになっている場合、両方のインターフェイスを passive モードにすることはできません。両方のインターフェイスを active モードにしたり、一方を active モードに、他方を passive モードにすることは可能です。

次に、インターフェイス上で EFM をイネーブルにする例を示します。

MSTP-176(config-if)# ethernet oam

ethernet oam mode

EFM モード(active または passive)とタイムアウト パラメータを設定するには、インターフェイス コンフィギュレーション モードで ethernet oam コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

ethernet oam [mode {active | passive} | timeout seconds ]

[no] ethernet oam [mode {active | passive} | timeout seconds ]

 
構文の説明

mode

EFM クライアント モードを設定します。

active

以前にインターフェイスを passive モードにした後に、EFM クライアント モードを active に設定します。デフォルト モードは、active です。

passive

EFM クライアント モードを passive に設定します。passive モードでは、デバイスは検出を開始したり、変数を問い合わせたり、ループバック モードを設定することはできません。

timeout

EFM ピアが動作不能であり、ステート マシンをリセットすることをデバイスが宣言するまでの時間の長さを秒数で指定します。

seconds

タイムアウトの秒数です。範囲は 2 ~ 30 秒です。デフォルトは 5 です。

 
コマンド デフォルト

デフォルトでは、EFM モードは active になっています。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

インターフェイスに EFM が設定されていると、EFM クライアントのデフォルト モードは active になります。トラフィックが通過する 2 つのインターフェイスで EFM がイネーブルになっている場合、両方のインターフェイスを passive モードにすることはできません。両方のインターフェイスを active モードにしたり、一方を active モードに、他方を passive モードにすることは可能です。

次に、EFM モードを passive に設定し、タイムアウトを 25 秒に設定する例を示します。

MSTP-176(config-if)# ethernet oam mode passive timeout 25

ethernet oam link-monitor frame

EFM インターフェイスでエラー フレームのしきい値またはウィンドウを設定するには、インターフェイス コンフィギュレーション モードで ethernet oam link-monitor frame コマンドを使用します。エラー フレームのしきい値またはウィンドウを削除するには、このコマンドの no 形式を使用します。

ethernet oam link-monitor frame {threshold {high {none| high frames } | low { low frames }} | window milliseconds }

[no] ethernet oam link-monitor frame {threshold {high {none| high frames } | low { low frames }} | window milliseconds }

 
構文の説明

threshold

この値と一致する、超える、または下回るとアクションがトリガーされるエラー フレームの数を設定します。

high

フレーム数のエラー フレームの上限しきい値を設定します。上限しきい値は下限しきい値よりも大きい値である必要があります。

none

上限しきい値をディセーブルにします。

high-frames

1 ~ 65535 の範囲の整数。フレーム数の上限しきい値を設定します。デフォルトはありません。上限しきい値は必ず設定する必要があります。

low

フレーム数のエラー フレームの下限しきい値を設定します。

low-frames

0 ~ 65535 の範囲の整数。フレーム数の下限しきい値を設定します。デフォルトは 1 です。

window

エラー フレームをカウントするウィンドウおよび期間を設定します。

milliseconds

10 ~ 600 の範囲の整数。ミリ秒単位で 100 の倍数を表します。デフォルトは 10 です。

 
コマンド デフォルト

ethernet oam link-monitor frame コマンドは設定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

ethernet oam link-monitor frame コマンドは、アクションをトリガーするエラー フレーム数、またはエラー フレームをカウントする期間を設定します。

次に、EFM リンク モニター フレーム ウィンドウを 300 ミリ秒に設定する例を示します。

MSTP-176(config-if)# ethernet oam link-monitor frame window 300

ethernet oam link-monitor frame-period

EFM インターフェイスでエラー フレーム期間を設定するには、インターフェイス コンフィギュレーション モードで ethernet oam link-monitor frame-period コマンドを使用します。エラー フレーム期間を削除するには、このコマンドの no 形式を使用します。

ethernet oam link-monitor frame-period {threshold {high {none| high-frames } | low { low-frames }} | window frames }

[no] ethernet oam link-monitor frame-period {threshold {high {none| high-frames } | low { low-frames }} | window frames }

 
構文の説明

threshold

この値と一致する、超える、または下回るとアクションがトリガーされる期間のエラー フレームの数を設定します。

high

フレーム数のエラー フレーム期間の上限しきい値を設定します。

none

上限しきい値をディセーブルにします。

high-frames

1 ~ 65535 の範囲の整数。フレーム数の上限しきい値を設定します。デフォルトはありません。上限しきい値は必ず設定する必要があります。

low

フレーム数のエラー フレーム期間のエラー フレームの下限しきい値を設定します。

low-frames

0 ~ 65535 の範囲の整数。フレーム数の下限しきい値を設定します。デフォルトは 1 です。

window

エラー フレームをカウントするウィンドウおよび期間を設定します。

frames

1 ~ 65535 の範囲の整数。フレーム数のウィンドウ サイズを設定します。それぞれの値は 10000 の倍数です。デフォルト値は 1000 です。

 
コマンド デフォルト

ethernet oam link-monitor frame-period コマンドは設定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

ethernet oam link-monitor frame-period コマンドは、フレーム数のエラー フレーム期間を設定します。上限しきい値を設定するときは、値は少なくともフレーム エラーの下限しきい値と同じである必要があります。

次に、EFM リンク モニター フレーム期間のウィンドウを 20000 フレームに設定する例を示します。

MSTP-176(config-if)# ethernet oam link-monitor frame-period window 2

 

次に、EFM リンク モニター フレーム期間の下限しきい値を 500 フレームに設定する例を示します。

MSTP-176(config-if)# ethernet oam link-monitor frame-period threshold low 500

ethernet oam link-monitor frame-seconds

EFM インターフェイスでフレーム秒数期間を設定するには、インターフェイス コンフィギュレーション モードで ethernet oam link-monitor frame-seconds コマンドを使用します。フレーム秒数期間を削除するには、このコマンドの no 形式を使用します。

ethernet oam link-monitor frame-seconds {threshold {high {none| high-frames } | low { low-frames }} | window milliseconds }

[no] ethernet oam link-monitor frame-seconds {threshold {high {none| high-frames } | low { low-frames }} | window milliseconds }

 
構文の説明

threshold

この値と一致する、超える、または下回るとアクションがトリガーされる数を設定します。

high

フレーム数のエラー フレーム秒数の上限しきい値を設定します。

none

上限しきい値をディセーブルにします。

high-frames

1 ~ 900 の範囲の整数。フレーム数の上限しきい値を設定します。デフォルトはありません。上限しきい値は必ず設定する必要があります。

low

フレーム数のエラー フレーム秒数の下限しきい値を設定します。

low-frames

0 ~ 900 の範囲の整数。フレーム数の下限しきい値を設定します。デフォルトは 1 です。

window

エラー フレームをカウントするウィンドウおよび期間を設定します。

milliseconds

100 ~ 9000 の範囲の整数。100 の倍数のミリ秒数を表します。デフォルトは 100 です。

 
コマンド デフォルト

ethernet oam link-monitor frame-seconds コマンドは設定されません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

ethernet oam link-monitor frame-seconds コマンドは、アクションをトリガーするエラー フレーム数、またはエラー フレームをカウントする期間を設定します。

次に、EFM リンク モニター フレーム ウィンドウを30000 ミリ秒(30 秒)に設定する例を示します。

MSTP-176(config-if)# ethernet oam link-monitor frame-seconds window 300

ethernet oam link-monitor high-threshold

EFM インターフェイスでエラーの上限しきい値を超過したときに実行する特定のアクションを設定するには、インターフェイス コンフィギュレーション モードで ethernet oam link-monitor high-threshold コマンドを使用します。上限しきい値のアクションを削除するには、このコマンドの no 形式を使用します。

ethernet oam link-monitor high-threshold action {none|disable-port}

[no] ethernet oam link-monitor high-threshold action {none|disable-port}

 
構文の説明

action

エラーの上限しきい値を超えたときに実行するアクションを指定します。

none

アクションを実行しないことを指定します。

disable-port

インターフェイスのエラー ディセーブル機能を実行します。

 
コマンド デフォルト

上限しきい値のアクションは設定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

次に、エラーの上限しきい値を超えたときに実行する disable-port アクションを設定する例を示します。

MSTP-176(config-if)# ethernet oam link-monitor high-threshold action disable-port

ethernet oam remote-failure link-fault

EFM の Remote Failure Indication(RFI; リモート障害表示)を設定するには、インターフェイス コンフィギュレーション モードで ethernet oam remote-failure link-fault コマンドを使用します。設定を削除するには、このコマンドの no 形式を使用します。

ethernet oam remote-failure link-fault action error-block-interface

[no] ethernet oam remote-failure link-fault action error-block-interface

 
構文の説明

action

RFI のために実行するアクションを指定します。

error-block-interface

error-block ステートにするインターフェイスを指定します。

 
コマンド デフォルト

リモート障害のアクションは設定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

次に、リモート障害が発生した場合に実行する error-block インターフェイスのアクションを設定する例を示します。

MSTP-176(config-if)# ethernet oam remote-failure link-fault action error-block-interface

ethernet cfm mip

MIP を作成して MIP パラメータを設定するには、インターフェイス コンフィギュレーション モードで ethernet cfm mip コマンドを使用します。

ethernet cfm mip level level vlan vlan

[no] ethernet cfm mip level level vlan vlan

 
構文の説明

level

メンテナンス レベル。level の範囲は 0 ~ 7 です。

vlan

VLAN レベル。VLAN の範囲は 1 ~ 4093 です。

 
コマンド デフォルト

MIP は作成されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

次に、メンテナンス レベルが 4 で VLAN レベルが 100 の MIP を作成する例を示します。

MSTP-176(config-if)# ethernet cfm mip level 4 vlan 100

ethernet cfm mep

MEP を作成して MEP パラメータを設定するには、インターフェイス コンフィギュレーション モードで ethernet cfm mep コマンドを使用します。

ethernet cfm mep domain domain_name mepid mepid vlan vlan

[no] ethernet cfm mep domain domain_name mepid mepid vlan vlan

 
構文の説明

domain_name

この MEP を含むメンテナンス ドメインの名前です。

mepid

MEP の ID です。MEPID の範囲は 1 ~ 8191 です。

vlan

VLAN レベル。VLAN の範囲は 1 ~ 4093 です。

 
コマンド デフォルト

デフォルトでは MEP は作成されません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

次に、MEP を作成する例を示します。

MSTP-176(config-if)# ethernet cfm mep domain test_mep mepid 100 vlan 200

ethernet cfm interface

インターフェイスで CFM をイネーブルにするには、インターフェイス コンフィギュレーション モードで ethernet cfm interface を使用します。インターフェイスで CFM をディセーブルにするには、このコマンドの no 形式を使用します。

ethernet cfm interface

[no] ethernet cfm interface

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

デフォルトでは、インターフェイスで CFM はディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

次に、インターフェイスで CFM をイネーブルにする例を示します。

MSTP-176(config-if)# ethernet cfm interface

rep segment

インターフェイスで REP をイネーブルにし、その REP にセグメント ID を割り当てるには、インターフェイス コンフィギュレーション モードで rep segment コマンドを使用します。デフォルトでは、すべてのインターフェイス上で REP はディセーブルになっています。インターフェイスで REP をディセーブルにするには、このコマンドの no 形式を使用します。

rep segment { id } [edge [no-neighbor] [primary]] [preferred]

[no] rep segment { id } [edge [no-neighbor] [primary]] [preferred]

 
構文の説明

id

インターフェイスに割り当てるセグメント ID です。ID の範囲は 1 ~ 1024 です。

edge

ポートをエッジ ポートとして設定します。primary キーワードを入力せずに edge キーワードを入力すると、ポートはセカンダリ エッジ ポートに設定されます。各セグメントにあるエッジ ポートは 2 つだけです。

no-neighbor

エッジ ポートがネイバー ポートを使用しないように指定します。

primary

ポートをプライマリ エッジ ポートに指定します。1 セグメント内のプライマリ エッジ ポートは 1 つだけです。別のスイッチのポートなど、セグメント内で 2 つのポートをプライマリ エッジ ポートに設定すると、REP がそのうちのいずれかを選択してセグメントのプライマリ エッジ ポートとして機能させます。

preferred

エッジ ポートを優先代替ポートに設定するか、または VLAN ロード バランシングの優先ポートに設定します。ポートに preferred を設定しても、そのポートが代替ポートになることは保証されませんが、そのポートは他の類似ポートよりは優先されます。通常、前に障害が発生したポートが、代替ポートとなります。

 
コマンド デフォルト

REP はインターフェイスでディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

インターフェイスで REP がイネーブルの場合、デフォルトでポートは標準のセグメント ポートに指定されます。

各 REP セグメントに 2 つのエッジ ポートを設定する必要があります。別のスイッチ上のポートなど、セグメント内で 2 つのポートをプライマリ エッジ ポートに設定した場合でも、その設定を使用できます。ただし、REP はセグメント プライマリ エッジ ポートとして機能するポートを 1 つだけ選択します。REP がスイッチの 2 つのポートでイネーブルの場合、ポートを通常のセグメント ポートまたはエッジ ポートのいずれかにする必要があります。

次に、通常のセグメント ポートで REP をイネーブルにする例を示します。

MSTP-176(config-if)# rep segment 100
 

次に、ポートで REP をイネーブルし、そのポートを REP プライマリ エッジ ポートとして指定する例を示します。

MSTP-176(config-if)# rep segment 100 edge primary
 

次に、ポートで REP をイネーブルし、そのポートを REP セカンダリ エッジ ポートとして指定する例を示します。

MSTP-176(config-if)# rep segment 100 edge
 

その他の例

MSTP-176(config-if)# rep segment 100 edge no-neighbor
MSTP-176(config-if)# rep segment 100 edge no-neighbor primary
MSTP-176(config-if)# rep segment 100 preferred
MSTP-176(config-if)# rep segment 100 edge preferred
MSTP-176(config-if)# rep segment 100 edge primary preferred
MSTP-176(config-if)# rep segment 100 edge no-neighbor preferred
MSTP-176(config-if)# rep segment 100 edge no-neighbor primary preferred

rep stcn

REP Segment Topology Change Notification(STCN; セグメント トポロジ変更通知)を他のインターフェイスまたは他のセグメントに送信するようにエッジ ポートを設定するには、インターフェイス コンフィギュレーション モードで rep stcn コマンドを使用します。インターフェイスまたはセグメントへの STCN の送信をディセーブルにするには、このコマンドの no 形式を使用します。

rep stcn {interface {interface-id} | segment {id_list}}

[no] rep stcn {interface {interface-id} | segment {id_list}}

 
構文の説明

interface interface-id

STCN を受信する物理インターフェイスまたはポート チャネルを指定します。

segment

STCN を受信する REP セグメント 1 つまたは一連のセグメントを指定します。

id_list

セグメント ID のリストです。有効範囲は 1 ~ 1024 です。

 
コマンド デフォルト

他のインターフェイスおよびセグメントへの STCN 送信は、デフォルトではディセーブルになっています。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

デフォルトでは STCN はディセーブルになっています。このコマンドは通常のセグメント ポートには適用されません。

次に、STCN を送信するように REP エッジ ポートを設定する例を示します。

MSTP-176(config-if)# rep stcn segment 50

MSTP-176(config-if)# rep stcn interface <1-22>

rep preempt delay

セグメント ポートの障害および回復の発生後、VLAN ロード バランシングがトリガーされるまでの待機時間を設定するには、インターフェイス コンフィギュレーション モードで rep preempt delay コマンドを使用します。設定した遅延を削除するには、このコマンドの no 形式を使用します。

rep preempt delay {seconds}

[no] rep preempt delay

 
構文の説明

seconds

REP プリエンプションを遅延する秒数です。時間遅延範囲は 15 ~ 300 秒です。

 
コマンド デフォルト

rep preempt delay コマンドを入力しない場合、プリエンプションの遅延は設定されません。デフォルト設定は、遅延のない手動によるプリエンプションです。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

REP プライマリ エッジ ポート上にだけこのコマンドを入力します。リンク障害および回復の後に VLAN ロード バランシングを自動的にトリガーするには、このコマンドを入力してプリエンプト時間の遅延を設定します。

次に、プライマリ エッジ ポートで REP プリエンプション時間遅延を 100 秒に設定する例を示します。

MSTP-176(config-if)# rep preempt delay 100

rep preempt

REP プリエンプションを手動で開始するには、インターフェイス コンフィギュレーション モードで rep preempt コマンドを使用します。REP VLAN ロード バランシングを非アクティブ化するには、このコマンドの no 形式を使用します。

rep preempt

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド デフォルト

デフォルト動作は手動プリエンプションです。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

VLAN ロード バランシングが設定されているプライマリ エッジ ポートにこのコマンドを入力します。

次に、手動で REP プリエンプションをトリガーする例を示します。

MSTP-176(config-if)# rep preempt

rep preempt segment

セグメントで REP プリエンプションを手動で開始するには、インターフェイス コンフィギュレーション モードで rep preempt segment コマンドを使用します。このコマンドには、 no 形式はありません。

rep preempt segment segment_id

 
構文の説明

segment_id

REP セグメントの ID です。値の範囲は 1 ~ 1024 です。

 
コマンド デフォルト

デフォルト動作は手動プリエンプションです。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

プライマリ エッジ ポートの存在するスイッチにこのコマンドを入力します。

次に、セグメント 100 で手動で REP プリエンプションをトリガーする例を示します。

MSTP-176(config-if)# rep preempt segment 100

rep block port

REP プライマリ エッジ ポートで REP VLAN ロード バランシングを設定するには、インターフェイス コンフィギュレーション モードで rep block port を使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

rep block port {id port_id | preferred} vlan {vlan_list | all}

[no] rep block port {id port_id | preferred} vlan {vlan_list | all}

 
構文の説明

id port_id

REP をイネーブルにすると自動的に生成される一意のポート ID を入力して VLAN ブロッキング代替ポートを指定します。REP ポート ID は 16 文字の 16 進整数値です。たとえば、0X0080001647FB1780 などです

preferred

VLAN ブロッキング代替ポートをセグメント ポートとして指定します。preferred キーワードを入力しても確実に代替ポートは指定されませんが、他の類似のポートより優先されます。

vlan

ブロックされる VLAN を指定します。

vlan_list

ブロックする 1 ~ 4094 の VLAN ID または VLAN の範囲またはシーケンス(1-3, 22, 41-44 など)です。

all

すべての VLAN をブロックします。

 
コマンド デフォルト

デフォルトでは、プライマリ エッジ ポートですべての VLAN がブロックされます。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
使用上のガイドライン

rep preempt segment 特権 EXEC コマンド(手動プリエンプション)を入力した場合のデフォルトのアクションは、プライマリ エッジ ポートで VLAN すべてがブロックされます。この動作は rep block port コマンドを設定するまで継続されます。

プライマリ エッジ ポートで代替ポートを判別できない場合は、デフォルトのアクションはプリエンプションなし、および VLAN ロード バランシングなしです。

次に、VLAN 1 ~ 100 をブロックするように代替ポートを設定する例を示します。

MSTP-176(config-if)# rep block port id 0X0080001647FB1780 vlan 1-100

shutdown

ポートをディセーブルにするには、 shutdown コマンドを使用します。ポートをイネーブルにするには、 no shutdown コマンドを使用します。このコマンドは管理者だけが実行できます。

shutdown

no shutdown

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド モード

インターフェイス コンフィギュレーション

次に、VLAN 2 のトラフィックをシャットダウンする例を示します。

MSTP-176(config-if)# shutdown vlan 2
 

mtu bytes

ポートが受け入れる最大フレーム サイズを設定するには、 mtu コマンドを使用します。

Maximum Transmission Unit(MTU; 最大伝送ユニット)を調整して、インターフェイスでジャンボ フレームをイネーブルにするには、 mtu コマンドを使用します。

mtu <bytes>

 
構文の説明

bytes

バイトのサイズです。有効な値は 64 ~ 9700 です。

 
デフォルト

デフォルトでは、ジャンボ フレームはディセーブルになっています。MTU のデフォルト値は 9700 です。

 
コマンド モード

インターフェイス コンフィギュレーション

 
使用上のガイドライン

この設定を行うには、管理者としてログインし、ポートが管理上のダウン状態であることを確認します。

次に、1800 バイトの MTU を指定する例を示します。

MSTP (config)# interface GigabitEthernet 2
MSTP (config-if)# mtu 1800
 
 

speed auto|1000, 10000

自動ネゴシエーションをイネーブルにするか、速度を手動で設定するには、インターフェイス コンフィギュレーション モードで speed コマンドを使用します。

 
構文の説明

auto

ファスト イーサネットの自動ネゴシエーションをイネーブルにします。インターフェイスは、メディアのタイプ、ネットワーク設定で使用されているピア カード、ハブ、およびスイッチの伝送速度などの環境要因に応じて、自動的に 1000 Mbps または 10000 Mbps で動作します。デフォルトでは自動ネゴシエーションを行います。

 
コマンド モード

インターフェイス コンフィギュレーション

 
使用上のガイドライン

GE_XP、10GE_XP、GE_XPE、および 10GE_XPE のクライアント速度およびトランク ポートを次のように設定できます。

表 C-2 速度値の設定

カード
ポート
速度

GE_XP および GE_XPE

1 ~ 20 のクライアント ポート

auto

1000 Mbps

GE_XP および GE_XPE

21 と 22 のトランク ポート

10000

10 GE-XP および 10 GE_XPE

1 ~ 4 のトランク ポート

10000

次に、1000 Mbps の動作を指定する例を示します。

MSTP-176(config-if)# speed 1000
 

 

flowcontrol on|off

ギガビット イーサネット インターフェイスがポーズ フレームを送信または受信するよう設定するには、 flowcontrol ON または OFF コマンドを使用します。

flowcontrol on|off

 
構文の説明

on

ポートがリモート ポートからのポーズ フレームを受信して処理したり、リモート ポートへポーズ フレームを送信したりする機能をイネーブルにします。

off

ポートがリモート ポートからのポーズ フレームを受信して処理したり、リモート ポートへポーズ フレームを送信したりするのを禁止します。

 
デフォルト

デフォルトでは、ギガビット イーサネットおよび 10 ギガビット イーサネット インターフェイスのポートはオフに設定されています。

 
コマンド モード

インターフェイス コンフィギュレーション

 
使用上のガイドライン

ポーズ フレームは、バッファが満杯であるために特定の期間フレームの送信を停止する信号を送信元に送る特殊なパケットです。

次に、ポートのポート フレーム機能をイネーブルにする例を示します。

MSTP-176(config-if)# flowcontrol receive on
MSTP-176(config-if)#
 

switchport mode trunk

ポートを UNI/NNI として設定するには、 switchport mode trunk コマンドを使用します。

switchport mode trunk

 
デフォルト

デフォルトでは、すべてのクライアント ポートは dot1q-tunnel であり、すべてのトランク ポートは trunk です。

 
コマンド モード

インターフェイス コンフィギュレーション

 
使用上のガイドライン

これらの設定を行うには、ポートが管理上のダウン状態になっている必要があります。

次の例では、ポートをトランク モードに設定する方法を示します。

MSTP(config-if)# switchport mode trunk
 

設定を確認するには、 show interfaces 特権 EXEC コマンドを入力します。

switchport mode dot1q-tunnel

これらのコマンドによりポートが UNI/NNI として設定され、 switchport mode trunk を使用します。

switchport mode dot1q-tunnel

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

デフォルトでは、すべてのクライアント ポートは dot1q-tunnel であり、すべてのトランク ポートは trunk です

 
コマンド モード

インターフェイス コンフィギュレーション

 
使用上のガイドライン

インターフェイスをトランクにするには、 switchport mode trunk コマンドを使用します。

次の例では、ポートを IEEE 802.1Q トンネル ポートとして設定する方法を示します。

MSTP-176(config-if)# switchport mode dot1q-tunnel
 

設定を確認するには、 show interfaces 特権 EXEC コマンドを入力します。

service-policy input name

ポートに関連するポリシーをマッピングすることで、ポートの入出力 QoS パラメータを設定するには、 service-policy input コマンドを使用します。

service-policy input name

[no] service-policy input name

 
構文の説明

name

適用されるサービス ポリシー マップの名前です。

 
デフォルト

ポリシー マップは適用されません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
使用上のガイドライン

設定時には、ポートが管理上のダウン状態である必要があります。

次に、ポリシーマップをインターフェイスに適用する例を示します。

MSTP-176(config-if)# service-policy input pmap1
MSTP-176(config-if)#
 

service-policy output name

ポートに関連するポリシーをマッピングすることで、ポートの入出力 QoS パラメータを設定するには、インターフェイス コンフィギュレーション コマンドで service-policy output name コマンドを使用します。

service-policy output name

[no] service-policy output name

 
構文の説明

name

適用されるサービス ポリシー マップの名前です。

 
デフォルト

ポリシー マップは適用されません。

 
コマンド モード

インターフェイス コンフィギュレーション

次に、ポリシーマップを出力インターフェイスに適用する例を示します。

MSTP-176(config-if)# service-policy output policy9
MSTP-176(config-if)#
 
 

service instance ethernet name

インターフェイスでサービス インスタンスを作成するには、 service instance ethernet name コマンドを使用します。

service instance ethernet name

 
構文の説明

name

サービス インスタンスの名前です。最大文字数は 32 文字です。

 
コマンド モード

インターフェイス コンフィギュレーション

次に、サービス インスタンスを作成する例を示します。

MSTP-176(config-if)# service instance Ethernet servether1
MSTP-176(config-if)#
 

l2protocol-tunnel

インターフェイスでプロトコル トンネリングをイネーブルにするには、 l2protocol-tunnel コマンドを使用します。

l2protocol-tunnel

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

レイヤ 2 プロトコルのトンネリングは設定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション

次に、プロトコル トンネリングをイネーブルにする例を示します。

MSTP-176(config-if)# l2protocol-tunnel
MSTP-176(config-if)#

 

[no] switchport port-security mac-address mac-address

インターフェイスにセキュア MAC アドレスを設定するには、 switchport port-security mac-address コマンドを使用します。

switchport port-security mac-address mac-address

[no] switchport port-security mac-address mac-address

 
構文の説明

mac-address

ポートの MAC アドレスです。形式は 00:00:00:00:00:00 です

 
デフォルト

ポートの MAC アドレスは保護されていません。

 
コマンド モード

インターフェイス コンフィギュレーション

次に、インターフェイスで MAC アドレスのセキュリティ保護を設定する例を示します。

MSTP-176(config-if)# switchport port-security mac-address ff:ee:00:12:30:04
 
 

ip igmp snooping mrouter

レイヤ 2 ポートをマルチキャスト ルータ ポートとして設定するには、ip igmp snooping mrouter コマンドを使用します。設定を削除するには、このコマンドの no 形式を使用します。

ip igmp snooping mrouter

 
コマンド モード

インターフェイス コンフィギュレーション

 
使用上のガイドライン

IGMP がイネーブルになっているポートに関連付けられている SVLAN で有効です。

次に、マルチキャスト ルータへのネクスト ホップ インターフェイスを指定する例を示します。

MSTP-176(config-if)# ip igmp snooping mrouter interface gigabitethernet 5
MSTP-176(config-if)#
 

encapsulation default

インターフェイスが使用するカプセル化方式を設定するには、サービス インターフェイス コンフィギュレーション モードで encapsulation default コマンドを使用します。

encapsulation default

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド モード

サービス インスタンス コンフィギュレーション

 
使用上のガイドライン

トランスペアレント モードでポートを設定するには、rew ing tag push dot1 <svlan> コマンドを実行します。

MSTP-176(config-if-srv)# encapsulation default

 

encapsulation dot1q first cvlan last cvlan

Virtual LAN(VLAN; 仮想 LAN)の特定のサブインターフェイスのトラフィックの IEEE 802.1Q カプセル化をイネーブルにするには、サービス インターフェイス コンフィギュレーション モードまたはサブインターフェイス コンフィギュレーション モードで encapsulation dot1q first cvlan last cvlan> コマンドを使用します。

encapsulation dot1q first cvlan last cvlan>

 
構文の説明

<first cvlan> <last cvlan>

各 Customer VLAN(CVLAN; カスタマー VLAN)ID の範囲とその次の範囲を分けるため、カンマを入力する必要があります。

 
デフォルト

デフォルトでは、IEEE 802.1Q のカプセル化はディセーブルになっています。

 
コマンド モード

サービス インスタンス コンフィギュレーション

 
使用上のガイドライン

IEEE 802.1Q カプセル化は、GigE インターフェイスおよび 10 GigE で設定可能です。IEEE 802.1Q はカードの相互接続、および VLAN トポロジを定義するための標準プロトコルです。

MSTP-176(config-if-srv)# encapsulation dot1q 1000 1002

encapsulation untagged

タグなしイーサネット フレーム入力を適切なサービス インスタンスにインターフェイスでマッピングするために使用する一致基準を定義します。

encapsulation untagged

 
構文の説明

このコマンドには、引数またはキーワードはありません。

 
コマンド モード

サービス インスタンス コンフィギュレーション

MSTP-176(config-if-srv)# encapsulation untagged

 

bridge-domain svlan

RFC 1490 フレーム リレー ブリッジングをイネーブルにしてブリッジ VLAN を GE_XP、10GE_XP、GE_XPE、および 10GE_XPE カードにマップするには、サービス インターフェイス コンフィギュレーション モードで bridge-domain コマンドを使用します。

bridge-domain svlan

 
構文の説明

svlan

ブリッジングの設定に使用される SVLAN ID。有効範囲は 1 ~ 4093 です。

 
デフォルト

ブリッジングはディセーブルです。

 
コマンド モード

サービス インスタンス コンフィギュレーション

次に、VLAN ID 99 を使用して GE_XP、10GE_XP、GE_XPE、および 10GE_XPE に IEEE 802.1Q VLAN ブリッジングを設定する例を示します。

MSTP-176(config-if-srv)# bridge-domain 99
 

police cir percent % bc bytes be bytes

インターフェイスで使用可能な帯域幅の割合(%)に基づいてトラフィック ポリシングを設定するには、ポリシー マップ コンフィギュレーション モードで police コマンドを使用します。

police cir percent % bc bytes be bytes

 
構文の説明

cir

CIR を表します。トラフィック ポリシングに使用される CIR を指定します。

percent

CIR の計算に使用される帯域幅の割合(%)を指定します。

%

帯域幅の割合(%)を指定します。有効値の範囲は 1 ~ 100 です。

bc

ポリシング トラフィックの最初のトークン バケットによって使用される適合バースト(bc)サイズ。

be

ポリシング トラフィックの 2 番めのトークン バケットによって使用される最大バースト(be)サイズ。

 
デフォルト

デフォルトではトラフィック ポリシングはディセーブルです。

 
コマンド モード

ポリシー マップ コンフィギュレーション、および VLAN プロファイル コンフィギュレーション。

次に、帯域幅の割合(%)に基づいた CIR と PIR を使用してトラフィック ポリシングを設定する例を示します。この例では、20% の CIR と 40% の PIR が指定されました。オプションの bc 値と be 値(それぞれ、300 ms、400 ms)も指定されています。

MSTP(config-pmap)# police cir percent 20 bc 300 ms be 400 ms
 
 

 

set cos number

発信パケットでレイヤ 2 Class of Service(CoS; サービス クラス)の値を設定するには、ポリシー マップ コンフィギュレーション モードで set cos コマンドを使用します。

set cos number

 
構文の説明

number

802.1Q SVLAN タグに適用する CoS 値を指定します。0 ~ 7 の値は、CoS の定数値を指定します。8 ~ 9 の値は、次の内容を意味します。

8 = TRUST。この値は、SVLAN CoS フィールドにコピーするなど、CVLAN CoS 値を信頼する必要があることを意味します。

9 = CVLAN。この値は、SVLAN CoS フィールドが CVLAN ID の値に基づいて設定されることを意味します。このマッピングは、EVC サービス インスタンスによって実行されます。インターフェイスのサービス インスタンスは、フレームと 1 つ以上の CVLAN が一致するように定義することができます。そのサービス インスタンスには、CoS を指定するポリシーを適用することもできます。その結果、インターフェイスの CVLAN から CoS にマッピングが行われます。

 
デフォルト

デフォルトでは、発信パケットの CoS 値は設定されません。

 
コマンド モード

ポリシーマップ コンフィギュレーション。

 
使用上のガイドライン

最大 9 つの CoS 値を入力します。

次の例では、異なるタイプのトラフィックに対して異なる CoS 値を割り当てるために、"cos-set" という名前のポリシー マップが作成されます。

MSTP(config)# policy-map cos-set
MSTP(config-pmap-c)# set cos 1
 

wrr-queue cos-map queue-id cos1 ... cosn

CoS 値をキューの廃棄しきい値にマッピングするには、wrr-queue cos-map コマンドを使用します。

wrr-queue cos-map queue-id cos1 ... cosn

 
構文の説明

queue-id

キュー番号。有効値は 1 です。

cos1 ... cosn

CoS 値。有効値は 0 ~ 9 です。

 
コマンド モード

ポリシーマップ コンフィギュレーション。

次に、標準送信キュー 1 に CoS 値 0 および 1 をマッピングする例を示します。

MSTP(config-pmap)# wrr-queue cos-map 1 1 0
MSTP(config-pmap)#
 

 

wrr-queue queue-id w eight 1-16 bandwidth percent %

帯域幅を標準送信キュー 1(低プライオリティ)と標準送信キュー 2(高プライオリティ)に割り振るには、 wrr-queue bandwidth コマンドを使用します。

wrr-queue <queue-id> weight <1-16> bandwidth percent <%>

 
構文の説明

weight <1-16)

WRR 重みを指定します。有効値は 1 ~ 15 です。

 
コマンド モード

ポリシーマップ コンフィギュレーション。

次に、3 対 1 の帯域幅比率を割り当てる例を示します。

MSTP(config-pmap)# wrr-queue weight 2 bandwidth 3