Cisco ONS 15454 リファレンス マニュアル Release 6.0
管理ネットワークの接続
管理ネットワークの接続
発行日;2012/01/09 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

管理ネットワークの接続

管理ネットワークの接続

この章では、ONS 15454 Data Communication Network(DCN)接続の概要について説明します。Cisco Optical Networking System(ONS)ネットワークの通信は、Cisco Transpot Controller(CTC)コンピュータと ONS 15454 ノード間の通信、ネットワーク接続された ONS 15454 ノード間の通信を含め、IP に基づいて行われます。この章では、一般的な IP ネットワーク構成における Cisco ONS 15454 のシナリオを紹介するとともに、プロビジョニング可能なパッチコード、IP ルーティング テーブル、外部ファイアウォール、開放型 Gateway Network Element(GNE; ゲートウェイ ネットワーク エレメント)ネットワークについて説明します。


) この章では、IP ネットワーキング全般の概念や手順については説明しません。また、あらゆるネットワーク状況に対応する IP アドレッシングの例も紹介しません。ONS 15454 ネットワーキングの設定手順については、『Cisco ONS 15454 Procedure Guide』で「Turn Up Node」の章を参照してください。


ONS 15454 DCN の通信は IP ベースですが、ONS 15454 は Open Systems Interconnection(OSI; 開放型システム間相互接続)プロトコル スイートに準拠した装置にネットワーク接続できます。この章では、ONS 15454 OSI の実装について説明し、IP と OSI が混在する環境で ONS 15454 をネットワーク接続するシナリオを紹介します。

次の内容について説明します。

「IP ネットワーキングの概要」

「IP アドレッシング シナリオ」

「プロビジョニング可能なパッチコード」

「ルーティング テーブル」

「外部ファイアウォール」

「オープン GNE」

「TCP/IP および OSI ネットワーキング」


) ONS 15454 を IP ネットワークに接続する場合には、LAN 管理者または IP ネットワークのトレーニングを受けた経験を持つ現場担当者と一緒に作業してください。


13.1 IP ネットワーキングの概要

IP 環境で ONS 15454 を接続する方法は多数あります。

直接接続またはルータを使用して LAN に接続できます。

IP サブネット化で ONS 15454 ノード グループを作成します。このノード グループにより、ネットワーク内で非 Data Communication Channel(DCC; データ通信チャネル)接続されたノードを プロビジョニング できます。

さまざまな IP 機能とプロトコルを使用して特定のネットワーク目的を実現できます。たとえば、プロキシ Address Resolution Protocol(ARP; アドレス解決プロトコル)により、LAN に接続された 1 つの ONS 15454 を、LAN に接続されていない ONS 15454 のゲートウェイとして使用できます。

スタティック ルートを作成することによって、ONS 15454 が複数の CTC セッションと同じサブネット上に配置されている場合に、その ONS 15454 との複数の CTC セッション間を接続できます。

ONS 15454 を Open Shortest Path First(OSPF)ネットワークに接続すると、ONS 15454 ネットワーク情報が複数の LAN および WAN を介して自動的に伝達されます。

ONS 15454 SOCKS(ネットワーク プロキシ プロトコル)プロキシ サーバは、CTC コンピュータと ONS 15454 要素ノードの間の可視性とアクセス可能性を制御できます。

13.2 IP アドレッシング シナリオ

ONS 15454 の IP アドレッシングには、一般的に 8 つのシナリオ(設定)があります。より複雑なネットワーク構成の基礎として、これらのシナリオを使用してください。 表13-1 に、IP ネットワークで ONS 15454 を設定する際の一般的なチェック項目の一覧を示します。

 

表13-1 ONS 15454 の IP トラブルシューティングに関する一般的なチェックリスト

項目
チェック内容

リンク完全性

次の構成要素の間でリンク完全性があることを確認します。

CTC コンピュータとネットワーク ハブまたはスイッチ

ONS 15454(バックプレーン ワイヤラップ ピンまたは RJ-45 ポート)とネットワーク ハブまたはスイッチ

ルータ ポートとハブ ポートまたはスイッチ ポート

ONS 15454 ハブ ポートまたはスイッチ ポート

接続に問題がある場合は、ONS 15454 に接続しているハブまたはスイッチ ポートを 10 Mbps の半二重に設定します。

ping

ノードに対して ping を実行し、コンピュータと ONS 15454 間の接続をテストします。

IP アドレス/サブネット マスク

ONS 15454 の IP アドレスとサブネット マスクが正しく設定されているかどうかを確認します。

光通信の接続

ONS 15454 の光トランク(スパン)ポートが稼働中で、DCC が各トランク ポートで有効かどうかを確認します。


) Advanced Timing,Communications,Control/Advanced Timing,Communications,Control Plus(TCC2/TCC2P)カード セキュア モード オプションを使用すると、1 つはバックプレーン LAN ポート用、もう 1 つはTCC2/TCC2P TCP/IP ポート用として、2 つの IP アドレスをノード用にプロビジョニングできます。セキュア モードの IP アドレッシング例については、「IP のシナリオ 9:セキュア モードを有効にした IP アドレッシング」を参照してください。他のシナリオの IP アドレスは、セキュア モードが無効になっていることを前提としています。セキュア モードが有効な場合、例に示した IP アドレスは、バックプレーン LAN ポートに適用されます。


13.2.1 IP のシナリオ 1:同一サブネット上の CTC および ONS 15454

IP のシナリオ 1 で、ONS 15454 の基本的な LAN 構成を示します(図13-1)。ONS 15454 と CTC コンピュータは同一サブネット上に存在します。すべての ONS 15454 が LAN A に接続され、すべての ONS 15454 が DCC 接続されています。

図13-1 IP のシナリオ 1:同一サブネット上の CTC および ONS 15454

 

13.2.2 IP のシナリオ 2:ルータに接続された CTC および ONS 15454 ノード

シナリオ 2 では、CTC コンピュータはサブネット(192.168.1.0)上にあり、LAN A(図13-2)に接続されています。ONS 15454 は異なるサブネット(192.168.2.0)上にあり、すべての ONS 15454 が LAN B に接続されています。ルータによって、LAN A と LAN B が接続されています。ルータ インターフェイス A の IP アドレスは LAN A(192.168.1.1)に、ルータ インターフェイス B の IP アドレスは LAN B(192.168.2.1)にそれぞれ設定されています。

CTC コンピュータでは、デフォルト ゲートウェイにルータ インターフェイス A が設定されています。LAN で Dynamic Host Configuration Protocol(DHCP)を使用する場合は、デフォルト ゲートウェイと IP アドレスが自動的に割り当てられます。図13-2 では、DHCP サーバは使用できません。

図13-2 IP のシナリオ 2:ルータに接続された CTC および ONS 15454 ノード

 

13.2.3 IP のシナリオ 3:プロキシ ARP による ONS 15454 ゲートウェイの有効化

ARP は、上位レベルの IP アドレスを宛先ホストの物理アドレスと照合します。ARP は、ルックアップ テーブル(ARP キャッシュと呼ばれる)を使用して変換を行います。ARP キャッシュ内でアドレスが見つからなかった場合は、ARP 要求と呼ばれる特別な形式でブロードキャストをネットワークに送出します。ネットワーク上の 1 つのマシンが自分のマシンの IP アドレスを含む ARP 要求を認識すると、ARP 要求の送信側ホストへ ARP 応答を返します。ARP 応答には、受信側ホストの物理ハードウェア アドレスが含まれます。送信側ホストはその ARP キャッシュにこのアドレスを保存します。したがって、この宛先 IP アドレスへの以降のすべてのデータグラム(パケット)が物理アドレスに変換できます。

プロキシ ARP により、LAN に接続された ONS 15454 は、LAN に接続されていない ONS 15454 の ARP 要求に応答できます(ONS 15454 プロキシ ARP に対する設定は不要です)。この応答を可能にするには、DCC 接続された ONS 15454 が同一サブネット上に存在する必要があります。LAN 装置が LAN に接続されていない ONS 15454 に ARP 要求を送信すると、ゲートウェイ ONS 15454 は自分の MAC(メディア アクセス制御)アドレスを LAN 装置に返します。LAN 装置は、次にリモートの ONS 15454 宛てのデータグラムを、このプロキシ ONS 15454 の MAC アドレスに送信します。プロキシ ONS 15454 は自分のルーティング テーブルを使用して、このデータグラムを LAN に接続されていない ONS 15454 に送信します。

IP のシナリオ 3 は、IP のシナリオ 1 に類似していますが、LAN に接続する ONS 15454 は #1 の 1つだけです(図13-3)。残りの 2 つの ONS 15454(#2 と #3)は、SONET DCC を介して ONS 15454 #1 に接続されます。3 つすべての ONS 15454 が同一サブネット上にあるので、プロキシ ARP によって ONS 15454 #1 は ONS 15454 #2 および #3 のゲートウェイとして使用できるようになります。


) このシナリオでは、すべての CTC がノード 1 に接続されているものと仮定しています。ラップトップ コンピュータが ONS 15454 #2 または #3 のどちらかに接続されている場合は、ネットワーク分割が発生します。ラップトップ コンピュータおよび CTC コンピュータのどちらも、すべてのノードを参照することはできません。ラップトップを終端の Network Element(NE; ネットワーク要素)に直接接続する場合は、スタティック ルートを作成するか(IP のシナリオ 5:スタティック ルートを使用した LAN 接続を参照)、または ONS 15454 SOCKS プロキシ サーバを有効にする(IP のシナリオ 7:ONS 15454 SOCKS プロキシ サーバのプロビジョニングを参照)必要があります。


図13-3 IP のシナリオ 3:プロキシ ARPの使用

 

プロキシ ARP を使用して、DCC 接続ノードのクラフト イーサネット ポートに接続されたホストと通信することもできます(図13-4)。ホストが接続されたノードには、ホストに対するスタティック ルートが必要です。スタティック ルートは、OSPF を使用してすべての DCC ピアに伝播されます。既存のプロキシ ARP ノードは、他のホストのゲートウェイになります。各ノードは、それぞれのルーティング テーブルで、サブネット内にありながら、DCC ネットワークに接続されていないホストへのルートを調べます。既存のプロキシ サーバは、これらの他のホストに対する ARP 要求にノードの MAC アドレスで応答します。ルーティング テーブルにホスト ルートが存在することによって、他のホスト宛ての IP パケットが確実に正しくルーティングされます。ノードと他のホスト間にスタティック ルートを設定するだけで、それ以外のプロビジョニングは不要です。次の制限事項があります。

いずれの追加ホストに対しても、プロキシ ARP サーバとして動作するノードは 1 つだけです。

ノードをイーサネット ポートに接続されたホスト用のプロキシ ARP サーバにはできません。

図13-4 のノード 1 は、CTC ホストに到達できることをノード 2 と 3 に伝えます。ノード 3 は同様に、ONS 152xx に到達できることを伝えます。ONS 152xx は単なる例です。任意の NE を追加ホストとして設定できます。

図13-4 IP のシナリオ 3:スタティック ルーティングでのプロキシ ARP の使用

 

13.2.4 IP のシナリオ 4:CTC コンピュータ上のデフォルト ゲートウェイ

IP のシナリオ 4 は IP のシナリオ 3 に似ていますが、ノード 2 とノード 3 がそれぞれ 192.168.2.0 と 192.168.3.0 の異なるサブネットにあります(図13-5)。ノード 1 と CTC コンピュータはサブネット 192.168.1.0 にあります。異なるサブネットからなるネットワークなので、プロキシ ARP は使用しません。CTC コンピュータが ノード 2 と 3 と通信できるように、ノード 1 を CTC コンピュータ上のデフォルト ゲートウェイにします。

図13-5 IP のシナリオ 4:CTC コンピュータ上のデフォルト ゲートウェイ

 

13.2.5 IP のシナリオ 5:スタティック ルートを使用した LAN 接続

スタティック ルートは次の 2 つの目的で使用します。

ルータによって別のサブネット上の ONS 15454 に接続されたあるサブネット上の CTC セッションに ONS 15454 を接続します(OSPF が有効な場合には、これらのスタティック ルートは不要です。OSPF の例については、IP のシナリオ 6:OSPF の使用を参照)。

同一サブネット上にある ONS 15454 間で複数の CTC セッションを有効にします。

図13-6 では、サブネット 192.168.1.0 上の CTC がインターフェイス A でルータに接続されています(このルータは OSPF で設定されていません)。別のサブネット上の ONS 15454 は ノード 1 に接続され、インターフェイス B でルータに接続されています。ノード 2 と 3 がそれぞれ異なるサブネットにあるので、プロキシ ARP は ノード 1 にゲートウェイとしての使用を認めません。LAN A(サブネット 192.168.1.0)上の CTC コンピュータに接続するには、ノード 1 上でスタティック ルートを作成する必要があります。さらに、LAN A 上の CTC コンピュータとノード 2、ノード 3 間のスタティック ルートを手動で追加することも必要です。ノード 2 と 3 が異なるサブネットにあるからです。

図13-6 IP のシナリオ 5:宛先として使用される CTC コンピュータのスタティック ルート

 

宛先エントリとサブネット マスク エントリは、ONS 15454 へのアクセスを制御します。

ルータに単一の CTC コンピュータを接続する場合は、サブネット マスク 255.255.255.255 を指定し、宛先として完全な CTC「ホスト ルート」IP アドレスを入力します。

サブネット上の複数の CTC コンピュータを 1 つのルータに接続する場合は、宛先サブネット(この例では 192.168.1.0)とサブネット マスク 255.255.255.0 を入力します。

すべての CTC コンピュータを 1 つのルータに接続する場合は、宛先 0.0.0.0 とサブネット マスク 0.0.0.0 を入力します。図13-7 に例を示します。

ルータ インターフェイス B の IP アドレスをネクスト ホップとして入力します。コスト(起点から終点までのホップ数)は 2 です。LAN A、C、D 上の CTC コンピュータとノード 2 と 3 間のスタティック ルートを手動で追加する必要があります。これらのノードが異なるサブネットにあるからです。

図13-7 IP のシナリオ 5:複数の LAN 宛先のスタティック ルート

 

13.2.6 IP のシナリオ 6:OSPF の使用

OSPF は、リンクステート インターネット ルーティング プロトコルです。リンクステート プロトコルは、「Hello プロトコル」を使用して隣接ルータとのリンクをモニタしたり、ネイバへのリンクの状態をテストしたりします。リンクステート プロトコルは、直接接続されているネットワークとそのネットワークのアクティブ リンクをアドバタイズします。各リンクステート ルータは、リンクステート「アドバタイズ」を取り込み、これらをまとめてネットワーク全体またはエリアのトポロジーを作成します。ルータは、このデータベースから最短パス ツリーを構築してルーティング テーブルを計算します。ルートは、トポロジーが変更されたときに再計算されます。

ONS 15454 は内部 ONS 15454 ネットワーク内で OSPF プロトコルを使用して、ノード検出、回線ルーティング、およびノード管理を行います。ONS 15454 上で OSPF を有効にすると、ONS 15454 トポロジーが LAN 上の OSPF ルータに送られます。ONS 15454 ネットワーク トポロジーを LAN ルータにアドバタイズすると、ONS 15454 サブネットワークのスタティック ルートを手動で入力しなくてすみます。図13-8 に、OSPF 対応のネットワークを示します。さらに 図13-9 に、同じネットワークで OSPF を使用しない場合を示します。スタティック ルートは、LAN A 上の CTC コンピュータに対応するルータに手動で追加して、ノード 2 および 3 と通信できるようにする必要があります。これは、ノード 2 および 3 が異なるサブネット上にあるからです。

OSPF は、エリアと呼ばれる小さい領域にネットワークを分割します。エリアは、トラフィック パターン別に編成されたネットワークの終端システム、ルータ、および伝送ファシリティの集まりです。OSPF エリアごとに、エリア ID という固有の ID 番号が与えられます。各 OSPF ネットワークに 1 つずつ、「エリア 0」というバックボーン エリアがあります。他のすべての OSPF エリアはエリア 0 に接続する必要があります。

OSPF ネットワークにアドバタイズできるように ONS 15454 OSPF トポロジーを有効にする場合は、ONS 15454 ネットワークに 10 進形式の OSPF エリア ID を割り当てる必要があります。LAN 管理者に相談して、割り当てるエリア ID 番号を決定してください。DCC 接続されたすべての ONS 15454 に、同じ OSPF エリア ID を割り当てる必要があります。

図13-8 IP のシナリオ 6:OSPF が有効な場合

 

図13-9 IP のシナリオ 6:OSPF が有効でない場合

 

13.2.7 IP のシナリオ 7:ONS 15454 SOCKS プロキシ サーバのプロビジョニング

ONS 15454 SOCKS プロキシは、企業のプライベート ネットワークと ONS 15454 ネットワーク間の内部ゲートウェイとして ONS 15454 ノードを動作させるアプリケーションです(SOCKS は、Internet Engineering Task Force [IETF] が開発した、IP ベースのアプリケーションに対応する標準プロキシ プロトコルです)。プライベート ネットワークから ONS 15454 ネットワークへのアクセスは許可されますが、ONS 15454 ネットワークからプライベート ネットワークへのアクセスは拒否されます。たとえば、現場技術者と Network Operations Center(NOC)の人間がどちらも同じ ONS 15454 にアクセスできるようにしながら、現場技術者には NOC LAN へのアクセスを禁止するように、ネットワークを設定できます。この場合、ONS 15454 の 1 つを GNE としてプロビジョニングし、他の ONS 15454 を End NE(ENE; 終端 NE)としてプロビジョニングします。GNE ONS 15454 は CTC コンピュータと ENE ONS 15454 間の接続をトンネリングし、ONS 15454 管理目的以外のアクセスを制限しながら管理機能を提供します。

ONS 15454 のゲートウェイ設定で次の作業を行います。

DCC IP トラフィックをイーサネット(クラフト ポート)トラフィックから分離し、フィルタリング規則に基づいてパケットを受け付けます。フィルタリング規則(SOCKS プロキシ サーバのファイアウォール フィルタリング規則パケットの宛先が ONS 15454 の場合の SOCKS プロキシ サーバのファイアウォール フィルタリング規則 を参照)は、パケットが ONS 15454 DCC または TCC2/TCC2P イーサネット インターフェイスのどちらに着信するかによって異なります。

Simple Network Time Protocol(SNTP)およびNetwork Time Protocol(NTP)要求を処理します。ONS 15454 ENE は、SNTP/NTP LAN サーバから GNE ONS 15454 を介して Time-of-Day(ToD)を取得できます。

SNMP version 1(SNMPv1; 簡易ネットワーク管理プロトコル バージョン1)トラップを処理します。GNE ONS 15454 は ENE ONS 15454 から SNMPv1 トラップを受信し、SNMPv1 トラップの宛先に転送するか、または ONS 15454 SNMP リレー ノードにリレーします。

ONS 15454 SOCKS プロキシ サーバは、Provisioning > Network > General タブを選択し、Enable SOCKS proxy server on port チェックボックスを使用して設定します(図13-10)。

図13-10 SOCKS プロキシ サーバ ゲートウェイの設定

 

このチェックボックスを選択すると、ONS 15454 がプロキシとして動作し CTC クライアントとプロキシ ONS 15454 に DCC 接続された ONS 15454 間を接続します。CTC クライアントはプロキシ ノードを介して DCC 接続ノードとの接続を確立します。CTC クライアントは、CTC クライアントが動作しているホストからは直接接続できないノードに、間接的に接続できます。このチェックボックスを選択しなかった場合、ノードは CTC クライアントのプロキシとして動作しません。ただし、確立されたプロキシ接続は CTC クライアントが終了するまで継続されます。さらに、SOCKS プロキシ サーバを ENE または GNE として設定できます。


) Network Address Translation(NAT; ネットワーク アドレス変換)または Port Address Translation(PAT; ポート アドレス変換)ルータ経由でノードに対して CTC を起動し、そのノードがプロキシを有効にしていなかった場合でも、CTC セッションが開始され、最初は問題なく動作しているように見えます。しかし、CTC がアラームの更新を受け取ることはなく、2 分ごとに切断と再接続を繰り返します。誤ってプロキシを無効にした場合でも、再接続時にプロキシを有効にすると、NAT/PAT ファイアウォール経由の場合も含めて、ノードの管理機能を回復できます。


External Network Element(ENE) ― ENE として設定した場合、ONS 15454 はデフォルト ルートまたはスタティック ルートの組み込みもアドバタイズも行いません。CTC コンピュータは、TCC2/TCC2P クラフト ポートを使用して ONS 15454 と通信できますが、DCC 接続された他の ONS 15454 とは直接通信できません。

また、ファイアウォールを有効にすると、ノードは DCC と LAN ポートの間で IP トラフィックがルーティングされないようにします。ONS 15454 は、LAN ポートに接続されたマシン、または DCC を介して接続されたマシンと通信できます。ただし、DCC 接続されたマシンは、LAN 接続されたマシンとは通信できません。同様に、LAN 接続されたマシンは DCC 接続されたマシンとは通信できません。ファイアウォール対応ノードとの接続に LAN を使用している CTC クライアントは、プロキシ機能を使用して DCC 接続されたノードを管理できます。別の方法では、この DCC 接続されたノードに到達できません。DCC 接続ノードに接続されている CTC クライアントが管理できるのは、他の DCC 接続ノードとファイアウォールそのものだけです。

GNE ― GNE として設定した場合、CTC コンピュータは他の DCC 接続されたノードに認識されます。また、ファイアウォールが有効になります。

Proxy-only ― これを選択した場合は、ファイアウォールが有効になりません。CTC は DCC 接続された他のあらゆる ONS 15454 と通信できます。

に、ONS 15454 SOCKS プロキシ サーバの実装を示します。GNE ONS 15454 は、セントラル オフィス LAN と ENE ONS 15454 に接続されています。セントラル オフィス LAN は、CTC コンピュータを備えた NOC LAN に接続されています。NOC CTC コンピュータとクラフトの技術者がどちらも ONS 15454 ENE にアクセスできなければなりません。ただし、クラフトの技術者が NOC やセントラル オフィス LAN にアクセスしたり表示したりできなくする必要があります。

この例では、ONS 15454 GNE はセントラル オフィス LAN の範囲内の IP アドレスが割り当てられ、その LAN ポートによって LAN に物理的に接続されています。ONS 15454 ENE には、セントラル オフィス LAN の範囲外の IP アドレスが割り当てられ、プライベート ネットワーク IP アドレスが割り当てられています。複数の ONS 15454 ENE が同じ場所に設置されている場合は、クラフト LAN ポートをハブに接続できますが、そのハブは他のネットワークに接続されていないようにします。

図13-11 IP のシナリオ 7:同一サブネット上に GNE と ENE が配置された ONS 15454 SOCKS プロキシ サーバ

 

表13-2 に、図13-11 の構成における ONS 15454 GNE および ENE の推奨設定値を示します。

 

表13-2 ONS 15454 ゲートウェイおよび終端 NE の設定値

設定
ONS 15454 ゲートウェイ NE
ONS 15454 終端 NE

OSPF

オフ

オフ

SNTP サーバ(使用する場合)

SNTP サーバ IP アドレス

ONS 15454 GNE IP アドレスに設定

SNMP(使用する場合)

SNMPv1 トラップ宛先

SNMPv1 トラップ宛先を ONS 15454 GNE、ポート 391 に設定

図13-12 に、ONS 15454 ENE が異なるサブネットにある場合について、同じプロキシ サーバの実装を示します。図13-13に、ONS 15454 ENE が複数のリングにある場合の実装を示します。どちらの例も、 表13-2 に示す設定値でONS 15454 GNE と ENE をプロビジョニングします。

図13-12 IP のシナリオ 7:異なるサブネット上に GNE と ENE が配置された ONS 15454 SOCKS プロキシ サーバ

 

図13-13 IP のシナリオ 7:ENE が複数のリングにある ONS 15454 SOCKS プロキシ サーバ

 

表13-3 に、ノードが ENE および GNE として設定されている場合に、ファイアウォールのパケット フィルタリングに関して ONS 15454 に適用される規則を示します。

 

表13-3 SOCKS プロキシ サーバのファイアウォール フィルタリング規則

パケットの着信先
パケットを受け付けるための宛先 IP アドレスの条件

TCC2/TCC2P イーサネット インターフェイス

ONS 15454 ノードの IP アドレス

ONS 15454 ノードのサブネット ブロードキャスト アドレス

224.0.0.0/8 ネットワーク範囲内のアドレス(標準マルチキャスト メッセージで使用するために予約されているネットワーク)

サブネット マスク = 255.255.255.255

DCC インターフェイス

ONS 15454 ノードの IP アドレス

別の DCC インターフェイス経由で接続されている任意の宛先

224.0.0.0/8 ネットワーク範囲内のアドレス

パケットの宛先が ONS 15454 ノードの場合は、 表13-4 に示す追加の規則が適用されます。拒否されたパケットは報告せずに、そのまま廃棄します。

 

表13-4 パケットの宛先が ONS 15454 の場合の SOCKS プロキシ サーバのファイアウォール フィルタリング規則

パケットの着信先
受け付け
拒否

TCC2/TCC2P イーサネット インターフェイス

拒否カラム以外のすべての UDP1 パケット

SNMP トラップ リレー ポート(391)宛の UDP パケット

DCC インターフェイス

すべての UDP パケット

Telnet および SOCKS プロキシ サーバ ポート宛てのパケットを除くすべての TCP2 プロトコル

OSPF パケット

ICMP3 パケット

Telnet ポート宛の TCP パケット

SOCKS プロキシ サーバ ポート宛の TCP パケット

UDP、TCP、OSPF、ICMP 以外の全パケット

1.UDP = User Datagram Protocol

2.TCP = Transmission Control Protocol

3.ICMP = Internet Control Message Protocol

SOCKS プロキシ サーバを実装する場合は、同じイーサネット セグメント上にある DCC 接続されたすべての ONS 15454 で同じゲートウェイ設定にする必要があります。これらの設定が異なると予測できない結果となり、共有イーサネット セグメントでいくつかのノードが到達不能になる場合があります。

ノードが到達不能になった場合は、次のいずれかの方法で設定を修正してください。

到達不能になった ONS 15454 からクラフト コンピュータを切り離します。到達不能になった ONS 15454 に DCC 接続されている別のネットワーク ONS 15454 を介して問題の ONS 15454 に接続します。

近接ノードで DCC を無効にすることによって、ノードからすべての DCC を切り離します。ONS 15454に CTC コンピュータを直接接続し、プロビジョニングを変更します。

13.2.8 IP のシナリオ 8:サブネット上のデュアル GNE

ONS 15454 は GNE のロードバランスを図るので、OSPF で ENE をアドバタイズしなくても、CTC から複数の GNE を介して ENE に到達できます。この機能により、ネットワークは GNE が異なるサブネット上に配置されている場合でも、GNE 損失から迅速に復旧できます。GNE で障害が発生すると、その GNE を経由するすべての接続で障害が発生します。CTC は障害 GNE とその GNE がプロキシになっていたすべての ENE から切り離され、残りの GNE を介して再接続されます。GNE のロードバランスによって、起動 GNE と DCC 帯域幅に対する依存度が下がり、その両方によって CTC のパフォーマンスが向上します。図13-14 に、同一サブネット上にデュアル GNE が配置されたネットワークを示します。

図13-14 IP のシナリオ 8:同一サブネット上のデュアル GNE

 

図13-15 に、異なるサブネットにデュアル GNE が配置されているネットワークを示します。

図13-15 IP のシナリオ 8:異なるサブネット上のデュアル GNE

 

13.2.9 IP のシナリオ 9:セキュア モードを有効にした IP アドレッシング

TCC2P カードのセキュア モード オプションを使用すると、ONS 15454 に IP アドレスを 2 つ設定できます。TCC2 カードを搭載している場合、または TCC2P カードを搭載していても 1 つだけの場合、セキュア モード オプションは CTC で認識されません。IP アドレスの 1 つは、ONS 15454 バックプレーン LAN ポート用にプロビジョニングします。もう 1 つの IP アドレスは、TCC2P TCP/IP クラフト ポート用にプロビジョニングします。この 2 つの IP アドレスによって、クラフト アクセス ポートと ONS 15454 LAN 間の分離層が 1 つ増えます。セキュア モードを有効にする場合、TCC2P TCP/IP ポート用にプロビジョニングする IP アドレスには、IP アドレッシングの一般的な注意事項を適用する必要があります。TCC2P IP アドレスはさらに、ONS 15454 バックプレーン ポートおよび ONS 15454 デフォルト ルータの IP アドレスとは異なるサブネット上になければなりません。

バックプレーン LAN ポートに割り当てた IP アドレスがプライベート アドレスになり、このアドレスを使用して ONS 15454 GNE をセントラル オフィス LAN または企業のプライベート ネットワーク経由で Operations Support System(OSS)に接続します。セキュア モードの場合、デフォルトでは、バックプレーンの LAN IP アドレスは CTC ノード ビューで表示されません。また、ノードに直接接続した技術者にも表示されません。このデフォルトを変更すると、スーパユーザに限り、CTC でバックプレーン IP アドレスを表示できるようになります。

図13-16に、セキュア モードを有効にした場合の、同一サブネット上の ONS 15454 を示します。

図13-16 IP のシナリオ 9:同一サブネット上の ONS 15454 GNE および ENE(セキュア モードが有効な場合)

 

図13-17 に、セキュア モードを有効にした場合の、ルータに接続された ONS 15454 を示します。どちらの例でも、TCC2/TCC2P ポート アドレスは、ノード バックプレーン アドレスとは異なるサブネット上にあります。

図13-17 IP のシナリオ 9:異なるサブネット上の ONS 15454 GNE および ENE(セキュア モードが有効な場合)

 

13.3 プロビジョニング可能なパッチコード

プロビジョニング可能なパッチコードとは、OSPF によってネットワーク全体にアドバタイズされる、ユーザがプロビジョニングしたリンクです。プロビジョニング可能なパッチコードは、仮想リンクとも呼ばれ、次のような状況で必要です。

トランスペアレント モードでプロビジョニングされた transponder(TXP)または muxponder(MXP)クライアント ポートに光ポートを接続する場合。

Dense Wavelength Division Multiplexing(DWDM; 高密度波長分割多重)光チャネル カードに光 ITU ポートを接続する場合。

2 つの TXP または MXP トランク ポートを DWDM 光チャネル カードに接続し、Generic Communications Channel(GCC)をトランスペアレントにリング上で搬送する場合。

TXP または MXP クライアント ポートおよびトランク ポートが再生グループに含まれていて、カードがトランスペアレント モードであり、なおかつ DCC/GCC 終端を使用できない場合。

プロビジョニング可能なパッチコードは、物理リンクの両端で必要です。各終端のプロビジョニングには、ローカル パッチコード ID、スロット/ポート情報、リモート IP アドレス、およびリモート パッチコード IDが含まれます。CTC ネットワーク ビューにおいて、パッチコードは破線で示されます。

表13-5 に、プロビジョニング可能パッチコードのクライアント ポートおよびトランク ポートでサポートされるカードの組み合わせを示します。

 

表13-5 プロビジョニング可能なパッチコードに対応する Cisco ONS 15454 クライアント/トランク カードの組み合わせ

トランク カード
クライアント カード
MXP_2.5G_10G/
TXP_MR_10G

TXP(P)_MR_2.5G
MXP_2.5G_10E/
TXP_MR_10E
32MUX-O
32DMX-O
32WSS/
32DMX

AD-xC-xx.x

4MD-xx.x
MXP_2.5G_10G/
TXP_MR_10G

--

--

--

TXP(P)_MR_2.5G

--

--

--

MXP_2.5G_10E/
TXP_MR_10E

--

--

--

MXP(P)_MR_2.5G

--

--

--

OC-192

--

--

--

--

--

OC-48

--

--

--

--

OC-192 ITU

--

--

--

OC-48 ITU

--

--

--


) スロット 8 に OCSM カードを搭載した場合、OC-N ポートから次のカードへのプロビジョニング可能パッチコードは、同一ノードではサポートされません。MXP_2.5G_10G、TXP_MR_10G、
TXP(P)_MR_2.5G、MXP_2.5G_10E、TXP_MR_10E、32MUX-O、32DMX-O、32WSS、および 32DMX です。


表13-6 に、パッチコードのクライアント間ポートでサポートされるカードの組み合わせを示します。

 

表13-6 プロビジョニング可能なパッチコードに対応する Cisco ONS 15454 クライアント/クライアント カードの組み合わせ

クライアント カード
MXP_2.5G_10G/
TXP_MR_10G
TXP(P)_MR_2.5G
MXP_2.5G_10E/
TXP_MR_10E
MXP_2.5G_10G/
TXP_MR_10G

--

TXP(P)_MR_2.5G

--

--

MXP_2.5G_10E/
TXP_MR_10E

--

表13-7 に、パッチコードのトランク間ポートでサポートされるカードの組み合わせを示します。

 

表13-7 プロビジョニング可能なパッチコードに対応する Cisco ONS 15454 トランク/トランク カードの組み合わせ

トランク カード
MXP_2.5G_10G/
TXP_MR_10G
TXP(P)_MR_2.5G
MXP_2.5G_10E/
TXP_MR_10E
MXP_2.5G_10G/
TXP_MR_10G

--

TXP(P)_MR_2.5G

--

--

MXP_2.5G_10E/
TXP_MR_10E

--

プロビジョニング可能なパッチコードで使用する場合、光ポートの要件は次のとおりです。

TXP/MXP ポート、Add Drop Multiplexer(ADM; 分岐挿入装置)ポート、またはマルチプレクサ/逆マルチプレクサ ポートに光ポートを接続する場合は、Section DCC/Line DCC(SDCC/LDCC)終端が必要です。

光ポートを 1+1 グループの保護ポートにする場合は、現用ポートに SDCC/LDCC 終端を設定する必要があります。

パッチコードのリモート側が Y 字ケーブルで保護されている場合、ADM またはマルチプレクサ/逆マルチプレクサ ポートの場合、光ポートにパッチコードが 2 本必要です。

プロビジョニング可能なパッチコードで使用する場合、TXP および MXP ポートの要件は次のとおりです。

TXP/XMP ポートを ADM またはマルチプレクサ/逆マルチプレクサ ポートに接続する場合は、パッチコードが 2 本必要です。CTC は自動的に、2 本めのパッチコードを設定するようにユーザに求めるプロンプトを表示します。

パッチコードが再生グループのクライアント ポートに接続されている場合、そのパッチコードの反対側は同じノードになければなりません。また、同じ再生グループ内のポートになければなりません。

クライアント ポートにパッチコードを使用できるのは、カードがトランスペアレント モードの場合だけです。

DWDM カードは、光チャネル ポートに限り、プロビジョニング可能なパッチコードをサポートします。1 つの DWDM 光チャネル ポートに使用できるプロビジョニング可能パッチコードは 1 本だけです。


) TXP、MXP、および DWDM カードについては、『Cisco ONS 15454 DWDM Installation and Operations Guide』を参照してください。


13.4 ルーティング テーブル

ONS 15454 のルーティング情報は、Maintenance > Routing Table タブを選択すると表示されます。ルーティング テーブルには、次の情報が表示されます。

宛先 ― 宛先ネットワークまたはホストのIPアドレス

マスク ― 宛先ホストまたはネットワークに到達するために使用されるサブネット マスク

ゲートウェイ ― 宛先ネットワークまたはホストに到達するために使用されるゲートウェイの IP アドレス

使用回数 ― 指定されたルートの使用回数

インターフェイス ― 宛先にアクセスするために使用される ONS 15454 インターフェイス。値は次のとおりです。

motfcc0 ― ONS 15454 イーサネット インターフェイス、すなわち TCC2/TCC2P 上の RJ-45 ジャックとバックプレーン上の LAN 1 ピン

pdcc0 ― SDCC インターフェイス、すなわち SDCC 終端として識別された OC-N トランク カード

lo0 ― ループバック インターフェイス

表13-8 に、ONS 15454 のルーティング テーブル エントリの例を示します。

 

表13-8 ルーティング テーブル エントリの例

エントリ
宛先
マスク
ゲートウェイ
使用回数
インターフェイス

1

0.0.0.0

0.0.0.0

172.20.214.1

265103

motfcc0

2

172.20.214.0

255.255.255.0

172.20.214.92

0

motfcc0

3

172.20.214.92

255.255.255.255

127.0.0.1

54

lo0

4

172.20.214.93

255.255.255.255

0.0.0.0

16853

pdcc0

5

172.20.214.94

255.255.255.255

172.20.214.93

16853

pdcc0

エントリ 1 の内容は次のとおりです。

宛先(0.0.0.0)はデフォルトのルート エントリです。ルーティング テーブル内のすべての未定義宛先ネットワークまたは宛先ホスト エントリはデフォルトのルート エントリにマップされます。

マスク(0.0.0.0)はデフォルト ルートの場合必ず 0 です。

ゲートウェイ(172.20.214.1)はデフォルトのゲートウェイ アドレスです。ルーティング テーブルにないすべての送信トラフィック、またはノードのローカル サブネットにない送信トラフィックは、このゲートウェイに送信されます。

インターフェイス(motfcc0)は、ONS 15454 イーサネット インターフェイスを使用してゲートウェイに到達することを示します。

エントリ 2 の内容は次のとおりです。

宛先(172.20.214.0)は、宛先ネットワーク IP アドレスです。

マスク(255.255.255.0)は 24 ビット マスクで、172.20.214.0 サブネット内のすべてのアドレスが宛先になります。

ゲートウェイ(172.20.214.92)はゲートウェイ アドレスです。このネットワークに属するすべての送信トラフィックは、このゲートウェイに送信されます。

インターフェイス(motfcc0)は、ONS 15454 イーサネット インターフェイスを使用してゲートウェイに到達することを示します。

エントリ 3 の内容は次のとおりです。

宛先(172.20.214.92)は、宛先ホスト IP アドレスです。

マスク(255.255.255.255)は 32 ビット マスクで、アドレス 172.20.214.92 だけが宛先であることを示します。

ゲートウェイ(127.0.0.1)はループバック アドレスです。このホストは、このアドレスを使用して、ホスト自身にネットワーク トラフィックを送信します。

インターフェイス(lo0)は、ローカル ループバック インターフェイスを使用してゲートウェイに到達することを示します。

エントリ 4 の内容は次のとおりです。

宛先(172.20.214.93)は、宛先ホスト IP アドレスです。

マスク(255.255.255.255)は 32 ビット マスクで、アドレス 172.20.214.93 だけが宛先であることを示します。

ゲートウェイ(0.0.0.0)は、宛先ホストがノードに直接接続されていることを意味します。

インターフェイス(pdcc0)は、DCC インターフェイスを使用して宛先ホストに到達することを示します。

エントリ 5 は、直接接続されていないノードを介してアクセス可能な DCC 接続されたノードを示します。

宛先(172.20.214.94)は、宛先ホスト IP アドレスです。

マスク(255.255.255.255)は 32 ビット マスクで、アドレス 172.20.214.94 だけが宛先であることを示します。

ゲートウェイ(172.20.214.93)は、IP アドレスが 172.20.214.93 であるノードを介して宛先ホストにアクセスすることを示します。

インターフェイス(pdcc0)は、DCC インターフェイスを使用してゲートウェイに到達することを示します。

13.5 外部ファイアウォール

ここでは、外部ファイアウォールに関する Access Control List(ACL; アクセス制御リスト)の例を示します。 表13-9 に、TCC2/TCC2P カードで使用するポートを示します。

 

表13-9 TCC2/TCC2P が使用するポート

ポート
機能
アクション4

0

未使用

D

20

FTP(ファイル転送プロトコル)

D

21

FTP の制御

D

22

SSH(Secure Shell; セキュア シェル)

D

23

Telnet

D

80

HTTP

D

111

SUNRPC(Sun Remote Procedure Call)

NA

161

SNMP トラップの宛先

D

162

SNMP トラップの宛先

D

513

リモート ログイン

D

683

CORBA IIOP5

OK

1080

プロキシ サーバ(SOCKS)

D

2001~2017

I/O カード Telnet

D

2018

アクティブ TCC2/TCC2P 上の DCC プロセッサ

D

2361

TL1

D

3082

raw TL1

D

3083

TL1

D

5001

BLSR6 サーバ ポート

D

5002

BLSR クライアント ポート

D

7200

SNMP アラーム入力ポート

D

9100

EQM ポート

D

9401

TCC ブート ポート

D

9999

フラッシュ マネージャ

D

10240~12287

プロキシ クライアント

D

57790

デフォルトの TCC リスナー ポート

OK

4.D = 拒否、NA = 該当しない、OK = 拒否しない

5.CORBA IIOP = Common Object Request Broker Architecture Internet Inter-ORB Protocol

6.BLSR = Bidirectional Line Switced Ring; 双方向ライン スイッチ型リング

次の ACL 例で、SOCKS プロキシ サーバ ゲートウェイ設定が有効になっていない場合の、ファイアウォールの設定を示します。この例で、CTC ワークステーションのアドレスは 192.168.10.10、ONS 15454 アドレスは 10.10.10.100 です。ファイアウォールは GNE に接続されているので、受信方向は CTC から GNE、送信方向は GNE から CTC です。CTC CORBA 標準定数は 683、TCC CORBA デフォルトは TCC 固定(57790)です。

access-list 100 remark *** Inbound ACL, CTC -> NE ***
access-list 100 remark
access-list 100 permit tcp host 192.168.10.10 host 10.10.10.100 eq www
access-list 100 remark *** allows initial contact with ONS 15454 using http (port 80) ***
access-list 100 remark
access-list 100 permit tcp host 192.168.10.10 host 10.10.10.100 eq 57790
access-list 100 remark *** allows CTC communication with ONS 15454 GNE (port 57790) ***
access-list 100 remark
access-list 100 permit tcp host 192.168.10.10 host 10.10.10.100 established
access-list 100 remark *** allows ACKs back from CTC to ONS 15454 GNE ***
 
access-list 101 remark *** Outbound ACL, NE -> CTC ***
access-list 101 remark
access-list 101 permit tcp host 10.10.10.100 host 192.168.10.10 eq 683
access-list 101 remark *** allows alarms etc., from the 15454 (random port) to the CTC workstation (port 683) ***
access-list 100 remark
access-list 101 permit tcp host 10.10.10.100 host 192.168.10.10 established
access-list 101 remark *** allows ACKs from the 15454 GNE to CTC ***
 

次の ACL 例で、SOCKS プロキシ サーバ ゲートウェイ設定が有効な場合の、ファイアウォールの設定を示します。最初の例と同様に、CTC ワークステーションのアドレスは 192.168.10.10、ONS 15454 アドレスは 10.10.10.100 です。ファイアウォールは GNE に接続されているので、受信方向は CTC から GNE、送信方向は GNE から CTC です。CTC CORBA 標準定数は 683、TCC CORBA デフォルトは TCC 固定(57790)です。

access-list 100 remark *** Inbound ACL, CTC -> NE ***
access-list 100 remark
access-list 100 permit tcp host 192.168.10.10 host 10.10.10.100 eq www
access-list 100 remark *** allows initial contact with the 15454 using http (port 80) ***
access-list 100 remark
access-list 100 permit tcp host 192.168.10.10 host 10.10.10.100 eq 1080
access-list 100 remark *** allows CTC communication with the 15454 GNE (port 1080) ***
access-list 100 remark
 
access-list 101 remark *** Outbound ACL, NE -> CTC ***
access-list 101 remark
access-list 101 permit tcp host 10.10.10.100 host 192.168.10.10 established
access-list 101 remark *** allows ACKs from the 15454 GNE to CTC ***
 

13.6 オープン GNE

ONS 15454 は、PPP(ポイントツーポイント プロトコル)ベンダー 拡張または OSPF タイプ 10 の不透明な Link State Advertisement(LSA; リンク ステート アドバタイズ)をサポートしない非 ONS ノードと通信できます。どちらも、ノードおよびリンクの自動検出に必要です。オープン GNE を設定すると、DCC ベースのネットワークが非 ONS ノードに対応する IP ネットワークとして機能します。

オープン GNE ネットワークを設定する場合は、デフォルト IP アドレス 0.0.0.0 または特定の IP アドレスを使用して、遠端の非 ONS ノードが含まれるように、SDCC、LDCC、および GCC 終端をプロビジョニングできます。遠端の非 ONS ノードは、SDLL、LDCC、および GCC の作成時に、Far End is Foreign チェックボックスを選択することによってプロビジョニングします。デフォルト IP アドレス 0.0.0.0 を使用した場合、遠端の非 ONS ノードが IP アドレスを提供できるようになります。0.0.0.0 以外の IP アドレスを設定した場合は、その IP アドレスで遠端ノードを識別できる場合に限ってリンクが確立されるので、セキュリティが強化されます。

デフォルトで SOCKS プロキシ サーバが許可するのは、検出された ONS ピアとの接続だけです。DCC ネットワークと LAN 間の IP トラフィックはすべて、ファイアウォールによってブロックされます。ただし、プロキシ トンネルをプロビジョニングすると、非 ONS ノードとの SOCKS バージョン 5 接続に最大 12 の宛先を追加できます。さらに、ファイアウォール トンネルを設定すると、DCC ネットワークと LAN 間の直接 IP 接続に最大 12 の宛先を追加できます。プロキシ トンネルとファイアウォール トンネルには、送信元サブネットと宛先サブネットの両方が含まれます。接続は送信元サブネット内を起点とし、宛先サブネット内を終点としないかぎり、SOCKS 接続も IP パケット フローも認められません。

CTC でプロキシおよびファイアウォール サブネットを設定するには、Provisioning > Network > Proxy and Firewalls サブタブを選択します。プロキシ トンネル、ファイアウォール トンネル、またはその両方を使用できるかどうかは、ノードのネットワーク アクセスがどのように設定されているかによって決まります。

GNE または ENE モードで SOCKS プロキシ サーバを有効にしてノードを設定している場合、プロキシ トンネル、ファイアウォール トンネル、またはその両方を設定する必要があります。

プロキシ専用モードで SOCKS プロキシ サーバを有効にしてノードを設定している場合は、プロキシ トンネルを設定できます。ファイアウォール トンネルは設定できません。

SOCKS プロキシ サーバを無効にしてノードを設定している場合は、プロキシ トンネルもファイアウォール トンネルも設定できません。

図13-18 に、DCC ネットワークに接続した外部ノードの例を示します。プロキシ トンネルおよびファイアウォール トンネルは、この例のような場合に便利です。トンネルを設定しなかった場合、GNE が PC と外部ノード間の IP アクセスをブロックしてしまいます。

図13-18 外部で終端する場合のプロキシ トンネルおよびファイアウォール トンネル

 

図13-19 に、ENE イーサネット ポートに接続したリモート ノードを示します。プロキシ トンネルおよびファイアウォール トンネルは、この例のような場合に便利です。トンネルを設定しなかった場合、GNE が PC と外部ノード間の IP アクセスをブロックしてしまいます。この構成では、ENE 上にもファイアウォール トンネルが必要です。

図13-19 ENE イーサネット ポートへの外部ノード接続

 

13.7 TCP/IP および OSI ネットワーキング

ONS 15454 DNC 通信は、TCP/IP プロトコル スイートを使用して行われます。ただし、OSI プロトコル スイートを使用する装置と ONS 15454 をネットワーク接続することもできます。TCP/IP プロトコルと OSI プロトコル間に直接の互換性はありませんが、目的は同じであり、どちらも OSI 参照モデルの同じレイヤを使用します。 表13-10 に、TCP/IP ベースの NE を OSI ベースの NE にネットワーク接続する場合に必要な、プロトコルとメディエーション プロセスを示します。

 

表13-10 TCP/IP および OSI プロトコル

OSI モデル
IP プロトコル
OSI プロトコル
IP-OSI 間のメディエーション

レイヤ 7 アプリケーション

TL1

FTP

HTTP

Telnet

IIOP

TARP7

TL1(OSI上)

FTAM8

ACSE9

T -- TD10

FT -- TD11

レイヤ 6 プレゼンテーション

PST12

レイヤ 5 セッション

セッション

レイヤ 4 トランスポート

TCP

UDP

TP(トランス
ポート)クラス 4

IP-over-CLNS13 トンネル

レイヤ 3 ネットワーク

IP

OSPF

CLNP14

ES-IS15

IS-IS16

レイヤ 2 データ リンク

PPP

PPP

LAP-D17

レイヤ 1 物理

DCC、LAN、ファイバ、電気

DCC、LAN、ファイバ、電気

7.TARP = TID Address Resolution Protocol; TID アドレス解決プロトコル

8.FTAM = File Transfer and Access Management

9.ACSE = Association-Control Service Element; アソシエーション制御サービス要素

10.T-TD = TL1-Translation Device

11.FT-TD = File Transfer ― Translation Device

12.PST = Presentation layer; プレゼンテーション レイヤ

13.CLNS = Connectionless Network Layer Service; コネクションレス ネットワーク レイヤ サービス

14.CLNS = Connectionless Network Layer Protocol; コネクションレス ネットワーク レイヤ プロトコル

15.ES-IS = End System-to-Intermediate System

16.IS-IS = Intermediate System-to-Intermediate System

17.LAP-D = Link Access Protocol on the D Channel

13.7.1 PPP

PPP は、ポイントツーポイント リンク上でデータグラムを伝送する、データ リンク(レイヤ 2)カプセル化プロトコルです。PPP は IP トラフィックの伝送用に開発されましたが、OSI CLNP を含め、他のプロトコルも伝送できます。OIS の伝送で使用される PPP コンポーネントは、次のとおりです。

High-Level Data Link Control(HDLC; ハイレベル データ リンク制御) ― ポイントツーポイント リンクで伝送できるようにデータグラムをカプセル化します。

Link Control Protocol(LCP; リンク制御プロトコル) ― ポイントツーポイント接続を確立、設定、テストします。

SDCC または LDCC を作成するたびに、CTCによって IP-over-PPP が自動的に有効になります。SDCC または LDCC は、OSI-over-PPP をサポートするようにプロビジョニングできます。

13.7.2 LAP-D

LAP-D は、OSI プロトコル スタックで使用されるデータ リンク プロトコルです。LAP-D は、ONS 15454 SDCC を OSI のみとしてプロビジョニングした場合に割り当てられます。プロビジョニング可能な LAP-D パラメータは、次のとおりです。

Transfer Service ― 次の転送サービスの 1 つを割り当てる必要があります。

Acknowledged Information Transfer Service(AITS) ― (デフォルト)2 つの LAP-D ユーザ間で論理接続が確立されるまで、データ交換は行われません。このサービスによって、信頼できるデータ転送、フロー制御、およびエラー制御のメカニズムが得られます。

Unacknowledged Information Transfer Service(UITS) ― 確認応答を使用しないで、ユーザ データが格納されたフレームを転送します。このサービスの場合、あるユーザが渡したデータが別のユーザに届く保証はありません。また、配信できなかった場合でも、ユーザに通知はありません。フロー制御やエラー制御のメカニズムは得られません。

Mode ― Network モードまたは User モードのどちらかに LAP-D を設定します。このパラメータによって、LAP-D フレームの Command/Response(C/R; コマンド/応答)値が設定されます。C/R 値は、フレームがコマンドなのか、それとも応答なのかを示します。

Maximum Transmission Unit(MTU; 最大伝送ユニット) ― この LAP-D N201 パラメータで、LAP-D 情報フレームの最大オクテット数を設定します。オクテット数の範囲は 512~1500 です。


) MTU は、ネットワーク上のすべての NE で同じサイズにする必要があります。


Transmission Timers ― 次の LAP-D タイマーをプロビジョニングできます。

T200 タイマーでは、再試行を開始する、または障害を宣言するまでのタイムアウト期間を設定します。

T203 タイマーでは、次のフレーム交換まで、すなわち、LAP-D「キープアライブ」Receive Ready(RR)フレームの送信が開始されるまでの最大時間を設定します。

次の LAP-D パラメータには固定値が割り当てられます。

Terminal Endpoint Identifier(TEI; 端末終端点識別子) ― 0 の固定値が割り当てられます。

Service Access Point Identifier(SAPI; サービス アクセス ポイント識別子) ― 62 の固定値が割り当てられます。

N200 Supervisory Frame Retransmissions ― 3 の固定値が割り当てられます。

13.7.3 OSI CLNS

OSI Connectionless Network Service(CLNS)は、Connectionless Network Protocol(CLNP)および CLNS を使用して実装します。CLNP および CLNS は、ISO 8473 規格で規定されています。CLNS は CLNP を使用してトランスポート レイヤにネットワーク レイヤ サービスを提供します。ネットワーク上で送信される各パケットとは無関係にパスが決定されるので、CLNS が接続を確立したり終了したりすることはありません。CLNS は、トランスポート レイヤ プロトコルに依存して、エラー検出およびエラー訂正を実行します。

CLNP は、コネクションレス リンクを介して上位レイヤ データとエラー表示を伝送する、OSI ネットワーク レイヤ プロトコルです。CLNP は、CLNS と上位レイヤ間のインターフェイスを提供します。CLNP は、IP と同じ多くのサービスをトランスポート レイヤに対して実行します。CLNP データグラムは、IP データグラムとよく似ています。分解(データ ユニット識別、フラグメント/合計長、およびオフセット)のメカニズムを提供します。IP と同様、CLNP ヘッダーに基づいて計算されたチェックサムで、CLNP データグラムを処理するための情報が正しく伝送されたかどうかを検証し、有効期間制御メカニズムである Time to Live(TTL)によって、データグラムがシステムに存在できる時間の長さを制限します。

CLNP では、Network Service Access Point(NSAP)を使用してネットワーク装置を識別します。CLNP の送信元アドレスおよび宛先アドレスは、NSAP です。CLNP はさらに、Network Element Title(NET)を使用して、End System(ES)または Intermediate System(IS)のネットワーク エンティティを識別します。NET は NSAP アドレスと同じネーム スペースから割り当てます。アドレスが NSAP であるか NET であるかは、NSAP のネットワーク セレクタ値によって決まります。

ONS 15454 は、ISO 8348 で規定されている ISO Data Country Code(ISO-DCC)NSAP アドレス形式をサポートします。NSAP アドレスは、Iitail Domain Part(IDP)と Domain-Specific Part(DSP)に分かれます。 表13-11 に、NSAP の各フィールドを示します。NSAP フィールド値は 16 進形式です。NSAP はすべて編集可能です。短縮形の NSAP を使用できます。ただし、同一 OSI ネットワーク エリア内のすべての NE の NSAP に、通常は同じ NSAP 形式を使用します。

 

表13-11 NSAP フィールド

フィールド
定義
説明
IDP

AFI

Authority and Format Identifier

NSAP アドレス形式を指定します。ISO-DCC アドレス形式の場合、初期値は 39 です。

IDI

Initial Domain Identifier

国別コードを指定します。初期値 は 840F です。米国の国別コードに F が埋め込まれています。

DSP

DFI

DSP Format Identifier

DSP 形式を指定します。初期値は 80 です。これは American National Standards Institute(ANSI; 米国規格協会)の規格に準拠した DSP 形式であることを示します。

ORG

Organization

組織の識別子です。初期値は 000000 です。

Reserved

Reserved

予約済み NSAP フィールドです。Reserved フィールドは通常、すべてゼロ(0000)です。

RD

Routing Domain

ルーティング ドメインを定義します。初期値は 0000 です。

AREA

Area

ノードが所属する OSI ルーティング エリアを表します。初期値は 0000 です。

System

System Identifier

ONS 15454 システムの識別子は、対応する IEEE 802.3 MAC アドレスに設定します。各 ONS 15454 は、3 つの OSI 仮想ルータをサポートします。各ルータの NSAP システム識別子は、ONS 15454 IEEE 802.3 MAC アドレスに n を加えたものです。 n は 0~2 です。プライマリ仮想ルータの場合、 n = 0 になります。

SEL

Selector

セレクタ フィールドは、CLNP ネットワーク レイヤ サービスを使用して、正しい宛先に Protocol Data Unit(PDU; プロトコル データ ユニット)を送ります。ONS 15454 がサポートするセレクタ値は、次のとおりです。

00 ― NET。ES-IS および IS-IS ルーティング交換プロトコルで PDU を交換する場合に使用します(ES-IS プロトコルおよびIS-IS プロトコル参照)。

1D ― トランスポート クラス 4(および FTAM および TL1 アプリケーション)(Telcordia GR-253-CORE 規格)に対応するセレクタ

AF ― TARP プロトコル(Telcordia GR-253-CORE 規格)に対応するセレクタ

2F ― GRE IP-over-CLNS トンネル(ITU/RFC 規格)に対応するセレクタ

CC ― Cisco IP-over-CLNS トンネル(Cisco 固有)に対応するセレクタ

E0 ― OSI ping アプリケーション(Cisco 固有)に対応するセレクタ

NSEL がアドバタイズされるのは、ノードが ES として設定されている場合だけです。ノードが IS として設定されている場合はアドバタイズされません。トンネル NSEL がアドバタイズされるのは、トンネルが作成されてからです。

図13-20 に、ISO-DCC NSAP アドレスを ONS 15454 のデフォルト値とともに示します。システム IDはノードの MAC アドレスとともに自動的に入力されます。

図13-20 ISO-DCC NSAP アドレス

 

ONS 15454 のメインの NSAP アドレスは、ノード ビューの Provisioning > OSI > Main Setup サブタブを選択すると表示されます(図13-21)。

図13-21 OSI の主要な設定

 

このアドレスは、ルータ 1 のプライマリ マニュアル エリア アドレスでもあります。Provisioning > OSI > Routers タブを選択すると、表示して編集できます。CTC における OSI ルータおよびマニュアル エリア アドレスについては、「OSI 仮想ルータ」を参照してください。

13.7.4 OSI ルーティング

OSI アーキテクチャには ES および IS が含まれます。OSI ルーティング方式の構成は、次のとおりです。

ES と IS にルートの決定に必要な情報を集めて配布させる、一連のルーティング プロトコル。ES-IS プロトコルと IS-IS プロトコルが含まれます。ES-IS ルーティングでは、同じ(単一)サブネットワークに接続された ES と IS 間で接続を確立し、到達できるようにします。

Routing Information Base(RIB; ルーティング情報ベース)。この情報に基づいて、ES 間のルートを計算できます。RIB は宛先(NSAP など)を特定するエントリが登録されたテーブル、その宛先に到達するまでパケットを転送するために使用するサブネットワーク、およびルーティング メトリックからなります。ルーティング メトリックは、特定のパケットまたはパケット クラスを伝送する場合に、プロパティの異なる別のルートと比較して、所定のルートが適しているかどうかを評価するために使用するルート特性(遅延特性、予想エラー レートなど)を伝えます。

ルーティング アルゴリズムである Shortest Path First(SPF)。RIB に格納されている情報を使用して、ES 間のルートを取得します。

OSI ネットワーキングにおいて、検出はアナウンスに基づいて行われます。ES は ES-IS プロトコルの End System Hello(ESH)メッセージを使用して、自分の存在を同じネットワークに接続された IS および ES にアナウンスします。ESH を待ち受けている ES または IS があれば、コピーを取得します。IS は NSAP アドレスと対応するサブネットワーク アドレスのペアをルーティング テーブルに格納します。ES は、アドレスを格納する場合もあれば、この種の情報が必要になったときに IS からの通知を待つ場合もあります。

IS は Intermediate System Hello(ISH)メッセージを作成して、同じブロードキャスト サブネットワークに接続されている IS および ES に設定情報をアナウンスします。ISH には ESH と同様、IS のアドレッシング情報(NET およびSubnetwork Point-of-Attachment Address [SNPA])および保留時間が含まれます。ISH は、ES にコンフィギュレーション タイマーを推奨する、ES コンフィギュレーション タイム値を伝えます。

ISH の交換をネイバ グリーティングまたは初期化といいます。各ルータは、直接接続を共有している他のルータについて学習します。初期化後、各ルータは Link-State Packet(LSP; リンク ステート パケット)を作成します。LSP には、IS のネイバ名と各ネイバに到達するためのコストを示すリストが格納されます。ルータはその後、他のすべてのルータに LSP を配布します。すべての LSP がすべてのルータに伝播されると、各ルータに完全なネットワーク トポロジー マップが LSP の形で備わります。ルータは LSP および SPF アルゴリズムを使用して、ネットワークの各宛先までのルートを計算します。

OSI ネットワークは、エリアとドメインに分割されます。エリアは、連続するネットワークとネットワーク管理者によってエリアと指定された接続ホストからなるグループです。ドメインは、接続されたエリアの集合です。ルーティング ドメインは、そのドメイン内のすべての ES に対して完全に接続できます。同一エリア内のルーティングをレベル 1 ルーティングといいます。2 つのエリア間のルーティングは、レベル 2 ルーティングといいます。レベル 1 エリア内で交換される LSP は、L1 LSP といいます。レベル 2 エリアにまたがって交換される LSP は、L2 LSP といいます。図13-22 に、レベル 1 ルーティングとレベル 2 ルーティングの例を示します。

図13-22 レベル 1 および レベル 2 の OSI ルーティング

 

TCP/IP と OSI の両方のプロトコル スタックを使用する NE からなるネットワーク用に ONS 15454 をプロビジョニングする場合は、次のいずれか 1 つとしてプロビジョニングします。

ES ― ONS 15454 は OSI ES 機能を実行し、IS を信頼して OSI エリア内のノードと通信します。

IS レベル 1 ― ONS 15454 は OSI IS 機能を実行します。OSI エリア内の IS および ES ノードと通信します。さらに、IS L1/L2 ノードに依存して、OSI エリア外の IS および ES ノードと通信します。

IS レベル 1/レベル 2 ― ONS 15454 は IS 機能を実行します。OSI エリア内の IS および ES ノードと通信します。さらに、他の OSI エリアに配置された IS L1/L2 ノードと通信します。このオプションは、ノードを異なる OSI エリアに配置された別の IS L1/L2 ノードに接続する場合に限ってプロビジョニングしてください。この場合、所定のエリア内で IS L1/L2 としてプロビジョニングされているすべてのノードに接続することも必要です。

13.7.4.1 ES-IS プロトコル

ES-IS は、ES(ホスト)と IS(ルータ)がどのようにして相互に相手を学習するかを定義する OSI プロトコルです。ES-IS の設定情報は、ES および IS の Hello メッセージによって、定期的な間隔で送信されます。Hello メッセージには、メッセージの生成元システムのサブネットワーク アドレスとネットワーク レイヤ アドレスが含まれます。

ES-IS コンフィギュレーション プロトコルは、OSI ネットワーク レイヤ アドレスと OSI サブネットワーク アドレスの両方を伝達します。OSI ネットワーク レイヤ アドレスによって、OSI レイヤ 3 と レイヤ 4 間のインターフェイスである NSAP なのか、OSI IS のネットワーク レイヤ エンティティである NET なのかを識別します。OSI SNPA は、ES または IS がサブネットワークに物理的に接続されるポイントです。SNPA アドレスは、サブネットワークに接続された各システムをそれぞれ固有のものとして表します。たとえば、イーサネット ネットワークの場合、SNPA は 48 ビット MAC アドレスです。設定情報のうち、ES-IS で送信される部分は、NSAP から SNPA または NET から SNPA のマッピングです。

13.7.4.2 IS-IS プロトコル

IS-IS は、ネットワークにリンク ステート情報をフラッディングして、完全で一貫性のあるネットワーク トポロジー図を作成する、OSI リンク ステート階層型ルーティング プロトコルです。IS-IS では、レベル 1 の IS と レベル 2 の IS が区別されます。レベル 1 IS は、同じエリア内の他のレベル 1 IS と通信します。レベル 2 IS は、レベル 1 エリア間をルーティングして、ドメイン内ルーティング バックボーンを形成します。レベル 1 IS が認識しなければならないのは、最も近接している レベル 2 IS への到達方法だけです。バックボーン ルーティング プロトコルは、エリア内ルーティング プロトコルに影響を与えることなく変更可能です。

OSI ルーティングは、ISH パケットを待ち受けることによって、ES が最も近接している IS を検出した時点で開始されます。ES が別の ES にパケットを送信する場合は、ES が直接接続されているネットワーク上の IS の 1 つにパケットを送信します。次にルータが宛先アドレスを調べて、最適なルートでパケットを転送します。宛先 ES が同一サブネットワーク上にある場合、ローカル IS は ESH を待ち受けることによってパケットを認識し、適切に転送します。IS が送信元にリダイレクト(RD)メッセージを返し、使用可能なダイレクト ルートがさらにあることを伝える場合もあります。宛先アドレスが同一エリアに含まれる別のサブネットワーク上の ES の場合、IS は正しいルートを認識して、適切にパケットを転送します。宛先アドレスが別のエリアの ES の場合は、レベル 1 IS が最も近接しているレベル 2 IS にパケットを送信します。パケットが宛先エリアのレベル 2 IS に到達するまで、レベル 2 IS での転送が続けられます。宛先エリア内では、宛先 ES に到達するまで、IS が最適パスを使用してパケットを転送します。

リンク ステート更新メッセージによって、IS はネットワーク トポロジーを学習できます。各 IS は、接続先 ES および IS とともに関連メトリックを指定した更新情報を生成します。この更新情報は、すべての近接 IS に送信され、そこからそれぞれのネイバに転送(フラッディング)されます(シーケンス番号によってフラッディングが終了し、古い更新と新しい更新が区別されます)。このような更新を使用することによって、各 IS は完全なネットワーク トポロジーを作成できます。トポロジーが変更されると、新しい更新が送信されます。

IS-IS では、最大パス値が 1024 の必須デフォルト メトリックを 1 つだけ使用します。メトリックは任意であり、通常はネットワーク管理者が割り当てます。1 つのリンクに指定できる最大値 は 64 です。パス リンクはリンク値を合計することによって算出されます。最大メトリック値は、各種のリンク タイプをサポートできる粒度が得られ、同時に、ルート計算に使用する最短パス アルゴリズムが十分に効率を発揮できるレベルに設定されています。IS-IS の 3 種類のオプション メトリック(コスト)である遅延、損失、およびエラーは、ONS 15454 ではサポートされません。IS-IS は、メトリックと CLNP パケット ヘッダーに指定されたQuality of Service(QoS; サービス品質)オプションのマッピングを維持します。IS-IS ではこのマッピングを使用して、インターネットワーク上のルートを計算します。

13.7.5 TARP

TARP は、TL1 Target Identifier(TID)を NSAP アドレスに変換しなければならない場合に使用します。TID から NSAP への変換は、NET に TID をマップし、さらに NSAP セレクタ値を使用して NET から NSAP を引き出すことで発生します(NSAP フィールド)。

TARP では選択的 PDU 伝播メソドロジーと NE 内に 配置された TID から NET へのマッピングの分散型データベースを組み合わせて使用します。TARP を使用すると、NE は他の NE とマッピング情報を自動的に交換することによって、TID と NET 間で変換できます。TARP PDU は、標準の CLNP データ PDU で伝送されます。 表13-12 に、TARP PDU の各フィールドを示します。

 

表13-12 TARP PDU のフィールド

フィールド
省略形
サイズ
(バイト数)
説明

TARP Lifetime

tar-lif

2

ホップの TARP TTL

TARP Sequence Number

tar-seq

2

ループを検出するために使用する TARP シーケンス番号

Protocol Address Type

tar-pro

1

TID をマップしなければならないプロトコル アドレス タイプを指定するために使用します。CLNP アドレス タイプを指定する場合は、FE の値を使用します。

TARP Type Code

tar-tcd

1

TARP Type Code は、PDU の TARP タイプを指定します。 表13-13 に示した 5 種類の TARP タイプが定義されています。

TID Target Length

tar-tln

1

tar-ttg フィールドのオクテット数

TID Originator Length

tar-oln

1

tar-tor フィールドのオクテット数

Protocol Address Length

tar-pln

1

tar-por フィールドのオクテット数

TID of Target

tar-ttg

n = 0、1、2...

ターゲット NE の TID 値

TID of Originator

tar-tor

n = 0、1、2...

TARP PDU 作成元の TID 値

Protocol Address of Originator

tar-por

n = 0、1、2...

TARP PDU 作成元のプロトコル アドレス(tar-pro フィールドで指定されたプロトコル タイプに対応)。tar-pro フィールドが FE(16 進数)に設定されている場合、tar-port には CLNP アドレス(すなわち NET)が入ります。

表13-13 に、TARP の相互作用とルーティングを制御する TARP PDU のタイプを示します。

 

表13-13 TARP PDU のタイプ

タイプ
説明
アクション

1

装置の TID に対応する NSAP がない場合に送信されます。

NE が TARP タイプ 1 の PDU を発信したあとで、その NE のルーティング エリア内のすべての隣接 NE に PDU が送信されます。

2

装置の TID に対応する NSAP がなく、タイプ 1 の PDU から応答がなかった場合に送信されます。

NE が TARP タイプ 2 PDU を発信したあとで、レベル 1 とレベル 2 のすべてのネイバに PDU が送信されます。

3

タイプ 1、タイプ 2、またはタイプ 5 PDU に対する応答として送信されます。

TARP 要求(タイプ 1 または 2)PDU の受信後、TARP タイプ 3 PDU が要求の発信元に送られます。タイプ 3 PDU は TARP の伝播手順を使用しません。

4

TID、NSAP の変更など、ローカルで変更が発生したときに、通知として送信されます。NE の初期化時に送信されることもあります。

タイプ 4 PDU は、通知の送信元 NE で TID またはプロトコル アドレスが変更されたことを伝える通知です。PDU は、NE のルーティング エリア内外のすべての隣接関係に送信されます。

5

装置で特定の NSAP に対応する TID が必要になったときに送信されます。

タイプ 5 PDU の送信時には、CLNP 宛先アドレスがわかっているので、そのアドレスだけに PDU が送信されます。タイプ 5 PDU は TARP の伝播手順を使用しません。

13.7.5.1 TARP 処理

TARP 処理を実行するために、各 NE で TARP Data Cache(TDC)が作成されます。CTC で TDC を表示して管理するには、ノード ビューの Maintenance > OSI > TDC サブタブを選択します。TDC サブタブには、次の TARP PDU フィールドがあります。

TID ― 起点 NE の TID(tar-tor)

NSAP ― 起点 NE の NSAP

Type ― TARP PDU が TARP 伝播プロセスによって作成されたのか(ダイナミック)、手動で作成されたのか(スタティック)の表示

表13-14 に示したプロビジョニング可能なタイマーで TARP 処理を制御します。

 

表13-14 TARP タイマー

タイマー
説明
デフォルト(秒数)
範囲(秒数)

T1

TARP タイプ 1 要求 PDU に対する応答を待機

15

0~3600

T2

TARP タイプ 2 要求 PDU に対する応答を待機

25

0~3600

T3

アドレス解決要求に対する応答を待機

40

0~3600

T4

T2 の満了時にタイマー開始(エラー リカバリで使用)

20

0~3600

表13-15 に、主要な TARP プロセスと各プロセスにおける一般的なイベント発生順序を示します。

 

表13-15 TARP 処理の流れ

プロセス
TARP の一般的な流れ

TID と一致する NET を検出

1. TARP が TDC を調べて一致するものを探します。一致するものがあった場合、TARP は要求側アプリケーションに結果を戻します。

2. 一致するものがなかった場合、TARP タイプ 1 PDU が生成され、タイマー T1 が開始されます。

3. 一致が検出されないうちにタイマー T1 が満了した場合は、タイプ 2 PDU が生成され、タイマー T2 が開始されます。

4. 一致が検出されないうちにタイマー T2 が満了した場合は、タイマー T4 が開始されます。

5. 一致が検出されないうちにタイマー T4 が満了した場合は、タイプ 2 PDU が生成され、タイマー T2 が開始されます。

NET と一致する TID を検出

タイプ 5 PDU が生成されます。タイマー T3 が使用されます。ただし、タイマーが満了した場合は、エラー リカバリ手順は発生せず、TID を検出できなかったことを示すステータス メッセージが表示されます。

TID またはプロトコル アドレス変更通知を送信

TARP がタイプ 4 PDU を生成し、tar-ttg フィールドに TID またはプロトコル アドレスが変更される前の NE TID 値を指定します。他の NE がアドレス変更通知を正常に受け取ったことを示す確認は送信されません。

13.7.5.2 TARP LDB

TARP Loop Detection Buffer(LDB; ループ検出バッファ)を有効にすると、TARP PDU が二重に TDC に含まれることがなくなります。TARP タイプ 1、2、または 4 の PDU が届くと、TARP は LDB で PDU 発信元の NET アドレス(tar-por)と一致するものを探します。一致するものがなかった場合、TARP は PDU を処理して、PDU のtar-por、tar-seq(シーケンス)エントリを LDB に割り当てます。tar-seq がゼロの場合、ノード ビューの OSI > TARP > Config タブを選択してプロビジョニングできる LDB エントリ タイマーを使用して、LDB エントリに対応付けられたタイマーが開始されます。一致が存在する場合は、tar-seq が LDB エントリと比較されます。tar-seq がゼロ以上で LDB エントリ以下の場合、PDU は廃棄されます。tar-seq が LDB エントリより大きい場合、PDU が処理され、LDB エントリの tar-seq フィールドが新しい値で更新されます。Cisco ONS 15454 LDB は、約 500 エントリを保持します。LDB は、ノード ビューの OSI > TARP > Config タブの LDB Flush Timer で設定した時間に基づき、定期的にフラッシュされます。

13.7.5.3 手動による TARP 隣接関係

ONS 15454 が TARP 機能のないルータまたは非 SONET NE を介して通信しなければならないネットワークでは、TARP の隣接関係を手動でプロビジョニングできます。CTC では、ノード ビューの Provisioning > OSI > TARP > MAT(Manual Area Table)サブタブで、手動による TARP 隣接関係をプロビジョニングします。手動による隣接関係を設定すると、図13-23 に示したように、TARP 要求が汎用ルータまたは非 SONET NE をホッピングします。

図13-23 手動による TARP 隣接関係

 

13.7.5.4 TID から NSAP への 手動プロビジョニング

NSAP に TID を手動で接続し、TDC に追加できます。スタティック TDC エントリは、スタティック ルートに類似しています。特定の TID に特定の NSAP を強制的に使用させることになります。その TID に対する解決要求には、必ずその NSAP が戻ります。TARP のネットワーク伝播や即時応答は伴いません。スタティック エントリを使用すると、TARP をサポートしない NE に TL1 コマンドを転送できます。ただし、スタティック TDC エントリが動的に更新されることはないので、ターゲット ノードで TID または NSAP が変更されても、古いエントリは削除されません。

13.7.6 TCP/IP および OSI メディエーション

2 種類のメディエーション プロセスによって、TCP/IP と OSI プロトコル スイートが動作している NE と ONS クライアント コンピュータ間で TL1 ネットワーキングとファイル転送が可能になります。

T-TD ― TL1-over-IP と TL1-over-OSI ゲートウェイ間のメディエーションを実行し、IP ベースの OSS で GNE に従属する OSI 専用 NE を管理できるようにします。図13-24 に、T-TD プロトコル フローを示します。

図13-24 T-TD プロトコル フロー

 

FT-TD ― FTAM と FTP 間で FTP 変換を行います。FT-TD ゲートウェイ エンティティには、FTAM レスポンダ(サーバ)と FTP クライアントが含まれ、FTAM イニシエータ(クライアント)が FTP サーバに対してファイルの格納、検索、または削除ができるようになります。FT-TD ゲートウェイは単方向であり、FTAM イニシエータによって駆動されます。FT-TD FTAM レスポンダは、OSI のフル スタックで FTAM イニシエータとメッセージを交換します。図13-25 に、FT-TD プロトコル フローを示します。

図13-25 FT-TD プロトコル フロー

 

ONS 15454 では、次のファイル転送プロセスに FT-TD を使用します。

ソフトウェアのダウンロード

データベースのバックアップおよび復元

ML および ML2 シリーズ カードの場合は、Cisco IOS コンフィギュレーションのバックアップおよび復元

13.7.7 OSI 仮想ルータ

ONS 15454 は、3 種類の OSI 仮想ルータをサポートします。ルータは図13-26 に示したように、Provisioning > OSI > Routers タブを選択してプロビジョニングします。

図13-26 OSI ルータのプロビジョニング

 

各ルータには、編集可能なマニュアル エリア アドレスとノード MAC アドレス + n に設定された固有の NSAP System ID があります。ルータ 1 の場合、 n = 0 です。ルータ 1 の場合、 n = 1 です。ルータ 2 の場合、 n = 2 です。ルータごとに有効にして異なる OSI ルーティング エリアに接続できます。ただし、ルータ 1 がプライマリ ルータなので、ルータ 1 を有効にしてからでなければ、ルータ 2 およびルータ 3 を有効にはできません。ルータ 1 のマニュアル エリア アドレスと System ID によって、ノードの TID に割り当てる NSAP アドレスが作成されます。さらに、ルータ 1 は次のように、ルータ 2 および ルータ 3 ではサポートされない OSI TARP、メディエーション、およびトンネリングの機能をサポートします。

TID と NSAP 間の解決

TARP データ キャッシュ

IP-over-CLNS トンネル

FTAM

FT-TD

T-TD

LAN サブネット

OSI 仮想ルータの制約は、ノードにプロビジョニングされたルーティング モードによって決まります。 表13-16 に、各ルータがサポートする IS L1、IS L1/L2、および DCC の数を示します。IS レベル 1および IS レベル 1/レベル 2 は、DCC サブネットごとに ES を 1 つ、LAN サブネット当たり最大 100 の ES をサポートします。

 

表13-16 OSI 仮想ルータの制約

ルーティング モード
ルータ 1
ルータ 2
ルータ 3
IS L1
エリア当たり
IS L1/L2
エリア当たり
DCC
IS 当たり

エンド システム

不可

不可

--

--

--

IS L1

250

--

40

IS L1/L2

250

50

40

OSI 仮想ルータごとに、プライマリ マニュアル エリア アドレスが 1 つずつあります。さらに 2 つのマニュアル エリア アドレスを追加作成できます。このマニュアル エリア アドレスの用途は、次のとおりです。

エリアの分割 ― 特定のエリア内のノードは、管理が困難になるか、超過トラフィックを発生させるか、またはエリアで使用できるアドレス スペースを超える可能性が生じる時点まで蓄積できます。追加のマニュアル エリア アドレスを割り当てると、サービスを妨げることなくスムーズに、ネットワークを別々のエリアに分割できます。

エリアのマージ ― 変遷可能エリア アドレスを使用して、3 つの独立したエリアを 1 つのエリアにマージし、共通のエリア アドレスを共有するようにします。

別のアドレスへの変更 ― 特定のノード グループに対応するエリア アドレスの変更が必要になる場合があります。複数のマニュアル エリア アドレスを使用して、旧エリア アドレス宛ての着信トラフィックが対応するノードに、引き続きルーティングされるようにします。

13.7.8 IP-over-CLNS トンネル

IP-over-CLNS トンネルは、IP をカプセル化して OSI NE 間で転送する場合に使用します。ONS 15454 は次の 2 種類のトンネル タイプをサポートします。

GRE ― Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)は、あるネットワーク レイヤをカプセル化して、別のレイヤ上で転送できるようにするトンネリング プロトコルです。GRE トンネルでは、トンネル フレームに CLNS ヘッダーと GRE ヘッダーの両方が追加されます。GRE トンネルは、シスコ ルータおよび他の一部のベンダーの NE でサポートされます。

Cisco IP ― Cisco IP トンネルでは、中継ヘッダーを使用せずに、IP パケットが直接カプセル化されます。Cisco IP は大部分のシスコ ルータでサポートされます。

図13-24 に、4 つの NE(A、B、C、および D)を通過する IP-over-CLNS トンネルを作成した場合のプロトコル フローを示します。トンネルの終端は NE A および D 上に設定されています。NE A および D は IP および OSI の両方をサポートします。NE B および C がサポートするのは OSI だけなので、OSI パケットだけをルーティングします。

図13-27 IP-over-CLNS トンネル フロー

 

13.7.8.1 IP-over-CLNS トンネルのプロビジョニング

IP-over-CLNS トンネルは、ノードの可視性や接続が失われないように、慎重に計画する必要があります。トンネルを開始する前に、トンネル タイプ(Cisco IP または GRE)が反対側の終端の機器でサポートされるかどうかを確認します。必ず、IP アドレスおよび NSAP アドレスを確認します。CTC で IP-over-CLNS トンネルをプロビジョニングするには、ノード ビューの Provisioning > OSI > IP over CLNS Tunnels タブを順番に選択します。手順については、『 ONS 15454 Procedure Guide 』にある「Turn Up Node」の章を参照してください。

シスコ ルータ上で IP-over-CLNS トンネルをプロビジョニングするには、前提条件として次の作業およびその他の OSI プロビジョニングが必要です。

(必須)IS-IS の有効化

(任意)インターフェイス上でのエリア ルーティングの有効化

(任意)複数のエリア アドレスの割り当て

(任意)IS-IS インターフェイス パラメータの設定

(任意)その他の IS-IS パラメータの設定

表13-17 に、IP-over-CLNS トンネル(CTunnel)を作成するための Cisco IOS コマンドを示します。

 

表13-17 IP-over-CLNS トンネルの IOS コマンド

ステップ
ステップ
目的

1

Router (config) # interface ctunnel interface-number

IP-over-CLNS トンネルを伝送する仮想インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。CTunnel インターフェイスごとに固有のインターフェイス番号を使用する必要があります。

2

Router (config-if) # ctunnel destination remote-nsap-address

CTunnel の宛先パラメータを設定します。CTunnel の宛先 NSAP1 アドレスを指定します。これが IP パケットを抽出する場所です。

3

Router (config-if) # ip address
ip-address mask

インターフェイスのプライマリまたはセカンダリ IP アドレスを設定します。

シスコ ルータ上で IP-over-CLNS トンネルをプロビジョニングする場合は、プロビジョニングするルータ用の Cisco IOS マニュアルに記載されている手順に必ず従ってください。IP-over-CLNS トンネルを含めた ISO CLNS プロビジョニングについては、『 Cisco IOS Apollo Domain, Banyon VINES, DECnet, ISO CLNS, and XNS Configuration Guide 』にある「Configuring ISO CLNS」の章を参照してください。

13.7.8.2 IP-over-CLNS トンネル のシナリオ 1:ONS ノードから他のベンダーの GNE へのトンネル

図13-28 に、ONS ノードから他のベンダーの GNE に対して作成された IP-over-CLNS トンネルを示します。他のベンダーの NE には、CTC コンピュータの接続先である IP DCN への IP 接続があります。ONS NE 1 と他のベンダーの GNE 間に、OIS 専用(LAP-D)SDCC と GRE トンネルが作成されています。

ONS NE 1 IP-over-CLNS トンネルのプロビジョニング情報は、次のとおりです。

宛先:10.10.10.100(CTC 1)

マスク:ホスト ルートの場合 255.255.255.255(CTC 1 専用)、またはサブネット ルートの場合 255.255.255.0(サブネット 10.10.10.0 上のすべての CTC コンピュータ)

NSAP:39.840F.80.1111.0000.1111.1111.cccccccccccc.00(他のベンダーの GNE)

メトリック: 110

トンネル タイプ:GRE

他のベンダーの GNE IP-over-CLNS トンネルのプロビジョニング情報は、次のとおりです。

宛先:10.20.30.30(ONS NE 1)

マスク:ホスト ルートには255.255.255.255(ONE NE 1 専用)またはサブネット ルートには 255.255.255.0(サブネット 10.30.30.0 上のすべての ONS ノード)

NSAP:39.840F.80.1111.0000.1111.1111.dddddddddddd.00(ONS NE 1)

メトリック: 110

トンネル タイプ:GRE

図13-28 IP-over-CLNS トンネル のシナリオ 1:ONS NE から他のベンダーの GNE へ

 

13.7.8.3 IP-over-CLNS トンネル のシナリオ 2:ONS ノードからルータへのトンネル

図13-29 に、ONS ノードからルータに対して作成された IP-over-CLNS トンネルを示します。他のベンダーの NE には、CTC コンピュータの接続先である IP DCN 上のルータへの OSI 接続があります。ONS NE 1 と他のベンダーの GNE 間に、OIS 専用(LAP-D)SDCC が作成されています。OSI-over-IP トンネルは、ルータがサポートするトンネル タイプに応じて、Cisco IP トンネル または GRE トンネルにできます。

ONS NE 1 IP-over-CLNS トンネルのプロビジョニングは、次のとおりです。

宛先:10.10.30.10(ルータ 1、インターフェイス 0/1)

マスク:ホスト ルートの場合 255.255.255.255(ルータ 1 専用)、またはサブネット ルートの場合 255.255.255.0(同一サブネット上のすべてのルータ)

NSAP:39.840F.80.1111.0000.1111.1111.bbbbbbbbbbbb.00(ルータ 1)

メトリック: 110

トンネル タイプ:Cisco IP

ルータ 1 CTunnel(IP-over-CLNS)のプロビジョニングは、次のとおりです。

ip routing

clns routing

interface ctunnel 102

ip address 10.10.30.30 255.255.255.0

ctunnel destination 39.840F.80.1111.0000.1111.1111.dddddddddddd.00

interface Ethernet0/1

clns router isis

router isis

net 39.840F.80.1111.0000.1111.1111.bbbbbbbbbbbb.00

図13-29 IP-over-CLNS トンネル のシナリオ 2:ONS ノードからルータへ

 

13.7.8.4 IP-over-CLNS トンネル のシナリオ 3:ONS ノードから OSI DCN 上のルータへのトンネル

図13-30 に、ONS ノードから OSI DN 上のルータに対して作成された IP-over-CLNS トンネルを示します。他のベンダーの NE には、CTC コンピュータの接続先である IP DCN への OSI 接続があります。ONS NE 1 と他のベンダーの GNE 間に、OIS 専用(LAP-D)SDCC が作成されています。OSI-over-IP トンネルは、ルータがサポートするトンネル タイプに応じて、Cisco IP トンネル または GRE トンネルにできます。

ONS NE 1 IP-over-CLNS トンネルの設定は、次のとおりです。

宛先:ルータ 2 の IP アドレス

マスク:ホスト ルートには255.255.255.255(CTC 1 専用)またはサブネット ルートには 255.255.255.0(同一サブネット上のすべての CTC コンピュータ)

NSAP:他のベンダーの GNE NSAP アドレス

メトリック: 110

トンネル タイプ:Cisco IP

ルータ 2 の IP-over-CLNS トンネルのプロビジョニング(Cisco IOS のプロビジョニング例)

ip routing

clns routing

interface ctunnel 102

ip address 10.10.30.30 255.255.255.0

ctunnel destination 39.840F.80.1111.0000.1111.1111.dddddddddddd.00

interface Ethernet0/1

clns router isis

router isis

net 39.840F.80.1111.0000.1111.1111.aaaaaaaaaaaa.00

図13-30 IP-over-CLNS トンネル のシナリオ 3:ONS ノードから OSI DCN 上のルータへ

 

13.7.9 OSI/IP ネットワーキングのシナリオ

次の 8 つのシナリオで、OSI ベースの NE からなるネットワークにおける ONS 15454 の例を示します。シナリオでは、さまざまな役割を果たす ONS 15454 を示します。シナリオの前提条件は、次のとおりです。

ONS 15454 NE は、IP アドレスと NSAP アドレスの両方を持つデュアル OSI および IP ノードとして設定されています。ONS 15454 NE では、ルートの再配布を行わない[Ships In The Night]として、OSPF と OSI(IS-IS または ES-IS)の両方のルーティング プロトコルが動作します。

ONS 15454 NE では TARP が動作するので、TL1 TID を NSAP アドレスに解決できます。TID は、宛先 TID が IP アドレスと NSAP アドレスの両方が認定された ONS 15454 NE である場合に、IP アドレスと NSAP アドレスの両方に解決される可能性があります。

ONS 15454 NE と OSI 専用 NE 間の DCC リンクでは、LAP-D 上で OSI のフル スタックが動作します。IS-IS、ES-IS、および TARP が含まれます。

ONS 15454 NE 間の DCC リンクでは、OSI のフル スタックおよび IP(OSPF)over PPP が動作します。

OSI ネットワークに参加するすべての ONS 15454 NE は、相互間で OSI-over-PPP が動作します。これは、他のベンダーの GNE から OSI ネットワークに参加するすべての ONS 15454 NE に TL1 コマンドをルーティングできるようにするために必要です。

13.7.9.1 OSI/IP のシナリオ 1:IP OSS、IP DCN、ONS GNE、IP DCC、および ONS ENE

図13-31 に、OSI/IP シナリオ 1 を示します。IP DCN、IP-over-PPP DCC、および OSPF ルーティングが行われる、ONS 15454 IP ベースの現在の実装です。

図13-31 OSI/IP のシナリオ 1:IP OSS、IP DCN、ONS GNE、IP DCC、および ONS ENE

 

 

1

IP OSS が TL1 および FTP を使用して ONS 15454 を管理します。

2

DCC が IP-over-PPP プロトコルを伝送します。

3

ONS 15454 ネットワークは IP-over-OSPF によって管理されます。

13.7.9.2 OSI/IP のシナリオ 2:IP OSS、IP DCN、ONS GNE、OSI DCC、および他のベンダーの ENE

OS/IP のシナリオ 2(図13-32)に、マルチベンダー OSI ネットワークにおける ONS 15454 GNE を示します。IP OSS が TL1 と FTP を使用して、ONS 15454 GNE と他のベンダーの GNE の両方を管理します。CTC と Cisco Transport Manager(CTM)も ONS 15454 を管理します。他のベンダーの NE が OSI フル スタック上でサポートするのは TL1 と FTAM だけなので、ONS 15454 GNE が T-TD と FT-TD メディエーションを実現し、TL1/IP を TL1/OSI に、FTAM/OSI を FTP/IP に変換します。

図13-32 OSI/IP のシナリオ 2:IP OSS、IP DCN、ONS GNE、OSI DCC、および他のベンダーの ENE

 

 

1

IP OSS が TL1 と FTP を使用して ONS 15454 と他のベンダーの NE を管理します。

2

ONS 15454 GNE が他のベンダーの NE のメディエーションを実現します。

3

ONS 15454 GNE と ONS 15454 NE 間の DCC は、IP-over-PPP と OSI-over-PPP に対応するものとしてプロビジョニングされています。

4

ONS 15454 GNE と他のベンダーの NE 間の DCC は、OSI-over-LAP-D に対応するものとしてプロビジョニングされています。

5

ONS 15454 と他のベンダーの NE からなるネットワークには、IP-over-OSPF と OSI-over-IS-IS プロトコルが組み込まれています。

ONS 15454 GNE は TL1 TID を IP アドレスまたは NSAP アドレスのどちらかに解決することによって、正しい NE に TL1 トラフィックをルーティングします。TL1 トラフィックを他のベンダーの NE(OSI 専用ノード)にルーティングする場合、TIDは NSAP アドレスとして解決されます。ONS 15454 GNE は、メディエーション機能に TL1 を渡し、メディエーション機能が OSI フル スタック上でその TL1 をカプセル化して、IS-IS プロトコルで宛先にルーティングします。

ONS 15454 NE に TL1 トラフィックを送る場合、TID は IP アドレスと NSAP アドレスの両方に解決されます。ONS 15454 GNE は現在の TL1 処理モデルに従い、TCP/IP スタックと OSPF ルーティングを使用して宛先 NE に要求を転送します。

OSS が開始するソフトウェア ダウンロードは、2 つの部分からなります。OSS から宛先 NE TL1 へのダウンロード要求とファイル転送です。TL1 要求の処理はすでに説明したとおりです。ONS 15454 NE は FTP を使用してファイルを転送します。OSI 専用 NE は FTAM を使用してファイルを転送します。FTAM プロトコルは、OSI NE と ONS 15454 GNE 間を OSI で伝送されます。GNE メディエーションによって、FTAM と FTP 間の変換が行われます。

13.7.9.3 OSI/IP のシナリオ 3:IP OSS、IP DCN、他のベンダーの GNE、OSI DCC、および ONS ENE

OSI/IP のシナリオ 3(図13-33)では、すべての TL1 トラフィックが IP DCN を介して OSS と GNE 間で交換されます。GNE に向かう TL1 トラフィックはローカルで処理されます。それ以外のすべての TL1 トラフィックは OSI スタックに転送され、そこで IP から OSI TL1 への変換が行われます。TL1 は OSI フル スタックでカプセル化され、DCC を介してターゲット NE に送られます。ONS 15454 と ONS 15454 以外を含めてすべての NE は NSAP アドレスが設定されていて、IS-IS ルーティングをサポートするので、GNE は IS-IS ドメイン内の任意のノードにルーティングできます。

ONS 15454 NE が受信し、その NSAP アドレスが宛先ではない TL1 トラフィックは、IS-IS ルーティングによって正しい宛先にルーティングされます。ONS 15454 NE が受信した NSAP 宛ての TL1 トラフィックは、OSI スタックからメディエーション機能に回され、そこで TL1 が抽出されて ONS 15454 TL1 プロセッサに渡されます。

OSS が開始するソフトウェア ダウンロードには、OSS から宛先ノードへの TL1 ダウンロード要求とファイル転送が含まれます。TL1 要求の処理はすでに説明したとおりです。ターゲット ノードは FTAM を使用してファイルを転送します。これは、GNE が DCC 上の IPをサポートしていないので、FTP を転送できないからです。したがって ONS 15454 NE は、FTAM クライアントをサポートし、OSI GNE に従属している場合に FTAM を使用してファイル転送を開始する必要があります。

このシナリオでは、GNE に IP 接続と OSI DCN 接続の両方があります。GNE がサポートするのは、TL1 と FTP over IP だけです。どちらも変換されてから、OSI で宛先 ENE(ONS 15454 または OSI 専用 NE)に伝送されます。その他の IP トラフィックはすべて GNE が廃棄します。CTC/CTM IP トラフィックは、IP-over-OSI トンネルを使用して ONS 15454 NE に伝送されます。このトンネルは、外部ルータと ONS 15454 NE 間に作成されています。トラフィックは、トンネル終端の ONS 15454 に送られます。トラフィックはその ONS 15454 からさらに、トンネルを使用し、外部ルータを経由して CTC/CTM に転送されます。

図13-33 OSI/IP のシナリオ 3:IP OSS、IP DCN、他のベンダーの GNE、OSI DCC、および ONS ENE

 

 

1

IP OSS が TL1 と FTP を使用して ONS 15454 と他のベンダーの NE を管理します。

2

他のベンダーの GNE は、TL1 と FTP にメディエーションを実行するので、ONE 15454 と他のベンダーの NE への DCC は OSI 専用です。

3

CTC/CTM は IP-over-CLNS トンネルを使用して ONS 15454 NE と通信します。トンネルは ONS 15454 ノードから外部ルータまで作成されます。

4

ONS 15454 NE は、ファイル転送に FTAM を使用し、OSI フル スタック上で TL1 を交換します。

図13-34 に、IP-over-CLNS トンネルのエンド ポイントが DCN ルータではなく GNE であること以外は同じシナリオを示します。

図13-34 OSI/IP のシナリオ 3:OSI/IP-over-CLNS トンネルのエンド ポイントが GNE にある場合

 

 

1

IP OSS が TL1 と FTP を使用して ONS と他のベンダーの NE を管理します。

2

ルータが他のベンダーの GNE に要求をルーティングします。

3

他のベンダーの GNE は、TL1 と FTP にメディエーションを実行するので、ONE 15454 と他のベンダーの NE への DCC は OSI 専用です。

4

CTC/CTM は、ONS 15454 と GNE 間の IP-over-CLNS トンネルを使用して ONS 15454 NE と通信します。

5

ONS 15454 NE は、OSI フル スタック上で TL1 を交換します。ファイル転送には FTAM を使用します。

13.7.9.4 OSI/IP のシナリオ 4:複数の ONS DCC エリア

OSI/IP シナリオ 4(図13-35)は、切り離された複数の ONS 15454 エリアに OSI GNE が従属していることを除き、OSI/IP のシナリオ 3 に類似しています。切り離された ONS 15454 OSPF エリアごとに、別々の IP-over-CLNS トンネルが必要です。または、CTC/CTM から ONS 15454 NE までの IP-over-CLNS トンネルを 1 つ作成し、さらに切り離された各 OSPF エリアで NE 間のトンネルを 1 つずつ設定する方法もあります。この方法の場合は、スタティック ルートを追加する必要があります。

図13-35 OSI/IP のシナリオ 4:複数の ONS DCC エリア

 

 

1

IP OSS が TL1 と FTP を使用して ONS 15454 と他のベンダーの NE を管理します。

2

切り離された ONS 15454 DCC エリアごとに別々のトンネルを作成します。

13.7.9.5 OSI/IP のシナリオ 5:OSI DCC 接続を使用しない GNE

OSI/IP のシナリオ 5(図13-36)は、OSI GNE と DCN 間の接続が IP だけであることを除き、OSI/IP のシナリオ 3 に類似しています。IP-over-OSI トンネルを使用して CTC/CTM IP トラフィックを伝送する OSI DCN 接続はありません。CTC/CTM アクセス用には、DCN と ONS 15454 NE 間の接続を別個に作成します。

図13-36 OSI/IP のシナリオ 5:OSI DCC 接続を使用しない GNE

 

 

1

IP OSS が TL1 と FTP を使用して ONS 15454 と他のベンダーの NE を管理します。

2

他のベンダーの GNE が TL1 と FTP 間を仲介するので、DCC は OSI 専用です。

3

CTC/CTM は独立した IP DCN 接続を使用して ONS 15454 NE と通信します。

4

ONS 15454 NE は、OSI フル スタック上で TL1 を交換します。ファイル転送には FTAM を使用します。

13.7.9.6 OSI/IP のシナリオ 6:IP OSS、OSI DCN、ONS GNE、OSI DCC、および他のベンダーの ENE

OSI/IP のシナリオ 6(図13-37)に、ONS 15454 による OSI DCN サポートを示します。すべての IP トラフィック(CTC/CTM、FTP、および TL1)が OSI DCN 経由でトンネリングされるので、OSI DCN が ONS 15454 に影響を与えることはありません。

図13-37 OSI/IP のシナリオ 6:IP OSS、OSI DCN、ONS GNE、OSI DCC、および他のベンダーの ENE

 

 

1

IP OSS が TL1 と FTP を使用して ONS 15454 と他のベンダーの NE を管理します。

2

OSS IP トラフィックは DCN 経由で ONS 15454 GNE にトンネリングされます。

3

CTC/CTM IP トラフィックは DCN 経由で ONS 15454 GNE にトンネリングされます。

4

GNE が他のベンダーの NE に対してメディエーションを実行します。

13.7.9.7 OSI/IP のシナリオ 7:OSI OSS、OSI DCN、他のベンダーの GNE、OSI DCC、および ONS NE

OSI/IP の シナリオ 7(図13-38)に、欧州のネットワーク例を示します。

図13-38 OSI/IP のシナリオ 7:OSI OSS、OSI DCN、他のベンダーの GNE、OSI DCC、および ONS NE

 

 

1

CTC/CTM だけで ONS 15454 NE を管理します。TL1/FTP は使用しません。

2

OSI OSS は他のベンダーの NE だけを管理します。

3

CTC/CTM は、ONS 15454 NE と外部ルータ間の IP-over-CLNS トンネルを使用して ONS 15454 と通信します。

欧州のネットワークでは

CTC と CTM は管理専用です。

IP-over-CLNS トンネルが広く普及しています。

TL1 管理は不要です。

FTP ファイル転送は不要です。

TL1 および FTAMからFTP のメディエーションは不要です。

CTC/CTM と ONS 15454 NE 間の管理用トラフィックは、IP-over-CLNS トンネルを使用して伝送されます。トンネル終端の ONS 15454(ONS 15454 NE 1)上でスタティック ルートを設定し、ダウンストリームの ONS 15454 NE(ONS 15454 NE 2 および 3)が CTC/CTM への到達方法を認識するようにします。

13.7.9.8 OSI/IP のシナリオ 8:OSI OSS、OSI DCN、ONS GNE、OSI DCC、および他のベンダーの NE

OSI/IP の シナリオ 8(図13-39)に、欧州のネットワーク例をもう 1 つ示します。OSI/IP のシナリオ 7 と同様、CTC/CTM だけで ONS 15454 NE を管理します。CTC/CTM IP トラフィックは、外部ルータと ONS 15454 GNE 間を IP-over-OSI トンネルで伝送されます。GNE がトンネルから IP を抜き取って宛先 ONS 15454 に転送します。OSS と 他のベンダーの NE 間の管理用トラフィックは、ONS 15454 GNE と NE によってルーティングされます。これが可能なのは、すべての ONS 15454 NE でデュアル スタック(OSI と IP)が動作するからです。

図13-39 OSI/IP のシナリオ 8:OSI OSS、OSI DCN、ONS GNE、OSI DCC、および他のベンダーの NE

 

 

1

CTC/CTM だけで ONS NE を管理します。TL1/FTP は使用しません。

2

OSI OSS は他のベンダーの NE だけを管理します。

3

CTC/CTM は、ONS 15454 NE と外部ルータ間の IP-over-CLNS トンネルを使用して ONS 15454 と通信します。GNE 上にスタティック ルートが必要です。

4

ONS 15454 GNE が他のベンダーの NE に OSI トラフィックをルーティングします。IP-over-CLNS トンネルは不要です。

13.7.10 CTCでの OSI のプロビジョニング

表13-18 に、ノード ビューの Provisioning タブから実行する OSI アクションを示します。OSI の手順および作業については、『 Cisco ONS 15454 Procedure Guide 』を参照してください。

 

表13-18 CTC の Provisioning タブから実行する OSI アクション

タブ
アクション

OSI > Main Setup

プライマリ エリア アドレスの表示および編集

OSI ルーティング モードの変更

LSP バッファの変更

OSI > TARP > Config

TARP パラメータの設定

PDU L1/L2 の伝播および生成

TARP データ キャッシュおよびループ検出バッファ

LAN ストームの抑制

起動時にタイプ 4 の PDU

TARP タイマー:LDB、T1、T2、T3、T4.

OSI > TARP > Static TDC

スタティック TARP データ キャッシュ エントリの追加および削除

OSI > TARP > MAT

スタティック マニュアル エリア テーブル エントリの追加および削除

OSI > Routers > Setup

ルータの有効化および無効化

マニュアル エリア アドレスの追加、削除、および編集

OSI > Routers > Subnets

OSI 用にプロビジョニングされた SDCC、LDCC、および LAN サブネットの編集

OSI > Tunnels

Cisco および IP-over-CLNS トンネルの追加、削除、および編集

Comm Channels > SDCC

SDCC への OSI コンフィギュレーションの追加

データ リンク レイヤ プロトコル、PPP または LAP-D の選択

Comm Channels > LDCC

SDCC への OSI コンフィギュレーションの追加

表13-19 に、ノード ビューの Maintenance タブから実行する OSI アクションを示します。

 

表13-19 CTC の Maintenance タブから実行する OSI アクション

タブ
アクション

OSI > ISIS RIB

IS-IS ルーティング テーブルの表示

OSI > ESIS RIB

IS に接続されている ES の表示

OSI > TDC

TARP データ キャッシュの表示、スタティックおよびダイナミック エントリの識別

TID から NSAP への解決

TDC のフラッシュ