Cisco ONS 15454/15454 SDH/Cisco ONS 15327 イーサネット カード ソフトウェア フィーチャ コンフィギュレーション ガイド Release 7.2
インターフェイスの設定
インターフェイスの設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

インターフェイスの設定

インターフェイスの一般的な注意事項

MAC アドレス

インターフェイス ポート ID

インターフェイスの基本設定

ファースト イーサネット、ギガビット イーサネット、および POS インターフェイスの基本設定

ファースト イーサネット インターフェイスの設定(ML100T-12)

ファースト イーサネット インターフェイスの設定(ML100X-8)

ギガビット イーサネット インターフェイスの設定(ML1000-2)

ギガビット イーサネット RFI の設定

ギガビット イーサネット RFI のモニタリングおよび確認

POS インターフェイスの設定(ML100T-12、ML100X-8、および ML1000-2)

ファースト イーサネット インターフェイスとギガビット イーサネット インターフェイスのモニタリング操作

インターフェイスの設定

この章では、ML シリーズ カードを起動して実行するための、ML シリーズ カードのインターフェイスの基本設定について説明します。Packet-over-SONET/SDH(POS)インターフェイスの高度な設定については、「POS の設定」を参照してください。この章で使用する Cisco IOS コマンドの詳細については、『 Cisco IOS Command Reference 』を参照してください。

この章の内容は次のとおりです。

「インターフェイスの一般的な注意事項」

「インターフェイスの基本設定」

「ファースト イーサネット、ギガビット イーサネット、および POS インターフェイスの基本設定」

「ファースト イーサネット インターフェイスとギガビット イーサネット インターフェイスのモニタリング操作」


) ML シリーズ カードの初期設定が完了してからインターフェイスを設定してください。


インターフェイスの一般的な注意事項

ML シリーズ カードの主な機能はデータ リンク間でパケットを中継することです。したがって、パケットを送受信するインターフェイスの特性を設定する必要があります。インターフェイスの特性には IP アドレス、ポートのアドレス、データ カプセル化方式、およびメディア タイプなどがあります。

多数の機能がインターフェイスごとにイネーブルにできます。インターフェイス コンフィギュレーション モードには、イーサネット ポートなどのインターフェイスの動作を修正するコマンドがあります。interface コマンドを入力する場合は、インターフェイスのタイプと番号を指定する必要があります。

次の一般的な注意事項は、すべての物理インターフェイスと仮想インターフェイスの設定に当てはまります。

すべてのインターフェイスに名前があります。名前はインターフェイス タイプ(ワード)とポート ID(番号)から成ります。例としては、FastEthernet 2 があります。

それぞれのインターフェイスは、ブリッジ グループ、または IP アドレスと IP サブネット マスクを使用して設定します。

VLAN(仮想 LAN)はサブインターフェイスを使用することによりサポートされます。サブインターフェイスとは、関連付けられた物理インターフェイスとは別に設定された論理インターフェイスです。

内部 POS インターフェイスを含め、それぞれの物理インターフェイスには、MAC(メディア アクセス制御)アドレスが割り当てられています。

MAC アドレス

イーサネット ネットワークに接続するポートまたは装置には、MAC アドレスが必要です。ネットワークの他の装置が、特定のポートをネットワーク内で検索したり、ルーティング テーブルとデータ構造を作成および更新したりするために MAC アドレスを使用します。

装置の MAC アドレスを検索するには、 show interfaces コマンドを次のように使用します。

Router# sh interfaces fastEthernet 0
FastEthernet0 is up, line protocol is up
Hardware is epif_port, address is 0005.9a39.6634 (bia 0005.9a39.6634)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, Auto Speed, 100BaseTX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:18, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
11 packets input, 704 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 11 multicast
0 input packets with dribble condition detected
3 packets output, 1056 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
 

インターフェイス ポート ID

インターフェイス ポート IDによって、ML シリーズ カードのインターフェイスの物理的な位置が指定されます。この ID は、設定するインターフェイスを特定する名前です。システム ソフトウェアは、インターフェイス ポート ID を使用して ML シリーズ カード活動状況を制御し、ステータス情報を表示します。インターフェイス ポート ID は、ネットワークの他の装置が使用することはなく、個々の ML シリーズ カードおよびその内部のコンポーネントとソフトウェアに固有です。

ML100T-12 では、12 個のファースト イーサネット インターフェイスのポート ID は Fast Ethernet 0 ~ 11 です。ML100X-8 では、8 つのファースト イーサネット インターフェイスのポート ID は Fast Ethernet 0 ~ 7 です。ML1000-2 では、2 つのギガビット イーサネット インターフェイスのポート ID は Gigabit Ethernet 0 ~ 1 です。どちらの ML シリーズ カードにも 2 つの POS ポートがあり、これらの 2 つの POS インターフェイスの ML シリーズ ポート ID は POS 0 と POS 1 です。ポート ID には、ユーザ定義の省略形を使用できます。たとえば、ファースト イーサネット インターフェイスの設定には f0、2 つのギガビット イーサネット インターフェイスの設定には gi0 または gi1、2 つの POS ポートの設定には POS0 と POS1 にすることができます。

Cisco IOS の show コマンドを使用すると、ML シリーズ カードの任意またはすべてのインターフェイスに関する情報を表示できます。


注意 ギガビット イーサネットのユーザ定義の省略形として、g0 または g1 を使用しないでください。使用すると、サポートされないグループ非同期インターフェイスが作成されます。

インターフェイスの基本設定

次の一般的な設定方法は、すべてのインターフェイスに当てはまります。インターフェイスを設定する前に、ブリッジまたはルーティングされるネットワークの計画を作成しておいてください。

インターフェイスを設定するには、次の手順を実行します。


ステップ 1 イネーブル EXE プロンプトで configure EXEC コマンドを入力してグローバル コンフィギュレーション モードを開始します。

Router> enable
Password:
Router# configure terminal
Router(config)#
 

ステップ 2 interface コマンド、インターフェイス タイプ(fastethernet、gigabitethernet、pos など)、インターフェイス ポート ID(インターフェイス ポート IDを参照)の順に入力します。

たとえば、ギガビット イーサネット ポートを 1 つ設定するには、次のコマンドを入力します。

Router(config)# interface gigabitethernet number
 

ステップ 3 interface コマンドの入力後に、設定するインターフェイスに必要なインターフェイス設定コマンドを入力します。

入力するコマンドによって、インターフェイス上で実行するプロトコルとアプリケーションが定義されます。ML シリーズ カードは、 interface コマンドがもう一度入力されるか、またはインターフェイス コンフィギュレーション コマンド以外のコマンドが入力されるまで、コマンドを集め、 interface コマンドに適用します。 end を入力して特権 EXEC モードに戻ることもできます。

ステップ 4 EXEC の show interface コマンドを入力して、設定したインターフェイスのステータスを確認します。

Router# sh interface fastEthernet 0
FastEthernet0 is up, line protocol is up
Hardware is epif_port, address is 0005.9a39.6634 (bia 0005.9a39.6634)
MTU 1500 bytes, BW 100000 Bit, DLY 100 use,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, Auto Speed, 100BaseTX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:18, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
11 packets input, 704 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 11 multicast
0 input packets with dribble condition detected
3 packets output, 1056 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
 


 

ファースト イーサネット、ギガビット イーサネット、および POS インターフェイスの基本設定

ML シリーズ カードは、ファースト イーサネット、ギガビット イーサネット、および POS の各インターフェイスをサポートしています。ここでは、すべてのインターフェイス タイプの設定例をいくつか説明します。

ファースト イーサネット、ギガビット イーサネット、または POS のインターフェイスに IP アドレスまたはブリッジ グループ番号を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# interface type number

インターフェイス コンフィギュレーション モードを起動して、ギガビット イーサネット インターフェイス、ファースト イーサネット インターフェイス、または POS インターフェイスのいずれかを設定します。

ステップ 2

Router(config-if)# { ip address ip-address subnet-mask | bridge-group bridge-group-number }

インターフェイスに割り当てる IP アドレスと IP サブネット マスクを設定します。

または

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 3

Router(config-if)# no shutdown

インターフェイスがシャット ダウンしないようにすることにより、インターフェイスをイネーブルにします。

ステップ 4

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 5

Router# copy running-config startup-config

(任意)設定の変更をタイミング制御用カード(TCC2/TCC2P)のフラッシュ データベースに保存します。

ファースト イーサネット インターフェイスの設定(ML100T-12)

ML100T-2 ファースト イーサネット インターフェイス上で IP アドレスまたはブリッジ グループ番号、速度、デュプレックス、およびフロー制御を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# interface fastethernet number

インターフェイス コンフィギュレーション モードを起動してファースト イーサネット インターフェイスを設定します。

ステップ 2

Router(config-if)# { ip address ip-address subnet-mask | bridge-group bridge-group-number }

インターフェイスに割り当てる IP アドレスと IP サブネット マスクを設定します。

または

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 3

Router(config-if)# [ no ] speed { 10 | 100 | auto }

伝送速度を 10 または 100 Mbps に設定します。speed または duplex を auto に設定した場合、システムで自動ネゴシエーションがイネーブルになります。この場合、ML シリーズ カードはパートナー ノードの speed および duplex モードと一致します。

ステップ 4

Router(config-if)# [ no ] duplex { full | half | auto }

全二重モード、半二重モード、または自動ネゴシエーション モードを設定します。

ステップ 5

Router(config-if)# flowcontrol send { on | off | desired }

(任意)インターフェイスのフロー制御送信値を設定します。フロー制御は、ポートレベルのポリシングを使用した場合にのみ機能します。ML シリーズ カードのファースト イーサネット ポートのフロー制御は IEEE 802.3x 準拠です。


) ファースト イーサネット ポートは対称フロー制御のみをサポートしているので、flowcontrol send コマンドは送受信両方のフロー制御動作を制御します。


ステップ 6

Router(config-if)# no shutdown

インターフェイスがシャット ダウンしないようにすることにより、インターフェイスをイネーブルにします。

ステップ 7

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 8

Router# copy running-config startup-config

(任意)設定の変更を TCC2/TCC2P フラッシュ データベースに保存します。

例4-1に、IP アドレスと自動ネゴシエーションを使用した ML100T-12 ファースト イーサネット インターフェイスの初期設定方法を示します。

例4-1 ML100T-12 ファースト イーサネット インターフェイスの初期設定

Router(config)# interface fastethernet 1
Router(config-if)# ip address 10.1.2.4 255.0.0.0
Router(config-if)# negotiation auto
Router(config-if)# no shutdown
Router(config-if)# end
Router# copy running-config startup-config
 

ファースト イーサネット インターフェイスの設定(ML100X-8)

ML 100X-8 は、100BASE-FX 全二重データ伝送をサポートしています。ファースト イーサネット インターフェイスでは、自動ネゴシエーションや速度を設定できません。またカードには、デフォルトで Automatic Media-Dependent Interface crossover(Auto-MDIX; 自動メディア依存型インターフェイス クロスオーバー)機能がイネーブルに設定されています。Auto-MDIX は、必要なケーブル接続タイプ(ストレートまたはクロス)を検出し、接続設定を適切に行います。ファースト イーサネット インターフェイス上で IP アドレス、ブリッジ グループ番号、またはフロー制御を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# interface fastethernet number

インターフェイス コンフィギュレーション モードを起動してファースト イーサネット インターフェイスを設定します。

ステップ 2

Router(config-if)# { ip address ip-address subnet-mask | bridge-group bridge-group-number }

インターフェイスに割り当てる IP アドレスと IP サブネット マスクを設定します。

または

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 3

Router(config-if)# flowcontrol send { on | off | desired }

(任意)インターフェイスのフロー制御送信値を設定します。フロー制御は、ポートレベルのポリシングを使用した場合にのみ機能します。ML シリーズ カードのファースト イーサネット ポートのフロー制御は IEEE 802.3x 準拠です。


) ファースト イーサネット ポートは対称フロー制御のみをサポートしているので、flowcontrol send コマンドは送受信両方のフロー制御動作を制御します。


ステップ 4

Router(config-if)# no shutdown

インターフェイスがシャット ダウンしないようにすることにより、インターフェイスをイネーブルにします。

ステップ 5

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 6

Router# copy running-config startup-config

(任意)設定の変更を TCC2/TCC2P フラッシュ データベースに保存します。

ギガビット イーサネット インターフェイスの設定(ML1000-2)

ML1000-2 ギガビット イーサネット インターフェイス上で IP アドレスまたはブリッジ グループ番号、自動ネゴシエーション、およびフロー制御を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。


) ネゴシエーション モードのデフォルト設定は、ギガビット イーサネットおよびファースト イーサネットのインターフェイスの場合は auto です。ギガビット イーサネット ポートは、常に全二重モードの 1000 Mbps で動作します。


 

コマンドの説明
目的

ステップ 1

Router# interface gigabitethernet number

インターフェイス コンフィギュレーション モードを起動してギガビット イーサネット インターフェイスを設定します。

ステップ 2

Router(config-if) # { ip address ip-address subnet-mask | bridge-group bridge-group-number }

IPアドレスおよびサブネット マスクを設定します。

または

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 3

Router(config-if)# [ no ] negotiation auto

ネゴシエーション モードを auto に設定します。ギガビット イーサネット ポートはパートナー ポートとリンクのネゴシエーションを試行します。

パートナー ポートの設定に関係なく、このポートでリンクを強制的に起動する場合は、ギガビット イーサネット インターフェイスを no negotiation auto に設定します。

ステップ 4

Router(config-if)# flowcontrol { send | receive } { on | off | desired }

(任意)インターフェイスに送信または受信のフロー制御値を設定します。フロー制御は、ポートレベルのポリシングを使用した場合にのみ機能します。ML シリーズ カードのギガビット イーサネット ポートのフロー制御は IEEE 802.3z 準拠です。

ステップ 5

Router(config-if)# no shutdown

インターフェイスがシャット ダウンしないようにすることにより、インターフェイスをイネーブルにします。

ステップ 6

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 7

Router# copy running-config startup-config

(任意)設定の変更を TCC2/TCC2P フラッシュ データベースに保存します。

例4-2に、自動ネゴシエーションと IP アドレスを使用したギガビット イーサネット インターフェイスの初期設定方法を示します。

例4-2 ギガビット イーサネット インターフェイスの初期設定

Router(config)# interface gigabitethernet 0
Router(config-if)# ip address 10.1.2.3 255.0.0.0
Router(config-if)# negotiation auto
Router(config-if)# no shutdown
Router(config-if)# end
Router# copy running-config startup-config
 

ギガビット イーサネット RFI の設定

Remote Failure Indication(RFI)は IEEE 802.3z 標準の一部で、エラー情報を交換するためにリンク ネゴシエーションの一部として送信されます。この機能により、他社製機器と ML1000-2 の間の通信が向上します。デフォルトでは RFI はオンではありませんが、ユーザがオンにすることができます。他社製機器が RFI の IEEE 802.3z 標準の実装をサポートしない場合は RFI をディセーブルにする必要があります。

ML シリーズ カードの RFI は双方向 RFI をサポートします。ML シリーズ カードにローカル エラーがある場合、ML シリーズ カードはローカル CARLOSS アラームを発生させて、リンク先に RFI を送信します。ML シリーズ カードがリンク先から RFI を受信すると、AUTONEG-RFI アラームを発生させてギガビット イーサネット ポートをシャット ダウンします。

ギガビット イーサネット インターフェイスで RFI をイネーブルにするには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router (config)# interface gigabitethernet number

インターフェイス コンフィギュレーション モードを起動してギガビット イーサネット インターフェイスを設定します。

ステップ 2

Router(config-if) # [ no ] rfi auto

IEEE 802.3z 標準 RFI をイネーブルにします。

RFI をディセーブルにするには、このコマンドの no 形式を使用します。

ステップ 3

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 4

Router# copy running-config startup-config

(任意)設定の変更を TCC2/TCC2P フラッシュ データベースに保存します。

例4-3 に、ギガビット イーサネット インターフェイスで RFI を初期設定する方法を示します。

例4-3 ギガビット イーサネット インターフェイスの RFI 設定

Router(config)# interface gigabitethernet 0
Router(config-if)# rfi auto
Router(config-if)# end
Router# copy running-config startup-config
 

ギガビット イーサネット RFI のモニタリングおよび確認

RFI を設定したら、show running configuration グローバル コマンドを使って、RFI がイネーブルになっていることを確認します。例4-4 に、このコマンドの出力を示します。ギガビット イーサネット ポートの出力の「rfi auto」の行は、それぞれのポートで RFI がイネーブルであることを示します。

show controller gigabit ethernet [ 0 | 1] グローバル コマンドを実行すると、さらに詳細な RFI 情報が表示されます。

例4-5 に、近端 ML シリーズ カードでこのコマンドを実行し、近端または遠端でエラーが検出されない場合の全出力を示します。Remote Fault Indication は 00(no error)、Local Fault Indication は 00(no error)です。

例4-6 に、近端 ML シリーズ カードでこのコマンドを実行し、近端でエラーが検出された場合の部分出力を示します。Remote Fault Indication は 00 (no error)ですが、Local Fault Indication は 01(link error)です。

例4-7 に、遠端 ML シリーズ カードでこのコマンドを実行し、近端でエラーが検出された場合の部分出力を示します。Remote Fault Indication は 01(link error)、Local Fault Indication は 00(link error)です。


) 近端 ML シリーズ カードが RFI シグナリング リンク エラーを送信するまでの 2 分間に遠端リンク先がリセットされれば、リンク先ではバック アップ時に RFI リンク エラーが表示されません。


例4-4 RFI の show run コマンド出力

Router# show running configuration
Building configuration...
 
Current configuration : 806 bytes
!
! No configuration change since last restart
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Interop-261-TOP-
!
boot-start-marker
boot-end-marker
!
enable password lab
!
clock timezone PST -8
clock summer-time PDT date Apr 2 2006 2:00 Oct 29 2006 2:00
ip subnet-zero
!
no mpls traffic-eng auto-bw timers frequency 0
 
interface GigabitEthernet0
no ip address
rfi auto
!
interface GigabitEthernet1
no ip address
rfi auto
 

例4-5 近端カードでの RFI の show controller コマンド出力(エラーが検出されない場合)

Near_End# show controller gigabit ethernet 0
IF Name: GigabitEthernet0
Port Status UP
Port rxLosState Signal present
Remote Fault Indication 00 (no error)
Local Fault Indication 00 (no error)
Port 0 Gmac Loopback false
SFP EEPROM information
----------------------
0x0 : 03 04 07 00 00 00 02 12 00 01 01 01 0C 00 0A 64
0x10: 37 37 00 00 46 49 4E 49 53 41 52 20 43 4F 52 50
0x20: 2E 20 20 20 00 00 FFFFFF90 65 46 54 52 4A 2D 31 33 31
0x30: 39 2D 37 44 2D 43 53 43 00 00 00 00 05 1E 00 00
 
GBIC Type: GBIC_1000BASE_LH
Send Flow Control: Enabled (Port level policing required to send pause frames)
Receive Flow Control : Enabled
CRC-ALARM: FALSE
 
MAC registers:
GCR: 0x0 CMCR : 0x00000803 (Tx Enabled, Rx Enabled)
 
MII registers of External GMAC:
Control Register (0x00): 0x1140 (Auto negotation Enabled)
Status Register (0x01): 0x16D (Link Status Up)
Auto Neg. Advt. Register (0x04): 0x1A0 (Dir 1, Sym 1)
Auto Neg. Partner Ability Reg (0x05): 0x41A0 (Dir 1, Sym 1)
TR_IPG_TIME Register (0x10): 0x7
PAUSE_TIME Register (0x11): 0x100
PAUSE_SA1 Register (0x13): 0x0
PAUSE_SA2 Register (0x14): 0x0
PAUSE_SA3 Register (0x15): 0x0
Pause Upper Threshold Reg. (0x19): 0x80
Pause Lower Threshold Reg. (0x1A): 0xFF
TX Full Threshold Register (0x1B): 0x40
Memory Address Register (0x1C): 0xF008
Sync Status Register (0x1D): 0x40
Sys Status Register (0x1E): 0x98
Sys Control Register (0x1F): 0x14
Auto Neg Ctrl Register (0xF004): 0x7
Rx Uinfo Registerter-GMAC (0xF006): 0x0
RX control Register-GMAC (0xF009): 0x3
RX Oversize Register-GMAC (0xF00A): 0x5F4
Statistics control register (0xF008): 0x1
 
Counters :
MAC receive conters:
Bytes 1952660
pkt64 0
pkts64to127 0
pkts128to255 0
pkts256to511 5485
pkts512to1023 0
pkts1024to1518 0
pkts1519to1530 0
pkts_good_giants 0
pkts_error_giants 0
pkts_good_runts 0
pkts_error_runts 0
pkts_ucast 0
pkts_mcast 5485
pkts_bcast 0
Rx Sync Loss 0
Overruns 0
FCS_errors 0
GMAC drop count 0
Symbol error 0
Rx Pause frames 0
 
MAC Transmit Counters
5d00h: %LINK-3-UPDOWN: Interface GigabitEthernet0, changed state to down
5d00h: %ETHERCHAN-5-MEMREMOVED: GigabitEthernet0 taken out of port-channel1
5d00h: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0, changed
staBytes 1952660
pkts64 0
pkts65to127 0
pkts128to255 0
pkts256to511 5485
pkts512to1023 0
pkts1024to1518 0
pkts1519to1530 0
Good Giants 0
Unicast packets 0
Multicast packets 5485
Broadcast packets 0
FCS errors 0
Tx Pause frames 0
Ucode drops 0
 

例4-6 近端カードでの RFI の show controller コマンド出力(近端エラーが検出された場合)

Near_End# show controller gigabit ethernet 0
IF Name: GigabitEthernet0
Port Status DOWN
Port rxLosState No signal
Remote Fault Indication 00 (no error)
Local Fault Indication 01 (link error)
Port 0 Gmac Loopback false
 

例4-7 遠端カードでの RFI の show controller コマンド出力(近端エラーが検出された場合)

Far_End# show controller gigabit ethernet 0
IF Name: GigabitEthernet0
Port Status DOWN
Port rxLosState Signal present
Remote Fault Indication 01 (link error)
Local Fault Indication 00 (no error)
Port 0 Gmac Loopback false

POS インターフェイスの設定(ML100T-12、ML100X-8、および ML1000-2)

POS ポートでカプセル化を変更できるのは、インターフェイスが手動でシャットダウン(ADMIN_DOWN)されているときだけです。POS インターフェイスの高度な設定については、「POS の設定」を参照してください。

POS インターフェイスの IP アドレス、ブリッジ グループ、カプセル化を設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# interface pos number

インターフェイス コンフィギュレーション モードを起動して POS インターフェイスを設定します。

ステップ 2

Router(config-if) # { ip address ip-address subnet-mask | bridge-group bridge-group-number }

IPアドレスおよびサブネット マスクを設定します。

または

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 3

Router(config-if) # shutdown

インターフェイスを手動でシャット ダウンします。POS ポートでカプセル化を変更できるのは、インターフェイスがシャットダウン(ADMIN_DOWN)されているときだけです。

ステップ 4

Router(config-if)# encapsulation type

カプセル化のタイプを設定します。有効な値は次のとおりです。

hdlc ― Cisco HDLC

lex ― (デフォルト)LAN 拡張。Cisco ONS イーサネット ライン カードと併用するための特殊なカプセル化

ppp ― ポイントツーポイント プロトコル

ステップ 5

Router(config-if) # no shutdown

シャットダウンされているインターフェイスを再起動します。

ステップ 6

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 7

Router# copy running-config startup-config

(任意)設定の変更を NVRAM(不揮発性 RAM)に保存します。

ファースト イーサネット インターフェイスとギガビット イーサネット インターフェイスのモニタリング操作

インターフェイスを設定したあとに設定を確認するには、show interface コマンドを入力します。POS インターフェイス上の動作に対するモニタリングの詳細については、 「POS の設定」 の章を参照してください。

例4-8に show interface コマンドの出力を示します。ポート速度とデュプレックス動作を含むインターフェイスのステータスが表示されます。

例4-8 show interface コマンドの出力

Router# show interface fastEthernet 0
FastEthernet1 is administratively down, line protocol is down
Hardware is epif_port, address is 000d.bd5c.4c85 (bia 000d.bd5c.4c85)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto-duplex, Auto Speed, 100BaseTX
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
 

ファースト イーサネット コントローラ チップに関する情報を表示するには、show controller コマンドを入力します。

例4-9 に、show controller コマンドの出力を示します。初期化ブロック情報を含む統計情報が表示されます。

例4-9 show controller コマンドの出力

Router# show controller fastEthernet 0
IF Name: FastEthernet0
Port Status DOWN
Send Flow Control : Disabled
Receive Flow Control : Enabled
MAC registers
CMCR : 0x0000042D (Tx Enabled, Rx Disabled)
CMPR : 0x150B0A80 (Long Frame Disabled)
FCR : 0x0000A00B (Rx Pause detection Enabled)
MII registers:
Control Register (0x0): 0x4000 (Auto negotiation disabled)
Status Register (0x1): 0x7809 (Link status Down)
PHY Identification Register 1 (0x2): 0x40
PHY Identification Register 2 (0x3): 0x61D4
Auto Neg. Advertisement Reg (0x4): 0x1E1 (Speed 100, Duplex Full)
Auto Neg. Partner Ability Reg (0x5): 0x0 (Speed 10, Duplex Half)
Auto Neg. Expansion Register (0x6): 0x4
100Base-X Aux Control Reg (0x10): 0x2000
100Base-X Aux Status Register(0x11): 0x0
100Base-X Rcv Error Counter (0x12): 0x0
100Base-X False Carr. Counter(0x13): 0x0
 

ファースト イーサネット インターフェイスの設定に関する情報を表示するには、show run interface [ type number ] コマンドを入力します。複数のインターフェイスがあり、特定のインターフェイスの設定を表示する場合にこのコマンドは便利です。

例4-10に、show run interface [ type number ] コマンドの出力を示します。IP アドレスまたは IP アドレスの未指定、およびインターフェイスの状態に関する情報が含まれます。

例4-10 show run interface コマンドの出力

daytona# show run interface FastEthernet 1
Building configuration...
 
Current configuration : 56 bytes
!
interface FastEthernet1
no ip address
shutdown
end