Cisco ONS 15454/15454 SDH/Cisco ONS 15327 イーサネット カード ソフトウェア フィーチャ コンフィギュレーション ガイド Release 7.2
EoMPLS の設定
EoMPLS の設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

EoMPLS の設定

EoMPLS の概要

EoMPLS のサポート

EoMPLS の制限

EoMPLS の QoS

EoMPLS の設定

EoMPLS 設定の注意事項

PE-CLE ポート上での VC タイプ 4 設定

PE-CLE ポート上での VC タイプ 5 設定

PE-CLE SPR インターフェイスでの EoMPLS 設定

MPLS クラウドに面しているポートでのブリッジ グループ設定

パケットのプライオリティと EXP の設定

EoMPLS の設定例

EoMPLS のモニタリングと確認

MPLS-TE の概要

ML シリーズ カードの RSVP

イーサネット FCS 保護

MPLS-TE の設定

ML シリーズ カードのトンネル サポート設定

RSVP ベース トンネル シグナリングおよび IGP フラッディングをサポートするインターフェイスの設定

MPLS-TE の OSPF およびリフレッシュ抑制の設定

MPLS-TE トンネルの設定

MPLS-TE の設定例

MPLS-TE および IP RSVP のモニタリングと確認

RPRW アラーム

EoMPLS の設定

この章では、ML シリーズ カードで Ethernet over Multiprotocol Label Switching(EoMPLS)を設定する方法について説明します。

この章の主な内容は次のとおりです。

「EoMPLS の概要」

「EoMPLS の設定」

「EoMPLS の設定例」

「EoMPLS のモニタリングと確認」

EoMPLS の概要

EoMPLS には、MPLS 対応のレイヤ 3 コアを経由するイーサネット トラフィックをトンネリングするメカニズムがあります。このメカニズムでは、イーサネット Protocol Data Unit(PDU; プロトコル データ ユニット)を MPLS パケット内にカプセル化し、ラベル スタッキングを使用して MPLS ネットワーク上で転送します。EoMPLS は、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)標準トラック プロトコルであり、Martini ドラフト、特に
draft-martini-l2circuit-encap-mpls-01 セクションと draft-martini-l2circuit-transport-mpls-05セクションに基づいています。

EoMPLS を使用することによって、サービス プロバイダーは自社の既存の MPLS バックボーンを使用してカスタマーに仮想イーサネット回線サービスや VLAN(仮想 LAN)サービスを提供できます。サービス プロバイダーのプロビジョニングも簡便化します。これは、Provider Edge Customer-Leading Edge(PE-CLE)装置が、接続されている Customer Edge(CE; カスタマー エッジ)装置にレイヤ 2 接続するだけだからです。

図18-1 に、サービス プロバイダーのネットワークに実装されている EoMPLS の例を示します。この例では、ML シリーズ カードは、RPR(Resilient Packet Ring; 復元パケット リング)アクセス リングを介して Cisco GSR 12000 シリーズに接続した PE-CLE 装置として動作します。point-to-point(p2p; ポイントツーポイント)サービスは、ML シリーズ カードを介して ML シリーズ カード RPR アクセス リングに接続されている様々な設置場所の CE 装置に提供されます。

図18-1 サービス プロバイダーのネットワークでの EoMPLS

 

EoMPLS をサービス プロバイダーのネットワークに実装する場合、ML シリーズ カード インターフェイスで 3 つの重要な機能を実行する必要があります。これらの ML シリーズ カード インターフェイスの機能は、MPLS コアを通過する EoMPLS ポイントツーポイント サービスの両側で設定する必要があります。

ML シリーズ カード インターフェイスは、プロバイダーのネットワークと CE 装置を直接接続し、PE-CLE インターフェイスと呼ばれています。この ML シリーズ カードの PE-CLE インターフェイスはファースト イーサネットまたはギガビット イーサネットであり、EoMPLS ポイントツーポイント セッションのエンドポイントとなるように設定されます。

ML シリーズ カード インターフェイスは、ML シリーズ カードの PE-CLE インターフェイスと RPR ネットワークをブリッジングします。この RPR/SPR インターフェイスは POS ポートを含み、MPLS IP 用に設定されています。

ML シリーズ カード インターフェイスは、コア MPLS インターフェイスに接続します。コア MPLS インターフェイスはファースト イーサネットまたはギガビット イーサネットであり、MPLS ネットワーク上で Cisco GSR 12000 シリーズのポートまたは同様の装置に接続します。この MPLS のクラウドに面しているインターフェイスは、SPR インターフェイスと MPLS クラウドをブリッジングします。

サービス プロバイダーのネットワークに EoMPLS を実装するには、入力側および出力側の PE-CLE ルータの間にディレクテッド Label Distribution Protocol(LDP; ラベル配布プロトコル)セッション(LSP)を設定して、Virtual Circuit(VC; 仮想回線)の情報を交換する必要があります。それぞれの VC は各方向に 1 つ、合計 2 つの LSP から構成されます。これは、LSP がレイヤ 2 フレームを一方向にだけ転送するディレクテッド パスであるためです。

EoMPLS は 2 段階のラベル スタックを使用してレイヤ 2 フレームを転送します。下側または内側のラベルが VC ラベル、上側または外側のラベルがトンネル ラベルです。VC ラベルが特定の LSP の出力側 PE-CLE によって入力側 PE-CLE に提供され、出力側 PE-CLE の特定の出力インターフェイスにトラフィックを転送します。VC ラベルは、VC のセットアップ中に出力側 PE-CLE によって割り当てられ、出力側インターフェイスと一意の設定用 VC ID 間のバインディングを表現します。VC のセットアップ中に入力側および出力側 PE-CLE は、指定した VC ID の VC ラベル バインディングを交換します。

ML シリーズ カードの EoMPLS VC は、MPLS 上でイーサネット ポートまたは IEEE 802.1Q VLAN を転送できます。VC タイプ 5 はイーサネット ポートをトンネリングし、VC タイプ 4 は、MPLS 上で VLAN を転送します。VC タイプ 5 セッションでは、mpls l2transport route コマンドを使用して、ML シリーズ カードの PE-CLE ポートで受信したトラフィックはすべて、遠端の ML シリーズ カードの PE-CLE ポートでリモート出力インターフェイスにトンネリングされることが予想できます。VC タイプ 4 では、トンネルはその VLAN への物理的な拡張として動作することが予想されます。EoMPLS セッション コマンドは、PE-CLE の VLAN サブインターフェイスに入ります。そのポート上で受信した VLAN タグ付きトラフィックのみがリモート PE-CLE にトンネリングされます。

EoMPLS のサポート

ML シリーズ カードの EoMPLS には次のような特性があります。

EoMPLS は、ファースト イーサネットとギガビット イーサネットのインターフェイスまたはサブインターフェイス上でのみサポートされます。

MPLS タグ スイッチングは、SPR インターフェイスでのみサポートされます。

Class of Service(CoS; サービス クラス)値は MPLS ラベル内の experimental(EXP)ビットに、静的にまたは IEEE 802.1p ビット(デフォルト)を使用してマップされます。

入力側 PE-CLE ML シリーズ カードによって、time-to-live フィールドが 2 に、トンネル ラベルが 255 の値に設定されます。

入力側 PE-CLE ML シリーズ カードによって、VC ラベルの S ビットが 1 に設定され、VC ラベルがスタックの下側にあることを示しています。

EoMPLS トラフィックが RPR 上で伝送されるため、RPR に入ってくるトラフィックに適用できるロード バランシングはすべて、EoMPLS トラフィックにも適用できます。

EoMPLS は、GFP-F フレーミングおよび HDLC フレーミングにおいて RPR でサポートされます。

Ethernet over MPLS の機能は、Cisco Any Transport over MPLS(AToM)製品の一部です。

EoMPLS のエンドポイント ポートをホスティングする ML シリーズ カードは、MPLS マイクロコード イメージを実行して EoMPLS をサポートする必要があります。複数のマイクロコード イメージの詳細については、「複数のマイクロコード イメージ」を参照してください。RPR 内の他の ML シリーズ カードは、MPLS マイクロコード イメージの制限を受けません。

EoMPLS の制限

ML シリーズ カードの EoMPLS には次のような制限があります。

パケットベースのロード バランシングはサポートされません。代わりに回線 ID ベースのロード バランシングが使用されます。

ゼロ ホップやヘアピン VC はサポートされません。1 つの ML シリーズ カードを VC の送信元と宛先の両方にすることはできません。

データ伝送を順序化するための MPLS 制御ワードはサポートされません。制御ワードを使用せずにパケットを送受信する必要があります。

EoMPLS トラフィックのシーケンス チェックや再順序化はサポートされません。どちらも制御ワードに依存して機能します。

最大伝送ユニット(Maximum Transmission Unit; MTU)のフラグメンテーションはサポートされません。

バックツーバック LDP セッションの明示ヌル ラベルはサポートされません。


注意 最大伝送ユニットのフラグメンテーションは MPLS バックボーン全体にわたってサポートされないため、ネットワーク オペレータは、エンドポイント間のすべての中間リンクの MTU がレイヤ 2 の最大 PDU を伝送するのに十分であることを確認する必要があります。

EoMPLS の QoS

EXP は 3 ビットのフィールドであり、MPLS ヘッダーの一部です。IETF が実験的に作成しましたが、後に標準 MPLS ヘッダーの一部になりました。MPLS ヘッダー内の EXP ビットはパケット プライオリティを伝送します。パス上の各ラベル スイッチ ルータは、パケットを適切なキューにキューイングし、それに基づいてパケットを処理することによって、パケット プライオリティに従います。

デフォルトでは、ML シリーズ カードは VLAN タグ ヘッダーの IEEE 802.1P ビットを MPLS EXP ビットにマップしません。MPLS EXP ビットはゼロ(0)の値に設定されます。

レイヤ 2 CoS と MPLS EXP の間は直接コピーできませんが、set mpls experimental アクションを使用すると、802.1p ビットとの照合に基づいて MPLS EXP ビット値を設定できます。このようなマッピングは、エントリ ポイントであるネットワークの入力側で行われます。

ML シリーズ カードでの EoMPLS トラフィックの QoS(Quality Of Service)は、インポジション ルータとディスポジション ルータの出力側インターフェイスで完全プライオリティまたは重み付きラウンド ロビン スケジューリング、あるいはその両方を使用します。このためには、スケジューリングのタイプを決定するサービス クラス キューを選択する必要があります。インポジション ルータでは、ポリシングに基づいてマーキングされたプライオリティ ビット EXP または RPR CoS がサービス クラス キューの選択に使用されます。ディスポジション ルータでは、dot1p CoS ビット(ラベルの EXP ビットからコピーされたもの)がサービス クラス キューの選択に使用されます。出力側インターフェイスのスケジューリングの他に、ポリシー出力アクションにも EXP ビットと RPR CoS ビットのリマーキングを含めることができます。

ML シリーズ カードの EoMPLS では、Cisco Modular QoS CLI(MQC; モジュラ QoS コマンドライン インターフェイス)を使用します。これは ML シリーズ カードの標準 QoS と同じようなものです。ただし、一部の MQC コマンドは利用できません。 表18-1 に、ML シリーズ カード インターフェイスに適用できる MQC ステートメントとアクションを示します。

 

表18-1 適用できる EoMPLS QoS の文とアクション

インターフェイス
適用できる MQC match ステートメント
適用できる MQC アクション

インポジション入力側

match cos

match ip precedence

match ip dscp

match vlan

police cir cir-burst [pir-bust pir pir conform [ set-mpls-exp | exceed [ set-mpls-exp ][violate set-mpls-exp ]

インポジション出力側

match mpls exp

bandwidth { bandwidth-kbps | percent percent }

および

priority kbps

および

[set-mpls-exp]

ディスポジション入力側

適用されない

適用されない

ディスポジション出力側

match mpls exp

bandwidth { bandwidth-kbps | percent percent }

および

priority kbps

および

set-cos cos-value

EoMPLS の設定

EoMPLS ポイントツーポイント サービスの両エンドポイントの ML シリーズ ピア カードを設定する必要があります。EoMPLS をイネーブルにするには、次の設定手順を実行します。

「PE-CLE ポート上での VC タイプ 4 設定」 (VC タイプ 4 または VC タイプ 5 が必須)

「PE-CLE ポート上での VC タイプ 5 設定」 (VC タイプ 4 または VC タイプ 5 が必須)

「PE-CLE SPR インターフェイスでの EoMPLS 設定」(必須)

「MPLS クラウドに面しているポートでのブリッジ グループ設定」(必須)

「パケットのプライオリティと EXP の設定」

EoMPLS 設定の注意事項

EoMPLS を設定する場合の注意事項は次のとおりです。

ループバック アドレスを使用してピア ML シリーズ カードの IP アドレスを指定します。

LDP 設定は必須です。デフォルトの Tag Distribution Protocol(TDP; タグ配布プロトコル)は機能しません。

EoMPLS は、ML シリーズ カード間で LDP をターゲットとするセッションを使用して EoMPLS VC を作成します。

MPLS バックボーンが、Intermediate System-to-Intermediate System(IS-IS)プロトコルや OSPF などの Interior Gateway Protocol(IGP)ルーティング プロトコルを使用する必要があります。

IP パケットのタグ スイッチングが PE-CLE ML シリーズ カードの SPR インターフェイス上でイネーブルになっている必要があります。

PE-CLE ポート上での VC タイプ 4 設定

カスタマーに面しているファースト イーサネット ポートまたはギガビット イーサネット ポートは EoMPLS、および VC タイプ 4 またはタイプ 5 にプロビジョニングされている必要があります。カード A とカード C 上のインターフェイス GigE 0.1 は、図18-2の VC タイプ 4 の機能を実行します。VC タイプ 4 の機能の詳細については、「EoMPLS の概要」を参照してください。

VC タイプ 4 は、2 枚の PE-CLE ML シリーズ カード間で IEEE 802.1Q VLAN パケットを転送します。VC タイプ 4 をプロビジョニングするには、カスタマーに面しているポート上で、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# mpls label protocol ldp

LDP を LDP として指定します。

LDP を指定する必要があります。ML シリーズ カードは、LDP としてデフォルトの TDP を使用した場合、EoMPLS は動作しません。

ステップ 2

Router(config)# interface loopback0

ループバック インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip address ip-address 255.255.255.255

IP アドレスを ループバック インターフェイスに割り当てます。このループバック IP アドレスは、EoMPLS ポイントツーポイント セッションでピアを特定するために使用されます。

サブネット マスクは必要ありません。

ステップ 4

Router(config)# interface {GigabitEthernet | FastEthernet} interface-number.sub-interface- number

インポジション インターフェイスに対してイーサネット サブインターフェイスを指定します。隣接する CE 装置のサブインターフェイスがこのサブインターフェイスと同じ VLAN 上にあることを確認します。

ステップ 5

Router(config-subif)# no ip address

IP アドレスが割り当てられている場合は IP アドレスをディセーブルにします。

ステップ 6

Router(config-subif)# encapsulation dot1Q vlan-id

サブインターフェイスによる 802.1q VLAN パケット受信をイネーブルにします。VLAN ID が隣接する CE 装置の VLAN ID と同じであることを確認します。

ステップ 7

Router(config-subif)# mpls l2transport route destination vc-id

または

xconnect destination vc-id encapsulation mpls

VLAN ベース EoMPLS の dot1Q VLAN サブインターフェイスに mpls l2transport route またはxconnect インターフェイス コンフィギュレーション コマンドを入力することで、カスタマー VLAN に基づいてトラフィックを転送するように EoMPLS トンネルを設定できます。

mpls l2transport route は、使用する VC が VLAN パケットを転送するように指定します。ピアのポイントツーポイント エンドポイント インターフェイスを使用してリモート LDP セッションを開始します。

destination によって、VC(PE-CLE)のもう一方の端にあるリモート ML シリーズのループバック IP アドレスを指定します。

vc-id はユーザ指定値です。この値は各 VC に対して一意である必要があります。VC ID は、VC のエンドポイントの接続に使用されます。VC の両端に同じ VC ID を指定します。

xconnect は、クロスコネクト サービス用に 802.1q VLAN 回線を擬似配線にバインドします。encapsulation mpls 擬似配線クラス パラメータは、トンネリング方式用に MPLS を指定します。


) xconnect コマンドは、mpls l2transport route インターフェイス コンフィギュレーション コマンドの新しいバージョンです。



) EoMPLS トンネルを削除するには、
no mpls l2transport route destination vc-id または
no xconnect destination vc-id encapsulation mpls インターフェイス コマンドを使用します。


ステップ 8

Router(config-subif)# end

特権 EXEC モードに戻ります。

ステップ 9

Router# show mpls l2transport vc

設定を確認します。

ステップ 10

Router# copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

PE-CLE ポート上での VC タイプ 5 設定

カスタマーに面しているファースト イーサネット ポートまたはギガビット イーサネット ポートは EoMPLS、および VC タイプ 4 またはタイプ 5 を使用してプロビジョニングする必要があります。カード A とカード C 上のインターフェイス GigE 1 は、図18-2の VC タイプ 5 の機能を実行します。VC タイプ 5 の機能の詳細については、「EoMPLS の概要」を参照してください。

VC タイプ 5 では、設定されたポートのパケットを 2 枚の PE-CLE ML シリーズ カード間で転送します。VC タイプ 5 をプロビジョニングするには、カスタマーに面しているポート上で、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# mpls label protocol ldp

LDP を LDP として指定します。

LDP を指定する必要があります。ML シリーズ カードは、LDP としてデフォルトの TDP を使用した場合、EoMPLS は動作しません。

ステップ 2

Router(config)# interface loopback0

ループバック インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip address ip-address 255.255.255.255

IP アドレスを ループバック インターフェイスに割り当てます。このループバック IP アドレスは、EoMPLS ポイントツーポイント セッションでピアを特定するために使用されます。

サブネット マスクは必要ありません。

ステップ 4

Router(config)# interface {GigabitEthernet | FastEthernet} interface-number

インポジション インターフェイスに対してイーサネット インターフェイスを指定します。

ステップ 5

Router(config-if)# no ip address

IP アドレスが割り当てられている場合は IP アドレスをディセーブルにします。

ステップ 6

Router(config-subif)# mpls l2transport route destination vc-id

または

xconnect destination vc-id encapsulation mpls

VLAN ベース EoMPLS の VLAN に mpls l2transport route またはxconnect インターフェイス コンフィギュレーション コマンドを入力することで、カスタマー VLAN に基づいてトラフィックを転送するように EoMPLS トンネルを設定できます。

mpls l2transport route は、使用する VC が VLAN パケットを転送するように指定します。ピアのポイントツーポイント エンドポイント インターフェイスを使用してリモート LDP セッションを開始します。

destination によって、VC(PE-CLE)のもう一方の端にあるリモート ML シリーズのループバック IP アドレスを指定します。

vc-id はユーザ指定値です。この値は各 VC に対して一意である必要があります。VC ID は、VC のエンドポイントの接続に使用されます。VC の両端に同じ VC ID を指定します。

xconnect は、クロスコネクト サービス用に 802.1q VLAN 回線を擬似配線にバインドします。encapsulation mpls 擬似配線クラス パラメータは、トンネリング方式用に MPLS を指定します。


) xconnect コマンドは、mpls l2transport route インターフェイス コンフィギュレーション コマンドの新しいバージョンです。



) EoMPLS トンネルを削除するには、
no mpls l2transport route destination vc-id または
no xconnect destination vc-id encapsulation mpls インターフェイス コマンドを使用します。


ステップ 7

Router(config-subif)# end

特権 EXEC モードに戻ります。

ステップ 8

Router# show mpls l2transport vc

設定を確認します。

ステップ 9

Router# copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

PE-CLE SPR インターフェイスでの EoMPLS 設定

RPR を MPLS クラウドのアクセス リングとして機能させるには、EoMPLS PE-CLE ファースト イーサネットまたはギガビット イーサネットをホスティングする同一 ML シリーズ カード上で SPR インターフェイスをプロビジョニングする必要があります。カード A とカード C 上のインターフェイス SPR 1 が、図18-2に示すように、この機能を実行します。

MPLS に対して SPR インターフェイスをプロビジョニングするには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# mpls label protocol ldp

LDP を LDP として指定します。

LDP を指定する必要があります。ML シリーズ カードは、LDP としてデフォルトの TDP を使用した場合、EoMPLS は動作しません。

ステップ 2

Router(config)# interface spr 1

RPR インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip address ip-address mask

IP アドレスを MPLS の RPR インターフェイスに割り当てます。

ステップ 4

Router(config-if)# mpls ip

SPR インターフェイスにタグ スイッチングを実装します。

ステップ 5

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了します。

ステップ 6

Router# copy running-config startup-config

実行コンフィギュレーション ファイルをスタートアップ コンフィギュレーション ファイルに保存します。

MPLS クラウドに面しているポートでのブリッジ グループ設定

RPR の ML シリーズ カードのファースト イーサネット ポートまたはギガビット イーサネット ポートは、MPLS クラウドの一部であるルータのインターフェイスに接続する必要があります。このファースト イーサネット ポートまたはギガビット イーサネット ポートと SPR サブインターフェイスを含むブリッジ グループを作成する必要があります。カード B とカード D 上のインターフェイス GigE 0 が、図18-2に示すように、この機能を実行します。

MPLS クラウドに面しているポートで EoMPLS をプロビジョニングするには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# bridge bridge-group-number protocol {rstp | ieee}

(任意)ブリッジ グループ番号を割り当て、IEEE 802.1D スパニング ツリー プロトコルまたは IEEE 802.1W 高速スパニング ツリーのいずれか適切なスパニング ツリーのタイプを定義します。

ステップ 2

Router(config)# interface {GigabitEthernet | FastEthernet} interface-number

インターフェイス コンフィギュレーション モードを開始して ML シリーズ カードの MPLS クラウドに面するファースト イーサネット インターフェイスまたはギガビット イーサネット インターフェイスを設定します。

ステップ 3

Router(config-if)# bridge-group bridge-group-number

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 4

Router(config-if)# no shutdown

シャットダウン ステートをアップにし、インターフェイスをイネーブルにします。

ステップ 5

Router(config)# interface spr 1.subinterface-number

ML シリーズ カードの SPR サブインターフェイス コンフィギュレーション モードを開始します。

ステップ 6

Router(config-if)# bridge-group bridge-group-number

ネットワーク インターフェイスをブリッジ グループに割り当てます。

ステップ 7

Router(config-if)# end

特権 EXEC モードに戻ります。

ステップ 8

Router# copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

パケットのプライオリティと EXP の設定

EoMPLS では、ラベル内の 3 つの EXP ビットを使用して QoS を提供し、パケットのプライオリティを決定します。ML シリーズ カードのポイントツーポイントのエンドポイント間で QoS をサポートするには、VC ラベルとトンネル ラベルの両方に EXP ビットを設定します。

EXP ビットを設定するには、次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# class-map class-name

トラフィック クラスのユーザ定義名を指定します。

ステップ 2

Router(config-cmap)# match any

すべてのパケットを照合することを指定します。

ステップ 3

Router(config-cmap)#end

グローバル コンフィギュレーション モードに戻ります。

ステップ 4

Router(config)# policy-map policy-name

設定するトラフィック ポリシーの名前を指定します。

ステップ 5

Router(config-pmap)# class class-name

定義しておいたトラフィック クラス名を指定します。この名前は class-map コマンドを使用して設定されたもので、トラフィックをトラフィック ポリシーに分類するために使用します。

ステップ 6

Router (config-pmap-c)# set mpls experimental imposition value

パケットが指定したポリシー マップと一致する場合に MPLS ビットに設定する値を指定します。

ステップ 7

Router(config)# interface GigabitEthernet interface-number
 
または
 
interface FastEthernet interface-number

インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

Router(config-if)# service-policy input policy-name

トラフィック ポリシーをインターフェイスに付加します。

EoMPLS の設定例

図18-2に、コンフィギュレーション コマンドで参照しているネットワーク例を示します。例 18-1 18-2 18-3 、および 18-4 に、コンフィギュレーション ファイルの中で、ネットワーク例の ML シリーズ カード上で EoMPLS をイネーブルにしている部分を示します。

図18-2 EoMPLS の設定例

 

例18-1 ML シリーズ カード A の設定

microcode mpls
ip subnet-zero
no ip domain-lookup
!
mpls label protocol ldp
!
interface Loopback0
 
ip address 10.10.10.10 255.255.255.255
!
interface SPR1
ip address 100.100.100.100 255.255.255.0
no keepalive
spr station-id 1
mpls ip
hold-queue 150 in
!
interface GigabitEthernet0
no ip address
!
interface GigabitEthernet0.1
encapsulation dot1Q 10
mpls l2transport route 3.3.3.3 1
!
interface GigabitEthernet1
no ip address
mpls l2transport route 4.4.4.4 2
!
interface POS0
no ip address
spr-intf-id 1
crc 32
!
interface POS1
no ip address
spr-intf-id 1
crc 32
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 10.10.10.0 0.0.0.255 area 0
!
ip classless
no ip http server
 

例18-2 ML シリーズ カード B の設定

bridge 10 protocol ieee
!
!
interface SPR1
no ip address
no keepalive
bridge-group 10
hold-queue 150 in
!
interface GigabitEthernet0
no ip address
bridge-group 10
 

例18-3 ML シリーズ カード C の設定

microcode mpls
ip subnet-zero
no ip domain-lookup
!
mpls label protocol ldp
!
interface Loopback0
 
ip address 20.20.20.20 255.255.255.255
!
interface SPR1
ip address 100.100.100.100 255.255.255.0
no keepalive
spr station-id 4
mpls ip
hold-queue 150 in
!
interface GigabitEthernet0
no ip address
!
interface GigabitEthernet0.1
encapsulation dot1Q 10
mpls l2transport route 1.1.1.1 1
!
interface GigabitEthernet1
no ip address
mpls l2transport route 2.2.2.2 2
!
interface POS0
no ip address
spr-intf-id 1
crc 32
!
interface POS1
no ip address
spr-intf-id 1
crc 32
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 10.10.10.0 0.0.0.255 area 0
!
ip classless
no ip http server
 

例18-4 ML シリーズ カード D の設定

bridge 20 protocol ieee
!
!
interface SPR1
no ip address
no keepalive
bridge-group 20
hold-queue 150 in
!
interface GigabitEthernet0
no ip address
bridge-group 20
 

EoMPLS のモニタリングと確認

表18-2 に、EoMPLS をモニタリングおよび確認するためのイネーブル EXEC コマンドを示します。

 

表18-2 トンネリングのモニタリングおよび保守に使用するコマンド

コマンドの説明
目的
show mpls l2transport vc

すべての EoMPLS トンネルに関する情報を示します。

show mpls l2transport vc detail

EoMPLS トンネルに関する詳細情報を示します。

show mpls l2transport vc vc-id

特定の EoMPLS トンネルに関する情報を示します。

MPLS-TE の概要

通常、MPLS トラフィックは OSPF または別の IGP ルーティング プロトコルで計算した最短コスト パスにルーティングされます。このルーティングは、さまざまな帯域幅の要求やリンク負荷を考慮したものではありません。MPLS Traffic Engineering(MPLS-TE)は、トラフィック フローを帯域幅要求を考慮したパスにマッピングすることでこの点に対応しています。このようなパスは MPLS-TE トンネルとして知られており、IGP で計算した通常のルートとは異なる場合もあります。

MPLS-TE(RFC 2702)を利用すると、サービス プロバイダーはトラフィック エンジニアリング トンネルを作成して特定のタイプのトラフィック用の帯域幅を確保し、エンド カスタマーにポイントツーポイント サービスを提供することができます。ML シリーズ カードは最大 24 の MPLS-TE トンネルをサポートします。MPLS-TE トンネルは、イーサネット ポートをトンネリングする VC タイプ 5 または 802.1Q VLAN をトンネリングする VC タイプ 4 を搬送します。

MPLS-TE を使用する ML シリーズ カードの場合、3 つの主要コンポーネントを設定する必要があります。まず、MPLS ネットワークにリンク リソースの情報を送信して配布する IGP ルーティング プロトコルを実装します。このために、ML シリーズ カードは OSPF と OSPF-TE 拡張(RFC 2328 および RFC 2370)をサポートします。ML シリーズ カードでは、IS-IS などの他のルーティング プロトコル用の MPLS-TE 拡張はサポートされません。

次に、必要なリソースを予約し MPLS ネットワークに LSP を確立するシグナリング プロトコルを設定します。これを実現するために、MPLS-TE トンネルは Resource Reservation Protocol(RSVP; リソース予約プロトコル)メッセージ(RFC 2205 および RFC 3209)を使用します。ML シリーズ カードは、POS インターフェイスおよび RPR(SPR)インターフェイス上で LSP トンネル用の RSVP および RSVP 拡張をサポートします。

最後に、該当する ML シリーズ カード インターフェイス上に MPLS-TE トンネルを設定します。そのためには、IP アドレス、宛先、カプセル化、帯域、および明示的パスまたは動的パスを設定した MPLS トンネル インターフェイスを作成する必要があります。

ML シリーズ カードの RSVP

ML シリーズ カードは RSVP を使用して MPLS-TE トンネルと対応するトンネル ラベルを確立します。対象となる LDP は VC ラベルを設定するためにそのまま使用されます。また、RSVP はトンネルの中間ノードの帯域幅を保証するためだけに使用されます。MPLS-TE トンネルのエンド ポイントであるML シリーズ カードでは、RSVP が帯域割り当てを行うためだけに使用されます。

ML シリーズ カード ポートの帯域幅の保証は、Cisco Modular QoS CLI(MQC; モジュラ QoS コマンドライン インターフェイス)を使用して設定します。これは ML シリーズ カードの標準 QoS とほとんど同じです。詳細については、「EoMPLS の QoS」を参照してください。

ML シリーズ カードは、EoMPLS VC に情報を搬送するために RSVP メッセージを使用することはありません。LDP セッションは、VC 情報を交換するために引き続き使用されます。また、RSVP は帯域幅を保証しません。帯域幅を割り当てるだけです。

ML シリーズ カードは RSVP サマリー リフレッシュと RSVP リフレッシュ抑制をサポートします(RFC 2961)。リフレッシュ抑制は拡張セットの 1 つで、RSVP によるメッセージング負荷を削減します。リフレッシュ削減により、RSVP は大量のフローをサポートできるようになります。この機能は ip rsvp signalling refresh reduction グローバル コンフィギュレーション コマンドを使用するとイネーブルになります。

イーサネット FCS 保護

お客様のイーサネット FCS をカプセル化して保護するようにML シリーズ カードを設定できます。ML シリーズ カードは、イーサネット FCS を EoMPLS トンネルまたは EoMPLS-TE トンネルのエンドツーエンドで変化のない状態で搬送します。本来のイーサネット FCS がエンドツーエンドで保護されるので、トラブルシューティングに役に立ちます。

イーサネット FCS 保護は、ML シリーズ カードではデフォルトでオフになっています。イーサネット FCS 保護をインターフェイスまたはサブインターフェイス コンフィギュレーション レベルに設定するには、[no] fcs-preservation-on コマンドを実行します。正しく動作するには、EoMPLS トンネルの両端に FCS 保護を設定する必要があります。

MPLS-TE の設定

ML シリーズ カードの MPLS-TE をイネーブルにする前に、MPLS ネットワークで次のタスクを実行します。

MPLS トンネルをオンにします。

OSPF をオンにします。

ML シリーズ カードに MPLS-TE を設定するには、次のセクションのタスクを実行します。

ML シリーズ カードのトンネル サポート設定

RSVP ベース トンネル シグナリングおよび IGP フラッディングをサポートするインターフェイスの設定

MPLS-TE の OSPF およびリフレッシュ抑制の設定

MPLS-TE トンネルの設定


) ML シリーズ カードは IS-IS が設定されている MPLS-TE をサポートしません。



) Cisco Express Forwarding(CEF)は ML シリーズ カード上でデフォルトでオンになっています。


ML シリーズ カードのトンネル サポート設定

ML シリーズ カードでトンネルのサポートを設定するには、グローバル コンフィギュレーション モードで次のコマンドを実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# mpls traffic-eng tunnels

デバイスの MPLS-TE トンネル機能をイネーブルにします。

RSVP ベース トンネル シグナリングおよび IGP フラッディングをサポートするインターフェイスの設定

RSVP ベース トンネル シグナリングおよび IGP フラッディングをサポートするようにインターフェイスを設定するには、インターフェイスコンフィギュレーションモードで次のコマンドを実行します。


) MPLS-TE をサポートするインターフェイスまたはサブインターフェイスのトンネル機能をイネーブルにする必要があります。



) VC タイプ 4 では一方の POS インターフェイスに MPLS-TE トンネルを設定し、もう一方の POS インターフェイスには 802.1Q トンネルを設定する必要があります。


 

コマンドの説明
目的

ステップ 1

Router(config-if)# mpls traffic-eng tunnels

RPR(SPR)インターフェイスまたは POS インターフェイスの MPLS-TE トンネルをイネーブルにします。

ステップ 2

Router(config-if)# ip rsvp bandwidth bandwidth

インターフェイスの IP の RSVP をイネーブルにし、予約する帯域幅の合計を指定します。

ip rsvp インターフェイス コマンド構文の詳細については、『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。

MPLS-TE の OSPF およびリフレッシュ抑制の設定

OSPF トラフィック エンジニアリング コマンド以外の OSPF コマンドの詳細については、『 Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols 』を参照してください。

MPLS-TE の OSPF およびリフレッシュ抑制を設定するには、グローバル コンフィギュレーション モードで次のコマンドを実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# router ospf process-id

IP の OSPF ルーティング プロセスを設定し、ルータでコンフィギュレーション モードを開始します。

process-id 引数は、OSPF ルーティング プロセスで内部的に使用する識別パラメータです。ローカルに割り当てられた任意の正の整数です。OSPF ルーティング プロセスごとに固有の値を割り当てます。

ステップ 2

Router(config-router)# mpls traffic-eng
area area-id

指定した OSPF 領域の MPLS-TE をオンにします。

ステップ 3

Router(config-router)# mpls traffic-eng
router-id loopback0

ノードのトラフィック エンジニアリング ルータ ID が、インターフェイス loopback0 に関連付けられた IP アドレスであることを示します。

ステップ 4

Router(config)# ip rsvp signalling refresh reduction

RSVP によるメッセージ負荷を抑制します。

MPLS-TE トンネルの設定

MPLS-TE トンネルを設定するには、グローバル コンフィギュレーション モードで次のコマンドを実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# interface tunnel

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# ip unnumbered loopback0

トンネル インターフェイスに IP アドレスを設定します。

MPLS-TE トンネル インターフェイスは単方向リンクを示すので、番号を指定しません。

ステップ 3

Router(config-if)# tunnel destination A.B.C.D

トンネルの宛先を指定します。

ステップ 4

Router(config-if)# tunnel mode mpls traffic-eng

トンネルのカプセル化モードを MPLS-TE に設定します。

ステップ 5

Router(config-if)# tunnel mpls traffic-eng autoroute announce

トンネルがアップの場合、拡張 SPF 計算時に IGP がトンネルを使用するように指定します。

ステップ 6

Router(config-if)# tunnel mpls traffic-eng bandwidth bandwidth

MPLS-TE トンネルの帯域幅を設定します。

ステップ 7

Router(config-if)# tunnel mpls traffic-eng
path-option number { dynamic | explicit }{ name path-name | path-number } [ lockdown ]

トンネルが名前付き IP 明示的パスまたはダイナミック パスを使用するように指定します。

MPLS-TE の設定例

図18-3 に、コンフィギュレーションコマンドが参照するネットワークの例を示します。例18-5 に、このネットワーク例の ML シリーズ カード A で MPLS-TE をイネーブルにする部分のコンフィギュレーション ファイルを示します。ML シリーズ カード A には明示的パスが設定されています。

図18-3 MPLS-TE の設定例

 

例18-5 ML シリーズ カード A の設定

microcode mpls
ip subnet-zero
no ip domain-lookup
!
mpls label protocol ldp
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
!
!
!
interface Loopback0
ip address 222.222.222.222 255.255.255.255
!
interface Tunnel0
ip unnumbered Loopback0
tunnel destination 212.212.212.212
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 1 explicit identifier 1
!
interface Tunnel1
ip unnumbered Loopback0
tunnel destination 212.212.212.212
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng path-option 2 explicit identifier 2
!
interface GigabitEthernet0
no ip address
shutdown
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet1.1
encapsulation dot1Q 10
fcs-preservation-on
mpls l2transport route 212.212.212.212 222
!
interface GigabitEthernet1.2
encapsulation dot1Q 20
mpls l2transport route 212.212.212.212 223
!
interface GigabitEthernet1.3
encapsulation dot1Q 30
mpls l2transport route 212.212.212.212 224
!
interface POS0
ip address 170.170.170.172 255.255.255.0
mpls traffic-eng tunnels
tag-switching ip
ip rsvp bandwidth 10000
!
interface POS1
ip address 2.1.1.22 255.255.255.0
mpls traffic-eng tunnels
tag-switching ip
ip rsvp bandwidth 10000
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 2.1.1.22 0.0.0.0 area 0
network 170.170.170.172 0.0.0.0 area 0
network 222.222.222.222 0.0.0.0 area 0
!
ip classless
no ip http server
!
!
ip explicit-path identifier 1 enable
next-address 2.1.1.1
next-address 192.168.3.2
next-address 192.168.3.1
next-address 2.2.1.1
next-address 2.2.1.2
next-address 212.212.212.212
!
ip explicit-path identifier 2 enable
next-address 170.170.170.171
next-address 192.168.3.2
next-address 192.168.3.1
next-address 2.2.1.1
next-address 2.2.1.2
next-address 212.212.212.212
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
line vty 0 4
exec-timeout 0 0
password xxx
no login

MPLS-TE および IP RSVP のモニタリングと確認

表18-3 に、ML シリーズ カードで MPLS-TE トンネルの状態のモニタリングおよび確認をサポートする特権 EXEC コマンドを示します。

 

表18-3 MPLS-TE のモニタリング コマンドおよび確認コマンド

コマンドの説明
目的
show mpls traffic-eng autoroute

IGP に伝えられたトンネルを、インターフェイス、宛先、帯域幅とともに表示します。

show mpls traffic-eng link-management admission-control

ローカルに許可されたトンネルとパラメータ(プライオリティ、帯域幅、着信および発信インターフェイス、状態など)を表示します。

show mpls traffic-eng link-management advertisements

現在 MPLS トラフィック エンジニアリング リンク管理機能がグローバル トラフィック エンジニアリング トポロジにフラッディングしているローカル リンク情報を表示します。

show mpls traffic-eng link-management bandwidth-allocation

現在のローカル リンク情報を表示します。

show mpls traffic-eng link-management igp-neighbors

IGP ネイバーを表示します。

show mpls traffic-eng link-management interfaces

インターフェイスのリソースおよび設定情報を表示します。

show mpls traffic-eng link-management summary

リンク管理情報の概要を、リンク カウントを含めて表示します。

show mpls traffic-eng topology

現在このノードで既知の MPLS-TE グローバル トポロジを表示します。

show mpls traffic-eng tunnel

MPLS-TE トンネルの情報を、LSP トンネル プロセスおよび RSVP プロセスを含めて表示します。

show mpls traffic-eng tunnel summary

MPLS-TE トンネルの概要を表示します。

表18-4 に、ML シリーズ カードで IP RSVP の状態のモニタリングおよび確認をサポートする特権 EXEC コマンドを示します。

 

表18-4 IP RSVP のモニタリング コマンドおよび確認コマンド

コマンドの説明
目的
show ip rsvp interface [interface-type interface-number]

RSVP に関する情報を表示します。

show ip rsvp installed [interface-type interface-number]

RSVP に関連する設置フィルタと対応する帯域幅の情報を表示します。

show ip rsvp neighbor [interface-type interface-number]

現在の RSVP ネイバーを表示します。

show ip rsvp sender [interface-type interface-number]

現在データベースにある RSVP パスに関連する送信側情報を表示します。

show ip rsvp request [interface-type interface-number]

アップストリームが要求されている RSVP 関連の要求情報を表示します。

show ip rsvp reservation [interface-type interface-number]

現在データベースにある RSVP に関連する受信側情報を表示します。

RPRW アラーム

ONS 15454 RPRW アラームについては、次の URL で『Cisco ONS 15454 Troubleshooting Guide』Release 5.0 を参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/ong/15400/r50docs/r50tblsh/r50alts.htm