Cisco ONS 15454/15454 SDH/15327 イーサネット カード ソフトウェア フィーチャ コンフィギュレーション ガイド Cisco IOS Release 12.2(27)SV CTC and Documentation Release 6.0
IRB の設定
IRB の設定
発行日;2012/02/06 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

IRB の設定

IRBの概要

IRB の設定

IRB の設定例

IRB のモニタリングと確認

IRB の設定

この章では、ML シリーズのカードに Integrated Routing and Bridging (IRB; 統合ルーティングおよびブリッジング)を設定する方法を説明します。この章で使用する Cisco IOS のコマンドについては、『 Cisco IOS Command Reference 』を参照してください。

この章の主な内容は次のとおりです。

「IRBの概要」

「IRB の設定」

「IRB の設定例」

「IRB のモニタリングと確認」


注意 ML シリーズでは、Cisco ISL(スイッチ間リンク)と Cisco Dynamic Trunking Protocol(DTP)はサポートされませんが ML シリーズのブロードキャストでこれらの形式は転送されます。装置間の接続に ISL または DTP を使用しないことをお勧めします。シスコの装置によっては、デフォルトで ISL または DTP を使用するものがあります。

IRBの概要

ネットワークによっては、複数のセグメント内でローカル トラフィックをブリッジし、これらのセグメント上のホストをルーティング対象ネットワーク上のホストまたは ML シリーズ カードに接続する必要がある場合があります。たとえば、ブリッジ トポロジーをルーティング トポロジーに移行するために、ブリッジド セグメントの一部をルーテッド ネットワークに接続するような場合です。

IRB機能を使用すると、指定したプロトコルを 1 つの ML シリーズ カード内のルーテッド インターフェイスやブリッジ グループの間でルーティングできます。具体的には、ローカルまたはルーティング不能のトラフィックは同じブリッジ グループ内のブリッジド インターフェイス間でブリッジされ、ルーティング可能なトラフィックは他のルーテッド インターフェイスまたはブリッジ グループにルーティングされます。

ブリッジングはデータ リンク層で実行され、ルーティングはネットワーク層で実行されるため、それぞれのプロトコル設定モデルが異なります。たとえば IP の場合、ブリッジ グループ インターフェイスは同じ 1 つのネットワークに属し、1 つの共同の IP ネットワーク アドレスがあります。一方、各ルーテッド インターフェイスは、個別のネットワークを表し、独自の IP ネットワーク アドレスを取得しています。IRB では、Bridge Group Virtual Interface(BVI; ブリッジ グループ仮想インターフェイス)の概念を使用して、これらのインターフェイスで特定のプロトコルのパケット交換を可能にします。

BVI は、ML シリーズ カード内の仮想インターフェイスとして、通常の ルーテ ッド インターフェイスと同様に機能します。BVI は、ブリッジングをサポートしませんが、ML シリーズ カード内のルーテッド インターフェイスに対して、対応するブリッジ グループを表します。インターフェイス番号は、BVI とブリッジ グループの間のリンクとなります。

IRB を設定する前に、次の点に注意してください。

ブリッジ グループでのデフォルトのルーティングまたはブリッジング(IRB がイネーブルの場合)の動作は、すべてのパケットがブリッジされます。BVI で IP トラフィックのルーティングを明示的に設定してください。

Local-Area Transport(LAT)などのルーティングできないプロトコルは、必ずブリッジされます。ルーティングできないトラフィックのブリッジングをディセーブルにすることはできません。

IRB を使用して特定のプロトコルをブリッジおよびルーティングする場合、ブリッジド インターフェイスでプロトコル属性を設定しないでください。BVI でプロトコル属性を設定することはできますが、ブリッジング属性を設定することはできません。

1 つのブリッジにより複数のネットワーク セグメントが 1 つの大きいフラット ネットワークにリンクされます。1 つのルーテッド インターフェイスから着信したパケットを複数のブリッジド インターフェイス間でブリッジするには、そのブリッジ グループを 1 つのインターフェイスで表す必要があります。

1 つの BVI グループ内のすべてのポートで Maximum Transmission Unit(MTU; 最大伝送ユニット)の設定を同一にする必要があります。

IRB の設定

IRB を設定するには、次の手順を実行します。

1. ブリッジ グループとルーテッド インターフェイスを設定します。

a. ブリッジングをイネーブルにします。

b. インターフェイスをブリッジ グループに割り当てます。

c. ルーティングを設定します。

2. IRB をイネーブルにします。

3. BVI を設定します。

a. BVI をイネーブルにして、ルーティングされたパケットを受け付けます。

b. BVI でルーティングをイネーブルにします。

4. ルーテッド インターフェイスで IP アドレスを設定します。

5. IRB 設定を確認します。

BVI を設定してルーティングをイネーブルにした場合、ブリッジ グループ内のセグメントにあるホスト宛てのパケットがルーテッド インターフェイスに着信すると、BVI にルーティングされ、ブリッジング エンジンに転送されます。このパケットは、ブリッジング エンジンからブリッジド インターフェイス経由で送出されます。同様に、ルーテッド インターフェイスにあるホスト宛てのパケットがブリッジド インターフェイスに着信すると、このパケットは、まず BVI に送信されます。さらに、このパケットは、BVI からルーティング エンジンに転送され、このルーティング エンジンからルーテッド インターフェイスに送信されます。

ブリッジ グループとそのブリッジ グループ内のインターフェイスを設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# bridge bridge-group protocol {ieee | rstp}

1 つまたは複数のブリッジ グループを定義します。

ステップ 2

Router(config)# interface type number

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# bridge-group bridge-group

インターフェイスを特定のブリッジ グループに割り当てます。

ステップ 4

Router(config-if)# end

イネーブル EXEC モードに戻ります。

IRB と BVI をイネーブルにして設定するには、グローバル コンフィギュレーション モードで次の手順を実行します。

 

コマンドの説明
目的

ステップ 1

Router(config)# bridge irb

IRB をイネーブルにします。トラフィックのブリッジングを有効にします。

ステップ 2

Router(config)# interface bvi bridge-group

BVI に対応するブリッジ グループの番号を割り当て、BVI を設定します。各ブリッジ グループに対応させることができる BVI は、1 つだけです。

ステップ 3

Router(config-if)# ip address ip-address ip-address-subnet-mask

ルーテッド インターフェイスに IP アドレスを設定します。

ステップ 4

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 5

Router(config)# bridge bridge-group route protocol

BVI をイネーブルにして、対応するブリッジ グループから受信したルーティング可能パケットをルーティングします。

BVI を使用して対応するブリッジ グループから他のルーテッド インターフェイスにルーティングするプロトコルごとに、このコマンドを実行してください。

ステップ 6

Router(config)# end

イネーブル EXEC モードに戻ります。

ステップ 7

Router# copy running-config startup-config

(任意)設定の変更を NVRAM に保存します。

IRB の設定例

図12-1 は、IRB の設定例です。例12-1 はルータ A の設定コードを、例12-2 はルータ B の設定コードを表しています。

図12-1 IRB の設定

 

例12-1 ルータ A の設定

bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
!
interface FastEthernet0
ip address 192.168.2.1 255.255.255.0
!
interface POS0
no ip address
crc 32
bridge-group 1
pos flag c2 1
!
interface POS1
no ip address
crc 32
bridge-group 1
pos flag c2 1
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0

例12-2 ルータ B の設定

bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
!
interface FastEthernet0
ip address 192.168.3.1 255.255.255.0
!
interface POS0
no ip address
crc 32
bridge-group 1
pos flag c2 1
!
interface POS1
no ip address
crc 32
bridge-group 1
pos flag c2 1
!
interface BVI1
ip address 192.168.1.2 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0

IRB のモニタリングと確認

表12-1 に、IRB をモニタリングおよび確認するためのイネーブル EXEC コマンドを示します。

 

表12-1 IRB をモニタリングおよび確認するためのコマンド

コマンドの説明
目的
Router# show interfaces bvi bvi-interface-number

BVI MAC(メディア アクセス制御)アドレスや処理統計情報などの BVI 情報を表します。 bvi-interface-number は BVI インターフェイスに割り当てられたブリッジ グループの番号です。

Router# show interfaces [type-number] irb

次のプロトコルについて BVI 情報を表示します。

このブリッジド インターフェイスから他のルーテッド インターフェイスにルーティングできるプロトコル(ただし、ルーティング可能なパケットに限る)

このブリッジド インターフェイスがブリッジするプロトコル

show interfaces bvi コマンドおよび show interfaces irb コマンドの出力例を次に示します。

例12-3 IRB のモニタリングと確認

Router# show interfaces bvi1
BVI1 is up, line protocol is up
Hardware is BVI, address is 0011.2130.b340 (bia 0000.0000.0000)
Internet address is 100.100.100.1/24
MTU 1500 bytes, BW 145152 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 03:35:28, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
1353 packets output, 127539 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 
Router# show interfaces irb
BVI1
Software MAC address filter on BVI1
Hash Len Address Matches Act Type
0x00: 0 ffff.ffff.ffff 0 RCV Physical broadcast
GigabitEthernet0
Bridged protocols on GigabitEthernet0:
clns ip
Software MAC address filter on GigabitEthernet0
Hash Len Address Matches Act Type
0x00: 0 ffff.ffff.ffff 0 RCV Physical broadcast
0x58: 0 0100.5e00.0006 0 RCV IP multicast
0x5B: 0 0100.5e00.0005 0 RCV IP multicast
0x65: 0 0011.2130.b344 0 RCV Interface MAC address
0xC0: 0 0100.0ccc.cccc 0 RCV CDP
0xC2: 0 0180.c200.0000 0 RCV IEEE spanning tree
POS0
Routed protocols on POS0:
ip
Bridged protocols on POS0:
clns ip
Software MAC address filter on POS0
Hash Len Address Matches Act Type
0x00: 0 ffff.ffff.ffff 9 RCV Physical broadcast
0x58: 0 0100.5e00.0006 0 RCV IP multicast
0x5B: 0 0100.5e00.0005 1313 RCV IP multicast
0x61: 0 0011.2130.b340 38 RCV Interface MAC address
0x61: 1 0011.2130.b340 0 RCV Bridge-group Virtual Interface
0x65: 0 0011.2130.b344 0 RCV Interface MAC address
0xC0: 0 0100.0ccc.cccc 224 RCV CDP
0xC2: 0 0180.c200.0000 0 RCV IEEE spanning tree
POS1
SPR1
Bridged protocols on SPR1:
clns ip
Software MAC address filter on SPR1
Hash Len Address Matches Act Type
0x00: 0 ffff.ffff.ffff 0 RCV Physical broadcast
0x60: 0 0011.2130.b341 0 RCV Interface MAC address
0x65: 0 0011.2130.b344 0 RCV Interface MAC address
0xC0: 0 0100.0ccc.cccc 0 RCV CDP
0xC2: 0 0180.c200.0000 0 RCV IEEE spanning tree
 

表12-1 に、表示される重要なフィールドを説明します。

 

表12-2 show interfaces irb コマンドで出力されるフィールドの説明

フィールド
説明
Routed protocols on...

指定したインターフェイスに対して設定されたルーテッド プロトコルの一覧

Bridged protocols on...

指定したインターフェイスに対して設定されたブリッジド プロトコルの一覧

Software MAC address filter on ...

指定したインターフェイスに対するソフトウェア MAC アドレス フィルタ情報の表

Hash

この MAC アドレス エントリの鍵付きリストのハッシュ キー/相対位置

Len

このハッシュ チェインの開始要素へのこのエントリの長さ

Address

正準(イーサネット順の) MAC アドレス

Matches

この MAC アドレスに一致した受信パケットの数

Routed protocols on...

指定したインターフェイスに対して設定されたルーテッド プロトコルの一覧

Bridged protocols on...

指定したインターフェイスに対して設定されたブリッジド プロトコルの一覧