Cisco ONS 15454 SONET/SDH ML シリーズ マルチレイヤ イーサネット カード ソフトウェア フィーチャ コンフィギュレーション ガイド
VRF Lite の設定
VRF Lite の設定
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

VRF Lite の設定

VRF Lite の概要

VRF Lite の設定

VRF Lite の設定例

VRF Lite のモニタリングと確認

VRF Lite の設定

この章では、ML シリーズ カードの VPN Routing and Forwarding Lite(VRF Lite)の設定方法について説明します。この章で使用する Cisco IOS コマンドの詳細については、『 Cisco IOS Command Reference 』を参照してください。この章の内容は次のとおりです。

「VRF Lite の概要」

「VRF Lite の設定」

「VRF Lite の設定例」

「VRF Lite のモニタリングと確認」


) ブリッジングをすでに設定している場合は、オプションの手順である VRF Lite の設定に進むことができます。


VRF Lite の概要

VRF は、複数のルーティング インスタンスを提供する IP ルーティングの拡張機能です。VRF は、各 VPN に個別の IP ルーティングと転送のテーブルを提供します。また、プロバイダー装置 (PE) のルータ間で MP-iBGP (Multi-Protocol internal BGP)と共に使用し、レイヤ 3 MPLS-VPN を提供します。ただし、ML シリーズの VRF 実装では、MP-iBGP は含まれていません。VRF Lite では、ML シリーズは PE 拡張機能またはカスタマー装置 (CE) 拡張機能とみなされます。VRF Lite が PE 拡張機能とみなされるのは、VRF を持つためです (MP-iBGP は備えていません)。また、この CE は 複数の VRF を持ち、1 つの CE ボックスで多数のカスタマーに対応できるため、CE 拡張機能ともみなされています。

VRF Lite を使用すると、ML シリーズ の CE は、複数のインターフェイスおよびサブインターフェイスをさまざまなカスタマーの PE と共に備えることができます(通常の CE が対象とするのは 1 カスタマーのみ)。CE は VRF (ルーティング情報)をローカルで保持し、接続されている PE に VRF を配信することはありません。CE はカスタマーのルータまたはインターネット サービス プロバイダー(ISP)PE のルータからトラフィックを受信すると、VRF 情報を使用して、適切なインターフェイスやサブインターフェイスにトラフィックを直接送信します。

VRF Lite の設定

VRF Lite を設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

Router(config)# ip vrf vrf-name

VRF の設定モードを開始し、VRF 名を指定します。

ステップ 2

Router(config-vrf)# rd route-distinguisher

VPN ルート区別子を作成します。

ステップ 3

Router(config-vrf)# route-target {import | export | both} route-distinguisher

指定した VRF に対する、インポート/エクスポート ルートの対象コミュニティ一覧を作成します。

ステップ 4

Router(config-vrf)# import map route-map

(オプション)指定したルート マップを VRF に関連付けます。

ステップ 5

Router(config-vrf)# exit

現在の設定モードを終了し、グローバル設定モードを開始します。

ステップ 6

Router(config)# interface type number

インターフェイスを指定し、インターフェイス設定モードを開始します。

ステップ 7

Router(config-vrf)# ip vrf forwarding vrf-name

インターフェイスまたはサブインターフェイスに VRF を関連付けます。

ステップ 8

Router(config-if)# end

特権 EXEC モードに戻ります。

ステップ 9

Router# copy running-config startup-config

(オプション)設定の変更を NVRAM に保存します。

例12-1 は、VRF の設定例を示しています。この例では、VRF 名は customer_a、ルート区別子は 1:1、インターフェイス タイプはファースト イーサネット 0.1 番です。

例12-1 VRF の設定

Router(config)# ip vrf customer_a
Router(config-vrf)# rd 1:1
Router(config-vrf)# route-target both 1:1
Router(config)# interface fastEthernet 0.1
Router(config-subif)# ip vrf forwarding customer_a

VRF Lite の設定例

図 12-1 は、VRF Lite の設定例を示しています。ルータ A とルータ B の設定は、例12-2 および 例12-3(P. 12-5) でそれぞれ説明しています。関連付けられているルーティング テーブルは、 例12-4(P. 12-6) 例12-9(P. 12-7) に示しています。

図 12-1 VRF Lite-- のネットワーク シナリオ例

 

例12-2 ルータ_A の設定

hostname Router_A
!
ip vrf customer_a
rd 1:1
route-target export 1:1
route-target import 1:1
!
ip vrf customer_b
rd 2:2
route-target export 2:2
route-target import 2:2
!
bridge 1 protocol ieee
bridge 2 protocol ieee
bridge 3 protocol ieee
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet0.1
encapsulation dot1Q 2
ip vrf forwarding customer_a
ip address 192.168.1.1 255.255.255.0
bridge-group 2
!
interface FastEthernet1
no ip address
!
interface FastEthernet1.1
encapsulation dot1Q 3
ip vrf forwarding customer_b
ip address 192.168.2.1 255.255.255.0
bridge-group 3
!
interface POS0
no ip address
crc 32
no cdp enable
pos flag c2 1
!
interface POS0.1
encapsulation dot1Q 1 native
ip address 192.168.50.1 255.255.255.0
bridge-group 1
!
interface POS0.2
encapsulation dot1Q 2
ip vrf forwarding customer_a
ip address 192.168.100.1 255.255.255.0
bridge-group 2
!
interface POS0.3
encapsulation dot1Q 3
ip vrf forwarding customer_b
ip address 192.168.200.1 255.255.255.0
bridge-group 3
!
router ospf 1
log-adjacency-changes
network 192.168.50.0 0.0.0.255 area 0
!
router ospf 2 vrf customer_a
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.100.0 0.0.0.255 area 0
!
router ospf 3 vrf customer_b
log-adjacency-changes
network 192.168.2.0 0.0.0.255 area 0
network 192.168.200.0 0.0.0.255 area 0
!

例12-3 ルータ_B の設定

hostname Router_B
!
ip vrf customer_a
rd 1:1
route-target export 1:1
route-target import 1:1
!
ip vrf customer_b
rd 2:2
route-target export 2:2
route-target import 2:2
!
bridge 1 protocol ieee
bridge 2 protocol ieee
bridge 3 protocol ieee
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet0.1
encapsulation dot1Q 2
ip vrf forwarding customer_a
ip address 192.168.4.1 255.255.255.0
bridge-group 2
!
interface FastEthernet1
no ip address
!
interface FastEthernet1.1
encapsulation dot1Q 3
ip vrf forwarding customer_b
ip address 192.168.5.1 255.255.255.0
bridge-group 3
!
interface POS0
no ip address
crc 32
no cdp enable
pos flag c2 1
!
interface POS0.1
encapsulation dot1Q 1 native
ip address 192.168.50.2 255.255.255.0
bridge-group 1
!
interface POS0.2
encapsulation dot1Q 2
ip vrf forwarding customer_a
ip address 192.168.100.2 255.255.255.0
bridge-group 2
!
interface POS0.3
encapsulation dot1Q 3
ip vrf forwarding customer_b
ip address 192.168.200.2 255.255.255.0
bridge-group 3
!
router ospf 1
log-adjacency-changes
network 192.168.50.0 0.0.0.255 area 0
!
router ospf 2 vrf customer_a
log-adjacency-changes
network 192.168.4.0 0.0.0.255 area 0
network 192.168.100.0 0.0.0.255 area 0
!
router ospf 3 vrf customer_b
log-adjacency-changes
network 192.168.5.0 0.0.0.255 area 0
network 192.168.200.0 0.0.0.255 area 0
!

例12-4 ルータ_A のグローバル ルーティング テーブル

Router_A# sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
C 192.168.50.0/24 is directly connected, POS0.1
 

例12-5 ルータ_A の customer_a VRF ルーティング テーブル

Router_A# show ip route vrf customer_a
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
O 192.168.4.0/24 [110/2] via 192.168.100.2, 00:15:35, POS0.2
C 192.168.1.0/24 is directly connected, FastEthernet0.1
C 192.168.100.0/24 is directly connected, POS0.2
 

例12-6 ルータ_A の customer_b VRF ルーティング テーブル

Router_A# show ip route vrf customer_b
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
C 192.168.200.0/24 is directly connected, POS0.3
O 192.168.5.0/24 [110/2] via 192.168.200.2, 00:10:32, POS0.3
C 192.168.2.0/24 is directly connected, FastEthernet1.1
 

例12-7 ルータ_B のグローバル ルーティング テーブル

Router_B# sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
C 192.168.50.0/24 is directly connected, POS0.1
 

例12-8 ルータ_B の customer_a VRF ルーティング テーブル

Router_B# sh ip route vrf customer_a
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
C 192.168.4.0/24 is directly connected, FastEthernet0.1
O 192.168.1.0/24 [110/2] via 192.168.100.1, 00:56:24, POS0.2
C 192.168.100.0/24 is directly connected, POS0.2
 

例12-9 ルータ_B の customer_b VRF ルーティング テーブル

Router_B# show ip route vrf customer_b
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
C 192.168.200.0/24 is directly connected, POS0.3
C 192.168.5.0/24 is directly connected, FastEthernet1.1
O 192.168.2.0/24 [110/2] via 192.168.200.1, 00:10:51, POS0.3
 

VRF Lite のモニタリングと確認

表 12-1 に、VRF Lite のモニタリングおよび確認に使用する特権 EXEC コマンドを示します。

 

表 12-1 VRF Lite のモニタリングと確認に使用するコマンド

コマンド
目的
Router# show ip vrf

VRF とインターフェイスのセットを表示します。

Router# show ip route vrf vrf-name

VRF の IP ルーティング テーブルを表示します。

Router# show ip protocols vrf vrf-name

VRF のルーティング プロトコル情報を表示します。

Router# ping vrf vrf-name ip-address

特定の VRF を持つ IP アドレスの ping を実行します。