Cisco ONS 15454 SONET/SDH ML シリーズ マルチレイヤ イーサネット カード ソフトウェア フィーチャ コンフィギュレーション ガイド
IRB の設定
IRB の設定
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

IRB の設定

統合ルーティングとブリッジング(IRB)の概要

IRB の設定

IRB の設定例

IRB のモニタリングと確認

IRB の設定

この章では、ML シリーズのカードに Integrated Routing and Bridging (IRB; 統合ルーティングとブリッジング)を設定する方法を説明します。この章で使用する Cisco IOS のコマンドについては、『 Cisco IOS Command Reference 』を参照してください。

この章の主な内容は、次のとおりです。

「統合ルーティングとブリッジング(IRB)の概要」

「IRB の設定」

「IRB の設定例」

「IRB のモニタリングと確認」


注意 ML シリーズでは、Cisco Inter-Switch Link(ISL; スイッチ間リンク)と Cisco Dynamic Trunking Protocol(DTP)はサポートされません。ただし、これらの形式はブロードキャストされます。装置間の接続に ISL または DTP を使用しないことをお勧めします。シスコの装置によっては、デフォルトで ISL または DTP を使用するものもあります。

統合ルーティングとブリッジング(IRB)の概要

ネットワークによっては、複数のセグメント内でローカル トラフィックをブリッジし、これらのセグメント上のホストをルーティング対象ネットワーク上の ML シリーズ カードに接続する必要がある場合があります。たとえば、ブリッジ トポロジをルーティング トポロジに移行するために、ブリッジ対象セグメントをルーティング対象ネットワークに接続するような場合です。

IRB 機能を使用すると、指定したプロトコルを 1 つの ML シリーズ カード内のルーティング対象インターフェイスやブリッジ グループの間でルーティングできます。具体的には、ローカルまたはルーティング不能のトラフィックは同じブリッジ グループ内のブリッジ対象インターフェイス間でブリッジされ、ルーティング可能なトラフィックは他のルーティング対象インターフェイスまたはブリッジ グループにルーティングされます。

ブリッジはデータ リンク層で実行され、ルーティングはネットワーク層で実行されるため、それぞれのプロトコル設定モデルが異なります。たとえば IP の場合、ブリッジ グループ インターフェイスは同じ 1 つのネットワークに属し、1 つの IP ネットワーク アドレスで総称的に表されます。一方、各ルーティング対象インターフェイスは、個別のネットワークを表し、独自の IP ネットワーク アドレスを取得しています。IRB では、Bridge Group Virtual Interface(BVI; ブリッジ グループ仮想インターフェイス)の概念を使用して、これらのインターフェイスで特定のプロトコルのパケット交換を可能にします。

BVI は、ML シリーズ カード内の仮想インターフェイスとして、通常の「ルーティング対象」インターフェイスと同様に機能します。BVI は、ブリッジをサポートしませんが、ML シリーズ カード内のルーティング対象インターフェイスに対して、対応する 1 つのブリッジ グループを表します。BVI とブリッジ グループの間は、インターフェイス番号によってリンクされます。

IRB を設定する前に、次の点を考慮してください。

ブリッジ グループでのデフォルトのルーティングまたはブリッジ(IRB が有効な場合)では、すべてのパケットがブリッジされます。BVI で IP トラフィックをルーティングするように明示的に設定してください。

local-area transport(LAT)などのルーティングできないプロトコルは、必ずブリッジされます。ルーティングできないトラフィックのブリッジを無効にすることはできません。

IRB を使用して特定のプロトコルをブリッジおよびルーティングする場合、ブリッジ対象インターフェイスへのプロトコル属性設定は禁じられています。BVI について、プロトコル属性を設定することはできますが、ブリッジ属性を設定することはできません。

1 つのブリッジにより複数のネットワーク セグメントが 1 つの大きいフラット ネットワークにリンクされます。1 つのルーティング対象インターフェイスから着信したパケットを複数のブリッジ対象インターフェイス間でブリッジするには、そのブリッジ グループを 1 つのインターフェイスで表す必要があります。

1 つの BVI グループ内のすべてのポートで maximum transmission unit(MTU; 最大転送ユニット)の設定を同一にする必要があります。

IRB の設定

IRB を設定するには、次の手順を実行します。

1. ブリッジ グループとルーティング対象インターフェイスを設定します。

a. ブリッジを有効にします。

b. インターフェイスをブリッジ グループに割り当てます。

c. ルーティングを設定します。

2. IRB を有効にします。

3. BVI を設定します。

a. BVI を有効にして、ルーティングされたパケットを受け付けます。

b. BVI でルーティングを有効にします。

4. ルーティング対象インターフェイスに IP アドレスを設定します。

5. IRB 設定を確認します。

BVI を設定してルーティングを有効にした場合、ブリッジ グループ内のセグメントにあるホスト宛てのパケットがルーティング対象インターフェイスに着信すると、BVI にルーティングされ、ブリッジ エンジンに転送されます。このパケットは、ブリッジ エンジンからブリッジ インターフェイス経由で送出されます。同様に、ルーティング対象インターフェイスにあるホスト宛てのパケットがブリッジ インターフェイスに着信すると、このパケットは、まず BVI に送信されます。さらに、このパケットは、BVI からルーティング エンジンに転送され、このルーティング エンジンからルーティング対象インターフェイスに送信されます。

ブリッジ グループとそのブリッジ グループ内のインターフェイスを設定するには、グローバル設定モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

Router(config)# bridge bridge-group protocol {ieee | rstp}

ブリッジ グループを定義します。

ステップ 2

Router(config)# interface type number

インターフェイス設定モードを開始します。

ステップ 3

Router(config-if)# bridge-group bridge-group

インターフェイスを特定のブリッジ グループに割り当てます。

ステップ 4

Router(config-if)# end

特権 EXEC モードに戻ります。

IRB と BVI を有効にして設定するには、グローバル設定モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

Router(config)# bridge irb

IRB を有効にします。トラフィックのブリッジを有効にします。

ステップ 2

Router(config)# interface bvi bridge-group

BVI に対応するブリッジ グループの番号を割り当て、BVI を設定します。各ブリッジ グループに対応させることができる BVI は、1 つだけです。

ステップ 3

Router(config-if)# ip address ip-address ip-address-subnet-mask

ルーティング対象インターフェイスに IP アドレスを設定します。

ステップ 4

Router(config-if)# exit

インターフェイス設定モードを終了します。

ステップ 5

Router(config)# bridge bridge-group route protocol

BVI を有効にして、対応するブリッジ グループからルーティング可能なパケットを受け付け、ルーティングします。

BVI を使用して対応するブリッジ グループから他のルーティング対象インターフェイスにルーティングするプロトコルごとに、このコマンドを実行してください。

ステップ 6

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 7

Router# copy running-config startup-config

(オプション)設定の変更を NVRAM に保存します。

IRB の設定例

図 11-1 は、IRB の設定例です。例11-1 はルータ A の設定コードを、例11-2 はルータ B の設定コードを表しています。

図 11-1 IRB の設定

 

例11-1 ルータ A の設定

bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
!
interface FastEthernet0
ip address 192.168.2.1 255.255.255.0
!
interface POS0
no ip address
crc 32
bridge-group 1
pos flag c2 1
!
interface POS1
no ip address
crc 32
bridge-group 1
pos flag c2 1
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0

例11-2 ルータ B の設定

bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
!
interface FastEthernet0
ip address 192.168.3.1 255.255.255.0
!
interface POS0
no ip address
crc 32
bridge-group 1
pos flag c2 1
!
interface POS1
no ip address
crc 32
bridge-group 1
pos flag c2 1
!
interface BVI1
ip address 192.168.1.2 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0

IRB のモニタリングと確認

IRB 設定を確認するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

Router# show interfaces bvi interface-name

BVI MAC アドレスや処理する統計情報などの BVI 情報を表します。

ステップ 2

Router# show interfaces irb

次のプロトコルについて BVI 情報を表示します。

このブリッジ対象インターフェイスから他のルーティング対象インターフェイスにルーティングできるプロトコル(ただし、ルーティング可能なパケットに限る。)

このブリッジ対象インターフェイスがブリッジするプロトコル

この処理を例11-3 に示します。

例11-3 IRB のモニタリングと確認

Router# show interfaces bvi1
BVI1 is up, line protocol is up
Hardware is BVI, address is 0005.9a39.6630 (bia 0000.0000.0000)
Internet address is 192.168.1.2/24
MTU 1500 bytes, BW 51840 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
141 packets output, 11458 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
 
Router# show interfaces irb
 
BVI1 *ERROR* bridging on sub-interface but NOT on interface
 
Software MAC address filter on BVI1
Hash Len Address Matches Act Type
0x00: 0 ffff.ffff.ffff 0 RCV Physical broadcast
 
FastEthernet0
 
Routed protocols on FastEthernet0:
ip
 
Software MAC address filter on FastEthernet0
Hash Len Address Matches Act Type
0xC2: 0 0180.c200.0000 0 RCV IEEE spanning tree
 
POS0
 
 
Routed protocols on POS0:
ip
 
Bridged protocols on POS0:
clns ip
 
Software MAC address filter on POS0
Hash Len Address Matches Act Type
0x00: 0 ffff.ffff.ffff 0 RCV Physical broadcast
0x58: 0 0100.5e00.0006 1 RCV IP multicast
0x5B: 0 0100.5e00.0005 105 RCV IP multicast
0xAA: 0 0005.9a39.6630 32 RCV Interface MAC address
0xAA: 1 0005.9a39.6630 0 RCV Bridge-group Virtual Interface
0xAE: 0 0005.9a39.6634 0 RCV Interface MAC address
0xC1: 0 0100.0ccc.cccd 4 RCV SSTP MAC address
0xC2: 0 0180.c200.0000 0 RCV IEEE spanning tree
 
POS1
 
Routed protocols on POS1:
ip
 
Bridged protocols on POS1:
clns ip
 
Software MAC address filter on POS1
Hash Len Address Matches Act Type
0x00: 0 ffff.ffff.ffff 0 RCV Physical broadcast
0x58: 0 0100.5e00.0006 2 RCV IP multicast
0x5B: 0 0100.5e00.0005 2 RCV IP multicast
0xAA: 0 0005.9a39.6630 0 RCV Bridge-group Virtual Interface
0xAB: 0 0005.9a39.6631 0 RCV Interface MAC address
0xAE: 0 0005.9a39.6634 0 RCV Interface MAC address
0xC1: 0 0100.0ccc.cccd 4 RCV SSTP MAC address
0xC2: 0 0180.c200.0000 1 RCV IEEE spanning tree